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INTRODUCTION TO EMBARCADERO’'S RAPID SQL

Rapid SQL® is an integrated development environment that enables developers to
create, edit, version, tune, and deploy server-side objects residing on Microsoft SQL
Server, Oracle, Sybase Adaptive Server, InterBase/Firebird, IBM DB2 for Linux, Unix,
and Windows, and IBM DB2 for z/OS databases. Its unified database development
environment provides extensive graphical facilities that simplify SQL scripting, object
management, reverse engineering, database project management, version control and
schema deployment. With Rapid SQL, programmers can develop and maintain high-
quality, high-performance client/server and web-based applications in less time, and
with greater accuracy.

PRODUCT BENEFITS BY AUDIENCE

DATABASE DEVELOPERS/ADMINISTRATORS

Rapid SQL provides an easy-to-use graphical user interface (GUI), which allows
Database Developers to be immediately productive in a cross-platform
environment without having platform specific knowledge. Along this line, Rapid
SQL provides standard object creation wizards and graphical object editors
for all supported platforms, which greatly reduce the time and effort to build an
application database from the ground up.

Rapid SQL also offers several cross-platform code-generation options, which
help Developers build SQL code that is syntactically and functionally correct the
first time. In addition, Rapid SQL can be used for the immediate or scheduled
execution of SQL scripts and files, both with output and notification options.
Rapid SQL makes short order of working with data by providing Developers with
several easy-to-use browsing, visual query building and data editing options.
All operations can be completed with drag-and-drop, point-and-click ease, with
little or no SQL coding required.

DATABASE PROJECT MANAGEMENT

Rapid SQL provides seamless, out-of-the-box integration with all major
Version Control Systems (VCS). Rapid SQL offers complete database project
management capabilities, which allows for the reverse-engineering of live
database objects into corresponding off-line SQL source code files, which may
be checked into and out of any of the supported VCSs. Rapid SQL also provides
detailed HTML reports at the database object level that can be viewed
immediately within the application or published to a defined web directory.
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ABOUT THIS EVALUATION GUIDE

This guide helps you get started using Rapid SQL. On completion, you'll have the
foundation to explore the many features of Rapid SQL. You'll have learned how to
register and connect cross-platform datasources, navigate the database explorer, work
with the individual Object Editors and Wizards, build and manage projects, and work
with the productivity-focused features. You will also know that Rapid SQL allows you to
concentrate more on what needs to be done and less on how it should be done.

This guide is divided into separate sessions. Do them all at once, or complete them
individually as you have time:

Session 1: Getting Started

Session 2: Productivity Enhancers

Session 3: Scripting

Session 4: Working with Code Workbench
Session 5: Building a Database Project

Section 6: Visual Query Builder and Data Editor
Section 7: Code Analyst

Section 8: SOL Debugging and Profiling

You can use this basic tutorial as a roadmap of product highlights; but also to help you
find your own path to explore Rapid SQL. Once you've started, you can select Help
Topics from the Help menu to find many additional resources including Tutorials that
complement and build on many of the activities shown in this brief guide.

[ Rapid SOL User Guide =<
] I & H-
Hide Mext Frint  Options

Cantents ||ﬂdex Search

'+ @ acine o Rap S0L Welcome to Rapid SQL

@ Rapid 5L Tutorial
Q Application Basics

@ using Rapid SGL is an integrated cross-platform database
Q Toals development enwvironment that provides a highly-intuitive and
Q Rapid 0L Add-On Tools well-integrated interface. Its graphical faciliies simplify SQL

scripting, object management, reverse-engineering, database
praject management, version control, and schema deplayment.
Additionally, it provides comprehensive fools for tuning and
editing code to ensure high-performance and guality.

Rapid SGL offers support for all major databases including [BM
DB2, InterBaselFirebird, Microsoft SAL Server, MySCQL, Oracle,
and Syhase.

See the following topics
= Rapid SQL Tutarial
= Application Basics
= Using

= Tools

= Bapid SQL Add-0n Tools
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SESSION 1: GETTING STARTED

DOWNLOAD AND INSTALL

You can obtain the latest version of the Rapid SQL software from the Embarcadero
website at http://www.embarcadero.com/downloads.

NOTE: Trial versions of Embarcadero products can be either fully installed versions or
InstantOn versions. InstantOn is an application virtualization technology that lets you
run an application using a single file, without running a full installation. When
downloading an InstantOn trial version, always use the Save option (as opposed to the
Run option), since the downloaded file is used to start the application during the course
of the trial period.

Provide the requested information and follow the steps indicated to download the
software and register the trial license. When you first install an evaluation copy of Rapid
SQL, you can use the tool for 14 days. After that time, a permanent license is needed.

Overview
The graphic below illustrates common elements of the Rapid SQL application window.

Database Explorer  Datasource Group  Datasource  Toolbars  Application Workspace
\ / / |

© Emhlhrcadern Rapid SOL /.'7.0 / /

£ MySQL Servers
=03 Orarle Servers
=S ROMLABORCYA0g_L {Oracle 10.1.0.2)
S ROMLABORCLI 1g_L {Oracle 11.1.0.6)
- TORLABZRCLIOG 1 (Oracle)

= TORLHEORCLIOG 2 (Oracle 10,2.0.3)
E

=

-5 TOPABORCLI1g 1 {Cracle 11.1.0.6)
& TéRLABORCLI1G 2 (Orade 11.1.0.8) |
£ OF Filkers

#-+]» Check Constraints
J"'... Clusters

J% Database Links

£|-Lig Directories

J% Foreign Keys

£ far Functions

- [ Indexes

H-{sh Java Sources
H-{ch Java Classes
H-{gh Java Resources

RN
(=l Im NE)
4 D:| ;xplorer FEl Fayorites | I
Feady /

/

Explorer Tab  Favorites Tab
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Rapid SQL allows you to view and manage all of your databases at the same time
from the Database Explorer. You can easily move from DB2 to InterBase/Firebird to
Oracle to SQL Server to Sybase all within the same window. Rapid SQL's multi-
threaded, productivity-enhancing environment allows you to have several workspaces
open at the same time so you can continue to work, even while the application
processes in the background.

Start Rapid SQL

How you start Rapid SQL depends on the type of application you are evaluating:
¢ InstantOn version — start the application by double-clicking the file you
downloaded.
e Fully-installed version - The Start menu sequence for Rapid SQL is always in the
form Programs > Embarcadero Rapid SQL version identifier > Embarcadero
Rapid SQL version identifier, where version identifier reflects the version you
are running.
To get started:
1. Run Rapid SQL.

The first time Rapid SQL starts, if offers to automatically discover and register any
datasources on your network. The Discover Datasources feature automatically
searches the DBMS configuration files and discovers datasources residing on your
system that are not currently registered. When you use this feature, a dialog box
lists the name of the server or instance and the type of DBMS of all unregistered
datasources found on your network or local machine and gives you the option to
register the discovered datasources.

2. Choose "No” for the purpose of this guide.

Registering Cross-Platform Datasources
For now, you will register a datasource manually.

1. On the Datasource menu, select Register Datasource. A Datasource
Registration Wizard opens.
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Datasource Registration
Information |E5'
Select the database tppe. l'g)
Database Type

Connection Information

Security Parameters

Datasource Properties @_I
Datasource Group () Mictosoft SOL Server
OMysaL
() Oracle
() Sybase Adaptive Server
() InterBaseFirebird
O ODEC

‘ Mext > | | Finizh | ‘ Cancel | | Help |

Choose Microsoft SQL Server as the DBMS type and then click Next.

Specify the Host name of a SQL Server datasource on your network, override the
Datasource name with “SAMPLE_DATASOURCE"” and then click Next.

4. Provide valid credentials in the User ID and Password boxes, and then select the
Auto-Connect? checkbox to eliminate having to provide credentials each time you
connect to this datasource.

5. Inthe left-hand pane, select Datasource Group, select the MS SQL Server folder,
and then click Finish.

Note: The Datasource Group panel also lets you assign a category to a
datasource. This provides a means to visually distinguish between different server
purposes, development vs. production, for example, in your enterprise.
Categorization is a customizable feature.

6. Select Yes when prompted to connect to the new datasource.

Rapid SQL offers the same easy-to-use Datasource Registration Wizard for all
supported DBMS platform connections. The connection information only needs to be
set up one time for each platform and can be saved locally or in a common datasource
catalog for use by other Embarcadero products.

By default, Rapid SQL stores datasource definitions in the Windows Registry. There is
also a local, file-based option. Embarcadero products supporting these methods can
share datasource catalogs on the same machine.

There is also a network-shared storage option.

Rapid SQL also offers the ability to import and export datasource definitions. This lets
you share definitions among users and across datasource storage methods.

Embarcadero Technologies 8



SESSION 2: PRODUCTIVITY ENHANCERS

Database Object Management Made Easy

Rapid SQL makes it easy and intuitive to navigate between datasources and to drill-
down into atomic database objects within the Database Explorer Tree. The Database
Explorer Tree displays all registered datasources and serves as the entry-point for much
of Rapid SQL's advanced functionality.

The Database Explorer Tree
1. Click on the Explorer title bar and select By Object Type.

Organizer 3 x

* Explorer- By Object Type ~
= Managed Datasources I
B3 DB2 Servers

B MS SOL Servers

2. Select and Expand the SAMPLE_DATASOURCE > Databases > pubs node to
display the database object sub-nodes.

EiE SAMPLE_DATASOURCET
B Logins

Elefy Databases (20)
1] adina

1] adinamig8t
1] ChangeRepo
1 claudiu

H COSTIN

#-[1 datamasker
1 Gk

1 GIM_1

HI gimmmih
101 harry

001 io_test

11 master

10 madel

[
[
[
[
[
[
[
[
[
[
[
[
[
#-[] msdh
[
E

Bl+b  Check Constraints
HE Defaults
%2 Foreign Keys
B fe Functions
Indexes
BHER Primary Kevs
& Procedurss
B4 Roles

Hm Rules

#-4d Schemas
H-E Tables

Creating an Object Using the Object Creation Wizard

From within the Database Explorer Tree you can create any database object using
simple Object Creation Wizards. The following is an example of how to use the Table
Object Creation Wizard. It is similar to the Object Creation Wizards available within
Rapid SQL for all database objects.
1. Right-click on the Tables node and select Create. A Create Table Wizard
opens.
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Create Table Wizard - Step 1 of 6 @

Properties @
Specify the table properties.
Propery value

= Creation
Schema [
Mame |
ANSI_NULLS option O

= Physical Storage
Filagroup PRIMARY
TextImage Filegroup FRIMARY

2. Select a Schema, provide a Name of SAMPLE_TABLE. Leave the remaining
default settings and click Next.

3. Add a column, using a Name of Sample_Column1 and select a Type of char.
Experiment with the Add Column and Delete buttons, and with selecting a
column and modifying its attributes.

4. Click Finish. The DDL View panel opens showing the DDL that will be used to
create the new table.

Create Table Wizard - Step 6 of 6 @
DDL Yiew (Read-Only)
Preview the generated SOL.
Properties SEROA
Columns 1 USE pUbS
Indexes 2 go
Conaiion 5 CREATE TABLE dbo.SAMPLE TABLE
. 4 (
i 5 % Sample Columnl char(l] NULL
K
7 ON [PRIMARY]
3 qo
9 IF OBJECT_ID('dbO.SM‘TPLE_TABLE' ) IS WNOT NULL
10 PRINT '"<<< CREATED TABLE dbo.SAMPLE TAELE >>>'
11 ELSE
12 PRINT '"<<< FAILED CREATING TABLE
dbo. SAMP LE TABLE >>> '
13 go
14
[¥]Launch Objact Editor After Executs
I Execute l ’ Cancel ] ’ Help

5. Deselect the Launch Object Editor After Execute and then click Execute.

Rapid SQL builds the platform-specific SQL code, syntactically-correct and ready to run
the first time. There is no SQL coding required in any of the Rapid SQL Object Creation
Wizards.
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Working With an Existing Object Using the Object Editor

While the wizard offered you the option to automatically open an editor on creating the
table, you can also manually open an editor.
1. In the Database Explorer, right-click on your new table and select Open.

Tables - TORLABSQLOS_1\FIFisa =Jo&d
@9% Create ¥ Drop Q,t Extract E,}lRepUrt <& Command ~ z Reefresh iECIUsa
Schema guest = Table 54MPLE_TABLE
4 Columns r Fropetties r Indexes r Conskraints. r Space r Dependencies r Permissians. r DL Migw ] 3
n s Add Column = & Delete
E3 Mame Type Tull Default Fraperty Value
i Sample_...  char(1) U= = Column Attributes A
Name Sample_Column1
Computed [}
= Datatype
Type char
Size 1
Allawy Nulls
Sparze Colurn
Default Collation SOL_Latind_General_CP1_..=
Drefault Y alue -
= Bindings
Defaul Binding
Fule Binding
= Computed Column |
-

Obiject Editor features are as follows:

e All Object Editors provide standardized, multi-tabbed windows for each
database object type.

e All Object Editors provide fully-functional toolbars for easy object
management.

e Rapid SQL has full knowledge of the underlying DBMS system catalog,
syntax and alteration rules, so the user can concentrate on what needs to
be done, not on how to do it.

e Drop-down boxes allow you to easily move between owners and objects.

The Rapid SQL Object Editors easily perform operations that would normally
require painstaking and error-prone scripting, such as deleting or inserting
columns in a table while preserving data, dependencies and permissions. Rapid
SQL analyzes the database catalog to determine its structure, and then
automatically generates the SQL script required for the extended alteration. For
instance, when a full table alteration is required, Rapid SQL automatically
unloads and reloads the data, eliminating tedious work.

2. Close the Object Editor window.

Object Documentation and Reporting

Rapid SQL provides rich, detailed HTML Reporting for all database objects. Building a
browser-ready report for any object is only a few mouse-clicks away.
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1. Expand the Tables node, right-click on any table and select Report from the menu.
A Report dialog opens.

Report

Report Home Page File Name:
Embarcadero\RapldSQL\Report\db0.s|mpIeTestTabIe_E)deaaaB_Table.HTNﬂ =3

[ JAppend date and time stamp to reportfile name
[ Sawve report in date specific folders

Report Title:
Tahle Report

Object Name:
dbo.cimpleTestTable_3fdfaask

Object Type:
Tables

[v' Execute Hx Cancel H'? Help ]

2. Enter a destination Report Home Page File Name. This can be a network web
server directory\file.

3. Enter a Report Title and click Execute.

The HTML report will automatically be displayed in the Rapid SQL application
workspace. For example:
dbo.authors

Object Type Table

Datasource EBT%B& { SGL Senver08.00.0760 )
Laogin sa

Database pubs

Repont Date 4f14/2003 16:54.45.847

Columns
Name Datatype Hull Default Default Rule Binding
Binding
au_id il Mo
au_lname varchar(dd)  |No
au_frame varchar20) No
phone char{12) Mo UNKNOWWN'

The HTML report can be saved to a new file or referenced in the file named above.
NOTE: All HTML reports are browser-ready and suitable for posting directly to the web.

Working With Code, Files and Data

Rapid SQL provides many features and powerful development tools for creating and
executing SQL code and working with data.

Note: For purposes of this Evaluation Guide, we are only covering high-level
functionality of the major features and tools within Rapid SQL.

Setting Environment Options
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The Options Editor allows you to set the Rapid SQL development environment to meet
your needs.
1. Select File > Options from the menu. The Options dialog opens.

Options
Tupe filter text Datasource
Datasource
+ Ganeral. Datazource Storage Management
Connection
IDEC (®windows Hegistry datasource calalog
Logging Legacy datazource starage that is compatible with previous versions of Embarcadera
SMITP Mail RIEEMEE,
Perf Center () File based datasource catalog
Reports Datasources are stored in the curent user's application data folder.
Explorer () Network shared datasource catalog
+-I50L Diatazources are located in a cammon resource that is shareable between multiple users.
+- Debug Datazource changes are not propagated ko other users and are not retained between instances
% DDL Extract of this application.
- Results Location of shared managed datasources file:
Grid Properties =3
Browsers
Wersion Control . .
. Recent Datazource List Contains: 8| Datazources [1-32)
Warnings
Directaries [CDetault to Alias Usage When Defining Mew D atasouices
Data Edibor
Query Buider D atasource Category Settings
Java

Color the status bar using the datasource's category color
Code Analyst X
Color the tabs using the datasource's categony color

Include categary shart name in the datasource toalbar combao

| Ok ‘ | Cancel | | Help |

The Options dialog has one page per option category. You select an option category
in the left-hand pane and can subsequently set options on that page. Options are
applied when you click OK.

Favorites Tab

The Favorites Tab provides a drag-and-drop library interface of all supported DBMS
syntax, SQL syntax, built-in functions, optimizer hints, and SQL-conditional syntax.
Additionally, it provides the ability to create custom folders to store commonly-used
code for quick and efficient access, as needed.

To open the Favorites Explorer:
1. At the bottom of the Explorer pane, click Favorites. The Favorites Explorer
appears.

2. Expand the Microsoft node and then expand the Schema sub-node.

3. Right-click the Procedures node and select Open. The selected code opens in the
SQL Editor window and is ready for execution.

4. Right-click in the editor window and select Close from the context menu.

To add a custom folder to the Favorites Explorer
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1. Open the Favorites Explorer and right-click the Favorites folder.

2. Select New Folder from the menu. A new folder is added to the bottom of the tree
view.

Working with Scripts and Files

Rapid SQL extends the auto-generation of SQL code by allowing you to run your scripts
across multiple databases at the same time. In addition, there is the option to execute
the code immediately or schedule it to run later.

Script Execution Facility

1. On the Favorites Explorer, navigate to the Microsoft SQL Server node and select
the Schema sub-node.

2. Right-click the Procedures node and select Script Execution Facility. The Script
Execution Facility dialog box appears.

File Execution Facility

Show Full File Paths

File name \
C:AProgram FilestEmbarcaderc RS0OL7E04DBAS crptyMicrostty Schemal,Froc.sql

Add L.

Rermove ...
Wiew ..

[3@ Cancel H"J Help ]

Click the Target tab and select the datasources to run the script against.

Click the Output tab and select a type of output format. For the purposes of this
example, select Graphical Output.

5. If you want to send a notification message indicating that the script has executed,
click the Notify tab and enter the appropriate information in the fields provided.

6. Click Execute if you want Rapid SQL to run the script against the datasources
specified on the Target tab. If not, simply close the dialog.

NOTE: Separate script output windows are created for each selected datasource.

File Execution Facility
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Similar to the Script Execution Facility, files containing SQL scripts can be added to the

File Execution Facility and executed immediately or scheduled to run later. Other than

the origin of the code, all supporting functionality is the same.

1. On the Tools toolbar, click File Execution Facility. Rapid SQL opens the File
Execution Facility dialog box.

2. To locate the file you want to execute, click Add. Use the Add Files dialog box to
locate and select a file.

3. On the Target tab, select the datasources to run the script against.

4. On the Output tab, select the desired output option. For the purposes of this
example, select Graphical Output.

NOTE: To enable the scheduling function for the script, you must select the File
Output option.

5. If you want to send notification that the script has executed, on the Notify tab,
complete the target information.

6. Click Execute if you want Rapid SQL to run the script against the target datasources.
Otherwise, close the dialog without executing.

NOTE: Separate script output windows are created for each selected datasource.

Viewing Data

Rapid SQL provides several options for browsing data. In addition, it gives you the
ability to construct even the most complex SQL statements with point-and-click ease.

Select * Browsing
1. On the Database Explorer ensure that the Explorer tab is displayed and then
expand the MS SQL server node.

2. Expand any database you know has table data, expand the Tables node, right-click
a table, and then click SELECT * FROM.

All columns and rows from the table are displayed in the active workspace. Close the
workspace window.

Retaining Datasource Explorer View Settings
1. Click on expandable settings at the top of the Explorer pane.
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Organizer

+ X

sl

£

F A - - - -

=] |ﬂ| Databases (47}
=[] adina

-+} Cherk Constraints
-l Defaulks

-2 Forelgn Keys

- far Functions

Indexes

¥ Primary Keys
g Procedures
&3 Roles

- Rules
- Ad schemas

COrganize by Object Owner
Show System Objects
Show Only My Objects

Full Refresh

Expand Al Groups
Collapse All Graups

Collapse All Dakasources

Retain Wiew Settings

2. Select Retain View Settings.

The Explorer will open the next time just as you left it. All connections that were
present when you closed Rapid SQL will be re-established.

Datasource Explorer Bookmarks
Rapid SQL allows you to set bookmarks for frequently visited database objects.
1. Right-click on any node in the Datasource Explorer Tree.

res@iny o |

Add Bookmark

S New...
Open
Drop...
Report..

Debug...

Compile...

Extract
i| Describe

Execute

2. Select Add Bookmark and use the Add Friendly Bookmark Name dialog to
optionally provide a new name, and create the bookmark.

After Bookmarks are defined you can use them to easily navigate to commonly used
datasource resources via the main menu “Bookmarks” item.

Bookmarks | Help

| Bookmark Manager...

>| Procedures: DEQ.IOTRIOTFIO @ GUSSY |
EST B . al0gsas

The Bookmark Manager handles maintenance of Bookmarks.
1. Select Bookmarks from the menu bar.

2. Select Bookmark Manager.
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Bookmark Manager

Bookmarks: Filter:

Eies DE2
“3 Procedures: DBOIOTFIOTFIO @ GUSSY

2 Help

[ 1Do not show 'add Friendly Bookmark Name' dialog [\/ OK l IX Close l

3. Close the Bookmark Manager dialog.

Setting Keyboard Shortcuts and Hotkeys
1. On the Tools menu, select Customize.
2. In the Customize dialog go to the Keyboard tab.
Customize

Taolbars | Tools | Options | Application Visual Style | Kevboard

Categary: Set Accelerator for:

File: [w| [Detaur ™ '\j
Commands: Current Keys:

1 N

Active Script )

Cloze

Cloze Project

Cloze Yersion Control Filr
NNIF it

Press Mew Shartout Key: Reset Al

Drescription:

Cloze

The Keyboard tab can be used to set keyboard shortcut hotkeys for all areas of
Rapid SQL functionality.

3. Close the Customize dialog.

Referencing Most Recently Used Datasources

1. Select File > Recent Datasources and then select a datasource.

Embarcadero Technologies 17



File | Datasource Project Browse Logfile View Tools Bookmarks Help

New R C

Open... Ctrl+O o 4

Close

Open Project...

Close Project

Print Setup...

Open Version C ol Files List...

Close V trol Files List...

EI Options...
Recentr,gatasources 3 1 GUSSY
Recent Projects » 2 TORLABSQLOS_2
. 3 SAMPLE_DATASOURCEL
Recent FEiles 4
4 TORLABSQLO5_1
Bt 5 TORLABSQLOB_1
6 TORLABSY15_2

HOMIHALPSIGN-H 7 DALLAS9
REPO_MSI3.ADDDA & ROMLABSQLOS 1
BFEN 219 ANNHAE = -

This will automatically place you on the datasource within the Explorer, ready to work
with active connection.
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SESSION 3: SCRIPTING

Generating Code

By providing several code generation and assistance options, Rapid SQL makes cross-
platform development easy for developers of all experience levels.

Note: The following examples build on the SQL Server 2000 SAMPLE_DATASOURCE
registered earlier in this Evaluation Guide. These examples can be applied to any
registered datasource for any of the supported platforms.

Code Generation Facility

The Code Generation Facility can be used to create complete procedures, functions
or packages revolving around views or tables.

Embarcadero Code Generator E’
1. Fromthe menu_’ open T(_)Ols > [E€8T204 _SOL_SERVER (50 Server 0 ] v o I
Code Generation Facility. (= e g
2. Select the S - 2 b |
- Select 1 or More Where Clause Columns Generate
SAMPLE_DATASOURCE [ 2l |fe L T Ja | omatpe :
datasource and the “pubs” s X okl No e
database from the dropdown list v | Gnie
boxes I ||
' G Coveca : GRANT ‘EXECUTE" TO:
3. Select the "authors” table, —_—| . 1 =
“state” as the input column and——11: 1 achatto) Mo [ Ao 1
all columns for output. / o i;é;};g; o R
Spot_Log Y. sate chaif2 Xo- v | :_:f:;‘::rv
4. Select "Select” as the code ey wareaglil| C 2| | fs >
. oot_Regh Agents Provide an Output File Name Groupt
option. tiseictias o | J
5. Select a file to save the SIS =l s et '
generated script and check
"Open”. No SQL statement coding is required to
6. Click "OK” and the DDL to generate complete stpred procgdures
create the procedure will be and packages. If applicable, Rapid _SQL
generated and displayed in an allows all generated code to be previewed
editable window, called the DDL and edited to fit any development need.
Editor. You can edit the name
of the new procedure and any of

the generated code at this time.
Name the new procedure
“sample_select_authors”.

Finished!

Embarcadero Technologies 19



Right-click feature

Similar to the Code Generation Facility, the “right-click” code generation feature can
be used to create complete procedures, functions or packages revolving around views
or tables.

=E Tables(13) 1:
&.m Mmﬁu‘ I 1. From the Database Explorer Tree, expand
}5 e —— the SAMPLE_DATASOURCE > pubs >
i =y
2@ dboem ~ % Tables sub-node.
- dbojob E4 Open
- dbopait . .
o Gooed X orop.. Right-click on the “authors” table.
E-EF dboroy 2 Repart...
P dosal Select Generate > Procedure > Select.
W[ dbosar ¥ Rename..,
e jﬁ::;::df:d:“’"' Select “state” as the input column, and
7 [2] Build Query...
433 dba il
LG ot | e stastic.. leave all output columns selected.
3 LI Ke [ .
_-;g ears ] E;"C‘““"’"‘ 5. Click "OK" and the DDL to create the
B v . procedure will be generated and displayed
€ temod> Triggers... in an editable window, called the DDL
Recompile... Editor. You can edit the name of the new
:“:;“: procedure and any of the generated code.
i HgQars. ..
natl Triopers.. Name the new procedure
Creste Insert Statements... “sample_select_authors”.
Exbrack Data as XML
o 6. Click on the P B¥ (execute or step execute)
EF}EEMME .
@ oect el button to submit the DDL and create the
Dependancies procedure.
Dgscribe -
= gthema Finished!
[E2) Copy Mamme(s)
B SELECT * FROM
Select
) Stabemerts k| Inzert
T Update
Delete
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Automated error detection and coding assistance

Rapid SQL provides a range of features that detect or help you avoid errors and save
keystrokes in developing your scripts.

To enable these features:

1. On the File menu select Options. The Options dialog opens.
2. On the Index Manager panel, ensure that Enable Indexing is selected.
3. On the Code Assist panel:
e Ensure that Severity levels for semantic validation problems has Warning
selected.

e Ensure that Enable Parsing and Parse Always are selected.
4. Click OK.

To see these features in action:

1. On the File menu, click New, and then ISQL.
Rapid SQL opens the SQL Editor window. You can add SQL code via your method
of choice (free-form typing, retrieve from a file, paste copied code, etc.).

= YY) Hh-O 8 ARA A
1 delect * from Jobs
2
Auto Commit Off CUA A\TORLABORCL10g_2\system Line 2 Col1
Dj Explorerl l |i| QueryBuilderl * - NTORLABORCL10g_2\system] Hﬂ SQL1* - \TORLABORCL10g_2\system X ﬂ

2. Experiment with the automated error detection and coding assistance as follows:
e Type SELECT * FROM and stop typing. Note the error condition.

1® SELECT * ERQM

With SQL Parsing enabled, Rapid SQL runs a syntax check any time there is an
interval of 1.5 seconds between keystrokes. You can also disable automatic
syntax checking and only run a check when you manually initiate it. Syntax error
annotation persists until you correct the problem.

e This time type a fragment that includes the name of a nonexistent object,
SELECT * FROM NON.OBJECT, for example. For now, ignore any popups.
The warning condition is a result of on-the-fly semantic validation. Rapid SQL
notifies you when a script contains a reference to an object that Rapid SQL
cannot resolve.

e Type SELECT * FROM followed by a space and then stop typing. If no popup
appears, press CTRL+SPACE. The Code Complete suggestion box lets you
select from objects or object name components such as databases or schema.
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This feature saves keystrokes and minimizes typing errors. See the online Help
for full descriptions of these features.
3. Close the current SQL Editor window.

To restore Rapid SQL settings:

1. On the File menu select Options. The Options dialog opens.

2. On both the Index Manager and Code Assist panels, click the Restore defaults
button.

3. Click OK.

Other coding aids

Rapid SQL provides extensive, easy-to-use coding aids for all of the supported DBMS
platforms, throughout the application. Aids are provided in the form of ready-to-use
code templates and blocks of syntactically correct code.

Paste SOL
1. From the Database Explorer Tree, expand the SAMPLE_DATASOURCE > pubs
sub-node.

Select File > New > SQL to open an SQL Editor window.
Select Edit > Paste SQL Statement to open the Paste SQL window.
Paste SQL

Datasoucs | SAMPLE_DATASOURCE  |v)|
Databaze pubs ™
-

Owaner dba

Object Tupe | Tables il (@) Select () Update () Inzert ) Delete

TABLES COLUMNS SELECT Stat:
dbo. suthors S 1
dbo bhubs i
dbo discourts
dbo diproperties

dbo new_suthors

dbo.hew_authors2

dbo.new_authors3

dbanew_suthorsd

dbo.new_suthorss

dbo.pub info i |
dba publshers v

] 2]

) i ® [ c]

4. Inthe Tables list, select authors.
5. Under the Columns list, click ALL.
6. Click the Select radio button.

7. Click Paste Statement to copy the generated code to the SQL Editor window.

You can use the statement as is, or modify the code as needed.

Paste SQL Syntax
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1. Select File > New > SQL to open a fresh SQL Editor window.
2. Select Edit > Paste SQL Syntax to open the SQL Syntax for SQL Server window.

SOL Syntax for SOL Server
SOL Statements: Syntas:

5 SOL Syntax | 1 IF Boolean sxpression
i SQL Commands 2 {sql_statement |
alter database | statement hlock}
a"e{tak?le. . 3 [ELEE [Boclean expressicon]
begin distributed tranzaction —
©asE BHPIession 4 {sql_statement |
checkpoint statement_block}]
begin...end
goto Label
if...else
return
create database
create default
create function [inline table
create function [multi-stater
create function [scalar]
create index
create procedure
create e
crezate schema |

< B ! ’& Easle] |§Xgancel| ”') ﬂelp]

) o v o v ) v ) v o) v o) o) v o) e i) )

3. Select a template and click Paste to copy the code template into the SQL Editor
window.

4. Add your own code to complete the needed operation.
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SESSION 4: WORKING WITH CODE WORKBENCH

The Code Workbench lets you configure resources for two SQL Editor features:
e Code Templates
e Auto Replace

Code templates are complete code blocks that can be easily added to open windows
or scripts with a few keystrokes. When you type CTRL+SPACE, the Code Assist menu
opens, letting you select a code template for insertion in the editor window.

=Tty - DG b 6| 2| B ER
1

while_loop - While Loop Exression

curgor_for - Curzar Far Laop
far_loop - For Loop Expression
=n 1> O DG Sk O
1 T;g <conditien> THEN

2 <statements>;

3 ELSIE <conditionX

4 <statements>;

5 ® “ELZE <statements>;
3 END IF;

Auto Replace lets you define shortcuts consisting of a few characters that represent
longer character strings. Instances of these Auto Replace expressions are automatically
replaced by the replacement string on activation events such as typing SPACE, TAB, or
RETURN. This feature is useful for creating shortcuts for one-line commands or SQL
statement subsets, or even to detect and fix common typographical errors such as teh
for the.

For example, consider an Auto Replace definition with an expression of sel to represent
Select * From:

= b b3
| 1@ sel

If the associated activation event includes a SPACE, then on typing sel followed by
typing SPACE, the following replacement occurs.

T | b BB D
1® select * from

Rapid SQL loads a default set of Auto Replace and Code template definitions at startup
but you can also add, edit, and delete definitions. In addition, you can save sets of
definitions to file and subsequently load specific sets of definitions, allowing you to
customize your templates to different platforms or development projects.
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To invoke Code Workbench settings:
1. Select Tools > Code Workbench.

Code Workbench

sT Code Templates T Auto Replace 1

Auto Replace

Enable Auto Replace []Replace substrings

Code Templates

[#]Enable Code Templates Edit Hat Keys

IImport Settings] [ExportSettings] [ [e]4 ] [ Cancel H Help ]

The Settings tab lets you enable the Auto Replace and Code Template features.
2. Inspect the Code Templates and Auto Replace tabs.

3. Click OK.
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SESSION 5: BUILDING A DATABASE PROJECT

Creating a new Rapid SQL Project

Rapid SQL provides an excellent team development environment by allowing you to
Reverse Engineer live database objects into off-line SQL source code files that can then
be easily added to a Version Control System (VCS). Rapid SQL's seamless VCS
integration offers all version control operations, such as get, check-out, check-in, history
and diff. This example will Reverse Engineer the table objects from the Microsoft SQL
Server “pubs” database into a Rapid SQL project and then will add the project to
version control under Microsoft Visual Source Safe.

1.
2.

Select File > New > Project to open the wizard.

Enter “sample_project” as the name, and browse and select a directory that
contains a VSS database. Enter a description (optional). Select From Database and
click OK.

3. Select "SAMPLE_DATASOURCE" and click Next.
4. Select "pubs” and click Next.

4

W »® N o

Select "dbo” as the owner. Right-click in the object type selection window and
unselect all of the options. Select only “Tables”. Under Extract Scope select
Selected Objects Only. Click Next.

Select only the authors, discounts and employees tables.
Uncheck all selected Options for tables. Click Next.
Select Retain. Click Next.

Preview the last panel and click Execute.

New Project Reverse Engineering Wizard - Step 6 of 6

Preview Operation
E 3L a
SEIVEL; ﬁ
Source: Target:
SAMPLE_DATASCOURCED master CAATINsample_project

Y'ou hawe chosen the following options and object types:

Bource Owner: dhbo

Target Owner: Retain Current Ownership
Joh Type: Custaom

Object types: Tables

Ix Cancel

l') Help l l@ Back l =

Finished! You have now successfully created a working database project. At this point,
the project is available to be added to Version Control. This can be done by clicking
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Yes when prompted and following the dialog, or by right-clicking on the project within
Project Explorer tree. Select Yes for the purpose of this guide.

Adding a Project to Version Control (Sample - Microsoft Visual Source Safe)

When a project is created Rapid SQL will automatically prompt you to add the project
files to the selected VCS solution. The following dialog will be displayed:

Visual SourceSafe Login

Useiname: |

Password |
Database:  [Microsoft Visual Studid Browse...
| Cancel | Hep |

After providing a user name and password, you can browse to locate and select the
roject database. folder.

bpen SourceSafe Database

Usemname: |scollw

¥ Open this databasa nes fime | un Visual ScurceSafe

All that remains is to provide a project name.

Add to SourceSafe Project 5]
ject:
f“"” [
7 Cancel
BT _ Dede |
(] Dasis_test Help
(B SOL_SERVER_Baseine =

Finished! The following message indicates that the project was successfully placed
under version control.

"Rapid SL

1 The files in project sample_project. epj have been placed under version control in a Visusl Source Safe project named
. sample_project epj.
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SECTION 6: VISUAL QUERY BUILDER AND DATA
EDITOR

Visual Query Builder

Rapid SQL gives you the ability to construct complex SQL statements with point-and-

click ease using the Visual Query Builder.

1. From the Database Explorer Tree, right-click on the “authors” table and select Build
Query. The “authors” table will be automatically added to the Query Builder
workspace.

2. On the Tables/Views tab, right-click on the “titleauthor” table and select Add.
Note that the tables are automatically identified as being joined by any columns
with the same name and datatype.

W EEE 2 < B s v |3 & Al
DML
e — | (@ Ax|
[ K R s 71
|81 Dwmers ] | ey _tname
R — au_fname
i Totie 2 | Ephone (2] Alx]
4 suthoes{dbo) Claddress T
G dscounts(dbo) = u_id 2
-0 employeedbo) city Jtle_id P
#[ jobs(dbo) Istate Jau_ord
o[ pub_info(dbo) j.P_..— Sroyaltyper
[ publshersidoo) coniract
@@ ropschedidbo)
5[ sales(dbo) S P
Osa |
use pubs
g0
SELECT dbo.authors.au_lnase.
dbo. authors au_fname
dbo_authors. phone
dbo. titleauthor royaltyper
FROM dbo.authors, dbo.titleauthor
VHERE (dbo.authors. au_id = dbo.titleauthor au_id)
<

i [2] QuenBuident

3. Click on the DML tab to expose the visual query building clauses and options. You
can right-click on any clause to easily add the code to the query.

Tables\iews
é SELECT
W ALL
5@ FROM
~E dbo.authars
- dbo.titleauthar
ELES COLUMNS
-~ dbo.authors. au_lname
-~ dbo.authors.au_fname
-~ dbo.authors. phone
-~ dbo.titleauthar. iopaltyper
D7 AR i
= Mew, .,
Delte o id= dbotite
-8 ORDER BY
- % GROUPEBY
- H HAVING
- & AND

4. Select the au_lname, au_fname, and phone check boxes in the authors table.

Note that the lower pane shows the query that is being built.

5. Click the Execute button to execute the query.
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b

The results will display in the lower window.

Before closing the Query Builder, experiment with additional options. Try selecting a
different statement type, such as Insert or Update, from the dropdown at the top of the
Query Builder window. Use the different clauses on the DML tab.

Any visual query builder session can easily be saved to a file for later use.

Live Data Editor
1. From the Database Explorer Tree, right-click on the “authors” table and select Edit
Data.

2. Inthe Data Editor Filter dialog, click Add All to add all columns to the editing
session.

At this point, you can add a WHERE clause that will filter for only the desired data.
Note that Rapid SQL builds the SQL to retrieve the data to be edited in the Select
Statement area.

3. Click OK. A Data Editor opens.

¥ dbo.authors - \ROMLABSOLOO_11pubstsa (=)
@0 2 b B 7 X 2] e MM Y T2 B ol
|//" au_id | au_lname | au_fname | phone | address | city |state| zip |cnntract| )
P [172-32-1176]White Johnson 408 496-7223 10932 Bigge Rd. Menlo Park Ch 94025 1
2 213-46-8915 Green IMarjorie 415 986-7020 309 63rd St #411 Oakland Ch 94618 1
3 238-95-7766 ‘Carson Cheryl 415 548-7723 589 Darwin Ln. Berkeley Ca 94705 1
4 267-41-2394 O'Leary Michzael 408 286-2428 22 Cleveland Av. #14 San Jose Ca 95128 1
5 274-80-9391 Straight Dean 415 834-2019 5420 College &v. Ozkland Cd 04609 1 [w]
1 -— Initial Zelect Statement 4/14/20098 09:58:07.5a2 B
2 —_
3 ZELECT T.au 1d, T.au lname, T.au fname, T.phens, T.address, T.city,
T.state, T.zip, T.contract FROM dbo.authors T ]
4 v
Add Partition Wiz Edit Partiti

Note the dropdown at the left of the toolbar. The editing window has LIVE and BATCH
modes:
e LIVE mode commits your changes each time you move to a new row.

e BATCH mode will allow you to move within the window and commit your
changes when ready. Changes made in BATCH mode can be cancelled by
selecting the “Reload Data” icon.

At any time during the session, you can change the filter parameters by selecting the
“Filter Data” icon.

hd
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SECTION 7: CODE ANALYST

The Code Analyst allows you to capture run-time statistics on executable database
objects, included stored procedures and functions. Not only can you capture runs for
single objects, but you can group more than one object.

To get started, select Tools > Code Analyst

Note: In order for Code Analyst to run, 5 repository tables will be created on the
database.

Select the database you would like the tables to be installed on and press OK.

Once the tables are installed, you're ready to start defining a session.

1. On the Code Analyst toolbar, click the Create New Collection button.

2. Define the session by giving it a name, selecting the objects to be executed, and
clicking Next.

@ X D OB A
IMQM Analyst Object Selection Dol

Session: 2

[an
Session Name | Sessionl

Gl © SelectbyOwner " Select by Object or |

Run Summaty
sessi

=
3. If the objects require parameters, Code Analyst prompts you to enter the
parameters.
Meia X )0 SR ]
Fi:‘vm"mmbmm:mmy i - ’_gv"ll'“o“ s
o ol = g |
= — =

Ingut Vakies

Q oo | B s | O Bee |

X Cancel | D Heo |

=l

"= ETCodetnn
After defining input variables, if you selected multiple objects, the sequence of
execution can be set by moving the object up or down in the list.

Code Analyst lets you schedule the session to run unattended during off-peak hours.
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Meie X ) O

* 3 A
ﬁwww__w, ok Detal
S Code Analyst Object Initiatization B
eszion: 2
o To set the parameters, double dick on each object,
e L e e e
Sessi Object Nome | ver |
pubs.dbo byroyaky
pubs. doo.reptal _oom |
Pubs. o, reptq2

_shedde |
<isk [ Fwh | conce | il

o |

"= ECodena..

Once the session has been run, the total time for the run is displayed in the Run
Summary tab.

MexeXr D

S Al
[ Mnsuway | SRR (TN SR R T
Sesuon 2|
[ |
Aun Sunmary

Session | S 10 fun Date | Total Time (mw) | Sehaduln |
Sessont 7 A 232004 83AM B4 000000

|

The Run Detail tab shows a breakdown of the different objects that make up the
session.
Maax)00snA

(LTINS

) T S [T
Ser R Und Tipe LUnd D Ut Otaaen ~
[Setment o) [nmpnom e o (M) o [i0mw) ) [ -

Und Enecution Time (me) Ut Tone % of P Tt

" E1cabon

The Unit Detail contains the specific time measurements for individual SQL statements.
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Maaxdo0xndl
ECETP N (Y T (RN (TN Ui |
Sesson. P Urd N »
[Saszcrd | [ e @ 232000 S0 2l | tocnsn pen B
Teo 10 Lrws % of Totel

Tep 0 Lnes Evacuton Time (4}

Totra [ 10 [fautee - % -
Pacerbage Colodation % Milweconds | ©
@ T Fun T 1™ Seconds heci
Uk Flon T " Mevies ol

B

L ] Cate | Total T o) [ of Totat Ay T o) | | Deperutecey. LU
3 I B B W DRI SELECT Gy patent o = MAX[patient 0}
FROM patient
1 HIRE L) 2 2 ? DULL] ot Gv_patart_id = Giv patert id 4 1
AT hiw murnen
' ) " # W DAL INSERT INTO PATIENTIPATENT O, v/
2 -

32

Embarcadero Technologies



SECTION 8: SQL DEBUGGING AND PROFILING

SQL Debugging

The SQL Debugger is another database productivity tool that lets you debug SQL

Server, Oracle, Sybase or DB2 stored procedures as well as Oracle functions. SQL

Debugger simplifies the task of finding coding errors.

1. From the Datasource Explorer browser, select the procedure/function object group
under your database.

2. From the detail window at right, select a procedure/function, which you would like
to debug.

3. Right-click the object to open the pull-down menu.
4. Select Debug to invoke the SQL Debugger.

Note: Pressing the Debug button or selecting Debug from the Command
dropdown menu can also invoke the SQL Debugger.

5. If the procedure/function contains input variables, the Procedure Execution window
prompts for entry of these values.

I Procedure Execution - dbo. byroyalty - @ﬁ

Qumer, Procedure:

Parameter.

| Name |Type ‘ NULLlDefauItl Value
B

Input Yalues

[@{ Open I [ Save I [0 Resat I

[X Cancsl l[" Help l B Continue

6. Enter the value(s) for the input variable(s) and press Continue.

Tip: Rapid SQL allows the user to save the input variable values to a file for later use.
This is very helpful for procedures/functions with many input variables that need to
be run repeatedly.
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The application opens the SQL Debugger Interface.

) | | [ =] &
1 » Procedure PARSE SAME IS
2 rc integer default 0;
3 1_cursor integer default 0:
4 BESIN
5 FOR 1 IN 1..1 LOOF
& 1l _cursor:=dbne_sgl.open_cursor;
7 dbms_sql.parse (1_cursor, "S§ELECT * FROM DUAL® ,dbkms_sgl.native);
8 FOR j TN 1..400000 LOOE
o ro:=dbms_sql.execute (1_cursor) ;
10 rc:=DBMS_SQL.FETCH_ROWE (1_cursor);
11 END LOOPE:
1z dbne sql.cleze curser(l cursor);
13 END LOOFE;
14 END;
15
16
17
14
Debugger - Wakch and Yariable Windows X Debugger - Dependency and Call Stack Windows *
Name [ Value | Type > TCODAU T PRHSE, SAMEN Line: 1

c NULL | integer
|_cursor |[NULL | integer

Variables L @ Watch ] [ | ﬁ CallStack L\ﬁ Dependency ] 3
Auto Commit OFF \TORLABORCL11g &\system / \ |j
Watch and Variables Call Stack and
Windows Dependencies Windows

The Debugger features basic execution, line-by-line execution, breakpoint support, and
other common debugging features. For details, refer to the online Help.

SQL Profiling- Oracle Only

The SQL Profiler within Rapid SQL provides the ability to capture the metrics of various
PL/SQL programmable objects as they are executed in the database. It quickly
identifies performance bottlenecks by first calculating the overall runtimes of objects
like Oracle packages, and then computing the amount of time each line of PL/SQL
code spends executing. Information is presented in an easily viewed, drill-down format.

1.

To start a profiling session, use the Tools menu option and select SQL Profiler,
Start.

Enter a name for the profiling session or select an existing name from the
dropdown. Press OK. The Profile session is now active.

SOL Profiler - Start

Frafile Camment:

<

¥ Cancel l l') Help l
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3. Execute the programmable object (i.e. Stored Procedure) you wish to capture
metrics on.

4. When finished, select Tools > SQL Profiler > Stop. The SQL Profiler — Stop dialog

window prompts you to select an option.

SQL Profiler - Stop

Do vou nowwish to end the
current profiling session and
record any unrecorded data
collected so far in this session in
the database?

I Stop & Analyze l

| or |

[ o]

[ e ]

Press Stop.
Under the Database Explorer, expand the PL/SQL Code Profiling section.

- E_xplorer—ElyObjectType i
|| H-% Packege Bodies
E PL/ de Profiling {3)

: : ;%H‘;dd Bookmark [

=@ fes
v

. E.ﬁ Proce| Il Run Summary

7. Right-click on the profile session and select Run Summary. The Run Summary
window will appear.

Comment

Iy_Profile ~
Run Summary
Comment Run ID Run Date Total Time (ms)
Iy _Frofile 60 01/09/2009 12:00:43 PM 47261
Iy _Frofile 61 01/09/2009 12:01:52 PM 5484

8. Select a session and select Run Detail from the right-click menu. The Run Detail

screen appears allowing you to view the metrics for this run in both a graphical and

text format.

Embarcadero Technologies 35



Comment Rurc Und Type: Urst Owner

[ create_admission) ~| [Rnm @oanovo3025605PM  v| (Al Types) ~| [ERaDMIN
¥
Time Unst — - Unkt Execution Time (ms) Ung Time % of Run Total
I 302 ERADMN CREATE_ADMISSION
(5 Millneconds fms) B 32 SYS DEeMS_OUTPUT 300
 Second (tec) (5 16 SY'S DEMS_PROFLER 20
€ Mintes {mn) 11 <anonymous> <anonymous» 200
53 7 <ononymous» <ancnymous> 150
B 7 <ancarymous> <anofymous> 100
—' [ 7 <anorymous» <anoaymous> 0
] 6 <ancoymous> <ancnymous> o
[ Unit Owner | Unit Name | Unit Type | TotastTime(ms) | % of Total |
|ERADMIN CREATE_ADMISSION PROCEDURE 02 0036
{SYS DEMS_OUTPUT PACKAGE BOOY k7 on
ISys DEMS_PROFLER PACKAGE BODY 16 0005
l«mym:- <HNONYIMOUL> ANONYMOUS BLOCK 1 0003
| canceymouss <anoerymons» ANONYMOUS BLOCK 7 0002
l-mm:r <ANONYTOUT> ANONYMOUS BLOCK 7 0002
|canonymous> CANOYMOUS> ANONYMOUS BLOCK 4 0002
{-smnyvrou:- CANOMYMOUS> ANONYMOUS BLOCK 6 0002
ramnyrmu: > <HOOCYMOUS> ANONYMOUS ELOCK 5 0002
| eaevenamonses Aot ANONYVIMOL IS P OCK n n

9. To drill down further into the data, highlight a unit and select Unit Detail from the
right-click Menu. Scroll through the Source window to view the times for each
statement.

10. To compare 2 cases, select the 2 cases you wish to compare (shift-click to select the
second case) from the Run Summary screen and select Compare from the right-click
menu. The SQL Profiler Run Comparison screen appears.

See the online help for more information on profiling.

ADDITIONAL RESOURCES

LICENSING YOUR EMBARCADERO TECHNOLOGIES PRODUCT

All Embarcadero Technologies products include a 14-day trial period. To continue using
the product without interruption, we recommend that you license it as soon as possible.
To license your product, use the License Request Wizard found in the Help menu of
your respective product. If you have not yet purchased your Embarcadero Technologies
product, contact sales@embarcadero.com, or uk.sales@embarcadero.com for sales in
the EMEA region.

EMBARCADERO TECHNOLOGIES PRODUCT SUPPORT

The Embarcadero Technologies Web site is an excellent source for additional product
information, including white papers, articles, FAQs, discussion groups, and the
Embarcadero Knowledge Base. Go to www.embarcadero.com/resources, or click any of
the links below, to find:

e Documentation

e Online Demos

e Technical Papers
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e Discussion Groups

e Knowledge Base
e FAQ

EMBARCADERO TECHNOLOGIES TECHNICAL SUPPORT

If you have a valid maintenance contract with Embarcadero Technologies, the
Embarcadero Technical Support team is available to assist you with any problems you
have with our applications. Our maintenance contract also entitles registered users of
Embarcadero Technologies products to download free software upgrades during the
active contract period. Evaluators receive free technical support for the term of their
evaluation (14 days).

We encourage you to open technical support cases via the Technical Support request
form at the Embarcadero Technologies Web site. For additional information about
Embarcadero Technologies Technical Support, go to the Support page on our Web
site.

EMBARCADERO TECHNOLOGIES ON THE WEB

To download evaluations of other Embarcadero Technologies products or to learn
more about our company and our products, visit us at www.embarcadero.com
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