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Introduction to Rapid SQL 7.5 

Rapid SQL® is an integrated development environment that enables developers to create, edit, 
version, tune, and deploy server-side objects residing on Microsoft® SQL Server, Oracle®, Sybase 
Adaptive Server®, IBM® UDB DB2®, and IBM® DB2® for OS/390® databases. Its unified database 
development environment provides extensive graphical facilities that simplify SQL scripting, object 
management, reverse engineering, database project management, version control and schema 
deployment. With Rapid SQL, programmers can develop and maintain high-quality, high-performance 
client/server and web-based applications in less time, and with greater accuracy. 

Product Benefits 
Rapid SQL provides an easy-to-use graphical user interface (GUI), which allows Database Developers 
to be immediately productive in a cross-platform environment without having platform specific 
knowledge. Along this line, Rapid SQL provides standard object creation wizards and graphical object 
editors for all supported platforms, which greatly reduce the time and effort to build an application 
database from the ground up. 

Rapid SQL also offers several cross-platform code-generation options, which help Developers build 
SQL code that is syntactically and functionally correct the first time. In addition, Rapid SQL can be 
used for the immediate or scheduled execution of SQL scripts and files, both with output and 
notification options. 

Rapid SQL makes short order of working with data by providing Developers with several easy-to-use 
browsing, visual query building and data editing options. All operations can be completed with drag-
and-drop, point-and-click ease, with little or no SQL coding required. 

Additionally, for database project management, Rapid SQL provides seamless, out-of-the-box 
integration with all major Version Control Systems (VCS). Rapid SQL offers complete database project 
management capabilities, which allows for the reverse-engineering of live database objects into 
corresponding off-line SQL source code files, which may be checked into and out of any of the 
supported VCSs. Rapid SQL also provides detailed HTML reports at the database object level that can 
be viewed immediately within the application or published to a defined web directory. 
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About This Evaluation Guide 

This evaluation guide is intended to help you get started using Rapid SQL. 

After completion of this evaluation guide, you’ll have the foundation you need to explore the many 
features of Rapid SQL.  You’ll have learned how to register and connect cross-platform datasources, 
navigate the database explorer, work with the individual object browsers, editors and wizards, build 
and manage projects, and leverage many of the productivity-focused features offered throughout 
Rapid SQL. You will also know that Rapid SQL allows you to concentrate more on what needs to be 
done and less on how it should be done. 

This guide is divided into 5 sessions. Do them all at once, or complete them individually as you have 
time.  

 Session 1: Getting Started with Rapid SQL 

 Session 2: Establishing Cross-Platform Datasources 

 Session 3: Database Object Management 

 Session 4: Building a Database Project 

 Session 5: Working with Code, Files, and Data 

 Session 6: 

 Session 7: 

 Session 8: 

You can use this basic tutorial as a roadmap of product highlights; but also to help you find your own 
path to explore Rapid SQL. 

Once you’ve started, you can select Help from the Toolbar to find additional resources including 
Tutorials that complement and build on many of the activities displayed in this brief guide. 
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Session 1: Getting Started with Rapid SQL 

Download, Install, and Start Rapid SQL 
You can obtain a trial version of the latest version of Rapid SQL from the Embarcadero web site at 
www.embarcadero.com. 

Click Download and follow the steps, as indicated. Run the executable to begin the installation 
process. 

When you first install the trial version of Rapid SQL, you can use the application for 14 days, after 
which a permanent license must be purchased from Embarcadero. 

User Interface Overview 
The graphic below illustrates all the elements of the Rapid SQL application window. 

Database Explorer   Datasource Group    Datasource    Toolbars    Application Workspace    

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

Explorer Tab   Project Tab    Favorites Tab     

Rapid SQL enables you to view and manage databases via Database Explorer. You can move from DB2 to Oracle to SQL 
Server to Sybase within the same window. Rapid SQL’s environment provides the ability to maintain several workspaces 
simultaneously and enables you to continue working while application processes occur in the background. 
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Starting Rapid SQL 
1. Choose Embarcadero Rapid SQL from the Windows Start menu. 

2. The first time Rapid SQL starts, the following message displays: 

 
Rapid SQL provides a Discover Datasources feature that automatically searches the DBMS configuration files and discovers 
datasources residing on your system that are not currently registered. The Discover Datasource feature is a dialog box that 
contains a list including the name of the server or instance and the type of DBMS of all unregistered datasources found on your 
network or local machine. This includes the name of the server or instance and the type of DBMS. Once discovered, you will be 
prompted to register the datasources in Rapid SQL. 

3. Choose Yes if you have previously installed and used Embarcadero products. Rapid SQL will 
find datasources already defined by these products in the datasource catalog stored on the 
machine, as identified in the Options>Datasource setting (See Setting Environment 
Options below). Choose No, for the purpose of this task. 

4. Select OK to continue. 

Registering Cross-Platform Datasources 
By selecting OK in the previous dialog or expanding the Datasource menu item and selecting 
Register Datasource, you will be presented with the Datasource Registration Wizard. 

To register a datasource (SQL Server example) 
1. Choose Microsoft SQL Server as the DBMS Type. 

 

1.  

 

2.  

3.  

4.  

5.  

6.  

7.  

8.  

9.  

Rapid SQL offers the same easy-to-use Datasource Registration Wizard for IBM DB2, Microsoft SQL Server, Oracle, Sybase, 
and ODBC connections. The connection information only needs to be set up one time for each platform and can be saved 
locally or in a common datasource catalog for use by other Embarcadero products. 
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2. Specify the database server. 

3. Specify SAMPLE_DATASOURCE as the Datasource Name. 

4. Click Next to complete the Datasource Registration dialog. 

5. Enter the user ID and password for the database. 

6. Select the Auto-Connect? Option and click Register. 

 

 

 

 

 

 

 

 

 

 

 

You can configure Embarcadero database applications to use a datasource catalog stored in the system registry of your 
machine (local) or to use a datasource catalog located in the registry of another computer (remote). This capability makes it 
easy to share datasource catalogs among multiple users so that maintenance can occur in one location. All Embarcadero 
database management products share the datasource catalog, which means that when you set up your datasource catalog 
using one product such as Rapid SQL, the same list of datasources is available in other Embarcadero Technologies products. 
Any changes you make to the datasource catalog are reflected in all Embarcadero database management products. 
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Session 2: Productivity Enhancers 

Database Object Management Made Easy 
Rapid SQL makes it easy and intuitive to navigate between datasources and to drill-down into atomic 
database objects within the Database Explorer Tree. The Database Explorer Tree displays all 
registered datasources and serves as the entry point for much of Rapid SQL’s advanced functionality. 

ive to navigate between datasources and to drill-down into atomic 
database objects within the Database Explorer Tree. The Database Explorer Tree displays all 
registered datasources and serves as the entry point for much of Rapid SQL’s advanced functionality. 

  
1. Click on the Explorer title bar and select “By 

Object Type”. 

2. Select and Expand the 
SAMPLE_DATASOURCE > Databases > pubs 
node to display the database object sub-nodes.

3. Expand these sub-nodes to the extent of the 
explorer tree to display all of the associated 
objects, as shown below.   
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Creating an Object Using the Object Creation Wizard 
From within the Database Explorer Tree you can create any database object using simple Object 
Creation Wizards. The following is an Oracle-based example of how to use the Table Object Creation 
Wizard. It is similar to the object creation wizards available in Rapid SQL for all database objects. 

1. Right-click on the Tables node to open the wizard and select New. Select the owner, type 
“SAMPLE_TABLE” as the table name. Select the tablespace and table organization option 
and click Next. 

 

 

 

 

 

 

 

 

 

 

 

 

Rapid SQL builds platform-specific SQL code, syntactically-correct and ready to run the first time. There is no SQL coding 
required in any of the Rapid SQL creation wizards. 

2. Add 1 column, “sample_column1, varchar(100), and take the remaining defaults. Click Next. 

3. Click Finish. 

4. The last panel (at right) is populated and displayed with the required SQL code. Preview and 
Execute. 

Note: Depending on the platform, the fields within the wizard will be different. 
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Working with an Existing Object Using the Object Editor 
When the Object Creation process is complete, Rapid SQL automatically opens an individual Object 
Editor for the new database object. An Object Editor can be opened by right-clicking on an object in 
the Database Explorer tree and selecting Open from the pop-up menu. The sample below is the 
Object Editor displayed for the “sample_table” created in the previous example. 

 

 

 

 

 

 

 

 

 

All Object Editors provide 
standardized, multi-tabbed windows 
for each database object type. 

Rapid SQL has full 
knowledge of the 
underlying DBMS system 
catalog, syntax and 
alteration rules, so the 
user can concentrate on 
what needs to be done, 
not how to do it. 

All Object Editors provide fully-
functional toolbars for easy object 
management. 

Drop-down boxes allow you 
to easily move between 
owners and objects. 

 

 

 

The Rapid SQL Object Editor easily performs operations that would normally require painstaking and error-prone scripting such 
as deleting or inserting columns in a table while preserving data, dependencies and permissions. Rapid SQL analyzes the 
database catalog to determine its structure, and then automatically generates the SQL script required for the extended 
alteration. For instance, when a full table alteration is required, Rapid SQL automatically unloads and reloads the data, 
eliminated tedious work. 
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Object Documentation and Reporting 
Rapid SQL provides rich, detailed HTML Reporting for all database objects. Building a browser-ready 
report for any object is just a few mouse-clicks away. 

1. Expand the “Tables’ and right-click on the “authors” table. 

2. Select Report from the menu. 

3. Enter a destination Home Page File Name. This can be a network web server directory/file. 
Enter a Report Title. 

4. Click Execute. 

5. The HTML report is automatically displayed in the Rapid SQL application workspace. The 
HTML report can be saved to a new file or referenced in the file named above. 
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All HTML reports are 
browser-ready and 
suitable for posting 
directly to the web. 
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Working with Code, Files, and Data 
Rapid SQL provides many features and powerful development tools for creating and executing SQL 
code and working with data. 

Note: For the purposes of this Evaluation Guide, only the high-level functionality of the major features 
and tools within Rapid SQL are covered. 

Setting Environment Options 
The Options Editor enables you to modify Rapid SQL development environment settings to meet 
your specific development needs. 

 

 

 

 

 

 

 

 

 

1. Select File>Options from the menu. 

2. Settings are displayed and modified by selecting from the drop down list box or from the 
tabbed window. 

3. Click OK once you have finished modifying the settings to have them automatically applied to 
all datasources. 
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Favorites Tab 
Rapid SQL’s Favorites tab provides a rich drag-and-drop library of all supported DBMS syntax, SQL 
syntax, built-in functions, optimizer hints, and SQL conditional syntax. It also allows you to store your 
most commonly used code in custom folders for easy access. 

1. Click on the Favorites tab to open the Favorites Explorer Tree. 

2. Expand the Microsoft SQL Server Node>Schema sub node. 

3. Click on the Procedures tree item. Note that it opens in the SQL Editor window and is ready 
for execution. 

4. To add a custom folder highlight, right-click on the Favorites node. Select New Folder. 

5. To add an existing script to the Favorites tab, open the script in a SQL Editor window, right-
click the workspace and select Add to Favorites, then follow the prompts. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Code from the Paste SQL, Paste SQL Syntax, and Favorites Tab features is available from any SQL or DDL Editing window. 

17 of 49 

 



Rapid SQL Evaluation Guide 

Working with Scripts and Files 
Rapid SQL extends the auto-generation of SQL code by allowing you to run your scripts across 
multiple databases at the same time. In addition, there is the option to execute the code immediately 
or schedule it to run later via the Windows NT Event Scheduler or the Embarcadero Job Scheduler. 

Script Execution Facility 
1. On the Favorites tab, select Microsoft SQL Server>Schema>Procedures. 

2. Click on the 
 

 icon to display the Script Execution Facility window. 

3. Select the data source to run the script against. 

4. Select the Output tab and set the output options. File output must be selected to enable the 
scheduling of the selected script. Choose Graphical output for the purpose of this task. 

5. Select Notify to set route the script output to a specific email address or file. 

6. Click Execute. The script runs against the selected data sources and separate script output 
windows are created for each selected datasource. 
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File Execution Facility 
The File Execution Facility is similar to the Script Execution Facility, in that files containing SQL scripts 
can be added and then executed immediately, or run later. Other then the origin of the code, all 
supporting functionality is the same. 

1. Click the   icon to display the File Execution Facility window. 

2. Select Add to browse for the file you want to execute. 

3. On the Target tab, select the data sources to run the script against. 

4. Select the Output tab and set the output options. File output must be selected to enable 
scheduling of the selected script. Choose Graphical output for the purposes of this guide. 

5. Select Notify to set route the script output to a specific email account or file. 

6. Click Execute to run the script against the selected data sources. Separate script output 
windows are created for each selected data source. 
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Viewing Data 
Rapid SQL provides several options for browsing data. Additionally, it provides the ability to construct 
even the most complex SQL statements with point-and-click ease. 

1. In the Database Explorer Tree, expand the SAMPLE_DATASOURCE>Pubs>Tables sub-
node. 

2. Right-click on the Authors table. 

3. Choose ‘SELECT * FROM’. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. All columns and rows from the table are displayed in the active workspace. 
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Retaining Datasource Explorer View Settings 
1. Click on the expandable settings at the top of the Explorer pane. 

2. Select Retain View Settings. 

 

 

 

 

 

 

 

 

 

 

 

 

3. Explorer opens the next time as it was when you closed it. All connections that were present 
when you closed Rapid SQL are re-established. 

21 of 49 

 



Rapid SQL Evaluation Guide 

Datasource Explorer Bookmarks 
Rapid SQL enables you to set bookmarks for frequently visited database objects. 

1. Right-click on any node in the Datasource Explorer tree. 

2. Select Add Bookmark. 

 

 

 

 

 

 

 

 

 

 

3. You can modify the bookmark’s name to suit your needs, or leave the default name provided 
by the feature. 

 

 

 

 

 

Once Bookmarks have been defined, you can use them to navigate commonly used datasource resources via the Bookmarks 
menu item. 

 

 

 

 

 

 

 

 

The Bookmark Manager handles the maintenance of Bookmarks. Select the Bookmarks from the menu and then select the 
Bookmark Manager item. 
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Setting Keyboard Shortcuts and Hotkeys 
1. Right-click in any open space above the Explorer and select Customize from the menu. 

2. In the Customize dialog, select the Keyboard tab. 

 

 

 

 

 

 

 

 

 

 

 

 

3. The tab can be used to set keyboard shortcuts and hotkeys for all Rapid SQL commands and 
functionality. 

 

Referencing Most Recently Used Databases 
1. Select File>Recent Datasources from the menu and select a data source. The interface 

automatically highlights the selected data source so you can begin work with an active 
connection. 
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Session 3: Scripting 

Generating Code 
By providing several code generation and assistance options, Rapid SQL makes cross-platform 
development easy for developers of all experience levels. 

The following examples build on the SQL Server 2000 SAMPLE_DATASOURCE registered earlier in 
this guide. However, these examples can be applied to any registered datasource for any of the 
supported platforms. 

Code Generation Facility 
The Code Generation Facility can be used to create complete procedures, functions, or packages 
revolving around views or tables. 

1. From the menu, select Tools>Code>Generation Facility. 

2. Select the SAMPLE_DATASOURCE data source and the ‘pubs’ database from the drop down 
selection menus. 

3. Select the ‘authors’ table, ‘state’ as the input column, and all columns as the output. 

4. Select ‘select’ as the code option. 

5. Select a file to save the generated script as and choose Open. 

6. Click OK. The DDL to create the procedure is generated and displayed in the DDL Editor 
window. You can edit the name of the new procedure and any of the generated code at this 
time. 

7. Name the new procedure ‘sample_select_authors’ and click on the  (execute or 
step execute) button to submit the DDL and create the procedure. 

8. The indicated file is automatically saved on the selected directory. 

 

 

 

 

 

 

 

 

 

 

 

 

No SQL statement coding is required to generate complete stored procedures and packages. If applicable, Rapid SQL enables 
all generated code to be previewed and edited to fit any development requirement. 
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Right-Click Feature 
Similar to the Code Generation Facility, the right-click code generation feature is used to create 
complete procedures, functions, or packages revolving around views or tables. 

1. On the Database Explorer Tree, expand the SAMPLE_DATASOURCE>pubs>Tables sub-
node. 

2. Right-click on the ‘authors’ table. 

3. Select Generate>Procedure>Select. 

4. Choose ‘state’ as the input column and leave all of the output columns selected. 

5. Click OK. The DDL to create the procedure is generated and displayed in the DDL Editor. You 
can edit the name of the new procedure and any of the generated code. 

6. Name the new procedure ‘sample_select_authors’ and click the  (execute or step 
execute) button to submit the DDL and create the procedure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

No SQL statement coding is required to generate complete stored procedures and packages. If applicable, Rapid SQL allows all 
generated code to be previewed and edited to fit any development need. 
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Code Assistance 
Rapid SQL provides extensive, easy-to-use code assistance features for all of the supported DBMS 
platforms throughout the application. Assistance is provided in the form of ready-to-use code 
templates and blocks of syntactically correct code. 

Paste SQL 
1. On the Database Explorer Tree, expand the SAMPLE_DATASOURCE>pubs sub-node. 

2. Select File>New>SQL. The SQL Editor window appears. 

3. Select the   toolbar menu item to open the Paste SQL window. 

 

 

 

 

 

 

 

 

 

 

4. Select the ‘authors’ table, all columns, and ‘select’ for the generation options. 

5. Click Paste Statement to copy the generated code to the SQL Editor window. You can use 
the statement “as is”, or modify the code as needed. 

27 of 49 

 



Rapid SQL Evaluation Guide 

 

Paste SQL Syntax 
1. On the Database Explorer Tree, expand the SAMPLE_DATASOURCE>pubs sub-node. 

2. Select File>New>SQL. The SQL Editor window appears. 

3. Select the 
 

 toolbar menu item to open the Paste SQL Syntax window. 

 

 

 

 

 

 

 

 

 

 

 

4. Select a template and click Paste to copy the code template into SQL Editor. 

5. Add your own code manually to complete the operation, as needed. 
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Session 4: Working with the Code Workbench 

Rapid SQL provides developers with the ability to create their own personal toolbox of coding 
accessories. The Code Workbench is composed of Auto Column Lookup and Auto Replace features, 
and Code Templates. To invoke the Code Workbench settings, select Tools>Code Workbench. 
From this panel, you can configure the Code Workbench to fit your needs. 

 
Select the specific options within the Code Workbench that you want to enable. 

 
Work with the Code Template facility by modifying the code templates that are shipped with Rapid SQL, or add your own. 

 
Rapid SQL ships with a set of Auto Replace entries. 
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When Column Auto Lookup is enabled, the list of columns for the specific table is listed. You can use the arrow keys or the 
mouse to select the column. The table must be aliased or fully qualified for this function to work. 

 
Invoke the Code Templates by pressing the defined hot key. Then select the desired code template to insert into the ISQL 
window. 
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Session 5: Building a Database Project 

Creating a new Rapid SQL Project 
Rapid SQL provides an excellent team development environment that enables you to reverse 
engineer live database objects into off-line SQL code files that can then be added to a Version Control 
System (VCS). Rapid SQL’s VCS integration offers all version control operations such as get, check-
out, check-in, history, and diff. The following example reverse engineers the table objects from the 
Microsoft SQL Server ‘pubs’ database into a Rapid SQL project, and then adds the project to version 
control under Microsoft Visual Source Safe. 

1. Select File>New>Project to open the New Project Reverse Engineering Wizard. 

2. Enter ‘sample_project’ as the name and browse and select a directory that contains a VSS 
database. Enter a description (optional), select ‘From Database’, and click OK. 

3. Select SAMPLE_DATABASE and click Next. 

4. Select ‘pubs’ and click Next. 

5. Select ‘dbo’ as the owner. Right-click in the object type selection window and de-select all 
options. Select only ‘Tables’. Under Extract Scope, choose ‘Selected Objects Only. Click 
Next. 

6. Select only the authors, discounts, and employees tables. 

7. Uncheck all selected ‘Options for tables’. Click Next. 

8. Select Retain. Click Next. 

9. Preview the last panel and click Execute. 

 

 

 

 

 

 

 

 

 

10. The project is created and can now be added to Version Control. Click Yes when prompted 
and follow the dialog, or right-click on the project within the Project Explorer tree. For the 
purpose of this exercise, ensure that you add the new project to Version Control. 
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Adding a Project to Version Control (Sample – Microsoft Visual Source Safe) 
When a project is created, Rapid SQL automatically prompts you to add the project files to the 
selected VCS solution (see Setting Environment Options in this section). The following dialog is 
displayed: 

 

 

 

 

 

 

1. Enter a user name and password (if applicable). 

2. Enter or Browse to the project database folder and select Open. 

 

 

 

 

 

 

 

 

3. Click OK and enter ‘sample_project’ as the Project name. 

 

 

 

 

 

 

 

 

 

The following message appears, indicating that the project was successfully placed under version 
control: 
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Session 6: Visual Query Builder and Data Editor 

Rapid SQL provides the ability to construct complex SQL statements with point-and-click functionality 
via the Visual Query Builder. 

1. From the Database Explorer Tree, right-click the ‘authors’ table and select Build Query. 

2. The ‘authors’ table is added to the Query Builder workspace. Right-click on the ‘titleauthor’ 
table and select ‘add’. Note that the tables are automatically identified as being joined by any 
columns with the same name and data type. 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click the DML tag to view the visual query building clauses and options. Right-click on any 
clause to add the code to the query. 

4. Click the  icon to execute the query. The results will display in the lower window 

. 
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Live Data Editor 
1. In the Database Explorer Tree, right-click ‘authors’ and select Edit Data. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Add all columns to the editing session. You can add a WHERE clause that will filter the 
desired data. Rapid SQL builds the code to retrieve the data to be edited in the bottom pane 
on the dialog. 

3. The editing window has two modes: LIVE and BATCH. LIVE mode commits your changes 
each time you select a new row. BATCH mode enables you to move within the window and 
commit your changes when needed. 

 

 

 

 

 

 

4. Changes made in BATCH mode are cancelled by clicking the Reload Data icon. 

5. At any time during the session, you can change the filter parameters by clicking the Filter Data 
Dialog icon. 
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Session 7: Code Analyst 

The Code Analyst enables you to capture run-time statistics on executable database objects, including 
stored procedures and functions. Not only can you capture runs for single objects, but you can group 
more than one object. 

To get started, select Tools>Code Analyst. 

In order for Code Analyst to run, you need to create 5 repository tables on the database: 

1. Select the database you want the tables to be installed on and click OK. 

2. When the tables are installed, you can begin defining a session. 

 
Define the session by giving it a name and selecting the objects to be executed. 

 
If the objects require parameters, Code Analyst prompts you to enter them in the Value column. 
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After defining input variables, the sequence of execution can be set by moving the object up or down in the list. Code Analyst 
provides the user the ability to schedule the session, enabling the job to run unattended during off-peak hours. 

 
Once the session has been run, the total time for the run is displayed in the Run Summary tab. 

 
The Run Detail tab shows a breakdown of the different objects that make up the session. 
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The Unit Detail contains the specific time measurements for individual SQL statements. 
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Session 8: SQL Debugging and Profiling 

SQL Debugging 
The SQL Debugger is a database productivity tool that enables you to debug SQL Server, Oracle, 
Sybase, or DB2 stored procedures as well as Oracle functions. SQL Debugger simplifies the task of 
finding coding errors. 

1. From Datasource Explorer, select the procedure/function object group under your database. 

2. From the detail window, select a procedure/function that you want to debug. 

3. Right-click the object and select Debug from the menu to start the SQL Debugger. 

 

 

 

 

 

 

 

 

 

 

 

 

Note: Clicking the Debug button or selecting Debug from the Command menu also opens the 
SQL Debugger. 

4. Click Debug to run the SQL Debugger. 

5. If the procedure/function contains input variables, the Procedure Execution window will 
prompt you to enter these values. Enter the value(s) of the input variable(s) and click 
Continue. 
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The SQL Debugger Interface appears: 
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SQL Profiling (Oracle Only) 
The SQL Profiler provides the ability to capture the metrics of PL/SQL programmable objects as they 
are executed in the database. It identifies performance bottlenecks by first calculating the overall 
runtimes of objects like Oracle packages, and then computes the amount of time each line of PL/SQL 
code spends executing. Information is presented in an easily viewed, drilldown format. 

1. To begin a profiling session, use the Tools menu option and select SQL Profiler>Start or click 
the Start Profiling icon on the SQL Profiler Toolbar. 

 

 

2. Enter a name for the profiling session or select an existing name from the drop down menu. 
Click OK. The Profile session becomes active. 

 

 

 

 

 

3. Execute the programmable object (i.e. Stored Procedure) you want to capture metrics on. 

4. When you are finished, click the Stop Profiling icon on the Toolbar. 

 

 

5. The SQL Profiler – Stop dialog appears. Click Stop. 
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6. Expand the PL/SQL Code Profiling section and right-click on the profile session. Select Run 
Summary. The Run Summary window appears. 

 

 

 

 

 

 

 

 

7. Select a session and choose Run Detail from the right-click menu. The Run Detail screen 
appears and displays the metrics for this session in both graphical and text formats. 

 

 

 

 

 

 

 

 

 

8. To drill down further into the data, highlight a unit and select Unit Detail from the right-click 
menu. Scroll through the Source window to view the times for each statement. 
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9. To compare 2 cases, select them both (pressing shift and selecting the second case with your 
mouse button) from the Run Summary screen and choose Compare from the right-click 
menu. The SQL Profiler Run Comparison window appears. 
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Session 9: Embarcadero SQL Tuner Integration 

SQL Tuning (Oracle Only) 
When working with poorly running SQL in Rapid SQL’s ISQL window, you can immediately transfer it 
into Embarcadero SQL Tuner for an automated rewrite session. 

To open the Tuner, click the Tune Current SQL icon on the ISQL window Toolbar to send the 
contents of the ISQL window to the Embarcadero SQL Tuner. 

 
 

48 of 49 

 



Rapid SQL Evaluation Guide 

Additional Evaluation Resources 

Embarcadero Technologies Product Support 
The Embarcadero Web site is an excellent source of additional product information, including white 
papers, articles, FAQs, discussion groups and the Embarcadero Knowledge Base. 

Go to www.embarcadero.com/support or click any of the links below to find: 

• Documentation 

• Online Demos 

• Technical Papers 

• Discussion Forums 

• Knowledge Base 

Licensing Your Embarcadero Technologies Product 
All Embarcadero Technologies products include a 30-day trial period. To continue using the product 
without interruption, we recommend that you license it as soon as possible. To license your product, 
use the License Request Wizard found in the Help menu of your respective product. If you have not 
yet purchased your Embarcadero Technologies product, contact sales@embarcadero.com, or 
uk.sales@embarcadero.com for sales in the EMEA region. 

Embarcadero Technologies Technical Support 
If you have a valid maintenance contract with Embarcadero Technologies, the Embarcadero Technical 
Support team is available to assist you with any problems you have with the application. Our 
maintenance contract also entitles registered users of Embarcadero Technologies’ products to 
download free software upgrades during the active contract period. 

To save you time, Embarcadero Technologies maintains a Knowledge Base of commonly encountered 
issues and hosts Discussion Forums that allow users to discuss their experiences using our products 
and any quirks they may have discovered. 

For additional information regarding Embarcadero Technologies Technical Support, go to the Support 
page on our Web site. 

Embarcadero Technologies on the Web 
To download evaluations of other Embarcadero Technologies products or to learn more about our 
company and our products visit us at www.embarcadero.com. 
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