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Introducing Rapid SQL

Introducing Rapid SQL

Rapid SQL is an integrated development environment that enables developers to
create, edit, version, tune, and deploy server-side objects residing on Microsoft SQL
Server, Oracle, Sybase Adaptive Server, InterBase/Firebird, IBM DB2 for Linux, Unix, and
Windows, and IBM DB2 for z/OS databases. Its unified database development
environment provides extensive graphical facilities that simplify SQL scripting, object
management, reverse engineering, database project management, version control, and
schema deployment. With Rapid SQL, programmers can develop and maintain high-
quality, high-performance client/server and web-based applications in less time, and
with greater accuracy.

About Rapid SQL

Your new application provides tools that can be used by a number of functions within an
organization using DBMS from multiple vendors, in testing, development, or production
environments.

Datasource management tools: Datasources must be registered. Datasources can be
registered manually or semi-automatically. Storage can be registry-based or file-based,
and a network storage option facilitates shared use of datasource catalogs.

Object management tools: Your application supports a wide range of database objects
and related elements for each DBMS. You can create new objects, edit existing objects,
and use a range of object operations that support common, general or DBMS-specific
actions.

Coding Environments/Editors: Fully-featured environments dedicated to SQL, DDL
and Active Script development are provided. Execution options are available as
appropriate, and environment-specific related features, such as rollback/commit and
query plan options, are provided. Related coding aids include on-the-fly semantic and
syntactic validation, text substitution shortcuts, and visual query building tools. Related
execution tools include script and file execution facilities.

Project Management, Version Control, and Script Library: Rapid SQL database
project management facilities help you organize, alter, and keep track of changes to
database objects or SQL scripts. The project management facilities act as a repository to
maintain all source code for a database project. Rapid SQL also incorporates version
control functions and build management facilities to help you manage and build
projects.

Other Time-savers and Productivity Tools: Working within the Rapid SQL
environment, you have access to database and file search facilities, use visual difference
to compare files or database objects, and access the Microsoft Windows task scheduler.

License-specific Add-ons: Depending on the licenses you purchased, you have access
to the following tools:
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o The Rapid SQL Code Analyst helps you identify time-consuming lines of code. It
lets you perform detailed response time analysis, benchmark the execution of
one or more procedures or functions, save response time metrics, and perform
intelligent comparisons against current execution times.

o Debuggers, available for IBM DB2 for Linux, Unix, and Windows, Oracle, Sybase,
and SQL Server, let you test functions and procedures. A Profiler is available for
Oracle datasources.
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Technical Requirements

Before using Rapid SQL, please verify that your environment meets the requirements
listed below:

Note: Users need full registry privileges during the installation and access
to the keys under HKEY_CURRENT_USER in the registry after installation.

Browser Requirements

Rapid SQL requires Microsoft Internet Explorer 11 or later.

Hardware Requirements

Embarcadero Technologies recommends the following minimum hardware
requirements:

o Pentium 4-level processor
o 1GB of memory

o 1 GB of disk space

o 1024 x 768 display

Operating System Requirements

Rapid SQL supports the following operating systems:
o Windows XP SP" (32-bit and 64-bit)
o Windows Vista (32-bit and 64-bit)
o Windows 7 (32-bit and 64-bit)
o Windows 8 (32-bit and 64-bit)

XP Support Notes

Windows XP has two user security groups: Users and Power Users. Microsoft
intentionally does not grant members of the Users Group the authority to install
applications or make global changes to the system. Restricted Users are members of the
Users Group. Standard users belong to the Power Users Group. Microsoft grants
members of the Power Users Group the authority to install programs. You must be a
member of the Administrators Group to install and use Embarcadero Technologies
applications. Because Restricted Users are members of the Users Group, they cannot
install and run Embarcadero Technologies applications.

Use the Group Membership tab to determine your group and review the Microsoft
security guidelines. On the Control Panel, open User Accounts. On the Users tab,
select a user and then click the Properties button. Click the Group Membership tab.
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Vista and Windows 7 Support Notes

Windows Vista UAC and Windows 7 provide two user types: Standard users and
Administrators. Rapid SQL can be installed or uninstalled by an administrator or by a
standard user using an administrator token. Standard users can run Rapid SQL. For the
purpose of running Rapid SQL, default standard user token privileges should not be
modified. Modifying standard user token privileges can result in licensing issues that will
prevent Rapid SQL from operating correctly.

32-bit versus 64-bit Application Considerations and
Restrictions

If you install the 64-bit version of Rapid SQL, and you are using custom drivers, you must
be using 64-bit versions of those drivers when using the é4-bit version of Rapid SQL.
Similarly, 32-bit versions of custom drivers must be used with the 32-bit Rapid SQL
installation.

For version control integration, if you install the é4-bit version of Rapid SQL, you can
work with either a 32-bit or 64-bit MSSCCI provider. The feature is controlled from the
Options Editor's Version Control tab (File > Options > General > Version Control).
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DBMS Support and Connectivity
Options

Dedicated Support Connectivity Options

Rapid SQL provides dedicated connectivity to a specific version range of IBM DB2 for
Linux, Unix, and Windows, IBM DB2 for z/OS,

InterBase/Firebird,

Microsoft SQL Server, MySQL, PostgreSQL, Oracle, Sybase, and Teradata databases.
The following connectivity options are provided:

o Native Embarcadero drivers: Rapid SQL is packaged with a set of native drivers,
each requiring a DBMS-specific client to be installed.

o InterBase/Firebird: InterBase requires both client and driver software to be
installed. Firebird requires driver software.

o JDBC drivers: Rapid SQL can connect to a datasource more directly using one
of the packaged, third-party JDBC drivers. No additional connectivity
components need to be installed. One or more third-party drivers, tested against
Rapid SQL, are installed with Rapid SQL.

The following table provides a summary of resources/requirements for connectivity to
dedicated DBMS platforms. For each platform, it lists supported versions, the client
software that must be installed if using native Embarcadero clients, and the third-party,
Type 4 JDBC drivers packaged with Rapid SQL.
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DBMS Supported Versions  Client Required for use  Packaged JDBC Source

Platform with native Embarcadero Driver &
drivers License
Apache Hive 0.13.1 Simba Hive ODBC Driver Apache Software license
(Technical (v1.4.13.1013) Foundation -
Preview)* Hortonworks Hive ODBC Apache Hive
Driver (v1.4.08.1008) JDBC v0.13.1

Cloudera ODBC Driver
for Apache Hive
(v2.05.10.1003)

Firebird Firebird 2.0 Firebird ODBC Driver Jaybird JDBC LGPL,
Driver source &
license
IBM DB2 for v8,v9, andv10 DB2 UDB Client for IBM Data Server -
z/OS Windows 8.0 or later Driver for JDBC
IBM DB2 for Versions 9.0-10.0 IBM DB2 LUW Client for IBM Data Server -
LUW Windows 8.0 or later Driver for JDBC
InterBase InterBase 2007 InterBase ODBC Driver  InterBase JDBC -
InterBase 2009 Driver
InterBase XE3
Microsoft SQL 2005 (All editions Microsoft SQL Server jTDS Type 4 LGPL
Server including 2005 Express Client Library JDBC Diriver for  source,
Edition for 32-bit x86 Microsoft SOL  license
and 64-bit Itanium & Server
x86-64) Microsoft SQL
2008 Server JDBC
2012 Driver
2014
MySQL 4.x MySQL Connector/ODBC MySQL GPL,
Driver 5.2.x Driver - Connector/J source &
MySQL Connector/ODBC JDBC Driver license
driver 3.51.x Driver
Oracle Oracle 9i, 10g, 11g, Oracle SQL*Net Client Oracle JDBC -
and 12¢ Thin Driver
PostgreSQL 9.3 minimum PostgreSQL ODBC Driver PostgreSQL BSD,
Specifically-supported  (latest version JDBC Driver license

PostgreSQL-based recommended)
database products

include Greenplum,

Pivotal HAWQ, and

BigSQL.
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Sybase ASE  Sybase 15.7 - Sybase  Sybase Open Client jTDS Type 4 LGPL,
16 JDBC Driver for source,
Microsoft SQL  license
Server

Sybase jConnect
JDBC Driver

Sybase IQ 12.7,15.4,16 SQL Anywhere ODBC Sybase jConnect
drivers for Sybase 1Q 12.7 JDBC Diriver for
Sybase |Q 32-bit ODBC  Sybase IQ

drivers

Teradata 13.10, 14.0, 14.10, and Teradata ODBC driver for Teradata JDBC
(Technical 15.0 Windows (version 15 Driver
Preview)* recommended)

* About Technical Previews - Technical previews are intended to
introduce a new DBMS platform only. The available functionality is
typically minimal. For example, command Line startup, standard
datasource registration and connection features, limited Datasource
Navigator tree functionality, a minimal set of object actions, as well as
SQL Editor execution and related, common SQL Editor functionality such
as Query Options, Paste SQL Syntax, and Paste SQL Statement. Access
may not be covered under SE or trial licenses. Contact
Oz.Basarir@embarcadero.com to obtain a separate license for a platform
designated as a Technical Preview.

Embarcadero Team Server 2016 Support

Rapid SQL can make use of datasource definitions stored on an Embarcadero Team
Server 2016.

Generic JDBC/ODBC Connectivity

Generic JDBC/ODBC connectivity to non-dedicated DBMS systems or non-database

datasources is also provided. Rapid SQL can connect to a datasource using a customer-
provided, third-party JDBC version 4.0 or ODBC version 3.0 driver. Minimal Rapid SQL
functionality is provided, including a basic Explorer tree and SQL querying.

IBM DB2 for Z/OS Stored Procedure Requirements

When working against an IBM DB2 for z/OS data source, Rapid SQL relies on the
following stored procedures, provided as an optional installation step in setting up the

DB2 subsystem:
o DSNwzP
o DSNUTILS

o ADMIN_COMMAND_DSN
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o ADMIN_COMMAND_DB2

Prior to using Rapid SQL against an IBM DB2 for z/OS data source, ensure that these
components are installed on the server. See IBM DB2 for z/OS documentation for more
information.

Specifically-tested JDBC/ODBC Connectivity
Products: Apache Hive/Hadoop

Rapid SQL has been successfully tested against Apache Hive/Hadoop datasources using
the Hortonworks ODBC driver. Similarly, Cloudera Impala datasources have been tested
using the Cloudera JDBC driver. In both cases, SQL querying and a Datasource
Navigator tree are available.

DBMS Versions no Longer Supported

As of this release, Rapid SQL is no longer being tested against Sybase ASE versions
before 15.7.
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Installing and Licensing Rapid SQL

Installing and Licensing Rapid SQL

Before you can register any Embarcadero Technologies application, you must meet the
minimum technical requirements. If you meet all the minimum technical requirements,
you can install Rapid SQL. After installation, you must license the application.

The following topics walk you through this process:

o Technical Requirements

o DBMS Support and Connectivity Options

o Installing Rapid SOL

o Licensing Your Product
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Installing Rapid SQL

To install the application successfully, you must complete each panel of the installation
wizard. 64-bit and 32-bit versions of Rapid SQL are available with the trial version, which
can be downloaded from http://www.embarcadero.com/products.

The Rapid SQL installation wizard installs all corresponding files on your machine. The
installer offers common options such as license agreement, file and folder selections,
and shortcut options. An application-specific option lets you associate file suffixes of
elements such as SQL scripts with Rapid SQL.

NOTE: Before installing Rapid SQL from Embarcadero ToolCloud, see
http://docs.embarcadero.com/products/xe/ for additional requirements
or revised instructions.

The panels presented by the wizard vary depending on whether you are upgrading or
performing an initial installation.

Caution: If you have not registered a license when you start a Rapid SQL
installation, you will be prompted to register a license. For more
information, see Licensing Your Product.

After the installation is complete, we recommend that you reboot your machine before
using Rapid SQL.
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Licensing Your Product

Each Embarcadero client application requires one or more licenses to run. An
Embarcadero product, such as Rapid SQL, has a baseline license that provides basic
feature support for that product. Also, incremental licenses may be required to support
specific DBMS platforms, product add-ons, or other functions.

For more information, see the following topics:

(0]

(0]

Licensing Overview

Licensing Your Application

Selecting a License Category During Startup

Online/Offline Mode and Concurrent License Checkout
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Licensing Overview

The following topics provide a high-level discussion of key licensing topics and directs
you to sources of more detailed information.

o Viewing Your License Type and Modules

o Understanding Trial, Workstation, and Networked Licenses

o Rapid SQL License Modules, DBMS Support, and Feature Availability

o Rapid SQOL XE License Modules, DBMS Support, and Feature Availability

o Directing Queries Regarding Licenses

Viewing Your License Type and Modules

The About... dialog, available from the Help menu, displays your license type and each
license module currently registered.

Understanding Trial, Workstation, and Networked
Licenses

Three kinds of licenses are available: Trial, Workstation, and Networked.

Trial licenses A license for a 14-day, full-featured trial version of the product. The trial license
must be registered before you can use the product.

Workstation A license or set of licenses is tied to a particular workstation. The product can
licensing only be used on that workstation.

Networked  Networked licenses are administered and distributed by a central License Server

licensing (Embarcadero License Center or Acresso FLEXnet Publisher). There are two
types of networked licenses: Concurrent and Networked Named User. With
Concurrent licensing, users on different machines take turns using licenses from
a shared pool. With Networked Named User licensing, licenses are pre-assigned
to specific users setup on the license server's user list. Those users are
guaranteed to have licenses available any time. NOTE: Concurrent licenses can
be borrowed for use without a network connection. For details, see
Online/Offline Mode and Concurrent License Checkout.

For a detailed description of licensing options, see
http://www.embarcadero.com/software-licensing-solutions.

Rapid SQL License Modules, DBMS Support, and
Feature Availability

Individual license modules correspond to the DBMS platforms you are licensed to use.
Also, each DBMS license module corresponds to a product edition. Feature availability
for each license module edition is as follows:
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o Standard: Provides baseline support including datasource management, object
management, SQL editing and execution, and standard tools and utilities.

o Professional (Rapid SQL): Standard Edition features plus SQL Debugger, SQL
Profiler, and Code Analyst.

Rapid SQL XE License Modules, DBMS Support, and
Feature Availability

An XE license provides access to all supported DBMS platforms. XE module and feature
availability are as follows:

o XE Pro (Rapid SQL): Provides baseline support including datasource
management, object management, SQL editing and execution, and standard
tools and utilities, SQL Debugger, SQL Profiler, and Code Analyst.

Directing Queries Regarding Licenses

Questions regarding license availability, feature availability, and client or server
licensing, should be directed as follows:

o If you work in an organization that uses networked licensing, direct any questions
to your site’s Rapid SQL administrator.

o If you are using workstation licensing, direct licensing questions to your
Embarcadero Technologies representative.
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Licensing Your Application

See the following topics for details on registering your product:

0 Redgistering a Trial or Workstation License during Installation

0 Redgistering a Workstation License After Application Startup

0 Redgistering By Phone

0 Redgistering a Networked License

Registering a Trial or Workstation License during
Installation

Shortly after initiating the download of a trial version of an Embarcadero product, you
should receive an email with a serial number you must register during installation.
Similarly, if you purchase an Embarcadero product while no trial version is active, you will
receive a serial number that must be registered during installation.

1. Start the installation. An Embarcadero License Registration dialog appears.
2. Copy the serial number from the email and paste it in the Serial Number field.

3. Enter your Embarcadero Developer Network account credentials in the Login or
Email and Password fields. If you have not previously created an EDN account or
have forgotten your password, click | need to create ... or I've lost my
password.

4. Click Register.

Your activation file should be downloaded and installed automatically. If this does not
happen, click the Trouble Connecting? Try Web Registration link and follow the
prompts. If you still have problems, see Registering By Phone.

Registering a Workstation License After Application
Startup

The following instructions assume that you have received a workstation license by email
and that you currently have a valid trial license. If you did not install a trial version or the
trial period has expired, follow the instructions in Registering a Trial or Workstation
License during Installation instead.

1. On the Help menu, select About, and then on the dialog that opens, click
Manage to open a license manager dialog.

2. On the Serial menu, select Add.

3. Copy the serial number from the email and paste it in the Add Serial Number
dialog, and then click OK.
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4. Right-click on the serial number you added, and then select Register from the
context menu. A registration dialog opens.

Note: The Registration Code box shows a machine-specific identifier required with
other registration methods.

5. Ensure that the Register using Online Registration radio box is selected.

6. Provide Developer Network credentials in the DN Login name or Email and DN
Password boxes. If you have not previously created an EDN account or have
forgotten your password, click | need to create ... or I've lost my password.

7. Click Register.
8. If prompted to restart the application, click Yes.

Your activation file should be downloaded and installed automatically. If this does not
happen, click the Trouble Connecting? Try Web Registration link and follow the
prompts. If you still have problems, Registering By Phone.

Registering By Phone

If you have problems with either of the above procedures, you can register licenses by
phone. You will have to provide:

o Developer Network credentials

o The registration code displayed in the Embarcadero License Registration dialog
that appears when you start an unlicensed application

o The product base license serial number
o The license serial numbers for any additional features you have purchased.

For North America, Latin America, and Asia Pacific, call (415) 834-3131 option 2 and then
follow the prompts. The hours are Monday through Friday, 6:00 A.M. to 6:00 P.M. Pacific
time.

For Europe, Africa, and the Middle East, call +44 (0)1628-684 494. The hours are Monday
through Friday, 9 A.M. to 5:30 P.M. UK. time.

Shortly after phoning in, you will receive an email containing an activation file. Then do
the following:

1. Save the file to the desktop or a scratch directory such as c:\temp.

2. On the Help menu select About and then on the dialog that opens, click
Register. A registration dialog opens.

3. Select the | have received an activation file (*.slip or reg*.txt) radio box.

4. Click the Browse button and use the Select License Activation File dialog to
locate and select the activation file you installed.
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5. Click the Import button to import the activation file and when complete, click the
Finish button.

6. If prompted to restart the application, click Yes.

Registering a Networked License

If you work in an organization using Networked licensing, an administrator, department
head, or someone performing a similar function will provide you with an activation file.

Once you receive the file, save it to the license subfolder of your product’s main
installation folder (typically Cz\Program
Files\Embarcadero\<product><version>\license\), then restart the application.

No additional steps are necessary.
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Selecting a License Category During
Startup

During startup, if multiple concurrent license categories are available, you are prompted
to select a category to use for this Rapid SQL session. Multiple license categories can be
set up to provide differing feature access or access to different DBMS versions. Feature
and DBMS version access are typically distributed across multiple license categories to
optimize the use of a site’s purchased licenses.

Note: This dialog also includes the option to remember your selection on subsequent
startups. If you select that option, you can subsequently use the Select Licenses button
on the About... dialog (Help > About) to select a different license.

Contact your License Administrator for details on individual license categories or
requests for additional feature or DBMS support.
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Online/Offline Mode and Concurrent
License Checkout

Concurrent licenses can be used in both online and offline modes. In online mode, you
must have a continuous network connection to your License Center. Licenses are
checked out on startup and checked back in on shutdown.

You can also use a license in offline mode. When you explicitly check out a license for
offline use, you can use the license without a connection to your License Center for a
specified duration. This lets you work while travelling or commuting, work away from
your primary work area, or use the license when a network connection is unavailable or
not required.

Note: Contact your site administrator for information on offline license availability, the
maximum duration, offline license policy at your site, or any other issues arising from
online license usage.

To check out a license for offline use:

1. On the Help menu, select Checkout License. The Check Out Licenses For
Offline Use dialog opens.

2. Select the check box associated with each individual license you want to check
out.

3. In the Checkout Duration box, type the number of hours that you can use the
offline license without a network connection to the License Center.

4. Click OK.
You can work offline for the specified duration. The duration period begins immediately.

If you subsequently establish a network connection to the License Center before the
license duration expires, you can indicate to the License Center that the offline license is
no longer required.

To indicate that an offline license is no longer required:
1. On the Help menu, select Checkin License.

There is no interruption in Rapid SQL usage. The license is not actually checked in until
you shut down Rapid SQL.
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Rapid SQL Tutorial exercises

The exercises that follow walk you through the Rapid SQL's major functional areas. After
completing these exercises, you will have the foundation you need to explore the many
features and benefits of Rapid SQL. You'll have learned how to competently manage the
major database administration and development tools provided.

This guide is divided into a set of sessions:

o Session 1: Getting Started

o Session 2: Productivity Enhancers

o Session 3: Scripting

o Session 4: Working with Code Workbench

o Session 5: Building a Database Project

o Session 6: Visual Query Builder

o Session 7: Live Data Editor

0 Session 8: Code Analyst

o Session 2: SOL Debugaing and Profiling

You can use this basic tutorial as a roadmap of product highlights, but also to help you
find your path to explore Rapid SQL.

Once you've started, you can select Help Topics from the Help menu to find many
additional resources that complement and build on many of the activities shown in this
tutorial.

Note: The tutorial exercises make use of the sample SQL Server database,
AdventureWorks. Since this is not part of a typical install, you can obtain the files from
installation CDs or online sources to install and attach that database. Alternatively, you
can perform the tasks targeted for the AdventureWorks database against another
available database. No destructive actions are initiated in the exercises.
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Session 1: Getting Started

Before anything else, you must perform the following tasks:

o Starting the Rapid SQL Application

0 Redgistering Cross-Platform Datasources to Rapid SOL

Starting the Rapid SQL Application

How you start Rapid SQL depends on the type of application you are evaluating:

o InstantOn version: start the application by double-clicking the file you
downloaded.

o Fully-installed version: The Start menu sequence for Rapid SQL is always in the
form Programs > Embarcadero Rapid SQLversion identifier> Rapid
SQLversion identifier, where version identifier reflects the version you are
running.

To get started
1. Run Rapid SQL.

The first time Rapid SQL starts, a dialog opens, prompting you to set up datasources. In
addition to letting you manually set up individual datasources, a number of more
automated methods are available. If you have installed and used other Embarcadero
tools, Rapid SQL can find any active datasources being used by those tools. Also, Rapid
SQL provides a Discover Datasources feature that automatically searches the DBMS
configuration files on your system for datasources that are not currently registered. Since
other Embarcadero tools let you export datasource definitions to file, you also have the
option of importing these definitions.

2. For the purpose of this tutorial, click Cancel. You will be registering a datasource
manually.

The main Rapid SQL window opens.

Embarcadero Technologies 24


http://docwiki.embarcadero.com/RapidSQL/Updates/en/Registering_Cross-Platform_Datasources_to_Rapid_SQL

Starting the Rapid SQL Application

Datasource Navigator Datasource Application Workspace

Datasource Group Toolbars

File Datasource Browse| Project Logfile View Tfuls Window Help
AL [N Y YL P
p-oAfeud--0aE

Y

1=1=F Y

: 5 | [Mo Dptasource Selected)] 5 || T|ﬂ
Datasource H;riga-tur R ox
Al@ &
DB2 Servers - -

Interbase-Firebird S5ervers
JDBC Servers
M5 0L Servers
MySOL Servers
My_Custom_Group
COracle Servers A
% ROMLABORCL11g_2 (Oracle11.1.0.7.0)
% ROMLABORCL11g_3 (Oracle11.2.0.1.0)
BF Filters
4-1-' Check Constraints
f‘ Clusters
% Database Links =

m

Proceed to Registering Cross-Platform Datasources to Rapid SQL.
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Registering Cross-Platform Datasources to Rapid SQL

Registering Cross-Platform
Datasources to Rapid SQL

For now, you will register a datasource manually.

1. On the Datasource menu, select Register Datasource. A Datasource
Registration Wizard opens.

2. Choose Microsoft SQL Server as the DBMS type and then click Next. The next
panel opens.

Register Datasource @
Information : ,[gl

Please enter the connection information for the SOL Server. E_Ij

Database Type Aedi g m—dT—w MllseE i
: = | [ |Uze Encreption
Connection Infarmation SOsieionae, e e = B
Security Parameters Pratocal: o TCRAR I Mamed Pipez
Custam Driver Properties
: Host: ( ~|

Datasource Properties
Datasource Group Part [optional]:

Drefault OB [optionall:

Datasource Mame: || -

Test Connection < Back Hewt » Finizh Cancel Help

3. Ensure that a Registration type of User defined is selected, specify the Host
name of an SQL Server datasource on your network, override the Datasource
Name with SAMPLE_DATASOURCE and then click Next.

4. Provide valid credentials in the User ID and Password boxes, and then select the
Auto-Connect? checkbox to eliminate having to provide credentials each time
you connect to this datasource.

5. In the left-hand pane, select Datasource Group, select the MS SQL Server
folder, and then click Finish.

Note: The Datasource Group panel also lets you assign a category to a datasource.
This provides a means to visually distinguish between different server purposes,
development vs. production, for example, in your enterprise. Categorization is a
customizable feature.

6. Select Yes when prompted to connect to the new datasource.

Rapid SQL offers the same easy-to-use Datasource Registration Wizard for all supported
DBMS platform connections. The connection information only needs to be set up one
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time for each platform and can be saved locally or in a common datasource catalog for
use by other Embarcadero products.

By default, Rapid SQL stores datasource definitions in the Windows Registry. There is
also a local, file-based option. Embarcadero products supporting these methods can
share datasource catalogs on the same machine.

There is also a network-shared storage option. Lastly, datasource definitions can be
stored centrally on an Embarcadero Team Server 2016 for use by Rapid SQL users.

Rapid SQL also offers the ability to import and export datasource definitions. This lets
you share definitions among users and across datasource storage methods.

Proceed to Session 2: Productivity Enhancers.

Session 2: Productivity Enhancers

This session focuses on some commonly used time-saving features:

o0 The Datasource Navigator Tree

o Creating an Object Using the Object Creation Wizard

o Working With an Existing Object Using the Object Editor

o Object Documentation and Reporting

o Working With Code, Files and Data

o Setting Environment Options

o Script Library

o Working with Scripts and Files

o Viewing Data

0 Retaining Datasource Navigator View Settings

o Datasource Navigator Bookmarks

o Setting Keyboard Shortcuts and Hotkeys

0 Referencing Most Recently Used Datasources
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The Datasource Navigator Tree

The Datasource Navigator Tree

Rapid SQL makes it easy and intuitive to navigate between datasources and to drill-
down into atomic database objects within the Datasource Navigator tree. The
Datasource Navigator displays all registered datasources and serves as the entry-point
for much of Rapid SQL's advanced functionality.

1. Click on the Navigator's dropdown and ensure that Organize By Object Type is
selected.

Datasource Mavigator X
£ @] 4\
[ DB2 Servers Organize by Object Type

|51 Interbase-Firebird Servers e sl O 2
[ JDBC Servers
[ MS SQL Servers Full Refresh

ﬁ SAMPLE_DATASQURCE
Expand All Groups

Collapse All Groups

Collapse All Datasources
Retain View Settings

Bookmarks 4

2. Select and expand the SAMPLE_DATASOURCE > Databases >
AdventureWorks node to display the database object sub-nodes.

[ Adventurebidorks
4-1-' Check Constraints
&% Database Secunty
[l Database Triggers
i Defaults
%2 Foreign Keys

Proceed to Creating an Object Using the Object Creation Wizard.
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Creating an Object Using the Object
Creation Wizard

From within the Navigator tree, you can create any database object using simple Object
Creation Wizards. The following is an example of how to use the Table Object Creation
Wizard. It is similar to the Object Creation Wizards available within Rapid SQL for all
database objects and other supported elements.

1. Right-click on the Tables node and select Create. A Create Table Wizard

opens.
Create Table Wizard - Step 1 of 6 5 @
Properties
Specify the table properties.,
Eiopeilies Froperty " alue
= Creation
Schema *
M ame
AMSI_MULLS option Ll
= Physzical Storage
Fartitioned []
Filegroup FG_ReadOnly -
Test Image Filegroup FG_ReadOnly *
Cancel | | Help

2. Select a Schema and provide a Name of SAMPLE_TABLE. Leave the remaining
default settings and click Next.

3. Add a column, using a Name of Sample_Column1 and select a Type of char.
Experiment with the Add Column and Delete buttons, and with selecting a
column and modifying its attributes.

4. Click Finish. The DDL View panel opens showing the DDL that will be used to
create the new table.

5. Deselect the Launch Object Editor After Execute and then click Execute.

Rapid SQL builds the platform-specific SQL code, syntactically-correct and ready to run
the first time. There is no SQL coding required in any of the Rapid SQL Object Creation
Wizards.

Proceed to Working With an Existing Object Using the Object Editor.
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Working With an Existing Object Using
the Object Editor

While the wizard offered you the option to automatically open an editor on creating the
table, you can also manually open an editor.

1. In the Navigator, ensure that the Tables node is expanded and then right-click
on your new table and select Open.

Calurnns |

* MName:

i Add Columin = & Delete

Type mull | Defaulk Biahsity Value
L Sample...  char(1) e = Column Attributes |

Mame Sample_Columnal .

Computed Fi

=l Datatype
Type char -
Size 1

Sllows Mullz

Sparze Column 3l

Drefault Callation SOL_Latinl_Gen_.=

Drefault Walue -

= Bindings
Default Binding -
Fiule Binding x ™

Object Editor features are as follows:

All Object Editors provide standardized, multi-tabbed windows for each
database object type.

All Object Editors provide fully-functional toolbars for easy object
management.

Rapid SQL has full knowledge of the underlying DBMS system catalog,
syntax and alteration rules, so the user can concentrate on what needs to
be done, not on how to do it.

Drop-down boxes allow you to easily move between owners and objects.

The Rapid SQL Object Editors easily perform operations that would
normally require painstaking and error-prone scripting, such as deleting
or inserting columns in a table while preserving data, dependencies, and
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permissions. Rapid SQL analyzes the database catalog to determine its
structure, and then automatically generates the SQL script required for
the extended alteration. For instance, when a full table alteration is
required, Rapid SQL automatically unloads and reloads the data,
eliminating tedious work.

2. Close the Object Editor window.

Proceed to Object Documentation and Reporting.

Object Documentation and Reporting

Rapid SQL provides rich, detailed HTML Reporting for all database objects. Building a
browser-ready report for any object is only a few mouse-clicks away.

1. Expand the Tables node, right-click on any table and select Report from the
menu. A Report dialog opens.

2. Enter a destination Report Home Page File Name. This can be a network web
server directory.

3. Enter a Report Title and click Execute.

The HTML report will automatically be displayed in the Rapid SQL application
workspace. For example:

dbo.SAMPLE_TABLE

Ohject Type Tahle

Datasource ROMLABSGLOS 1 { SOL Server 09.00.3073 )
Login sa

Database Adventure'orks

Report Date FI2320M217:28:27 824

Columns

Name Datatype Mull Default | Default Binding

sample_Column char(1) Yes

The HTML report can be saved to a new file or referenced in the file named above.
Note: All HTML reports are browser-ready and suitable for posting directly to the web.

Proceed to Working With Code, Files and Data.
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Working With Code, Files and Data

Rapid SQL provides many features and powerful development tools for creating and
executing SQL code and working with data.

Note: For purposes of this exercise, we are only covering the high-level functionality of
the major features and tools within Rapid SQL.

Proceed to Setting Environment Options.

Setting Environment Options

The Options dialog allows you to set the Rapid SQL development environment to meet
your needs.

1. Select File > Options from the menu. The Options dialog opens.

Dakasource
ki aeer el . Datasource Storage Management

Zonneckion

Java (%) windows Fegistry datasource catalog

Logging Legacy datasource storage that iz compatible with previous versions of Embarcadero

SMTP Mai R

Perf Center () File based datasource catalog

ERStudio Paorkal D atazources are stored in the curent user's application data folder.

Reports {1 Metwark shared datazource catalog

Excplarer D atazources are located in a commaon resource that iz shareable between multiple users
F- I30L [Datasource changes are not propagated to ather users and are nat retained bebween
+- Debug inztahces of thiz application.
+- DOL Extract Location of shared managed datasources file;
+- Resulks =

arid Propetties

Browsers : .

; Recent D atazource Ligt Containg: 8| Datazources [1-32)

Wersion Control

W arnings Re-zort the Datasource Combo bazed on Connection state

Data Transfer [ ] Default to Alias Usage ‘When Defining Mew [ atasources

Cracle Likiities ;

MySOL Litilities D atazaurce Category Settings

Direckories Color the gtatus bar uzing the datasource's categony colar

iatia Edlt'_:'r Colar the tabs uzing the datasource's categon color

Query Builder _

DEMS_JAVA Include category zhark name in the datazource toolbar combo

Code Analyst

The Options dialog has one page per option category. Select an option category in the
left-hand pane and you can subsequently set options on that page. Options are applied
when you click OK.

2. Close the Options dialog.

Proceed to Script Library.
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Script Library

The Script Library provides a drag-and-drop library interface of all supported DBMS
syntax, SQL syntax, built-in functions, optimizer hints, and SQL-conditional syntax.
Additionally, it provides the ability to create custom folders to store commonly-used
code for quick and efficient access, as needed.

To open the Script Library:

1.
2.
3.

4.

Select View > Script Library. The Script Library window opens.
Expand the Microsoft node and then expand the Schema sub-node.

Right-click the Procedures node and select Open. The selected code opens in
the SQL Editor window and is ready for execution.

Right-click in the editor window and select Close from the context menu.

To add a custom folder to the Script Library

1.
2.

Right-click the Script Library folder.

Select New Folder from the context menu. A new folder is added to the Script
Library folder.

To close the Script Library window:

Select View > Script Library.

Proceed to Working with Scripts and Files.
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Working with Scripts and Files

Rapid SQL extends the auto-generation of SQL code by allowing you to run your scripts
across multiple databases at the same time.

File Execution Facility

Files containing SQL scripts can be added to the File Execution Facility and executed
immediately or scheduled to run later.

1. On the Tools menu, select File Execution Facility. Rapid SQL opens the File
Execution Facility dialog box.

2. To locate the file, you want to execute, click Add. Use the Add Files dialog box
to locate and select a file.

3. On the Target tab, select the datasources to run the script against.

4. On the Output tab, select the desired output option. For the purposes of this
example, select Graphical Output.

Note: To enable the scheduling function for the script, you must select the File Output
option.

5. If you want to send notification that the script has executed, on the Notify tab,
complete the target information.

6. Click Execute if you want Rapid SQL to run the script against the target
datasources. Otherwise, close the dialog without executing.

Note: Separate script output windows are created for each selected datasource.

Script Execution Facility

The Tools menu also offers a Script Execution Facility. Similar to the File Execution
facility, it lets you type or paste the script to be executed.

Proceed to Viewing Data.
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Viewing Data

Rapid SQL provides several options for browsing data. Also, it gives you the ability to
construct even the most complex SQL statements with point-and-click ease.

Select * Browsing

1. On the Datasource Navigator, expand the MS SQL Servers node.

2. Expand any database you know has table data, expand the Tables node, right-
click a table, and then click SELECT * FROM.

All columns and rows from the table are displayed in the active workspace.
3. Close the workspace window.

Proceed to Retaining Datasource Navigator View Settings.

Retaining Datasource Navigator View
Settings

1. Click on the dropdown at the top of the Datasource Navigator.

Crganize by Ohject Cwner

Shaow System Objects L3
Show Only My Objects k|
Full Refresh

Expand &ll Groups
Collapse All Groups

Collapse All Datasources

Retain View Settings

2. Select Retain View Settings.

Next time, the Navigator will open just as you left it. All connections that were present
when you closed Rapid SQL will be re-established.

Proceed to Datasource Navigator Bookmarks.
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Datasource Navigator Bookmarks

Rapid SQL allows you to set bookmarks for frequently visited database objects.

1. Right-click on any node in the Datasource Navigator.

E.E% Frocedures (217) [.
% ADM Add Bookmark

-5?& A0M a2 New..
D ADM
B2 CLA @l: Open
_;?_u, CLA) >< Drop...
. |

Ti& CLAICK Report..
By CLAL

W CLAL & Debug..
B CLA
@5 CLAL
% CLAL D! Extract
Bl o CLAL :
.E'. le;ﬂescnbe
w4 DBz P Bxecute

Compile...

2. Select Add Bookmark and use the Add Friendly Bookmark Name dialog to
optionally provide a new name, and create the bookmark.

After Bookmarks are defined, you can use them to easily navigate to commonly used
datasource resources. In this case, you would select the dropdown at the top of the
Datasource Navigator, selecting Bookmarks > SQLServer and then selecting the
bookmark you just created.

The Bookmark Manager handles maintenance of Bookmarks.

3. Select the dropdown at the top of the Datasource Navigator and then select
Bookmarks>Bookmark Manager.

Bookmark Manager

Bookmarks: Filter: | |

EHE= SOLServer
L3 dbo.procT able ; Procedures @ pubs ROMLABSOLOS 2

(4N te 2 Help

[ ]1Da not show '4dd Friendly Bookmark Mame' dialog. » OK # Cloze
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4. Close the Bookmark Manager dialog.

Proceed to Setting Keyboard Shortcuts and Hotkeys.

Setting Keyboard Shortcuts and
Hotkeys

1. On the Tools menu, select Customize.

2. In the Customize dialog, go to the Keyboard tab.

.

Customize

__Tu:u:ull:uars Tools | Options .ﬁ.pplicatiunVisuaISt}IIe_ KE}'bDafd_

Categony: Set Accelerator for:
File \v| | Defaut ] &3

Commands: Current Keys:

[ ]

| Active Script =

| Cloze

| Cloze Project

| Cloze Version Contral Fil_ | &

| z Ll i
S AR P 1 Press New Shartcut Key: Reset Al

Drezcription:

Cloze

The Keyboard tab can be used to set keyboard shortcut hotkeys for all areas of Rapid
SQL functionality.

3. Close the Customize dialog.

Proceed to Referencing Most Recently Used Datasources.
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Referencing Most Recently Used Datasources

Referencing Most Recently Used
Datasources

1. Select File > Recent Datasources and then select a datasource.

Receml\ga tasources 4 TORLABSQLO05.1 '
|.-._:.; { Yt
Recent Projects | TORLAEIOIE 2
. | SAMPLE_DATASOURCE]
Recent Eiles 4
' TORLABSQLO5 9

| Bt TORLABSQLOS_1
TORLABSY15 2
DALLASY

ROMLABSOQLOS5 1

(v SR R R B S SV S S

This will automatically place you on the datasource within the Navigator, ready to work
with active connection.

Proceed to Session 3: Scripting.

Session 3: Scripting
This session looks at Rapid SQL's development environment:

o Generating Code

o Right-click feature

o Automated error detection and coding assistance

o Other coding aids
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Generating Code

Generating Code

By providing several code generation and assistance options, Rapid SQL makes cross-
platform development easy for developers of all experience levels.

Note: The following examples build on the SAMPLE_DATASOURCE registered earlier in
this Evaluation Guide. These examples can be applied to any registered datasource for
any of the supported platforms.

Code Generation Facility

The Code Generation Facility can be used to create complete procedures, functions or
packages revolving around views or tables.

1. From the menu, open Tools > Code Generation Facility.

2. Select the SAMPLE_DATASOURCE datasource, the AdventureWorks database,
and the Purchasing schema from the dropdown list boxes.

S SAMPLE_DATASOURCE (SQL Server 09| = !

I adventurewiorks -

! Purchasing - i

3. Select the Vendor table, Name as the input column and all columns for output.

SEIECT | OF MOME W HEME LIAUSE LOIUmns
Praductyendar

PurchaseOrderD etail Nam:j " |_T-'t"pe |rrju"ab'l't-"' |
endar i a
Eﬂirsﬂa:éﬁgéderHeader _ _.-'-‘-.u:u:u:uuntNumber AccountMurm... Mo
Vepdor v Name Name No
Vnnrdress | CreditR ating birink Mo
PreferedyendorStatus Flag Mo
VendorLontact ActiveFlag Flag Mo
PurchaszsingwebServicelRL  rvarchar[1024] Yes
ModifiedDate datetime Mo

Select 1 ar Mare Dutput Calumns

M ame | Tupe | Wulability |
v YendorlD int No

v| AccountMumber AccountM__. Mo

v Mame Hame Ho

v CreditRating tinyint Mo

| Preferred¥endorStatus Flag Mo

v ActiveFlag Flag Mo

¥ PurchasingwebServic... nvarchar(l... Yes

v ModifiedD ate datetime Ho

4. Select Select as the code option.
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Generate
Chject Tvpe:

v Select

| Insert

| Update
Delete

5. Select a file to save the generated script and check Open.

Frovide an Output File Mame

File: |:|

Open [ |Ezecute lmmediately

6. Click OK and the DDL to create the procedure will be generated and displayed
in an editable window, called the DDL Editor. You can edit the name of the new
procedure and any of the generated code at this time. Name the new procedure
sample_select_vendors.

7. Click on the Execute button to submit the DDL and create the procedure.

b

The indicated file will be saved on the selected directory.

Note: No SQL statement coding is required to generate complete stored procedures
and packages. If applicable, Rapid SQL allows all generated code to be previewed and
edited to fit any development need.

Proceed to Right-click feature.
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Right-click feature

Similar to the Code Generation Facility, the “right-click” code generation feature can be
used to create complete procedures, functions or packages revolving around views or
tables.

1. From the Datasource Navigator tree, expand the SAMPLE_DATASOURCE >
AdventureWorks > Tables sub-node.

2. Right-click on the Vendors table.

: Purchasing.Wendar

» Purchasing.Mendord, HIHEEe:

: Purchasing.Wendar Triggers...

: Sales ContactCreditd Generate r Procedi . ——
. sales.CountryRegion & i oonnect s % oo
: Sales.CreditCard

: Zales.Currency Refresh Update..,
; Sales.CurrencyRate Filter... Delete..,

Select Generate > Procedure > Select.

Select Name as the input column, and leave all output columns selected.

ISARE S

Click OK and the DDL to create the procedure will be generated and displayed
in the DDL Editor. You can edit the name of the new procedure and any of the
generated code. Name the new procedure sample_select_vendors2.

6. Click on the Execute or Step Execute button to submit the DDL and create the
procedure.

4

Proceed to Automated error detection and coding assistance.
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Automated error detection and coding
assistance

Rapid SQL provides a range of features that detect or help you avoid errors and save
keystrokes in developing your scripts.

To enable these features:
1. On the File menu, select Options. The Options dialog opens.
2. In the left-hand pane, expand the ISQL node and then select Code Assist.
3. On the Code Assist panel:
= Ensure that Enable Code Complete is selected.

= Ensure that Severity levels for semantic validation problems has
Warning selected.

= Ensure that Enable Real-time syntax checking is selected.
4. Click OK.
To see these features in action:
1. On the File menu, click New, and then SQL.

Rapid SQL opens the SQL Editor window. You can add SQL code via your method of
choice (free-form typing, retrieve from a file, paste copied code, etc.).

() T - bbb O & h-© =L [(BRA Al
1 SELECT * FROM Purchasing . Vendor
=
{Auto Commit Off HCUA WTORLABORCLIO0g 2%system
D Explorerl |ﬂl SQL1 * - \TORLABORCL10g_ X\system X ﬂ

2. Type SELECT * FROM and stop typing.
Note the error condition.
1 SELECT * EEQM

Rapid SQL can run a syntax check any time there is an interval of 1.5 seconds between
keystrokes. You can also disable automatic syntax checking and only run a check when
you manually initiate it. Syntax error annotation persists until you correct the problem.
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3. This time, type a fragment that includes the name of a nonexistent object,
SELECT * FROM NON.OBJECT, for example. For now, ignore any popups. The
warning condition is a result of on-the-fly semantic validation.

1 SELECT * FPROM NDN.OEJECT|

Rapid SQL notifies you when a script contains a reference to an object that Rapid SQL
cannot resolve.

4. Type SELECT * FROM followed by a space and then stop typing. If no popup
appears, press CTRL+SPACE. The Code Complete suggestion box lets you
select from objects or object name components such as databases or schema.
This feature saves keystrokes and minimizes typing errors. See the online Help
for full descriptions of these features.

5. Close the current SQL Editor window.

To restore Rapid SQL settings:
1. On the File menu, select Options. The Options dialog opens.
2. On the Code Assist panel, click the Restore defaults button.
3. Click OK.

Proceed to Other coding aids.
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Other coding aids

Other coding aids

Rapid SQL provides extensive, easy-to-use coding aids for all of the supported DBMS
platforms, throughout the application. Aids are provided in the form of ready-to-use
code templates and blocks of syntactically correct code.

Paste SQL

1. From the Datasource Navigator tree, expand the SAMPLE_DATASOURCE >
AdventureWorks sub-node.

2. Select File > New > SQL to open an SQL Editor window.

3. Select Edit > Paste SQL Statement to open the Paste SQL window.

4. On the Paste SQL dialog, select Sample_Datasource from the Datasource
dropdown, AdventureWorks from Database, All Owners from Owner, and an

Object Type of Tables.

5| Paste 30L

Datasource | SAMPLE_DATASOURCE

==

Purchasing. PurchaseCrderHead
Purchasing. ShipMethod
Purchasing. Yendar

Purchasing MendorAddress
Purchasing. WendorConkact
Sales, ContactCreditCard

Sales, CountryRegionCurrency
Sales, CreditCard

Sales, Currency

Sales. CurrencvRate
1| m

A | LCancel

Databasze |.ﬁ.dventure'-.-'-.-'|:-rks = |
: Help
Carier |.ﬁ.II Cnaners s |
Object Type ITEIHES 'l i@ Select (0 Update (0 nsert () Delete
SELECT Statement
T ables “ 1 Columng
1

Paste Tables AL
5. Inthe Tables list, select Purchasing.Vendor.
6. Under the Columns list, click ALL.
7. Click the Select radio button.
8.
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Faste Statement

Click Paste Statement to copy the generated code to the SQL Editor window.
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You can use the statement as is, or modify the code as needed.

Paste SQL Syntax

1. Select File > New > SQL to open a fresh SQL Editor window.
2. Select Edit > Paste SQL Syntax to open the SQL Syntax for SQL Server

window.
| SQL Syntax for SQL Server = Eol
SOL Staterments; Swrta: .
£= 5CL Syntax |11 IF Boolean_expression
5 501 Cammands [l 2 {=g_staterment | staterment_block}

m

alter database

alter table

begin distributed transaction
Case EXpression

checkpoink

beqgin...end

goko Label

2 [ELSE [Boolean_expression]
4  {sgl_statement | statement_block} ]

Paste LCancel Help

3. Select a template and click Paste to copy the code template into the SQL Editor
window.

4. Add your own code to complete the needed operation.

Proceed to Session 4: Working with Code Workbench.
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Session 4: Working with Code
Workbench

The Code Workbench lets you configure resources for two SQL Editor features:
o Code Templates
o Auto Replace

Code templates are complete code blocks that can be easily added to open windows or
scripts with a few keystrokes. When you type CTRL+SPACE, the Code Assist menu
opens, letting you select a code template for insertion in the editor window.

1
Loop - Loop expreszion

@ i|F_ELSIF - If ElzelF Statement [%
curzar_far - Cursor For Loop
Ed | for_loop - For Loop Expression

<] | (2]
T b b @G| G & b6
1 @ HIF <condition> THEN
2 “<gtatemental>;
7 ELSIE <condition>
4 <statementszs>;
5 “EL3E <statements>;
6 END IF;:

Auto Replace lets you define shortcuts consisting of a few characters that represent
longer character strings. Instances of these Auto Replace expressions are automatically
replaced by the replacement string on activation events such as typing SPACE, TAB, or
RETURN. This feature is useful for creating shortcuts for one-line commands or SQL
statement subsets, or even to detect and fix common typographical errors such as teh
for the.

For example, consider an Auto Replace definition with an expression of sel to represent
Select * From:
(O] #O

1@ sell

If the associated activation event includes a SPACE then on typing sel followed by
pressing SPACE, the following replacement occurs:

1 {E- melect * -fr.l:ll:ﬂ

Rapid SQL loads a default set of Auto Replace and Code template definitions at startup,
but you can also add, edit, and delete definitions. Also, you can save sets of definitions
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to file and subsequently load specific sets of definitions, allowing you to customize your
templates to different platforms or development projects.

To invoke Code Workbench settings:
1. Select Tools > Code Workbench.

Code Warkbench @

Settings | Auto Replace Code Templates

Auto Replace

[V]Enable Auto Heplace [ Replace substings

Code Templates
[]|Enable Code Templates Edit Hot Keys

Import Settings Export Settings Festore Settings | ] 4 Cancel Help

The Settings tab lets you enable the Auto Replace and Code Template features.
2. Inspect the Code Templates and Auto Replace tabs.
3. Click OK.

Proceed to Session 5: Building a Database Project.
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Session 5: Building a Database Project

Rapid SQL provides an excellent team development environment by allowing you to
reverse engineer live database objects into off-line SQL source code files. You can
subsequently perform tasks such as distribute the files or add them to a Version Control
System (VCS). This example will reverse engineer the table objects from the Microsoft
SQL Server AdventureWorks database into a Rapid SQL project

1.
2.

Select File > New > Project to open the wizard.

Enter sample_project as the name, and accept the default target directory.
Select From Database and click OK.

On the Connection page, select SAMPLE_DATASOURCE and click Next.
On the Catalogs page, select AdventureWorks and click Next.

Click Schemas to open the Schema Selection dialog. Select Human Resources,
Purchasing, and Sales, and then click OK. The Object Selection page opens.

Under Object Types, select Tables. Then, under Objects, expand the Tables
node and select the Purchasing.Vendor, Sales.SpecialOffer, and
HumanResources.Employee tables. Click Next.

On the Options page, leave the default selections and click Finish.

When the Execute page shows that reverse engineering is complete, click
Continue.

The Project tab displays the results of the reverse engineering.
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Project 1 =
i[2] sample_project epj
=HEE Table
HumanResources. Employes sgl
-[2] Purchasing Vendar sql
~[2] Sales.SpecialCffer sql
I:-} |User Datatype
-[2] dbo.AccountNumber sql
] dbo.Fag.sqgl
dbo.Mame sqgl

=

3

HumanResources AK_Employee_LoginlD .sql
HumanResources . AK_Employee_Mational|DMumber sql
HumanResources. AK_Employee_rowaguid.sql
HumanResources. [¥_Employee_ManagerlD =gl
HumanResources. [¥_Humanresources_vacantionshours sgl
Sales AK_SpecialOffer_rowguid.sgl

Purchasing. AK_Vendor_AccountMumber sql

B Foreign Key Constraint

HumanResources. FK_Employee_Cortact_ContactlD sql
HumanResources. FK_Employee_Employee_ManagerlD =gl

(i o) ) o] [ [ i) = [ ]

Before closing the Project tab, investigate the individual project elements. Also, check
the File and Project menus for project and version control options.

Proceed to Session é: Visual Query Builder.
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Session 6: Visual Query Builder

Rapid SQL gives you the ability to construct complex SQL statements with point-and-
click ease using the Visual Query Builder.

1. From the Navigator tree, right-click on the HumanResources.Employee table
and select Build Query.

The table is automatically added to the Query Builder workspace.
2. On the Tables/Views tab, right-click on the Department table and select Add.

3. Similarly, on the Tables/Views tab, right-click on the
EmployeeDepartmentHistory table and select Add.

4. Rearrange the contents of the window to look like the following graphic.

5. Select the columns indicated in the graphic.

alx] alx] -
1 EmployeelD ra _|EmployeelD &
_InationallDNumber _l|DepartmentID P
_IContactID _ShiftlD P 3
_ILoginID ~StartDate 217
_IManagerID EE ~|EndDate

ATitle _IModifiedDate

_IBirthDate ax]

_IMaritalStatus IDepartmentd &

JG.ender e

JleeD_ate Tcrouphame

_ISalariedFlag IModifiedDate

_IVacationHours

_ISickLeaveHours

_ICurrentFlag

rowguid

_IModifiedDate

4 m I

Note that the tables are automatically identified as being joined by any columns with the
same name and datatype. Also, note that the query is being built in the lower pane.

6. Click on the DML tab to expose the visual query building clauses and options.
You can right-click on any clause to easily add the code to the query.
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T ablesNiewsT 0] ML\|

+-[F HumanResources.Emplo =
(i HumanResources.Emplo
> (i1 HumanResources.Emplo
f1 HumanResources.Depar

- ?  WHERE
B & D
L7 H % Mew
S5 o Delete ,
-8 ORDER bY R
%  GROUPBY =|

7. Experiment with adding, deleting, and modifying clauses.

8. Click the Execute button to execute the query.

b

The results will display in the lower window.

Before closing the Query Builder, experiment with additional options. Try selecting a
different statement type, such as Insert or Update, from the dropdown at the top of the
Query Builder window. Use the different clauses on the DML tab.

Note: Any visual query builder session can easily be saved to a file for later use.

Proceed to Session 7: Live Data Editor.
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Session 7: Live Data Editor

1. From the Navigator, right-click on the Purchasing.Vendor table and select Edit
Data.

2. In the Data Editor Filter dialog, click Add All to add all columns to the editing
session.

At this point, you can add a WHERE clause that will filter for only the desired data. Note
that Rapid SQL builds the SQL to retrieve the data to be edited in the Select Statement
area.

3. Click OK. A Data Editor opens.

@ | uve P BAIX S OB MY REIESS S
|i‘ VendorID AccountNumber Hame CreditRa *
4 1 INTERMATOOO1 International =
2 2 { ELECTROMOODZ2 Electronic Bike Repair & Supplies
3 3 | PREMIEROOO1 Fremier Sport, Inc.
4 4 | COMFORT0001 Comfort Road Bicycles 28
;g T P——————— =T e '
| — Initial Select Statement 7/24/2012 14:08:45.881
2 ~— -J5E 350 T BN ONE IO OO O TEOT M OONET TNV DN IO 3N T NN RN DN NN DN N I NN N N DN N DN R O NS O R DN NN NG NN I NN W AR N 2
3 SELECT T.VendorID, T.AccountMumber, T.Name, T.CreditRating, T.PreidV:
1 | {1}

Note the dropdown at the left of the toolbar. The editing window has LIVE and BATCH
modes:

o LIVE mode commits your changes each time you move to a new row.

o BATCH mode will allow you to move within the window and commit your
changes when ready. Changes made in BATCH mode can be canceled by
selecting the Reload Data icon.

At any time during the session, you can change the filter parameters by selecting the
Filter Data icon.

T

Proceed to Session 8: Code Analyst.
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Session 8: Code Analyst

The Code Analyst allows you to capture run-time statistics on executable database
objects, including stored procedures and functions. Not only can you capture statistics
for single objects, but you can group more than one object.

To get started
1. Select Tools > Code Analyst.

Note: For Code Analyst to run, 5 repository tables will be created in the database.
Select the database you would like the tables to be installed on and press OK. Once the
tables are installed, you are ready to start defining a session.

On the Code Analyst toolbar, click the Create New Collection button.

=t

2. On the Code Analyst Object Selection dialog, provide a Session Name, locate
and select the objects to be executed, and click Next.

Code Analyst Object Selection | 2 |

Session Mame

i@ Selectby Owner () Select by Object

- |Databases -
|:| adina | =
|:| adina_smoke i
- adinuta
|:| AdventureWorks
-] alex_mig
|:| alexb
|:| alexbf
|:| alexbfdsf
&[] ANA_FO3
&[] ANAFO2
-] ANAFO4
-] ANAFO46 5 -

|[am}

ack lexd = Cancel Help

A

3. Use the Code Analyst Object Initialization dialog to initiate providing input
parameters as required, change the order of execution, and when ready, click
Finish.
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Once the session has been run, the total time for the execution is displayed in the Run
Summary tab.

4. Select the other tabs to view the tabular and graphical representation of the
execution details on your selected objects. For example:

= The Run Detail tab shows a breakdown of the different objects that make
up the session.

= The Unit Detail tab contains the specific time measurements for
individual SQL statements.

5. Close the Code Analyst window.

Proceed to Session 9: SOL Debugging and Profiling.
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Session 9: SQL Debugging and
Profiling

Rapid SQL offers the following facilities that help you test and optimize code:
o SQL Debugging

o SQL Profiling- Oracle Only

SQL Debugging

The SQL Debugger is another database productivity tool that lets you debug SQL
Server, Oracle, Sybase ASE or DB2 stored procedures, as well as Oracle functions. SQL
Debugger simplifies the task of finding coding errors.

1. In the Navigator, expand the Procedure or Function node.
2. Right-click the object and select Debug from the context menu.

3. If the procedure or function takes input parameters, the Procedure Execution
window prompts you to enter values.

I Procedure Execution - dbo. byroyalty - |‘Q_Jﬁ=
Chner; Frocedure:
Farameter:

Name iTypE | NULLI Defﬂult| Yalue

{@percentage int I B

InputValues
@  DOpen ‘ ‘ Save ‘ ‘ § Beset ‘
‘)( Cancel ‘ ‘ 2 Help | ‘ B Continug

4. Enter input values and press Continue.

Tip: Rapid SQL allows the user to save the input variable values to a file for later use.
This is very helpful for procedures/functions with many input variables that need to be
run repeatedly.

The application opens the SQL Debugger Interface.
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o T T o0 | BT L BECER B 253 R
1 gr Procedure PARSE SAME IS
= rc integer default 0O;
3 1 cursor integer default 0;
4 = EEGTIHN
&5 H EoR 4cER Fesl LoD
=] I emrsor: =dbis =] Soped cursot
7 dbm=z _=gl.parse (1l _cursor,
B "@ELECT * FROM DUAL'™ ,dbms sql.native):
= FOR j IN 1..400000 LOOPE
10 ro:=dbmz =gl.execute (1 cursor);
11+ rci;=DBM& SQL.FETCH ROWS (1 curser);
1z END LOOP;
13 - dbmz =gl.cloze cursoril cursor);
14 END LOOP;
15 END;
Debugger - Watch and Yariable Windows *  Debugger - Dependency and Call Stack Windows
Name [ Value | Type | [ CODRUTAFARSE. SAMEQ Line: 1
I (NULL _integer
[_cursor [MULL  |integer
4 \\_\ K&l variables L.@ Watch ] B4 . @ Callstack L fﬁ} Dependency |
Autka Cammit CFF \“TORLABORCLL1g & | ¢ : i

The Debugger features basic execution, line-by-line execution, breakpoint support, and
other common debugging features. For details, refer to the relevant online Help topics.

Proceed to SQL Profiling- Oracle Only.
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SQL Profiling- Oracle Only

The SQL Profiler within Rapid SQL provides the ability to capture the metrics of various
PL/SQL programmable objects as they are executed in the database. It quickly identifies
performance bottlenecks by first calculating the overall runtimes of objects like Oracle
packages, and then computing the amount of time each line of PL/SQL code spends
executing. Information is presented in an easily viewed, drill-down format.

1. To start a profiling session, use the Tools menu option and select SQL Profiler >
Start.

2. Enter a name for the profiling session or select an existing name from the
dropdown. Press OK. The Profile session is now active.

-

SQL Profiler - Start @

Frofile Comment:

v - % Cancel ‘ |':" Help ‘

3. Execute the programmable object (i.e. Stored Procedure) you wish to capture
metrics on.

4. When finished, select Tools > SQL Profiler > Stop. The SQL Profiler — Stop
dialog window prompts you to select an option.

~

SOL Profiler - Stop

Do ywou how wish to end the
current profiling session and
recard any unrecorded data
collected sofarin this session in
the database?

stop & Analyze

=top

Cancel

Help
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5. Press Stop.
6. On the Navigator, expand the PL/SQL Code Profiling node.

¥ Explorer- By Object Type | &
#-% Package Bodies
E] @l PL,’SGL Ccuje Frofiling (3)

El E F"rl:n::e

IS e

7. Right-click on the profile session and select Run Summary. The Run Summary
window opens.

Comment;
y_Prafile v
-Run Sumrmary
Comment Run ID Run Date Total Time (ms)
My Profie 60 01/09/200 120043 P 47261
M':.l' F'rDﬂE al ;leDQEDDQ 12:01:52 PM 54B4§

8. Select a session and select Run Detail from the right-click menu. The Run Detail
screen appears allowing you to view the metrics for this execution in both a
graphical and text format.

ot Run ILirsit My Lirit Chwarser
| ceeste_adwrsaond >| |Aun B @ON0Z0IC2EEISPM ~| [(A Typea] >| |ERADMWIN
T L
s Lt 5 =
B 0 CFADOR CREATE ADWESSIH Lint Exex: i (v} Link Time % of Fun Tobal
& Millneconds (] D 32 5YS.DEMS_OUTPUT Sy
™ Sacorels [mac) [ 16 575 DBsaS_PROFLER o
~ : 11 canonmouss <andfmouss o
Mauzes ) 2 7 eancrmmous <anonymouss 150
[ 7 cacrrymous e sarorymmoes 100
jan| [ 7 sancrymouss <anonimises =
| R e s ®
Uit Sweee Linst Harrie Linit Type | ot lime sy | % of Total |
ERAleari CREATE_ACSSSI0N PROCEDURE ] s
SYS DEws_OUTRUT PACHAGE BODY £ -] oo
SYE DEME_PROFLER PACHACE BODY 1% DO0s
<aretrtout = “anommiuts ANCHVIMCUS BLOCH " ]
wAF e amat > <AL ANCHVMCUS BLDCH T 0002
wafudrhous > R i s ANCHVYMOUS BLOCK T 0002
“aefrTouss “aneryTouI Y ANCHMOUS BLOCH T e
SRR TR TSI ARCHIOUS BLOCH [} L]
<A TR OIS ANCHIOUS BLOCH % [0
e e SRS Fils T 14, Hast L a

9. To drill down further into the data, highlight a unit and select Unit Detail from
the right-click menu. Scroll through the Source window to view the times for each
statement.
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10. To compare 2 cases, select the 2 cases you wish to compare (shift-click to select
the second case) from the Run Summary screen and select Compare from the
right-click menu. The SQL Profiler Run Comparison screen appears.

See the relevant online Help topics for more information on profiling.

Embarcadero Technologies 59



	Introducing Rapid SQL
	About Rapid SQL

	Technical Requirements
	Browser Requirements
	Hardware Requirements
	Operating System Requirements
	XP Support Notes
	Vista and Windows 7 Support Notes

	32-bit versus 64-bit Application Considerations and Restrictions

	DBMS Support and Connectivity Options
	Dedicated Support Connectivity Options
	Embarcadero Team Server 2016 Support
	Generic JDBC/ODBC Connectivity
	IBM DB2 for Z/OS Stored Procedure Requirements
	Specifically-tested JDBC/ODBC Connectivity Products: Apache Hive/Hadoop
	DBMS Versions no Longer Supported

	Installing and Licensing Rapid SQL
	Installing Rapid SQL
	Licensing Your Product
	Licensing Overview
	Viewing Your License Type and Modules
	Understanding Trial, Workstation, and Networked Licenses
	Rapid SQL License Modules, DBMS Support, and Feature Availability
	Rapid SQL XE License Modules, DBMS Support, and Feature Availability
	Directing Queries Regarding Licenses

	Licensing Your Application
	Registering a Trial or Workstation License during Installation
	Registering a Workstation License After Application Startup
	Registering By Phone
	Registering a Networked License

	Selecting a License Category During Startup
	Online/Offline Mode and Concurrent License Checkout
	Rapid SQL Tutorial exercises
	Session 1: Getting Started
	Starting the Rapid SQL Application
	Registering Cross-Platform Datasources to Rapid SQL
	Session 2: Productivity Enhancers
	The Datasource Navigator Tree
	Creating an Object Using the Object Creation Wizard
	Working With an Existing Object Using the Object Editor
	Object Documentation and Reporting
	Working With Code, Files and Data
	Setting Environment Options
	Script Library
	Working with Scripts and Files
	File Execution Facility
	Script Execution Facility

	Viewing Data
	Select * Browsing

	Retaining Datasource Navigator View Settings
	Datasource Navigator Bookmarks
	Setting Keyboard Shortcuts and Hotkeys
	Referencing Most Recently Used Datasources
	Session 3: Scripting
	Generating Code
	Code Generation Facility

	Right-click feature
	Automated error detection and coding assistance
	Other coding aids
	Paste SQL
	Paste SQL Syntax

	Session 4: Working with Code Workbench
	Session 5: Building a Database Project
	Session 6: Visual Query Builder
	Session 7: Live Data Editor
	Session 8: Code Analyst
	Session 9: SQL Debugging and Profiling
	SQL Debugging
	SQL Profiling- Oracle Only

