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INTRODUCTION

ER/Studio Team Server is a model and metadata collaboration platform that provides greater
meaning, understanding and context to enterprise data. Database professionals, developers,
and business analysts gain better comprehension and compliance using integrated model,
metadata & collaboration tools. Team Server's collaborative enterprise glossary brings together
the entire organization to foster improved metadata, business definitions, governance,
compliance, and security policies. Online models showcase data relationships, while powerful
search capabilities help users locate enterprise data with ease. Integration with Embarcadero's
database management tools, including DBArtisan Team Server, extends the reach of enterprise
metadata with interactive “on-the-fly” tool-tips containing glossary definitions, policy
information and associated metadata in the client tools.

PRODUCT BENEFITS BY AUDIENCE

Data Consumers
* Integrate effective data comprehension capabilities in to daily workflows, delivering context
and meaning to every user.
® Enable collaboration around data among teams across business units or business functions.

* Support corporate compliance initiatives by driving responsible use of sensitive or private
data.

Data Modeling Professionals
¢ Integrate the glossary's business definitions with internal web assets to provide on-the-fly
business context with tool-tips and pop-ups.
e Create a single registry of all available data sources.
* Adhere to industry regulations and business standards regarding security and privacy, by

alerting users who view or modify sensitive data within the tools.

Data Management Professionals & Developers

® Enable extended search capability with DBArtisan Team Server.

¢ Develop applications faster by using business terms to easily locate data elements.

¢ Monitor access to and use of business glossaries and associated functions, to understand
immediate data management requirements.

* View in-line metadata in DBArtisan & Rapid SQL.

ABOUT THIS GUIDE

This guide is intended to help you get started using Embarcadero’s metadata collaboration
solution, ER/Studio Team Server, as part of the ER/Studio product family.

The design of the guide is to enable you to either read through and see the
exciting features that Team Server delivers, or if you have a demo environment set
up, you can follow our evaluation step-by-step sections. These sections are
highlighted with the ‘mouse’ icon and allow you to get first-hand experience at
the exciting new features.
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INTRODUCTION

Should you wish to experience some of the more advanced features in the
evaluation, you will be required to configure your installation so that these
features can be demonstrated. These sections are highlighted with the
‘configuration/tools’ icon.

The reading sections enable you to walk you through some more complicated
P features and give an overview for you to read through only. These are
highlighted by the ‘reading’ icon.

To complete this guide fully, you will need to have versions of ER/Studio Data
Architect, Repository and Team Server installed. For more information, an up to date installation
guide is available online. Please see http://docwiki.embarcadero.com/TeamServer/ERStudio/en
for details.

You will need additional files for this evaluation, they can be found here: TS Eval Files.zip

The tutorials are divided into 14 sessions in three parts, do them all at once or complete them
individually as your time permits. You can use this basic tutorial as a road map of some product
highlights, but also to help you find your own path in exploring Embarcadero’s Team Server.

Part 1 - The basics

Getting Started with Embarcadero Team Server on page 5

ER/Studio Team Server - Glossaries and Terms on page 6

e Create a new glossary on page 6

Import Glossaries and Terms on page 7

Searching for Terms - A Usage Example on page 7

e Filtering Search Terms on page 8

Part 2 - Set up, Alerts and DB Team Server

e Setting up for further evaluation on page 9

ER/Studio Data Architect Configuration on page 10

ER/Studio Team Server Configuration on page 11

ER Objects - Viewing Alerts on page 14

DB Team Server and DB Power Studio Product Integration on page 15

Part 3 - Advanced features

e ER/Studio Team Server - More Features on page 22

e People on page 22

¢ Glossary Tooltips on page 22

4 TEAM SERVER EVALUATION GUIDE


http://docs.embarcadero.com/products/er_studio/erstudioDA9.7_EN/Eval_PDF_Files.zip
http://docs.embarcadero.com/products/er_studio/erstudioDA9.7_EN/Eval_PDF_Files.zip
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page

GETTING STARTED WITH EMBARCADERO TEAM SERVER

GETTING STARTED WITH EMBARCADERO TEAM SERVER

When you first log in to Team Server, you are presented with the Start Here page.

ER Objects ERTools DataSources Apps

What's New?

15 it exciting new features, interface
updates, bugfixes, orall of the above?.
Click hereto open thewiki and find out!

{5 Getting Started

If you are new to Team Server and are
looking to get up and running quickly, click
here for the video of the initial tasks

Watch Video »

Learn Mare =

[} Access Team

Server with an API

Access and control your business glossaries
and model data from your own application.

Learn Mare »
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The default login being Username = Admin > Password = Admin.

Welcome to Team Server Core

Enterprise model and metadata collaboration for context, consistency, and compliance

Importing Glossaries

Click hereforavideoexplaing how to
importglossariesand termstoyour
Team Serverinstallation.

() Data Lineage

Graphically understand and interactively
explore data lineage.

Watch Video »

Learn More »

@ Manage Your Data
with DB PowerStudio®

Simplify database development,
administration, and performance tuning
across all major DBMS platforms

Learn Mare »

 User Page

synchronize with Model
Repository

Click hereforavideo,looking athow to
collaborate by syndngyour diagram.

(H Save Time...

#3. If you use the HTML version of a report,
the printing function of your web browser
can be used to print the report directly.
Press Ctrl + P to open the printing function

Learn Mare »

‘s Now supporting
Big Data!

We love data, the bigger the better!

The latest version of DA now supports
Hadoop Hive, MongoDB, Teradata and
many more platforms to help you get the
best from your data

Learn Mare »



ER/STUDIO TEAM SERVER - GLOSSARIES AND TERMS

The graphic below names and describes the functionality of some key elements of the Team

Server user interface.

Home page displays the social

interface, showing recent activity
and team communication.

Easy access to Global Search,

Glossaries, Terms, People,

Items that you have followed
are listed here to give you
easy one-click access. As

are users that have followed
you.

ER Objects, ER Tools and
Data Sources.

My Settings ~ | Log Out

Home Glossaries Terms People ERObjects ERTools DataSources

Start Here

Stream
Filter |

< previous Page 12 . next page > 10w |items per page

Description

Community

= is f\lowing glossary Custon

Documentation

ally is followiryy glossary Account

tand glossary H

above-the-line
Business Terms

E Business Terms

nin related glossary H ces and term Co-e Business Terms

m

nin related term Co-em tand glussary

m

ness Glessary and term Co-employment

admin related glossary Er

el niolie

ER/STUDIO TEAM SERVER - GLOSSARIES AND TERMS

Now that you have logged in, you can start to explore the rich features of Embarcadero Team
Server.

Your Home Page has Streams to keep you informed of any modifications or activity with, for
example, ER Objects, Glossaries or Terms that you have an interest in. These are especially
useful to keep in touch with any discussions.

The top navigation menu allows you to navigate through the features available. The left menu

bar gives further features related to the current top menu item.
@mbarcadero

Home  Glossaries Terms Pe

CREATE A NEW GLOSSARY
1 To create a new Glossary, on the top menu bar click on the Glossaries tab.
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ER/STUDIO TEAM SERVER - GLOSSARIES AND TERMS

2 On the top right of the window, click the m button to open the New Glossary
dialog.

3 Enter the Name, ‘My Glossary’ and a Definition of your choosing.
4 Click Save to create your new Glossary.
That's it!
Creating Terms in your new Glossary is just as easy. However, if you would like to create many

Glossaries and Terms quickly and easily, we have an import function that can create Glossaries
and Terms simply.

IMPORT GLOSSARIES AND TERMS

1 Toimport a .csv file, on the top menu bar click on the m tab.

2 On the top right of the window, click the EEsissidal button.

3 Browse and locate the glossaries_demo.csv file that is supplied for this example and click

the m button.

NOTE: You are welcome to choose the glossaries_full.csv file, which is a much larger file,
packed with Glossaries and Terms available for you to use. Please be aware that it will
take a few minutes to import the fully loaded csv file.

® You can download the supplied files here:TS Eval Files.zip

You can now start to explore and relate Terms to your ER Objects.

SEARCHING FOR TERMS - A USAGE EXAMPLE

1 To search for a Term, on the top menu bar click on the tab.

2 In the Search Bar, type ‘Customer’

TIP:  You will notice that as you type, the search function matches results while you are
typing. This makes your time spent looking for items more efficient.
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ER/STUDIO TEAM SERVER - GLOSSARIES AND TERMS

~N

From the search results, click on the item Customer with a Term Type of Sales.

The description of this Sales Glossary Term is “A person or organization that has expressed
interest in a product by contacting our sales department.” However, in the Marketing
department, this may be referred to as a ‘Prospect’. Clearly defined business terms made
available in your organization can explain and simplify the use of the same terms in different

departments.

From the left Menu bar, click Related Terms, to see which other Terms might be useful to
you, that you may not have directly searched for.

In this example you can see that ‘Prospect’ is a related term. Misunderstandings of similar
terms in your organization can be overcome by relating terms, allowing your users to easily
find and clarify business terms.

Stream Customer
Description _5_3‘55 .
Discussions

Followers

v Relat:
[l Reiated Glossaries e sare

B Related Terms

Customer
Marketing
A person or organization who has made a product purchase.

Related ER Objects

Prospect
Sales
A person or organization that has expressed interest in 3 product by contacting our sales department.

FILTERING SEARCH TERMS
As you have found already, searching for Terms can be simple but powerful. Giving your users
the capability to collaborate effectively.

Sometimes users across your organization can be confused with different abbreviations and
searching on the Internet can often just confuse matters. Your organization’s Glossary, is the
single, common source for truthful metadata for your organization.

TEAM SERVER EVALUATION GUIDE



SETTING UP FOR FURTHER EVALUATION

If you would like to narrow your search, you can filter what is included in the search by changing
the values in the Search In filters.

1 Click on in the top navigation menu, in the search box, type 'FOS'.

2 Inthe ‘Search In’ tickboxes, clear all items except Aliases/Synonyms..

Home  Glossaries Terms

All Terms

My Terms

Search In:

! ustomn Attributes

= Only Factory Outlet Store is remaining from the search results. The Search In filters enable
you to search not only queries the Term name, but also Aliases/Synonyms, Abbreviations,
Definition, Notes (not by default) and Custom Attributes.

SETTING UP FOR FURTHER EVALUATION

Before viewing Model data in ER/Studio Team Server you will need to synchronize with the
Repository data. Adding a Model to the Repository is done from ER/Studio.

To open ER/Studio in Windows 7, go to Start > All Programs > ER Studio Data Architect.

% Remote Desktop Connection
(D) Erstudio Data Architect XES )

» Al Programs

| Search programs and files

TEAM SERVER EVALUATION GUIDE 9
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SETTING UP FOR FURTHER EVALUATION

ER/STUDIO DATA ARCHITECT CONFIGURATION

1

2
3

From your ER/Studio DA program window, Open the AOE.dm1 file which is found with the
evaluation files.

Click the Repository Login in the menu bar Repository > Log In. Tools [Repository | Help
. . . Project Center

Log in using the name and password that you set during the Diagrams N
Repository install. Dats Dictionary v
Releases 3
In the Data Model Window (the left pane) right click the [ — ,
Securi 3

"J IE & * (o7 -'_| Logln..

4 AOE.DML - Physical Model View: AOE DW(CLVJ/_; Log Cut :

B — p

Logical Get Latest Diagram

3 Mai
EHES Pur

FH H
=

AOE.dm1 Model icon and from the context menu, click Add Diagram. On the Add Diagram
options window, click OK to add the diagram to the Repository.

Check Qut Diagram
Check In Diagram r
Add Diagram ]

Right Click the AOE.DM1 model icon again. You will now see more options available. Click
Check Out Diagram. At this point you can also choose to check out the model exclusively if
you require. For this demo, you can accept the default setting.

You have now added a diagram and checked out a diagram from the Repository!

This allows many users to collaborate on a model and check in their changes for others to

see. The icons change from a 'locked’ padlock , to an open padlock ‘W@ to show which
objects you have checked out. Your model should now have green ‘open padlock’ icons.

SETTING UP A SENSITIVE DATA ALERT
6 Click the Data Dictionary tab to change the Data Model window to a Data Dictionary

10

eData Model Data Dictional M# Data Lineage Macro
it y ge | &

For Help, press F1

window. Expand the following selection Data Dictionary > AOE_DD > Data Security
Information > Data Security Classification and double-click Privacy Level. You will be
asked to check out the item from the Repository, click Check Out to open the editor.
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SETTING UP FOR FURTHER EVALUATION

7 In the Data Security Property Editor, change to the Binding Information tab and in the
Object Class List, click on Attribute. In the Object list pane expand AOE.DM1 > AOE
PDM > CrtCrd. Select the tickbox for CrtCrd, which will include: CrdCrdID, CrdTyp,
CrdNmb, ExpMonth, ExpYear, MdfDte.

U Data Security Property Editor

MName ] Value Binding Information l
Object Class List Object List

<_Z|Aﬂribute || =3 acE DM

| Entity F2 Logical

Mode! B AOEDW

Gy Submodsl Bl AOE PDM
g Wiew :_ Adr
Bl AdrTyp
BHT) AWBuildVm
EHT BIOfMs
B Ce
BH CetCiCrd
Bl CetTyp
B Cor
B

ARRKRKRRRKIROOOO0O00000

8 Double click CrdNmb and set the Value Override as ‘Regulated Customer Info’.
9 Click OK to close the editor.
10 Right click Data Dictionary > AOE_DD and click Check In Data Dictionary.
11 Click OK to sync your changes. Then Yes and OK in the following pop up windows.

NOTE: You have now bound information to columns in ER/Studio Data Architect.

12 Finally, right click the AOE.DM1 in the data model window and choose Check In Diagram.

ER/STUDIO TEAM SERVER CONFIGURATION

q \ Now that you have synchronized your ER/Studio model to the Repository, we are going to sync
/\ your Team Server with the Repository to view and work with that model data.

1 Login to Team Server using a web browser and browsing to the server address/port, and
username and password that you chose during installation.

2 Click the My Settings > Admin menu on the right of the top menu bar.

My Settings | Log Out

Help
Preferences

Admin h

Activity

TEAM SERVER EVALUATION GUIDE 11



SETTING UP FOR FURTHER EVALUATION

3 In the administration page, you have access to ER/Studio Synchronization.

NOTE: To sync with the Repository, you will need to have added a model to the Repository from ER/
Studio DA, which is listed on page 9.

4 On the left menu bar, click ER/Studio Synchronization and then Click the tickbox for the
AOE.DM1 Project in the main window.

Home  Glossaries Terms Pq

] Projects 4 ]
Repository Management
SR [ Adventure Works3.DML Update (Mot Synchronized
Licenses
AOE.DMl Update (Mot Synchronized
Permissions

ER/Studio
Synchronization

5 From the Actions menu, click ‘'Synchronize Selected’ to sync the Repository data to ER/
Studio Team Server.

6 If this is the first time you have visited the web page, you may have popups blocked in your
web browser. If this is the case, you will need to 'Allow pop-ups’ for your server's address by
clicking on the alert bar pictured below.

=

My Settings | Log Out

§ Firefox prevented this site from opening a pop-up window.

Home  Glossaries Terms People ERObjects ERTools DataSources

7 Once the sync has completed, you will see the status as Success. If you would like to check
on progress, please click refresh.

8 To catalog all of the ER Objects, click My Settings > Admin > Repository Management >
Update Search Index. You can click refresh to check on the progress.

¥ Updating search index ...

Start Time: May 7, 2014 11:57:07 AM CEST
Objects Indexed: 0

This may take a while, depending on the size of your reporting

repository.

You have now synchronized the Repository data across to your Team Server installation!

12 TEAM SERVER EVALUATION GUIDE



SETTING UP FOR FURTHER EVALUATION

ER/STUDIO TEAM SERVER CONFIGURATION - ADDING AN ALERT

1 To set up an Alert, Click on the ER Objects tab in the top Navigation menu.

2 Inthe Search Box, type in 'Privacy Level'. Click on the Security Object Privacy Level in the

Object list.
Privacy Level
AOE.DM1 > AOQE_DD = Data Security Classification
ER Object > Security

This privacy level property specified the level of privacy for a given piece of information in...

3 On the Privacy Level Security Object page, click on Bl Alerts  from the left menu.

4 To create a new Alert, click the button.

5 Fill out the New Condition Alert settings, Value, Regulated Customer Info, Warning and
any additional text you require.

New Condition Alert ®

Show Alert for Matching
) Bound Object

@ value

Matching Value

Regulated Customer Inﬁ::E
Alert Level

@ wWarning

@ Info
MNotification Text

Regulated Customer Information!
Mot to be replicated without proper

approval.
Coove [ concal

6  Save the new Alert.

TEAM SERVER EVALUATION GUIDE 13



SETTING UP FOR FURTHER EVALUATION

ER OBJECTS - VIEWING ALERTS

Searching for ER Objects is made simple in Team Server.

1 From the top navigation menu, click IRESLITEECRE.

2 Inthe search box, type ‘credit card’. You will see from the search result that the column
CrdNmb is listed.

LV/ The name of the column does not correspond with your search, but because Team Server is
searching all fields, it makes it easy to find Objects that are abbreviated or shortened.

3 Open the ER Object CrdNmb and you can see the security alert that you set up earlier!

CrdNmb

Column
AOQE .DM1 > AQE PDM > CrtCrd = CrdMmb
Mot linked to any term [Create Linked Term]

Regulated Customer Information! Mot to be replicated without proper approval.

4 If you have a DB Artisan Team Server license, the alert that you see here is also available
when viewing the column in DB Artisan.

RELATING TERMS

It is very easy to relate Objects to Glossary Terms.

—_

On the top navigation menu, Click on Terms.
Customer Lifetime Value

2 Type'CLV"in search box. Buciness Terme
[Delete]

3 Click on Customer Lifetime Value term.

4 Click Related ER Objects view | round 1

5 Click on Relate tab U

6

In the search box, type the following:
‘datefirstpurchase’ and relate it to the Customer Lifetime Value term using the

button,

TERMS - ADVANCED USE
You have already imported terms, and seen how relating different terms can be useful.

14 TEAM SERVER EVALUATION GUIDE



DB TEAM SERVER AND DB POWER STUDIO PRODUCT INTEGRATION

Lets have a look at a more advanced term.

NOTE: The related objects used here were set up in a previous section, see Relating Terms.

1 On the top navigation menu, Click .

2 Type '‘Customer Lifetime Value' in to the search box.

TIP:  You can also type ‘CLV' as the search will find the term through it's abbreviation.

3 Click the Term Customer Lifetime Value to open the Term.

Streem S Customer Lifetime Value
Description — B_usmEs-s Terms

Discussions

Followers Created by admin on Apr 25 jilim

Name

|l Related Glossaries .
Customer Lifetime Value

E = Term Entity Type

Related ER Objects Business Terms

i n i—1

tor
CLV = GC- z:; (R =

=1

In this example, you may have been asked to organize the data required for the CLV
“N equation. Normally this information would be in disparate locations and finding and
confirming that data may be a difficult process.

With the Terms you have set up in previous sections, you can simply click ‘Related ER
Objects’ and collect all of the data required for the equation. While having 'Stewards' listed
for your Terms, you can easily find the organization’s expert for that particular data.

DB TEAM SERVER AND DB POWER STUDIO PRODUCT
INTEGRATION

DB Team Server can be integrated with the following DB Power Studio products:

e DBArtisan - aimed primarily at DBAs, DBArtisan provides a comprehensive DBMS toolbox.
General feature categories include object management, a SQL editing, execution, and
debugging environment, and a variety of monitoring and analysis tools.

® Rapid SQL - aimed at developers, Rapid SQL also features object management and a SQL
editing, execution, and debugging environment. A collection of coding aids is also
provided.

The following section is a read through only. To demo these features you will need a working
data source and a DB Artisan installation. If you need an introduction to the features and
benefits of these products, see http://www.embarcadero.com/products for details.

TEAM SERVER EVALUATION GUIDE 15
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DB TEAM SERVER AND DB POWER STUDIO PRODUCT INTEGRATION

[Q“ ENABLING AND CONFIGURING DB TEAM SERVER USAGE

If you are familiar with either product, then you know that the Options Editor (File > Options) is
where you set up DBArtisan/Rapid SQL features. A Team Server panel lets you enable DB Team
Server usage and provide the URL required to connect. Once configured, a Tools > Login
command lets you sign in to your DB Team Server instance.

S - E 3 - 3
1 Options | 2 |
Type filter text | [ Team Server l
- Datasource
G- General Use Team Server

- Connection

R Team Server URL: | hitp://ROMLABERCOND1:81

- LDAP Confi ti
i “Mote: to be able to madify the Team Server URL, please make sure you are not logged in

- Logging and no restrictions are imposed by the Administrataor.

- Mail - %

. Perf Center Embarcaderc Team Server - Log In | 2 |

.. Tearmn Server
Team Server URL: http:/fROMLABERCOMNO1:31

\ User: MyAccount E—

Password: Ty
[ ] Keep me signed in

v
m USING THE TEAM SERVER NAVIGATOR

Once logged in, you have access to datasource definitions, ER/Studio data model details, and
activity streams available. A View > Team Server > Navigator command lets you toggle display
of the Team Server Navigator. Similar to the Datasource Navigator provided in DBArtisan and
Rapid SQL, the Team Server Navigator provides a browsing tool and lets you initiate Team
Server features.

16 TEAM SERVER EVALUATION GUIDE



DB TEAM SERVER AND DB POWER STUDIO PRODUCT INTEGRATION

Team Server Mavigator X -
@ P 'z‘ 3 Datasource Mavigator B =
2 (@) ¢
[ DB2 (0 £ D82S
5 IDEC (0} EMVErS

[ Interbaze-Firebird Servers
[ JDBC Servers
[ MS SOL Servers

Ml SOL (4
) ROMLAENMYSOLSL 1 (0)
Sl ROMLAENYSQLS1 1.2 (0)

%I TORLABIMTEREOL (0) ?1!] ROMLABARTSQLO0_Connl (S5QL Server 0.0.0.0)
il TORLABINTERENL 2 (0) i ROMLABSQLOO 1 (5QL Server 08.00.2039)
51 ODEC (0 i ROMLABSQLOE 2 (SQL Server 10.00.1600)
) Oracle (5) ?1!] romlabsgld8_3 (5QL Server 0.0.0.0)
C3 0s390 (0 ?1!] ROMLABSQL12 1 (SQL Server 11.00.2100)
3 SOL Azure () i| ROMLABSQL12 2 Conn (S5QL Server 11.00.2100)
31 SOL Server (13) i SAMPLE_DATASOURCE (SQL Server 09.00.3073)
Sybase () _l—ql!] TORLABWIN2KS_1 (S5QL Server 10.0.1600.0)

?1!] WANTTOCOMECT (SQL Server)
i MySQL Servers
i My_Custom_Group
[ ODBC Servers
[ Oracle Servers
[ Servers
[T Sybase Servers
[ Teradata Servers

o Sybase I (4)

v
M REGISTERING A DB TEAM SERVER DATASOURCE LOCALLY

Without DB Team Server, DBArtisan and Rapid SQL use locally-specified, static datasource
definitions. Significantly, a locally-registered datasource can be synchronized with a Team Server

definition.
Team Server Mavigator 1 x
o Datasource Mavigator X
P& ¥
; S0L Server (12) 4 Sybase Servers
4 3 Sybase (5) > nj'!] SROMLABSY157 1 Conn_02 (Sybase A
__% ROMLABSY1254 2 > % ROMLABARTSY1254 (Sybase)
__E_ ROMLABSY1254 3 4 F nj'!| ROMLABSY1254 3 (Sybase)

For organizations with multiple copies of Rapid SQL or DBArtisan, when a datasource definition
must be changed due to an operational change, the change can be made in one location and
automatically propagated to all Rapid SQL/DBArtisan instances. When registering a datasource
to DBArtisan or Rapid SQL, a single control attaches the locally registered datasource to the
Team Server version.
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DB TEAM SERVER AND DB POWER STUDIO PRODUCT INTEGRATION

Datab T
SEA0ASE WRE Available database types:

Connection Information

Security Parameters g!-”BM din
m| Microsoft SQL Server
Custom Driver Properties %WSQL
Datasource Properties j'ﬂ@lacle
Datasource Group El Sybase Adaptive Server
i Sybass 12

i Windows Azure SGL Database
&-‘ﬁemdata (Technical Preview)

£l Generic ODBC
£l Generic JDBC
Related Team Server Data Source: @ Relate
@@ROMLABSQL1Z_2 Conn
ROMLABARTSQL1Z

ROMLABSQLOE_3
ROMLABSQL12_1

Once initially registered, an attached, local datasource definition is resynchronized with the
Team Server version each time you connect to that datasource.

OTHER DATASOURCE MANAGEMENT FEATURES

A Rapid SQL or DBArtisan user has access to a feature (Datasource > Reconcile Data Sources)
that lets you manage multiple Team Server and local datasource definitions simultaneously.
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Reconcile Team Server Data Sources (Admin) l ‘ @

Matching data sources (Select Team Server and local data sources to link)

[ Team Server Name Local Name Type Server/Instance Mam =
] ROMLABSYBIQ152_1 ROMLABSYBIQ152_1  SybaseIQ ROMLABSYBIQ152_1

[] ROMLABSGQLOS_3 romlabsgl05_3 MS S0L romlabsqgld3_3 E
(] @@ROMLABSQL12 2 C... ROMLABSQL1Z 2 Conn MSSQL ROMLABSQL1Z 2

|:| ROMLABSOL02 jdbc ROMLABSOLOZ Sybase I  ROMLABSOLOZ

[ ROMI ARSOI 12 4 ROM ARSON 12 1 MS S0 ROMI ARSOI 12 1 i

Unmatched Team Server data sources (Select Team Server data sources to import and link)

[ Team Server Name Type 2
[ ROMLABARTSY 157 _jdbc Sybase ‘E‘ i
|:| SROMLABSY 157 _1 Conn_02 Sybase i
[ sybase IQ Demo QDEBC I
il [ NRCTEST NRC ‘"
| lUnmatched local data sources (Select local data sources to export to Team Server and link)
[ Data Source Name Type it
[] saMDB10 DB2 L4
[7] saMPLE DB2
[ radad NRC s
Reconcile Cancel
L o~

A full set of options is provided for managing the relationship between Team Server datasource
definitions and those registered locally.

ADVANCED DATASOURCE SEARCH

In addition to simple browsing of datasources available on a DB Team Server instance, a
Datasource > Team Server Data Source Search command issued from DBArtisan or Rapid
SQL opens a dialog that lets you perform an advanced search of datasources.
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Team Server Data Source Search | 23 |
Search:
ROM n Search Save | -

[ MName v” Is v] RO -
[ Data source type - ][ g v] E]

MName Type Version &
© ROMLABSOLOZ jdbc Sybase 10 (B
© ROMLABSQLOE 3 MS SQL :
- ROMLABSGL1Z 1 MS SGL -
Close
| — — |

You can search by name or by one or more ANDed criteria. Specific conditions include items
such as database type and version as well as operational characteristics like performance and
storage details. The advanced search mechanism attempts to anticipate the differing needs
across an enterprise. For example:

e |T personnel might be interested in all datasources with free space issues.
e A developer might be looking for all datasources of a specific DBMS type and version.

* A quality assurance engineer might be looking for a specifically-configured datasource in
order to duplicate a customer issue.

P
m USING MODEL DATA IN THE SQL EDITOR

Rapid SQL and DBArtisan both have powerful SQL Editor environments that let you develop,
debug, and execute SQL scripts. Key features include automated coding assistance and error
detection options. When you open a SQL Editor (File > New > ISQL in DBArtisan or File > New
SQL in Rapid SQL) against a datasource attached to a DB Team Server definition, editor features
can make use of associated model data.

For example, if a line of code references an object with associated meta data, a warning icon is
displayed in the gutter, beside the page number. On execution, details from the model data for
that object definition are displayed in the Error pane.
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1 select *

24 from gim.dbo.BROKER t1

3 where t1.BROKER_FIRST_MNAMES is not null
4 and t1.BROKER_LAST MNAME is null'

5
Errar x
Batch | line | Column | Error type | Error Meszsage

2 b Metadata Information BROKER (Broker) Data Steward : Larry

4 28 @ Syntax Encountered unexpected token “nulll”

Similarly, when hovering the mouse over a column name, table name or view name, a tooltip
showing the entity/attribute description is displayed.

select #
from aim.dbo.BROKER t1
where t1. BROKER FIRST MAME is not nul and t1.BROKER LAST MAME is null

Metadata Information: BREOKER (Broker) Data Steward: Larry

LA e L) P

Subsequently clicking in the tooltip opens a browser window on DB TeamServer, with the
associated ER/Studio model data definition for that object.

While those features provide immediate access to model data from DB Team Server, you can
also have entity/attribute information automatically written to a script. The Format feature,
primarily aimed at beautifying code, is initiated using the Format button.

=)

When invoked, a comment with element/attribute details is written to each line referencing an
element with associated model data.

select t1.coll "Agent_First_Name"

, t1.col2 "Agent_Middle_Initial"

, t1.col3 "Agent_Last_MName"

, t1.cold "Agent_Years_With_Firm"

from GIM.dbo.FINTAB_44 /* Entity: Finance_Agent_Table ‘,'“|

LA B L

A developer subsequently opening script, a function or procedure for example, can quickly see
that it references data that may be regulated.
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OTHER DB TEAM SERVER FUNCTIONALITY
Miscellaneous DB Team Server functionality in Rapid SQL and DBArtisan includes:

e Users can monitor their own activity stream or the activity stream for a datasource definition.
Similarly, users can open a window to monitor their notifications.

¢ Rapid SQL and DBArtisan let you open a browser window on the connected DB Team Server
for direct access to Team Server features.

ER/STUDIO TEAM SERVER - MORE FEATURES

. PEOPLE
Collaborating is made easy with Team Server. On the top navigation menu through the People

menu item, you have access to follow, discuss and collaborate with your social connections.

GLOSSARY TOOLTIPS
» ' To enable the Glossary Tool Tip feature:

4

1 Ensure you are running your Team Server window in Mozilla Firefox.

2 On the top navigation menu, Click m

4 Install Greasemonkey add-on using the link provided. + Add to Firefox
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5 You may also receive a warning before installing similar to the following pop up message.
Click “Install Now' to proceed with the add-on installation.

-
Software Installation l E

Install add-ons only from authors whom you trust.

Malicious software can damage your computer or viclate your privacy.

You have asked to install the following item:

- . Greasemonkey (Author not verified)
g https://addons.mozilla.org/firefox/downloads/|atest/748/addon-T48- |atest.xpitsre=d|

1

’ Cancel ]
6 When the install has finished, click Add Glossary Tool Tip .

7 Click OK to install

NOTE: You may be required to restart your browser.

8 Click My Settings > Admin.

9 From the left navigation bar, click Glossary Tool Tip.

10 In the top right of the page, click .

11 Fill out the fields of the New Association pop-up window, clicking Add to save each field
before adding another.

URL Patterns - The URL list of the web sites/pages that you would like to associate with your
Glossary. Type in this field http://en.wikipedia.org/**

Glossaries - A list of one or more Glossaries that you would like to associate with the web sites in
the URL Patterns field. Type ‘Sales’ then click Add

Definitions - You can add a definition of your association between the URL and Glossary.

12 Click Save.

13 \ Go to http://en.wikipedia.org/wiki/Customer to watch the magic!

On the page that opens, you can see how the fields are highlighted, and when you hover your
mouse over the highlighted ‘customer’ words, a definition is given from your Sales glossary.
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Customer

. . A perzon or organization that has expreszed interest
From W”‘ﬁd“ﬁ- the fl in 3 product by contacting our sales department.
View in Team Server

"Clientele" redirects here. For the British rock band, see The Clientele.

Conclusion

Thank you for completing the tutorials. It should have given you a good start to continue
working with your diagrams in a collaborative environment. You should now know how to import
and relate Glossaries and Terms, create Data Sources and Object alerts, and set up Glossary
Tool Tips to enable user collaboration and simplify data compliance in your organization.

ADDITIONAL EVALUATION RESOURCES

Embarcadero Technologies provides a variety of resources to help support your evaluation and
selection of a Data Modeling product for your organization.

Web site

Visit our Web site for current product and company information, educational materials and
supporting information. Visit www.embarcadero.com.

Electronic Documentation

Detailed reference documentation is available on the ER/Studio Evaluation CD or online at http://
docwiki.embarcadero.com/TeamServer/ERStudio/en/

Further manuals are available at http://docs.embarcadero.com.

Online FAQ
The ER/Studio online FAQ provides answers to commonly asked questions regarding licensing,
installation and other helpful topics.
To review the FAQs for ER/Studio visit: www.embarcadero.com/products/er-studio/faq

Support
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ADDITIONAL EVALUATION RESOURCES

You can contact ER/Studio support engineers, consultants and engineers directly by sending
inquiries to:

For North America, Latin America and Asia Pacific:
support@embarcadero.com

For Europe, Africa and the Middle East:

uk.support@embarcadero.com

or log a case through embarcadero.com at: http://support.embarcadero.com/

Telephone Support

We encourage you to call us anytime you would like help or have questions during your evaluation,
we value your feedback.

For North America, Latin America and Asia Pacific:
Phone: 415.834.3131
Hours: Monday to Friday, 6:00am - 6:00pm Pacific time
For Europe, Africa and the Middle East
Phone: +44 (0) 1628 684499
Hours: Monday to Friday, 9:00am to 5:30pm UK time
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