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Introducing ER Studio Data Architect

Introducing ER Studio Data Architect

ER Studio Data Architect is a visual modeling application used for platform-independent logical
data architecture analysis and design, in addition to platform-specific physical database design
and construction. The powerful, multi-level design environment addresses the everyday needs
of database administrators, developers, and data architects who build and maintain large,
complex database applications and strive to consolidate, report, and re-use metadata across
the enterprise.

ER Studio Data Architect's progressive interface and simplicity has been designed to effectively
address the ease-of-use issues which have plagued data modeling and CASE tools for the past
decade and more. The application equips you to create, understand, and manage the life-cycle
of mission-critical database designs and business metadata within the enterprise.

ER Studio Data Architect is rich and customizable, offering:
Strong logical design capabilities
e The ability to spawn many physical designs from a corporate logical design.
e Bi-directional model comparison and information synchronization.
e Visual-Basic for Applications API for product customization.
e Powerful DDL reverse engineering and generation.
e Metadata import and export capabilities.
e Data lineage documentation.

e Sophisticated XML, HTML, and RTF-based documentation and reporting facilities.

About this Document

This document helps you install and use ER/Studio DA and introduces you to the basic
functionality of ER/Studio DA.

For more information and the latest documentation versions, see the Embarcadero website at
www.embarcadero.com.

Notice for Developer Edition Users

The Developer Edition of ER Studio Data Architect provides the user with all the standard
functionality of ER/Studio except for the following limitations:

e No access to the ER/Studio Repository and ER/Studio Team Server.

e Limited import and export functionality; the Import and Export Metadata Model Bridges
are not supported.
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Introducing ER Studio Data Architect

e Limited database support. For a list of supported database platforms, see Supported
Platforms.

Application Interface

The application interface is divided into several tabbed windows that let you navigate and
customize your workspace. The application includes context-sensitive toolbars, menus, intuitive
icons, keyboard commands, and other resources to help you work efficiently. ER Studio Data
Architect user interface has a standard Windows look and feel.

For a detailed description of the internal data structure of the ER Studio Data Architect
application and the Repository, you can look at Metadata models (DM1 files), usually found in
the following directories:

e Windows XP: C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudioDA_X.X\Sample Models

e  Windows 8, Windows 7, and Windows Vista:
C:\ProgramData\Embarcadero\ERStudioDA_X.X\Sample Models

For information on enhanced Ul features, please see the corresponding numbers below:
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Introducing ER Studio Data Architect

Interface Features

ER Studio Data Architect has an enhanced user interface that is similar to Microsoft
Windows with intuitive icons.

1. You can dock toolbars anywhere in the ER Studio Data Architect user interface.

2. The name of the active model, with or without the full path to the file, can be displayed
on the title bar of the main application window. This is an option you can set in Tools >
Options > Application > Application Defaults.

3. ER Studio Data Architect displays the active model in bold type, so that you can easily
see which model or submodel you are working on.

4. The Data Model tab of the Data Model Explorer displays indexes, relationships, and
attributes as separate nodes.

5. The Data Model tab of the Data Model Explorer displays schema objects like packages,
procedures, functions, materialized views, auxiliary tables, and triggers as separate
nodes.

6. The Overview Window lets you navigate large Data Models.

7. The Zoom Window helps you focus on the details of a specific area of a large, reduced
diagram.

The Data Model Explorer is comprised of five tabs that offer easy access to important
functionality and also includes an Explorer tree that lets you efficiently navigate the objects of
your data models. The ER Studio Data Architect interface to the Data Model is divided into two
main areas. On the left is the Data Model Explorer and on the right is the Data Model Window.
This convention is carried out on other tabs of the user interface, such as the Repository and
Data Lineage tabs, where you'll find an explorer on the left and a graphical representation on
the right. The Data Model Window also provides a complete workspace for creating physical
and logical data models and smaller, movable windows to help you navigate large data models.

See Also

e What's New

e Upgrading ER Studio Data Architect

e Supported Platforms

o Release Notes
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What's New

What's New

ER Studio Data Architect 9.7.1
Published April 24th, 2014

Release 9.7.1 features summary:

e Teradata - NUMBER data types

e Teradata - View syntax

e Teradata - Table and Column definitions

e Ul - Expand/Collapse in Get Diagram Ul

e Ul - "Retain View" setting in Get Diagram Ul

e Ul - Automatically Backup Local Files on Get

Teradata - NUMBER data types

The NUMBER datatype is now supported for Teradata 14.

Teradata - View syntax

The Teradata view syntax "count * over" is now supported.

Teradata - Table and Column definitions

Comparing against Teradata now supports table and column definitions.
Ul - Expand/Collapse in Get Diagram Ul

The product includes the option to expand a collapsed node in the Get Repository Diagram
explorer showing all descendant nodes.

Ul - "Retain View" setting in Get Diagram Ul

The state of the explorer tree in the Get Repository Diagram dialog is now retained upon
exiting.

Ul - Automatically Backup Local Files on Get

An option to automatically/always backup local copy of a dm1 file during a get is now available.

Embarcadero Technologies 7



What's New

* ittt s eyl
p I mmomnwhm |RmTume§hn'p |
4\?& Man Modd
b
¢
Product Version
S M Model Displant
Product Version 1D DE Platform
Product ID {FK) (AK11) DB Platfarm D
:’e;sel'unﬂmber Name s
a Descriplion L
Is Default
15 Suppoted Created By
Created By RowTimeStamp
RowTimeStamp
Product Version Platform
= :

See Also

e Release Notes

e Installation Guide

e Supported Platforms
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Installing Embarcadero ER Studio Data Architect

Installing Embarcadero ER Studio Data
Architect

This section will help you ensure your environment meets the technical requirements and helps
you install ER Studio Data Architect or ER Studio Data Architect XE.

You can download a 14-day trial version of ER Studio Data Architect, from

http://www.embarcadero.com/downloads. Embarcadero will send you a license registration
code by email.

System Requirements

Review the requirements before you install ER Studio Data Architect. Adhering to these
requirements optimizes ER Studio Data Architect performance.

ER Studio Data Architect Requirements

Hardware

Processor

Pentium Ill, 600 MHz or higher

RAM

1GB

340 MB

Disk Space

175 MB in the System TEMP
directory for temporary file
storage during installation.

DVD Reader

Operating
System

Any of the following:

* Windows 8

¢ Windows 7 (32-bit and 64-bit modes)
¢ Windows Server 2008

* Windows Vista

* Windows XP Professional

¢ Windows 2003 (32-bit mode)

¢ Windows 2000 Pro Server

e Advanced Server with Service Pack 2

Software

To use an Open Data Base Connectivity (ODBC) database
as a data source, install the ODBC driver on your client
computer.

To connect to the DBMS using native connectivity, install
the native client libraries available from the DBMS vendor.

Privileges

Local administrator privileges (required for installation
only).
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DBMS privileges to create objects on the server: EXECUTE
permission as the user needs to execute stored
procedures for example Create_Temp_Tables.

Installing ER Studio Data Architect

@Note: To ensure compatibility, the release dates of ER/Studio Repository and ER Studio
Data Architect must be the same.

Log on to Windows with local administrator privileges.

1. Start the ER Studio Data Architect installation program.

@Note: To do a silent install, you can run the installation program from the command
prompt with the -s parameter.

2. Walk through the installation wizard following the onscreen prompts.
The following provides additional information for some options that are not self-explanatory:

e Default Notation: Choose the notation type you want ER Studio Data Architect to use by
default to display the model.

e IDEF1X: Data modeling technique used by many branches of the United States Federal
Government.

e |E (Martin/Finkelstein): Information Engineering (IE) as developed by Martin and later
revised by Finkelstein.

e |E (Crow's Feet): Uses IE notation and represents relationships with connecting lines
between entities, and symbols at the ends of those lines to represent the cardinality of
the relationship. This is the notation used in Oracle texts and in other applications such
as Visio. Foreign keys are displayed in entity boxes.

e |E (Hide Foreign Keys): Uses standard |E notation, but foreign keys are not displayed in
entity boxes.

@Note: You can change the notation setting at a later time. To change the notation, choose
Tools > Options from the ER Studio Data Architect Main menu, and then click the Logical or
Physical tab where you can choose the notation type.

e Shared Application Data Location: By default, ER Studio Data Architect installs shared
directories and application files such as the DatatypeMapping, Macros, and Sample
Models directories in the following locations:

e Windows XP:C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudio_X.X

e  Windows 8, Windows 7, and Windows
Vista:C:\ProgramData\Embarcadero\ERStudio_X.X
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If you prefer to store these files in another directory after installation, follow the procedure in
Changing the Location of Shared Files.

e For step-by-step instructions on how to use ER Studio Data Architect, see the Tutorials
section.

Installing ER Studio Data Architect via Command Line

ER Studio Data Architect can also be installed from the command line as follows:
erda_<ver>.exe Optional parameters:

e /s (specifies to install silently without prompts, using default installation settings.
e TARGETDIR=<install dir> (specify an alternate installation directory)
e DESKTOPICON=TRUE (enable the desktop icon option)

For information on installing ER/Studio with Embarcadero AppWave, please see the AppWave
Admin Quick Start and the AppWave Administrator Guide at http://docwiki.embarcadero.com

See Also

e What's New

e Upgrading ER Studio Data Architect

e Uninstalling ER Studio Data Architect

e Licensing ER Studio Data Architect

e Release Notes
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Upgrading From Previous Versions

Upgrading From Previous Versions

Upgrading from Embarcadero Connect to ER/Studio Team Server

For detailed instructions on upgrading to ER/Studio TS, see the Wiki-based ER/Studio TS
Documentation.

@Note: Files saved in later versions of ER Studio Data Architect may not work with ER/Studio
Team Server if they use new features. For example, if you use SQL Server 2014 for your Physical
Model in ER Studio Data Architect 9.7, you will need to update to the corresponding version of
ER/Studio Team Server for those files to synchronize.

Upgrades for ER/Studio Repository 6.6 users
Keep the following in mind when updating for this release:

e Only a service upgrade is required

e No diagram data version upgrade is required.

e There are no database changes from version 6.5
Upgrades for version of ER/Studio Repository prior to 6

Use the following checklist to ensure ER/Studio Repository is correctly upgraded.

Upgrade Checklist

e Download ER/Studio Enterprise Upgrade. To download the most current release, go to
embarcadero.com.

e Review the ER/Studio ReadMe. For the most current installation and usage information,
see the ReadMe at embarcadero.com.

e Prepare to upgrade. For what to do before you upgrade to the latest version, see
Preparing to Upgrade the Repository.

e Upgrade ER/Studio Repository. For ER/Studio Enterprise installations, which include the
Repository. For ER/Studio Repository upgrade details, see Upgrading the Repository.

e See notes regarding upgrading ER/Studio Team Server to match the features available
in your version of ER Studio Data Architect.

Important Notes

e The Repository upgrade must be done incrementally from one major version to the next
until the target version is reached. You cannot skip major versions during the Repository
upgrade as the installer for each major version only contains the database changes
between the new version and the previous one. When upgrading from earlier versions,
such as from 5.5 to Repository 6.5, you must first upgrade the Repository to version 6.0,
update the database, uninstall version 6.0, then upgrade to 6.5, and update the
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database. Once the Repository upgrade is complete and you have installed the latest
version of ER Studio Data Architect, then you should upgrade your diagrams with the
latest version of ER Studio Data Architect.

If you are upgrading to ER/Studio Repository, upgrade your version of ER Studio Data
Architect also. Ensure the build date of ER/Studio Repository coincides with the build
date of ER Studio Data Architect.

If you are also using ER/Studio Portal (Connect), you must also upgrade it to the latest
version.

You can install ER Studio Data Architect 9.x and an earlier ER Studio Data Architect
version on the same workstation.

Any *.dm1 files you use from the previous version will be copied and converted to 8.x
format when you open them for the first time. You can then save the diagram with a
different name or use the same name to write over the old file. Previous versions of ER
Studio Data Architect will not read 8.x and higher files.

Upgrading diagrams can be time consuming and memory intensive. The number and
size of ER Studio Data Architect diagrams managed in the upgraded Repository dictates
how long the upgrade process takes.

Reference Models, supported in previous versions, are not supported in ER Studio Data
Architect 7.x and later versions.

Preparing to Upgrade the Repository

AWARNING: Ensure you have backed up all your.dm1 files.

1.

©® N o A~ w DN

Check in all your diagrams and objects. If you try to check in a file from the previous
version with the same name as a current file, the current file will become corrupted.

Rename all local copies of Repository diagrams in the active file directory as follows:
Choose Repository > Options.

Make note of the Active File Directory.

Switch to the Windows Explorer and rename all the diagrams in the Active File Directory.
Ensure no one is logged into the Repository.

Backup the current Repository database.

Restart the Repository host computer.
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Upgrading the Repository

@Note: This procedure is for ER/Studio Enterprise installations only, which include the
Repository. When you upgrade ER Studio Data Architect, you must also upgrade ER/Studio
Repository to correspond with the same build date as ER Studio Data Architect.

Log on to Windows with local administrator privileges.

1. Start the Repository installation program and select Repair Repository Services. The
installation program starts the following services:

2. Embarcadero Repository Communication Server
3. Embarcadero Repository Database Server
4. Embarcadero Repository Event and Dispatch Server

The Repository services and your existing database will be upgraded to the current version.

@Note: If you are upgrading from a Repository version prior to 4.0, you can delete the
CA\Program Files\Embarcadero\Repository\Data directory. This directory is not used with
Repository versions 4.0 and later.

See Also

e Release Notes

e Installing Embarcadero ER Studio Data Architect

e Licensing

Embarcadero Technologies 14


http://docwiki.embarcadero.com/ERStudioDA/en/Release_Notes
http://docwiki.embarcadero.com/ERStudioDA/en/Licensing

Tutorials

Tutorials

The tutorials are intended to help you get started using Embarcadero’s data modeling and
database design solution, ER Studio Data Architect.

After completing these tutorials, you'll have the foundation you need to explore the many
features and benefits of ER Studio Data Architect. You will have learned how to do the
following:

e Create a new data model.

e Work with logical and physical diagrams.

e Leverage productivity-focused features such as powerful reporting engines.
e Use common tasks and commands to make you more productive.

The tutorials are divided into three sessions. Do them all at once or complete them individually
as your time permits.

You can use this basic tutorial as a road map of product highlights, but also to help you find
your own path in exploring ER Studio Data Architect.

Once you have started, you can click Help from the Main menu to find many additional
resources that complement and build on many of the activities shown in this brief guide. Or visit
the Contents section of http://docwiki.embarcadero.com

See Also

e What's New

e Upgrading ER Studio Data Architect

e Licensing ER Studio Data Architect

e Release Notes
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Tutorials: Getting Started

Tutorials: Getting Started

Interface Features

ER Studio Data Architect has an enhanced user interface that is similar to Microsoft
Windows with intuitive icons.

The graphic below names and describes the functionality of some key elements of the ER
Studio Data Architect user interface.

For information on enhanced Ul features, please see the corresponding numbers below:
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1. Sophisticated diagram auto-layout tools provide single-click clean up of diagram
objects.

2. Data Model Explorer displays information about logical and physical models, submodels

and nested submodels.

Repository object status icons display real-time user access information.
Complex schema objects like functions can be displayed to illustrate dependencies.
Toolbars are dockable anywhere in the ER Studio DA application window.

The Overview Window lets you navigate large Data Models.

N o kW

diagram.

The Zoom Window helps you focus on the details of a specific area of a large, reduced
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Starting to Data Model with ER Studio Data Architect
On the Windows Start > Programs menu, choose Embarcadero > ERStudio Data Architect.
1. Choose File > New > Draw a new data model.

As you can see in the Create a New Model dialog, there are a number of ways to begin
modeling with ER Studio Data Architect:

e Build a new design from the ground up by drawing a new data model.
Build a data model from an existing database through live reverse engineering.

Import designs from other modeling products such as Computer Associate’s ERwin or
SQL files.

N Tip: You can select an initial layout style for your model before the SQL import takes place.

e Ensure Relational is selected for the new model type and then click OK.

After selecting Draw a new data model and clicking OK, ER Studio Data Architect will
resemble the image below:

# ER/Studio Data Architect - [Repo Server: MBWHCHOWO4] - [Modeld - Logical Model View] [= [[B]8X]
iﬁfile Edit View Insert Model Format Layout Tools Repository Macro Shortcuts Window  Help
- X

PmEs &% Q) 0 E NG R ¥ 0% nl @00 38

Z PO & o TE N s ] I
0508

@@ a@@ = =mT ]
X B B R NECAE R TR

l;m DATA MODEL
Logical
Main Model

%]
~
-

@Data_|ﬂ Data | HPData ...|$=Macm | < T = | >

Entitiez =0 Attributes = 0 Fielationships =0

For Help, prezz F1 Logical Model Yiewsz =0

See Also

e Application Interface

e Upgrading ER Studio Data Architect

e Uninstalling ER Studio Data Architect

e Licensing ER Studio Data Architect
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Tutorials: Logical and Physical Modeling

ER Studio Data Architect supports both logical (non-DBMS or technology-specific) modeling
and physical (DBMS-specific) modeling. ER Studio Data Architect is designed to allow
organizations the flexibility to analyze and design a business problem or application logically
and generate as many different physical interpretations from the logical model as required.
Multiple physical models can be generated from the logical model for the same DBMS (for
example, Oracle) or other DBMSs (such as Oracle, SQL Server and DB2). Generating logical and
physical models will be discussed in detail in the following sessions.

Using Data Dictionary Domains to Populate New Entity

Establishing Relationships Between Entities

Creating and Working with Submodels

Generating Physical Models from a Logical Model

Denormalizing the Physical Model

Finding out How an Entity Maps to the Physical Model

See Also

Logical Design Concepts

Data Modeling Concepts
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Tutorials: Using Data Dictionary Domains
to Populate New Entity

As instructed in Getting Started, you have chosen to draw a new data model to begin a logical
model from the ground up. Before we begin to add entities, we will populate ER Studio Data
Architect with some sample domains (Domains are re-usable attributes).

1.
2.

Choose File > Import Data Dictionary.

Next to the File Location box, click the ellipsis and browse to the Sample Models
folder, which is located at:

o For Windows XP:
C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudioDA_X.X\Sample Models

o For Windows 8, Windows 7, and Windows Vista:
C:\ProgramData\Embarcadero\ERStudioDA_X.X\Sample Models

Double-click the Orders.dm1 sample model and then click OK.
This model contains a pre-populated, sample data dictionary.

@Note: Under Resolve Imported Objects with Duplicate Names, you can choose
between a couple of options to determine how the dictionary objects are imported. This
is important when importing into a diagram that already has dictionary objects in it.
Once opened, you will see that the ER Studio Data Architect Model Explorer has
automatically switched to the Data Dictionary tab to allow immediate drag and drop
access to domains.

...... e
Attachrment:
Attribute |
I: Souce
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Entity Pra
I:% Applic
% Type
General F
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Now, to add an entity to the Data Model Window, click the Entity tool on the Modeling
Toolbar,

and then click in the Data Model Window to drop the entity.
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~ Tip: The cursor will change to an entity symbol once the Entity tool is clicked, so
you can click to drop as many entities on the Data Model Window as you want.

5. Right-click to return your mouse to the selection cursor.

6. Right-click the entity and open the Entity Editor. In the entity name field, type Customer,
replacing the default entity name, Entity1 and then click OK..

7. In the Domains folder of the Data Dictionary tab, locate the ID domain in the Numeric
Domains folder.

e
1 o Coda Basrsion

-
L|f B T p Customer
an.

Il cosated By
I} Pocsiy Cate T CustomernD
HS Booean lonsre
- e
-Ji| s Detnea

[l ba Mo oy

[l 15 Srntere Raguned
Hhamaric. [ionyine

1l At

- 1| Emenmzn

L —

|l o ==l
= W

8. Click the ID domain (do not release your mouse), drag it onto the Customer entity, and
then release it just below the entity’s name, which is the entity’s Primary Key field.

™ Tip: You can edit or rename an entity and insert, edit or rename attributes by
holding down the Shift key and then clicking the name or attribute. Pressing the Tab key
cycles between the entity’s name, and primary key and non-primary key fields. After
naming the field, press Return to insert a new field.

N\ Tip: If you need to zoom in on the entity to read the entity name and attributes,
press F8 to view the Zoom Window, then use the scroll bars of the Zoom Window to
center the entity on the Data Model Window. Press Shift while rolling the mouse wheel
forward to increase the view magnification. You can use the Pan tool to reposition the
view to better see the entity.

9. In the entity, click ID, the name of the attribute we just created from the ID domain, and
change its Attribute Name and Default Column Name properties to CustomerlD, as
seen in the illustration above. Then click OK.

10. Repeat the process in step 7 and step 8 to populate the Customer entity with the
following domains:

o Name and Phone from the Property Domains folder
o Address, City, State, Zip Code from the Address Domains folder.
11. Drop another entity on the Data Model Window and call it Order.

12. Drag the ID domain onto the Order entity’s Primary Key field, change the Attribute and
Column name toOrderlD.

13. Right-click the Order entity and select Comments.
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14. Enter some text in the Comments editor, click Add and then click OK. You can add
comments to any database object in the same manner. This can be very useful when you
want to provide feedback on a model to other users.

15. Save your data model. We will use it in the next session of this tutorial.

See Also

e Ensuring Consistent Domain Definitions Using User Datatypes

e Reusing Attribute Definitions Using Domains
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Tutorials: Establishing Relationships
Between Entities

1. On the Modeling toolbar, click the Non-Identifying, Mandatory Relationship tool.
EEhmchflasheeRNTOE] A
B &M =TT i - -

{Mon-Identifying, Mandatory Relationship

@Note: The screen shots of this tutorial were taken using a model where the notation
was set to |IE (Crow’s Feet). Depending upon the notation your model is currently set to,
the icons for each relationship will be slightly different.

~ Tip: You can change the model notation by choosing Model > Model Options,
and then selecting another notation option in the Notation area.

2. To establish a relationship between Customer and Order, click the parent entity,
Customer and then click the child entity, Order.

@Note: ER Studio Data Architect supports sound design practices by automatically
propagating the primary key, from parent to child entities. If there are candidate
alternate keys that should also be propagated to the child, in the Relationship Editor you
can choose all available parent entity keys in the Parent Key list. Deleting a relationship
will remove a non-native propagated attribute. However, if you want to keep the child
columns of the relationship or foreign constraint, when you delete the relationship you
can check the Make Foreign Keys Native option. In this case, if the relationship between
Customer and Order is deleted, the CustomerID will be left in the Order entity.

What is a Domain?

A Domain is a valuable tool in establishing standard, re-usable Attributes/Columns. They allow
data modelers to create a data element once (such as an ID field you require all of your entities
to leverage as its primary key) which has the same data type, definition, rule, and constraint no
matter where the data element is distributed and bound. Read more about Domains in ER
Studio Data Architect User Guide.

See Also

e Reusing Attribute Definitions Using Domains

e Ensuring Consistent Domain Definitions Using User Datatypes
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Tutorials: Creating and Working with
Submodels

Now that you have a general understanding of how to build logical models from the ground up
in ER Studio Data Architect, it is important to understand how to work with an important
navigation feature of ER Studio Data Architect, called Submodels. Submodels and nested
submodels are designed to break down large, complicated views of a data model in order to
focus on a specific area. An important aspect of Submodels to understand is that any changes
made in the submodel, other than layout, color, display settings, notation or similar items which
can be unique to the submodel, will occur automatically in the Main Model view. In other words,
change or add an attribute to an object in a Submodel and the change is automatically
propagated to its Main Model counterpart.

Close the current sample model, and open a more mature model. Use this exercise to learn
more about submodeling.

1. Choose File > Open.
2. Select Orders.dm1 and then click Open.

3. To preserve this sample model for future use, choose File > Save As and then save the
Orders.dm1 file with a new name.
In this exercise, we will be modifying this model.

4. Collapse the folders in the Data Model tab of the Data Model Explorer to look like the
image below:
4 - Orders - Logical Model View [
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In the Orders.DM1 sample model, there are no physical models. This model includes
several submodel folders that help to describe the logical model:

o Main Model - This is the entire collection of all logical objects in the Orders.DM1
file. Note the absence of the magnifying glass on the folder icon which
designates it as the main model.

o Bill of Materials throughShopping Cart — These are submodels, which are smaller
collections of entities derived from the Main Model that help to describe specific
areas of the Main Model free from other entities.

o Alternate Key through Primary Key — These are nested submodels, which can go
n’ levels deep and are literally submodels of submodels.
Feel free to explore. Click the plus sign (+) to expand these folders.
Let's create a submodel with all the objects related to the Orders.DM1 Address
components.

5. To make a new submodel, navigate to Logical Main model and with the CTRL key
depressed, click the objects in the Data Model Explorer, as seen in the image below.

¥ ER/Studio Data Architect - [Repo Server: MBWHCHOWO4] - [Orders.Di1 - Logical

l\ﬂ File Edit Miew Insert Model Format Layout Tools Bepository  Macro Shorbeouts

PR R = e | Q) N NG OO | 3 34 ¢ RRSTR -1
el & R | D o & E B o b e
i H2000@0 = =T GBS &% BT,
q Orders.dm1 - Logical Model View * |

A |__J

| Authorized Product [
| Bill of Materials
| Commizgion Credit

| Customer p=——— 1) st

1 Cusztomer Address | A

- Attributes (7] 1 . Address :

S Customer Ade | Bl
Address Type .

Customer D
Label 'M

f
|z Default :
Created By d :F )
RowTimeStar : = By

EEI-'} Incoming Relatio

]—'ﬁ Outgoing Relatio v o
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[ DB Platform
FHT Discount Level 3 B e
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@Note: Any objects selected in the Data Model Explorer will also be selected on the
Data Model Window as well (also seen here). You can also select entities by lassoing
them on the Data Model Window.

6. With the entities selected, choose Model > Create Submodel.

*% Create Submodel

|.-“-‘-.|:I-:Iress Components | %y Edit Submodel |

|#’ ak. | |x Cancel |

7. Below Create Submodel, enter Address Components as the name for the submodel.
8. Click OK.

ER Studio Data Architect creates the Address Components submodel.

| Orders.dml - Logical Model View: (Address Components) * ]

L
RNl

2 Embarcadero Sales Order Processing S

Bill of Materials o
kL Commizzion Tracking

iy Customer

o Customer Address

HES Main Model Displaps

What do the results look like and how do | navigate to the submodel?

Once created, you will see the new submodel listed in the Data Model Explorer, denoted as a
submodel by the magnifying glass over its folder, as in the case with Bill of Materials and the
other submodels.

See Also

e Retrieving a Repository Diagram, Model, Submodel or Named Release

e Creating and Editing Submodels
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Tutorials: Generating Physical Models from
a Logical Model

ER Studio Data Architect can generate as many physical models from a single logical model as
desired. There are many ways to leverage multiple physical models in ER Studio Data Architect
to help the design process. Examples of how multiple physical models are used are:

e Managing change in an existing application: Maintain independent development, test,
and production physical model diagrams that represent specific databases.

e Migrating database applications: Use ER Studio Data Architect as an analysis and design
hub for migrating database applications. Manage a physical model of the legacy source
database application in addition to its new target physical model, which can be for an
entirely new DBMS than originally maintained in the legacy database.

Let's generate a new physical model from a logical model in order to build a database. We will
use the Orders.DM1 sample model.

1. Open your version of the Orders.DM1 sample model.

N\ Tip: Use the steps shown in the last session to do so.

2. Select the Main Model and then click Model > Generate Physical Model.
ER Studio Data Architect invokes a step-by-step wizard to walk you through the process
of generating a DBMS-specific physical model.

E= Generate Physical Model - Page 1 of & |;|@@

Welcome to the Generate Physical Model Wizard!
\_1 ;
yumme =
#

What is the name of the phyzical model?
|DB2 Physical Modsl

} w'hat tppe of Physical Model is thiz?
* Relational

" Dimenzional

} WWhat is the target database platform?

} Do you wish to validate the model?
&+ Do rnaot validate

" Walidate after generating Physical Model

} Wizard Quick Launch
Select Settings File
[~ Use File-Based Quick Launch Settings

|Nnne j | |

" Settings Only {+ Settings and Objects

(X Carcel] [ oo |
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3. Name the new physical model, DB2 Physical Model and then select DB2 UDB for

0OS/390 8.x as the target DBMS to generate.

4. Continue through the Generate Physical Model wizard, which prompts several
questions about how you want your physical model to be generated.

@Note: The wizard prompts you to customize items such as individual object
selection, index assignment, default storage parameters, resolution of many-to-many
relationships that may be in the logical model, and naming conventions. In Step 3 of the
wizard, you can add prefixes or suffixes to the object name. For example, it can be
useful to add an indicator of the object type in the name. A DBMS-specific validation
check is also provided in this wizard.

N Tip: The Quick Launch can store common settings so that an operation can be
reused on this model or on any other models. You can reuse the settings on another
model by choosing the Use File-Based Quick Launch Setting option when saving the
Quick Launch information on the last page of the wizard.

5. To generate the new Physical Model, on the last page of the wizard, click Finish.

Now that a physical model has been generated from the logical model, feel free to navigate to
specific objects via the Data Model Explorer, such as the CUSTMR table selected here. Double-
click and view the physical details of the object such as DDL, Indexes, Partitions, and Storage.
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See Also

e Developing the Physical Model
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e Transforming Model Obijects from Logical to Physical
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Tutorials: Denormalizing the Physical
Model

ER Studio Data Architect comes equipped with denormalization wizards to help you optimize
the physical design once the physical model is generated. The wizards help automate the
process and keep the ties between the physical tables and the logical entities.

The active, denormalization wizards available depend on which tables are selected in the
physical model when you select Denormalization Mapping. For example, if two tables that are
related to each other are selected, the valid operations would be Rollups or Rolldowns.

Delete Table
Entity Color and Font Settings r
Align Entities »

w

|@ Rollups...

L @ Rolldowns...

Resize ' Harizontal Splits. ..

Create Submodel ...

Denormalization Mapping

Edit - Frad Mar i
Cait LIs d Mapp

m
]

L

m

En

Create Procedure » =
Create Trigger L4

Create Yiew

Apply To Submadel(s)...

Macros F

g Add/Remove Macro Shortouts

Compare and Merge Utility. ..
% Submodel Synch Utility. ..

When only one table is selected, the option to split the tables becomes available. The Table
Merge option is available when two unrelated tables are selected.

Let's walk through an example of a denormalization operation using the generated physical
model in a previous session of this tutorial. We may want to reduce the overhead on the Custmr
table by splitting it into two physical tables, Custmr_East and Custmr_West. Splitting the table
can reduce the query time and provide opportunities to store the tables at different locations
which could further reduce lookup time.

Before the operation, the Custmr table should look like:
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Custmr

Custr_ID [PK

1. Open the Orders1.dm1 model you modified and saved in the last session.
2. In the Data Model Explorer, right-click the Custmr table in the Physical Model.

3. Choose Denormalization Mapping > Horizontal Splits.
Notice that since only Custmr is selected, the only possible mappings are vertical and
horizontal splits.
The Horizontal Table Split Wizard launches.

4. On Page 1, type 2 for the number of splits.

5. On Page 2, rename Custmr1 and 2__‘;0 Custmr_East and Custmr_West respectively.

& | Horizontal Table Split Wizard - Page 2 of 4. Lo | B |
Please review the naming conventions for each of the replicated table. Mote
} that in order for two or more tables to retain the same name on the physical
madel, a unigue database ownerfqualifier must be provided.
E Check the "Submodel' check box to incude the new splits in the submodels
of the original table.
il = : i ; ! : Replicated Table| Submodel| Table Name  |Entity Name | Dwner
H : Pre mapped Table  |Custmr _ |Customer )
H 1 Customer
i 2 Custome:
Ll
[l
ol
i
[ X Cancel ] ’ “‘? Help J [ -@ Back ] | Mext @ | \v Einish

6. On Page 3, click Next.
We will keep all the relationships.

7. On Page 4, type a name and definition for the denormalization operation, and then click
Finish.

Finished! After the split the Custmr table will be two physical tables that look like this:
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Custmr_Ezst
Custmr_ID [P}
Frsy_Nme
LE_hme
Cmgny_Mme
Emil_addr
o 1D Custmr_Viast
- — f—mﬂ’;—_\=—”“"'“r Cusamr_ID [PK)
I RWTmEmD Frahme
| Lzt Nme
| J_ J_ Cmpy_Nme
0 T Emi_Addr
| | | Cerf_ID
- I '5_Exsing_Cusamr
I i ond By
RWTMSEmp

IT

The two tables are identical except for the name.

You can selectively choose which attributes are included in the resultant tables by using a

vertical split.

The denormalization mapping is stored with each of the tables.

e e e ey
' Table Editor

Use "Switch To" an an entity or table listed to edit that object, or dick Edit to edit the mapping definition and attachment bindings.
[~ show only submodels that use this object

I Entity Hame: ICusmmer Table Mame: ICustﬂr_West Owner: I v!

| T Physical Only [~ Do Mot Generate

Ll

i PresQL & PostSQL I MNaming Standards I Compare Options I Data Lineage I Security Information I Attachment Bindings
Storage I Partitions. I Constraints Dependencies I Capacity Planning | Permissions
Columns I DDL I Indexes I Fareign Keys I Definition MNaote Where Used

@ Where Used

! B3 Submodel Usage
El#, DB2 Physical Model (IBM DB2)
EI@ Denormalization Mappinags
EI-% Haorizontal Table Split: Custmr_Horizontal_Split_Mapping_1
M3 Pre-map State
Table Name: Custmr
&R Post-map State

Table Name: Custmr_\West

El Logical
i [ Entity Name: Customer 0

Table Name: Custmr_East |

%%

% [ %

— — e e [2 e ] g
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You can use the denormalization information to undo the operation or see the history of what
happened. ER Studio Data Architect tracks the before and after states of these operations. This
comes in handy in the next section where we discuss the Where Used analysis that can be
performed between the logical and physical models.

See Also

e Optimizing Query Performance on the Physical Model (Denormalizing the Physical

Model)

e Upgrading Diagrams with Denormalization Mappings
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Tutorials: Finding out How an Entity Maps
to the Physical Model

Now that we have performed a denormalization operation, the logical entity, Customer,
essentially has become two physical tables, Custmr_East and Custmr_West. The ties between
the logical and physical models are not lost. ER Studio Data Architect allows you to see what
Customer in the logical model maps to in the DB2 physical model.

Let's take a look at the Customer entity in the logical model.
1. In the Data Model Explorer, navigate back to the Customer entity in the Logical model.
2. To start the Entity Editor, double-click the Customer entity.
3. Click the Where Used tab.

(B ntity editor =)

Entity Hame: |Cust0mer Table Mame: |Cus1mr Owner: -
[ Logical Only
Attributes ] Keys l Relationships l Definition ] Note

Compare Options l Data Lineage ] Security Information l Attachment Bindings
i ; Constraints l Dependencies ] Permissions ] Maming Standards
IJse "Switch To"™ on an entity or table listed to edit that object, or dick Edit to edit the mapping definition and attachment bindings.
I Show only submodels that use this object

:’;' Where Used &
EZE| Logical &
! B3 submodel Usage
El DB2 Physical Model (TBM DEZ) &
-__" Table Name: Custmr_East 0
-|___'| Table Mame: Custmr_West 0
B4 Denormalization Mappings =
-%- Harizontal Table Split: Custmr_Horizontal_Split_Mapping_1 &

N’ oK \ IXCanceI‘ [‘? Help ]

b

Once the tree is expanded, you can see the lineage of what has happened to the object. Notice
that Custmr_East and Custmr_West are listed as physical implementations of the Customer
entity. The denormalization mapping object shows how the end result was achieved.

The Where Used tab also displays the submodel usage of a particular entity within the logical
or physical model. This allows you to see which business areas the entity belongs to.

@Note:Where Used information is also available for attributes and columns.
Conclusion

In this session, you have seen how incredibly quick and easy it is to:
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e Build a logical data model from scratch.

e Create a new submodel view to understand how to model on specific parts of a larger
Main Model.

e Generate a physical model from a logical database in preparation for building a new
database.

e Denormalize objects in the physical model.

e View the mappings between the logical and physical models using the Where Used tab.

See Also

e Developing the Logical Model

e Developing the Physical Model

e Synchronizing Physical and Logical Models

e Generating a Script File or Database
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Tutorials: Documenting an Existing
Database

One of ER Studio Data Architect’s most powerful applications is that of a documentation
generator to communicate complex databases and associated metadata to the Enterprise. ER
Studio Data Architect is equipped with extensive report generation capabilities:

e HTML Report Generation: Instantaneous generation of an HTML-based Web site
designed to provide simple navigability through data models and model metadata
using standard browsers such as Google Chrome or Mozilla Firefox.

e RTF Report Generation: Instantaneous documentation generation compatible with
applications like Microsoft Word.

In the exercise below, we will reverse-engineer an existing database and generate an HTML
report for distribution and navigation to those who depend upon the information about the
data model, but who may not be permitted to connect to the database for security or
organizational reasons.

PRE-REQUISITE:

This exercise assumes that you can connect to an existing database in order to document it. If
you cannot connect to an existing database, you can still generate documentation from the
installed sample models; skip steps 1 through step 8 below which relate to in reverse-
engineering and begin at step 9 after opening a sample model included with ER Studio Data
Architect.

1. Choose File > New.

& ER/Studio Data Architect

Create a New Model

%) " Draw a new data model |

@ (+ Reverse-enginesr an existing databaze

% £ Impaort kodel From: | J

2. Select Reverse-engineer an existing database.

J Login ___
X LCancel
2  Help

3. Click Login.

o You can reverse engineer the database from either an ODBC datasource or via
Native RDBMS client connectivity. In this example, Native Connectivity to
Microsoft SQL Server will be demonstrated.

4. Type the relevant connectivity information such as the data source name, and user name
and password and then click Next.
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F

# " Reverse Engineer Wizard - Page 1 of 5 gl

—Mew Reverse Engineering Operation

Connection {" ODBC: . Sebup. |

{* Native Direct Connection

{” Embarcadero Connect Data Source

Database Type: IMS SGL Server LI
Datasource: | ETSOLO1

User Mame: I 58

Bl I [a——

[ Use Windows Authentication

[ Create Embarcadero Connect Data Source from settings

Mame: I

—Wizard Quick Launch
Select Settings File

5. Walk through the Reverse Engineer Wizard selecting the objects, options, and layout
preferences for the model.

@Note: A new feature using ER/Studio Team Server data sources is available in the
Reverse Engineer Wizard. Please see ER/Studio TS documentation for more details.
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—Include

[¥ User Tables
Datasource Name: | [~ System Tables
[~ UserViews

Datasource Type: |MS SOL Server [ System Views
[~ Triggers

..... |
s Database List master = W
|- Peackages

[T Starage Objects

Owner List dbo ™ Object Types

[~ Synonyms

[~ Materialized Views
[ Users

[ Roles

[~ Schema Objects

Select All

]
Deselact All

’ What database objects do you want lo reverse engineer?

Tables | /1o

Triggers ! Packages I Object Types | Procs/Funcs {|”]#]

Avadable Objecs Selected Obyects
_I—E | Dbject Name f Obiject Marre |
MSieplication_options
o 3pt_falback_db
) spi_falback_dey

[ Include obect permissons

— Capacity Planning
[~ Table Row Count [~ Column Average Width
[T Column Percent Nul
X Concel ;[? Help | @ Bock H-} Mext ] (b Finish v
7

6. Continue through the wizard to select layout styles and other preferences.
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(] Reverse Engineer Wizard - Page 4 of 5

ER/Studio Data Architect can infer Referential Integrity when none is
declared in the database. Clicking the options below will create
relationships between entities in your diagram.

[~ Infer Primary Keys

[ Infer Foreign Keys from Indexes
_|*,:6 [ Infer Foreign Keys from Names
I_ .

s [ Infer Domains (Create a Domain for each Column)
’ ER/Studio Data Architect can ensure all objects referenced by those

you've selected for reverse engineering are also induded.
[¢ Reverse Engineer View Dependencies

[+ Reverse Engineer Other Dependencies (e.q. Procedures,
Triggers, etc)

’ Select the Initial Layout Option

E Circular E Orthagonal Q Tree
IE Hierarchical i] Symmetric

Select the Logical View Parser Option

[~ Use Physical Parser

!X Cancel H? Help | |-1- Back 'E-} Mext i

J

[C] Reverse Engineer Wizard - Page 5 of 5

What type of Physical Model is this?
(® Relational ( Dimensional

’ Select external naming standards template for logical

gl i E

f"“_i ' [+ Create custom datatypes for unsupported types
|Microsaft SQL Server 2005 (system) -
’ Summary of Selected Objects ia“\" LE
( \ Object Tepe | Dwner | Dbiect Name |
Tahle dbo MSreplication_options
“ Table dba spt_fallback_db
Table |dbo | spt_fallback_dev
Tahla dba spt_maonitor
Table dba spt_values

b Sawve Settings for Quick Launch? Save As ...

lx Cancel H? Hol [4- Back I+ Hest [ﬁ Finizh

&

7. Click Finish and ER Studio Data Architect reverse engineers your database!
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Once reverse engineering of your database is complete, we will generate a complete
HTML report of the database for others in your organization to review.

8. In the Data Model Explorer, select the Physical Main Model.

9. Choose Tools > Generate Reports. .
D er/Studio Data Architect Report Wizard - Page 1 of 4 =N ECR =<

’ Benerate HTML or RTF file
Select report ppe
(@ HTML report (" RTF report

’ Repot Directony
Select directory for report

'_]_.r{ | | C:\Users\Embt\AppData\Roaming\Embarcadero\ERStudio\Rep _I

]
2 Wizard Quick Launch

Select Settings File
[ Use file-basad Quick Launch settings.

[Fone ~ | |

(% Settings Only  ( Settings and Objects

’ Do you want to invoke an Editor to view the report after it iz generated?

" Yes  No
b Bxuﬂe HTHML report using performance-enhanced version for large data
mi 3
[ use enhanced version.
‘x Lancel “gﬂ Help & Back Mext b ¥ Finich 4

10. On the first page of the wizard, for the report type, select HTML.
11. On page 2, click Select All in both areas of the Diagram tab.
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BER.media Data Architect Report Wizard - Page 2 of 4

’ Please select the objects in pour data model that pou'd like to generate a
report for

Diagram |Daia Lineagel Data Dictionary | Procedures Funcﬁnns| Triggarsl Securit, DE

W = % branl - H W Diagram -
¥ =l Logical = ¥ Mamea =
| W —HZ§ Main Model ¥ Description ™
W =5 Entibes F¥ Author
l_,.,J ! ¥ —;i Address - Company
= 3 Mo Address.. — Vearsion
| 7 = AWBuild._. ¥ CopyrightOwner
= = BillOfMa... - CopyrightYear
¥ ) Contact ¥ Bound Atachment
2 ol Contac! =l ¥ Model
3 M Contacl.. — Mame
T Ho Country.. i Database Platform
¥ <oy Country . - Model Notation
¥ =y CrediCa. F¥ PreSaL
[ - Culture e ¥ PostSOL >
Select Al | Unselect Al Select All I Unselect All

X Concel |'? Help | '4- Back | Next -}| b Einish

12. Click Select All in both areas of the Data Dictionary and the Procedures tabs, and then
click Next.

@Note: The tabs available on page 2 depend on what objects are supported by the
database platform of the selected model. Some databases support more database
objects than Microsoft SQL Server 2005, such as Oracle11g and IBM DB2 LUW 9.x for
which there are also tabs on this page for procedures, functions, triggers, packages, and
tablespaces. If the model was previously denormalized, a Denormalization Mappings
tab would also appear.

13. On page 3, in the Submodel Image Options area, click Select All.

N Tip: In the Logo and Link Options, you can choose to replace the ER Studio Data
Architect default Embarcadero Technologies logo in favor of your own corporate logo
(and Hyperlink).
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) ER/Studio Data Architect Repart Wizard - Page 3 of 4 [ o [e s

Select HTML generation options
Submodel Image Dptions

Submodal images will be generated in the ,E T braLrg - -
report for the selected submodels. = ?.‘mi n Madel =
Individual Zoom and Quality seftings can be - Human Resources
set for each submodel by selecting itin the = 5
L - s r -8 Person
- i O Production
~ O Purchasing
e Image Type JPG - O e
[ Syst X
- Zooil T 100% b
Qualty — — 7% SelectAll |  UnselectAll |
Logo and Link Options
Image file | Browse.
MNew Link Repon Title

Description  |SQL Server 2005 Sample Mode!

Repoit Formatling

Object Definition Fermalting: @ Preserve formatling T Wrap text
Object Note Formatting: ® Preserve formatting " Wrap text
Explorer Tree: I~ Include ownerin tree

X Cancel | %  Help | 4 Back | { Next c)j B Finith

Because HTML formatting can be included in object definitions, you can also choose to
preserve the formatting specified on the Definitions tab of the various object editors.

14. Click Next to advance to Page 4 of 4, and then click Finish.
ER Studio Data Architect then begins the report publication process and launches the
default browser so you can review the report.

15. Finished!

Start navigating the report via your browser. Navigation will perform exactly as it does when you
are using ER Studio Data Architect! Expand the tree to find Model Image and click on it (see
below). You will see a read-only version of your data model (as seen below). Use the Explorer to
navigate to any metadata you want or select the entities and relationships in the model image
to jump to their information.

Conclusion
In this session, you learned how to:
e Connect to and reverse-engineer an existing database with ER Studio Data Architect.

e Document a database in seconds by using ER Studio Data Architect’s automatic HTML
documentation publication facility.

See Also

e Generating RTF and HTML Model Reports

e [ER/Studio TS documentation]
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Tutorials: Documenting Data Lineage

The Data Lineage feature of ER Studio Data Architect enables you to document the movement
of data from point A to point B (and any intermediate steps in between). This movement is
sometimes referred to as Extraction, Transformation and Load (ETL). Points A and B can be
anything from flat files, high-end databases such as Oracle and DB2, XML, Access databases,
and Excel worksheets. This is sometimes referred to as source and target mapping. A model
produced in ERStudio can represent any point along the way. Data Architects need the ability
to specify the source or target of data down to the column-level. Along with the metadata that
defines the source and target mapping are rules for how the data is manipulated along the way.

The next section will help you document the data lineage of your systems.
It is comprised of the following tasks which correspond to the general ETL workflow:

e Creating a Data Flow

e Creating a Data Movement Rule

e Defining External Source and Target Systems

e Creating a Data Lineage and Transformation Visualization

See Also

e Data Lineage Workflow

e Documenting Data Extraction, Transformation, and Load
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The Data Flow organizes and encapsulates one data transformation and the source tables and
columns used in the transformation to produce the target data. Multi-tiered mappings are
possible and there can be multiple transformations involving different columns between two
tables as illustrated below.

4 GIMDB.DML1 - Data Flow Model View: Broker * ]
¥ Datalineage # | | Broker Investment
E@..ﬁaﬁﬂiﬁ & Broker Id (PK) F Investment 1d ()
b Transformations !H UL % Investment Type Id (Fk)
[‘}ﬁgﬁ Transfarmation V S L?St Mame V Imvestrment WYendor
BN Inputs ¢ Broker First Mame 2 Investment Mame

~ Broker [Logicall < Broker Middle Initial

Erraker First Wame !'“ Manager Id (Fi5
Eroker Last Mame ¥ Years With Firm

& Investment Unit
“# Imvestrnent Duration

4 Outputs l L

§jiTransformation3

= Bioker [Laogizal]
| BROKER_DIM [GIM_D'w)
1 Investment [Logical]
—ﬁ} Shapes
= Data Moverment Rules
ﬁ [ata Retention [Archive Rulg]
ﬁ Upzert (Update Rulg]
=H % Data Sources
Local Models
Logical
] Entities (10)
— Bioker
| Broker Dim
| Client
Client Fact

u=HBraker.Broker Last Mame
u~Broker Broker First Mame
= nvestment.Investment 1d

~4BROKER_DIM.BROKER_MAME

E BROKER_DIM

F BROKER_ID (FK)
“ BROKER_MNAME
< YEARS_WITH_FIRM

Create a Data Lineage Data Flow

1. Choose File > Open and select the GIMB.DM1 diagram in the Sample Models
directory.

2. Click the Data Lineage tab at the bottom of the application window.
You are prompted to create a Data Lineage Data Flow.

Data Architect & 3

L] "_n. There are currently no Data Lineage Data Flows available to display, Would yvou like ko create ane now?
L

Yes Mo

3. Click Yes.
If this is not the first time you click the Data Lineage tab after opening a diagram, from
the Data Lineage Explorer, right-click the Data Flows node and then click Create Data
Flow.
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If you would like to keep your version of GIMB. DM1 unchanged, 'save as'a different
filename before proceeding past the Undo/Redo warning dialog.

4. Enter a data lineage data flow name and then click OK.

Add Data Lineage Data Flowr

M arme: |E!rn:nker

|d’ ak. | |x Cancel |

@Note: The name that appears in the diagram title tab at the top of the application
window is appended with: data flow name, when you click a task in the Data Lineage
explorer, such as GIMDB.DM1 - Data Flow Model View: Broker*.

L | JFGIMDE_80_testing.DM1 - Data Flow Maodel View: Broker * ]
H# Datalineage
T [ata Flows EROKER

# Broker § BROKER_ID (PK)
) Client Load

% OFFICE LOCATION 10 (FKD

The Data Flow has been created.

See Also

e Data Lineage Workflow

e |Introduction to Data Lineage

Embarcadero Technologies 43


http://docwiki.embarcadero.com/ERStudioDA/en/Data_Lineage_Workflow
http://docwiki.embarcadero.com/ERStudioDA/en/Introduction_to_Data_Lineage

Tutorials: Creating a Data Movement Rule

Tutorials: Creating a Data Movement Rule

Data Movement rules describe how source and target tables and entities are related. You can
relate source data to one or more tables and entities in the same model, the active diagram, or
to tables imported from external systems. The rules defined here are used at the table level on

the Data Lineage tab of the entity and table editors.

Create a data movement rule

1. On the Data Lineage tab, right-click Data Movement Rules and choose New Data

Movement Rule.

IS

B " Data Movement Rule

ESREERTCTR

Rule Information ] Binding Information

Recovern Rule
|lpdate Rule
Boolean

Drate

Esternal File Path

Rule Hame: |Ea|:ku|:l e
Rule Type: | &rchive Rule X cancel
i Archive Bule i
Rule Text: Backup Fule i .
Create Rule I ? Help
Deletion Rule &

&

2. Complete the Data Movement Rule editor as required and then click OK to exit the

editor.

N Tip: Once created, you can edit the Data Movement rule by double-clicking it to

launch the Data Movement Rule editor.

The following describes options that require additional explanation:
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Rule Information tab

e Rule Name: Enter a name that indicates the operation and objects acted on, depending
on the specifics of your binding definition.

e Rule Type: Select a generic movement rule type that best describes the data
movement.

e Rule Text: Document your data movement plan here, perhaps adding instructions or
contingency plans.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this attachment. You
can override this setting using the Data Lineage tab of the entity or table editor.

See Also

e Assigning Model Data Movement Properties

e Data Lineage Workflow
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Tutorials: Defining External Source and
Target Systems

Data sources can originate from models in the active diagram (local models) or from external
sources that are either imported into the active diagram or created on the Data Lineage tab. A
data source can be imported from *.dmT files, *.dt1 files, database or from SQL files, flat files,

and other common application files. The following describes how to import metadata from an
external source.

@Note: Source data imported through the Data Lineage tab only includes information such
as table and column name, datatype, nillability, primary key, and column definitions. To obtain
more details, reverse engineer the database or import it into ER Studio Data Architect using the
Metadata Wizard.

Import external source or target data
1. From the Data Lineage tab, expand the Data Sources node.

2. Right-click Other Sources and choose Import New Source.
E% Import Source - Page 1 of 5

Welcome to the Data Source Import Wizard!

Please select where you would like to import the source
metadata from:

&+ From a model in another DM file

> 3 | 3 B

(" From a Repository based D1 file

" From a SOL file

ﬁ " From a live databaze

Companszon Quick Launch

Select Settings File
[v Use file-bazed Quick Launch settings.

| Load file...

(" Setings Only ™ Settings and Objects

|x LCancel | [ ? Help l

3. Complete the Import Source wizard as required and then click Finish to import the
source.

The new source will appear under the Other Sources node.

The following describes options that require additional explanation:
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Page 1 - Please select where you would like to import the source metadata from

From a Repository based DMT1 file: Lets you obtain source from data models and
Named Releases managed within the ER/Studio Repository. When you select this
option, ER Studio Data Architect opens the Repository Operation Status dialog box and
the Get From Repository dialog box. This process connects to the current Repository
Server defined in the Repository settings. The Import Source wizard automatically gets
the diagram.

From an SQL file ER Studio Data Architect imports the SQL file.

From a live database: If you select this option, a page appears where you can select the
database and connection type. The connection type can be either ODBC or
Native/Direct Connection. For information about connecting to databases, including
troubleshooting information, see Connecting to Database Sources and Targets.

Comparison Quick Launch: The Compare Quick Launch data is saved as an *.rvo file.
For information on using the Quick Launch option in the wizard, see Saving and Using
Quick Launch Settings.

Page 5 - Results

Current and Target Model Display Grid: Between the Source and Target models is a
Resolution column. The default merge decision is Merge the data into the new source
file. You can click on any item in the Resolution column to enable the decision list. If you
want to change the decision, click the list and then click the new resolution. When you
change the default resolution of an object, the decisions of their dependent properties
and objects are automatically updated. You can also click the category folders, like the
Tables Resolution column to change all the decisions for all the underlying objects in
that object category. And, you can use the CTRL key to select multiple items, and then
right click to enable the decision list.

SQL Difference: To enable the SQL Difference utility, select any difference that is a long
text field, such as a Definition, Note, or DDL, and then click SQL Difference to view the
differences between the SQL of the models. This utility only allows you to view the
differences; difference resolutions are performed on the Results page of the Compare
and Merge Utility.

Filter Report on Results: Create a report of the source content and your chosen
resolutions. You can choose to create an HTML or an RTF report.

N Tip: You can modify the default display using the options at the bottom of the
page.

See Also

Importing a Model from External Metadata

Attaching External Documents to the Data Model
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Tutorials: Creating a Data Lineage and
Transformation Visualization

1. To create the data source or transformation input tables, expand Data Sources > Local
Models > Logical > Entities and then drag and drop the Broker and Investment
tables onto the Data Lineage window.

2. To create the data target or transformation output tables, navigate to Data Sources >
Local Models > GIM_DW and then drag and drop the Broker table onto the Data
Lineage window.

4 GIMDB.DML1 - Data Flow Model View: Broker * ]
## DataLineage - Broker Investment
= Data Flows

& Broker Id (PK)

H3 Broker

= Tranzformations
— .
Y] Lansformahorﬁ
FHE Inputs

% Office Location Id (FI)
< Broker Last Mame
<# Broker First Mame

& Investment Id (PK)
L |nvestrnent Type 1d (FK)
< Investrment Vendor
< Investment Mame

~— Braker (Logical]
Broker First Mame
Broker Last Mame

Cormpaonents
= Bioker [Loaical)
| BROKER_DIM [GIM_DWw]
1 Investment [Logical]
—d_,\ Shapes
= Data Moverent FBules
Q Drata Retention [Archive Rule)
Q pzert [Update Rule)
=Y Data Sources
Local Models
Logical
1 Entities [10]
—1 Broker
| Broker Dim
| Client
Client Fact

< Broker Middle Initial
L Manager Id (FK)
< Years With Firm

< Investment Unit

< Investrnent Duration

P R T

jiTransformation3

5~ Broker Broker Last Mame
U~ Braker.Broker First Mame
= rvestment Investment 1d

~4BROKER_DIM.BROKER_MAME

E BROKER_DIM

& BROKER_ID (FK)
< BROKER_MAME
o YEARS_WITH_FIRM

3. To obtain the Transformation Insertion tool, right-click an empty space in the Data
Lineage window and then click Insert Transformation.

4. To insert the transformation, click in the Data Lineage window between the source and
target data sources and then right-click to drop the Transformation Insertion tool.

5. Reposition and resize the transformation object to suit your needs.

6. Right-click an empty space of the Data Lineage window and then click Insert Data
Stream.

N\ Tip: Transformation and Data Flow tools are also available on the toolbar. Hover
the mouse over the tools to find the tool you need.
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7. Click an input and then click the transformation object. Repeat as many times as
necessary to link all the inputs to the transformation object.

8. Click the transformation object and then click an output.

4 JFGIMDB_80_testing.DM1 - Data Flow Model View: Broker * |
WM DataLineage a ||| EBUKER INVESTMENT
F}@ Data Flows UGy B INVESTMENT_ID (FK)
S Eraker % OFFICE_LOCATION_ID (FK) -
i Tranzformations o CLRELE RS ]S !; ::Egmg:};{;;i—;i e
Components * BROKER_FIRST_NAWE o INVESTMENT _MAWE
_ < BROKER_MIDDLE_INITIAL = =
wHi® Client Load & MAHAGER, 1D (FI) J INVESTMENT_UNIT
et Clisnt Load 2 3 YEARS_WITH_FIRM # INVESTMENT_DURATION
EI-@% Data Movement Rules \ ‘/
—ﬁ Data Retention [&rchive Ru - .
—ﬁ Upsert [Update Rule] [ wyTransformation1
i Data Sources Inputs:
-l Lacal Models BROKER.BROKER_ID l

Entities [10)

[l G D
— Tables [4) BROKER_ID (PE)

“ BROKER_NAWE
B GIM_OLTP M "
Tables [B]
= “iews [2] bl
Elp, @o. Hio. 8w @R |¢

B YEARS_MITH_F IR

N\ Tip: If the Inputs and Outputs do not display in the diagram as they do in the
illustration above, choose View > Diagram and Object Display Options >
Transformation and then click Inputs and Outputs Columns.

9. To define which columns should be used in the transformation and any transformation
rules, double-click the new transformation to open the Transformation Editor.

10. Complete the Transformation Editor as required and then click OK to exit the editor.

# ' Transformation Editor (50 S
Name: {ErckerName\ Type: <unspecified> _:_1

Columns | Defiion |  Data MovementRules | Attachments |

Inputs: Outputs:
parent Model | Parent Ob... | Atiribute/Column | Data Type | Definition | Parent Model | Parent Oby... | Attribute/Column | Data Type | Definition |
Logical |Broker Broker Last Mame |VARCHA... | | GIM_DW |BROKER_DIM |BROKER_MAME  varchar(... | |
Logical |Broker Broker First Name |VARCHA... |
Logical |Investment | Investment Name [VARCHA... |

(8 tee | [v o | [ concel |
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11. You are done! Now you can more easily share your ideas with your colleagues!

N\ Tip: Once the Data Flow is created, you can double-click it to change its name, or double
click a transformation or component to change its properties.

The following describes options in the Transformation Editor that require additional
explanation, for more options that are not required for this tutorial, please read the User Guide:

Columns tab
e Inputs: Click the ellipsis (...) button to choose the inputs to be transformed in this task.

e Outputs: Click the ellipsis (...) button to choose the outputs resulting from the
transformation.

Definition tab
e Business: Describe the transformation for your audience.

e Code: Enter the code that will perform the transformation, such as a SELECT statement,
or a VBBasic or Java Script function or procedure.

Data Movement Rules tab

These are the rules from the Data Movement Rules node of the Data Lineage Explorer.

@Note: You can delete or edit an input or output column by double-clicking the
transformation in the Data Lineage window, clicking the ellipsis in the Transformation Editor
and then deselecting the column you want to remove.

Attachments tab

Bind an external piece of information or attachment to the transformation. You can also remove
an attachment from an object, override the default value of an attachment, or change the
position of a bound attachment. To override the value of the attachment you have moved to
the Selected Attachments grid, double-click the Value field of the target attachment. ER
Studio Data Architect opens the Value Override Editor or a list, depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must
be applied to the default before they will display on this tab.

See Also

e Documenting Data Extraction, Transformation, and Load

e Introduction to Data Lineage
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Tutorials: Diagram Navigation and
Aesthetics

To assist with the creation of presentation-quality diagrams that are easy to navigate and are
aesthetically pleasing, ER Studio Data Architect offers progressive diagram Auto Layout and
Navigation utilities that also help you to clean up complex diagrams. Modelers should spend
time solving complex database or business data model problems, not forcing boxes and lines
to look a certain way.

Navigating the Diagram

To demonstrate some of ER Studio Data Architect’s layout and navigation utilities, we will
import a sample SQL script provided with ER Studio Data Architect.

1. Close any files you have open.

2. Choose File > New.

& ER/Studio Data Architect

Create a Hew Model

%) " Draw a new data model

@ " Reverse-enginesr an existing database

& Import ..
X LCancel
%  Hep

% {* |mport Model From: |ER File ﬂ
ER# File
Esternal Metadata

o

3. Select Import Model From: and then in the import list, click SQL File.

@Note: The ERX File choice enables you to import Computer Associates ERwin 3.5.2
ERX files. Selecting From External Metadata launches the MetaWizard to import from
alternative sources.

The 'Import Database SQL File dialog appears:
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- 5
#% Import Database SQL File CoxT
= -

Select a Database SQL File
I C:\Program Files\Embarcadero\ERStudio Data Archit @
} Select the target database platform
|1BMDB2 UDB for 05/350 9.x ¥

ER/Studio Data Architect can infer Referential Integrity when
none is dedared in the script, Clicking the options belaw will
create relationships between entities in your diagram,

[ Infer Primary Keys

[ Infer Foreign Keys from Indexes

[ Infer Foreign Keys from Names [T lgnore Case
[ Infer Domains (Create a Domain for each Column)

Select the Initial Layout Option

@ Circular E | Orthogonal | Tree
I_@ Hierarchical }f | Symmetric
What type of Physical Model is this?

' Relational
" Dimensional

Select the Logical View Parser Option
[~ use Physical Parzer

} [V Create custom datatypes for unsupported types

|16M DB 2 UDB for 0S/390 9.x (system) |

4. To the right of Select a Database SQL File click the folder icon, click Sample DDL
(DB2 7.x for ©S390).SQL, and then click Open.

o The full path to this file is:
For Windows XP:
C:\Documents and Settings\<user>\Application
Data\Embarcadero\ERStudio\SQLCode
For Windows 8, Windows 7, and Windows Vista:
C:\Program Files\Embarcadero\ERStudio Data Architect XEA\SQLCode

5. Inthe Select the target database platform list, click IBM DB2 UDB for OS /390 9.x.
6. Click OK.

Finished! Once the SQL Script is finished importing (as depicted below) the following items will
assist you in leveraging a variety of Auto Layout and Navigation Features.
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Layout and & lignment Toolbar Zoom Window

[ata Model Explorer Oerview Window

8 Frmtndin Mafa snrhitert - [Repn Semer: RS ] - [FRE. El"

D Dle T4 Mime Isedt Mede Toimat Laeot Tncls Sepostory
: o Shoaleoly Window  Help
OB B O R 5 |
imE s okt ity N A\
P ?I'%l'ﬂﬂﬂ_j?%gﬂlt * =4
Gy RARG b §i3 5 D v
: L- Logical Mudel Ve ® | r.’!%i _;
pﬁﬁ»ﬁ d,

3 :Z..Z - 1%

El-rj Main Model
Eri ez 07

Fodzresz ==

fdzressT e !

HuBid ersion ‘

Co-tactZeziCad v

Co-tactTuza e |

Ca_h:yF cgion

Ca_n:yF cgionC._m:

CrediCaid

Cuhuic

=] Curriy £
ol o WMo Bel@a |«

e Layout and Alignment Toolbar: Use any of the four Auto Layout styles to change the
layout of the diagram with the click of a button. The auto layout styles are all entirely
customizable styles. You can also customize the diagram layout via the Layout Properties
pages that can be launched by clicking Layout > Layout Properties. In addition, you
can have multiple layout styles in a model. Select some object and then choose the
layout style. If you don't have any objects selected when you click the layout button, the
layout style chosen will be applied to the entire model.

o Data Model Explorer: Click on any object in the Data Model explorer and it will
automatically be selected in the diagram and focused in both the Zoom Window and
Overview window.

e Overview Window: Use this window as a thumbnail of your model to pan the entire
model or zoom in and out. It can also pan and zoom the diagram if grabbed or sized. If
the Overview window is not already visible, press F9 to activate it.

e Zoom Window: Use this window as a magnifying glass to enlarge any diagram objects
under your mouse cursor. You can also press SHIFT+F8 to freeze the zoom window to
keep a single object frozen while you continue to pan around the diagram. If the Zoom
window is not already visible, press F8 to activate it.

Diagram Aesthetics

One of the tremendous benefits of building data models is the wide range of audiences that
can realize value from them. Part of this relies on what information is displayed in the diagram.
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Depending on the audience you may want to limit or expand what is displayed. For example,
developers may benefit from looking at a model that displays data type, null option, and unique
and non-unique index information, while business analysts may just need the entity name and
the definition. ER Studio Data Architect offers many display properties that can be customized
exactly for this purpose.

Continuing with the previous section, we will use the DB2 model that was built to demonstrate
some of the ways to customize the appearance of the model.

We will use the Diagram and Object Display Options dialog on the Diagram toolbar to further
customize the view of the logical and physical models.

e You can use the Colors & Fonts tool to customize the look and feel further of each
model.

Setting the Logical Model Display

1. Select the logical model and then on the Diagram Toolbar, click the Diagram and
Object Display Options tool.

Diagram Toolbar

[l dy & & QW | » oo

|Diagram and Object Display Clpticunsl

2. Inthe Diagram and Object Display Options dialog, click the Entity tab, and then in the
Display Level area, select Entity.

3. Click OK.

-

| RGST_CLNT

|
|
|
|
|
|
|
|
E\ | FRIWEK_ACTUL

FHCL_TRANS I

@Note: Only entity names are displayed for each entity. You may also want to re-layout the
diagram since the entity sizes have changed.
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Setting the Physical Model Display

1. Select the physical model and then choose View > Diagram and Object Display
Opti

2.

ons.

In the Diagram And Object Display Options dialog, click the Table tab.

Diagram And Object Display Options
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In the Display Level area, select Physical Attribute Ordering.

4. Inthe Available Options area, select the specific properties you want to display.

5. Click OK.

The model should now display more details for the physical model, as seen below.

OB2OVVNSS.EDB_SPEC ([EDB_SPEC)

FsrEC_ID (FK)
BCTERY_ID SMALLINT  NOT NULL
#ABER CHARIE)  NOT NULL
PLAST_UPDT_OT TIMESTAMPNGT NULL

CHAR[11)  NOT MULL [AK1:2)

DE2OWNS9.EDE_SPEC_XREF ([EDE_SPEC_XREF}

@ SYS_MAME CHAR{32) MULL (AK1:1)
BEHORT_MAME  CHAR(2Z) MULL
B LONG_NAME  CHAR{120) MULL
HrERTo2AIK
WFRTO2BIX (AK1)

T —

-

- — £=DE20VINGS. EDE_FRIMWE_SPEC (EDE_FRMUK_SPEC)

o
$ ASEN_TYFE [FK)
$ STRT_DT (FK)

SMALLINT
DATE

@ LAST_UPDT_DT

% END_DOT DATE
% MIN_CROML SMALLINT
@ MAX_CRONL SMALLINT

TIMESTAMPNOT MULL

B cFEC_ID FK)
WP DATA

@ SEQ_NUM

@ LAST_UFDT
@ BTRT_DT

W END_DT

B CREAT_DT

-
MOT MULL {IE1:2}
MOT MULL {IE1:2}
MOT NULL

HIT MULL

MOT MULL

CHAR[11) HOT NMULL [(AK1:1)
LD FARCHAR NOT NULL
SMALLINT NOT NULL {AK1:3)
TIMESTAMP MOT MULL (AK1:2)
DATE MOT MULL
DATE NOT NULL
TIMESTAMP NOT NULL

NET NULL ¥ KDATTAIK (AKT)

E FRTOTAI
'& FRTOTEI IET)
L
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@Note: Since the sizes of the objects changed, you may want to change the model layout
using one of the ER Studio Data Architect advanced layout engines. You can also customize the
default display properties for new models by choosing Tools > Options, and then selecting the
desired options on the Display tab.

Conclusion
In this session, you have learned how to:
e Import an SQL file and allow ER Studio Data Architect to automatically create a diagram.

e Use a variety of auto layout and navigation tools to enhance the aesthetic experience of
the diagram and to improve the data model navigability.

e Customize the display of both the logical and physical models.

Thank you for completing the tutorials section. Please visit the User Guide for more examples
and information on using ER Studio Data Architect.
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