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Introducing ER/Studio Data Architect

Introducing ER/Studio Data Architect

ER/Studio Data Architect is a visual modeling application used for platform-independent
logical data architecture analysis and design, in addition to platform-specific physical database
design and construction. The powerful, multi-level design environment addresses the everyday
needs of database administrators, developers, and data architects who build and maintain
large, complex database applications and strive to consolidate, report, and re-use metadata
across the enterprise.

The progressive interface and simplicity of ER/Studio Data Architect has been designed to

effectively address the ease-of-use issues which have plagued data modeling and CASE tools
for the past decade and more. The application equips you to create, understand, and manage
the life-cycle of mission-critical database designs and business metadata within the enterprise.

ER/Studio Data Architect is rich and customizable, offering strong logical design capabilities
like:

The ability to spawn many physical designs from a corporate logical design.

e Bi-directional model comparison and information synchronization.
e Visual-Basic for Applications API for product customization.

e Powerful DDL reverse engineering and generation.

e Metadata import and export capabilities.

e Data lineage documentation.

e Sophisticated XML, HTML, and RTF-based documentation and reporting facilities.

About this document

This document helps you install and use ER/Studio DA and introduces you to the basic
functionality of ER/Studio DA.

For more information and the latest documentation versions, see the Embarcadero website at
www.embarcadero.com.

Notice for Developer Edition Users

The Developer Edition of ER/Studio Data Architect provides the user with all the standard
functionality of ER/Studio except for the following limitations:

e No access to the ER/Studio Repository and ER/Studio Team Server.

e Limited import and export functionality; the Import and Export Metadata Model Bridges
are not supported.

e Limited database support. For a list of supported database platforms, see Supported
Platforms.
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Introducing ER/Studio Data Architect

Application Interface

The application interface is divided into several tabbed windows that let you navigate and
customize your workspace. The application includes context-sensitive toolbars, menus, intuitive
icons, keyboard commands, and other resources to help you work efficiently. ER/Studio Data
Architect user interface has a standard Windows look and feel.

For a detailed description of the internal data structure of the ER/Studio Data Architect

application and the Repository, you can look at Metadata models (DM1 files), usually found in
the following directories:

e Windows XP: C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudioDA_X.X\Sample Models

e  Windows 8, Windows 7, and Windows Vista:
C:\ProgramData\Embarcadero\ERStudioDA_X.X\Sample Models

For information on enhanced Ul features, please see the corresponding numbers below:
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Interface Features

ER/Studio Data Architect has an enhanced user interface that is similar to Microsoft Windows
with intuitive icons.

1. You can dock toolbars anywhere in the ER/Studio Data Architect user interface.

2. The name of the active model, with or without the full path to the file, can be displayed
on the title bar of the main application window. This is an option you can set in Tools >
Options > Application > Application Defaults.

3. ER/Studio Data Architect displays the active model in bold type, so that you can easily
see which model or submodel you are working on.

4. The Data Model tab of the Data Model Explorer displays indexes, relationships, and
attributes as separate nodes.
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Introducing ER/Studio Data Architect

5. The Data Model tab of the Data Model Explorer displays schema objects like packages,

procedures, functions, materialized views, auxiliary tables, and triggers as separate
nodes.

6. The Overview Window lets you navigate large Data Models.

7. The Zoom Window helps you focus on the details of a specific area of a large, reduced
diagram.

The Data Model Explorer is comprised of five tabs that offer easy access to important
functionality and also includes an Explorer tree that lets you efficiently navigate the objects of
your data models. The ER/Studio Data Architect interface to the Data Model is divided into two
main areas. On the left is the Data Model Explorer and on the right is the Data Model Window.
This convention is carried out on other tabs of the user interface, such as the Repository and
Data Lineage tabs, where you'll find an explorer on the left and a graphical representation on
the right. The Data Model Window also provides a complete workspace for creating physical
and logical data models and smaller, movable windows to help you navigate large data models.

See Also

e Tutorial:Installing Embarcadero ER Studio Data Architect

e \What's New

e Upgrading ER/Studio Data Architect

e Licensing ER/Studio Data Architect

e Release Notes
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What's New

What's New

ER/Studio Data Architect 10.0.0
Published Sept 9th, 2014

Release 10.0.0 features summary:

e SaxBasic Update

e Import Bridges update

e MongoDB now supported across the product

e Hive now supported across the product

e Performance Improvement

e x4 bit client now available

Sax Basic Update

Version 10 of Sax Basic, now called WinWrap basic, has been upgraded to the latest version.
This update includes the latest product features and updated documentation.

Import Bridges update

The Import Bridges have been updated with all the latest support. For the latest list, please see
our MetaWizard Import/Export Bridges pages.

MongoDB is now supported across the product

As part of the expanded platform support and to enable better visibility into metadata for
unstructured data formats (including a notation to show nested data hierarchies that is unique
to ER/Studio), this release provides native support for MongoDB 2.4 and 2.6.
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What's New

Change Database Platform H

— Database Platform

Database Platform:

.
DB Platform Version:

|MongoDB 2.4 =] | X Cancel

~Datatype Mapping 1 | @ Help
Select Mapping:

|MongoDB 2.4 (system) |

Hive now supported across the product

We have customers that are using Hive for their large data set. For this reason,this release
provides native support for Hive 0.12 and 0.13.

Change Database Platform “

— Database Flatform
Database Platform:

I Hive ;I

o  OK
DB Platform Version:
|Hive 0.12 ~|| X Cancel
~Datatype Mapping—————————1 | @ Help
Select Mapping:
|Hive 0.12 (system) k1

®Perf0rmance Improvement

With an improved memory model, the Model Repository has had a performance upgrade,
particularly for large models.

@bit client now available

ER/Studio Data Architect and ER/Studio Repository now run as a native é4-bit application.
Separate installers let you choose between 32-bit and 64-bit applications. You must be using
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What's New

64-bit versions of DBMS platform drivers when using the 64-bit version of ER/Studio Data
Architect.

See Also

e Release Notes

e |nstallation Guide

e Supported Platforms
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Installing Embarcadero ER/Studio Data Architect

Installing Embarcadero ER/Studio Data
Architect

This section will help you ensure your environment meets the technical requirements and helps
you install ER/Studio Data Architect.

You can download a 14-day trial version of ER/Studio Data Architect, from
http://www.embarcadero.com/downloads. Embarcadero will send you a license registration
code by email.

System Requirements

Review the requirements before you install ER/Studio Data Architect. Adhering to these
requirements optimizes the performance.

ER/Studio Data Architect Requirements

Processor Dual Core or higher

RAM 2GB

Hardware||Disk Space
670 MB

Any of the following:

Operating System * Windows XP - 8
¢ Windows Server 2000 - 2008

To use an Open Data Base Connectivity (ODBC) database as a data source, install the ODBC

driver on your client computer.
Software ‘ ‘ o . . G ‘
To connect to the DBMS using native connectivity, install the native client libraries available from

the DBMS vendor.

Local administrator privileges (required for installation only).
Privileges||DBMS privileges to create objects on the server: EXECUTE permission as the user needs to
execute stored procedures for example Create_Temp_Tables.

Installing ER/Studio Data Architect

N\ Tip: We recommend to have installed most current version of both, ER/Studio Repository
and ER/Studio Data Architect, to ensure compatibility.

@)Note: It is not possible to install the x64 bit version where a x32 bit version is also installed.
You will need to remove any previously installed x32 bit versions of the software.
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Log on to Windows with local administrator privileges.

1.

Start the ER/Studio Data Architect installation program.

@Note: To do asilent install, you can run the installation program from the command
prompt with the -s parameter.

2. Walk through the installation wizard following the onscreen prompts.

The following provides additional information for some options that are not self-explanatory:

Default Notation: Choose the notation type you want ER/Studio Data Architect to use
by default to display the model.

IDEF1X: Data modeling technique used by many branches of the United States Federal
Government.

IE (Martin/Finkelstein): Information Engineering (IE) as developed by Martin and later
revised by Finkelstein.

IE (Crow's Feet): Uses IE notation and represents relationships with connecting lines
between entities, and symbols at the ends of those lines to represent the cardinality of
the relationship. This is the notation used in Oracle texts and in other applications such
as Visio. Foreign keys are displayed in entity boxes.

IE (Hide Foreign Keys): Uses standard IE notation, but foreign keys are not displayed in
entity boxes.

@Note: You can change the notation setting at a later time. To change the notation, choose
Tools > Options from the ER/Studio Data Architect Main menu, and then click the Logical or
Physical tab where you can choose the notation type.

Shared Application Data Location: By default, ER/Studio Data Architect installs shared
directories and application files such as the DatatypeMapping, Macros, and Sample
Models directories in the following locations:

Windows XP:C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudio_X.X

Windows 8, Windows 7, and Windows
Vista:C:\ProgramData\Embarcadero\ERStudio_X.X

If you prefer to store these files in another directory after installation, follow the procedure in
Changing the Location of Shared Files.

For step-by-step instructions on how to use ER/Studio Data Architect, see the Tutorials
section.

Installing ER/Studio Data Architect via Command Line

ER/Studio Data Architect can also be installed from the command line as follows:
erda_<ver>.exe Optional parameters:
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e /s (specifies to install silently without prompts, using default installation settings.
e TARGETDIR=<install dir> (specify an alternate installation directory)
e DESKTOPICON=TRUE (enable the desktop icon option)

For information on installing ER/Studio with Embarcadero AppWave, please see the AppWave
Admin Quick Start and the AppWave Administrator Guide at http://docwiki.embarcadero.com

See Also

e Tutorial: Modeling Tutorials

e Upgrading ER/Studio Data Architect

e Uninstalling ER/Studio Data Architect

e Licensing ER/Studio Data Architect

e Release Notes
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Upgrading From Previous Versions

Upgrading From Previous Versions

Use the following checklist to ensure ER/Studio Repository is correctly upgraded.

Upgrade Checklist

e Download ER/Studio Enterprise Upgrade. To download the most current release, go to
embarcadero.com.

e Review the ER/Studio ReadMe. For the most current installation and usage information,
see the ReadMe at embarcadero.com.

e Prepare to upgrade. For what to do before you upgrade to the latest version, see
Preparing to Upgrade the Repository.

e In case you need to ER/Studio Team Server to match the features available in your
version of ER/Studio Data Architect see ER/Studio Team Server Upgrade Notes.

@Note: This procedure is for ER/Studio Enterprise installations only, which include the
Repository. When you upgrade ER/Studio Data Architect, you must also upgrade ER/Studio
Repository to correspond with the same build date as ER/Studio Data Architect.

Preparing to Upgrade the Repository

User preparations
1. Ensure you have backed up all your.dm1 files.

2. Check in all your diagrams and objects. If you try to check in a file from the previous
version with the same name as a current file, the current file will become corrupted.

3. Rename all local copies of Repository diagrams in the active file directory as follows:
1. Choose Repository > Options.
2. Make note of the Active File Directory.

3. Switch to the Windows Explorer and rename all the diagrams in the Active File
Directory.

Administrator preparations
1. Ensure no one is logged into the Repository.
2. Backup the current Repository database.

3. Restart the Repository host computer.
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Upgrading From Previous Versions

@Note: If you are upgrading from a Repository version prior to 4.0, you can delete the
C:\Program Files\Embarcadero\Repository\Data directory. This directory is not used with
Repository versions 4.0 and later.

Upgrades from ER/Studio Repository 6.5/6.6 users to
ER/Studio Repository 6.7

Keep the following in mind when updating for this release:
e Only a service upgrade is required.For this purpose:
1. Log on to Windows with local administrator privileges.

2. Start the Repository installation program and select Repair Repository Services. The
installation program starts the following services:

3. Embarcadero Repository Communication Server
4. Embarcadero Repository Database Server
5. Embarcadero Repository Event and Dispatch Server

e No diagram data version upgrade is required. User preparations are not required.

e There are no database changes from version 6.5 or 6.6.

Upgrades from ER/Studio Repository 6

1. Prepare Repository to upgrade
2. Log on to Windows with local administrator privileges.

3. Start the Repository installation program and select Repair Repository Services. The
installation program starts the following services:

4. Embarcadero Repository Communication Server
5. Embarcadero Repository Database Server
6. Embarcadero Repository Event and Dispatch Server

The Repository services and your existing database will be upgraded to the current version.

Upgrades from ER/Studio Repository prior to 6

The Repository upgrade must be done incrementally from one major version to the next until
the target version is reached. You cannot skip major versions during the Repository upgrade as
the installer for each major version only contains the database changes between the new
version and the previous one.
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When upgrading from earlier versions, such as from 5.5 to Repository 6.7, you must first
upgrade the Repository to version 6.0, that will update the database, uninstall version 6.0, then
upgrade to 6.7, and update the database.

Once the Repository upgrade is complete and you have installed the latest version of ER/Studio
Data Architect, then you should upgrade your diagrams with the latest version of ER/Studio
Data Architect.

Important Notes

e Always backup the Repository database before upgrading.

e You can install ER/Studio Data Architect 9.x and an earlier ER/Studio Data Architect
version on the same workstation.

e Any *.dm1 files you use from the previous version will be copied and converted to the
current version format when you open them for the first time. You can then save the
diagram with a different name or use the same name to write over the old file. Previous
versions of ER/Studio Data Architect may not read files generated on a higher major
release.

e Upgrading diagrams can be time consuming and memory intensive. The number and
size of ER/Studio Data Architect diagrams managed in the upgraded Repository dictates
how long the upgrade process takes.

See Also

e Release Notes

e Installing Embarcadero ER Studio Data Architect

e Licensing
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Tutorials

Tutorials

The tutorials are intended to help you get started using Embarcadero’s data modeling and
database design solution, ER/Studio Data Architect.

After completing these tutorials, you'll have the foundation you need to explore the many
features and benefits of ER/Studio Data Architect. You will have learned how to do the
following:

e Create a new data model.

e Work with logical and physical diagrams.

e Leverage productivity-focused features such as powerful reporting engines.
e Use common tasks and commands to make you more productive.

The tutorials are divided into three sessions. Do them all at once or complete them individually
as your time permits.

You can use this basic tutorial as a road map of product highlights, but also to help you find
your own path in exploring ER/Studio Data Architect.

Once you have started, you can click Help from the Main menu to find many additional
resources that complement and build on many of the activities shown in this brief guide. Or visit
the Contents section of http://docwiki.embarcadero.com

See Also

e Tutorial: Getting Started

e Upgrading ER/Studio Data Architect

e Licensing ER/Studio Data Architect

e Release Notes
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Tutorials: Getting Started

Tutorials: Getting Started

Interface Features

ER/Studio Data Architect has an enhanced user interface that is similar to Microsoft
Windows with intuitive icons.

The graphic below names and describes the functionality of some key elements of the
ER/Studio Data Architect user interface.

For information on enhanced Ul features, please see the corresponding numbers:

3 ER/Studio Data Architect XES - [Repo Server: ESEBTConnect][Logged In As: Admin] - [e-Commerce Order Shopping Cart2 - Physical Mod... L (=) [
i‘% File Edt View Inset Model Format Layout Da;;zase Tools Repository Macro Shortcuts ﬂindowjelp -8
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FoignKeys (25)  |fomc e s e e e e e e e e e e e e e e s s a e v Dosage_Form
Aliases i Route 0

|| For Help, press F1 | Columns =108 |[Foreign Keys =21 | CAP |INUM|[SCAL]

1. Sophisticated diagram auto-layout tools provide single-click clean up of diagram
objects.

2. Data Model Explorer displays information about logical and physical models, submodels
and nested submodels.

3. Repository object status icons display real-time user access information.

Embarcadero Technologies 19


http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features
http://docwiki.embarcadero.com/ERStudioDA/XE6/en/Introduction#Interface_Features

Tutorials: Getting Started

Complex schema objects like functions can be displayed to illustrate dependencies.
Toolbars are dockable anywhere in the ER Studio DA application window.

The Overview Window lets you navigate large Data Models.

N o ok

The Zoom Window helps you focus on the details of a specific area of a large, reduced
diagram.

Starting to Data Model with ER/Studio Data Architect
On the Windows Start > Programs menu, choose Embarcadero > ERStudio Data Architect.
1. Choose File > New > Draw a new data model.

As you can see in the Create a New Model dialog, there are a number of ways to begin
modeling with ER/Studio Data Architect:

e Build a new design from the ground up by drawing a new data model.
e Build a data model from an existing database through live reverse engineering.

e Import designs from other modeling products such as ERwin or SQL files.

N Tip: You can select an initial layout style for your model before the SQL import takes place.

e Ensure Relational is selected for the new model type and then click OK.

After selecting Draw a new data model and clicking OK, ER/Studio Data Architect will
resemble the image below:

& ERsStudio Data Architect - [Repo Server: MBWHCHOWO4] - [Modeld - Logical Model View] [= |[B]X]
E@Eile Edit Wiew Insert Model Format Layout Tools Repository Macro Shortouts  Window  Help
- 3 X

REES| @ QAN BeRm| F] o n1@)a) K
R RA WS HRE| o oo & EFHE GHHHHHOO_H

X R SR ENEAL R X KR AN X
]Eﬁ‘-?l DATA MODEL

| Logical

Main Model

A
v
b > e
@Da‘la_|ﬁData | BB Data .| 38 Macro | < | »
For Help, press F1 Logical Maodel Wiews =0 Entities = 0 Attributez =0 Relationshipz =0
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See Also

e Tutorial:Logical and Physical Modeling

e Application Interface

e Upgrading ER/Studio Data Architect

e Uninstalling ER/Studio Data Architect

e Licensing ER/Studio Data Architect
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Tutorials: Logical and Physical Modeling

ER/Studio Data Architect supports both logical (non-DBMS or technology-specific) modeling
and physical (DBMS-specific) modeling. ER/Studio Data Architect is designed to allow
organizations the flexibility to analyze and design a business problem or application logically
and generate as many different physical interpretations from the logical model as required.
Multiple physical models can be generated from the logical model for the same DBMS (for
example, Oracle) or other DBMSs (such as Oracle, SQL Server and DB2). Generating logical and
physical models will be discussed in detail in the following sessions.

e Using Data Dictionary Domains to Populate New Entity

e Establishing Relationships Between Entities

e Creating and Working with Submodels

e Generating Physical Models from a Logical Model

e Denormalizing the Physical Model

e Finding out How an Entity Maps to the Physical Model

See Also

e Tutorial:Using Data Dictionary Domains

e Logical Design Concepts

e Data Modeling Concepts
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Tutorials: Using Data Dictionary Domains
to Populate New Entity

As instructed in Getting Started, you have chosen to draw a new data model to begin a logical
model from the ground up. Before we begin to add entities, we will populate ER/Studio Data
Architect with some sample domains (Domains are re-usable attributes).

1. Choose File > Import Data Dictionary.

2. Next to the File Location box, click the ellipsis and browse to the Sample Models
folder, which is located at:

o For Windows XP:
C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudioDA_X.X\Sample Models

o For Windows 8, Windows 7, and Windows Vista:
C:\ProgramData\Embarcadero\ERStudioDA_X.X\Sample Models

3. Double-click the Orders.dm1 sample model and then click OK.

This model contains a pre-populated, sample data dictionary.

@Note: Under Resolve Imported Objects with Duplicate Names, you can choose
between a couple of options to determine how the dictionary objects are imported. This
is important when importing into a diagram that already has dictionary objects in it.

Once opened, you will see that the ER/Studio Data Architect Model Explorer has
automatically switched to the Data Dictionary tab to allow immediate drag and drop
access to domains.

M ain
Attachrents
Attribute |
Souce

I:% Targe

E ntity Pri
I:% Applic
% Type
General F
L% Marmir a
B | A

4. Now, to add an entity to the Data Model Window, click the Entity tool on the Modeling
Toolbar,
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and then click in the Data Model Window to drop the entity.

N Tip: The cursor will change to an entity symbol once the Entity tool is clicked, so
you can click to drop as many entities on the Data Model Window as you want.

5. Right-click to return your mouse to the selection cursor.

6. Right-click the entity and open the Entity Editor. In the entity name field, type Customer,
replacing the default entity name, Entity1 and then click OK..

7. In the Domains folder of the Data Dictionary tab, locate the ID domain in the Numeric
Domains folder.
22 e
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8. Click the ID domain (do not release your mouse), drag it onto the Customer entity, and
then release it just below the entity’s name, which is the entity’s Primary Key field.

N Tip: You can edit or rename an entity and insert, edit or rename attributes by
holding down the Shift key and then clicking the name or attribute. Pressing the Tab key
cycles between the entity’s name, and primary key and non-primary key fields. After
naming the field, press Return to insert a new field.

N Tip: If you need to zoom in on the entity to read the entity name and attributes,
press F8 to view the Zoom Window, then use the scroll bars of the Zoom Window to
center the entity on the Data Model Window. Press Shift while rolling the mouse wheel
forward to increase the view magnification. You can use the Pan tool to reposition the
view to better see the entity.

9. In the entity, click ID, the name of the attribute we just created from the ID domain, and
change its Attribute Name and Default Column Name properties to CustomerlD, as
seen in the illustration above. Then click OK.

10. Repeat the process in step 7 and step 8 to populate the Customer entity with the
following domains:
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o Name and Phone from the Property Domains folder
o Address, City, State, Zip Code from the Address Domains folder.
11. Drop another entity on the Data Model Window and call it Order.

12. Drag the ID domain onto the Order entity’s Primary Key field, change the Attribute and
Column name toOrderlD.

13. Right-click the Order entity and select Comments.

14. Enter some text in the Comments editor, click Add and then click OK. You can add
comments to any database object in the same manner. This can be very useful when you
want to provide feedback on a model to other users.

15. Save your data model. We will use it in the next session of this tutorial.

See Also

e Tutorial:Establishing Relationships Between Entities

e Ensuring Consistent Domain Definitions Using User Datatypes

e Reusing Attribute Definitions Using Domains
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Tutorials: Establishing Relationships
Between Entities

1. On the Modeling toolbar, click the Non-Identifying, Mandatory Relationship tool.

i E@- el LeeBldOE] A
B &M =TT e "R

{Mon-Identifying, Mandatory Relationship

@Note: The screen shots of this tutorial were taken using a model where the notation
was set to |IE (Crow’s Feet). Depending upon the notation your model is currently set to,
the icons for each relationship will be slightly different.

N\ Tip: You can change the model notation by choosing Model > Model Options,
and then selecting another notation option in the Notation area.

2. To establish a relationship between Customer and Order, click the parent entity,
Customer and then click the child entity, Order.

@Note: ER/Studio Data Architect supports sound design practices by automatically
propagating the primary key, from parent to child entities. If there are candidate
alternate keys that should also be propagated to the child, in the Relationship Editor you
can choose all available parent entity keys in the Parent Key list. Deleting a relationship
will remove a non-native propagated attribute. However, if you want to keep the child
columns of the relationship or foreign constraint, when you delete the relationship you
can check the Make Foreign Keys Native option. In this case, if the relationship between
Customer and Order is deleted, the CustomerID will be left in the Order entity.

What is a Domain?

A Domain is a valuable tool in establishing standard, re-usable Attributes/Columns. They allow
data modelers to create a data element once (such as an ID field you require all of your entities
to leverage as its primary key) which has the same data type, definition, rule, and constraint no
matter where the data element is distributed and bound. Read more about Domains in
ER/Studio Data Architect User Guide.

See Also

e Tutorial:Creating and Working with Submodels

e Reusing Attribute Definitions Using Domains

e Ensuring Consistent Domain Definitions Using User Datatypes
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Tutorials: Creating and Working with
Submodels

Now that you have a general understanding of how to build logical models from the ground up
in ER/Studio Data Architect, it is important to understand how to work with an important
navigation feature of ER/Studio Data Architect, called Submodels. Submodels and nested
submodels are designed to break down large, complicated views of a data model in order to
focus on a specific area. An important aspect of Submodels to understand is that any changes
made in the submodel, other than layout, color, display settings, notation or similar items which
can be unique to the submodel, will occur automatically in the Main Model view. In other words,
change or add an attribute to an object in a Submodel and the change is automatically
propagated to its Main Model counterpart.

Close the current sample model, and open a more mature model. Use this exercise to learn
more about submodeling.

1. Choose File > Open.
2. Select Orders.dm1 and then click Open.

3. To preserve this sample model for future use, choose File > Save As and then save the
Orders.dm1 file with a new name.

In this exercise, we will be modifying this model.

4. Collapse the folders in the Data Model tab of the Data Model Explorer to look like the
image below:
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In the Orders.DM1 sample model, there are no physical models. This model includes
several submodel folders that help to describe the logical model:

o Main Model - This is the entire collection of all logical objects in the Orders.DM1
file. Note the absence of the magnifying glass on the folder icon which
designates it as the main model.

o Bill of Materials throughShopping Cart — These are submodels, which are smaller
collections of entities derived from the Main Model that help to describe specific
areas of the Main Model free from other entities.

o Alternate Key through Primary Key — These are nested submodels, which can go
‘'n’ levels deep and are literally submodels of submodels.

Feel free to explore. Click the plus sign (+) to expand these folders.

Let's create a submodel with all the objects related to the Orders.DM1 Address
components.

5. To make a new submodel, navigate to Logical Main model and with the CTRL key
depressed, click the objects in the Data Model Explorer, as seen in the image below.

Embarcadero Technologies 28



Tutorials: Creating and Working with Submodels
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@Note: Any objects selected in the Data Model Explorer will also be selected on the
Data Model Window as well (also seen here). You can also select entities by lassoing
them on the Data Model Window.

6. With the entities selected, choose Model > Create Submodel.

*% Create Submodel

|.-“-‘-.|:I-:Iress Components | %y Edit Submodel |

|#’ ak. | |x Cancel |

7. Below Create Submodel, enter Address Components as the name for the submodel.

8. Click OK.
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ER/Studio Data Architect creates the Address Components submodel.

9 Orders.dml - Logical Model View: (Address Components) * ]

L .
2 Embarcadero Sales Order Processing ”

i Addrezsz Components
by Bill of Materials

i Commizsion Tracking
iy Customer

iy Customer Address

FHES Main Model Displaps

What do the results look like and how do | navigate to the submodel?

Once created, you will see the new submodel listed in the Data Model Explorer, denoted as a

submodel by the magnifying glass over its folder, as in the case with Bill of Materials and the
other submodels.

See Also

e Tutorial:Generating Physical Models from a Logical Model

e Retrieving a Repository Diagram, Model, Submodel or Named Release

e Creating and Editing Submodels
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Tutorials: Generating Physical Models from
a Logical Model

ER/Studio Data Architect can generate as many physical models from a single logical model as
desired. There are many ways to leverage multiple physical models in ER/Studio Data Architect
to help the design process. Examples of how multiple physical models are used are:

e Managing change in an existing application: Maintain independent development, test,
and production physical model diagrams that represent specific databases.

e Migrating database applications: Use ER/Studio Data Architect as an analysis and design
hub for migrating database applications. Manage a physical model of the legacy source
database application in addition to its new target physical model, which can be for an
entirely new DBMS than originally maintained in the legacy database.

Let's generate a new physical model from a logical model in order to build a database. We will
use the Orders.DM1 sample model.

1. Open your version of the Orders.DM1 sample model.

N\ Tip: Use the steps shown in the last session to do so.
2. Select the Main Model and then click Model > Generate Physical Model.

ER/Studio Data Architect invokes a step-by-step wizard to walk you through the process
of generating a DBMS-specific physical model.
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E= Generate Physical Model - Page 1 of &
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} Wizard Quick Launch
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[~ Use File-Based Quick Launch Settings

|Nnne j | |
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3. Name the new physical model, DB2 Physical Model and then select DB2 UDB for
0OS/390 8.x as the target DBMS to generate.

4. Continue through the Generate Physical Model wizard, which prompts several
questions about how you want your physical model to be generated.

@Note: The wizard prompts you to customize items such as individual object
selection, index assignment, default storage parameters, resolution of many-to-many
relationships that may be in the logical model, and naming conventions. In Step 3 of the
wizard, you can add prefixes or suffixes to the object name. For example, it can be
useful to add an indicator of the object type in the name. A DBMS-specific validation
check is also provided in this wizard.

N\ Tip: The Quick Launch can store common settings so that an operation can be
reused on this model or on any other models. You can reuse the settings on another
model by choosing the Use File-Based Quick Launch Setting option when saving the
Quick Launch information on the last page of the wizard.

5. To generate the new Physical Model, on the last page of the wizard, click Finish.

Now that a physical model has been generated from the logical model, feel free to navigate to
specific objects via the Data Model Explorer, such as the CUSTMR table selected here. Double-
click and view the physical details of the object such as DDL, Indexes, Partitions, and Storage.

Embarcadero Technologies 32



Tutorials: Generating Physical Models from a Logical Model

[] LTy

! La

_ﬂr_llc kot Yoew  Inscrt [dode

Farmct  Layout  Latchase  _cals  Licposiory

Piald S % QNG e 2 gy as -

[ do O B W & 6

|- l® EIEE@G o8

FeG@adn=+ T B0 &H

|

g .__.-" Drdzrsdml  Uhiyssl Mode Yiow: Db M'hiwsical WMod< ; Tl:l th E|Ji|.|JI'

New Physical
Model in the
Data Model Exploren

Double-click
CUSTMR, to invoke
the Table Editor
and view design
details, such as
the DOL script.

See Also

=] Erbarzazets Zdzs Onder Frocossing
Lzgezl
I'# DB Prosical Moo

I'HES Wrn Maded

IHT akes (211

Iil-lj Arder_| rpee

IIH Ader_I2N

Ii Ardrr_| nle

II Adrr_lypn

I Ader_lypc e

= App_ta

aulleal Pt Jaml
Eil_knly

Cimve el

Cuid n_dd
Cudu_Pn

-~
Enlilp Mae. | Tiele
| Physica Onby I T

Peirrissinne | P [ Fns-oc
Uz 2ofined Mzplimgs | ]

Culuins JCL

Cu

\i

I reb_Mrre
Lal_k e

Crrp-y M
Erl_add

I |1

I+ Ewulrig Cud
Lz Zv

] N

e Tutorial:Denormalizing the Physical Model

e Developing the Physical Model

e Transforming Model Objects from Logical to Physical
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Tutorials: Denormalizing the Physical
Model

ER/Studio Data Architect comes equipped with denormalization wizards to help you optimize
the physical design once the physical model is generated. The wizards help automate the
process and keep the ties between the physical tables and the logical entities.

The active, denormalization wizards available depend on which tables are selected in the
physical model when you select Denormalization Mapping. For example, if two tables that are
related to each other are selected, the valid operations would be Rollups or Rolldowns.

Delete Table
Entity Color and Font Settings »
Align Entities »

Denormalization Mapping

el

|@ Rollups...

LA =l Ralldowns. ..
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Create Procedure k =
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Create Trigger 4

Create Wiew
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Apply To Submadel(s)...

Macros L4

g(: Add/Remove Macro Shortouts

Compare and Merge Utility. ..
% Submadel Synch Utility. ..

When only one table is selected, the option to split the tables becomes available. The Table
Merge option is available when two unrelated tables are selected.

Let's walk through an example of a denormalization operation using the generated physical
model in a previous session of this tutorial. We may want to reduce the overhead on the Custmr
table by splitting it into two physical tables, Custmr_East and Custmr_West. Splitting the table
can reduce the query time and provide opportunities to store the tables at different locations
which could further reduce lookup time.
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[=RL

ALY

Before the operation, the Custmr table should look like:

1. Open the Orders1.dm1 model you modified and saved in the last session.

2. In the Data Model Explorer, right-click the Custmr table in the Physical Model.

3. Choose Denormalization Mapping > Horizontal Splits.

Notice that since only Custmr is selected, the only possible mappings are vertical and

horizontal splits.

The Horizontal Table Split Wizard launches.

4. On Page 1, type 2 for the number of splits.

5. On Page 2, rename Custmr1 and 2 to Custmr_East and Custmr_West respectively.

-

B ' Horizontal Table Split Wizard - Page 2 of 4.

-

o | B |

e e

that in order for two or more tables to retain the same name on the physical

} Please review the naming conventions for each of the replicated table. Mote
madel, a unigue database ownerfqualifier must be provided.

Check the "Submodel' check box to incude the new splits in the submodels
of the original table.
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| Customer

Pre mapped Table | |Custmr
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[-@ Back H Hext @|

Finizh
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6. On Page 3, click Next.

We will keep all the relationships.
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7. On Page 4, type a name and definition for the denormalization operation, and then click
Finish.

Finished! After the split the Custmr table will be two physical tables that look like this:

Custmr_Ezst

Cusimi_ID [FK

r5_lime

Custmr_Visst

astmr_ID [P
rst_MNme
L=t Nme
Cmprry_kime

nix

i

The two tables are identical except for the

You can selectively choose which attributes are included in the resultant tables by using a
vertical split.

The denormalization mapping is stored with each of the tables.
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You can use the denormalization information to undo the operation or see the history of what
happened. ER/Studio Data Architect tracks the before and after states of these operations. This
comes in handy in the next section where we discuss the Where Used analysis that can be
performed between the logical and physical models.

See Also

e Tutorial:Finding out How an Entity Maps to the Physical Model

e Optimizing Query Performance on the Physical Model (Denormalizing the Physical

Model)

e Upgrading Diagrams with Denormalization Mappings
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Tutorials: Finding out How an Entity Maps
to the Physical Model

Now that we have performed a denormalization operation, the logical entity, Customer,
essentially has become two physical tables, Custmr_East and Custmr_West. The ties between
the logical and physical models are not lost. ER/Studio Data Architect allows you to see what
Customer in the logical model maps to in the DB2 physical model.

Let's take a look at the Customer entity in the logical model.
1. In the Data Model Explorer, navigate back to the Customer entity in the Logical model.
2. To start the Entity Editor, double-click the Customer entity.
3. Click the Where Used tab.

[ ] Entity Editor E=EERT)

Entity Hame: |Cust0mer Table Mame: |Cus1mr Owner: -
[ Logical Only
Attributes ] Keys l Relationships l Definition ] Note

tions l Data Lineage ] Security Information l Attachment Bindings

Constraints l Dependencies ] Permissions ] Maming Standards
IJse "Switch To"™ on an entity or table listed to edit that object, or dick Edit to edit the mapping definition and attachment bindings.
I Show only submodels that use this object

:’;' Where Used &
EZE| Logical &
! B3 submodel Usage
El DB2 Physical Model (TBM DEZ) &
-__" Table Name: Custmr_East 0
-|___'| Table Mame: Custmr_West 0
B4 Denormalization Mappings =
-%- Harizontal Table Split: Custmr_Horizontal_Split_Mapping_1 &

N’ oK \ IXCanceI‘ [‘? Help ]

b

Once the tree is expanded, you can see the lineage of what has happened to the object. Notice
that Custmr_East and Custmr_West are listed as physical implementations of the Customer
entity. The denormalization mapping object shows how the end result was achieved.

The Where Used tab also displays the submodel usage of a particular entity within the logical
or physical model. This allows you to see which business areas the entity belongs to.

@Note:Where Used information is also available for attributes and columns.
Conclusion

In this session, you have seen how incredibly quick and easy it is to:
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e Build a logical data model from scratch.

e Create a new submodel view to understand how to model on specific parts of a larger
Main Model.

e Generate a physical model from a logical database in preparation for building a new
database.

e Denormalize objects in the physical model.

e View the mappings between the logical and physical models using the Where Used tab.

See Also

e Tutorial:Documenting an Existing Database

e Developing the Logical Model

e Developing the Physical Model

e Synchronizing Physical and Logical Models

e Generating a Script File or Database
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Tutorials: Documenting an Existing
Database

One of ER/Studio Data Architect’s most powerful applications is that of a documentation
generator to communicate complex databases and associated metadata to the Enterprise.
ER/Studio Data Architect is equipped with extensive report generation capabilities:

e HTML Report Generation: Instantaneous generation of an HTML-based Web site
designed to provide simple navigability through data models and model metadata
using standard browsers such as Google Chrome or Mozilla Firefox.

e RTF Report Generation: Instantaneous documentation generation compatible with
applications like Microsoft Word.

In the exercise below, we will reverse-engineer an existing database and generate an HTML
report for distribution and navigation to those who depend upon the information about the
data model, but who may not be permitted to connect to the database for security or
organizational reasons.

PRE-REQUISITE:

This exercise assumes that you can connect to an existing database in order to document it. If
you cannot connect to an existing database, you can still generate documentation from the
installed sample models; skip steps 1 through step 8 below which relate to in reverse-
engineering and begin at step 9 after opening a sample model included with ER/Studio Data
Architect.

1. ChooseFile > New.

¥ ER/Studio Data Architect

Create a New Model

'%) " Draw a new data model |

@ {+ Reverse-engineer an existing database

I% " Impart Madel From: | J

2. Select Reverse-engineer an existing database.

#" Login ___
X Cancel
Y  Help

3. Click Login.

o You can reverse engineer the database from either an ODBC datasource or via
Native RDBMS client connectivity. In this example, Native Connectivity to
Microsoft SQL Server will be demonstrated.

Embarcadero Technologies 40



Tutorials: Documenting an Existing Database

4. Type the relevant connectivity information such as the data source name, and user name
and password and then click Next.

F

# " Reverse Engineer Wizard - Page 1 of 5 gl

—Mew Reverse Engineering Operation

Connection {" ODBC: . Sebup. |

{* Native Direct Connection

{” Embarcadero Connect Data Source

Database Type: IMS SGL Server LI
Datasource: | ETSOLO1

User Mame: I 58

Bl I [a——

[ Use Windows Authentication

[ Create Embarcadero Connect Data Source from settings

Mame: I

—Wizard Quick Launch
Select Settings File

5. Walk through the Reverse Engineer Wizard selecting the objects, options, and layout
preferences for the model.

@Note: A new feature using ER/Studio Team Server data sources is available in the
Reverse Engineer Wizard. Please see ER/Studio TS documentation for more details.
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Datasource Type:

Database List

Owwner List

—Include

¥ User Tables

Datasource Name: |

[~ System Tables
[~ UserViews

[MS SQL Server [~ System Views

[~ Triggers

limaﬂler - B il'—‘ml:s,'Funcs

|- Peackages
[ Storage Objects

[ Alias

[~ Sequences

[~ Synonyms

[~ Materialized Views
[ Users

[ Roles

[~ Schema Objects

Select All

]
Deselact All

—l_del.

gm———

£)

S

Tables | views | Trggers

Avadable Objects

|Dbie:t Mame r

[ nchude obiect pemissan:

’ What database objects do you want 1o reverse engineer?

Sedacted Objectz
Object Mame |
MSiepication_ophions
spt_falback_db
spt_falback_dew
2pi_manko

E =pl_walues

-

14

— Capacity Flanning
[~ Table Row Count

[ Column Average Width
[T Colurmn Percent hu

XW‘?H¢|

4  Back HQ Hm\ E‘

6. Continue through the wizard to select layout styles and other preferences.

Embarcadero Technologies

42



Tutorials: Documenting an Existing Database

s

ER/Studio Data Architect can infer Referential Integrity when none is
declared in the database. Clicking the options below will create
relationships between entities in your diagram.

[ Infer Primary Keys
[ Infer Foreign Keys from Indexes
[ Infer Foreign Keys from Names
[~ lgnore Case
[ Infer Domains (Create a Domain for each Column)

ER/Studio Data Architect can ensure all objects referenced by those
you've selected for reverse engineering are also induded.

[¢ Reverse Engineer View Dependencies

[+ Reverse Engineer Other Dependencies (e.q. Procedures,
Triggers, etc)
Select the Initial Layout Option

EE Circular E] Orthagonal _!‘_{I Tree
W Hierarchical il Symmetric

Select the Logical View Parser Option
[~ Use Physical Parser

x;mu”? udp]

¢ w3

Reverse Engineer Wizard - Page 5 of 5

What type of Physical Model is this?
(@ Relational ( Dimensional

’ Select external naming standards template for logical

| ]

} [+ Create custom datatypes for unsupported types

|Microsaft SQU Server 2005 (system) |

} Summary of Selected Objects |All |

Dbject Type | Dwner | Dbject Name |

Table |dbo | MSreplication_options

Table |dbo | spt._fallback_db

Table |dbo | spt_fallback_dev

Table dbao spt_monitor

Table | dbo | spt_values

b Save Settings for Quick Launch? Save As ... |

X Concel || P Hob

* Back iv Hegt '# Emizh |

4
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7. Click Finish and ER/Studio Data Architect reverse engineers your database!

Once reverse engineering of your database is complete, we will generate a complete
HTML report of the database for others in your organization to review.

8. In the Data Model Explorer, select the Physical Main Model.

9. Choose Tools > Generate Reports.

) ER/Studio Data Architect Report Wizard - Page 1 of 4 =N EoE ==

’ Benesate HTML or RTF file
Select report type
(& HTML report (" RTF report

’ Feport Directony
Select directony for report

—]_.({ | | C:\Users\Embt\AppData)\RoamingEmbarcadero)\ERStudia\Rep _I

i
2 Wizard Quick Launch

Select Settings File
[ use file-based Quick Launch settings.

[Rore ~ | |

(% Settings Only  ( Settings and Objects

’ Do you want to invoke an Editor to view the report after it iz generated?

" Yes  No
b Bxuﬂe HTHML report using performance-enhanced version for large data
mi 3

[ use enhanced version.

‘x Lancel “gﬂ Help & Back Mext b ¥ Finich y,

10. On the first page of the wizard, for the report type, select HTML.
11. On page 2, click Select All in both areas of the Diagram tab.
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BER.media Data Architect Report Wizard - Page 2 of 4

’ Please select the objects in pour data model that pou'd like to generate a
report for

Diagram |Daia Lineagel Data Dictionary | Procedures Funcﬁnns| Triggarsl Securit, DE

W = % branl - H W Diagram -
¥ =l Logical = ¥ Mamea =
| W —HZ§ Main Model ¥ Description ™
W =5 Entibes F¥ Author
l_,.,J ! ¥ = Address - Company
= 3 Mo Address.. — Vearsion
| 7 = AWBuild._. ¥ CopyrightOwner
= = BillOfMa... - CopyrightYear
¥ ) Contact ¥ Bound Atachment
2 ol Contac! =l ¥ Model
3 M Contacl.. — Mame
T Ho Country.. i Database Platform
¥ <oy Country . - Model Notation
¥ =y CrediCa. F¥ PreSaL
[ - Culture e ¥ PostSOL >
Select Al | Unselect Al Select All I Unselect All

X Concel |'? Help | '4- Back | Next -}| b Einish

12. Click Select All in both areas of the Data Dictionary and the Procedures tabs, and then
click Next.

@Note: The tabs available on page 2 depend on what objects are supported by the
database platform of the selected model. Some databases support more database
objects than Microsoft SQL Server 2005, such as Oracle11g and IBM DB2 LUW 9.x for
which there are also tabs on this page for procedures, functions, triggers, packages, and
tablespaces. If the model was previously denormalized, a Denormalization Mappings
tab would also appear.

13. On page 3, in the Submodel Image Options area, click Select All.

N Tip: In the Logo and Link Options, you can choose to replace the ER/Studio Data
Architect default Embarcadero Technologies logo in favor of your own corporate logo
(and Hyperlink).
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€ ER/Studio Data Architect Report Wizard - Page 3 of 4 T e

Select HTML generation options
Submodel Image 0 ption:

=] & -
Submodel images will be generated in the :: : B braLrQ ical
report for the selected submodels. - ' E"Iain Madal =
Individual Zoom and Quality seftings can be r Human Rescurces |
\ selfor each submodel by selecting itin the r Person
0 e, - Production
O Purchasi
H
(|} Syste ¥
- OO, ! 10 (A - yalom
Qualty ——— 7% SelectAl |  UnselectAll |

Logo and Link Options

Image file | Browse..

Newlink | Report Title

Description  [SQL Server 2005 Sample Model

Repont Formatling

Object Definition Formating: @ Preserve formatiing ™ Wrap text
Object Mote Formatting: @ Preserve formating " Wrap text
Explorer Tree: [ Include owner in ree

X Cancel | %  Help ‘ ¢ Back | E MNext }i 45 Finish

Because HTML formatting can be included in object definitions, you can also choose to
preserve the formatting specified on the Definitions tab of the various object editors.

14. Click Next to advance to Page 4 of 4, and then click Finish.

ER/Studio Data Architect then begins the report publication process and launches the
default browser so you can review the report.

15. Finished!

Start navigating the report via your browser. Navigation will perform exactly as it does when you
are using ER/Studio Data Architect! Expand the tree to find Model Image and click on it (see
below). You will see a read-only version of your data model (as seen below). Use the Explorer to
navigate to any metadata you want or select the entities and relationships in the model image
to jump to their information.

Conclusion
In this session, you learned how to:
e Connect to and reverse-engineer an existing database with ER/Studio Data Architect.

e Document a database in seconds by using ER/Studio Data Architect’s automatic HTML
documentation publication facility.
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See Also

e Tutorial:Documenting Data Lineage

e Generating RTF and HTML Model Reports

e [ER/Studio TS documentation]
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Tutorials: Documenting Data Lineage

The Data Lineage feature of ER/Studio Data Architect enables you to document the movement
of data from point A to point B (and any intermediate steps in between). This movement is
sometimes referred to as Extraction, Transformation and Load (ETL). Points A and B can be
anything from flat files, high-end databases such as Oracle and DB2, XML, Access databases,
and Excel worksheets. This is sometimes referred to as source and target mapping. A model
produced in ERStudio can represent any point along the way. Data Architects need the ability
to specify the source or target of data down to the column-level. Along with the metadata that
defines the source and target mapping are rules for how the data is manipulated along the way.

The next section will help you document the data lineage of your systems.
It is comprised of the following tasks which correspond to the general ETL workflow:

e Creating a Data Flow

e Creating a Data Movement Rule

e Defining External Source and Target Systems

e Creating a Data Lineage and Transformation Visualization

See Also

e Tutorial:Creating a Data Flow

e Data Lineage Workflow

e Documenting Data Extraction, Transformation, and Load
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The Data Flow organizes and encapsulates one data transformation and the source tables and
columns used in the transformation to produce the target data. Multi-tiered mappings are
possible and there can be multiple transformations involving different columns between two
tables as illustrated below.

q GIMDB.DML1 - Data Flow Model View: Broker * ]
i | Dat; LinT:Tge #| | Broker Investment
D@..ﬂ'aﬁmﬁ F Broker Id (PK) F Investment Id (PK)
b Transformations !H i Bl U ALY % Investment Type 1d (FK)
[‘}ﬁgﬁ Transfarmation  Broker Last Name & Investment Vendar
EHE Inputs “ Broker First Name ¥ Investment MNama
~— Braoker [Logicall V Broker Middle Initial & Investment Unit
Broker First Mame !,ﬂManagE”d (Fi) & Investrment Duration
Eroker Last Mame ¥ Years With Firm

Inwestment [d
4 Outputs l l

§jiTransformation3

~ Broker [Lagical] u~Broker.Broker Last Mame

| BROKER_DIM [GIM_D/) i~ Broker Broker First Mame
| Investment (Logical) U~ |nyestment.nvestment Id
L #; Shapes
B Data Movemant Bulss ~4BROKER_DIM.BROKER_MAWME
ﬁ [ata Retention [Archive Rulg]
ﬁ Upzert (Update Rulg] l
=H % Data Sources
Local Models E BROKER_DIM
Logical ¥ BROKER_ID (PK)
| Entitiez (10] “ BROKER_MAME

_—_. T
Broker W YEARS_WITH_FIRM
| Broker Dim

| Client
Client Fact

Create a Data Lineage Data Flow

1. Choose File > Open and select the GIMB.DM1 diagram in the Sample Models
directory.

2. Click the Data Lineage tab at the bottom of the application window.

You are prompted to create a Data Lineage Data Flow.

ER/Studio Data Architect & 3 X

L ] "_n. There are currently no Data Lineage Data Flows available ta display, Would wou like ko create ane now?
[

Yes Mo |

3. Click Yes.
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If this is not the first time you click the Data Lineage tab after opening a diagram, from
the Data Lineage Explorer, right-click the Data Flows node and then click Create Data
Flow.

If you would like to keep your version of GIMB. DM1 unchanged, 'save as'a different
filename before proceeding past the Undo/Redo warning dialog.

4. Enter a data lineage data flow name and then click OK.

Add Data Lineage Data Flov

M arne: |Brnker

|q" ak | |x Cancel |

@Note: The name that appears in the diagram title tab at the top of the application
window is appended with: data flow name, when you click a task in the Data Lineage
explorer, such as GIMDB.DM1 - Data Flow Model View: Broker*.

1 JFGIMDE_80_testing.DM1 - Data Flow Model View: Broker * ]

M Datalineage
—HHa  Data Flows BROKER

i Broker ® BROKER_ID (FK)
i Client Load

% OFFICE LOCATION 10 7FKD

The Data Flow has been created.

See Also

e Tutorial:Creating a Data Movement Rule

e Data Lineage Workflow

e |Introduction to Data Lineage
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Tutorials: Creating a Data Movement Rule

Data Movement rules describe how source and target tables and entities are related. You can
relate source data to one or more tables and entities in the same model, the active diagram, or
to tables imported from external systems. The rules defined here are used at the table level on

the Data Lineage tab of the entity and table editors.

Create a data movement rule

1. On the Data Lineage tab, right-click Data Movement Rules and choose New Data

Movement Rule.

-

B | Data Movement Rule

E@m-‘

Rule Information ] Binding Information

Rule Hame: |Backup

& 0K

Rule Type: | &rchive Fule

Archive Rule
Backup Rule
Create Rule
Deletion Rule
Recovery Rule
|Ipdate Rule
Boolean

D ate

Esternal File Path

Rule Text:

x Cancel

T Hep

[t

2. Complete the Data Movement Rule editor as required and then click OK to exit the

editor.

N\ Tip: Once created, you can edit the Data Movement rule by double-clicking it to

launch the Data Movement Rule editor.

The following describes options that require additional explanation:

Embarcadero Technologies

51



Tutorials: Creating a Data Movement Rule

Rule Information tab

e Rule Name: Enter a name that indicates the operation and objects acted on, depending
on the specifics of your binding definition.

e Rule Type: Select a generic movement rule type that best describes the data
movement.

e Rule Text: Document your data movement plan here, perhaps adding instructions or
contingency plans.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this attachment. You
can override this setting using the Data Lineage tab of the entity or table editor.

See Also

e Tutorial:Defining External Source and Target Systems

e Assigning Model Data Movement Properties

e Data Lineage Workflow
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Tutorials: Defining External Source and
Target Systems

Data sources can originate from models in the active diagram (local models) or from external
sources that are either imported into the active diagram or created on the Data Lineage tab. A
data source can be imported from *.dmT files, *.dt1 files, database or from SQL files, flat files,

and other common application files. The following describes how to import metadata from an
external source.

@Note: Source data imported through the Data Lineage tab only includes information such
as table and column name, datatype, nillability, primary key, and column definitions. To obtain
more details, reverse engineer the database or import it into ER/Studio Data Architect using the
Metadata Wizard.

Import external source or target data
1. From the Data Lineage tab, expand the Data Sources node.

2. Right-click Other Sources and choose Import New Source.

E® Import Source - Page 1 of 5

Welcome to the Data Source Import Wizard!

Please select where you would like to import the source
metadata from:

(¢ From a model it anatber DT file

| =

" From a Repozitory bazed D1 file

" From a SQL file

‘ " From a live database

U } Comparison Quick Launch

Select Settings File

[v Uze file-bazed Quick Launch settings.

| Load file. ..

" Settings Only  * Settings and Objects

|x Cancel | ’ ? Help ]
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3. Complete the Import Source wizard as required and then click Finish to import the

source.

The new source will appear under the Other Sources node.

The following describes options that require additional explanation:

Page 1 - Please select where you would like to import the source metadata from

From a Repository based DM1 file: Lets you obtain source from data models and
Named Releases managed within the ER/Studio Repository. When you select this
option, ER/Studio Data Architect opens the Repository Operation Status dialog box and
the Get From Repository dialog box. This process connects to the current Repository
Server defined in the Repository settings. The Import Source wizard automatically gets
the diagram.

From an SQL file ER/Studio Data Architect imports the SQL file.

From a live database: If you select this option, a page appears where you can select the
database and connection type. The connection type can be either ODBC or
Native/Direct Connection. For information about connecting to databases, including
troubleshooting information, see Connecting to Database Sources and Targets.

Comparison Quick Launch: The Compare Quick Launch data is saved as an *.rvo file.
For information on using the Quick Launch option in the wizard, see Saving and Using
Quick Launch Settings.

Page 5 - Results

Current and Target Model Display Grid: Between the Source and Target models is a
Resolution column. The default merge decision is Merge the data into the new source
file. You can click on any item in the Resolution column to enable the decision list. If you
want to change the decision, click the list and then click the new resolution. When you
change the default resolution of an object, the decisions of their dependent properties
and objects are automatically updated. You can also click the category folders, like the
Tables Resolution column to change all the decisions for all the underlying objects in
that object category. And, you can use the CTRL key to select multiple items, and then
right click to enable the decision list.

SQL Difference: To enable the SQL Difference utility, select any difference that is a long
text field, such as a Definition, Note, or DDL, and then click SQL Difference to view the
differences between the SQL of the models. This utility only allows you to view the
differences; difference resolutions are performed on the Results page of the Compare
and Merge Utility.

Filter Report on Results: Create a report of the source content and your chosen
resolutions. You can choose to create an HTML or an RTF report.

N\ Tip: You can modify the default display using the options at the bottom of the
page.
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See Also

e Tutorial:Creating a Data Lineage and Transformation Visualization

e Importing a Model from External Metadata

e Attaching External Documents to the Data Model
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Tutorials: Creating a Data Lineage and
Transformation Visualization

1.

To create the data source or transformation input tables, expand Data Sources > Local
Models > Logical > Entities and then drag and drop the Broker and Investment
tables onto the Data Lineage window.

To create the data target or transformation output tables, navigate to Data Sources >
Local Models > GIM_DW and then drag and drop the Broker table onto the Data
Lineage window.

q GIMDB.DML1 - Data Flow Model View: Broker * ]

B¥ DataLineage ~ Broker Investment

[i]-@‘ Diata Flows

{3 Broker

[i]-@ Transformations
= :
Y] ;ransformahonS

FHE Inputs

~— Braker (Logical]
Broker First Mame

Broker Last Mame

Components
= Bioker [Loaical)
| BROKER_DIM [GIM_DWw]
1 Investment [Logical]
—d_,\ Shapes
Data Moverent FBules
ﬁ [ata Retention [Archive Rule)
ﬁ Upzert (Update Rule)
Data Sources
Local Models
Logical
1 Entities [10]
—1 Broker
| Broker Dim
| Client
Client Fact

& Broker Id (PK)

% Office Location 1d (FK)
<7 Broker Last Name

< Braker First Narme

< Broker Middle Initial
L Manager Id (FK)

& Investment Id (P

L |rvestrnent Type 1d (FK)
< Investrment Vendor

< Investment Name

< Investment Unit

< Investrnent Duration

< Years With Firm

P S

. Transformation3

5~ Broker Broker Last Mame
U~ Braker.Broker First Mame
= rvestment Investment 1d

~4BROKER_DIM.BROKER_MAME

E BROKER_DIM

& BROKER_ID (FK)
< BROKER_MAME
o YEARS_WITH_FIRM

To obtain the Transformation Insertion tool, right-click an empty space in the Data
Lineage window and then click Insert Transformation.

To insert the transformation, click in the Data Lineage window between the source and
target data sources and then right-click to drop the Transformation Insertion tool.

Reposition and resize the transformation object to suit your needs.

Right-click an empty space of the Data Lineage window and then click Insert Data
Stream.

Embarcadero Technologies 56



Tutorials: Creating a Data Lineage and Transformation Visualization

N\ Tip: Transformation and Data Flow tools are also available on the toolbar. Hover
the mouse over the tools to find the tool you need.

7. Click an input and then click the transformation object. Repeat as many times as
necessary to link all the inputs to the transformation object.

8. Click the transformation object and then click an output.

4 JFGIMDB_80_testing.DM1 - Data Flow Model View: Broker * |
## Data Lineage A | FEEKER INVESTMENT
E—@ Cata Flows NG # INVESTMENT_ID (P
D Broker % OFFICE_LOCATION_ IO (FK) -
i Transformations o CLRGLER RS S !; ::Egmi::{;;i}:i Fro
Components 7 BROKER_FIRST_NAME o INVESTMENT _MAE
_ » BROKER_MIDOLE_INITIAL - =
FHa® Client Load S MANAGER 1D (FK) b INVESTMENT_UNIT
et Client Load 2 & YEARS_WITH_F IRh S RT3 e
[—:I-@‘-ﬁ Data Movement Rules \ ‘/
—Q D ata Retention [Archive Ao : .
—Q Upzert [Update Rule) [ wyTransfermation1
=hiY Data Sources l'np'-ftii I
il Lacal Models BROKER.BROKER_ID
| Logical
Entities [10]
E_G:M_DW BROKER_IDO (P
[ Tables 4 P ERDKER:NAE.HI?
# GIM_OLTP 3 YEARS_WITH_FIRf

— Tahles [B]
Wiews [£] el

\ Tip: If the Inputs and Outputs do not display in the diagram as they do in the
illustration above, choose View > Diagram and Object Display Options >
Transformation and then click Inputs and Outputs Columns.

9. To define which columns should be used in the transformation and any transformation
rules, double-click the new transformation to open the Transformation Editor.

10. Complete the Transformation Editor as required and then click OK to exit the editor.
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E * Transformation Editor l | |
Mame: {Brokﬁr Name| Type: <unspecified> _:j
Columns 1 Definition 1 Data Movement Rules Attachments ]
| Inpus: M‘] Outputs: A_J

Parent Model i Parent Obj... 3 Attribute/Column 1 Data Type 1 Definition 1

Parent Model j Parent Obj... J Attribute/Column ] Data Type 1Deﬁnit’on ]

Logical |Broker
Logical

Logical

|Broker Last Mame |VARCHA... |
roker First Name |VARCHA,
| Investment Mame |VARCHA... |

GIM_Dw

_|BROKER_DIM |[EROKER_MNAME _|varcharf... | |

Z  Hebp

[qﬂ" oK J [x gan-:el]

LS

11. You are done! Now you can more easily share your ideas with your colleagues!

N\ Tip: Once the Data Flow is created, you can double-click it to change its name, or double
click a transformation or component to change its properties.

The following describes options in the Transformation Editor that require additional
explanation, for more options that are not required for this tutorial, please read the User Guide:

Columns tab

e Inputs: Click the ellipsis (...) button to choose the inputs to be transformed in this task.

e Outputs: Click the ellipsis (...) button to choose the outputs resulting from the

transformation.

Definition tab

e Business: Describe the transformation for your audience.

e Code: Enter the code that will perform the transformation, such as a SELECT statement,
or a VBBasic or Java Script function or procedure.

Data Movement Rules tab

These are the rules from the Data Movement Rules node of the Data Lineage Explorer.
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@Note: You can delete or edit an input or output column by double-clicking the
transformation in the Data Lineage window, clicking the ellipsis in the Transformation Editor
and then deselecting the column you want to remove.

Attachments tab

Bind an external piece of information or attachment to the transformation. You can also remove
an attachment from an object, override the default value of an attachment, or change the
position of a bound attachment. To override the value of the attachment you have moved to
the Selected Attachments grid, double-click the Value field of the target attachment.
ER/Studio Data Architect opens the Value Override Editor or a list, depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data
Dictionary and must be applied to the default before they will display on this tab.

See Also

e Tutorial: Diagram Navigation and Aesthetics

e Documenting Data Extraction, Transformation, and Load

e |Introduction to Data Lineage
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Tutorials: Diagram Navigation and
Aesthetics

To assist with the creation of presentation-quality diagrams that are easy to navigate and are
aesthetically pleasing, ER/Studio Data Architect offers progressive diagram Auto Layout and
Navigation utilities that also help you to clean up complex diagrams. Modelers should spend
time solving complex database or business data model problems, not forcing boxes and lines
to look a certain way.

Navigating the Diagram

To demonstrate some of ER/Studio Data Architect’s layout and navigation utilities, we will
import a sample SQL script provided with ER/Studio Data Architect.

1. Close any files you have open.

2. Choose File > New.

# ER/Studio Data Architect

Create a Hew Model

%) " Draw a new data model

@ (" Rewerze-engineer an existing databaze

% * |mport Model Fram: |EF File ﬂ

ER= File
Euternal Metadata

o

3. Select Import Model From: and then in the import list, click SQL File.

f Import ..
X Cancel
% Hep

@Note: The ERX File choice enables you to import ERwin 3.5.2 ERX files. Selecting
from External Metadata launches the MetaWizard to import from alternative sources.

The 'Import Database SQL File dialog appears:
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. 5
#% Import Database SQL File - CoxT
= - [

Select a Database SQL File
I C:\Program Files\Embarcadero\ERStudio Data Archit @
} Select the target database platform

|1BMDB2 UDB for 05/350 9.x ¥

ER/Studio Data Architect can infer Referential Integrity when
none is dedared in the script, Clicking the options belaw will
create relationships between entities in your diagram,

[ Infer Primary Keys

[ Infer Foreign Keys from Indexes

[ Infer Foreign Keys from Names [T lgnore Case
[ Infer Domains (Create a Domain for each Column)

Select the Initial Layout Option

@ Circular E | Orthogonal | Tree
I_@ Hierarchical }f | Symmetric
What type of Physical Model is this?

' Relational
" Dimensional

Select the Logical View Parser Option
[~ use Physical Parzer

} [V Create custom datatypes for unsupported types

|16M DB 2 UDB for 0S/390 9.x (system) |

4. To the right of Select a Database SQL File click the folder icon, click Sample DDL
(DB2 7.x for ©S390).SQL, and then click Open.

o The full path to this file is:
For Windows XP:
C:\Documents and Settings\<user>\Application
Data\Embarcadero\ERStudio\SQLCode
For Windows 8, Windows 7, and Windows Vista:
C:\Program Files\Embarcadero\ERStudio Data Architect XEA\SQLCode

5. Inthe Select the target database platform list, click IBM DB2 UDB for OS /390 9.x.
6. Click OK.

Finished! Once the SQL Script is finished importing (as depicted below) the following items will
assist you in leveraging a variety of Auto Layout and Navigation Features.
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Layout and A lignment Toolbar Foom Window

Data Model Explorer Overview Window

88 rnstadin Naka Arehitert - [Repn Sewuer: B [IT'F

)

=4 IBM DBz 05Z92.0M"
= I' Lnul |

E{ & Wain Model T

Enkaz 0 |
Adorasz ==
AdzressT pe !
MaBlidveon | -i
Co~tactZiaciCad et
CortackTuza
E-:-,n wF coion
l:-:-,n WF cgionC_m:
Erc-:ilI:al-:I
Eutulc

|_| Cu Iemgs F.
o, @o. | 9o ﬂw. R |«

e Layout and Alignment Toolbar: Use any of the four Auto Layout styles to change the
layout of the diagram with the click of a button. The auto layout styles are all entirely
customizable styles. You can also customize the diagram layout via the Layout Properties
pages that can be launched by clicking Layout > Layout Properties. In addition, you
can have multiple layout styles in a model. Select some object and then choose the
layout style. If you don't have any objects selected when you click the layout button, the
layout style chosen will be applied to the entire model.

o Data Model Explorer: Click on any object in the Data Model explorer and it will
automatically be selected in the diagram and focused in both the Zoom Window and
Overview window.

e Overview Window: Use this window as a thumbnail of your model to pan the entire
model or zoom in and out. It can also pan and zoom the diagram if grabbed or sized. If
the Overview window is not already visible, press F9 to activate it.

e Zoom Window: Use this window as a magnifying glass to enlarge any diagram objects
under your mouse cursor. You can also press SHIFT+F8 to freeze the zoom window to
keep a single object frozen while you continue to pan around the diagram. If the Zoom
window is not already visible, press F8 to activate it.
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Diagram Aesthetics

One of the tremendous benefits of building data models is the wide range of audiences that
can realize value from them. Part of this relies on what information is displayed in the diagram.
Depending on the audience you may want to limit or expand what is displayed. For example,
developers may benefit from looking at a model that displays data type, null option, and unique
and non-unique index information, while business analysts may just need the entity name and
the definition. ER/Studio Data Architect offers many display properties that can be customized
exactly for this purpose.

Continuing with the previous section, we will use the DB2 model that was built to demonstrate
some of the ways to customize the appearance of the model.

We will use the Diagram and Object Display Options dialog on the Diagram toolbar to further
customize the view of the logical and physical models.

e You can use the Colors & Fonts tool to customize the look and feel further of each
model.

Setting the Logical Model Display

1. Select the logical model and then on the Diagram Toolbar, click the Diagram and
Object Display Options tool.

Diagram Toolbar

[cldy & & QW < | BERIR A E
4!

|Diagram and CObject Display Gptinns|

2. Inthe Diagram and Object Display Options dialog, click the Entity tab, and then in the
Display Level area, select Entity.

3. Click OK.

-

| RGST_CLNT

|
|
|
|
|
|
|
|
E\ | FRIWEK_ACTUL

FHCL_TRANS I
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@Note: Only entity names are displayed for each entity. You may also want to re-layout the
diagram since the entity sizes have changed.

Setting the Physical Model Display

1. Select the physical model and then choose View > Diagram and Object Display
Options.

2. In the Diagram And Object Display Options dialog, click the Table tab.

Diagram And Object Display Options W [ (=] m]
Diagram  Table 1 Relationship i Wiew 1 Schema Object Drawing Shapes 1 Securty Objects 1 Apply To i
| ¥ Shadow | I Datatype

" Logical Attribute Order I Dok
{1 T Mull Option
| % Physical Attribute Ordering [l I Atemate Key
| 7 Primary Key Only || T Inversion Entry
e m Keys - Ower ;
|| I Display Entity Names [ Defaul
" Table || " Display Atibute Names [ Name Compartmert
¢ Defirition [ Hidden Attibutes Madcer [~ Wrap Name
1 T Indexes [” Data Security
" Note I i e
1 [~ Atachments I Data Security Value
{1 [T Abtact L sl [~ Column Bitmaps
v o | [Xowd| [2 ue |

3. Inthe Display Level area, select Physical Attribute Ordering.

4. Inthe Available Options area, select the specific properties you want to display.

5. Click OK.

The model should now display more details for the physical model, as seen below.
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DBE2OWINSS EDB_SPEC (EDB_SPEC)

FPESFEC_ID (FK)  CHAR[M1)  NOT HULL [AK1:2)
WCTGRY_ID SMALLINT  NOT NULL
‘W ABBR CHAR(E) MOT MULL

S LAST_UPDT_DT TIMESTAMPNOT NULL

WEYS_MAME CHAR(2Z) MULL {AK1:1)
PSHORT_MAME  CHAR[2Z) NULL
WPLONG_MAME  CHAR{120) HULL
HrRTo2AL
___________________ —!_ BERTOABIK (AK1)
1 -4 -4 1

DB20VWN33 EDB_SPEC_XREF (EDB_SPEC_XREF}

o _JT, —l_—_ T

U— — CZpB20VWINGS.EDE_FRIMWEK_SPEC (EDE_FRMWK_SPEC)

o
& ASSH_TYFE (FK)

F STRT_DT (P DATE

@ LAST_UFDT_DT

TIMESTAMPFNCT MULL

& END_DT DATE
& MIN_CRDNL SMALLINT
@ MAX_CRDML SMALLINT

CHARM1Y NOT MULL (AK1:1)

LONG VARCHAR NOT NULL
SMALLINT NOT NULL (AK1:2)
TIMESTAMP MOT MULL [AK1:2)
DATE NOT MULL
DATE NOT MULL
TIMESTAMP MOT MULL

E FRTOTAIK
'#FRTOTEIX (IE1)
-

|
- - -
SMALLINT  NOT NULL {IE1:2} : -";ﬂEFEu_L FK)
MOT MULL {IE1:2) | -) DATA
MOT MULL {IE1:1 I @ SEQ_NUM
NOT NULL {IE1:4 : & LAST_UPDT
| @ STRT_DT
| i
MOT NULL | _)EM:_E:T
MOT MULL : @ CREAT_DOT
Mo MO [ B DT ALK (AKT)
|
! 1
! 1
! 1
! 1
! 1

@Note: Since the sizes of the objects changed, you may want to change the model layout

using one of the ER/Studio Data Architect advanced layout engines. You can also customize the
default display properties for new models by choosing Tools > Options, and then selecting the

desired options on the Display tab.

Conclusion

In this session, you have learned how to:

e Import an SQL file and allow ER/Studio Data Architect to automatically create a diagram.

e Use a variety of auto layout and navigation tools to enhance the aesthetic experience of

the diagram and to improve the data model navigability.

e Customize the display of both the logical and physical models.

Thank you for completing the tutorials section. Please visit the User Guide for more examples

and information on using ER/Studio Data Architect.

See Also
o Wiki Home
e User Guide
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