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Before you start
Introducing ER/Studio Data Architect

ER/Studio Data Architect is a visual modeling application used for platform-
independent logical data architecture analysis and design, in addition to platform-
specific physical database design and construction. The powerful, multi-level design
environment addresses the everyday needs of database administrators, developers,
and data architects who build and maintain large, complex database applications
and strive to consolidate, report, and re-use metadata across the enterprise.

The progressive interface and simplicity of ER/Studio Data Architect is designed to
effectively address the ease-of-use issues which have plagued data modeling and
CASE tools for the past decade and more. The application equips you to create,
understand, and manage the life-cycle of mission-critical database designs and
business metadata within the enterprise.

ER/Studio Data Architect is rich and customizable, offering strong logical design
capabilities like:

¢ The ability to spawn many physical designs from a corporate logical design.

Bi-directional model comparison and information synchronization.

e Visual-Basic for Applications API for product customization.

e Powerful DDL reverse engineering and generation.

e Metadata import and export capabilities.

e Datalineage documentation.

e Sophisticated XML, HTML, and RTF-based documentation and reporting facilities.
With Team Server collaboration increases

e Central repository for models

e Checkin/out of models or model fragments

e Version control

And with Team Server Core a web based portal allows a wider audience to exploit
the valuable knowledge in the models

e Publish models

e Business Glossary to support Data Governance

e Data Catalogs to allow users to find data

e Reporting and Analysis to publish useful reports on data

e Collaboration tools to allow the extended team to interact with models

e Subscription to get noftified with data assets change
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Product benefits by audience

e Data Modelers and Data Architects: ER/Studio Data Architect is critical for
organizations concerned with eliminating data redundancy, creating an
enterprise view of data assets, and assisting development with making informed
decisions about how best to reuse elements pre-defined by the enterprise. Its
powerful logical (non-database or technology specific) analysis and design
environment helps to normalize and create an enterprise view of the objects
concerning the data managed by an organization. More importantly, it can
communicate this quickly through powerful reporting and metadata exchange
mechanisms throughout the enterprise.

o Database Administrators and Database Developers: Managing databases is
incredibly difficult without a blueprint or roadmap to understand important
object dependencies. ER/Studio Data Architect's round-trip engineering
capabilities including database reverse-engineering provide database
administrators (DBAs) or developers with important physical data models in
seconds. These models are powerful and efficient change management
platforms, allowing users to update a model with the required changes
necessary at the database and automatically generate DBMS-specific,
syntactically correct, alteration or database DDL.

e Business and IT Managers: ER/Studio Data Architect's robust reporting facilities
allow you to deliver critical information about designs to the enterprise in
seconds. This heavily leveraged and beneficial capability of ER/Studio Data
Architect allows users to provide, in literally seconds, clear, easily navigable and
safe-to-distribute documentation about a database or enterprise data model to
those who need to review it.

e Data Stewards and Data Governance Teams: Allow stewards to manage a
Business Glossary of Business Terms and relate them to data models to ask the
important questions “what information is important to use” and “where is that
informatione”

What's new

For the latest updates on new features, fixed issues, and known issues in this release,
please see the online version at
http://docwiki.embarcadero.com/ERStudioDA/185/en/What%27s New.
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Installing IDERA ER/Studio Data
Architect

This section will help you ensure your environment meets the technical requirements
and helps you install ER/Studio Data Architect.

You can download a 14-day trial version of ER/Studio Data Architect, from
https://www.idera.com/er-studio-data-architect-software/freetrialsubscriptionform.
IDERA will send you a license registration code by email.

System requirements

Review the requirements before you install ER/Studio Data Architect. Adhering to these
requirements optimizes the performance.

ER/Studio Data Architect Requirements

Hardware Processor Dual core or higher
RAM 4GB
Disk Space 2.5 GB
Operating System Any of the following:
e Windows 7
e Windows 8.1

e  Windows 10

Software To use an Open Database Connectivity (ODBC)
database as a data source, install the ODBC driver on
your client computer.

To connect to the DBMS using native connectivity,
install the native client libraries available from the
DBMS vendor.

Privileges Local administrator privileges (required for installation
only.)

Appropriate permissions are required to reverse or
forward engineer directly to or from a database.

IDERA, Inc. 7
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Installing ER/Studio Data Architect

Tip We recommend to have installed most current version of both,
ER/Studio Repository and ER/Studio Data Architect, to ensure
compatibility.

Note It is not possible to install the xé4 bit version where a x32 bit version is also

installed. You will need to remove any previously installed x32 bit
versions of the software.

Log on to Windows with local administrator privileges.
1. Start the ER/Studio Data Architect installation program.
2. Walk through the installation wizard following the onscreen prompts.

The following provides additional information for some options that you can
check after the installation:

o You can change the notation setting. Go Tools > Options from the
ER/Studio Data Architect Main menu, and then click the Logical or
Physical fab where you can choose the notation type.

o By default, ER/Studio Data Architect installs shared directories and
application files such as the DatatypeMapping, Macros, and Sample
Models directories in the following location:
C:\ProgramData\IDERA\ERStudioDA_x.x. If you prefer to store these files in
another directory after installation, follow the procedure in Changing the
Location of Shared Files.

o For step-by-step instructions on how to use ER/Studio Data Architect, see
the Tutorials section.

Additional Notes

For silent installations, launch the installer with commands adding —q to the installer:

installer.exe —-qg

Also, you can see a percentage bar instead of —q if you set a —passive:

installer.exe -passive
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Upgrading from previous versions

Use the following checklist to ensure ER/Studio Repository is correctly upgraded.

Upgrade checklist

Download ER/Studio Enterprise Upgrade. To download the most current release,
go to https://www.idera.com/er-studio-data-architect-
software/freetrialsubscriptionform.

Review the ER/Studio ReadMe. For the most current installation and usage
information, see the ReadMe at
http://docs.embarcadero.com/products/er_studio/.

In case you need to upgrade Team Server/Repository to match the features
available in your version of ER/Studio Data Architect, see the Team Server and
Repository Installation and Upgrade Guide located at
http://docs.embarcadero.com/products/er studio/.

Note

This procedure is for ER/Studio Enterprise installations only, which include
the Repository. When you upgrade ER/Studio Data Architect, you must
also upgrade ER/Studio Repository to correspond with the same build
date as ER/Studio Data Architect.

License Enforcement: When working with the Repository, all users must use the same
license type. ER/Studio now enforces this rule by marking the Repository as an Enterprise
Team Edition Repository when a user with an Enterprise Team Edition license logs in.
Subsequent log in attempts by users with a non-Team Edition license are denied.

Preparing to upgrade the Repository

User preparations

1.
2.

Ensure you have backed up all your .dmi1 files.

Check in all your diagrams and objects. If you try to check in a file from the
previous version with the same name as a current file, the current file will
become corrupted.

Rename all local copies of Repository diagrams in the active file directory as
follows:

a. Choose Repository > Options.
b. Make note of the Active File Directory.

c. Switch to the Windows Explorer and rename all the diagrams in the
Active File Directory.
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Upgrades from ER/Studio Repository 6.x/7.0

With the release of ER/Studio 2016, the Repository is combined into a single installer and
database implementation with Team Server. For information about the upgrade of
Repository versions 6.5 through 7.0 to Team Server 17.0 and later where only the
Repository is being used, see the ER/Studio: Upgrading from Repository (v6.5-7.0) to
Team Server x.x.x at http://docs.embarcadero.com/products/er studio_team_server/.

Important notes
e Always back up the Repository database before upgrading.
e You can install both the current version and an earlier version of ER/Studio Data
Architect on the same workstation.
See also
e Release Notes
e Installing ER/Studio Data Architect

e Licensing
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Tutorials

The tutorials are intended to help you get started using IDERA’s data modeling and
database design solution, ER/Studio Data Architect.

After completing these tutorials, you'll have the foundation you need to explore the
many features and benefits of ER/Studio Data Architect. You will have learned how to
do the following:

e Create a new data model.

e Work with logical and physical diagrams.

e Leverage productivity-focused features such as powerful reporting engines.
e Use common tasks and commands to make you more productive.

The tutorials are divided into different sessions. Do them all at once or complete them
individually as your time permits.

You can use these basic tutorials as a road map of product highlights, but also to help
you find your own path in exploring ER/Studio Data Architect.

Choose a topic to work with:

e Getting started

e Logical and physical modeling

e Using data dictionary domains to populate new entity

e Establishing relationships between entities

e Creating and working with submodels

e Generating physical models from a logical model

e Denormalizing the physical model

¢ How an entity maps to the physical model

¢ Documenting an existing database

¢ Documenting data lineage

e Creating a data flow

e Creating a data movement rule

e Defining external source and target systems

e Creating a data lineage and transformation visualization

e Diagram navigation and aesthetics

e Data Source Mapping

Once you have started, you can click Help from the Main menu to find many
additional resources that complement and build on many of the activities shown in this
brief guide. Or visit the Contents section of http://docwiki.embarcadero.com.
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Tutorials: Getting started
Interface features

ER/Studio Data Architect has an enhanced user interface that is similar to Microsoft
Windows with infuitive icons.

The graphic below names and describes the functionality of some key elements of the
ER/Studio Data Architect user interface.

For information on enhanced Ul features, please see the corresponding numbers below
or mouse over the image:

ER/Studio Data Architect - Orders - Logical Model View

File Diagram  Insert  Model  Tools  Repository  Macro stye - @ -
k M cut p E—E a5 Sub Model Object Styles ‘ 51 q & pan ¢ cascade i “]
(] 1]+
i@ Copy &” This Object Style ~ = b Navigate Relationships = ile Horizontal ]— 1=l
Select Find Layout Alignment —__ Zoom Window = Diagram/Object
= @ Move | EntityView +  Edresize - & - ( Refresh [T] Tile Vertical  Control = Bvley
Edit Fin Circular Layout it Zoom Window Options

Hierarchical

EmoaTg»=.

Orthogonal Layout

Orders - Logical Model View

Tree Layout

Global Layout

Increment Layout

" Sales Orggr Prgcessing
= Logi
2 MEM Model ‘

EHEY Bill of Mbtegals

—~] Busigest Data Objects
Him Entities [3)
By Attributes (19)
R Keyd(3)
Views
Relafionships (2]
Usey
Roles
Shapes

L0 Comeisdion Tracking

BHEY Customer

EHEY Customer Address

=HEg Main Model Displaps

—~]] Business Data Objects

;,‘1___3 Entities (40)

B Attibutes [279)

L3 Keys(B1)

Views

Relationships (45]

Users

Roles

Shapes e e i it
Data ... a Data.. M#DataL. NMacm < )h

Produc

Layout Properties

<
&
}f Symmetrical Layout
£
b @
&
b4

Product Type ID (FK)

User Count ID (FK)

=19 Product Version Platform ID (FK)
'I‘_ Great Plains ID

<

Done Logical Model Views =0 Entities = 40 Attributes = 279 Relationships = 45

1. Sophisticated diagram auto-layout tools provide single-click clean-up of
diagram objects.

2. Design elements and other often-used functions are dockable for quick access.

3. Data Model Explorer displays information about logical and physical models,
submodels, and nested submodels.

4. Repository object status icons display real-time user access information.

5. The Overview Window lets you navigate large Data Models.

6. The Zoom Window helps you focus on the details of a specific area of a large,

reduced diagram.
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Starting to data model with ER/Studio Data Architect
1. On the Windows Start > Programs menu, choose IDERA > ER/Studio Data

Architect.
2. Choose File > New. As you can see in the Create a New Model dialog, there are
a number of ways to begin modeling with ER/Studio Data Architect:

a. Build a new design from the ground up by drawing a new data model.

b. Build a data model from an existing database through live reverse
engineering.
Import designs from other modeling products such as erwin or SQL files.

You can select an initial layout style for your model before the SQL

Tip
import takes place.

3. Select Draw a new data model, and then select Relational for the model type
before clicking OK.
ER/Studio Data Architect will resemble the image below:

ER/Studio Data Architect - [Model1 - Logical Model View]

File Diagram Insert Model Tools Repository Macro Style ~ 9 x>
E_ &+ + I- +.‘5 Repository Properties }
-
Log Options
In 0 ki Qr.!are v
LogIn Diagrams Data Dictionary Named Releases Repository Administration Business Glossary
DATA MODEL | o)
-
= Logical
#{35 Main Model

Data Model | [l Data Dictionary @M Data Lineage $gMacro | ¢
Logical Model Views = 0 Entties = 0 Attrbutes = 0 Relationships = 0

For Help. press F1
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Tutorials: Logical and physical modeling

ER/Studio Data Architect supports both logical (hon-DBMS or technology-specific)
modeling and physical (DBMS-specific) modeling. ER/Studio Data Architect is designed
to allow organizations the flexibility to analyze and design a business problem or
application logically and generate as many different physical interpretations from the
logical model as required. You can generate multiple physical from the logical model
for the same DBMS (for example, Oracle) or other DBMSs (such as Oracle, SQL Server
and DB2). Generating logical and physical models are discussed in detail in the
following sessions.

Using Data Dictionary Domains to Populate New Entity

Establishing Relationships Between Entities

Creating and Working with Submodels

Working with Business Data Objects

Generating Physical Models from a Logical Model

Denormdlizing the Physical Model

Finding out How an Entity Maps to the Physical Model

IDERA, Inc. 14



Tutorials: Using data dictionary domains to
populate new entity

As instructed in Getting Started, you have chosen to draw a new data model to
begin a logical model from the ground up. Before we begin to add entities, we
will populate ER/Studio Data Architect with some sample domains.

What is a Domain? Domains are simply re-usable Attributes/Columns and are
valuable tools in establishing standards. They allow data modelers to create a
data element once (such as an ID field you require all of your entities to
leverage as its primary key) which has the same data type, definition, rule, and
constraint no matter where the data element is distributed and bound. Read
more about Domains in ER/Studio Data Architect User Guide.

1. Choose Tools > Import Data Dictionary. The Import Data Dictionary
Options dialog box appears.

2. Next to the File Location box, click the ellipsis and browse to the Sample
Models folder, which is located at C:\Program
Files\IDERA\ERStudioDA_X.X\Sample Models.

3. Double-click the Orders.dm1 sample model so that it populates the
dialog box, and then click OK. This model contains a pre-populated,
sample data dictionary.

Note Under Resolve Imported Objects with Duplicate Names, you can
choose between the options to determine how the dictionary
objects are imported. This is important when importing into a
diagram that already has dictionary objects in it.

Once opened, you will see that the ER/Studio Data Architect Model
Explorer has automatically switched to the Data Dictionary tab to allow
immediate drag-and-drop access to domains.

B2 DataDictonary A
= Main
43 Attachments
=4 Attribute Properties
I:% Souce Data
% Target Data
—-,2;\ Entity Properties

.—.12\ General Properties
L% Naming Dictionary

{J Data Security Information

FH=9 Defaults

—H No

—H Space

—H System Date

Ll Zero

3 Rules

FH-9 Reference Values

&8 EMBT Product Set
&g State Codes

{3 Naming Standards Templates
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Now, to add an entity to the Data Model Window, click the Entity tool on the
Insert ribbon, and then click in the Data Model Window to drop the entity.

Tip The cursor will change to an entity symbol once the Entity tool is
clicked, so you can click to drop as many entities on the Data Model
Window as you want.

Right-click to return your mouse to the selection cursor.

Right-click the entity and click Edit Entity to open the Entity Editor. In the Entity
Name field, type Customer, replacing the default entity name, and then click
OK.

In the Domains folder of the Data Dictionary tab, locate the ID domain in the
Numeric Domains folder.

Logical

Zip Code ~
2Zip Code Extension
~H, Audit Domains

C
F Jj Create Date

Jj Created By
[J| Modify Date
Boolean Domains = .
] s stomer

Jj Is Default

jj Is Mandatory

lj Is System Required
Numeric Domains

[} Amount

Extension
ID

Max

Min
Precision
Price
Quantity
Scale

Sequence No
TshlaBawlin

Data Model ﬁ Data Dictionary | @ Data Lineage ﬁua:ro <

IIIIIIIIIIHLEIIII[LJ_E

W

8. Click the ID domain (do not release your mouse), drag it onto the Customer

entity, and then release it just below the entity’s name, which is the entity’s
Primary Key field.

Tip You can edit or rename an entity and insert, edit or rename
attributes by holding down the Shift key and then clicking the
name or attribute. Pressing the Tab key cycles between the
entity’s name, and primary key and non-primary key fields. After
naming the field, press Return to insert a new field.

Tip If you need to zoom in on the entity to read the entity name and
attributes, press F8 to view the Zoom Window, then use the scroll
bars of the Zoom Window to center the entity on the Data Model
Window. Press Shift while rolling the mouse wheel forward to
increase the view magnification. You can use the Pan tool to
reposition the view to better see the entity.
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9. In the entity, double-click ID, the name of the attribute we just created from the
ID domain. This step opens the Entity Editor.

10. In the editor, select the attribute line, and then click Edit.

11. Change the entity Attribute Name and Default Column Name properties to
CustomerlD, and then click OK.

12. Repeat the process in steps 7 and 8 to populate the Customer entity with the
following domains:

o Name and Phone from the Property Domains folder
o Address, City, State, Zip Code from the Address Domains folder.
13. Drop another entity on the Data Model Window and call it Order.

14. Drag the ID domain onto the Order entity’s Primary Key field; change the
Attribute and Column name to OrderlID.

15. Right-click the Order entity and select Comments.

16. Enter some text in the Comments editor, click Add, and then click OK. You can
add comments to any database object in the same manner. This feature is useful
when you want to provide feedback on a model to other users.

17. Save your data model. We will use it in the next session of this tutorial.
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Tutorials: Establishing relationships between entities
1. On the Insert ribbon, click Relationships > Non-Identifying, Mandatory Relationship.

File Diagram Insert Maodel Tools Repository Macro

CIEMTo 25 8¢

Objects Relationships Shapes

m
E

=
I
=
=

Logical |IDEF1x

] b |dentifving Relationship

iy  Non-ldentifying, Mandatory Relationship

= Business D ) on-identifying Optional Relatronship

Enlnhes (2)| &3 One-to-One Relationship

‘[_j g:;:['m' "1 Non-Specific Relationship Customs
C J Attributes (£ 7 # Cust
e Kevs (2l | ) omplete Subtype Cluster -
La ey;m o R & Nam
PK10.0/ == Incomplete Subtype Cluster & Phor
||||| I | & addr
Tip You can change the model notation by choosing Model > Model
Options, and then selecting another notation option in the Notation

areaq.

2. To establish a relationship between Customer and Order, click the parent entity,
Customer and then click the child enfity, Order.

Tip ER/Studio Data Architect supports sound design practices by
automatically propagating the primary key, from parent to child
entities. If there are candidate alternate keys that you want to
propagate to the child, choose all available parent entity keys in
the Parent Key list in the Relationship Editor. Deleting a relationship
removes a non-native propagated attribute. However, if you want
to keep the child columns of the relationship or foreign constraint,
when you delete the relationship check the Make Foreign Keys
Native option. In this case, if the relationship between Customer
and Order is deleted, the CustomerlD remains in the Order entity.
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Tutorials: Creating and working with submodels

Now that you have a general understanding of how to build logical models from the
ground up in ER/Studio Data Architect, it is important to understand how to work with
an important navigation feature of ER/Studio Data Architect, called submodels.
Submodels and nested submodels are designed to break down large, complicated
views of a data model in order to focus on a specific area. An important aspect of
submodels to understand is that any changes made in the submodel, other than layout,
color, display settings, notation or similar items which are unique to the submodel, will
occur automatically in the Main Model view. In other words, change or add an
attribute to an object in a submodel and the change is automatically propagated to its
Main Model counterpart. Close the current sample model, and open a more mature
model. Use this exercise to learn more about submodeling.

1. Choose File > Open.
2. Select Orders.dm1, and then click Open.

3. To preserve this sample model for future use, choose File > Save As and then
save the Orders.dm] file with a new name.

In this exercise, we will modify this new model, so be sure to open the newly-
named file rather than Orders.dm1 before continuing.

4. Collapse the folders in the Data Model tab of the Data Model Explorer to look
like the image below:

Logical

Sales Order Processing

Zl.g Logical
4 5 Main Model |
Oy Bl of Matenalks

-y Commission Tracking
BHEY Customer

HHEY Customer Address
EHEy Main Model Displays
—{:‘ﬂ Business Data Objects
] Entities (40)

F -~/ Attributes (279)
28 Keys (B1)

Views
Relationships [45)
Users

Roles
Shapes

[+ Alternate Key
-y Conceptual
EHEy Datatype
-y Definitions
g Domain
EHEg MNullability

:;ﬂ_ Primary Key

# Payment

g Pricing

EHEy Product

HEY Sales Order

EHAY Sales Order Address
HEg Sales Tax

HEy Shopping Cart

Data Model a Data Dictionary M Data Lineage ﬂl‘da(ro
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In the sample model, there are no physical models. This model includes several
submodel folders that help to describe the logical model:

o Main Model - This is the entire collection of all logical objects in the
sample file. Note the absence of the magnifying glass on the folder icon
which designates it as the main model.

o Bill of Materials through Shopping Cart — These are submodels, which are
smaller collections of entities derived from the Main Model that help to
describe specific areas of the Main Model free from other entities.

o Alternate Key through Primary Key — These are nested submodels, which
can go ‘n’ levels deep and are literally submodels of submodels.

Feel free to explore. Click the plus sign (+) to expand these folders.

Let’s create a submodel with all the objects related to the sample file Address
components.

5. To make a new submodel, navigate to the Main Model and with the CTRL key
depressed, click the objects in the Data Model Explorer, as seen in the following
image.

Logical

Sales Order Processing A
il.-@ Logical

={2% Main Model

—~J Business Data Objects
:-.-:% Entities (40)

#-— Address Component
[+= Address Detail
[+ Address Role
[+ Address Type
¥ =| Address Type Component
iil-.- 5 App Ll_ser _
Zil-.-' | Authonzed Product Discount
T-j Bill of Maternials Address
ZT.-;_'I Commizsion Credit
BHE) Custorner
HHE Customer Address
HHE Custarmer Phone
HHE DB Platfarm
HHE Discount Level
+— Part
+= Papment Detail

+7 Paument Netail Tune

Note Any objects selected in the Data Model Explorer also are selected
on the Data Model Window. You can also select entities by lassoing
them on the Data Model Window.
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6. With the entities selected, choose Model > Create Submodel.

ER/Studio Data Architect - [NewOrders - Logical Model View *]

File Diagram Insert Model Tools Repository Macro
@ m D] D AL Ej Submaodel Synchronization @ Create T3 aﬁ - £
& Q [z XML Schema Generation - =F ‘0 ﬁ'.t
Generate Add Compare Naming Universal Create Mod
Physical Model New Merge Standards Utility Naming Utility 0: Validate Model el Data Flow = Optio
Physical Utilities Sub Model Data Lineage
Sales Order Processing ~
Logical
=43 Main Model
l—i Business Data Objects
[ Entities (40)
+— Addiess Component
¥4 Address Detall

7. Inthe Create Submodel dialog box, type Address Components as the name for
the submodel, and then click OK.

ER/Studio Data Architect creates the Address Components submodel.

Physical Utilities

Sales Order Processing
= Logical
{2 Main Model
Ii]-@ Address Components ;
'f@ Bill of Materials
+HO9 Commission Tracking

i—@ Customer

AUES Mockamnsr Addrase

What do the results look like and how do | navigate to the submodel?

Once created, you will see the new submodel listed in the Data Model Explorer,

denoted as a submodel by the magnifying glass over its folder, as in the case with Bill of
Materials and the other submodels.
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Tutorials: Working with Business Data Objects

The logical model’s primary purpose is to communicate the content of existing data assets
and requirements for new data assets with the consumers of data assets. The entity object
does this as well, but has the job of an intermediary with the physical data model. We also
have the Business Data Object (BDO). This object type allows us to group entities that cover a
particular topic or business concept to make the logical model easier to understand. Use this
exercise to learn more about Business Data Objects.

1. Inthe Logical model, look at the group of entities around the text “Customer.” These
entities all apply to the concept of Customer and can be grouped intfo a BDO.

Customer
Customer ID
Customer
Last Name
Company Name
EMail Address o
Onyx ID |
Is Existing Customer I
Created By
RowTimeStamp
Phone Role
T Phone Role ID Customer Phone
Customer Phone ID
Name .
Customer Address Description 1 = Customer ID (FK)
Customer Address ID Is Default Phone Role ID (FK)
Created By Area Code
Address Type ID (FK) RowTimeStamp Phone
Customer ID (FK) Extension
Label Is Default
Is Default Created By
Created By RowTimeStamp
RowTimeStamp

2. Create a Business Data Object by accessing the Insert ribbon and clicking Objects >
Business Data Object, and then clicking in the model area to place the BDO. Be sure to
put the object near the Customer information for ease of grouping in the next step.

3. Rename the BDO to “Customer” and then resize the BDO so that it covers the following
entities:

a.

o
C.
d
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Customer

. Customer Phone

Phone Role

. Customer Address
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4. Select these entities inside the BDO, and then right click Add to Business Data Object.

E Resize

Add to Business Data Object

Demmira Erem Bricimare 12t Ak

[ETe. g

e Crossisni iy

| e e ] e e

% | Select Relationships ¥
Aotmorped Produo beogy Tt i

- _Qj Create Submodel ...
Aee dwer Auin Ivoted Useam W

yEyT—yy Create Procedure »

Create Trigger >

P— Create View

(==

Apply To Submodel(s)...

v o ! Customer Macros 3
- Add/Remove Macro Shortcuts

Submodel Synch Utility...

b1~
) Compare and Merge Utility...
@
&

Naming Standards Utility...

e —]

— — q“:"‘" - O Generate Reports...
XML Schema Generation...

= Ll

el Jomimee] 96 Cut Ctri+X
j Copy Ctrl=C

5. Open the Business Data Object Editor by double-clicking the BDO. Notice that all the
entities are included in the list.

6. Select the Customer entity, and then click Set Anchor. This states that the primary entity
for the BDO “Customer” is the entity “Customer.”

7. Optional. Set a definition for the BDO as well as a physical name.
8. Opfional. Add attachments.

Tips e You can simplify the diagram by double clicking the minus sign
to hide the entity content.

¢ Whenever you move the BDO, the entities move with it.

e You also can see the BDO and its contents listed in the tree view
on the left.
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Tutorials: Generating physical models from a logical
model

ER/Studio Data Architect can generate as many physical models from a single logical model
as desired. There are many ways to leverage multiple physical models in ER/Studio Data
Architect to help the design process. Examples of how multiple physical models are used are:

¢ Managing change in an existing application: Maintain independent development, test,
and production physical model diagrams that represent specific databases.

¢ Migrating database applications: Use ER/Studio Data Architect as an analysis and
design hub for migrating database applications. Manage a physical model of the
legacy source database application in addition to its new target physical model, which
can be for an entirely new DBMS than originally maintained in the legacy database.

Let’s generate a new physical model from a logical model in order to build a database. We
will use the sample model.

1. Open your version of the Orders.DM1 sample model.

Tip Use the steps shown in the first session o do so.

2. Select the Main Model, and then on the Model ribbon, click Generate Physical Model.

ER/Studio Data Architect invokes a step-by-step wizard to walk you through the process
of generating a DBMS-specific physical model.

| 3 Generate Physical Model - Page 1 of 5 O X
|

Welcome to the Generate Physical Model Wizard!

’ What is the name of the physical model?

’ What type of Physical Model is this?
(+ Relational
" Dimensional

’ What is the target database platform?

! = B

’ Do you wish to validate the model?
" Do not validate
(*+ Validate after generating Physical Model

> Wizard Quick Launch
Select Settings File
[~ Use File-Based Quick Launch Settings

INone j j ‘ | E

(" Settings Only (¥ Settings and Objects

X Cancel ? Help & Back Next Finish
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3. Name the new physical model, DB2 Physical Model, and then select DB2 UDB for
0$§/390 11.x as the target DBMS to generate.

4. Continue through the Generate Physical Model wizard, which prompts several
questions about how you want your physical model generated.

Note The wizard prompts you to customize items such as individual object
selection, index assignment, default storage parameters, resolution
of many-to-many relationships that may be in the logical model,
and naming conventions. In Step 3 of the wizard, you can add
prefixes or suffixes to the object name. For example, it can be useful
to add an indicator of the object type in the name. A DBMS-
specific validation check is also provided in this wizard.

Tip The Quick Launch can store common settings so that an operation
can be reused on this model or on any other models. You can reuse
the settings on another model by choosing the Use File-Based
Quick Launch Settings option when saving the Quick Launch
information on the last page of the wizard.

5. To generate the new Physical Model, on the last page of the wizard, click Finish.

Now that a physical model is generated from the logical model, feel free to
navigate to specific objects via the Data Model Explorer, such as the CUSTMR
table selected here. Double-click and view the physical details of the object
such as DDL, Indexes, Partitions, and Storage.

LY SR Ly e - —

Physical = Table Editor O X
._iéslalis U,[dT' Fracessing Entity Name: | Customer Table Name:  [ustmr Owner: ’—;|
£ ogical _
l__‘fa DB2 Physical Model [~ Physical Only [~ Do Mot Generate

_'al-ga;’l MOdeE] ta Objects [1) PreSQL & PostSQL I Naming Standards 1 Compare Options I Data Lineage 1 Security Information 1 Attachment Bindings
1+ gl
l-_j T:;;s[ima @bt Storage 1 Partitions | Constraints } Dependencies I Capacity Planning } Permissions

B K] Addr_Cmpnt Columns ] DDL I Indexes | Foreign Keys I Definition | Note ] Where Used
:‘:/ :gj:iggle _ Column Domain Datatype Mulls
T T [ 7 Custmr_ID ID INTEGER IDENTITY
1 et 2| Frst_Nme Name VARCHAR(30) NOT NULL
) Addr_Typ_Cmpnnt —
5= app_Usr 3] Lst_Nme Name VARCHAR(30) NOT NULL
__:] Autl:rzd_Prdcl_Discnl 4] Cmpny_Nme Name VARCHAR(30) NOT NULL
__:‘ Bill_Mtls i Emi_Addr EMail Address VARCHAR(20) NULL
_.;.‘ Crmssn_Credt i Onyx_ID Name VARCHAR(30) NULL

(4 Custre | [7]  ts_Exsing_Cusimr s Boolean NOT NULL
B Custm_Addr 8]  cnd By Created By VARCHAR(30) NOT NULL
:—: Custrr_Phn i RwTmStmp Modify Date TIMESTAMP NOT NULL
:—: DB_Pitfim

:—: Discnt_Lvl

T Phn_Role

T Prdet

#7) Prdet_Cnfig

::—: Prdct_Disent

::—: Prdct_Typ

::—:] Prdct_Visn

::—:] Prdct_Vrien_Plfim

m Pit

:—: Pymnt_DH

:—: Pymnt_DH_Typ

:—: Pymnt_Mthd

#== Shppng_Crt f ’ r o &

g 2reenat dF A |/ Ed " Delete Up s Down  OK X Cancel 7 Help
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Tutorials: Denormalizing the physical model

ER/Studio Data Architect comes equipped with denormalization wizards to help you
optimize the physical design once the physical model is generated. The wizards help
automate the process and keep the ties between the physical tables and the logical
entities.

The active, denormalization wizards available depend on which tables are selected in
the physical model when you select Denormalization Mapping. For example, if two
tables that are related to each other are selected, the valid operations would be
Rollups or Rolldowns.

I
I
I
Delete Table I
Rop s |
er—— Table Color and Font Settings b :
pocd mh Align Entities » :
Denormalization Mapping ] '%1 Rollups... I
&P Rolldowns...

T

'ﬁ_ B3 Resize

———————— [ ek Remove From Business Data Object
| L]
|
I
|

Apply To Submodel(s)...

| i
"o L o Select Relationships A o 9
s Radiy J (= G “:
whh A Al i, P . _Qj Create Submodel ... e
o .
= Create Procedure »
' Create Trigger b
1 ~
I Create View  [TTTTmTmomsmsmsssEmesssss=
1
1
1
I
1

AMarrnar 1Y

When only one table is selected, the Denormalization Mapping options Horizontal Splits
and Vertical Splits are available for you to split the table accordingly. The Table Merges
option is available when two unrelated tables are selected.

Let’s walk through an example of a denormalization operation using the generated
physical model in a previous session of this tutorial. We may want to reduce the
overhead on the Custmr table by splitting it info two physical tables, Custmr_East and
Custmr_West. Splitting the table can reduce the query time and provide opportunities
to store the tables at different locations which could further reduce lookup time.
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Before the operation, the Custmr table looks like this:

Custmr

Custmr_ID (PK)
Frst_Nme
Lst_Nme
Cmpny_Nme
Emi_Addr

Ony D
Is_Exstng_Custmr [
Crid_By
RwTmStmp

1. Open the Orders1.dml model you modified and saved in the first session.
2. In the Data Model Explorer, right-click the Custmr table in the Physical Model.
Choose Denormalization Mapping > Horizontal Splits.

Noftice that since only Custmr is selected, the only possible mappings are vertical
and horizontal splits.

The Horizontal Table Split Wizard launches.
4. On Page 1 of the wizard, type 2 for the number of splits, and then click Next.

On Page 2 of the wizard, rename Custmr_1 and Custmr_2 to Custmr_East and
Custmr_West, and then click Next.

| ﬂl Horizontal Table Split Wizard - Page 2 of 4 = | x

that in order for two or more tables to retain the same name on the physical

’ Please review the naming conventions for each of the replicated table. Note
model, a unique database owner/qualifier must be provided.

Check the 'Submodel chedk box to indude the new splits in the submodels

of the original table.
Replicated Table| Submodel | Table Name
1 v Custmr_East Customer
2 W Custmr_West Customer

X Cancel 7 Help & Back  Next & & Finish

6. On Page 3 of the wizard, we will keep all of the relationships, so click Next.

7. On Page 4 of the wizard, verify the name and definition for the denormalization
operation, and then click Finish.
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Finished! The Custmr table now is split into two physical tables that look like this:

Custmr_East Custmr_West
Custmr_ID (PK) Custmr_ID (PK)
Frst_Nme Frst_Nme
Lst_Nme Lst_Nme
Cmpny_Nme Cmpny_Nme
EmI_Addr Emi_Addr
Onyx_ID Onyx_ID
Is_Exstng_Custmr []Is_Exstng_Custmr
Crid_By Crid_By
RwTmStmp RwTmStmp

T T T

Nofice that the two tables are identical except for the name. You can selectively
choose which attributes are included in the resultant tables by using a vertical split.

The denormalization mapping is stored with each of the tables.

f 35 |
| = Table Editor o X |

Owner: I—L; |

|
I Entity Name:  Customer Table Name:

[~ Physical Only [~ Do Mot Generate

Custmr_East

PreSQL &PostSQL | NamingStandards | Compare Options | Datalineage | Security Information | Attachment Bindings
Storage |  Partons |  Constraints | CapacityPlanning | Permissions
Columns | DDL ] Indexes | Definition | Note Where Used

Use "Switch To™ on an entity or table listed to edit that object, or dick Edit to edit the mapping definition and attachment bindings.

[ show only submodels that use this object

) Where Used
&l @ Logical

3] l_"] Entity Name: Customer 8 ™|

H{9 Submodel Usage

EF DB2 Physical Model (IBM DB2)
ﬁf Denormalization Mappings

H- Horizontal Table Split: Custmr_Horizontal_Split_Mapping_1

=] rj Pre-mq:l State
.- ‘_'] Table Name: Custmr
= rj Post-map State
] Table Name: Custmr_East
] Table Name: Custmr_West 1l
S Elusmess Data Object: Customer

Dependencies
ForeignKeys |

AR

R D ’QJ

« OK X cCancel % Hep Y
You can use the denormalization information to undo the operation or see the history of
what happened. ER/Studio Data Architect tracks the before and after states of these
operations. This comes in handy in the next section where we discuss the Where Used

analysis that can be performed between the logical and physical models.
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Tutorials: How an entity maps to the physical model

Now that we performed a denormalization operation, the logical entity, Customer,
essenftially has become two physical tables, Custmr_East and Custmr_West. The fies
between the logical and physical models are not lost. ER/Studio Data Architect allows
you to see what Customer in the logical model maps to in the DB2 physical model.

Let’s take a look at the Customer entity in the logical model.
1. In the Data Model Explorer, go back to the Customer entity in the Logical model.

2. To start the Entity Editor, double-click the Customer entity, and then click the
Where Used tab.

| —] Entity Editor O X ‘

(B i Entity Name: Customer Table Mame:  Custor Owner: | -

! [~ Logical Only |
Attributes | Keys [ Relationships [ Definition ] Note

Compare Options | Data Lineage | Security Information l Attachment Bindings
sed | Constraints [ Dependencies ] Permissions ] Naming Standards
Use "Switch To" on an entity or table listed to edit that object, or dick Edit to edit the mapping definition and attachment bindings.
I~ show only submodels that use this object
b Where Used
=2 Logical
ﬂ Business Data Object: Customer
i HHE Submodel Usage
=LYy DB2 Physical Model (IBM DB2)

I\:‘ I\C

N

Ej Table Name: Custmr_East 0
Ej Table Name: Custmr_West ™|
E_f ) Denormalization Mappings
E-ﬂa Horizontal Table Split: Custmr_Horizontal _Split_Mapping_1 &
¥ oK X cancel T Hep

In the expanded tree, you can see the lineage of what happened to the object. Notice
that Custmr_East and Custmr_West are listed as physical implementations of the Customer
entity. The denormalization mapping object shows how the end result was achieved. The
Where Used tab displays the submodel usage of a particular entity within the logical or
physical model, which allows you to see which business areas the entity belongs to.

Note Where Used information is also available for attributes and columns.

Conclusion
In this session, you have seen how incredibly quick and easy it is to:

e Build alogical data model from scratch.

e Create a new submodel view to understand how to model on specific parts of a
larger Main Model.

e Generate a physical model from a logical database in preparation for building a
new database.

¢ Denormalize objects in the physical model.

¢ View the mappings between the logical and physical models using the Where
Used tab.
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Tutorials: Documenting an existing database

One of ER/Studio Data Architect’s most powerful applications is that of a
documentation generator to communicate complex databases and associated
metadata to the Enterprise. ER/Studio Data Architect is equipped with extensive report
generation capabilities:

¢ HTML Report Generation: Instantaneous generation of an HTML-based Web site
designed to provide simple navigability through data models and model
metadata using standard browsers such as Google Chrome or Mozilla Firefox.

e RTF Report Generation: Instantaneous documentation generation compatible
with applications like Microsoft Word.

In the exercise below, we will reverse-engineer an existing database and generate an

HTML report for distribution and navigation to those who depend upon the information
about the data model, but who may not be permitted to connect to the database for
security or organizational reasons.

Prerequisite

This exercise assumes that you can connect to an existing database in order to
document it. If you cannot connect to an existing database, you can still generate
documentation from the installed sample models; skip steps 1 through step 8 below
which relate to in reverse-engineering and begin at step 9 after opening a sample
model included with ER/Studio Data Architect.

1. Choose File > New. The Create a New Model window appears.

2. Select Reverse-engineer an existing database, and then click Login.

ER/Studio Data Architect o

Create a New Model
" " Login ...
i T) (" Draw a new data model
X Cancel
1| * Reverse-engineer an existing database =
| I K4 Help

" Import Model From: |E::.' File J

o You canreverse engineer the database from either an ODBC datasource or
via Native RDBMS client connectivity. In this example, we use Native
Connectivity to Microsoft SQL Server.

The Reverse Engineer Wizard appears.
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3. Type the relevant connectivity information such as the data source name, user
name, and password, and then click Next.

j Reverse Engineer Wizard - Page 1 of 5 | X

-New Reverse Engineering Operation -

Connection Type: " ODBC: Set :

{* Native/Direct Connection

" Team Server Data Source

Database Type:  [Ms SQL Server ~|
Datasource: | etsvsqltest2016

User Name: | sa

PBSSWDfd: | EEXEXXXTXXXE

™ Use Windows Authentication

[” Create Team Server Data Source from settings

Name: |
Wizard Quick Launch
Select Settings File
| | _Gol
X Cancel ¥ Help & Back | (& Nem | @ Finish

4. Walk through the Reverse Engineer Wizard selecting the objects, options, and
layout preferences for the model.

Note A new feature using ER/Studio Team Server data sources is available
in the Reverse Engineer Wizard. Please see ER/Studio Team Server
documentation for more details.
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3 Reverse Engineer Wizard - Page 2 of 5 O *
—Indude
[V User Tables
ik I ™ System Tables
™ User Views
Datasource Type: | MS SQL Server [~ System Views
[~ Triggers
Database List: |mastﬂ' _I I Procs/Funcs
I_ Packages
. |—— I_ Storage Objecks
Fwmesr Uik dbo ;I [T objectT YDES
I Alias
™ sequences
™ Synonyms
[T Materialized Viev
™ Users
™ Roles
[~ schema Objects
Select Al |
Deselect Al
X Cancel 9 Help & Back | " Finish
/.
3 Reverse Engineer Wizard - Page 3 of 5 Od x
} What database objects do you want to reverse engineer?
Tables | o | s | eroct (10
Available Objects Selected Objects
| Db'lct Name l Object Name |
MSreplication_options
’ } | spt_fallback_db
FV | |spt_falback_dev
" | spt_monitor
4
«
[~ Include object permissions
Capacity Planning
[~ Table Row Count [ Column Average Width
r Colurnn Percent WNul
X Cancel ¥ Help & Back & New 4 Finish
/.
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5. Conftinue through the wizard to select layout styles and other preferences.

:] Reverse Engineer Wizard - Page 4 of 5 O *

ER/Studio Data Architect can infer Referential Integrity when none is
dedared in the database. Clicking the options below will create
relationships between entities in your diagram.

[ Infer Primary Keys
[” Infer Foreign Keys from Indexes
[ Infer Foreign Keys from Names
I Ignore Case
[™ Infer Domains (Create a Domain for each Column)

ER /Studio Data Architect can ensure all objects referenced by those
you've selected for reverse engineering are also induded.

[¥ Reverse Engineer View Dependendes

[¥ Reverse Engineer Other Dependendies (e.g. Procedures,
Triggers, etc)

Select the Initial Layout Option
ﬁl Circular Orthogonal &l Tree
I-E Hierarchical ﬁl Symmetric

Select the Logical View Parser Option
[ Use Physical Parser

X Cancel 7 Help

3 Reverse Engineer Wizard - Page 5 of 5 O x

’ What type of Physical Model is this?
% Relational  Dimensional
} Select external naming standards template for logical

| E
=l
=

} [V Create custom datatypes for unsupported types

|Microsoft SQL Server 2016 (system)

’ Summary of Selected Objects  |Al

Object Type Owner | Object Name
Table dbo |MSreplication_options
Table dbo spt_fallback_db
Table dbo spt_fallback_dev
Table dbo spt_monitor

’ Save Settings for Quidk Launch? Save As ... |

X Cancel 9 Help
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6. Click Finish and ER/Studio Data Architect reverse engineers your database.

Once reverse engineering of your database is complete, we will generate a
complete HTML report of the database for others in your organization to review.

In the Data Model Explorer, select the Physical Main Model.

8. Choose Tools > Generate Reports.

0 ER/Studio Data Architect Report Wizard - Page 1 of 4 O X

Generate HTML or RTF file
Select report type
(¢ HTML report (" RTF report

Report Directory ‘
Select directory for report

[C:\Users\mdja.pollard\,ﬁppData‘Roamhg\Idefa\ERSb..ldio\erc _l

Wizard Quick Launch
Select Settings File
[~ Use file-based Quick Launch settings.

[Nore = | |

(¢ settings Only { Settings and Objects

Do you want to invoke an Editor to view the report after it is
generated?

* Yes " No

Generate HTML report using performance-enhanced version for large
data models.

™ Use enhanced version.

X cancel ¥ Help Back Next dp Finish

9. On the first page of the wizard, select HTML for the report type.
10. On page 2, click Select All in both areas of the Diagram tab.
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’ Please select the objects in your data model that you'd
like to generate a repoit for.

Diagram |Data I.ineagel Data Dicu'onaryl Securltyl ED ‘
¥ = DATAMODEL |a =] W |Diagram '
¥ 48 Logcal :g e
Vv :-:-@ Main M... v ﬁh? -

I =Mzl Entii... v Company
W ; . F¥ Version
v & - ¥ CopyrightOwner
v 2 Hv Copyright Year
= -V Bound Attachment
& i e 5 ¥ _Model
v 4Py Physical Hv¥ Name
(72 EHEa Main M... Hv Database Platform
e v Model Notation
W iz Tables
[ Hv¥ PreSQL
¥ R v PostSOL v

Select Al | Unselect Al | [ selectAl | uUnselect Al

X Cancel 2 Help & Back  Next & # Finish y

11. Click Select All in both areas of the Data Dictionary and the Procedures tabs,
and then click Next.

Note The tabs available on page 2 depend on what objects are
supported by the database platform of the selected model. Some
databases support more database objects than Microsoft SQL
Server, such as Oracle and IBM DB2 LUW for which there are also
tabs on this page for procedures, functions, friggers, packages,
and tablespaces. If the model was previously denormalized, a
Denormalization Mappings tab would also appear.

12. On page 3, click Select All in the Submodel Image Options area.

Tip In Logo and Link Options you can choose to replace the ER/Studio
Data Architect default IDERA logo in favor of your own corporate
logo (and Hyperlink).
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0 ER/Studio Data Architect Report Wizard - Page 3 of 4 O >

Select HTHML generation options
Submodel Image Dptions

Submodel images will be generated in the V= e DATA MODEL |
report for the selected submodels. W E Logical
Individual Zoom and Quality settingscan | [ LS Main Model
be set for each submodel by selecting it 72 EHB Physical
in the tree. )
W L Main Model
Image Type: JPG -
Zoom: —1 100%
Qualty: = | SelectAl | UnselectAl |

Logo and Link Dptions

Image file | Browse... |

New Link | Report Ttle |
Description

Initial Reversed Database

Report Formatting
Object Defintion Formatting:  * Preserve formatting " Wrap text

Object Note Formatting: * Preserve formatting " Wrap text
Explorer Tree: [ Include ownerin tree.
X Cancel ¥ Help < Back Next &» 5 Finish o

Because HTML formatting can be included in object definitions, you can also
choose to preserve the formatting specified on the Definitions tab of the various
object editors.

13. Click Next to advance to the last page, and then click Finish.

ER/Studio Data Architect then begins the report publication process and
launches the default browser so you can review the report.

14. Finished!

Start navigating the report via your browser. Navigation will perform exactly as it
does when you are using ER/Studio Data Architect. Expand the tree to find
Model Image and click on it (see below). You will see a read-only version of your
data model (as seen below). Use the Explorer to navigate to any metadata you
want or select the entities and relationships in the model image to jump to their
information.

Conclusion
In this session, you learned how to:

¢ Connect to and reverse-engineer an existing database with ER/Studio Data
Architect.

¢ Document a database in seconds by using ER/Studio Data Architect’s
automatic HTML documentation publication facility.
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Tutorials: Documenting data lineage

The Data Lineage feature of ER/Studio Data Architect enables you to document the
movement of data from point A to point B (and any intermediate steps in between).
This movement is sometimes referred to as Extraction, Transformation and Load (ETL).
Points A and B can be anything from flat files, high-end databases such as Oracle and
DB2, XML, Access databases, and Excel worksheets. This is sometimes referred to as
source and target mapping. A model produced in ER/Studio can represent any point
along the way. Data Architects need the ability to specify the source or target of data
down to the column-level. Along with the metadata that defines the source and target
mapping are rules for how the data is manipulated along the way.

The next section will help you document the data lineage of your systems.
It is comprised of the following tasks which correspond to the general ETL workflow:
e Creating a Data Flow

e Creating a Data Movement Rule

e Defining External Source and Target Systems

e Creating a Data Lineage and Transformation Visualization
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Tutorials: Creating a data flow

The Data Flow organizes and encapsulates one data transformation and the
source tables and columns used in the transformation to produce the target data.
Multi-tiered mappings are possible and there can be multiple tfransformations
involving different columns between two tables as illustrated below.

. GIMDB - Data Flow Model View: Broker *

¥ Datalineage A
— Data Flows

#5 Broker

—HiHy Transformations

Broker

Investment

& Broker Id (PK)
% Office Location Id (FK)

# Investment Id (PK)
% Investment Type Id (FK)

44 Transformationl ¥ Broker Last Name & Investment Vendor

= Irputs < Broker First Name & Investment Name
#H— Broker [Logical) < Broker Middle Initial & Investment Unit
*HT Investment (Logical) % Manager Id (FK) @ Investment Duration

EHEY Outputs & Years With Firm ?_
[+] BROKER_DIM [GIM_D

+1 B Components 1
Shapes - ~

{4 Transformation1

[=H#4 Data Movement Rules
,ﬁ Data Retention [Archive Rule]
£ Upsert [Update Rule)

Data Sources

U~ Broker.Broker Last Name
i~ Broker Broker First Name
U= |nvestmentinvestment Id

Local Models
Logical ~1BROKER_DIM BROKER_NAME
;'J Entities (10) ‘ &
—g Broker l
—H Broker Dim
H Clent E BROKER_DIM
g Client Fact $
= Client Transaction * gggig:_:?;::}
Investment o
E Irvvestment Dim ¥ YEARS_WITH_FIRM
—H Investment Type
Dffice Location 4
| Fegion Dimension v

Data ... a Data.. M#iDatalL... ﬂl\-‘lacro <

Create a data lineage data flow

1. Choose File > Open and select the GIMB.DM1 diagram in the Sample Models
directory.

2. Click the Data Lineage tab at the bottom of the application window. You are
prompted to create a Data Lineage Data Flow.

ER/Studio Data Architect i

! There are currently no Data Lineage Data Flows available to
.-_li display. Would you like to create one now?

Yes No
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3. Click Yes.

If this is not the first time you click the Data Lineage tab after opening a diagram,
from the Data Lineage Explorer, right-click the Data Flows node, and then click
Create Data Flow.

If you would like to keep your version of GIMB.DM1 unchanged, 'save as' a
different flename before proceeding past the Undo/Redo warning dialog.

4. Enter a data lineage data flow name, and then click OK.

iy Add Data Lineage Data Flow e

Name: ‘BmkEd

 OK X Cancel

— S— - 1

Note The name that appears in the diagram title tab at the top of the
application window is appended with: data flow name, when you
click a task in the Data Lineage explorer, such as GIMDB.DM1 -
Data Flow Model View: Broker*.

The Data Flow is created.
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Tutorials: Creating a data movement rule

Data Movement rules describe how source and target tables and entities are related.
You can relate source data to one or more tables and entities in the same model, the
active diagram, or to tables imported from external systems. The rules defined here are
used at the table level on the Data Lineage tab of the entity and table editors.

Create a data movement rule

1.

2.

3.

On the Data Lineage tab, right-click Data Movement Rules, and then choose
New Data Movement Rule.

| #¥ Data Mavement Rule - O *

Rule Information I Binding Information

Rule Name: [Backup & OK

Rule Type: hd
| ule 1ype |A|ch|ve Riule :I X cancel
Rule Text:

Backup Rule =
Create Rule T  Heb
Deletion Rule

Recavery Rule

Update Rule

Boolean

Date

Extemal File Path v

Complete the Data Movement Rule editor as required

o Rule Name: Enter a name that indicates the operation and objects acted
on, depending on the specifics of your binding definition.

o Rule Type: Select a generic movement rule type that best describes the
data movement.

o Rule Text: Document your data movement plan here, perhaps adding
instructions or contingency plans.

Tip Once created, you can edit the Data Movement rule by double-
clicking it to launch the Data Movement Rule editor.

Click OK to exit the editor.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this
aftachment. You can override this setting using the Data Lineage tab of the entity or
table editor.
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Tutorials: Defining external source and target systems

Data sources can originate from models in the active diagram (local models) or from
external sources that are either imported into the active diagram or created on the
Data Lineage tab. A data source can be imported from *.dmT files, *.dt1 files,
database or from SQL files, flat files, and other common application files. The following
describes how to import metadata from an external source.

Note

Source data imported through the Data Lineage tab only includes

information such as table and column name, datatype, nullability,
primary key, and column definitions. To obtain more details, reverse
engineer the database or import it into ER/Studio Data Architect using

the Metadata Wizard.

Import external source or target data

1. From the Data Lineage tab, expand the Data Sources node.

2. Right-click Other Sources, and then choose Import New Source.

ﬂ Import Source - Page 1 of 5

........

X Cancel

ha ¥
-

‘? Help

Welcome to the Data Source Import Wizard!

Please select where you would like to import the source
metadata from:

(+ From a model in another DM1 file

| 5 [@E
" From a Reposttory based DM1 file
\

" From a SQL file

" From a live database

Comparison Quick Launch
Select Settings File
¥ Use file-based Quick Launch settings

| Load file...

" Settings Only (* Settings and Objects

Back Next Finish

3. Complete the Import Source wizard as required, and then click Finish to import

the source.

The new source will appear under the Other Sources node.
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The following describes options that require additional explanation:

Page 1: Please select where you would like to import the source metadata from

O

From a Repository based DMT1 file: Lets you obtain source from data
models and Named Releases managed within the ER/Studio Repository.
When you select this option, ER/Studio Data Architect opens the
Repository Operation Status dialog box and the Get From Repository
dialog box. This process connects to the current Repository Server defined
in the Repository settings. The Import Source wizard automatically gets the
diagram.

From an SQL file: ER/Studio Data Architect imports the SQL file.

From a live database: If you select this option, a page appears where you
can select the database and connection type. The connection type can
be either ODBC or Native/Direct Connection. For information about
connecting to databases, including troubleshooting information, see
Connecting to Database Sources and Targets.

Comparison Quick Launch: The Compare Quick Launch data is saved as
an *.rvo file. For information on using the Quick Launch option in the
wizard, see Saving and_Using_ Quick_ Launch_Settings.

Page 5. Results

O

Current and Target Model Display Grid: Between the Source and Target
models is a Resolution column. The default merge decision is Merge the
data into the new source file. You can click on any item in the Resolution
column to enable the decision list. If you want to change the decision,
click the list and then click the new resolution. When you change the
default resolution of an object, the decisions of their dependent
properties and objects are automatically updated. You can also click the
category folders, like the Tables Resolution column to change all the
decisions for all the underlying objects in that object category. And, you
can use the CTRL key to select multiple items, and then right click to
enable the decision list.

SQL Difference: To enable the SQL Difference utility, select any difference
that is a long text field, such as a Definition, Note, or DDL, and then click
SQL Difference to view the differences between the SQL of the models.
This utility only allows you to view the differences; difference resolutions
are performed on the Results page of the Compare and Merge Utility.

Filter Report on Results: Create areport of the source content and your
chosen resolutions. You can choose to create an HTML or an RTF report.

Tip

You can modify the default display using the options at the
bottom of the page.
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Tutorials: Creating a data lineage and transformation
visualization

1.

To create the data source or tfransformation input tables, expand Data Sources >
Local Models > Logical > Entities, and then drag and drop the Broker and
Investment tables onto the Data Lineage window.

. To create the data target or fransformation output tables, navigate to Data

Sources > Local Models > GIM_DW, and then drag and drop the Broker_DIM table
onto the Data Lineage window.

To obtain the Transformation Insertion tool, right-click an empty space in the Data
Lineage window, and then click Insert Transformation.

To insert the fransformation, click in the Data Lineage window between the source
and target data sources, and then right-click to drop the Transformation Insertion
tool.

Reposition and resize the transformation object to suit your needs.

Right-click an empty space of the Data Lineage window, and then click Insert Data
Stream.

Tip Transformation and Data Flow tools are also available on the
toolbar. Hover the mouse over the tools to find the tool you need.

Click an input and then click the fransformation object. Repeat as many times as
necessary to link all the inputs to the fransformation object.

Click the transformation object and then click an output.

Broker Investment
¥ Broker Id (PK) ¥ Investment Id (PK)
% Office Location Id (FK) % Investment Type Id (FK)
» Broker Last Name 7 Investment Vendor
¥ Broker First Name ¢ Investment Name
“ Broker Middle Initial « Investment Unit
% Manager Id (FK) < Investment Duration
» Years With Firm l—/

i 4 Transformation 1

h_-j

E BROKER_DIM

# BROKER_ID (PK)
¥ BROKER_NAME
@ YEARS_WITH_FIRM
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9. To define which columns should be used in the transformation and any
transformation rules, double-click the new transformation to open the
Transformation Editor.

10. Complete the Transformation Editor as required, and then click OK to exit the

editor.
. 3 Transformation Editor ] X
Name: ] Broker Name Type: <unspecified > LI

Culumnsf Definition Data Movement Rules I Attachments ]

Inputs: I Outputs:
Parent Model l Parent Obj... J Attribute/Column ] Data Type ] Deﬁnition] Parent Model l Parent Obj... ] Attribute/Column 1 Data Type] Deﬁnmon]
Logical Broker Broker Last Name |VARCHA... JGIM DWW BROKER DIM BROKER NAME |varchar(...

Logical |Broker Broker First Name |VARCHA... |
Logical Investment | Investment Name |VARCHA. ..
7 X cone

11. Finished! Now you can more easily share your ideas with your colleagues.

Tip Once the Data Flow is created, you can double-click it to
change its name, or double click a transformation or
component to change its properties.

The following describes options in the Transformation Editor that require additional

explanation, for more options that are not required for this futorial, please read the User
Guide.

Columns tab

e Inputs: Click the ellipsis (...) button to choose the inputs to be transformed in this
task.

e Outputs: Click the ellipsis (...) button to choose the outputs resulting from the
transformation.

Definition tab
e Business: Describe the fransformation for your audience.

e Code: Enter the code that will perform the transformation, such as a SELECT
statement, or a VBBasic or Java Script function or procedure.
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Data Movement Rules tab

These are the rules from the Data Movement Rules node of the Data Lineage
Explorer.

Note You can delete or edit an input or output column by double-clicking
the transformation in the Data Lineage window, clicking the ellipsis in
the Transformation Editor and then deselecting the column you want
to remove.

Aftachments tab

Bind an external piece of information or attachment to the transformation. You
can also remove an atftachment from an object, override the default value of
an attachment, or change the position of a bound attachment.

To override the value of the attachment you have moved to the Selected
Attachments grid, double-click the Value field of the target attachment.
ER/Studio Data Architect opens the Value Override Editor or a list, depending on
the attachment datatype. Attachments are created in the Attachments folder
of the Data Dictionary and must be applied to the default before they will
display on this tab.
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Tutorials: Diagram navigation and aesthetics

To assist with the creation of presentation-quality diagrams that are easy to navigate
and are aesthetically pleasing, ER/Studio Data Architect offers progressive diagram
Auto Layout and Navigation utilities that also help you to clean up complex diagrams.
Modelers should spend fime solving complex database or business data model
problems, not forcing boxes and lines to look a certain way.

Navigating the diagram

To demonstrate some of ER/Studio Data Architect’s layout and navigation utilities, we
willimport a sample SQL script provided with ER/Studio Data Architect.
1. Close any files you have open.

2. Choose File > New.

3. Select Import Model From > SQL File, and then click Import.

Note The ERX File choice enables you to import erwin ERX files. Selecting

From External Metadata launches the MetaWizard to import from
alternative sources.

ER/Studio Data Architect x
Create a New Model
o Import ...
S~
i 3 " Draw a new data model |Relational
: X Cancel
@ " Reverse-engineer an existing database =
Y Help

@ Import Model From: [ERX File -]
ERX File
Bxtemal Metadata

The Import Database SQL File dialog appears.
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4. To the right of Select a Database SQL File, click the folder icon, and then find
Sample DDL (DB2 7.x for 0$390).SQL (located at C:\Program Files\IDERA\ERSfudio
Data Architect x.xX\SQLCode\Sample DDL (DB2 7.x for OS3%0).SQL), and then click
Open.

5. In the Select the target database platform list, click IBM DB2 UDB for OS /390 x.x, and then
click OK.

Import Database SQL File *

Select a Database SQL File
| C:\Program Files\IDERA\ERStudio Data Architect 18 |3

[ ’ Select the target database platform

[1EM DB2 UDB for 0S/390 11.x |

ER/Studio Data Architect can infer Referential Integrity when
none is dedared in the script. Clicking the options below wil
create relationships between entities in your diagram.

[ Infer Primary Keys

[ Infer Foreign Keys from Indexes

[ Infer Foreign Keys from Names I~

™ Infer Domains (Create a Domain for each Column)

Select the Initial Layout Option

ﬁl Circular E‘ Orthogonal ﬁ] Tree
|_<E Hierarchical EI Symmetric
What type of Physical Model is this?
{* Relational
" Dimensional
Select the Logical View Parser Option
™ Use Physical Parser

’ IV Create custom datatypes for unsupported types

|1BM DB2 UDB for 05/390 11.x (system) v

 OK X Cancel 2 Heb

Finished! Once the SQL Script is finished importing, the following items will assist
you in leveraging a variety of Auto Layout and Navigation Features.

¢ Diagram > Layout. Use any of the Auto Layout styles, such as hierarchical, orthogonal, and
symmetrical, to change the layout of the diagram with the click of a button. The auto
layout styles are all entirely customizable styles. You can also customize the diagram layout
via the Layout Properties option. In addition, you can have multiple layout styles in a model.
Select an object, and then choose the layout style. If you don’t have any objects selected
when you click the layout button, the layout style chosen is applied to the entire model.

e Tools > Overview Window. Use this window as a thumbnail of your model to pan
the entire model or zoom in and out. It can also pan and zoom the diagram if
grabbed or sized.
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e Tools > Zoom Window. Use this window as a magnifying glass to
enlarge any diagram objects under your mouse cursor. You can also
press SHIFT+F8 to freeze the zoom window to keep a single object
frozen while you continue to pan around the diagram. If the Zoom
window is not already visible, press F8 to activate it.

o Data Model Explorer: Click any object in the Data Model explorer and
it is automatically selected in the diagram and focused in both the
Zoom Window and Overview window.

Diagram aesthetics

One of the fremendous benefits of building data models is the wide range of
audiences that can realize value from them. Part of this relies on what
information is displayed in the diagram. Depending on the audience you
may want to limit or expand what is displayed. For example, developers may
benefit from looking at a model that displays data type, null option, and
unigue and non-unique index information, while business analysts may just
need the entity name and the definition. ER/Studio Data Architect offers
many display properties that can be customized exactly for this purpose.

Continuing with the previous section, we will use the DB2 model that was built
to demonstrate some of the ways to customize the appearance of the model.

We will use the Diagram and Object Display Options dialog on the Diagram
toolbar to further customize the view of the logical and physical models.

Setting the logical model display

1. Select the Logical model and then on the Diagram ribbon, click the
Diagram and Object Display Options tool.

File Diagram nsert Model Tools Repository Macro

Style ~
k p =71 L4 Sub Model Object Styles | Q & Pan —"’1 ™
(m] i-
U_‘ # This Object Style ~ — 4 ‘J-rl igate Relationships ):|1| Horizontal J— =T+

Fin ut — Alignmen t find iagram/Object
@ Move  entityrview - B - @& 7 Refresh M ite ntr m Display

2. In the Diagram and Object Display Options dialog, click the Entity tab,
select Entity in the Display Level areqa, and then click OK.

il

RQST_CLNT

|
|
|
|
|
|
|
|
ﬁ\ FRIMWVE_ACTUL

FHCL_TRANS I

Note Only entity names are displayed for each entity. You may also want to
re- layout the diagram since the entfity sizes have changed.
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Setting the physical model display

1. Select the Physical model, and then choose Diagram > Diagram and Object
Display Options.

2. In the Diagram And Object Display Options dialog, click the Table tab.

[
E' Diagram And Object Display Options O X

Diagram Table | Relationship l\.ﬁewl Schema Object ] Drawing Shapes ! Security Objects ] Apply To |

Display Level Awvailable Options
| WV Shadow [ Datatype
" Logical Attribute Order [~ Domain i : gt
y I~ Null Option [y | [ Hide Fact At
% Physical Attribute Ordering [~ Atemate Key [™ Hide Dime;
" Primary Key Only [~ Inversion Entry
[~ Owner lv Triggers
~
A K [ Display Entty Names [~ Defaul
" Table ™ Display Attribute Names | Name Compartment
¢ Defntion ™ Hidden Attributes Marker |~ Wrap Name
~ ™ Indexes I~ Data Security
Note [~ Atachment [T DataSe )
™ Atta tWalu ¥ Column Bitmaps
 OK X Cancel D Hep

3. Inthe Display Level areq, select Physical Attribute Ordering.

4. In the Available Options area, select the specific properties you want to display,
and then click OK. The model now displays more details for the physical model.

EDB_S$PEC
¥ sPEC 1D (PK
¥ CTGRY_ID
w ABBR
+ LAST_UPDT DT
« SYS_NAME
+ SHORT_NAME
@ LONG_NAME
Ll LI I I B I B
_______________________________ =) [ I O I -
T ====-
g =====-
Fo-mTTT o T T ILTTTIIT
1 |
| |
1
| I
{ |
EDB_PROD X
% PROD_ID (FK) |
¥ LGCY TYPE |
¥ STRT_DT
EDB_SPEC_XREF $END DT EDB_FRMWEK_SPEC
P AssN_TYPE (PX) ¥ PROD_LINE % SPEC_ID (FK;
$ STRT_DT (PX) ¥ CNTRY_CD ¢ DATA
W SPEC D LEFT (PK)(FK + POSTL_ST + 5E0_NUM
B SEEC D RIGHT (PKNFK + CO CD +LAST_UPDT
¥ LAST_UPOT DT ¥ RISK_GRP ¥ STRT_DT
¥ END_DT ¥ BUSN_TYPE ¢ END_DT
¥ MIN_CRONL ¥ LOB ¥ CREAT_DT
¥ MAX_CRONL ¥ PLCY_TYPE
¥ PLCY_FORM_GRP
¥ PLCY_FORM_NUM
¥ RISK_TYPE
Note Because the sizes of the objects changed, you may want to change

the model layout using one of the advanced layout engines.
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Tutorials: Data Source Mapping
Steps for using the Data Source Mapping:

1.

o O DN

Create or open a diagram

Connect and Publish on Team Server

Log in to Team Server from ER/Studio Data Architect:

To log in to Team Server, choose Repository > Team Server Log In.
Complete the log in dialog and then click OK.

Right click on the physical model that you want to map and select Data Source
Mapping option.

Relate the model with the data source.

Edit any table on the physical model related and go to Where use tab. Or right
click on the table and select Where use option.

. The Where Used tab/dialog shows the data sources related. These are potential

database instances that could be impacted if the table changes.
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Conclusion

In this session, you have learned how to:

e Import an SQL file and allow ER/Studio Data Architect to automatically create a
diagram.

e Use a variety of auto layout and navigation tools fo enhance the aesthetic
experience of the diagram and to improve the data model navigability.

¢ Customize the display of both the logical and physical models.

Thank you for completing the tutorials section. Please visit the User Guide for more
examples and information on using ER/Studio Data Architect.

See Also
e WikiHome

e User Guide
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