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WELCOME TO ER/STUDIO BUSINESS ARCHITECT

ER/Studio Business Architect (previously known as EA/Studio) applies two different types of
modeling: Business Process Modeling Notation (BPMN), and Conceptual Modeling. These
modeling processes allow you to integrate roles from various constituencies to collaborate,
agree, create, and enable executable processes.

The Business Process Modeling portion of ER/Studio Business Architect (ER/Studio BA) is a
visual modeling application that focuses on business process modeling and its relationship to
related enterprise and data artifacts. Business processes do not exist in a vacuum within the
organization, so ER/Studio BA allows you to link key business process information to data,
organization, rules, etc. to get a broad view of the organization and show how processes and
data impact one another.

The Conceptual Modeling portion allows Data Modelers to create high-level designs of core
business concepts to gain acceptance and requirements from the business. These high-level
Conceptual models can be forward engineered to create detailed Logical Data Models in ER/
Studio. You can relate data objects to business process information and create Usage (CRUD)
and Impact Analysis reports. In addition to process-specific information, related business
information can also be linked to data objects such as business rules, business elements,
business units, and stewards.

Through robust reporting, modeling, and graphical impact analysis, users are able to provide
relevant information to various stakeholders within the organization in a format that makes sense
to them. For example, a data analyst may wish to see a Usage (CRUD) report showing what data
is used by a given process for compliance. A business user may want to see a list of relevant
business rules in a spreadsheet. A process modeler needs to see a semantically-rich process
model. ER/Studio BA allows each stakeholder to see a different “slice” of information—all from
the same data source and metadata model.

Continuous Im -rn:wemem
Manage/Monitor £ .
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ABOUT ER/STUDIO BUSINESS ARCHITECT

ER/Studio BA is used for creating graphical representations of your business from the core
concepts that describe the business, to the processes detailing how your business operates. You
can model business processes and how those processes use data. The Business Process
Modeling is based on the BPMN standard.

The Conceptual Modeling provides intuitive ways to outline subject areas and concepts that can
then drive the creation of detailed data models. The Conceptual Modeling uses high-level
representations allowing for top-down database design.

Functionality

Description

Conceptual Modeling

Conceptual Model Creation

Support for high-level conceptual modeling using elements such as subject areas,
business entities, interactions, and relationships.

Relationship Traceability

Model links between any conceptual or process modeling elements allowing you to
trace relationships between models.

Conceptual Model Export

Conceptual models can be exported to Embarcadero’s ER/Studio to become the
foundation for creating ER/Studio logical data models. The export uses pre-defined

mapping.

Business Process Modeling

Process Model Creation

Support for straightforward process modeling that uses standard elements such as
sequences, tasks, swimlanes, start events, and gateways.

BPMN Compliance

Optional automatic validation of process diagrams to ensure compliance with the
BPMN specification and prevent the addition of non-compliant modeling elements.

Embedded sub-process
support for functional
decomposition

Independent sub-processes and embedded collapsible sub-processes can be
included within a business process to allow for maximum flexibility in diagramming,
while still ensuring a workable visual diagram.

Impact Analysis Reporting

Multi-object, Multi-level
Reporting

Impact analysis reports can be generated to show interrelationships between
process, data, stewardship, business rules, diagram usage, heritage, connecting
objects etc.

Report Filtering

Impact analysis reports can filter based on type of relationship, object type, or text
strings including wildcard matching.

Usage (CRUD) Reporting

Link Process with Data

The relationships between business processes and data objects can be modeled to
identify what processes create, read, update, or delete data objects.

CRUD Reporting

CRUD reports identify which processes affect which data, and what affects they
have. Reports are available in a straightforward spreadsheet view.

Report Filtering

Reports can be shown across object types, or can be filtered based on individual
object types such as tasks or business processes, allowing users to drill down based
on specific requirements.

Business Artifact Modeling

External Data Objects

Support for data objects which are general data storage constructs that can
represent databases, file systems, or other data storage mechanisms.
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ABOUT ER/STUDIO BUSINESS ARCHITECT >

Functionality

Description

Business Elements

Captures business terms that can later be used to enforce naming standards or as
the foundation of logical data models.

Business Rules

Incorporate policies, practices, or formulas related to business processes as part of
the process model elements and metadata processes, allowing users to drill down
based on specific requirements.

Business Units

Create and incorporate business units into process models such as sales, human
resources, or accounting.

Stewardship Support for inclusion of organizational roles such as ‘DBA’ or ‘Sales Manager’ to
incorporate ownership for specific processes or tasks.
Links Create generic associations between objects for impact analysis and CRUD

reporting.

User Interface

Organizational Hierarchies

ER/Studio BA allows you to organize your information to align with your business
strategy, allowing for a Project-based tree hierarchy which can group multiple
model types and diagrams into intuitive projects to allow for alignment with
business initiatives or organizations.

Flexible Interface

Full support for multiple property editors, tab-based navigation, undo/redo,
collapsible nested tree views, zoom-based navigation, and keyboard shortcuts.

Flexible object formatting and
display options

Ability to customize a wide variety diagram options including line width, color and
fill options, font displays, line connector points, line bend formats, etc.

Grid Editing

A table-based alternative to the hierarchical tree view, allowing the display of large
numbers of objects or business rules in an easy to read format.

Publish Model to Web

Automatically generate HTML views of your models to share with other people in
your organization.

Import / Export

Share Information Across
Multiple Roles and Formats

Can share process models among a broad range of user groups by exporting them
into a wide variety of supported formats including xml, csv, html, pdf, rtf, and jpeg.

ER/Studio Import/Export

Import and export Embarcadero’s ER/Studio Business Architect models for use as
data assets or Conceptual diagrams.

Visio Import

Configurable import capabilities let you import diagrams from Microsoft® Visio®.

Collaboration and Reporting

Connect to ER/Studio Repository to share workspaces, diagrams, and models.
Connect to ER/Studio Portal to explore and report on ER/Studio BA objects in ER/
Studio Repository. For more information, see Working with ER/Studio Repository.

Architecture

Separation of Data and
Display

ER/Studio BA is based on a metadata foundation that allows core data to be
manipulated and displayed in a variety of formats, without requiring a “picture” or
diagram, speeding performance and increasing knowledge transfer across multiple
constituencies.

Object Reuse

Core processes and enterprise objects can be reused across multiple diagrams,
allowing for a “single version of the truth” across the organization.

Standards-Based

ER/Studio BA is based on industry standards: Eclipse-based, XML file formats with
published Schema, and BPMN modeling notations.

12
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ABOUT ER/STUDIO BUSINESS ARCHITECT > ABOUT THE USER GUIDE

ABOUT THE USER GUIDE

The User Guide focuses on the key features and capabilities of the application.The table below
describes the sections of the online Help:

Section

Description

Application Basics

Explains the application design, navigation tools, and important
concepts, as well as how to configure the application.

Using ER/Studio
Business Architect

Explains how to use workspaces, projects, models, diagrams, and
diagram elements as part of the modeling process.

Working with ER/Studio
Repository

Explains how to configure and connect to the repository to get,
check in, and check out workspaces, diagrams, and models.

Using Business Process
Modeling Notations

Explains how to work with the Business Process Modeling
Notation.

Using Conceptual
Modeling Notations

Explains how to work with the Conceptual Modeling Notation.

ER/Studio Business
Architect Tools

This chapter covers the main tools used in ER/Studio BA: Create
Diagrams from Selected Elements, Find, Search, Links, Usages
Grid Editor, Reports, and Views.

ER/Studio Business
Architect Tools -
Importing and Exporting

This chapter covers Conceptual Models Import and Export to ER/
Studio, External Data Objects Import and Export to ER/Studio,
and Visio Import.

Property Views

Explains the fields in the Property View.

Glossary

Defines words used in ER/Studio BA and this documentation.

For more information, see

Technical Requirements

Product Resources

Licensing ERStudio Business Architect

Additional Product Resources

® Embarcadero Technologies Technical Support

TECHNICAL REQUIREMENTS

Before using ER/Studio BA, verify that your environment meets the application hardware and
operating system requirements.
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ABOUT ER/STUDIO BUSINESS ARCHITECT > PRODUCT RESOURCES

Hardware Requirements

ER/Studio BA hardware requirements vary. The table below outlines the minimum
recommended requirements for ER/Studio BA:

Hardware Minimum Requirement
CPU 1.2 Ghz
RAM 1 GB MB of RAM
Disk Space Hard Drive Install 250 MB
Storage - Sufficient space for workspaces, which will vary according to
complexity.
Video SVGA
High resolution monitor (1024 x 768 or higher) with high color (16-bit)
Media CD-ROM or the Internet (www.embarcadero.com).

Operating System Requirements

ER/Studio BA supports the following operating systems:

e Microsoft Windows® XP SP2

e Microsoft® Vista ® 2007

e Microsoft Windows® 7

NOTE:

experience. The premium experience, Windows Aero
ER/Studio BA.

ER/Studio BA is supported on Windows Vista when using the Windows Vista Basic

®, is not supported for use with

PRODUCT RESOURCES

The section gives you additional resources that are available to help you use ER/Studio BA.

The Object Management Group/Business Process Management Initiative is responsible for
generating a standard Business Process Modeling Notation (BPMN) providing businesses with
standard graphical notations for internal business procedures.

For more information, see http://www.bpmn.org

The Business Process Modeling Notation (BPMN) specification provides standardized graphical
notations for expressing business processes in a Business Process Diagram (BPD).

For more information, see http://www.bpmn.org/Documents/OMG%20Final

14
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LICENSING ERSTUDIO BUSINESS ARCHITECT

For information on licensing ER/Studio BA, go to the Quick Start Guide at
docs.embarcadero.com

UNINSTALLING ER/STUDIO BA

To uninstall ER/Studio BA so you can install a later version, do the following:

1 Click Start > Programs > Embarcadero ERStudio Business Architect X.X, and then
Uninstall ERStudio Business Architect. ER/Studio BA opens the Uninstall Wizard.

2 You can select to uninstall all or part of the products. The separate components are:
Program Files, Help Documents, and Common Components.

3 Complete the wizard panels, and then click Finish. ER/Studio BA and all its components are
uninstalled.

NOTE: During the uninstall, you have the option to remove all preference settings. If the
settings are removed at this time, all the preferences you have set are lost for future
installs

NOTE: The workspaces and their related projects, models and diagrams are stored in a
different directory and are not uninstalled.

ADDITIONAL PRODUCT RESOURCES

The Embarcadero Web site is an excellent source for additional product information, including
white papers, articles, FAQs, discussion groups, and the Embarcadero Knowledge Base.

Go to www.embarcadero.com/support, or click any of the links below, to find:

e Documentation

Online Demos

Technical Papers

® Discussion Forums

Knowledge Base
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EMBARCADERO TECHNOLOGIES TECHNICAL SUPPORT

If you have a valid maintenance contract with Embarcadero Technologies, the Embarcadero
Technical Support team is available to assist you with any problems you have with our
applications. Our maintenance contract also entitles registered users of Embarcadero
Technologies’ products to download free software upgrades during the active contract period.

To save you time, Embarcadero Technologies maintains a Knowledge Base of commonly-
encountered issues and hosts Discussion Forums that allow users to discuss their experiences
using our products and any quirks they may have discovered.

To speak directly with Embarcadero Technical Support, see Contacting Embarcadero
Technologies Technical Support below.

NOTE: Evaluators receive free technical support for the term of their evaluation (14 days).

Contacting Embarcadero Technologies Technical Support

When contacting Embarcadero Technologies Technical Support please provide the following to
ensure swift and accurate service:

Personal Information
e Name

e Company name and address

Telephone number

Fax number

Email address

Product and System Information

e Embarcadero product name and version number. This information is found under Help,
About.

® Your client operation system and version number.
e Your database and version number.
Problem Description

A succinct but complete description of the problem is required. If you are contacting us by
telephone, please have the above information, including any error messages, available so that
an Embarcadero Technical Support Engineer can reproduce the error and clearly understand the
problem.

There are three ways to contact Embarcadero’s Technical Support department:
* Via the Web
e Via Phone

* \ia Email
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Via the Web

Embarcadero Technical Support provides an online form that lets you open a Support case via
the Web. To access this form, go to http://www.embarcadero.com/support/open_case.jsp.

We normally acknowledge the receipt of every case on the same day, depending on the time of
submission.

Via Phone
United States

Embarcadero Technologies Technical Support phone number is (415) 834-3131 option 2 and
then follow the prompts. The hours are Monday through Friday, 6:00 A.M. to 6:00 P.M. Pacific
time.

For licensing issues, including Product Unlock Codes, call (415) 834-3131 option 2 and then
follow the prompts. The hours are Monday through Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

The Embarcadero Technologies Technical Support fax number is (415) 495-4418.
EMEA

Embarcadero Technologies Technical Support phone number is +44 (0)1628 684 499. The hours
are Monday to Friday, 2 A.M. to 5:30 PM. U.K. time.

For licensing issues, including Product Unlock Codes, call +44 (0)1628-684 494. The hours are
Monday to Friday, 9 A.M. to 5:30 PM. U.K. time

The Embarcadero Technologies Technical Support fax number is +44 (0)1628 684 401.

Via Email
United States

Depending on your needs, send your email to one of the following:

e support@embarcadero.com - Get technical support for users and evaluators

® upgrade@embarcadero.com - Request upgrade information

¢ key@embarcadero.com - Request a product key

* wish@embarcadero.com - Make a suggestion about one of our products
EMEA

Depending on your needs, send your email to one of the following:

e uk.support@embarcadero.com- Get technical support for users and evaluators

e uk.upgrade@embarcadero.com - Request upgrade information

e uk key@embarcadero.com - Request a product key

* uk.wish@embarcadero.com - Make a suggestion about one of our products
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APPLICATION BASICS

Application Basics acquaints you with the application and provides information about what ER/
Studio BA offers in the way of design, navigation, and general application features. The
information presented here is high-level and conceptual. For information on how to use the ER/
Studio BA feature set, see Using ER/Studio Business Architect.

ER/Studio BA uses workspaces and projects to organize business process and conceptual
modeling. You can use diagrams to create a visual model of both business process and
conceptual modeling systems. You can navigate ER/Studio BA by using the application toolbars,
menus, shortcut menus, and the keyboard commands.

Application Basics includes three sections:

Topic Description

Product Design Explains the views and windows that make up ER/Studio BA.

Navigation Explains the ER/Studio BA Model View, toolbars, menus,
palettes, and keyboard commands used to navigate the
application.

Preferences Explains the different ways you can configure default application
settings using Preferences.

PRODUCT DESIGN

ER/Studio BA consists of views and windows used to edit, navigate, and display information
about each workspace and its corresponding diagrams. The application is broken down into five
main categories: Workspaces, Projects, Models, Diagrams, and the Grid Editor.

Workspaces

A workspace is a unit of storage used for any collection of data modeling projects in ER/Studio
BA. You can only open and work with one workspace at a time, but you can add any number of
projects and models in a single workspace.

For more information, see Using Workspaces.

Projects

A project is a unit of storage used for any collection of models and their associated elements in
ER/Studio BA. You can have multiple Projects open simultaneously so you can easily switch back
and forth between Projects.

For more information, see Using Projects.
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Models

You can create Business Process and Conceptual models. A model is a specific collection of
elements/objects related to a specific modeling type, for example the Business Process
Modeling Notation (BPMN). A BPMN model would contain those objects associated with a
specific business processes: tasks, swimlanes, gateways, etc. Objects within a model are
displayed in the Model View tree by type (for example, a grouping node contains all of the tasks
within the project).

NOTE: If you are modeling with the Business Process Modeling Notation, you can create a
model in ‘Validation” mode, which enforces the rules of the Business Process Modeling
Notation. With Validation set to Off you can use the visual drawing objects without
being constrained by the rules of the notation.

For more information, see Working with Models.

Diagrams
You can create two different types of diagrams:
* Business Process Diagram (BPD): This type of diagram uses a flowcharting technique which
is tailored for creating graphical models of business process operations. A Business Process

Model is a network of graphical objects, which track the flow of activities and their order of
execution.

¢ Conceptual Diagrams: This is a high level diagram used to explain entities related to the
business/organization.

For more information, see Using Diagrams.

Grid Editor

The Grid Editor enables you to view the objects in the Model View tree in a spread-sheet format.
It can be launched from most nodes in the Model View tree. When launched, the Grid Editor
appears in the diagram area. If a diagram is already open, it appears as an additional tab.

NOTE: |If afilter has been set in the tree, this filter carries over to the Grid Editor.

For more information, see Grid Editor.
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NAVIGATION

ER/Studio BA provides tools for navigating the product functionality, and for navigating within
and between projects and diagrams. The main navigational areas are:

Model View

Palettes

Toolbars

e Menus

Shortcut Menus

Keyboard Commands

MODEL VIEW

The Model View appears in the upper left portion of the ER/Studio BA application by default. It
contains the Model View tree displaying the hierarchy of workspaces, projects, models,
diagrams, and elements. It also displays the hierarchy of reference elements. Workspaces,
projects, models, diagrams, and elements can be created, organized, and viewed.

For more information, see The Model View.

PALETTES

The Palette contains the palettes used to create modeling diagrams in the Diagram View. You
can change the display settings of this palette.

There are seven main palettes: Business Process Objects, Conceptual Objects, Reference
Objects, External Data Objects, and Drawing Shapes.

The Modeling palette that is available in the palette depends on what model type you are
working with. For example, if you are working in a Business Process Model diagram, the
associated palette appears. If you are working with a Conceptual Model diagram, the Business
Process Model palette is replaced by the Conceptual Model palette.

For more information, see Using the Palette.

Palette Icons

The table below describes the main elements on the Palette:

Element Palette Icon | Description

Select % The select cursor allows you to click on
elements and select commands.

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 21



APPLICATION BASICS > NAVIGATION

Element Palette Icon | Description

Marquee 5 Click this cursor to select multiple
items by enclosing them in a frame.

Business There are six main groups of notation
Process elements:
Objects Events: There are three types of events:

Start, Intermediate, and End.

Activities: Activities available are:
Tasks, Embedded Sub-processes, and
Independent Sub-processes.

Gateways: Gateways control sequence
flows. There are five different gateway
control types which indicate the flow
control behavior.

Connection Elements: There are three
different elements used to connect
elements: Sequence Flow, Message
Flow, and Association.

Swimlanes: There are two elements
(pools and lanes) that are used to help
partition and organize activities.

Artifacts: There are four different
artifacts that allow you to show
additional information: Data Objects,
Groups, Annotations, and Off-Page

Connectors.
Conceptual This palette contains the five objects
Objects used in Conceptual Modeling
Reference This palette displays the four available
Objects reference objects and the link.

External Data The External Data Objects palette

% =

Objects displays the seven different data
objects available.

Drawing M The drawing shapes node contains

Shapes nine basic shapes you can use to

create diagrams. This palette also
includes a text label, line, and
annotation.
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Palette Settings Dialog

The Palette Settings dialog box is where you specify display options for the palette. To open this
dialog, right click on any object on the Palette and click Settings. The table below describes the
display options:

Option Description

Layout Columns: Icons in the palette are displayed in columns.
List: Icons in the palette are listed below each main heading.
List: Displays both the icon and its descriptive text.

Icons Only: Only the icons in the palette are displayed. No
labels are shown.

Details: Icons in the palette are displayed with labels and
descriptions.

Layout Options The layout option displayed depends on which Layout type
you select.
Drawer Options The contents in the palette are organized using drawers, which

open and close. Each group element contains specific Palette
Entries. An Entry defines a tool or template for the User. Select
one of the options listed below to determine the drawer’s
behavior.

¢ Always close when opening another drawer.
¢ Close automatically when there is not enough room.

* Never close.

BUSINESS PROCESS OBJECTS PALETTE

This palette appears in the Diagram Area when you open or create a Business Process diagram.
It is not available if a Conceptual Model is open. If a element has additional options available, a
drop-down menu appears to the right of the icon and element name in the palette. For
example, if you click the End Event element, six additional end event types are available.

Element | Palette Icon | Description

Start Events

Start Event @ Initiates the start of a Process.

Link = A mechanism for connecting the end
of one Process to the start (or trigger)
of another.

Message [ A message arrives from a participant

and triggers the start of the Process.

This type of event is triggered when
the conditions for a rule become true.

e

c

:
[iid]
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Element

Palette Icon

Description

Timer

I.;"j

A specific time-date or a specific cycle
(e.g., every Friday at 10:00 a.m.) is set
that triggers the start of the Process.

Intermediate Events

Intermediate Event

Happens during the course of a
process event.

Cancel

This trigger is used within a Transaction
Sub-process. This type of event must
be attached to the boundary of a Sub-
process.

Compensation

Compensation is when activities are
invoked that undo an undesirable
outcome.

=
=
o
=

The trigger sets or catches errors. It
sets an error if the Event is part of a
Normal Flow. It reacts to a named error
when attached to the boundary of an
activity.

(.
=)
=~

Connects an End Event of one Process
to an Intermediate Event in another
Process.

Message

A message arrives from a participant
and triggers an Event. The Process
then continues if it is waiting for a
message, or changes the flow for
exception handling.

Y
=
o

This trigger is only used for exception
handling. This event is triggered when
a Rule becomes True. A Rule is an
expression that evaluates some
Process data.

Timer

A specific time-date or cycle is set that
triggers an Event. It can act as a delay
mechanism if used within the main
flow. If used for exception handling, it
changes the Normal Flow into an
Exception Flow.

End Events

End Event

Ends a process flow.

24
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Element

Palette Icon

Description

Cancel

b4

The type of End is used within a
Transaction Sub-process. It indicates
that the Transaction should be
cancelled and triggers a Cancel
Intermediate Event attached to the
Sub-process boundary. It also indicates
that a Transaction Protocol Cancel
message should be sent to any Entities
involved in the Transaction.

Compensation

This End indicates that a
Compensation is necessary. The
Compensation identifier triggers an
intermediate Event when the Process is
rolling back.

A named Error should be generated.
This Error is caught by an Intermediate
Event within the Event Context.

A Link is a mechanism for connecting
the end of one process to the start of
another.

Message

A message is sent to a participant at
the conclusion of the process.

Terminate

All activities in the Process should be
ended immediately. The Process is
ended without compensation or event
handling.

Tasks

Task

[

This is an activity that is performed
within a business process.

Loop Task

El

The attributes of Tasks and Sub-
processes determine if they are
repeated or performed once. There are
two types of loops: Standard and
Multi-Instance. The looping indicator is
displayed at the bottom-center of the
activity.

Parallel Multiple
Instance Loop Task

=l

This refers to parallel multiple
instances of the activities. Activities
that are Parallel Multi-Instance have a
parallel marker placed in the bottom
center of the activity.

Sequential Multiple
Instance Loop Task

=l

This refers to sequential multiple
instances of the activities. Activities
that are sequential multi-Instance have
a parallel marker placed in the bottom
center of the activity.
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Element Palette Icon | Description

Embedded Sub-Processes

Embedded Sub- =1 An Embedded (or nested) Sub-process
Process is an activity that contains other

activities (a Process). The Process
within the Process is dependent on the
parent Process for instigation and has
visibility to the parent’s global data. No
mapping of data is required.

Embedded Sub- Select this icon to place a collapsed
Process (Collapsed) embedded sub-process in the Diagram
View

o]

Ad Hoc Embedded
Sub-process

An Ad Hoc Process is a group of
activities that have no pre-definable
sequence relationships.

vE

Activities within the Process are
disconnected from each other. During
execution of the Process, any one or
more of the activities may be active
and they can be performed in almost
any order or frequency.

The attributes of Tasks and Sub-
processes will determine if they are
repeated or performed once. There are
two types of loops: Standard and
Multi- Instance. A small looping
indicator is displayed at the bottom-
center of the activity.

Parallel Multiple The attributes of Tasks and Sub-
Instance Embedded processes determine if they are
Sub-process repeated or performed once. A small
parallel indicator is displayed at the
bottom-center of the activity.

Serial Multiple The attributes of Tasks and Sub-
Instance Embedded processes determine if they are
Sub-process repeated or performed once. A small
parallel indicator is displayed at the
bottom-center of the activity.

Loop Embedded
Sub-process

o

=

=

Transaction =] A Sub-process, either collapsed or
Embedded Sub- expanded, can be set as being a
process Transaction, which has a special

behavior that is controlled through a
transaction protocol (such as BTP or
WS-Transaction). The boundary of the
activity is double-lined to indicate that
itis a Transaction.

Independent Sub-processes

Independent Sub- (oY An independent Sub-process element
Process is an activity within a Process that calls
to another process that exists within a
business process definition diagram.
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Element Palette Icon | Description

Loop Independent i) The attributes of Tasks and Sub-

Sub-process e processes will determine if they are
repeated or performed once. There are
two types of loops: Standard and
Multi- Instance. A small looping
indicator is displayed at the bottom-
center of the activity.

Parallel Multiple = The attributes of Tasks and Sub-

Instance n processes determine if they are

Independent Sub- repeated or performed once. A small

process parallel indicator is displayed at the
bottom-center of the activity.

Serial Multiple = The attributes of Tasks and Sub-

Instance n processes determine if they are

Independent Sub- repeated or performed once. A small

process parallel indicator is displayed at the
bottom-center of the activity.

Transaction ] A sub-process, either collapsed or

Independent Sub-
process

expanded, can be set as being a
Transaction, which has a special
behavior that is controlled through a
transaction protocol (such as BTP or
WS-Transaction). The activity has a
double border to indicate that it is a
Transaction.

Gateways

Gateway

This symbol displays decisions,
merges, forks, and joins in the process
flow. They control how Sequence Flows
interact as they converge and diverge
within a process. You can set the
Gateway Control Types of a gateway
and change the logic specified by it.

Complex

Decision: This expression determines
which output flow is taken from
multiple Sequence Flow names.

Merge: You specify a complex flow
condition referencing incoming
Sequence Flow names or process data
coming into a gateway. This expression
determines when the task starts.

Data-Based

These are the most common gateways
used. A data token traverses the
Process Flow arriving at the gateway. It
can only go out on one flow. This
control type is represented by either a
diamond with an “x” in the middle or
blank diamond shape.
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Element Palette Icon

Event-Based @

Decision: This represents a branching
point where the alternatives are based
on an event occurring at that point.

Merge: The exclusive merge models
data-based or event-based merges.
Only one of the many inputs is chosen
as the output.

Inclusive @

Decision: One or more of the outgoing
Sequence Flows may be taken. A
default flow must be specified at this
point, there cannot be zero output
flows.

Merge: A process flow continues when
it receives the first input signal from the
input Sequence Flow. If other signals
arrive after that, they are not used.

Parallel @

Fork: All Sequence Flows out of this
gateway are taken.

Join: This gate must receive input
signals from all input Sequence Flows.
The process flow does not continue
until it receives all signals.

Sequence Flows

Sequence Flow -5

A sequence flow shows the sequence
of processes in an organization. You
can use the sequence flow lines to
connect events, activities, and
gateways in pools or lanes. The
Seqguence Flow has five different
designations that can be set using the
Sequence Flow Property View. Double-

click the Sequence Flow to open the
Sequence Flow Properties dialog.

Conditional Flow P A conditional flow is evaluated at
runtime to determine whether or not
the flow is used. If the conditional flow
is outgoing from an activity, then the
Sequence Flow has a mini-diamond at
the beginning of the line. If the
conditional flow is outgoing from a
Gateway, then the line does not have
the diamond.

28
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Element Palette Icon | Description

Default Flow Y For Data-Based Exclusive Decisions or
Inclusive Decisions, one type of flow is
the Default Condition flow. This flow is
used only if all other outgoing
conditional flows are not true at
runtime. These Sequence Flows have a
diagonal slash added to the beginning
of the line.

You would add a Default Conditional
Flow marker to a Sequence Flow for
two types of decision: Data-based
Exclusive and Inclusive Decisions. This
flow is used only if all the other
outgoing conditional flows are not true
at runtime.

Exception Flow 2 Exception Flows occur outside the
normal flow of the Process and it is
based upon an Intermediate Event that
occurs during the performance of the

Process.

Message Flows

Message Flow e Shows the model order of processes
between organizations (i.e. between
pools).

Associations

Association An Association is used to associate

information and artifacts with events
and activities

Association to Target S The Association connection flows from
the source to the target.

Association from PR The Association connection flows from
Target the target to the source.

Association to/from RS The Association connection indicates a
Target flow in both directions.

Pools

Pool (Horizontal) C This pool is drawn as a rectangular

region placed horizontally. A lane is a
subpartition within a pool and extends
the entire length of the pool. A pool
represents an organization, function,
application, class, or an entity.

Pool (Vertical) D This pool is drawn as a rectangular
region placed vertically. It has the same
characteristics as the horizontal pool.

Lanes
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Element Palette Icon | Description

Lanes = Lanes organize and categorize
activities. When you place a process in
a pool or lane you specify who is doing
what. If you place an event in a lane
you specify where that event occurs.
When you place a gateway in a lane
you specify where a decision is made
or who makes it.

Nested Lane You can place lanes within existing
lanes with this object.

Artifacts

Data Object Data objects provide information
about how documents, data, and other
objects are used and updated in a
Process. They represent data so are
defined by a combination of entities or
classes.

.\
-

Use the Group symbol to visually
organize activities.

Group

Annotation C Textual annotation allows you to
provide additional facts and details
about an element.

Off-Page Connector ©) If a process model extends beyond the

length of one printed page you can
use a Off-Page Connector to show how
Sequence Flow connections extend
across the page breaks.

CONCEPTUAL OBJECTS PALETTE

This palette appears in the Diagram Area when you open or create a Conceptual Model
diagram. It is not available if a Business Process Model is open. If a element has additional
options available, a drop-down menu appears to the right of the icon and element name in the
palette. For example, if you click the Relationship element, additional relationship types are
available.

Artifact Palette Icon Description
Subject Area @ Describes the broad term of the business. It can be

used by itself as a model object and/or as a
grouping mechanism containing business entities.

Business Entities @ “Thing” of the business/organization containing
other business entities or elements, for example,
inventory.

Business A property of a business entity, for example, an

=1

Attributes employee identification number. You can copy and
paste an attribute from one Business Entity to
another within the same workspace.
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Artifact Palette Icon Description

Interaction —5 Relationship between two elements representing
an action or process or transaction. Interactions
can be created between different types.

Group P A graphical object to visually show that items are

’ grouped together.
Relationship
Relationship | .. Relationship between two elements representing a

loose couple. Relationships can only be created
between conceptual modeling elements of the
same type. A warning dialog opens if you try to
create a relationship between different types.

Many-to-Many

Denotes that many components are related to
many components.

Many-to-One = Denotes that many components are related to one
component.

One-to-Many —_ Denotes that one component is related to many
components.

Group

Group P A graphical object to visually show that items are

grouped together.

REFERENCE OBJECTS PALETTE

The Reference Object Palette displays the four main reference objects as well as the Link and
Usage connectors. Domains are not visualized on diagrams so the Domain element icon is not
available on the Reference Object’s palette T

Reference Object

Palette Icon

Definition

Business Element

@

A singular element of the business that can be
bound to different business attributes across
conceptual models. A Business Element can be
used to seed business attributes in a business
entity.

Business Rule

A business rule is a policy, practice, or formula
related to the operation and enforcement of
business practices.

Business Unit

A business unit is an organizational area within or
external to an enterprise.

Stewards

A steward is a person or organization responsible
to, or associated with a model element.
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Reference Object Palette Icon | Definition
Links
Link =5 This link displays high-level views of information

requirements. This type is used to simply relate
objects together. The link you create is labeled
“conceptual”.

Usage u When you select this option you create a link that
enables you to designate a usage type: create,
read, update, or delete database records. The
connection you create is labeled “usage”

EXTERNAL DATA OBJECTS PALETTE
You can use an External Data Object (EDO) in a diagram for reference or for data flow
diagramming. You can then link to External Data Objects with a specific business process or task.

There are two different types of EDOs: Logical and Physical. The Logical types are entities and
attributes. The Physical types are tables and views.

Type Palette Icon Description

Entity ﬁ A set of distinguishable objects that
can be represented in a database.

Table A set of data in a database.

View a A view of the data, usually consists of a
subset of the tables in the database.

Data Store T A repository for data.

Data Feed Q A shell for data containment.

Report A text file

Flat File A file containing records, one record
per line. Fields may have a fixed width
with padding, or delimited by white
space, tabs, commas (CSV), or other
characters. There are no structural
relationships.
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All drawing shapes can be resized, formatted, and labeled. You can also format the shapes to be

either shadowed or transparent.

Type Palette Icon Description

Rectangle = Rectangle is drawn as a box with 90
degree angles.

Rounded = Rectangle drawn with rounded corners.

Rectangle

Circle o Drawn as 360 degree circle. Can be
resized to an oval.

Triangle i Drawn as a standard isosceles triangle.

Diamond & Standard diamond shape.

Pentagon ) Standard five-sided pentagon.

Hexagon @ Standard six-sided hexagon.

Octagon @ Standard eight-sided octagon.

Cylinder 5 Standard cylinder shape.

Text Label A text label is a non-BPMN object that

is pure text, without a tail or bracket.

You can add borders to the label, and
change the color and width of those
borders.

Line Ve Aline can be used between two
drawing shape objects.

Annotation C A textual annotation allows you to
provide additional facts and details
about a shape.

USING THE PALETTE

You use the Palette to place objects in the Diagram View. You have the option of expanding or

minimizing the palette view.
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Expanding the Palette View

You can expand or collapse this view. If you want to expand it, click the arrow indicator located at
the top of the palette. Also, if you place the cursor anywhere over the palette when it is
minimized, it automatically expands.

8=

(==

Palette

Placing Elements in a Diagram

When you place an element from the Palette in the Diagram View a new element is created in
the diagram and in the Model View tree.

NOTE: If you create an element from the Model View tree, a graphical representation of that
element is not created on a diagram until a diagram is created and you drag the
element from the tree to the diagram.

1 Select the element you want to use from the palettes.

NOTE: Some items on the palette have a drop-down indicator. Click this to gain access to
additional selections that are related to the selected element.

Palette L
% Select

L.f Marques
Dg Business Process -
(@) Start Event =

v @ Skart Event
[E8 Message Start Event
-__{;__-I'Timer Skart Event
Rule Start Event
& Link Start Event

FraiEss l I

2 Click anywhere in the Diagram View.
Each time you click in the Diagram View, an element is placed on the diagram. Notice that

the cursor is in multi-drop mode %Eﬂ
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3 Press ESC to disable the multi-drop mode. The cursor returns to its normal mode ( &).

NOTE:

You can also disable the multi-drop mode by right-clicking in the element. The shortcut

menu opens and once you close this menu you are no longer in multi-drop mode.

TOOLBARS

By using the application toolbars you can navigate the most commonly used functionality in ER/
Studio BA. You can also move and dock toolbars to further optimize your workspace. ER/Studio
BA has the following toolbars:

Toolbar

Description

Business Process Objects
Toolbar

Contains the notation elements used
when creating business process
models.

Conceptual Objects Toolbar

Contains the five notation elements
used when creating conceptual
models.

Reference Objects Toolbar

Contains the icons representing the
four reference objects used in ER/
Studio BA.

External Data Objects
Toolbar

Contains the available data object
icons that represent different types of
data.

Drawing Shapes Toolbar

Contains drawing shapes, text labels,
lines and annotation elements.

Repository Toolbar

Commands used to interface with the
ER/Studio Repository, such as logging
in and logging out of the Repository,
and checking in and checking out
workspaces and objects.

Formatting Toolbars

Commands used to format elements in
the Diagram View.

Layout and Alignment
Toolbar

Commands used to align and layout
elements in the Diagram View.

Standard Toolbar

Contains the standard application
tools such as saving, printing, and
undo-redo.

Business Process Objects Toolbar

You can use the commands on this toolbar for placing business process elements in a diagram.
These commands are also available on the Palette which is available when you create a new
diagram or open an existing diagram.
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You have the ability to show and hide this toolbar using the View main menu. By default, the
Business Process Toolbar appears in the application once you have created a diagram. Do the
following to hide this toolbar:

NOTE: Not all objects appear on the toolbar. A drop-down arrow appears to the right of the
element icon, indicating that additional selections are available.

1 On the main menu, click View > Toolbars.
2 From the pull-right menu, select Business Process Objects. The toolbar is now hidden.

The table below lists each command, its representative icon, and a brief description of each
command.

| @-90-@-W-B - B-® =~ A== EF000 @ |

Command Icon Description

Start Event @ Starts a process flow. In terms of Sequence Flow, the

Start Event starts the flow of the Process, so it won't
have any incoming Sequence Flows. Click the drop-
down arrow to gain access to the Start Event trigger
that indicates how the Process starts: Message,
Timer, Rule, Link, or Multiple.

Intermediate Q} This event happens during the course of a process
Event event. Click the drop-down arrow to gain access to
the Intermediate Event trigger that indicates how
the Process proceeds: Cancel, Compensation, Error,
Link, Message, Rule, or Timer.

End Event Q This event ends a process flow. Click the drop-down
arrow to gain access to the End Event trigger that

indicates how the Process ends: Cancel,

Compensation, Error, Link, Message, or Terminate.

Task This is an activity that is performed within a business

-]
process. Click the drop-down arrow to gain access
to additional tasks: Loop Task, Parallel Multiple
Instance Loop Task, and Sequential Multiple
Instance Loop Task.
Embedded =1 An Embedded (or nested) Sub-process is an activity

Sub-process that contains other activities (a Process). The Process
within the Process depends on the parent Process
for instigation and has visibility to the parent’s global
data. No mapping of data is required. Click the
drop-down arrow to gain access to additional
Embedded Sub-processes: Embedded Sub-Process
(Collapsed), Ad hoc, Loop, Parallel Multiple Instance
Loop, Sequential Multiple Instance, and Transaction.
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Command Icon Description

Independent An independent Sub-process is an activity within a
Sub-process Process that calls to another Process that exists
within a business process definition diagram. Click
the drop-down arrow to gain access to additional
Independent Sub-processes: Loop, Parallel Multiple
Instance Loop, Sequential Multiple Instance, and
Transaction.

El

Gateway & This symbol displays decisions, merges, forks and
joins in the process flow. They control how
Sequence Flows interact as they converge and
diverge within a process. You can set the Gateway
Control Types of a gateway and change the logic
specified by it. Click the drop-down arrow to gain
access to additional gateways: Complex, Data-
Based, Event-Based, Inclusive, and Parallel.

Sequence — A Sequence Flow shows the sequence of processes
Flow in an organization. You can use the sequence flow
lines to connect events, tasks, activities, and
gateways in pools or lanes. Click the drop-down
arrow to gain access to additional Sequence Flows:
Conditional, Default, and Exception.

Message ) Shows the order of processes between
Flow organizations (i.e. between pools).

Association | . An Association is used to associate information and

artifacts with events and activities. Click the drop-
down to gain access to additional Associations:
Association from Target, Association to Target, and
Association to/from Target.

Pool [ This pool is drawn as a rectangular region placed
(Horizontal) horizontally and a lane is a subpartition within a pool
and extends the entire length of the pool. A pool
represents an organization, function, application,
class, or an entity.

When you place a process in a pool or lane you
specify who is doing what. If you place an event in a
pool or lane you specify where that event occurs.
When you place a gateway in a pool or lane you
specify where a decision is made or who makes it.

Pool (Vertical) D This pool is drawn as a rectangular region placed

vertically and a lane is a subpartition within a pool
and extends the entire length of the pool. A pool
represents an organization, function, application,
class, or an entity.

When you place a process in a pool or lane you
specify who is doing what. If you place an eventin a
pool or lane you specify where that event occurs.
When you place a gateway in a pool or lane, you
specify where a decision is made or who makes it.
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Command Icon Description

Lane - A lane is a subpartition within a Pool and extends
the entire length of the pool, either vertically or
horizontally. Lanes are used to organize and
categorize activities.

Nested Lane Lanes can be nested within lanes.

Data Object Data objects provide information about how
documents, data, and other objects are used and
updated in a Process. They represent data so are
defined by a combination of entities or classes.

Group PEeTY Use the Group symbol to visually organize activities.

Annotation C Textual annotation allows you to provide additional
facts and details about an element.

Off-Page o) This is a graphical object that you can use to

Connector indicate to the reader of the diagram to move to the
next page.

Conceptual Objects Toolbar

The table below describes the available shapes. Not all objects appear on the toolbar. A drop-
down arrow appears to the right of the element icon, indicating that additional selections are

available.

=1

. @ (1)

Element

Toolbar Icon

Description

Subject Area

L

A subject area can be a model object
or a grouping mechanism containing
business entities. Examples of a
subject area are a Customer
Relationship Management system, or a
Point of Sale system.

Business
Entity

Elements of a business or organization
containing other business entities or
elements. Examples of an entity would
a customer or a product.

Business
Attribute

=1

Abusiness attribute is the property of a
business entity. Examples of attributes
would be a customer address or an
employee identification number.

Interaction

This is the relationship between two
elements representing an action,
process, or transaction.
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Element Toolbar Icon

Description

Relationship

Displays relationships between two
objects representing a loose coupling.
The relationships are between two like
object types. Click the drop-down
arrow to gain access to additional
relationships types: many-to-many,
many-to-one, and one-to-many.

Group eroa

Use the Group symbol to visually
organize activities.

External Data Objects Toolbar
The table below describes the objects available on this toolbar.

HEETQBEM

Element Toolbar Icon | Description

Entity ﬁ Distinguishable objects that can be
represented in a database

Table A set of data in a database.

Data Store m A data store is a repository for data.

Data Feed Q A shell for data containment.

Report This is a text file.

Flat File Aflat file is a file containing records,
one record per line. Fields may have a
fixed width with padding, or delimited
by white space or tabs or commas
(CSV) or other characters. There are no
structural relationships.

Drawing Shapes Toolbar

APPLICATION BASICS > NAVIGATION

Drawing Shapes are used to provide additional information about the Process. There are nine
drawing shapes, a text label, a line, and an annotation. The table below displays the available

shapes.
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EE0Av@@EOET-C

Element Toolbar Icon | Description

Rectangle = Rectangle is drawn as a box with 90
degree angles. Can be resized.

Rounded = Rectangle drawn with rounded corners.

Rectangle

Circle o Drawn as 360 degree circle. Can be
resized to an oval.

Triangle 'y Drawn as a standard isosceles triangle.

Diamond & Standard diamond shape.

Pentagon & Standard five-sided pentagon.

Hexagon & Standard six-sided hexagon.

Octagon @ Standard eight-sided octagon.

Cylinder 5 Standard cylinder.

Text Label A text label is a non-BPMN object that

is pure text, without a tail or bracket.
You can add borders to the label, and
change the color and width of those
borders.

Line s Aline can be used between two
drawing shape objects. The line is
automatically elbowed.

Annotation C Textual annotation allows you to
provide additional facts and details
about a shape.
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Repository Toolbar

You can use the commands on the Repository toolbar to log in and out of the Repository, and
check in and out workspaces, diagrams, and objects. The table below lists each command and
its representative icon, and provides a brief description of each command.

M PEERYHYEED D W0

NOTE: The commands on the Repository toolbar will be unavailable until you log in to the
Repository. For information on specifying the Repository details, see. For information

on logging in to the Repository, see Logging In and Out of the Repository.

Element Toolbar Icon | Description

= Logs you into the Repository specified
sl in Window > Preferences > Repository.
Users must be defined in the
Repository. For information on creating
users, see the “Administrator’s
Reference Guide” in the ER/Studio

LogIn

User Guide.

Log Out Xij Logs you out of the Repository. When

- you are not using Repository

commands you should log out.

Add Copies the local open workspace to

Workspace qg the Repository and changes the
permissions of the open workspace to
read-only.

Get Copies the latest version of a

Workspace QIE workspace in the Repository to local
storage. Opens a dialog where you can
browse through the Repository for the
desired workspace.

Get Latest Updates the local copy of the

Version dﬁb workspace with the copy that is in the
Repository.

Check Out Changes the permissions of the

Workspace 3 workspace to read-write and records in
the Repository that this workspace has
been exclusively checked out. Other
users cannot check out the same
workspace simultaneously.

Undo Check a Makes the workspace available for
Out 5 other users to check out. Permissions
Workspace of the local copy are changed to read-

only.
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Element Toolbar Icon | Description
Check In Updates the Repository version of the
Workspace ﬂ open Workspace and changes the

permissions of the local copy to read-

only.

Delete Deletes the open workspace from the

Workspace @ Repository. The local copy of the
workspace is not deleted.

Check Out oy Changes the permissions of the local

Object(s) copy of the selected object(s) to read-
write and marks the Repository copy as
exclusively checked out. Other users
cannot check out the same object(s)
simultaneously.

Check In Updates the Repository copy of the

Object(s) 0 selected object with the local object
content. You can check in Diagrams
and Models using this command.

Change Allows the logged in user to change

Password all their Repository account password.

Formatting Toolbars

You can use the commands on the formatting toolbar to format the elements in the Diagram
View. You can use this toolbar to format the fonts, as well as the line and background color of
any element in the Diagram View. Also, you can hide or show this toolbar in the application.

To format an element:
1 Select an element you want to change, for example a Task.
2 If you want to change this task’s background color click the drop-down arrow next to the

Change Fill icon (1) on the Formatting Toolbar. A list of all available colors opens.

3 Select the color you want to use. The task’s background color changes and the color list
closes.

To Hide or Show the Formatting toolbar:

You have the ability to show and hide this toolbar using the View main menu. By default, the
Formatting Toolbar automatically appears in the application. Do the following to hide this
toolbar:

1 On the main menu, click View > Toolbars.
2 From the pull-right menu, select Formatting. The toolbar is now hidden.

The table below lists each command, its representative icon, and a brief description of each
command.
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Vs v (Blz s u A=

Arial

Command Toolbar Icon | Description

Font Select a new font from the drop-down

Selection list box.

Font Size 5 Select a new font size from the drop-

Selection A down list box.

Bold R Applies bold formatting to the
selected text.

Italics I ltalicizes the selected text.

Strikeout S A line is drawn through the selected
text.

Underline u Underlines the selected text.

Change Font A A drop-down menu opens a color

Color

palette. When you select a color from
the palette, the selected text is now
displayed in the selected color.

This list includes the color labeled
"default blue” which is the default
color used as the fill color for all
Business Process Modeling Notation
objects.

Change Line }. - A drop-down menu opens a color

Color g palette. When you select a color from
the palette, the border of the selected
object is now displayed in the selected
color.

Change Fill % . A drop-down menu opens a color

Color palette. When you select a color from
that palette, the background of the
selected object now displays the
selected color.

Left Justify = Justifies the text on the left side of the

Text - element.

Center Text Centers the text in the element.
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Command Toolbar Icon | Description

Right Justify = Justifies the text on the right side of
Text - the element.

Align Text - Aligns the text to the top of an

Top element.

Align Text - — Vertically centers the text in an
Center = element.

Align Text - Aligns the text to the bottom of an
Bottom = element.

Increase Font

Each time you click this icon, the font

) A . ; .
Size size of the selected object’s label is
increased by one point size.
Decrease - Each time you click this icon, the font
Font Size A size of the selected object’s label is

decreased by one point size.

Layout and Alignment Toolbar

The table below lists each command, its representative icon, and a brief description of each

command.

| B2 %3 i

momas H L Il 5 @ B D

Command Toolbar Icon | Description
Align Left o Left aligns all selected elements with
I the selected element.
Align Right aE Right aligns all selected elements with
w1 the selected element.
Align Top or Aligns all selected elements with the
d top of the selected element.
Align Bottom y Aligns all selected elements with the
ot
- bottom of the selected element.
Center |, Centers vertically the selected
Vertically +la elements with the center of the
selected element.
44
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Command Toolbar Icon | Description

Center Las Centers horizontally the selected

Horizontally ta elements with the center of the
selected element.

Distributing Hi Evenly distributes three or more nodes

Horizontally horizontally.

Distributing E Evenly distributes three or more nodes

Vertically vertically.

Match Width All selected elements are resized to

=l
—H
=

match the width of the widest selected

element. The selected element has
black handles.

Match Height

(u

All selected elements are resized to
match the height of the longest
selected element. The selected
element has black handles

Bring to Front

If multiple elements are stacked, click
this icon to bring the selected element
to the top or front of the stack.

Send to Back

If multiple elements are stacked, click
this icon to drop the selected element
to the back of the stack. An outline of
the moved element appears in the
stack showing the location of the
moved element.

Group E Groups two or more selected elements
. into a single entity that can be moved
around a diagram.
Ungroup Removes the selected grouping. This

command is available only if the
element selected is in a group.
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Aligning Elements in the Diagram View
Take the following steps to align elements within the Diagram View:

1 Select the elements you want to align by holding down the mouse button and drawing a box
around the items you want included. All items within the selection box are now marked.

2 Shift+click the element you want to align all other elements with. That element is now
highlighted with black boxes instead of hollow boxes.

™ Y
Nl
Start End
Bwvent Bwent

3 Click the alignment command and all elements are aligned with the selected element. In the
example below all elements are centered vertically g with the start event.

-
®

Start
Evert

By default, the Layout and Alignment Toolbar automatically appears in the application. Do the
following to hide this toolbar:

1 On the main menu, click View > Toolbars.

2 From the pull-right menu, select Layout and Alignment and the toolbar is now hidden.

Distributing Horizontally

Once you place elements in the Diagram View you can evenly distribute those elements
horizontally.

1 Select three or more elements in the Diagram View.

NOTE: Elements don't have to all be the same (i.e., all tasks or all reference objects).
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Click [H] and the selected elements are spaced equidistantly from each other on a
horizontal plane.

NOTE: Only the spacing between the elements are changed, not the vertical placement of the
elements in the diagram.

Taskz2

.

Task1 i
Task3

Distributing Vertically

Once you place elements in the Diagram View you can evenly distribute those elements
vertically.

1

Select three or more elements in the Diagram View.

NOTE: Elements don't have to all be the same (i.e., all tasks or all reference objects).

Click I and the selected elements are spaced equidistantly from each other on a vertical
plane.

NOTE: Only the spacing between the elements are changed, not the horizontal placement of
the elements in the diagram.

Task1

Task?2

Task3

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 47



APPLICATION BASICS > NAVIGATION

Reference Objects Toolbar

You can create a link between elements and add a reference object to the Diagram View from
the Reference Objects palette. The table below lists each object, its representative icon, and a
brief description of each object.

@& E

el

Command Toolbar Icon | Description
Business @ A singular element of the business that
Element can be bound to different business

attributes across conceptual models.
Can be used to seed business
attributes in a business entity.

Business Rule

A business rule is a policy, practice, or
formula related to the operation and
enforcement of business practices.

Business Unit

A business unit is an organizational
area within or external to an enterprise.

Steward

& | a6

A steward is a person or organization
responsible or associated with a model
element.

Link

Display high-level views of information
requirements. This type is used to
simply relate objects together.

Usage

You can label the function of the
connection as create, read, update, or
delete database records. All created
connections are labeled “usage”.

Standard Toolbar

The Standard Toolbar contains the basic tools used in the application. The table below lists the
commands, the corresponding icons, and a brief description for each.

EH & of B - 100 IS
Command Toolbar_lcon | Description
Save Saves the workspace, project, model,

and/or diagram.
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Command

Toolbar_lcon

Description

Print

Opens the Print dialog box, where you
can print the open diagram in the
active Diagram View.

Export

You can export the Grid Editor and
save in the following formats: csy, html,

pdf, and rtf.

Cut

When you cut an element, the
application removes it from the
diagram and places it on a clipboard.
You can then paste the cut element in
the same Diagram window, a different
Diagram window in the same
workspace. The cut item remains on
the clipboard until you cut or copy
another selection.

Copy

When you copy an element, the
application leaves it on the diagram
and places it on a clipboard. You can
then paste the copied element in the
same Diagram window, a different
Diagram window in the same
workspace. The copied item remains
on the clipboard until you cut or copy
another selection.

Paste

You can paste any cut or copied object
into a Diagram window.

Delete

When you want to delete an object
from the Model View tree, the Delete
Elements dialog opens. Click Yes to
permanently remove the object from
the model and the diagram.

When you want to delete an object
from the Diagram View, the Delete
Elements dialog opens. Click Delete to
permanently remove the selected
object from the diagram

Undo

A
G

Standard Undo functionality.

Redo

[
L

Restores the undo command.

Custom Zoom

100% -

Enter a specific percent value for
zooming. You can also pick from
several default zoom percentage
values ranging from 25 percent to 400
percent. You can also select Fit to
Page which fits the entire diagram on
one page.
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Command Toolbar_lcon | Description
Zoom In @ Enlarges the active diagram by a
A preset increment each time you select
this option.
Zoom Out = Reduces the active diagram by a preset
b increment each time you select this
option.
MENUS

You can use the ER/Studio BA menus to gain access its features. The menus are: File, Edit, View,
Repository, Diagram, Format, Tools, Window, and Help.

Menus provide access to many of ER/Studio BA functions. Click any item on the menu bar to
access its submenu items. The table below describes the functions available under the relevant
menu bar items:

Menu Function

Eile Create, open, save, and close the current workspace, its models, projects,
and diagrams. You can also export/import from this menu.

Edit You can access functionality for undo, redo, cutting, copying, pasting,
deleting, and selecting all. You can also access the Find and Search
functionality.

View Gives you access to the toolbars, and zoom levels in a view.

Repository Gives you access to Repository operations such as log in and out, and check
in and out workspaces and objects.

Diagram When a diagram is open, the following commands are available: Case Shift,
Layout, and Grid. The Show All Links and Update Impact Analysis
commands are also available when applicable.

Format You can use these commands in a diagram to group objects, align objects,
or reorder the layers of objects.

Tools Gives you access to the following commands: Create Diagram from
Selected Obijects, Create Link, Create Usage, Generate Impact Analysis
Diagram, Show Diagrams, Grid Editor, and Reports.

Window Reset perspectives, Show Views, or Preferences.

Help You can open ER/Studio BA online documentation, view the licensing
information, open the Evaluation Guide, contact support, and open the
About dialog.
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File

The table below describes the functions available when you click the File command:

Menu Item lcon Description
New - Workspace = Opens the New Workspace dialog where you can create a new
B

workspace, new project, new model, and new diagram.

New - Project E‘ Opens the New Project diagram. You can enter a description of the
new project and select where to create the project.

New - Model 'ﬁ' Opens the New Model dialog. You can enter a description of the
new model and select where to create the model.

New - Diagram The pull-right menu gives you two options: Business Process or
Conceptual. This menu displays the type of diagram to be created.
For example if you are creating a new diagram in a Conceptual
Model, only Conceptual is available from the pull-right menu.You
can enter a description of the new diagram and select where to
create the diagram. You can also rename the pool and lane in the
New Diagram dialog for a Business Process diagram.

Open Workspace... Opens the standard windows dialog listing existing workspaces
from the file system where you can select one to open. You can also
press Ctrl+O.

Close - Workspace Closes the currently opened workspace.

Close - Diagram Closes the active diagram only.

Close - All Diagrams Closes all the opened diagrams. You are prompted to save the
diagrams before they are closed.

Close - All Property Closes all the opened Property Views.

Views

Save = This saves everything in the Workspace. You can also press Ctrl+S.

Import - Comma You can import large amounts of Reference Objects data in the

Separated Values (CSV) Comma Separated Value file format into ER/Studio BA.
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Menu Item lcon Description

Import - From ER/ Conceptual Objects

Studio Data Architect Create New: Select this command to open a wizard where you can

select data files to import from ER/Studio Data Architect.

Update Existing: You can use this option to update an existing data
source. All existing objects that match an object you have selected
will be updated.

External Data Objects

Create New: Select this command to open a wizard where you can
select data files to import from ER/Studio Data Architect.

Update Existing: You can use this option to update an existing data
source. All existing objects that match an object you have selected
will be updated.

Import - Microsoft Visio Diagrams created in Microsoft Visio can be imported.

Modell

=

Import - Workspace You can import a compressed workspace.

-
|

Export - Workspace You can export a workspace and store it as a compressed file.

ml
7|

You can export diagrams and save them in the following file
formats: jpg, rtf, and pdf.

Export - Diagrams

EN

Export - Grid Editor... You can export the Grid Editor in the four formats: csv, html, pdf,

and rtf

il

Export B You can export Conceptual Models and diagrams to ER/Studio.

If you right-click on a Conceptual Model node (ﬁ'), the command
is Export>Model to ERStudio Data Architect.... All elements are
included in the export dialog.

If you right-click on a Conceptual Model diagram node (), the
command is Export Diagram to ER/Studio Data Architect... Only the
elements on the selected diagram are available for export.

Print... c Opens the Print dialog. You can also press Ctrl+P.

History A list of the most recently opened workspaces is displayed. You can
set a preference that determines the number of entries that appear
in this list.

Exit Exits the application. A Save Workspace dialog opens asking if you
want to save the current workspace.
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Edit

The table below describes the functions available when you click the Edit command:

Menu Item Icon Description

Undo v Standard undo functionality.

Redo 5 Standard redo functionality.

Cut of Moves a selected object to the clipboard and removes it from the

diagram display.

Copy -, Copies selected items to the clipboard.
Paste - Pastes the data from the clipboard into a diagram.
Delete % Deletes an object from the Diagram View. The deleted object is not

placed on the clipboard.

Select All Selects all objects in the Diagram View.

Select All of All related types on a Diagram View are selected. For example, if you

Selected Type select a start event and your diagram contains start, intermediate and
end events, all events are selected.

Finding in 44 Opens a dialog where you can search for items by Name and Object

Diagram Type in the opened diagram. The searched-for item is highlighted in the
diagram.

Search... & Opens a dialog for an advanced search of the metamodel. The results of

the search appear in a separate Search Results View dialog.

Properties Opens the Property View dialog for the selected object.
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View

The table below describes the functions available when you click the View command:

Menu Item Description

Toolbars Allows you to hide or view the following:

e Business Process Objects Toolbar

¢ Conceptual Objects Toolbar

e Reference Objects Toolbar

¢ External Data Objects Toolbar

¢ Drawing Shapes Toolbar

¢ Formatting Toolbars

e [ ayout and Alignment Toolbar

Zoom Level Enlarges the active diagram by a preset increment each time you
select this option. You can also use the Fit to Page or Custom
command.

Repository

The table below describes the functions available when you click the Repository command:

Menu ltem Description

LogIn Logs you into the Repository specified in Window > Preferences >
Repository. Users must be defined in the Repository. For
information on creating users, see the “Administrator’s Reference
Guide” in the ER/Studio User Guide.

Log Out Logs you out of the Repository. When you are not using Repository
commands you should log out.

54 ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE



APPLICATION BASICS > NAVIGATION

Menu Item Description

Workspace Add Workspace: Copies the local open workspace to the
Repository and changes the permissions of the open workspace to
read-only.

Get Workspace: Copies the latest version of a workspace in the
Repository to local storage. Opens a dialog where you can browse
through the Repository for the desired workspace.

Get Latest Version: Updates the local copy of the workspace with
the copy that is in the Repository.

Check Out Workspace: Changes the permissions of the workspace
to read-write and records in the Repository that this workspace has
been exclusively checked out. Other users cannot check out the
same workspace simultaneously.

Undo Check Out Workspace: Makes the workspace available for
other users to check out. Permissions of the local copy are changed
to read-only.

Check In Workspace: Updates the Repository version of the open
Workspace and changes the permissions of the local copy to read-
only.

Delete Workspace: Deletes the open workspace from the
Repository. The local copy of the workspace is not deleted.

Check Out Object(s): Changes the permissions of the local copy of
the selected object(s) to read-write and marks the Repository copy

as exclusively checked out. Other users cannot check out the same

object(s) simultaneously.

Check In Object(s): Updates the Repository copy of the selected
object with the local object content. You can check in Diagrams and
Models using this command.

Security Change Password: Allows the logged in user to change their
Repository account password.

Diagram

The table below describes the functions available when you click the Diagram command:

Menu Item Description

Case Shift You can set the case format for all element labels. When you make a
selection, all labels in the diagram conform to the new selection.
You have three options:

Lower: All text appears in lower case lettering, including the initial
letter of each word on the label.

Preserve: All text appears as it was entered in the label.

Upper: All text appears in upper case lettering.
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Menu Item

Description

Grid

This pull-right menu contains three additional commands:
Show Grid Lines: The grid lines appear in the Diagram View.

Show Parent Objects as Transparent: When a parent object such
as a pool or lane is placed on a diagram, the grid lines appear in the
object, i.e. the object is transparent.

Snap Objects to Grid: When an element is placed in the Diagram
View, it automatically snaps to the nearest grid. When an element is
moved, it also snaps to the nearest grid line.

Layout

Select Curved, Elbowed, or Straight for all connections. The default
selection is curved.

Connections

Select this command to display or hide the connections for all or
individual objects in the diagram. The connections available on the
pull-right menu depends on the type of diagram (either Business
Process or Conceptual).

Update Impact
Analysis

Instead of generating a new Impact Analysis diagram each time you
add links or usages, you can refresh or update your existing
diagram to show new connections.

For more information, see Edit Diagrams.

Format

The table below describes the functions available when you click the Format command.

Menu ltem Description

Align Objects Gives you access to all the align and size commands. These
commands are also available on the Align Toolbar.

Grouping Group: Groups two or more selected elements into a single entity
that can be moved around a diagram in a block. The Group
command is available if two or more elements are selected. Once
the items are grouped a bounding box appears around the
grouped items.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Order This command gives your access to two functions: Bring to Front
and Send to Back.

Tools

The table below describes the functions available when you click the Tools command.

Menu ltem

Icon Description

Create Diagram
from Selected

Elements...

You can create new diagrams from existing model objects.
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Menu Item Icon Description

Create Link... =5 Opens the Create Link wizard.

Create Usage... u, Opens the Create Usage wizard.

Impact Analysis == Generate New Diagram: Creates a diagram that shows a graphical

Diagram == representation of created links or usages.

You can also update this diagram.

Show Diagram When a diagram is closed (i.e., not displayed in the Diagram View),
you can select the Show Diagram in model view command to open
the highlighted diagram.

Grid Editor... = The Grid Editor is an spreadsheet-like display format that is an

= alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The Grid
Editor can be printed or exported as a report.

Reports e Impact Analysis: Opens an impact analysis property view of the
selected object.

Web Report: You can generate an HTML report on all diagrams in
the opened workspace.
Window

The table below describes the functions available when you click the Window command:

Menu Item Description
Reset Perspective Reset the current perspective to the default settings.
Show View The commands available are:

Error Logging: Opens the Error Logging View.

Help: Opens online help.
Model: Opens the Model View

Overview: Opens the Overview Window.

Palette: Opens the Palette view in the Diagram View.

Search Results: Opens the Search Results view to the right of the
Diagram View area.

Preferences... Opens the Preferences Editor dialog where you can change default
settings.
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Help

The table below describes the functions available when you click the Help command:

Menu Item lcon Description

Help Contents @ Displays the main online help file.

Evaluation Guide Opens a tutorial which guides you through the initial creation of
business process and conceptual models.

Check for Updates Opens the ER/Studio BA web site where you can download
application updates.

Buy Now Opens the Embaracdero Technologies Product web site where you
can purchase Embarcadero’s software.

Contact Support @ Opens the Embarcadero Technologies Contact Support web site.

Discussion Forums

Opens the Embarcadero Technologies Discussion Forums web site
where you can log on and participate in forums with other users.

Embarcadero License

Manager

Opens the Embarcadero License Manager dialog.

About ER/Studio BA

Opens the About ER/Studio BA dialog displaying the version and
build identification for the current install.

About ER/Studio BA

The About dialog displays the version number, build identification number for your application,
as well as a list of third-party software used in the product. Through this About dialog, you also

have access to Feature Details, Plug-in Details, and Configuration Details.

Click Feature Details and a dialog opens displaying how ER/Studio BA is built internally. This is
for informational purposes only.

Click Plug-in Details and a dialog opens displaying the following information on all the plug-ins

in use:
* Provider
¢ Plug-in Name
® \ersion

¢ Plug-in ID

When you click Configuration Details a dialog opens displaying the following information:

o Platform Details

e System Properties

e Features
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Plug-in Registry

e User Preferences

Current Install Configuration

Configured Sites

Configured Features

Configured Plug-ins

You can copy and save this configuration information to a clipboard. Also, you can view the
Eclipse error log in a separate window.

SHORTCUT MENUS

Many of ER/Studio BA windows incorporate shortcut menus to give you another method for
quickly accessing application functions. The contents of these menus mirror the application's
menu bar functions. To execute shortcut menu options from any selected window, view, dialog,
or element do the following:

1 Right-click the selected object to open the applicable shortcut menu.
2  On the shortcut menu, click the menu item.

There are two main areas where shortcut menus are available: Model View Tree Nodes, and
Diagram View.

MODEL VIEW TREE NODES

The following shortcut menus are available:

* Workspace Node

® Project Node

e Model Node - Conceptual Modeling

e Diagram Node - Business Process Modeling

e Diagram Node - Conceptual Modeling

e | ane Elements on the Model View Tree

e Flements on the Model View Tree

e Search Results View
e Grid Editor

e Error Logging View
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Reference Objects

Palette

Workspace Node

The table below describes the functions available when you right-click the Workspace Node in
the Model View tree:

Reference Object Elements
External Data Objects

Shortcut Menu Item Icon Description

New You can create a new workspace, project, or model from this pull-
right menu.

Open Workspace... =) Select an existing workspace to open.

B
Note: You can only have one workspace open at a time.

Close Closes the current workspace. A Save Resource dialog opens asking
if you want to save the changes.

Save Workspace Saves the current workspace. Note that an asterisk appears on the
Model View tab each time you make any changes to the workspace
and/or its associated projects, models, and diagrams. Once you
save the workspace the asterisk is removed.

Fe) *odel X

Rename Opens the Rename Workspace dialog where you can enter a new
name for the selected workspace. You can also press F2.

Delete ® Select Delete and the Confirm Workspace Delete dialog opens

asking you to confirm your decision.

Import - From ER/
Studio Data Architect

Create New Conceptual Objects: Select this command to open a
wizard where you can select data files to import from ER/Studio
Data Architect.

Update Existing Conceptual Objects: You can use this option to
update an existing data source. All existing objects that match an
object you have selected will be updated.

Import - Microsoft Visio

Opens a wizard that walks you through the importing of a Microsoft

Model Visio model into ER/Studio BA.

Export... e You can export your workspaces in a compressed format which can
then be imported into another ER/Studio BA application on another
computer.

Repository When logged in to ER/Studio Repository, you can check in and

check out Repository workspaces.
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Shortcut Menu Item lcon Description
Insert Project/Model If you have deleted a project or model but did not delete the
associated files, you can select this command to “restore” the
deleted project or model.
Refresh & Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected workspace.

Project Node

The table below describes the functions available when you right-click the Project Node in the

Model View tree:

Shortcut Menu Item lcon Description

New You can create a new project or new model from this pull-right
menu.

Close Closes the open project.

Save Project Saves the current project.

Rename Opens the Rename Project dialog where you can rename the
project and its owning folder.

Delete b4 Select Delete and the Confirm Project Delete dialog opens asking
you to confirm your decision. You have three options in this dialog:
* No, | do not want to delete the project.
® Yes, and also delete the associated files.
® Yes, but do not delete the associated files.

Links =5 If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links > Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link
wizard opens. If there is only one link the command is Links > Edit.

Usage (CRUD) u If you are creating a new usage, click Usage > New and the Usages

wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.
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Shortcut Menu Item lcon Description

Import - From ER/ @ Create New Conceptual Objects: Select this command to open a
Studio Data Architect wizard where you can select data files to import from ER/Studio
Data Architect.

Update Existing Conceptual Objects: You can use this option to
update an existing data source. All existing objects that match an
object you have selected will be updated.

Import - Microsoft Visio @ Opens a wizard that walks you through the importing of a Microsoft
Model Visio model into ER/Studio BA.

Repository When logged in to ER/Studio Repository, you can check in and
check out Repository objects.

Insert Project/Model If you have deleted a project or model but did not delete the
associated files, you can select this command to “restore” the
deleted project or model.

Refresh ey Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected project.

Model Node - Business Process Modeling

The table below describes the functions available when you right-click the Model Node in the
Model View tree:

Shortcut Menu ltem Icon Description

New You can create a new diagram, new model, or new pool from this
pull-right menu.

Open/Close This is a toggle command that closes an open model and vice versa.
Save Model Saves the open model.
Rename Opens the Rename Model dialog where you can rename both the

model and its folder.

Delete b4 Select Delete and the Confirm Model Delete dialog opens asking
you to confirm your decision. You have three options in this dialog:

* No, | do not want to delete the model.
® Yes, and also delete the associated files.

® Yes, but do not delete the associated files.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Link>Edit.

(mE]
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Shortcut Menu Item

lcon

Description

Usage (CRUD)

If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Grid Editor...

The Grid Editor is a spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. Grid
Editors can be printed or exported as a report.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Import - Comma
Separated Values (CSV)

[

You can import large amounts of Reference Objects data in the
Comma Separated Value file format into ER/Studio BA.

Import - Microsoft Visio
Model

Visio model into ER/Studio BA.

Opens a wizard that walks you through the importing of a Microsoft

Export Allows you to export a model to ER/Studio Data Architect.
Repository When logged in to ER/Studio Repository, you can check in and
check out Repository objects.
Insert Model... If you have deleted a model but did not delete the associated files
you can select this command to “restore” the deleted model.
Refresh Py Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected model.

Model Node - Conceptual Modeling

The table below describes the functions available when you right-click the Model Node in the

Model View tree:

Shortcut Menu Item lcon Description

New You can create a new diagram, model, Business Entity or Subject
Area from this pull-right menu.

Open/Close This is a toggle command that closes an open model and vice versa.

Save Model Saves the open model.

Rename Opens the Rename Model dialog where you can rename both the

model and its folder.
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Shortcut Menu Item

lcon

Description

Delete

Select Delete and the Confirm Model Delete dialog opens asking
you to confirm your decision. You have three options in this dialog:

- No, | do not want to delete the model.
- Yes, and also delete the associated files.

- Yes, but do not delete the associated files.

Links

(=]

If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link
wizard opens. If there is only one link the command is Links>Edit.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Grid Editor...

The Grid Editor is a spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. Grid
Editors can be printed or exported as a report.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Import - Comma

Separated Values (CSV)

[

You can import large amounts of Reference Objects data in the
Comma Separated Value file format into ER/Studio BA.

Import - From ER/
Studio Data Architect

Create New Conceptual Objects: Select this command to open a
wizard where you can select data files to import from ER/Studio
Data Architect.

Update Existing Conceptual Objects: You can use this option to
update an existing data source. All existing objects that match an
object you have selected will be updated.

Export Model to ER/
Studio Data Architect

You can export objects on a Model to ER/Studio Data Architect
where the elements in the conceptual diagram map to the logical
diagram in ER/Studio Data Architect.

Repository When logged in to ER/Studio Repository, you can check in and
check out Repository objects.
Insert Model If you have deleted a model but did not delete the associated files
you can select this command to “restore” the deleted project or
model.
Refresh ey Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected model.
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Diagram Node - Business Process Modeling

The table below describes the functions available when you right-click a Business Process

Modeling Diagram Node in the Model View tree:

Shortcut Menu Item

lcon

Description

Open/Close

If the diagram is closed, click this command to open the diagram in
the Diagram View.

Save Diagram

This command is available if any changes have been made to the
open diagram.

Rename

Opens the Rename Diagram dialog.

Delete

Delete the diagram from the Model View tree. A Delete Element
dialog opens asking you to confirm the delete action.

Grid Editor...

The Grid Editor is a spreadsheet-like display format that is an
alternative to the Model View tree view. This view displays the
properties of the selected node. For example the Grid Editor for a
lane would displays all the elements in the lane, the element’s
names, and their descriptions. This is valuable for large objects or
business-related objects, such as business rules. Grid Editors can be
printed or exported as a report.

Export

L.

You can export the opened diagram and save it in the following
formats: csv, html, pdf, and rtf.

Note: This command is available only if the diagram is opened in
the Diagram View area.

Import Comma

Separated Values
(CYV)...

[

You can import large amounts of Reference Objects data in the
Comma Separated Value file format into ER/Studio BA.

Export Diagram to ER/
Studio Data Architect

You can export objects on a Model to ER/Studio Data Architect
where the elements in the business process diagram map to the
logical diagram in ER/Studio Data Architect.

Repository When logged in to ER/Studio Repository, you can check in and
check out Repository objects.
Refresh ey Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected diagram.

Diagram Node - Conceptual Modeling

The table below describes the functions available when you right-click a Conceptual Model

Diagram Node in the Model View tree:

Shortcut Menu Item

lcon

Description

Open/Close

If the diagram is closed, click this command to open the diagram in
the Diagram View.
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Separated Values (CSV)

Shortcut Menu Item lcon Description

Rename Opens the Rename Diagram dialog.

Delete b4 Delete the diagram from the Model View tree. A Delete Element
dialog opens asking you to confirm the delete action.

Grid Editor... = The Grid Editor is a spreadsheet-like display format that is an

= alternative to the Model View tree view. This view displays the

properties of the selected node. This is valuable for large objects or
business-related objects, such as business rules. Grid Editors can be
printed or exported as a report.

Import Comma fag You can import large amounts of Reference Objects data in the

Comma Separated Value file format into ER/Studio BA.

Export Diagram to ER/
Studio Data Architect

You can export elements on a Conceptual Model diagrams to

Embarcadero’s ER/Studio Data Architect application.

Repository When logged in to ER/Studio Repository, you can check in and
check out Repository objects.
Refresh o Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected diagram.

Lane Elements on the Model View Tree

The table below describes the functions available when you right-click a lane on the Model View

tree:

Shortcut Menu Item

lcon

Description

New

This command is available only for pools and lanes in the Model
View tree. When you select this command a pull-right is available to
create a new lane.

Move Lane...

Opens a Move Lane dialog where you can move lanes up or down
in the Model View tree.

Rename

Makes the node name editable. If the diagram is open, it also
renames the element in the Diagram View. You can also click F2.

Delete

This command opens the Delete Elements dialog asking if you are
sure you want to delete the selected elements. Clicking Yes
removes the elements from the project and any diagrams (both in
the Model View tree and in the Diagram View) on which the
elements appear.

Links

(E]

If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link
wizard opens. If there is only one link the command is Links>Edit.

66

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE




APPLICATION BASICS > NAVIGATION

Shortcut Menu Item lcon Description

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
- wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Diagram Usage A pull-right menu lists the diagram(s) the select element appears in.
This allows you to quickly locate and open the diagram where the
element appears. If the element appears on more then ten
diagrams the More... option appears opening a dialog listing all
diagrams.

Impact Analysis You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Refresh i Updates the currently displayed information with new data or
W changes.
Properties Opens the Property View dialog for the selected element.

Elements on the Model View Tree

The table below describes the functions available when you right-click an element on the Model
View tree:

Shortcut Menu Item Icon Description

New Creates a new element which is placed in the Model View tree. The
list of elements available on the pull-right menu depends on the
element you right-click on. This command is not available for all

elements.
Create Diagram from You can create new diagrams from existing model objects.
Selected Elements...
Rename Makes the node name editable. If the diagram is open, it also

renames the element in the Diagram View. You can also click F2.

Delete b4 This command opens the Delete Elements dialog asking if you are
sure you want to delete the selected elements. Clicking Yes
removes the elements from the project and any diagrams (both in
the Model View tree and in the Diagram View) on which the
elements appear.

Create Mapping/Edit If you right-click on a Subject Area you can map to one or more
Mapping Conceptual Model diagrams or Business Entities.
Diagram Mappings This command is available once you have mapped a diagram to a

Subject Area. When it is selected a pull-right menu opens
displaying the mapped diagram(s).
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Shortcut Menu Item lcon Description

Diagram Usage A pull-right menu lists the diagram(s) the select element appears in.
This allows you to quickly locate and open the diagram where the
element appears. If the element appears on more then ten
diagrams the More... option appears opening a dialog listing all
diagrams.

Grid Editor... = The Grid Editor is a spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for
business-related objects, such as business rules. Grid Editors can be
printed or exported as a report.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

=

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
” wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Impact Analysis = You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Refresh o Updates the currently displayed information with new data or
changes.

Properties Opens the Property View dialog for the selected element.

Search Results View

The table below describe the functions available when you right-click a row or cell in the Search
Results view.

Shortcut Menu ltem Description

Name, Type, Description, Notes | By default, all columns are displayed. These are
toggle settings, so you can select or deselect which
columns you want displayed.

Open Search Dialog Opens the Search dialog so you can specify a new
search or modify your existing search.
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Shortcut Menu Item Description
Find In Opens a pull-right menu with the following
commands:

Active Diagram: This command finds and highlights
the selected search item in the active diagram.

All Diagrams: This command searches for the
selected search item on all diagrams in the model.
The Diagram Usage dialog opens displaying all the
diagrams where the element appears.

Model View: Finds the selected search item in the
Model View tree.

Run Previous Search The pull-right menu displays the previous searches.
Up to ten searches are listed. You can also select the
Clear History option.

Filter Results Opens the Search Results Filter dialog. Use this to
refine the search. You can select which types of
objects you don’t want to see in the Results view. You
can expand or collapse the tree. You can also select or
deselect all the tree node items.

Customize Columns Opens the Customize Columns dialog where you
select the columns you want displayed in the Search
Results view.

Properties Opens the Property View for the selected search item.

Grid Editor

The table below describes the functions available when you right-click a row or cell in the Grid
Editor:

Shortcut Menu Item Icon Description

Name Select this command to display the Name column in the Grid Editor.

Data Type Select this command to display the Data Type column in the Grid
Editor.

Type Select this command to display the Type column in the Grid Editor.

E-Mail Address Select this command to display the E-Mail Address column in the
Grid Editor.

Responsibility Select this command to display the Responsibility column in the
Grid Editor.

Description Select this command to display the Description column in the Grid
Editor.

Notes Select this command to display the Notes column in the Grid Editor.

Sort Ascending by Al Reorders the selected column by sorting from A to Z.

Name <

Sort Descending by z| Reorders the selected column by sorting from Z to A.

Name A
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Shortcut Menu Item lcon Description

Customize Columns G Opens the Customize Columns dialog where you can customize the
Grid Editor to display only selected columns. Deselect the columns
you want to hide in the view and click OK. The selected columns no
longer appear and the tab displays the notation that you have
customized this Grid Editor.

Delete b4 Deletes a selected item. A warning dialog opens asking if you are
sure you want to delete the selected item. If you select Yes, the item
is removed not only from the Grid Editor, but also from the

workspace.
Refresh Py Updates the currently displayed information with new data or
= changes. You can also press F5.
Properties Opens the Property View dialog for the selected element.

Error Logging View

You can open the Error View by clicking Window > Show View > Error Logging on the main
menu. The table below describes the functions available when you right-click the Error View:

Shortcut Menu Item lcon Description

Copy - Copies the event details to the clipboard where you can save or

= print it.
Clear Log Viewer 7 Clears all error details from the Log Viewer.
Delete Log b4 The action permanently deletes all log events. When you select this
action a warning dialog opens asking you to confirm the delete
action.
Open Log = Opens the current log file in Notepad.
Restore Log sl Restores all the error details that were cleared using the Clear Log
b Viewer command.

Export Log = You can export the current log to another file location and save it as
b a logfile.

Import Log i= All existing files with the .log extension are listed. The selected
T4 imported log file opens the Error View.

Event Details = Opens the Event Details dialog displaying the date, severity level,
error message, the exception stack trace, and session data.You can
copy the event details to the clip board by clicking [=;.
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Reference Objects

The table below describes the functions available when you right-click the top level Reference
Objects node in the Model View tree:

Acrme Company
@- Compliance Reinstatement Project
= B
-- External Daka Objecks
E’ Business Elements
% Business Rules
=-E8 Business Units
DE Accounting
Finance

: D[E Sales
gl] Camains
]% Stewards

eference COhjects

Shortcut Menu Item Icon Description

New Create a new Business Element, Business Rule, Business Unit,
Domain, or Steward. The available command depends on which
node you select. For example if you right-click Business Rules, the
command is New Business Rule.

Save Project Saves the current project.

Grid Editor... = The Grid Editor is a spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. Grid
Editors can be printed or exported as a report.

Refresh 2 Updates the currently displayed information with new data or
w changes.
Properties Opens the Property View dialog for the selected reference object.

Reference Object Nodes

The table below describes the functions available when you right-click a Reference Objects
Node (for example Business Units) in the Model View tree:
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= ng’ﬂ &cme Company

@- Compliance Reinstatement Project
Elfﬂﬁ Reference Objects

? External Daka Objects

E’ Business Elerments

% Business Rulas
= B2
Accaunting
' D[E Finance

: - OfS Sales
-l Domains
\% Skewards

Shortcut Menu Item lcon Description
New Create a new Business Element, Business Rule, Business Unit,
Domain, or Steward. The available command depends on which
node you select. For example if you right-click Business Rules, the
command is New Business Rule.
Create Diagram from You can create new diagrams from existing model objects.
Selected Elements...
Grid Editor... = The Grid Editor is a spreadsheet-like display format that is an
= alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. Grid
Editors can be printed or exported as a report.
Import Comma By You can import large amounts of Reference Objects data in the
Separated Values (CSV) Comma Separated Value file format into ER/Studio BA.
Refresh Py Updates the currently displayed information with new data or
= changes.
Properties Opens the Property View dialog for the selected reference object.

Reference Object Elements

Once you have created a Reference Object element, a shortcut menu for the newly-created
Reference Object is available:

Shortcut Menu ltem Icon Description

Create Diagram from
Selected Elements

You can create new diagrams from existing model objects.

Rename Makes the node name editable. If the diagram is open, it also

renames the element in the Diagram View. You can also click F2.
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Shortcut Menu Item

lcon

Description

Delete

This command opens the Delete Elements dialog asking if you are
sure you want to delete the selected elements. Clicking Yes
removes the elements from the project and any diagrams (both in
the Model View tree and in the Diagram View) on which the
elements appear.

Links

(=]

If you are creating a new link, click Links > New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link
wizard opens. If there is only one link the command is Links > Edit.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Diagram Usage

A pull-right menu lists the diagram(s) the select element appears in.
This allows you to quickly locate and open the diagram where the
element appears. If the element appears on more then ten
diagrams the More... option appears opening a dialog listing all
diagrams.

Bindings...

This command is available when you right-click on a Business
Element or Domain. It opens the property editor for the selected
element where you can create or edit bindings.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Create as Pool

This command is available only for the Business Unit and Stewards.

Refresh

Updates the currently displayed information with new data or
changes.

Properties

Opens the Property View dialog for the selected element.

External Data Objects

The table below describes the functions available when you right-click the top-level External

Data Objects Node in the Model View tree:

Shortcut Menu ltem lcon Description
New Create a new external data source: data source, entity, table, view,
data store, data feed, report, or flat file.
Close Collapses or expands the list of External Data Objects.
Save Model Saves any changes made.
Grid Editor... = The Grid Editor is a spreadsheet-like display format that is an
|E==]

alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. Grid
Editors can be printed or exported as a report.
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Shortcut Menu Item lcon Description

Import - From ER/ @ Create New External Data Objects: Select this command to open a
Studio Data Architect wizard where you can select data files to import from ER/Studio
Data Architect.

Update Existing External Data Objects: You can use this option to
update an existing data source. All existing objects that match an
object you have selected will be updated.

Export to ER/Studio %) You can export objects to ER/Studio Data Architect where the
Data Architect... elements in the conceptual diagram map to the logical diagram in
ER/Studio Data Architect.

Insert Data Source... If you have deleted a data source file but did not delete the
associated files, you can select this command to “restore” the
deleted data source file.

Refresh i, Updates the currently displayed information with new data or
= changes.

Properties Opens the Property View dialog for the selected external data
= object.

External Data Object Elements

Once you have created an External Data Object element, a different shortcut menu is available:

Shortcut Menu ltem Icon Description

New Create a new external data source: data source, entity, table, view,
data store, data feed, report, or flat file.

Create Diagram from You can create new diagrams from existing model objects.
Selected Elements...

Rename Makes the node name editable. If the diagram is open, it also
renames the element in the Diagram View. You can also click F2.

Delete 4 This command opens the Delete Elements dialog asking if you are
sure you want to delete the selected elements. Clicking Yes
removes the elements from the project and any diagrams (both in
the Model View tree and in the Diagram View) on which the
elements appear.

Diagram Usage A pull-right menu lists the diagram(s) the select element appears in.
This allows you to quickly locate and open the diagram where the
element appears. If the element appears on more then ten
diagrams the More... option appears opening a dialog listing all
diagrams.

Links If you are creating a new link, click Links > New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links > Edit.

(%]
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Shortcut Menu Item lcon Description

Usage (CRUD) u If you are creating a new usage, click Usage > New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD) > Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

Impact Analysis You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Refresh o Updates the currently displayed information with new data or
w changes.
Properties Opens the Property View dialog for the selected element.

Palette View

The table below describes the functions available when you right-click the Palette View:

Shortcut Menu ltem Description

Layout Columns: Displays the icons and object labels in two columns within
the palette.

List: Displays both the icon and the object label for each object in
the palette.

Icons Only: Displays the icons without identifying labels.

Details: Displays each icon with a brief description of the action
taken when you select the object.

Settings Opens the Using the Palette dialog where you can change the
display characteristics of the palette.

DIAGRAM VIEW
The table below describes the functions available when you right-click in the Diagram View:

Shortcut Menu Item lcon Description

Case Shift You can set the default case shift for all element labels. You have
three options:

Lower: All text appears in lower case lettering, including the initial
letter of the label.

Preserve: Text appears as entered.

Upper: All text appears in upper case lettering.
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Shortcut Menu Item lcon Description

Grid This pull-right menu contains three additional commands:
Show Grid Lines: The grid lines appear on the diagram.

Show Parent Objects as Transparent: When a parent object such
as a pool or lane is placed on a diagram, the grid lines appear in the
object, i.e. the object is transparent.

Snap Objects to Grid: When an element is placed in the Diagram
View, it automatically snaps to the nearest grid. When an element is
moved, it also snaps to the nearest grid line.

Connections If it is a Business Process diagram, this command shows or hides:
All, Associations, Line Shapes, Links, Message Flows, Sequence
Flows, or Usages.

If it is a Conceptual Model diagram, this command shows or hides:
All, Interactions, Line Shapes, Links, Relationships, or Usages.

If it is a Impact Analysis diagram, this command shows or hides
Links and Usages.

Edit This opens a pull-right menu allowing you to select all elements in
the diagram.
Layout You have three choices: curved, elbowed, or straight. The default

setting for connections is curved. If you change this setting to
“straight” you get a Change Diagram Layout dialog, warning you
that this selection overrides any changes you have made to
individual relationships.

Connection Labels The default setting is to show connection labels when drawn. You
can select to hide or show all connection labels in the diagram.
Grid Editor... = The Grid Editor is an spreadsheet-like display format that is an
|E==]

alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The Grid
Editor can be printed or exported as a report.

Zoom In @, Select this command to increase the size of the diagram in the view.
Zoom Out = Select this command to decrease the size of the diagram in the

' view.
ELEMENTS

Shortcut menus are available for all the elements used in ER/Studio BA. All commands and a
description of each are listed for each element. There are five different element sets:

e Business Process Modeling Objects

e Conceptual Objects

e Reference Objects
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e External Data Objects

e Drawing Shapes

BUSINESS PROCESS MODELING OBJECTS

The commands on the shortcut menus for the Business Process Modeling Objects are very
similar. However additional commands appear on each of the objects. Shortcut menus are
available for the following objects:

e Start and Intermediate Events

e Fnd Events
e Tasks

e Embedded Sub-processes

¢ Independent Sub-processes

* Gateways

e Pools
e |anes

e Sequence Flows

* Message Flows

e Associations

e Data Objects, Groups, Annotations, and Off-Page Connectors

Start and Intermediate Events

A Start Event indicates where a particular process starts. A trigger for a Start Event is designed to
show the general mechanism that instantiates that particular process. An Intermediate Event
occurs between a Start Event and an End Event. It is an event that occurs after a Process has
been started.

Shortcut Menu ltem Icon Description
Show Name This is a toggle command. If it is selected the element label shows.
Trigger Type You can change the trigger on an event from the shortcut menu.

When you select Trigger Type, a pull-right menu displays all the
applicable triggers for the event, including the setting of “None".

Appearance... Opens the Appearance tab in the Property View where you can edit
the font and color options, horizontal alignments, and Diagram
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.
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Shortcut Menu Item lcon Description
Grouping Group: Groups two or more selected elements into a single entity

that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and Send
to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

(=E]

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.

End Events

The End Event indicates where a process ends. You can define the consequences or results of
reaching an End Event.

Shortcut Menu Item Icon Description
Show Name This is a toggle command. If it is selected the element label shows.
Result Type You can change the result type on an event from the shortcut menu.

When you select Trigger Type, a pull-right menu displays the
following results for the event: None, Cancel, Compensation, Error,
Link, Message, and Terminate.
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Shortcut Menu Item lcon Description

Appearance... Opens the Appearance tab in the Property View where you can edit
the font and color options, horizontal alignments, and Diagram
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Grouping Group: Groups two or more selected elements into a single entity

that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and Send
to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

Links 5 If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis = You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.
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Tasks

A task is an activity that is included within a Process. You use a Task when the work in the Process
is not broken down to a finer level of Process Model detail.

Shortcut Menu Item lcon Description
Show Name This is a toggle command. If it is selected the element label shows.
Appearance... Opens the Appearance tab in the Property View where you can edit

the font and color options, horizontal and vertical alignments,
Diagram display options, and Line display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Grouping Group: Groups two or more selected elements into a single entity

that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and Send
to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

ConvertTo You can convert a task to either an Embedded Sub-process or an
Independent Sub-process

Links =5 If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis % You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.
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Shortcut Menu Item lcon Description
Properties Opens the Property View dialog for the selected element. When

you right-click on a task and select Properties, three additional
commands are available on the pull-right menu:

Loop Type: Lists all available loop types in the pull-right menu.
Select a type from the list to change it.

Task Type: Lists all available task types in the pull-right menu.
Select a type from the list to change it.

Embedded Sub-processes

An Embedded (or nested) Sub-process element is an activity containing other activities (a
Process). The Process within the Process depends on the parent Process for instigation and has
visibility to the parent’s global data.

Shortcut Menu Item Icon Description

Show Name This is a toggle command. If it is selected the element label
shows.

Show As Expanded When you place an embedded sub-process in the Diagram

View, the default setting displays it as an expanded sub-process.
Select this toggle command to expand or contract the sub-
process.

Appearance... Opens the Appearance tab in the Property View where you can
edit the font and color options, horizontal and vertical
alignments, Diagram display options, and Line display options
of the object.

Connections This command shows or hides the following connection objects:
All, Associations, Line Shapes, Links, Message Flows, Sequence
Flows, or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.
Grid Editor... = The Grid Editor is an spreadsheet-like display format that is an
|E==]

alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The
Grid Editor can be printed or exported as a report.
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Shortcut Menu Item

lcon

Description

Links

(E]

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View

Select this command to locate the selected element in the
Model View tree.

Properties

Loop Type

Lists all available loop types in the pull-right menu. Select a type
from the list to change it.

Ad hoc

]

Ad hoc is a boolean attribute, which has a default of False. This
specifies whether the Process is Ad Hoc or not. The activities
within an Ad Hoc Process are not controlled or sequenced in a
particular order. Their performance is determined by the
performers of the activities. If set to True, then the Ad Hoc
marker is placed at the bottom center of the Process or the Sub-
Process shape for Ad Hoc Processes.

Transaction

This option determines whether or not the behavior of the Sub-
Process will follow the behavior of a Transaction.

Display Properties

Opens the Properties dialog for the selected element.

Independent Sub-processes

An Independent Sub-process element is an activity within a Process that “calls” to another
Process that exists within a separate diagram. The Process that is called is not dependent on the
Independent Sub-process’ parent Process for instantiation or global data.

Shortcut Menu Item

lcon

Description

Show Name

This is a toggle command. If it is selected the element label
shows.
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Shortcut Menu Item

lcon

Description

Show As Expanded

When you place an independent sub-process in the Diagram
View, the default setting is that it is displayed as a contracted sub-
process. Select this toggle command to open a diagram.

Appearance...

Opens the Appearance tab in the Property View where you can
edit the font and color options, horizontal and vertical alignments,
Diagram display options, and Line display options of the object.

Connections

This command shows or hides the following connection objects:
All, Associations, Line Shapes, Links, Message Flows, Sequence
Flows or Usages.

Grouping

Group: Groups two or more selected elements into a single entity
that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects

When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order

This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit

This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Links

If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link
wizard opens. If there is only one link the command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View

Select this command to locate the selected element in the Model
View tree.

Properties

Loop Type

Lists all available loop types in the pull-right menu. Select a type
from the list to change it.

Transaction

This option determines whether or not the behavior of the Sub-
Process follows the behavior of a Transaction.
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Shortcut Menu Item lcon Description
Display Properties Opens the Properties dialog for the selected element.
Gateways

A Gateway controls the divergence and convergence of the Sequence Flow. It determines
branching, forking, merging, and joining of paths.

Shortcut Menu Item lcon Description
Show Name This is a toggle command. If it is selected the element label shows.
Gateway Type Lists all available gateway types in the pull-right menu. Select a type

from the list to change it.

Appearance Opens the Appearance tab in the Property View where you can edit
the font and color options, horizontal alignments, Diagram display
options, and Line display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Grouping Group: Groups two or more selected elements into a single entity

that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and Send
to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Links =5 If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.
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Shortcut Menu Item

lcon

Description

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View

Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.
Pools

A Pool represents a participant in a Process. It is also called a “swimlane” and is a graphical

container for partitioning a set of activities from other pools.

Shortcut Menu ltem

Icon

Description

Show Name

This is a toggle command. If it is selected the element label shows.

Appearance...

the font and color options, horizontal alignments, Diagram display
options, and Line display options of the object.

Opens the Appearance tab in the Property View where you can edit

Connections

Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

This command shows or hides the following connection objects: All,

Grouping Group: Groups two or more selected elements into a single entity
that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and Send
to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Insert Lane Inserts a lane in the pool. You can select where you want the lane

placed in the pool from the pull-right menu.

Remove All Lanes
(Black Box)

When all lanes are removed from a pool it becomes a black box
pool. The pool header label remains, but the lane area is blank.

Show All Lanes

in the pool are shown.

This is a toggle of the Remove All Lanes command. All hidden lanes
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Shortcut Menu Item lcon Description

Links

If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link
wizard opens. If there is only one link the command is Links>Edit.

(5]

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Create Diagram from This function gives you the ability to create a diagram from the Pool
Selected Elements... that exists on the diagram.

Grid Editor... = The Grid Editor is an spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The Grid
Editor can be printed or exported as a report.

Impact Analysis Ex You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.

Lanes

A Lane is a subpartition within a pool. Lanes organize and categorize activities. Lanes are often
used to separate the activities associated with a specific company function or role.

Shortcut Menu Iltem lcon Description
Show Name This is a toggle command. If it is selected the element label shows.
Appearance... Opens the Appearance tab in the Property View where you can edit

the font and color options, horizontal alignments, and Diagram
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Insert Lane Inserts a lane in the pool.

Move Lane Opens the Move Lane dialog where you can reorder the lanes.
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Shortcut Menu Item lcon Description

Remove All Lanes When all lanes are removed from a pool it becomes a black box
(Black Box) pool. The pool header label remains, but the lane area is blank.

Show All Lanes This is a toggle of the Remove All Lanes command. All hidden lanes
in the pool are shown.

Grid Editor... == The Grid Editor is an spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The Grid
Editor can be printed or exported as a report.

Links =5 If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis You have two commands available from the pull-right menu:

Ll
v |

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.

Sequence Flows

A Sequence Flow shows the sequence of processes in an organization or department. When you
use pools or lanes in your diagram, you use Sequence Flow lines to connect events, activities,
and gateways within the pools or lanes.

Shortcut Menu Item Icon Description
Show Name This is a toggle command. If it is selected the element label is
shown.
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Shortcut Menu Item lcon Description
Condition Type
None
Conditional
Default
Appearance... Opens the Appearance tab in the Property View where you can edit

the font and color options, Diagram display options, and Line
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Edit This opens a pull-right menu allowing you to delete, or select all

elements in the diagram.

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: orthogonal bend points with “curved” corners are placed
on the line.

Elbowed: orthogonal bend points are placed on the line.

Straight: the line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses the
shortest distance between two elements.

Reset to Default Docking Position: The docking position of the
line/element intersection is reset to its default setting.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

C=2

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis % You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

88 ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE



APPLICATION BASICS > NAVIGATION

Shortcut Menu Item lcon Description
Properties Opens the Property View dialog for the selected element.

Message Flows

Message Flows are used to show the flow of messages between two participants that are
prepared to send and receive them. A Message Flow can connect directly to the boundary of a
pool or it can cross the boundary of a pool and connect to an object within that pool.

Shortcut Menu ltem lcon Description

Show Name This is a toggle command. If it is selected the element label is
shown.

Appearance... Opens the Appearance tab in the Property View where you can edit

the font and color options, Diagram display options, and Line
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows
or Usages.

Edit This opens a pull-right menu allowing you to delete, or select all

elements in the diagram.

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: orthogonal bend points with “curved” corners are placed
on the line.

Elbowed: orthogonal bend points are placed on the line.

Straight: the line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses the
shortest distance between two elements.

Reset to Default Docking Position: The docking position of the
line/element intersection is reset to its default setting.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

(5]

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.
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Shortcut Menu Item lcon Description

Impact Analysis Ea You have two commands available from the pull-right menu:
You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.
You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.

Associations

An Association is used to associate information with events and activities. It can be used to
associate reference objects, external data objects, shapes, and activities with textual
information.

Shortcut Menu ltem Icon Description

Show Name This is a toggle command. If it is selected the element label is
shown.

Directional Arrow You can change the direction on an Association connecting object

from the shortcut menu. When you select Direction Arrow, a pull-
right menu displays the following options:

) No directional arrows are shown.
To: (****) Displays the arrow at the target element.
From: (*"") Displays the arrow at the source element.

Both: ((--Br ) Directional arrows are shown at both ends of the
connecting object.

Appearance... Opens the Appearance tab in the Property View where you can edit
the font and color options, Diagram display options, and Line
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

90 ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE



APPLICATION BASICS > NAVIGATION

Shortcut Menu Item lcon Description

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: orthogonal bend points with “curved” corners are placed
on the line.

Elbowed: orthogonal bend points are placed on the line.

Straight: the line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses the
shortest distance between two elements.

Reset to Default Docking Position: The docking position of the
line/element intersection is reset to its default setting.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

C=2

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis = You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.

Data Objects, Groups, Annotations, and Off-Page Connectors

Artifacts provide additional information about the business process. Using artifacts allows you to
add non-standard elements to satisfy a specific need. Since you do not want to alter the basic
look-and-feel of a diagram, you can use artifacts to link to the existing events and activities
through Associations. Artifacts do not affect the basic Sequence Flow or Message Flow, nor do
they affect mapping to execution languages.

Shortcut Menu Item lcon Description

Show Name This is a toggle command. If it is selected the element label shows.
This command does not apply to the Annotation object.

Show State This command applies to the Data Object element only.
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Shortcut Menu Item lcon Description

Appearance... Opens the Appearance tab in the Property View where you can edit
the font and color options, horizontal alignment, and Diagram
display options of the object.

Connections This command shows or hides the following connection objects: All,
Associations, Line Shapes, Links, Message Flows, Sequence Flows,
or Usages.

Grouping Group: Groups two or more selected elements into a single entity

that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment commands
are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and Send
to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

Links If you are creating a new link, click Links>New and the Create Link
wizard opens. If you are editing an existing link, click Links>Edit. If
there are multiple links, the pull-right menu displays a list of the
existing links. Click the name on the pull-right and the Edit Link

wizard opens. If there is only one link the command is Links>Edit.

(%]

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the Usages
wizard opens. If you want to edit or view an existing usage, click
Usage (CRUD)>Edit or View. The Usage (CRUD) tab opens in the
Property View for the selected element.

You can also select to show or hide the Usage in the Diagram View.

Impact Analysis You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the Model
View tree.

Properties Opens the Property View dialog for the selected element.

CONCEPTUAL OBJECTS

The commands on the shortcut menus for the Conceptual Modeling Objects are very similar.
However additional commands appear on each of the objects. Shortcut menus are available for
the following objects:

e Subject Area
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Business Entity

Business Entity
Business Attribute

® |nteraction

Relationship

Subject Area

Conceptual Modeling allows Business Users to create high-level designs of the core “concepts”
and subject areas that drive the business, which can be passed onto data and process modelers
to drive more detailed logical and physical design. A Subject Area can reference a collection of

entities.

Shortcut Menu ltem

lcon

Description

Show Name

This is a toggle command. If it is selected the element label
shows.

Show As Expanded

Shows or hides the expand/contract control that appears in the
right-hand corner of the object.

Show Expansion Control

You can hide or show the expander indicator located in the
lower right-hand corner of the object. The expander is shown as
the default setting.

Appearance...

Opens the Appearance tab in the Property View where you can
edit the font and color options, horizontal and vertical
alignment, Diagram display options, Line display options, and
shape options of the object.

Connections

This command shows or hides the following connection objects:
All, Relationships, Interactions, Line Shapes, Links, or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.
Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

Create Mapping/Edit
Mapping

You can map a Subject Area to one or more Conceptual Model
diagrams or Business Entities.

Diagram Mapping

This command is available once you have mapped a diagram to
a Subject Area. When it is selected a pull-right menu opens
displaying the mapped diagram(s).
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Shortcut Menu Item lcon Description

Links

=5 If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram

View.

Create Diagram from This function gives you the ability to create a diagram from the

Selected Elements... Subject Area element that exists on the diagram.

Grid Editor... = The Grid Editor is an spreadsheet-like display format that is an

= alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The
Grid Editor can be printed or exported as a report.

Impact Analysis Ex You have two commands available from the pull-right menu:
You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

Business Entity

A Business Entity is a high-level “container” for businesses/organizations. They can stand alone
or can be containers for other Business Entities or Business Attributes.

Shortcut Menu ltem Icon Description

Show Name This is a toggle command. If it is selected the element label
shows.

Show As Expanded Shows or hides the expand/contract control that appears in the

right-hand corner of the object.

Show Expansion Control You can hide or show the expander indicator located in the
lower right-hand corner of the object. The expander is shown as
the default setting.
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Shortcut Menu Item lcon Description

Appearance... Opens the Appearance tab in the Property View where you can
edit the font and color options, horizontal and vertical
alignment, Diagram display options, Line display options, and
Business Attribute display options of the object.

Connections This command shows or hides the following connection objects:
All, Relationships, Interactions, Line Shapes, Links, or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Insert Attribute Inserts a Business Attribute in the Business Entity.

Links

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Create Diagram from This function gives you the ability to create a diagram from the
Selected Elements... Business Entity element that exists on the diagram.

Grid Editor...

The Grid Editor is an spreadsheet-like display format that is an
alternative to the Model View tree view. This is valuable for large
objects or business-related objects, such as business rules. The
Grid Editor can be printed or exported as a report.

Impact Analysis £a You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.
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Shortcut Menu Item

lcon

Description

Properties

Opens the Property View dialog for the selected element.

Business Attribute

Business Attributes are the low-level details (i.e., properties), of a Business Entity. You can
reorder the Business Attributes within a Business Entity.

Shortcut Menu Item

lcon

Description

Unique Identifier

This a toggle that turns the Unique Identifier setting (#) on or off
for the selected attribute.

Data Type

The Data Types available are high level: binary, BLOB/Image,
boolean, char, CLOB/Large Text, Decimal, Date, Integer, Time
Stamp, Varchar, and XML. The data type selected appears in the
Property View for the selected attribute.

Optionality

You can set the Optionality for an attribute. If you select
Mandatory it becomes a “required” property and a plus sign (+)
appears to the left of the attribute. If it is optional, a minus sign
(-) appears to the left of the attribute. You can set a preference
under the Display Options for Business Entities to always show
the optionality indicator for Business Attributes.

Appearance...

Opens the Appearance tab in the Property View where you can
edit the font and color options and horizontal alignment of the
object.

Connections

This command shows or hides the following connection objects:
All, Relationships, Interactions, Line Shapes, Links, or Usages.

Grouping

Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Edit

This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Links

(%]

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.
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Shortcut Menu Item

lcon

Description

Impact Analysis

ifs
Tl

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View

Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.
Interaction

An interaction represents an action, process, or transaction between two objects. These
interactions are often expressed as action verb phrases.

Shortcut Menu ltem

lcon

Description

Show

You can show the name, verb phrase and inverse verb phrase for
the Interaction.

Appearance...

Opens the Appearance tab in the Property View where you can
edit the font and color options, Diagram display options, and
Line display options of the object.

Connections

This command shows or hides the following connection objects:
All, Relationships, Interactions, Line Shapes, Links, or Usages.

Edit

This opens a pull-right menu allowing you to delete, or select all
elements in the diagram.

Layout

You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: Orthogonal bend points with “curved” corners are
placed on the line.

Elbowed: Orthogonal bend points are placed on the line.

Straight: The line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses
the shortest distance between two elements.

Reset to Default Docking Position: The docking position of
the line/element intersection is reset to its default setting.

Links

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.
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Shortcut Menu Item lcon Description

Usage (CRUD) u If you are creating a new usage, click Usage>New and the

h Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Impact Analysis You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

Relationship

Relationships can only be defined between common object types. For example two business
entities can have a relationship, but a business entity and a subject area cannot.

Shortcut Menu ltem Icon Description

Show You can show the name, verb phrase inverse verb phrase, and
unique identifier for the Relationship.

Relationship Type Sets the Relationship type. You can view and/or change this
setting in the Property View. Your choices are:

® Generic

* Many-to-Many
* Many to One
¢ One to Many

Optionality Sets the Source to Target Optionality. You can view and/or
change this setting in the Property View. You choices are:

¢ Optional to Optional

e Optionality to Mandatory
* None

® Mandatory to Optional

® Mandatory to Mandatory

Appearance... Opens the Appearance tab in the Property View where you can
edit the font and color options, Diagram display options, and
Line display options of the object.

Connections This command shows or hides the following connection objects:
All, Relationships, Interactions, Line Shapes, Links or Usage.

Edit This opens a pull-right menu allowing you to delete, or select all
elements in the diagram.
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Shortcut Menu Item lcon Description

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: orthogonal bend points with “curved” corners are
placed on the line.

Elbowed: orthogonal bend points are placed on the line.

Straight: the line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses
the shortest distance between two elements.

Reset to Default Docking Position: The docking position of
the line/element intersection is reset to its default setting.

Links =5 If you are creating a new link, click Links>New and the Create

Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the

” Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Impact Analysis % You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Impact Analysis Report... An Impact Analysis Report can be generated for any node on
the Model View tree. It shows the interrelationships between
objects. Impact Analysis reports can be printed or exported.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

REFERENCE OBJECTS

The commands on the shortcut menus for the Reference Objects in a diagram are very similar.
However additional commands appear on each of the objects. Since Domains are not visible in a
diagram, no shortcut menu is available here.

Shortcut menus are available for the following objects:

® Business Element
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Business Rule

Business Unit

Steward

Links

® Usage

Business Element

Business Elements are often used by business users to document their list of “terms and/or
definitions”. While from a business user’s point-of-view, this may be no more than a list of terms,
they can be used by a modeler to seed attributes of semantically-rich models.

Shortcut Menu Item Icon Description

Show Name This is a toggle command. If it is selected the element label
shows.

Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, horizontal alignment, and
Diagram display options of the object.

Connections This command shows or hides the following connection objects:
All, Interactions, Line Shapes, Links, Relationships, or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Binding Business Attributes Opens the Bindings tab for the selected Business Element. You
to Business Elements... can add, edit or delete bindings.
Links =5 If you are creating a new link, click Links>New and the Create

Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.
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Shortcut Menu Item

lcon

Description

Usage (CRUD)

If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Create Diagram from

Selected Elements...

This function gives you the ability to create a diagram from the
Business Element that exists on the diagram.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View

Select this command to locate the selected element in the
Model View tree.

Properties

Opens the Property View dialog for the selected element.

Business Rule

A business rule is a policy, practice, or formula related to the operation and enforcement of

business practices.

Shortcut Menu Item

lcon

Description

Show Name

This is a toggle command. If it is selected the element label
shows.

Appearance...

Opens the Appearance tab in the Property View where you can
edit the font and color options, horizontal alignment, and
Diagram display options of the object.

Connections

This command shows or hides the following connection objects:
All, Interactions, Line Shapes, Links, Relationships, or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.
Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.
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Shortcut Menu Item lcon Description

Links

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

(E]

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Create Diagram from This function gives you the ability to create a diagram from the
Selected Elements... Business Rule element that exists on the diagram.

Impact Analysis You have two commands available from the pull-right menu:

o
v |

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

Business Unit

A business unit is an organizational area within or external to an enterprise, for example, Human
Resources, Sales, Accounting, etc.

Shortcut Menu Iltem lcon Description

Show Name This is a toggle command. If it is selected the element label
shows.

Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, horizontal alignment, and
Diagram display options of the object.

Connections This command shows or hides the following connection objects:
All, Line Shapes, Links or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.
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Shortcut Menu Item

lcon

Description

Order

This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit

This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Creating as Pool

This creates a pool and lane with the same name as the Business
Unit. The Business Unit is automatically associated with the Pool
as a participant. A conceptual link from the Pool to the Business
Unit is also created. The name of the link is the name of the
Business Unit. This command is enabled only when Business
Process diagrams are open.

Detaching from Pool

Once you have created a Business Unit or Steward as a pool you
can eliminate the relationship between the reference object and
the pool. This command is enabled only when Business Process
diagrams are open.

Links

=0

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Create Diagram from

Selected Elements...

This function gives you the ability to create a diagram from the
Business Unit element that exists on the diagram.

Impact Analysis

You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View

Select this command to locate the selected element in the
Model View tree.

Properties

Opens the Property View dialog for the selected element.
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Steward

A steward is a person or organization responsible for or associated with a model element, for
example: DBA, Auditor, Jeffrey Smith, etc.

Shortcut Menu Item

lcon

Description

Show Name This is a toggle command. If it is selected the element label
shows.
Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, horizontal alignment, and
Diagram display options of the object.

Connections

This command shows or hides the following connection objects:
All, Interactions, Line Shapes, Links, Relationships, or Usages.

Grouping

Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects

When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,

delete, or select all elements in the diagram.

Creating as Pool

This creates a pool and lane with the same name as the Steward.
The Steward is automatically associated with the Pool as a
participant. A conceptual link from the Pool to the Steward is
also created. The name of the link is the name of the Steward.
This command is enabled only when Business Process diagrams
are open.

Detaching from Pool

Once you have created a Business Unit or Steward as a pool you
can eliminate the relationship between the reference object and
the pool. This command is enabled only when Business Process
diagrams are open.

Links

(5]

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

You can also select to show or hide the link in the Diagram View.

Usage (CRUD)

If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.
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Shortcut Menu Item lcon Description

Impact Analysis Ea You have two commands available from the pull-right menu:
You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.
You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

Links

With a link you create a representation of a relationship between elements. These elements can
consist of reference objects, data objects, and elements within a diagram.

Shortcut Menu ltem Description

Show Name (Type)
Verb Phrase

Inverse Verb Phrase

Appearance... Opens the Appearance tab in the Property View where you can
edit the font and color options, Diagram display options, and
Line display options of the object.

Connections If you right-click on a connection (for example a Sequence Flow)
you get the following commands:

Hide Selected: The selected connection no longer appears in
the diagram.

Show Attached/Hide Attached:

e If it is a Business Process diagram, the command shows or
hides the following: All, Associations, Line Shapes, Links,
Message Flows, Sequence Flows, or Usages.

e If it is a Conceptual Model diagram, the command shows or
hides the following: All, Interactions, Line Shapes, Links,
Relationships, or Usages.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.
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Shortcut Menu Item Description

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: Orthogonal bend points with “curved” corners are
placed on the line.

Elbowed: Orthogonal bend points are placed on the line.

Straight: The line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses
the shortest distance between two elements.

Reset to Default Docking Position: The docking position of
the line/element intersection is reset to its default setting.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

Usage

You can show the create, read, update, or delete database attributes on a connection. When this
connection is created they are labeled with the attributes you selected at the time of creation.
These elements can consist of reference objects, data objects, and elements within a diagram.

Shortcut Menu ltem Description
Show Name (Type)
Usage
Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, Diagram display options, and
Line display options of the object.

Connections If you right-click on a connection (for example a Sequence Flow)
you get the following commands:

Hide Selected: The selected connection no longer appears in
the diagram.

Show Attached/Hide Attached:

e If it is a Business Process diagram, the command shows or
hides the following: All, Associations, Line Shapes, Links,
Message Flows, Sequence Flows, or Usages.

e If it is a Conceptual Model diagram, the command shows or
hides the following: All, Interactions, Line Shapes, Links,
Relationships, or Usages.

Edit This opens a pull-right menu allowing you to delete, or select all
elements in the diagram.
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Shortcut Menu Item Description

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: Orthogonal bend points with “curved” corners are
placed on the line.

Elbowed: Orthogonal bend points are placed on the line.

Straight: The line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses
the shortest distance between two elements.

Reset to Default Docking Position: The docking position of
the line/element intersection is reset to its default setting.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

EXTERNAL DATA OBJECTS
The shortcut menu for all the External Data Objects contain the same commands.

Shortcut Menu ltem lcon Description

Show Name This is a toggle command. If it is selected the element label
shows.

Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, horizontal alignment, and
Diagram display options of the object.

Connections This command shows or hides the following connection objects:
All, Interactions, Line Shapes, Links, Relationships, or Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Links If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the

command is Links>Edit.

=)

You can also select to show or hide the link in the Diagram View.
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Shortcut Menu Item lcon Description

Usage (CRUD) u If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Impact Analysis = You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

DRAWING SHAPES

The shortcut menu for all the Drawing Shapes contain the same commands with the exception
of the Line.

Shortcut Menu ltem Icon Description

Show Name This is a toggle command. If it is selected the element label
shows.

Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, horizontal and vertical
alignment, Diagram display options, and Line display options of
the object.

Connections This command shows or hides connection objects. For
conceptual diagrams the following connections are listed: All,
Line Shapes, Links, or Usages. For business process diagrams
the following connections are listed: All, Associations, Line
Shapes, Links, Message Flows, Sequence Flows, and Usages.

Grouping Group: Groups two or more selected elements into a single
entity that can be moved around a diagram in a block.

Ungroup: Removes the selected grouping. This command is
available only if the element selected is in a group.

Align Objects When two or more objects are selected, the alignment
commands are available on a pull-right menu.

Order This is a pull-right menu displaying two commands that control
stacking of elements in the Diagram View: Bring to Front and
Send to Back.

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.
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Shortcut Menu Item lcon Description

Links

If you are creating a new link, click Links>New and the Create
Link wizard opens. If you are editing an existing link, click
Links>Edit. If there are multiple links, the pull-right menu
displays a list of the existing links. Click the name on the pull-
right and the Edit Link wizard opens. If there is only one link the
command is Links>Edit.

(5]

You can also select to show or hide the link in the Diagram View.

Usage (CRUD) u If you are creating a new usage, click Usage>New and the
Usages wizard opens. If you want to edit or view an existing
usage, click Usage (CRUD)>Edit or View. The Usage (CRUD) tab
opens in the Property View for the selected element.

You can also select to show or hide the Usage in the Diagram
View.

Impact Analysis = You have two commands available from the pull-right menu:

You can generate an Impact Analysis Diagram which graphically
displays all the associated relationships and elements.

You can also show the Impact Analysis Report.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

Line
The Line has a different set of commands available because of its different characteristics.

Shortcut Menu ltem Description

Show Name This is a toggle command. If it is selected the element label
shows.

Appearance... Opens the Appearance tab in the Property View where you can

edit the font and color options, Diagram display options, and
Line display options of the object.

Connections If you right-click on a connection (for example a Sequence Flow)
you get the following commands:

Hide Selected: The selected connection no longer appears in
the diagram.

Show Attached/Hide Attached:

e If it is a Business Process diagram, the command shows or
hides the following: All, Associations, Line Shapes, Links,
Message Flows, Sequence Flows, or Usages.

e If it is a Conceptual Model diagram, the command shows or
hides the following: All, Interactions, Line Shapes, Links,
Relationships, or Usages.
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Shortcut Menu Item Description

Edit This opens a pull-right menu allowing you to cut, copy, paste,
delete, or select all elements in the diagram.

Layout You can change the layout on individual connections. The
commands e available on the pull-right menu are:

Curved: Orthogonal bend points with “curved” corners are
placed on the line.

Elbowed: Orthogonal bend points are placed on the line.

Straight: The line is always straight. However there can be bend
points on the connection.

Remove Bend Points: Removes all bends so the line traverses
the shortest distance between two elements.

Reset to Default Docking Position: The docking position of
the line/element intersection is reset to its default setting.

Find in Model View Select this command to locate the selected element in the
Model View tree.

Properties Opens the Property View dialog for the selected element.

KEYBOARD COMMANDS

The application keyboard commands help you expedite your tasks by minimizing mouse clicks.

Command Description

Hot-Key Object Movement You can move objects by pre-set
increments using the specified hot
keys.

Eclipse Hot-Key Object Movement You can use the hot-keys to move the

elements or connections, but the key
combination is different

Selecting Objects in Container You can select objects in a container
Elements element such as a Subject Area by
using the Alt key.

Key Assist Commands This is a list of “hot” keys or shortcuts
used by ER/Studio BA.

Hot-Key Object Movement

This allows you to move elements and connectors in the Diagram View using specified hot keys.
You can change the default setting for the hot-key object movement in the Preferences Editor.

1 From the main menu choose Windows > Preferences.

2 Select Diagrams. The default setting for “Override Eclipse hot-key object movement” is
enabled.

110 ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE



APPLICATION BASICS > NAVIGATION

When the hot-key movement is overridden you can move elements and connections in the
Diagram View using the arrow keys.

Action Key Combination

Directional arrow key only Each time you click a directional arrow, the
element or connection is moved one pixel in the
direction of the arrow.

Shift + directional arrow While holding down the Shift key, each time you
click a directional arrow, the element or
connection is moved ten pixels in the direction
of the arrow.

Ctrl + directional arrow While holding down the Ctrl key, each time you
click a directional arrow, the element or
connection is moved 20 pixels in the direction of
the arrow.

NOTE: If this preference is not enabled, the directional arrow keys are used to move between
elements on the diagram.

Eclipse Hot-Key Object Movement

When the override preference is not selected, you can still use the hot-keys to move the
elements or connections, but the key combination is different.

1 Select the element that you want to move.
2 Press the period key and a directional arrow.
NOTE: Notice that the element changes color when it is in the move mode.

N\

E

-

Gateway?

3 Each time you click a directional arrow, the element is moved one pixel in the direction of
the arrow.

4 When you press the period key again, you are taken out of the move function to the resize
function.

5 Each time you press the period key, the resize cursor moves to a difference resize point on
the element.
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Selecting Objects in Container Elements

You can select multiple elements that have been placed in container elements.

1 To invoke the marquee cursor, hold down the ALT key while dragging the mouse around the
items you want selected with the container.

Subject Area1

Business
Entity

2 Release both the ALT key and the mouse button and the items within the frame are

selected.

NOTE:

The container elements used in ER/Studio BA consist of: Subject Area, Business Entity,

Pool/Lane, and Embedded Subprocess.

Key Assist Commands

ER/Studio BA offers the following general shortcuts/accelerators for the application. Select Ctrl
+ Shift + L to open the list of Key Assist Commands in the application.

The table below describes the keyboard commands:

Result

Keyboard Command

Activate Editor

F12

Backward History Alt+Left

Bold Ctrl+B

Close Ctrl+W

Close All Ctrl+Shift+F4
Content Assist Ctrl+Space
Context Information Ctrl+Shift+Space
Console Alt+Shift+Q, C
Copy Ctrl+C

Cut Shift+X
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Result Keyboard Command
Delete Delete

Find and Replace Ctrl+F
Forward History Alt+Right
Group Ctrl+Shift+G
Italics Ctrl+l

Last Edit Location Ctrl+Q
Maximize Active View or Ctrl+M
Editor

New Workspace Ctrl+N

New Menu Alt+Shift+N
Next Ctrl+.

Next Editor Ctrl+F6

New Perspective Ctrl+F8

Next View Ctrl+F7
Open Editor Drop Down Ctrl+E

Open Property View from | Alt+Enter
Grid Editor

Open Resource Ctrl+Shift+R
Open Workspace Ctrl+0

Paste Shift+V
Previous Ctrl+,
Previous Editor Ctrl+Shift+Fé6
Previous Perspective Ctrl+Shift+F8
Previous View Ctrl+Shift+F7
Print Ctrl+P
Properties Alt+Enter
Quick Fix Ctrl+1

Redo Ctrl+Y
Refresh F5

Rename F2

Save Ctrl+S

Save All Ctrl+Shift+S
Select All Ctrl+A
Select All textin Notes and | Ctrl+A
Description Fields

Select Element Shift+Click
Show In Menu Alt+Shift+W
Show Key Assist Ctrl+Shift+L
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Result

Keyboard Command

Show System Menu

Alt+-

Show View (View: Outline)

Alt+Shift+Q, O

Show View (View:

Alt+Shift+Q, X

Problems)

Show View Menu Ctrl+F10
Switch to Editor Ctrl+Shift+E
Underline Ctrl+U
Undo Ctrl+Z
Ungroup Ctrl+Shift+U
Zoom In Ctrl+=
Zoom Out Ctrl+-
PREFERENCES

You can configure many of ER/Studio BA's properties to better suit your workflow and your work
goals. The application offers a number of configuration options from different locations.

You can customize the application configuration to meet your specific needs. You do this using
the Preferences Editor, where you set your preferences for the application’s global defaults. You
can also use this dialog to add, edit, and delete selected default values.

Preferences Editor

You can use the Preferences Editor to make changes to defaults used application-wide. You can
also edit default values.
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= Preferences

| Business Process Modeling

Business Process Modeling

Zonceptual Modeling
Default Yalues Display diagram usage when deleting elements

Oi
E:E;?::dern Licensing Automatically delete event triggers and results:

Find/Search Yalidate against BPMM specification default; Off  w
Formakking

Import/Export
Messages

Model View

Marning

Property Views
Reporting
Repository Opkions
Workspaces/Models

Preferences far Business Process Madeling,

[

IR

[ Restaore Defaulks ] [ Apply ]

[ oK H Cancel ]

The table below describes the components in the Preferences Editor:

Component Description

type filter text This is a search text box which enables you to quickly locate the
preference you want to change. The item you are searching for appears in
the Categories tree.

Categories tree | Displays in tree form all preferences available for editing, adding, or
deleting. Expand the nodes of this tree to display each node’s defaults in
the Details grid.

Details pane Lists all options and their default values for any node selected in the
Categories tree.
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Component Description
Apply to This button is available on applicable preferences (for example
Diagram Formatting). It applies the changes immediately to the open diagram.

Note: The Apply to Diagram function does not apply to the Display
Options command for existing elements in a diagram.

Restore Defaults | Restores the default values for all preferences on the opened preference
page, and displays a warning message explaining the repercussions of the
restoration.

Apply Click Apply to institute the changes you made in the Preferences dialog.
OK Accept all the changes made and closes the dialog.
Cancel Cancels all changes made and closes the dialog.

Opening the Preferences Editor

1 On the main menu, click Window > Preferences....

2 To locate the preference you want to change, you can type the preference name in the Type
Filter Text box and press Enter. The preference appears in the Categories tree.

OR

Expand the nodes in the Categories tree and select the preference you want to edit.
3 In the Details pane, edit the settings you want to change.

NOTE: When working Formatting Preferences, if you are changing preferences in multiple
panes, you must click Apply before going to the next pane or all formatting changes to
the object is lost.

4 Click OK and ER/Studio BA saves your changes and the Preferences dialog closes.

You can set preferences for behavior and appearance in the ER/Studio BA application. The
nodes available are:

Business Process Modeling

Conceptual Modeling

Default Values

Diagrams
Find/Search

Formatting

Import/Export

License Manager

®* Messages
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Model View

* Naming

Property Views

® Reporting
Repository Options
Workspaces/Models

BUSINESS PROCESS MODELING

In this node you can set preferences that directly affect the Business Process Modeling Notation
elements. The table below describes the details available for the Business Process Modeling
node.

Detail Description
Display Diagram Usage If you select this preference, the Delete dialog displays the
When Deleting Elements following option: “Click here to see the diagrams on which the

elements appear.” When you click &, a box opens showing a
list of the other diagrams that are using this object.

Automatically Delete Event | You have two options when deleting a trigger/result from an
Triggers and Results event:

Prompt: A Delete dialog will always open warning you that all
event triggers/results along with their associated information
will be deleted. When you select OK, the trigger/result(s) are
removed from the event.

Always: The trigger/result(s) are deleted without a warning

dialog.

The default setting is Prompt.
Validating Against BPMN When you create a new project, this validation preference sets
Specification the default value (on or off) in the New Project Wizard dialog.

There are two subnodes listed in the Business Processing Modeling node: Pools and Processes.

Pools
The Pools preference has one setting:

Detail Description
Adjust pool size when When this option is selected (default setting) if you increase the
resizing lanes size of a lane, the pool increases in size as well. If you deselect

this preference, you won't see the pool grow in size and the
lane above or below it will shrink.
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Processes

The Processes preference has one setting:

Detail

Description

Show Processes in
Application

Select this option to display elements in a diagram or pool
under the Process node ( ‘}ﬁg ) in the Model View.

If this option is not selected, all elements are displayed under
the Pool node.

CONCEPTUAL MODELING

Expand the Conceptual Model node to gain access to the subnode Bindings. The table below

describes the preferences available for bindings.

Detail

‘ Description

Duplicate attribute warning options

Automatically create
business attributes from
business elements

You have two settings on how you want to handle the binding
of business elements to business attributes:

Prompt: A Binding Creation Warning dialog will always open
prompting you for a decision on how to handle business
attributes that already exist with the same name.

Always: If a bound business attribute with the same already
exists in the business entity, a new bound business attribute will
always be created with a unique name. When this option is
selected, the second preference is made available.

The default setting is Prompt.

Create the new attribute
with a unique name and
bind it to the business
element

This option is enabled if the “Always” preference is selected.
Select it if you want all newly created attributes to have unique
names and automatically bound to the business element.

Create the new attribute
with a unique name but do
not bind it to the business
element

This option is enabled if the first preference is selected. Select
it if you want all newly created attributes to have unique names,
but do not want it automatically bound to the business
element.

Display warning when
attempting to bind a

business element and
domain to an attribute

You cannot bind both a Business Element and a Domain to an
attribute. A warning dialog opens giving you an opportunity to
resolve the conflict. You can deselect this option to hide this
warning.

DEFAULT VALUES

The preferences in this section set default values for metadata objects. You can set these values
for Attributes, Business Attributes, Business Elements, Columns, and Domains.
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Attributes
The table below describes the preference available for the Attributes node:

Detail Description

Data Type Select the default value you want to always appear for
Attributes. You can select: None, Binary, Boolean, Char, Date,
Decimal, Float, Integer, Long Binary, Money, Timestamp,
Varchar, and XML.

Width Set the default length of the attribute/domain datatype.

Scale Set the default number of digits after a decimal (for those data
types that imply a decimal.

Business Attributes
The table below describes the preference available for the Business Attributes node:

Detail Description

Data Type Select the default value you want to always appear for Business
Attributes. You can select: None, Binary, Boolean, Char, Date,
Decimal, Float, Integer, Long Binary, Money, Timestamp,
Varchar, and XML.

Width Set the default length of the attribute/domain datatype.

Scale Set the default number of digits after a decimal (for those data
types that imply a decimal.

Business Elements
The table below describes the preference available for the Business Elements node:

Detail Description

Data Type Select the default value you want to always appear for Business
Elements. You can select: None, Binary, BLOB/Image, Boolean,
Char, CLOB/Large Text, Date, Decimal, Integer, Timestamp,
Varchar, and XML.

Columns
The table below describes the preference available for the Columns node:

Detail Description

Data Type Select the default value you want to always appear for Columns
You can select: None, Binary, Boolean, Char, Date, Decimal,
Float, Integer, Long Binary, Money, Timestamp, Varchar, and

XML.
Width Set the default length of the attribute/domain datatype.
Scale Set the default number of digits after a decimal (for those data

types that imply a decimal.
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Domains

The table below describes the preferences available for the Domains node:

Detail Description

Data Type Select the default value you want to always appear for
Domains. You can select: None, Binary, BLOB/Image, Boolean,
Char, CLOB/Large Text, Date, Decimal, Integer, Timestamp,
Varchar, and XML.

Width Set the default length of the attribute/domain datatype.

Scale Set the default number of digits after a decimal (for those data
types that imply a decimal.

Optionality Select the optionality you want to always appear for Domains.
Your choices are: None, Mandatory, or Optional.

DIAGRAMS

You can set global preferences for three main diagram preferences. You can also set a
preference for the generation of Impact Analysis Diagrams. The table below describes the

preferences available for the Diagrams node:

Detail

Description

Options for All Diagrams

Automatically perform
diagram layout

You have two options for the type of notification you get when
right-clicking in a diagram and selecting one of the Layout
options: prompt, and always. The default setting is Prompt.

Enable multi-drop on object
creation

Select this preference to enable the multi-drop mode. When
you select an element from the Palette view, the cursor is in the

multi-drop mode [% .

So, you can place as many elements as you need. This
preference is selected as the default setting.

Override Eclipse hot-key
object movement

Select this option to override the Eclipse Hot-Key Object
Movement. This allows you to use the directional keys to move
elements in the Diagram View.

Options for New Diagrams

Default Line Layout

When creating a new diagram, you can set the default line style
used when you create a connecting object between two
objects. Your three options are curved, elbowed, or straight.
The default setting is curved.

120

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE




APPLICATION BASICS > PREFERENCES

Detail

Description

Default Case Shift

When creating a new diagram, you can set the default case
shift for all element labels. You have three options:

Lower: All text appears in lower case lettering, including the
initial letter of the label.

Preserve: Text is preserved as it was entered.
Upper: All text appears in upper case lettering.

The default setting is “Preserve.”

Show Grid Lines

Changes the default setting so that each time a diagram is
opened or a new diagram is created, the grid lines
automatically appear.

Show parent objects as
transparent when grid lines
are displayed

When a parent object such as a pool or lane is placed on a
diagram, the grid lines appear in the object, i.e. the object is
transparent.

Snap Objects to Grid

Changes the default setting so that when an element is placed
in the Diagram View, it automatically snaps to the nearest grid.
When an element is moved, it also snaps to the nearest grid
line.

General Preference

Open last used diagram
when starting application

The last used diagram opens when the workspace is opened.
This options is selected by default.

Impact Analysis Diagrams

The table below describes the preference available for Impact Analysis diagrams:

Detail

Description

Automatically generate
large Impact Analysis
Diagrams

Select this option if you always want Impact Analysis Diagrams
of any size automatically generated. If this option is not
selected you are given the option whether to generate a large
diagram or not.

FIND/SEARCH

There are two sets of preferences you can set: Search Dialog and Search Results.

Search Dialog

The one preference for the Search Dialog lets you set the number of entries you want to appear

in the search history list.
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Search Results

There are two preferences you can set for the Search Results view:

Preference Description
Maximum number of elements to Enter the maximum number of returns
return to show for a search. The preference

would be helpful if you are search large
models with many elements.

Display Options You can select which columns you want
to appear in the Search Results view.
Your options are: Name, Type,
Description, Notes, Parent, and Project
Hierarchy.

FORMATTING

You can set global preferences for the following element types:

Business Process Modeling Formatting

Conceptual Modeling Formatting

External Data Objects Formatting

Reference Objects Formatting

Shapes Formatting

The changes you make in these preference dialogs are then applied to all future elements you
place in the Diagram View. For example, if you change the fill color of a gateway to red. Now all
gateways you place in the diagram View will be red. The preferences you can set are fonts and
colors, text justification, rendering, display option settings, and line display options.

To open the Formatting Preferences dialog, do the following:

1 From the main menu select Windows > Preferences.

2 Expand the Formatting node and select element types you want to format (i.e., Business
Process Modeling, Conceptual Modeling, External Data Objects, etc.).

Once you select the type of elements you want to format, additional information appears where
you can specify display format defaults for a selected element. The formatting options are
explained below:

Detail Description

Tree The Tree contains the set of business processing modeling
elements which have visual formatting preferences set. This
is anything which can be viewed in a diagram and printed.
When you open the Formatting Preferences, all available
elements are listed.
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Detail Description

Font and Color Once you select an object in the List Pane, you can change

Options the following settings: font type, font size, font style, and font
color. You can also change an element’s fill color and line
color.

Horizontal Alignment | You can set the justification style for text in a selected

element.

Vertical Alignment You can set the top to bottom alignment of text in a selected
element.

Rendering You can set the appearance of a selected element using the

shadowed and gradient settings.

Display Options The Show Name on Creation option displays an element’s
name when that element is placed on a diagram.

Note: This only applies to newly created elements on a
diagram. Existing elements are not updated when you click
the Apply to Diagram button.

Line Display Options | Depending on the element you are formatting, you can
change the following: line width, source decorator, source
decorator size, line style, target decorator, and target
decorator size.

Each dialog offers action buttons. The table below describes each button:

Button Description

Apply to Diagram | Applies the changes immediately to elements in an open diagram.

Note: The Apply to Diagram function does not apply to the Display Options
command for existing elements in a diagram.

Restore Defaults | Restores formatting of the element to the application defaults.

Apply Applies your specifications without closing the dialog box.
OK Applies your specifications, and then closes the dialog box.
Cancel Closes the Preferences dialog and cancels all changes made in the Formatting

dialog, unless something has been applied earlier.

BUSINESS PROCESS MODELING FORMATTING

This is where you can set global preferences for Business Process Modeling Notation (BPMN)
elements. You can set Font and Color Options, Horizontal Alignment, Vertical Alignment,
Rendering, Display Options, and Line Display Options. The availability of the formatting
elements depends on the element you select.
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Font and Color Options

You can change the font style, font size, and font colors. You can also change the fill and line
colors of a selected element in the Font and Color portion of the Formatting dialog.

Command Icon Description
Front Style Select a new font style from the drop-
down list.
Front Size Select a new font size from the drop-
down list.
Bold Applies bold formatting to the label
B text.
Italics ltalicizes the label text.
I
Underline u Underlines the label text.
Strikeout < A line is drawn through the label text.

You can also change the font color, element outline color, and element fill color.

Command

lcon

Description

Change Font
Color

=

Opens the Color dialog. You can select
an existing color or create a custom
color for the color of the label font.

Change Line . Opens the Color dialog. You can select
Color é" an existing color or create a custom
color for the border of the element.
Change Fill Opens the Color dialog. You can select
Color % an existing color or create a custom

color for the background of the
element.

Horizontal Alignment

You can change the justification setting for the text label in an element.

Command Icon Description
Left Justify . Justifies the text on the left side of the
Text = | text box.
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Command Icon Description
Center Text _ Centers the text within the text box.
Right Justify _ Justifies the text on the right side of
Text = the text box.
Vertical Alignment

Icon Description
Top - Places the text in the top portion of the
element.
Center Centers the text within the element.
Bottom Places the text in the bottom portion of
= the element.
Rendering

Shadowed

Description

Gradient

When this option is selected the
element has a slight shadowed

background. The Shadowed option is
the default setting.

default setting.

Task1

Task1

When this option is selected the

element has a gradient shading. If it is
not selected the element is a solid
color. The Gradient option is the
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You can change the top to bottom alignment settings for the text label in an element.
Command

There are two commands available that affect the appearance of elements in the Diagram View:
Command
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Display Options
The Show Name on Creation option displays an element’s name when that element is placed on
a diagram.

NOTE: This only applies to newly created elements on a diagram. Existing elements are not
updated when you click the Apply to Diagram button.

Line Display Options
You can set the line display preferences for the Sequence Flow, Message Flow, and Association
objects. Not all preferences are available for all objects.

Command Description

Line Width This preference sets the width of an interaction or
relationship in a diagram. Select 1 through 5 pixels
from the drop-down list box. This preference is
available for the Sequence Flow, Message Flow,
and Association.

Line Style Choose a line style from the drop-down list. You
can select from one of five different styles from the
drop down list. The list includes solid, dash, dot,
dash-dot, and dash-dot-dot.

Source Decorator Size You can set the size of the target decorator. This
option is available for the Message Flow element.

Target Decorator Size You can set the size of the target decorator. This
option is available for the Sequence Flow, and
Message Flow elements.

CONCEPTUAL MODELING FORMATTING
This is where you can set global preferences for conceptual Data Modeling elements. The
following preferences can be set: Font and Color Options, Horizontal Alignment, Vertical

Alignment, Rendering, Diagram Display Options, Shape, and Line Display Options. The
availability of the formatting elements depends on the element you select.

Font and Color Options

You can change the font style, font size, and font colors. You can also change the fill and line
colors of a selected element in the Fonts and Colors portion of the Formatting dialog.

Command Icon Description
Front Style Select a new font style from the drop-
down list.
Front Size Select a new font size from the drop-
down list.
Bold Applies bold formatting to the label
B | text.
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Command Icon Description
Italics ltalicizes the label text.
I
Underline Underlines the label text.
u
Strikeout s A line is drawn through the label text.
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You can also change the font color, element outline color, and element fill color.

Command Icon Description
Change Font A Opens the Color dialog. You can select
Color — an existing color or create a custom

color for the color of the label font.

Change Line . Opens the Color dialog. You can select
Color é" an existing color or create a custom
color for the border of the element.
Change Fill Opens the Color dialog. You can select
Color % an existing color or create a custom

color for the background of the
element.

Horizontal Alignment

You can change the justification setting for the text label in an element.

Command Icon Description

Left Justify _ Justifies the text on the left side of the
Text = text box.

Center Text _ Centers the text in the text box.

Right Justify — Justifies the text on the right side of
Text = the text box.
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Vertical Alignment
You can change the top to bottom alignment settings for the text label in an element.

Command Icon Description
Top - Places the text in the top portion of the
element.
Center Centers the text within the element.
Bottom Places the text in the bottom portion of
= the element.
Rendering

There are two commands available that affect the appearance of elements in the Diagram View:

Command Description

Shadowed When this option is selected the element has a
slight shadowed background. The Shadowed
option is the default setting.

Gradient When this option is selected the element has a
gradient shading. If it is not selected the element is
a solid color. The Gradient option is the default
setting.
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Diagram Display Options

You can set the global preferences for the objects. Not all options are available for all objects.

Command Description

Show Name on Creation The Show Name on Creation option displays an element’s
name when that element is placed on a diagram. Applies to
all Conceptual Modeling elements.

Show Unique Identifier You can show or hide the Unique Identifier indicator (#) on
Business Attributes.

For a Relationship, you can control whether or not to display
the unique identifier source decorator by default.

Show Expansion Control This preference can be set for the Business Entity and Subject
Area only. Select this option to display the “+" or “-"
indicator in the element. This option is not selected by
default.

Show Business Attributes Displays the Business Attributes in a Business Entity element.
This preference applies only to the Business Entity element.

Align Attributes to Top As you add attributes they are stacked at the top of the
Business Entity. If this preference is not selected, attributes
are added from the bottom up. This preference applies only
to the Business Entity element

Show Optionality If an Optionality type is set for a Business Attribute, you can
set the preference to always show the indicator This
preference applies only to the Business Entity element.

NOTE: This only applies to newly created elements on a diagram. Existing elements are not
updated when you click the Apply to Diagram button.

Shape

You can change the shape for a Subject Area element.

Command Description

Oval Element appears as an elongated
circle in the Diagram View.

Rectangle Element appears as a rectangle in the
Diagram View.
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Line Display Options

You can set the line display preferences for the Business Entity, Subject Area, Interaction and
Relationship objects.

Command Description

Line Width This preference sets the width of a border on an
element, or an interaction or relationship in a
diagram. Select 1 through 5 pixels from the drop-
down list box.

Line Style This preference sets the line style of an interaction
or relationship in a diagram. You can select from
one of five different styles from the drop down list.
The list includes solid, dash, dot, dash-dot, and
dash-dot-dot.

Source Decorator Set the preference for the beginning or source of
an interaction or relationship connection in a
diagram. Your five options are None, Arrow,
Diamond, Crows Feet, Triangle, or Hollow Circle.

Target decorator Set the preference for the end or target of an
interaction connection in a diagram. Your five
options are None, Arrow, Diamond, Crows Feet,
Triangle, or Hollow circle.

Target Decorator Size You can set the size of the target decorator for the
Interaction element.

EXTERNAL DATA OBJECTS FORMATTING

This is where you can set global preferences for External Data Object elements. For all External
Data Objects you can set Font and Color Options, Horizontal Alignment, Vertical Alignment,
and Display Options. The availability of the formatting elements depends on the element you
select.

Font and Color Options

You can change the font style, font size, and font colors. You can also change the fill and line
colors of a selected element in the Fonts and Colors portion of the Formatting dialog.

Command Icon Description
Front Style Select a new font style from the drop-
down list.
Front Size Select a new font size from the drop-
down list.
Bold Applies bold formatting to the label
B | text.
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Command Icon Description
Italics ltalicizes the label text.
I
Underline Underlines the label text.
u
Strikeout s A line is drawn through the label text.
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You can also change the font color, element outline color, and element fill color.

Command Icon Description
Change Font A Opens the Color dialog. You can select
Color — an existing color or create a custom

color for the color of the label font.

Change Line . Opens the Color dialog. You can select
Color é" an existing color or create a custom
color for the border of the element.
Change Fill Opens the Color dialog. You can select
Color % an existing color or create a custom

color for the background of the
element.

Horizontal Alignment

You can change the justification setting for the text label in an element.

Command Icon Description

Left Justify _ Justifies the text on the left side of the
Text = text box.

Center Text _ Centers the text in the text box.

Right Justify — Justifies the text on the right side of
Text = the text box.
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Vertical Alignment
You can change the top to bottom alignment settings for the text label in an element.

Command Icon Description
Top - Places the text in the top portion of the
element.
Center Centers the text within the element.
Bottom Places the text in the bottom portion of
= the element.

Display Options
The Show Name on Creation option displays an element’s name when that element is placed on
a diagram.

NOTE: This only applies to newly created elements on a diagram. Existing elements are not
updated when you click the Apply to Diagram button.

REFERENCE OBJECTS FORMATTING

This is where you can set global preferences for Reference Object elements. For all Reference
Objects you can set Font and Color Options, Horizontal Alignment, Vertical Alignment, and
Diagram Display Options. You can also set Line Display Options for the Link and Usage
Reference Objects. The availability of the formatting elements depends on the element you
select.

NOTE: Since Domains are not visualized on a diagram, you cannot set formatting preferences
for them.

Font and Color Options

You can change the font style, font size, and font colors. You can also change the fill and line
colors of a selected element in the Fonts and Colors portion of the Formatting dialog.

Command Icon Description
Front Style Select a new font style from the drop-
down list.
Front Size Select a new font size from the drop-
down list.
Bold Applies bold formatting to the label
B | text.
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Command Icon Description
Italics ltalicizes the label text.
I
Underline Underlines the label text.
u
Strikeout s A line is drawn through the label text.
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You can also change the font color, element outline color, and element fill color.

Command Icon Description
Change Font A Opens the Color dialog. You can select
Color — an existing color or create a custom

color for the color of the label font.

Change Line . Opens the Color dialog. You can select
Color é" an existing color or create a custom
color for the border of the element.
Change Fill Opens the Color dialog. You can select
Color % an existing color or create a custom

color for the background of the
element.

Horizontal Alignment

You can change the justification setting for the text label in an element.

Command Icon Description

Left Justify _ Justifies the text on the left side of the
Text = text box.

Center Text _ Centers the text in the text box.

Right Justify — Justifies the text on the right side of
Text = the text box.
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Vertical Alignment

You can change the top to bottom alignment settings for the text label in an element.

Command Icon Description
Top - Places the text in the top portion of the
element.
Center Centers the text within the element.
Bottom Places the text in the bottom portion of
= the element.

Diagram Display Options

You can set preferences for what you want displayed on creation of a reference object.

Command Description

Show Name on Displays an element’s name when that element is placed on

Creation a diagram. This preference is available for all reference
objects.

Show Usage on Displays the Usage settings when a usage is created on the

Creation diagram (C=Create, R=Read, U=Update, and D=Delete).
This preference is available only for the Usage reference
object.

NOTE: These only apply to newly created elements on a diagram. Existing elements are not
updated when you click the Apply to Diagram button.

Line Display Options

You can set preferences for the Link and Usage Reference objects.

Command Description

Line Width This preference sets the width of an interaction or
relationship in a diagram. Select 1 through 5 pixels
from the drop-down list box. This is the only line
display option you can set for a Link.

Line Style This preference sets the line style of an interaction
or relationship in a diagram. You can select from
one of five different styles from the drop down list.
The list includes solid, dash, dot, dash-dot, and
dash-dot-dot. This applies only to a Usage.
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Command Description

Source Decorator Set the preference for the beginning or source of
an interaction or relationship connection in a
diagram. Your five options are None, Arrow,
Diamond, Crows Feet, Triangle, or Hollow Circle.
This applies only to a Usage.

Target decorator Set the preference for the end or target of an
interaction connection in a diagram. Your five
options are None, Arrow, Diamond, Crows Feet,
Triangle, or Hollow circle. This applies only to a
Usage.

SHAPES FORMATTING

This is where you can set global preferences for drawing shapes. For all Shapes you can set Font
and Color Options, Horizontal Alignment, Vertical Alignment, Rendering, Display Options and
Line Display Options. The availability of the formatting elements depends on the element you
select.

Font and Color Options

You can change the fonts, font size, font colors, and the fill and line colors of a selected element
in the Colors and Fonts portion of the Formatting dialog.

To change the font select a font from the drop-down menu in the Font text box. You can also
change the font size by selecting a size from the drop-down menu in the size text box. You can
edit the font settings of all element labels. The following commands are available:

Command Icon Description
Front Style Select a new font style from the drop-
down list.
Front Size Select a new font size from the drop-
down list.
Bold Applies bold formatting to the label
B text.
Italics ltalicizes the label text.
I
Underline u Underlines the label text.
Strikeout s A line is drawn through the label text.
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You can also change the font color, element outline color, and element fill color with the

Command Icon Description
Change Font A Opens the Color dialog. You can select
Color — an existing color or create a custom

color for the color of the label font.

Change Line . Opens the Color dialog. You can select

Color é" an existing color or create a custom
color for the border of the element.

Change Fill Opens the Color dialog. You can select

Color % an existing color or create a custom
color for the background of the
element.

following

Horizontal Alignment

You can change the justification settings for the text label in an element.

These commands do not justify the text labels on elements that use text boxes outside

NOTE:
the element.
Command Icon Description
Left Justify _ Justifies the text on the left side of the
Text = text box.

Center Text

Centers the text in the text box.

Right Justify
Text

Justifies the text on the right side of
the text box.

Vertical Alignment

You can change the top to bottom alignment settings for the text label in an element.

Command Icon Description

Top = Places the text in the top portion of the
element.

Center Centers the text within the element.
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Command Icon Description
Bottom Places the text in the bottom portion of
the element.
Rendering
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There are two commands available that affect the appearance of elements in the Diagram View:

Command

Description

Shadowed

When this option is selected the
element has a slight shadowed
background. The Shadowed option is
the default setting.

Gradient

When this option is selected the
element has a gradient shading. If it is
not selected the element is a solid
color. The Gradient option is the
default setting.

Task1

Task1

Transparent

The shapes have a transparent
background when this preference is
selected.

Transparent Line

This preference refers to the border of
the text box. When placed in a pool,
you can set the preference so the
border does not show.

Display Options

The Show Name on Creation option displays an element’s name when that element is placed on

a diagram.

NOTE: This only applies to newly created elements on a diagram. Existing elements are not
updated when you click the Apply to Diagram button.
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Line Display Options

You can set the line display preferences for the Line object.

Command Description

Line Width This preference sets the width of an interaction or
relationship in a diagram. Select 1 through 5 pixels
from the drop-down list box.

Line Style This preference sets the line style of an interaction
or relationship in a diagram. You can select from
one of five different styles from the drop down list.
The list includes solid, dash, dot, dash-dot, and
dash-dot-dot.

Source Decorator Set the preference for the beginning or source of
an interaction or relationship connection in a
diagram. Your five options are None, Arrow,
Diamond, Crows Feet, or Triangle.

Target decorator Set the preference for the end or target of an
interaction or relationship connection in a
diagram. Your five options are None, Arrow,
Diamond, Crows Feet, or Triangle.

IMPORT/EXPORT

You can set the default locations for importing workspaces and exporting workspaces, diagrams,
and grid editors. Click Browse to open the Browse for Folder dialog.

Preference Description

Default Export Location Select the location where you want the exported files placed.
The default location that appears in the Browse for Folder
dialog is the My Documents folder.

Default Import Location Select the location where the imported files reside. The default
location that appears in the Browse for Folder dialog is the My
Documents folder.

You can also set the following preferences:

e Comma Separated Values Preferences

ER/Studio Data Architect Preferences

Impact Analysis Preferences

Usage(CRUD) Preferences

Visio Preferences
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Comma Separated Values Preferences

You can set import options when you are importing comma Separated Value files.:

Preference

Description

Default Import Location

Select the location where the imported files reside. The default
location that appears in the Browse for Folder dialog is the My
Documents folder.

ER/Studio Data Architect Preferences

You can set export options when you are importing from and exporting to ER/Studio:

Preference

Description

Export Options

Default export location

Select the location where you want the exported model placed.
The default location that appears in the Browse for Folder
dialog is the My Documents folder.

Installed version of ER/
Studio Data Architect

You have three options: None, 7.0, and 7.1, 7.5. Choose 7.5 for
versions 7.5 and later

ER/Studio 7.0 does not support an XML data type. If this option
is selected and the exported file contains a business attribute
with an XML data type, it will be exported as VARCHAR.

ER/Studio 7.1 supports XML data type and will be exported
intact.

Automatically Open
Generated Models in ER/
Studio Data Architect

Select this option if you want ER/Studio Data Architect to open
automatically after the export of a Conceptual Model. When
this option is selected, the option in the Export to ER/Studio
Data Architect dialog is also selected.

Import Options

Default Import Location

Select the location where the ER/Studio Data Architect models
reside. The default location that appears in the Browse for
Folder dialog is the My Documents folder.

Import Domains as

Select the type of element you want domains imported as. Your
choices are: Business Elements, Domains, and Business
Elements Referencing Domains.

Impact Analysis Preferences

You can set import options when you are importing Impact Analysis report files.:

Preference

Description

Default Import Location

Select the location where the imported files reside. The default
location that appears in the Browse for Folder dialog is the My
Documents folder.
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Usage(CRUD) Preferences

You can set import options when you are importing Usage (CRUD) report files.:

Preference Description

Default Import Location Select the location where the imported files reside. The default
location that appears in the Browse for Folder dialog is the My
Documents folder.

Visio Preferences

You can set import options when you are importing from Microsoft Office Visio®.:

Preference Description

Automatically Save Main | The Instance-level mappings are not saved as part of the
Object Type Mapping custom mapping file. You have two options:

Prompt: The “"Unable to Save Instance-Level Mappings” dialog
always appears when you click Save, giving you the option to
save or reject the current object type mappings.

Always: The current object type mappings are automatically
saved without any warning.

Default Import Location Select the location where the imported Visio files reside. The
default location that appears in the Browse for Folder dialog is
the My Documents folder.

Default Custom Mapping | Select the location where you want to save your custom

File Location mapping settings when importing Visio models.
Retain Visio object sizes Select this option to ensure that if a presentation element is
when creating resized in Visio, that resizing is carried over to ER/Studio BA.

presentation elements

LICENSE MANAGER

You can set preferences for what licensing information you want logged.

Preference Description

File Location Set the file location of the License Manager log. You can
change the location by clicking Browse to go to the Open
dialog.

Mag Log Size (bytes) The default log size is 1048576.

Log Options You can select to display the following message types: Error,
Information, and Debug. The options you select determine
what messages appear in the Error Logging View.
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MESSAGES

The Messages Preference settings display the default location of the application log file and
what type of error logging messages are displayed.

Preference Description

Log File Location Displays the location of the log file. This location cannot be
edited.

Error Logging Options You can select to display the following message types: Debug,

Error, Fatal, Information, Trace, and Warning. The options you
select determine what messages appear in the Error Logging
View.

MODEL VIEW

There are two different preferences you can set for the Model View:
Preference Description

Automatically Expand If you have large models and click the Expand All icon in the
when Clicking Expand All | Model View, you will get a dialog warning you that this action
Button may take an extended length of time.

Prompt: The warning dialog will always appear.

Always: The Expand All action happens without the warning
dialog.

Display Tooltips When "On" is selected, a descriptive text box appears when
the cursor is placed on an icon or node in the Model View tree.

Group Obijects by Type Objects within a model are displayed in the tree grouped by
type (for example, a Task node will contain all of the tasks within
the model).

Select presentation nodes | If this preference is set, both the presentation element node
when using the Find In (designated by a small arrow placed on the element @)

Model View Feature as well as the element node are highlighted in the Model View

tree.

NAMING

Select this option if you want to include the source and target in the relationship names.

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 141



APPLICATION BASICS > PREFERENCES

If you select this option the relationship names are displayed as follows in the Model View tree
and diagram:

= DiagramZne Pool
== Diagramione Laneg
= Task

=8 Outgoing Relationships
{ == Task.Taskl |

B Taskl

If this option is not selected, the target/source relationship names are displayed as follows in the
Model View tree and diagram:

=1 DiagramCne Pool
== Diagrarmonelans
= Task
-5 Cukgaing Relationships
=l-=# Sequence Flow _]
B Taskl

PROPERTY VIEWS

You can set a preference for opening Property Views for each created object. When this
preference is selected, each time you create an object, either in the Model View or from the

palette, the associated Property View is opened as well.

NOTE: You can close all Property Views by selecting File > Close > All Property Views
from the main menu or the Close All menu on the Property View toolbar.:

Preference Description
Open Property View on If you select this option, whenever you
object creation place a new object on the diagram

window the property view pane
displays so you can enter property
values for the new object.

REPORTING
You have two options for the Web Report:
Preference Description
Launch report upon | If you select this option, once you select the command
completion to generate reports on all diagrams in an opened
workspace, a web browser is launched showing the
report.
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Preference Description

Default report Click Browse to select the folder where you want your

location Web Reports stored. You can also create a new folder
in the Browse For Folder dialog.

REPOSITORY OPTIONS

You have three options for the Repository:

Preferences Description

Server Machine Specify the URL or hostname of ER/Studio Repository.

Server Port Specify the port ER/Studio BA uses to communicate
with the repository server. The default is 54333.

Check out model Choose what action, if any, you want the system to

when checking out | perform with respect to the models in a diagram, when

diagram a diagram is checked out; always check out the

models, never check out the models, or prompt the
user to decide what to do each time a diagram is
checked out.

WORKSPACES/MODELS

The table below describes the preferences available for the Workspaces/Models node:

Detail ‘ Description

Workspace Options

Default workspace directory | Click the browse button to open the Browse For Folder dialog.
You can change the existing default directory or create a new
folder to be the default directory.

Entries in recently used Set the number of previous workspaces you want to appear in
workspace list the File > History menu. The default setting is 4.

Prompt for workspace when | If this option is selected, the Welcome dialog opens when you
starting application first start the application. It allows you to create a new
workspace, open the last used workspace, import a
compressed-format workspace, or open an existing workspace.
If it is not selected, ER/Studio BA opens to the last used

workspace.

Model Options

Default Model Type When you create a model, the default model type can be set
so the preferred type always appears in the Model Type list
box.
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The ER/Studio BA workflow enforces a hierarchical approach to help you manage large design
projects. To use the application effectively, it is important that you understand the product’s
scope and the relationship between Workspaces, Projects, Models, Diagrams, and Diagram
Elements (objects) before using the product. This section of Help gives you information on how
to use the ER/Studio BA features listed below:

® Workspaces and Projects

Using Models

Processes - Business Process Modeling

Diagrams and Elements

Reference Objects

External Data Objects

Drawing Shapes

WORKSPACES AND PROJECTS

A workspace is a unit of storage used for any collection of data modeling projects, reference
objects, and data source projects. In ER/Studio BA you can only open and work with one
workspace at a time, but you can collect any number of projects in a single workspace.

A project is used to create a collection of user-created data models or subprojects. Data sources
and reference objects also exist as their own projects within the workspace. A Project is a
collection of items including models, diagrams, model elements, documents, business rules, etc.
For example, a “Human Resources” project might contain a business process model describing
the main functions of the Human Resources department, and a data model describing the data
structures used by these processes, and business rules describing prescribed behavior of the
organization. You can also create nested projects where a project is a parent of another project.
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The graphic below shows both a Business Process Modeling workspace and project in the
Model View tree.

3 Hodel X & | B IEI ¥ G T O

& Company Waorkspace
Cn:nmpliann:e Reinstaterment Project 4= Project
= ﬁ Sales Conceptual Model
Sales Units
= ﬁ Shipping Process Model
Crder Picking
1 Order Picking
@- Compliance Reinstatemenet Project Park Two
=\ Reference Objects
= .f' External Data Objects
@ Morthwind
Impact Analvsis For Customers
ﬁ Customers
3 Entity
g Business Elements
% Business Rules
%E Business Units
% Skewards

EI

USING WORKSPACES

In the Model View tree, your workspace occupies the root node under which all projects and
their associated elements appear in a hierarchical format. On creation, you can specify the name
and location of your workspace and save it as an *.exw file.

It is easy to create a workspace from the Welcome page that opens when you first start the
application. Once you create a workspace you can insert a project or a model. You can then
save, open, close, rename, and delete it. You can also open a workspace in read-only mode. You
can open the Property View for the workspace.

Using the Workspace Dialog

When you first start ER/Studio BA the splash screen opens followed by the Welcome to ER/
Studio Business Architect dialog. You have four options available:

Option Description

Create a new workspace (with optional | Opens the New Workspace dialog where you create
project, model, and diagram) a new workspace, project, model, and diagram. For
more information, see Creating a New Workspace.

Express create You can quickly create a workspace, project, model,
and diagram. Select the type of model and enter a
name, which is used for the workspace, project,
model and diagram that are created. For more
information, see Using Express Create.
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Option

Description

Import a compressed workspace

You can import and open an existing workspace that

you have exported and stored as a compressed file.
For more information, see Importing a Compressed

Workspace.

Opens the last workspace you worked on. This is the
default setting if a previous workspace exists.

Open My Last Used Workspace

Click Browse to open the Browse for a workspace file
dialog. The default path is x:/My Documents/
EStudioBusinessArchitect/

When selected and OK has been clicked, the ER/
Studio Repository log in dialog appears where you
can log in and then copy a workspace from the ER/
Studio Repository to you local desktop.

Open an Existing Workspace

Get a workspace from the Repository

If you select this option, each time you open ER/
Studio BA, the last workspace you worked on
automatically opens.

Always use last workspace on startup

= Welcome to ER/Studio Business Architect

Welcome to ER/Studio Business Architect
Welcome to ERJStudio Business architect, Wwhat would wou like to do?

() Create a new workspace (with optional project, model, and diagram)

() Import a compressed workspace
(%) Open my last used workspace

O Open an exisking workspace:

() Get a workspace From the Repository

[ always use last workspace on startup

Ezit
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Creating a New Workspace
You can create a Workspace, and if desired, a Project, a Model, and a Diagram as well using the
Create a New Workspace dialog. The file extension of a workspace is .exw.

1 On the File menu, select New > Workspace. The New Workspace dialog opens.

NOTE: When creating a new workspace, if an existing workspace is open, you get a Save
Workspace dialog asking if you want to save the current workspace. Click Yes and it is
closed. When the previous workspace is closed, all projects, models, and diagrams
associated with the workspace are also saved and closed.

2 Enter the workspace name in the first text box.

The default path for workspaces is .. . \My
Documents\Embarcadero\ERStudioDataArchitect. You can click the drop—down arrow in
this text box to display a list of last used locations.

3 If you want to change the path, click Browse to open the Browse For Folder dialog and
select another folder.

NOTE: You can also create a new folder by clicking Make New Folder.
4 If you want to create an associated project at this time, click Create a project within this
workspace. You can now enter the name of that project in the Project Name text box.

Next, you can create a model and associate it with either the project or the workspace. A model
is a specific collection of elements related to a modeling notation such as Business Process
Modeling Notation or Conceptual Modeling.

5 Click Create a model within this... and then select either Project or Workspace from the
drop-down list.

6 Enter the name of your model in the Model Name text box.
7 Select either Business Process or Conceptual from the Model type drop-down list.

8 If you are creating a Business Process model, you can select On in the Validate against
BPMN specification box, to enable the validation option.

The validation checks compliance to the Business Process Modeling Notation
specifications. For example, if validation is enabled and you draw a message flow from a
start event to a task, you get a dialog stating that this is an invalid relationship. If validation
is set to Off, it is drawn without notification.

NOTE: When you select On the following icon is displayed {fly next to the model node in the
tree. If you select Off, a different icon % is displayed.
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9 To create a diagram associated with the model click Create a diagram within this model
and enter the name of your diagram in the Diagram Name text box.

NOTE: If you are creating a Business Process model, notice that the diagram name, the Name
of pool with invisible boundary and First lane name text boxes are populated with the
same name as the Model name. You can then rename the diagram, the pool, and the
lane if desired. If you are creating a Conceptual model, these fields are not available.

In the Business Process Modeling Notation Specification, all business process diagrams
must contain at least one pool and each pool is a container for one process. In ER/Studio
BA, when you create a diagram, a pool and lane with an invisible boundary are automatically
created.

10 Click OK. ER/Studio BA creates the workspace (with the file extension of .exw), project,
model, and diagram and adds them to the Model View tree.

Related Topics:
® Creating a Project

Creating and Working with Diagrams

Upgrading Workspaces

Upgrading Workspaces

If you have upgraded ER/Studio BA to a newer version your workspace must be upgraded
before it can be used. The first time you open an existing workspace, or if you are importing a
compressed workspace, the Workspace Upgrade dialog opens. This process updates the
version number in the workspace, project(s), model(s), and data source files. It also updates
business attribute optionality and connection label justification.

CAUTION: When upgrading workspaces that have elements created by importing an ER/
Studio model, if the ER/Studio model is imported again in version 1.6, new
elements are added instead of updating the existing ones.

1 Click Details to view a list of what the upgrade process includes. The upgrades include the
following:

® Business Process Modeling process information

e Shape transparency

Mandatory Property of conceptual modeling relationships

Unique identifier options for conceptual model business attributes

Bound element properties for conceptual model business attributes

Enforcement options for business elements.

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 149



USING ER/STUDIO BUSINESS ARCHITECT > WORKSPACES AND PROJECTS

5
6

The hierarchy that appears in the list box includes the workspace and all projects and
models. It also includes any reference and external data objects. Clear the check box of any
items you want excluded from the upgrade.

NOTE: Excluded items are removed from the workspace and are automatically upgraded if
they are inserted back into the workspace.

You have the option to backup your workspace before performing the upgrade. Browse to
the location where you want to store your backup. The workspace name is appended with
“backup” and has a file extension of .exz.

NOTE: If the upgrade fails you can import the backup file.

Click OK and a progress dialog opens telling you the workspace is being upgraded. A
dialog opens telling you that the upgrade was successful.

Click Details and a list of all upgraded files open. You can print or save these details.

Click OK to close this dialog and the upgraded workspace opens in ER/Studio BA.

CAUTION: Workspaces created in ER/Studio BA's beta versions are not upgraded.

Updating Business Elements and Business Attributes

The upgrade processes business attributes first and then business elements, based on rules
below.

For business elements, if the enforce/propagate properties are cleared in the 1.0/1.1
version, the enforcement options should be cleared after upgrade. If the enforce/propagate
properties are selected in the 1.0/1.1 version, the enforcement options should be selected
after upgrade.

For business attributes:

e |f the "enforce name"” property is selected on the original business element, a comparison
will be done on each business attribute bound to the business element. If the attribute
name matches the business element name, the override property is not set. If the names
don't match, the override property is set.

e |f the “propagate data type"” property is selected on the original business element, a
comparison will be done on each business attribute bound to the business element. If the
data type matches the business element data type, the override property is not set. If the
data types don't match, the override property is set.

e If the “propagate description” property is selected on the original business element, a
comparison will be done on each business attribute bound to the business element. If the
attribute description matches the business element description, the override property is
not set. If the descriptions don't match, the override property is set.

e If the “propagate notes” property is selected on the original business element, a
comparison will be done on each business attribute bound to the business element. If the
attribute’s notes match the business element’s notes, the override property is not set. If
the notes don't match, the override property is set.
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Exporting a Workspace

You can export your workspaces in a compressed format. You can then import that compressed
workspace into another ER/Studio BA application on another computer. The file extension for
this compressed file is .exz.

1

Open the workspace you want to export in the Model View tree.

2 Select File > Export > Workspace from the main menu and the Export dialog opens.

OR

Right-click the workspace node in the Model View tree and select .4 Export....

NOTE: If your workspace has been modified and has not been saved, you will get a warning
dialog asking you to save it.

Select the location where you want to save the compressed file and enter a new file name if
desired.

NOTE: You will get a warning if the compressed files already exist in that location.

Click Save and the file is saved to your chosen location. The workspace name is appended
with “_backup” and has a file extension of .exz.

Importing a Compressed Workspace

You can import and open a compressed workspace in ER/Studio BA.

1

In the Welcome to ER/Studio BA dialog (which is available when you first start the
application), select Import a Compressed Workspace.

OR

From the main menu select File > Import > Workspace.... The Import a Compressed
Workspace dialog opens.

Enter or browse to the location where you stored your compressed workspace.

NOTE: The file extension for the compressed workspace is .exz.

3 Enter or browse to the location where you want to extract the selected workspace.

CAUTION: You will get a warning in the dialog if you attempt to extract a compressed

workspace file to a folder that already contains one or more files included in the
compressed file.

4 Click OK and compressed workspace is opened in the Model View tree.

NOTE: If you are importing a workspace into a newer version of ER/Studio BA, a Workspace
Upgrade dialog opens.
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Using Express Create

When you first open ER/Studio BA a Welcome to ER/Studio Business Architect dialog opens.
Instead of using the Create a New Workspace option, you can use the Express Create which
streamlines the creation process by creating a workspace, project, model, and diagram all
named the same.

NOTE: The Express Create option is only available in the Welcome to ER/Studio Business
Architect dialog.

1 Select the Express Create option in the Welcome dialog.

2 Select the Type from the drop-down list box. Your choices are Business Process and
Conceptual.

3 Enter the name you want to use for your new workspace, project, model, and diagram.

4 When you click OK the created workspace, project, model and diagram appear in the Model
View tree. The diagram is also opened in the Diagram View as a tabbed view. The palette
associated with the model (i.e., either Business Process or Conceptual) is available in the
Palette view.

Saving a Workspace

A workspace is saved under the following conditions:
e \When a workspace is created, it is automatically saved.

e When you close a workspace or exit the application, you are prompted to save your current
workspace.

* When you open an existing workspace or create a new workspace, if another workspace is
open, you are prompted to save that workspace.

When you make additions or changes in a workspace, you can save your workspace by:
Clicking Save ([1]] ) on the main toolbar.
OR
Right-clicking the workspace name in the Model View tree and selecting Save Workspace.

OR

From the main menu, select File > Save.
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Opening a Workspace

Only one workspace can be opened at a time in the Model View tree.

Choose File > Open Workspace.

Press Ctrl +0O.

Right-click in the Model View and select Open Workspace. The Open dialog appears
listing all available workspaces in the default location.

5 Expand the Workspace folder you want to open and double-click the file with the extension
.exw. This is the file extension for all workspaces.

NOTE: If you have another workspace open, you are prompted to save the current workspace.
When you click Yes, that workspace is saved and the newly selected workspace is
opened in the Model View tree.

Closing a Workspace
Choose File > Close>Workspace.

Right-click the workspace node in the Model View and select Close.

NOTE: If you have made additions or changes to your workspace you are prompted to save
your current workspace. Click Yes and the workspace and all the project, model, and
diagram data is saved and closed.

Renaming a Workspace

1 Right-click the workspace node in the Model View tree and select Rename Workspace.

NOTE: If your workspace is unsaved a Save Workspace dialog opens telling you that you must
save your workspace before it can be renamed.

2 In the Rename Workspace dialog, enter the new name in the text box and click OK.

Deleting a Workspace

When you create a new workspace, a folder with the workspace name is created in your default
location, for example ...My Documents\ERStudioBusinessArchitect\workspace name.
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To delete a workspace:
1 Right-click the Workspace name in the Model View tree and select Delete.

2 In the Confirm Workspace Delete dialog you have three choices.

No, | do not want to delete the workspace. | The delete action is canceled and no
action is taken.

Yes, and also delete the associated files This option lists the entire path where
under x:\.Documents and Settings\.... the workspace files are stored. When
you choose this option, the workspace
is deleted from the Model View tree
and the folder containing the
workspace information is also deleted.

Yes, but do not delete the associated files. | The reference to the workspace in the
Model View tree is removed but the
workspace folder still remains in the
directory.

3 Select the option you want and click OK.

NOTE: If you select the third option, you can reopen the workspace by going to the location
where you workspace is stored, for example ...My
Documents\ERStudioBusinessArchitect\workspace name, and double-click on the
workspace name.

Using Read-only Workspaces

A workspace will be opened as read-only under the following conditions
® Open the same workspace on the same computer
e Open the same workspace on a network

When you open a workspace that is already open, you will be informed that the workspace is in
use but that it can be opened as read-only. You can then choose to open the workspace as read
only or cancel the operation..

When you open workspace as read-only, the workspace name is shown in the title bar with a
read-only indicatory. You can view the models in the workspace, generate reports, but can't
make any changes to the workspace data or diagrams. All import mechanisms are also disabled.

NOTE: A temporary marker file is used to track the open status of a workspace
(~MyWorkspace.etwtemp), created in the workspace’s folder on the file system.

The following actions are NOT allowed in a read-only workspace:
® Import of Visio, CSV, or ER/Studio
e Deleting from menus, diagrams, model views, or property views

e Create actions from menus, diagrams, model view, property views
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Cut/copy and paste
® Accessing Property Views

® Diagram creation

Editing a Diagram (moves, deletes, editing, show/hide)

® Dropping elements from toolbars or palettes

Drag/drop in model view within metadata or diagram nodes

No drag/drop from model view to diagram

* Any save actions

Setting of properties from right-click menus
The following actions are allowed in a read-only workspace:
* Export

e Generation of a new web report

Rename - Project, Model, Diagram, Independent Sub-process, Invisible Pool.

Insert Project/Model, Insert Model.

Creating Impact Analysis Diagram.

USING PROJECTS

A Project is a collection of items including models, documents, business rules, etc. For example,
a "Human Resources” project might contain a business process model describing the main
functions of the Human Resources department, and a data model describing the data structures
used by these processes, and business rules describing prescribed behavior of the organization.
The file extension of a project is .exp. You can:

¢ Creating a Project

Inserting a Project

Reparenting a Project

Renaming a Project

Closing a Project

Saving a Project

Deleting a Project

NOTE: You can have multiple Projects open simultaneously. You can then easily switch back
and forth between them.
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Right-click a Project in the Model View tree to gain access to additional functions:

Command Icons Description

Links

This command opens the Create Link wizard which
allows you to create links between elements.

(%]

Usages u, This command opens the Create Usage wizard which
allows you to create usage connections between
elements.

You have two commands available from the pull-right
menu:

Impact Analysis

You can generate an Impact Analysis Diagram which
graphically displays all the associated relationships
and elements.

You can also show the Impact Analysis Report.

Refresh o Updates the currently displayed information in the
Model View with new data or changes.

Properties Opens the Property View for the selected element.

Creating a Project

When you create a workspace, you can create a new project at that time in the New Workspace
dialog. But you can also create other new projects in that workspace to store your models and
diagrams using the New Project dialog.

1 On the File menu, select New > Project.

OR

In the Model View tree right-click the workspace and select New > Project.The New
Project dialog opens.

2 In the Project name box, type the name of the new project.

3 You can enter a description of the new project in the Description text box. Press Enter to
add a CRLF in the text box.

NOTE: If you press Ctrl+Enter the New Project dialog closes and the new project name
appears in the Model View tree.

4 You can then select where to create the project: in the existing workspace or nested in the
existing project.

5 Click OK. The project is created and the dialog box closes.

NOTE: The default storage directory for the new project is set when you create the workspace.
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Inserting a Project

If you have deleted a project or model but did not delete the associated files you can select this
command to “restore” the deleted project or model. You can:

e insert a model in a model
e insert a model in a project
® insert a project in a workspace
e insert a data source project under External Data Objects node.
The following actions are NOT allowed when inserting projects and models:
* insert a project from another workspace
e insert a project under a model
* insert a reference object project under a workspace, project, or model
* insert a data source project under a workspace, project, or model
e insert a project or model under the External Data Objects node
* insert a reference project under the External Data Objects node

CAUTION: The undo/redo function is not available for the insert project command.

To insert a project:
1 Right-click the Workspace node in the Model View tree and select Insert Project/Model.

2 Inthe Insert Project or Model dialog open the folder that is labeled with the project’s name
that you want to restore.

CAUTION: If you attempt to insert a project into another workspace you will get a warning
dialog. A project can only be inserted into the workspace it was created in.

3 Select the file labeled meta-model . exp, click Open and the selected project is placed in the
Model View tree.

Reparenting a Project

You can reparent a project within a workspace by dragging and dropping the project from one
location to another. Basically you will be removing the project from the current workspace
location and immediately reinserting the project into the workspace at another location. When
you reparent the project, all associated files including models, diagrams, and elements are also
reparented.

CAUTION: Itis recommended you do a a backup of your workspace before doing a
reparenting action.
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The following rules apply to the reparenting action. If any of the error conditions listed below
occur, you will get a dialog warning you that the reparenting is not valid and will not be allowed.

Projects can be reparented to workspace.

A project will be allowed to be reparented to another project, but not to one of its own child
projects.

A project will not be allowed to be reparented to the following: (1) Reference Object project;
(2) External Data Object project; (3) a data source; or (4) a model.

A model will be allowed to be reparented to a project.

A model will be allowed to be reparented to a model of its same nature (i.e., Conceptual or
Business Process) as long as it isn't one of its own child models.

Models can be reparented to workspace.
You cannot reparent a Reference Object project or an External Data Object project.
A data source:

¢ will be allowed to be reparented to another data source as long as it isn't one of its own
children.

¢ will be allowed to be reparented to the External Data Objects project.
¢ will not be allowed to be reparented to the Reference Object project.

¢ will not be allowed to be reparented to a project or model.

To Reparent a Project:

1

In the Model View, select the project you want to reparent and drag it to its new location.

NOTE: When dragging the node, the destination node must be highlighted as illustrated in
the following screen shot.
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NOTE: If you have not saved your workspace you will get a warning dialog telling you that you
must save the workspace and all associated diagrams must be closed. If you click Yes
the workspace is saved, all associated diagrams are closed, and the project is
reparented.

2 Release the node and the project and all associated files are reparented to its new location.

Renaming a Project

You can rename a project by using the Rename Project command. When you rename a project
you are changing the name of the project and the associated project’s folder on the file system.

In the Model View tree, select the project node you want to rename.
1 Right-click the node and select Rename Project.

2 Enter the new name in the text box and press Enter. The project’s name changes.

Closing a Project
1 Right-click the project node in the Model View and select Close.

NOTE: If you have made additions or changes to your project you are prompted to save it.
Click Yes and the project, model, and diagram data are saved and closed.

Saving a Project
A project is saved under the following conditions:

* When a project is created, it is automatically saved.
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* When you close a project, you are prompted to save it.

When you make additions or changes to a model or diagram in a project, you can save your
project by:

Clicking Save ([]]) on the main toolbar.

Right-clicking the project name in the Model View tree and selecting Save Project.

On the main menu, choose File > Save.

Deleting a Project
1 Right-click the Project name in the Model View tree and select Delete.

2 In the Confirm Project Delete dialog you have three choices:

No, | do not want to delete the project. The delete action is canceled and no
action is taken.

Yes, and also delete the associated files under | This option lists the entire path where
x:\.Documents and Settings\.... the Project files are stored. When you
choose this option, the project is
deleted from the Model View tree and
the folder containing the project
information is also deleted.

Yes, but do not delete the associated files. The reference to the project in the
Model View tree is removed but the
project folder still remains in the
directory.

3 Select the option you want and click OK.

CAUTION: The undo/redo function is not available for the remove command, which is the
third option in the Confirm Project Delete dialog.
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USING MODELS

A model is a specific collection of elements/objects related to a modeling notation (BPMN,
Conceptual, etc.). For example, the Human Resources BPMN model would contain those
objects associated with the business processes of HR: tasks, swimlanes, gateways, etc. A model
is where the object “lives”. i.e., objects are stored within a model, but can be visualized in other
formats such as a visual diagram, grid editor, etc. In Business Process Modeling you can choose
whether to create a model in “Validation” mode, which enforces the rules of the specified
notation, or with validation off, which allows you to use the visual objects without being
constrained by the rules of the notation. Nested models are allowed. The file extension of a
model is .exm.

When you create a workspace or project in ER/Studio BA you are given the opportunity to create
a new model. You can have “nested” models with a model. These nested models can also
contain diagrams as shown in the following graphic.

s
S EEE| ¥ H
= WorkspaceCne
= E- ProjeckCne
= ﬁ ModelCne
=i subMadel
Diagrarn T
[ DiagramTwo
DiagramOne
[ Diagramone
Eﬂ% Reference Objects

Elements within a model can be displayed two different ways in the Model View tree:

Command Description Example
Grouping by Object When you click the Group by Object 2 iy Modekone
Type type E| 4 iy subModalone
icon ( ), elements are sorted by # | Disgrams
type, # B Pocls
for example, a Task node contains all of * @ Events
the tasks within the model. Under each = &7 Tasks
; = Task One
node the items are sorted
alphabetically, = Task Thres
; . = Task Two
unless there is a sequence associated
with an object (lanes, for example).
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Command Description Example
Model View Hierarchy | This is a hierarchal representation of all =
elements in a model, in a diagram = "5 Comphance Renstatement Praject
node, = iy shipping Pracess Model
and in the model node. 5 k4 Order Picking
[ Start Event
IQ End Evert
B Task
= Taski
5P Taskz
5 Tasks
[ﬁ} Gatevay

=[] Order Picking Pool
= &= Order Picking Lane
<@ srart Evert
@ End Event
B Task
= Taskl
B Task2
= Taskd
(:} Gabaway

I

WORKING WITH MODELS

You can create a new Model at the time you create a workspace or by using the menu command.
Once you create a it you can do the following to a model:

® Open/close

e Save
e Rename

® Reparent

® |nsert

e Delete

Right-click a model node in the Model View tree to gain access to the following additional
functions:

Command Icon Description

Links

This command opens the Create Link
wizard which allows you to create links
between elements.

(%]

Usages u This command opens the Create

- Usage wizard which allows you to
create usage connections between
elements.
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Command Icon Description
Grid Editor = This is a table-like editor which is an
Be=

alternative to the Model View. Content
in the Grid Editor can be printed or
exported as a report.

You have two commands available
from the pull-right menu:

You can generate an Impact Analysis
Diagram which graphically displays all
the associated relationships and
elements.

Impact Analysis

You can also show the Impact Analysis

Report.
Refresh o, Updates the currently displayed
= information with new data or changes.
Properties Opens the Property View for the

selected model.

Creating a Model Using the Menu Command
1 On the File menu, select New > Model.

OR

In the Model View tree, right-click the workspace and select New > Model to open the New
Model dialog.

NOTE: You can also create a new model by right-clicking the project node or the model node
in the Model View tree.

2 Enter the model name in the Model Name text box.

3 Inthe Model Type drop-down list, select the type of model you want to create. You have the
following options:

Model Icon Model Type Description

ﬁ Conceptual Modeling Conceptual modeling is used by

enterprise architects, business users,
and data architects to model
information about the business as it
relates to data, data flow, process, or
information assets.

ﬁ Business Process Modeling Uses the Business Process Modeling

Notation (BPMN) specification to
graphically express business
processes.
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4 If you are creating a Business Process model, select On in the Validate against BPMN
specification box to enable the validation option. If you are creating a Conceptual Model,
this option is unavailable.

The validation checks compliance to the Business Process Modeling Notation
specifications. For example, if validation is enabled and you draw a message flow from a
start event to a task, you get a dialog stating that this is an invalid relationship. If validation
is off, it is drawn without notification. When you select On the following icon is displayed

iy next to the model node in the tree. If you select Off, a different icon @&, is displayed.

NOTE: The default preference for validation can be set. When creating a new model, the New
Model Wizard displays the preference set, which you can change.

5 You can enter a description of the new model in the Description text box. Press Enter to add
a CRLF in the text box.

NOTE: If you press Ctrl+Enter the New Model dialog closes and the new model name appears
in the Model View tree.

6 Select where to create the model: either in the workspace, or in a project. You can also nest
a model within a model.

NOTE: The default storage directory for the new model is set when you create the workspace.

7 To create a diagram associated with the model click Create a diagram within this model
and enter the name of your diagram in the Diagram Name text box.

NOTE: If you are creating a Business Process model, notice that as you enter the diagram
name, the Name of pool with invisible boundary and First lane name text boxes are
populated with the same name. You can then rename both the pool and the lane if
desired. If you are creating a Conceptual model, these fields are not available.

In the Business Process Modeling Notation Specification, all business process diagrams
must contain at least one pool and each pool is a container for one process. In ER/Studio
BA, when you create a diagram, a pool and lane with an invisible boundary are automatically
created.

8 Click OK. The new model is created and placed in the location you selected.

Saving a Model
A model is saved under the following conditions:

* \When a model is created, it is automatically saved.

When you make additions or changes in a model, you can save your model by:

Clicking Save ([1]] ) on the main toolbar.

Right-clicking the model name in the Model View tree and selecting Save Model.
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Renaming a Model

You can rename a model in the Model View tree.

1 Inthe Model View tree, right-click the model node you want to rename and select Rename
Model.

2 Inthe Rename Model dialog enter the new name in the text box and click OK. The model is
renamed in the Model View tree and in the file folder.

Reparenting a Model

You can reparent a model within a workspace by dragging and dropping the model from one
location to another. Basically you will be removing the model from the current workspace
location and immediately reinserting the model into the workspace at another location. When
you reparent the model, all associated files including diagrams and elements are also
reparented.

CAUTION: Itis recommended you do a a backup of your workspace before doing a
reparenting action.

The following rules apply to the reparenting action. If any of the error conditions listed below
occur, you will get a dialog warning you that the reparenting is not valid and will not be allowed.
Note that these rules apply to both projects and models.

e Projects can be reparented to workspace.

* A project will be allowed to be reparented to another project, but not to one of its own child
projects.

e A project will not be allowed to be reparented to the following: (1) Reference Object project;
(2) External Data Object project; (3) a data source; or (4) a model.

e A model will be allowed to be reparented to a project.

e A model will be allowed to be reparented to a model of its same nature (i.e., Conceptual or
Business Process) as long as it isnt one of its own child models.

e Models can be reparented to workspace.
® You cannot reparent a Reference Object project or an External Data Object project.
* A data source:

¢ will be allowed to be reparented to another data source as long as it isn't one of its own
children.

¢ will be allowed to be reparented to the External Data Objects project.
e will not be allowed to be reparented to the Reference Object project.

¢ will not be allowed to be reparented to a project or model.
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To Reparent a Model:

1 In the Model View, select the model you want to reparent and drag it to its new location.

NOTE: When dragging the node, the destination node must be highlighted as illustrated in

the following screen shot.

-
*iodel &3

EE-\

SRR

{5

Compliancepkei
;T P
M s

¢ - abe
Elﬁ Shipping Process Model

-- Crder Picking

--EI Crder Picking Poal

--I:I Pool

-3 Pooll

ey e el e Froject: Conceptual Project |
Concepkual

------ ﬁ‘ Conceptual Model

-} Reference Ohjecks

enbRroject
e

NOTE: If you have not saved your workspace you will get a warning dialog telling you that you
must save the workspace and all associated diagrams must be closed. If you click Yes
the workspace is saved, all associated diagrams are closed, and the model is

reparented.

2 Release the node and the model and all associated files are reparented to its new location.

Deleting a Model

When you delete a model, you are presented with three different options in the Confirm Model

Delete dialog.

1 Inthe Model View tree, right-click the model node you want to delete and select Delete.

2 In the Confirm Model Delete dialog you have three choices:

No, | do not want to delete the model.

The delete action is canceled and no
action is taken.

Yes, and also delete the associated files under
x:\.Documents and Settings\....

This option lists the entire path where
the model files are stored. When you
choose this option, the model is
deleted from the Model View tree and
the folder containing the model
information is also deleted.
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Yes, but do not delete the associated files. The reference to the model in the
Model View tree is removed but the
model folder still remains in the
directory.

3 Select the option you want and click OK.

Opening and Closing a Model

When you first open a workspace the model is closed. You can open the model and all
associated diagrams and elements:

1 Right-click the model in the Model View tree.

2 Click Open. The Model View tree expands displaying all associated diagrams and diagram
elements.

NOTE: You can also open the model by clicking the plus icon (#) next to the model node.

You can close the model as well. This action collapses the model node in the Model View tree.
1 Right-click the model in the Model View tree.

2 Click Close. The Model node of the Model View tree collapses hiding all associated
diagrams and diagram elements.

Inserting a Model

If you have deleted a model but did not delete the associated files, you can select this command
to “restore” the deleted model.

1 Right-click the Model node in the Model View tree and select Insert Project/Model.

2 Inthe Insert Model dialog open the folder that is labeled with the model’s name that you
want to restore.

3 Select the file labeled meta-model . edsp, click Open and the selected model is placed in
the Model View tree.

PROCESSES - BUSINESS PROCESS MODELING

When working in ER/Studio BA you have two different types models, Conceptual and Business
Process. When working with Business Process models, you work with Processes. This section
discusses how processes are used when working with Business Process models.

A Process is a collection of flow objects connected by flows that is executed in a sequence
(usually depicted on a diagram). In ER/Studio BA, all processes are contained by a pool. A pool
contains only one process, but you can have multiple pools in a diagram which can then
collaborate via messages.
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You can set a preference to display elements in a diagram or pool under the Process node ( =f)
in the Model View. If this option is not selected, all elements are displayed under the Pool node.

In the Business Process Modeling Notation Specification, all Business Process Diagrams must
contain at least one pool. In ER/Studio BA, when you Diagram, a pool and lane with an invisible
boundary are created as well. In ER/Studio BA, when you place an object in the diagram, that
object is automatically placed in the pool.

Initially when you create the diagram, the pool and lane are given a default name. You can
rename both the created pool and its associated lane.

In the following example, the diagram contains a pool with an invisible boundary (named Order
Picking Pool) and is indicated by the I icon in the Model View tree. The lane, named Order
Picking Lane, is “owned” by the pool. The event is owned by the process, but since the process
is hidden, it appears under the pool.

- Compliance Reinstatement Project

Elﬁ Shipping Process Model

EI O_rder Picking

Task """ éﬁ Start Event
[E-1 Crder Picking Pool

El Crder Picking Lane
El@ Skart Event

| Message Trigger
Eﬂ--fﬂ% Reference CObjects

* When you place an element, for example a Start Event, that start event is shown as a
presentation element under the Diagram node (this is indicated by an arrow symbol
placed on the icon g).

El Crder Picking
éﬂ' Skark Event
[=-1 Qrder Picking Poal
El Crder Picking Lane
=143 Start Event

[l Message Trigger

-} Reference Objects

In the following example, the model contains one visible pool/lane and one invisible pool/lane.
The Model View tree displays the elements under the pool. However, in the diagram node, the
presentation elements are displayed under the lane node to show their location within the lanes
depicted on the diagram.
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= gl Acme Company
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e If you select the preference to show process in the application the elements in a pool are
displayed under the Process node.

Elﬁ Shipping Process Model
El Order Picking

----- @ Stark Event

o,

EI‘*E Crder Picking Pool
' El@ Start Event

£ Message Trigger

= COrder Picking Lane
-} Reference Objects

DIAGRAMS AND ELEMENTS

This section outlines how to work with diagrams and diagram elements and covers the following
topics:
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e Using Diagrams

e Using Diagram Elements

USING DIAGRAMS

In ER/Studio BA, you can model two different types of diagrams: Business Process and
Conceptual.

Business Process Diagrams

A Business Process Diagram (BPD) uses a flowcharting technique which is tailored for creating
graphical models of business process operations. A Business Process Model is a network of
graphical elements, which track the flow of activities and their order of performance.

A BPD is made up of a set of graphical elements that enable the easy development of simple
diagrams. The elements utilize shapes that are familiar to most modelers. For example, activities
are rectangles and decisions are diamonds. The end result is a mechanism used for creating
business process models which are able to handle complex business processes.

The graphical aspects of the notation are separated into specific categories. This provides a
small set of notation categories so that the reader of a BPD can easily recognize the basic types
of elements and understand the diagram. Within the basic categories of elements, additional
variation and information can be added to support the requirements for complexity without
dramatically changing the basic look-and-feel of the diagram.

Conceptual Diagrams

Conceptual modeling is used by enterprise architects, business users, and data architects to
model information about the business as it relates to mostly to data. However it could include
other things like data flow, process, or information assets. The conceptual model is used to drill
down into more detail which would be Process models and Logical/Physical data models. It
simplifies the organization of hundreds if not thousands of physical objects. It is powerful
enough to link to further technical (or physical) detail, but simple enough to communicate to
non-technical users.

Diagram Basics

e The Diagram View contains visual displays of elements.

e The Model View tree contains element nodes which are separate definitional metadata for
those elements. Therefore, you can create an element without needing a graphical
representation of it on the diagram.

e Elements can be reused/referenced in multiple models, regardless of model type, i.e. a
database element from a data model can be reused/referenced in a business process
model.

e The file extension of a diagram .exd.
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The following sections discuss creating and working with diagrams, editing diagrams, and using
the zoom features.

Related Topics:

Using Diagram Elements.

WORKING WITH DIAGRAMS

You can create two different types of diagrams: Business Process Diagrams and Conceptual
Diagrams. In the Business Process Diagram, you can create graphic business process models
based on the Business Process Modeling Notation. When you create a business process
diagram, a pool and a lane with an invisible boundary are automatically created. In the Business
Process Modeling Notation Specification, all business process diagrams must contain at least
one pool and each pool is a container for one process.

In the Conceptual Diagram, you model information about a business as it relates to data, data
flow, process, or information assets.

When you create a diagram, the application opens a new diagram view, which you can use to
arrange the elements and links of your diagram.

You have the following actions available with diagrams: create, open and close, export, delete

Business Process diagrams, delete Conceptual Model diagrams, rename, and print. You can also
have a Diagram Usage dialog that helps you locate an element on multiple diagrams.

Right-click the newly created diagram to gain access to additional functions:

Command Description

Grid Editorr This is a table-like editor which is an alternative to the
Model View. Content in the Grid Editor can be printed
or exported as a report.

Refresh Updates the currently displayed information with new
data or changes.

Properties Opens the Property View for the selected element.

Creating a Diagram

You can create a new diagram at the time you create a workspace or by using the menu
command.

1 Onthe File menu, select New > Diagram. The pull-right menu displays the type of diagram
to be created. For example if you are creating a new diagram in a Conceptual Model, only
Conceptual is available from the pull-right menu.

OR
¢ Right-click the model name in the Model View tree and select New > Diagram.

2 In the New Diagram dialog, enter the diagram name in the Diagram name text box.
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3 You can enter a description of the new diagram in the Description text box. Press Enter to
add a CRLF in the text box.

NOTE: If you press Ctrl+Enter the New Diagram dialog closes and the new diagram name
appears in the Model View tree.

4 You can then select which model to place the diagram in from the models appearing in the
list box.

NOTE: If you are creating a Business Process diagram, when you entered the diagram name
in the Diagram Name text box, the Pool Name and Lane Name text boxes were
populated with the same name. You can rename both the pool and the lane.

If you are creating a Conceptual model, this option is not available.

5 Press OK to close the dialog. The new diagram appears in the Model View tree and a
tabbed view opens in the Diagram View.

Opening and Closing Diagrams

You can open and close diagrams to better manage system resources. When you open a project,
all its diagrams remain closed. You can only work with a diagram and its elements when it is
open.

Opening Diagrams

Do one of the following options to open a diagram:
In the Model View tree, right-click the diagram node and click Open.
OR
In the Model View tree, double-click the diagram.
OR

In the Model View tree, select the diagram you want to open and press Enter.

Closing Diagrams

The following describe the various ways used to close diagrams.

e Closing a Single Diagram

e Closing Other Diagrams

e Closing All Diagrams
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Closing a Single Diagram

To close any single diagram, do one of the following:

In the Model View tree, right-click the diagram node, and then click Close. The diagram is
closed and automatically saved.

OR

On the Diagram window, right-click the Diagram View tab, and then click Close. A Save
Resources dialog opens asking you if you want to save the changes. Click Yes and the
diagram closes.

OR

Click the #z in the Diagram View tab for the opened diagram. A Save Resources dialog
opens asking you if you want to save the changes. Click Yes and the diagram closes.

Closing Other Diagrams

You can close all the opened diagrams except the active one.

1
2

Right-click the Diagram View tab of the active diagram.

Click Close Others from the menu. If the other diagrams you are closing have been
modified a Save Resources dialog opens asking you if you want to save the changes. Click
Yes and all the ‘diagrams close with the modifications saved.

Closing All Diagrams

1
2

To close all open diagrams, right-click any Diagram View tab, and then click Close All.

If any of the diagrams you are closing have been modified a Save Resources dialog opens
asking you if you want to save the changes. Click Yes and all the other diagrams close with
the modifications saved.

Exporting Diagrams

You can export both Business Process and Conceptual diagrams in three different formats: rtf,
pdf, and jpg. You can also export a Conceptual diagram to ER/Studio. Take the following steps
to export a diagram:

1
2

Open the diagram you want to export in the Model View tree.

Once the diagram is opened, right-click the diagram node in the Model View tree and select
Export....

OR

From the main menu, select File > Export > Diagram....

In the Export dialog, select the directory where you want to save the exported diagram,
enter the file name, and select the type of file (jpg, rtf, or pdf).
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4 Click Save and the exported file is saved in the selected file format. You can then open the
exported file it in the appropriate application.

Deleting Business Process Diagrams

You can permanently delete any Business Process diagram listed in the Model View tree. To
delete a diagram, do the following:

In the Model View tree, right-click the diagram, and then click Delete. If it is a Business
Process diagram, it is associated with a pool having an invisible boundary which can also be
deleted. So, in the Delete Diagram with Associated Pool dialog you are given two
options:.

Do you want to delete the associated | Click Yes the diagram, and all

pool, along with the elements it associated pools and lanes are
contains? deleted.

Do you want to delete only the Click No. When this option is selected
diagram? the invisible pool, its associated lane,

and all elements in the lane are still in
the Model View tree.

NOTE: You can undo the deletion by clicking Undo Delete Elements from the Edit menu. The
diagram and all associated elements are restored in the Model View tree.

Deleting Conceptual Model Diagrams

You can permanently delete any Conceptual Model diagram listed in the Model View tree. To
delete a diagram, do the following:

1 Right-click the diagram node in the Model View tree and select Delete.

OR

Select the diagram node you want to delete in the Model View tree and click § on the
toolbar.

OR

Select the diagram node you want to delete in the Model View tree and click the Delete
key.

2 The Delete Items dialog box opens. Clicking Yes completely removes the selected diagram
from the workspace.

NOTE: You can undo the deletion by clicking Undo Delete Elements from the Edit menu. The
diagram and all associated elements are restored in the Model View tree.
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Renaming Diagrams

You can rename a diagram in the Model View tree.

1 Inthe Model View tree, right-click the diagram node you want to rename and select Rename
Diagram. If your diagram is unsaved, a warning dialog opens asking if you want to continue
with the renaming process.

2 Click Yes and the Rename Diagram dialog opens.

3 Enter the new name in the text box and click OK. The diagram is renamed in the Model View
tree.

Printing Diagrams

You can print the diagram you have created using ER/Studio BA. You can also save the print
settings for the opened diagram. To open the Print dialog:

1 Open the diagram you want to print in the Diagram View.

Click =53 on the main menu.

OR

On the main menu, click File > Print.

OR
Press Ctrl+P. The Print dialog opens.

The following settings are available:

Setting Description

Printer... When you click the Printer button the Print dialog opens
where you can select the Printer you want to use.

Preferences In this dialog, you can select the printer, set a page
range, and set the number of copies you want to print.

Note: Once you set your print options in this dialog,
click Print to close this dialog. However, the diagram
does not print until you click the OK button in the first

Print dialog.

Scale

Actual Size The page is printed as is with no zoom.

Fit Page All element in the diagram are reduced to fit on one
page.

Custom You can set the percentage of the page you want

printed. As you change the percentage in the combo
box, notice that the information in the preview pane
changes. As you increase the percentage a grid appears
in the preview pane indicating where the page divisions

appear.
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Setting Description
Margins
Inches Sets the margins for the page. As you increase the size
of the margin, notice that the preview pane shows
where the page divisions appear based on the margin
size.
Note: The value you enter for the margin must contain
the decimal separator. For example if you want one inch
margins, you must enter 1.0, not 1.
Margins (inches)
Left: 1.0 — Correct entry
Right: 1o
Top: l = Incorrect entry
Bottom: | 1 —
Copies
Number of Copies Select the number of copies you want printed of the
selected diagram.
Collate Multiple copies are printed in order.
Options
Center to Page Centers the diagram in the center of the printed page.
Print Page Numbers A page number is placed on each page as it is printed.
Print Border When you select this option a border is placed around
the printed diagram. You can set the width of this
border.
Width When you select the Print Border option, you can then
set the width of the border.

2 After you make any changes to the print options, click OK. The diagram is printed and any
changes you made to the print options are saved with the diagram.

NOTE: Click Save Settings if you make print option changes and want to save these options
without printing the diagram.

Using the Diagram Usage Dialog

The Diagram Usage dialog helps you quickly locate elements on one or more diagrams. There
are two different ways of using this dialog:

® \When you right-click on an element in the Model View, a pull-right menu lists the diagram(s).
This allows you to quickly locate and open the diagram where the element appears. If the
element appears on more then ten diagrams the More... option appears, opening a dialog
listing all the diagrams.
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e Right-click on an element in the Search Results View and select Find In > All Diagrams. The
Diagram Usage dialog opens where you can select and open a diagram from those listed.

You can also click = on the Search Results toolbar.

EDIT DIAGRAMS

When you select Diagram on the main menu, you gain access to four commands that help you
edit diagrams:

e Case Shift
e Grid
® layout

e Connections

Case Shift

You can set the case format for all element labels. When you make a selection, all labels in the
diagram conform to the new selection. You have three options:

Command Description
Lower Case All text appears in lower case lettering,
including the initial letter of the label.
Preserve Case All text appears as it was entered for
the label.
Upper Case All text appears in upper case lettering.
Grid

Rather than guessing at the alignment of your elements, you can use the lines of the grid as a
guide. The grid, which you can turn on or off, is a network of lines that covers your diagram. The
Snap Objects to Grid command is a toggle command that you can turn on or off as well.

Command Description

Show Grid Lines Select this command and grid lines appear in
the diagram. You can change the preferences
so that the appearance of grid lines is the
default setting for the application.

The grid also displays in a pool, sub-process, or
subject area. You can change the preferences
for this so the grid lines don't display.

Show Parent Objects as When a parent object such as a pool, lane, or
Transparent subject area is placed on a diagram, the grid
lines appear in the object. You can change the
preferences to make it the default setting.
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Command

Description

Snap Objects to Grid

Changes the default setting so that when an
element is moved, it snaps to the nearest
grid.This feature is active whether the grid lines
are showing or not.

You can change the preferences so that the
snap to grid action is the default setting for the
application.

Layout

When you change this setting you get a Change Diagram Layout dialog warning you that this
selection overrides any changes you have made to individual relationships. For example, if the
setting was elbowed when you created your diagram and you then change to straight, all

connections are changed to the selected layout style.

Command Description

Elbowed All connections are drawn with ninety degree
bends in the line. This is the default setting.

Straight All connections are drawn as the shortest
distance between the two elements you are
connecting.

Connections

Once you have created a link in the Diagram View, select this command to show or hide the links

for all the object in the diagram.

USING ZOOM IN DIAGRAMS

You can change the scale of any diagram displayed in a Diagram View. The application offers

several zooming features which are described in the following table:

Feature

Description

Preset Percentages

You can enlarge or reduce a diagram using a present percentage.

Note: You also have the option of setting a Custom on the Standard
Toolbar.

Custom Zooming

Custom zoom into and out of any Diagram window by specifying a
zoom percentage on the Formatting toolbar. When you use the
custom zoom feature, you type a specific zoom percentage, or select
a preset percentage from the custom zoom drop-down list. The
higher the specified percentage value, the closer the zoom.

Zooming In and Out

Incrementally zoom into and out of any Diagram window, enlarging or
reducing the size of your diagram gradually with the click of a button.
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Feature Description
Fit to Page Reduces the size of all elements in the Diagram View so that the

entire diagram fits on one page.

TIP: ER/Studio BA also offers an Overview Window, where you can zoom into and out of
specific parts of any Diagram window from a single, unscalable window.

Preset Percentages

To enlarge or reduce a diagram using a preset percentage, do the following:

1 On the View menu, click Zoom Level.

2 From the pull-right menu, select the percentage amount that you want to enlarge or reduce
your diagram. The available percentages are: 25, 50, 75, 100, 200, and 400.

Custom Zooming

You can gain access to the Custom Zoom feature three different ways:
On the View menu, click Zoom Level > Custom to open the Zoom Level dialog.

OR

On the Standard toolbar, click the Custom Zoom box (| 100%  =|). In the Custom Zoom
box, do one of the following:

* Type a zoom percentage value.
OR

e Select a preset zoom value from the list to display the diagram at the specified zoom
percentage.

TIP:  The custom zoom drop-down list also offers the option to Fit to Page.

Zooming In and Out

To zoom in (enlarge the diagram), do one of the following:

On the Standard toolbar, click @, .

OR

In the Diagram View, right-click, and then click Zoom In.
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To zoom out (reduce the diagram), do one of the following:

On the Standard toolbar, click =, .

OR

In the Diagram View window, right-click, and then click Zoom Out to redraw the diagram
according to the zoom size specified.

Fit to Page

Fit to Page reduces or enlarges the diagram so all elements appear in the visible view area of the
diagram.

On the View menu, click Zoom Level > Fit to Page.

OR
On the Standard toolbar, click the drop-down arrow in the Custom Zoom box | 100%
and click Fit to Page.

All elements in the Diagram View are reduced or enlarged so the entire diagram now fits on
one page.

USING DIAGRAM ELEMENTS

The table below describes the different functions available when working with the diagram
elements in ER/Studio BA.

Diagram Element Function | Description

Create New Elements Explains how to create and place elements in the diagram
from both the Model View and the palette.

Label Diagram Elements Explains how to label elements placed in a diagram. You can
also edit those labels.

Edit Diagram Elements Explains how to cut, copy, paste, select all diagram elements,
select all similar diagram elements, delete elements, and
change the diagram element size.

Format Diagram Elements You can format an individual element or a group of elements
using the Formatting toolbar.

Right-click an element in the Model View tree to gain access to the following functions:
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Command

Icon

Description

Z
)
=

You can create new elements from a
lane node in a Business Process
diagram, and from a Subject Area or
Business Entity in a Conceptual Model
diagram.

Rename

You can rename elements two different
ways.

Delete

There are several different ways to
delete elements.

Create Mapping

This command is only available for a
Subject Area element in a Conceptual
Model. You can map a Subject Area to
one or more Conceptual Model
diagrams.

Diagram Mapping

This command is available if you have
mapped a Subject Area to a
Conceptual Model. Click this
command and a pull-right displays the
name of the diagram the Subject Area
is mapped to.

Grid Editor

il

This is a table-like editor which is an
alternative to the Model View. Content
in the Grid Editor can be printed or
exported as a report.

c
=]
A
(2]

(E]

This command opens the Create Link
wizard which allows you to create links
between elements.

Usages

This command opens the Create
Usage wizard which allows you to
create usage connections between
elements.

Impact Analysis

o
v |

You have two commands available
from the pull-right menu:

You can generate an Impact Analysis
Diagram which graphically displays all
the associated relationships and
elements.

You can also show the Impact Analysis
Report.

Refresh

Updates the currently displayed
information with new data or changes.

Properties

Opens the Property View for the
selected element.
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CREATE NEW ELEMENTS

ER/Studio BA offers two methods for creating new elements in the Diagram View: from the
palette, and from the Model View tree. How you create elements in the Model View tree depend
on whether you are working the Business Process Models or Conceptual Models. You can also

create multiple existing elements from the Model View.

Creating New Elements from the Palette

To create any type of element in the Diagram View, do the following:
1 On the Palette, click the element icon you want to use.

2 In the Diagram View, click a location in the view to place the element.

NOTE: The cursor is in the multi-drop mode [FE‘_‘I so you can place as many elements as you

need. Press ESC to exit the multi-drop mode. The cursor changes from [SE‘_‘I to [¥. You
can also set a preferences to disable the multi-drop mode globally.

Creating New Elements in the Model View for a Business Process Model

You can create a new element in the Model View tree from the lane node. Once you have
created the element, you can drag the element onto an open diagram in the Diagram View.

To create any type of element in the Diagram drawing area, do the following:
1 In the Model View tree, right-click the lane node where you want to place the new element.
NOTE: You can also create a new lane from the Pool node.
2 Select New and click the element you want created from the pull-right menu. The selected
element is placed in the lane node.

You can then drag the elements that are not nested onto an open diagram.

Creating New Elements in the Model View for a Conceptual Model

You can create a new element in the Model View tree from several different nodes. Once you
have created the element, you can drag the element onto an open diagram in the Diagram
View.
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To create any type of element in the Diagram drawing area, do the following:

1 To create a specific element:

® For a Business Entity or Subject Area element for a model, right-click the model node
where you want to place the new element.

® For a new Subject Area to be nested in an existing Subject Area, right-click the Subject
Area node where you want to nest the new element.

® For a Business Attribute, right-click the Business Entity where you want the new attribute
to reside.

® For a new Business Entity to be nested in an existing Business Entity, right-click the
Business Entity node where you want to nest the new element.

2 Select New and click the element you want created from the pull-right menu. The selected
element is placed in the lane node.

3 You can then drag the elements that are not nested onto an open diagram.

Creating Multiple Existing Elements from the Model View

To place multiple diagram elements listed in the Model View tree on the Diagram View, do the
following:

1 On the Model View, click the first element.
2 Press CTRL and click all remaining elements.

3 Drag the elements on the Diagram View and the elements are placed in the Diagram
window. The application displays any links shared between elements.

LABEL DIAGRAM ELEMENTS

When you label the elements in a diagram you can use autotype feature for quick and easy
labeling. You can also edit existing labels.

Using the Autotype Feature

Once you have placed an element on a diagram you can use the autotype feature to label it.
This feature enables you to start typing immediately in a text box that opens automatically.

The autotype feature has the following functions:

e Asyou enter text, it autowraps in the text box.

® You can use returns in the text box by pressing Ctrl+Enter. As you enter text, the text box
continues to expand downward.

e The autotype text box is closed by clicking the mouse button in the diagram or by pressing
Enter.
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Editing Existing Labels

You can edit existing labels for elements three ways:

e Ifitis a label outside the element, for example a start event, select the element you want to
edit in the Diagram View and then click the label. An editable text box opens allowing you
to change or replace the existing label.

e If the element itself is labeled, for example a task, select the element and just start entering
text. It automatically goes into the autotype mode.

¢ Double-click the element and the Property View opens. You can change the label in the
Name text box.

e Right-click an element in the Model View tree and select Rename from the context menu.

The new label appears on the selected element and in the Model View tree.

EDIT DIAGRAM ELEMENTS
Once you place a diagram element, you edit them in the following ways:

e Renaming Elements

Deleting Elements

Cutting Elements

Copying Elements

Pasting Elements

Selecting all Elements

® Selecting all Similar Elements
e Grouping Elements

e Changing Diagram Element Size

Renaming Elements

You have two different ways of renaming an element in the Model View tree:
Right-click the element node and select Rename.

OR

Select the element and press F2. The element node name becomes editable.
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Deleting Elements

You can delete elements from the Model View tree and the Diagram View area. When you

delete elements you have different options presented to you in the Delete Element dialog
depending on whether you are deleting the element from the Model View tree or from the
Diagram View. The table lists the options available:

Location Description

Remove This command is available when you delete the element from the
diagram only. The element and its associated metadata remain in
the project to be used by this or other diagrams (the remove
command affects the display only).

Delete This action permanently removes the element from the project,
including the visual display on the diagram, the element itself, and
its associated metadata.

Note: Because this delete action may include other diagrams
sharing this element, click @ in the Delete Items dialog to list all
the diagrams that are affected by this deletion. You can set a
preference to turn this listing option off.

View diagrams on which | When you click @ in the Delete Element dialog, a window opens
the elements appear. displaying the diagram where the element resides as well as its
connecting elements.

Cancel No action is taken and the element remains in the project and on
the diagram. The Delete Element dialog is closed.

NOTE: ER/Studio BA does not place deleted elements on the clipboard for future pasting.
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Deleting Elements from the Model View Tree

Do one of the following options to delete elements:

1 In the Model View tree, select the diagram element.

® From the main menu, select Edit and then click Delete.

OR
¢ Right-click the element and click Delete.

The Delete Elements dialog opens.

& Delete Elements E|

¥au have chosen ko delete the selected elements,

Click Rerove ko disassociabe the elerments Fram this diagram wigw ar
click Delete ko completely remove the elements From the waorkspace,

+ Click here to see the diagrams on which the elements appear,

)] [ Remove H Delete ” Cancel

2 Click @ to view all the diagrams on which the element(s) appear.

 Delete Elements

!

You have chosen ko delete the selected elements,

Click Remove to disassociate the elerments from this diagram view or
click. Delete ko completely remove the elements from the workspace.

=| Click here to see the diagrams on which the elements appear.

= [ Entity
diag
kest
7 [ Remove l [ Delete ] [ Cancel

3 Click Yes to delete the selected element from the Model View tree.
NOTE: If you delete an element that resides on both the Model View tree and the diagram,

and the diagram isn’t open, when you open the diagram the deleted element no
longer appears in the diagram.
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Deleting Elements from the Diagram View

Do one of the following options to delete elements:
1 In the Diagram View, select the diagram element.
e On the Standard toolbar click 3¢ .
OR

e Right-click the element, and, under Edit, click Delete.

The Delete Elements dialog opens.

& Delete Elements E|

Y¥ou have chosen to delete the selected elements,

Click Remowe to disassociate the elements From this diagram wiew or
click Delete ko completely remove the elements From the workspace,

+ Click here to see the diagrams on which the elements appear,

L2 [ Femave H Delete H Cancel

NOTE: The default preference setting is to display a list of the other diagrams that are using

this element in the Delete Element dialog. When you click # in the Delete Element
dialog a window opens displaying the diagram where the element resides as well as its

connecting elements. You can change this preference so this list no longer appears in
the Delete Elements dialog.

2 Click @ to view all the diagrams on which the element(s) appear.

% Delete Elements @

¥ou have chosen to delete the selected elements,

Click Remowe to disassociate the elements From this diagram wiew or
click Delete ko campletely remove the elements From the warkspace,

= Click here to see the diagrams on which the elements appear,
= [ Entity
diag
kest

)] [ Remove H Delete ” Cancel
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3 Click one of three choices:

® Remove: Disassociates the element from the Diagram View.
® Delete: Completely removes the element from the workspace.

e Cancel: Cancels the actions and the element is not deleted.

Cutting Elements

You can cut most elements displayed in the Diagram View. When you cut an element, the
application removes it from the window and places it on a clipboard. You can then paste the cut
element in the same Diagram window, or in a different Diagram window in the same workspace,
or in selected third-party applications like Microsoft Word®©. The cut item remains on the
clipboard until you cut or copy another selection.

NOTE: You cannot cut a lane within a pool.

To cut a selected element
e Right-click the element and select Edit > Cut.
OR

e Select the element and select Edit > Cut from the main menu.

OR

e Select the element and press Ctrl+X.
OR

e Select the element and click 2 on the Standard toolbar.

ER/Studio BA removes the element from the Diagram window, placing it on a clipboard for
pasting.

Copying Elements

You can copy most elements displayed in a Diagram View. When you copy an element, the
application leaves the original on the diagram and places a copy of it on a clipboard.

NOTE: You cannot copy a lane within a pool.

You can then paste the copied element in the same Diagram window, or in a different Diagram
window in the same workspace, or in selected third-party applications like Microsoft Word® or
Microsoft Visio®. The copied item remains on the clipboard until you cut or copy another
selection.

NOTE: ER/Studio BA fully utilizes Window's copy buffer, letting you copy elements from any
model for placement in Microsoft applications. Because the application automatically
pastes copied graphics into third-party applications, you do not need to export images
from ER/Studio BA for import into these applications.
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To copy an element

e Right-click the element and select Edit > Copy.

OR

e Select the element and select Edit > Copy from the main menu.
OR

e Select the element and press CTRL+C.

OR

e Select the element and click = on the Standard toolbar.

ER/Studio BA copies the element, placing the duplicate on a clipboard for pasting.

Pasting Elements
You can paste any cut or copied element into the following:

e same diagram
e different diagram in the same workspace

e different diagram in a different workspace

e external document such as Microsoft® Word.

NOTE: Pasting to an external application is done using the .jpg format so the image only
appears in applications that supports the .jpg format.

When you cut or copy an element, the application places it on a clipboard for you to paste. The
copied item remains on the clipboard until you cut or copy another selection. You can paste a
symbol from the clipboard as many times as you want.

TIP:  Cut or copied elements cannot be pasted into different model types. For example if
you copied a Start Event from a Business Process model diagram, you cannot paste
that event onto a Conceptual Model diagram.

NOTE: When you cut or copy an element in a diagram, when it is pasted to an external
application, it is done using the .jpg format. Therefor the image will only appear in
applications that can handle the jpg format.
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To paste an element

Right-click the background of the destination window, and then select Edit > Paste.
OR
On the Standard toolbar, click [Z .

OR

From the main menu, select Edit > Paste.

OR
Press CTR+V.

Selecting all Elements

You can select all elements in a Diagram View. When you select a single element (by clicking the
element), ER/Studio BA displays handles around the selected graphic. Likewise, when you select
all elements, the application displays handles around every element in the window, letting you
cut, copy, delete, or otherwise work with all elements at once.

To select all elements in a Diagram View
On main menu select Edit > Select All.
OR
Press CTRL+A.

OR
Right-click an element in the diagram and select Edit > Select All.

Selecting all Similar Elements

You can select all elements or links of a given type in the Diagram View. When you select a single
element or link (by clicking it), ER/Studio BA displays handles around the selected graphic.
Likewise, when you select all similar elements or links, the application displays handles around
every element or link of the same type in the window, letting you cut, copy, delete, or otherwise
work with them all at once. For example, when you click a task in a diagram, and then click Select
All Similar Elements, ER/Studio BA selects all other tasks in the Diagram View.

To select all similar elements in a Diagram window
Select the element, and on the main menu select Edit > Select All Similar Elements.

OR
Select the element and press Ctrl+Shift+A.
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Grouping Elements

This feature provides the ability to group elements together into a single entity that can be
moved around a diagram in the Diagram View. Once items are grouped, a bounding box
appears around the group items. They move together in a block and are essentially “locked”
together, movement-wise. The Ungroup feature removes the grouping and allows the elements
to be moved separately again.

The Group/Ungroup command is available on the Format main menu, the Alignment and Layout
Toolbar, and on the shortcut menus of all elements (except the connecting elements). You can
also use Ctrl+Shift+G to group and Ctrl+Shift+U to ungroup.

The following rules and constraints apply to the Grouping functionality:

The Group command is only available if more than one item selected.
The Ungroup command is only available if the item selected is in a group.

If you select both the source and target elements, the connecting flow is also selected. If you
select just one of the ends, the flow is not selected. However, when you move the grouped
elements, the connecting flow remains connected to both the source and target and adjusts
to the move accordingly.

When doing a Copy and Paste, all grouped objects are copied and they are grouped
together upon paste.

The grouping is removed if only one presentation element remains in a group.

To Group Elements:

1

Select the elements you want to group by clicking and dragging a box around the select
items. You can also select each item by holding down the left mouse button and clicking on
each element in the diagram.

Right-click in any of the selected elements and click Grouping>Group. A bounding box
appears around the selected elements.

Place the cursor on the bounding box and the cursor changes to the move cursor (4%»).

Hold down the left mouse button and move the grouped items in the diagram.

NOTE: You can move elements within the group box. Click on the element you want to move
and handles appear around the element. You can then move the selected element
within the box. Note that the box stays in the same location.

Changing Diagram Element Size

You can change the size of any element in a Diagram window.

1

To change the size of an element, in the element’s Diagram view, click the element.

2 Drag the element handles to change its size.

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 191



USING ER/STUDIO BUSINESS ARCHITECT > DIAGRAMS AND ELEMENTS

FORMAT DIAGRAM ELEMENTS
You can format an individual element or a group of elements using the Formatting toolbar.

Airial vie v B I S UA- @ &~ ==

NOTE: You can also set global formatting preferences for both the Business Process Modeling
and Conceptual elements by selecting Windows > Preferences. For more information,

see Formatting.

Font and Color Options

You can change the font style, font size, font colors, and the fill and line colors of a selected
element in the Colors and Fonts portion of the Formatting dialog.

To change a selected font, select a font from the drop-down menu in the Font text box. You can
also change the font size by selecting a size from the drop-down menu in the size text box. You
can edit the font settings of all element labels. The following toolbar commands are available:

Command Icon Description

Bold R Applies bold formatting to the label
text.

Italics I Italicizes the label text.

Strikeout 5 A line is drawn through the label text.

Underline u Underlines the label text.
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Command Icon Description

Change Font A Click the drop-down arrow to select an

Color — existing color or click “Other” to open
the Color dialog where you can create
a custom color for the color of the label
font.

Change Line i - Click the drop-down arrow to select an

Color g existing color or click “Other” to open
the Color dialog where you can create
a custom color for the border of the
element.

Change Fill % . Click the drop-down arrow to select an

Color existing color or click "Other” to open

the Color dialog where you can create
a custom color for the background of
the element.

following commands

Justification

You can change the justification settings for the text label in an element.

These commands do not justify the text labels on elements that use text boxes outside

NOTE:
the element.
Command Icon Description
Left Justify Justifies the text on the left side of the

Text

text box.

Center Text

Centers the text in the text box.

Right Justify = Justifies the text on the right side of
Text - the text box.
Font Size

You can incrementally increase or decrease the text size of a selected element in the diagram.

Command Icon Description

Increase Font A Each time you click this icon, the font

Size of the selected label increases by one
point size.

Decrease Font - Each time you click this icon, the font

Size A of the selected label decreases by one
point size.
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REFERENCE OBJECTS

When you create a new workspace, reference objects are automatically created as well. You can
create new reference objects three different ways: (1) in the Model View; (2) by using the
Reference Objects Palette; or (3) by using the Reference Objects Toolbar.

The table below lists the reference objects created when you create a new workspace:

Reference Object Icon Definition

External Data Objects @ You can import or create new external data
objects and then link those objects to business
processes and tasks.

Business Element @ Elements are often used by business users to

document their list of “terms and/or definitions”.
While from a business user’s point-of-view, this
may be no more than a list of terms, they can be
used by a modeler to seed attributes of
semantically-rich models. An element can be
bound to different business attributes across
conceptual models to enforce naming and
definition standards. It is the The business
element allows an organization to achieve a
common meaning and lineage around core
business concepts such as “customer”, “customer
identifier”, “trade”, etc.

Business Rule % A business rule is a policy, practice, or formula
related to the operation and enforcement of
business practices.

Business Unit DE A business unit is an organizational area within or
external to an enterprise.

Domains [[E A reusable attribute template that promotes

consistent domain definitions. You construct
domains as you would attributes, specifying a
name, datatype properties, null status, default
values and validation rules.

Stewards % A steward is a person or organization responsible
to, or associated with a model element.

Link & This link displays high-level views of information
requirements. This type is used to simply relate
objects together.

Usage u When you select this option you create a link that
- enables you to designate a usage type: create,
read, update, or delete database records. The link
you create is labeled “usage”
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Creating Reference Object in the Model View

1 Right-click a reference object in the Model View tree and select New. The command that
appears depends on the reference object clicked. For example, if you right-click on Business
Rules, the command will be New Business Rule.

NOTE: If you right-click on External Data Objects and click New, a pull-right menu opens
listing all available data objects.

2 The newly created reference object appears nested below the selected object in the Model
View tree.

NOTE: Once you create the reference object, you can then drag that object onto the Diagram
View. A representative icon is placed in the diagram. You can then link these objects
to processes and tasks in the diagram.

=- [} Reference Objects
+ ? External Data Objects
&P Business Elements

% Business Rule
Business Uniks
% Stewards

3 Right-click the newly created object to gain access to the following functions:

Command Icon Description

Rename When you select this command or
press F2, the text label for the object
can be edited.

Delete % When this command is selected, the
Delete Elements dialog opens asking
you to confirm the delete action.

C
=]
A~
(2]

This command opens the Create Link
wizard which allows you to create links
between elements.

(E]

Usages u This command opens the Create
Usage wizard which allows you to
create usage connections between
elements.

You have two commands available
from the pull-right menu:

Impact Analysis

You can generate an Impact Analysis
Diagram which graphically displays all
the associated relationships and
elements.

You can also show the Impact Analysis
Report.

Refresh Updates the currently displayed
L] information with new data or changes.
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Command Icon Description

Properties Opens the Property View for the

selected reference object.

Creating a Reference Object using the Reference Objects Palette

1 Expand the Reference Objects portion of the Palette and select the reference object you
want in your diagram.

2 Click once in the Diagram View and the object is placed in both the Model View tree and the
diagram.

NOTE: The cursor is in the multi-drop mode [%EI so you can place as many elements as you

need. Press ESC to exit the multi-drop mode. The cursor changes from [% to &.

3 Right-click the newly created object to gain access to the following functions:

Command Icon Description

Connections Once you have created a link, select
this command to show or hide all the
links on the diagram.

Edit The available commands are: cut, copy,
delete, or select all.

C
=]
A~
(2]

This command opens the Create Link
wizard which allows you to create links
between elements.

(%]

Usages u This command opens the Create
Usage wizard which allows you to
create usage connections between
elements.

Impact Analysis Ex You have two commands available
- from the pull-right menu:

You can generate an Impact Analysis
Diagram which graphically displays all
the associated relationships and
elements.

You can also show the Impact Analysis
Report.

Creating as Pool This command is available only for the
business Units and Stewards reference
objects. This command creates a pool
that is semantically linked to either a
Business Unit or Steward.

Detaching from This command is available only for the
Pool business Units and Stewards reference
objects. This command deletes the link
between the reference object and the
pool.
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Command Icon Description

Properties Opens the Property View for the
selected reference object.

Creating a Reference Object using the Toolbar
1 Click the Reference Object you want to place in the Diagram View from the toolbar.

NOTE: If this toolbar is available, select View > Toolbars > Reference Objects from the main
menu.

2 Click once in the Diagram View to place the object.

Note that the object you just placed also appears in the Model View tree under the
appropriate Reference Object node. For example, if you placed a Business Rule object in
the diagram, a new Business Rule node appears under the main Business Rules node.

USING BUSINESS ELEMENTS

Business Elements are often used by business users to document their list of “terms and/or
definitions”. While from a business user’s point-of-view, this may be no more than a list of terms,
they can be used by a modeler to seed attributes of semantically-rich models. A “business
element” can be bound to different business attributes across conceptual models to enforce
naming and definition standards. An organization can achieve a common meaning and lineage

around core business concepts such as “customer”, “customer identifier”, “trade”, etc. by using
the business element concept.

In Conceptual Modeling, a business element can be used like a domain is used at the logical
level. Business Elements can be “bound” to business attributes to seed a conceptual model and

enforce standards.

USING BUSINESS RULES

A business rule is a policy, practice, or formula related to the operation and enforcement of
business practices. You can create a new business rule in the Reference Objects node:

1 Right-click on the Business Rules node in the Model View tree and select New. The
command that appears depends on the reference object clicked. So when you right-click on
Business Rules, the command will be New Business Rule.

The newly created reference object appears nested below the selected object in the Model
View tree. When you right-click the newly created object you gain access to a shortcut menu
where you can rename or delete the Business Rule. You can also view the Impact Analysis
Report. You can create a link, and open the Property View for the selected business rule.
You can also double-click an object to open the Property View.

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 197



USING ER/STUDIO BUSINESS ARCHITECT > REFERENCE OBJECTS

2 Once you create the reference object, you can then drag that object onto the Diagram View.
A representative icon is placed in the diagram. You can then link these objects to processes
and tasks.

USING BUSINESS UNITS

A business unit is an organizational area within or external to an enterprise, for example, Human
Resources, Sales, Accounting, etc. You can create a new business unit in the Reference Objects
node. You can create a pool from a Business Unit or detach a pool from a Business Unit.

Creating a New Business Unit

1 Right-click on the Business Units node in the Model View tree and select New. The
command that appears depends on the reference object clicked. So when you right-click on
Business Units, the command will be New Business Unit.

The newly created reference object appears nested below the selected object in the Model
View tree. When you right-click the newly created object you gain access to a shortcut menu
where you can rename or delete the Business Unit. You can also view the Impact Analysis Report.
You can create a link, and open the Property View for the selected business unit. You can also
double-click an object to open the Property View.

2 Once you create the reference object, you can then drag that object onto the Diagram View.
A representative icon is placed in the diagram. You can then link these objects to processes
and tasks.

Creating as Pool

Conceptually a pool represents the participant in a process - the “who” of the action. Since a list
of Business Units and Stewards is maintained in the Reference Objects, which also represent the
“who", you can semantically link the two objects. For example, you can keep track of the
business units in your organization in the Reference Objects, for example Sales, Documentation,
Engineering, etc. You then want to show the process that Documentation goes through to get
ready for a software release.

Rather than create a new pool called “Documentation”, it's better to use the existing object to
semantically link them so that we understand that it's the same business unit we're talking about.
This avoids redundancy because you can define it once and use it multiple times. Because the
two objects are “bound” if you change the name of the business unit/steward you also change
the name of the pool.
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Detaching from Pool

Once you have created a Business Unit or Steward as a pool you can eliminate the relationship
between the reference object and the pool.

Right-click the reference object either in the Model View tree or in the diagram and select
Detach from Pool. The link is deleted between the reference object and the pool. Any
changes you make to the reference object are no longer propagated to the pool. However
both the reference object and the pool remain on the diagram.

USING DOMAINS

Domains are reusable attribute templates that promote consistent domain definitions. You
construct domains as you would attributes, specifying a name, datatype properties, null status,
default values, and validation rules. After creating domains, you can re-use them in your data
model by applying them to attributes and table columns.

For more information see

¢ Dragging and Dropping Domains on Business Entities

¢ Importing ER/Studio Data Architect Domains as ER/Studio BA Domains

By defining a Domain, you can then propagate changes to the underlying domain definition to
all attributes and table columns that reference it.

NOTE: Domains are not visualized on diagrams so the Domain element icon is not available
on the Reference Object’s toolbar or palette.

One important method for enforcing business rules is to define and to apply domain restrictions.
Domain integrity refers to the rules governing what values an attribute can take. By restricting
and validating an attribute's values, you can implement important business rules such as
ensuring that a checking account maintains a positive balance, or preventing the entry of invalid
phone numbers.

Dragging and Dropping Domains on Business Entities

Dragging/dropping of Domains to Business Entities are allowed. A Business Attribute is created
using the domain name if an attribute with that name doesn't already exist. If an attribute with
that name already exists, a unique name is assigned to the attribute.

Importing ER/Studio Data Architect Domains as ER/Studio BA Domains
e The ER/Studio DA domain data type will be created as the ER/Studio BA domain’s data
type.

® The ER/Studio DA width will be created as the ER/Studio BA domain’s width.
e The ER/Studio DAscale will be created as the ER/Studio BA domain’s scale.

e The ER/Studio DA "allow nulls” property will be created as the ER/Studio BA domain’s
"Optionality” property. Allow nulls is equivalent to ‘optional’.
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¢ The enforcement options on the domains will be set from the “allow override” options of
the ER/Studio DA domain.

e The business attributes will be bound to the domains as per the ER/Studio DA model.

¢ Since domains do not enforce description/notes from the domains, the descriptions and
notes will be set on the business attribute, but there is no enforcement from that point on.
Same for attribute names.

Importing ER/Studio Domains as Business Elements Referencing Domains

® The domain's name will be created as both the business element’s name and the ER/Studio
BA domain’s name. The “enforce name” option will be cleared on the business element (i.e.
not enforced).

e The domain’s description will be created as the business element’s description.
e The domain’s notes will be created as the business element’s notes.

e The domain’s data type will be created as the ER/Studio BA domain’s data type.
® The ER/Studio DA width will be created as the ER/Studio BA domain’s width.

e The ER/Studio DA scale will be created as the ER/Studio BA domain’s scale.

e The ER/Studio DA "allow nulls” property will be created as the ER/Studio BA domain
"Optionality” property.

® The enforcement options on the domains will be set from the “allow override” options of
the ER/Studio DA domain.

e The business element will point to the domain.

e The business attributes will be bound to the business elements as per the ER/Studio DA
model.

USING STEWARDS

A steward is a person or organization responsible for or associated with a model element, for
example: DBA, Auditor, Jeffrey Smith, etc. You can create a new steward in the Reference
Objects node. You can also create a pool from a Steward.

You can create a pool from a Steward or detach a pool from a Steward.
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Creating a New Steward

1 Right-click on the Stewards node in the Model View tree and select New. The command
that appears depends on the reference object clicked. So when you right-click on Steward,
the command will be New Steward.

The newly created reference object appears nested below the selected object in the Model
View tree. When you right-click the newly created object you gain access to a shortcut menu
where you can rename or delete the Steward. You can also view the Impact Analysis Report.
You can create a link, and open the Property View for the selected steward. You can also
double-click an object to open the Property View.

2 Once you create the reference object, you can then drag that object onto the Diagram View.
A representative icon is placed in the diagram. You can then link these objects to processes
and tasks. The example below shows a steward linked to a task via an association.

Process Order

Skeward

Creating as Pool

Conceptually a pool represents the participant in a process - the “who” of the action. Since a list
of Business Units and Stewards is maintained in the Reference Objects, which also represent the
“who", you can semantically link the two objects. For example, you can keep track of the
business units in your organization in the Reference Objects, for example Sales, Documentation,
Engineering, etc. You then want to show the process that Documentation goes through to get
ready for a software release.

Rather than create a new pool called “Documentation”, it's better to use the existing object to
semantically link them so that we understand that it's the same business unit we're talking about.
This avoids redundancy because you can define it once and use it multiple times. Because the
two objects are “bound” if you change the name of the business unit/steward you also change
the name of the pool.
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Detaching from Pool

Once you have created a Business Unit or Steward as a pool you can eliminate the relationship
between the reference object and the pool.

1 Right-click the reference object either in the Model View tree or in the diagram and select
Detach from Pool. The link is deleted between the reference object and the pool. Any
changes you make to the reference object are no longer propagated to the pool. However
both the reference object and the pool remain on the diagram.

EXTERNAL DATA OBJECTS

You can import, export, or create External Data Objects (EDOs). These objects can then be
shown on a diagram. You can use an External Data Object (EDO) in a diagram for reference or
for data flow diagramming. You can then link to EDOs with a specific business process or task.
You can also link the Individual Elements (attributes, columns, and data elements) contained in
these External Data Objects.

There are two different types of EDOs: Logical and Physical. The Logical types are entities and
attributes. The Physical types are tables and views. The table below lists the different types of
EDO:s.

Type ’ Icon | Description

Logical

Data Source Pl

Data Feed Q

Data Store M A data store is a repository for data.
Entity ﬁ Distinguishable objects that can be

represented in a database.

Flat File Aflat file is a file containing records,

one record per line. Fields may have a
fixed width with padding, or delimited
by white space or tabs or commas
(CSV) or other characters. There are no
structural relationships.

Report
Physical
Table A set of data in a database.
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Type Icon Description

View ﬁ

Individual Elements

The Individual Elements only appear on the Impact Analysis Diagrams when they are linked to a
source object. They cannot be displayed on a Business Process or Conceptual Modeling
diagram. Also, these Individual Elements are not available on the External Data Objects Toolbar
or Palette.

The table below lists the individual objects contained in External Data Objects:

Type Icon Description
Attribute II An Attribute is a subset of an Entity
Column ]I An individual column of data within a

Table or View.

An individual piece of data in a Data
Store, Data Feed, Report, or Flat File

Data Element

=l

External Data Objects on a Diagram

Once you have imported or created External Data Objects, these objects can be visualized on a
diagram by dragging the object from the tree to the diagram in the Diagram View, or from the
tree to the diagram node on the tree. Representative icons are then placed in the Diagram View.
Once on the diagram, you can open the Property View for that object.
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Instantiating Data Objects for Reference

You can instantiate an External Data Object on a business process diagram. The following
example shows that the customer data table is used and/or referenced by the Customer Pool
through an association to a table object.

—
=

Customer Data Table

= Ask for i
= or 1ce
E
]
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=
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=
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Instantiating Data Objects for Data Flow Diagramming

You can use combinations of data objects and Business Processing Modeling Objects to create
data flow diagrams. In the following example there is no limitation/validation on how objects are
used (for example, the data object can be either a source or a target for a sequence flow).

Submit Data bo Processing J
’| Process Order

Cuskomer

Linking Business Processes to Data

You can use the create link wizard to associate External Data Objects with other objects and
then view it in an Impact Analysis Diagram. For example, you may want to associate data objects
with specific business processes or tasks.

CREATING EXTERNAL DATA OBJECTS

You can create and define generic External Data Objects to represent a high-level description of
what data is accessed or data for which a model or database structure is not known (for example
external data feeds from a company like JD Edwards). Once you create an external data object,
you can create individual elements as well.

204 ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE



USING ER/STUDIO BUSINESS ARCHITECT > EXTERNAL DATA OBJECTS

To create an external data object:

1

In the Model View, right-click the External Data Objects node in the Reference Objects node
and select New. The pull-right menu lists all the available types that can be created.

Select the type from the list and the selected type is placed in the External Data Object
node. The label, which you can edit, is the type name. You can then drag this object onto the
diagram.

OR

Select the external data object icon from the External Data Objects Palette and click once in
the Diagram View to place it. The object placed in the Diagram View automatically appears
in the Model View tree.

OR

Select the external data object icon from the External Data Objects Toolbar and click once
in the Diagram View to place it. The object placed in the Diagram View automatically
appears in the Model View tree.

You can define all elements of the newly created external data object in the Property View.

Creating Individual Elements

1

In the Model View, right-click the External Data Object you have created. For example, you
can right-click on an Entity EDO and create an Attribute.

From the pull-right menu select the individual element (attributes/columns, or data) you
want to create.

NOTE: You can also create an element from an External Data Object node by pressing insert,
or by pressing insert on an existing individual element.

The individual element appears in the Model View in an editable mode. Rename the
element.

Double-click on the element to open the Property View where you can set or change the
element’s properties.
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DELETING EXTERNAL DATA OBJECTS

You can delete external data objects either from the Model View tree or from the Diagram View.

Deleting Objects from the Model View

1 Right-click the external data object that you want to delete in the External Data Objects
node.

2 Select Delete and the Delete Items dialog opens.

3 Click Yes and the item is removed completely from the workspace.

Deleting Objects from the Diagram View

1 Right-click the external data object that you want to delete in the Diagram View and select
Edit > Delete.

In the Delete Elements dialog you have three choices:

Location Description

Remove This command is available when you delete the element from the
diagram only. The element and its associated metadata remain in
the project to be used by this or other diagrams (the remove
command affects display only).

Delete This action permanently removes the element from the project,
including the visual display on the diagram, the element itself, and
its associated metadata.

Note: Because this delete action may include other diagrams
sharing this element, click # in the Delete Items dialog to list all
the diagrams that are affected by this deletion.

Cancel No action is taken and the element remains in the project and on
the diagram. The Delete Element dialog is closed.

2 Select the option you want and click OK.

DRAWING SHAPES

Drawing Shapes are used to provide additional information about the Process. There are nine_
drawing shapes, one text label, and one line. You can use these shapes to create diagram
objects without the semantic meaning implied by the modeling notations. The drawing shapes
are displayed in the Model View tree. You can rename these shapes in the tree.

Characteristics:

® The size of the shapes can be increased or decreased
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® The line and fill colors can be changed
® The shapes can be labeled

When you right-click the drawing shapes you gain access to a shortcut menu where you can
show the name of the shape, or edit it. You can also view the Impact Analysis Report. You can
create a link, and open the Property View for the selected shape. You can also double-click an
object to open the Property View.

Setting Preferences for Shapes

You can set global preferences for the drawing shapes. The changes you make in this
preferences dialog are then applied to all future elements you place in the Diagram View. For
example, if you change the fill color of an octagon to red, from now on, all octagons you place in
the Diagram View are red.

1 To open the Preferences dialog select Windows > Preferences on the main menu.

2 Expand the Formatting node and select Shapes.
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WORKING WITH ER/STUDIO REPOSITORY

The Repository provides access to workspaces for one person at a time. Modelers can update or
delete model information simultaneously by working with ER/Studio® Business Architect in the
normal fashion and by merging their changes into a single model.

To use Repository operations such as check in, check out, and get workspace, you must first
specify the Repository connection details and then log in to the Repository.

When you are finished working with the Repository, you should log out. If you close ER/Studio
Business Architect, you are automatically logged out of the Repository.

This section provides usage information for Repository Users:

e Specifying Repository Connection Details

® | ogging In and Out of the Repository

e Establishing Security for the Repository

* Working with Objects in the Repository

NOTE: Repository architecture, setup, maintenance, control, and query options are covered in
the “Administrator’s Reference” of the ER/Studio Data Architect Users Guide.

SPECIFYING REPOSITORY CONNECTION DETAILS

Using configurable Repository settings you can specify and modify server check out policy and
communication settings.
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Setting Repository Options
1 Click Window > Preferences.

2 Specify your connection details in the Repository Options and click Apply and then click
OK to exit the editor.

The following describe options that require additional explanation:
Server Machine: Specify the URL or hostname of ER/Studio Repository.

Server Port: Specify the port ER/Studio BA uses to communicate with the Repository server.
The default is 54333.

Check out model when checking out diagram: Choose what action, if any, you want the
system to perform with respect to the models in a diagram, when a diagram is checked out;
always check out the models, never check out the models, or prompt you to decide what to
do each time a diagram is checked out.

Check out workspace when creating/deleting models: Choose what action, if any, you
want the system to perform with respect to the workspace, when a model is checked out
and deleted or when diagram is checked out and a new model is added to it; always check
out the workspace, never check out the workspace, or prompt you to decide what to do
each time a workspace is checked out.

LOGGING IN AND OUT OF THE REPOSITORY

Log in to the Repository
1 Tolog in to the Repository, click Repository > Log In.

2 Complete the log in dialog and then click OK.
The following describes the options that require additional explanation:
User Name: Enter your user name. This is case-sensitive.

Password: Enter your password. This is case-sensitive. You can change your password, click
Repository > Security > Change Password.

Remember me: Select this option and ER/Studio BA will remember and then auto
complete the User Name and Password for you when you choose to log in.

Notes

® During the Repository Installation, a default user name and password Admin is set as the
default. The Administrator should change the Admin password after the initial log in.
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e The Admin user can't be deleted. This prevents an accidental lockout. In the ER/Studio
Security Center, you can set up additional users with Roles and Privileges to maintain
Repository security.

e |f an administrator changes the repository security, users must log in again to update their
permissions.

Log out of the Repository
To log out of the Repository, click Repository > Log Out.

ESTABLISHING SECURITY FOR THE REPOSITORY

Security of the Repository contents is managed through the Repository Security Center by
creating and then assigning users particular Roles and Privileges.

NOTE: To prevent an accidental lockout, the Admin user can’t be deleted.

The Administrator can restrict user access to Repository items at the workspace level. To restrict
access to the Repository, the administrator creates users and then assigns the users a role, which
grants specific permissions to the user, or the administrator creates new roles to assign to users.
Then the Administrator can grant users full access to some Repository items and restrict or deny
access to other items.

Before creating users and roles, the Administrator should understand the following Repository
concepts:

¢ Client Side Security Caching: To promote the concept of detached modeling collaboration
(e.g. being logged out of ER/Studio Repository and possibly detached from the network), all
security associated with the user by diagram is cached on the client when the user logs into
ER/Studio Repository.

NOTE: When security changes are made, users must re-login to update their permissions.

® Super User: Super User is a default Role created upon installation of ER/Studio Repository.
The default 'Admin' user is assigned to the Super User role. This user can do anything to
Repository objects, users and roles managed in the ER/Studio Repository as it is granted all
privileges. It is not removable or editable, and is only found at the 'Repository' level of the
Repository Security area of the Security Center.

* No Access: No Access is a role that can be applied only at the workspace level of the

Repository. It is a quick and global mechanism to prevent any access whatsoever to certain
workspaces.
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Notes

e \When a user checks out a workspace from the Repository, ER/Studio BA tracks the user and
machine combination for that particular file. In addition, to enable users to model while they
are "offline” or unable to connect to the Repository server, when a workspace is checked
out, ER/Studio stores information about the security rights of the user and the workspace
with the file, which has the following effects:

e When a user is logged into the Repository, and attempts to open a workspace that was
retrieved from the Repository by a different user/machine combination than the currently
logged in user, ER/Studio BA indicates that the file cannot be opened due to the conflict.
This ensures that one user does not attempt to work on or check in changes to a
workspace that was originally retrieved by a different user. Because the Repository keeps
track of object check outs based on the user and machine, only the user on the machine
that originally checked out an object can check it back in.

e Even if a user is not logged into the Repository, Repository files that have been checked
out can be opened and worked on in ER/Studio BA. ER/Studio BA will load the security
permission data for the user that originally retrieved the file from the Repository, and that
security data will govern the rest of the working session until the user either logs in to the
Repository or closes the file. If multiple files are open while the user is NOT logged in to
the Repository they must all have been retrieved by the same user. Of course, this also
applies when the user IS logged in.

e The cached security data stored with each diagram is updated whenever an open
Repository file is saved while logged in to the Repository, but if the file is not saved before
closing it, then any changes to the security permissions for that user and workspace will
not be cached with the file. So, if you plan to work offline, and the security settings have
changed since the file was last saved, then you should open each file while logged into
the Repository and save it before taking the files to work offline.

e |f an admin makes changes to the security Ul, such as changing permissions on worspaces to
grant or revoke access, users must re-login to update their permissions.

This section includes the following topics:

e Creating and Managing Roles

e Creating and Managing Users

¢ Granting and Prohibiting User Access to Repository Items

See Also
Working with Objects in the Repository

CREATING AND MANAGING ROLES

ER/Studio BA supports customized roles with different sets of permissions. Repository Object
Type Permissions are pre-defined privileges to operate on Repository items. You can assign
them to a role, which gives users assigned to that role, permission to perform certain Repository
operations. You can use the available privileges to create specific roles to suit your environment.
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For example, you can create a role which has the Repository permissions to create, update, and
delete workspaces. You can then assign a new user that role for the Repository and then create
and assign another role to provide update priveledges to existing workspaces the user may
need to update.

NOTE: To access, create, update, and delete user and roles, a Repository administrator must
have Access Security Info and Update Security Info privileges.

Create, Update, Rename, and Delete Roles
1 Click Repository > Security > Security Center.

2 Select the Manage Roles tab.
3 To create a new role, click New.

¢ In the Create Repository Role dialog, enter a Name and a Description for the new role.

¢ In the Repository Object Type Permission area, select the permissions you want to
assign to the role for the selected object type.

¢ Click Apply and continue changing security settings and then when finished, click OK to
exit the security center.

* To apply the new role to exisitng users, see Assigning Users Roles for Accessing
Repository Items.

To update a role, select a role from the list, select or clear the checkboxes to add or remove
permission, click OK, and then click OK again to exit the security center.

To delete a role, select a role from the list and then click Delete.
To rename a role, select a role from the list and then click Rename.

¢ In the Rename Repository Role dialog, enter a new name, click OK, and then click OK
again to exit the security center.

4 Inform affected users that they should log out of the Repository and then log in again to
receive the security updates.

Notes

¢ Once created, the Administrator can select the role and update, delete or rename it at any
time. Renaming the role does not affect the privileges users have, but if you delete a role
users who had access to Repository items through that role, will no longer have access to
those items.

e Users cannot modify workspaces without the necessary permissions, regardless of whether
the user has the workspace checked out.

® Once you delete a role from the Repository, it will no longer be in the database.
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® The following lists the Repository Object Types, the permissions you can grant, and the
common operations these permissions give access to:

Repository Repository Object Type | Permitted Operations
Object Types Permissions
Repository Access Security Info Security Center: View settings

Update Security Info

Security Center: View and change settings

Create Workspace

Add Workspace

Update Workspace

Check Out Workspace, Check In Workspace
Check Out Object(s), Check In Object(s)
Undo Check Out Workspace, Undo Check Out Object(s)

Delete Workspace

Delete Workspace
If you delete a workspace in Repository, the file itself remains on the
local disk.

CREATING AND MANAGING USERS

Managing users entails creating, changing, and deleting user account permissions and logins,
and activating and deactivating their accounts. Using Roles, you can choose the permissions

granted a user for the Repository item.

NOTE:

To access, create, update, and delete user information, a Repository administrator
must have Repository Object Type Permission, Access Security Info and Update
Security Info privileges.

Create, Edit, Delete, Deactivate, Reactivate, and Check In Users

1 Log in to the Repository.

2 Click Repository > Security > Security Center.

3 Click the Manage Users tab.

4 On the Manage Users tab, you can manage users by clicking their name in the list and then
clicking a management option and following the prompts as required.

5 Continue making security changes and then click OK to exit the security center.

6 To assign permissions to users, see Assigning Users Roles for Accessing Repository ltems.

7 Notify users that they must log out and then log in again to receive the security updates.

Notes

® You cannot delete or deactivate the Admin user, but you should change the Admin
password from the default, which is Admin.

e The new user appears in the user list with a star indicating that this user does not yet have
any roles assigned to it for any Repository items.
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e Users must log out and log in again to receive any security updates.

® The Admin does not need to know the user’s password to create a new password for the

user.

The Admin can look to the Manage Users tab to find out which users are logged in to the
Repository and whether or not they currently have items checked out. Knowing if users have
items checked out is particularly useful when upgrading the Repository, because after before
upgrading the Repository the users should check all their items in and then do a clean get
and check out of the items when the upgrade is complete. Knowing which users are logged
in is useful when changing security center settings because after making any setting
changes, the Admin should request online users to log off and log in again to receive the
security center updates.

The Aministrator may want to deactivate a user to prevent the user from logging into the
server while the Repository is being updated. Once deactivated the user must be
reactivated before they can log in to the Repository.

GRANTING AND PROHIBITING USER ACCESS TO REPOSITORY ITEMS

On the Repository Security tab of the Security Center, users with the appropriate privileges can
assign other users the appropriate access privileges for different objects, granting them
permission to perform specific operations on a Repository item and prohibiting them from
performing other operations on the same object.

Assigning Users Roles for Accessing Repository Items

1
2
3

Log in to the Repository.
Click Repository > Security > Security Center.

Click the Manage Roles tab; explore the available roles to determine if an existing role
provides the access you want to grant the user. If necessary, create a new role with the
appropriate permissions.

To grant permission to access and update security information, or to view only workspaces,
in the Repository Object pane, select Repository.

To grant permission to update or delete an existing workspace, in the Repository Object
pane, expand Repository and select the name of a workspace.

In the Available Users pane, click and drag a user name onto the name of the role you want
to apply to the user for the Repository or for the selected workspace.

Click Apply and then click OK to exit the Security Center.
Notify users that the must log out and then log in again to receive the security updates.

TIP: Toremove the role assignment of a user to a Repository item, click the Repository item,
drag the user name from under role onto another role in the Available Roles area or
drag the user name back to the Available Users pane.
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Notes

e Auser can only have one role for each object. But a user can have different roles for different
objects.

o |f a3 useris listed in the Available Users area, but is unselectable, the user has been
deactivated and must be reactivated before you can modify the user.

Prevent Users from Accessing Specific Repository Items

The system-defined No Access role can prevent a user from accessing selected projects or
diagrams

1 Log in to the Repository.
2 Click Repository > Security > Security Center.

3 In the Repository Object area, navigate to and then click to select the workspace you want
to secure from specific users.

4 From the list of users in the Available Users area, click a user name or CTRL-click several
names and then drag the users onto the No Access role in the Available Roles area.

5 Repeat step 3 and step 4 as required to secure other diagrams and projects.

6 Click Apply, continue changing security settings if required, and then click OK to exit the
security center.

Change User Access to Repository Items

To change user access to Repository items, change the permissions of the role the user has for
the Repository item or assign another role to the user for that particular Repository item.

WORKING WITH OBJECTS IN THE REPOSITORY

The Repository performs version control and allows other users to retrieve a copy of the
workspace to view or edit on their local machines if they have permission.

The Repository includes a robust features set for working with workspaces. Detailed procedures
for using these features are provided in subsequent sections.

Adding a Workspace to the Repository

® Retrieving a Repository Workspace

Getting the Latest Version of a Workspace

Saving Changed Items to the Repository (Checking In)

Checking Out Repository ltems

216 ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE



WORKING WITH ER/STUDIO REPOSITORY > WORKING WITH OBJECTS IN THE REPOSITORY

¢ Discarding Changes Made to a Checked Out Workspace

e Deleting Workspaces from the Repository

ADDING A WORKSPACE TO THE REPOSITORY
Using the Add Workspace operation you can add the active workspace to the Repository.

NOTE: You cannot add data model objects to the Repository without first adding the
workspace containing them.
1 Log in to the Repository.
2 Click Repository > Workspace > Add Workspace.

3 Enter a comment if you want to and then click OK to exit the dialog and complete the
operation.

When an object has been added to the Repository, the object icon changes to include a
little database icon in the upper left-hand corner.

Add to Repository _ :E__gq

Repository Workspace
Checked In

Workspace

RETRIEVING A REPOSITORY WORKSPACE

Retrieving a workspace in the Repository downloads a copy of the selected workspace from the
Repository onto your local machine. If a local version of the workspace exists, the Get from
Repository operation refreshes the local copy with the version from the Repository.

NOTE: Permissions assigned to your user account in the Repository Security Center determine
what type of access you have to Repository objects. For more information, see About

Repository Permissions.

1 Log in to the Repository.
2 Click Repository > Workspace > Get Worspace.

3 In the Repository Get Workspace Selection dialog, scroll through the list of available
workspaces, select the workspace you want, and then click OK.

NOTE: You can also get a workspace through the Welcome to ER/Studio Business Architect
dialog that appears each time ER/Studio BA is started.
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GETTING THE LATEST VERSION OF A WORKSPACE

The Get Latest Version function synchronizes the local version of the open workspace with the
version in the Repository, copying the Repository version to local storage and overwriting the
local copy. For example, if another user has changed the workspace since you last checked it in,
you can get the latest version to update your local version after they submit their changes.

Click Repository > Workspace > Get Latest Version.

SAVING CHANGED ITEMS TO THE REPOSITORY (CHECKING IN)

The check in process synchronizes the changes made to the local checked out item with the
Repository version by updating the Repository version.

The check in process lets you check in an object, such as an diagram or a model, when you are
done working with it.

Checking In Objects

When you check in an object, all object components are checked in as well. You can check in a
newly created object, such as a model which you added to a checked-out workspace or you can
check in multiple, selected objects simultaneously to the Repository.

The procedure to check in an object into the Repository is basically the same for all object types.

To check in a project, diagram or model
1 Save the changes you have made to the workspace; click File > Save.

2 Click the object you want to check in or CTRL-click several objects to check in more than
one object.

3 Right-click and then select Repository > Check In Object(s).

4 Enter a comment in the Repository Check In Object(s) dialog and then click OK to start the
check-in process.

To check in a workspace
1 Save the changes you have made to the workspace; click File > Save.

2 Click Repository > Check In Workspace.

3 Enter a comment in the Repository Check In Object(s) dialog and then click OK to start the
check-in process.
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CHECKING OUT REPOSITORY ITEMS

Checking out write enables items previously added to the Repository, such a workspace, project,
diagram or model. The procedure to check out an item from the Repository is the same for all
object types.

To check out a project, diagram or model

If you have a workspace checked out, and have checked in some objects, you can check them
back out using this procedure.

1 Open a Repository workspace; a workspace that was previously added to the Repository.

2 Click the item you want to check out or CTRL-click several items to check out more than one.
3 Select Repository > Workspace > Check Out Object(s).
4

In the Repository Check Out Object(s) dialog, enter a comment if you want to and then
click OK to start the check-out process.

NOTE: Checked out objects appear in the workspace explorer tree with a check mark in the
top left-corner of the object icon.

To check out a workspace

If the active workspace was previously added to or retrieved from the Repository, you can check
it out.

1 Open a Repository workspace.
2 Select Repository > Workspace > Check Out Workspace.

3 In the Repository Check Out Workspace dialog, enter a comment if you want to and then
click OK.

NOTE: Checked out objects, including the workspace, appear in the workspace explorer tree
with a check mark in the top left-corner of the object icon.

Check Out of Repository IIJ
- > ﬁ
H@ 4=

Repository Workspace Repository Workspace
Checked In Checked Out

DISCARDING CHANGES MADE TO A CHECKED OUT WORKSPACE

If you have checked out a workspace, made changes to it, and want to undo all the changes you
made you can undo the check out.

1 Log in to the Repository and open the target workspace.

2 To discard the changes, click Repository > Workspace > Undo Check Out Workspace.
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DELETING WORKSPACES FROM THE REPOSITORY

The Delete Workspace operation lets you delete a workspace from the Repository.
1 Login to the Repository.
2 On the Repository toolbar, click the Delete Workspace icon.

3 In the Repository Delete Workspace Selection dialog, select the diagram to delete and
then click OK.

Notes

* When you delete a Workspace from the Repository, the local copy of the Workspace is not
deleted.

¢ \When deleting a workspace, the Repository leaves workspace data behind and marks it as
deleted. If deleted, data is still present in the Repository but visible only when querying the
Repository directly, not through ER/Studio BA.
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A Business Process Model is a visual representation of the flow of activities and their order of
performance using a set of graphical elements that use shapes familiar to most modelers and
business users. For example, activities are rectangles and decisions are diamonds. The result is
having an easy-to-understand mechanism for creating business process models which produce
complex business processes.

The following example of a Business Process diagram shows the interaction between a customer
applying for a loan and the bank/lender.
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BUSINESS PROCESS MODELING ELEMENTS

There are six different categories of Business Process Modeling Notation elements: Events,
Activities, Gateways, Connection Elements, Swimlanes, and Artifacts. The following sections
discuss all aspects of how you can use them in the application.
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ER/Studio BA offers business flow functionality when working with the elements of the diagram.
As you place an element in the Diagram View it is validated against the BPMN specification. If a
placement or link is invalid, based on the BPMN specification, you will get a warning dialog.

Validating Against BPMN Specification

When you create a new model you can choose to validate the creation of certain elements and
flows against the BPMN specifications. The validation checks compliance with the Business
Process Modeling Notation specifications. For example, if validation is enabled and you draw a
message flow from a start event to a task, you get a dialog stating that this is an invalid
relationship. You can select one of three options to resolve the invalid notification:

¢ Do not allow the relationship to be created.
e Allow the relationship to be created.

e Allow the relationship and do not validate future relationships against the BPMN
specification.

NOTE: You can set a preference to turn this feature off or on.

EVENTS

An event is something that occurs during the course of a business process. These events affect
the flow of the process and usually have either a trigger or a result, depending on the event.
There are three types of Events based on when they affect the flow: Start, Intermediate, and End.
The table below describes the event elements:

Events Palette Icon | Description

Start Events @ Starts a process flow. In terms of a Sequence Flow, the

Start Event starts the flow of the Process, so it won't have
an incoming Sequence Flow. A Start Event can have one
of four Triggers that indicates how the Process starts:
Message, Timer, Rule, and Link.

Intermediate Q} Happens during the course of a process event. The
Events available triggers are Cancel, Compensation, Error, Link
Message, Rule, and Timer.

End Events @ Ends a process flow. The available results are: Cancel,
Compensation, Error, Link, Message, and Terminate.

START EVENTS

A Start Event indicates where a particular process starts. A trigger for a Start Event is designed to
show the general mechanism that instantiates that particular process. Use Cases for each trigger
type are discussed in the Using the Start Event topic.
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Using the Start Event

A process may begin with a start event. This start event can be normal (with no specified trigger)
or have one of four different types of triggers. Principle characteristics of a start event are:

e A Start Event is optional.

e |f a Process is complex and/or the starting conditions are not obvious, then it is
recommended that a Start Event be used.

o |f there is an End Event, then there must be at least one Start Event.

Tech Support Tech Support
Takes Call Solves Problem
Call Tech Support Call Terminate«d

The table below describes the Start Event triggers that you can use to indicate what kind of start
event is needed for the diagram:

Element Palette Icon | Description

Start @ This is the normal start event without a specified trigger.

Message =l A message arrives from a participant and triggers the
. start of the Process.

Timer 5 A specific time-date or a specific cycle (e.g., every Friday

at 10:00 a.m.) is set that triggers the start of the Process.

Rule This type of event is triggered when the conditions for a
rule become true.

Link = A mechanism for connecting the end of one Process to
the start (or trigger) of another.

Using the Start Event Message Trigger

When a message arrives from a participant it triggers the start of the process. For example a
start event could be the receipt of a message that a repair is needed on a computer.

_ Route Ticket to _
@ Creaf}tiii?;palr Apprr.!priate Complete Repairs Cln??cl::ralr
Receive Repairman Repair
Repair Ticket
Request Closed
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Using the Start Event Timer Trigger

If there is a timer trigger on a start event, the process is started whenever the timer reaches a
specific time, date, or cycle. This timer trigger must be received or conditions must be fulfilled
before the process can start.

Distribute Tests

Start
SAT Test
10:00 a.m.

Pick up Tests Grade Tests Post Results A.O

End BEvent

Using the Start Event Rule Trigger

A rule trigger indicates that a signal, sent from another process based on the satisfaction of a
rule, should start the current process. This rule trigger must be received or conditions must be
fulfilled before the process can start.

Warning Light Warning Beep

Appears on Dash Sounds in Car
Seat Belt Seat Belt
not huckled
huckled
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Using the Start Event Link Trigger

A link trigger indicates that when a signal is sent from another process, the current process
should start. This link trigger must be received or conditions must be fulfilled before the process
can start.
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INTERMEDIATE EVENTS

An Intermediate Event occurs between a Start Event and an End Event. It is an event that occurs
after a Process has been started. It affects the flow of the process but does not directly terminate
the process. Intermediate Events can be used to:

e Show where messages are expected or sent within the Process,
e Show delays that are expected within the Process,
¢ Disrupt the normal flow through exception handling, or

e Show the extra work required for compensation.
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An example of one use of Intermediate Events is to represent exception or compensation
handling. This is shown by placing an Intermediate Event on the boundary of a Task. The
Intermediate Event can attach to any location of the activity boundary and the outgoing
Sequence Flow can flow in any direction. Use Cases for each trigger type are discussed in the

Using Intermediate Event Triggers topic.

Employee Review

Using Intermediate Event Triggers

Review Status of
Discussed
Changes

There are seven Intermediate Event Triggers and the table below displays the palette icon and
description for each:

Triggers Palette Icon | Description

Compensation < Compensation is when activities are invoked that undo an
undesirable outcome.

Cancel % This trigger is used within a Transaction Sub-process. This
type of event must be attached to the boundary of a Sub-
process.

Error v, The trigger sets or catches errors. It sets an error if the
Event is part of a Normal Flow. It reacts to a named error
when attached to the boundary of an activity.

Link = Connects an End Event of one Process to an
Intermediate Event in another Process.

Message =) A message arrives from a participant and triggers an

. Event. The Process then continues if it is waiting for a
message, or changes the flow for exception handling.

Rule This trigger is only used for exception handling. This
event is triggered when a Rule becomes True. A Rule is
an expression that evaluates some Process data.

Timer 5 A specific time-date or cycle is set that triggers an Event.
It can act as a delay mechanism if used within the main
flow. If used for exception handling, it changes the
Normal Flow into an Exception Flow.
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Using the Compensation Intermediate Event

A Compensation Association occurs outside the Normal Flow of the Process and is based upon
an event (a Cancel Intermediate Event) that is triggered through the failure of a Transaction or a
Compensation Event. The target of the Compensation Association must be marked as a
Compensation Activity.

Compensation Intermediate Event Use Case

The following is a use case for how a compensation intermediate event would be implemented.

A travel agent books a flight for a corporate client. The normal flow for the business process
occurs as follows:

e There is a start event (message) when a corporate client calls to book a flight.

e The travel agent makes the necessary arrangements (a Book Flight task) and the flight is
booked (end event).

* However, the corporate client calls back and has to cancel. This is handled by an
intermediate compensation event which “interrupts” the normal sequence flow to an
outgoing directed association “flow” (compensation association). There is a rollback of
travel arrangements (compensation activity) where the travel agent cancels the flight (a
Cancel Flight task).

NOTE: Note that the Book Flight task cannot be compensated by a Cancel Flight task until the
Book Flight task has been completed. The end result of this compensation is that the
corporate client card is restored to an initial balance of $0.00, unless there are
cancellation fees.

Book Flight

Callto Flight
hook hooked
flight

|
|
|
i
|
L= Cancel FHight

4

The tasks in the above scenario could be replaced by a Book Flight sub-process (e.g., if there are
several steps to booking a flight you may decide to create a sub-process, either embedded or
independent) and a Cancel Flight sub-process. These would become compensated sub-
processes if the intermediate compensation event is “invoked”.
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Placing an Intermediate Compensation Event
1 From the Business Process Objects Palette, click the drop-down arrow on the Intermediate
Event node.

2 Select the Compensation Intermediate Event icon (| €€ |) and click the task that contains

the event you want to compensate (or roll back).

3 With the automatic connection feature you can then immediately draw an association link to
the task containing the information for the roll back. A compensation marker is then
automatically placed on the second task.

Task One

Task Two

4

4 Press ESC to exit the multi-drop mode.

NOTE: The cursor changes from [% to .

Using the Cancel Intermediate Event

A cancel trigger can be attached to an intermediate event. The resulting event type is always
attached to the boundary of a transaction action. It acts as a mechanism to interrupt this

transaction action.
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In the following example, when buying concert tickets online, if the payment succeeds the
tickets are purchased. If the tickets are not paid, the payment action triggers a cancel action.
This cancellation action also results in the Cancel Tickets action and the process ends.

Pick Concert

Reszerve Tickets

———
¥
—

Pay for Tickets

Paid

Cancel Tickets

Boaok Tickets

lt‘ End

End
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Using the Error Intermediate Event

The Process involving an error intermediate event begins with the receipt of a request for an
online purchase. After a credit card verification, an online purchase is made. The purchase may
take more than one attempt before it is successful. After the purchase is confirmed, a reply is
sent.

i Check Online Confirm Online —i1 @’
R Purchase Purchase

Reply

Handle Fault 4,@

Reply

Using the Link Intermediate Event

A link is a mechanism for connecting the end event of one process flow to the start event of
another process flow. A link intermediate event can be used as an “Off-Page Connector” or as a
"Go To object.”

CAUTION: If your off-page connectors need to be named the same, you must use the Off-
page Connector icon instead of the Link Intermediate Event object. You cannot
have two Link Intermediate Events with the same name on a diagram.
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Using the Link as an Off-Page Connector

If a process model extends beyond the length of one printed page you can use a Link
Intermediate Event to show how Sequence Flow connections extend across the page breaks. In
the sample below, a pair of Link Intermediate Events is used; one at the end of page one and the
second at the beginning of page two. This Event is named and has an incoming Sequence Flow
and no outgoing Sequence Flow. The second Link Event shares the same name, and has an
outgoing Sequence Flow and no incoming Sequence Flow.

Request Menu
from Caterer A
Caterers presemnt Wedding Party
. » mens reviews menu 4’@
Weddi A
eaaing Request Menu
Rehersal f Caterer B
Dinner rom rer
Page One
@ Select Caterer A Confirm Menu Pay Deposit
A
Page Two
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Using Link as a “Go To"” Object

Link Intermediate Events can also be used is as “Go To” objects. They work the same as Off-
Page Connectors, but can be used on the same page or across multiple pages. They reduce the

length of Sequence Flow lines which may be hard to follow or trace. When it is used as a Go To
object, the process continues as if the Sequence Flow had directly connected the two objects.
The following diagram shows the “Go To"” links used in place of a long Sequence Flow link from
the first gateway to the Close Order task, thus simplifying the look of the diagram.
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Ship Computsr
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Using the Message Intermediate Event

Claa Crdar

When placed within the diagram, a message event specifies that the process is waiting for a
message in order to resume its activity. There are usually flow links before and/or after this event.

Pharmacy waiting

on call from
doctor to fill Prescription filled

prescription

Call received

Using the Rule Intermediate Event

The Rule Intermediate Event is triggered when the conditions for a rule become true during the
execution of the process. This trigger can occur in the normal flow of the process or it can be
attached to the boundary of an action or it can also be used in an event-based decision pattern.
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The rule intermediate event is used for exception handling when a named rule becomes true.
Because the rule intermediate event is only used for exception handling, it has to be placed on
the edge of an activity, as it creates an exception flow.

Temp rises
to 74 degrees

Internal temp

risesto
Internal temp 74 degrees
drops to
72 degrees

Using the Timer Intermediate Event

When placed on an activity, the timer event represents something that can occur during the
execution of an activity. There is usually a link (flow or message) going out of the event to specify
the action to perform if such an event occurs.

1 Click the Timer Intermediate Event icon on the Business Process Modeling Notation
palette.

2 Click the task onto which you want to place the event. When you do this, the event then
becomes part of the activity.

The following example shows a timer event during an activity execution.

Place Pizzain

Assemble Pizza Remove

from oven

Add Extra Cheese
Topping
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END EVENTS

The End Event indicates where a process ends. You can define the consequences or results of
reaching an End Event. The example below shows a simple online credit card application with an
end message denoting that a message was generated at the end of a process.

Complete Application Application
Application Online Reviewed Declined
Open Messaqge

online Generated to
credit Applicam
card
wehbsite

A use case for each End Event trigger is discussed in the Using the End Event topic.

Using the End Event

If there is a start event, then there must be an end event. There are different results or
consequences that happen when you reach an end result.

The table below displays the palette icon and description for each End Event result:

Result Palette Icon | Description
Compensation < This End Event indicates that a Compensation is

necessary. The Compensation identifier triggers an
Intermediate Event when the Process is rolling back.

Cancel % The type of End Event is used within a Transaction Sub-
process. It indicates that the Transaction should be
canceled and triggers a Cancel Intermediate Event
attached to the Sub-process boundary. It also indicates
that a Transaction Protocol Cancel message should be
sent to any Entities involved in the Transaction.

Error v, A named Error should be generated. This Error is caught
by an Intermediate Event within the Event Context.

Link N A Link is a mechanism for connecting the end of one
process to the start of another.

Message =0 A message is sent to a participant at the conclusion of
= the process.
Terminate ' All activities in the Process should be ended immediately.
ot The Process is ended without compensation or event
handling.

Using the Compensation End Event

This type of End Event indicates a Compensation is necessary. The Compensation identifier
triggers an Intermediate Event when the Process is rolling back.
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At the end of a trip, a person checks out of a hotel using express checkout. Their bill has been
delivered during the night and the person finds a charge for an extra day. Prior to departing the
hotel the person goes to the checkout desk and asks for a refund. The clerk refunds the client’s
credit card, rolling back the process by reimbursing the person. As express checkout was the
end of the process (end event). A compensate end event with outgoing directed association
“flow” (compensation association) to the original charge activity is necessary to rollback charges
to the person’s credit card.

Placing a Compensation End Event

Take the following steps to place a compensation end event:

1 From the Business Process Objects Palette click the drop-down arrow on the End Event

node @ .

2 Select the Compensation End Event icon (| € |) and click the task that contains the event

you want to compensate for (or roll back).

3 Press ESC to exit the multi-drop mode.

NOTE: The cursor changes from [%_‘I to [&.
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Using the Cancel End Event

This End Event can only be used within a Transaction Sub-process and causes the cancellation of
that Process. The process is ended with normal event handling. In the following example, the
client did not pay for his tickets so the process was cancelled.

Fick Concert

Reszerve Tickets

Pay for Tickets

Paid

Cancel Tickets

Book Tickets

It' Ernd

End
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Using the Error End Event

The Error End Event indicates that a named Error should be generated. The following diagram
shows the process for a consumer who wants to make a purchase with a credit card. If the credit
card is invalid the process goes to an error end event. The desired behavior is a valid credit card
which takes the flow to a task called “Charge Credit Card” and then to an end event.

Inwalid Card

Purchase with Charge Credit

Select Product card card

Using the Link End Event

There are points within a process where it is important to know whether a specific milestone has
been met. The process model must be able to identify and react to the milestone.

The example below shows how information can be passed from one part of a diagram to
another part. In the diagram, paperwork must be completed in one sub-process before the
paperwork in another sub-process can start. A Link End Event that follows the Payment Received
Task is used to trigger a corresponding Link Start Event that precedes the first task in the second
sub-process.

Crdar Dotk Payment
Recelve s Crdar nvolce Curtomer Recalved
é ¥
- Papsrwork
Curtomar Nesds ‘
Auto Part II‘ -om pletid Crder Ships

Parts Cepartmeant
Recalven
Paparwark

Crder Allad Ordsr Packaged

Paparwork
Complatad
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Using the Message End Event

A Message End Event finishes a process and sends a message to a participant.

| Check Online Confirm Online —I‘" @’
Check Credit Card Purchase Purchase

Reply

Handle Fau @

Reply

Using the Terminate End Event

The Terminate End Event indicates that all activities in the Process should be ended immediately
even if there are tasks that have not started or are still active. This includes all instances of Multi-
Instances. The Process is ended without compensation or event handling. The Terminate End
Event symbol is placed where the cancellation should be signalled.

Sub-process C

m 3

Take E

Task A

i J

[—]
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ACTIVITIES

An activity is work that a company performs and can be atomic or non-atomic (compound). The
types of activities that are a part of a Process Model are: Process, Sub-process, and Task.
Processes must be contained within a Pool. The table below displays the icon for each element
with a description.

Element Palette Icon Description

Task

This is an activity that is performed within a

o .
business process.

Sub-processes

Independent Sub- An independent Sub-process element is an
process activity within a Process that calls to another
process that exists within a business process
definition diagram.

El

Embedded Sub-process

An Embedded (or nested) Sub-process is an
activity that contains other activities (a
Process). The Process within the Process is
dependent on the parent Process for
instigation and has visibility to the parent's
global data. No mapping of data is required.

&l

Task

A task is an activity that is included within a Process. You use a Task when the work in the Process
is not broken down to a finer level of Process Model detail. Generally, an end-user and/or an
application are used to perform the Task when it is executed. The tasks can have different
behaviors, however these behaviors are not indicated by any graphical indicators.

To set a type for a task:
1 Right-click on the tasks to open the Properties View.

2 On the General tab, click the drop-down arrow in the Task type text box and select the type
from the list. The additional properties that you can set change depending on the type
selected. For example if you select “Service”, you can set the “In Message”, “Out Message”
and “Implementation” properties.

NOTE: You can convert a task to an Independent Sub-process or Embedded Sub-process.

There are seven different task types:

Task Type Description

Service A Service Task provides some sort of service such as a
Web service or an automated application.

Receive A Receive task waits for a message to arrive from an
external participant. Once the message has been
received, the Task is completed. A Receive Task is often
used to start a Process.
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Task Type Description

Send A Send Task sends a message to an external participant.
Once the message has been sent, the Task is completed.

User This is a workflow task performed by a human with the
assistance of a software application. It is scheduled
through a task list manager of some sort.

Script When the Task is ready to start, the engine executes a
script written in a language that a business process
engine can interpret. When the script is completed, the
Task is also completed.

Manual A Manual Task is expected to be performed without the
aid of any business process execution engine or any
application.

Reference The Reference Task refers to another activity that has

been defined with the exact same behavior.

The table below describes the two types of markers for a Task:

Element Icon Description

Loop D The attributes of Tasks and Sub-processes determine if
they are repeated or performed once. There are two

types of loops: Standard and Multi-Instance. The looping

indicator is displayed at the bottom-center of the activity.

Parallel Multiple I This refers to multiple instances of the activities. Activities
Instance that are Parallel Multi-Instance have a parallel marker
placed in the bottom center of the activity.

Converting a Task

When you right-click on a task you can select the Convert to command on the shortcut menu.
You have two conversion options: Embedded Sub-process and Independent Sub-process. This
command is useful if you want to break down a task into smaller parts or add more details/
subtasks.

For example, in your design process you determined that your task will be “Load New Software
on Computer”. You then decide you want to make the task more detailed requiring a sub-
process where you can create tasks for each detail: (1) shop for best price on software; (2)
purchase software; (3) verify compatibility; and (4) load software.

When you convert a task the following characteristics apply:
¢ A converted element is placed on the diagram in the same place as the task.

e The converted task is renamed with the new element’s type default name. For example, if
you are converting to an embedded sub-process, the converted element is named
"embedded sub-process”.

e \When connecting objects are anchored to the task, they are not moved and after the
conversion and retain their connection point.
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* You will get a warning dialog if the conversion breaks any validation rules.
* Object formatting attributes are retained after the conversion.

® Elements retain their same size after the conversion.

Sub-processes

A Sub-process extends the set of common activity attributes. The two different sub-processes
are embedded and independent.

The Sub-process can be in a collapsed view that hides its details or it can be an expanded view
that shows its details within the view of the Process in which it is contained. In the collapsed
form, the Sub-process element uses a marker to distinguish it as a sub-process, rather than a
Task. The first graphic shows a collapsed sub-process. The second graphic shows the Embedded
Sub-process expanded.

Embedded Sub-
Process

[+]

=l[ Task 1 }
Task
Start Event Task2
End nt
Ga‘t wa}r TEISH 3
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Embedded Sub-process

An Embedded (or nested) Sub-process element is an activity containing other activities (a
Process). The Process within the Process depends on the parent Process for instigation and has
visibility to the parent’s global data. No mapping of data is required. The elements within the
Embedded Sub-process, being dependent on their parent, do not have all the features of a full
Business Process Diagram, such as Pools and Lanes. So an expanded view of the Embedded
Sub-process only contains Events, Activities, connecting elements, and Artifacts.

NOTE: When an Embedded Subprocess is placed in the Diagram View, the label appears
vertically centered. Once you add a child element, the label is then relocated to the
top center of the Embedded Subprocess.

There are six types of standard markers for Embedded Sub-processes, including the Standard
marker. The (Collapsed) Sub-process Marker, can be combined with four other markers: a Loop
Marker or a Parallel Marker, a Compensation Marker, and an Ad Hoc Marker. A collapsed sub-
process may have one to three of these other markers, in all combinations except that the Loop
and Multiple Instance cannot be shown at the same time.
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The table below briefly describes each embedded sub-process:.

Element Palette Icon Description

Standard =1 A Sub-process hides its flow details.

Embedded Sub- The Collapsed Sub-process element

process uses a marker to distinguish it as a Sub-
process, rather than a Task. The marker
is a small square with a plus sign (+)
inside.

Ad Hoc i An Ad Hoc Process is a group of

Embedded Sub- - activities that have no pre-definable

process sequence relationships.
Activities within the Process are
disconnected from each other. During
execution of the Process, any one or
more of the activities may be active
and they can be performed in almost
any order or frequency.

Loop = The attributes of Tasks and Sub-

Embedded Sub- o processes will determine if they are

process repeated or performed once. There are
two types of loops: Standard and
Multi- Instance. A small looping
indicator is displayed at the bottom-
center of the activity.

Multiple = The attributes of Tasks and Sub-

Instance " processes determine if they are

Embedded Sub- repeated or performed once. A small

process parallel indicator is displayed at the
bottom-center of the activity.

Transaction =] A Sub-process, either collapsed or

Embedded Sub- expanded, can be set as being a

process Transaction, which has a special
behavior that is controlled through a
transaction protocol (such as BTP or
WS-Transaction). The boundary of the
activity is double-lined to indicate that
it is a Transaction.

NOTE: To select multiple elements in the Embedded Subprocess, hold down the ALT key to

invoke the marquee cursor.

Independent Sub-process

An Independent Sub-process element is an activity within a Process that “calls” to another
Process that exists within a separate diagram. The Process that is called is not dependent on the
Independent Sub-process’ parent Process for instantiation or global data. The called Process is
instantiated when called, but it can be instantiated by other Independent Sub-process elements
(in other diagrams) or by a message from an external source. The Independent Sub-process
element may pass data to/from the called Process.
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When an Independent Sub-process (ISP) is created (either in the Model View tree or dropped in
the Diagram view), a new diagram with an associated pool and lane are created at the model
level. The default name of the ISP will be the default name of the Independent Sub-process
element (e.g. Independent Sub-Process).

There are six types of standard markers for Independent Sub-processes, including the Standard
marker. The (Collapsed) Sub-process Marker, can be combined with four other markers: a Loop
Marker or a Parallel Marker, a Compensation Marker, and an Ad Hoc Marker. A collapsed sub-
process may have one to three of these other markers, in all combinations except that the Loop
and Multiple Instance cannot be shown at the same time.

The table below briefly describes each independent sub-process:

Element Palette Icon Description
Standard o A Sub-process hides its flow details.
Independent The Collapsed Sub-process element
Sub-process uses a marker to distinguish it as a sub-
process, rather than a Task. The marker
is a small square with a plus sign (+)
inside.
Ad Hoc = An Ad Hoc Process is a group of
Independent -~ activities that have no pre-definable
Sub-process sequence relationships.
Activities within the Process are
disconnected from each other. During
execution of the Process, any one or
more of the activities may be active
and they can be performed in almost
any order or frequency.
Loop =] The attributes of Tasks and Sub-
Independent o processes will determine if they are
Sub-process repeated or performed once. There are
two types of loops: Standard and
Multi- Instance. A small looping
indicator is displayed at the bottom-
center of the activity.
Multiple = The attributes of Tasks and Sub-
Instance " processes determine if they are
Independent repeated or performed once. A small
Sub-process parallel indicator is displayed at the
bottom-center of the activity.
Transaction ] A sub-process, either collapsed or
Independent expanded, can be set as being a
Sub-process Transaction, which has a special
behavior that is controlled through a
transaction protocol (such as BTP or
WS-Transaction). The activity has a
double border to indicate that it is a
Transaction.
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GATEWAYS

A Gateway controls the divergence and convergence of the Sequence Flow. It determines
branching, forking, merging, and joining of paths. Basically it is a question that is asked at a
point in the flow. This question has a defined set of alternative answers.

Element Palette Icon | Description

Gateway & This symbol displays decisions, merges, forks, and joins in

the process flow. It controls how Sequence Flows interact
as they converge and diverge within a process. You can
set the Gateway Control Types of a gateway and change
the logic specified by it.

There are two different ways to set the Gateway's control
types: from the palette, or on the Model View.

Placing Gateways Using the Palette
1 Click Gateway in the Business Process Objects Palette to expand the node.

2 Click the gateway with the control type you want to use from the expanded node.
3 Click once in the Diagram View and the selected gateway is placed in the diagram.

NOTE: Notice that the selected gateway also appears in the Model View tree with the
appropriate icon designating the control type.

Placing Gateways Using the Model View

1 Right-click the lane name where you want to place the gateway.

2 Select New and then select Gateway from the list of available elements and a gateway node
is placed in the Model View tree.

3 Double-click the gateway node and the Gateway Properties View opens.

4 In the Type list box select the control type you want to use from the type drop-down list and
click OK. The gateway node icon changes to represent your control type.

NOTE: You can then drag the gateway node from the Model View tree on to the Diagram
View.
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GATEWAY CONTROL TYPES

You can set control types for gateways. A control type changes the logic and also the symbol it
represents. The table below lists all the available control types for a gateway.

Control Type

Icon

Explanation

Data-Based

®

These are the most common gateways used. A data token
traverses the Process Flow arriving at the gateway. It can only go
out on one flow. This control type is represented by either a

"u_n

diamond with an “x" in the middle or blank diamond shape.

Event-Based

Decision: This represents a branching point where the
alternatives are based on an event occurring at that point.

Merge: The exclusive merge models data-based or event-
based merges. Only one of the many inputs is chosen as the
output.

Inclusive

Decision: One or more of the outgoing Sequence Flows may
be taken. A default flow must be specified at this point, there
cannot be zero output flows.

Merge: A process flow continues when it receives the first
input signal from the input Sequence Flow. If other signals arrive
after that, they are not used.

Complex

Decision: This expression determines which output flow is
taken from multiple Sequence Flow names.

Merge: You specify a complex flow condition referencing
incoming Sequence Flow names or process data coming into a
gateway. This expression determines when the task starts.

Parallel

Fork: All Sequence Flows out of this gateway are taken.

Join: This gate must receive input signals from all input
Sequence Flows. The process flow does not continue until it
receives all signals.

USING DATA-BASED GATEWAYS

The Data-Based Decision is a branching point where the alternatives are based on conditional
expressions contained within the outgoing Sequence Flow. Only one of the Alternatives is

chosen.
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In the following graphic, there are three alternative tasks that may be performed. The decision
on which task is performed is based on the boolean expression contained in the Condition
Expression attribute of the outgoing Sequence Flow of the Gateway. The expression uses the
values of process data to determine which path is taken.

Alternative One

Task Alternative Two

Gatgway

Alternative Three

Using Event-Based Gateways

An Event-Based decision represents a branching point where the alternatives are based on an
event that occurs at that point in the Process. The specific Event, such as the receipt of a
Message or a Timer event, determines which of the paths will be taken. Only one of the
Alternatives is chosen. The following example shows an event-based gateway using message
events.

Task One
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Using Inclusive Gateways

Inclusive gateways provide more than one possible outcome. There is usually a corresponding
merging inclusive gateway. The following example shows a number of chapters in a book that
may be included in a book.

Write Chapter on
Methods
What
Chapters
to includ
¢ inelde Write Chapter on
Processes Compiled Book
Write Chapter on
Outcome
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Using Complex Gateways

A Complex Gateway is used to handle situations that are not easily handled through the other
types of Gateways. Complex Gateways can also be used to combine a set of linked simple
Gateways into a single, more compact situation. Complex behavior can be defined for both the
merging and splitting behavior.

Human
Resources Report

Development
Department
Report

CEO Reviews [ Quality
Reports * Assurance
- r Department

Report

Gatd

Documentation
Department
Report

Marketing
Department
Report
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Using Parallel Gateways

Parallel Gateways are places in the Process where multiple parallel paths are defined. Events on
parallel outcome paths execute simultaneously and independently of each other. You can create
a decision point that directs the process flow down multiple flows so activities are executed in
parallel (instead of executing in sequence). These flows can then be reunited into a single flow to
complete the task. The process execution waits until the last task in each parallel flow has been
completed. The following example shows two parallel gateways. The task following the second
gateway is executed only after all the parallel paths are completed.

- o

Make Snacks

Buy Drinks

Y

<+ Leawve for party

O—<+=

Buy Plates and
Glasses

Load lce Chest

e e e e

CONNECTION ELEMENTS

There are three ways of connecting Events and Activities to each other or to other information:
Sequence Flow, Message Flow, and an Association. You can gain access to the Property View for
each connection element by double-clicking the relationship element in the diagram.
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The table below describes the link types displayed on the Business Process Objects Palette:

Connection Palette Icon | Description
elements
Seqguence Flow — A sequence flow shows the sequence

of processes in an organization. You
can use the sequence flow lines to
connect events, processes, and
gateways in pools or lanes. The
Sequence Flow has three different
designations that can be set using
the Sequence Flow Property View.
Double-click the Sequence Flow to
open the Sequence Flow Properties

dialog.

Message Flow b Shows the model order of processes
between organizations (i.e. between
pools).

Association An Association is used to associate

information and artifacts with events
and activities.

SEQUENCE FLOW

A Sequence Flow shows the sequence of processes in an organization or department. When you
use pools or lanes in your diagram, you use Sequence Flow lines to connect events, activities,
and gateways within the pools or lanes. The Sequence Flow is represented as a line with a filled-
in arrow head.

Task One

j Task Two

There are five different types of sequence flows and you can change a sequence flow type:

Type Flow_Type_Examples | Description

Normal Flow > This is the flow originating from a Start
Event and continues through activities
via alternative and parallel paths until
ending at an End Event.
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Type Flow_Type_Examples | Description

Uncontrolled Flow > This flow is not affected by any
conditions and does not pass through
a Gateway, for example a single
Sequence Flow connecting two
activities. An Uncontrolled Flow can
also apply to multiple Sequence Flows
converging or diverging from an
activity. For each uncontrolled
Sequence Flow, a “Token” flows from
the source element to the target
element.

Conditional Flow < > A conditional flow is evaluated at

) runtime to determine whether or not
the flow is used. If the conditional flow
is outgoing from an activity, then the
Sequence Flow has a mini-diamond at
the beginning of the line. If the
conditional flow is outgoing from a
Gateway, then the line does not have
the diamond.

Default Flow \ - For Dgta—Basgd Exclusive Decisions or
Inclusive Decisions, one type of flow is
the Default Condition flow. This flow is
used only if all other outgoing
conditional flows are not true at
runtime. These Sequence Flows have a
diagonal slash added to the beginning
of the line.

You would add a Default Conditional
Flow marker to a Sequence Flow for
two types of decision: Data-based
Exclusive and Inclusive Decisions. This
flow is used only if all the other
outgoing conditional flows are not true
at runtime.

5 Exception Flows occur outside the
J normal flow of the Process and it is

— based upon an Intermediate Event that
TEromsen occurs during the performance of the
L J Process.

Exception Flow r

Changing the Type of Flow Marker

1 Double-click the Sequence Flow that you want to change to a default flow marker and the
Properties dialog opens.

2 Click the drop-down arrow in the Condition Type box and select Default from the list.

3 Click OK. The Properties dialog closes and the marker is added to the sequence flow.
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MESSAGE FLOW

Message Flows are used to show the flow of messages between two participants that are
prepared to send and receive them. A Message Flow can connect directly to the boundary of a
pool or it can cross the boundary of a pool and connect to an object within that pool. Also, if
there is an Expanded Sub-Process in one of the Pools, then the Message Flow can be connected
to either the boundary of the Sub-Process or to objects within the Sub-Process. The following
example shows a Message Flow across the boundary of a pool.

@
0
=
[u]
E Verify item is in
= stock
=
.?. Ey
I
: [
I
| i
© T i .
s
'f:: Place Order Process Order 4’0
=]
m
ASSOCIATION

An Association is used to associate information with events and activities. It can be used to
associate reference objects, external data objects, shapes, and activities with textual
information. You can also use an Association to associate Data Objects with other objects.

There are four different Associations available:
® Association ()
¢ Association to Target (..»)
® Association From Target (<)
¢ Association To/From Target (<)
The selection you make is reflected on the beginning and ending indicator on the Association.

You can set global preferences for all the line display options in the Preferences.
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The example below shows an Association connecting a Data Object with two tasks.

SWIMLANES

1
1
1
: Job Description
1
1
1

Receive Job
Description

Review .Job
Description

You can group primary modeling elements by using swimlanes which consist of pools and lanes.
A Pool represents a participant in a process. It also acts as a graphical container for partitioning a
set of activities from other Pools, usually in the context of Business-to-Business (B2B) situations.
A Lane is a subpartition within a Pool and extends the entire length of the Pool. Lanes are used
to organize and categorize activities.

The table below describes the types accessible from the Business Process Objects Palette:

Swimlanes Palette Description
Icon
Pools (Horizontal) | Horizontal Pool: This pool is drawn as a rectangular

region placed horizontally. A lane is a subpartition within a
pool and extends the entire length of the pool. A pool
represents an organization, function, application, class, or
an entity.

Vertical Pool: This pool is drawn as a rectangular region
placed vertically. It has the same characteristics as the
horizontal pool.

Lanes

Lanes organize and categorize activities. When you place a
process in a pool or lane you specify who is doing what. If
you place an event in a lane you specify where that event
occurs. When you place a gateway in a lane you specify
where a decision is made or who makes it.

Nested Lane

You can insert lanes within lanes.
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POOLS

A Pool represents a participant in a Processes. It is also called a “swimlane” and is a graphical
container for partitioning a set of activities from other pools. The activities within separate Pools
are considered self-contained Processes. When this is true, the Sequence Flow may not cross the
boundary of a Pool. A Message Flow is the mechanism to show the communication between two
participants, and is the connection used between Pools.

Sequence Flow
|

o
E
o
& Task Task1
o
\.I.u'
|
Message Flow —h:
|
|
- |
o |
= I
1 Task2 == =
0w
iy
1'd

When you create a pool in ER/Studio BA, a lane is created at the same time. If Validation is
turned when you create the project, the lane is not labeled.

Pool

FPool La|ne

A pool can be shown as a "White Box” with all the details of the activity in the pool exposed. A
“Black Box"” hides all of a pool’s activities. No Sequence Flow is associated with a black box, but
a Message Flow can attach to its boundaries. The default display for a pool is as a white box.

NOTE: When all lanes are removed from a pool it becomes a black box pool. The pool header
label remains, but the lane area is hidden.
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PROCESSES

When creating a pool and lane, visible or invisible, when elements are dropped in the lane (or
diagram), the elements appear at the same level as the lane in the Model View.

) = T
Hilodel 23 &

== S
El% shipping Process Model B
-- Order Picking
=] Order Picking
@ Start Event
@ End Event

-8 Order Picking -|

However, in the Business Process Modeling Notation specification, all elements in a pool are
owned by a process. This process is not shown by default in the Model View tree. However, it can
be displayed by setting the Processes Preference.

iy = ~
*dodel &3 &

53 | = & | Mg &
Elﬁ Shipping Process Model ;I
-- Order Picking

( El*'-‘ﬁ?;I Crrder Picking I

A Skart Event
‘Q End Event

-0 Order Picking

LANES

A Lane is a subpartition within a pool. Lanes organize and categorize activities. Lanes are often
used to separate the activities associated with a specific company function or role. A Sequence
Flow may cross the boundaries of Lanes within a Pool, but a Message Flow may not be used
between events and activities in Lanes of the same Pool or between the lanes of the same Pool.

When you click a lane in a pool, selection handles appear on the selected lane.
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You have many ways to insert lanes in pools. You can also resize lanes, create nested lanes,
reorder lanes in pools, delete lanes from pools, and remove lanes from pools.

NOTE: To select multiple elements in the Lane, hold down the ALT key to invoke the marquee
cursor.

INSERTING LANES IN POOLS

In ER/Studio BA when you create a pool, one lane is also created in that pool. There are several
different ways to insert additional lanes in a pool: (1) from the diagram shortcut menu; (2) from
the palette; (3) from the Model View tree; and (4) using the insert key. You can also create nested
lanes lanes.

Inserting Lanes in a Pool Using the Diagram Shortcut Menu

1 Right-click in the pool header and the shortcut menu opens.

2 Click Insert Lane and if it is a horizontal pool, it is inserted at the bottom. If it is a vertical
pool, it is inserted on the right.

Inserting Lanes by an Existing Lane Using the Diagram Shortcut Menu

1 Right-click in a lane and the shortcut menu opens.

2 Click Insert Lane. If it is a horizontal pool you can choose to insert the new lane above or
below the selected lane. If it is a vertical pool you can choose to insert the new lane to the
left or right of the selected lane.
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Inserting Lanes from the Business Process Objects Palette

1 From the Palette, click the Lane icon ( =).

2 When you place the cursor in a pool or lane an indicator appears. This thick double-line
indicates where the lane will be dropped (above or below selected lane). In the following
example the new lane is inserted below the BPPool lane.

Lane

Insertion

Indicator
4]

Pool

Lane

Inserting a Lane from Pool Node in the Model View

You can create a lane in a pool from the pool node in the Model View tree.

1 Right-click the pool node in the Model View tree.

2 Select New > Lane. If it is a horizontal pool, a lane is added to the bottom of the pool. If it is
a vertical pool, the lane is added to the right of the pool.

You can also create a lane from a lane node in the Model View tree.
1 Right-click the lane node in the Model View tree and select New > Lane.

2 Then select either Above or Below from the pull-right menu. If it is a horizontal pool, a lane
is either added above or below the selected lane, or to the left or right of the selected lane.

NOTE: In the Model View tree hierarchy, the lanes are always placed above or below the
selected lane based on your choice of location.

Inserting a Lane Using the Insert Key

1 Select a pool or lane.
2 Press the Insert (INS) key.

e |f pool is selected (in a diagram), and you press the Insert key, the new lane is added to the
bottom or to the right.
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e If alane is selected (in a diagram), and you press the Insert key, the new lane is added to the
top (above) or to the left.

Creating a Nested Lane

You have two different ways to create a nested lane:

e Right-click in an existing lane and select Insert Lane > Within Lane.

e Select the Nested Lane icon (== ) from the Business Process Objects palette and click once
in an existing lane.

RESIZING LANES

You can resize lanes by selecting the selected lane's border on the diagram and dragging. The
resizing function has the following characteristics/restrictions:

® You can set a preference so the pool size will adjust when resizing lanes.

® You can resize individual lanes.

When sizing the pool the minimum size limits on all of the lanes are respected (i.e. the
minimum size of the pool is the sum of the minimum size of the child lanes.)

When showing/reshowing hidden lanes, the size of existing lanes within a given diagram
does not change. Newly added lanes are the default lane size and can increase the size of
the pool by the size of the lane, as required.

Resizing a Lane

1 Select the lane to be resized.

2 Place the cursor on the top or bottom (horizontal pools) or the left or right (vertical pools)
lane selector indicators.

NOTE: Note that the cursor changes from the move cursor (4%») to the resize cursor (I )
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Lane1

£
o/

Pool
Lane3

Lane2?

3 Drag the cursor to resize the lane or pool to the desired size.

REORDERING LANES IN POOLS
You can reorder the lanes in a pool either in the diagram or in the Model View tree.

NOTE: You can only reorder lanes within its own pool. You cannot move lanes from one pool
to another.

Reordering Lanes in a Diagram

There are two different ways to order lanes in the diagram: (1) dragging the lane to a new
position within the pool; or (2) using the Move Lane dialog.

Using the Drag Method

1 Click the lane or lanes you want to move. The selected lane now has selection handles.

NOTE: Select multiple lanes by pressing Ctrl and then clicking the lanes you want to move.
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2 While holding down the mouse button, drag the lane its new position. Notice that the order
of the lanes in the Model View tree reflect the change you just made in the diagram.

When you are reordering the lanes in a pool an indicator appears. This thick line indicates
where the lane will be dropped (above or below selected lane). In the following example the
new lane is placed above the lane labeled THREE.

Reorder Indicator

THREE

FPaool
TWO

ONE

Using the Move Lane Dialog
1 In the diagram select the lane or lanes you want to reorder.

NOTE: Select multiple lanes by pressing Ctrl and clicking the lanes.

2 Right-click the selected lane(s) and click Move Lane on the shortcut menu. The Move Lane

dialog appears.
= Move Lane @

Before lane:

Crder Picking Lane
Lane
fmove to end)

[ 8] 4 H Cancel ]

3 From the list of lanes, select the lane you want to move the lane before and click OK.
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Reordering Lanes in the Model View Tree

There are two different ways to order lanes in the Model View tree: (1) dragging the lane to a
new position within the tree; or (2) using the Move Lane dialog.

Using the Drag method:
1 Select the lane or lanes you want to reorder.

NOTE: Select multiple lanes by pressing Ctrl and then clicking the lanes you want to move.

2 Drag the lane or lanes to its new position in the tree. A horizontal indicator displays where
the moved lane will be inserted. In the example below, lane ONE is moved to just below
lane THREE.

B *Model X & BlE| & 0

= gl workspace One
= @- Project
=iy Model
Ciagrarm
= Pool
=3 THREE
=1 TWo
= gellS
G End Event
m Reference Objects

Using the Move Lane Dialog
1 Inthe Model View tree select the lane or lanes you want to reorder.

NOTE: Select multiple lanes by pressing CTRL and clicking the lanes.

2 Right-click the selected lane(s) and click Move Lane on the shortcut menu. The Move Lane

dialog opens.
& Move Lane @

Before lane;

Order Picking Lane
Lane
(rmove bo end)

(0] 4 l [ Cancel
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3 From the list of lanes, select the lane you want to move the lane before and click OK.

DELETING LANES FROM POOLS

You can delete lanes from pools in either the Model View tree or the diagram. This command
deletes the lane, and all elements in the lane, from the Model View tree and the diagram. The
deleted lane and elements are eliminated from the metamodel and are not available on the
clipboard.

NOTE: There must always be at least one lane in the pool. You cannot delete all of the lanes
or the last lane in a pool.

Deleting a Lane from a Pool in the Model View
1 Right-click the lane node you want to delete in the Model View tree and select Delete.

OR

Select Edit > Delete from the main menu.

OR

Press the Delete key. The Delete Elements dialog opens.

NOTE: You can also delete multiple lanes. Select a lane node and while holding down the
CTRL key, select the other lanes you want to delete.

= Delete ltems @

Are vou sure you want o delete the selected items?

Clicking ¥es will completely remove the ikems from the workspace,

(7 [ Yes l [ Mo

2 Click Yes to delete the lane from the pool.

NOTE: You can delete a lane or multiple lanes from the Model View tree when the diagram is
closed.
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Deleting a Lane from a Pool in a Diagram

1 Select the lane you want to delete

2 Right-click in the lane and select Edit > Delete.
OR
Select Edit > Delete from the main menu.
OR

Press the Delete key.

NOTE: You can also delete multiple lanes. Select a lane and while holding down the CTRL key,
select the other lanes you want to delete.

3 From the Delete Elements dialog, click Delete and the selected lane is deleted from the
pool.

& Delete Elements E|

You have chosen to delete the selected elements.

Click Remove to disassociate the elements From this diagram wiew ar
click Delete to completely remove the elements From the workspace.

+ Click here to see the diagrams on which the elements appear.

7] Remove H Delete H Zancel

REMOVING LANES FROM POOLS
You can remove all lanes from a pool or remove just one or more lanes.

Removing all Lanes from a Pool

You can remove (hide) lanes from a pool in the diagram including the last lane. If the last lane is
removed, the pool is then a “Black Box" pool.

1 Select the pool you want to remove the lanes from.
2 Right-click in the pool and select Remove All Lanes (Black Box).

NOTE: When a pool becomes a black box pool, the relationships between items inside the
pool and other entities are hidden.

3 To show all lanes right-click in the pool and select Show All Lanes.

NOTE: If you have the Validation option set to On, when there is only one lane, then that lane
shares the name of the Pool and only the Pool name is displayed.
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Removing one more Lanes from a Pool in the Diagram:

1 Select the lane(s) you want to remove.

2 Right-click in the lane and select Edit > Delete.
OR
Select Edit > Delete from the main menu.
OR

Press the Delete key.

3 From the Deleting Elements dialog, click Remove and the selected lane is removed from
the pool on the diagram.

& Delete Elements §|

¥ou have chosen to delete the selected elements,

Click Remove ko disassociate the elements From this diagram wigw ar
click Delete to completely remove the elements From the workspace.,

+ Click here to see the diagrams on which the elements appear.

7] [ Remove H Delete H Cancel ]

4 To show the removed lane(s) right-click the pool and select Show All Lanes.

ARTIFACTS

Artifacts provide additional information about the business process. Using artifacts allows you to
add non-standard elements to satisfy a specific need. Since you do not want to alter the basic
look-and-feel of a diagram, you can use artifacts to link to the existing events and activities
through Associations. Artifacts do not affect the basic Sequence Flow or Message Flow, nor do
they affect mapping to execution languages.

NOTE: If you are entering text in an annotation element, the autotype text box is closed by
pressing Enter.
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The current set of artifacts includes: data objects, groups, and annotations. The table below

describes the artifacts available from the Business Process Objects Palette:

Artifacts

Palette
lcon

Description

Data Object

Data objects provide information about how documents,
data, and other objects are used and updated in a Process.
They represent data so are defined by a combination of
entities or classes.

Data Objects are Artifacts because they do not directly
affect a Sequence or Message Flow. They provide
information on what activities are required or what they
produce.

Group

Use the Group symbol to visually organize activities.

A Group is represented by a rounded corner rectangle
drawn with a dashed border. The grouping can be used for
documentation or analysis purposes, but does not affect
the Sequence Flow.

Annotation

Textual annotation allows you to provide additional facts
and details about an element.

Text Annotations are used to provide additional information
for the elements of a diagram.

Off-Page
Connector

If a process model extends beyond the length of one
printed page you can use an Off-Page Connector to show
how Sequence Flow connections extend across the page
breaks.
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Conceptual modeling is used by enterprise architects, business users, and data architects to
model high-level business concepts and subject areas. A common usage of a Conceptual Model
is to relate this model to a Logical Data Model. However, it could include other elements like
data flow, process, or information assets in addition to more abstract interactions between
business 'things’, for example, areas of a business and their associations.

The example below shows a basic, high-level conceptual diagram. The main subject area is “US

Consumer Banking” and is made up of three other subject areas: “Lending”, “Online Banking”,
and "“Securities”.

*Loan Application Process *Enterprise Diagram X *Customer Conceptual Diagram

US Consumer Banking

Online Banking

You can add additional information for each subject area for this high-level diagram. For
example, you could expand the “Lending” subject area to view the Business Entities and their
attributes.
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*Loan Application Process *Enterprise Diagram *Cusktomer Conceptual Diagram

US Consumer Banking

Lending

Online Banking

" Customer |
Mame

Address

Credit Rating

Loan
Auka Loan
Haome Loan
RY Loan

CONCEPTUAL MODEL ELEMENTS

The table below lists the objects used in creating conceptual models.

Artifact Palette Icon Description
Subject Area @ A Subject Area is an abstraction of a particular

functional area identified in some manner by the
business, for example a Sales Organization or
Customer. It can also be a functional application
area (CRM system, etc.). It can be visualized as a
model object and/or used as a grouping
mechanism containing other business entities.

Business Entities @ Represents a core "object” of the business. Similar
in concept to a logical entity in Logical Data
Modeling, but at a higher level of abstraction. The
audience is often the business user, not a technical
data architect. Business Entities are used by data
modelers and business users to get basic
requirements and descriptions from the business.
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Artifact

Palette Icon

Description

Business
Attributes

=1

The properties of a business entity, for example, an
employee identification number.

Interaction

Interactions represent an action, process, or

transaction between two objects. For example,
“Customer” -> “Reviews Status of” -> “Orders”.
They are often expressed as action verb phrases.

A relationship between two things representing a
loose coupling or association. This is only
supported between like object types, for example
a Business Entity to a Business Entity. There are
four different types of relationships available:
Generic, Many-to-Many, Many-to-One, and One-
to-Many.

Relationship | ...

You will get an error message if you attempt to
create a relationship between a subject area and a
business entity.

Group P Use the Group symbol to visually organize

elements.

SUBJECT AREA

Conceptual Modeling allows Business Users to create high-level designs of the core “concepts”
and subject areas that drive the business, which can be passed onto data and process modelers
to drive more detailed logical and physical design. A Subject Area can reference a collection of
entities. You can embed the entities in the Subject Area, or you can have the Subject Area
reference a diagram with multiple entities.

® A Subject Area can be Create Mapping/Edit Mapping to other Conceptual Model diagrams.

e The Subject Area presentation element in the Diagram View can be shown as an oval or a
rectangle. You can set this as a global preference. You can also set the shape for each
individual Subject Area in its Property View. Double-click on a Subject Area, select the
Appearance tab in the Property View and then make your selection under the Shape option.

e Subject Areas can be expanded or collapsed. You can then view or hide Business Entities or
other Subject Areas within the parent Subject Area. Right-click in a Subject Area in the
Diagram View and select Show as Expanded. This is a toggle command.

® You can also elect to hide or show the expansion control in the Subject Area in the Diagram
View. Right-click the Subject Area and select Show Expansion Control. Depending on the
state of the element (expanded or contracted), a plus or minus symbol is placed in the
bottom center of the Subject Area. This is a toggle command. You can also choose to show
or hide the expansion control as a global preference.
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e \When a Subject Area is placed in the Diagram View, the label appears vertically centered.
Once you add a child element the label is then relocated to the top center of the Subject
Area.

® Once other Subject Areas have been placed within a Subject Area, these child items appear
on the Impact Analysis tab under the “Heritage” ({§§ ) heading. You can view this Impact
Analysis Report in the Property View for the Subject Area.

NOTE: When a Business Entity is placed within a Subject Area, this is a mapping action and
appears under the Mappings ([} ) heading in the Impact Analysis Report.

¢ The following example shows a simple, expanded Subject Area with three Business Entities.
Business Entities contain Business Attributes which are properties of that entity.

Customer

-,

Individual
Marne
Address
E-riail

Corporation
Coproration Mame
Locations

Group Identifier

v

Household
Marne
Home fddress
Phione Murmber

NOTE: To select multiple elements in the Subject Area, hold down the ALT key to invoke the
marguee Cursor.
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CREATE MAPPING

You can create mappings for Subject Areas to conceptual models, diagrams, and business
entities. You can also map to business process model diagrams. A Subject Area can reference a
collection of entities in a diagram, or specific individual entities. When a Conceptual model is
exported to ER/Studio DA, the Subject Area will be an ER submodel, and all the referenced
entities will appear under that submodel.

NOTE: All individual entities in a submodel are mapped, not just the model diagrams.
Also, you can create an Interaction mapping to a Business Process diagram. An interaction

represents an action, process, or transaction between two objects. Mapping an interaction to a
Business Process diagram provides a quick and easy way to view the mapped diagram.

Once you have created a mapping you can view, edit, or delete it.

Creating Subject Area Mappings
To create references from a Subject Area, use the Mapping functionality. There are three ways to
map:

Right-click the Subject Area node that you want to map in either in the Model View tree or
in the Diagram View and select Create Mapping.

OR

In the Subject Area Property View, select the Mappings tab and click , and the Create
Mapping dialog opens.

NOTE: Only the first level business entity is selectable. All nested business entities (i.e.,
business entity within a business entity) are grayed out and cannot be selected. When
you select a top level business entity all child business entities are selected as well. You
cannot map only to a nested (or child) entity. Once you have mapped a business entity,
you cannot delete only the nested entity. You must delete the first level business entity
which includes the nested entity.

OR

Drag and drop Business Entities into a Subject Area. When you drag a Business Entity on a
diagram into a Subject Area on a diagram, all contained entities are automatically mapped.
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Creating Interaction Mappings
To create references from an Interaction to a Business Process diagram, use the Mapping
functionality. There are two different ways to map.

1 Right-click the Interaction node that you want to map in either in the Model View tree or in
the Diagram View and select Create Mapping.

OR

In the Interaction Property View, select the Mappings tab and click , and the Create
Mapping dialog opens.

2 In this dialog, select the business process diagram from the tree and click OK.

Viewing the Mapping
You can view the results of your mapping three ways depending on what you mapped: (1) in the

Property View of the mapped object; (2) via the shortcut menu in the Model View tree; or (3) on
the Impact Analysis tab in the Property View.

e Open the Property View either by double-clicking the Subject Area or Interaction in the
Diagram View or selecting Properties from the shortcut menu in the Model View tree.
Then click the Mappings tab.

NOTE: When you double-click the mapped diagram in the Mappings tab of the Property View,
the diagram opens in the Diagram View.

® For a Subject Area, if you mapped to a diagram, right-click the Subject Area node in the
Model View tree or diagram and select Diagram Mapping. The pull-right displays all
diagrams that are mapped.

¢ To view an Entity's mapping, click the Impact Analysis tab in the Entity’s Property View to
see what Subject Areas map to it.

Editing a Mapping
Once you have created a mapping, you can then create more mappings or delete existing
mappings.
1 Right-click the Subject Area either in the Model View tree or in a diagram, select Edit
Mapping, and the Edit Mapping dialog opens. For a Subject Area, this dialog lists the

workspace, model, diagram(s), and all conceptual model elements for the selected subject
area. The elements mapped to the selected subject area are checked.

NOTE: When a business entity is grayed out, it cannot be cleared because it is graphically
contained by the subject area on one or more diagrams.

For an Interaction, right-click in the Model View tree or in a diagram and select Edit
Mappings. The Edit Mappings dialog lists the Business Process diagrams selected.

2 Deselect a checked element to delete the mapping. You can also delete a mapping using
the Property View.
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Select an unchecked element and when you click OK, a mapping is created between the
selected subject area and the checked element.

Deleting a Mapping

1

Open the Property View for the Subject Area or Interaction containing the created
mappings.

Select the Mappings tab to view the diagrams and/or entities that have been mapped.

Select the diagram and/or entity you want to remove from the mapping and click .

e |f you have nested entities, you cannot delete only the nested entity. You must delete the
parent-level business entity which includes the nested entity. If you select the nested
entity to delete, you will get a warning in the Property View.

e If you have an entity contained in a subject area on a diagram, you cannot delete the
mapping. You must remove the mapping by dragging the element out of the Subject
Area.

BUSINESS ENTITIES

A Business Entity is a high-level “container” for businesses/organizations. They can stand alone
or can be containers for other Business Entities or Business Attributes.

Business Entities can be expanded or collapsed. You can then view or hide other Business
Entities and Business Attributes within the parent element. Right-click in a Business Entity in
the Diagram View and select Show as Expanded. This is a toggle command.

You can also elect to hide or show the expansion control in the Business Entity in the
Diagram View. Right-click the Business Entity and select Show Expansion Control.
Depending on the state of the element (expanded or contracted), a plus or minus symbol is
placed in the bottom right-hand corner of the element. This is a toggle command. You can
also choose to show or hide the expansion control as a global preference.

When a Business Entity is placed in the Diagram View, the label appears vertically centered.
Once you add a child element the label is then relocated to the top center of the Business
Entity.

Once other Business Entities have been placed within a Business Entity these child items

appear on the Impact Analysis Tab under the “Heritage” ({#§ ) heading. You can view this
Impact Analysis Report in the Property View for the Business Entity.

Business Entities contained in a Subject Area in a diagram are owned by the model, not the
subject area.

NOTE: When a Business Entity is placed within a Subject Area, the Subject Area is
automatically mapped to the entity and appears under the Mappings (@) heading in
the Impact Analysis Report.
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The following example shows two Business Entities containing their related Business Attributes

for a shipping company. The two entities are connected with an Interaction showing a many-to-
many relationship.

4 Order M
Ship to Address
Bill ko Address
Crder Skaktus
Process Date

Ship Date
Y -
T
1
1
| Order Product
l
1
r:
d Product )
Product Mame
Product Type
Product Identification #
Description
. v

NOTE: To select multiple elements in the Business Entity, hold down the ALT key to invoke the
marquee cursor.
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BUSINESS ATTRIBUTES

Business Attributes are the low-level details (i.e., properties), of a Business Entity. You can quickly
add Business Attributes to a Business Entity by pressing the Insert key while the Business Entity
is selected. A new business attribute will be added at the bottom of the list or below a selected
Business Attribute. The following example shows the Business Entity “WEB CUSTOMER" with
seven Business Attributes for that customer. In this example the Expansion Control is displayed
in the lower right-hand corner of the entity.

(" WEB CUSTOMER
Cuskomer Mame

E-rmail Address

Credit Card Mumber
Address - Street
Address - City and State
Address - Country
Contack Phone Mumber

\ =

When working the Business Attributes you can:

Set Unique ldentifiers, which map to Keys in the ER logical model can be set.

Set the data type for the Business Attribute in the Property View and. The Data Types
available are high level: binary, BLOB/Image, boolean, char, CLOB/Large Text, Decimal,
Date, Integer, Time Stamp, Varchar, and XML.

Set the Optionality for an attribute. If you select Mandatory it becomes a “required”
property and a plus sign (+) appears to the left of the attribute. If it is optional, a minus sign
(-) appears to the left of the attribute. You can set a export and/or print under the Display
Options for Business Entities to always show the optionality indicator for Business Attributes.

Bind Business Attributes to Business Element or Domains in the Reference Objects node.
Scroll through the list of attributes in a Business Entity using the up and down arrows.

Reorder the Business Attributes within a Business Entity.

Reordering Business Attributes

You can reorder business attributes in a Business Entity.

1

2

Double-click the Business Entity that contains the Business Attributes you want to reorder.
This opens the Property View.

Click the Business Attributes tab of Business Entity property view.
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3 Select the attribute you want to move and click either the up arrow () or the down arrow
() to change the order of the attributes.

The change in order is reflected in both the Model View tree and in the element on the
Diagram.

SETTING UNIQUE IDENTIFIERS

You can set a unique identifier for a Business Attributes in the Conceptual model making the
entity unique. When exporting to ER/Studio DA, Business Attributes designated as unique
identifiers are created as entity attributes with the primary key set to True.

The CASE Method (Barker) notations are used as follows:

e Business Attributes, which are parts of the definition of a unique identifier, are shown
preceded by hash marks (#). You can show or hide this indicator, if desired.

e Relationships, which are part of the definition of a unique identifier, are marked by a short
line across the relationship near the entity being identified.

In the following example, the unique identifier of Line Item is a combination of the attribute
"Line No." and the relationship "part of one and only one Purchase Order." Since the marked
relationship represents the fact that each line item is partly identified by a particular purchase
order, it implies that the Purchase Order’s unique identifier "PO Number" participates in
identification of the Line Item as well. When implemented, a column derived from "PO Number"
is generated in the table derived from Line Item. It serves as a foreign key to the table derived
from Purchase Order, and is part of the primary key of the table that is derived from Line Item.

Line Item N Purchase Order
#Line Ma, part of #PO Mumber
Cuankity | Crder date
actual price |
3 &

Relationships

When you set a Unique Identifier for a Business Attribute, all relationships having the Business Entity
containing that Business Attribute as the source gets a new indicator. You can show or hide this
indicator, if desired.

NOTE: If another Business Attribute is set as a Unique Identifier, additional decorators are not
added.
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BINDING BUSINESS ATTRIBUTES TO BUSINESS ELEMENTS

In Conceptual Modeling, a Business Attribute can be “bound” to a Business Element to seed a
conceptual model. You can export and/or print a binding report.There are several different ways
of binding Business Elements to Business Attributes:

¢ Binding via Drag and Drop

¢ Binding from a Business Attribute

¢ Binding from a Business Attribute

The binding characteristics/limitations follow:
¢ A Business Element can be bound to a Business Attribute.

¢ You cannot bind both a Domain and a Business Element to the same attribute. You will get a
Bound Domain Warning dialog giving you the option to resolve the conflict.

® You can bind multiple Business Attributes to a Business Element in the same Business Entity.

e Once a Business Attribute is bound to a Business Element, changes to the properties (i.e.,
Name, Description, Notes, and Domain/data type) of the Business Element cascade to the
attribute. However, you can use the Override option if you want to change the enforcement
of those properties.

Binding via Drag and Drop

You can drag a Business Element from the Model View tree onto a Business Entity in the
Diagram View.

1 Select the Business Element you want to bind with a Business Entity.

2 Drag the Business Element from the Model View onto the Business Entity in the Diagram
View.

3 If the entity already contains a bound Business Attribute with the same name, the Duplicate
Attribute Exists dialog opens.
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& Duplicate Attribute Exists

The selected business entity already contains an attribute named ‘Aocount’,

What would you like ko do?

(%) Mame the new attribuke ‘Accountl’ and bind it Eo the business element 'Account’,
() Mame the new attribute "Sccountl’, but don't bind it ko the business element "Account’,

{:} Do nok create a new atkribuke,

[ ]oon't ask me again

®

e Select the first option if you want to bind the element to a new business attribute. This
action creates a new attribute with a unique name. For example, if your existing attribute
was “Element”, the new attribute would be “Element1”.

e The second option creates a new attribute with a new name but does not bind it to the
Business Element.

e Select the last option if you do not want to create a new attribute. This selection cancels
your drag and drop action.

Binding from a Business Attribute

To bind a Business Attribute to a Business Element:

1 Double-click a Business Attribute either in the Model View tree or in the Diagram View to
open the Property View.

2 Onthe General tab, in the Business Element Binding options box, click the drop-down arrow
in the Bound Business Element list box. All available Business Elements are listed.

3 Select the Business Element you want to bind the Business Attribute to.

NOTE: If a naming conflict exists, (i.e. duplicate names) the Duplicate Attribute Exists dialog
opens allowing you to resolve the conflict.

& Duplicate Attribute Exists

The selected business entity already contains an attribute named 'BE One'. |

what would you like to do?

¥ Eind this attribute to the business element 'BE One', |

™ Do not bind this attribute ta the business element 'BE One',

@
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4 You can choose to override the properties of a bound Business Attribute (Name,
Description, Notes, and Domain/data type) with the changes you make in the Business
Element. For example, you can change the Data type setting of “Account” as shown in the
following screen shot. Because the Domain/datatype enforcement option is selected in the
Enforcement options box, that value is propagated to the bound Business Attribute.

i u—
& Account 53 o Fl.l:l:l:uunq
@& Business Element: Account

' ame:

General
Descripkion Diamain: Im
lotes

Eindings Eata bype: |B-:u:ulean ;I]

Lirks
Usage (CRUD) —Enforcement options
Irmpact Analysis Enforce these properties when binding to business attributes:
MName
Description
MNotes
(_ Domaindata tgpe-]

When you open the Property View for the bound Business Attribute, notice that the Data
type setting is now the same as the “Account” Data type setting.

5 If you change any of the properties in the bound Business Attribute a violation occurs telling
you that one or more properties of the Business Element and the Business Attribute no
longer match. For example if you changed the Data Type to “Decimal” in the Business
Attribute, a violation notice appears in the Bindings hierarchy. Click Bindings and notice that
a "Data Type Violation: Decimal” warning appears in the hierarchy.
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i —
O ElementCne &3

O Business Attribute: ElementOne

General Mame: Elementlne  Daka bype: Char Widkb: 0
Descriptian Description: <kone>  Nokes: <RMone=
Mokes
Bindings = “'33" Bindings
Links EEHE Reference Objects
=g Business Elements
Ilzage (CRUDY

El" ElementCne

Impact Analysis B (15t Type Yidlation: Decimal

Appeatance

+F X EEEE

6 You can choose to resolve the violations by clicking | ifk |. Violations do not have to be
resolved and are left in the Bindings hierarchy as a reminder of the changes you made.

Viewing the Binding

There is no visual indicator on the diagram showing that a Business Element has been bound to
the Business Attribute. However, you can view the binding either from the Business Attribute or
from the Business Element via their Property Views:

* When you double-click the bound Business Attribute, the Property View for the attribute
opens. Click Bindings and the bindings hierarchy is shown under the Bindings heading
(=@=). This hierarchy shows the Business Elements the Business Attribute is bound to.
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i
O Accourt Balance &3

O Business Attribute: Account Balance

General Mame: Account Balance  Daka kype: Mone Widkbs 10
Description Description: <Mone>  Motes: <Mone>=

Mokes

Bindings = "EF Eindings

Linke El--m Reference CObjects

El‘ Business Elements
LeaocyCRLD) &= ¥.ccount Balance

Impact Analysis

Appearance

+ =2 EE EE ] S

¢ When you double-click on a Business Element, the Property View for that element opens.
Click Bindings to view the attributes bound to an element.

-
& Account Balance #2

@& Business Element: Account Balance

eneral Mame: Accounk Balance  Daka kype: Mone

Descriptian Description: <Mone>=  Moktes: =PMonex

Mokes

Bindings = ’*‘ﬁ" Bindings

Linke El@- Enterprise architecture Initiative
= Business Concepts

Ilzage (CRUDY

ElD Business Enkity
Impact Analysis - 0 pccount Balance
Ell:l #ccount

Binding from a Business Element

To bind a Business Attribute from a Business Element:

1 Double-click a Business Element either in the Model View tree or in the Diagram View to
open the Property View.

2 Click the Bindings tab to open the Bindings hierarchy page.
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3 Click and the Creating Binding with Targets... dialog opens. All Business Entities and
their associated unbound Business Attributes are listed.

NOTE: If a binding has already been created, the Add Target to Binding... dialog opens.

4 Select the target (i.e. attribute) you want to bind with the Business Element and click OK.

NOTE: If you attempt to bind an attribute that is already bound to a Domain, you will get a
Bound Domain Warning Dialog.

. Bound Domain Warning

P Attributes cannot be bound to both business elements and domains. IF vou
\4\-/ want ko add domain information bo a business attribute, wou can do this by
setking a domain on the bound business element from its properties view,
Otherwise, yau can remove the binding ta the domain and bind this attribute
ko the selected business element.

Do wou wank to remove the binding to the domain and bind this attribute ko
the selected business element?

[ Don't askme again

[ ‘fes l [ Mo ]

5 In the Property View for the Business Element, click Bindings to view the Bindings
hierarchy.
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Using the Override Option

When binding Business Attributes to Business Elements you can choose to enforce some or all
of the properties of the Business Element to the Business Attribute.

1 Create a Business Element and select the properties you want enforced when binding to
Business Attributes. In the following example, when you bind a Business Attribute to
ElementOne, the Name and Domain/data type properties will be enforced on the Business
Attribute. The Description and Notes properties of the Business Elements will not be
enforced.

' u—
@ Elementone 52 o ElementOnew

& Business Element: ElementOne
I

Mame; | AE=ae=

General

Descripkion Domain: IN:::ne 'I

Motes

Bindings Daka bype: |Bu:u:-|ean |

Liriks

Usage (CRUD) rEnforcement options

Impact Analysis Enforce these properties when binding to business attributes:
Mame
[ pescription
D Maotes

Domainfdata kype

2 However, when you bind the Business Attribute to the Business Element, you have the
option to override the enforced properties. In the following example notice that in the
Business Attribute Property View, the Description and Notes options are greyed out. Also
notice that the Name and Data type list boxes are not available.
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JE Elementne &3

s Aty

Mame: |ElementOne

| Unigue identifier: [J

_rlzilata bvpe: IBDD|EE|I‘| j| ]
T 0
B Scale: 1]
_ Optionality:
: rBusiness element binding options —Domain binding opkions
— || Bound business element: IEIementOne L” Bound domain: INDI'IE vl
Bound business element domain: :I Crverride the Following properties of the domain:
D Data tvpe
Cwerride the Following properties of the business element; O width and scale
O tame O optionality

O Description

D MNotes

[ oomain/data kype

3 If you want to override any of the available properties, select that option in the Business
Element binding options. For example, if you selected the Domain/data type option, the
Data Type list box becomes available and you can change the setting.

4 Once you override a property and click on the Bindings tab, a violation notation appears in
the hierarchy telling you that the properties of the Business Attribute and the Business
Element no longer match and what that mismatch is.

F
O Elementons &3

O Business Attribute: ElementOne

Gaeneral Mame: Elermentlne  Data bype: Char Widkb: 0 Scale: 0 !
Description Description: <Mone=  Motes: <Mone:

Mokes

Bindings = “ﬁ" Bindings

Linke =1} Reference Objects

Ele Business Elements

Usage (CRUD) El" ElermentOne
Impact Analysis P

& Data Tvpe Violation: Decimal

Appearance
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BINDING BUSINESS ATTRIBUTES TO DOMAINS

In Conceptual Modeling, a Business Attribute can be “bound” to a Domain to seed a
conceptual model and enforce data type standards. You can export and/or print a binding
report.There are several different ways of binding Domains to Business Attributes:

¢ Binding via Drag and Drop

¢ Binding from a Business Attribute

¢ Binding from a Domain

The binding characteristics/limitations follow:
e A Business Attribute can be bound to a Domain.

¢ You cannot bind both a Domain and a Business Element to the same attribute. You will get a
Bound Domain Warning dialog giving you the option to resolve the conflict.

E 3 Bound Domain Warning

0 Atkribukes cannot be bound to both business elements and damains, IF you
\._4-(’ want ko add domain information to a business aktribute, vou can do this by
sekting a domain on the bound business element From its properties view,
Otherwise, wou can remove the binding to the domain and bind this attribute
ko the selected business element.,

Do wou want to remove the binding to the domain and bind this attribute to
the selected business element?

[T Don't ask me again

[ es ] [ Mo

¢ You can bind multiple Business Attributes to a Domain in the same Business Entity.

e Once a Business Attribute is bound to a Domain, changes to the properties (i.e., data type,
width and scale, and optionality) of the Domain cascade to the attribute. However you can
use the Override option if you want to change the enforcement of those properties.

Binding via Drag and Drop
You can drag a Domain from the Model View tree onto a Business Entity in the Diagram View.

1 Select the Domain you want to bind with a Business Entity.
2 Drag the Domain from the Model View onto the Business Entity in the Diagram View.

3 If the entity already contains a bound Business Attribute with the same name, a new
attribute is created with a unique name. For example, if your existing attribute was
“Domain”, the new attribute would be “Domain1”.
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Binding from a Business Attribute

To bind a Business Attribute to a Domain:

1 Double-click a Business Attribute either in the Model View tree or in the Diagram View to
open the Property View.

2 Onthe General tab, in the Domain Binding Options group box, click the drop-down arrow in
the Bound Domain list box. All available Domains are listed.

3 Select the Domain you want to bind the Business Attribute to.

4 You can choose to override the properties of a bound Business Attribute (data type, width
and scale, and optionality) with the changes you make in the Domain. For example, you can
change the width setting of “DomainOne” as shown in the following screen shot. Because
the Width and Scale enforcement option is selected in the Enforcement options box, that
value is propagated to the bound Business Attribute.

-
11 oomain one 52

[l pomain: Domain One
I

Marme: | Domain one

General

Descripkion Daka kype: | Yarchar LI
Motes width:

Bindings Scale: ]

Impact Analysis Optionality: I Mone - I

rEnforcement options

Enforce these properties when binding ko business attribukes:
Daka bype
Cpkionality

When you open the Property View for the bound Business Attribute, notice that the Width
setting is now the same as the Domain One width setting.

5 If you change any of the properties in the bound Business Attribute a violation occurs telling
you that one or more properties of the Domain and the Business Attribute no longer match.
For example if you changed the Data Type to “Binary” in the Business Attribute, a violation
notice appears in the Bindings hierarchy. Click Bindings and notice that a “Data Type
Violation: Varchar” warning appears in the hierarchy.
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i —
I pomain ore | O Business Attribute 53

O Business Attribute: Business Attribute

GaEneral Mame: Business Attribute  Daka kype: Binary Wyidkb: 100
Description Descripbion: <Mone=  Motes: <konex>
Mokes
Bindings = ”'EF Bindings
Links Elm Reference Objects
= oomains

IJsage (CRLUDY

Impack Analysis

EI{]]] Damain One
O @ == Tvpe Wiolation: Yarchar

Appeatance

HE1REE qﬁh/-D

6 You can choose to resolve the violations by clicking | /14 [. However, violations do not have to

be resolved and are left in the Bindings hierarchy as a reminder of the changes you made.

Viewing the Binding
There is no visual indicator on the diagram showing that a Business Attribute has been bound to

a Domain. However, you can view the binding either from the Business Attribute or from the
Domain via their Property Views:

* \When you double-click the bound Business Attribute, the Property View for the attribute
opens. Click Bindings and the bindings hierarchy is shown under the Bindings heading
(=@ ). This hierarchy shows the Domain(s) the Business Attribute is bound to.

-
O Business Attribute &3 11 DDmainDne}

O Business Attribute: Business Attribute

General Mame: Business Atbribube Daka bypes
Diescription Description: <Mone=  Motes: <Mone:
[okes
Bindings = “W‘ Bindings
Links Elm Reference Objects

=1 Domains
Usage (CRUD) [l]] DarnainCre

Impact Analysis

Appearance
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® When you double-click on a Domain, the Property View opens. Click Bindings to view the
attributes bound to the Domain.

'
O Business Attribute ﬁ]]] ComainCne &3

Il bomain: DomainOne

General Data bype: Varchar  SWidths 0 Scale: O
Descripkion
[= =% Bindings
Motes El@- Conceptual Project
Bindings - Conceptual
Impact Analysis EID Business Enkityl
O Business Attribute

Binding from a Domain

To bind a Business Attribute from a Domain:

1 Double-click a Domain either in the Model View tree or in the Diagram View to open the
Property View.

2 Click the Bindings tab to open the Bindings hierarchy page.
3 Click and the Creating Binding with Targets... dialog opens. All Business Entities and
their associated Business Attributes and Domains are listed.

NOTE: If a binding has already been created, the Add Target to Binding... dialog opens.

4 Select the target (i.e. attribute) you want to bind to the Domain and click OK.

NOTE: If you attempt to bind an attribute that is already bound to a Business Element, you will
get a Bound Domain Warning dialog.
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) Bound Domain Warning

b Attribukes cannok be bound to both business elements and domains, IF wou
\t‘/ want o add domain information to a business attribute, vou can do this by
setting a domain on the bound business element from its properties view,

Otherwise, vou can remove the binding to the domain and bind this attribute
ko the selected business element,

Lo wou want to remove the binding to the domain and bind this attribute to
the selected business element?

[T Don't ask me again

[ ‘s l [ Mo ]

5 In the Property View for the Domain, click Bindings to view the Bindings hierarchy.

Using the Override Option

When binding Business Attributes to Domains you can choose to enforce some or all of the
properties of the Domain to the Business Attribute.

1 Create a Domain and select the properties you want enforced when binding to Business

Attributes. In the following example, when you bind a Business Attribute to DomainOne, the

Data Type and Optionality properties will be enforced on the Business Attribute. The Width
and Scale properties of the Domain will not be enforced.

r
[l]] ComainCne &3

[l Domain: DomainOne
I

Marme: | Domaincne

General

Description Data bvpe: |'u'aru:har x|
Motes Width: ]

Bindings Srale: i

Impact Analysis Optionality: I None - I

—Enfarcement opkions

Enforce these properties when binding to business attribubes:
Daka bype
[ width and scale
Optionality
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2 However, when you bind the Business Attribute to the Domain, you have the option to
override the enforced properties. In the following example notice that in the Business
Attribute Property View, the Width and Scale option is greyed out. Also notice that the Data
type and Optionality list boxes are not available.

Mame: | Business Akkribuke

Unigue identifier: ]

Daka bvpe: ﬂ'-.-'arn:har ;I]

wiidth: 0
Scale: n

Cpkianality: I Mone - I

rBusiness element binding options — Domain binding opkions

Bound business element: |N-:une j Bound domain: IDDmainOne vI

Cwerride the Following properties of the domain:

Bound business element domain:
D Data type
Creerride the Following properties of the business element: (D Width and scal_e-]
O rame O optionalicy

O Description

D Motes
O Domaingdata kype

3 If you want to override any of the available properties, select that option in the Domain
binding options. For example, if you selected the Data Type option, the Data Type list box

becomes available and you can change the setting.

4 Once you override a property and click on the Bindings tab a violation notation appears in
the hierarchy telling you that the properties of the Business Attribute and the Domain no

longer match and what that mismatch is.

= =% Bindings
Elfm'; Reference Chjects
El[l]] Damains
El[l]] Damain2ne
- A Data Type violation: Warchar

PRINTING AND EXPORTING BINDINGS
You can print or export binding resolutions as a report. You could have several hundred items
that were overridden and want to see that information in another file or printed to paper.
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Export Bindings Report
To export a Bindings Report:

1 On the Bindings tab of a business element containing bindings or a bound business
attribute, click 3.

2 Inthe Export dialog, select the workspace where you want the report created.

3 The default report name is based on the name of the business attribute. You can edit this
name.

4 In the Save as Type text box, select the format from the drop-down list. Your options are:
html, pdf, and rtf.

5 Click Save and the report is generated.

6 To view this report, go to the directory where it was saved and double-click on the report
name.

Print Bindings Report
To print a Bindings Report:
1 In the Bindings tab of a business element containing bindings or a bound business

attribute, click =.

2 In the Print dialog, select the Printer and click OK.

INTERACTION

An interaction represents an action, process, or transaction between two objects. These
interactions are often expressed as action verb phrases. The verb and inverse verb phrases can
be added using the Property View and then displayed in the Diagram View. You can also create a
mapping from the Interaction to a business process diagram.

You can set line style, line thickness, end point selection, and begin point selection for the
Interaction in the Property View. You can also set global preferences for all the line display
options in the Preferences.
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The following diagram shows two interactions between the Business Entities. The “Shop in
Store” interaction displays the verb and inverse verb phrases that were added in the Property
View for that Interaction.

Shop in Store

CLSTOMER. validates|PRODUCT Purchase via web PRODUT is validated by CUSTOMER
CUSTOMER PRODUCT )
Tarne Lapkop Computers
Address CPU's
Web Address Monitars
A
RELATIONSHIP

Relationships can only be defined between common object types. For example two business
entities can have a relationship, but a business entity and a subject area cannot.

You can set Relationship properties using the Property View. These properties include the
following:

¢ You can add verb and inverse verb phrases which are then displayed in the Diagram View.
® You can set the optionality of the relationship.
® You can choose one of four different relationship types:

e Generic (). You can customize the end points using the Line Display Options in the
Appearance tab of the Property View.

* Many-to-Many (%)

® Many-to-One ()
® One-to-Many (—«)

e The selection you make is reflected on the beginning and ending indicator on the
relationship.

® You can set line style, line width, and source/target decorator size for the Relationship in the
Property View under the Appearance tab.

® You can also set global preferences for all the line display options in the Preferences.
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The following diagram shows a one-to-many relationship with an optionality setting of
Mandatory to Optional between two related Business Entities.

- ORDER ) . PRODUCT A
Ship ko Address Produck Marme
Bill ko Address Product Type
Crder Stakus Category
Ship Date Descripkion
—————— —_ =
% » N y

Setting the Optionality of a Relationship

Split-line notation appears when you set source/target optionality on a Conceptual Model
relationship. The line display depends on the optionality selected for the relationship. The
following options are available:

e Optional to Mandatory
* Mandatory to Optional
e Optional
e Mandatory
To set the optionality of a relationship
1 In the Diagram View, double-click the Relationship to open the Property View.
OR

In the Model View, double-click either the Outgoing Relationships or Incoming
Relationships icon (- ) located in either the target or source elements to open the
Property View.
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294

Conceptual Diagram

Ship to Address

Bill to Address

Crder Stakus

- Ship Datke

[=-@+ Cukgoing Relationships
[

(&) proDUCT

=-{&) ProDUCT

@ Product Mame

Product Tvpe
Zakegory

Description

=43 Incoming Relationships

[ s s

Select the Relationship Type from the drop down list and the Relationship display in the
Diagram View changes to reflect the type chosen.

Select the Optionality from the drop-down list and the split-line notation displayed reflect
the optionality chosen.

You can customize the end points using the Line Display Options in the Appearance tab of
the Property View.
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ER/Studio BA Tools outlines how to use the tools and features. The table below describes the

different sections of this chapter:

Topic

Description

Create Diagram from
Selected Elements

This function gives you the ability to create diagrams from both
Business Process and Conceptual Model elements that exist on
the Model View tree or on a diagram.

Find The Find functions give you the ability to find information in
the current diagram.

Search A Search dialog lets you search for elements, or specific text in
descriptions and notes. You can filter the search parameters
and view the results in the Search Results view.

Links There are two wizards that walk you through the creation or
editing of a link relationship between elements.

Usages There are two wizards that walk you through the creation or

editing of a usage relationship between elements.

Impact Analysis Diagram

This is a graphical representation of the links or usages you
created. You can also update an existing diagram.

Grid Editor The Grid Editor is a spreadsheet-like display format used as an
alternative to the Tree view. This is valuable for displaying large
numbers of objects or business-related textual objects, such as
business rules. Grid Editors can be printed or exported as a
report in csv, html, pdf, and rtf formats.

Reports Note: There are two main reports in ER/Studio BA: the Impact
Analysis Report and the Web Report.

Views Views support editors and provides alternative presentations

as well as ways to navigate the information in ER/Studio BA.

CREATE DIAGRAM FROM SELECTED ELEMENTS

You can create new diagrams from existing model objects for both Business Process and
Conceptual diagrams. To do this, you can select model elements in the Model View tree or right-
click on elements in an open diagram. You can then create a diagram from the selected
elements. This command is also available on the Tools main menu.

NOTE: The newly-created diagram is displayed in the Model View tree with the elements

displayed as presentation elements, which is indicated by a special marker on the

element icons ({g)).

Specific rules apply to both the Business Process Model and Conceptual Model diagrams. The
following rules apply in general to the creation process:
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* Any combination of Reference Objects or External Data Objects can be selected and added
in combination with Business Process or Conceptual Model elements, with the following
exceptions: (1) Business Process triggers; (2) External Data Object attributes, columns, and
data elements; and (3) Reference Object Domains.

® The Create Diagram from Selected Elements command is disabled when an invalid
combination of elements are selected. Those invalid combinations include:

e Combinations of Business Process or Conceptual Model elements

e Elements from more than one model (with the exception of Reference and/or External
Data Objects).

¢ Selections which include items which cannot be displayed on a diagram.
e Elements which cannot be created on a diagram.

® When creating a diagram from selected elements, relationships are discovered on the new
diagram. However, a relationship can only be discovered when both the source and target
nodes are selected when creating the diagram.

Creating Business Process Model Diagrams

When creating a diagram from Business Process Model elements, only one diagram can exist in
a Business Process model that shows a private (internal) process (i.e., without pool/lanes). A new
Business Process diagram can be created using this command when the following conditions are
met:

e This command is only available for pools in a Business Process model and only pools in the
same model can be selected.

e This command is not available for a combination of elements in different models.

® Elements of the same process are selected, where there is not already an existing diagram
representing that abstract process.

¢ All Reference Objects and External Data Objects can be selected and included when
creating a diagram.

Creating Conceptual Model Diagrams

New diagrams can be created from existing Business Entities, Subject Areas. and Groups,
assuming they are all in the same model. All Conceptual Model elements can be selected to
create a new diagram, with the following clarifications:

e This command is available for Business Entities, Subject Areas, and Group, but not for
Business Attributes or Relationships.

e If only Subject Areas, Business Entities, or Groups are selected, the relationships are
discovered and drawn.

e If Interactions and Relationships connecting elements are selected, they are also included
on the diagram.
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e |f a connecting element is selected without a target or source element, the source and target

element are discovered and included on the diagram.

Using the Create Diagram from Selected Elements Command

1

Right-click on a selected element in either the Model View or an open diagram and click
Create Diagram from Selected Elements.

NOTE: Hold down the CTRL key to select multiple elements, for example a Subject Area and
a Business Element.

2 In the New Diagram dialog, enter the new diagram’s name and description.

NOTE: Inthe New Diagram dialog, the available model(s) depend on what model elements
are selected. For example, if only pools are selected, the pool’s model is the only
model available. If only reference objects are selected, all models are available.

3 Click OK, the New Diagram dialog closes and the newly-created diagram opens in the
Diagram View area. The diagram also appears in the Model View tree under the model node
you specified when you created the diagram.

FIND
The Find function has two different ways to find elements: Finding in Diagram and Finding in
Model View.

Finding in Diagram
This option lets you search for an object name in an active diagram. The found element is then
highlighted in the diagram.

1

On the Main menu, select Edit > Find in Diagram... or press CTRL+F and the Find dialog
displays.

Enter the name of the element you want to find. This searches for any element in the current
diagram

You can select the options to match whole words only or match case at this point.

NOTE: “Match whole word only” looks for a full match. If you want to do a partial match, you
would keep this unchecked. Also, the “Match case’ option looks at case.

Select the direction you want to search. In this case direction means up or down, searching
an internal list that is created when the Find operation starts.

NOTE: If multiple elements are found, the Find Next command selects the next match based
on the direction you have indicated.

Click OK and the found object is centered and highlighted in the Diagram Area.
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e |f a search item is not found, a Message dialog opens telling you that there are no elements
on the diagram that meet the search criteria.

e If you have found all items in that diagram you will get a message that there are no more
elements on the active diagram meeting the search criteria

Finding in Model View

This function lets you quickly locate an element on an active diagram in the Model View tree.

Right-click an element in the Diagram Area and click Find in Model View or click CTRL+H.
The element is highlighted in the Model View tree.

SEARCH

You can do an advanced search of the workspace using this function. Once a search is complete
a Results View appears with all matches listed. On this view, you can find where an element
resides in the workspace and on which diagram(s) (opened and closed) they appear.

1 Select Edit > Search or press CTRL+E to open the Search dialog.
2 The table below describes each field of this dialog:

Field Description

Find What Enter the name of the item you want to
search for. A drop-down arrow gives
you access to the last ten search
strings. You can set a preference for
the number of entries in this list.

Find Click Find to start the search. This
button is not enabled if the search
string is blank.

Match Case The search matches the exact case of
the search string.

Match whole words only The search matches a whole word, not
partial search strings.

Search In... You can choose what you want
included in the search: Entire
workspace, or specific projects,
models, and data sources.

Look For Select an type of items you want to
look for: Names (of elements),
Descriptions, or Notes.
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Field Description

Limit To You can choose what types of elements
should be searched. This filter limits
what types should be included in the
search. You have the following options
in this tree:

Expand.: Click [+ to expand all
nodes of the tree.

Collapse: Click |=] to collapse all
nodes of the tree.

Select All: Click #, to select all
nodes of the tree.

Clear All: Click to clear all
selections made in the tree.

Restore Defaults You can click Restore Defaults =
to reset all the values back to 'Fu
their original settings.

3 Once you made all your settings in the Search dialog, click Find. A progress dialog may or
may not be shown depending on the time it takes to do the search.

4 Once the search is complete, a Search Results view opens.

Search Results View

This view opens automatically after a search is completed if it isn't already displayed. A Search
Result Count header displays the number of found items. The table displays five columns:

Column Description

Name Name of the element you searched for.

Type Element type

Description Displays the descriptive text for the
element.

Notes Displays the note text for the element.

Parent The element’s owner. This is required if
multiple elements appear with the
same name.

You can gain access to the commands for the View either through a shortcut menu or the
toolbar.

NOTE: You can set preferences for the number of elements to return, as well as what columns
you want to be displayed.
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Using the Shortcut Menu

1 Right-click on a populated row in the Search Results view and the following commands are
available to you:

Shortcut Menu Item Description

Name, Type, Description, Notes | By default, all columns are displayed. These are
toggle settings, so you can select or deselect which
columns you want displayed.

Open Search Dialog Opens the Search dialog so you can specify a new
search or modify your existing search.

Find In Opens a pull-right menu with the following
commands:

Active Diagram: This command finds and
highlights the selected search item in the active
diagram. This command is not available if the element
exists only in the Model View.

All Diagrams: This command searches for the
selected search item on all diagrams in the model.
The Diagram Usage dialog opens displaying all the
diagrams where the element appears. Select the
diagram you want to open and click OK.

Model View: Finds the selected search item in the
Model View tree.

Run Previous Search The pull-right menu displays the previous searches.
Up to ten searches are listed. You can also select the
Clear History option.

Filter Results Opens the Search Results Filter dialog. Use this to
refine the search. You can select which types of
objects you don't want to see in the Results view. You
can expand or collapse the tree. You can also select or
deselect all the tree node items.

Customize Columns Opens the Customize Columns dialog where you
select the columns you want displayed in the Search
Results view.

Properties Opens the Property View for the selected search item.

2 Double-click on a search results row and the associated property view is displayed.

Using the Toolbar

The following commands are available in the Search Results view toolbar:

Command Icon Description

Search ) Opens the Search dialog so you can
specify a new search or modify your
existing search.
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Command Icon Description

Find in Model View

Click this icon to find the selected
search item in the Model View tree.
This command is not enabled if the
item isn't in the Model View (for
example it is filtered, not shown, etc.).

Find in Active Diagram This command finds and highlights the

selected search item in the active
diagram. This icons is enabled only if
there is a diagram open and
something is selected in the Search
Results view.

If the selected search item is not found
on the active diagram, a dialog opens
telling you the element is not found.
You are given the option to search for
the element on other diagrams. If you
click Yes, the Diagram Usage dialog
opens.

This command searches for the
selected search item on all diagram in
the model. The Diagram Usage dialog
opens displaying all the diagrams
where the element appears.

Find in All Diagrams

B

Open Property View Opens the Property View for the

selected search item. You can also
open the Property View by right-
clicking on the search item and
selecting Properties.

Run Previous Search a Click the drop-down arrow on this icon
v to display the previous searches. The
settings are included with the search
name so you can remember what was
searched. Up to ten searches are listed.

Filter Results \,_fsl Opens the Search Results Filter dialog.

Use this to refine the search. You can
select which types of objects you don't
want to see in the Results view. You can
expand or collapse the tree. You can
also select or deselect all the tree node
items.

LINKS

With a link you create a representation of a relationship between elements. These elements can
consist of reference objects, data objects, and elements (including lanes) within a diagram. You
can link the Individual Elements (attributes, columns, and data elements) contained in an
External Data Objects.
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Once you create links you can edit the link and create an Impact Analysis Diagram displaying the
link relationships with source and target elements.

NOTE: When you create a link, the wizard creates a one-to-many relationship.

Creating a Link
1 In the Model View tree, right-click an element (i.e., project, model, pool, lane, or element)

and select Links > New .

OR

On the main menu select Tools > Create Link and the Create Link Wizard opens for the
selected element in the diagram.

OR

Right-click an element in the diagram and select Links > New to open the Create Link
Wizard.

OR

Double-click the selected element to open its Property View. Select the Links tab and then

click to open the Create Link wizard.

NOTE: You can also draw a link between two elements by using the Link icon (&= ) on the
Reference Objects palette.

2 In the Create Link dialog, you can specify the details for the new link:

Detail Description

Target Elements

Target Elements tree Lists all available target elements. Only the elements appearing in
the Model View tree and/or diagram are available to be selected.
Select the target element(s) you want to link with your originally
selected source element. The tree includes the following elements:
Business Process Modeling, Conceptual Model, External Data
Objects, Projects/Models/Data Sources, and Reference Objects.

Filter button Click this button to select the types you want included in the list of
Target Elements. You can include/exclude the following types:
Business Process Modeling, Conceptual Modeling, External Data
Objects, Reference Objects, Shapes, and Projects/Models/Data
Sources.

You can click Restore Defaults to reset all the values backto =
their original settings. |
Once you make your selection and close the Filter dialog, the label
for the Target Elements list box now indicates the list is filtered.

Expand All button Expands all the nodes in the Target Elements list box.

Collapse button Collapses all the nodes in the Target Elements list box.
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Detail Description

Link Properties

Name Enter the name for the link you are creating.

Verb Phrase Type a verb phrase that describes the relationship from the
perspective of the source. For example: EMPLOYEE "owns"
RESUME. This label appears on the link where it connects to the
source.

Inverse Verb Phrase Type a verb phrase that describes the relationship from the
perspective of the target. For example: RESUME "is owned by"
EMPLOYEE. This label appears on the link where it connects to the
source.

Description You can enter a description of the link you are creating. A shortcut
menu is available with the following commands: cut, copy, paste,
delete and select all. The Undo command is also available. You can
cut, copy and paste text from other applications and other dialogs
to the Description text box.

Notes You can enter additional information in this text field. A shortcut
menu is available with the following commands: cut, copy, paste,
delete and select all. The Undo command is also available. You can
cut, copy and paste text from other applications and other dialogs
to the Notes text box.

3 Once you have specified all the details for the new link click OK. You can view this newly
created link four different ways:
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e Create an Impact Analysis Diagram.

e Right-click either the source or target element in the diagram and select Connections >
Show > Links.

NOTE: If you have created links between elements that exist in two different processes (for
example, in two different diagrams in a workspace or in two different pools), the Show
> Links command does not display those links.

¢ Click the Impact Analysis tab in the either source element, target element or link Property
Views.

e The created link appears in the Model View tree as a separate folder. In the following
example the subject area “Lending” has an outgoing “link” relationship to the subject
area “Securities”.

Fg Hiodel

T
[
[+
J
<

= Banking Processing
= ﬁ U5 Consurnet Banking
ﬁ Modelone
Customer Conceptual Diagram
Entetprise Diagram
|:| Account
|:| Business Enkiky
|:| Cuskomer
D Geographic Location
D Loan
D Parky
I:l Salary
[=1-4 US Consumer Banking
=5 Lending
[=-3+ Cukgoing Relationships
= Lirik,
4 Securities
4 Onling Banking
O Securities

4 You can show the link label by right-clicking on the link and selecting Show > Name.

5 If you entered a Verb Phrase and/or an Inverse Verb Phrase you can also display them by
right-clicking the link and selecting Show.
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Connecting Links to Lanes

You can also connect a link to a lane in a pool.
1 Click Link (@= ) on the Reference Objects palette.

2 Click on the object you want to connect to the lane and then click in the lane. The following
rules apply as to where you click in the lane:

® Draw the link directly to the Lane Header / Name Label to connect to the lane.

® |n order to connect to a lane, the link must be connected closer to the center or inner
edge of the lane. Attempting to connect to the upper (or left) portion of the lane will
connect to the pool instead.

The following example shows where you would need to click to connect to a lane. (note
where the cursor is in the following illustration).

Task

Fooll

%@

Once you click in the lane, the link connects to the border of the selected lane.

Task

Pooll
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Editing Links
You can edit links either through the Edit Links dialog or by using the Link’s property view.

1 To open the Edit Links dialog, right-click the target element or source element in the model
view tree and select Link > Edit. Select the link you want to edit from the pull-right menu
displaying the name(s) of the links.

2 To open the property view, double-click the link you just created, either in the Model View or
in the diagram, and the Property View for that link opens. You can edit the following
properties of the link on the General tab.

3 The dialog box and the property view contain the same properties which can be edited.
However, they are displayed in different formats. The following properties can be edited:

Name Displays the names of the two linked elements.

Verb Phrase Type a verb phrase that describes the relationship from the
perspective of the source. For example: EMPLOYEE "owns"
RESUME. This label appears on the link where it connects to the
source.

Inverse Verb Phrase Type a verb phrase that describes the relationship from the
perspective of the target. For example: RESUME "is owned by"
EMPLOYEE. This label appears on the link where it connects to the
target.

4 You can add a description of the link in the Description tab of the Property View and add
additional information under the Notes tab.

5 You can edit the target element by clicking on the Source and Targets tab. The

Property View for the selected element opens as a tabbed view.

Drawing a Link

Instead of using the Create Link wizard, you can create a link in the Diagram View using the link
icon (@® ) in the Reference Objects palette or Reference Objects toolbar.

1 Click the drop-down arrow on the Reference Objects palette and select &= Link, or select

from the Reference Objects toolbar.

2 Click the element that is the origination or source of the link.
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3 Click the element that you want the first element linked to (i.e., the target) and a link is
created. Link icons are placed on the elements at the beginning and ending of the link.

Task

Lirk,

Task1

USAGES

You can show the create, read, update, or delete database attributes on a connection. When this
connection is created they are labeled with the attributes you selected at the time of creation.
These elements can consist of reference objects, data objects, and elements within a diagram.
Once you create these usage indicators, you can edit and export the usage. You can also create

an Impact Analysis Diagram displaying the created usage.

NOTE: When you create a usage, the wizard creates a many-to-one relationship.

Creating a Usage
1 In the Model View tree, right-click an element (i.e., project, model, pool, lane, or element)
and select Usage (CRUD)> Y, New.
OR

On the main menu select Tools > Create Usage and the Create Usage Wizard opens for
the selected element.

OR

Right-click an element in the diagram and select Usage (CRUD) > New to open the Create
Usage Wizard.

OR
Double-click the selected element to open its Property View. Select the Usage (CRUD) tab
and then click to open the Create Usage wizard.

NOTE: You can also draw a usage between two elements by using the Usage icon (U,) on the

Reference Objects palette.

ER/STUDIO® BUSINESS ARCHITECT 1.7 USER GUIDE 307



ER/STUDIO BUSINESS ARCHITECT TOOLS > USAGES

2 In the Create Usage dialog, you can specify the details for the new usage:

Detail Description

Target Elements

Target Elements tree Lists all available target elements. Only the elements appearing in
the Model View tree and/or diagram are available to be targeted.

Select the element(s) you want to connect with your originally
selected element.

Filter Lists of Target Elements | Opens the Create Usage Target Element Filter. You can select the
button types you want included in the list of Target Elements. You can
include/exclude the following types: Business Process Modeling,
Conceptual Modeling, External Data Objects, Reference Objects,
Shapes, and Projects/Models/Data Sources.

You can click Restore Defaults ( '@ |) to reset all the values back to
their original settings.

Once you make your selection and close the dialog, the label for the
Target Elements list box now indicates the list is filtered.

Expand All button Expands all the nodes in the Target Elements list box.

Collapse button Collapses all the nodes in the Target Elements list box.

Link Properties

Usage Create: Attribute indicating usage adds new records or entries.
Read: Attribute indicating usage views existing records or entries.

Update: Attribute indicating usage edits existing records or
entries.

Delete: Attribute indicating usage deletes existing records or

entries.
Description You can enter a description of the link you are creating.
Notes You can enter additional information in this text field.

3 Once you have specified all the details for the new usage click OK. You can view this newly
created usage five different ways:

e Create an Impact Analysis Diagram.

¢ Right-click either the source or target element and select Connections > Show > Usages.

e Right-click an element in the Model View and select Usage(CRUD) > Edit or View... and
the Property View opens. Click the Impact Analysis tab for either one of the connected
elements.

® The created usage appears in the Model View tree in either an Incoming Relationships or
Outgoing Relationships node (depending on whether you selected the source or target
element). In the following example the task “Task in Invisible Pool” has an outgoing
“usage” relationship to the task “Task”.
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4 You can show the usage name by right-clicking on the link and selecting Show > Name.

5 The CRUD attributes are shown by default. You can hide these attributes by right-clicking on
the Usage and deselecting the Show > Usage command.

Editing Usage
You can edit the names, attributes, descriptions and notes for usages by using the Usage (CRUD)
property view.

1 Right-click the source element in the Model View tree and select Usage (CRUD) > Edit. The
Property View for that element opens with the Usage (CRUD) tab displayed. This tab displays
the receivers and their usage settings in the grid.

2 Select a receiver from the grid and click the Edit Usage . You can edit the name and usage

settings for the selected usage under the General tab. You can also add or edit descriptions and
notes.

NOTE: You can also double-click the usage you just created, either in the Model View or in the
diagram, and you are taken directly to the Property View for the usage.

3 If you want to edit just the usage setting, select the receiver in the grid and press F2. This
places you in an edit mode for that cell.
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Exporting a Usage

You can export the Usage (CRUD) report from the Property View using four different formats:
CSV, HTML, PDF, and RTF.

1 From the Model View or the diagram, double-click the source element of the Usage (CRUD)
relationship to open the Property View. For example if you created a usage from “Task A” to
“Task B”, you would double-click on “Task A”.

2 Click the Usage (CRUD) tab to open the report and click export icon (Ié ).

—

General <0 Subject Area: Party
Drescription
d Filter: OFF
Mokes
Mappings Receivers | sage | Receivetr Descripkion |
: Subject Areas
Links Account C
Jsage (CRUD) Geographic Locakion R
Salarw 1

Impact Analysis

Appearance

+ 5] x%] 2] 28

3 Inthe Export dialog export the folder location you want to save the report in. The default
location is the current workspace folder.

4 You can use the default file name or rename it.

5 Select the type of report you want to generate: CSV, HTML, PDF, or RTF and click Save. A file
is generated and the Export dialog closes.
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6 Open the folder where you saved the report and double-click to open it. The following
example shows a report exported in the CSV format.

EH Microsoft Excel

File Edit Wiew Insert Format Tools Data  wWindow  Help  Adobe PDF

NEHS /I IRIVE | & L@R-F9-0-18 -2 %06

A13 - fe
A, B C

1 |Receiver Type Receiver Mame Lsage

2 |Subject Area Accaunt C

3 |Subject Area Geographic Location R

4 |Subject Area Salary Ll

5

=

Drawing a Usage

Instead of using the Create Usage wizard, you can create a usage in the Diagram View using the
Usage (Y,) icon in the Reference Objects palette or Reference Objects toolbar.

1 Click the drop-down arrow on the Reference Objects palette and select U, Usage, or select

U, from the Reference Objects toolbar.
2 Click the element that is the origination of the usage.

3 Click the element that you want the first element connected to and a usage is created.

NOTE: The usage thatis placed in the diagram has an editable text field containing the usage
settings (C, R, U, D). You can change these settings in the text field.

4 Right-click the usage and select Show > Name. The connection is labeled with the source
and target name (for example “Lending.Securities”.
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5 You can set the usage type in the Property View, which can be shown as well. In the following
example the usage indicator is “R" for read.

Review New
Application

Review MNew Application,Data Feed

Data Feed

IMPACT ANALYSIS DIAGRAM

Once you have created a link or usage, you can create an Impact Analysis Diagram displaying a
graphical representation of those links. You can update an existing Impact Analysis diagram
rather than generating a new one for the same element. The Impact Analysis Diagram can also

be viewed as a grid.

If a source object has been linked to an External Data Object Attribute, Column, or Data
Element, they also will appear on the Impact Analysis Diagram. Their names are displayed as
ParentName.Name in the view and are not editable in the diagram. You can double-click on
them to open the associated Property View, where you can change their properties.

You can create an Impact Analysis Diagram several ways:

Right-click an element that you have created a link or usage for in the Model View tree and
select Impact Analysis > Generate New Diagram....

OR

Right-click an element that you have created a link or usage for in the Diagram View and
select Impact Analysis Diagram....

OR
Open the Property View for an element and click in on the Impact Analysis tab.

OR

Select an element in the Model View tree or Diagram View and on the main menu select
Tools > Generate Impact Analysis Diagram....

NOTE: You will get a warning dialog telling you that they may be a delay when generating
large diagrams.
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The created diagram appears as an additional tab in the Diagram View. It also appears in the
Model View tree and is represented by the following icon: [#]. You can save the diagram by
clicking |zl . You can also print this diagram by clicking (=1 on the Standard toolbar.

The following example shows a sample Impact Analysis Diagram. The two tasks (Company and
Employee) are linked and have both a verb phrase and an inverse verb phrase. The data object
(Resume) shows a usage indicator connected to the Employee task and has a usage setting of
“C" for create.

— Originating
Element

Emploves contacted by company
Verl Phrase

Link,
Indicates Inverse Verh
"Update™ Phrase

usade

\J [ o Company conkacks emploves

Employee I_ Target Element

Emploves. Resume {

Resume

Updating an Impact Analysis Diagram

Instead of generating a new Impact Analysis diagram each time you add links or usages, you can
refresh or update your existing diagram to show new connections.

Right-click in the background of an existing Impact Analysis Diagram in the Diagram View
and click Update Impact Analysis.

OR

Right-click the Impact Analysis diagram node in the Model View and click Update Impact
Analysis.

OR

Select the Impact Analysis diagram in the Model View and on the main menu, select
Diagram > Update Impact Analysis.

NOTE: This menu option is available only if the Impact Analysis diagram is open and is
selected on the Model View.
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View an Impact Analysis Diagram in the Grid Editor
1 Right-click in the background of an opened Impact Analysis Diagram.

OR
Right-click on the Impact Analysis Diagram in the Model View.

2 Select Grid Editor.... The information now appears in a grid format with full editing
capabilities.

For more information, see Grid Editor.

GRID EDITOR

The Grid Editor displays information about diagrams, reference objects data, or selected
elements in a diagram in a spread-sheet format. The spread-sheet format allows you to enter a
lot of information quickly. This Grid Editor is dynamic, reflecting changes made in the Model
View tree or the Diagram view. When you open a Grid Editor it is placed in the Diagram View as
a tabbed view and if a diagram is already open, it appears as an additional tab.

When you create a Grid, the Grid Editor displays all the element types in alphabetical order. The
names of the elements are listed in alphabetical order under each element type as well. The
following example shows some of the elements in a business process modeling diagram.

Loan Application Pro... ! Loan Application Pro...: Grid Editor 3
Object Tvpe Mame
1  |Associations | External Auditor,Lender
2 Loan Application. Submit Application. Receive Application
3 R eview Application, Credit Check
4 Underwrite Application, Underwriter Database
5 Data Feeds Credit Check,
& Data Objects Loan Application
7 Data Stores IUnderwriter Database
a8 Events End Event
9 Start Event
10 Gateways Application Approved?
11 Aukoapprove?
1z Loan Approved?
13 Lanes Lane
14 Loan Officer
15 IUnderwriter
16 Links Customer
17 Message Flows Send Approval Mokice Receive Response
15 Send Rejection Motice. Receive Response
19 Subrnit Application, Receive Application

The columns available depend on the node or elements selected. For example if you create a
grid on the Steward Object node, there is a column labeled E-Mail Address. This information
would not appear if you selected a diagram node. You can choose to hide/show columns from
within this common subset as described in the Customizing the Grid Editor section.
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The following table lists all the elements and the information that appears for each:

Element Available Columns

Business Process Modeling Elements

Associations Name
Message Flows Description
Sequence Flows Notes
Events Name
Tasks Description
Pools/Lanes Notes
Gateways

Data Object Name
Group Description
Annotation Notes

Off-Page Connector

Conceptual Modeling Elements

Subject Area Name
Business Entity Description
Business Attribute Notes
Interaction

Relationship

Reference Objects

Business Element Name
Data Type
Description

Notes

Business Rule Name
Type
Description

Notes

Business Unit Name
Description

Notes

Stewards Name

Type

E-Mail Address
Responsibility
Description

Notes

External Data Objects
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Element Available Columns
Data Feed Name

Data Store Description

Entity Notes

Flat File

Report

Table

View

Drawing Shapes

All Shapes Name
Parent (Parent Type)
Description

Notes

Opening the Grid Editor
Right-click a node in the Model View tree and select Grid Editor.

OR
Select an item in the Model View tree and select Tools > Grid Editor from the main menu.

NOTE: |If a filter has been set in the Model View tree node, this filter also applies to the Grid
Editor.

The following nodes have the Grid Editor option available:

Node Description

Model Displays all elements contained in the
selected model.

Diagram Displays all items contained in the
diagram.
Elements Displays information for the element

and all items contained in that
element. For example, if you right-
clicked on a business entity, all the
business attributes will be listed as
well. Relationships for the selected
element are listed also.

Business Element/ Business | Displays the elements, rules, units, and
Rule/Business Unit/Steward | stewards that you have created. within
nodes their related folder. For example all
business rules created are listed in the
Grid Editor when you right-click on the
Business Rules node. However, when
you right-click on a created business
rule within that folder, the Grid Editor is
not available.
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Node Description

External Data Objects node | Displays all the external data objects
you have created or added in the
current workspace.

USING THE GRID EDITOR

It is easy to navigate in the Grid Editor. All items on this Grid Editor are editable and can be
sorted. There is a quick and easy way to enter large amounts of reference object data in the Grid

Editor. That data can then be imported into another grid editor. You can print or export the Grid
Editor, and customize what columns appear.

Navigating

® When a cell is selected, Tab moves you forward and Shift+Tab moves you backwards
among the populated cells in a row. If you continue to tab at the end of a row, you advance
to the first cell in the next row.

e When a cell is selected and you press Enter, you move down a row to the cell directly below
the selected cell. For example, if you select the cell in the Name column, pressing Enter
moves you to the Name column in the next row. You remain in edit mode until you press Esc
or click another row.

® \When a row is selected and you press Enter, you move down to the next row. When there
are no more rows, then the first row in the Grid Editor is selected.

e While a row is selected, you can use the up/down arrow keys to navigate between the rows.
Pressing F2 puts you in the edit mode for the name.

Editing
You can edit the text in the Grid Editor in two ways:

¢ In-line editing: Click once to select the row and then click again to put the cell you want to
edit in edit mode.

TIP: Ifacellisin the edit mode, you cannot use the right/left arrow keys to move the cursor
within the text field unless you press F2.

® Property Editor: To launch the Property View for an item double-click on a row, press
Alt+Enter, or right-click in the row and click Properties. Changes made in the Property View
are reflected in the Grid Editor when completed.
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You can also cut, copy and paste in the Grid Editor.

1 Click once to select the row and then click again to put the cell you want to edit in edit
mode. You can also press F2.

2 Right-click the selected cell and select either cut or copy. You can then paste a cut or copied
cell into another cell or in a selected third-party applications like Microsoft® Word or
Microsoft® Excel.

3 You can also copy or cut text from a third-party applications like Microsoft Word or Microsoft
Excel and paste it into a selected cell in the Grid Editor.

Sorting

The default sorting is alphanumeric by name, within a type. When you double-click on a column
header the sorting toggles between ascending or descending order (within the type nodes). The
direction of the sort is indicated by a directional arrow in the column header.

Printing
You can print the current Grid Editor.

1 With the Grid Editor open and active, select File > Print from the main menu, click =5 on
the Standard Toolbar, or press Ctrl+P.

2 In the Print dialog select the options you want and click Print.

USING THE GRID EDITOR FOR ENTERING REFERENCE OBJECTS DATA

The Grid Editor provides a fast and simple means of entering large amounts of data for
Reference Objects.

1 Inthe Model View tree, right-click on one of the Reference Object subnodes (for example
Business Elements).

2 Select Grid Editor and the Grid Editor opens.

NOTE: If no reference objects exist, the first row is blank. If reference objects already exist for
the selected node, the blank row appears at the end of the existing objects.

3 When you select the blank row, the Name text field becomes editable. Enter the element
name and tab to the Data Type cell.

4 You can select one of the data types from a drop-down list. The list of data types depends
on the type of reference object you are creating.

5 Tab to the Description cell and enter any descriptive text. You can also add addition
information in the Notes column.
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When you tab again you are automatically taken to the next blank row where the Name cell
is editable.

NOTE: A newly created Reference Object element now appears in the Model View tree under
the selected subnode.

You can quickly navigate through the rows. Each time you press Enter you advance down
one row. When you reach the last row, you are returned to the first row.

EXPORTING THE GRID EDITOR

You can export the Grid Editor in the following formats:
File Type Description
csv Comma separated text file
html Hypertext Markup Language
pdf Adobe Acrobat
rtf Rich Text Format

1

Open a Grid Editor or select a Grid Editor that is already open in the Diagram view.

Select File > Export > Grid Editor from the main menu or click g5 and the Export dialog
opens. The default folder is the current workspace.

Name the file, select the file type from the drop-down menu and click OK. The exported file
is saved in the selected folder.

NOTE: When exporting the Grid Editor in the pdf file format, the column widths are set relative
to their actual width in the application.

IMPORTING DATA EXPORTED FROM THE GRID EDITOR

You

can import Comma Separated Value (CSV) files containing Reference Objects that you have

exported from a Grid Editor. This function is useful when you have many Reference Objects of a
certain type that you want to use in another workspace or make available to another user. You
can export that information and then make it available to be imported without the burden of re-
entering the data.
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The exported CSV files from ER/Studio BA can only contain one type of exported Reference
Object. For example, you could export all your Business Rules contained in a workspace and
your exported file would only contain those Business Rules. Once imported, these objects are
placed in the appropriate folder (i.e., Business Rules) in the Model View tree.

1
2

320

Open the workspace where you want to import the csv file.
Choose File > Import > Comma Separated Values (CSV)... from the main menu

OR

Right-click the Reference Object node where you want to place the imported objects and
select Import Comma Separated Values (CSV)....

The CSV Import Wizard opens.

Select the object type you want to import from the Available Object Types list. This object
type must match the object types you exported.

Browse to the location of the previously exported Grid Editor file and select the file you want
to import.

Click OK and then click Next.

If there are elements that exist with the same name the Possible Duplicate Elements dialog
opens. You can choose to create a new element with a unique name or update the existing
element. When updating existing elements the following will occur: (1) Elements in the
project having corresponding objects in the import are updated with new information; and
(2) Objects in the import without corresponding element in the project are added to the
project as new element.

If there are problems with the import, a Problems in File dialog opens. A table lists any
errors, warnings, or information, as well as the line number of the problem.

e Click Launch Editor to open the application associated with the CSV extension, where
you can view and correct any problems.

¢ Once you have corrected the problem click Revalidate.

If the import is successful, an Import Summary dialog opens displaying all the records that
have been imported.

Click Finish and a CSV Import Complete notification dialog opens telling you how many
elements were created in ER/Studio BA.

Once you close the notification dialog, the imported elements are placed under the
appropriate node in the Model View tree.

You can then drag these elements on to an existing diagram. When you double-click on an
element, the Property View for that element opens displaying the imported data.
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CUSTOMIZING THE GRID EDITOR

You can customize the Grid Editor to display only selected columns.
1 Open a Grid Editor in the application.

2 Right-click in the Grid Editor and select Customize Columns.... All columns are displayed by
default.

3 In the Customize Columns dialog, deselect the columns you want to hide in the view and
click OK.

4 The selected columns no longer appear and the tab displays the notation that you have
customized this Grid Editor.

! Ciagramne; Grid Editor {Cuskomized)

Chject Tyvpe Mame
Events Stark Evenk
Gateways Gateway
Tasks Task,

REPORTS

There are two main reports in the ER/Studio BA application: The Impact Analysis Report and the
Web Report. If your installation also encompasses ER/Studio Repository, you can view and
create many different reports through ER/Studio Portal. For more information, see the ER/Studio
Portal User Guide.

IMPACT ANALYSIS REPORT

The Impact Analysis Report exists for most elements in the Model View tree. As you make
changes to an element this report is updated dynamically. For example, if you add a link, that
link and its target are immediately displayed in the report.

You can gain access to these reports by double-clicking on any element in the tree to open the
Property View. Once the Property View for the selected element is open, click the Impact
Analysis tab.

You can also open the Impact Analysis Report by selecting an element in the tree and choosing
Tools > Reports > Impact Analysis....

Impact Analysis Reports can be printed or exported. You can also filter the report so only
selected elements are shown.
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This report shows the following interrelationships between elements:

Main Category Definition

Workspace Hierarchy Displays the workspace, projects, and models
associated with it.

Diagram Usage Displays all diagrams the element is in. This
includes any generated Impact Analysis
Diagrams, which include graphical
representations of all links and usages on a
diagram.

Heritage Displays the parent and/or children of the
selected element.

Incoming and Outgoing Displays all connecting objects for the selected
Connecting Objects element, including the type of connection, and
the origination and termination of the
connection.

Links Displays all links ( @z ) for a selected element
and the name of the element where the link
terminates.

You are also given information on whether the
current element is the source or the target of a

link.

Usages Display all usages (UI,) for a selected element

and the name of the element where the usage
terminates.

Using the Impact Analysis Filter

In the Impact Analysis report, click A 1o open the Impact Analysis Filter dialog. There are two
tabs: Setting Relationship Types and Setting Object Types. The status of the filter (on or off) is
displayed in the header of the Impact Analysis report.

Setting Relationship Types

You can select the types of relationships you want included in the impact analysis. You can select
an entire level, for example, Heritage. Or you can select lower levels such as Parent, which is a
subset of Heritage.

Setting Object Types

All object types are listed in a collapsed list under this tab. Click @ to view all types associated
with a selected heading. You can select the entire group or select individual elements within that

group.
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Using the Text Filter Option

If you only want objects with a certain name or by a certain alpha character to appear in the tree:

1

Click |9 to open the Impact Analysis Filter dialog.

2 Select the Text Filter icon and the text box is now available.

3 Enter the name you want to base the filter on. There are several different options:

If you enter an alpha character followed by an asterisk, all elements with the entered alpha
character will appear in the tree. For example, if you entered “T*” in the text box,
elements shown would include not only “Tasks” but “My Tasks” as well because a space is
used in the name.

Also shown are elements that are connected to an element with the selected criteria. For
example, if you have a gateway labeled “GateOne” connected to a sequence flow named
“To Task One”, if you have filtered on “T*", both the gateway and the sequence flow
appear in the Model View tree.

Also, you can enter an alpha character followed by a question mark as a single character
“wild card” search. For example, if you entered “T?sk” the filter would show all names
beginning in “T” and ending with “sk” in the Model View tree.

Once you have entered the text string you want searched on, press Enter and the Impact
Analysis tab opens with the filtered selection.

Exporting the Impact Analysis Report

You can export the report in the following formats:

File Type Description

csv Comma Separated Value text
file

html Hypertext Markup Language

pdf Adobe Acrobat

rtf

Rich Text Format

In the Property View, click i£5 and the Export dialog opens. The default folder is the current
workspace.

Name the file, select the file type from the drop-down menu and click OK. The exported
Impact Analysis Report is saved in the selected folder.

Printing the Impact Analysis Report

1
2

In the Property View select the Impact Analysis page and click =1 .

In the Print dialog select the options you want and click Print.
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WEB REPORT

ER/Studio BA offers a Web report feature that lets you generate a series of Web pages detailing
key information about your workspace. This read-only report contains information about both
Conceptual Model and Business Process Diagrams.

To create this report, you must complete the Web Report wizard. Web reports are ideal for
adding to organizational intranets to quickly disseminate the latest information about the state
of your projects. This section of help describes how to:

e Create a Web report

e Use a Web report

CREATING WEB REPORTS

ER/Studio BA offers an extensive HTML reporting feature you can use to display and review your
projects online. To execute this feature, you must complete the Web Report Wizard, which
allows you to filter, set descriptions and set a location of the reports. Once executed, the wizard
produces reports for each project and model stored in their own subfolder, which is named for
the project/model they represent.

The Web Report Wizard

You can generate a report on all information in the opened workspace using the Web Report
Wizard. You can generate separate web reports for individual models as well as individual
diagrams. The reports are created in the HTML format.

1 Choose Tools > Reports > Web Report from the main menu and the Web Report wizard
opens. The first panel lists the following:

e The current workspace

Reference Objects

External Data Objects

All related projects

All related models

All related diagrams

All items are selected by default.

NOTE: Only reference objects in the diagrams are included in the Web Reports. Reference
Objects that exist only on the tree are not included in the report.

2 Deselect the items you don't want included in your web report and click Next.

NOTE: If a diagram is selected, the model elements are filtered based on the selected
diagram.
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In the Object Type Selection list box, specify the types of objects you want to include in the
report. The following categories are available: Business Process Modeling, Conceptual
Modeling, External Data Objects, Reference Objects, and Shapes. All items in this list box
are selected by default. You can expand the categories and include/exclude individual
elements within that category.

Click Next to the Select Report Location dialog. Select a directory where you want the
report to be created. The default setting for the generated report is a folder named Web
Reports under the workspace directory (...My Documents\ERStudioBusinessArchitect\Web
Reports). The default web report name is the same as the currently opened workspace. You
can also browse to a new directory, if you don't want to use the default.

NOTE: If you have already created a web report for your current workspace, you will get a
warning that a report already exists in the specified location and that files will be
overwritten.

If you selected the preference to launch the report upon completion, the “Launch report
upon completion” option is already selected in the Web Report dialog.

Click Next to open the Report Details dialog. The Title and Author fields can be edited.
You can also enter a description of the report. These details are displayed on the first page
when the report first opens.

Click Finish and a progress information dialog opens telling you the reports are being
generated.

Once the report has been generated a title page opens, as well as a tree displaying the
workspaces, projects, models, diagrams, elements, reference objects, and external data
objects. This tree is located on the left-hand side of the window.

You may get an Information Bar dialog warning you when Internet Explorer blocks a pop-up

window. Click OK to close this dialog. Click once in the yellow bar with the warning icon (13}
) and select Allow Blocked Content from the menu. Click Yes once again to close the
Security Warning dialog.

Expand the tree and click on any diagram node to display a graphical representation of the
diagram.

Click on an element and the report displays the element’s properties. For example a
business entity named Account in a conceptual model diagram is displayed as CMBusiness
Entity: Customer Support.
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USING WEB REPORTS

When you use ER/Studio BA to create an HTML Web report, the application produces a folder
for the workspace and all associated projects, models, diagrams, and elements.

1 In the left pane, click the name of any diagram and the Web Report displays a graphic of

that diagram in the right pane.

2 Click any element in the tree and the Web Report displays, in the right pane, the element’s

properties in a tabular format.

3 Where applicable, a link is provided to a related element. For example, in the following
graphic, the lane labeled “Underwriter” is a child of the pool “Lender”.

EI@' Applications

El% Application Models
Independent Sub-Process
Loan Application Process
test

- Customer

'E' Lane

E""""j Incoming Relationships
H{L ] Independent Sub-Process
- = Independent Sub-Proce
= Lender

(_L:JE' Underwriter ]

E Receive Application

"E Review Application
"E Send approval Motic
"E Send Rejection Motic
<> Autoapprove?

H-=3 | gan Officer

43 Incoming Relationships

I+

HA 1 Loan application Process
T test

Ea

Underwriter (Lane)

Details

|Hame |Lln|:|erwriter
|Parent pool |m
|Parenl: lane |

Loan Officer (Lane)

Details
|Name |L|:|an Cfficer
|Parent pool |Leru:|er

|Parenl: lane |
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4 When you click on the hyperlink “Lender”, the web page for that element opens, displaying

the details for that pool.

El@' Applications

Eﬁ application Models
Independent Sub-Process
Loan Application Process
test

EHE Custormer

'E' Lane

b Incoming Relationships

EH:| Independent Sub-Process
= = Independent Sub-Proce
= Lender

== Underwriter

"E Receive Application
"E Review Application
"E Zend Approval Notic

"E Send Rejection Motit

VIEWS

Lender (Pool)

Details

|Name |Lender
|Participanl: |F‘articigant2
|Prm:ess |m
|Buundarr visible |True

Lanes

|Lln|:|erwriter

|L|:|an Qfficer

Views provide alternative presentations as well as ways to navigate the information in ER/Studio

BA.

Views have their own menus. To open the menu for a view, click the icon at the left end of the
view's title bar. Some views also have their own toolbars. The actions represented by buttons on
view toolbars only affect the items within that view.

ER/Studio BA offers six main views in the application. Each view can be opened, and moved and
docked in a different location. And each view has a set of icons in the toolbar that makes it easy

to manipulate the view.

The table below lists the five views:

Topic Description

The Diagram View The Diagram View, located to the right of the Model View tree, is
where you can place the graphical representations of the
Business Process Modeling Notational and Conceptual elements
as well as elements from the other palettes.

The Model View The Model View tree displays the hierarchy of workspaces,
projects, models, diagrams, and elements. It also displays the
hierarchy of reference elements. Workspaces, projects, models,
diagrams, and elements can be created, organized, and viewed.
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Topic Description

The Palette View The Palette View contains the business process elements,
conceptual elements, reference objects, external data objects,
and drawing shapes elements used to create business process
modeling diagrams in the Diagram View.

Error Logging View The Logging Views include the Error Logging view. This view
tracks errors generated by ER/Studio BA.

Help View The Help View displays dynamically generated help topics.

Overview Window The Overview window is a scalable window displaying any

diagram in its entirety.

Search Results Shows the results of a Search of the metadata for a workspace.

Opening a View Window

1 On the Window menu, select Show View.

2 From the pull-right menu, select the view you want to open.

Moving and Docking Views

You can change the location of a view:

1 Drag the view by its title bar to the desired location. But do not release the left mouse
button yet.

As you move the view around the Workbench, the mouse pointer changes to one of the
drop cursors. The drop cursor indicates where the view will be docked if you release the left
mouse button.

NOTE: The drop cursor changes as you drag the view over the left, right, top, or bottom
border of another view or editor.

2 When the view is in the location that you want, release the left mouse button to dock the
view.

NOTE: A group of stacked views can be dragged using the empty space to the right of the
view tabs.

You can also move a view by using the pop-up menu for the view. (Left-click the icon at the left
end of the view's title bar, or right-click anywhere else in the view's title bar).

Using Drop Cursors
The table below shows the different drop cursors and where the view will be moved to:

Drop Cursor | Where the view is moved to:

'y The view is docked above the view underneath
the cursor.
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Drop Cursor

Where the view is moved to:

the cursor.

The view is docked below the view underneath

The view is docked to the right of the view
underneath the cursor.

The view is docked to the left of the view
underneath the cursor.

¥
»
-
7

The view is docked as a Tab in the same pane as
the view underneath the cursor.

Q

view here.

This area is restricted and you cannot dock a

Using the Views Toolbar

Each View window has a set of icons that allow you customize the view windows. You can use a
drop-down menu to gain access to view tools, and you can minimize or maximize each view

window.
Toolbar Icon | Element Description
- Menu Displays a drop-down menu containing all the toolbar
icons for the selected window.
= Minimize This command hides the view and only the icon and tab
representing the view are displayed in the application
window. Click once in the tab to restore the view to its
original size and location.
= Maximize The view is expanded to fill the entire application
window.
= Restore Once you have maximized a view window, the Restore

icon appears in the upper right corner of the window.
Click this icon to restore the maximized window to its
original size.

THE DIAGRAM VIEW

The Diagram View, located to the right of the Model View tree, is where you can place the

graphical representations of the Business Process Modeling Notational elements, Conceptual

elements, Reference Object elements, External Data