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INTRODUCTION

Rapid SQL is an integrated development environment that enables developers to create, edit, 
version, tune, and deploy server-side objects residing on Microsoft SQL Server, Oracle, Sybase 
Adaptive Server, InterBase/Firebird, IBM DB2 for Linux, Unix, and Windows, and IBM DB2 for z/
OS databases. Its unified database development environment provides extensive graphical 
facilities that simplify SQL scripting, object management, reverse engineering, database project 
management, version control and schema deployment. With Rapid SQL, programmers can 
develop and maintain high-quality, high-performance client/server and web-based applications 
in less time, and with greater accuracy.

ABOUT RAPID SQL
Rapid SQL provides tools that can be used by a number of functions within an organization 
using DBMS from multiple vendors, in testing, development, or production environments.

MAJOR FUNCTIONAL AREAS
Datasource management tools - Before use with Rapid SQL, datasources must be registered. 
Datasources can be registered manually or semi-automatically. Storage can be registry-based or 
file-based, and a network storage option facilitates shared use of datasource catalogs.

Object management tools - Rapid SQL supports a wide range of database objects and related 
elements for each DBMS. You can create new objects, edit existing objects, and use a range of 
object operations that support common, general or DBMS-specific actions.

Scripting environments - Rapid SQL offers fully-featured environments dedicated to SQL, DDL, 
Java and Active Script development. Execution options are available as appropriate, and 
environment-specific related features, such as rollback/commit and query plan options, are 
provided. Related coding aids include on-the-fly semantic and syntactic validation, text 
substitution shortcuts, and visual query building tools. Related execution tools include script and 
file execution facilities.

Data Utilities - A Data Editor lets you edit your tables in real-time, supports all editable 
datatypes, and provides unicode options.  Table data can also be imported from formats such as 
spreadsheets.

Project Management - Rapid SQL database project management facilities help you organize, 
alter, and keep track of changes to database objects or SQL scripts. The project management 
facilities act as a repository to maintain all source code for a database project. Rapid SQL also 
incorporates version control functions and build management facilities to help you manage and 
build projects.

Other Time-savers and Productivity Tools - Working within the Rapid SQL environment, you 
have access to database and file search facilities, use visual difference to compare files or 
database objects, and access the Microsoft Windows task scheduler.

License-specific Add-ons - Depending on the licenses you purchased, you have access to the 
following tools:
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INTRODUCTION
• The Code Analyst helps you identify time-consuming lines of code. It lets you perform 
detailed response time analysis, benchmark the execution of one or more procedures or 
functions, save response time metrics, and perform intelligent comparisons against current 
execution times.

• Debuggers, available for IBM DB2 for Linux, Unix, and Windows, Oracle, Sybase, and SL 
Server, let you test functions and procedures. A Profiler is available for Oracle datasources.

BENEFITS TO SPECIFIC USERS
Rapid SQL provides benefits to the following users:

ABOUT THIS BOOK
This book has three major components:

• Installing Rapid SQL lists technical requirements, provides details on DBMS version support, 
summarizes the installation process, and includes licensing details.

• Tutorial exercises provides learning curve material on Rapid SQL. It walks you through the 
major areas of functionality, getting you ready for independent work.

• New Features describes all feature updates for the current major release.

Database Administrators Rapid SQL lets database administrators accomplish more with the limited time they 
have. It eliminates the tedious tasks associated with researching schema 
dependencies when making object changes. Also included are a host of utilities, 
which condense DBA tasks taking hours or days down to minutes. 

Rapid SQL provides an easy-to-use graphical user interface (GUI), which allows 
Database Developers to be immediately productive in a cross-platform environment 
without having platform specific knowledge. The GUI in general, and wizards and 
editors specifically, provide time-savings over traditional hand-coding or other 
manual methods.

Developers In addition to a fully-featured scripting environment, Rapid SQL offers several cross-
platform code-generation options, which help Developers build SQL code that is 
syntactically and functionally correct the first time. 

Complementing coding facilities, the object creation wizards and graphical object 
editors greatly reduce the time and effort to build an application database from the 
ground up.

Rapid SQL facilitates moving applications and complete database systems between 
environments.

Project Managers Project management facilities and Version Control System integration provide 
fundamental project management.
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INSTALLING RAPID SQL
Before you can register any Embarcadero Technologies application, you must meet the 
minimum technical requirements. If you meet all the minimum technical requirements, you can 
install Rapid SQL. After installation, you must license the application.

The following topics walk you through this process:

• Technical Requirements

• Database Support and Connectivity Options

• Installing Rapid SQL

• Licensing

Lastly, for more information, see "Additional Product Resources" on page 17.

TECHNICAL REQUIREMENTS
Rapid SQL is a 32-bit application that runs in a Microsoft Windows environment. Before using 
Rapid SQL, please verify that your environment meets the following requirements:

• Hardware Requirements

• Operating System Requirements

NOTE: Users need full registry privileges during the installation and access to the keys under 
HKEY_CURRENT_USER in the registry after installation.

HARDWARE REQUIREMENTS
Embarcadero Technologies recommends the following minimum hardware requirements:

• 1024 MB of memory 

• 512 MB of disk space 

OPERATING SYSTEM REQUIREMENTS
Rapid SQL supports the following operating systems:

• Windows XP SP2 (32-bit and 64-bit)

• Windows Vista (32-bit and 64-bit)

• Windows 7 (32-bit and 64-bit)

For more detailed information, see the following topics:

• XP Support
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INSTALLING RAPID SQL
• Vista and Windows 7 Support

• 32-bit Versus 64-bit Operating System Support and Restrictions

XP SUPPORT 
Windows XP has two user security groups: 

• Users 

• Power Users 

Microsoft intentionally does not grant members of the Users Group the authority to install 
applications or make global changes to the system. Restricted Users are members of the Users 
Group. Standard users belong to the Power Users Group. Microsoft grants members of the 
Power Users Group the authority to install programs. You must be a member of the 
Administrators Group in order to install and use Embarcadero Technologies applications. 

Because Restricted Users are members of the Users Group, they cannot install and run 
Embarcadero Technologies applications. 

CAUTION: You must be a member of the Administrators Group in order to install and use 
Embarcadero Technologies applications. 

To open the Group Membership tab where you can determine your group and review the 
Microsoft security guidelines: 

1 On the Control Panel, open User Accounts. 

2 On the Users tab, select a user and then click the Properties button. 

3 Click the Group Membership tab.

VISTA AND WINDOWS 7 SUPPORT

Windows Vista UAC and Windows 7 provide two user types:

• Standard user

• Administrator

Rapid SQL can be installed or uninstalled by an administrator or by a standard user using an 
administrator token. Standard users can run Rapid SQL.

CAUTION: For the purpose of running Rapid SQL, default standard user token privileges 
should not be modified.  Modifying standard user token privileges can result in 
licensing issues which will prevent Rapid SQL from operating properly.
8 RAPID SQL XE 3/8.1.1 QUICK START GUIDE



INSTALLING RAPID SQL
32-BIT VERSUS 64-BIT OPERATING SYSTEM SUPPORT AND RESTRICTIONS

Rapid SQL is a 32-bit application that runs emulated on 64-bit versions of Windows. The only 
requirement is that Rapid SQL supports only 32-bit versions of the client software that must be 
installed for connectivity to each DBMS that Rapid SQL will work against.

DATABASE SUPPORT AND CONNECTIVITY OPTIONS
Rapid SQL provides dedicated DBMS platform support with the following connectivity options:

• For use with IBM DB2, SQL Server, MySQL, Oracle, and Sybase ASE datasources, Rapid SQL 
is packaged with a set of proprietary drivers that work in conjunction with a supported set of 
clients that must be installed. 

InterBase requires both client and driver software to be installed. Firebird requires driver 
software.

For information on the DBMS clients or client/driver combinations that must be installed, 
see "Packaged Embarcadero Drivers with Native Client Support" on page 10.

• Alternatively, you can connect to a supported DBMS using a Type 4 JDBC driver packaged 
with Rapid SQL. For a listing of the third-party JDBC drivers, see "Third-party JDBC drivers" 
on page 10.

The following table lists the DBMS platform versions for which dedicated support is provided, 
and the connectivity options supported:

Lastly, generic JDBC and ODBC is provided for non-dedicated DBMS platforms and other 
datasources. For details, see "Generic JDBC and ODBC Support" on page 11.

DBMS Version Native 
Embarcadero 
Driver Support

Packaged Third-
party JDBC Client 
Support

Firebird 2.0

IBM DB2 for z/OS 8 and 9

IBM DB2 LUW 8.0 - 9.7

InterBase 2007 and InterBase 2009

Microsoft SQL Server 2000, 2005, and 2008

For SQL Server 2005 and 2008, only object types like users, logins, 
roles, config parameters, etc., are supported. We do NOT support 
Microsoft .NET extensions at this time.

MySQL 4.x. 

(Rapid SQL is tolerant of 5.x but does not support Stored 
Procedures, Triggers, or Views)

Oracle 9i, 10g, and 11g

Sybase ASE 12.5 - 15.0.3

Sybase IQ 12.7 - 15.4
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PACKAGED EMBARCADERO DRIVERS WITH NATIVE CLIENT SUPPORT 
If you are using a native Embarcadero connectivity option to connect to supported DBMS 
platforms, ensure that the relevant client or driver/client combination is installed and configured:

NOTE: Since Rapid SQL is a 32-bit application that runs emulated on 64-bit versions of 
Windows, only 32-bit versions of the DBMS client software are supported.

THIRD-PARTY JDBC DRIVERS
If policy or preference dictates use of Type 4 JDBC drivers, the following table includes the 
drivers supplied for each supported DBMS platform:

DBMS Client

Firebird Firebird ODBC driver

IBM DB2 for z/OS IBM DB2 Client for Windows 8 or later

IBM DB2 for Linux, Unix, 
and Windows

IBM DB2 Client for Windows 8 or later

Microsoft SQL Server Microsoft SQL Server Client Library 

MySQL MySQL ODBC driver 3.5.1 and above

Oracle Oracle SQL*Net Client 

Sybase ASE Sybase Open Client

Interbase DataDirect ODBC driver for InterBase and the InterBase Client

Platform JDBC Driver

Firebird Jaybird JDBC Driver

IBM DB2 for Linux, Unix and Windows

IBM DB2 for z/OS

IBM Data Server Driver for JDBC

InterBase InterBase JDBC driver

Microsoft SQL Server jTDS Type 4 JDBC Driver for Microsoft SQL Server

Microsoft SQL Server JDBC Driver

MySQL MySQL Connector/J JDBC Driver

Oracle Oracle JDBC Thin Driver

Sybase ASE  jTDS Type 4 JDBC Driver for Microsoft SQL Server

Sybase jConnect JDBC Driver

Sybase IQ  Sybase jConnect JDBC Driver for Sybase IQ
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GENERIC JDBC AND ODBC SUPPORT
Generic JDBC/ODBC connectivity to non-dedicated DBMS systems or non-database 
datasources is also provided. Rapid SQL can connect to a datasource using a customer-
provided, third-party JDBC version 3.0 or ODBC version 3.0 driver. Minimal Rapid SQL 
functionality is provided, including a basic Explorer tree and SQL querying. 

IBM DB2 FOR Z/OS STORED PROCEDURE REQUIREMENTS
When working against an IBM DB2 for z/OS data source, Rapid SQL relies on the following 
stored procedures, provided as an optional installation step in setting up the DB2 subsystem:

• DSNWZP

• DSNUTILS

• ADMIN_COMMAND_DSN

• ADMIN_COMMAND_DB2

Prior to using Rapid SQL against an IBM DB2 for z/OS data source, ensure that these 
components are installed on the server. See http://publib.boulder.ibm.com/infocenter/dzichelp/
v2r2/topic/com.ibm.db2.doc.inst/stpadd.htm#stpadd for more information.

INSTALLING RAPID SQL
To install Rapid SQL successfully, you must complete each panel of the installation wizard. For 
more information, see "Installation Wizard" on page 11.

After the installation is complete, we recommend that you reboot your machine before using 
Rapid SQL.

CAUTION: To install Rapid SQL from the command line, you should be sure to manually 
uninstall all prior versions of Rapid SQL. 

INSTALLATION WIZARD
The Rapid SQL Installation Wizard installs all corresponding files on your machine. The panels 
presented by the wizard vary depending on whether you are upgrading or performing an initial 
installation. To proceed to the next panel of the wizard, click Next. To cancel the installation 
process at any time, click Cancel.

NOTE: Before installing Rapid SQL from Embarcadero ToolCloud, see http://
docs.embarcadero.com/products/xe/ for additional requirements or revised 
instructions.

CAUTION: If you have not registered a license when you start a Rapid SQL installation, you 
will be prompted to register a license.  For more information, see "Licensing" 
on page 12.
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INSTALLING RAPID SQL
Use the following table as a guide to understanding the panels you may encounter when 
installing Rapid SQL:

LICENSING
Each Embarcadero client application requires one or more licenses in order to run. An 
Embarcadero product, such as Rapid SQL or ER/Studio, has a baseline license which provides 
basic feature support for that product. In addition, incremental licenses may be required to 
support specific DBMS platforms, product add-ons, or other functions.

For more information, see the following topics:

• Licensing Overview

• Licensing Your Application

• Selecting a License Category During Startup

• Online/Offline Mode and Concurrent License Checkout

LICENSING OVERVIEW
The following topics provide a high-level discussion of key licensing topics and directs you to 
sources of more detailed information.

• Viewing Your License Type and Modules

• Understanding Trial, Workstation, and Networked Licenses

• Rapid SQL License Modules, DBMS Support, and Feature Availability

• Rapid SQL XE License Modules, DBMS Support, and Feature Availability

Panel Description

Welcome... The start of the install process.

License Agreement This panel of the Installation Wizard displays the license agreement. To 
continue the installation, click I accept the terms in the license agreement. 
You cannot proceed to the next step in the installation if the I DO NOT accept 
the terms in the license agreement option is selected. 

Destination Folder Identify the folder where you want the program files to reside. The default 
directory is C:\Program Files\Embarcadero\RSQL<version identifier>\.

Start Menu Lets you provide a Start menu group and optionally have an application icon 
created on the desktop.

Associate Files Specify whether you want files with extensions of .sql or .eqb to be associated 
with the Rapid SQL application.

Ready to install the program Review your settings and click Install to continue the installation process. 

Installing... Displays the installation progress.

Setup Complete Finishes the installation process. 
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INSTALLING RAPID SQL
• Directing Queries Regarding Licenses

VIEWING YOUR LICENSE TYPE AND MODULES

The About... dialog, available from the Help menu, displays your license type and each 
individual license module currently registered.

UNDERSTANDING TRIAL, WORKSTATION, AND NETWORKED LICENSES

Three kinds of licenses are available: Trial, Workstation, and Networked.

For a detailed description of licensing options, see http://www.embarcadero.com/software-
licensing-solutions.

RAPID SQL LICENSE MODULES, DBMS SUPPORT, AND FEATURE AVAILABILITY

Individual license modules correspond to the DBMS platforms you are licensed to use. In 
addition, each DBMS license module corresponds to a product edition. Feature availability for 
each license module edition is as follows:

• Standard - Provides baseline support including datasource management, object 
management, SQL editing and execution, and standard tools and utilities.

• Professional - Standard edition features plus SQL Debugger, SQL Profiler, and Code 
Analyst.

RAPID SQL XE LICENSE MODULES, DBMS SUPPORT, AND FEATURE AVAILABILITY

An XE license provides access to all supported DBMS platforms. XE module and feature 
availability is as follows:

• XE Pro - Provides baseline support including datasource management, object 
management, SQL editing and execution, and standard tools and utilities, SQL Debugger, 
SQL Profiler, and Code Analyst.

Trial licenses A license for a 14-day, full-featured trial version of the product. The trial license must be 
registered before you can use the product.

Workstation licensing A license or set of licenses is tied to a particular workstation. The product can only be 
used on that workstation. 

Networked licensing Networked licenses are administered and distributed by a central License Server 
(Embarcadero License Center or Acresso FLEXnet Publisher). There are two types of 
networked licenses: Concurrent and Networked Named User. With Concurrent licensing, 
users on different machines take turns using licenses from a shared pool. With 
Networked Named User licensing, licenses are pre-assigned to specific users setup on 
the license server's user list. Those users are guaranteed to have licenses available any 
time. 

NOTE: Concurrent licenses can be borrowed for use without a network connection. For 
details, see "Online/Offline Mode and Concurrent License Checkout" on page 16.
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INSTALLING RAPID SQL
DIRECTING QUERIES REGARDING LICENSES

Questions regarding license availability, feature availability, and client or server licensing, should 
be directed as follows:

• If you work in an organization that uses networked licensing, direct any questions to your 
site’s Rapid SQL administrator.

• If you are using workstation licensing, direct licensing questions to your Embarcadero 
Technologies representative.

LICENSING YOUR APPLICATION
See the following topics for details on registering your product:

• Registering a Trial or Workstation License during Installation

• Registering a Workstation License After Application Startup

• Registering By Phone

• Registering a Networked License

REGISTERING A TRIAL OR WORKSTATION LICENSE DURING INSTALLATION

Shortly after initiating download of a trial version of an Embarcadero product, you should receive 
an email with a serial number you must register during installation. Similarly, if you purchase an 
Embarcadero product while no trial version is active, you will receive a serial number that must 
be registered during installation.

1 Start the installation. An Embarcadero License Registration dialog appears.

2 Copy the serial number from the email and paste it in the Serial Number field.

3 Enter your Embarcadero Developer Network account credentials in the Login or Email and 
Password fields. If you have not previously created an EDN account, or have forgotten your 
password, click I need to create ... or I’ve lost my password.

4 Click Register.

Your activation file should be downloaded and installed automatically. If this does not happen, 
click the Trouble Connecting? Try Web Registration link and follow the prompts. If you still 
have problems, see "Registering By Phone" on page 15.
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INSTALLING RAPID SQL
REGISTERING A WORKSTATION LICENSE AFTER APPLICATION STARTUP

The following instructions assume that you have received a workstation license by email and that 
you currently have a valid trial license. If you did not install a trial version or the trial period has 
expired, follow the instructions in "Registering a Trial or Workstation License during Installation" 
on page 14 instead.

1 On the Help menu select About and then on the dialog that opens, click Manage to open a 
license manager dialog.

2 On the Serial menu, select Add.

3 Copy the serial number from the email and paste it in the Add Serial Number dialog, then 
click OK.

4 Right-click on the serial number you added, and then select Register from the context 
menu. A registration dialog opens.

NOTE: The Registration Code box shows a machine-specific identifier required with other 
registration methods.

5 Ensure that the Register using Online Registration radio box is selected.

6 Provide Developer Network credentials in the DN Login name or Email and DN Password 
boxes. If you have not previously created an EDN account, or have forgotten your password, 
click I need to create ... or I’ve lost my password.

7 Click Register.

8 If prompted to restart the application, click Yes.

Your activation file should be downloaded and installed automatically. If this does not happen, 
click the Trouble Connecting? Try Web Registration link and follow the prompts. If you still 
have problems, "Registering By Phone" on page 15.

REGISTERING BY PHONE

If you have problems with either of the above procedures, you can register licenses by phone. 
You will have to provide:

• Developer Network credentials

• The registration code displayed in the Embarcadero License Registration dialog that 
appears when you start an unlicensed application

• The product base license serial number

• The license serial numbers for any additional features you have purchased.

For North America, Latin America and Asia Pacific, call (415) 834-3131 option 2 and then follow 
the prompts. The hours are Monday to Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For Europe, Africa and the Middle East, call +44 (0)1628-684 494. The hours are Monday to 
Friday, 9 A.M. to 5:30 P.M. U.K. time.
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INSTALLING RAPID SQL
Shortly after phoning in, you will receive an email containing an activation file. Then do the 
following:

1 Save the file to the desktop or a scratch directory such as c:\temp.

2 On the Help menu select About and then on the dialog that opens, click Register. A 
registration dialog opens.

3 Select the I have received an activation file (*.slip or reg*.txt) radio box.

4 Click the Browse button and use the Select License Activation File dialog to locate and 
select the activation file you installed.

5 Click the Import button to import the activation file and when complete, click the Finish 
button.

6 If prompted to restart the application, click Yes.

REGISTERING A NETWORKED LICENSE

If you work in an organization using Networked licensing, an administrator, department head, or 
someone performing a similar function will provide you with an activation file.

Once you receive the file, save it to the license subfolder of your product’s main installation 
folder (typically C:\Program Files\Embarcadero\<product><version>\license\), 
then restart the application.

No additional steps are necessary.

SELECTING A LICENSE CATEGORY DURING STARTUP
During Rapid SQL startup, if multiple concurrent license categories are available, you are 
prompted to select a category to use for this Rapid SQL session. Multiple license categories can 
be set up to provide differing feature access or access to different DBMS versions. Feature and 
DBMS version access are typically distributed across multiple license categories to optimize use 
of a site’s purchased licenses.

NOTE: This dialog also includes the option to remember your selection on subsequent 
startups. If you select that option, you can subsequently use the Select Licenses button 
on the About... dialog (Help > About) to select a different license.

Contact your License Administrator for details on individual license categories or requests for 
additional feature or DBMS support.

ONLINE/OFFLINE MODE AND CONCURRENT LICENSE CHECKOUT
Concurrent licenses can be used in both online and offline modes. In online mode, you must 
have a continuous network connection to your License Center. Licenses are checked out when 
you start Rapid SQL and checked back in when you shut Rapid SQL down.
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ADDITIONAL PRODUCT RESOURCES
You can also use a license in offline mode. When you explicitly check out a license for offline use, 
you can use Rapid SQL without a connection to your License Center for a specified duration. 
This lets you work while travelling or commuting, work away from your primary work area, or use 
Rapid SQL when a network connection is unavailable or not required. 

NOTE: Contact your site administrator for information on offline license availability, the 
maximum duration, offline license policy at your site, or any other issues arising from 
online license usage.

To check out a license for offline use:

1 On the Help menu, select Checkout License. The Check Out Licenses For Offline Use 
dialog opens.

2 Select the check box associated with each individual license you want to check out.

3 In the Checkout Duration box, type the number of hours that you can use the offline license 
without a network connection to the License Center.

4 Click OK.

You can work offline for the specified duration. The duration period begins immediately.

If you subsequently establish a network connection to the License Center before the license 
duration expires, you can indicate to the License Center that the offline license is no longer 
required. 

To indicate that an offline license is no longer required:

1 On the Help menu, select Checkin License. 

There is no interruption in Rapid SQL usage. The license is not actually checked in until you shut 
down Rapid SQL.

ADDITIONAL PRODUCT RESOURCES

The Embarcadero Web site is an excellent source for product information and access to 
additional resources:

• Release notes and product documentation

• Information on other Embarcadero application and database development tools

• Embarcadero Development Network

• Product and technical support

• Educational and product expertise material in the form of online demos, white papers, and 
video presentations

• Access to sales staff and Embarcadero resellers
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ADDITIONAL PRODUCT RESOURCES
For access, direct your browser to www.embarcadero.com.
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TUTORIAL EXERCISES

The exercises that follow walk you through the Rapid SQL’s major functional areas. After 
completing these exercises, you will have the foundation you need to explore the many features 
and benefits of Rapid SQL. You’ll have learned how to competently manage the major database 
administration and development tools provided.

This guide is divided into a set of sessions:

• Session 1: Getting Started

• Session 2: Productivity Enhancers

• Session 3: Scripting

• Session 4: Working with Code Workbench

• Session 5: Building a Database Project

• Session 6: Visual Query Builder

• Session 7: Live Data Editor

• Session 8: Code Analyst

• Session 9: SQL Debugging and Profiling

You can use this basic tutorial as a roadmap of product highlights, but also to help you find your 
own path to explore Rapid SQL. 

Once you’ve started, you can select Help Topics from the Help menu to find many additional 
resources that complement and build on many of the activities shown in this tutorial. 

SESSION 1: GETTING STARTED
Before anything else, you must perform the following tasks:

• Starting Rapid SQL

• Registering Cross-Platform Datasources

STARTING RAPID SQL
How you start Rapid SQL depends on the type of application you are evaluating:

• InstantOn version - start the application by double-clicking the file you downloaded. 

• Fully-installed version - The Start menu sequence for Rapid SQL is always in the form 
Programs > Embarcadero Rapid SQL version identifier > Embarcadero Rapid SQL 
version identifier, where version identifier reflects the version you are running.
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TUTORIAL EXERCISES
To get started

1 Run Rapid SQL.

The first time Rapid SQL starts, a dialog opens, prompting you to set up datasources. In 
addition to letting you manually set up individual datasources, a number of more 
automated methods are available. If you have installed and used other Embarcadero tools, 
Rapid SQL can find any active datasources being used by those tools. In addition, Rapid 
SQL provides a Discover Datasources feature that automatically searches the DBMS 
configuration files on your system for datasources that are not currently registered. Since 
other Embarcadero tools let you export datasource definitions to file, you also have the 
option of importing these definitions.

2 For the purpose of this tutorial, click Cancel. You will be registering a datasource manually. 

The main Rapid SQL window opens.
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REGISTERING CROSS-PLATFORM DATASOURCES
For now, you will register a datasource manually.

1 On the Datasource menu, select Register Datasource. A Datasource Registration Wizard 
opens.

2 Choose Microsoft SQL Server as the DBMS type and then click Next.

3 Specify the Host name of an SQL Server datasource on your network, override the 
Datasource Name with SAMPLE_DATASOURCE and then click Next.

4 Provide valid credentials in the User ID and Password boxes, and then select the Auto-
Connect? checkbox to eliminate having to provide credentials each time you connect to this 
datasource.

5 In the left-hand pane, select Datasource Group, select the MS SQL Server folder, and then 
click Finish.

NOTE: The Datasource Group panel also lets you assign a category to a datasource. This 
provides a means to visually distinguish between different server purposes, 
development vs. production, for example, in your enterprise. Categorization is a 
customizable feature.

6 Select Yes when prompted to connect to the new datasource.
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Rapid SQL offers the same easy-to-use Datasource Registration Wizard for all supported DBMS 
platform connections. The connection information only needs to be set up one time for each 
platform and can be saved locally or in a common datasource catalog for use by other 
Embarcadero products.

By default, Rapid SQL stores datasource definitions in the Windows Registry. There is also a 
local, file-based option. Embarcadero products supporting these methods can share datasource 
catalogs on the same machine.

There is also a network-shared storage option.

Rapid SQL also offers the ability to import and export datasource definitions. This lets you share 
definitions among users and across datasource storage methods.

SESSION 2: PRODUCTIVITY ENHANCERS
This session focuses on some commonly used time-saving features:

• The Database Explorer Tree

• Creating an Object Using the Object Creation Wizard

• Working With an Existing Object Using the Object Editor

• Object Documentation and Reporting

• Working With Code, Files and Data

• Setting Environment Options

• Favorites Tab

• Working with Scripts and Files

• Viewing Data

• Retaining Datasource Explorer View Settings

• Datasource Explorer Bookmarks

• Setting Keyboard Shortcuts and Hotkeys

• Referencing Most Recently Used Datasources
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THE DATABASE EXPLORER TREE
Rapid SQL makes it easy and intuitive to navigate between datasources and to drill-down into 
atomic database objects within the Database Explorer Tree. The Database Explorer Tree displays 
all registered datasources and serves as the entry-point for much of Rapid SQL’s advanced 
functionality. 

1 Click on the Explorer title bar and select Organize By Object Type.

2 Select and expand the SAMPLE_DATASOURCE > Databases > pubs node to display the 
database object sub-nodes.
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CREATING AN OBJECT USING THE OBJECT CREATION WIZARD
From within the Database Explorer Tree you can create any database object using simple Object 
Creation Wizards. The following is an example of how to use the Table Object Creation Wizard. 
It is similar to the Object Creation Wizards available within Rapid SQL for all database objects 
and other supported elements. 

1 Right-click on the Tables node and select Create. A Create Table Wizard opens.

2 Select a Schema and provide a Name of SAMPLE_TABLE. Leave the remaining default 
settings and click Next.

3 Add a column, using a Name of Sample_Column1 and select a Type of char. Experiment 
with the Add Column and Delete buttons, and with selecting a column and modifying its 
attributes.   

4 Click Finish. The DDL View panel opens showing the DDL that will be used to create the 
new table.

5 Deselect the Launch Object Editor After Execute and then click Execute.

Rapid SQL builds the platform-specific SQL code, syntactically-correct and ready to run the first 
time. There is no SQL coding required in any of the Rapid SQL Object Creation Wizards.
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WORKING WITH AN EXISTING OBJECT USING THE OBJECT EDITOR
While the wizard offered you the option to automatically open an editor on creating the table, 
you can also manually open an editor. 

1 In the Database Explorer, ensure that the Tables node is expanded and then right-click on 
your new table and select Open.

Object Editor features are as follows:

• All Object Editors provide standardized, multi-tabbed windows for each database object 
type.

• All Object Editors provide fully-functional toolbars for easy object management.

• Rapid SQL has full knowledge of the underlying DBMS system catalog, syntax and 
alteration rules, so the user can concentrate on what needs to be done, not on how to do 
it.

• Drop-down boxes allow you to easily move between owners and objects.

• The Rapid SQL Object Editors easily perform operations that would normally require 
painstaking and error-prone scripting, such as deleting or inserting columns in a table 
while preserving data, dependencies and permissions. Rapid SQL analyzes the database 
catalog to determine its structure, and then automatically generates the SQL script 
required for the extended alteration. For instance, when a full table alteration is required, 
Rapid SQL automatically unloads and reloads the data, eliminating tedious work.

2 Close the Object Editor window.
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OBJECT DOCUMENTATION AND REPORTING
Rapid SQL provides rich, detailed HTML Reporting for all database objects. Building a browser-
ready report for any object is only a few mouse-clicks away.

1 Expand the Tables node, right-click on any table and select Report from the menu. A 
Generate Report dialog opens.

2 Select Detail Report (Report on each selected item) and click OK. A Report dialog opens.

3 Enter a destination Report Home Page File Name. This can be a network web server 
directory. 

4 Enter a Report Title and click Execute.

The HTML report will automatically be displayed in the Rapid SQL application workspace. 
For example:

The HTML report can be saved to a new file or referenced in the file named above.

NOTE: All HTML reports are browser-ready and suitable for posting directly to the web.

WORKING WITH CODE, FILES AND DATA
Rapid SQL provides many features and powerful development tools for creating and executing 
SQL code and working with data.

NOTE: For purposes of this Evaluation Guide, we are only covering high-level functionality of 
the major features and tools within Rapid SQL. 
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SETTING ENVIRONMENT OPTIONS
The Options dialog allows you to set the Rapid SQL development environment to meet your 
needs. 

1 Select File > Options from the menu. The Options dialog opens.

The Options dialog has one page per option category. You select an option category in the left-
hand pane and can subsequently set options on that page. Options are applied when you click 
OK.

2 Close the Options dialog.

FAVORITES TAB
The Favorites Tab provides a drag-and-drop library interface of all supported DBMS syntax, SQL 
syntax, built-in functions, optimizer hints, and SQL-conditional syntax. Additionally, it provides 
the ability to create custom folders to store commonly-used code for quick and efficient access, 
as needed.

To open the Favorites Explorer:

1 At the bottom of the Explorer pane, click Favorites. The Favorites Explorer appears.

2 Expand the Microsoft node and then expand the Schema sub-node.
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3 Right-click the Procedures node and select Open. The selected code opens in the SQL 
Editor window and is ready for execution.

4 Right-click in the editor window and select Close from the context menu.

To add a custom folder to the Favorites Explorer

1 Right-click the Favorites > Schema folder.

2 Select New Folder from the menu. A new folder is added to the bottom of the Schema 
folder.

WORKING WITH SCRIPTS AND FILES
Rapid SQL extends the auto-generation of SQL code by allowing you to run your scripts across 
multiple databases at the same time. In addition, there is the option to execute the code 
immediately or schedule it to run later.

FILE EXECUTION FACILITY

Similar to the Script Execution Facility, files containing SQL scripts can be added to the File 
Execution Facility and executed immediately or scheduled to run later. Other than the origin of 
the code, all supporting functionality is the same. 

1 On the Tools menu, select File Execution Facility. Rapid SQL opens the File Execution 
Facility dialog box.

2 To locate the file you want to execute, click Add. Use the Add Files dialog box to locate and 
select a file.

3 On the Target tab, select the datasources to run the script against.

4 On the Output tab, select the desired output option. For the purposes of this example, 
select Graphical Output.

NOTE: To enable the scheduling function for the script, you must select the File Output 
option.

5 If you want to send notification that the script has executed, on the Notify tab, complete the 
target information.

6 Click Execute if you want Rapid SQL to run the script against the target datasources. 
Otherwise, close the dialog without executing.

NOTE: Separate script output windows are created for each selected datasource.

SCRIPT EXECUTION FACILITY

The Tools menu also offers a Script Execution Facility.  Similar to the File Execution facility, it lets 
you type or paste the script to be executed.
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VIEWING DATA
Rapid SQL provides several options for browsing data. In addition, it gives you the ability to 
construct even the most complex SQL statements with point-and-click ease.

SELECT * BROWSING

1 On the Database Explorer ensure that the Explorer tab is displayed and then expand the 
MS SQL Servers node. 

2 Expand any database you know has table data, expand the Tables node, right-click a table, 
and then click SELECT * FROM. 

All columns and rows from the table are displayed in the active workspace.   

3 Close the workspace window.

RETAINING DATASOURCE EXPLORER VIEW SETTINGS
1 Click on expandable settings at the top of the Explorer pane.

2 Select Retain View Settings.

The Explorer will open the next time just as you left it. All connections that were present when 
you closed Rapid SQL will be re-established. 
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DATASOURCE EXPLORER BOOKMARKS
Rapid SQL allows you to set bookmarks for frequently visited database objects.

1 Right-click on any node in the Datasource Explorer Tree.

2 Select Add Bookmark and use the Add Friendly Bookmark Name dialog to optionally 
provide a new name, and create the bookmark.

After Bookmarks are defined you can use them to easily navigate to commonly used datasource 
resources using the Bookmarks menu. 
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The Bookmark Manager handles maintenance of Bookmarks.

1 Select Bookmarks > Bookmark Manager.

2 Close the Bookmark Manager dialog.

SETTING KEYBOARD SHORTCUTS AND HOTKEYS
1 On the Tools menu, select Customize.

2. In the Customize dialog go to the Keyboard tab.

The Keyboard tab can be used to set keyboard shortcut hotkeys for all areas of Rapid SQL 
functionality. 

3 Close the Customize dialog.
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REFERENCING MOST RECENTLY USED DATASOURCES
1 Select File > Recent Datasources and then select a datasource. 

This will automatically place you on the datasource within the Explorer, ready to work with active 
connection. 

SESSION 3: SCRIPTING
This session looks at Rapid SQL’s development environment:

• Generating Code

• Right-click feature

• Automated error detection and coding assistance

• Other coding aids

GENERATING CODE
By providing several code generation and assistance options, Rapid SQL makes cross-platform 
development easy for developers of all experience levels. 

NOTE: The following examples build on the SQL Server 2000 SAMPLE_DATASOURCE 
registered earlier in this Evaluation Guide. These examples can be applied to any 
registered datasource for any of the supported platforms. 

CODE GENERATION FACILITY

The Code Generation Facility can be used to create complete procedures, functions or 
packages revolving around views or tables.

1 From the menu, open Tools > Code Generation Facility.

2 Select the SAMPLE_DATASOURCE datasource and the pubs database from the dropdown 
list boxes.
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3 Select the authors table, state as the input column and all columns for output.

4 Select Select as the code option.

5 Select a file to save the generated script and check Open.

6 Click OK and the DDL to create the procedure will be generated and displayed in an 
editable window, called the DDL Editor. You can edit the name of the new procedure and 
any of the generated code at this time. Name the new procedure sample_select_authors.
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7 Click on the Execute or Step Execute button to submit the DDL and create the procedure.

The indicated file will be saved on the selected directory.

NOTE: No SQL statement coding is required to generate complete stored procedures and 
packages. If applicable, Rapid SQL allows all generated code to be previewed and 
edited to fit any development need.

RIGHT-CLICK FEATURE
Similar to the Code Generation Facility, the “right-click” code generation feature can be used to 
create complete procedures, functions or packages revolving around views or tables.

1 From the Database Explorer Tree, expand the SAMPLE_DATASOURCE > pubs > Tables 
sub-node.

2 Right-click on the authors table.
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3 Select Generate > Procedure > Select.

4 Select state as the input column, and leave all output columns selected.

5 Click OK and the DDL to create the procedure will be generated and displayed in the DDL 
Editor. You can edit the name of the new procedure and any of the generated code. Name 
the new procedure sample_select_authors2.

6 Click on the Execute or Step Execute button to submit the DDL and create the procedure.
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AUTOMATED ERROR DETECTION AND CODING ASSISTANCE
Rapid SQL provides a range of features that detect or help you avoid errors and save keystrokes 
in developing your scripts.

To enable these features:

1 On the File menu select Options. The Options dialog opens.

2 In the left-hand pane, expand the ISQL node and then select Code Assist.

3 On the Code Assist panel:

• Ensure that Enable Code Complete is selected.

• Ensure that Severity levels for semantic validation problems has Warning selected.

• Ensure that Enable Real-time syntax checking is selected.

4 Click OK.

To see these features in action:

1 On the File menu, click New, and then ISQL. 

Rapid SQL opens the SQL Editor window. You can add SQL code via your method of choice 
(free-form typing, retrieve from a file, paste copied code, etc.). 

2 Type SELECT * FROM and stop typing. 

Note the error condition.

Rapid SQL can run a syntax check any time there is an interval of 1.5 seconds between 
keystrokes. You can also disable automatic syntax checking and only run a check when you 
manually initiate it. Syntax error annotation persists until you correct the problem.

3 This time type a fragment that includes the name of a nonexistent object, SELECT * FROM 
NON.OBJECT, for example. For now, ignore any popups. The warning condition is a result 
of on-the-fly semantic validation. 
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Rapid SQL notifies you when a script contains a reference to an object that Rapid SQL 
cannot resolve.

4 Type SELECT * FROM followed by a space and then stop typing. If no popup appears, press 
CTRL+SPACE. The Code Complete suggestion box lets you select from objects or object 
name components such as databases or schema. This feature saves keystrokes and 
minimizes typing errors. See the online Help for full descriptions of these features.

5 Close the current SQL Editor window.

To restore Rapid SQL settings:

1 On the File menu select Options. The Options dialog opens.

2 On the Code Assist panel, click the Restore defaults button.

3 Click OK.

OTHER CODING AIDS
Rapid SQL provides extensive, easy-to-use coding aids for all of the supported DBMS platforms, 
throughout the application. Aids are provided in the form of ready-to-use code templates and 
blocks of syntactically correct code.

PASTE SQL 
1 From the Database Explorer Tree, expand the SAMPLE_DATASOURCE > pubs sub-node.

2 Select File > New > SQL to open an SQL Editor window. 

3 Select Edit > Paste SQL Statement to open the Paste SQL window.
RAPID SQL XE 3/8.1.1 QUICK START GUIDE 37



TUTORIAL EXERCISES
4 In the Tables list, select authors.

5 Under the Columns list, click ALL.

6 Click the Select radio button.

7 Click Paste Statement to copy the generated code to the SQL Editor window.

You can use the statement as is, or modify the code as needed.

PASTE SQL SYNTAX 
1 Select File > New > SQL to open a fresh SQL Editor window. 

2 Select Edit > Paste SQL Syntax to open the SQL Syntax for SQL Server window.
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3 Select a template and click Paste to copy the code template into the SQL Editor window.

4 Add your own code to complete the needed operation.

SESSION 4: WORKING WITH CODE WORKBENCH
The Code Workbench lets you configure resources for two SQL Editor features:

• Code Templates

• Auto Replace

Code templates are complete code blocks that can be easily added to open windows or scripts 
with a few keystrokes. When you type CTRL+SPACE, the Code Assist menu opens, letting you 
select a code template for insertion in the editor window.
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Auto Replace lets you define shortcuts consisting of a few characters that represent longer 
character strings. Instances of these Auto Replace expressions are automatically replaced by the 
replacement string on activation events such as typing SPACE, TAB, or RETURN. This feature is 
useful for creating shortcuts for one-line commands or SQL statement subsets, or even to detect 
and fix common typographical errors such as teh for the.

For example, consider an Auto Replace definition with an expression of sel to represent 
Select * From:

If the associated activation event includes a SPACE, then on typing sel followed by pressing 
SPACE, the following replacement occurs.

Rapid SQL loads a default set of Auto Replace and Code template definitions at startup but you 
can also add, edit, and delete definitions. In addition, you can save sets of definitions to file and 
subsequently load specific sets of definitions, allowing you to customize your templates to 
different platforms or development projects.

To invoke Code Workbench settings:

1 Select Tools > Code Workbench. 

The Settings tab lets you enable the Auto Replace and Code Template features.

2 Inspect the Code Templates and Auto Replace tabs.

3 Click OK.
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SESSION 5: BUILDING A DATABASE PROJECT

CREATING A NEW RAPID SQL PROJECT
Rapid SQL provides an excellent team development environment by allowing you to reverse 
engineer live database objects into off-line SQL source code files that can then be easily added 
to a Version Control System (VCS). Rapid SQL’s seamless VCS integration offers all version 
control operations, such as get, check-out, check-in, history and diff.  This example will reverse 
engineer the table objects from the Microsoft SQL Server pubs database into a Rapid SQL 
project and then will add the project to version control under Microsoft Visual Source Safe.

1 Select File > New > Project to open the wizard.

2 Enter sample_project as the name, and browse and select a directory that contains a VSS 
database. Enter a description (optional). Select From Database and click OK.

3 Select SAMPLE_DATASOURCE and click Next.

4 Select pubs and click Next. 

5 Select dbo as the owner. Right-click in the object type selection window and deselect all of 
the options. Select only Tables. Under Extract Scope select Selected Objects Only. Click 
Next.

6 Select only the authors, discounts, and employees tables.

7 Uncheck all selected Options for tables. Click Next.

8 Select Retain. Click Next.

9 Preview the last panel and click Execute. 
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Finished! You have now successfully created a working database project. At this point, the 
project is available to be added to Version Control. This can be done by clicking Yes when 
prompted and following the dialog, or by right-clicking on the project within Project Explorer 
tree. Select Yes for the purpose of this guide. 

ADDING A PROJECT TO VERSION CONTROL (SAMPLE - MICROSOFT VISUAL SOURCE 
SAFE)
When a project is created, Rapid SQL will automatically prompt you to add the project files to 
the selected VCS solution. The following dialog will be displayed:

After providing a user name and password, you can browse to locate and select the project 
database folder.
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All that remains is to provide a project name.

Finished! The following message indicates that the project was successfully placed under 
version control.

SESSION 6: VISUAL QUERY BUILDER
Rapid SQL gives you the ability to construct complex SQL statements with point-and-click ease 
using the Visual Query Builder.

1 From the Database Explorer Tree, right-click on the authors table and select Build Query. 

The authors table will be automatically added to the Query Builder workspace. 
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2 On the Tables/Views tab, right-click on the titleauthor table and select Add. 

Note that the tables are automatically identified as being joined by any columns with the 
same name and datatype. 

3 Click on the DML tab to expose the visual query building clauses and options. You can right-
click on any clause to easily add the code to the query.
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4 Select the au_lname, au_fname, and phone check boxes in the authors table.

Note that the lower pane shows the query that is being built. 

5 Click the Execute button to execute the query. 

The results will display in the lower window.

Before closing the Query Builder, experiment with additional options. Try selecting a different 
statement type, such as Insert or Update, from the dropdown at the top of the Query Builder 
window. Use the different clauses on the DML tab.

NOTE: Any visual query builder session can easily be saved to a file for later use. 

SESSION 7: LIVE DATA EDITOR
1 From the Database Explorer Tree, right-click on the authors table and select Edit Data.

2 In the Data Editor Filter dialog, click Add All to add all columns to the editing session.

At this point, you can add a WHERE clause that will filter for only the desired data. Note that 
Rapid SQL builds the SQL to retrieve the data to be edited in the Select Statement area.

3 Click OK. A Data Editor opens.

Note the dropdown at the left of the toolbar. The editing window has LIVE and BATCH modes: 

• LIVE mode commits your changes each time you move to a new row. 
RAPID SQL XE 3/8.1.1 QUICK START GUIDE 45



TUTORIAL EXERCISES
• BATCH mode will allow you to move within the window and commit your changes when 
ready. Changes made in BATCH mode can be cancelled by selecting the Reload Data icon.

At any time during the session, you can change the filter parameters by selecting the Filter Data 
icon.

SESSION 8: CODE ANALYST
The Code Analyst allows you to capture run-time statistics on executable database objects, 
including stored procedures and functions. Not only can you capture statistics for single objects, 
but you can group more than one object.

To get started

1 Select Tools > Code Analyst.

NOTE: In order for Code Analyst to run, 5 repository tables will be created on the database. 
Select the database you would like the tables to be installed on and press OK. Once 
the tables are installed, you’re ready to start defining a session.

2 On the Code Analyst toolbar, click the Create New Collection button.

3 On the Code Analyst Object Selection dialog, provide a Session Name, locate and 
selecting the objects to be executed, and click Next.
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4 Use the Code Analyst Object Initialization dialog to initiate providing input parameters as 
required, change the order of execution, and when ready, click Finish.

Once the session has been run, the total time for the execution is displayed in the Run 
Summary tab.

5 Select the other tabs to view the tabular and graphical representation of the execution 
details on your selected objects. For example:

• The Run Detail tab shows a breakdown of the different objects that make up the session.

• The Unit Detail tab contains the specific time measurements for individual SQL 
statements.

6 Close the Code Analyst window.

SESSION 9: SQL DEBUGGING AND PROFILING
Rapid SQL offers the following facilities that help you test and optimize code:

• SQL Debugging

• SQL Profiling- Oracle Only
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SQL DEBUGGING
The SQL Debugger is another database productivity tool that lets you debug SQL Server, 
Oracle, Sybase ASE or DB2 stored procedures as well as Oracle functions. SQL Debugger 
simplifies the task of finding coding errors.

1 In the Explorer, expand the Procedure or Function node.

2 Right-click the object and select Debug from the context menu.

3 If the procedure or function takes input parameters, the Procedure Execution window 
prompts you to enter values.

4 Enter input values(s) and press Continue.

TIP: Rapid SQL allows the user to save the input variable values to a file for later use. This 
is very helpful for procedures/functions with many input variables that need to be run 
repeatedly.

The application opens the SQL Debugger Interface.
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The Debugger features basic execution, line-by-line execution, breakpoint support, and other 
common debugging features. For details, refer to the relevant online Help topics.

SQL PROFILING- ORACLE ONLY
The SQL Profiler within Rapid SQL provides the ability to capture the metrics of various PL/SQL 
programmable objects as they are executed in the database. It quickly identifies performance 
bottlenecks by first calculating the overall runtimes of objects like Oracle packages, and then 
computing the amount of time each line of PL/SQL code spends executing. Information is 
presented in an easily viewed, drill-down format.

1 To start a profiling session, use the Tools menu option and select SQL Profiler > Start. 

2 Enter a name for the profiling session or select an existing name from the dropdown. Press 
OK. The Profile session is now active.
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3 Execute the programmable object (i.e. Stored Procedure) you wish to capture metrics on.

4 When finished, select Tools > SQL Profiler > Stop. The SQL Profiler – Stop dialog window 
prompts you to select an option.

5 Press Stop.

6 On the Explorer, expand the PL/SQL Code Profiling node. 
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7 Right-click on the profile session and select Run Summary. The Run Summary window 
opens.

8 Select a session and select Run Detail from the right-click menu. The Run Detail screen 
appears allowing you to view the metrics for this execution in both a graphical and text 
format.

9 To drill down further into the data, highlight a unit and select Unit Detail from the right-click 
menu. Scroll through the Source window to view the times for each statement.

10 To compare 2 cases, select the 2 cases you wish to compare (shift-click to select the second 
case) from the Run Summary screen and select Compare from the right-click menu. The 
SQL Profiler Run Comparison screen appears.

See the relevant online Help topics for more information on profiling.
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NEW FEATURES

• Connectivity Updates

• Sybase IQ Support

• Updated DBMS Platform Version Support

• SQL Server Feature Support

• Sybase Feature Support

• SQL Editor Improvements

• User interface changes and related features

CONNECTIVITY UPDATES

Direct Type 4 JDBC Driver Support

In previous releases, Rapid SQL connectivity was primarily restricted to native Embarcadero 
drivers. These proprietary drivers, packaged with Rapid SQL, work in conjunction with a 
supported set of third-party clients that must be installed. While this remains the default, a new 
Connect Using JDBC control lets you specify a more direct Type 4 connection that does not 
require a native client. 

With the exception of Interbase/Firebird datasources, one or more Type 4 JDBC drivers for each 
supported platform are now packaged with Rapid SQL. In addition, a new Generic JDBC option 
activates the Manage control. That control lets you select and configure a non-packaged, 
custom JDBC driver of your choice.
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Rapid SQL queries the selected driver to determine the properties, options, or parameters that 
the JDBC driver accepts. The Datasource Registration Wizard’s new Custom JDBC Properties 
panel lets you provide these name/value pairs.

Oracle/Sybase Client Selection Support

If you are using Embarcadero native drivers to connect to Oracle and Sybase datasources, then 
for cases where multiple client versions are installed, Rapid SQL selects the default client as 
defined by system/environment variables. For this release, Rapid SQL now lets you override the 
default, indicating the specific client version to be used with Sybase ASE and Oracle datasource 
connections.

Against Oracle, the Options Editor lets you specify:

• The directory associated with the client software

• The path to the TNSNAMES.ORA configuration file
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The Options editor offers similar functionality for Sybase connectivity. In addition to letting you 
select the main Sybase directory, you also select the sub-directory associated with the specific 
client you wish to use. You can also select the specific configuration file (typically named 
SQL.INI) to be used for Rapid SQL connections.

SYBASE IQ SUPPORT
This release introduces for Sybase IQ, Sybase's column-oriented DBMS. This release will offer 
the following: 

• The ability to register and connect to Sybase IQ datasources 
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• Explorer visibility of the following object types: DBSpaces, Domains, Foreign Keys, 
Functions, Groups, Indexes, Join Indexes, Primary Keys, Procedures, System Indexes, 
System Tables, System Triggers, Tables, Triggers, Users, and Views

• Extract and Drop object actions are available for all supported object types. An Object 
Properties action, providing sp_iqhelp procedure call output, is available against domains, 
functions, procedures, system tables, tables, and views.

• SQL Editor support 

UPDATED DBMS PLATFORM VERSION SUPPORT
Rapid SQL now provides support for Sybase ASE version 15.5. All current Rapid SQL 
functionality is now available on this platform version.

SQL SERVER FEATURE SUPPORT
The following topics describe updated support for SQL Server features.

Enhanced Public Key Encryption Support

Rapid SQL now offers Certificate, Asymmetric Key, and Symmetric Key objects.

A dedicated wizard and editor are available for creating and editing each of the new object 
types. Each provides the basic properties required to generate CREATE ASYMMETRIC KEY, 
CREATE CERTIFICATE, or CREATE SYMMETRIC KEY statements.
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In addition, the following object actions are provided:

Add Private Key - changes the private key for a certificate, adds a private key to a certificate 
that currently does not have one, and optionally, specifies a decryption password. 

Backup Certificate - backs up a certificate to file. 

SYBASE FEATURE SUPPORT
The following topics describe updated support for Sybase features.

Proxy Tables

New properties let you add FOR PROXY_UPDATE and DEFAULT_LOCATION= parameters when 
creating a database, as well as to change the default location for an existing database.

A new Resynchronize action, available against databases defined with the For Proxy Update 
property selected, forces the resynchronization of proxy tables within the proxy database.

Archive databases

A new ARCHIVE Type option and a new Scratch Database property lets you generate CREATE 
ARCHIVE DATABASE DDL and specify a WITH SCRATCH_DATABASE value.
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Relaxed Durability Databases

A new Durability property of the Database Wizard/Editor lets you control persistence of 
committed transactions. 

Selecting one of the FULL, NO RECOVERY, or AT_SHUTDOWN options includes a 
DURABILITY= option in the DDL generated to create or alter the database.

In-memory Databases support

A new property on the Database Wizard lets you create in-memory databases.
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An in-memory database can be created against a device initialized (DISK INITI) using the 
inmemory parameter.

Disk Resize Flexibility

In previous releases, Rapid SQL’s database device resize disk functionality restricted you to 
increasing disk size in page increments only. The Resize object action now lets you increase disk 
size in kilobyte, megabyte, gigabyte, or terabyte units.

SQL EDITOR IMPROVEMENTS
The following topics describe updates to the SQL Editor.

Hyperlinks to Invoke Object Actions

Hyperlinks let you invoke common or object type-specific object actions against tables, views, 
functions, procedures, packages, and package bodies referenced in a script. A configurable 
keystroke combination (default, CTRL+Right-click) opens an object action menu.
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Datasource Index Control

Error detection and coding assistance features rely on a datasource index generated when you 
open an SQL Editor against a datasource. Semantic Validation, the new Hyperlinks object 
actions feature, and Code Assist all use the datasource index for tasks such as verifying object 
name spellings, recognizing object types, and populating suggestion lists. The Options Editor’s 
new ISQL > Code Assist > Advanced provides control over the generated index.

You can now configure:

• The specific object types included in the index

• The maximum size of the index 

• The maximum number of results returned when the index is queried
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USER INTERFACE CHANGES AND RELATED FEATURES
Continuing from previous releases, this release features reworked object management editors 
and wizards. By DBMS platform:

• Oracle - Job Queues

• Sybase - Segments
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