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INTRODUCTION

Rapid SQL is an integrated development environment that enables developers to create, edit,
version, tune, and deploy server-side objects residing on Microsoft SQL Server, Oracle, Sybase
Adaptive Server, InterBase/Firebird, IBM DB2 for Linux, Unix, and Windows, and IBM DB2 for z/
OS databases. Its unified database development environment provides extensive graphical
facilities that simplify SQL scripting, object management, reverse engineering, database project
management, version control and schema deployment. With Rapid SQL, programmers can
develop and maintain high-quality, high-performance client/server and web-based applications
in less time, and with greater accuracy.

ABOUT RAPID SQL

Rapid SQL provides tools that can be used by a number of functions within an organization
using DBMS from multiple vendors, in testing, development, or production environments.

MAJOR FUNCTIONAL AREAS

Datasource management tools - Before use with Rapid SQL, datasources must be registered.
Datasources can be registered manually or semi-automatically. Storage can be registry-based or
file-based, and a network storage option facilitates shared use of datasource catalogs.

Object management tools - Rapid SQL supports a wide range of database objects and related
elements for each DBMS. You can create new objects, edit existing objects, and use a range of
object operations that support common, general or DBMS-specific actions.

Scripting environments - Rapid SQL offers fully-featured environments dedicated to SQL, DDL,
Java and Active Script development. Execution options are available as appropriate, and
environment-specific related features, such as rollback/commit and query plan options, are
provided. Related coding aids include on-the-fly semantic and syntactic validation, text
substitution shortcuts, and visual query building tools. Related execution tools include script and
file execution facilities.

Data Utilities - A Data Editor lets you edit your tables in real-time, supports all editable
datatypes, and provides unicode options. Table data can also be imported from formats such as
spreadsheets.

Project Management - Rapid SQL database project management facilities help you organize,
alter, and keep track of changes to database objects or SQL scripts. The project management
facilities act as a repository to maintain all source code for a database project. Rapid SQL also
incorporates version control functions and build management facilities to help you manage and
build projects.

Other Time-savers and Productivity Tools - Working within the Rapid SQL environment, you
have access to database and file search facilities, use visual difference to compare files or
database objects, and access the Microsoft Windows task scheduler.

License-specific Add-ons - Depending on the licenses you purchased, you have access to the
following tools:

RAPID SQL XE 2/8.0.2 QUICK START GUIDE 5



INTRODUCTION

® The Code Analyst helps you identify time-consuming lines of code. It lets you perform
detailed response time analysis, benchmark the execution of one or more procedures or
functions, save response time metrics, and perform intelligent compares against current
execution times.

e Debuggers, available for IBM DB2 for Linux, Unix, and Windows, Oracle, Sybase, and SL
Server, let you test functions and procedures. A Profiler is available for Oracle datasources.

BENEFITS TO SPECIFIC USERS
Rapid SQL provides benefits to the following users:

Database Administrators Rapid SQL lets database administrators accomplish more with the limited time they
have. It eliminates the tedious tasks associated with researching schema
dependencies when making object changes. Also included are a host of utilities,
which condense DBA tasks taking hours or days down to minutes.

Rapid SQL provides an easy-to-use graphical user interface (GUI), which allows
Database Developers to be immediately productive in a cross-platform environment
without having platform specific knowledge. The GUI in general, and wizards and
editors specifically, provide time-savings over traditional hand-coding or other
manual methods.

Developers In addition to a fully-featured scripting environment, Rapid SQL offers several cross-
platform code-generation options, which help Developers build SQL code that is
syntactically and functionally correct the first time.

Complementing coding facilities, the object creation wizards and graphical object
editors greatly reduce the time and effort to build an application database from the
ground up.

Rapid SQL facilitates moving applications and complete database systems between
environments.

Project Managers Project management facilities and Version Control System integration provide
fundamental project management.

ABOUT THIS BOOK

This book has three major components:

e Installing Rapid SQL lists technical requirements, provides details on DBMS version support,
summarizes the installation process, and includes licensing details.

e Tutorial exercises provide learning curve material on Rapid SQL. It walks you through the
major areas of functionality, getting you ready for independent work.

e New Features describe all feature updates for the current major release.
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Before you can register any Embarcadero Technologies application, you must meet the
minimum technical requirements. If you meet all the minimum technical requirements, you can
install Rapid SQL. After installation, you must license the application.

The following topics walk you through this process:

e Technical Requirements

e Database Support
e Installing Rapid SQL

® Licensing

Lastly, for more information, see Additional Product Resources.

TECHNICAL REQUIREMENTS

Rapid SQL is a 32-bit application that runs in a Microsoft Windows environment. Before using
Rapid SQL, please verify that your environment meets the following requirements:

e Hardware requirements

¢ Operating system requirements

NOTE: Users need full registry privileges during the installation and access to the keys under
HKEY_CURRENT_USER in the registry after installation.

HARDWARE REQUIREMENTS
Embarcadero Technologies recommends the following minimum hardware requirements:

e 1024 MB of memory
e 512 MB of disk space

OPERATING SYSTEM REQUIREMENTS
Rapid SQL supports the following operating systems:

* \Windows XP (32-bit and 64-bit)
¢ \Windows Vista (32-bit and 64-bit)
¢ Windows 7 (32-bit and 64-bit)
For more detailed information, see the following topics:

e XP Support
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e \ista and Windows 7 Support

e 32-bit Versus 64-bit Operating System Support and Restrictions

XP SUPPORT
Windows XP has two user security groups:

e Users
* Power Users

Microsoft intentionally does not grant members of the Users Group the authority to install
applications or make global changes to the system. Restricted Users are members of the Users
Group. Standard users belong to the Power Users Group. Microsoft grants members of the
Power Users Group the authority to install programs. You must be a member of the
Administrators Group in order to install and use Embarcadero Technologies applications.

Because Restricted Users are members of the Users Group, they cannot install and run
Embarcadero Technologies applications.

CAUTION: You must be a member of the Administrators Group in order to install and use
Embarcadero Technologies applications.

To open the Group Membership tab where you can determine your group and review the
Microsoft security guidelines:

1 On the Control Panel, open User Accounts.

2 On the Users tab, select a user and then click the Properties button.

3 Click the Group Membership tab.

VISTA AND WINDOWS 7 SUPPORT
Windows Vista UAC and Windows 7 provide two user types:

e Standard user
e Administrator

Rapid SQL can be installed or uninstalled by an administrator or by a standard user using an
administrator token. Standard users can run Rapid SQL.

CAUTION: For the purposes of running Rapid SQL, default standard user token privileges
should not be modified. Modifying standard user token privileges can result in
licensing issues which will prevent Rapid SQL from operating properly.
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32-BIT VERSUS 64-BIT OPERATING SYSTEM SUPPORT AND RESTRICTIONS

Rapid SQL is a 32-bit application that runs emulated on 64-bit versions of Windows. The only
requirement is that Rapid SQL supports only 32-bit versions of the client software that must be
installed for connectivity to each DBMS that Rapid SQL will work against.

DATABASE SUPPORT
The table below describes the database platforms Rapid SQL supports and the server and client

requirements:

Platform

Server

Client

IBM DB2 for z/OS

IBM DB2 for z/OS 8 and 9

When going through a DB2 Connect
gateway, DB2 Client for Windows 6.0 or
later. When going directly to the mainframe
from the client, DB2 Connect Personal
Edition vé or higher on the client machine.

IBM DB2 for Linux, Unix,
and Windows

IBM DB2 Universal Database 8.0 - 9.7

IBM DB2 Client for Windows 7.2 or later.

NOTE: When using a v8 client, Rapid SQL
only supports connecting to a v8 Database
on Windows, Linux and Unix.

InterBase/Firebird

InterBase 2007 and InterBase 2009

DataDirect ODBC driver for InterBase and
the InterBase Client

Firebird 2.0

Firebird ODBC Driver

Microsoft SQL Server

Microsoft SQL Server 2000, 2005, and 2008

NOTE: For SQL Server 2005 and 2008, only
object types like users, logins, roles, config
parameters, etc., are supported. We do
NOT support Microsoft .NET extensions at
this time.

Microsoft SQL Server Client Library

MySQL MySQL 4.x. (Rapid SQL is tolerant of 5.x MySQL ODBC driver 3.5.1 and above
but does not support Stored Procedures,
Triggers, Views.)
Oracle Oracle 8i, 9i, 10g, and 11g Oracle SOL*Net Client
Sybase ASE Sybase ASE 12.5-15.0.3 Sybase Open Client
NOTE: Since Rapid SQL is a 32-bit application that runs emulated on é4-bit versions of

Windows, only 32-bit versions of the DBMS client software are supported.

IBM DB2 FOR Z/OS STORED PROCEDURE REQUIREMENTS

When working against an IBM DB2 for z/OS data source, Rapid SQL relies on the following
stored procedures, provided as an optional installation step in setting up the DB2 subsystem:

e DSNWZP

e DSNUTILS
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e ADMIN COMMAND DSN
e ADMIN_ COMMAND DB2

Prior to using Rapid SQL against an IBM DB2 for z/OS data source, ensure that these
components are installed on the server. See http://publib.boulder.ibm.com/infocenter/dzichelp/

v2r2/topic/com.ibm.db2.doc.inst/stpadd.htmi#stpadd for more information.

INSTALLING RAPID SQL

To install Rapid SQL successfully, you must complete each panel of the installation wizard. For
more information, see Installation Wizard.

After the installation is complete, we recommend that you reboot your machine before using
Rapid SQL.

CAUTION: To install Rapid SQL from the command line, you should be sure to manually
uninstall all prior versions of Rapid SQL.

INSTALLATION WIZARD

The Rapid SQL Installation Wizard installs all corresponding files on your machine. The panels
presented by the wizard vary depending on whether you are upgrading or performing an initial
installation. To proceed to the next panel of the wizard, click Next. To cancel the installation
process at any time, click Cancel.

NOTE: Before installing Rapid SQL from Embarcadero ToolCloud, see http://
docs.embarcadero.com/products/xe/ for additional requirements or revised
instructions.

CAUTION: If you have not registered a license when you start a Rapid SQL installation, you
will be prompted to register a license. For more information, see Licensing.

Use the following table as a guide to understanding the panels you may encounter when
installing Rapid SQL:

Panel Description
Welcome... The start of the install process.
License Agreement This panel of the Installation Wizard displays the license agreement. To

continue the installation, click | accept the terms in the license agreement.
You cannot proceed to the next step in the installation if the | DO NOT accept
the terms in the license agreement option is selected.

Destination Folder Identify the folder where you want the program files to reside. The default
directory is C:\Program Files\Embarcadero\RSQL<version identifier>\.

Start Menu Lets you provide a Start menu group and optionally have an application icon
created on the desktop.
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Panel Description

Associate Files Specify whether you want files with extensions of .sqgl or .egb to be associated
with the Rapid SQL application.

Ready to install the program Review your settings and click Install to continue the installation process.
Installing... Displays the installation progress.

Setup Complete Finishes the installation process.

LICENSING

Each Embarcadero client application requires one or more licenses in order to run. An
Embarcadero product, such as Rapid SQL or ER/Studio, has a baseline license which provides
basic feature support for that product. In addition, incremental licenses may be required to
support specific DBMS platforms, product add-ons, or other functions.

For more information, see the following topics:

e Licensing Overview

e |icensing your Application

e Selecting a License Cateory During Startup

¢ Online/Offline Mode and Concurrent License Checkout

LICENSING OVERVIEW

The following topics provide a high-level discussion of key licensing topics and directs you to
sources of more detailed information.

e Viewing your License Type and Modules

Understanding Trial, Workstation, and Networked Licenses

Rapid SQL License Modules, DBMS Support, and Feature Availability

Rapid SQL XE License Modules, DBMS Support, and Feature Availability
Directing Queries Regarding Licenses

VIEWING YOUR LICENSE TYPE AND MODULES

The About... dialog, available from the Help menu, displays your license type and each
individual license module currently registered.
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UNDERSTANDING TRIAL, WORKSTATION, AND NETWORKED LICENSES
Three kinds of licenses are available: Trial, Workstation, and Networked.

Trial licenses A license for a 14-day, full-featured trial version of the product. The trial license must be
registered before you can use the product.

Workstation licensing A license or set of licenses is tied to a particular workstation. The product can only be
used on that workstation.

Networked licensing Networked licenses are administered and distributed by a central License Server
(Embarcadero License Center or Acresso FLEXnet Publisher). There are two types of
networked licenses: Concurrent and Networked Named User. With Concurrent licensing,
users on different machines take turns using licenses from a shared pool. With
Networked Named User licensing, licenses are pre-assigned to specific users setup on
the license server's user list. Those users are guaranteed to have licenses available any
time.

NOTE: Concurrent licenses can be borrowed for use without a network connection. For
details, see Online/Offline Mode and Concurrent License Checkout.

For a detailed description of licensing options, see http://www.embarcadero.com/software-
licensing-solutions.

RAPID SQL LICENSE MODULES, DBMS SUPPORT, AND FEATURE AVAILABILITY

Individual license modules correspond to the DBMS platforms you are licensed to use. In
addition, each DBMS license module corresponds to a product edition. Feature availability for
each license module edition is as follows:

e Standard - Provides baseline support including datasource management, object
management, SQL editing and execution, and standard tools and utilities.

® Professional - Standard edition features plus SQL Debugger, SQL Profiler, and Code
Analyst.

RapID SQL XE LICENSE MODULES, DBMS SUPPORT, AND FEATURE AVAILABILITY

An XE license provides access to all supported DBMS platforms. XE module and feature
availability is as follows:

¢ XE Pro - Provides baseline support including datasource management, object
management, SQL editing and execution, and standard tools and utilities, SQL Debugger,
SQL Profiler, and Code Analyst.

DIRECTING QUERIES REGARDING LICENSES

Questions regarding license availability, feature availability, and client or server licensing, should
be directed as follows:

e If you work in an organization that uses networked licensing, direct any questions to your
site’s Rapid SQL administrator.
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e |f you are using workstation licensing, direct licensing questions to your Embarcadero
Technologies representative.

LICENSING YOUR APPLICATION
See the following topics for details on registering your product:

e Registering a trial or workstation license during installation

® Registering a workstation license after application startup

® Registering by phone

e Registering a networked license

REGISTERING A TRIAL OR WORKSTATION LICENSE DURING INSTALLATION

Shortly after initiating download of a trial version of an Embarcadero product, you should receive
an email with a serial number you must register during installation. Similarly, if you purchase an
Embarcadero product while no trial version is active, you will receive a serial number that must
be registered during installation.

1 Start the installation. An Embarcadero License Registration dialog appears.
2 Copy the serial number from the email and paste it in the Serial Number field.

3 Enter your Embarcadero Developer Network account credentials in the Login or Email and
Password fields. If you have not previously created an EDN account, or have forgotten your
password, click | need to create ... or I've lost my password.

4 Click Register.

Your activation file should be downloaded and installed automatically. If this does not happen,
click the Trouble Connecting? Try Web Registration link and follow the prompts. If you still
have problems, see Registering by phone.

REGISTERING A WORKSTATION LICENSE AFTER APPLICATION STARTUP

The following instructions assume that you have received a workstation license by email and that
you currently have a valid trial license. If you did not install a trial version or the trial period has
expired, follow the instructions in Registering a Trial or Workstation License During Installation
instead.

1 On the Help menu select About and then on the dialog that opens, click Manage to open a
license manager dialog.

2 On the Serial menu, select Add.

3 Copy the serial number from the email and paste it in the Add Serial Number dialog, then
click OK.
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4 Right-click on the serial number you added, and then select Register from the context
menu. A registration dialog opens.

NOTE: The Registration Code box shows a machine-specific identifier required with other
registration methods.

5 Ensure that the Register using Online Registration radio box is selected.

6 Provide Developer Network credentials in the DN Login name or Email and DN Password
boxes. If you have not previously created an EDN account, or have forgotten your password,
click I need to create ... or I've lost my password.

7 Click Register.
8 If prompted to restart the application, click Yes.

Your activation file should be downloaded and installed automatically. If this does not happen,
click the Trouble Connecting? Try Web Registration link and follow the prompts. If you still
have problems, see Registering by phone.

REGISTERING BY PHONE
If you have problems with either of the above procedures, you can register licenses by phone.
You will have to provide:

e Developer Network credentials

¢ The registration code displayed in the Embarcadero License Registration dialog that
appears when you start an unlicensed application

The product base license serial number

The license serial numbers for any additional features you have purchased.

For North America, Latin America and Asia Pacific, call (415) 834-3131 option 2 and then follow
the prompts. The hours are Monday to Friday, 6:00 A.M. to 6:00 PM. Pacific time.

For Europe, Africa and the Middle East, call +44 (0)1628-684 494. The hours are Monday to
Friday, 2 A.M. to 5:30 PM. U.K. time.

Shortly after phoning in, you will receive an email containing an activation file. Then do the
following:

1 Save the file to the desktop or a scratch directory such as c: \temp.

2 On the Help menu select About and then on the dialog that opens, click Register. A
registration dialog opens.

3 Select the | have received an activation file (*.slip or reg*.txt) radio box.

4 Click the Browse button and use the Select License Activation File dialog to locate and
select the activation file you installed.

5 Click the Import button to import the activation file and when complete, click the Finish
button.
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6 If prompted to restart the application, click Yes.

REGISTERING A NETWORKED LICENSE
If you work in an organization using Networked licensing, an administrator, department head, or
someone performing a similar function will provide you with an activation file.

Once you receive the file, save it to the 1icense subfolder of your product’s main installation
folder (typically C:\Program Files\Embarcadero\<product><versions>\license\),
then restart the application.

No additional steps are necessary.

SELECTING A LICENSE CATEGORY DURING STARTUP

During Rapid SQL startup, if multiple concurrent license categories are available, you are
prompted to select a category to use for this Rapid SQL session. Multiple license categories can
be set up to provide differing feature access or access to different DBMS versions. Feature and
DBMS version access are typically distributed across multiple license categories to optimize use
of a site’s purchased licenses.

NOTE: This dialog also includes the option to remember your selection on subsequent
startups. If you select that option, you can subsequently use the Select Licenses button
on the About... dialog (Help > About) to select a different license.

Contact your License Administrator for details on individual license categories or requests for
additional feature or DBMS support.

ONLINE/OFFLINE MODE AND CONCURRENT LICENSE CHECKOUT

Concurrent licenses can be used in both online and offline modes. In online mode, you must
have a continuous network connection to your License Center. Licenses are checked out when
you start Rapid SQL and checked back in when you shut Rapid SQL down.

You can also use a license in offline mode. When you explicitly check out a license for offline use,
you can use Rapid SQL without a connection to your License Center for a specified duration.
This lets you work while travelling or commuting, work away from your primary work area, or use
Rapid SQL when a network connection is unavailable or not required.

NOTE: Contact your site administrator for information on offline license availability, the
maximum duration, offline license policy at your site, or any other issues arising from
online license usage.

To check out a license for offline use:

1 On the Help menu, select Checkout License. The Check Out Licenses For Offline Use
dialog opens.

2 Select the check box associated with each individual license you want to check out.
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3 Inthe Checkout Duration box, type the number of hours that you can use the offline license
without a network connection to the License Center.

4 Click OK.
You can work offline for the specified duration. The duration period begins immediately.

If you subsequently establish a network connection to the License Center before the license
duration expires, you can indicate to the License Center that the offline license is no longer
required.

To indicate that an offline license is no longer required:
1 On the Help menu, select Checkin License.

There is no interruption in Rapid SQL usage. The license is not actually checked in until you shut
down Rapid SQL.

ADDITIONAL PRODUCT RESOURCES

The Embarcadero Web site is an excellent source for product information and access to
additional resources:

¢ Release notes and product documentation

Information on other Embarcadero application and database development tools

Embarcadero Development Network

Product and technical support

Educational and product expertise material in the form of online demos, white papers, and
video presentations

e Access to sales staff and Embarcadero resellers

For access, direct your browser to www.embarcadero.com.
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TUTORIAL EXERCISES

The exercises that follow walk you through the Rapid SQL's major functional areas. After
completing these exercises, you will have the foundation you need to explore the many features
and benefits of Rapid SQL. You'll have learned how to competently manage the major database
administration and development tools provided.

This guide is divided into a set of sessions:

e Session 1: Getting Started

e Session 2: Productivity Enhancers

e Session 3: Scripting
e Session 4: Working with Code Workbench

e Session 5: Building a Database Project

e Session 6: Visual Query Builder

e Session 7: Live Data Editor

e Session 8: Code Analyst

e Session 9: SOL Debugging and Profiling

You can use this basic tutorial as a roadmap of product highlights, but also to help you find your
own path to explore Rapid SQL.

Once you've started, you can select Help Topics from the Help menu to find many additional
resources that complement and build on many of the activities shown in this tutorial.

SESSION 1: GETTING STARTED

Before anything else, you must perform the following tasks:

e Starting Rapid SOL

e Reqistering Cross-Platform Datasources

STARTING RAPID SQL
How you start Rapid SQL depends on the type of application you are evaluating:

* InstantOn version - start the application by double-clicking the file you downloaded.

e Fully-installed version - The Start menu sequence for Rapid SQL is always in the form
Programs > Embarcadero Rapid SQL version identifier > Embarcadero Rapid SQL
version identifier, where version identifier reflects the version you are running.
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To get started
1 Run Rapid SQL.

The first time Rapid SQL starts, a dialog opens, prompting you to set up datasources. In
addition to letting you manually set up individual datasources, a number of more
automated methods are available. If you have installed and used other Embarcadero tools,
Rapid SQL can find any active datasources being used by those tools. In addition, Rapid
SQL provides a Discover Datasources feature that automatically searches the DBMS
configuration files on your system for datasources that are not currently registered. Since
other Embarcadero tools let you export datasource definitions to file, you also have the
option of importing these definitions.

2 For the purpose of this tutorial, click Cancel. You will be registering a datasource manually.

The main Rapid SQL window opens.
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& TORLABORCL10g 2 (Oracle 10.2.0,3)
L TORLABORCL11g 1 (Orace 11.1.0.8)
& TORLABORCL11g 2 (Orace 11.1.0,8) | |
‘f Filters

l-I-l Check Constraints

---... Clusters

% Database Links
_L-g Directaries

(%] | iy e
h |:D Explarer El Favarites |

| Ready

A i

| | |
Explorer Talkb  Favourites Tab Application Workspace
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REGISTERING CROSS-PLATFORM DATASOURCES

For now, you will register a datasource manually.

On the Datasource menu, select Register Datasource. A Datasource Registration Wizard
opens.

-

Datasource Registration

Information |E=-31 =
Select the database tym L2

Datshase Tvpe | @t
Connection Information SR

: Y Microzaft SAL Server
Security Parameters
Dakasource Properties 'r::' hpSLIL
Dratasource Eroup i Oracle

' Sybaze Adaptive Server

" InterB aze/Firebird
() ODBC

| Hest » | | Firuzh | | Cancel | | Help

Choose Microsoft SQL Server as the DBMS type and then click Next.

Specify the Host name of an SQL Server datasource on your network, override the
Datasource Name with SAMPLE_DATASOURCE and then click Next.

Provide valid credentials in the User ID and Password boxes, and then select the Auto-
Connect? checkbox to eliminate having to provide credentials each time you connect to this
datasource.

In the left-hand pane, select Datasource Group, select the MS SQL Server folder, and then
click Finish.

NOTE: The Datasource Group panel also lets you assign a category to a datasource. This
provides a means to visually distinguish between different server purposes,
development vs. production, for example, in your enterprise. Categorization is a
customizable feature.

6 Select Yes when prompted to connect to the new datasource.

Rapid SQL offers the same easy-to-use Datasource Registration Wizard for all supported DBMS
platform connections. The connection information only needs to be set up one time for each
platform and can be saved locally or in a common datasource catalog for use by other
Embarcadero products.
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By default, Rapid SQL stores datasource definitions in the Windows Registry. There is also a
local, file-based option. Embarcadero products supporting these methods can share datasource
catalogs on the same machine.

There is also a network-shared storage option.

Rapid SQL also offers the ability to import and export datasource definitions. This lets you share
definitions among users and across datasource storage methods.

SESSION 2: PRODUCTIVITY ENHANCERS

This session focuses on some commonly used time-saving features:

e The Database Explorer Tree

¢ Creating an Object Using the Object Creation Wizard

e Working With an Existing Object Using the Object Editor

e Object Documentation and Reporting

e Working With Code, Files and Data

e Setting Environment Options

e Favorites Tab

e Working with Scripts and Files

® Viewing Data
e Retaining Datasource Explorer View Settings

e Datasource Explorer Bookmarks

e Setting Keyboard Shortcuts and Hotkeys

e Referencing Most Recently Used Datasources
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THE DATABASE EXPLORER TREE

Rapid SQL makes it easy and intuitive to navigate between datasources and to drill-down into
atomic database objects within the Database Explorer Tree. The Database Explorer Tree displays

all registered datasources and serves as the entry-point for much of Rapid SQL's advanced
functionality.

1 Click on the Explorer title bar and select Organize By Object Type.

Organizer o x

* Explorer - By Ohject Type | &
= Managed Datasources |
#{3 DB2 Servers

EiEs MS SOL Servers

2 Select and expand the SAMPLE_DATASOURCE > Databases > pubs node to display the
database object sub-nodes.

=] pubs
[+ 4—1—* Check Constraints
[+ ﬁ-u Database Triggers
i+ Defaults
[+-345 Foreign Keys

RAPID SQL XE 2/8.0.2 QUICK START GUIDE 21



TUTORIAL EXERCISES

CREATING AN OBJECT USING THE OBJECT CREATION WIZARD

From within the Database Explorer Tree you can create any database object using simple Object
Creation Wizards. The following is an example of how to use the Table Object Creation Wizard.
It is similar to the Object Creation Wizards available within Rapid SQL for all database objects
and other supported elements.

1 Right-click on the Tables node and select Create. A Create Table Wizard opens.

Create Table Wizard - Step 1 of 6 a @
Properties
Specify the kable properties.
Eropeilies Froperty Walue

=l Creation
Schema -
M arne
AMSI_MULLS option F

= Physical Storage
Partitioned Fl
Filegroup FG_ReadOnly -
Text Image Filegroup FG_ReadOnly -

Cancel | | Help

2 Select a Schema, provide a Name of SAMPLE_TABLE. Leave the remaining default settings
and click Next.

3 Add a column, using a Name of Sample_Column1 and select a Type of char. Experiment
with the Add Column and Delete buttons, and with selecting a column and modifying its
attributes.

4 Click Finish. The DDL View panel opens showing the DDL that will be used to create the
new table.

5 Deselect the Launch Object Editor After Execute and then click Execute.

Rapid SQL builds the platform-specific SQL code, syntactically-correct and ready to run the first
time. There is no SQL coding required in any of the Rapid SQL Object Creation Wizards.
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WORKING WITH AN EXISTING OBJECT USING THE OBJECT EDITOR

While the wizard offered you the option to automatically open an editor on creating the table,
you can also manually open an editor.

1 In the Database Explorer, ensure that the Tables node is expanded and then right-click on
your new table and select Open.

5 Zolumns ]
g Add Column + & Delete
# Marme Type Bull | Default Broity Vi
1 Sample...  char(1) i = Column Attributes [
Mame Sample_Calumnl Bl
Computed F
=l Datatype
Type char b
Size 1
illow Mullz
Sparze Column F
Default Collation SAL_Latinl_Gen_.=
Default Y alue x
= Bindings
Drefault Binding b
Rule Binding T [

Object Editor features are as follows:

All Object Editors provide standardized, multi-tabbed windows for each database object
type.

All Object Editors provide fully-functional toolbars for easy object management.

Rapid SQL has full knowledge of the underlying DBMS system catalog, syntax and
alteration rules, so the user can concentrate on what needs to be done, not on how to do

it.
Drop-down boxes allow you to easily move between owners and objects.

The Rapid SQL Object Editors easily perform operations that would normally require
painstaking and error-prone scripting, such as deleting or inserting columns in a table
while preserving data, dependencies and permissions. Rapid SQL analyzes the database
catalog to determine its structure, and then automatically generates the SQL script
required for the extended alteration. For instance, when a full table alteration is required,
Rapid SQL automatically unloads and reloads the data, eliminating tedious work.

2 Close the Object Editor window.
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OBJECT DOCUMENTATION AND REPORTING
Rapid SQL provides rich, detailed HTML Reporting for all database objects. Building a browser-
ready report for any object is only a few mouse-clicks away.

1 Expand the Tables node, right-click on any table and select Report from the menu. A
Generate Report dialog opens.

2 Select Detail Report (Report on each selected item) and click OK. A Report dialog opens.

3 Enter a destination Report Home Page File Name. This can be a network web server
directory.

4 Enter a Report Title and click Execute.

The HTML report will automatically be displayed in the Rapid SQL application workspace.
For example:

dbo.authors

Object Type Table

Datasource EE!T%EJB [ SOL Senver 08.0000760 )
Lagin sa

Database pubs

Report Date 41472003 168:54:45 847

Columns
Hame Datatype Hull Default Default Rule Binding
Binding
au_id id Mo
au_lnane varchan4dl) M
au_frname varchar(20) My
phane char(12) Mo TINENOWIN'

The HTML report can be saved to a new file or referenced in the file named above.

NOTE: All HTML reports are browser-ready and suitable for posting directly to the web.

WORKING WITH CODE, FILES AND DATA

Rapid SQL provides many features and powerful development tools for creating and executing
SQL code and working with data.

NOTE: For purposes of this Evaluation Guide, we are only covering high-level functionality of
the major features and tools within Rapid SQL.
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SETTING ENVIRONMENT OPTIONS

The Options dialog allows you to set the Rapid SQL development environment to meet your
needs.

1 Select File > Options from the menu. The Options dialog opens.

Dakasource
i laenerdl s D atazource Storage Management

Conneckion

Java (#1windows Registry datasource catalog

Logging Legacy datasource storage that iz compatible with previous verzions of Embarcadero

SMTP Mai S

Perf Center () File baged datasource catalog

ERyStudio Portal Datazources are ztored in the cument uzer's application data folder.

Reports {3 Metwork shared datasource catalog

Explorer Datazources are located in a common resource that iz shareable between mulliple uzers
+- 1500 Datazource changes are not propagated to other users and are not retained between
4 Debug inztances of this application.
+- DOL Exkract Location of thared managed datazources file;
+- Results P

Grid Propetties

Browsers : .

2 Recent D atazource List Contains: 8| Datazources [1-32]
‘Wersion Conkrol
Warnings Re-zart the Datazource Combo bazed on Connection state
efault to Alias Uzage ‘When Defining Mew Datazources

Data Transfer | [T Default to Alias Usage When Defining Mew Dat

Cracle Ukilities 5 e -

MySaL Utiities atazource Category Sethings

Direckaties Colar the statuz bar uzing the datazource's categon color

Hla Edlt'_:'r Color the tabs uging the datazource's categary color

Query Builder

DEMS JAYA Include categaory short name in the datasource toolbar combo

Code Analyst

The Options dialog has one page per option category. You select an option category in the left-
hand pane and can subsequently set options on that page. Options are applied when you click
OK.

2 Close the Options dialog.

FAVORITES TAB

The Favorites Tab provides a drag-and-drop library interface of all supported DBMS syntax, SQL
syntax, built-in functions, optimizer hints, and SQL-conditional syntax. Additionally, it provides
the ability to create custom folders to store commonly-used code for quick and efficient access,
as needed.

To open the Favorites Explorer:
1 At the bottom of the Explorer pane, click Favorites. The Favorites Explorer appears.

2 Expand the Microsoft node and then expand the Schema sub-node.
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3 Right-click the Procedures node and select Open. The selected code opens in the SQL
Editor window and is ready for execution.

4 Right-click in the editor window and select Close from the context menu.

To add a custom folder to the Favorites Explorer
1 Open the Favorites Explorer and right-click the Favorites folder.

2 Select New Folder from the menu. A new folder is added to the bottom of the tree view.

WORKING WITH SCRIPTS AND FILES

Rapid SQL extends the auto-generation of SQL code by allowing you to run your scripts across
multiple databases at the same time. In addition, there is the option to execute the code
immediately or schedule it to run later.

FILE EXECUTION FACILITY

Similar to the Script Execution Facility, files containing SQL scripts can be added to the File
Execution Facility and executed immediately or scheduled to run later. Other than the origin of
the code, all supporting functionality is the same.

1 On the Tools menu, select File Execution Facility. Rapid SQL opens the File Execution
Facility dialog box.

2 To locate the file you want to execute, click Add. Use the Add Files dialog box to locate and
select a file.

3 On the Target tab, select the datasources to run the script against.

4 On the Output tab, select the desired output option. For the purposes of this example,
select Graphical Output.

NOTE: To enable the scheduling function for the script, you must select the File Output
option.
5 If you want to send notification that the script has executed, on the Notify tab, complete the

target information.

6 Click Execute if you want Rapid SQL to run the script against the target datasources.
Otherwise, close the dialog without executing.

NOTE: Separate script output windows are created for each selected datasource.

SCRIPT EXECUTION FACILITY

The Tools menu also offers a Script Execution Facility. Similar to the File Execution facility, it lets
you type or paste the script to be executed.
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VIEWING DATA

Rapid SQL provides several options for browsing data. In addition, it gives you the ability to
construct even the most complex SQL statements with point-and-click ease.

SELECT * BROWSING

1 On the Database Explorer ensure that the Explorer tab is displayed and then expand the
MS SQL Server node.

2 Expand any database you know has table data, expand the Tables node, right-click a table,
and then click SELECT * FROM.

All columns and rows from the table are displayed in the active workspace.

3 Close the workspace window.

RETAINING DATASOURCE EXPLORER VIEW SETTINGS
1 Click on expandable settings at the top of the Explorer pane.

Qrganizer H X
= £y Databases (47) Organize by Object Owner
=[] adina :
Shows System Object k|
%+ Check Constraints e
+ i Defaults Show Only My Objects |
+-%2 Foreign Keys '
+- fr Functions Full Refresh
+ Indexes
- ":j& BiaEy kove Expand All Groups
+ I;—?a Procedures Collapse All Groups
+-44 Roles Collapse all Datasources
+-7 Rules
+Ad schemas Retain Yiew Settings

2 Select Retain View Settings.

The Explorer will open the next time just as you left it. All connections that were present when
you closed Rapid SQL will be re-established.
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DATASOURCE EXPLORER BOOKMARKS
Rapid SQL allows you to set bookmarks for frequently visited database objects.

1 Right-click on any node in the Datasource Explorer Tree.

[:]E Frocedures (217) |.
Hd AD Add Bookmark

..............

Bl ADM
Bl ADM
Ho ADM
ﬁ CLA @L: Open
F gy CLal X Drop..
£} |
[ OBy Report.
_.,% CLA, ﬁj Debug...
Bl CLA
Bl CLA
v clalpy
Bl CLAL
Bah CLAL =
Ez DEzs P | Execute

a® New..

Compile...

2 Select Add Bookmark and use the Add Friendly Bookmark Name dialog to optionally
provide a new name, and create the bookmark.

After Bookmarks are defined you can use them to easily navigate to commonly used datasource
resources using the Bookmarks menu.

il

| Bookmark Manager. ..

| SQL_‘-'fQ[\-'er » . dbo.procTable : Procedures @ pubs ROMLABSOLOS_Z
= 7 I":";‘; |
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The Bookmark Manager handles maintenance of Bookmarks.

1 Select Bookmarks > Bookmark Manager.

Bookmark Manager .

Bookrmarkz: Filker: | | I

(B> SOLServer
L3 dbo.procT able ; Procedures (8 pubs ROMLABSQLOS 2

ﬁ' 9&:} Delete . f") Help

=
o L

[1Da not show ‘Add Friendly Bookmark Mame' dialog, « Ok 3 Close

2 Close the Bookmark Manager dialog.

SETTING KEYBOARD SHORTCUTS AND HOTKEYS
1 On the Tools menu, select Customize.

2. In the Customize dialog go to the Keyboard tab.

-

Customize
Toolbarz | Toolz .Elpticuns ..-’-'-.pplicatinn‘u’isualﬁtylel Fepboard

Categony: Set Accelerator for:

= T I T =

| File: |v] | Default |v| 1@
Commands: Current K.eps:

1. [Ai
Arctive Script |
Cloze fileai
Cloze Project Femoe
Cloze Version Contral Filr

A Sl el = Press Mew Shorteut Key: Fiesat Al

Description:

=3

Cloze

The Keyboard tab can be used to set keyboard shortcut hotkeys for all areas of Rapid SQL
functionality.

3 Close the Customize dialog.
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REFERENCING MOST RECENTLY USED DATASOURCES
1 Select File > Recent Datasources and then select a datasource.

Receml\gata SOuUrces 4 ' TORLABSQLOS 1
|.4\r.; | I :
Recent Projects b | TORLABSQLO5_2
Recent Eiles y SAMPLE_DATASOURCEL

| Eat TORLABSQLOS 1

TORLABSY15 2
DALLASS

:_L.
2
3
4 TORLABSQLD5 9
5
]
7
8 BEOMLABSOQLO5 1

This will automatically place you on the datasource within the Explorer, ready to work with active
connection.

SESSION 3: SCRIPTING

This session looks at Rapid SQL's development environment:

e Generating Code

Right-click feature

Automated error detection and coding assistance

Other coding aids

GENERATING CODE

By providing several code generation and assistance options, Rapid SQL makes cross-platform
development easy for developers of all experience levels.

NOTE: The following examples build on the SQL Server 2000 SAMPLE_DATASOURCE
registered earlier in this Evaluation Guide. These examples can be applied to any
registered datasource for any of the supported platforms.

CODE GENERATION FACILITY

The Code Generation Facility can be used to create complete procedures, functions or
packages revolving around views or tables.

1 From the menu, open Tools > Code Generation Facility.

2 Select the SAMPLE_DATASOURCE datasource and the pubs database from the dropdown
list boxes.
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[ 1 pubs
dbo
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3 Select the authors table, state as the input column and all columns for output.

(#) Tables (0 Views

AjTH=00003
AjTH=00003
althors

b_table
combaodet
combohdr
compressionsa6d
dbolMVEMTORY
DEMOTABLE
doc_exhb
employes
extended_test

flo
Glabally_Unique_Data
INVEMTORY
job=

mytable
riytable 1
mytable_test
publizhers

Select 1 or Mare Where Clauze Calumiz

2 | &

4 Select Select as the code option.

Generate
Cbject Tvpe:

v Select
[hzert
| Update
Delete

5 Select a file to save the generated script and check Open.

Provide an Output File Hame

File:

Open

[C1Esecute Immediately

-]

| | |
iau 1d char[11] Mo [
au_lname varchar(40] Mo
au_frame varchar(20] Mo
phone char[12] Mo
addrezs varchar(40] Yes
L city varchar[20] ez ) |
[w state char[2] Yes |
4 | ¥ |
Select 1 or More Output Columns
| | |~
v au_id char[11] Mo [
¥ au_Iname varchar[40] Ho
v au_fname varchar[20] HNo
v phone char[12] Mo
v| address varchar[40] Yes
¥| city varchar[20] Yes
vl state char[2] Yes |
£ (>

6 Click OK and the DDL to create the procedure will be generated and displayed in an
editable window, called the DDL Editor. You can edit the name of the new procedure and
any of the generated code at this time. Name the new procedure sample_select_authors.
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7 Click on the Execute or Step Execute button to submit the DDL and create the procedure.

bbb

The indicated file will be saved on the selected directory.

NOTE: No SQL statement coding is required to generate complete stored procedures and
packages. If applicable, Rapid SQL allows all generated code to be previewed and
edited to fit any development need.

RIGHT-CLICK FEATURE

Similar to the Code Generation Facility, the “right-click” code generation feature can be used to
create complete procedures, functions or packages revolving around views or tables.

1 From the Database Explorer Tree, expand the SAMPLE_DATASOURCE > pubs > Tables
sub-node.

2 Right-click on the authors table.
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SE) Tables(13) I p *
el .o

B-E@ dbodsi Add Eookemark

- dbodip ...

[%}E A S bew. .

w0 doojot & oOpen

EE dbosut % prop..,

- dboput

S dbosoy M Report..

B0 dbo.sal

T

B0 dbosar & Rename,.,

#-[ dbosts Y3 Edit Data...

H-E dbotitle 2

&[0 dooutile [Z] Build Query. ..

- Tiggeis | [l1L Updste Statistics...

"J:E Unique et Creste Like...

e Users

:1}-%'.5 Usar Datati

i Views Indexes...

& tempdd Triggers. ..

Recompile,..

DECC...

Truncate...

Dizabla Triggers,..

Enable Trippers...

Create Insert Statements..,
Extrack Data ag £ML

3 Extract

@ ovjeatep
Dependencis
Deszonbe

T_E Schema

() Copy Mame(s)

@) SELECT * FROM

Selet
i Statements b Insert
= | |\Updste

Drebote

3 Select Generate > Procedure > Select.
4 Select state as the input column, and leave all output columns selected.

5 Click OK and the DDL to create the procedure will be generated and displayed in the DDL
Editor. You can edit the name of the new procedure and any of the generated code. Name
the new procedure sample_select_authors2.

6 Click on the Execute or Step Execute button to submit the DDL and create the procedure.

b b
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AUTOMATED ERROR DETECTION AND CODING ASSISTANCE

Rapid SQL provides a range of features that detect or help you avoid errors and save keystrokes
in developing your scripts.

To enable these features:

1
2
3

On the File menu select Options. The Options dialog opens.

In the left-hand pane, expand the ISQL node and then select Code Assist.
On the Code Assist panel:

e Ensure that Enable Code Complete is selected.

¢ Ensure that Severity levels for semantic validation problems has Warning selected.

e Ensure that Enable Real-time syntax checking is selected.
Click OK.

To see these features in action:

1

2

3

34

On the File menu, click New, and then ISQL.

Rapid SQL opens the SQL Editor window. You can add SQL code via your method of choice
(free-form typing, retrieve from a file, paste copied code, etc.).

(- - b A & h-O % ARA| A
i[s Select * from Jobs
2

{Auto Commit Off CUA WTORLABORCLLIOD 2system

D Explorerl ].J,ﬂ SQL1 * - \TORLABORCL10g \system X ﬂ

Type SELECT * FROM and stop typing.

Note the error condition.
i SELECT * EFROM

Rapid SQL can run a syntax check any time there is an interval of 1.5 seconds between
keystrokes. You can also disable automatic syntax checking and only run a check when you
manually initiate it. Syntax error annotation persists until you correct the problem.

This time type a fragment that includes the name of a nonexistent object, SELECT * FROM
NON.OBJECT, for example. For now, ignore any popups. The warning condition is a result
of on-the-fly semantic validation.

RAPID SQL XE 2/8.0.2 QUICK START GUIDE



TUTORIAL EXERCISES

1 & SELECT * FROM NDN.DBJECT|

Rapid SQL notifies you when a script contains a reference to an object that Rapid SQL
cannot resolve.

4 Type SELECT * FROM followed by a space and then stop typing. If no popup appears, press
CTRL+SPACE. The Code Complete suggestion box lets you select from objects or object
name components such as databases or schema. This feature saves keystrokes and
minimizes typing errors. See the online Help for full descriptions of these features.

5 Close the current SQL Editor window.

To restore Rapid SQL settings:
1 On the File menu select Options. The Options dialog opens.

2 On the Code Assist panel, click the Restore defaults button.

3 Click OK.

OTHER CODING AIDS

Rapid SQL provides extensive, easy-to-use coding aids for all of the supported DBMS platforms,
throughout the application. Aids are provided in the form of ready-to-use code templates and
blocks of syntactically correct code.

PAsTE SQL
1 From the Database Explorer Tree, expand the SAMPLE_DATASOURCE > pubs sub-node.

2 Select File > New > SQL to open an SQL Editor window.

3 Select Edit > Paste SQL Statement to open the Paste SQL window.
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4
5
6
7

v 5YS.ALLOCATION

] 5v5.4PPLY$_CONF_HDLR_COI
| 5SS APPLYE_COMSTRAINT_CC

L] 5YS.APPLYS _DEST_OBJ

L1 5v5.APPLYS_DEST_OBJ_CMAF
| S¥5.APPLYE_DEST_OBJ_OPS

[l 5v5.4PPLY$ ERRORA

[ S¥S.APPLY$ ERROR_HAMDLE
1 5Y5.APPLYS_ERROR_TxN
| 5v5.APPLYS_SOURCE_DE.

AT A L A LTI AL S el

| S%S.APPLY$_SOURCE_SCHEM |

[ Paste Tables A || AL

| HORIZOM_T¥PE_ID

| ALLOCATION_PERCENT

1 REFORT_DATE

SOURCE_ID

| ALLOCATION_ID
CREATE_USER_ID

CREATE_TIMESTAMP
LPDATE_USER_ID

| UPDATE_TIMESTAMP
L WALID_DATA FLAG

| SOURCE_MOTIOMAL

| SOURCE_AMOUNT

I
=

<

Paste SOL
Datasource Sample_Datazource - % Cancel
Database " 5 1.

#  Help
Chaner S5 -
Object Type | Tables = (®5elect ) Update O ngert () Delate
| TABLES COLUMNS | SELECT Statement
[ 5v5.ACCESSE [ | CLIEMT_ID 1

SYS.ALERT_QT ) PLAM_ID

)

In the Tables list, select authors.

Under the Columns list, click ALL.

Click the Select radio button.

Click Paste Statement to copy the generated code to the SQL Editor window.

You can use the statement as is, or modify the code as needed.

PASTE SQL SYNTAX
1 Select File > New > SQL to open a fresh SQL Editor window.

2 Select Edit > Paste SQL Syntax to open the SQL Syntax for SQL Server window.
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SQL Syntax for SOL Server

SOL Statements: Syntax:
= SOL Syntax ) a]: IF Boolean expression
£Hez SOL Commands [l = {gql statement |
~[5] alter database | statement block}
TS| pentable, : % [ELSE [Boolean expression]
beqgin distributed tranzactio T
~[2] case expression 2 Eral mtatonenty |
-[B checkpaint statement klock!}]
~[2] begin...end
~[2] goto Label
--[2] i el
-[2] retum
L [ create database ™
< F i s > T | 2 Paste l ¥ Cancel | 7 Help |

3 Select a template and click Paste to copy the code template into the SQL Editor window.

4 Add your own code to complete the needed operation.

SESSION 4: WORKING WITH CODE WORKBENCH

The Code Workbench lets you configure resources for two SQL Editor features:
e Code Templates
e Auto Replace

Code templates are complete code blocks that can be easily added to open windows or scripts
with a few keystrokes. When you type CTRL+SPACE, the Code Assist menu opens, letting you
select a code template for insertion in the editor window.

1
Loop - Loop expression

EH1F_ELSIF - If ElzelF Statememt [%
curzar_far - Curzor Faor Loop
for_loop - For Loop Expreszion

] | 3)

L™ | - bbb @G & k-6

1 @ [HIF <condition> THEN

2 <gtatement=si;

3@ |ELSIF <condition>

4 <statementsli;

5@ “ELSE <statements>;

& EMD IF:
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Auto Replace lets you define shortcuts consisting of a few characters that represent longer
character strings. Instances of these Auto Replace expressions are automatically replaced by the
replacement string on activation events such as typing SPACE, TAB, or RETURN. This feature is
useful for creating shortcuts for one-line commands or SQL statement subsets, or even to detect
and fix common typographical errors such as teh for the.

For example, consider an Auto Replace definition with an expression of sel to represent
Select * From:

Her =1 A 3]
1® =gl

If the associated activation event includes a SPACE, then on typing sel followed by pressing
SPACE, the following replacement occurs.

Rapid SQL loads a default set of Auto Replace and Code template definitions at startup but you
can also add, edit, and delete definitions. In addition, you can save sets of definitions to file and
subsequently load specific sets of definitions, allowing you to customize your templates to
different platforms or development projects.

To invoke Code Workbench settings:
1 Select Tools > Code Workbench.

Code Workbench @

Auto Replace

Enable Auto Replace [ 1Replace substrings

Code Templates

Enable Code Templates Edit Hot Kews

[Impnrt Settings] [Expu:urt Settings] Restore Settings 84 ] [ Cancel ] [ Help

The Settings tab lets you enable the Auto Replace and Code Template features.
2 Inspect the Code Templates and Auto Replace tabs.
3 Click OK.
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SESSION 5: BUILDING A DATABASE PROJECT

CREATING A NEW RAPID SQL PROJECT

Rapid SQL provides an excellent team development environment by allowing you to reverse
engineer live database objects into off-line SQL source code files that can then be easily added
to a Version Control System (VCS). Rapid SQL's seamless VCS integration offers all version
control operations, such as get, check-out, check-in, history and diff. This example will reverse
engineer the table objects from the Microsoft SQL Server pubs database into a Rapid SQL
project and then will add the project to version control under Microsoft Visual Source Safe.

1
2

N 00 N O

Select File > New > Project to open the wizard.

Enter sample_project as the name, and browse and select a directory that contains a VSS
database. Enter a description (optional). Select From Database and click OK.

Select SAMPLE_DATASOURCE and click Next.
Select pubs and click Next.

Select dbo as the owner. Right-click in the object type selection window and deselect all of
the options. Select only Tables. Under Extract Scope select Selected Objects Only. Click
Next.

Select only the authors, discounts, and employees tables.
Uncheck all selected Options for tables. Click Next.
Select Retain. Click Next.

Preview the last panel and click Execute.
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.

.New Project Reverse Engineering Wizard - Step 6 of 6 ﬁ

Freview Operation

sabMPLE_DATASOURCEY master  ChAATsample_project

“ou have chosen the following options and ohject types:

Bource Owner:
I Target Owner:
(Job Tynpe:

Object tvpes:

# Cancel H":' Help Hd:' Back | = Nex B Execute

- &

Target:

dho

Fetain Current Cwnership
Custom

Tahles

Finished! You have now successfully created a working database project. At this point, the
project is available to be added to Version Control. This can be done by clicking Yes when
prompted and following the dialog, or by right-clicking on the project within Project Explorer

tree. Select Yes for the purpose of this guide.

ADDING A PROJECT TO VERSION CONTROL (SAMPLE - MICROSOFT VISUAL SOURCE

SAFE)

When a project is created, Rapid SQL will automatically prompt you to add the project files to
the selected VCS solution. The following dialog will be displayed:

Visual SourceSafe Login

n,

Llsiriame: |

Password |

Database:  |Microsolt Visual Studid

] _cons |

Browss... |

Help

After providing a user name and password, you can browse to locate and select the project

database folder.
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Open SourceSafe Database

Username:  [seollw

[# Dpen this databare ney time | un Visual SourcaSala

All that remains is to provide a project name.

REdT0 Saurcesate Project’ 5}
Erajest
o
4 |
S _ Dese |
=-| Az lesl
8 SOL_SERVER_Baseine il

Finished! The following message indicates that the project was successfully placed under
version control.

r’Ruiﬂd'StH. ﬁ"

L] The files in project sampls - project.apj have been placed under version control in & Yisuad Source Safe project named
. sample_project. epj.

SESSION 6: VISUAL QUERY BUILDER

Rapid SQL gives you the ability to construct complex SQL statements with point-and-click ease
using the Visual Query Builder.

1 From the Database Explorer Tree, right-click on the authors table and select Build Query.

The authors table will be automatically added to the Query Builder workspace.
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2 On the Tables/Views tab, right-click on the titleauthor table and select Add.

Note that the tables are automatically identified as being joined by any columns with the

same name and datatype.

m| [T Ao p|n s x| & M
DML
x|
"!m tﬂ WETHT L
[ 40 Dyeriers »| | l2dau_lname
—4 Table -~ -
[ suthoesidbol plizne ] e
th \Jadidress a0 id ]
Wl decounts(dbo) e
5 ety TThitie id P
H0 employes(dho) 2
w0 ibldbol state LJau_ord
M pub_infoldbo) —Jap Hroyaiiyper
[ publishersidbal .Jcontract
&M ropsched|do]
w0 salesidbo) ¥ &
Osa |
use pubs
go
SELECT dbo.authors.au lname.
dbo authors au_fname
dbo_authors  phone,
dbo.titleauthor rovaltvyper
FROM dbo authors, dbo. titleauthor
WHERE (dbo_authors au_id = dbo.titlesuthor au_id)
<

[E] DueyBuiden

3 Click on the DML tab to expose the visual query building clauses and options. You can right-
click on any clause to easily add the code to the query.

Tableziews

{3 SELECT

LW ALL

=@ FROM

- dboauthors

-E dbotitleauthar
-y COLUMNS

-5 dbo.authors.au_lhame
dbio.authars. au_frame
- dbo.authors.phone
-E dbotitleauthor. royaltyper
" N e

E| gﬁ{-‘ Mew, .,
L__EE'?EE__ au_id = dba itk
-8 0ORDERBY

- = GROUPBY

H HAYING

]
L

|
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4 Select the au_Ilname, au_fname, and phone check boxes in the authors table.
Note that the lower pane shows the query that is being built.

5 Click the Execute button to execute the query.

b

The results will display in the lower window.

Before closing the Query Builder, experiment with additional options. Try selecting a different
statement type, such as Insert or Update, from the dropdown at the top of the Query Builder
window. Use the different clauses on the DML tab.

NOTE: Any visual query builder session can easily be saved to a file for later use.

SESSION 7: LIVE DATA EDITOR
1 From the Database Explorer Tree, right-click on the authors table and select Edit Data.

2 In the Data Editor Filter dialog, click Add All to add all columns to the editing session.

At this point, you can add a WHERE clause that will filter for only the desired data. Note that
Rapid SQL builds the SQL to retrieve the data to be edited in the Select Statement area.

3 Click OK. A Data Editor opens.

i dbo.authors - \ROMLABSQLOO_1\pubsisa = 2/E3
@ | LIVE ) P | 5 # X & | A :._=_| 4 M ¥ ﬁ '3- | Loy
|ﬁ' au_jd | au_lname | au_fname | phone | address ‘A
b [172-32-1176)White Johnsan 408 406-7223 10932 Bigge Rd. =
2 213-46-8915 ‘Green Marjorie 413 986-7020 309 6ard St #411
3 238-95-7766 (Carson _.Cheryl 415 345-7723 589 Darwin Ln.
4 267-41-2394 :O'Leary Michael 408 286-2428 122 Cleveland Av, #1
5 |274-80-9391 Straight Dean 415 824-2010 5420 College Av, v
¢ | i)
1 -— Initial Select Statement 4/14/2009 09:58:|s)
o —— ======—=—=—=—=—=—==—=—=—==—=—=—=—===—===—====—=========: | |
3 SELECT T.au_id; T.au_lname, T.au fname, T.pl|
T.ztate, T.zip, T.contract FROM dbo.author:
4 s
i

Note the dropdown at the left of the toolbar. The editing window has LIVE and BATCH modes:

¢ LIVE mode commits your changes each time you move to a new row.
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e BATCH mode will allow you to move within the window and commit your changes when
ready. Changes made in BATCH mode can be cancelled by selecting the Reload Data icon.

At any time during the session, you can change the filter parameters by selecting the Filter Data
icon.

by

SESSION 8: CODE ANALYST

The Code Analyst allows you to capture run-time statistics on executable database objects,
including stored procedures and functions. Not only can you capture statistics for single objects,
but you can group more than one object.

To get started
1 Select Tools > Code Analyst.

NOTE: In order for Code Analyst to run, 5 repository tables will be created on the database.
Select the database you would like the tables to be installed on and press OK. Once
the tables are installed, you're ready to start defining a session.

2 On the Code Analyst toolbar, click the Create New Collection button.

3 On the Code Analyst Object Selection dialog, provide a Session Name, locate and
selecting the objects to be executed, and click Next.
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Code Analyst Object Selection

Session Mame | Session!

* Selectby Owner [ Select by Object

- DEI'
# [ master
+ [Jrmodsl
+ [ rosdb
+ Dfﬂ:q’th‘."ﬂl‘ld
= DPI-IEIS
- O&o
= OProcedures
Elbyrovvaly
Crentqgl
Oreptaz
Oreptga

=]

| __tep |

=

4 Use the Code Analyst Object Initialization dialog to initiate providing input parameters as

required, change the order of execution, and when ready, click Finish.

Once the session has been run, the total time for the execution is displayed in the Run

Summary tab.

5 Select the other tabs to view the tabular and graphical representation of the execution
details on your selected objects. For example:

® The Run Detail tab shows a breakdown of the different objects that make up the session.

¢ The Unit Detail tab contains the specific time measurements for individual SQL

statements.

6 Close the Code Analyst window.

SESSION 9: SQL DEBUGGING AND PROFILING
Rapid SQL offers the following facilities that help you test and optimize code:

e SQOL Debuggin
e SQOL Profiling- Oracle Only
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SQL DEBUGGING
The SQL Debugger is another database productivity tool that lets you debug SQL Server,

Oracle, Sybase or DB2 stored procedures as well as Oracle functions. SQL Debugger simplifies

the task of finding coding errors.

1
2
3

4

46

In the Explorer, expand the Procedure or Function node.
Right-click the object and select Debug from the context menu.

If the procedure or function takes input parameters, the Procedure Execution window
prompts you to enter values.

[ Procedure Execution - dbo.byroyalty ] X

Ol Frocedure:
dho krarya ity
Farameter:

Mame |TypE | NULLI DEfﬂuIt| Yalue

i B

{@percentage int

Inputvalues
@  Open ‘ ‘ Save ‘ ‘ 8 Beset ‘
‘x Cancel ‘ ‘ 2 Help ‘ ‘ B Continug

Enter input values(s) and press Continue.
TIP: Rapid SQL allows the user to save the input variable values to a file for later use. This

is very helpful for procedures/functions with many input variables that need to be run
repeatedly.

The application opens the SQL Debugger Interface.
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=Ty AL SANEMESE=NRSIR Y
1 gr Procedure PARSE SAME IS
= re integer default 0O;
3 1 cursor integer default 0;
4 E! BEEGIM
5 =] FoOrR 1 IN 1..1 LoOOP
& 1 cursor:=dbm= =gl.open cursor;
7 dbm= =sgql.parse (1l cursor,
a TSELECT ¥ FECOM DAL ;dbms_sql.native);
= FOR j IN 1..400000 LOOP
Al rc:=dkbkms sql.execute(l cursor);
11 rc:=DBMS SQL.FETCH ROWS (1 cursor);
1= END LOOQE;
L5 < dbmz =gl.cloze curscril cursor);
14 END LOOE;
15 END;
Debugaer - Wakch and Yariable Windows X Debugger - Dependency and Call Stack Windows x
Name | Value | Type | |[o FCODRUTAFEASE SEMED Line: 1
1= [NULL  |integer
|_cursar [MULL | integer
q \\ @ Yariables I .@ _'-.-'u'al;cln I B4 Y @ CallStack, L & D_Epe_ndgrq;_;-{ | B
Auta Cammit OFF \TORLABORCLL1g ;& | ¢ i

The Debugger features basic execution, line-by-line execution, breakpoint support, and other
common debugging features. For details, refer to the relevant online Help topics.

SQL PROFILING- ORACLE ONLY

The SQL Profiler within Rapid SQL provides the ability to capture the metrics of various PL/SQL
programmable objects as they are executed in the database. It quickly identifies performance
bottlenecks by first calculating the overall runtimes of objects like Oracle packages, and then
computing the amount of time each line of PL/SQL code spends executing. Information is
presented in an easily viewed, drill-down format.

1 To start a profiling session, use the Tools menu option and select SQL Profiler > Start.

2 Enter a name for the profiling session or select an existing name from the dropdown. Press
OK. The Profile session is now active.
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~

ﬁQL Profiler - Start

Frofile Camment:

| v

v % Cancel ‘ "‘:" Help ‘

3 Execute the programmable object (i.e. Stored Procedure) you wish to capture metrics on.

4 When finished, select Tools > SQL Profiler > Stop. The SQL Profiler — Stop dialog window
prompts you to select an option.

” =

ﬁQL Profiler - Stop ﬁ

Do ywou now wish to end the
current profiling session and
record any unrecorded data
collected so far in this session in
the databasze?

otop & Analyze

atop

Cancel

Help

5 Press Stop.
6 On the Explorer, expand the PL/SQL Code Profiling node.

* Explorer- By Object Type |~
"'1 Fackage Bodies '
E FL/SOL Code Profiling (3)

‘ Tl il .

. B @ a "i Add Bookmark I
H-@ tes ‘
28 Prima! D start

B Proce| [ll] Run Summary

. i T LT T =T TTETEY
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7 Right-click on the profile session and select Run Summary. The Run Summary window
opens.

Comment;
My_Profile v

-Fun Summary

Comment Run ID Run Date Total Time (ms)
Why_Profile 60 :01,/09/2009 12:00:43 PM 47261 i
My_Profile ; 61 01/09/2000 12:01:52 FM 5484

8 Select a session and select Run Detail from the right-click menu. The Run Detail screen
appears allowing you to view the metrics for this execution in both a graphical and text

format.
Comment Run Urs Type: Urst Owner.
|craate_sdmission) | |[Run®) @MN0/20030256.05PM  w| |[[AN Types) ~| [ERaDMIN
&
Time Und 0 = Uit Execution Teme (ms) Und Time % of Run Totw

v MiBiteconds jma B 32 SYS DBMS_OUTRUT 300

~ Seconds fsec) [ 16 SYS DEMS_PROFLER 0

M : 11 <anonymouss canofymouss 200

rutes fmn) 07 «ancermous » <anoiymouss 150

B 7 canoerymous s canooyTmiouss 100

18] | [ 7 cantrymouss <ancrrymous> 0

B 6 <ancoymoLs» <anonymouss 0

Unit Owner | Unit Mame | Unit Type | TotastTime(ms) | % of Total |

ERADMN CREATE_ADMISSION PROCEDURE 02 008
SYS DEMS _OUTPUT PACHAGE BODY n o
SYS DEMS_PROFLER PACKACGE BODY 16 0005
L T <AL ANCNYMOUS BLOCK 1 0003
CANOCTTIORISS RIS ANONYMOUS BLOCK 7 0002
CANOMTTHoUE wANORYTROUE ANONYMOUS BLOCK 7 0002
CANOTTY TS B e T ANONYMOUS BLOCK T 0002
CANOTYTOLE L e T ANONYMOUS BLOCK ] 0002
AT TTOAE SOOI ANONYMOUS BLOCK 5 0002
AT I AT AN IS B O6CH n n

9 To drill down further into the data, highlight a unit and select Unit Detail from the right-click
menu. Scroll through the Source window to view the times for each statement.

10 To compare 2 cases, select the 2 cases you wish to compare (shift-click to select the second
case) from the Run Summary screen and select Compare from the right-click menu. The
SQL Profiler Run Comparison screen appears.

See the relevant online Help topics for more information on profiling.
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NEW FEATURES

This release introduces new or updated features in the following categories:

e Updated DBMS Version Support

SQL Server Feature Support

Oracle Feature Support

Sybase Feature Support

e Datasource/Server Updates

Unicode updates
SQOL Editor

User interface changes and related features

UPDATED DBMS VERSION SUPPORT

Rapid SQL now provides support for IBM DB2 for Linux, Unix, and Windows version 9.7. All
current Rapid SQL functionality is now available on this platform version.

SQL SERVER FEATURE SUPPORT
The following topics describe updated support for SQL Server features.

Synonym Support

This release introduces support for SQL Server synonyms. You can now create a one-part object
name used in SQL statements to reference a partially-qualified to fully-qualified, multi-part
object name. A new wizard and editor are provided and a basic set of object operations is also
available.

- =¥ dbo
Property Walue % a Lreate
Q

Permissions SRS iben
DDL Yiew Schema dbo = % Do
g:rr::r MySynonym CI% | Eutract
Databaze adina = E‘-ﬁ’, Migrate
Referenced Object Type Table hd E&l Repork
Referenced Object Dwner dbo A
Feferenced Object Mame primary_ a - ﬁ’ Rename...
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Table and Index Partitioning

This release introduces support for table and index partitioning on SQL Server. Both Wizards/
Editors now include a Partitioned property that enables partitioning, and a Partition Scheme
property used to reference a new object type that lets you specify a file group mapping. The
Partition Scheme, in turn, references another new object type, a Partition Function, that maps
the rows of a table or index into partitions based on values of a specified column.

Paticred

Partition Scheme zasd -
Properties
Specify the partition scheme properties.
Property Walle
: = Creation
M arne
Properties Partition Functian -
Specify the partition Function propef
L
S R R : I;:Iegru?uuz M armne
Nome o -
= Attributes i
[nput Parameter Tupe ift x
Range LEFT -

Function Yalues

A full set of Wizards, Editors, and object operations are available for the new object types.

Full-text Search Support

Full-text Catalogs and Full-text Indexes are now supported object types in Rapid SQL, letting
you set up the indexes that aid linguistic/proximity searches and the files to store those indexes.
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Properties
Specify the Full-text index properties,
= Creation
. Farent Type Table -
Farent Schema | -
_ . an Properties
il Specify the Full-text catalog properties

Full-text Catalog Mame
- fropeies Froperty " alue

Filegroup Hame -

Change Tracking = st
Stoplist Name |
Accent Sensitive
Drefalt Fi
Avthonzation Dwner *

A set of associated object actions lets you rebuild catalogs, merge smaller indexes, enable and
disable indexes, and provide native control options for index population.

DDL Triggers
Rapid SQL now provides support for SQL Server DDL Triggers. These triggers fire in response to
DDL events. Support provided is as follows:

e Database Trigger object type — builds and submits CREATE TRIGGER... ON DATABASE

statements
Froperty Value
Trigger Events i reahon
Definition T MyDDLTrigger
= |Attributes
Trigger Timing Lelian '
Fronedes [CJB0D_COUNTER SIGHATURE i
| | JADD_ROLE_MEMBER 1l
Properties %3 = Q:t @ @
Trigger Events L - .
|DﬁWMn | 1 CREATE TRIGZER MyDDLTrigger
2 O DATABASE FOR DROF TABLE AZ
3 PRINT 'You must disable Trigger
"gsafety " to drop or alter tableszsl!
4 EOLLEACK

A Change Status object action lets you enable or disable triggers.
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ORACLE FEATURE SUPPORT

The following topics describe updated support for Oracle features.

DBMS_STATS procedure call availability with Analyze object action

The Analyze object action, available against clusters, indexes (primary keys, unique keys), and
tables, now offers options corresponding to DBMS_STATS package procedure calls. The
following table displays the new Rapid SQL options available in the Analyze wizard and the
corresponding DBMS_STATS procedure calls generated for those options:

Rapid SQL Analyze wizard option DBMS_STATS call generated

Gather Statistics DBMS_STATS.GATHER_INDEX_STATS
DBMS_STATS.GATHER_TABLE_STATS,

Delete Statistics DBMS_STATS.DELETE_INDEX_STATS
DBMS_STATS.DELETE_TABLE_STATS

Import Statistics DBMS_STATS.IMPORT_INDEX_STATS
DBMS_STATS.IMPORT_TABLE_STATS

Virtual Columns

Against Oracle 11g datasources, Rapid SQL now supports virtual columns. When defining a
column in the Table Editor, you can use the new Virtual property to define a column as virtual.
You then use the Default Value control to enter a valid Oracle column expression defining the
virtual column.

=l Column Attributes

Mame cl
I Wirtual |
= Dratatype
Type inkeger -
nuzed F
Allows Hullz
= Encryption
Encrypted ]
[ Default Value cl +c2 | -

Unusable Index Partition visibility

Opened against a partitioned index, the Index Editor’s Partition tab now displays whether
Oracle has marked a partition definition as unusable.
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Temporary Tablespace Group Support

The Tablespace Wizard now has a Tablespace Group control available when creating
TEMPORARY tablespaces.

Properties
Specify the tablespace properties. @

Eiopetins Property YWalue

= Creaton

Mame
= Tablezpace
Eig File L
Type TEMFPORARY A
T ablezpace Group
E—Emeryption

* Storage

Temporary tablespace group support provides the following benefits:

e Multiple default temporary tablespaces can be specified at the database level.
e Users can make simultaneous use of multiple temporary tablespaces in different sessions.

¢ Single SQL operations can make use of multiple temporary tablespaces for sorting.

Invisible Indexes

For Oracle 11g datasources, Rapid SQL now supports invisible indexes. Both the Index Wizard
and Index Editor have an Invisible property. This property lets you include an INVISIBLE clause
with the CREATE INDEX statement in the DDL generated to create or edit the index. Invisible

indexes are not used by the optimizer during queries unless the
OPTIMIZER_USE_INVISIBLE_INDEXES parameter is set to TRUE at the session or system level.

Properties
Specify the index properties, Q)
Ergperties Property Walle
Colurnrs = |Attributes ||
Jtorage Index Type IMIQUE B
Partition Mo Sart Ol
DDL Yigw Logging YES x|
Reverze ]
Function-B ased F .
I rvisible ]
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Read-only Table Support
A new Change Access Status action lets you toggle a table between READ ONLY and READ/
WRITE modes.

Change Access Status - @
I Adinpontings | 1 object(z] for changing access status:
Dependencies sl
- |CMLREAD OMLY 01 _%
= Change Table Access Status
Fiead-only
Head.-unly
Setz the table in READ OMLY or READ WRITE mode.
Tablez marked as READ OMLY block DML operations
. againzt them.
Preview | | Schedule Back | MNewt » | | Execute | | Cancel | | Help |

The Oracle Tables Editor and the Browser display for an Oracle table have both been updated
to indicate the current READ ONLY mode status.

Online Reorganize Tables Option

When executed against Oracle tables, the Reorganize object action now offers an Online
option. During an online reorganization, the table can still be accessed using DML statements

like SELECT and UPDATE.

=

{.
Reorganize @
I fckion Options 1 object(z] to reorganize
Cependencies A.alnzeeze E: Al
Preview = Reorganize method EA}
Online L =
=I. T ablezpace TR
T ablezpace -
= DataBlockStorage
Fercent Free =
Parrent | 1zad :V!
Preview | | Schedule 3 Mexst » | | Execute | | Cancel | | Help

Online reorganization is implemented using DBMS_REDEFINITION procedures.
DBMS_REDEFINITION is Oracle’s online table reorganization package and is available as of
Oracle 9i.
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Recycle Bin Support

This release introduces support for the Oracle Recycle Bin, letting you retain dropped tables and
associated objects until they are explicitly purged. The Recycle Bin can be enabled and disabled
at the datasource node level.

=71 Oracle Servers

| $ Disconnect
= Hls| ROMLABORCL
DE‘ Change Graup. ..
| | Edit
%1 nreqgisker _
| =t . . =W
| Elml| Register Like | Data Load
Eﬂ Monitor E",'_*J Data Unload
l:',:"’J Configure. .. E; Export...
| B3 Extract 8 Import...
| B Migrate. .. | 8= Analyze...
| Command ¥ |18 Enable Recyds Bin. g,

S =

Expanding the Recycle Bin node displays the current contents of the Recycle Bin. Object actions
available against objects currently in the Recycle Bin offer a variety of purge, recover, and
querying options.

CMLIVE BIN$fbxHSmMPETPERC. .
@ Select * From E

@-C Flashback Recycle Bin Entry. ..
q Purge Recycle Bin Entry...

Purge Recycle Bin...

FLASHBACK TABLE Action Support

A Flashback Table action now available against Oracle tables, lets you restore a table to some
previous state. Options let you restore to a timestamp, an SCN, or a defined Restore Point. For
tables in the Recycle Bin, you can restore the table to its state before being dropped.

SYBASE FEATURE SUPPORT
The following topics describe updated support for Sybase features.

Login Trigger Support

You can now configure a login to have a procedure executed each time a user logs in
successfully. The Add/Modify Login Trigger object action lets you configure any stored
procedure on the user's default database as a login trigger. The Drop Login Trigger object
action lets you drop a configured login trigger from a login.
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r[]rup Login T'rigger i @W
sl = |
. % Add/Modify Login Trigger = @
£
;'Diff;“m pral ﬁct"f“-?'_jt‘D”s | 1 objects(s) to be added/madified:
I;L,;"I":I;EI'I'IE - E%A%i}hudir Login Trigger
z g:f:ﬁl:illa I : Lagin F'ru:u:e;ure . |g'—:|:
Default lar
LDDF!E&I - AN
Lagin trigger
{J " | Presview | |§chedule| _. Bac | Memt » | | E:-:ecute| | Cancel | | Help |

When a login is configured with a login trigger, the stored procedure name is visible as a Login
trigger property in the Logins Editor.

Support for sp_hidetext

This release introduces support for the sp_hidetext system procedure. A new Hide Text object
action lets you hide the source text for supported, compiled objects.

't} Databases " =
4-1-' heck Constraing Confirm Hide Text @
Ml Defauls 7 7
2 Extended Proceq | ctian Options | 1 object(s] to be hidden:
fr Functions Dependencies S
* Prasiom dbokest
5% Procedures
M Rules
Tables
|j—L| Triggers
o Users : i
& Views | Preview | |§chedule | | « Back | Mext » | | Execute | | Cancel | | Help |
DESTRUCTIYE ACTION - PLEASE CONFIRM

INSTEAD OF Triggers

The Trigger Wizard and Trigger Editor have been updated to support the INSTEAD OF form of
CREATE TRIGGER statements. Now, when you select a Parent Type of View for a trigger, the
wizard generates customizable INSTEAD OF trigger code syntax on the Definition tab.
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NEW FEATURES

Properties
Specify the trigger properties.,

Properties

Enter the definition bodsy.

Property Walle
= Creation (|
Farent Type Yiew Sl
Definition

a2

Properties % = %t 53 1§|
Definition | = . .
1 CREATE TREIGZEER dbo.MyViewlTrigger
2 OH dbo.eese
3 INSTEAD OF IMNSEERT, UPDATE, DELETE AS

Launch Object Editor After Execute

User-defined Functions

This release provides support for Sybase user-defined functions. A new wizard and editor are
provided. The wizard generates CREATE FUNCTION syntax, letting you provide the body of the
function. A basic set of object operations is also provided.

s

Create Function Wizard - Step 1 of 2

5

fx ax
Properties ﬁ‘{ codite
Specify the function properties, e dbo }9‘&'. Create
1 frdbo | ©L Open
_ ErOpeisEs Property Walue fxdbo | % Drop
Definition S aatan for dbo P Eutract
Owner dbo fx dbo %: iyt
M ame MyFunction fx dbo | . L
3 Jx dbo | D% | Report p—
Create Function Wizard - Step 2 of 2 i [ ﬂ
| Rename, ..
Definition Jax dho J _
Enker the definition body, fx qag | Hide Texk. .. o
= Properties [ % = %t EZ'} 1%
Defirition | & .
1 CREATE FUNCTION dbo.MyFunction [ )
2 EETUENE
5} AR
4 E| BEGEIHN
Launch Object Editar After Execute
Execute | | LCancel | | Help
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NEW FEATURES

DATASOURCE/SERVER UPDATES

JDBC Driver Availability

When registering or editing datasources, most third-party JDBC driver options are no longer
available. InterBase datasources are the only exception.

Current Session Role Activation

For Oracle and Sybase datasources, you can now activate and deactivate roles for the current
login or user within the current session. The Role Activation feature lets you build and submit
SET ROLE commands.

—

=105 Cracle Servers

Gl ROWLABORELT0E 2 Braeis| Role Activation : @ L
=) Svbase Servers | Fole Activation Please select the role you want ko activate or deactivate:
(= ﬂ TORIABESYIENT S fcibann o ) v
F[@ Riiiaaicy Fale Active | Default | Pazsword
: i za_role es
7| Change Group. . z20_role Yeg
| Edit oper_role Yeg
% Unregister sybaze_tz role Yes
= . . eaz_admin [ Mo
Register Like
L=l s 2as_Lzer ] Mo
| &4 | Role Activation... mon_role Yes
| Cancel | | Help

UNICODE UPDATES
Unicode character-handling has been improved in the SQL Editor and Data Editor. This includes:

¢ Improved encoding detection and options when saving and opening files.

e Additional UTF-8, UTF-16, and UTF-32 encodings with BOM and endian variations are now
available.

e Handling of surrogate pairs and characters made up of multiple Unicode characters (LTR
scripts only) have been brought in line with Windows Vista and Windows 7 support.
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NEW FEATURES

SQL EDITOR

Query Options Supporting Sybase Set Option Text Format Messages

If you are using the sa_role or have the set tracing permission, you can now set the
query environment to generate diagnostic output in text format. The Query Options
dialog now offers all show... option variations for the Set command.

Query Options
Cption Walue
= Text Format [ |

Show Default r
Show Lop Drefauilt *

Show Managers Drefauilt -
Show Propz Default x
Show Parallel Default x =

Show Higtograms Drefault x
Show Abstract Plan Default -

Show Search Engine Drefauilt *
Show Counters Drefauilt *

Show Best Plan Default =

Show Code Gen Default x|

Show Pio Cozting Default &l |

Show Lio Costing Default e 1

Show Pll Costing Diefault -

Show Elirmination Default -

Show Mizzing Stats Drefauilt 2 [ |

USER INTERFACE CHANGES AND RELATED FEATURES

Continuing from previous releases, this release features reworked object management editors
and wizards. By DBMS platform:

¢ Oracle - Tablespaces
® SQL Server - Logins

¢ Sybase - Logins, Groups, User Messages
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