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Mobile Tutorials: Mobile Application Development (iOS and Android)

Mobile Tutorials: Mobile Application
Development (iOS and Android)
This integrated set of tutorials walks you through development of a Delphi or C++
multi-device application for iOS and Android:
o

After the three initial setup tutorials, the first tutorial shows you how to
construct an iOS or Android application using FireMonkey tools.

o

The remaining tutorials demonstrate the recommended FireMonkey
components to use in order to achieve a native look-and-feel in your iOS
and Android applications.

These mobile tutorials are also available in PDF format here:
http://docs.embarcadero.com/products/rad_studio/radstudioXE7/Mobile_Tutori
als_en.pdf

Setup
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o

Set Up Your Development Environment on the Mac
(iOS)

o

Set Up Your Development Environment on Windows
PC (iOS)

o

Set Up Your Development Environment on Windows
PC (Android)
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Using Basic User Interface Elements

Using Basic User Interface Elements
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Using LiveBindings to Populate a ListBox (iOS and
Android)

o

Using Layout to Adjust Different Form Sizes or
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Using Device Functionality
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Using Backend as a Service

Using Backend as a Service
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Mobile Tutorial: Set Up Your Development Environment on the Mac (iOS)

Mobile Tutorial: Set Up Your
Development Environment on the
Mac (iOS)
A FireMonkey Delphi application destined for the iOS target platform can be
optionally tested on the iOS Simulator available on the Mac. FireMonkey C++
and Delphi applications can be tested using the iOS Device target platform; this
testing requires a test iOS device connected to the Mac.
o

The first half of this tutorial describes the steps that you need to perform in
order to run your iOS application (Delphi only) on the iOS Simulator on the
Mac.

o

The second half of this tutorial describes additional steps required in order
to run your iOS application (Delphi or C++) on your iOS Device.

Note: The iOS Simulator is not supported by BCCIOSARM, the C++ Compiler for
the iOS Device. Only iOS devices are supported by BCCIOSARM.

Requirements on the Mac and iOS
o

10.8 Mountain Lion

o

10.9 Mavericks

o

10.10 Yosemite

(Neither OS is supported on legacy PowerPC- and 680x0-based Macintosh
systems. All Macs since 2007 are Intel-based; all Macs since 2008 are 64-bit.)
o

For Mac OS X development, the latest version of Xcode

o

For iOS development, the latest version of the iOS SDK and Xcode
installed, along with the Xcode command line tools.

Note: RAD Studio does not support versions of the iOS SDK lower than 8.0.
o

Membership in one of several Apple Developer Programs, which are
described in this topic under Sign up for a Developer account.

o

An iOS device connected to the Mac by USB port (required for testing or
running your iOS app on the device)
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Mobile Tutorial: Set Up Your Development Environment on the Mac (iOS)

Steps to Configure Your Mac to Run Your iOS
Application
To deploy an iOS application to your device for debugging and testing purposes,
your system should have the configuration shown in the following figure. RAD
Studio runs on a Windows PC computer. This PC computer is connected to a
Mac running the Platform Assistant and having installed the appropriate versions
of Xcode and iOS SDK (for iOS development). To run iOS apps on an iOS device,
the iOS device should be connected via USB cable to the Mac.

To deploy an iOS application to the iOS Simulator on the Mac or to an iOS
device, you need to install the following tools on your Mac:
o

o

Platform Assistant (PAServer)


RAD Studio uses the Platform Assistant to run and debug multidevice applications and to deploy multi-device applications on
Mac OS X and iOS devices.



Install and run the Platform Assistant on your Mac.

Xcode

Xcode is the development and debug environment on the Mac and provides
the required development files for Mac OS X and iOS applications.

Step 1: Install the Platform Assistant
The Platform Assistant must be running on the Mac when you deploy an iOS app
from your PC to either the iOS simulator or an iOS device.
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The Mac OS X installer for the Platform Assistant is named PAServer16.0.pkg and
it is available in two places:
o

Inside the RAD Studio installation directory on your PC:

C:\Program Files
(x86)\Embarcadero\Studio\16.0\PAServer\PAServer16.0.pkg
o

On the Web, for download to the Mac:

http://altd.embarcadero.com/release/studio/16.0/PAServer/PAServer16.0.p
kg

For further details, see Installing the Platform Assistant on a Mac.

Step 2: Run the Platform Assistant
In the Finder on the Mac, activate the .app file (PAServer-16.0.app) as follows:
1. Navigate to the top-level Applications folder.
2. Double-click PAServer-16.0.app to start the Platform Assistant:
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The Terminal window appears, displaying the Platform Assistant banner and the
password prompt:
Connection Profile password <press Enter for no password>

Either press Return, or enter a password for PAServer and then press Return.
3. Next you are prompted to enter your Mac user password to allow the
Platform Assistant to debug (take control of another process) your
application.

Enter your password, and select Take Control:

For more details about running the Platform Assistant, see Running the Platform
Assistant on a Mac.

Step 3: Install Xcode on the Mac
Xcode is the development and debug environment on the Mac, and provides
the required development files for Mac OS X and iOS applications.
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You can install Xcode from any of the following sources:
o

On your "Mac OS X Install" DVD, under Optional Installs, double-click
Xcode.mpkg to install Xcode on your system.

o

At the Mac App Store, download Xcode for free.

o

As a registered Apple Developer, you can download the latest version of
Xcode as a bundle (.dmg). To register and then download Xcode:
1. Register (free of charge) as an Apple Developer at
http://developer.apple.com/programs/register/.
2. Download Xcode as a bundle from
https://developer.apple.com/downloads.

Next Steps
You have configured your Mac to run an iOS application on the iOS Simulator.
Note: Only Delphi applications can be run on the iOS Simulator.
C++Builder does not support the iOS Simulator.
o

iOS Simulator: To run an iOS application (Delphi only) on the iOS Simulator
on the Mac, you do not have to complete the second half of this tutorial.
Instead, you can now go on to the next tutorial (Mobile Tutorial: Set Up
Your Development Environment on Windows PC (iOS)) to complete the
configuration of your RAD Studio IDE.

o

iOS Device: To run your iOS application (either Delphi or C++Builder) on
your iOS Device, please use the following steps in this tutorial to complete
the configuration of your Mac. Then go on to next tutorial (Mobile Tutorial:
Set Up Your Development Environment on Windows PC (iOS)) to complete
the configuration of your RAD Studio IDE.
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Additional Steps to Configure Your Mac to Run Your iOS Application on Your iOS Device

Additional Steps to Configure Your
Mac to Run Your iOS Application on
Your iOS Device
The following additional steps enable you to run your iOS application on your iOS
Device.

Remember that your iOS device should be connected to your Mac via USB
cable.

Step 1: Make Sure that the Xcode Command Line
Tools Are Installed on Your Mac
Notice: Beginning from the Xcode version 6.1, the Xcode Command Line Tools
are automatically installed during Xcode installation.
To make sure that the Xcode command line tools are installed on your Mac:
1. Start Xcode on the Mac.
2. Choose Preferences from the Xcode menu.

3. In the General window, click the Locations tab.
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4. On the Location window, check that the Command Line Tools shows the
Xcode version (with which the Command Line Tools were installed). This
means that the Xcode Command Line Tools are already installed and you
do not need to install them.

5. If the Xcode Command Line Tools are not installed, the Command Line
Tools does not show the Xcode version.
1. In this case, click the Downloads tab on the Location window.
2. On the Downloads window, choose the Components tab.

3. Click the Install button next to Command Line Tools.
You are asked for your Apple Developer login during the install process.
For more details, see Installing the Xcode Command Line Tools on a Mac.
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Step 2: Sign Up for a Developer Account
Membership in one of the iOS developer programs is a requirement for building,
running, debugging, and deploying applications for iOS.
You can join a developer program in either of the following ways:
o

As an individual developer.

o

As a member (or leader) of a team in an enterprise (business) program or
university program.

For more details, see Joining an iOS Developer Program.

Step 3: Request, Download and Install Your
Development Certificate
Applications that are deployed on the device (or on the iOS Simulator) need to
be cryptographically signed before they run. The Development certificate
contains information that is needed for signing the applications. Each individual
(an individual developer or a team member) must have a unique development
certificate, which can be used for multiple applications.
For development teams, development certificates must be requested by each
team member, and these requests must be approved by a team admin.

Embarcadero Technologies

24

Additional Steps to Configure Your Mac to Run Your iOS Application on Your iOS Device

Request, Download and Install Your Certificate
1. In the Keychain Access application on your Mac, select from the
Keychain Access menu: Certificate Assistant > Request a Certificate From
a Certificate Authority:



If you are a development team member for a
corporate/organization program, your team administrator needs to
approve your request. After your team administrator approves it,
you can download the certificate.



If you are an individual developer, you should see a download
option for your certificate shortly after you request it. See Apple
documentation at: Code Signing Guide for details.

Save the certificate request as a CSR file, and then send it to your Certificate
Authority through the iOS provisioning portal in the following way:
1. When prompted, enter your Apple ID and password, and then click
Sign In.
2. Under iOS Apps, click Certificates.
3. On the page that opens, click the plus sign (+) icon.
This opens the Add iOS Certificate wizard.
4. On the Select Type page, click Continue and follow the onscreen
instructions to proceed with the wizard.
5. When prompted, upload the CSR file that you saved on your Mac.
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2. Go to iOS Provisioning Portal. You can download the Development
certificate clicking the Download button as shown below:

3. Launch the Development Certificate by double-clicking it. It
automatically loads in the Keychain Access application.

Step 4: Register Your Device for Deployment
Before a device can run user applications, it must be registered in the Apple
Provisioning Portal. Devices are registered by their Unique Device ID (UDID). The
UDID can be determined using Xcode, as follows:
1. Make sure your iOS device is connected to your Mac machine.
2. Open Xcode and go to Devices (Window > Devices or Window >
Organizer > Devices tab in Xcode 5).
3. Click on your device.
4. Next to the Identifier label is a string of characters:

The Identifier string represents your device's UDID.


If you are an individual developer, register your device by adding the
UDID in the Devices tab of the Apple Provisioning Portal.



If you are part of a company/organization, ask your team admin to
register your device.
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Step 5: Create and Install a Provisioning Profile
Provisioning profiles are used for linking a developer and devices to a
development team. This provisioning profile is required for running applications
on an iOS device.
o

If you are an individual developer, you must create a provisioning profile.
For specific information, see: Creating and Downloading a Distribution
Provisioning Profile.

o

If you are part of a company/organization, your team admins must create
a provisioning profile that you can use.

After your provisioning profile is created, you must install it into Xcode, as follows:
o

Xcode5:

1. Open Xcode on the Mac and go to the Organizer (Window > Organizer).
2. In the Library section, select Provisioning Profiles and click Refresh.
3. Xcode asks you to sign in with your Apple ID. Enter your credentials and
select Log in.
The provisioning profiles available to you are installed into your Xcode:

4. Select a valid iOS provisioning profile and drag-and-drop it into the
Provisioning profiles of your test device.
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o

Xcode 6:

1. Open Xcode on the Mac and go to the Devices (Window > Devices).
2. Right-click the device and select Show Provisioning Profiles…

3. Click the plus sing button to add a provisioning profile.

4. Find your provisioning profile, select it and click Install.
5. Click Done to close the window.
You have configured your Mac to run your iOS application on your iOS Device.
To run your iOS application, please see Mobile Tutorial: Set Up Your Development
Environment on Windows PC (iOS) and complete the configuration of your RAD
Studio IDE. (If you have configured your PC as part of running your application
on the iOS Simulator, you can skip this step.)
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See Also
o

Mobile Tutorial: Set Up Your Development Environment on Windows PC
(iOS)

o

Mobile Tutorial: Creating an Application for Mobile Platforms (iOS and
Android)

o

paserver, the Platform Assistant Server Application

o

Installing Xcode on a Mac

o

Installing the Xcode Command Line Tools on a Mac

o

Installing the Platform Assistant on a Mac

o

Running the Platform Assistant on a Mac

o

Acquiring an iOS Developer Certificate

o

Troubleshooting: Cannot Deploy to the iOS Device

o

Useful Apple Web Pages:


Apple Developer Program



iOS Developer Program



Creating and Configuring App IDs



Creating signing certificates (Code Signing Guide)



iOS Provisioning Portal (Requires your Apple Developer login)



Devices tab of the Apple Provisioning Portal



Create an Apple ID



Creating and Downloading a Distribution Provisioning Profile
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Mobile Tutorial: Set Up Your
Development Environment on
Windows PC (iOS)
Before starting this tutorial, you should read and perform the following tutorial
session:
o

Mobile Tutorial: Set Up Your Development Environment on the Mac (iOS)

A FireMonkey application destined for the iOS target platform can be tested
initially on the iOS Simulator available on the Mac. The second half of the testing
process uses the iOS Device target platform and requires a test iOS device
connected to the Mac.
Note: On iOS devices, you can run both Delphi and C++ applications. However,
the iOS Simulator is not supported by BCCIOSARM, so only iOS devices are
supported for C++.
To deploy an iOS Application to your iOS device or iOS Simulator for debugging
and testing purposes, RAD Studio uses the Platform Assistant, which you must
install and run on the Mac. Your hardware and software development
environment should have the configuration demonstrated in the following figure.
RAD Studio runs on a Windows PC computer. Your PC computer should be
connected to a Mac running the Platform Assistant and having installed the
appropriate versions of Xcode and iOS SDK (for iOS development). To run iOS
apps on an iOS device, the iOS device must be connected via USB cable to the
Mac.

This section describes the steps to set up your development environment after
you configure your environment on your Mac.
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Setting Up Your RAD Studio Environment
You need to execute the following configuration steps to prepare the iOS
development with RAD Studio.

Create a Connection Profile for the Mac
1. In the RAD Studio IDE, open Tools > Options > Environment Options >
Connection Profile Manager.
2. Click Add:
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3. Now you see the Create a Connection Profile wizard. Define a name for
the connection profile, such as "My Mac".
Make sure you select OS X as the platform, and then click Next:
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4. On the Remote machine information page, set the name or IP address of
the host Mac, a port number to use (the default port 64211 typically
works), and an optional password (if you want to use a password).

5. Click Test Connection, and make sure that the connection profile
succeeds with no error (you should receive the message "Connection to
<hostname> on port <portnumber> succeeded").
6. If the Test Connection succeeds, click the Finish button, otherwise check
the settings and try again.
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Add an SDK to the Development System for the iOS Device
Connected to the Mac
1. Open Tools > Options > Environment Options > SDK Manager:

2. Click Add.
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3. On the Add a New SDK dialog box, select iOS Device - 32 bit or iOS
Device - 64 bit as a platform.

4. After you select a platform, the IDE fills a Profile (such as "My Mac") and
SDK version combo box with the list of SDK versions available on the
machine where the Platform Assistant server is running:

5. Click OK to add the selected SDK version.
6. After the operation completes, click Close to close the dialog.
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See Also
o

Mobile Tutorial: Creating an Application for Mobile Platforms (iOS and
Android)

o

Mobile Tutorial: Set Up Your Development Environment on the Mac (iOS)

o

Working with a Mac and a PC

o

Running Your iOS Application on an iOS Device

o

Running Your iOS Application on the iOS Simulator

o

FireMonkey Platform Prerequisites

o

Creating an iOS App

o

Mac OS X Application Development

o

Creating a FireMonkey Application

o

Apple developer.apple.com pages


iOS Developer Library



iOS Developer Library: Getting Started



iOS Dev Center



Launching Your App on Devices



Preparing Your iOS App for Distribution in the App Store



iAd Network
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Mobile Tutorial: Set Up Your
Development Environment on
Windows PC (Android)
The largest part of the testing process of a FireMonkey application destined for
the Android target platform uses the Android Device target platform and
requires a test Android device connected by USB cable to your development
system. You do not need to use the Platform Assistant in developing apps for the
Android target platform. (PAServer is, however, required for developing Mac OS
X and iOS apps.)
Note: If you install the Android development tools during your RAD Studio
installation, Installing the USB Driver for Your Android Device is the only setup step
described here that you need to perform on your PC.
After you complete either this tutorial or the one required step, your next steps
are to:
o

Enable USB debugging on your Android device

o

Configure your system to detect your Android device

Setting Up Your RAD Studio Environment
The following Android development tools are installed on your development
system during RAD Studio installation:
o

Java Development Kit (JDK)

o

Android Software Development Kit (SDK)

o

Android Native Development Kit (NDK)
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Android Development Tools Are Installed with RAD Studio

We recommend that you install the Android development tools using our
product installer. However, if you already have the Android development tools
installed on your system, or if you want to install the tools yourself, you can
choose to skip this step in the installer. For specific instructions on installing the
Android development tools yourself, see Installing the Android Development
Tools.
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Default Installed Locations of the Android Development Tools
Tool

Default Location

C:\Program Files\Java\jdk1.7.0_25
Java
Developme
nt Kit (JDK)
C:\Users\Public\Documents\Embarcadero\Studio\16.0\PlatformSDK
Android
s\android-sdk-windows
Software
Developme
nt Kit (SDK)
C:\Users\Public\Documents\Embarcadero\Studio\16.0\PlatformSDK
Android
s\android-ndk-r9c
Native
Developme
nt Kit (NDK)
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Adding Your Android SDK in Tools Options > SDK Manager
Important:
o

If the Android SDK and NDK are installed during the RAD Studio installation,
your Android SDK should be automatically discovered by the RAD Studio
SDK Manager, and you do not need to perform this step. Proceed to the
next step: Installing the USB Driver for Your Android Device.

o

If you installed the Android SDK and NDK yourself, you need to perform this
step so that RAD Studio can build apps that target Android devices.

1. Select Tools > Options > Environment Options > SDK Manager.
Here is the SDK Manager when it is fully populated with the recommended
Android SDK:

Note:


The SDK Manager fields are blank if the SDK Manager cannot detect the
default installed Android SDK and you have not yet added an Android
SDK to the SDK Manager.



Fields that are marked with
do not have the correct path. Click the [...]
in that field and browse to the installed location of the library files.

2. Click Add.
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3. On the Add a New SDK dialog box, click the down-arrow in the Select an
SDK version field, and select Add New... from the drop-down list:

Note: If your installed Android SDK is listed in the Select an SDK version list, select
your Android SDK.
4. The Create a new Android SDK wizard is displayed.


On this wizard, complete the first two fields: Android SDK Base Path
and Android NDK Base Path (their installed locations).
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Either enter the paths of the installed locations or click the ellipsis [...] and
navigate to the installed locations.


The
symbol indicates that the base paths are missing, and the
Next button is enabled only after these fields are filled.



Here is the wizard when no SDKs have been added and the base
path fields are empty:

This wizard verifies the base paths you specify and then auto-populates the paths
to the various other libraries (that is, the tools on page 2 of the wizard).
Thus, you might need to enter only the base paths for the NDK and SDK, on page
1 of the wizard. Then the second page will auto-populate, if given a little time. Or
you might need to verify the auto-populated addresses (if they are present).
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There are no

Here is the first page of the wizard after you browse to (or enter) the
paths to the Android SDK and NDK.
icons because the paths have been verified.

Embarcadero Technologies

43

Mobile Tutorial: Set Up Your Development Environment on Windows PC (Android)

5. Click Next to go to the next page of the wizard, where the wizard will
attempt to prefill the fields by discovery.


Here is the second page of the wizard with all its fields prefilled:



For any fields that do not prefill, click the ellipsis [...] button and
browse to the installed location.

6. Click Finish to close the wizard.
You can view and manage your installed Android SDKs by opening the SDK
Manager.

Installing the USB Driver for Your Android Device
(Required)
Instructions and download sites are available for various Android devices here:
o

http://developer.android.com/sdk/win-usb.html (Google USB Drivers)

o

https://developer.amazon.com/sdk/fire/connect-adb.html (Kindle Fire
USB Drivers)

o

http://developer.android.com/tools/extras/oem-usb.html (OEM USB
Drivers)
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For example, for a Nexus 7 or Nexus 10 tablet, you install the Google USB Driver
using the Android SDK Manager, as follows:
1. Start the SDK Manager.exe by selecting Start | Programs | Embarcadero
RAD Studio | Android SDKs | Android Tools:

Tip: If the Android SDK Manager does not start, run android.bat from the \tools
directory inside your installed SDK directory.
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2. In the Android SDK Manager, install the USB driver for your Nexus 7 or
Nexus 10 :
1. Select Google USB Driver, clear all other checkboxes, and click
Install 1 Package:

2. Power up your Android device and connect it by USB cable to your
development system.
3. In the Control Panel Device Manager on your development system,
right-click your Nexus 7 or Nexus 10, and select Update Driver
Software.
4. In the Update Driver Software dialog box, browse to the \extras
folder in your Android SDK directory, and select the folder that
matches your Nexus 7 or Nexus 10. (Select google for the Nexus 7 or
Nexus 10.)
5. Click OK.
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See Also
o

Installing the USB Driver for Your Android Device

o

Enabling USB Debugging on an Android Device

o

Configuring Your System to Detect Your Android Device

o

Mobile Tutorial: Creating an Application for Mobile Platforms (iOS and
Android)

o

Installing the Android Development Tools

o

Android Mobile Application Development
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Mobile Tutorial: Creating an
Application for Mobile Platforms (iOS
and Android)
This topic describes how to create a "Hello World" multi-device application (C++
or Delphi) for either the iOS or Android target platform.

Before You Start
To develop mobile (iOS and Android) applications using RAD Studio, you need to
complete some important configuration steps. This tutorial assumes that you
have completed all the necessary setup steps.
For details, see:
o

Mobile Tutorial: Set Up Your Development Environment on the Mac (iOS)

o

Mobile Tutorial: Set Up Your Development Environment on Windows PC
(iOS)

o

Mobile Tutorial: Set Up Your Development Environment on Windows PC
(Android)
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Step 1: Create a New FireMonkey Application for
Android or iOS
1. Select either:


File > New > Multi-Device Application - Delphi



File > New > Multi-Device Application - C++Builder

The Multi-Device Application wizard appears:
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2. Select Blank Application. The Form Designer shows a new form:

3. Select the target platform from the Project Manager.
1. Android: See Configuring Your System to Detect Your Android
Device to use an Android device.
2. iOS: If you want to create an iOS app, open the Target Platform
node in the Project Manager and double-click iOS Simulator (only
for Delphi) or a connected iOS device (for either Delphi or C++):
Note: When you select a platform, the components not available for this
particular platform appear grayed.

Step 2: Select a Style
1. Select either iOS or Android from the Style drop-down menu in order to
define the Master view to show all the properties related with this style.
Note: See Style Selector for more information.

Step 3: Place Components on the Multi-Device Form
We recommend that you read this tutorial before you start placing components:
Mobile Tutorial: Using Layout to Adjust Different Form Sizes or Orientations (iOS
and Android).
The first step in creating a multi-device application is designing the user
interface. There are many reusable components available in the IDE for creating
user interfaces.
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1. Move the mouse pointer over the Tool Palette, and expand the Standard
category by clicking the plus (+) icon next to the category name.
2. Select the TEdit component and either double-click TEdit or drop it onto
the Form Designer.
3. Repeat these steps, but now add a TLabel and a TButton component to
the form.
4. Select the edit box and set the KillFocusByReturn property in the Object
Inspector to True.
5. Select the button and change the Text property in the Object Inspector to
"Say Hello".
6. Now you should see three components on the Form Designer. Here is an
iOS app:
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7. After you place these components on the Form Designer, the IDE
automatically sets names for the components.
To see or to change the name of a component, click the component on the
Form Designer, and then find its Name property in the Object Inspector and the
Structure View:
For a TButton component, the component name is set by default to Button1 (or
Button2, Button3, depending on how many TButtons you have created in this
application).
8. The form on which these components are located also has a name.
Select the background of the Form Designer, and select the Name
property in the Object Inspector. The name of the form Form1 (or Form2,
Form3,...) is displayed. You can also locate the name of the form in the
Structure View:

Note: Form names set by default as Form1, Form2, Form3,... are for the Master
views. Device views are named FormName_ViewName such as Form1_iPhone
(iPhone 3.5” form) and Form1_NmXhdpiPh (Android 4” Phone form).
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9. You can easily switch to source code by selecting the Code (for Delphi) or
<unit name>.cpp/<unit name>.h (for C++) tab at the bottom of the Form
Designer.
You can also press the F12 key to switch between the Form Designer and
the Code Editor:
Delphi

C++

The Code Editor displays the source code that the IDE has generated. You should
find three components defined (Edit1, Label1, and Button1):
Delphi

C++

Note: When you save or run your project, the uses and include
clauses are updated (to add FMX.StdCtrls for TLabel and FMX.Edit
for TEdit).
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Step 4: Adding Views to Your Project
If you want to customize you application for a particular type of device, you can
do it using Views.
1. Go to the Views selector.
2. Select the available views you want to add just by clicking on them.
3. Go to the view to do the changes you want to include.
To add a customized view, see Adding a Customized View to the View Selector.

Step 5: Write an Event Handler for a Button Click by
the User
The next step is defining an event handler for the TButton component. You can
define event handlers for your application in the same way you define event
handlers for desktop platforms. For the TButton component, the most typical
event is a button click.
Double-click the button on the Form Designer, and RAD Studio creates skeleton
code that you can use to implement an event handler for the button click
event:
Delphi

C++

Now you can implement responses within the Button1Click method.
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The following code snippets (Delphi and C++) implement a response that
displays a small dialog box, which reads "Hello + <name entered into the edit
box>":
Delphi code:
Label1.Text := 'Hello ' + Edit1.Text + ' !';

C++ code:
Label1->Text = "Hello " + Edit1->Text + " !";

In Delphi, the quotation marks that surround string literals must be straight single
quotation marks (that is, 'string'). You can use the plus (+) sign to concatenate
strings. If you need a single quote inside a string, you can use two consecutive
single quotes inside a string, which yields a single quote.
While you are typing code, some tooltip hints appear, indicating the kind of
parameter you need to specify. The tooltip hints also display the kinds of
members that are supported in a given class:

Delphi
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Step 6: Test Your Mobile Application
The implementation of this application is finished, so now you can run the
application.
You can click the Run button ( ) in the IDE, press F9, or select Run > Run from the
RAD Studio main menu:
Delphi
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Test Your Android Application on the Android Device
If you complete the steps described in Mobile Tutorial: Set Up Your Development
Environment on Windows PC (Android) before creating your new project, you
can now run your Android app on an Android device connected to your PC by
USB cable.
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Test Your iOS Application
Testing on the Mac (iOS Simulator)
By default, FireMonkey Delphi iOS applications run on the iOS Simulator target
platform. You can confirm the target platform in the Project Manager:

When you run your application, it is deployed to the Mac and then to the iOS
Simulator on the Mac. For our app, a form with an edit box and a button is
displayed. Enter text into the edit box, and click the Say Hello button:
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Note: On the iOS simulators, you can test only your Delphi
applications.

Testing on a Connected iOS Device
If you complete the steps described in Mobile Tutorial: Set Up Your Development
Environment on the Mac (iOS) and Mobile Tutorial: Set Up Your Development
Environment on Windows PC (iOS) before creating your new project, you can
now run your iOS app on an iOS device connected to your Mac by USB cable.
To run your iOS app on a connected iOS device, first select the iOS Device - 32
bit or iOS Device - 64 bit target platform so that the Platform Assistant deploys
the application to the connected iOS Device:

After you select the appropriate iOS Device target platform, run your iOS app by
clicking the Run button in the IDE, pressing F9 or selecting Run > Run.
On your Mac, you might see a dialog asking your permission to code sign your
iOS app. Select either "Always Allow" or "Allow" to sign your app.
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Then go to your iOS device and wait for your FireMonkey iOS app to appear.
Watch for the FireMonkey launch image (the icon is available in
$(BDS)\bin\Artwork\iOS, and you can set the launch image in Application
Options):

See Also
o

Mobile Tutorial: Using a Button Component with Different Styles (iOS and
Android)

o

Android Mobile Application Development

o

iOS Mobile Application Development

o

Mac OS X Application Development

o

Mobile Code Snippets
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Mobile Tutorial: Using a Button
Component with Different Styles (iOS
and Android)
Buttons in Mobile Platforms
FireMonkey defines various types of buttons, and you can use these different
types of buttons with the same steps described here. The FireMonkey buttons
include TButton and TSpeedButton.
Following are some examples of different styles with Button components
available for you to use in different parts of the user interface of your application:
o

Buttons on the Form:
iOS
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o

Buttons on the Navigation Bar (also known as Toolbar):
iOS

Android

Define the Look and Feel for a Button Component
After you place a new button on the Form Designer, you can specify some
important properties for a selected component by using the Object Inspector.
Select a component (in this case, a button), and then browse and change the
value of some properties as follows:
o

Change the text displayed on the button surface by updating the value
of the Text property in the Object Inspector.

o

Change the value of the Position.X and Position.Y properties (or drag the
component using your mouse.)

o

Change the value of the Height and/or Width properties (or drag the
edge of the component using your mouse.)

o

Click the down-arrow in the StyleLookup property.

In the StyleLookup drop-down list, you can select a predefined Style based on
how your component is to be used:
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o

To create a colored button, change the values of the TintColor and
IconTintColor properties. The latter property is available only for styled
buttons with icons. The next section gives more details about using
TintColor and IconTintColor.

Using TintColor and IconTintColor on Buttons
For TButton and TSpeedButton, FireMonkey provides two properties that
determine how to tint or color the button:
o

TintColor specifies the button background color.

o

IconTintColor specifies the color of the icon on styled buttons.
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The TintColor and IconTintColor properties are only available in the Object
Inspector if you select a proper Style for the button and select a proper View in
the Form Designer (these properties are not visible in all Views).
For the Android target platform:
You can apply a tint to most buttons of any style:
o

For speed buttons, you need to select a proper StyleLookup value in order
to change the TintColor value in the Object Inspector.

o

To modify TintColor and IconTintColor, choose an Android device from the
Views list in the upper right of the Form Designer.

For the iOS target platforms:
o

FireMonkey provides buttons that correspond to the Apple Style Guide,
and some buttons might not support the tint feature.

o

For example, on iOS 7, segmented buttons have the TintColor property.
(On iOS 6, the segmented buttons do not support the tint feature.)

When you change the StyleLookup property of a button, the Object Inspector
automatically displays or hides the TintColor and IconTintColor properties as
appropriate for the StyleLookup property value. The following image shows three
TSpeedButtons on an Android app:
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Using Styled and Colored Buttons on Target Platforms
For information on the availability of the StyleLookup, TintColor, and IconTintColor
properties for buttons on all target platforms, see this summary table: Using Styled
and Colored Buttons on Target Platforms.

Placing an Image over a Button
RAD Studio allows you to easily put custom images on button components at
design time.
To place an image over a button:
1. With a TButton and TImage component on the Form Designer, make
TImage a child component of TButton. (Use the Structure View.)
2. In the Object Inspector, select TImage and set its Align property to Client.
3. In the Structure View, select the button, expand the Image node, and
then click 0 - Empty (1.000).
4. In the Object Inspector, click the ellipsis button (...) next to Bitmap.
5. Add your custom image in the MultiResBitmap Editor.
6. In the Object Inspector, select TButton, and do the following:


Clear the Text property.



Set the Height and Width properties of TButton to the actual height
and width of your image.
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Create a Segmented Control Using Button
Components
FireMonkey uses a SpeedButton component to define the Segmented Control,
which gives users the ability to select one value from several options.
iOS

Android

To define a Segmented Control, use the following steps:
1. Place three TSpeedButton components from the Tool Palette. Place the
TSpeedButton components next to each other using your mouse:
iOS

Android

2. Select the first component, and change its StyleLookup property to
segmentedbuttonleft:
iOS

Android

3. Select the second component, and change its StyleLookup property to
segmentedbuttonmiddle.

Embarcadero Technologies

66

Mobile Tutorial: Using a Button Component with Different Styles (iOS and Android)

4. Select the third component, and change its StyleLookup property to
segmentedbuttonright. Now all three buttons look like a Segmented
Control:
iOS

Android

5. Select each component, and change the Text property as you like:
iOS

Android

6. Use the mouse to select these three buttons:
iOS

Android

7. Set the GroupName property to a unique name such as
LocationSegments:
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8. To specify that one of these components is to appear as Pressed by
default, set the IsPressed property for one component to True:
iOS

Android

Create a Scope Bar on a Toolbar Component
You can define a Segmented Control on a toolbar; this is also known as a Scope
Bar, a segmented control that can be used to control the scope of a search.
Use the same TSpeedButton controls as in the previous steps, but with the
following values for the StyleLookup property (only available on iOS target
platform):
o

toolbuttonleft

o

toolbuttonmiddle

o

toolbuttonright

(on the Android target platform set StyleLookup as toolbutton for each of the
buttons.)
iOS
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See Also
o

Mobile Tutorial: Creating an Application for Mobile Platforms (iOS and
Android)

o

Mobile Tutorial: Using a Calendar Component to Pick a Date (iOS and
Android)

o

Android Mobile Application Development

o

FMX.Mobile.Controls Sample (Delphi)

o

FMX.StdCtrls.TButton

o

FMX.StdCtrls.TSpeedButton

o

FMX.Controls.TStyledControl.StyleLookup

o

FMX.StdCtrls.TToolBar

o

FMX.StdCtrls.TCustomButton.IconTintColor

o

FMX.StdCtrls.TCustomButton.TintColor

o

FMX.StdCtrls.TToolBar.TintColor
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Mobile Tutorial: Using a Calendar
Component to Pick a Date (iOS and
Android)
Calendar in Mobile Platforms
FireMonkey uses the TDateEdit component to wrap a calendar component or
datepicker for the mobile target platform:
iOS7

Android

iPad2
LG-E612

Note: The TCalendarEdit component used in RAD Studio XE5 or
earlier is deprecated. Use the TDateEdit component instead.
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To use the TDateEdit component, perform the following simple steps:
1. Select the TDateEdit component in the Tool Palette, and drop the
component onto the Form Designer. To find the component in the Tool
Palette, enter the first few characters (such as "dat") in the search box (
):

After you drop the component, you can see the TDateEdit component on the
Form Designer:

Optionally, in the Object Inspector, you can set the following properties of
TDateEdit:


ShowCheckBox: when true, displays a checkbox on the TDateEdit
control. This checkbox allows you to enable/disable the TDateEdit
control at run time.



ShowClearButton: when true, displays a button on the TDateEdit
control. Click this button to clear values in this control at run time.
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2. Basically, that's it. Run your application on either a simulator or your
connected mobile device. After you tap TDateEdit, the calendar control
appears, and you can select a date.

iOS6 (iPhone5)

Android (LG-E612)

Implementing an Event Handler for User Changes to
the Date
After the user changes the date, the OnChange event is fired. You can
implement an event handler for the OnChange event to react to the user's
action.
To implement the OnChange event handler'
1. Select the TDateEdit component.
2. In the Object Inspector, open the Events page, and double-click the
empty space next to OnChange.
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3. Write code as follows:
Delphi:
procedure TForm25.DateEdit1Change(Sender: TObject);
begin
ShowMessage(FormatDateTime('dddddd', DateEdit1.Date));
end;

C++Builder:
void __fastcall TForm25::DateEdit1Change(TObject *Sender)
{
ShowMessage(FormatDateTime("dddddd", DateEdit1->Date));
}

Embarcadero Technologies

73

Mobile Tutorial: Using a Calendar Component to Pick a Date (iOS and Android)

This code shows a message dialog with a date selected. The FormatDateTime
function converts the selected date to a specified format (in this case dddddd
gives long-style date format):
iOS (iPad)

Android (LG-E612)

See Also
o

Mobile Tutorial: Using a Button Component with Different Styles (iOS and
Android)

o

Mobile Tutorial: Using Combo Box Components to Pick Items from a List
(iOS and Android)

o

Date and Time Support

o

Type conversion routines

o

FMX.DateTimeCtrls.TDateEdit
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Mobile Tutorial: Using Combo Box
Components to Pick Items from a List
(iOS and Android)
Implementing a Picker in Multi-Device Applications
For mobile platforms, FireMonkey wraps the Picker component with the
TComboBox component:
iOS 7 (iPad2)
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To define a picker and the associated list items:
1. Select either of the following:


File > New > Multi-Device Application - Delphi > Blank Application



File > New > Multi-Device Application - C++Builder > Blank
Application

2. Select the TComboBox component in the Tool Palette, and drop it on the
Form Designer.
To find TComboBox, enter the first few characters ("Com") in the Search
box of the Tool Palette:

3. After you drop the component, you can see the TComboBox component
on the Form Designer.
Right-click the TComboBox component and select Items Editor...:
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4. To define items, click Add Item several times.

5. In the Structure View, select ListBoxItem1 (the first item in the list).
6. In the Object Inspector, edit the Text property for ListBoxItem1.
In this example (the fifty states in the USA), enter "Alabama" as the first
item in the list:

7. Edit other items as well, such as Alaska, Arizona, Arkansas, California,
Colorado, and so forth.
8. Select the TComboBox component and in the Object Inspector, set the
TComboBox.Align property to Top.
9. Add a second TComboBox (ComboBox2) to the form. Select the
TComboBox component in the Tool Palette, and drop it again on the Form
Designer.
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10. Select ComboBox2 and in the Object Inspector, set the TComboBox.Align
property to Bottom.
11. Run the application on your chosen mobile target platform (iOS Simulator
(for Delphi only), iOS Device, or Android Device).
After you tap a TComboBox, the Picker control appears, and you can
select an item.

Building a List of Items Using Code
To build a list of items using code, you should implement the onFormCreate event
handler in the following way:
Delphi:
procedure TForm1.FormCreate(Sender: TObject);
begin
ComboBox2.Items.Add('Tiger');
ComboBox2.Items.Add('Cat');
ComboBox2.Items.Add('Penguin');
ComboBox2.Items.Add('Bee');
// Other animals can be listed here
ComboBox2.Items.Add('Elephant');
ComboBox2.Items.Add('Lion');
end;

C++Builder:
void __fastcall TForm1::FormCreate(TObject *Sender)
{
ComboBox2->Items->Add("Tiger");
ComboBox2->Items->Add("Cat");
ComboBox2->Items->Add("Penguin");
ComboBox2->Items->Add("Bee");
// Other animals can be listed here
ComboBox2->Items->Add("Elephant");
ComboBox2->Items->Add("Lion");
}

Displaying a Specific Item
The currently selected item is specified by the ItemIndex property. ItemIndex is an
integer value that is specified using a zero-based index (that is, the first item is
zero).
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To display the list with the fifth item selected ("California"), specify ItemIndex for
ComboBox1 as follows:
Delphi:
procedure TForm1.FormCreate(Sender: TObject);
begin
// Index of 5th item is "4"
ComboBox1.ItemIndex := 4;
ComboBox2.Items.Add("Tiger");
ComboBox2.Items.Add("Cat");
ComboBox2.Items.Add("Penguin");
ComboBox2.Items.Add("Bee");
// Other animals can be listed here
ComboBox2.Items.Add("Elephant");
ComboBox2.Items.Add("Lion");
end;

C++Builder:
void __fastcall TForm1::FormCreate(TObject *Sender)
{
// Index of 5th item is "4"
ComboBox1->ItemIndex = 4;
ComboBox2->Items->Add("Tiger");
ComboBox2->Items->Add("Cat");
ComboBox2->Items->Add("Penguin");
ComboBox2->Items->Add("Bee");
// Other animals can be listed here
ComboBox2->Items->Add("Elephant");
ComboBox2->Items->Add("Lion");
}

If you do not know the index value, you can find the value by using the IndexOf
method. To display the ComboBox2 with the item whose text is 'Penguin'
selected, add the following line to the previous code:
Delphi:
ComboBox2.ItemIndex := ComboBox2.Items.IndexOf('Penguin');

C++Builder:
ComboBox2->ItemIndex = ComboBox2->Items->IndexOf("Penguin");
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Implementing an Event Handler for the User's
Selection
After the user selects an item, the OnChange event is fired. To respond to the
user's action, you can implement an event handler for the OnChange event.
Note: Before proceeding with this scenario, perform the following
steps:
1. Select the TMemo component in the Tool Palette, and drop
it on the Form Designer.
2. In the Object Inspector, set the TMemo.Align property to
Client.
To implement an OnChange event handler:
1. Select the ComboBox1 component.
2. In the Object Inspector, open the Events page, and double-click the
empty space next to OnChange.
3. The Code Editor opens. Write code as follows:
Delphi:
procedure TForm1.ComboBox1Change(Sender: TObject);
begin
Memo1.Lines.Insert(0, (Format('%s: Item %s at Index %d was selected. ',
[ComboBox1.Name,ComboBox1.Selected.Text, ComboBox1.ItemIndex])));
end;

C++Builder:
void __fastcall TForm1::ComboBox1Change(TObject *Sender)
{
Memo1->Lines->Insert(0, ComboBox1->Name + ": Item " + ComboBox1->Selected>Text + " at Index " + IntToStr(ComboBox1->ItemIndex) + " was selected.");
}

This event handler displays a message dialog that indicates the item that was
selected.
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In the Delphi code, the Format function returns a formatted string assembled
from a format string and an array of arguments:
Android (LG - E612)

iOS6 (iPad)

See Also
o

Mobile Tutorial: Using a Calendar Component to Pick a Date (iOS and
Android)

o

Mobile Tutorial: Using Tab Components to Display Pages (iOS and Android)

o

Creating a Metropolis UI ComboBox

o

iOS Mobile Application Development

o

Mac OS X Application Development
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Mobile Tutorial: Using a Map
Component to Work with Maps (iOS
and Android)
FireMonkey wraps a map component as TMapView. This component provides
access to map APIs that depend on the target platform in the following way:
o

On Android devices: Google Maps Android API

o

On iOS devices: Map Kit Framework

This tutorial describes how to create a simple FireMonkey application that uses
the TMapView component.
iOS

Android

iPad
Android (LG - E612)
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Basic Features of the TMapView Component
The TMapView component adds interactive maps to your mobile applications.
The basic features of this component are as follows:
o

Four Types of Maps: Normal, Satellite, Hybrid, and (for Android only) Terrain

o

Gesture Control: Intuitive tilt, rotate, and zoom gesture controls

o

Control the Map View: Ability to control the map properties, such as the
map center coordinates, the map orientation, and so on

Creating a Sample Application
This section helps you develop a sample application (for Android and iOS target
platforms) that illustrates the use of the TMapView component. The application
demonstrates the following techniques:
o

Selecting a map type

o

Rotating the map

o

Specifying the map center coordinates

o

Adding markers to the map

Configuring Android Applications to Use the TMapView component
Before using Google Maps, ensure that you have a Google Maps Android API v2
key (freely available). Without this key in place, your map app will generate a
run-time error.
You also need to configure some permissions and project options for your
application.
For detailed instructions on how to configure your application, see Configuring
Android Applications to Use Google Maps.

Designing the User Interface
1. Create a blank Multi-Device Application, by selecting:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++: File > New > Multi-Device Application - C++Builder > Blank
Application

2. Select two TToolBar components in the Tool Palette, and drop them on the
Form Designer.
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3. Select the TMapView component in the Tool Palette, and drop it on the
Form Designer.
4. In the Object Inspector, set the Align property of TMapView to Client.
5. In the Object Inspector, set the Align properties of the toolbars to Top and
Bottom, respectively.

Designing the Application Toolbars
Place all control elements on the toolbars. The application uses two toolbars (a
top toolbar, and a bottom toolbar).
To design the top toolbar
o

In the Tool Palette, select the following components and drop them onto
the top toolbar:


TArcDial: Rotates the map.



Two TEdit components: Allow you to set the map center
coordinates (latitude and longitude).



TButton: Updates the map using the current map center
coordinates.

To specify the appropriate properties for control elements, do the following:
1. In the Form Designer, select ArcDial1, and then in the Object Inspector,
set the ShowValue property to True.
2. Select Edit1, and set the Name and Text properties to edLat and 0.0,
respectively.
3. Select Edit2, and set the Name and Text properties to edLong and 0.0,
respectively.
4. Select Button1, and set the Text property to Go.
To design the bottom toolbar
1. In the Tool Palette, select the TLayout component and drop it onto the
bottom toolbar.
2. In the Object Inspector, specify the following properties of Layout1:


Set the Align property to Center.



Set the Width property to 241.

3. In the Tool Palette, select three TSpeedButton components, and add them
as child elements of Layout1.
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4. In the Object Inspector, specify the following properties of the speed
buttons:


Set the Text property of buttons to Normal, Satellite, and Hybrid,
respectively.



Set the GroupName property of each button to Selector.



Set the StyleLookup property to segmentedbuttonleft,
segmentedbuttonmiddle, and segmentedbuttonright, respectively.

After performing the above steps, your Form Designer will be similar to the
following screen:

Implementing the Control Elements Functionality
To complete the application development, you should implement event
handlers for all control elements that you have dropped onto the toolbars.

Embarcadero Technologies

85

Mobile Tutorial: Using a Map Component to Work with Maps (iOS and Android)

To implement the OnClick event handlers for speed buttons
1. On the Form Designer, double-click a speed button (Normal, Satellite, and
Hybrid).
2. In the Code Editor, specify the following event handlers for each button:
Delphi:
//-------------------For Normal button ---------------------------------------procedure TForm1.SpeedButton1Click(Sender:TObject) ;
begin
MapView1.MapType := TMapType.Normal;
ArcDial1.Value := 0.0;
end;
// -------------------For Satellite button-------------------------------------procedure TForm1.SpeedButton2Click(Sender:TObject) ;
begin
MapView1.MapType := TMapType.Satellite;
ArcDial1.Value := 0.0;
end;
// --------------------For Hybrid button---------------------------------------procedure TForm1.SpeedButton3Click(Sender:TObject) ;
begin
MapView1.MapType := TMapType.Hybrid;
ArcDial1.Value := 0.0;
end;

C++Builder:
//-------------------For Normal button ---------------------------------------void __fastcall TForm1::SpeedButton1Click(TObject *Sender) {
MapView1->MapType = TMapType::Normal;
ArcDial1->Value = 0.0;
}
// -------------------For Satellite button-------------------------------------void __fastcall TForm1::SpeedButton2Click(TObject *Sender) {
MapView1->MapType = TMapType::Satellite;
ArcDial1->Value = 0.0;
}
// --------------------For Hybrid button---------------------------------------void __fastcall TForm1::SpeedButton3Click(TObject *Sender) {
MapView1->MapType = TMapType::Hybrid;
ArcDial1->Value = 0.0;
}
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To implement the OnChange event handler for the ArC Dial element
1. On the Form Designer, select ArcDial1.
2. In the Object Inspector, open the Events tab, and then double-click next
to onChange.
Specify the following code:
Delphi:
procedure TForm1.ArcDial1Change(Sender: TObject);
begin
MapView1.Bearing := ArcDial1.Value;
end;

C++Builder:
void __fastcall TForm1::ArcDial1Change(TObject *Sender)
{
MapView1->Bearing = ArcDial1->Value;
}

To implement the OnClick event handler for the Go Button
1. On the Form Designer, double-click the Go button.
2. In the Code Editor, specify the following code:
Delphi:
procedure TForm1.Button1Click(Sender: TObject);
var
mapCenter: TMapCoordinate;
begin
mapCenter := TMapCoordinate.Create(StrToFloat(edLat.Text),
StrToFloat(edLong.Text));
MapView1.Location := mapCenter;
end;

C++Builder:
void __fastcall TForm1::Button1Click(TObject *Sender) {
TMapCoordinate mapCenter =
TMapCoordinate::Create(StrToFloat(edLat->Text),
StrToFloat(edLong->Text));
MapView1->Location = mapCenter;
}
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Markers identify locations on the map. If you want to add markers to the map,
you can implement the OnMapClick event handler for the map in the following
way.
To implement the OnMapClick event handler for the map
1. In the Structure View, select MapView1.
2. In the Object Inspector, open the Events tab, and double-click next to
OnMapClick.
3. In the Code Editor, implement the following event handler:
Delphi:
procedure TForm1.MapView1MapClick(const Position: TMapCoordinate);
var
MyMarker: TMapMarkerDescriptor;
begin
MyMarker := TMapMarkerDescriptor.Create(Position, 'MyMarker');
// Make a marker draggable
MyMarker.Draggable := True;
// Make a marker visible
MyMarker.Visible :=True;
MapView1.AddMarker(MyMarker);
end;

C++Builder:
void __fastcall TForm1::MapView1MapClick(const TMapCoordinate &Position)
{
TMapMarkerDescriptor myMarker =
TMapMarkerDescriptor::Create(Position, "MyMarker");
// Make a marker draggable
myMarker.Draggable = true;
// Make a marker visible
myMarker.Visible = true;
MapView1->AddMarker(myMarker);
}

Running the Sample Application
To run this application, do the following:
1. In the Project Manager, select the target platform (supported platforms:
Android or iOS).
Important: Before running this application on Android
devices, ensure that you have completed the steps from
Configuring Android Applications to Use Google Maps.
2. Press Shift+Ctrl+F9 to run the application without debugging.
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To test your application, you can use the following scenario:
1. Click the Hybrid button.
2. Specify the new map center (by default the map center is (0.0, 0.0)):


In the left text box, set the latitude value (such as 50 degrees).



In the right text box, set the longitude value (such as 20 degrees).



Click the Go button.

3. Click any point on the map to add a marker.
4. Tap the Arc Dial (knob-style rotating button) and try to rotate it. [This
changes the map orientation (bearing). The map orientation is the
direction in which a vertical line on the map points, measured in degrees
clockwise from north.]
iOS

Android

Android (LG - E612)

iPad
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See Also
o

TMapView

o

Configuring Android Applications to Use Google Maps

o

Mobile Tutorial: Using Location Sensors (iOS and Android)
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Configuring Android Applications to
Use Google Maps
This topic explains how to configure your Android applications to use the
TMapView component and Google Maps Android API.
The following subjects are covered:
o

Getting Google Maps API key

o

Configuring specific project options

Getting the Google Maps API key
To access the Google Maps servers with the Maps API, you have to add a Maps
API key to your application. This section outlines basic steps to get this key:
1. Retrieve information about your application's certificate.
2. Register a project in the Google APIs Console and add the Maps API as a
service for the project.
3. Request a MAPS API key.
Note: For more information and detailed instructions, see Get an
Android certificate and the Google Maps API key.

Retrieving Your Application Certificate
The Maps API key is based on a short form of your application's digital certificate,
known as its SHA-1 fingerprint. The fingerprint is a unique text string generated
from the commonly-used SHA-1 hashing algorithm. You may have certificates of
two types: Debug certificate and Release certificate.
Note: This section explains how to retrieve the debug certificate. For
information on how to retrieve the release certificate, see Get an
Android certificate and the Google Maps API key.
To display the debug certificate fingertip
1. Locate the appropriate debug.keystore file. RAD Studio uses the
debug.keystore file located into:
%Users%\<user name>\AppData\Roaming\Embarcadero\BDS\<version
number>\ , for example:
C:\Users\JohnDoe\AppData\Roaming\Embarcadero\BDS\16.0\debug.keyst
ore
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2. Switch to the above folder, and run:
keytool -list -v -keystore debug.keystore -alias androiddebugkey
-storepass android -keypass android

Note: As a rule, the keytool tool is available in <Java
installation folder>\Bin, such as C:\Java\Bin.
3. The keytool tool displays an output similar to this: Alias name:
androiddebugkey Creation date: Jan 24, 2015 Entry type:
PrivateKeyEntry Certificate chain length: 1 Certificate[1]:
Owner: CN=Unnamed, OU=Mobile Organization, O=My Company, L=San
Francisco, ST=California, C=US Issuer: CN=Unnamed, OU=Mobile
Organization, O=My Company, L=San Francisco, ST=California, C=US
Serial number: 1af9d77f Valid from: Sat Jan 24 23:12:12 GST 2015
until: Wed Jun 11 23:12:12 GST 2042 Certificate fingerprints:
MD5: 20:E1:7D:12:4F:83:2A:37:FB:F5:43:3B:CC:27:88:4B SHA1:
0B:4D:1E:83:2F:91:3A:BD:92:EB:87:62:6D:34:66:9D:6A:51:3B:ED
SHA256:
91:75:AC:BE:C9:74:6F:67:3E:9A:E4:35:04:D4:05:E0:8F:A4:54:30:41:4A
:EB:0A:61:E0:D1:33:7C:D8:0F:82 Signature algorithm name:
SHA256withRSA Version: 3 The line that begins SHA1 contains the

certificate's SHA-1 fingerprint. The fingerprint is the sequence of 20 twodigit hexadecimal numbers separated by colons.

Creating an API Project in the Google APIs Console
Important: Before proceeding with this section, make sure that you
have a Google Account.
1. In a browser, navigate to the Google APIs Console.
Note: If you have not used the Google APIs Console before,
you're prompted to create a project that you use to track
your usage of the Google Maps Android API. Click Create
Project to create a new project called API Project. On the
next page, this name appears in the upper left-hand corner.
2. Select Services from the left navigation bar.
The main window displays a list of APIs and services.
3. In the list of services, scroll down until you see Google Maps Android API
v2.
4. To the right of the entry, click the switch indicator so that it is on.
This displays the Google Maps Android API Terms of Service.
5. If you agree to the terms of service, click the checkbox below the terms of
service, and then click Accept.
This returns you to the list of APIs and services.

Embarcadero Technologies

92

Configuring Android Applications to Use Google Maps

Requesting a Maps API Key
Now you can request an API key. It is possible to request and register more than
one key per project.
To request an API key
1. Navigate to your project in the Google APIs Console.
2. In the Services page, verify that the "Google Maps Android API v2" is
enabled.
3. In the left navigation bar, click API Access.
4. In the resulting page, click Create New Android Key.
5. In the resulting dialog, enter the SHA-1 fingerprint, then a semicolon, and
then your application's package name. For example:
0B:4D:1E:83:2F:91:3A:BD:92:EB:87:62:6D:34:66:9D:6A:51:3B:ED;my.co
mpany.Mymap

Important: To get a valid Maps API key, ensure that you use
the exact application's package name. This name uniquely
identifies your application. The package key in the Android
Version Information contains the package name (see the
screenshot under the "To set the apiKey key value"
procedure later in this document).
6. The Google APIs Console displays Key for Android apps (with certificates)
followed by a forty-character API key, for example: API key:
AIzaSyCMuJ2w8_gQEedvqUg-9lxWXFg7feAl9PQ

Configuring Specific Project Options
For your Android application to access Google Maps, ensure that you have
configured the following project options and permissions:
o

Enable the Access network stateuses permission.

o

Enable the Maps Serviceentitlement option.
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o

Set the apiKey key value in the Android Version information.
Important: Before proceeding with this section, in the Project
Manager, set the Target Platform to Android:

To check the configured permissions list
1. In the RAD Studio IDE, open Project > Options > Uses Permissions
2. Ensure that the Access network state permission is enabled:
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To check the Entitlement List
1. In the RAD Studio IDE, open Project > Options > Entitlement List
2. Ensure that the Maps Service' option is enabled:
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To set the apiKey key value
1. In the RAD Studio IDE, open Project > Options > Version Info
2. Set the apiKey key to the Maps API key value that you have requested for
your application (see Step 6 in the Requesting a Maps API Key section
earlier in this document).
3. Click OK.

Important: For your changes to the project options to take effect,
press Shift + F9 to rebuild your project.
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See Also
o

TMapView

o

Mobile Tutorial: Using a Map Component to Work with Maps (iOS and
Android)
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Mobile Tutorial: Using a MultiView
Component to Display Alternate
Views of Information (iOS and
Android)
About the TMultiView Component
The FMX.MultiView.TMultiView component represents a container (the master
pane) for other controls, and provides a way for you to easily present alternate
views of information. The TMultiView component allows you to implement a
master-detail interface, which can be used for any supported target platform.
o

The master pane can display a collection of any visual controls, such as
edit boxes, labels, lists, and so forth.

o

The detail pane typically displays information based on the properties of
the controls in the master pane.
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The following screen illustrates an example master-detail interface. In the master
pane (the left docked panel), you enter a geographical position, and then click
Search to cause the detail pane (the right panel) to display the appropriate
Google map.

Master Pane Presentation Modes
The TMultiView class defines a set of properties that allow you to control the
interface behavior. For example, the TMultiView.Mode property specifies the
master pane presentation mode as described in the following table:
TMultiView.Mode

Master Pane Presentation

Drawer

Drawer (Push/Overlap)

Panel

Docked panel

PlatformBehaviour

(see the following table)

Popover

Popup menu

Custom

For details, see the Custom Mode subsection.
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Note: At design time, after you change the TMultiView.Mode
property value in the Object Inspector, the master pane might
become invisible. To work around this issue, on the Form Designer,
select the TMultiView component, and then in the Object
Inspector, set the Visible property to True.

Drawer Mode
If you set the TMultiView.Mode property to Drawer (using
TDrawerAppearance.Mode=OverlapDetailView), the master pane is initially
hidden. To display the master pane, the user swipes right from the left edge of
the screen, as shown in the following animated image:
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Popover Mode
You can also set the TMultiView.Mode property to Popover to make the master
pane a popup menu that is displayed next to the Master button specified in the
TMultiView.MasterButton property.

Important: In the Popover mode, you must set the
TMultiView.MasterButton property. This property refers to a UI
element that displays or hides the master panel. In the above
screen, the Master button is the Show/Hide button.
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Platform Dependent Behavior Mode
You can let the application automatically select the master pane presentation
mode, if the TMultiView.Mode property is set to PlatformBehaviour. For this
setting, the application behavior depends on the device type and orientation,
as described in the following table:
Device Type

Device Orientation

Master Pane Presentation

Phone

Landscape, Portrait Drawer (push/overlap)

Tablet

Landscape

Docked panel

Tablet

Portrait

Drawer (push/overlap)

Custom Mode
In Custom mode, you can customize the master pane presentation to conform
to your tasks. To customize the master pane presentation, perform the following
basic steps:
1. Declare your own class, such as MyPresentationClass that descends from
TMultiViewPresentation or from other classes that were declared in the
FMX.MultiView.Presentations unit.
2. In the MyPresentationClass, optionally, override the following virtual
methods defined in the base class:


DoOpen



DoClose



GetDisplayName



DoInstall

DoUninstall
These methods define the master pane behavior.


3. In the Form Designer, select the TMultiView component, and then in the
Object Inspector, set its property Mode to Custom.
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4. Implement the onFormCreate event handler as follows:


For Delphi:

procedure TForm1.FormCreate(Sender: TObject);
begin
MultiView1.CustomPresentationClass := MyPresentationClass;
end;



For C++:

void __fastcall TForm1::FormCreate(TObject *Sender)
{
MultiView1->CustomPresentationClass = __classid(MyPresentationClass);
}

This topic helps you develop a simple application that illustrates the use of the
TMultiView component.

Designing the User Interface
1. Create a blank Multi-Device Application, by selecting:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++: File > New > Multi-Device Application - C++Builder > Blank
Application

2. Select the TMultiView component in the Tool Palette, and drop it on the
Form Designer.
3. Drop other controls, such as buttons, edit boxes or any other controls you
need onto the MultiView container.
4. In the Tool Palette, select a component you want to use as a detail pane
(such as TPanel), and drop any controls onto this panel.
5. In the Object Inspector, specify the appropriate properties of the
TMultiView component.
To clarify this procedure, the following sections consider a particular example: an
application that controls the mobile device camera.
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Designing the Master Pane
1. Select the TMultiView component in the Tool Palette, and drop it on the
Form Designer.
2. Drop two TButton components into the TMultiview container, and then in
the Object Inspector specify the following properties of those buttons:


Set the Name property to bStartCamera and bStopCamera,
respectively.



Set the Text property to Start Camera and Stop Camera,
respectively.

3. Drop a TLabel component into the TMultiview container, and then in the
Object Inspector, set its Text property to Camera type:.
4. Drop two TButton components into the TMultiview container, and then in
the Object Inspector specify the following properties of those buttons:


Set the Name property to bFrontCamera and bBackCamera,
respectively.



Set the Text property to Front and Back, respectively.

Designing the Detail Pane
1. Select the TPanel component in the Tool Palette, and drop it on the Form
Designer.
2. In the Object Inspector, set the TPanel.Align property to Client.
3. Drop the TCameraComponent into the TPanel container.

Embarcadero Technologies

104

Mobile Tutorial: Using a MultiView Component to Display Alternate Views of Information (iOS and
Android)

4. Drop the TImage into the TPanel container, and set the following
properties:


Name = imgCameraView



Align = Client

Tip: Put all elements of the details pane into a unique container (a
TPanel component in our example). This container should be
specified in the TMultiView.TargetControl property.
Note: It is not recommended to put native controls on the detail
pane because they do not support the Z-order of the form: a
native control is always on top of other controls available on your
form.

Implementing the Camera Buttons Functionality
To complete the application development, you should implement event
handlers for the application buttons and the GetImage private method that gets
an image from the device camera.
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To implement the OnClick event handlers
1. On the Form Designer, double-click the Start Camera button, and insert
the following code:


For Delphi:

procedure TForm1.bStartCameraClick(Sender: TObject);
begin
CameraComponent1.Active := true;
end;



For C++:

void __fastcall TForm1::bStartCameraClick(TObject *Sender)
{
CameraComponent1->Active = true;
}

2. Double-click the Stop Camera button, and insert the following code:


For Delphi:

procedure TForm1.bStopCameraClick(Sender: TObject);
begin
CameraComponent1.Active := false;
end;



For C++:

void __fastcall TForm1::bStopCameraClick(TObject *Sender)
{
CameraComponent1->Active = false;
}
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3. Double-click the Front button, and insert the following code:


For Delphi:

procedure TForm1.bFrontCameraClick(Sender: TObject);
begin
CameraComponent1.Active := False;
CameraComponent1.Kind := FMX.Media.TCameraKind.FrontCamera;
CameraComponent1.Active := True;
end;



For C++:

void __fastcall TForm1::bFrontCameraClick(TObject *Sender) {
// select Front Camera
CameraComponent1->Active = false;
CameraComponent1->Kind = TCameraKind::FrontCamera;
CameraComponent1->Active = true;
}

4. Double-click the Back button, and insert the following code:


For Delphi:

procedure TForm1.bBackCameraClick(Sender: TObject);
begin
CameraComponent1.Active := False;
CameraComponent1.Kind := FMX.Media.TCameraKind.BackCamera;
CameraComponent1.Active := True;
end;



For C++:

void __fastcall TForm1::bBackCameraClick(TObject *Sender) {
// select Back Camera
CameraComponent1->Active = false;
CameraComponent1->Kind = TCameraKind::BackCamera;
CameraComponent1->Active = true;
}
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To implement the onSampleBufferReady event handler
o

In the Form Designer, double-click the CameraComponent1 and
implement the following code:


For Delphi:

procedure TForm1.CameraComponent1SampleBufferReady(Sender: TObject;
const ATime: Int64);
begin
TThread.Synchronize(TThread.CurrentThread, GetImage);
end;



For C++:

void __fastcall TForm1::CameraComponent1SampleBufferReady(TObject
*Sender,
const __int64 ATime)
{
GetImage();
}

For the TForm1 class, you should implement the private method GetImage. The
onSampleBufferReady event handler calls this method to get the image from the
device camera.
Do the following:
1. In the private section of the TForm1 class, declare the GetImage method:


For Delphi:

private
{ Private declarations }
procedure GetImage;



For C++:



In the header file (.h file), add the following code:

private:
// User declarations
void __fastcall GetImage();
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2. Implement the GetImage method as follows:


For Delphi:

procedure TForm1.GetImage;
begin
CameraComponent1.SampleBufferToBitmap(imgCameraView.Bitmap, True);
end;



For C++:

void __fastcall TForm1::GetImage()
{
CameraComponent1->SampleBufferToBitmap(imgCameraView->Bitmap,
true);
}

Setting the TMultiView Component Properties
In the Form Designer, select the TMultiView component, and then in the Object
Inspector, set the following properties:
o

TargetControl = Panel1

o

Mode = Drawer

o

Visible = True

o

Expand the DrawerOptions node, and set the Mode property to
OverlapDetailView.

o

Expand the ShadowOptions node, and set the Color property to Beige.
(This property defines the color of the master panel shadow. You can use
any available color.)

Running the Example Application
To run this application, do the following:
1. In the Project Manager, select the target platform (supported platforms:
Android or iOS).
2. Press Shift+Ctrl+F9 to run the application without debugging.
3. To open the master panel, swipe right from the left edge of the device
screen.
4. To activate the device camera, on the master panel, click Start Camera.
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5. Optionally, you can select the front or back camera (if available) by using
the Front or Back button, respectively.

To close the master panel, slide it left.

Mobile Product Samples that Use TMultiView
Go to the Mobile Samples folder in
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples.
o

MultiViewDemo

o

LocationDemo

o

MusicPlayer

o

Device Sensors and Services

o

SurfSpot Finder Sample (Delphi)
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See Also
o

FMX.MultiView.TMultiView

o

FMX.MultiView.TMultiViewPresentation

Embarcadero Technologies

111

Mobile Tutorial: Using the Web Browser Component (iOS and Android)

Mobile Tutorial: Using the Web
Browser Component (iOS and
Android)
FireMonkey wraps the Web Browser component as the TWebBrowser
component. You can use TWebBrowser in desktop apps as well as mobile apps,
but this topic describes how to create a simple FireMonkey Web Browser
application for iOS and Android platforms.
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Design the User Interface
1. Select either:


File > New > Multi-Device Application - Delphi > Blank Application



File > New > Multi-Device Application - C++Builder > Blank
Application

2. Select the TToolBar component in the Tool Palette, and drop it on the
Form Designer.
To find TToolBar, enter a few characters (such as "tool") in the Search box of the
Tool Palette:

3. After you drop the component, you can see the TToolBar component at
the top of the Form Designer. Here is a screenshot after setting the iOS
style in the Form Designer:

4. Select the TButton component in the Tool Palette and drop it on the
TToolBar.
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5. Select the TButton component on the Form Designer, and then in the
Object Inspector, set the StyleLookup property to priortoolbutton.


The priortoolbutton StyleLookup value for TButton adds a Back
button label. On iOS devices, the label is similar to the following
image:



For more detail about selecting a style in multi-device applications,
see Mobile Tutorial: Using a Button Component with Different Styles
(iOS and Android).

6. Select the TEdit component in the Tool Palette and drop it on the TToolBar.
Make sure that the size of the Edit control is wide enough to fill the area of
the TToolBar:

7. Select the Edit box on the Form Designer, and then in the Object
Inspector, set the ReturnKeyType property to Done, the KeyboardType
property to URL, and the KillFocusByReturn property to True.
For more information about selecting the most appropriate Virtual Keyboard
type in mobile platforms, see Selecting the Proper Virtual Keyboard for the Web
Browser Application.
8. Select the TWebBrowser component in the Tool Palette and drop it on the
form.
9. Select the Web Browser component on the Form Designer, go to the
Object Inspector and select Client for the Align property.
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After you complete these steps, the form should be similar to the following
picture:

Write an Event Handler to Open a Web Page when
the User Changes the URL in the Edit Control
Unlike desktop platforms, mobile platforms use the Virtual Keyboard to enter text
as in the following images. The user can complete the action by clicking "Done".
iOS

iPad
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FireMonkey provides many types of event handlers to cover most actions taken
by users. After the "Done" button is selected, the FireMonkey framework sends an
OnChange event to the TEdit control. On the other hand, there is no specific
event for the "Back" button. In this section, you implement event handlers to
support both scenarios.

Implement a Common Method to Open a Web Page
Before implementing event handlers, first implement a common method to open
a Web page based on the Text property of the Edit control.
1. In the private section of the TForm1 class, declare the OpenURL method:
Delphi:
private
{ Private declarations }
procedure OpenURL;

C++Builder:
private:
// User declarations
void __fastcall openURL();

2. Implement the openURL method as follows:
Delphi:
procedure TForm1.OpenURL;
begin
WebBrowser1.Navigate(Edit1.Text);
end;

C++Builder:
void __fastcall TForm1::openURL()
{
WebBrowser1->Navigate(Edit1->Text);
}
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Implement an Event Handler for the OnChange Event
1. Create the event handler by selecting the Edit component (in the Form
Designer), and then double-clicking the white space next to the
OnChange event (in the Object Inspector's Events tab).
The Object Inspector creates a new event handler called Edit1Change:

2. Complete the event handler by adding the following code:
Delphi:
procedure TForm1.Edit1Change(Sender: TObject):
begin
OpenURL;
end;

C++Builder:
void __fastcall TForm1::Edit1Change(TObject *Sender)
{
openURL();
}

Embarcadero Technologies

117

Mobile Tutorial: Using the Web Browser Component (iOS and Android)

Implement an Event Handler for the Back Button
To implement the Back button for your Web Browser, you can simply call the
GoBack method on the Web Browser component:
Delphi:
procedure TForm1.Button1Click(Sender: TObject);
begin
WebBrowser1.GoBack;
end;

C++Builder:
void __fastcall TForm1::Button1Click(TObject *Sender)
{
WebBrowser1->GoBack();
}

The basic behavior is now implemented for this Web Browser application. Try
running your application on your Android device, the iOS Simulator, or your iOS
device.
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Selecting the Proper Virtual Keyboard for the Web
Browser Application
After you run your first Web Browser application, you might realize that the Virtual
Keyboard is not optimized.
iOS provides several virtual keyboards as follows:
Alphabet:

Default:

EmailAddress:

NumberPad:

NumbersAndPunctuation: PhonePad:

NamePhonePad:

URL:

Android provides several virtual keyboards as follows:
Alphabet:

Default:

NumberPad:

NumbersAndPunctuation: PhonePad:
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The most appropriate Virtual Keyboard type for Web Browser components is URL.
As we have already discussed in Design the User Interface, the following steps set
the URL as the Virtual Keyboard type for the Web Browser component in this
example. Select the Edit box on the Form Designer, and then in the Object
Inspector, set the KeyboardType property to URL.

WebBrowser Mobile Code Snippet
The WebBrowser project in Mobile Code Snippets demonstrates the functionality
described in this tutorial.
You can find the WebBrowser project at:
o

Start | Programs | Embarcadero RAD Studio XE8 | Samples and navigate
to \Object Pascal\Mobile Snippets\WebBrowser

o

Subversion
Repository:http://sourceforge.net/p/radstudiodemos/code/HEAD/tree/br
anches/RadStudio_XE8/Object%20Pascal/Mobile%20Snippets/WebBrowse
r
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See Also
o

Mobile Tutorial: Using Combo Box Components to Pick Items from a List
(iOS and Android)

o

Mobile Tutorial: Using Tab Components to Display Pages (iOS and Android)

o

FMX.Mobile.KeyboardTypes Sample (Delphi)

o

FMX.Mobile.KeyboardTypes Sample (C++)

o

TWebBrowser

o

TToolBar

o

TButton

o

TEdit

o

KeyboardType

o

StyleLookup
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Mobile Tutorial: Using Tab
Components to Display Pages (iOS
and Android)
Tabs are defined by FMX.TabControl.TTabControl, which is a container that can
hold several tab pages. Each tab page can contain any control as a UI element.
You can hide the tab for these pages, and change pages without showing tabs.

For each tab, you can specify:
o

A text label — for both iOS and Android

o

Predefined icons — for iOS only

o

Custom icons — for both iOS and Android

Using the Native Style for Tabs on iOS and Android
This tutorial shows tabs with the same style on both iOS and Android, but this
practice is not recommended.
We recommend that you observe the native style of each platform, as follows:
o

On Android:


Tabs are commonly placed at the top of the screen (so you should
set TTabPosition either to Top or to PlatformDefault).



Tabs traditionally display only text. However, FireMonkey allows you
to specify custom icons to be displayed on tabs (see Using Custom
Multi-Resolution Icons for Your Tabs).
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o

On iOS:


Tabs are typically shown at the bottom of the screen (so you should
set TTabPosition either to Bottom or to PlatformDefault).



Tab items always display both text and an icon, which can be set
via the StyleLookup property for each tab.

Note: You can use the PlatformDefault value of the TTabPosition
enumeration to set the tab position according to the default
behavior of the target platform. When PlatformDefault is set for
TTabPosition:
o

In iOS apps, tabs are aligned at the lower edge of the
TTabControl.

o

In Android apps, tabs are aligned at the top edge of the
TTabControl.

Designing Tab Pages Using the Form Designer
To create tab pages in your application, use the TTabControl component with
the following steps:
1. Select:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++: File > New > Multi-Device Application - C++Builder > Blank
Application

2. In the Views field on the Form Designer, create a view for each platform
you want to support. This tutorial uses an iOS and an Android view.
3. Select TTabControl from the Tool Palette:
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4. After you drop the TTabControl, an empty TabControl is shown on the Form
Designer (you might need to manually adjust the position of the
TabControl):
iOS

Android
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5. Typically, applications that use TabControl use the full screen to show
pages.
To do this, you need to change the default alignment of TabControl. In
the Object Inspector, change the Align property of TabControl to Client:

6. Right-click the TabControl, and select Items Editor... from the context
menu:

7. Click Add Item three times, so that now you have three instances of
TabItem here. Close the dialog box.
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8. On the Form Designer, select the first TabItem and change its StyleLookup
property:
iOS 7

Android
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10. You can place any component on each page.
To move to a different page, just click the tab you want on the Form
Designer, or change the ActiveTab property in the Object Inspector:

11. To change the location of tabs, select the TabPosition property for the
TabControls component.
For each tab, you can select any of the following values of the
TabPosition property in the Object Inspector:

Comparing the Tab Settings on iOS and Android
The following figures show both apps with the same TabPosition settings (Top,
Bottom, Dots, and None) on iOS and Android.
However, you should set the appropriate different tab settings for each mobile
platform, as indicated in #Using the Native Style for Tabs on iOS and Android.
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Top
iOS

Android

Tabs are displayed at the Top.
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Bottom
iOS

Android

Tabs are displayed at the Bottom.
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Dots
iOS

Android

No Tabs are displayed.
Instead, three Dots ([...]) are displayed to indicate additional pages.
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None
iOS

Android

No Tabs or Dots are displayed at run time, although you can see them at design time.
Page can be changed only through code or action.
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Platform Default
iOS

Android

Tabs are displayed with their platform default settings.
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Using Custom Multi-Resolution Icons for Your Tabs
You can use custom multi-resolution icons as well as custom text on tabs in your
application.
This tutorial shows you how to construct the following three tabs that have
custom icons and text:

Notes:
o

In Android apps, predefined icons are not supported, so you must use
custom icons.

o

In iOS apps, you can use either predefined icons or custom icons.

o

To use custom icons on either iOS or Android, select the appropriate iOS or
Android design device in the Form Designer, set the StyleLookup property
of TTabItem to tabitemcustom, specify your custom icon as described in
this section, and then build your app.

o

For iOS, you can use our predefined icons by setting the StyleLookup
property of TTabItem to the icon of your choice, such as
(tabitemsearch).

o

The custom glyphs used in this section are available in a zip file that is
delivered in your C:\Program Files
(x86)\Embarcadero\Studio\16.0\Images\GlyFX directory.
The three PNGs used here are located in the Icons\Aero\PNG\32x32
directory:


users_32 (People)



unlock_32 (Security)



tree_32 (Organization)

Unzip the glyFX.zip file before you use the MultiResBitmap Editor if you want to
use these images or any others available in the GlyFX collection.
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Displaying Multi-Resolution Custom Icons on Tabs
1. For a multi-device application, drop a TabControl component onto the
Form Designer, set its Align property to Client, and add several tabs on the
TabControl:

2. Select a tab, and click the ellipsis button [...] on the CustomIcon property
of TTabItem in the Object Inspector:

3. The MultiResBitmap Editor opens:
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4. Ensure that you are in the Master view, and in the MultiResBitmap Editor,
click the array next to Custom size, and then choose Default size.

5. Repeat the following steps to add any additional scales that you want to
support:
1. In the MultiResBitmap Editor, click

(Add new item).

2. Enter the additional Scale you want to support, such as 1.5, 2, or 3.
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6. Click the Fill All from File button
to use, and then click Open.

, navigate to an image file you want

The selected image now appears appropriately scaled in each of the Scale
entries on the MultiResBitmap Editor:

7. Close the MultiResBitmap Editor.
8. Repeat Steps 2 to 7 for each of the remaining tabitems, and assign each
tabitem a custom icon image.
9. In the Text property, change the text on each tab:
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After you define a custom icon, the FireMonkey framework generates a Selected
Image and Non-Selected (dimmed) Image based on the given .png file. This
transformation is done using the Alpha-Channel of the bitmap data. For
example:
Original Image Selected Image Non-Selected Image

Using a Single-Resolution Bitmap for a Custom Icon
You can also use only a single-resolution bitmap by using the Bitmap Editor. A
single-resolution bitmap displays only one scale in the Structure View:

To specify a single-resolution bitmap for a custom icon, perform the first step of
the procedure above and then proceed as follows:
1. In the Structure View, select Empty under CustomIcon:

2. Now, in the Object Inspector, click the ellipsis button [...] in the Bitmap field
(of the TabItem1.CustomIcon[0]). This opens the Bitmap Editor:
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3. In the Bitmap Editor, click the Load... button, and select a PNG file.
The recommended size is 30x30 pixels for normal resolution, and 60x60
pixels for high resolution:

4. Click OK to close the Bitmap Editor.
5. In the Object Inspector, set the StyleLookup property to be
tabitemcustom:
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Defining Controls within a TabControl
As discussed, each Tab Page can contain any number of controls including
another TabControl. In such a case, you can easily browse and manage
different tab pages in the Structure View:
iOS

Embarcadero Technologies

139

Mobile Tutorial: Using Tab Components to Display Pages (iOS and Android)

Android
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Changing the Page at Run Time
By the User Tapping the Tab
If Tabs are visible (when the TabPosition property is set to other than None), an
end user can simply tap a Tab to open the associated page.

By Actions and an ActionList
An action corresponds to one or more elements of the user interface, such as
menu commands, toolbar buttons, and controls. Actions serve two functions:
o

Actions represent properties common to the user interface elements, such
as whether a control is enabled or whether a check box is selected.

o

Actions respond when a control fires, for example, when the application
user clicks a button or chooses a menu item.

Here are the steps to enable a user to move to different tab pages by clicking a
button:
1. On a multi-device application, place a TabControl, and add several tab
items on it (TabItem1, TabItem2, and TabItem3).
2. In the Object Inspector, select TabItem2, and then change the tab
caption, which is specified in the Text property to Security.
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3. From the Tool Palette, add a TButton to the form, and then add an
ActionList component:
iOS:

Android:
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4. In the Form Designer, activate the Master view. Then select the button
component in the Object Inspector, and select Action | New Standard
Action | Tab > TChangeTabAction from the drop-down menu. After the
user clicks this button, the action you just defined is performed (the tab
page changes):
iOS:

Android:
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5. Select ChangeTabAction1 in the Structure View, and then select TabItem2
for the Tab property in the Object Inspector. By linking to TabItem2, this
action can change the page to TabItem2:
iOS:

Android:
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6. With the previous step, the caption (the Text property) of the button is
automatically changed to "Go To Security" because the caption of
TabItem2 is "Security" in our example. Change the size of the button to fit
the new caption text, or change the CustomText property of
ChangeTabAction1 component as shown here:
iOS:

Android:

7. ChangeTabAction also supports the Slide animation to indicate a
transition between pages. To use it, set the Transition property to Slide:
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By Source Code
You can use any of the following three ways to change the active tab page
from your source code, by clicking the button.
1. Add a TButton to the form.
2. In the Form Designer, double-click the button to create the OnClick event.
3. Choose one of the following actions, and add the code in the event
handler of the OnClick event of the button.

Assign an instance of TTabItem to the ActiveTab property
Delphi:
TabControl1.ActiveTab := TabItem1;

C++:
TabControl1->ActiveTab = TabItem1;

Change the TabIndex property to a different value
The TabIndex property is a zero-based Integer value. You can specify any
number between 0 and TabControl1.TabCount - 1.
Delphi:
TabControl1.TabIndex := 1;

C++:
TabControl1->TabIndex = 1;
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If ChangeTabAction is defined, you can execute an action from your code
Delphi:
// You can set the target at run time if it is not defined yet.
ChangeTabAction1.Tab := TabItem2;
// Call the action
ChangeTabAction1.ExecuteTarget(nil);

C++:
ChangeTabAction1->Tab = TabItem2;
ChangeTabAction1->ExecuteTarget(NULL);

See Also
o

Mobile Tutorial: Using a Button Component with Different Styles (iOS and
Android)

o

Mobile Tutorial: Using the Web Browser Component (iOS and Android)

o

Mobile Tutorial: Using ListBox Components to Display a Table View (iOS
and Android)

o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)
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Mobile Tutorial: Using LiveBindings
to Populate a ListView (iOS and
Android)
This tutorial shows how to use LiveBindings Designer to populate a FireMonkey
ListView component from a TPrototypeBindSource containing some sample data.
The tutorial shows you how to add the sample data and how to make the
bindings between the prototyping source and the list view component in order
to fill the list.
Like every LiveBinding, this tutorial requires no code. However, in order to create
a useful application, you do need to add event handlers and other code.

Step 1: Creating the Project
1. Create a new project. Choose a Multi-Device Application for this
example. In the wizard, choose Blank Application.
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2. In the Tool Palette, locate a TListView component and drop it onto the
form.
3. Add a TPrototypeBindSource component to the form.
4. On the form, select the ListView1 component, and then in the Object
Inspector, set the Align property to Client and the SearchVisible property
to True.
The form should now look like the following screen, before you set the Style or
View in the Form Designer:

Note: For more information about the selection of the Style and Views, see Style
Selector and Using FireMonkey Views.

Embarcadero Technologies

149

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and Android)

Step 2: Adding Fields
1. Right-click the TPrototypeBindSource component and then select Add
Field....

2. From the Add Field dialog box, select ColorsNames and click OK.
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Step 3: Creating LiveBindings
1. Open the LiveBindings Designer (choose View > LiveBindings Designer),
and drag the ColorsName1 property of the TPrototypeBindSource onto the
Item.Text property of the ListView to bind these properties.
The ListView component automatically populates its items with color names from
the prototyping data component:
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2. Set TListView.ItemAppearance to ImageListItemRightButton, as follows:


Place focus on the ListView component by selecting it (in the
Structure View, the Form Designer, or the Object Inspector).



Then, in the Object Inspector, locate the ItemAppearance node,
expand it and change the ItemAppearance property to
ImageListItemRightButton:

3. Optionally, you can apply a tint to the TListView text buttons. Do the
following:


Place focus on the ListView component by selecting it (in the
Structure View, the Form Designer, or the Object Inspector).



In the Structure View, under ItemAppearance, expand Item and
then select TextButton.



In the Object Inspector, locate the TintColor property and set its
value to an appropriate value, such as Seagreen.
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The following image shows both the Structure View and the Object Inspector. In
the Structure View, Item is expanded and TextButton is selected, and in the
Object Inspector, TintColor is set to Seagreen:

Note: At design time, the tint color that you applied to text buttons
might not be visible. To make your changes visible, choose the
Master view in the Style selector to change the current style of your
Form Designer to either Android or iOS. For details, see Form
Designer.
At this point in the tutorial, you have configured the ListView component to
display an image on the left-hand side of the item text, and to display a button
on the right-hand side of the item text.
In the next step, you populate the image and the button with sample data.

Embarcadero Technologies

153

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and Android)

Step 4: Adding More Fields (Bitmaps, Currency)
You need to add two more fields in order to make the list view component
display an image and some text on the button associated with each list item.
1. Right-click the TPrototypeBindSource component and select Add Field....
2. In the Add Field dialog box, Ctrl+Click to select Bitmaps and Currency
field data. When finished, click OK.
3. Go to the LiveBindings Designer and do the following:
1. Connect the Bitmap1 property of the prototyping source data to
the Item.Bitmap property of the list view component.
This step adds a button representing the color and number of each list view item,
such as Blue 19.
2. Connect the CurrencyField1 property from the prototyping source
data to the Item.ButtonText property of the list view component.
This step displays the currency field value on the button located on the righthand side of each list view item.

Now the list view displays some color data associated with each item and also
displays sample currency data on the button associated with each list item.
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Step 5: Adding the onButtonClick Event Handler
To create a usefull application, you can add the onButtonClick event handler
that fires when you click a ListView item.
To add the onButtonClick event handler
1. On the multi-device application form, select the ListView1 component.
2. In the Object Inspector, open the Events tab, and then double-click
OnButtonClick.
3. In the Code Editor, implement an appropriate OnButtonClick event
handler.
The following sample code adds the event handler that displays a message box
when you click a ListView item:
Delphi:
procedure TForm1.ListView1ButtonClick(const Sender: TObject;
const AItem: TListViewItem; const AObject: TListItemSimpleControl);
begin
ShowMessage(AItem.Text + ' ' +AItem.ButtonText + ' is clicked.');
end;

C++Builder:
void __fastcall TForm1::ListView1ButtonClick(TObject * const Sender,
TListViewItem * const AItem, TListItemSimpleControl * const AObject) {
ShowMessage(AItem->Text + " " + AItem->ButtonText + " is clicked.");
}
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The Results
To see your mobile app as it would appear on a mobile device, you need to
configure your system as described in the appropriate Setup tutorial, available
here, and set the View to a target mobile device (such as iPhone 4") in the Form
Designer. Then you need to complete the necessary steps for deploying your
app to the target mobile platform.
Then you can run the application on your mobile device, either by pressing F9 or
by choosing Run > Run.
iOS

iPad

Android

Galaxy S4

If you click the Blue item, the application displays the following message box:
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See Also
o

Mobile Tutorial: Using Tab Components to Display Pages (iOS and Android)

o

Mobile Tutorial: Using LiveBindings to Populate a ListBox in Mobile
Applications (iOS and Android)

o

Mobile Tutorial: Using Layout to Adjust Different Form Sizes or Orientations
(iOS and Android)

o

Customizing FireMonkey ListView Appearance

o

FMX.ListView.TListView

o

TPrototypeBindSource

o

LiveBindings in RAD Studio

o

LiveBindings Designer

o

Using FireMonkey Views

o

RAD Studio Tutorials
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Mobile Tutorial: Using ListBox
Components to Display a Table View
(iOS and Android)
Using ListBox Components to Display a Table View in
Mobile Platforms
On the mobile platform, FireMonkey uses the FMX.ListBox.TListBox component to
present a Table View in a mobile style, like the following ListBoxes.
Note:
FMX.ListBox.TListBox performance can be slow on mobile. Use
TListView if you want to develop more complex applications,
especially apps with large databases.
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Plain List
iOS
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Grouped List
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Search Box
You can add a search box to a ListBox. With a search box, users can easily
narrow down a selection from a long list as in the following pictures.

This tutorial describes the basic steps to build items for a Table View in your multidevice applications for mobile platforms.

Create Items on the ListBox Component
1. Select:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++Builder: File > New > Multi-Device Application - C++Builder
> Blank Application
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2. Select the TListBox component in the Tool Palette, and drop it on the Form
Designer. To find TListBox, enter a few characters (such as "TList") in the
Search box of the Tool Palette:

3. Select the TListBox component on the Form Designer, go to the Object
Inspector and select Client for the Align property.
4. On the Form Designer, right-click the TListBox component, and select
Items Editor:
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5. On the Items Designer, click the Add Item button several times to add
several items to the ListBox:

6. Close the Items Designer. Now you can find your ListBox Items on the
TListBox component. For example:
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Add a Header
You can define a Header on the TListBox component by using the following
steps:

A Header for a TListBox
1. On the Form Designer, right-click the TListBox component, and select Add
Item > TListBoxHeader:

2. On the Tool Palette, select the TLabel component and drop it on top of
the TListBoxHeader component you just added:
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3. In the Object Inspector, change the properties of the TLabel component
as follows:
Property

Value

Align

Client

StyleLookup

toollabel

TextSettings.HorzAlign Center
Text

(Text value as you want)

Add a Group Header/Footer to the List
You can define a Group Header and a Group Footer for items on TListBox as
follows:

1. On the Form Designer, right-click the TListBox component, and select
Items Editor.
2. On the Item Designer, select TListBoxGroupHeader from the drop-down
list, and then select Add Item:

3. Select TListBoxGroupFooter from the drop-down list, and then select Add
Item.
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4. Select ListBoxGroupHeader1 in the list of items, and click the Up button
several times until this item becomes the top item on the list:

5. Close the dialog box. Now you have a Group Header and a Group Footer
on the TListBox component.

Show List Items as Separate Grouped Items
Items on a ListBox can be shown as either a Plain list or a Grouped list. This choice
is controlled by the GroupingKind property and the StyleLookup property, as
shown in the following graphic:
Show Items as Plain List

Plain = GroupingKind Property Value

listboxstyle = StyleLookup Property
Value

Show Items as Grouped List

Grouped = GroupingKind Property
Value

transparentlistboxstyle = StyleLookup
Property Value

You can select the GroupingKind property and the StyleLookup property in the
Object Inspector when the ListBox is selected in the Form Designer.
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Add a Check Box or Other Accessory to a ListBox Item
Each item in a TListBox can use an Accessory such as Check Mark through the
ItemData.Accessory property. The following picture shows the value you can
assign to ItemData.Accessory and the Accessory assigned:

You can select the Accessory property in the Object Inspector when ListBox Item
is selected in the Form Designer.

Add an Icon to a ListBox Item
Each Item on a ListBox component can contain Bitmap data, as an Icon,
through the ItemData.Bitmap property:

You can select the Bitmap property in the Object Inspector when the ListBoxItem
is selected in the Form Designer.
In order to view the Icon, you must select a StyleLookup which supports the
Bitmap property. Change the StyleLookup property to listboxitemleftdetail.
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Add Detail Information to an Item
You can add additional text information to each item on the ListBox component.
Specify additional text in the ItemData.Detail property, and select the location of
the Detail Text through the StyleLookup property, as shown in the following table:
StyleLookup property

Look & Feel

listboxitemnodetail

listboxitembottomdetail

listboxitemrightdetail

listboxitemleftdetail

Running Your Application
Run the application either by choosing Run > Run or by pressing F9.

Create Your ListBox Application
1. Select:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++Builder: File > New > Multi-Device Application - C++Builder
> Blank Application

2. Select the TListBox component in the Tool Palette, and drop it on the Form
Designer.
3. Select the TListBox component on the Form Designer, go to the Object
Inspector and select Client for the Align property.
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Add Items to a ListBox from Your Code
To add regular items to a ListBox, you can simply call the Items.Add method as
shown in the following code snippet:
o

Delphi:

ListBox1.Items.Add('Text to add');

o

C++:

ListBox1->Items->Add("Text to add");

If you want to create items other than a simple item, or control other properties,
you can create an instance of the item first, and then add it to the list box.
The following sample codes add items to a ListBox, as shown in the picture:
iOS
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Delphi:
procedure TForm1.FormCreate(Sender: TObject);
var
c: Char;
i: Integer;
Buffer: String;
ListBoxItem : TListBoxItem;
ListBoxGroupHeader : TListBoxGroupHeader;
begin
ListBox1.BeginUpdate;
for c := 'a' to 'z' do
begin
// Add header ('A' to 'Z') to the List
ListBoxGroupHeader := TListBoxGroupHeader.Create(ListBox1);
ListBoxGroupHeader.Text := UpperCase(c);
ListBox1.AddObject(ListBoxGroupHeader);
// Add items ('a', 'aa', 'aaa', 'b', 'bb', 'bbb', 'c', ...) to the list
for i := 1 to 3 do
begin
// StringOfChar returns a string with a specified number of repeating
characters.
Buffer := StringOfChar(c, i);
// Simply add item
// ListBox1.Items.Add(Buffer);
// or, you can add items by creating an instance of TListBoxItem by
yourself
ListBoxItem := TListBoxItem.Create(ListBox1);
ListBoxItem.Text := Buffer;
// (aNone=0, aMore=1, aDetail=2, aCheckmark=3)
ListBoxItem.ItemData.Accessory := TListBoxItemData.TAccessory(i);
ListBox1.AddObject(ListBoxItem);
end;
end;
ListBox1.EndUpdate;
end;

Embarcadero Technologies

170

Mobile Tutorial: Using ListBox Components to Display a Table View (iOS and Android)

C++:
void __fastcall TForm1::FormCreate(TObject *Sender)
{
char c;
int i;
String Buffer ;
TListBoxItem *ListBoxItem ;
TListBoxGroupHeader *ListBoxGroupHeader

;

ListBox1->BeginUpdate();
for (c = 'a'; c <= 'z'; c++)
{
// Add header ('A' to 'Z') to the List
ListBoxGroupHeader = new TListBoxGroupHeader(ListBox1);
ListBoxGroupHeader->Text = UpperCase(c);
ListBox1->AddObject(ListBoxGroupHeader);
// Add items ('a', 'aa', 'aaa', 'b', 'bb', 'bbb', 'c', ->->->) to the
list
for (i = 1; i < 4; i++)
{
// StringOfChar returns a string with a specified number of repeating
characters->
Buffer = StringOfChar(c, i);
// Simply add item
// ListBox1->Items->Add(Buffer);
// or, you can add items by creating an instance of TListBoxItem by
yourself
ListBoxItem = new TListBoxItem(ListBox1);
ListBoxItem->Text = Buffer;
// (aNone=0, aMore=1, aDetail=2, aCheckmark=3)
ListBoxItem->ItemData->Accessory =
static_cast<TListBoxItemData::TAccessory>(i);
ListBox1->AddObject(ListBoxItem);
};
};
ListBox1->EndUpdate();
}
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Create an Overflow Menu
An overflow popup menu is accessed via the Action Bar and is used to provide
access to additional items or items that are used less often.
In FireMonkey, you can easily implement an overflow menu using TListBox:
1. Add a TToolBar component on the form and set the alignment to Top.
2. Place three TSpeedButton components on the TToolBar component:







For the first TSpeedButton:


Set the Align property to Left.



Change the Name property to OrganizeButton.



Set the StyleLookup to organizetoolbutton.

For the second TSpeedButton:


Set the Align property to Right.



Change the Name property to OverflowButton.



Select detailstoolbutton for the StyleLookup property.

For the last TSpeedButton:


Set the Align property to Right.



In Object Inspector expand the Margins node and set the
Right margin to 5.



Change the Name property to SearchButton.



Set the StyleLookup to searchtoolbutton.

3. Drop a TListBox to the form.


Add five TListBoxItem from Items Editor.



Check akTop and akRight from the Anchors property of the TListBox
component.



Set Height to 220.



Change Name to OverflowMenu.



Set the Visible property to False.
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4. For the first four TListBoxItem components in TListBox go to Object
Inspector, expand ItemData:


Define the Bitmap property.



Change the Text property to the text value that you want.



Select listboxitemleftdetail for the StyleLookup property.

5. For the last TListBoxItem, in the Object Inspector expand ItemData:


Set Accessory to aMore and Text to More.

6. Add a TShadowEffect component to the overflow menu.
Structure View
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Creating the Event Handler for the Overflow Button
In the Form Designer, double-click the OverflowButton component. Add the
following code to this event handler:
o

Delphi:

procedure TForm1.OverflowButtonClick(Sender: TObject);
begin
OverflowMenu.Visible := not OverflowMenu.Visible; //change the visibility
status
if OverflowMenu.Visible then // the Overflow Menu is displayed
begin
OverflowMenu.BringToFront;
OverflowMenu.ItemIndex := -1; // the ItemIndex property specifies the
currently selected item(default value is -1 that means that no item is
selected)
OverflowMenu.ApplyStyleLookup;
OverflowMenu.RealignContent; // realigns the children TListBoxItem controls
of the OverflowMenu TListBox
end;
end;

o

C++:

void __fastcall TForm1::OverflowButtonClick(TObject *Sender)
{
OverflowMenu->Visible = !(OverflowMenu->Visible); //change the
visibility status
if (OverflowMenu->Visible) {
// the Overflow Menu is
displayed
OverflowMenu->BringToFront();
OverflowMenu->ItemIndex = -1; // the ItemIndex property
specifies the currently selected item(default value is -1 that means that no
item is selected)
OverflowMenu->ApplyStyleLookup();
OverflowMenu->RealignContent(); // realigns the children
TListBoxItem controls of the OverflowMenu TListBox
}
}
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Add a Search Box
o

To add a Search Box to the ListBox component, right-click the TListBox
component and simply select Add Item > TSearchBox from the context
menu:

o

To add it to the Action Bar:


Set the Visible property to False.



To create the event handler for the SearchButton, double-click it
and add the following code:

Delphi:
procedure TForm1.SearchButtonClick(Sender: TObject);
begin
SearchBox1.Visible := not SearchBox1.Visible; //change the visibility status
end;

C++:
void __fastcall TForm1::SearchButtonClick(TObject *Sender) {
SearchBox1->Visible = !(SearchBox1->Visible); //change the visibility
status
}
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Running Your Application
1. Select either:


Run > Run



Run > Run Without Debugging

2. To invoke the overflow menu, click the vertical ellipsis on the Action bar.
3. To view the search box, click the SearchButton.
Android (Samsung Tab 2.0)

Android (Samsung Tab 2.0)

Displaying the overflow menu

Displaying the search box
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See Also
o

FMX.ListBox.TListBox

o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)

o

Mobile Tutorial: Using LiveBindings to Populate a ListBox in Mobile
Applications (iOS and Android)

o

Mobile Tutorial: Using a Button Component with Different Styles (iOS and
Android)

o

Mobile Tutorial: Using the Web Browser Component (iOS and Android)

o

Mobile Tutorial: Using Tab Components to Display Pages (iOS and Android)

Embarcadero Technologies

177

Mobile Tutorial: Using LiveBindings to Populate a ListBox in Mobile Applications (iOS and Android)

Mobile Tutorial: Using LiveBindings
to Populate a ListBox in Mobile
Applications (iOS and Android)
This tutorial guides you through the steps of connecting data to a FireMonkey
ListBox control on your mobile devices, using LiveBindings.

Step 1: Creating the Project
In this project, you need a list box, a rectangle, and also a prototyping binding
source. To add these components, follow the steps below:
1. Select:


For Delphi: File > New > Multi-Device Application - Delphi



For C++: File > New > Multi-Device Application - C++Builder

2. Select the TListBox component in the Tool Palette, and drop it on the Form
Designer.
3. Select the list box component on the Form Designer, and in the Object
Inspector, locate the DefaultItemStyles.ItemStyle property. Set it to the
listboxitemrightdetail style.

4. Unselect the list box component by clicking in a blank area of the Form
Designer.
5. Select the TRectangle component in the Tool Palette, and drop it on the
Form Designer.
6. Select the rectangle component on the Form Designer, and in the Object
Inspector, set the Align property to Bottom.
7. Select the list box component and set its Align property to Client.
8. Now drop a TPrototypeBindSource from the Tool Palette onto your form.
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At this point, your form should be similar to the following iOS screen:

Embarcadero Technologies

179

Mobile Tutorial: Using LiveBindings to Populate a ListBox in Mobile Applications (iOS and Android)

You need to add sample data for colors and color names to the
TPrototypeBindSource component in order to support the purpose of this tutorial
and to link to the list box and the rectangle.
1. Right-click the TPrototypeBindSource component, and then click Add
Field on the context menu.
2. Select AlphaColors and ColorsNames from the Field Data list, and clear
the Shuffle Values check box.
This operation adds sample alphabetically sorted data (alpha color
values and names).

3. Validate your selection by clicking the OK button. Now the sample data is
ready to be used through LiveBindings.
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Step 2: Creating the LiveBindings
Open the LiveBindings Designer. The diagram with no connections is similar to the
following image:

1. Bind ColorsName1 from PrototypeBindSource1 to Item.Text from ListBox1.
(Click ColorsName1 and drag the mouse to Item.Text.) Now the list box
displays all the color names in the prototyping binding source.
2. Bind ColorsName1 from PrototypeBindSource1 to ItemHeader.Text from
ListBox1. Now the list box also displays headers with all the color names in
the prototyping binding source.
3. In the LiveBindings Designer, click the binding that connects ColorsName1
to ItemHeader.Text.
4. In the Object Inspector, locate the FillHeaderCustomFormat property and
select the SubString(%s, 0, 1)binding expression from the drop-down list.
At this point, the list box groups all the color names into alphabetical categories:

5. Bind AlphaColor1 from PrototypeBindSource1 to Item.LookupData from
ListBox1. This ensures that the selection of the color name also points to
the correct alpha color value.
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6. Bind AlphaColor1 from PrototypeBindSource1 to Item.Detail from ListBox1.
This ensures the alpha color value appears in the right side of the item in
the list box.
7. Click the ellipsis button [...] on the Rectangle1 diagram block in the
LiveBindings Designer, and in the dialog that opens, type Fill.Color. Select
the Fill.color check box, then click OK:

8. Bind Fill.Color from Rectangle1 to SelectedValue from ListBox1. This ensures
the rectangle's fill color changes according to your list box item selection.
Note: When attempting to bind Fill.Color to SelectedValue, a
confirmation message box opens. In this message box, choose Yes.
After you complete the steps above, the LiveBindings diagram will be similar to
the following image:

Your application is now ready to run on the mobile device.
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The Results
To run the application, press F9 or choose Run > Run.
When you select a list box item, the rectangle's color changes accordingly:

iOS (iPad)
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See Also
o

LiveBindings in RAD Studio

o

LiveBindings Designer

o

Using Custom Format and Parse Expressions in LiveBindings

o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)

o

Mobile Tutorial: Using ListBox Components to Display a Table View (iOS
and Android)

o

Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and Android)
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Mobile Tutorial: Using Layout to
Adjust Different Form Sizes or
Orientations (iOS and Android)
This tutorial describes a general strategy for using the Master view for different
form factors (such as phone or tablet), without using different views for each
form factor.

Every FireMonkey Component Can Have an Owner, a
Parent, and Children
First, every FireMonkey component has the idea of Owner, Parent, and Children.
If you place a component on a form, the form becomes the owner and parent
of the component.
If you add components (for example, a Button, Label, and others) to another
component (for example, a ToolBar), the ToolBar is both parent and owner of the
Button, Label, and others. You can see this parent-child relationship graphically
represented in the tree view in the Structure View.
The Layout for a child is defined as a value relative to its parent. In the following
picture, Label1 is the child of Toolbar1, and the Layout of Label1 is relative to
Toolbar1.

Using Common Layout-Related Properties of a
FireMonkey Component
Using the Align Property
A control's Align property determines whether it is automatically repositioned
and/or resized along its parent's four sides or center, both initially and as the
parent is resized.
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The default value for the Align property is None, which means that no automatic
calculations are performed: the control stays where it is placed:
Align = None

Typical values for the Align property are as follows (Dodgerblue indicates the
area for the child):
Top

Bottom

Left

Right

Center

Client

If you use an Align value of Top, Bottom, Left, or Right for one component, the
Align properties for other components use the remaining area.
The size and shape of the remaining area (Client) also changes based on the
orientation of the device, and based on the form factor (iPhone or iPad).
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The following pictures show the layout for landscape (horizontal) and for portrait
(vertical) when you have two (2) components that use Top, and one (1)
component that uses Client.

Using the Margins Property
Margins ensure separation between controls automatically positioned by a
parent.
In the following picture, the right side of the component (Align = Client) uses the
Margins property to ensure space around the component.

Using the Padding Property
Padding sets aside space on the interior of the parent's content box. In the
Object Inspector, you can set values (in pixels) for the Padding:
o

Left

o

Right

o

Bottom

o

Top
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In the following picture, the parent component (which contains two regions)
uses the Padding property to ensure space inside the parent component:

Using the Anchors Property
Anchors are needed when a control must maintain its position at a certain
distance from the edges of its parent, or must stretch while maintaining the
original distance between its edges and the edges of its parent. Anchored
controls 'stick' to the sides of containers and stretch, if so specified.

Anchors Property for the Edit Control
If you have an Edit control on top of a ToolBar, you may want to keep a fixed
distance between the right edge of the Edit Control and the edge of the form
(ToolBar). Anchors enable you to specify that a control is to remain fixed in
relation to the sides of its parent.
If you want the Edit control to maintain the same relative position in relation to
the ToolBar (its parent), you can set the Anchors property to akLeft, akTop,
akRight. When the ToolBar is resized, the Edit control is resized according to the
Anchors settings:
iOS

Android
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Anchors Property for Button Control
If you have a Button control at the right end of the ToolBar, you may want to
keep the same distance between the right edge of the Button control and the
edge of the Form. However, you might not want to maintain the same distance
between the left edge of the Button control and the left edge of the Form. In this
case, you can set the Anchors property to akTop, akRight (de-select akLeft), so
that the Button control maintains the same distances with the ToolBar (parent) for
Top and Right.
iOS:

Android:

Using the TLayout Component
TLayout, a component that is not visible at run time, can be used to group its
child controls to be manipulated as a whole. For example, you can set the
visibility of a group of controls at one time by setting the Visible property of the
layout. TLayout does not automatically set any of the properties of its children.
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To make selected controls children of TLayout, use the Structure View.
Highlight the controls you want to move. Then drag the group of controls over
the control that should be the parent, and drop the controls there. In the
Structure View, the group of controls are now children of the new parent:
1. Initial State

2. Highlight the Controls to Move

3. Drag onto Parent

You can use Align, Padding, Margins, Anchors, and other properties of TLayout to
define the layout for a specific area. You can use the TLayout component just
like the DIV tag in HTML.

See Also
o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)

o

Mobile Tutorial: Using ListBox Components to Display a Table View (iOS
and Android)

o

Mobile Tutorial: Using Location Sensors (iOS and Android)

o

Tutorial: Using FireMonkey Layouts

o

FireMonkey Layouts Strategies

o

Arranging FireMonkey Controls

o

Gestures in FireMonkey
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Mobile Tutorial: Taking and Sharing a
Picture, and Sharing Text (iOS and
Android)
Before starting this tutorial, you should read and perform the following tutorial:
o

Mobile Tutorial: Using a Button Component with Different Styles (iOS and
Android)

This tutorial covers the following typical tasks for using pictures and sharing text
with your applications in mobile platforms.
On iOS Devices:
Taking a picture with the device camera
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Sharing or printing a picture
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On Android Devices:
Taking a picture with the device camera Using a picture from the device Photo Library
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Sharing or printing a picture
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Topics
o

Taking and Sharing Pictures and Text Using Action Lists

o

Taking Pictures Using FireMonkey Interfaces

See Also
o

Mobile Tutorial: Using Location Sensors (iOS and Android)

o

Mobile Tutorial: Using Notifications (iOS and Android)

o

Mobile Code Snippets

o

FireMonkey Actions

o

FMX.StdCtrls.TButton

o

FMX.Objects.TImage

o

FMX.MediaLibrary

o

FMX.Mobile.PhotoEditorDemo Sample (Delphi)

o

http://appleinsider.com/articles/12/02/16/share_sheets
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Mobile Tutorial: Using Location
Sensors (iOS and Android)
Before starting this tutorial, you should read and perform the following tutorial
sessions:
o

Mobile Tutorial: Using ListBox Components to Display a Table View (iOS
and Android)

o

Mobile Tutorial: Using the Web Browser Component (iOS and Android)

o

Mobile Tutorial: Using Layout to Adjust Different Form Sizes or Orientations
(iOS and Android)

Note: On Android devices, TLocationSensor requires specific Uses Permissions to
be set, specifically Access coarse location and Access fine location.
This tutorial describes the basic steps to locate your mobile device (using latitude
and longitude), and to use Reverse Geocoding to convert to a readable
address, such as in the following picture:

Embarcadero Technologies

196

Mobile Tutorial: Using Location Sensors (iOS and Android)

Design the User Interface
This demo application is designed with two major components: a TListBox (on the
left-hand side) and a TWebBrowser.
Note: Before proceeding with this scenario, in the Project Manager,
set the active target platform to iOS Device or Android. Otherwise,
you cannot add the TWebBrowser component.
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o

In the TListBox, set the Align property to Left to reserve the left side of the
UI. Then create the following subcomponents under the ListBox:


o

A TListBoxHeader component with the following sub-components:


A TLabel component to show the title "Location Demo"



A TSwitch (Switch1) component to select on/off of
TLocationSensor



A TListBoxGroupHeader with the text "Your Location"



A TListBoxItem with the name "ListBoxItemLatitude" and "Latitude" as
text



A TListBoxItem with the name "ListBoxItemLongitude" and
"Longitude" as text



A TListBoxGroupHeader with the text "Current Address"



A TListBoxItem with the name "ListBoxItemAdminArea" and
"AdminArea" as text



A TListBoxItem with the name "ListBoxItemCountryCode" and
"CountryCode" as text



A TListBoxItem with the name "ListBoxItemCountryName" and
"CountryName" as text



A TListBoxItem with the name "ListBoxItemFeatureName" and
"FeatureName" as text



A TListBoxItem with the name "ListBoxItemLocality" and "Locality" as
text



A TListBoxItem with the name "ListBoxItemPostalCode" and
"PostalCode" as text



A TListBoxItem with the name "ListBoxItemSubAdminArea" and
"SubAdminArea" as text



A TListBoxItem with the name "ListBoxItemSubLocality" and
"SubLocality" as text



A TListBoxItem with the name "ListBoxItemSubThoroughfare" and
"SubThoroughfare" as text



A TListBoxItem with the name "ListBoxItemThoroughfare" and
"Thoroughfare" as text

A TWebBrowser component (WebBrowser1) to show the Web Page
(Google Maps). Set the Align property to Client.
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After you create these components, select all TListBoxItem items and select
listboxitemleftdetail in the StyleLookup property. This allows TListBoxItem to show
both a label and detailed text.

The Location Sensor
The location sensor is wrapped by the TLocationSensor component.
TLocationSensor fires an OnLocationChanged event when the device detects
movement. You can adjust the sensitivity of TLocationSensor using the Distance
and Accuracy properties.
o

The Distance property specifies the minimum distance (in meters) by
which the device must move in order to make the location sensor
relocate the device and return new location information. For example, if
you set Distance to "10", TLocationSensor fires an OnLocationChanged
event when you move "10 meters".

o

The Accuracy property represents the level of precision (in meters) by
which the sensor locates the device geographically, relative to the
geographical point at which the device is actually located.

Tip: You should specify the lowest accuracy that works for your application; the
higher the accuracy, the more time and power that the sensor requires to
determine the location. The recommended values: Distance=0; Accuracy=0.

Read Location Information (Latitude, Longitude) from
the LocationSensor Component
The TLocationSensor component needs to be activated for use. You can turn
on/off TLocationSensor based on your input, such as a TSwitch component, or
other Application events.
1. Place a TLocationSensor component from the Tool Palette.
2. On the Form Designer, select the TSwitch component.
3. In the Object Inspector, in the Events tab double-click OnSwitch event.
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4. Add the following code to the OnSwitch event handler:
Delphi:
procedure TForm1.Switch1Switch(Sender: TObject);
begin
LocationSensor1.Active := Switch1.IsChecked;
end;

C++:
void __fastcall TForm1::Switch1Switch(TObject *Sender)
{
LocationSensor1->Active = Switch1->IsChecked;
}

As discussed earlier, TLocationSensor fires an OnLocationChanged event when
you move the mobile device. You can show the current location (Latitude and
Longitude) using parameters with an event handler.
1. On the Form Designer, select the TLocationSensor.
2. In the Object Inspector, in the Events tab double-click OnLocationChange
event.
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3. Add the following code to the OnLocationChange event handler:
Delphi:
procedure TForm1.LocationSensor1LocationChanged(Sender: TObject;
const OldLocation, NewLocation: TLocationCoord2D);
var
LDecSeparator: String;
begin
LDecSeparator := FormatSettings.DecimalSeparator;
FormatSettings.DecimalSeparator := '.';
// Show current location
ListBoxItemLatitude.ItemData.Detail := Format('%2.6f',
[NewLocation.Latitude]);
ListBoxItemLongitude.ItemData.Detail := Format('%2.6f',
[NewLocation.Longitude]);
end;

C++:
void __fastcall TForm1::LocationSensor1LocationChanged(TObject *Sender, const
TLocationCoord2D &OldLocation,
const TLocationCoord2D &NewLocation)
{
char LDecSeparator = FormatSettings.DecimalSeparator;
FormatSettings.DecimalSeparator = '.';
// Show current location
ListBoxItemLatitude->ItemData->Detail = ListBoxItemLatitude->ItemData>Detail.sprintf(L"%2.6f", NewLocation.Latitude);
ListBoxItemLongitude->ItemData->Detail = ListBoxItemLongitude>ItemData->Detail.sprintf(L"%2.6f", NewLocation.Longitude);
}

Show the Current Location Using Google Maps via a
TWebBrowser Component
As discussed in the Mobile Tutorial: Using the Web Browser Component (iOS and
Android), the TWebBrowser component wraps a Web browser for mobile
platforms.
You can call Google Maps from the TWebBrowser component with the following
URL parameters:
https://maps.google.com/maps?q=(Latitude-value),(Longitude-value)
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So you can add this URL to your previously created event handler
OnLocationChanged as follows:
Delphi:
procedure TForm1.LocationSensor1LocationChanged(Sender: TObject;
const OldLocation, NewLocation: TLocationCoord2D);
var
URLString: String;
begin
// code for previous step goes here
// Show Map using Google Maps
URLString := Format(
'https://maps.google.com/maps?q=%s,%s',
[Format('%2.6f', [NewLocation.Latitude]), Format('%2.6f',
[NewLocation.Longitude])]);
WebBrowser1.Navigate(URLString);
end;

C++:
void __fastcall TForm1::LocationSensor1LocationChanged(TObject *Sender, const
TLocationCoord2D &OldLocation,
const TLocationCoord2D &NewLocation)
{
// code for previous step goes here
// Show Map using Google Maps
String LLongitude = FloatToStr(NewLocation.Longitude, FormatSettings);
String URLString = "";
URLString =
URLString.sprintf(L"https://maps.google.com/maps?q=%2.6f,%2.6f",
NewLocation.Latitude, NewLocation.Longitude);
FormatSettings.DecimalSeparator = LDecSeparator;
WebBrowser1->Navigate(URLString);
}

Use Reverse Geocoding
TGeocoder is an object which wraps the Geocoding (or Reverse Geocoding)
service.
Geocoding is the process of transforming geographic data, such as the address
and zip code, into geographic coordinates. Reverse geocoding is the process of
transforming geographical coordinates into other geographical data, such as
the address.
In this case, we use TGeocoder to "Reverse Geocode" our location (in Latitude
and Longitude) to readable address information.
Here is the basic sequence of actions with TGeocoder:
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1. Create an instance of TGeocoder.
2. Define an event OnGeocodeReverse so that you can receive the event
later.
3. Set data to execute "Reverse Geocoding".
4. TGeocoder accesses the service on the network to resolve the address
information.
5. TGeocoder fires an OnGeocodeReverse event.
6. Your iOS App receives the address information through the parameter on
the OnGeocodeReverse event and updates the user interface.
Note: As TGeocoder is not a component (this is just a class), you need to define
these steps through your code (you cannot drop a component, nor assign an
event handler through the Object Inspector).
First, define a new field "FGeocoder" in the private section of the form. You can
also define an "OnGeocodeReverseEvent procedure" as in the following code
snippets.
Delphi:
type
TForm1 = class(TForm)
// IDE defines visible (or non-visual) components here automatically
private
{ Private declarations }
FGeocoder: TGeocoder;
procedure OnGeocodeReverseEvent(const Address: TCivicAddress);
public
{ Public declarations }
end;

C++:
Note: Place this code snippet in the header file (.h)
class TForm1 : public TForm
{
// IDE defines visible (or non-visual) components here automatically
private:
// User declarations
TGeocoder *FGeocoder;
void __fastcall OnGeocodeReverseEvent(TCivicAddress* const Address);
public:
// User declarations
__fastcall TForm1(TComponent* Owner);
};
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Now you can create an instance of TGeocoder and set it up with data with the
following Delphi or C++ code.
TGeocoder.Current gives the type of class that actually implements the
Geocoding Service. The code in "TGeocoder.Current.Create" calls the
constructor (Create) for the specified type, and saves it to the FGeocoder field.
You also need to specify an event handler, which is fired when TGeocoder
completes Reverse Geocoding. Assign OnGeocodeReverseEvent (which you just
defined in the previous step) to FGeocoder.OnGeocodeReverse.
Finally, if you successfully created an instance of TGeocoder, and TGeocoder is
not running, call TGeocoder.GeocodeReverse with location information. After
TGeocoder receives data, the OnGeocodeReverseEvent event is fired.
Delphi:
procedure TForm1.LocationSensor1LocationChanged(Sender: TObject;
const OldLocation, NewLocation: TLocationCoord2D);
begin
// code for previous steps goes here
try
// Setup an instance of TGeocoder
if not Assigned(FGeocoder) then
begin
if Assigned(TGeocoder.Current) then
FGeocoder := TGeocoder.Current.Create;
if Assigned(FGeocoder) then
FGeocoder.OnGeocodeReverse := OnGeocodeReverseEvent;
end;
// Translate location to address
if Assigned(FGeocoder) and not FGeocoder.Geocoding then
FGeocoder.GeocodeReverse(NewLocation);
except
ListBoxGroupHeader1.Text := 'Geocoder service error';
end;
end;
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C++:
void __fastcall TForm1::LocationSensor1LocationChanged(TObject *Sender, const
TLocationCoord2D &OldLocation,
const TLocationCoord2D &NewLocation)
{
// code for previous steps goes here
// Setup an instance of TGeocoder
try {
if (FGeocoder == NULL) {
if (TGeocoder::Current != NULL) {
FGeocoder = (TGeocoder*)new TGeocoderClass(TGeocoder::Current);
}
if (FGeocoder != NULL) {
FGeocoder->OnGeocodeReverse = OnGeocodeReverseEvent;
}
}
// Translate location to address
if ((FGeocoder != NULL) && (FGeocoder->Geocoding)) {
FGeocoder->GeocodeReverse(NewLocation);
}
}
catch (...) {
ListBoxGroupHeader1->Text = "Geocoder service error";
}
}

Show a Readable Address in the ListBox Component
As described earlier, after Reverse Geocoding is completed, an
OnGeocodeReverseEvent is fired.
Next, assign properties in the TCivicAddress address parameter to show readable
address information in the list box fields:
Delphi:
procedure TForm1.OnGeocodeReverseEvent(const
begin
ListBoxItemAdminArea.ItemData.Detail
ListBoxItemCountryCode.ItemData.Detail
ListBoxItemCountryName.ItemData.Detail
ListBoxItemFeatureName.ItemData.Detail
ListBoxItemLocality.ItemData.Detail
ListBoxItemPostalCode.ItemData.Detail
ListBoxItemSubAdminArea.ItemData.Detail
ListBoxItemSubLocality.ItemData.Detail
ListBoxItemSubThoroughfare.ItemData.Detail
ListBoxItemThoroughfare.ItemData.Detail
end;
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C++:
void __fastcall TForm1::OnGeocodeReverseEvent(TCivicAddress*
{
if (Address != NULL){
ListBoxItemAdminArea->ItemData->Detail
>AdminArea;
ListBoxItemCountryCode->ItemData->Detail
>CountryCode;
ListBoxItemCountryName->ItemData->Detail
>CountryName;
ListBoxItemFeatureName->ItemData->Detail
>FeatureName;
ListBoxItemLocality->ItemData->Detail
>Locality;
ListBoxItemPostalCode->ItemData->Detail
>PostalCode;
ListBoxItemSubAdminArea->ItemData->Detail
>SubAdminArea;
ListBoxItemSubLocality->ItemData->Detail
>SubLocality;
ListBoxItemSubThoroughfare->ItemData->Detail
>SubThoroughfare;
ListBoxItemThoroughfare->ItemData->Detail
>Thoroughfare;
}
}

const Address)
= Address= Address= Address= Address= Address= Address= Address= Address= Address= Address-

Describing Why Your Application Needs the User
Location
Before you deploy your final application you should select Project > Options >
Version Info and update the values of NSLocationAlwaysUsageDescription and
NSLocationWhenInUseUsageDescription with a message that explains why your
application is asking for the user location. Your users see this message when your
application asks them to authorize iOS to provide the location of the iOS device
to your application.

See Also
o

Mobile Tutorial: Using Layout to Adjust Different Form Sizes or Orientations
(iOS and Android)

o

Mobile Tutorial: Using Notifications (iOS and Android)

o

Mobile Tutorial: Using Remote Notifications (iOS and Android)

o

System.Sensors.TGeocoder

o

System.Sensors.Components.TLocationSensor

o

Mobile Code Snippets: Notifications
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Mobile Tutorial: Using Notifications
(iOS and Android)
This tutorial describes the basic steps to use notifications on your mobile device.

Three Basic Notification or Alert Styles
When users set notifications for apps on their mobile devices, notifications can be
delivered from apps in the three basic styles shown here. The banner appears
briefly, but the alert dialog box requires dismissal by the user.

Notification Banner on Mobile Devices
iOS

Android
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Alert Dialogs: iOS Badge Number and Android Notification Number
iOS Badge Number

iPad
Android Notification Number

Android

Notification Center on Mobile Devices
The following images show the notification center on an iPad (Notification
Center) and Android (notification drawer), where the user can pull down the list
of all recent notifications.
iOS
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Android

Access the Notification Service
On the mobile platforms, FireMonkey provides the TNotificationCenter
component that allows you to easily access the Notification Service.
To access the notification service, do the following:
1. Create a new mobile application:


For Delphi: File > New > Multi-Device Application - Delphi



For C++: File > New > Multi-Device Application - C++Builder

2. Include the needed units in the project:


For Delphi applications, add the following 2 units to the uses clause
if they are not present:

uses
FMX.Platform, FMX.Notification;



For C++ applications, add the following include operators to the
project header file (.h file):

#include <FMX.Platform.hpp>
#include <FMX.Notification.hpp>

3. Select the TNotificationCenter component in the Tool Palette, and drop it
on the Form Designer.
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Note: If the TNotificationCenter component is disabled, select the target platform
for Android or iOS.
The FMX.Notification.TNotificationCenter.CreateNotification method allows you to
create an instance of the TNotification class object.

Add FMLocalNotificationPermission (iOS 8 Only)
In order to use notifications on iOS 8 devices, you need to ensure that the
FMLocalNotificationPermission Key/Value pair is enabled on the Version Info
page of Project Options.
1. Choose Project > Options > Version Info.
2. In the Target field, select Debug configuration - iOS device - 32-bit
platform.
3. Set the Value field for FMLocalNotificationPermission to true.
The FMLocalNotificationPermission setting enables local notifications on iOS 8
devices:

Set the Icon Badge Number and Notification Number
from Code
TNotification.Number defines the Icon Badge Number (for iOS devices) and the
notification number (for Android devices).
To set the iOS icon badge number (for Delphi or C++) or the Android notification
number (only for Delphi apps), you need to implement the corresponding
method.
1. Drop a TButton to the form.
2. In the Object Inspector, change the Name property to SetNumber.
3. Create the OnClick event of the SetNumber button by double-clicking the
button.
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4. Implement the event handler for the OnClick event of the SetNumber
button by adding the following code:


For Delphi:

procedure TForm1.SetNumberClick(Sender: TObject);
var
MyNotification: TNotification;
begin
// Create an instance of TNotification
MyNotification := NotificationCenter1.CreateNotification;
try
// --- your code goes here --// Set the icon or notification number
MyNotification.Number :=18;
// Set the alert message
MyNotification.AlertBody := 'Delphi for your mobile device is
here!';
// Note: You must send the notification to the notification center
for the Icon Badge Number to be displayed.
NotificationCenter1.PresentNotification(MyNotification);
finally
MyNotification.DisposeOf;
end;
end;



For C++:

void __fastcall TForm1::SetNumberClick(TObject *Sender)
{
if (NotificationCenter1->Supported()) {
TNotification *myNotification = NotificationCenter1>CreateNotification();
__try {
myNotification->Number = 18;
myNotification->AlertBody = "C++ for your mobile
device is here!";
NotificationCenter1>PresentNotification(myNotification);
}
__finally {
myNotification->DisposeOf();
}
}
}
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After running your application (press F9) and clicking the SetNumber button, you
can see the following:
o

A badge on the application icon (on the iOS Home screen):

o

A number next to the notification message in the notification center (on
Android):

Android

Schedule Notification
You can also schedule Notification Messages using the ScheduleNotification
method that the TNotificationCenter class inherits from
TCustomNotificationCenter.
To show a Notification Message, you need to create an instance of the
TNotification class, and then define the Name, AlertBody, and FireDate fields.
1. Drop a new TButton to the form.
2. In the Object Inspector, change the Name property to
ScheduleNotification.
3. Create the OnClick event of the ScheduleNotification button by doubleclicking the button.
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4. Implement the event handler for the OnClick event of the
ScheduleNotification button by adding the following code:


For Delphi:

procedure TForm1.ScheduleNotificationClick(Sender: TObject);
var
MyNotification: TNotification;
begin
MyNotification := NotificationCenter1.CreateNotification;
try
MyNotification.Name := 'MyNotification';
MyNotification.AlertBody := 'Delphi for your mobile device is here!';
// Fired in 10 seconds
MyNotification.FireDate := Now + EncodeTime(0, 0, 10, 0);
// Send notification to the notification center
NotificationCenter1.ScheduleNotification(MyNotification);
finally
MyNotification.DisposeOf;
end;
end;



For C++:

void __fastcall TForm1::ScheduleNotificationClick(TObject *Sender)
{
if (NotificationCenter1->Supported()) {
TNotification *myNotification = NotificationCenter1>CreateNotification();
__try {
myNotification->Name = "MyNotification";
myNotification->AlertBody = "C++ for your mobile
device is here!";
// Fire in 10 seconds
myNotification->FireDate = Now() + EncodeTime(0,
0, 10, 0);
// Send notification to the notification center
NotificationCenter1>ScheduleNotification(myNotification);
}
__finally {
myNotification->DisposeOf();
}
}
}
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After running your application (press F9) and clicking the ScheduleNotification
button, you can see the Notification Message (AlertBody) at the top of your
device Home Screen. For iOS devices, this message is similar to the following
screen:

Repeat a Notification Message
You can also repeat a Notification Message using the RepeatInterval property of
the TNotification object.
To repeat a Notification Message, you need to create an instance of the
TNotification class, and then define the Name, AlertBody, and FireDate fields.
Also you need to use the ScheduleNotification method and set the
RepeatInterval property. In the following code, the repeated interval is set to a
minute.
1. Drop a new TButton to the form.
2. In the Object Inspector, change the Name property to
RepeatedNotification.
3. Create the OnClick event of the RepeatedNotification button by doubleclicking the button.
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4. Implement the event handler for the OnClick event of the
RepeatedNotification button by adding the following code:


For Delphi:

procedure TForm1.RepeatedNotificationClick(Sender: TObject);
var
MyNotification: TNotification;
begin
MyNotification := NotificationCenter1.CreateNotification;
try
MyNotification.Title := 'MyNotification';
MyNotification.AlertBody := 'Repeating notification each minute!';
//Fired in 10 seconds
MyNotification.FireDate := Now + EncodeTime(0, 0, 10, 0);
//Repeated each minute
MyNotification.RepeatInterval := TRepeatInterval.Minute;
// Send notification to the notification center
NotificationCenter1.ScheduleNotification(MyNotification);
finally
MyNotification.Free;
end;
end;



For C++:

void __fastcall TForm1::RepeatedNotificationClick(TObject *Sender) {
if (NotificationCenter1->Supported()) {
TNotification *myNotification =
NotificationCenter1->CreateNotification();
__try {
myNotification->Name = "MyNotification";
myNotification->AlertBody = "Repeating
notification each minute!";
// Fire in 10 seconds
myNotification->FireDate = Now() + EncodeTime(0,
0, 10, 0);
// Repeated each minute
myNotification->RepeatInterval =
TRepeatInterval::Minute;
// Send notification to the notification center
NotificationCenter1>ScheduleNotification(myNotification);
}
__finally {
myNotification->Free();
}
}
}
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After running your application (press F9) and clicking the RepeatedNotification
button, you can see the Notification Message (AlertBody) at the top of your
device Home Screen. For iOS devices, this message is similar to the following
screen:

Update or Cancel a Scheduled or Repeated
Notification Message
Each Scheduled Notification Message is identified through the Name property of
the TNotification object.
Note: For the iOS platform, CancelNotification and
ScheduleNotification can cancel or update only those notifications
that have not been presented yet. If a notification has already
appeared in the Device Notification List, you can neither update
nor cancel the notification on iOS.
To update a scheduled notification, simply call the ScheduleNotification method
again with an instance of TNotificationCenter that has the same name (Name
property).
To cancel a scheduled notification, you can simply call the CancelNotification
method with the identifier you used.
1. Drop a new TButton to the form.
2. In the Object Inspector, change the Name property to
CancelNotification.
3. Create the OnClick event of the CancelNotification button by doubleclicking the button.
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4. Implement the event handler for the OnClick event of the
CancelNotification button by adding the following code:


For Delphi:

procedure TForm1.CancelNotificationClick(Sender: TObject);
begin
NotificationCenter1.CancelNotification('MyNotification');
end;



For C++:

void __fastcall TForm1::CancelNotificationClick(TObject *Sender)
{
NotificationCenter1->CancelNotification("MyNotification");
}

Present the Notification Message Immediately
You can also show the notification message immediately through the
PresentNotification function.
To show a notification message, you need to create an instance of the
TNotification class, and then define the Name and AlertBody fields.
1. Drop a new TButton to the form.
2. In the Object Inspector, change the Name property to
PresentNotification.
3. Create the OnClick event of the PresentNotification button by doubleclicking the button.
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4. Implement the event handler for the OnClick event of the
PresentNotification button by adding the following code:


For Delphi:

procedure TForm1.PresentNotificationClick(Sender: TObject);
var
MyNotification: TNotification;
begin
MyNotification := NotificationCenter1.CreateNotification;
try
MyNotification.Name := 'MyNotification';
MyNotification.AlertBody := 'Delphi for your mobile device is here!';
// Set Icon Badge Number (for iOS) or message number (for Android) as
well
MyNotification.Number := 18;
MyNotification.EnableSound := False;
// Send message to the notification center
NotificationCenter1.PresentNotification(MyNotification);
finally
MyNotification.DisposeOf;
end;
end;



For C++:

void __fastcall TForm1::PresentNotificationClick(TObject *Sender)
{
if (NotificationCenter1->Supported()) {
TNotification *myNotification = NotificationCenter1>CreateNotification();
__try {
myNotification->Name = "MyNotification";
myNotification->AlertBody = "C++ for your mobile
device is here!";
// Set Icon Badge Number (for iOS) or message number
(for Android) as well
myNotification->Number = 18;
myNotification->EnableSound = False;
// Send notification to the notification center
NotificationCenter1>PresentNotification(myNotification);
}
__finally {
myNotification->DisposeOf();
}
}
}
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Customizing the Notification Sound
You can use a customized sound for the notification message immediately
through the SoundName property of the TNotification object.
You need to create an instance of the TNotification class, define the
EnableSound and the SoundName properties. You also need to indicate the full
path to the file sound and the file extension.
1. Drop a new TButton to the form.
2. In the Object Inspector, change the Name property to SoundNotification.
3. Create the OnClick event of the SoundNotification button by doubleclicking the button.
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4. Implement the event handler for the OnClick event of the
SoundNotification button by adding the following code:


For Delphi:

procedure TForm1.SoundNotificationClick(Sender: TObject);
var
MyNotification: TNotification;
begin
MyNotification := NotificationCenter1.CreateNotification;
try
MyNotification.Name := 'MyNotification';
MyNotification.AlertBody := 'Delphi for your mobile device is here!';
MyNotification.EnableSound := True;
MyNotification.SoundName := GetSoundName;
MyNotification.FireDate := Now + EncodeTime(0, 0, 10, 0);
// Send message to the notification center
NotificationCenter1.ScheduleNotification(MyNotification);
finally
MyNotification.Free;
end;
end;



For C++:


In the .cpp file, add the following code:

void __fastcall TForm1::SoundNotificationClick(TObject *Sender)
{
TNotification *myNotification = NotificationCenter1>CreateNotification();
__try {
myNotification->Name = "MyNotification";
myNotification->AlertBody = "C++ for your mobile device is
here!";
myNotification->EnableSound = true;
myNotification->SoundName = GetSoundName();
myNotification->FireDate = Now() + EncodeTime(0, 0, 10, 0);
// Send notification to the notification center
NotificationCenter1->ScheduleNotification(myNotification);
}
__finally {
myNotification->Free();
}
}
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5. Declare the GetSoundName function.


For Delphi:


Set the GetSoundName declaration in the private section of
the unit.



Add the System.IOUtils to the project uses clauses.

uses
System.IOUtils;
private
function GetSoundName: string;



For C++:


In the header file (.h file), add the following declaration:



Set the GetSoundName declaration in the private section of
the unit.



Include the System.IOUtils.hpp to the project uses clauses.

#include <System.IOUtils.hpp>
private:
// User declarations
__fastcall UnicodeString GetSoundName ();
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6. Implement the GetSoundName function.
Note: Depending on the target operating system, the sound data should be a
different file extension.


For Delphi:

{$R *.fmx}
function TForm1.GetSoundName: string;
begin
{$IFDEF IOS}
Result := 'myiOSSound.caf';
{$ENDIF}
{$IFDEF ANDROID}
Result := TPath.Combine(TPath.GetSharedDocumentsPath,
'myAndroidSound.mp3');
{$ENDIF}
end;



For C++:


In the .cpp file, add the following code:

UnicodeString __fastcall TForm1::GetSoundName ()
{
UnicodeString result;
#if defined(_PLAT_IOS)
result = "myiOSSound.caf";
#endif
#if defined(__ANDROID__)
result =
System::Ioutils::TPath::Combine(System::Ioutils::TPath::GetSharedDocument
sPath(), "myAndroidSound.mp3");
#endif
return result;
//
}

7. Add the sound files to your project:


Find the myAndroidSound.mp3 and myiOSSound.caf files in the
Windows Explorer, and drag them to the Project Manager. Drop
them on the name of your project.

Note: The sound files myAndroidSound.mp3 and myiOSSound.caf are not
included in the RAD Studio installation. You can use any MP3 and CAF files that
you have, but remember to change the name in the code snippet above to the
name of your files. See this link for more information on how to convert MP3 files
to CAF format: How to convert MP3 to CAF


In the Confirm dialog, click Yes to add the sound files to your
project.
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8. Open the Deployment Manager to ensure that the sound files are
deployed with your application. You can see the corresponding entries in
the remote path column:


For iOS: StartUp\Documents (see deploying files in iOS applications).



For Android: assets\internal (see deploying files in Android
applications).

9. Change the remote path of the added files in the Deployment Manager:


For iOS: .\



For Android: assets\

Notification Banner or Notification Alert
By default, your application shows the notification banner:
o

Notification Banner on iPad

o

Notification Banner on Android devices

Android
o

Notification Alert (only for iOS devices)
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To use a notification alert instead of a notification banner (only for iOS devices),
the end user needs to change the Alert style to Alerts through the configuration
page of Notification Center, available in the device Settings:

Add Action to the Notification Alert (iOS Only)
You can also customize an alert by adding an Action button that opens the
application.
To customize an Alert Action, you need to set the AlertAction field to the Action
button name, and then set the HasAction field to True, as follows.
1. Drop a new TButton to the form.
2. In the Object Inspector, change the Name property to ActionNotification.
3. Create the OnClick event of the ActionNotification button by doubleclicking the button.
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4. Implement the event handler for the OnClick event of the
ActionNotification button by adding the following code:


For Delphi:

procedure TForm1.ActionNotificationClick(Sender: TObject);
var
MyNotification: TNotification;
begin
MyNotification := NotificationCenter1.CreateNotification;
try
MyNotification.Name := 'MyNotification';
MyNotification.AlertBody := 'Delphi for iOS is here! ';
MyNotification.Number := 2;
MyNotification.AlertAction := 'Launch';
MyNotification.HasAction := True;
MyNotification.FireDate := Now + EncodeTime(0, 0, 20, 0);
NotificationCenter1.ScheduleNotification(MyNotification);
finally
MyNotification.DisposeOf;
end;
end;



For C++:

void __fastcall TForm1::ActionNotificationClick(TObject *Sender)
{
if (NotificationCenter1->Supported()) {
TNotification *myNotification = NotificationCenter1>CreateNotification();
__try {
myNotification->Name = "MyNotification";
myNotification->AlertBody = "C++ for iOS is here!";
myNotification->Number = 2;
myNotification->AlertAction = "Launch";
myNotification->HasAction = True;
myNotification->FireDate = Now() +
EncodeTime(0,0,20,0);
NotificationCenter1>ScheduleNotification(myNotification);
}
__finally {
myNotification->DisposeOf();
}
}
}

Note: Only iOS devices support the notification alert feature.
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The notification alert opens at the time that was specified through the FireDate
field.

Add Action to Notifications
The TNotificationCenter class provides the onReceiveLocalNotification event
handler that allows you to write a response when the user clicks the notification
message in the notification center. To write the response, double-click the
TNotificationCenter component on the Form Designer, and then implement the
OnReceiveLocalNotification event handler.
The following code snippet implements a response to show a message box that
says "The <Notification name>" notification clicked."
o

For Delphi:

procedure TForm1.NotificationCenter1ReceiveLocalNotification(Sender: TObject;
ANotification: TNotification);
begin
ShowMessage('The ' + ANotification.Name + ' notification clicked.' );
end;

o

For C++:

void __fastcall TForm1::NotificationCenter1ReceiveLocalNotification(TObject
*Sender, TNotification *ANotification)
{
ShowMessage("The " + ANotification->Name + " notification
clicked.");
}
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Running the Application
To run the application, either choose Run > Run or press F9. Click the different
buttons to schedule or present notifications in your device.

See Also
o

Mobile Tutorial: Taking and Sharing a Picture, and Sharing Text (iOS and
Android)

o

Mobile Tutorial: Using Location Sensors (iOS and Android)

o

Mobile Tutorial: Using Remote Notifications (iOS and Android)

o

FMX.Notification.IFMXNotificationCenter

o

Mobile Code Snippets: Notifications


SendCancelNotifications



SetResetBadgeNumber (iOS only)

o

Creating events Index

o

Using the Mac OS X Notification Center

o

How to convert MP3 to CAF
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Mobile Tutorial: Using Remote
Notifications (iOS and Android)
This tutorial gives the basic steps to configure and to use Remote Notifications
(push notifications) on your iOS or Android mobile device.
Note: Kindle Fire devices do not support push notifications.

Remote Push Notification
Remote Notifications are notifications sent to a mobile device using a datachannel from a service provider in real-time.
Both iOS and Android offer built-in support for remote notifications, and RAD
Studio offers a REST BaaS framework that supports the following protocols, cloud
providers and backend service:
o

o

o

Protocols:


iOS: Apple Push Notification APN



Android: Google Cloud Messaging GCM

Cloud service providers:


Parse



Kinvey

Backend service:


EMS

In order to receive push notifications, you need to set up the messaging service
(APS or GCM), the device, the cloud service provider or EMS, and your RAD
Studio application, as described in the three pages of this mobile tutorial.
Notes:
o

The term Remote Notifications covers Apple Push Notification as well as
Google Cloud Messaging.

o

iOS and Android also have local notifications which are sent from an app
or from the OS to get the user’s attention. For more information, see
Mobile Tutorial: Using Notifications (iOS and Android).

o

The term Service Provider covers in this tutorial the Cloud service providers
(Kinvey and Parse) and the backend service provider EMS.
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REST BAAS framework
Our REST BAAS framework offers you a variety of actions:
o

Create, retrieve, update and delete objects

o

Sign up, login, retrieve, update and delete users

o

Upload, download and delete files or streams

o

Query objects and users

o

Send push notifications

o

Register for and receive push notifications on a device

Topics in this Mobile Tutorial
We recommend that you perform these sequentially as steps in a procedure.
1. Setting Up the Messaging Service
2. Setting up the Service Provider. Choose one of the following options,
depending on the service provider:


Using the Cloud Service to Send Push Notifications



Using EMS to Send Push Notifications

3. Multi-Device Application to Receive Push Notifications

See Also
o

BaaS Overview

o

Getting Started with Kinvey and Parse

o

EMS Push Notifications

o

Enterprise Mobility Services

o

Managing BaaS Users

o

Using BaaS for Backend Storage

o

Mobile Tutorial: Using Notifications (iOS and Android)

o

Mobile Tutorial: Using BaaS for Backend Storage (iOS and Android)

Code Samples
o

BaaS ToDo Sample
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Multi-Device Application to Receive
Push Notifications
You create a basic application to receive push notification with elements that
are generic to Android and iOS, and you add the code that makes the
characteristics for the specific platforms.
Note: Because our implementation is based on the REST BAAS framework, RAD
Studio allows you to use in your iOS or Android apps one of the following service
providers:
o

Kinvey

o

Parse

o

EMS

Before you create your application to receive push notifications, ensure to
complete these two required steps:
o

Setting Up the Messaging Service

o

Choose the provider:


Using the Cloud Service to Send Push Notifications



Using EMS to Send Push Notifications

Design and Set Up the User Interface
1. To create an Multi-Device Application, select either of the following:
File > New > Multi-device Application - Delphi > Blank Application
File > New > Multi-device Application - C++Builder > Blank Application
2. Drop a TCheckBox component on the form.
In the Object Inspector, set the following properties of the CheckBox:
1. Set the Align to Top.
2. Set the IsChecked property to False.
3. Set the Text to Active.
3. Add a TMemo component to the form and set the Align property to
Client.
4. Drop a TPushEvents object.
5. Set the AutoActivate to False.
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6. In LiveBindings Designer add a link from Active in PushEvents to IsChecked
in CheckBox. The Active property of PushEvents is set to True when the
CheckBox component is checked.
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7. Depending on the service provider you want to use, add:


For Parse: a TParseProvider.



For Kinvey: a TKinveyProvider.



For EMS: a TEMSProvider.

1. Using TKinveyProvider (iOS or Android)

In the Object Inspector, set the following properties of the
KinveyProvider:


Expand the Android Push node and copy to GCMAppID the
Project Number from Registering with Google.



Set the AppKey, AppSecret and MasterSecret to API Keys
values from setting up your project in Kinvey.



Set UserName and Password to the values defined at
Adding an User in Kinvey.
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2. Using TParseProvider (iOS or Android)

In the Object Inspector, set the following properties of the
ParseProvider:


Set the ApplicationID, MasterKey and RestApiKey to API Keys
from Creating a Project at Parse.

Note: You do not need to add the GCM AppID when developing Android apps
and using Parse.
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3. Using TEMSProvider (iOS or Android)

In the Object Inspector, set the following properties of the
EMSProvider:


Expand the Android Push node and copy to GCMAppID the
Project Number from Registering with Google.



Set the ApplicationId, AppSecret and MasterSecret to API
Keys values from setting up your EMS Server.
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Creating the Event Handlers
1. On the form, select PushEvent1 and go to the Object Inspector:


Check whether the Provider property is set to KinveyProvider1, to
ParseProvider1 or to EMSProvider1 , depending on which provider
you used.



Go to Events tab and create an event handler for each event by
double-clicking the Value field.

2. Switch to Code tab by pressing F12.
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3. Define the event handlers as follows:
Delphi:
implementation
{$R *.fmx}
procedure TForm1.PushEvents1DeviceRegistered(Sender: TObject);
begin
Memo1.Lines.Add('Device Registered');
Memo1.Lines.Add('');
end;
procedure TForm1.PushEvents1DeviceTokenReceived(Sender: TObject);
begin
Memo1.Lines.Add('Device Token Received');
Memo1.Lines.Add('');
end;
procedure TForm1.PushEvents1DeviceTokenRequestFailed(Sender: TObject;
const AErrorMessage: string);
begin
Memo1.Lines.Add('Device Token Request Failed');
Memo1.Lines.Add(AErrorMessage);
Memo1.Lines.Add('');
end;
procedure TForm1.PushEvents1PushReceived(Sender: TObject;
const AData: TPushData);
begin
Memo1.Lines.Add('Device push received');
Memo1.Lines.Add(AData.Message);
Memo1.Lines.Add('');
end;
end.
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C++:
//------------------------------------------------------------------------void __fastcall TForm1::PushEvents1DeviceRegistered(TObject *Sender)
{
Memo1->Lines->Add("Device Registered");
Memo1->Lines->Add("");
}
//------------------------------------------------------------------------void __fastcall TForm1::PushEvents1DeviceTokenReceived(TObject *Sender)
{
Memo1->Lines->Add("Device Token Received");
Memo1->Lines->Add("");
}
//------------------------------------------------------------------------void __fastcall TForm1::PushEvents1DeviceTokenRequestFailed(TObject
*Sender, const UnicodeString AErrorMessage)
{
Memo1->Lines->Add("Device Token Request Failed");
Memo1->Lines->Add(AErrorMessage);
Memo1->Lines->Add("");
}
//------------------------------------------------------------------------void __fastcall TForm1::PushEvents1PushReceived(TObject *Sender,
TPushData * const AData)
{
Memo1->Lines->Add("Push Received");
Memo1->Lines->Add(AData->Message);
Memo1->Lines->Add("");
}
//-------------------------------------------------------------------------
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Android Settings
Note: To verify whether your Android device supports GCM, see GCM Overview

Project Settings
To enable your application to receive remote notifications:
1. Right-click your project in the Project Manager.
2. Choose Project > Options > Entitlement List.
3. Set Receive Push Notification value to True.

Note: If you want to enable receiving a notification even if the application is not
running while the remote notification comes in, you will need to register a Service
Class. This Java service class will create an entry in the Notification Center of the
Android Device. If you do not need or want items in the Notification Center, you
can skip this step.
You need to include an additional entry in the AndroidManifest.xml for the
project, by customizing your AndroidManifest.template.xml. In the
AndroidManifest.template.xml file of your project search for the following tag:
<%receivers%>

Add the following code below it:
<service android:name="com.embarcadero.gcm.notifications.GCMIntentService" />
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iOS Settings
Project Settings
1. Right-click your project in the Project Manager.
2. Choose Project > Options > Version Info, and set the CFBundleIdentifier
key. This should be the same as the identifier of your App ID. It is the
Bundle ID from Creating iOS App ID on Apple Developer Program section.

Running Your Application on a Mobile Device
Now your application is ready to run on either a simulator or your connected
mobile device.
To run your application
1. In Project Manager, select your target platform.
2. Choose either of the following commands:


Run > Run



Run > Run Without Debugging

3. Click the Active checkbox.
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4. Go to Parse, Kinvey or Sending EMS Push Messages and send a new push:
Note: You can use your own EMS application to send EMS Push Notifications
messages.
Parse

Kinvey
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EMS

5. Switch to your mobile device:
iOS

Android
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iOS EMS

6. Send your app to background and send another push from Parse or
Kinvey. Now go to Notifications:
iOS

Android

Embarcadero Technologies

242

Multi-Device Application to Receive Push Notifications

See Also
o

Mobile Tutorial: Using Notifications (iOS and Android)

o

Mobile Tutorial: Using BaaS for Backend Storage (iOS and Android)

o

Enterprise Mobility Services

o

EMS Push Notifications

o

Entitlement List

Code Samples
o

BaaS ToDo Sample
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Mobile Tutorial: Using the Phone
Dialer on Mobile Devices (iOS and
Android)
This tutorial describes the basic steps for using the phone dialer services on your
mobile device.

About the Phone Dialer Services on Mobile Devices
On mobile platforms, FireMonkey provides the IFMXPhoneDialerService interface
that defines the structure of the phone dialer service classes, such as
TPhoneDialerService.
The phone dialer services allow you to perform the following operations:
o

Get the carrier-related information

o

Make a call

o

Detect the call state changes.

Accessing the Phone Dialer Services
To create an application that uses the phone dialer services, perform the
following basic steps:
1. Select:


For Delphi: File > New > Multi-Device Application - Delphi



For C++: File > New > Multi-Device Application - C++Builder

2. Open the Code Editor and do the following:
o

Add the following lines to your code if they are not present:

Delphi:
uses
FMX.Platform, FMX.PhoneDialer;

C++:
#include <FMX.Platform.hpp>
#include <FMX.PhoneDialer.hpp>
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o

Only for Delphi apps: Add the following line to the public section of the
form definition:

constructor Create(AOwner: TComponent); override;

o

Add the following properties to the private section of the form definition:

Delphi:
private: // User declarations
PhoneDialerService: IFMXPhoneDialerService;

C++:
private: //User declarations
_di_IFMXPhoneDialerService phoneDialerService;
bool serviceSupported;

o

Only for Delphi apps: in the implementation section, override the form
constructor as follows:

constructor TForm1.Create(AOwner: TComponent);
begin
inherited Create(AOwner);
TPlatformServices.Current.SupportsPlatformService(IFMXPhoneDialerService,
IInterface(PhoneDialerService));
end;

o

Only for C++Builder apps: in the Structure View, click the form, and in the
Object Inspector, open the Events tab, and then double-click onCreate.
Implement the following onCreate event handler for the application form:

void __fastcall TForm1::FormCreate(TObject *Sender)
{
serviceSupported = (TPlatformServices::Current>SupportsPlatformService(__uuidof(IFMXPhoneDialerService)) &&
(phoneDialerService = TPlatformServices::Current>GetPlatformService(__uuidof(IFMXPhoneDialerService))));
}

Now your application can access the phone dialer services.
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Designing the User Interface
This tutorial uses the TLabel, TButton, and TEdit components as the user interface
elements.
To set up the UI elements, perform the following steps:
1. Drop two TLabel components on the Form Designer, and then set their
Name properties to lblCarrierName and lblISOCountryCode, respectively.
2. Set the Text property for the labels to Carrier Name and ISO Country
Code, respectively.
3. Drop a TButton component on the Form Designer, and in the Object
Inspector, set the following properties of this button:


Name to btnGetCarrierInfo



Text to Get Carrier Info

Getting the Carrier Properties
To get information on the carrier, make the following changes:
1. On the Form Designer, select the Get Carrier Info button.
2. In the Object Inspector, double-click the onClick event, and implement
the onClick event handler as follows:
Delphi:
procedure TForm1.btnGetCarrierInfoClick(Sender: TObject);
begin
{ test whether the PhoneDialer services are supported on your device }
if Assigned(PhoneDialerService) then
begin
{ if yes, then update the labels with the retrieved information }
lblCarrierName.Text := 'Carrier Name: ' +
PhoneDialerService.GetCarrier.GetCarrierName;
lblISOCountryCode.Text := 'ISO Country Code: ' +
PhoneDialerService.GetCarrier.GetIsoCountryCode;
end;
end;
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C++:
void __fastcall TForm1::btnGetCarrierInfoClick(TObject *Sender)
{
if (serviceSupported) {
lblCarrierName->Text = "Carrier Name: " + phoneDialerService>GetCarrier()->GetCarrierName();
lblISOCountryCode->Text = "ISO Country Code: " +
phoneDialerService->GetCarrier()->GetIsoCountryCode();
}
else ShowMessage("This device does not support the Phone Dialer
services.");
}

Running the Application
Important: Before running your Delphi application on an Android
device, verify that the following permissions are set in Project >
Options > Uses Permissions for the All configurations - Android
platform target:
o

Call phone

o

Read phone state

For more information, see Uses Permissions.
To run the application, choose Run > Run or press F9.
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After you click the Get Carrier Info button, the application displays the basic
information about the carrier, similar to the following screens:
iOS

Android

Making a Call
FireMonkey provides the IFMXPhoneDialerService.Call method that makes a
phone call to a specified phone number.
For your application to make calls, add the following elements to the Form
Designer:
1. Add a TLabel component, and then set its Text property to Telephone
Number.
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2. Add a TEdit component, and in the Object Inspector, set the following
properties:


Name to edtTelephoneNumber.



KillFocusByReturn to True.



KeyboardType to PhonePad.



ReturnKeyType to Go.

3. Add a TButton component, and in the Object Inspector, do the following:
o

Set the Name property to btnMakeCall.

o

Set the Text property to Make Call.

o

On the Events tab, double-click onClick, and then implement the onClick
event handler as follows:

Delphi:
procedure TForm1.btnMakeCallClick(Sender: TObject);
begin
{ test whether the PhoneDialer services are supported on your device }
if Assigned(PhoneDialerService) then
begin
{ if the Telephone Number is entered in the edit box then make the call,
else
display an error message }
if edtTelephoneNumber.Text <> '' then
PhoneDialerService.Call(edtTelephoneNumber.Text)
else
begin
ShowMessage('Please type-in a telephone number.');
edtTelephoneNumber.SetFocus;
end;
end;
end;

C++:
void __fastcall TForm1::btnMakeCallClick(TObject *Sender)
{
if (serviceSupported) {
if (edtTelephoneNumber->Text != "" )
{
phoneDialerService->Call(edtTelephoneNumber->Text);
}
else {
ShowMessage("Please type-in a telephone number.");
edtTelephoneNumber->SetFocus();
}
}
else ShowMessage("This device does not support the Phone Dialer
services.");
}
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To make a call:
1. Run the application.
2. In the TEdit field under Telephone Number, type the phone number.
3. Click the Make Call button.
iOS

Android

Detecting the Call State Changes
The IFMXPhoneDialerService interface provides the OnCallStateChanged event
that allows you to handle the call state changes. The TCallState enumeration
describes possible phone call states.
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The following table describes the items in the TCallState enumeration (the
supported states for each platform are marked with "+").
Item

Description

iOS Android

None

No call state.

+

-

Connected

The phone caller is connected to the called party. +

+

Incoming

An incoming phone call.

+

+

Dialing

The phone is in a dialing state.

+

-

+

+

Disconnected Call is disconnected.

Implementing the OnCallStateChanged Event Handler
To implement the OnCallStateChanged event handler, perform the following
steps:
1. Add the following procedure header to the private section of the form
definition:
Delphi:
procedure MyOnCallStateChanged(const ACallID: String; const ACallState:
TCallState);

C++:
void __fastcall MyOnCallStateChanged(const UnicodeString aCallID, const
TCallState aCallState);
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2. Rewrite the form constructor (Delphi applications) or the onFormCreate
event handler (C++ applications) that you have defined in the
#Accessing the Phone Dialer Services section as follows:
Delphi:
constructor TForm1.Create(AOwner: TComponent);
begin
inherited Create(AOwner);
TPlatformServices.Current.SupportsPlatformService(IFMXPhoneDialerService,
IInterface(PhoneDialerService));
if Assigned(PhoneDialerService) then
PhoneDialerService.OnCallStateChanged := MyOnCallStateChanged;
end;

C++:
void __fastcall TForm1::FormCreate(TObject *Sender)
{
serviceSupported = (TPlatformServices::Current>SupportsPlatformService(__uuidof(IFMXPhoneDialerService)) &&
(phoneDialerService = TPlatformServices::Current>GetPlatformService(__uuidof(IFMXPhoneDialerService))));
if (serviceSupported) {
phoneDialerService->OnCallStateChanged = MyOnCallStateChanged;
}
}

3. Add a TLabel component to the Form Designer, and in the Object
Inspector, set its Name property to lblCallState.
4. In the Code Editor, add the following event handler code:
Delphi:
procedure TForm1.MyOnCallStateChanged(const ACallID: String; const
ACallState: TCallState);
var outText: String;
Begin
case ACallState of
TCallState.None:
outText := 'No calls';
TCallState.Connected:
outText := 'Connected';
TCallState.Incoming:
outText := 'Incoming call';
TCallState.Dialing:
outText := 'Dialing';
TCallState.Disconnected: outText := 'Disconnected';
end;
lblCallState.Text := outText;
End;
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C++:
void __fastcall TForm1::MyOnCallStateChanged(const UnicodeString aCallID,
const TCallState aCallState) {
switch (aCallState) {
case TCallState::None:
lblCallState->Text = "No calls";
break;
case TCallState::Connected:
lblCallState->Text = "Connected";
break;
case TCallState::Incoming:
lblCallState->Text = "Incoming call";
break;
case TCallState::Dialing:
lblCallState->Text = "Dialing";
break;
case TCallState::Disconnected:
lblCallState->Text = "Disconnected";
break;
}
}

After you implement this event handler, the application shows the phone call
state.
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For example, the following iOS screen indicates that the phone is in a dialing
state:

Note: In this sample project, the TLabel component is next to the
TEdit box and the Make Call button, under Telephone Number.
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See Also
o

Mobile Tutorial: Taking and Sharing a Picture, and Sharing Text (iOS and
Android)

o

Mobile Tutorial: Using Location Sensors (iOS and Android)

o

FMX.PhoneDialer.IFMXPhoneDialerService

o

Android Mobile Application Development

o

iOS Mobile Application Development

o

Mobile Code Snippets: Phone Dialer
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Mobile Tutorial: Using BaaS for
Backend Storage (iOS and Android)
This tutorial gives the basic steps to use backend storage using Kinvey and Parse
as BaaS providers.
This tutorial creates a Shopping List where the items added are stored in the
cloud by the BaaS provider, so these items can be shared and updated among
different devices if needed.
iOS

iPod

Android

Nexus 7

With backend storage you can store files and data in the cloud. This information
can later be retrieved, updated, and deleted.
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In this tutorial you are going to:
o

Create new items and store them in the cloud.

o

Retrieve items from the cloud.

o

Delete items from the cloud.

Getting Your App Ready in Kinvey and Parse
Before you start doing this tutorial, ensure you already have an account with
Kinvey or Parse and that you already have an app created in the backend
provider.
o

Getting Started with Kinvey and Parse


Creating an Account with Kinvey



Creating an Account with Parse



Creating an App with Kinvey



Creating an App with Parse

Design and Set Up of the User Interface
This tutorial uses a TListView as UI component to display the information retrieved
from the cloud.
To set up the UI for this sample tutorial follow these steps:
1. Create a blank Multi-Device Application, by selecting:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++: File > New > Multi-Device Application - C++Builder > Blank
Application

2. Drop a TLabel on the form and set the following properties in the Object
Inspector:


Set the Text property to Shopping List.



Set the Align property to Top.



Set the HorzAlign property in TextSettings to Center.
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3. Drop a TButton on the TLabel and set the following properties in the
Object Inspector:


Set the Align property to Right.



Set the StyleLookup property to refreshtoolbutton.



Set the Name property to RefreshButton.

4. Drop a TEdit on the form and set the following properties in the Object
Inspector:


Set the Align property to Top.

5. Drop a TButton on the TEdit and set the following properties in the Object
Inspector:


Set the Align property to Right.



Set the Text property to Add Item.



Set the Name property to AddItemButton.

6. Drop a TListView on the form and set the following properties in the Object
Inspector:


Set the Align property to Client.

Adding the Backend Components
This tutorial uses the TBackendStorage service component to manage the
backend storage in order to create, retrieve, update, and delete objects. This
app also uses one of the BaaS provider components:
o

TKinveyProvider is the Kinvey BaaS provider component that contains the
information about the Kinvey could service connection.

o

TParseProvider is the Parse BaaS provider component that contains the
information about the Parse could service connection.

Continue with the following steps:
1. Drop one of the two BaaS provider components on the form
TKinveyProvider or TParseProvider depending on the backend provider
you use in your app.
2. Drop a TBackendStorage on the form, and in the Object Inspector set the
Provider property to the BaaS provider component you are using.
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3. Depending on the BaaS provider you are using:


Select the KinveyProvider1 component and in the Object Inspector
set the AppKey, AppSecret and MasterSecret to the values
provided by Kinvey.



Select the ParseProvider1 component and in the Object Inspector
set the ApplicationID, MasterKey and RestApiKey to the values
provided by Parse.
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Creating and Storing Objects
In the app, when you type something in the TEdit and click Add Item, the
content typed in the TEdit gets stored in the cloud, in the Kinvey or Parse BaaS
provider. To create the object, use the CreateObject method.
1. Double-click the AddItemButton and type the following code:
Delphi:
procedure TForm1.AddItemButtonClick(Sender: TObject);
var
LJSONObject: TJSONObject;
LEntity: TBackendEntityValue;
begin
if Edit1.Text = '' then
ShowMessage('Please, enter an item.')
else
begin
LJSONObject := TJSONObject.Create;
LJSONObject.AddPair('item', Edit1.Text);
BackendStorage1.Storage.CreateObject('ShoppingList', LJSONObject,
LEntity);
ShowMessage('New item created: ' +Edit1.Text);
LJSONObject.Free;
Edit1.Text := '';
end
end;

C++:
void __fastcall TForm1::AddItemButtonClick(TObject *Sender)
{
TJSONObject *LJSONObject;
TBackendEntityValue LEntity;
if (Edit1->Text == "") {
ShowMessage("Please, enter an item.");
}
else {
LJSONObject = new TJSONObject;
LJSONObject->AddPair("item", Edit1->Text);
BackendStorage1->Storage->CreateObject("ShoppingList",
LJSONObject, LEntity);
ShowMessage("New item created: "+ Edit1->Text);
LJSONObject->Free();
delete LJSONObject;
Edit1->Text="";
}
}
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Deleting Objects
To allow users to delete any item from the list. In the TListView component, if you
swipe your finger left or right over one of the items of the TListView, a Delete
button displays on the right-hand side. To delete the item when the Delete
button of such item is clicked, do the following:
1. Select the TListView and in the Events tab of the Object Inspector, doubleclick the OnDeletingItem event. This event occurs before the item is
deleted. Add the following code:
Delphi:
procedure TForm1.ListView1DeletingItem(Sender: TObject; AIndex: Integer; var
ACanDelete: Boolean);
var
LQuery: string;
LJSONArray : TJSONArray;
LEntities: TArray<TBackendEntityValue>;
begin
ACanDelete := False;
LJSONArray := TJSONArray.Create;
try
LQuery := Format('query={"item":"%s"}', [(Sender as
TListView).Items[AIndex].Text]); // 'query={"item":"%s"}' in Kinvey and
'where={"item":"%s"}' in Parse
BackendStorage1.Storage.QueryObjects('ShoppingList', [LQuery], LJSONArray,
LEntities);
if (Length(LEntities) > 0) and
BackendStorage1.Storage.DeleteObject('ShoppingList', LEntities[0].ObjectID)
then
ACanDelete := True
else
ShowMessage ('Item could not be deleted.');
finally
LJSONArray.Free;
end;
end;

Note: The line LQuery :=Format('query={"item":"%s"}',[(Sender as
TListView).Items[AIndex].Text]); is for Kinvey, in Parse the word query must change
to where so if you are using Parse as BaaS provider this line must be LQuery
:=Format('where={"item":"%s"}',[(Sender as TListView).Items[AIndex].Text]);.
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C++:
void __fastcall TForm1::ListView1DeletingItem(TObject *Sender, int AIndex, bool
&ACanDelete)
{
System::UnicodeString LQuery[1];
DynamicArray<TBackendEntityValue> LEntities;
ACanDelete = False;
TJSONArray *LJSONArray;
LJSONArray = new TJSONArray;
try {
TListView* list = reinterpret_cast<TListView*>(Sender);
LQuery[0] = ("query={\"item\":\""+(list->Items->Item[AIndex]>Text)+"\"}"); // "query={\"item\":\"" in Kinvey and "where={\"item\":\"" in
Parse
BackendStorage1->Storage->QueryObjects("ShoppingList", LQuery,
0, LJSONArray, LEntities);
if (((LEntities.Length)>0) & BackendStorage1->Storage>DeleteObject("ShoppingList", LEntities[0].ObjectID)) {
ACanDelete = True;
} else {
ShowMessage("Item could not be deleted.");
}
}
__finally {
LJSONArray->Free();
}
}

Note: The line LQuery[0]=("query={\"item\":\""+(list->Items->Item[AIndex]>Text)+"\"}"); is for Kinvey, in Parse the word query must change to where so if you
are using Parse as BaaS provider this line must
be LQuery[0]=("where={\"item\":\""+(list->Items->Item[AIndex]->Text)+"\"}");.
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Retrieving Objects
To update all content in the TListView to reflect any possible change, you can
retrieve the objects with QueryObjects, clear the list view and add all items you
have retrieved from the backend storage.
1. To add a new method to refresh the list:
Delphi:


Open the Class Explorer window by choosing View > Class Explorer.



In the Class Viewer pane, right-click TForm1 under Unit1 and select
Add Method.



Write RefreshList under “Method name”, select Procedure under
“Method type" and click OK.
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C++:


Open the Class Explorer window by choosing View > C++ Class
Explorer.



In the Type List pane (left pane), expand your project, right-click
TForm1 under and select Add Method.



Write RefreshList under “Name”, void under “Return type”, set
“Visibility” to public and click Add.
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2. Add the following code to the new method:
Delphi:
procedure TForm1.RefreshList;
var
LJSONArray : TJSONArray;
LItem: TListViewItem;
I: Integer;
begin
LJSONArray := TJSONArray.Create;
try
BackendStorage1.Storage.QueryObjects('ShoppingList', [], LJSONArray);
ListView1.ClearItems;
for I := 0 to LJSONArray.Count-1 do
begin
LItem := ListView1.Items.Add;
LItem.Text := (LJSonArray.Items[I].GetValue<string>('item'));
end;
finally
LJSONArray.Free;
end;
end;

C++:
void TForm1::RefreshList()
{
String LQuery [1];
TJSONArray *LJSONArray;
TListViewItem *LItem;
TJSONObject *LJSONObject;
String ItemText;
int i;
LJSONArray = new TJSONArray;
try {
BackendStorage1->Storage->QueryObjects("ShoppingList",
LQuery, 0, LJSONArray);
ListView1->ClearItems();
for (i = 0; i < LJSONArray->Count; i++) {
LItem = ListView1->Items->Add();
LJSONObject = dynamic_cast<TJSONObject
*>(LJSONArray->Items[i]);
ItemText = (LJSONObject->Values["item"]>Value());
LItem->Text = ItemText;
}
}
__finally {
LJSONArray->Free();
}
}
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3. Double-click the RefreshButton and the following code so this button calls
the RefreshList method:
Delphi:
procedure TForm1.RefreshButtonClick(Sender: TObject);
begin
RefreshList;
end;

C++:
void __fastcall TForm1::RefreshButtonClick(TObject *Sender)
{
RefreshList();
}

4. To refresh the list once an item is added, double-click the AddItemButton
to access the code of the OnClick event added before and add the
following code as the very last sentence of the else statement:
Delphi:
RefreshList;

C++:
RefreshList();
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5. To refresh the list after an item is deleted, select the TListView and in the
Events tab of the Object Inspector, double-click the OnDeleteItem event.
This event occurs after the item is deleted. Add the following code:
Delphi:
procedure TForm1.ListView1DeleteItem(Sender: TObject; AIndex: Integer);
begin
RefreshList;
end;

C++:
void __fastcall TForm1::ListView1DeleteItem(TObject *Sender, int AIndex)
{
RefreshList();
}

Running Your Application
To run your application follow these steps:
1. In the Project Manager, select the target platform where you want to run
your app.
Note: This app uses the swipe-to-delete feature that is supported on mobile apps
(iOS and Android), as well as desktop apps (Windows and Mac OS X) when
touch input is available.
2. Select Run > Run or Run > Run Without Debugging.
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3. Once you add or delete items in your application, you can go to your
Kinvey console or to your Parse dashboard to see the changes also from
the cloud.
iOS

iPod

Android

Nexus 7

See Also
o

BaaS Overview

o

Getting Started with Kinvey and Parse

o

Managing BaaS Users

o

Using BaaS for Backend Storage

o

Mobile Tutorial: Using Remote Notifications (iOS and Android)

Code Samples
o

BaaS ToDo Sample
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Mobile Tutorial: Using InterBase
ToGo with dbExpress (iOS and
Android)
Caution: dbExpress, which is described in this tutorial, is being deprecated. This
means that dbExpress will be removed from RAD Studio in an upcoming release.
Instead of dbExpress, we recommend that you use our newer database solution,
FireDAC, which is described in a similar tutorial, here:
Mobile Tutorial: Using InterBase ToGo with FireDAC (iOS and Android).
Before starting this tutorial, you should read and perform the following tutorial
session:
o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)
Tip: Following this tutorial requires a license for IBToGo or IBLite:
o

o

If you purchased one of the following RAD Studio versions,
you have received in Email a key for an unlimited
development and deployment license for IBLite:


RAD Studio XE8 Professional or higher



Delphi XE8 Professional or higher with Mobile

If you are a trial user, your installation includes a trial license
for IBToGo. You can test InterBase on iOS and Android by
selecting your test license during the deployment step, as
described in this tutorial. The trial licenses are installed with
your trial product, in
C:\Users\Public\Documents\Embarcadero\InterBase\redis
t\InterBaseXE3.

Note: On Android devices, InterBase ToGo apps require specific Uses Permissions
to be set, specifically:
o

Read external storage (the database is placed in the external memory)

o

Write external storage (the database is placed in the external memory)

o

Internet (you need to connect with a remote server)
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This tutorial describes the basic steps to browse data managed by InterBase
ToGo on your iOS and Android devices through the dbExpress framework.
iOS

Android

Note: You can use FireDAC, dbExpress, and Interbase Express (IBX) components
to build Interbase ToGo applications. For a detailed discussion on Interbase
Express components usage in a Delphi application, read the Getting Started with
InterBase Express article. For this tutorial, we will connect to Interbase ToGo using
dbExpress framework.

Using dbExpress to Connect to the Database
dbExpress is a very fast database access framework, written in Delphi. RAD
Studio provides drivers for most major databases, such as InterBase, Oracle, DB2,
SQL Server, MySQL, Firebird, SQLite and ODBC. You can access these different
databases using procedures similar to the procedure described here.
o

For the mobile platforms, dbExpress supports InterBase ToGo as well as
SQLite. These database products can run on iOS and Android devices.
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o

For other databases, such as Oracle, you need to have at least a client
library. On Windows platforms, the client library is provided as a DLL to
connect to. Therefore, you need to develop applications using middle-tier
technologies such as DataSnap to connect to these database products
from a mobile device.

Another tutorial discusses how to connect to Enterprise Database without using a
client library on a mobile device; see Mobile Tutorial: Connecting to an Enterprise
Database from a Mobile Client (iOS and Android).

Design and Set Up the User Interface
This tutorial uses TListView and TPanel components as the UI elements.
To set up a ListView and a Panel component, use the following steps:
1. To create an HD Multi-Device Application, select either of the following:


File > New > Multi-Device Application - Delphi > Blank Application



File > New > Multi-Device Application - C++Builder > Blank
Application

2. Drop a TListView component on the form.
3. In the Object Inspector, set the following properties of the ListView:


Set the Align property to Client, so that the ListView component
uses the entire form.



Set the ItemAppearance to ListItemRightDetail.



Set the SearchVisible to true.

4. Add a TPanel component to the form, and set the following properties in
the Object Inspector:


Set the Align property for the TPanel component to Top.

5. Add a TLabel component to the Panel, and set the following properties in
the Object Inspector:


Set the Align property for the TLabel component to Client.



Set the StyleLookup property to toollabel.



Set the HorzAlign property from TextSettings to Center.



Set the Text property to DB DEMO.
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Connecting to the Data
Following are the basic steps to connect to data in a database using dbExpress:
1. On the Tool Palette, double-click the TSQLConnection component.

2. In the Object Inspector, set the following properties for TSQLConnection:
1. This app uses InterBase ToGo, so set the Driver property to
IBLite/ToGo.

2. Set the LoginPrompt property to False, so that the user is not
prompted for a login.
3. Click the ellipsis [...] for the Params property, and set the Database
value to
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata\dbdemos.gdb (location of the database).
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4. Ensure the VendorLib value is set to ibtogo.dll (client software
library); then click ok to close the dialog box:

5. Set the Connected property to True.
Note: If you get an error ("unavailable database") on development environment,
this means you do not have a current license for InterBase. The license of
InterBase Developer Edition is included as part of the product for some product
editions. For more information, see Troubleshooting.
2. Add a TSQLDataSet component to the form, and set the following
properties:
1. Set the SQLConnection property to SQLConnection1 (the one that
you added in a previous step).
2. Set the CommandText property to select COMMON_NAME,
SPECIES_NAME from BIOLIFE order by COMMON_NAME.
3. Set the Active property to True.
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3. Open the LiveBindings Designer and connect the data and the user
interface as follows:
1. Click COMMON_NAME in SQLDataSet1, and drag the mouse cursor
to Item.Text in ListView1.

At this point, TBindSourceDB and TBindingsList components were added to the
form.
2. Click SPECIES_NAME in BindSourceDB1, and drag the mouse cursor
to Item.Detail in ListView1.
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Deploying Your Application to Mobile
Up to this point, you have used InterBase on your desktop. This means that the
actual database is located at your local hard disk drive (for example,
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\dbdem
os.gdb). On the mobile Device, the application is sand-boxed, and typically you
can only read and write data that is located in the Documents folder (for iOS
device) and internal storage (for Android device) under your application folder.
To connect to a local database on mobile, you need to perform the following
actions:
o

Deploy the database to the mobile Device.

o

Check the configuration (to connect to the database file) to a local file
under the Documents folder (for iOS device) or internal storage (for
Android device).

Deploy InterBase ToGo, dbExpress Driver, and the Database File to
Mobile
To execute your application on mobile, you need to deploy the following files:
o

Interbase ToGo

o

dbExpress Driver to InterBase (for iOS Simulator)

o

The database file (dbdemos.gdb)

1. You can add the database to your project with one of the following two
methods:


Right-click the project name in the Project Manager and select
Add… from the context menu (or Project > Add to Project) to
display the Add to Project dialog box. Navigate to the database
location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata, select the database dbdemos.gdb and click Open.



Navigate to the database location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata and drag and drop the database dbdemos.gdb to the project in

the Project Manager. Click Yes to confirm that you want to add the
file to your project.
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2. After adding the database file, the Featured Files window displays. Select
the following database modules, and then click OK to close the Featured
Files dialog box:


InterBase ToGo. You need to select the license to be used when
deploying the application on the device.


The Tip at the beginning of this tutorial describes how to
activate an InterBase license.



The suggested names for the license files available are listed
in the Featured Files dialog, under the following name
pattern: reg_*.txt.

As you can see in the image below, the reg_ibtogo.txt license file is selected for
this tutorial.


You might have received from Embarcadero a license file
for IBToGo or IBLite that has a pattern of reg_nnnnnnn.txt,
where nnnnnnn is a generated number:


If you have saved that file over reg_ibtogo.txt or
reg_iblite.txt in the location below (for example,
C:\Users\Public\Documents\Embarcadero\InterBase
\redist\InterBaseXE3), you can just select the

desired license.




If you have saved the file with its original name, then
select Add Files (shown in the next step) and include
the license file in the list of files that need to be
deployed with the application.

DBExpress InterBase Driver
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Tip: If you plan to test your application on the iOS Simulator, then you also have
to select the DBExpress InterBase Driver for iOS Simulator.
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3. Open the Deployment Manager by selecting Project > Deployment.
4. Select Debug configuration - iOS Device platform or Debug configuration Android platform from the drop-down list of target platforms at the top of
the Deployment Manager and see that the database dbdemos.gdb has
been added to the platforms.
5. See how the Remote Path of dbdemos.gdb has been set for iOS and
Android platforms:


Remote Path on iOS Device platform: StartUp\Documents\



Remote Path on Android platform: assets\internal\

As you just configured, when you run the app on the mobile device, the
database file (dbdemos.gdb) is to be deployed to the Documents folder (for iOS
platform) or internal storage (for Android platform) in the sandbox area of your
multi-device application.

Modify Your Code to Connect to a Local Database File on Mobile
As described in the previous step, the TSQLConnection component is connected
to a database on your local file system with an absolute path. So you need to
replace the location of the file before connecting to the database, as follows:
1. In the Form Designer, select the SQLConnection1 component.
2. In the Object Inspector, double-click the Value field of the BeforeConnect
event.
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3. Add the following code to this event handler:
Delphi:
procedure TForm1.SQLConnection1BeforeConnect(Sender: TObject);
begin
{$IF DEFINED(iOS) or DEFINED(ANDROID)}
SQLConnection1.Params.Values['Database'] :=
TPath.Combine(TPath.GetDocumentsPath, 'dbdemos.gdb');
{$ENDIF}
end;

C++:
void __fastcall TForm1::SQLConnection1BeforeConnect(TObject *Sender)
{
#if (defined(__arm__) && (defined(__APPLE__) || defined(__ANDROID__)) )
SQLConnection1->Params->Values["Database"] =
System::Ioutils::TPath::Combine(System::Ioutils::TPath::GetDocumentsPath(),
"dbdemos.gdb");
#endif
}

The TPath record is declared in System.IOUtils unit, so you need to add
System.IOUtils in the uses clause.
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Run Your Application on a Simulator or on a Mobile
Device
Now your application is ready to run. You should be able to browse data just as
you can in the IDE. You can narrow down the list using the Search Box.
iOS

Embarcadero Technologies

Android

280

Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and Android)

Troubleshooting
InterBase Issues
See the following section with detailed information about Interbase License
Issues.
Note: Follow the steps at IBLite and IBToGo Test Deployment Licensing to obtain a
valid license file.

Exception Handling Issues
If your application raises an exception without having proper exception handling
code, your multi-device application simply crashes (disappears) at run time.
If you encounter a crash, you might want to connect manually to the database
while you troubleshoot the issue using the following steps:
1. Select the SQLConnection1 component, and change the Connected
property to False.
2. Drop a button on the form, and create the following event handler to
manually connect to the database:
Delphi:
procedure TForm1.Button1Click(Sender: TObject);
begin
try
SQLConnection1.Connected := True;
SQLDataSet1.Active := True;
except
on e: Exception do
begin
ShowMessage(e.Message);
end;
end;
end;

C++:
void __fastcall TForm1::Button1Click(TObject *Sender) {
try {
SQLConnection1->Connected = True;
SQLDataSet1->Active = True;
}
catch(Exception *e) {
ShowMessage(e->Message);
}

3. Check the error message.
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See Also
o

InterBase ToGo with dbExpress

o

IBLite and IBToGo Licensing in RAD Studio

o

http://www.embarcadero.com/products/interbase/product-editions

o

Getting Started with InterBase Express

o

Mobile Tutorial: Using dbExpress and SQLite (iOS and Android)

o

Mobile Tutorial: Connecting to an Enterprise Database from a Mobile
Client (iOS and Android)

o

Mobile Tutorial: Using FireDAC in Mobile Applications (iOS and Android)
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Mobile Tutorial: Using InterBase
ToGo with FireDAC (iOS and Android)
Before starting this tutorial, you should read and perform the following tutorial
session:
o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)
Tip: To follow this tutorial, you need a license for IBToGo or IBLite:
o

o

If you purchased one of the following RAD Studio versions,
you have received in Email a key for an unlimited
development and deployment license for IBLite:


RAD Studio XE8 Professional or higher



Delphi XE8 Professional or higher with Mobile

If you are a trial user, your installation includes a trial license
for IBToGo. You can test InterBase on iOS and Android by
selecting your test license during the deployment step, as
described in this tutorial. The trial licenses are installed with
your trial product, in
C:\Users\Public\Documents\Embarcadero\InterBase\redis
t\InterBaseXE3.

Follow the steps at IBLite and IBToGo Test Deployment Licensing to
obtain and install your license file.
Note: On Android devices, InterBase ToGo apps require specific Uses Permissions
to be set, specifically:
o

Read external storage (the database is placed in the external memory)

o

Write external storage (the database is placed in the external memory)

o

Internet (you need to connect with a remote server)
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This tutorial describes the basic steps to browse data managed by InterBase
ToGo on your iOS and Android devices through the FireDAC framework.
iOS

Android

Note: You can use FireDAC, dbExpress, and Interbase Express (IBX) components
to build Interbase ToGo applications. For a detailed discussion on Interbase
Express components usage in a Delphi application, read the Getting Started with
InterBase Express article. For this tutorial, we will connect to Interbase ToGo using
FireDAC.
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Using FireDAC to Connect to the Database
FireDAC is a unique set of Universal Data Access Components for developing
cross-platform database applications for Delphi and C++Builder. With its powerful
common architecture, FireDAC enables native high-speed direct access from
Delphi to InterBase, SQLite, MySQL, SQL Server, Oracle, PostgreSQL, IBM DB2, SQL
Anywhere, Access, Firebird, Informix, and more.
o

For the mobile platforms, FireDAC supports InterBase ToGo as well as
SQLite. These database products can run on iOS and Android devices.

o

For other databases, such as Oracle, you need to have at least a client
library. On Windows platforms, the client library is provided as a DLL to
connect to. Therefore, you need to develop applications using middle-tier
technologies such as DataSnap to connect to these database products
from a mobile device.

Another tutorial discusses how to connect to Enterprise Database without using a
client library on a mobile device; see Mobile Tutorial: Connecting to an Enterprise
Database from a Mobile Client (iOS and Android).

Design and Set Up the User Interface
This tutorial uses TListView and TPanel components as the UI elements.
To set up a ListView and a Panel component, use the following steps:
1. To create an HD Multi-Device Application, select either of the following:


File > New > Multi-Device Application - Delphi > Blank Application



File > New > Multi-Device Application - C++Builder > Blank
Application

2. Drop a TListView component on the form.
3. In the Object Inspector, set the following properties of the ListView:


Set the Align property to Client, so that the ListView component
uses the entire form.



Set the ItemAppearance to ListItemRightDetail.



Set the SearchVisible to true.

4. Add a TPanel component to the form, and set the following properties in
the Object Inspector:


Set the Align property for the TPanel component to Top.

Embarcadero Technologies

285

Mobile Tutorial: Using InterBase ToGo with FireDAC (iOS and Android)

5. Add a TLabel component to the Panel, and set the following properties in
the Object Inspector:


Set the Align property for the TLabel component to Client.



Set the Views to either iOS or Android.



Set the StyleLookup property to listboxitemlabel.



Set back the Views to Master.



Set the HorzAlign property in TextSettings to Center.



Set the Text property to DB DEMO.

Connecting to the Data
Following are the basic steps to connect to data in a database using FireDAC:
1. On the Tool Palette, double-click the TFDConnection component.

2. Right-click the TFDConnection component and choose Connection Editor.
3. In the FireDAC Connection Editor, set the following parameters of the
TFDConnection:
1. Set the Driver ID property to IB.
2. Set the Database parameter to:
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\dbdemos.
gdb (location of the database)

and click Open in the File Open dialog box.
3. Set the User_name parameter to sysdba.
4. Set the Password parameter to masterkey.
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5. Set the Protocol parameter to TCPIP.

6. Click the Test button to test the connection.
7. Click OK to close the Connection Editor.
2. In the Object Inspector, set the following properties of TFDConnection:
1. Set the LoginPrompt property to False, so that the user is not
prompted for a login.
2. Set the Connected property to True.
Note: If you get an error ("unavailable database") in the development
environment, this means you do not have a current license for InterBase. The
license of InterBase Developer Edition is included as part of the product for some
product editions. For more information, see Troubleshooting.
3. Add a TFDQuery component to the form.
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4. Right-click the TFDQuery component and choose Query Editor.
1. Write in the SQL Command Text editor select COMMON_NAME,
SPECIES_NAME from BIOLIFE order by COMMON_NAME.
2. Click the Execute button to see the command results.

3. Click OK to close the Query Editor.
5. In the Object Inspector, set the Active property of the TFDQuery
component to True.
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6. Open the LiveBindings Designer and connect the data and the user
interface as follows:
1. Click COMMON_NAME in FDQuery1, and drag the mouse cursor to
Item.Text in ListView1.

At this point, TBindSourceDB and TBindingsList components were added to the
form.
2. Click SPECIES_NAME in BindSourceDB1, and drag the mouse cursor
to Item.Detail in ListView1.
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7. Add a TFDPhysIBDriverLink component to the form.
8. Add a TFDGUIxWaitCursor component to the form.
Note: The Preparing a FireDAC Application for Run Time topic explains the use of
the TFDGUIxWaitCursor and TFDPhysIBDriverLink components in a FireDAC
application.

Deploying your Application to Mobile
Up to this point, you have used InterBase on your desktop. This means that the
actual database is located at your local hard disk drive (for example,
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\dbdemos.
gdb). On the mobile Device, the application is sand-boxed, and typically you

can only read and write data that is located in the Documents folder (for iOS
device) and internal storage (for Android device) under your application folder.
To connect to a local database on mobile, you need to perform the following
actions:
o

Deploy the database to the mobile device.

o

Check the configuration (to connect to the database file) to a local file
under the Documents folder (for iOS device) or internal storage (for
Android device).

Deploying InterBase ToGo Required Files and the Database File to
Mobile
To execute your application on mobile, you need to deploy the following files:
o

Interbase ToGo required file (the license file and other configuration files)

o

The database file (dbdemos.gdb)

Deploy these files to your application as follows:
1. You can add the database to your project with one of the following two
methods:


Right-click the project name in the Project Manager and select
Add… from the context menu (or Project > Add to Project) to
display the Add to Project dialog box. Navigate to the database
location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata, select the database dbdemos.gdb and click Open.



Navigate to the database location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata and drag and drop the database dbdemos.gdb to the project in

the Project Manager. Click Yes to confirm that you want to add the
file to your project.
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2. After adding the database file, the Featured Files window displays. Select
InterBase ToGo in the Feature Files, and then click OK to close the
Featured Files dialog box.


Under the node InterBase ToGo you need to select the license to
be used when deploying the application on the device.


The Tip at the beginning of this tutorial describes how to
activate an InterBase license.



The suggested names for the license files available are listed
in the Featured Files dialog, under the following name
pattern: reg_*.txt.



You might have received from Embarcadero a license file
for IBToGo or IBLite that has a pattern of reg_nnnnnnn.txt,
where nnnnnnn is a generated number:


If you have saved that file over reg_ibtogo.txt or
reg_iblite.txt in the location below (for example,
C:\Users\Public\Documents\Embarcadero\InterBase
\redist\InterBaseXE3), you can just select the

desired license.


If you have saved the file with its original name, then
select Add Files (shown in the next step) and include
the license file in the list of files that need to be
deployed with the application.

3. Open the Deployment Manager by selecting Project > Deployment.
4. Select Debug configuration - iOS Device - 32 bit platform, Debug
configuration - iOS Device - 64 bit platform or Debug configuration Android platform from the drop-down list of target platforms at the top of
the Deployment Manager and see that the database dbdemos.gdb has
been added to the platforms.
5. See how the Remote Path of dbdemos.gdb has been set for iOS and
Android platforms:


Remote Path on iOS Device platform: StartUp\Documents\



Remote Path on Android platform: assets\internal\
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As you just configured, when you run the app on the mobile device, the
database file (dbdemos.gdb) is to be deployed to the Documents folder (for iOS
platform) or internal storage (for Android platform) in the sandbox area of your
multi-device application.
For the TFDConnection, create the BeforeConnect event handler as follows:
1. In the Form Designer, select the TFDConnection component.
2. In the Object Inspector, go to the Events tab and double-click the
BeforeConnect event.
3. Implement the event handler for the BeforeConnect event by adding the
following code:


For Delphi:

procedure TForm1.FDConnection1BeforeConnect(Sender: TObject);
begin
{$IF DEFINED(iOS) or DEFINED(ANDROID)}
FDConnection1.Params.Values['Protocol'] := 'Local';
FDConnection1.Params.Values['Database'] :=
TPath.Combine(TPath.GetDocumentsPath, 'dbdemos.gdb');
{$ENDIF}
end;

The TPath record is declared in System.IOUtils unit, so you need to add
System.IOUtils in the uses clause, as follows:
implementation
{$R *.fmx}
{$R *.NmXhdpiPh.fmx ANDROID}
{$R *.iPhone4in.fmx IOS}
uses System.IOUtils;
procedure TForm1.FDConnection1BeforeConnect(Sender: TObject);
// previous code goes here



For C++:

void __fastcall TForm1::SQLConnection1BeforeConnect(TObject *Sender)
{
#if ((defined(__arm__) && defined(__APPLE__)) || defined(__ANDROID__))
FDConnection1->Params->Values["Protocol"] = "Local";
FDConnection1->Params->Values["Database"] =
System::Ioutils::TPath::Combine(System::Ioutils::TPath::GetDocumentsPath(
), "dbdemos.gdb");
#endif
}

You need to add #include <System.IOUtils.hpp> in the unit (.cpp file).
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Run Your Application on a Simulator or on a Mobile
Device
Now your application is ready to run (Run > Run or press F9). You should be able
to browse data just as you can in the IDE. You can narrow down the list using the
Search Box.
iOS
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Troubleshooting
InterBase Issues
See the following section with detailed information about Interbase License
Issues.
Note: Follow the steps at IBLite and IBToGo Test Deployment Licensing to obtain a
valid license file.

Exception Handling Issues
If your application raises an exception without having proper exception handling
code, your multi-device application simply crashes (disappears) at run time.
If you encounter a crash, you might want to connect manually to the database
while you troubleshoot the issue using the following steps:
1. Select the FDConnection1 component, and change the Connected
property to False.
2. Drop a button on the form, and create the following event handler to
manually connect to the database:
Delphi:
procedure TForm1.Button1Click(Sender: TObject);
begin
try
FDConnection1.Connected := True;
FDQuery1.Active := True;
except
on e: Exception do
begin
ShowMessage(e.Message);
end;
end;
end;

C++:
void __fastcall TForm1::Button1Click(TObject *Sender) {
try {
FDConnection1->Connected = true;
FDQuery1->Active = true;
}
catch(Exception &e) {
ShowMessage(e.Message);
}
}

3. Check the error message.
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See Also
o

InterBase ToGo

o

IBLite and IBToGo Licensing

o

Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and Android)

o

http://www.embarcadero.com/products/interbase/product-editions

o

Mobile Tutorial: Using FireDAC and SQLite (iOS and Android)

o

Mobile Tutorial: Connecting to an Enterprise Database from a Mobile
Client (iOS and Android)
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Mobile Tutorial: Using dbExpress and
SQLite (iOS and Android)
Caution: dbExpress, which is described in this tutorial, is being deprecated. This
means that dbExpress will be removed from RAD Studio in an upcoming release.
Instead of dbExpress, we recommend that you use our newer database solution,
FireDAC, which is described in a similar tutorial, here:
Mobile Tutorial: Using FireDAC and SQLite (iOS and Android).
Before starting this tutorial, you should read and perform the following tutorial
session:
o

Mobile Tutorial: Using ListBox Components to Display a Table View (iOS
and Android)

This tutorial describes the basic steps to use SQLite as a local data storage on
your mobile device through the dbExpress framework.
iOS
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Using dbExpress to Connect to the Database
dbExpress is a very fast database access framework, written in Delphi. RAD
Studio provides drivers for most major databases, such as InterBase, Oracle, DB2,
SQL Server, MySQL, Firebird, SQLite, and ODBC. You can access these different
databases using procedures similar to the procedure described here.
o

For the mobile platforms, dbExpress supports InterBase ToGo as well as
SQLite. These database products can run on iOS and Android devices.

o

For other databases, such as Oracle, you need to have at least a client
library. On Windows platforms, the client library is provided as a DLL to
connect to. Therefore, you need to develop applications using middle-tier
technologies such as DataSnap to connect to these database products
from a mobile device.

Another tutorial discusses how to connect to Enterprise Database without using a
client library on a mobile device; see Mobile Tutorial: Connecting to an Enterprise
Database from a Mobile Client (iOS and Android).

Creating the Database in the Windows Environment
for Development Purposes
First, you need to create a SQLite database file on your Windows development
platform. Use the following steps, so that you can use the Form Designer to
design the user interface of your application.

Create the Database in the Data Explorer
1. Go to Data Explorer, right-click the SQLite node and select Add New
Connection:

2. Define the name of the connection, such as ShoppingList.
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3. Specify the location of the database file:

4. Click the Advanced button and open the Advanced Properties dialog
box.
5. Change the FailIfMissing property to False and click OK to close the
Advanced Properties dialog box:
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Note: Setting FailIfMissing to False instructs the Data Explorer to create a new
database file if the file is not available.
6. Back on the Modify Connection dialog box, click the Test Connection
button. With this operation, the new database file is created if no file
existed:

Note: Ensure that sqlite3.dll is present on your development system. If this file is
not present, download sqlite3.dll from http://www.sqlite.org/download.html to
your system path (such as C:\Windows\SysWOW64 for 64-bit Windows).

Create Table on DataExplorer
1. On the Data Explorer, double-click the ShoppingList node under the
SQLite section, right-click Tables, and then select New Table from the
context menu.

2. Set Data Type for a ShopItem column to TEXT.

3. Click the Save button and specify a table name (for example, Item.)
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Design and Set Up the User Interface

Visible UI components are loaded on the designer
This tutorial uses one TListBox component as the UI element.
To set up a ListBox component and other UI elements, use the following steps:
1. Create a multi-device application using File > New > Multi-Device
Application - Delphi or File > New > Multi-Device Application - C++Builder.
2. Drop a TToolBar on the form.
3. Drop a TButton on the ToolBar component and set the following properties
in the Object Inspector:


Set the Align to Right.



Set the Name property to ButtonAdd.



Set the StyleLookup to addtoolbutton.
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4. Drop a TButton on the ToolBar component and set the following properties
in the Object Inspector:


Set the Align to Left.



Set the Name property to ButtonDelete.



Set the StyleLookup to deletetoolbutton.



Set the Text to Delete.



Set the Visible to False.

5. Drop a TLabel on the ToolBar component and set the following properties
in the Object Inspector:


Set the Align to Client.



Set the StyleLookup to toollabel.



Set the Text to Shopping List.



Set the TextSettings.HorzAlign to Center.

6. Drop a TListBox component on the form and set the following properties in
the Object Inspector:


Set the Align property to Client, so that the ListBox component uses
the entire form.
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Connecting to the Data
Following are the basic steps to connect to data in a database which is already
defined in the Data Explorer:
1. Select the Item table on the Data Explorer and drag it to the Form
Designer.

Note: This creates two components (ShoppinglistConnection: TSQLConnection
and ItemTable: TSQLDataSet) on the form.

2. Select the ShoppinglistConnection component on the form, and then
change the Connected property to True.
3. Select the ItemTable component on the form, and then change the
Active property to True.
4. Select View > LiveBindings Designer and the LiveBindings Designer opens.
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5. Select ShopItem in the ItemTable component and drag ShopItem to
Item.Text of ListBox1.

Following these steps connects the user interface of the app with data on a
SQLite database. If you used a table with existing data for this tutorial, now you
should see actual data within the Form Designer.
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Creating the Event Handler to Make the Delete Button
Visible When the User Selects an Item from the List
The Visible property for the Delete button is set to False. Therefore, by default, the
end user does not see this button. You can make it visible when the user selects
an item on the list, as follows:
o

Select ListBox1 and define the following event handler for the OnItemClick
event.

Delphi:
procedure TForm1.ListBox1ItemClick(const Sender: TCustomListBox;
const Item: TListBoxItem);
begin
if ListBox1.Selected <> nil then
ButtonDelete.Visible := True
else
ButtonDelete.Visible := False;
end;

C++Builder:
void __fastcall TForm1::ListBox1ItemClick(const TCustomListBox *Sender,const
TListBoxItem *Item)
{
if (ListBox1->Selected)
ButtonDelete->Visible = True;
else
ButtonDelete->Visible = False;
}
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Creating the Event Handler for the Add Button to Add
an Entry to the List

Database connections are also configured
The next step is adding a feature to this application for adding an item to the
shopping list.
1. Drop a TSQLQuery component to the form.
2. Set the following properties in the Object Inspector:


Set the Name property to SQLQueryInsert.



Set the SQLConnection property to ShoppinglistConnection.



Set the SQL property as follows:

INSERT INTO ITEM (ShopItem) VALUES (:ShopItem)


Select the Expand (...) button on the Params property.



Select the ShopItem parameter and set DataType to ftString:
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3. In the Form Designer, double-click the ButtonAdd component. Add the
following code to this event handler:
Delphi:
procedure TForm1.ButtonAddClick(Sender: TObject);
var
Values: array[0 .. 0] of string;
begin
Values[0] := String.Empty;
InputQuery('Enter New Item', ['Name'], Values, Self.OnInputQuery_Close);
end;
procedure TForm1.OnInputQuery_Close(const AResult: TModalResult; const AValues:
array of string);
var
TaskName: string;
begin
TaskName := string.Empty;
if AResult <> mrOk then
Exit;
TaskName := AValues[0];
try
if not (TaskName.Trim = string.Empty) then
begin
SQLQueryInsert.ParamByName('ShopItem').AsString := TaskName;
SQLQueryInsert.ExecSQL();
ItemTable.Refresh;
LinkFillControlToField1.BindList.FillList;
if ListBox1.Selected <> nil then
ButtonDelete.Visible := True
else
ButtonDelete.Visible := False;
end;
except
on Ex: Exception do
ShowMessage('Error: ' + Ex.Message);
end;
end;

Declare this procedure prototype under the private section of the Form class:
private
procedure OnInputQuery_Close(const AResult: TModalResult; const AValues:
array of string);
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C++Builder:
To replicate the same functionality in C++, additional steps are required:
1. Add the next type definition after the TForm1 definition:
typedef void __fastcall (__closure *TInputCloseQueryProcEvent)(const
System::Uitypes::TModalResult AResult,
System::UnicodeString const *AValues, const int AValues_High);

2. Add the next class definition:
class InputQueryMethod : public TCppInterfacedObject<TInputCloseQueryProc>
{
private:
TInputCloseQueryProcEvent Event;
public:
InputQueryMethod(TInputCloseQueryProcEvent _Event) {
Event = _Event;
}
void __fastcall Invoke(const System::Uitypes::TModalResult AResult,
System::UnicodeString const *AValues, const int AValues_High) {
Event(AResult, AValues, AValues_High);
}
};

3. Add the next declaration under the private section of the form:
void __fastcall OnInputQuery_Close(const System::Uitypes::TModalResult AResult,
System::UnicodeString const *AValues, const int AValues_High);
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4. Add the actual functions:
void __fastcall TForm1::ButtonAddClick(TObject *Sender) {
String caption = "Caption";
String Prompts[1];
Prompts[0] = "Prompt 0";
String Defaults[1];
Defaults[0] = "Default 0";
_di_TInputCloseQueryProc Met = new
InputQueryMethod(&OnInputQuery_Close);
InputQuery("caption", Prompts, 0, Defaults, 0, (TInputCloseQueryProc
*)Met);
}
void __fastcall TForm1::OnInputQuery_Close(const System::Uitypes::TModalResult
AResult,
System::UnicodeString const *AValues, const int AValues_High) {
String TaskName;
TaskName = "";
if (AResult != mrOk)
return;
TaskName = AValues[0];
try {
if (TaskName.Trim() != "")
SQLQueryInsert->ParamByName("ShopItem")->AsString =
TaskName;
SQLQueryInsert->ExecSQL();
ItemTable->Refresh();
LinkFillControlToField1->BindList->FillList();
if (ListBox1->Selected != NULL)
ButtonDelete->Visible = True;
else
ButtonDelete->Visible = False;
}
catch (Exception& Ex) {
ShowMessage("Error: " + Ex.Message);
}
}
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The InputQuery function shows a dialog box asking the end user to enter a text.
This function returns True when the user selects OK, so that you can add data to
the database only when the user selects OK and the text contains some data.
iOS

Android

Creating the Event Handler for the Delete Button to
Remove an Entry from the List
The next step is adding a feature to this application to remove an item from the
shopping list:
1. Drop a TSQLQuery component to the form.
2. Set the following properties in the Object Inspector:


Set the Name property to SQLQueryDelete.



Set the SQLConnection property to ShoppinglistConnection.



Set the SQL property as follows:

delete from Item where ShopItem = :ShopItem


Select the Expand (...) button on the Params property.



Select the ShopItem parameter and set DataType to ftString.
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3. In the Structure View, select the ButtonDelete component. Add the
following code to this event handler.
Delphi:
procedure TForm1.ButtonDeleteClick(Sender: TObject);
var
TaskName: String;
begin
TaskName := ListBox1.Selected.Text;
try
SQLQueryDelete.ParamByName('ShopItem').AsString := TaskName;
SQLQueryDelete.ExecSQL();
ItemTable.Refresh;
LinkFillControlToField1.BindList.FillList;
if ListBox1.Selected <> nil then
ButtonDelete.Visible := True
else
ButtonDelete.Visible := False;
except
on e: Exception do
begin
SHowMessage(e.Message);
end;
end;
end;

C++Builder:
void __fastcall TForm1::ButtonDeleteClick(TObject *Sender) {
String TaskName = ListBox1->Selected->Text;
try {
SQLQueryDelete->ParamByName("ShopItem")->AsString = TaskName;
SQLQueryDelete->ExecSQL();
ItemTable->Refresh();
LinkFillControlToField1->BindList->FillList();
if (ListBox1->Selected)
ButtonDelete->Visible = True;
else
ButtonDelete->Visible = False;
}
catch (Exception &e) {
ShowMessage(e.Message);
}
}
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Setting Up Your Database Deployment for Mobile
Platforms
Up to this point, you have used SQLite on your desktop. This means that the
actual database is located on your local hard disk drive (for example,
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\shoplist
.s3db). On the mobile device, applications are sand-boxed, and typically you
can only read and write data that is located in the Documents folder (for iOS
device) and internal storage (for Android device) under your application folder.
To connect to a local database on mobile, you need to perform the following
actions:
o

Deploy the database to the mobile device.

o

Check the configuration (to connect to the database file) to a local file
under the Documents folder (for iOS device) or internal storage (for
Android device).

Add and Configure Your Database File in the Deployment Manager
Before you can run your application on mobile, you need to set up the
deployment for your database file (shoplist.s3db).
1. You can add the database to your project with one of the following two
methods:


Right-click the project name in the Project Manager and select
Add… from the context menu (or Project > Add to Project) to
display the Add to Project dialog box. Navigate to the database
location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata, select the database shoplist.s3db and click Open.



Navigate to the database location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata and drag and drop the database shoplist.s3db to the project

in the Project Manager. Click Yes to confirm that you want to add
the file to your project.
2. After adding the database file, the Featured Files window displays, click
Cancel to close it.
3. Open the Deployment Manager by selecting Project > Deployment.
4. Select Debug configuration - iOS Device - 32 bit platform, Debug
configuration - iOS Device - 64 bit platform or Debug configuration Android platform from the drop-down list of target platforms at the top of
the Deployment Manager and see that the database shoplist.s3db has
been added to the platforms.
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5. See how the Remote Path of shoplist.s3db has been set for iOS and
Android platforms:


Remote Path on iOS Device platform: StartUp\Documents\



Remote Path on Android platform: assets\internal\

As you just configured, when you run the app on the mobile device, the
database file (shoplist.s3db) is set to be deployed to the Documents folder (for
iOS platform) or internal storage (for Android platform) in the sandbox area of
your multi-device application.

Modifying Your Code to Connect to a Local Database
File on Mobile Platforms
The basic features of this application are now implemented. As you worked in
the Data Explorer, you created a database file on Windows. The database file is
not available on your mobile device unless you copy it to the mobile device or
create it on the fly.
You can create a SQLite Database and Table with the following steps:

Specifying the Location of the SQLite Database on the Mobile Device
1. In the Form Designer, select the ShoppinglistConnection component.
2. In the Object Inspector, double-click the BeforeConnect event.
3. Add the following code to this event handler:
Delphi:
procedure TForm1.ShoppinglistConnectionBeforeConnect(Sender: TObject);
begin
{$IF DEFINED(iOS) or DEFINED(ANDROID)}
ShoppinglistConnection.Params.Values['ColumnMetadataSupported'] := 'False';
ShoppinglistConnection.Params.Values['Database'] :=
TPath.Combine(TPath.GetDocumentsPath, 'shoplist.s3db');
{$ENDIF}
end;

The TPath record is declared in System.IOUtils unit, so you need to add
System.IOUtils in the uses clause of your unit.
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C++Builder:
void __fastcall TForm1::ShoppinglistConnectionBeforeConnect(TObject *Sender) {
#if defined(__ANDROID__) || defined(__APPLE__)
ShoppinglistConnection->Params->Values["ColumnMetadataSupported"] =
"False";
ShoppinglistConnection->Params->Values["Database"] =
System::Ioutils::TPath::Combine(System::Ioutils::TPath::GetDocumentsPath(),
"shoplist.s3db");
#endif
}

The TPath record is declared in System.IOUtils library, so you need to add
#include <System.IOUtils.hpp> in your header unit.

Creating a Table if None Exists
With SQLite you can create a table when no table exists, by using the CREATE
TABLE IF NOT EXISTS statement. You can create a table after the
TSQLConnection component connects to the database and before the
TSQLDataSet component connects to the table. Use the following steps:
1. In the Form Designer, select the ShoppinglistConnection component.
2. In the Object Inspector, double-click the AfterConnect event.
3. Add the following code to this event handler:
Delphi:
procedure TForm1.ShoppinglistConnectionAfterConnect(Sender: TObject);
begin
ShoppinglistConnection.ExecuteDirect('CREATE TABLE IF NOT EXISTS Item
(ShopItem TEXT NOT NULL)');
end;

C++Builder:
void __fastcall TForm1::ShoppinglistConnectionAfterConnect(TObject *Sender){
ShoppinglistConnection->ExecuteDirect("CREATE TABLE IF NOT EXISTS Item
(ShopItem TEXT NOT NULL)");
}
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Running Your Application on a Mobile Device
Now your application is ready to run on either a simulator or your connected
mobile device.
To run your application
1. In Project Manager, select your target platform.
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2. Choose either of the following commands:


Run > Run



Run > Run Without Debugging

iOS

Android

Note: If you have an issue with running the application, follow the
steps given in Troubleshooting.
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See Also
o

Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and Android)

o

Mobile Tutorial: Connecting to an Enterprise Database from a Mobile
Client (iOS and Android)

o

SQLite support in RAD Studio

o

Android Mobile Application Development

o

iOS Mobile Application Development
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Mobile Tutorial: Using FireDAC and
SQLite (iOS and Android)
Before starting this tutorial, you should read and perform the following tutorial
session:
o

Mobile Tutorial: Using LiveBindings to Populate a ListView (iOS and
Android)

This tutorial describes the basic steps to use SQLite as a local data storage on
your mobile device through the FireDAC framework.
iOS
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Using FireDAC to Connect to the Database
FireDAC is a unique set of Universal Data Access Components for developing
cross-platform database applications for Delphi and C++Builder. With its powerful
common architecture, FireDAC enables native high-speed direct access from
Delphi to InterBase, SQLite, MySQL, SQL Server, Oracle, PostgreSQL, IBM DB2, SQL
Anywhere, Access, Firebird, Informix, and more.
o

For the mobile platforms, FireDAC supports InterBase ToGo as well as
SQLite. These database products can run on iOS and Android devices.

o

For other databases, such as Oracle, you need to have at least a client
library. On Windows platforms, the client library is provided as a DLL to
connect to. Therefore, you need to develop applications using middle-tier
technologies such as DataSnap REST to connect to these database
products from a mobile device.

Another tutorial discusses how to connect to Enterprise Database without using a
client library on a mobile device; see Mobile Tutorial: Connecting to an Enterprise
Database from a Mobile Client (iOS and Android).

Creating the Database using FireDAC framework
First, you need to create a SQLite database file on your Windows development
platform. Use the following steps, so that you can use the Form Designer to
design the user interface of your Mobile App.
Note: In the Form Designer, activate the Master view for this tutorial.
1. To create an Multi-Device Application, select:


For Delphi: File > New > Multi-Device Application - Delphi > Blank
Application



For C++: File > New > Multi-Device Application - C++Builder > Blank
Application

2. On the Tool Palette, double-click the TFDConnection component.

3. Right click the TFDConnection component and choose Connection Editor.
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4. In the FireDAC Connection Editor, set the following parameters of the
TFDConnection:


Set the Driver ID property to SQLite.



Set the Database parameter to:

C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\shoplist
.s3db (location of the database)

and click Open in the File Open dialog box.
Note: You can set the above Database parameter even if shoplist.s3db does not
exist, RAD Studio creates it automatically. (To display Employees.s3db or other
*.s3db files in the Open dialog, set the All Files (*.*) option.)


Set the LockingMode parameter to normal.



Click the Test button to test the connection.



Click OK to close the Connection Editor.

5. In the Object Inspector, set the following properties of TFDConnection:


Set the LoginPrompt property to False, so that the user is not
prompted for a login.



Set the Connected property to True.
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6. On the Tool Palette, double-click the TFDQuery component.
7. In the Object Inspector, set the following properties of TFDQuery:


Set the Name property to FDQueryCreateTable.



Set the SQL property as follows:

CREATE TABLE IF NOT EXISTS Item (ShopItem TEXT NOT NULL)

8. Right click the FDQueryCreateTable and choose Execute.

Design and Set Up the User Interface

Visible UI components are loaded on the designer
This tutorial uses one TListView component as the UI element.
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To set up a ListView component and other UI elements, use the following steps:
1. Drop a TToolBar on the form.
2. Drop a TButton on the ToolBar component and set the following properties
in the Object Inspector:


Set the Name property to ButtonAdd.



Set the StyleLookup to addtoolbutton.



Set the Align to Right.

3. Drop a TButton on the ToolBar component and set the following properties
in the Object Inspector:


Set the Name property to ButtonDelete.



Set the StyleLookup to deletetoolbutton.



Set the Align to Left.



Set the Text to Delete.



Set the Visible property to False.

4. Drop a TLabel on the ToolBar component and set the following properties
in the Object Inspector:


Set the Align to Client.



Set the StyleLookup to toollabel.



Set the Text to Shopping List.



Expand the TTextSettings node and set the HorzAlign property to
Center.

5. Drop a TListView component on the form and set the following properties
in the Object Inspector:


Set the Align property to Client, so that the ListView component
uses the entire form.
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Using the LiveBindings Wizard
This tutorial uses the LiveBindings Wizard to add the LiveBindings components
(TBindSourceDB, TBindingsList), and the TFDQuery component.

Add the LiveBinding components
1. Select View > LiveBindings Designer and the LiveBindings Designer opens.
2. Select LiveBindings Wizard.

3. Select Create a data source binding task.
4. Click the Next button.
5. Select FireDAC class name.
6. Click the Next button.
7. Change the Command Type to Query.
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8. Set the Command Text property to select ShopItem from Item.

9. Click the Test Command button.
10. Click the Next button.
11. Click the Finish button.
At this point, TBindSourceDB and TFDQuery components were added to your
form.
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Connecting to the Data
1. Reopen the LiveBindings Wizard.
2. Select Link a control with a field binding task.

3. Click the Next button.
4. Select the Existing Control tab.
5. Select the ListView1 component.
6. Click the Next button.
7. Select BindSourceDB1.
8. Click the Next button.
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9. Select ShopItem Field Name.

10. Click the Next button.
11. Click the Finish button to close the wizard.
Note: These last steps are not mandatory for this tutorial since there is only one
field in BindSourceDB1. These steps are useful to link with the selected value if we
are managing several fields of a database.
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Displaying ShopItem in the ListView
The following step displays the text of ShopItem in the TListView component.
1. In the LiveBindings Designer select ShopItem in the BindSourceDB1
component and drag ShopItem to Item.Text in ListView1.

Following these steps connects the user interface of the app with data on a
SQLite database. If you used a table with existing data for this tutorial, now you
should see actual data within the Form Designer.

Creating the Event Handler to Make the Delete Button
Visible When the User Selects an Item from the List
The Visible property for the Delete button is set to False. Therefore, by default, the
end user does not see this button. You can make it visible when the user selects
an item on the list, as follows:
o

Select ListView1 and define the following event handler for the
OnItemClick event.

Delphi:
procedure TForm1.ListView1ItemClick(const Sender: TObject;
const AItem: TListViewItem);
begin
ButtonDelete.Visible := ListView1.Selected <> nil;
end;

o

For C++:

void __fastcall TForm1::ListView1ItemClick(const TObject *Sender,
const TListViewItem *AItem) {
ButtonDelete->Visible = (ListView1->Selected != NULL);
}

Embarcadero Technologies

326

Mobile Tutorial: Using FireDAC and SQLite (iOS and Android)

Creating the Event Handler for the Add Button to Add
an Entry to the List

Database connections are also configured
The next step is adding a feature to this application for adding an item to the
shopping list.
1. Drop a TFDQuery component on the form.
2. Set the following properties in the Object Inspector:


Set the Name property to FDQueryInsert.



Set the SQL property as follows:

INSERT INTO ITEM (ShopItem) VALUES (:ShopItem)


Select the Expand (...) button on the Params property.



Select the ShopItem parameter and set DataType to ftString:
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3. In the Structure View, right-click the ButtonAdd component and select
Control > Bring to Front. This brings the button to the visual front of the
active form.
o

For Delphi:

o

Declare the following procedure in the private section:

private
procedure OnInputQuery_Close(const AResult: TModalResult; const AValues:
array of string);

o

Add the following procedure :

procedure TForm1.OnInputQuery_Close(const AResult: TModalResult; const AValues:
array of string);
var
TaskName: String;
begin
TaskName := string.Empty;
if AResult <> mrOk then
Exit;
TaskName := AValues[0];
try
if (TaskName.Trim <> '')
then
begin
FDQueryInsert.ParamByName('ShopItem').AsString := TaskName;
FDQueryInsert.ExecSQL();
FDQuery1.Close();
FDQuery1.Open;
ButtonDelete.Visible := ListView1.Selected <> nil;
end;
except
on e: Exception do
begin
ShowMessage(e.Message);
end;
end;
end;

o

In the Form Designer, double-click the ButtonAdd component. Add the
following code to this event handler:

procedure TForm1.ButtonAddClick(Sender: TObject);
var
Values: array[0 .. 0] of String;
begin
Values[0] := String.Empty;
InputQuery('Enter New Item', ['Name'], Values, Self.OnInputQuery_Close)
end;
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o

For C++:

To replicate the same functionality in C++, additional steps are required.
o

Add the following definition after the TForm1 definition (in the .h file of your
unit):

typedef void __fastcall(__closure * TInputCloseQueryProcEvent)
(const System::Uitypes::TModalResult AResult,
System::UnicodeString const *AValues, const int AValues_High);

o

Add the following class definition (in the .h file of your unit, after the
previously defined type):

class InputQueryMethod : public TCppInterfacedObject<TInputCloseQueryProc>
{
private:
TInputCloseQueryProcEvent Event;
public:
InputQueryMethod(TInputCloseQueryProcEvent _Event) {
Event = _Event;
}
void __fastcall Invoke(const System::Uitypes::TModalResult AResult,
System::UnicodeString const *AValues, const int AValues_High) {
Event(AResult, AValues, AValues_High);
}
};

o

Add the following declaration under the private section of the form (in the
.h file of your unit):

private: //User declarations
void __fastcall OnInputQuery_Close
(const System::Uitypes::TModalResult AResult,
System::UnicodeString const *AValues, const int AValues_High);
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o

Add the following code (in the .cpp file of your unit):

void __fastcall TForm1::OnInputQuery_Close(const System::Uitypes::TModalResult
AResult,
System::UnicodeString const *AValues, const int AValues_High) {
String TaskName;
TaskName = "";
if (AResult != mrOk)
return;
TaskName = AValues[0];
try {
if
(!(Trim(TaskName) == "")) {
FDQueryInsert->ParamByName("ShopItem")->AsString =
TaskName;
FDQueryInsert->ExecSQL();
FDQuery1->Close();
FDQuery1->Open();
ButtonDelete->Visible = (ListView1->Selected != NULL);
}
}
catch (Exception &e) {
ShowMessage(e.Message);
}
}

o

In the Form Designer, double-click the ButtonAdd component. Add the
following code to this event handler:

void __fastcall TForm1::ButtonAddClick(TObject *Sender) {
String caption = "Enter New Item";
String Prompts[1];
Prompts[0] = "Name:";
String Defaults[1];
Defaults[0] = "";
_di_TInputCloseQueryProc Met = new
InputQueryMethod(&OnInputQuery_Close);
InputQuery(caption, Prompts, 0, Defaults, 0, (TInputCloseQueryProc *)Met);
}
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The InputQuery function shows a dialog box asking the end user to enter text. This
function returns True when the user selects OK, so that you can add data to the
database only when the user selects OK and the text contains some data.
iOS

Android

Creating the Event Handler for the Delete Button to
Remove an Entry from the List
The next step is adding a feature to this application to remove an item from the
shopping list:
1. Drop a TFDQuery component on the form.
2. Set the following properties in the Object Inspector:


Set the Name property to FDQueryDelete.



Set the SQL property as follows:

delete from Item where ShopItem = :ShopItem


Select the Expand (...) button on the Params property.



Select the ShopItem parameter and set DataType to ftString.
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3. In the Structure View, right-click the ButtonDelete component and select
Control > Bring to Front. This brings the button to the visual front of the
active form.
4. In the Form Designer, double-click the ButtonDelete component. Add the
following code to this event handler.
o

For Delphi:

procedure TForm1.ButtonDeleteClick(Sender: TObject);
var
TaskName: String;
begin
TaskName := ListView1.Selected.Text;
try
FDQueryDelete.ParamByName('ShopItem').AsString := TaskName;
FDQueryDelete.ExecSQL();
FDQuery1.Close;
FDQuery1.Open;
ButtonDelete.Visible := ListView1.Selected <> nil;
except
on e: Exception do
begin
SHowMessage(e.Message);
end;
end;
end;

o

For C++:

void __fastcall TForm1::ButtonDeleteClick(TObject *Sender) {
String TaskName = ListView1->Selected->Text;
try {
FDQueryDelete->ParamByName("ShopItem")->AsString = TaskName;
FDQueryDelete->ExecSQL();
FDQuery1->Close();
FDQuery1->Open();
ButtonDelete->Visible = (ListView1->Selected != NULL);
}
catch (Exception &e) {
ShowMessage(e.Message);
}
}
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Preparing Your Application for Run Time
FireDAC has a loosely-coupled multilayered architecture, where layers provide
services. A service API is defined as a COM interface that other layers can
request using the interface factory.
To properly operate FireDAC, you must link the implementation of the
IFDGUIxWaitCursor and IFDPhysDriver interfaces to your application.
For this, drop the TFDGUIxWaitCursor and TFDPhysSQLiteDriverLink components on
the form.

Setting Up Your Database Deployment for mobile
Up to this point, you have used SQLite on your desktop. This means that the
actual database is located on your local hard disk drive (for example,
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\shoplist
.s3db). On the mobile Device, applications are sand-boxed, and typically you
can only read and write data that is located in the Documents folder (for iOS
device) and internal storage (for Android device) under your application folder.
To connect to a local database on mobile, you need to perform the following
actions:
o

Deploy the database to the mobile device.

o

Check the configuration (to connect to the database file) to a local file
under the Documents folder (for iOS device) or internal storage (for
Android device).

Add and Configure Your Database File in the Deployment Manager
Before you can run your application on mobile, you need to set up the
deployment for your database file (shoplist.s3db).
1. You can add the database to your project with one of the following two
methods:


Right-click the project name in the Project Manager and select
Add… from the context menu (or Project > Add to Project) to
display the Add to Project dialog box. Navigate to the database
location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata, select the database shoplist.s3db and click Open.



Navigate to the database location
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\D
ata and drag and drop the database shoplist.s3db to the project

in the Project Manager. Click Yes to confirm that you want to add
the file to your project.

Embarcadero Technologies

333

Mobile Tutorial: Using FireDAC and SQLite (iOS and Android)

2. After adding the database file, the Featured Files window displays, click
Cancel to close it.
3. Open the Deployment Manager by selecting Project > Deployment.
4. Select Debug configuration - iOS Device - 32 bit platform, Debug
configuration - iOS Device - 64 bit platform or Debug configuration Android platform from the drop-down list of target platforms at the top of
the Deployment Manager and see that the database shoplist.s3db has
been added to the platforms.
5. See how the Remote Path of shoplist.s3db has been set for iOS and
Android platforms:


Remote Path on iOS Device platform: StartUp\Documents\



Remote Path on Android platform: assets\internal\

As you just configured, when you run the app on the mobile device, the
database file (shoplist.s3db) is set to be deployed to the Documents folder (for
iOS platform) or internal storage (for Android platform) in the sandbox area of
your multi-device application.

Modifying Your Code to Connect to a Local Database
File on mobile
The basic features of this application are now implemented. Following the steps
from this tutorial, you created a database file on Windows. The database file is
not available on your mobile device unless you copy it to the mobile device or
create it on the fly.
You can create a SQLite Database and Table with the following steps:

Specifying the Location of the SQLite Database on the Mobile Device
1. In the Form Designer, select the FDConnection1 component.
2. In the Object Inspector, double-click the BeforeConnect event.
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3. Add the following code to this event handler:
o

For Delphi:

procedure TForm1.FDConnection1BeforeConnect(Sender: TObject);
begin
{$IF DEFINED(iOS) or DEFINED(ANDROID)}
FDConnection1.Params.Values['Database'] :=
TPath.Combine(TPath.GetDocumentsPath, 'shoplist.s3db');
{$ENDIF}
end;

The TPath record is declared in System.IOUtils unit, so you need to add
System.IOUtils in the uses clause of your unit.
implementation
{$R *.fmx}
uses System.IOUtils;

o

For C++:

void __fastcall TForm1::FDConnection1BeforeConnect(TObject *Sender) {
#if defined(__ANDROID__) || defined(__APPLE__)
FDConnection1->Params->Values["Database"] =
System::Ioutils::TPath::Combine(System::Ioutils::TPath::GetDocumentsPath
(), "shoplist.s3db");
#endif
}

You need to add #include <System.IOUtils.hpp>.

Creating a Table if None Exists
With SQLite you can create a table when no table exists, by using the CREATE
TABLE IF NOT EXISTS statement. You can create a table after the
TFDConnection component connects to the database and before the TFDQuery
component connects to the table. Use the following steps:
1. In the Form Designer, select the FDConnection1 component.
2. In the Object Inspector, double-click the AfterConnect event.
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3. Add the following code to this event handler:
o

For Delphi:

procedure TForm1.FDConnection1AfterConnect(Sender: TObject);
begin
FDConnection1.ExecSQL('CREATE TABLE IF NOT EXISTS Item (ShopItem
NULL)');
end;

o

TEXT NOT

For C++:

void __fastcall TForm1::FDConnection1AfterConnect(TObject *Sender) {
FDConnection1->ExecSQL("CREATE TABLE IF NOT EXISTS Item (ShopItem
NOT NULL)");
}

TEXT

Running Your Application on a Simulator or on a
Mobile Device
Now your application is ready to run on either a simulator or your connected
mobile device.
To run your application
1. In Project Manager, select your target platform.
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2. Choose either of the following commands:


Run > Run



Run > Run Without Debugging
iOS

Android

Note: If you have an issue with running the application, follow the
steps given in Troubleshooting.

See Also
o

Mobile Tutorial: Using InterBase ToGo with FireDAC (iOS and Android)

o

Mobile Tutorial: Connecting to an Enterprise Database from a Mobile
Client (iOS and Android)

o

SQLite support in RAD Studio

o

Android Mobile Application Development

o

iOS Mobile Application Development
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Mobile Tutorial: Connecting to an
Enterprise Database from a Mobile
Client (iOS and Android)
Before starting this tutorial:
o

o

Read and perform the following tutorial session:


Mobile Tutorial: Using ListBox Components to Display a Table View
(iOS and Android)



Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and
Android)

Choose Start | Programs | Embarcadero InterBase XE7 | <xx>-bit instance
= gd_db | InterBase Server Manager and verify that the InterBase server is
running. The InterBase server must be running before you create or run the
example.

This tutorial describes how to connect to an Enterprise database from a mobile
client application.
To connect to an Enterprise Database, you need to have a client library. In most
cases, the client library is provided by the database vendor in DLL format. This
strategy does not work well for mobile devices because no client library is
available. To resolve this issue, you can develop a middle tier to connect to an
Enterprise Database, and your application can communicate with the middle
tier.
RAD Studio provides the DataSnap framework with which you can develop the
middle tier (and access the middle tier) with almost no coding required. This
tutorial describes the steps to develop the middle tier and then develop the
mobile client.
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Creating the Middle Tier, a DataSnap Server
First, create a DataSnap server that exposes a table from a database server. This
tutorial uses a DataSnap Server VCL Forms Application as a DataSnap server.
Note: In this tutorial, the DataSnap server (a VCL application)
functions as the middle tier in a multi-tiered database application.
You can easily create and later delete an instance of a DataSnap
server. After you understand the basic steps, you can convert the
middle tier to a Windows service application.

Create a DataSnap Server VCL Application
1. In order to create a new Delphi or C++ project, choose File > New > Other
and from the New Items dialog select:


For Delphi:Delphi Projects > DataSnap Server > DataSnap Server



For C++:C++Builder Projects > DataSnap Server > DataSnap Server
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2. The New DataSnap Server wizard appears:

1. At first step, choose Forms Application as project type.
2. At the second step, check VCL Application as application type.
3. At the third step, choose the TCP/IP protocol, Server Methods Class
and Sample Methods from the Server Features list.
4. At the fourth step, leave the default TCP/IP communications port to
211. This will ensure that the communication between the client
and the server will pass through the default DataSnap port.
5. At the final step (number five) select TDSServerModule as the
ancestor for the Server Methods.
2. Save the form unit as DataSnapServerUnit.
3. Switch to DataSnapServerUnit, and change the Name property of the
Form to DSServerForm.
4. Save the server methods unit (by default as created by the Wizard:
ServerMethodsUnit1) as ServerModuleUnit.
5. Save the server container unit (by default as created by the Wizard:
ServerContainerUnit1) as ServerContainerUnit.
6. Save the new project as DataSnapServerProject.
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7. Select ProjectGroup1 in the Project Manager, and save the project as
DataSnapTutorialProjectGroup.groupproj.

Define a DataSet on the DataSnap Server
1. Switch to the ServerContainerUnit.pas file and replace the uses clause in
the implementation with: uses Winapi.Windows, ServerModuleUnit, for
Delphi, and replace #include "ServerMethodsUnit.h" with #include
"ServerModuleUnit.h" in ServerContainerUnit.cpp, for C++;
2. Switch to the ServerModuleUnit.pas file.
3. In the Form Designer, change the Name property of the Server Module to
DSServerModule_EMPLOYEE.
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4. Configure the following components on the Server Module:


Drop a TSQLConnection component on the Server Module, and set
the following properties:

TSQLConnection encapsulates a dbExpress connection to a database server.


Set the Name property to SQLConnection_EMPLOYEE.



Set the LoginPrompt property to False.



Set Driver to InterBase Server.

Note: Make sure that the InterBase Server is running.


Expand the Driver node, and set the DataBase property to
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Sam
ples\Data\EMPLOYEE.GDB.





Change the Connected property to True. If you get an error,
double-check the Driver properties:

Drop a TSQLDataSet component on the Server Module, and set the
following properties:

TSQLDataSet represents the data retrieved using dbExpress.





Set the Name property to SQLDataSet_EMPLOYEE.



Set the SQLConnection property to
SQLConnection_EMPLOYEE.



Set the CommandType property to ctTable.



Set the CommandText property to EMPLOYEE.



Change the Active property to True. If you get an error,
double-check the properties you just configured.

Drop a TDataSetProvider component on the Server Module, and
set the following properties:
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TDataSetProvider packages data from a dataset and passes one or more
transportable data packets to the DataSnap client.


Set the Name property to DataSetProvider_EMPLOYEE.



Set the DataSet property to SQLDataSet_EMPLOYEE:

Note: This tutorial uses InterBase as an example. However, you can
connect to any database server using the same steps. Select the
proper driver, and other properties to point to your database.

Expose the DataSet from the DataSnap Server
You have just created a new Server Module that contains a DataSet and a
DataSetProvider that packages data to the next layer. The next step is to expose
the Server Module to the DataSnap client.
1. In the Form Designer, open ServerContainerUnit.
2. Select DSServerClass1, and update the existing event handler for the
OnGetClass event. Add the following code to the DSServerClass1 event
handler:
Delphi:
procedure TServerContainer1.DSServerClass1GetClass(DSServerClass:
TDSServerClass;
var PersistentClass: TPersistentClass);
begin
PersistentClass := TDSServerModule_EMPLOYEE;
end;

C++ (only for iOS):
void __fastcall TServerContainer1::DSServerClass1GetClass(TDSServerClass
*DSServerClass,
TPersistentClass &PersistentClass)
{
PersistentClass = __classid(TDSServerModule_EMPLOYEE);
}
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With this event handler, the DataSnap Server exposes providers as well as public
methods in this class to a DataSnap client. Based on the steps in the previous
section, now you are going to expose the DataSetProvider_EMPLOYEE
DataSetProvider component to your DataSnap client.

Run the DataSnap Server
Implementation of the DataSnap Server is complete. Right-click
DataSnapServerProject.exe and select Run Without Debugging.

.
Now you can see the DataSnap server running on your Windows machine.
Because this DataSnap server has no UI element, it looks like a blank form, and
this is as expected at this point.
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Creating a Mobile Application that Connects to the
DataSnap Server
The next step is creating the mobile client application.
1. In the Project Manager, right-click DataSnapTutorialProjectGroup, and
select Add New Project.

2. Select Multi-Device Application on the Delphi Projects page:

3. Save the new Unit as DataSnapClientUnit.
4. Save the new Project as DataSnapClientProject.
5. Open DataSnapClientUnit, and change the Name property of the Form to
DSClientForm.
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6. Drop the following components on the Form Designer:


TSQLConnection component (SQLConnection1)

TSQLConnection encapsulates a dbExpress connection to a database server.
Also, it supports the DataSnap server.


Set the Driver property to DataSnap.



Expand the Driver property, and set the HostName property
to the host name of the DataSnap server.



Set the LoginPrompt property to False.



Set the Connected property to True.

If you see an error, please double-check the properties you have just set.


TDSProviderConnection component (DSProviderConnection1)

The TDSProviderConnection component provides connectivity to the DataSnap
server using dbExpress.





Set the SQLConnection property to SQLConnection1.



Set ServerClassName to TDSServerModule_EMPLOYEE. This
name needs to match the name of the class of the Server
Module of the DataSnap server.



Set the Connected property to True.

TClientDataSet component (ClientDataSet1)

TClientDataSet implements a database-independent dataset, and this can be
used as a local in-memory buffer of the records from another dataset.





Set the RemoteServer property to DSProviderConnection1.



Set the ProviderName property to
DataSetProvider_EMPLOYEE. This name needs to match the
name of the provider for the DataSnap server.



Set the Active property to True.

TListBox component
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7. Open the LiveBindings Designer and connect the data and user interface
as follows:
1. Click FULL_NAME in BindSourceDB1, and drag the mouse cursor to
Item.Text in ListBox1:

2. Now you have created and configured the DataSnap Client on
the mobile platform. You should be able to see the data coming
from the DataSnap server in the IDE:
iOS
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Deploy the MIDAS Library to iOS Simulator
To execute your application on the iOS Simulator, you need to deploy the
following files:
o

MIDAS Library

1. Open the Deployment Manager by selecting Project > Deployment.
2. Select Add Featured Files (

):

3. Select the following module, and then click OK to close the Deployment
Manager:


MIDAS Library

Run Your Application on the mobile platform
Now your application is ready to run.
In the Project Manager, select the mobile target platform, and run your
application. You should be able to browse data just as you do within the IDE.
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See Also
o

Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and Android)

o

Mobile Tutorial: Using dbExpress and SQLite (iOS and Android)

o

Mobile Tutorial: Using FireDAC in Mobile Applications (iOS and Android)

o

Developing DataSnap Applications

o

Understanding Multi-tiered Database Applications

o

Datasnap.DSServer.TDSServer

o

Start the InterBase Server
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Mobile Tutorial: Using FireDAC in
Mobile Applications (iOS and
Android)
This tutorial describes the basic steps to use SQLite as a local data storage on
your mobile device through the FireDAC framework.
iOS

Android

Using FireDAC to Connect to the Database
FireDAC is a unique set of Universal Data Access Components for developing
multi-device database applications for Delphi and C++Builder. With its powerful
common architecture, FireDAC enables native high-speed direct access from
Delphi to InterBase, SQLite, MySQL, SQL Server, Oracle, PostgreSQL, IBM DB2, SQL
Anywhere, Access, Firebird, Informix, and more.

Embarcadero Technologies

350

Mobile Tutorial: Using FireDAC in Mobile Applications (iOS and Android)

The FireDAC native driver supports SQLite database version 3.0 and later. For a
detailed discussion on SQLite usage in FireDAC for a Delphi application, read the
"Using SQLite with FireDAC" article.
To use SQLite in your application, the sqlite3.dll file must be present on your
development system. If this file is not present, download sqlite3.dll from
http://www.sqlite.org/download.html to your system path (such as
C:\Windows\SysWOW64 for 64-bit Windows).

Design and Set Up the User Interface
Create a new project. Choose a Multi-Device Application.
1. Drop a TFDConnection component on the form.
2. Right click the TFDConnection component and choose Connection Editor.
3. In the FireDAC Connection Editor, set the following parameters of the
TFDConnection:
1. Set the Driver ID property to SQLite.
2. Set the Database parameter to:
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\Employee
s.s3db (location of the database)

and click Open in the File Open dialog box.
(To display Employees.s3db in the Open dialog, set the All Files (*.*) option.)
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3. Click the Test button to test the connection.

4. Click OK to close the Connection Editor.
4. In the Object Inspector, set the following properties of TFDConnection:
1. Set the LoginPrompt property to False, so that the user is not
prompted for a login.
2. Set the Connected property to True.

Using the LiveBindings Wizard
Use the LiveBindings Wizard to add the LiveBindings components
(TBindSourceDB, TBindingsList), TFDQuery, and the TListView component.

Add the LiveBinding components
1. Select View > LiveBindings Designer and the LiveBindings Designer opens.
2. Select LiveBindings Wizard.

3. Select Create a data source binding task.
4. Click the Next button.
5. Select FireDAC class name.
6. Click the Next button.
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7. Change the Command Type to Query.
8. Set the Command Text property to select Name, Department, Seniority
from Employee order by Department.

9. Click the Test Command button.
10. Click the Next button.
11. Click the Finish button.
At this point, TBindSourceDB and TFDQuery components were added to your
form.
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Add the ListView component
1. Reopen the LiveBindings Wizard.
2. Select Link a control with a field binding task.

3. Click the Next button.
4. Select TListView.
5. Click the Next button.
6. Select BindSourceDB1.
7. Click the Next button.
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8. Select Name Field Name.

9. Click the Next button.
10. Click the Finish button to close the wizard.
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Using the LiveBindings Wizard

LiveBindings Designer
Use the LiveBindings Designer to add new connections between the
TBindSourceDB and TListView components.
1. Select the ItemHeader.Text member from TListView.
2. Bind to the Department member of the BindSourceDB1 component by
dragging (a connection line appears).
3. Select the Item.Text member from TListView.
4. Bind to the Name member of the BindSourceDB1 component by dragging
(a connection line appears).
5. In the Object Inspector, set the following properties of TListView:
1. Set the ItemAppearance to ImageListItemRightButton.
In the LiveBindings Designer, the TListView should have a new member,
Item.ButtonText.
2. Set the Align property to Client.
6. In the LiveBindings Designer, select the Item.ButtonText member from
TListView.
7. Bind to the Seniority member of the BindSourceDB1 component by
dragging (a connection line appears).

Embarcadero Technologies

356

Mobile Tutorial: Using FireDAC in Mobile Applications (iOS and Android)

Preparing Your Application for Run Time
FireDAC has a loosely-coupled multilayered architecture, where layers provide
services. A service API is defined as a COM interface that other layers can
request using the interface factory.
To properly operate FireDAC, you must link the implementation of the
IFDGUIxWaitCursor and IFDPhysDriver interfaces to your application.
For this, drop the TFDGUIxWaitCursor and TFDPhysSQLiteDriverLink components
on the form.

Setting Up Your Database Deployment for mobile
Up to this point, you have used SQLite on your desktop. This means that the
actual database is located on your local hard disk drive (for example,
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\Employ
ees.s3db). On the mobile device, applications are sand-boxed, and typically
you can only read and write data that is located in the Documents folder (for iOS
device) and internal storage (for Android device) under your application folder.
To connect to a local database on mobile, you need to perform the following
actions:
o

Deploy the database to the mobile device.

o

Change the configuration (to connect to the database file) to a local file
under the Documents folder (for iOS device) or internal storage (for
Android device).

Add and Configure Your Database File in the Deployment Manager
Before you can run your application on mobile, you need to set up the
deployment for your database file (Employees.s3db).
1. Open the Deployment Manager by selecting Project > Deployment.
2. Select Add Files and select the database file (for example,
C:\Users\Public\Documents\Embarcadero\Studio\16.0\Samples\Data\
Employees.s3db).
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3. Select Employees.s3db, and change Remote Path to StartUp\Documents\
(for iOS platform) or assets\internal\ (for Android platform).
RemotePath on iOS device platform

RemotePath on Android platform

4. Select the Platforms column (double-click the ellipsis [...] in the row for
Employees.s3db):
1. Ensure that iOSSimulator, iOSDevice32 and iOSDevice64 or Android
are present for Employees.s3db.
2. Remove Win32 from the list if it is present (you do not have to copy
database files to the Win32 platform).
5. Select All-Configurations - iOS Device - 32 bit platform, All-Configurations iOS Device - 64 bit platform or All-Configurations - Android platform and
make sure Employees.s3db is set to be deployed to StartUp\Documents\
or assets\internal\.
As you just configured, when you run the app on the mobile device, the
database file (Employees.s3db) is set to be deployed to the Documents folder
(for iOS platform) or internal storage (for Android platform) in the sandbox area
of your application.

Modifying Your Code to Connect to a Local Database
File on Mobile
The basic features of this application are now implemented. The database file
used in this application was created on Windows and the file is not available on
your mobile device unless you copy it to the mobile device or create it on the fly.

Specifying the Location of the SQLite Database on the Mobile Device
1. In the Form Designer, select the FDConnection1 component.
2. In the Object Inspector, double-click the BeforeConnect event.
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3. Add the following code to this event handler:
Delphi:
procedure TForm1.FDConnection1BeforeConnect(Sender: TObject);
begin
FDConnection1.Params.Values['Database'] :=
TPath.Combine(TPath.GetDocumentsPath, 'Employees.s3db');
end;

The TPath record is declared in System.IOUtils unit, so you need to add
System.IOUtils in the uses clause of your unit.
C++ (only for iOS):
void __fastcall TForm1::FDConnection1BeforeConnect(TObject *Sender)
{
FDConnection1->Params->Values["ColumnMetadataSupported"] = "False";
FDConnection1->Params->Values["Database"] =
System::Ioutils::TPath::Combine(System::Ioutils::TPath::GetDocumentsPath(),
"Employees.s3db");
}

The TPath record is declared in System.IOUtils library, so you need to add
#include <System.IOUtils.hpp> in your header unit.
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Running Your Application on the Simulator or on the
Mobile Device
Now your application is ready to run (select Run > Run).
iOS
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See Also
o

Connect to SQLite (FireDAC)

o

Preparing a FireDAC Application for Run Time

o

LiveBindings in RAD Studio

o

Mobile Tutorial: Using InterBase ToGo with dbExpress (iOS and Android)

o

Mobile Tutorial: Connecting to an Enterprise Database from a Mobile
Client (iOS and Android)

o

Tutorial: Using FireDAC from a Multi-Device Application on Desktop
Platforms
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Mobile Tutorials: Table of
Components Used
The following table lists the FireMonkey components that are used in each of the
mobile tutorials:
Mobile Tutorial
Creating a Multi-Device
Application (iOS and Android)
Using a Button Component with
Different Styles (iOS and Android)
Using a Calendar Component to
Pick a Date (iOS and Android)

FireMonkey Components, Properties and Methods
Used
TEdit, TButton, TLabel
KillFocusByReturn, Text, Name
TButton, TSpeedButton
Position, Height, Width, StyleLookup, TintColor,
IconTintColor, GroupName, IsPressed
TDateEdit
ShowCheckBox

Using Combo Box Components to TComboBox
Pick Items from a List (iOS and
ItemIndex, IndexOf, OnChange
Android)
Using a MultiView Component to
Display Alternate Views of
Information (iOS and Android)

Using the Web Browser
Component (iOS and Android)

TMultiView, TDrawerAppearance
Visible, Mode, MasterButton, DoOpen, DoClose,
GetDisplayName, DoInstall, TargetControl,
DrawerOptions, ShadowOptions
TWebBrowser, TButton, TVirtualKeyboard
ReturnKeyType, GoBack, KeyboardType,
KillFocusByReturn

Using Tab Components to Display
Pages (iOS and Android)

TTabControl, TTabItem, MultiResBitmap Editor,
ActionList, TButton

Using LiveBindings to Populate a
ListView (iOS and Android)

TListView, TPrototypeBindSource, TextButton

Using ListBox Components to
Display a Table View (iOS and
Android)

Embarcadero Technologies

TListBox, TLabel, TToolBar, TSpeedButton, TSearchBox,
TListBoxHeader, TListBoxGroupHeader,
TListBoxGroupFooter
Align, StyleLookup, HorzAlign, Text, Accessory,
TListBoxItemData.Detail, Bitmap, StyleLookup,
TListBoxItemData.Detail
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Using LiveBindings to
Populate a ListBox in TListBox, DefaultItemStyles.ItemStyle, TRectangle,
Mobile Applications TPrototypeBindSource, LiveBindings Designer,
(iOS and Android)
Using Layout to
Adjust Different Form TLayout and its properties: Align, Margins, Padding, and Anchors
Sizes or Orientations TVertScrollBox
(iOS and Android)
Taking and Sharing a
Picture, and Sharing
Text (iOS and
Android)

TToolBar, TImage, TActionList, FMX.MediaLibrary,
TTakePhotoFromCameraAction, OnDidFinishTaking,
OnBeforeExecute,TShowShareSheetAction, TToolBar, TButton,
TMemo

Using Location
Sensors (iOS and
Android)

TListBox with added items and groupheaders, TWebBrowser,
TLocationSensor, OnLocationChanged, TSwitch, TGeocoder and
its methods

Using Notifications
(iOS and Android)

TNotificationCenter, TNotification, TNotification.Number,
ScheduleNotification, RepeatInterval

Using InterBase ToGo
TListView, TPanel, TLabel, TSQLDataSet, LiveBindings Designer,
with dbExpress (iOS
Deployment Manager
and Android)
Using SQLite and
dbExpress (iOS and
Android)

Data Explorer, TListBox, TButton, TLabel, TSQLQuery, InputQuery,
Deployment Manager

Connecting to an
Enterprise Database
from a Mobile Client
(iOS and Android)

DataSnap Server Wizard, TDSServerModule, TSQLConnection,
TSQLDataSet, TDataSetProvider, TDSProviderConnection,
TClientDataSet, TListBox

Using InterBase ToGo TFDConnection, TBindSourceDB, TFDQuery, TListView, TPanel,
with FireDac (iOS and TLabel, LiveBindings Designer, TFDGUIxWaitCursor,
Android)
FTFDPhysSQLiteDriverLink, Deployment Manager
Using FireDAC and
SQLite (iOS and
Android)

TFDConnection, LiveBindings Wizard, TBindSourceDB, TFDQuery,
TListView, LiveBindings Designer, TFDGUIxWaitCursor,
FTFDPhysSQLiteDriverLink, Deployment Manager

Using Remote
TPushEvents, AutoActivate, TKinveyProvider, AppKey, AppSecret,
Notifications (iOS and MasterSecret, TParseProvider, ApplicationID, RestApiKey,Provider,
Android)
LiveBindings Designer
Using BaaS for
Backend Storage
(iOS and Android)
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TListView, TLabel, TButton, TBackendStorage, TKinveyProvider and
its properties AppKey, AppSecret, MasterSecret, and the
TParseProvider component and its properties ApplicationID,
MasterKey and RestApiKey
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Note: This list of components is intended for informational purposes only, and
might not be entirely accurate or complete.
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