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Mobile Tutorials: Mobile Application 
Development (iOS and Android) 
 

This integrated set  of tutorials walks you through development of an iOS or Android 

mobile application for both Delphi and C++:  

¶ After the three initial setup tutorials, the first tutorial shows you how to construct 

an iOS or Android application using FireMonkey tools.  

¶ The remaining tutorials demonstrate the recommended FireMonkey components 

to use in order to achieve a native look -and -feel in your iOS and Android 

applications.  



Setup  
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Setup 

 

¶ Set Up Your Development Environment on the Mac (iOS)  

 

¶ Set Up Your Development Environment on Windows PC 

(iOS) 

 

¶ Set Up Your Development Environment on Windows PC 

(Android)  

Using Basic User Interface Elements 

 

¶ Creating a FireMonkey Mobile Application (iOS and 

Android)  

 

¶ Using a Button Component with Different Styles (iOS and 

Android)  

 

¶ Using a Calendar Component to Pick a Date (iOS and 

Andro id)  
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¶ Using Combo Box Components to Pick Items from a List 

(iOS and Android)  

 

¶ Using the Web Browser Component (iOS and Android)  

 

¶ Using Tab Components to Display Pages (iOS and Android)  

 

¶ Using LiveBindings to Populate a ListView (iOS and Android)  

 

¶ Using ListBox Components to Display a Table View (iOS and 

Android)  

 

¶ Using LiveBindings to Populate a ListBox (iOS and Android)  
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¶ Using Layout to Adjust Different Form Sizes or Orientations 

(iOS and Android)  

Using Device Functionality 

 

¶ Taking and Sharing a Picture, and Sharing Text (iOS and 

Android)  

 

¶ Using Location Sensors (iOS and Android)  

 

¶ Using Notifications (iOS and Android)  

 

¶ Using Remote Notifications (iOS and Android)  
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¶ Mobile Tutorial: Using the Phone Dialer on Mobile Devices 

(iOS and Android)  

Accessing a Database 

 

¶ Using InterBase ToGo with FireDAC (iOS and Android)  

¶ Using InterBase ToGo with dbExpress (iOS and Android)  

 

¶ Using SQLite and FireDAC (iOS and Android)  

¶ Using SQLite and dbExpress (iOS and Android)  

 

¶ Connecting to an Enterprise Database from a Mobile 

Client (iOS and Android)  

See Also 

¶ Mobile Tutorials: Table of Components Used  

¶ FireMonkey Quick Start  

¶ Creating an iOS App  

¶ Creating an Android App  

http://docwiki.embarcadero.com/RADStudio/XE6/en/Mobile_Tutorials:_Table_of_Components_Used
http://docwiki.embarcadero.com/RADStudio/XE6/en/FireMonkey_Quick_Start_Guide_-_Introduction
http://docwiki.embarcadero.com/RADStudio/XE6/en/Creating_an_iOS_App
http://docwiki.embarcadero.com/RADStudio/XE6/en/Creating_an_Android_App
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¶ FireMonkey Application Design  

¶ Mobile Code Snippets  

¶ iOS Mobile Application Development  

¶ Android Mobile Application Development  

¶ Supported Target Platforms  

http://docwiki.embarcadero.com/RADStudio/XE6/en/FireMonkey_Application_Design
http://docwiki.embarcadero.com/RADStudio/XE6/en/Mobile_Code_Snippets
http://docwiki.embarcadero.com/RADStudio/XE6/en/IOS_Mobile_Application_Development
http://docwiki.embarcadero.com/RADStudio/XE6/en/Android_Mobile_Application_Development
http://docwiki.embarcadero.com/RADStudio/XE6/en/Supported_Target_Platforms
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Mobile Tutorial: Set Up Your 
Development Environment on the Mac 
(iOS) 
 

 

A FireMonkey Delphi application destined for the iOS target pla tform can be optionally 

tested on the iOS Simulator  available on the Mac. FireMonkey C++ and Delphi 

applications can be tested using the iOS Device  target platform; this testing requires a 

test iOS device connected to the Mac.  

¶ The first half of this tutorial describes the steps that you need to perform in order 

to run your iOS application (Delphi only) on the iOS Simulator  on the Mac.  

¶ The second half of this tutorial describes additional steps required in order to run 

your iOS Application (Delphi or C++) on your iOS Device . 

Note:  The iOS Simulator  is not supported by BCCIOSARM, the C++ Compiler for 

the iOS Device . Only iOS devices are supported by BCCIOSARM.  

Requirements on the Mac and iOS 

¶ 10.8 Mountain Lion  

¶ 10.9 Mavericks  

(Neither OS is supported on legacy PowerPC - and 680x0 -based Macintosh 

systems. All Macs since 2007 are Intel -based; all Macs since 2008 are 64 -bit.)  

¶ For Mac OS X development, the latest version of Xcode  

¶ For iOS development, t he iOS SDK and the appropriate version of Xcode  installed 

(see the table below), along with the Xcode command line tools : 

http://docwiki.embarcadero.com/RADStudio/XE6/en/BCCIOSARM.EXE,_the_C%2B%2B_Compiler_for_the_iOS_Device
http://docwiki.embarcadero.com/RADStudio/XE6/en/BCCIOSARM.EXE,_the_C%2B%2B_Compiler_for_the_iOS_Device
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_Xcode_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_Xcode_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Xcode_Command_Line_Tools_on_a_Mac
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iOS version    Xcode version    

iOS 6.0 Xcode 4.5  

iOS 6.1 Xcode 4.6  

iOS 7.0 Xcode 5.0  

iOS 7.1 Xcode 5.1  

¶ Membership in one of several Apple Developer Programs, which are described in 

this topic under Sign up for a Developer acco unt . 

¶ An iOS device connected to the Mac by USB port (required for testing or running 

your iOS app on the device)  

Steps to Configure Your Mac to Run Your iOS Application 

To deploy an iOS application to the iOS Simulator  on the Mac or to an iOS device, you 

need to install the following tools on your Mac:  

¶ Platform Assistant (PAServer)  

For debugging purposes, RAD Studio uses the Platform A ssistant, an application 

that you must install and run on the Mac.  

¶ Xcode  

Xcode is the development and debug environment on the Mac, and provides 

the required develo pment files for Mac OS X and iOS applications.  

 

 

Step 1: Install the Platform Assistant 

As discussed, the Platform Assistant must be running on the Mac when you deploy an 

iOS app from your PC to either the iOS simulator or an iOS device.  

http://docwiki.embarcadero.com/RADStudio/XE6/en/PAServer,_the_Platform_Assistant_Server_Application
http://docwiki.embarcadero.com/RADStudio/XE6/en/PAServer,_the_Platform_Assistant_Server_Application
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Platform_Assistant_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_the_Platform_Assistant_on_a_Mac
http://developer.apple.com/xcode/
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The Mac OS X inst aller for the Platform Assistant is named PAServer14.0.pkg  and it is 

available in two places:  

¶ Inside the RAD Studio installation directory:  

C: \ Program Files 

(x86) \ Embarcadero \ Studio \ 14.0 \ PAServer \ PAServer14.0.pkg  

¶ On the Web, for download to the Mac:  

http://altd.embarcadero.com/release/studio/14.0/PAServer/PAServer14.0.p

kg  

 

For further details, see Installing the Platform Assistant on a Mac . 

Step 2: Run the Platform Assistant 

In the Finder on the Mac, activate the .app file ( PAServer 14.0.app ) as follows:  

1. Navigate to the top -level Applications  folder.  

2. Double -click PAServer 14.0.app  to start the Platform Assistant:  

http://altd.embarcadero.com/release/studio/14.0/PAServer/PAServer14.0.pkg
http://altd.embarcadero.com/release/studio/14.0/PAServer/PAServer14.0.pkg
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Platform_Assistant_on_a_Mac
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The Terminal window appears, displaying the Platform Assistant banner and the 

password prompt:  

Connection Profile password <press Enter for no password>  

 

Either press Return, or enter a password for PAServer and then press Return.  

3. Next you are prompted to enter your Mac user password to allow the Platform 

Assistant to debug (take control of another process) your application. Enter your 

password, and select  Take Control : 
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For more details about running the Platform Assistant, see Running the Platform Assistant 

on  a Mac . 

Step 3: Install Xcode on the Mac 

Xcode  is the development and debug environment on the Mac, and provides the 

required development files for Mac OS X  and iOS applications.  

You can install Xcode from any of the following sources:  

¶ On your "Mac OS X Install" DVD, under Optional Installs , double -click 

Xcode.mpkg  to install Xcode on your system.  

¶ At the Mac App Store , download Xcode for free.  

¶ As a registered Apple Developer, you can download the latest version of Xcode 
as a bundle ( .dmg ). To register and then download Xcode:  

1. Register (free of charge) as an Apple Developer at 

http://developer.apple.com/programs/register/ . 

2. Download Xcode as a bundle from 

https://developer.apple.com/downloads . 

 

Next Steps 

You have configured your Mac  to run an iOS Application on the iOS Simulator . 

Note:  Only Delphi applications can be run on the iOS Simulator . 

C++Builder does not support the iOS Simulator.  

¶ To run an iOS Application now on the iOS Simulator, see Mobile Tutorial: Set Up 

Your Development Environment on Windows PC (iOS)  to complete the 

configuration of your RAD Studio IDE.  

http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_the_Platform_Assistant_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_the_Platform_Assistant_on_a_Mac
http://developer.apple.com/xcode/
http://docwiki.embarcadero.com/RADStudio/XE6/en/Mac_OS_X_Application_Development
http://docwiki.embarcadero.com/RADStudio/XE6/en/IOS_Mobile_Application_Development
http://www.apple.com/mac/app-store/
http://developer.apple.com/programs/register/
https://developer.apple.com/downloads
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¶ To run your iOS Application  on your iOS Device , please use the following steps on 

this page to complete the configuration of your Mac. Note that for Delphi apps 

only, you can perform these steps after you test an application on the iOS 

Simulator . 

 

Additional Steps to Configure Your Mac 
to Run Your iOS Application on Your iOS 
Device 
The following additional steps enable you to run your iOS Application on your iOS 

Device . 

 

 

 

Step 1: Install the Xcode Command Line Tools on a Mac 

To install the necessary Xcode tools using Xcode on the Mac:  

1. Start Xcode on the Mac.  

2. Choose Preferences  from the Xcode menu.  

 

3. In the General panel, click Downloads . 

4. On the Downloads window, choose the Components  tab.  
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5. Click the Install  button next to Command Line Tools .  

You are asked for your Apple Develop er login during the install process.  

For more details, see Installing the Xcode Command Lin e Tools on a Mac . 

 

Step 2: Sign Up for a Developer Account 

Membership in one of the iOS developer programs is a requirement for building, 

running, debugging, and deploying applications for iOS.  

You can join a developer program  in either of the following ways:  

¶ As an individual developer.  

¶ As a member (or leader) of a team in an enterprise (business) program or 

university program.  

For more details, see Joining an iOS Developer Program . 

Step 3: Request, Download and Install Your Development 
Certificate 

Applications that are deployed on the device (or on the iOS Simulator) need to be 

cryptographically s igned before they run. The Development certificate  contains 

information that is needed for signing the applications. Each individual (an individual 

developer or a team member) must have a unique development certificate, which 

can be used for multiple appli cations.  

For development teams, development certificates must be requested by each team 

member, and these requests must be approved by a team admin.  

 

http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Xcode_Command_Line_Tools_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Joining_an_iOS_Developer_Program
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Request, Download and Install Your Certificate 

1. In the Keychain Access application on your Mac, select from  the Keychain 

Access menu: Certificate Assistant > Request a Certificate From a Certificate 

Authority:  

 

Save the certificate request as a file, and then send it to your Certificate 

Authority by uploading it in the Apple iOS provisioning portal . 

o If you are a development team member for a corporate/organization 

program, your team administrator needs to approve your request. After 

your team administrator approves it, you can download the certificate.  

o If you are an individual developer, you should see a download option for 

your certificate shortly after you request it. See Apple documentation at: 

Creating signing certificates  for details.  

2. Go to iOS Provisioning Portal . You can download the Development certificate 

after the status changes from Submitted  to Issued :  

 

3. Launch the Development Certificate by double -clicking it. It automatically loads 

in the Keychain Access  application.  

https://developer.apple.com/ios/my/certificates/index.action
https://developer.apple.com/library/ios/documentation/Security/Conceptual/CodeSigningGuide/Introduction/Introduction.html
https://developer.apple.com/ios/my/certificates/index.action
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Step 4: Register Your Device for Deployment 

Before a device can run user applications, it must be regi stered in the Apple 

Provisioning Portal . Devices are registered by their Unique Device ID (UDID). The UDID 

can be determined using Xcode, as follows:  

1. Make sure your iOS device is connected to your Mac machine.  

2. Open Xcode and go to Organizer ( Window > Organizer ). 

3. In the Devices  tab, click on your device.  

4. Next to the Identifier  label is a string of characters:  

 

The Identifier string represents your device's UDID.  

o If you are an ind ividual developer, register your device by adding the 

UDID in the Devices tab of the Apple Provisioning Portal . 

o If you are part of a company/organization, ask your team admin to 

register  your device.  

Step 5: Create and Install a Provisioning Profile 

Provisioning profiles are used for linking a developer and devices to a development 

team. This provisioning profile is required for running applications on an iOS device.  

¶ If you are an individ ual developer, you must create a provisioning profile. For 

specific information, see: Creating and Downloading a  Distribution Provisioning 

Profile. 

¶ If you are part of a company/organization, your team admins must create a 

provisioning profile that you can use.  

After your provisioning profile is created, you must install it into Xcode, as follows:  

1. Open Xcode on the M ac and go to the Organizer ( Window > Organizer ). 

2. In the Library  section, select Provisioning Profiles  and click Refresh. 

3. Xcode asks you to sign in with your Apple ID. Enter your credentials and select 

Log in .  

The provisioning profiles available to you are  installed into your Xcode:  

https://developer.apple.com/ios/my/devices/index.action
https://developer.apple.com/ios/my/devices/index.action
https://developer.apple.com/ios/my/devices/index.action
https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppStoreDistributionTutorial/Introduction/Introduction.html
https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppStoreDistributionTutorial/Introduction/Introduction.html
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4. Select a valid iOS provisioning profile and drag -and -drop it into the Provisioning 

profiles of your test device.  

 

You have configured your Mac to run your iOS Application on your iOS Device . 

To run your iOS Application, please  see Mobile Tutorial: Set Up Your Development 

Environment on Windows PC (iOS)  and complete the configuration of your RAD Studio 

IDE. (If you have config ured your PC as part of running your application on the iOS 

Simulator , you can skip this step.)  

See Also 

¶ Mobile Tutorial: Set Up Your Development Environment on Windows PC (iOS)  

¶ Mobile Tutorial: Creating a FireMonkey Mobile Application (iOS and Android)  

¶ paserver, the Platform Assistant Server Application  

¶ Installing Xcode on a Mac  

¶ Installing the Xcode  Command Line Tools on a Mac  

¶ Installing the Platform Assistant on a Mac  

¶ Running the Platform Assistant on a Mac  

¶ Useful Apple Web Pages:  

o Apple De veloper Program  

o iOS Developer Program  

o Creating and  Configuring App IDs  

o Creating signing certificates (Code Signing Guide)  

o iOS Provisioning Portal (Requires your Apple Developer login)  

http://docwiki.embarcadero.com/RADStudio/XE6/en/PAServer,_the_Platform_Assistant_Server_Application
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_Xcode_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Xcode_Command_Line_Tools_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Platform_Assistant_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_the_Platform_Assistant_on_a_Mac
https://developer.apple.com/programs/start/standard/
https://developer.apple.com/programs/ios/
https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppDistributionGuide/MaintainingProfiles/MaintainingProfiles.html
https://developer.apple.com/library/ios/documentation/Security/Conceptual/CodeSigningGuide/Introduction/Introduction.html
https://developer.apple.com/ios/my/certificates/index.action
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o Devices tab of the Apple Provisioning Portal  

o Create an Apple ID  

o Crea ting and Downloading a Distribution Provisioning Profile  

https://developer.apple.com/ios/my/devices/index.action
https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/wa/createAppleId
https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppDistributionGuide/MaintainingProfiles/MaintainingProfiles.html#//apple_ref/doc/uid/TP40012582-CH30-SW1
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Mobile Tutorial: Set Up Your 
Development Environment on Windows 
PC (iOS) 
 

Before starting this tutorial, you should read and perform the following tutorial session:  

¶ Mobile Tutorial: Set Up Your Development Environment on the Mac (iOS)  

 

A FireMonkey application destined for the iOS target platform can be tested initially on 

the iOS Simulator  available on the Mac. The second half of the testing process uses the 

iOS Device  target platform and requires a test iOS device connected to the Mac.  

Note:  On iOS devices, you can run both Delphi and C++ applications. However, 

the iOS Simulator  is not supported by BCCIOSARM. Only iOS devices are 

supported by BCCIOSARM.  

To deploy an iOS Application  to your device for debugging and testing purposes, RAD 

Studio uses the Platform Assi stant , which you must install and run on the Mac.  

 

This section describes the steps to set up your development environment after  you 

configure your environment on your Mac.  

Setting Up Your RAD Studio Environment 

The following configuration steps accelerate the iOS development with RAD Studio.  

Create a Connection Profile for the Mac 

1. Open Too ls > Options > Environment Options > Connection Profile Manager . 

2. Select Add :  

http://docwiki.embarcadero.com/RADStudio/XE6/en/BCCIOSARM.EXE,_the_C%2B%2B_Compiler_for_the_iOS_Device
http://docwiki.embarcadero.com/RADStudio/XE6/en/PAServer,_the_Platform_Assistant_Server_Application
http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Platform_Assistant_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_the_Platform_Assistant_on_a_Mac
http://docwiki.embarcadero.com/RADStudio/XE6/en/Create_a_Connection_Profile
http://docwiki.embarcadero.com/RADStudio/XE6/en/Connection_Profile_Manager
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3. Now you see the Create a Connection Profile  wizard. Define a name for the 

connection profile, such as "My Mac".  

Make sure you select OS X as the platform, and then click Next :  

http://docwiki.embarcadero.com/RADStudio/XE6/en/Create_a_Connection_Profile
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4. On the Remote machine information  page, set the name or IP address of the 

host Mac, a port number to use (the default port 64211 typically works), and an 

optional password (if you want to use a password).  

5. Click Test Connection  and make sure that the connection prof ile succeeds with 

no error (you should receive the message "Connection to <hostname> on port 

<portnumber> succeeded" ). 

6. If the Test Connection  succeeds click the Finish button, otherwise check the 

settings and try again.  
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Add an SDK to the Development System for the iOS Device Connected to 
the Mac 

1. Open Tools > Options > Environment Options > SDK Manager :  

http://docwiki.embarcadero.com/RADStudio/XE6/en/Adding_a_Mac_OS_X_or_iOS_Device_SDK
http://docwiki.embarcadero.com/RADStudio/XE6/en/SDK_Manager
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2. Select Add . 

3. On the Add a New SDK  dialog box, select iOS Device  as a platform.  

4. Select a Platform to connect (such as the "iOS Device"):  
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5. After you select a platform, the IDE fills a Profile (such as "My Mac") and SDK 

version combo box with the list of SDK versions available on the machine where 

the Platform Assistant server is running:  

 

Click OK to close the dialog.  

See Also 

¶ Mobile Tutorial: Creating a FireMonkey Mobile Application (iOS and Android)  

¶ Working with a Mac and a PC  

¶ Running Your iOS Appl ication on an iOS Device  

¶ Running Your iOS Application on the iOS Simulator  

¶ FireMonkey Platform Prerequisites  

¶ Creating an iOS App  

¶ Mac OS X Application Development  

¶ Creating a FireMonkey Application  

¶ Apple developer.apple.com pages  

o iOS Developer Library  

o iOS Developer Library: Getting Started  

o iOS Dev Center  

o Provisioning an iOS Device  

o Preparing Your iOS App for Distribution in the App Store  

http://docwiki.embarcadero.com/RADStudio/XE6/en/Working_with_a_Mac_and_a_PC
http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_Your_iOS_Application_on_an_iOS_Device
http://docwiki.embarcadero.com/RADStudio/XE6/en/Running_Your_iOS_Application_on_the_iOS_Simulator
http://docwiki.embarcadero.com/RADStudio/XE6/en/FireMonkey_Platform_Prerequisites
http://docwiki.embarcadero.com/RADStudio/XE6/en/Creating_an_iOS_App
http://docwiki.embarcadero.com/RADStudio/XE6/en/Mac_OS_X_Application_Development
http://docwiki.embarcadero.com/RADStudio/XE6/en/Creating_a_FireMonkey_Application
http://developer.apple.com/library/ios/navigation/
http://developer.apple.com/library/ios/navigation/index.html?section=Resource+Types&topic=Getting+Started
http://developer.apple.com/devcenter/ios/index.action
https://developer.apple.com/library/ios/recipes/xcode_help-devices_organizer/articles/provision_device_for_development-generic.html
https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppDistributionGuide/Introduction/Introduction.html
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o iAd Network  

http://developer.apple.com/iad/
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Mobile Tutorial: Set Up Your 
Development Environment on Windows 
PC (Android) 
 

The largest  part of the testing process of a FireMonkey application destined for the 

Android  target platform uses the Android Device  target platform and requires a test 

Android device connected by USB cable to your development system. You can 

optionally test your app lication on an Android Emulator  running on the Windows 

development platform. You do not need to use the Platform Assistant  in developing 

apps for the Android target platform. ( PAServer is, however, required for developing 

Mac OS X and iOS apps.)  

Note:  If you install the Android development tools during your RAD Studio 

installation, Installing the USB Driver for Your Android Device  is the only setup step 

described here that you need to perform on your PC.  

After you complete either this tutorial or the one required step , your next steps 

are to:  

¶ Enable USB debugging on your Android device  

¶ Configure your system to detect your Android device  

Setting Up Your RAD Studio Environment 

The following Android development tools are insta lled on your development system 

during RAD Studio installation:  

¶ Java Development Kit (JDK)  

¶ Android Software Development Kit (SDK)  

¶ Android Native Development Kit (NDK)  

http://docwiki.embarcadero.com/RADStudio/XE6/en/PAServer,_the_Platform_Assistant_Server_Application
http://docwiki.embarcadero.com/RADStudio/XE6/en/PAServer,_the_Platform_Assistant_Server_Application
http://docwiki.embarcadero.com/RADStudio/XE6/en/Enabling_USB_Debugging_on_an_Android_Device
http://docwiki.embarcadero.com/RADStudio/XE6/en/Configuring_Your_System_to_Detect_Your_Android_Device
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Android Development Tools Are Installed with RAD Studio 

 

We recommend that you install the Android development tools using our product 

installer. However, if you already have the Android development tools installed on your 

system, or if you want to install the tools yourself, you can choose to skip this step in the 

installer. For specific instructions on installing the Android development tools yourself, 

see Installi ng the Android Development Tools . 

http://docwiki.embarcadero.com/RADStudio/XE6/en/Installing_the_Android_Development_Tools
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Default Installed Locations of the Android Development Tools 

Tool Default Location  

Java 

Developme
nt Kit (JDK) 

C: \ Program Files \ Java \ jdk1.7.0_25  

Android 

Software 

Developme
nt Kit (SDK) 

C: \ Users \ Public \ Documents \ Embarcadero \ Studio \ 14.0 \ PlatformSDKs \ adt

- bundle - windows - x86 - 20131030 \ sdk  

Android 

Native 

Developme
nt Kit (NDK) 

C: \ Users \ Public \ Documents \ Embarcadero \ Studio \ 14.0 \ PlatformSDKs \ and

roid - ndk - r9c  

Adding Your Android SDK in Tools Options > SDK Manager 

Important:  

¶ If the Android SDK and NDK are installed during the RAD Studio installation, 

your Android SDK should be automatically discovered by the RAD Studio 

SDK Manager , and you do not need to perform this step. Proceed to the 

next step: Installing the USB Driver for Your Android Device . 

¶ If you installed the Android SDK and NDK yourself, you nee d to perform this 

step so that RAD Studio can build apps that target Android devices.  

1. Select Tools > Options > Environment Options > SDK Manager .  

Here is the SDK Ma nager when it is fully populated with the recommended 

Android SDK:  

http://docwiki.embarcadero.com/RADStudio/XE6/en/SDK_Manager
http://docwiki.embarcadero.com/RADStudio/XE6/en/SDK_Manager
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Note:  

o The SDK Manager  fields are blank if the SDK Manager cannot detect the 

default installed Android SDK and you have not yet added an Android 

SDK to the SDK Manager.  

o Fields that are marked with do not have the correct path. Click the [...] 

in that field and browse to the in stalled location of the library files.  

2. Click Add . 

3. On the Add a New SDK  dialog box, click the down -arrow in the Select an SDK 

version  field, and select Add New...  from the drop -down list:  

 

http://docwiki.embarcadero.com/RADStudio/XE6/en/SDK_Manager
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Note:  If your installed Android SDK is listed in the Select an SDK  version  list, select 

your Android SDK.  

4. The Create a new Android SDK  wizard is displayed.  

o Complete the first two fields on this wizard: Android SDK Base Path  and 

Android NDK Base Path  (their installed locations). Either enter the paths of 

the installed lo cations or click the ellipsis [...] and navigate to the installed 

locations.  

o The symbol indicates that the base paths are missing, and the Next  

button is enabled only after these fields are filled.  

o Here is the wizard when no SDKs have been added and the b ase path 

fields are empty:  

 

This wizard verifies the base paths you specify and then auto -populates the paths 

to the various other libraries (that is, the tools on page 2 of the wizard).  

Thus, you might need to enter only the base paths for the NDK and S DK, on page 

1 of the wizard. Then the second page will auto -populate, if given a little time. Or 

you might need to verify the auto -populated addresses (if they are present).  

o Here is the first page of the wizard after you browse to (or enter) the paths 

to t he Android SDK and NDK. There are no icons because the paths 

have been verified.  
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5. Click Next  to go to the next page of the wizard, where the wizard will attempt to 

prefill the fields by discovery.  

o Here is the second page of the wizard with all its fiel ds prefilled:  

 

o For any fields that do not prefill, click the ellipsis [...] button and browse to 

the installed location.  

6. Click Finish to close the wizard.  


