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INTRODUCTION TO EMBARCADERO’S
PERFORMANCE CENTER
Performance Center is a database monitoring application that allows for quick problem
determination, ensuring both availability and performance. Its intuitive interface and 24x7
architecture addresses the problems of managing medium to large database installations by
relatively few database administrators (DBAs).
Performance Center is uniquely designed to help DBAs address performance on an enterprise
level. This is done through several key components. First is the Health Index, which is one easyto-read statistic that conveys the overall health of a database. Next is the Enterprise view, which
allows you to check both database availability and performance from one central location. The
Alarm Center provides a query mechanism that can scan all of your monitored datasources for
thresholds that have been violated, eliminating the need to check for problems on a databaseby-database basis. Finally, the Web monitoring capabilities of Performance Center allow DBAs
to monitor their database environment from any standard Web browser, with no client software
needing to be present on the workstation being used. These features, combined with historical
reports, easy navigation, robust notifications, and many others, make Performance Center a tool
that will increase the efficiency and productivity of any database administrator.

PRODUCT BENEFITS BY AUDIENCE
DATABASE ADMINISTRATORS
Performance Center is critical for organizations concerned with proactively
ensuring that databases are running at peak efficiency, while at the same time
providing a way to quickly resolve problems when they do occur. With its
intuitive approach to problem determination combined with expert help for
every monitored statistic, even intermediate to novice DBAs can become
extremely productive. Solving problems using the expert help recommendations,
as well as observing the many things that can cause performance degradation,
actually serves as a tutorial for less experienced administrators. For the advanced
DBA who simply cannot be everywhere at once, Performance Center’s
customization allows him or her to effectively have a set of virtual eyes on a vast
array of databases at one time.

DATABASE ADMINISTRATOR MANAGEMENT
Getting a handle on precisely how well a company’s databases are performing is
often quite challenging. There is a real tendency for users to think that the
databases are always the cause of a performance problem, even when many
other factors may be at work. Moreover, defending Service Level Agreements is
often impossible due to the lack of real-world data showing things like database
availability. With Performance Center’s Historical Reports, all this information
(and much more) can be easily captured and presented at an executive summary
Embarcadero Technologies
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level. This information is valuable not only to management, but also the DBA
who may realize that a certain database performed poorly over the past month
and may require more attention in the short term.

ABOUT THIS EVALUATION GUIDE
This evaluation guide is intended to help you get started using Embarcadero’s Performance
Center.
After completing this evaluation guide, you will have the foundation you need to explore the
many features and benefits of Performance Center against your own databases. You will have
learned how to add datasources for monitoring, view your monitored datasources at an enterprise
level, set thresholds and alarms for statistics, drill down into problems to obtain more granular
information, and generate historical reports. You’ll also have become familiar with some
frequently used navigational techniques and customization options.
This guide is divided into seven sections:
Session 1: Getting Started with Performance Center
Session 2: Adding Monitored Datasources to Performance Center
Session 3: Monitoring the Enterprise
Session 4: Using SQL Text Capture
Session 5: Configuring and Using Thresholds
Session 6: Configuring and Using the Health Index
Session 7: Researching Problems and Determining Courses of Action
Session 8: Generating Historical Reports
Session 9: Using the Web Client
Once you’ve started, you can
select Help from the toolbar to
find many additional resources
that complement and build on
many of the activities shown in
this brief guide.
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SESSION 1: GETTING STARTED WITH PERFORMANCE CENTER
GETTING THE PRODUCT
You can obtain the latest version of Performance Center by visiting the Embarcadero
Web site at http://www.embarcadero.com/downloads and filling out the product
request form. Upon submission, an Embarcadero representative will contact you with
information on receiving an evaluation copy of the product. When you first install an
evaluation copy of Performance Center, you can use the tool for 14 days. After that
time, a permanent license is needed.

ARCHITECTURAL OVERVIEW
The following graphic illustrates the elements of the Performance Center architecture. If
you choose to do so, you can run all components of Performance Center on the same
machine, but be advised that doing so results in a substantial load on system resources.
Therefore, you will want to ensure that the machine has adequate memory (RAM) and a
fast processor.
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INSTALLATION
Due to the distributed nature of Performance Center, taking a few moments to read the
installation guide prior to running the setup.exe installer eliminates a lot of potential
problems.
As you read through the installation guide the number of prerequisites for Performance
Center may seem extensive, but keep in mind two things:
1) Most are standard Microsoft Windows™ components, all of which are actually
included with Windows 2000™; and
2) The installation program does all the work when it comes to the prerequisites.
Should you find yourself in a situation where you do need assistance, simply open a
case with our support staff at http://www.embarcadero.com/support/open_case.jsp and
they will be glad to assist you with your installation issues.

PRODUCT NAVIGATION
The following graphic represents the navigation basics of the Performance Center client
application.
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Enterprise view presents all
monitored datasources in one,
concise window. Using the Health
Index, you can quickly determine
which databases need attention.

Explorer allows browsing of
individual datasources. Color-coded
icons quickly show threshold
violations

DifferentOutput window
shows Status, Notifications
and Enterprise Alerts and
the date and time on which
they were fired.

Tabbed monitoring
windows allow for quick
navigation between
datasources.

If you want to just monitor the activity of the databases that Performance Center is
polling, you can also use your Internet Explorer browser in conjunction with the
Performance Center Web Client. For more information on the Web Client go to
Session 9.
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Note: The URL shown in the graphic above shows a connection to a Performance Center server
named “cswkbro03”.

SESSION 2: ADDING MONITORED DATASOURCES TO
PERFORMANCE CENTER
When you first launch the Performance Center client, it automatically prompts you to
register a datasource for monitoring. If you are adding additional datasources to your
environment, you can invoke the Register Datasource window by selecting Datasource
> Register.
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DEFINING THE DATASOURCE
The Datasource Name drop-down list is populated with the Oracle, Sybase, etc.,
datasources (as determined by selecting the Datasource Type) defined on the
Performance Center server. This means that you must first add all datasources to be
monitored to the Performance Center server’s database client configuration files.
Once you select the datasource for monitoring, you are prompted to enter a database
server’s DBA account. This is necessary so Performance Center can create the required
objects on the monitored datasource, and grant the correct privileges to the monitoring
user.
The User ID and Password fields are those of the monitoring user. This is the user
interacting with the Performance Center server in the collection of statistics. Any objects
created and used by Performance Center are created under this ID.
Note: If you do not already have a user defined that you would like to use for monitoring,
clicking the New button guides you through a user-creation wizard.

MANAGING DATASOURCES
Once your datasources are added to Performance Center, you have the following
options: Register, Properties, Unregister, Clone, or Purge. To do this type of datasource
management, select Datasource > Manage, highlight the desired datasource, and
then click the desired task option:
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SESSION 3: MONITORING THE ENTERPRISE
Once you have registered your datasources, you can begin to monitor the performance
of your databases. The first place to start is the enterprise screen where you can take
advantage of Performance Center’s Health Index.

USING THE ENTERPRISE VIEW
Performance Center gives you the ability to pinpoint problem databases throughout
your enterprise without the cumbersome task of checking each database individually.
To accomplish this, click the Enterprise tab of the main window (if it is not already the
active tab.)
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Single-click the “Health Index” column heading to sort the health index values in
ascending order. Clicking the heading a second time reverses the sort. By sorting in this
fashion, you can see which datasources are performing well and which are not, all from
one convenient window. You can also sort by any of the columns on this screen simply
by clicking the desired column heading.
The Enterprise view accurately conveys the status of your databases by telling you not
only the status of the datasource, but also the status of the listener as well. Without a
valid listener, the database may as well be considered down to the users on your
network.
The Current Alarms column indicates whether any alarms have been fired for the given
datasource. (More on Alarms in Session 5.)
Finally, the legend at the bottom explains the meaning of the icons shown in the Name
column for each datasource.
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EXAMINING INDIVIDUAL DATASOURCES
There are a couple of ways to narrow your observations to a specific datasource. The
first is to double-click one of the datasources in the Enterprise view. The second
involves using the Explorer.
To activate the Explorer Tree, select View >
Explorer. In the Explorer Tree, right-click on a
datasource and select View from the pop-up
menu for the desired datasource.

When an individual datasource is viewed, that page is opened as an additional tab in
the main viewing area as shown below (note the tabs on the bottom of the screen).
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You can switch between the Enterprise and other datasource views by clicking the
desired tab.
When a monitoring window is invoked for a particular datasource, the first view you see
is the overview homepage for that datasource. The overview homepage is a composite
picture of the most useful statistics from each category used in determining the
performance of your database.
In addition to this overview, there are seven homepages that group statistics into the
following categories:
•
•
•
•
•
•
•

Memory
I/O
Space
Databases
Contention
Users
Network.
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You navigate to a particular category by clicking one of the eight categories on the
navigation bar.

HOMEPAGE HEADINGS
Each homepage has a heading area that relays information about the given category as
well as some general information about the monitored datasource.

The category that is currently active appears in the title after the name of the monitored
datasource. For example, in the preceding graphic, the I/O homepage for the
TORLABSQL00_2 datasource is displayed.
Where applicable, each homepage displays a Health Index specific to that category. It
is the combination of all the categorical Health Indexes that compose the overall Health
Index for the datasource. (More on how this works, and how to customize it, in Session
5.
Looking at the upper-right corner of the heading, you will find the Alarm icon. These
operate at the monitored datasource level and can be accessed from any of the
homepages. Likewise, the “Server Up Since” and the “Last Updated” statistics just
below the category headings apply to the datasource in general and not to a specific
category. “Last Updated” indicates the last time that the Performance Center client
information was refreshed by the Performance Center server.
Note: If you are running a SQL Server datasource, the SQL Server Logs icon also appears in the
upper right corner.

Explore the various homepages to see the different statistics that Performance Center
monitors. In Session 6, we explore how to use the drill-down functionality of the
Performance Center home pages in order to gather more granular information for each
statistic.

SESSION 4: USING SQL TEXT CAPTURE
SQL Text capture is a pro-active root-cause analysis tool and is now available in a 24/7
environment. It is an alert-based trackable instance of events. The information
captured is stored in the repository for future analysis. The SQL Capture is triggered by
a threshold violation. When such a violation occurs, a SQL Capture session is triggered
and collects performance-related data for the SQL running currently on the datasource
that fired the threshold.
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You can set up how the notification takes place. As long as an alert is open you will
receive notification based on the interval you set up.

TO SET UP THE SESSION LENGTH:
1. Select Monitor > Server Options.
2. Click SQL Capture.
3. Set the SQL capture interval. The default is 30 minutes.

4. You can also set the Cooldown period. This setting determines how long to wait
between consecutive capture sessions on a given data source. When an alert is
triggered, if there is no existing SQL Capture Session on that data source,
Performance Center checks to see when the last session ended. A new SQL
Capture Session will not be started if the previous session’s cool down period is
not over.

TO SET UP THE CAPTURE INTERVAL:
1. In the Datasources tree, right-click the registered datasource you want to set the
interval for and click Properties.
2. In the Register Datasource dialog, click Advanced.
3. Set the interval time and click OK. The default is 30 minutes.
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TO SET A SQL CAPTURE SESSION ON AN INDIVIDUAL ALERT:
1. Click Datasource > Alert Maintenance.
2. In the Datasource Alert Maintenance dialog right-click the statistic you want to
monitor and click Edit.

3. In the Alert Properties dialog select the SQL Capture option and click OK.
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4. When you select the SQL Capture option and click OK, a message appears
asking if you want to test the selected data sources.

5. Click Yes and after a brief moment the message closes. You will not get a
confirmation on the compatibility. You will only get a warning message if it is not
compatible.
6. When an alert occurs on your selected statistic, an e-mail is generated.
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TO GAIN ACCESS TO THE CAPTURED INFORMATION:
1. In the Datasources tree, double-click Profiled SQL.

2. In the SQL Profiling Session that opens for the selected datasource, select an
Alert Name from the list box and click Find.
Note: You can also use a session ID as a search criteria.
3. Select the result that you want information on and click View Details.
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4. In the Details tab that appears, you can scroll through the session details that
have been generated. Note the color-coding of the Activity column allows you
to quickly identify the type of activity.
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TO ENABLE SYBASE ASE 12.5 FOR SQL CAPTURE:
Sybase ASE 12.5 must enable SQL Capture if you want to use the capture function in
Performance Center. Take the following steps to ensure that the SQL Capture feature is
activated for Sybase ASE:
1. Enable the following System Configuration settings:
• Enabling Monitoring
• Wait Event Timing
• Max SQL Text Monitored
• SQL Batch Capture
Examples:
sp_configure
sp_configure
sp_configure
sp_configure

"enable monitoring", 1
"wait event timing", 1
"SQL batch capture", 1
"max SQL text monitored", 4096* *

Note: This is the maximum length for SQL text stored by Sybase, but we suggest
4096 as a good starting point.
2. Grant the user mon_role.
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3. Install the Sybase MDA tables (Sybase official documentation has directions these should only be installed by a DBA).
•
•
•
•

If the monProcess table is missing, the user will not be able to see currently
connected sessions.
If the sysprocesses table is missing, the user will not be able to see
information about Adaptive Server processes.
If the monWaitEventInfo table is missing, the user will not be able to see
information about wait events.
If the monProcessSQLText table is missing, the user will not be able to see
currently executing SQL statements.

Example:
isql -U sa -P yourpassword -S YOURSERVER -i
$SYBASE/$SYBASE_ASE/scripts/installmontables

SESSION 5: CONFIGURING AND USING ALERTS
Performance Center provides you with a template of default Alerts for the database
platforms you are monitoring upon installation. However, you may need customized
Alerts for your particular installations. With Performance Center you can customize your
alerts on a per-datasource basis, or apply the same template to a group of datasources,
in order to gain maximum flexibility in your monitoring solutions. We will now look at
various ways to configure these alerts.

ADMINISTERING ALL DEFAULT ALERTS FOR A DATASOURCE
1. Select the desired datasource by either
a. Clicking it in the Explorer Tree
b. Clicking it in the Enterprise view screen
c. Selecting it from the drop-down list just below the main menu.
2. From the main menu select Datasource > Alerts Maintenance to open the
following screen:
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If you want to operate on a different datasource, you can do so from this screen by
selecting it from the Datasource drop-down list.
As you can see, you can have several alerts for a single statistic. Looking at the
preceding graphic of the default alert template shows how the severity of the violation
increases as the statistic strays further away from its optimum value. For example, the
Bufferpool Index Hit Ratio is only a Low violation when it is below 90, but it moves to
Critical when it drops below 80.
Let’s say that you want to edit the alert violation for a Bufferpool Index Hit Ratio less
than 90. To do so, you can double-click the alert or single-click it, then click Edit. Either
method invokes the following screen:
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Here you can change any of the conditional settings that compose the alert. The
bottom section allows you to tie the alert to a Notification (such as email, pager, or net
broadcast) or an Action (such as launching a CMD file to take some corrective steps to
solve a problem).
The tree on the left provides a way to easily edit the alert for other datasources to which
it is applied. This means that only datasources that have the given alert applied to them
appears in the list. To apply the alert to a datasource that does not already have it,
select the statistic name at the top of the navigation tree on the left side of the screen
(in the above screenshot, it would be “BufferpoolHit Ratio”) then click Apply for a list of
available datasources to which you want to apply this alert.

ADMINISTERING AN ALERT FOR A SINGLE STATISTIC
Browsing through all of the available statistics for a given datasource can become a
cumbersome task. There are times when you know specifically the statistic that you
want, and you do not want to filter through an entire list to find it. To jump directly to
the alerts for a single statistic:
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1. Right click the statistic from one of
the homepages (or the Explorer
Tree).
2. Select Alerts from the pop-up menu.

This takes you to the same Alerts
Maintenance screen that you were in earlier,
however this time the list of alerts has been filtered to your particular statistic.
You could have accomplished this same filtering by using the Category and Statistic
drop-down lists on the top of the screen. Moreover, if you wish to work with any other
alert, even on another datasource, there is no need to exit this screen. Simply use the
drop-down lists to filter to the desired level.

FINDING REAL-TIME ALERT VIOLATIONS
When an alert is violated, it triggers a Performance
Center “Alarm” that is displayed in several
different ways.
If you are using the Explorer Tree, then the first
thing you notice is that the icons for the categories
containing an alarm changes colors indicating the
severity of the violation. When you expand the
category branch of the Explorer Tree, the specific
statistic in violation is also color-coded. From
there, simply double-click the statistic to take you
to the homepage containing the alarm.
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In addition to the Explorer Tree’s color-coded icons, the headings for the various
homepages also change colors and pulsate when a statistic exceeds its alert values.
Clicking the color-coded heading takes you to the homepage containing the alarm.

And finally, on the homepage
containing the alarm, the statistic in
violation pulsates as well as changes
colors according to the violation
severity.

Note: You can turn off the pulsing action by selecting Monitor > Client Options > Category
and un-checking Show thresholds as pulses.

FINDING HISTORICAL THRESHOLD VIOLATIONS
If you have been away from your Performance Center client for a period of time, or
simply did not have it activated on your workstation, you can quickly determine the
alerts that were violated for any or all monitored datasources using the Alarm
homepage.
To access the Alarm homepage, you can either
click the Alarm icon in the header of any
homepage (shown in graphic on the right), or
double click the Alarm node in the Explorer Tree.
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From the Alarm
homepage, click Get
Alerts to enter the
search criteria. From the
Alarms Criteria dialog,
you can refine your
search as broad or
narrow as you desire.

Note: The Date & Time Range values default to a 15 minute history from the current time.

Once you click OK, the report is then presented in a table format. To sort on any of the
columns, double-click the column heading.

The power behind the Alarm report is that you can determine problems across all of
your monitored datasources without having to interrogate each one individually.
However, for those times when you do want to focus your results to a more detailed
range of parameters, the criteria window allows you to do that as well.
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SESSION 6: CONFIGURING AND USING THE HEALTH INDEX
As mentioned earlier, the Health Index is a powerful feature that conveys the overall
health of a datasource in one statistic. Out of the box, Performance Center provides you
with a default formula for the Health Index based on some general guidelines published
by Embarcadero’s database experts. However, you are probably going to have a few
databases that are specialized in such a way that monitoring their performance requires
customization.

VIEWING CATEGORY HEALTH INDEXES
The Health Index for a datasource is a statistic generated
from five different Health Indexes. To view all of the health
indexes simultaneously, right-click the Health Index node in
the Explorer Tree and select View.

The Health Index homepage displays a graph for each of the category Health Indexes
as well as the main Health Index (upper left) for the datasource.

Embarcadero Technologies

28

CHANGING THE HEALTH INDEX FORMULA
The Health Index for a datasource is computed by a formula involving the category
Health Indexes where a weight is given to each specific category. The first step in
customizing the Health Index is to alter these weights to meet your needs.
As mentioned earlier, Performance Center provides a default template for all
datasources. That default (or system) template is not editable for customization.
Therefore, you must first Clone that template and create your own. Cloning a template
involves making a copy of it, which is easy to do in Performance Center.
Select Maintenance > Health Index Templates to open the following screen:

Highlight one of the templates and click Clone. For our example, we’ll use the Oracle
template.
1. Select the Category Weight that you wish
to change, and then click Edit. The
Clone Template dialog appears.
2. Verify the new template name or enter a
new name and click OK.
3. In the Health Index Templates dialog
select the newly created template and
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click Edit. In this example it is “Copy of Embarcadero SQL Server Health Index
Template”.
4. In the Health Index Template Properties Edit dialog you can adjust the category
weights.

Note that all weights must sum to 100, and at no time during your editing of the values
can the sum exceed 100. This means that you must first decrease a value before
increasing another value. The same logic applies to the Statistic Weights on the right
side of the screen. These are the sub-components that correspond to the highlighted
Category Health Index in the left pane. When you have completed altering the weights
to your desire click OK.

The final step is to apply the new Health Index
Template to the desired datasource(s).
Highlight the new Health Index Template that
you just created, and then click Apply. Select
the desired datasource(s) (using CTRL+click
for multi-select) then click OK. The new
Health Index Template has now been applied
to the datasource(s).
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In the future, you may wish to alter the Health Index formula for a specific datasource
while leaving the template intact. To do this, select Datasource > Health Index. Any
changes you make when using this approach only affects the particular datasource with
which you are working. In contrast, should you go back and edit the Health Index
template (accessed from the Maintenance menu), any changes you make take effect on
all datasources to which that template has been applied.

SESSION 7: RESEARCHING PROBLEMS AND DETERMINING
COURSES OF ACTION
At this point we have covered Alerts and Health Indexes. Now we will look at some
basic things to do once you have determined that one of your databases is not
performing well.
In the following graphic, Performance Center is showing that we have a problem with
the level of query plan requests generated by stored procedures in the Procedure Plan
Hit Ratio.
Note: If you are reading this on a black and white hardcopy, you will not see the color-coding
effects that indicate this problem.
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DRILL-DOWN DATA
If this were the only information that Performance Center provided, a tremendous
amount of manual effort from the DBA would be required to identify exactly what was
causing the problem. For this reason, Performance Center provides you with an
abundant amount of drill-down information for almost every statistic shown on the
home pages. Clicking the Procedure Plan Hit Ratio statistic invokes the following drilldown information.
Note: To access drill-down information for any category, right-click the heading, such as
“Memory.”

Each home page has underlying information that is presented via tabbed grid controls
like the one shown above. For any of these grids, double-click a column heading to sort
the information based on that column.
Performance Center activates the tab most likely to contain the additional information
required to troubleshoot the homepage statistic on which you clicked. Simply click the
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other tabs to view more information pertaining to the general category in question, in
this case, Memory.
Note: In some cases; even the tabbed data has additional drill down information. An example
of this would be the Memory drill-down for Oracle. Much of the initial drill-down data is
presented in terms of Session information (i.e., the Leading Sessions tab). To see additional
details regarding a particular session, double-click the desired session and it invokes another
tabbed grid of information specific to the given session.

EXPERT HELP
If after viewing the drill down information you are still in doubt as to the course of
action, Performance Center provides an Expert Help guide with detailed information on
every monitored statistic for the databases you are monitoring. The Expert Help gives
you a general description of the statistic, what range of values is considered optimal,
and some suggestions on how to fix a problem situation.

To access Help, right-click the statistic
(the actual value, not the title) then select
Help.
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SESSION 8: GENERATING HISTORICAL REPORTS
Performance Center uses the historical information stored in its repository to generate a
series of reports. The report data is accessible regardless whether the Performance
Center client(s) were active or not. As long as the Performance Center Server
component was up and running, data was being collected in the repository.
1. Select Report > Historical to open the Historical Report Wizard.

2. Select a report and then select to either run it immediately or schedule it to run
in the future.

Embarcadero Technologies

34

Note: If you select the schedule option, a modified wizard opens allowing you to set the
beginning and ending time and the number of days to gather data from. Once you have set
the parameters, click Schedule and a Schedule Properties dialog opens.

3. Complete the required information in the wizard and click OK. The report then
appears as a tabbed view.
Most of the reports allow you to narrow down your reporting information using
the report constraints available in the wizard.
The Time Rollup value allows you to control the granularity of your x-axis value.
Therefore, if you are running a report that spans several months, it is probably a
good idea to set the Time Rollup value to Month instead of Day.
Note: The fields that appear in the wizard depend on the report selected.

INSERT GRAPHIC OF REPORT

SESSION 9: USING THE WEB CLIENT
The Web Client enables DBAs and operators to review database performance statistics
from any Web browser without requiring any additional software. The Web Client is
automatically installed on the server machine and can be accessed from any client or
from a remote computer when you type in the URL as long as the Performance Center
is running.
The statistics you see are all visible in the Web Client with the exception of Oracle’s OS
page statistics, so you can how many, and where, alarms have been triggered. You can
also easily review drill-down details by clicking a target statistic.
To access the Web Client from a Performance Center client or server machine, on the
main menu, click View>Web Client.

ACCESSING THE WEB CLIENT
To access the Web Client remotely, type the URL, which would look like:
<http://SERVERMACHINE/webclient>
OR
<http://SERVERMACHINE/perfcntr/ServerManager.dll?RequestPage?Page=Enterp
riseView>.
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Click on a datasource to view the home page for the selected datasource. Each
homepage has a heading area that relays information about the given category as well
as some general information about the monitored datasource. The Web Client provides
you with the same type of drill-down information that is available in the Performance
Center application.

ADDITIONAL EVALUATION RESOURCES
Embarcadero Technologies provides a variety of resources to help support your
evaluation and selection of a performance-monitoring tool for your organization.
Web site
Visit our Web site at www.embarcadero.com for current product and company information,
educational materials and supporting information.

Electronic Documentation
Detailed reference documentation is available on the Performance Center Evaluation CD or
online at http://www.embarcadero.com/resources/documentation.

Online FAQ
Visit the Performance Center online FAQ at
http://www.embarcadero.com/products/performance_center/faq for answers to commonly asked
questions regarding licensing, installation and other helpful topics.

Email Support
You can contact Performance Center support engineers, consultants and engineers directly by
sending inquiries to support@embarcadero.com

Telephone Support
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We encourage you to call us anytime you would like help or have questions during your
evaluation. Please call 415.834.3131 ext. 2, Monday to Friday, 6:00am - 6:00pm PST, Saturday
and Sunday, 8:00am - 5:00 PST.
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