Welcome to ER/Studio Data Architect® 9.1.4  

ER/Studio Home | ER/Studio Documentation | Embarcadero Technical Support | www.embarcadero.com

Read Me Last Updated: August 15, 2012. Any updates to these Read Me notes will be available at docs.embarcadero.com.


Thank you for using Embarcadero ER/Studio Data Architect, previously known as ER/Studio, the award-winning data modeling application for logical and physical database design and construction. ER/Studio Data Architect's (ER/Studio DA) powerful, multi-level design environment addresses the everyday needs of database administrators, developers and data architects who build and maintain large, complex database applications.

ER/Studio DA's progressive interface and processes have been logically organized to effectively address the ease-of-use issues that have plagued data modeling tools for the past decade. The application facilitates your ability to create, understand and manage the mission-critical database designs within an enterprise. It offers strong logical design capabilities, bidirectional synchronization of logical and physical designs, automatic database construction, accurate reverse engineering of databases, and powerful HTML-based documentation and reporting facilities. Before you use ER/Studio, please read the information below.

For instructions and more detailed descriptions of new features in our last major release, see the ERStudioQuickStart.pdf file, in the ER/Studio DA installation Readme directory or download the most-recent guide from Embarcadero's Web site, http://www.embarcadero.com/resources/documentation.html.


WHAT'S NEW IN ER/STUDIO DATA ARCHITECT

What's New in ER/Studio DA 9.1.4

What's New in ER/Studio DA 9.1.3

What's New in ER/Studio DA 9.1

What's New in ER/Studio DA 9.0.1

What's New in ER/Studio DA 9.0


What's New in ER/Studio DA 9.1.4

Updated MetaWizard Import Bridge

A new option on the second page of the Import MetaWizard, Summary Lineage allows you to choose how ETL Activity Summary mappings are imported into ER/Studio Data Architect.

ETL mapping metadata is generally imported and summarized at the level of OMG CWM Activities (Informatica Workflow, DataStage Container). Such ETL Activity summary indicates which source tables and columns are related to which target tables and columns, whenever summarization is possible.

ETL Activity summary is represented in ER/Studio as a DataFlow, and it may contain a large number of source and target table components.


What's New in ER/Studio DA 9.1.3

Graphically Understand and Interactively Explore Data Lineage with ER/ETL

ER/ETL works through the ER/Studio Import External Metadata functionality to automatically import complex and challenging ETL transformations as a visual diagram that can be stored in and made available from ER/Studio Repository. Making this visual data lineage accessible from ER/Studio Portal gives you the ability to document, report, and search across all imported and documented ETL transformations from a single source. Labor-intensive documentation tasks disappear and data governance reporting gets so much easier and the ability to quickly and more accurately interpret large volumes of data becomes a reality.

ER/ETL imports from all major ETL tools to ER/Studio DA including:

ER/ETL allows you to import ETL transformations from the ETL platforms listed above to ER/Studio 9.1.3 and higher.

Add-on licenses for each ER/ETL platform are available from sales@embarcadero.com


What's New in ER/Studio DA 9.1

Customer requests continue to guide us in our quest to bring to market the best database tools available. Thank you for your support.

Database Support Improvements


What's New in ER/Studio DA 9.0.1

User Interface Improvement

Double-click behavior on the Where Used tab of the Table Editor and Entity Editor can be controlled by the Tools > Options > Where used tab so that double-clicking an object will either bring up the object editor or the user-defined mapping editor.

DB2 z/OS Support Improvement

For DB2 z/OS physical models a new Generated by Default option is available for ROWID columns and columns marked as IDENTITY columns. That option is also available for TIMESTAMP data types to indicate a "row change timestamp" column.


What's New in ER/Studio DA 9.0 and ER/Studio Repository 6.0

Additional Operating System Support

ER/Studio DA and ER/Studio Repository now support Windows 7, 64-bit mode in addition to 32-bit mode.

Additional Platform Support

ER/Studio DA now fully supports Netezza 4.6 and 5.0.

User Interface Improvements

Denormalizations are no longer displayed in the Data Model Tree, denormalizations such as Horizontal and Vertical Splits, and Rollups and Rolldowns, are maintained with the table data and appear on the Where Used tab of the Table Editor. From the Where Used tab you can see the denormalization history of the table. You can also edit and delete denormalization mapping from the Where Used tab. For more information, see the "Denormalization" section in the ER/Studio Data Architect User Guide or online help.

ER/Studio Repository Performance Improvements

ER/Studio Repository software is now multi-threaded, enabling some processes to occur concurrently. The following describes some important rules that affect multi-threading on the Repository:


Release Notes

Important Installation Notes

Important Advisory Notes

Known Issues

Bug Fixes

Upgrade Instructions

Upgrading ER/Studio DA

Upgrading ER/Studio Repository

Additional Resources

Embarcadero Technologies Technical Support

Release Notes

Important Installation Notes

Known Issues
ERS-19014When merging tables of a Netezza model, the Repository does not detect the RANDOM flag on the Distribution tab.
ERS-19140The Distribute On Random property is not applied to the diagrams on the Review Changes Window when merging a diagram to the Repository.
ERS-19199The Sybase ASE 15.x client is not yet supported
ERS-19221Support for ROW SECURITY has not yet been implemented for Netezza.
ERS-19252Denormalization and User mapping changes are still under construction.
ERS-19268Editing an associative table after breaking the link to the corresponding non-specific relationship in the physical model can lead to data corruption.
ERS-19274Repository Log In hangs when the Repository database server is down.
ERS-19308The edit data lineage source/target mapping dialog comes up slowly.
ERS-19429Denormalization Mappings are not displayed properly in the Repository Review Changes dialog.
ERS-19562In the Edit Mappings dialog, applying an attachment to one table involved in a Denormalization Mappings will apply the attachment to all tables in the mapping.
ERS-20513The options to reverse-engineer View and Other Dependencies are not saved in Quicklaunch files.
ERS-21620On occasion, after registering ER/Studio with an ER/ETL license, the new license might not be recognized by ER/Studio. To resolve theis issue, go to License Selection and then to License Manager and add or register the license.

Bug Fixes

Use your browser Find feature to locate a particular bug number or click a link below to see the issues addressed in a specific build.

Bugs Fixed in ER/Studio DA 9.1.2

Bugs Fixed in ER/Studio DA 9.1.1

Bugs Fixed in ER/Studio DA 9.1

Bugs Fixed in ER/Studio DA 9.0.1

Bugs Fixed in ER/Studio DA 9.0

Bugs Fixed in ER/Studio DA 9.1.2
ERS-20396Verb phrases now maintain their relative position to the relationship line when a relationship is moved.
ERS-20999Relationships on top of shapes can now be selected.
ERS-21124ER/Studio now remains stable when using the Microsoft Office 97 or XP toolbar styles.
ERS-21185Verb phrases now maintain their relative position to the relationship line when the relationship layout option is changed.
ERS-21278Relationships based on Alternate Keys are now reverse-engineered properly.
ERS-21327Diagrams that contain procedures referencing invalid views can now be added to the Repository.
ERS-21330Diagramming performance in the Visual Data Lineage pane has been improved.

Bugs Fixed in ER/Studio DA 9.1.1
ERS-4509The Results page in the Compare Wizard is now displayed properly when the system's DPI mode is set to 133%.
ERS-11244ER/Studio now handles memory usage better when saving large files.
ERS-17453ER/Studio now properly imports DB2 iSeries SQL scripts that contain RCDFMT in the CREATE TABLE statements.
ERS-17454ER/Studio now properly imports DB2 iSeries SQL scripts that contain RENAME TABLE statements.
ERS-18161Review Changes now properly handles checking in domains with UDT's as datatype overrides.
ERS-18260Reverse-engineering of Dbase databases is now supported.
ERS-18373The View parser now supports delimited single-quote characters.
ERS-18472The DB2 View parser now supports the ORDER clause.
ERS-18585The Datatype Mapping control in the Model Options dialog now also reads in the Datatype Mapping files from the user specified location in Tools->Options->Directories.
ERS-18586The Automation Interface now allows users to modify the External File Path value of an attachment with a URL string
ERS-18637The Entity Editor now allows adding columns to Flat File data lineage models.
ERS-18734Chinese characters are now displayed properly in RTF reports.
ERS-19116The Index.Owner automation property is now returned properly in Oracle models.
ERS-19126Name case differences are now detected properly in the Compare Merge.
ERS-19137View aliases are now Merged properly.
ERS-19186The GenDDLUsingFileBasedQuickLaunch automation method now excludes tables marked as Do Not Generate.
ERS-19257The Entity Editor no longer changes COUNTER columns to INTEGER.
ERS-19315View comments are now Merged properly.
ERS-19745The DB2 View parser now supports the ORDER clause.
ERS-19746The View parser now retrieves the correct columns from nested SELECT clauses.
ERS-19747The View parser no longer generates "invalid field name found during comparison" errors.
ERS-19770Entities with font/color overrides are now copied and pasted properly.
ERS-19958Column datatypes are no longer merged when the option to compare datatypes is turned off.
ERS-20024ER/Studio no longer includes hidden associative entities when checking for name uniqueness in a physical model.
ERS-20027The Model Validation Wizard no longer considers a space to be an invalid character in logical and generic physical models.
ERS-20401The Attribute editor now allows the user to deselected "Override bound data" for definitions on columns bound to a domain where the definition has been modified.
ERS-20454The Compare Wizard now generates the correct alter script when modifying a compressed Oracle table.
ERS-20468Where Used now shows the correct denormalization mappings for rolenamed foreign keys.
ERS-20482ER/Studio now removes rolenames on native columns when a file is loaded.
ERS-20501Views no longer display duplicate columns.
ERS-20512The Table Editor now allows compression on Teradata columns that are part of the Primary Key but not part of the Primary Index.
ERS-20690Renaming columns in the Explorer Tree now works properly.
ERS-20691Foreign key column names are now retained properly when performing a Roll-Up denormalizationmapping
ERS-20698Performance processing of bound attachments in the automation interface has been greatly improved.
ERS-20729The DDL Wizard now properly generates Pre-SQL that contains DROP statements.
ERS-20781ER/Studio remains stable when performing a Roll-Up denormalizationmapping on a subset of subtypes.
ERS-20794The tab order in the Transformation Editor has been improved.
ERS-20795The Transformation Editor now has shortcuts on all the buttons.
ERS-20827The View Parser now supports Teradata views that contain the EXTRACT syntax.
ERS-20832The Index Partition editor now remains stable after clicking Edit.
ERS-20833It is now possible to define an Oracle partition without a high value.
ERS-20841The Table editor now supports 255 character identifiers in Sybase ASE 15 models.
ERS-20852SQL Server index partition keys are now generated properly in the DDL tab of the Table editor.
ERS-20866The DDL Wizard no longer inserts line breaks in DB2 OS/390 comments.
ERS-20902The Compare Wizard now generates PK's and FK's in the correct order.
ERS-20939The Compare Options flag on attributes is now retained after performing a Check Out.
ERS-20945The Import MetaWizard now remains stable when importing from SQL Server Integration Services.
ERS-20959Project hierarchy is now maintained properly when adding diagrams to the Repository.
ERS-20961The sample Data Lineage Query SQL scripts have been updated.
ERS-20966ER/Studio now remains stable when switching between submodels that display definitions.
ERS-20974Attribute Identity property options are now saved and retrieved properly.

Bugs Fixed in ER/Studio DA 9.1
ERS-18184The Tools->Colors & Fonts dialog now properly sets the font settings for indexes and triggers.
ERS-18410The performance of copying and pasting stored procedures has been greatly improved.
ERS-18753The Compare Wizard now remains stable when comparing against a database that has triggers.
ERS-18841Model and Object background colors are no longer exported when the option to export them is deselected in Display Options.
ERS-18876Data Lineage images are now generated in reports executed via automation.
ERS-18882HTML tags in domain Notes are now interpreted properly in Reports.
ERS-19074Long comments are now saved properly when checking-in a Data Dictionary into the Repository.
ERS-19093Review Changes during check-in no longer displays differences due to internal unification and/or denormalization changes.
ERS-19324The DDLGeneration automation object now uses the Generate Owner Name setting saved in the Quicklaunch.
ERS-19389Compare and Merge between logical and physical no longer creates unnecessary rolenames on Foreign Keys.
ERS-19405The Entity.InformixLockMode property has been added to the automation interface.
ERS-19613The View Editor now remains stable after changing the Owner name.
ERS-19662The DB2TbsPartition.TrackModReset and CompressReset methods have been added to the automation interface to set those properties to "default."
ERS-19694DiagramManager.RepoGetLatestDiagram now works properly after binding a Dictionary to the diagram.
ERS-19703The Project tree is now displayed properly in the Get Diagram dialog.
ERS-19704The Compare Wizard no longer displays differences in the Freeze Names property when the option to compare the property is turned off.
ERS-19714The DB2 z/OS View parser now supports the EXCEPT operator.
ERS-19763The Repository Merge no longer flags split keys as relationship loops.
ERS-19774The ObjectPermissions.Remove method now works properly when a GUID is supplied.
ERS-19776Oracle SQL Import now properly sets the scale for TIMESTAMP columns to 6.
ERS-19785The DiagramManager.RepoDataDictionaries collection now returns the list of Enterprise Data Dictionaries.
ERS-19896The Get Diagram dialog now displays the correct description for a selected Named Release.
ERS-19935The Compare Wizard now merges domains from an Enterprise Data Dictionary into a Repository diagram with just a local dictionary.
ERS-19939Reverse-engineer now supports Auxiliary Table Index names greater than 18 characters.
ERS-20003ER/Studio now works properly with a secured Portal server.
ERS-20177The Compare Wizard now properly generates VARCHAR(MAX) in alter scripts.
ERS-20190The MergeModel.MergeReport automation method now works properly.
ERS-20200Defaults are now generated in Teradata DDL.
ERS-20400ER/Studio now properly handles relationships that propagate columns with ROWGUIDCOL property set.
ERS-20479The DDLGeneration automation object now uses the Generate Owner Name setting saved in the Quicklaunch.
ERS-20506ER/Studio now displays the correct message when an error occurs when saving a file due to lack of space or memory.
ERS-20540The Help button in the Repository Security Center is now functional.
ERS-20640The correct Column sequence is now reverse-engineered from Netezza.
ERS-20641The SQL Server Procedure parser now supports the READONLY keyword.
ERS-20763Repository Check-in now completes after deleting a displayed Index that has a font/color specified.

Bugs Fixed in ER/Studio DA 9.0.1
ERS-14534 ER/Studio DA no longer places quotes around the keyword USER in DB2 LUW column defaults.
ERS-18696 ER/Studio DA no longer generates duplicate Foreign Key constraint DROP statements when generating alter script.
ERS-18702 The Compare Wizard now properly matches functions with the same name in different schemas.
ERS-18703 The Function Editor now supports creating functions with the same name in different schemas.
ERS-18704 The Compare Wizard now properly merges views between models.
ERS-18914 The DDL Wizard now generates the table type for all MySQL tables.
ERS-18934 The Review Changes dialog no longer displays "Update unified." messages.
ERS-19000 ER/Studio DA now generates an error when attempting to rename an "Other Source" in the Data Lineage tree with the name of an existing physical model.
ERS-19008 The About box now reflects the current license type.
ERS-19011 The Compare Wizard now ignores "Freeze Names" differences when comparing against a database.
ERS-19073 The ReverseEngineer.Database automation property now works for Sybase databases.
ERS-19165 The Repository Rename Filename dialog no longer allows users to specify illegal filename characters.
ERS-19194 The DDL Wizard now properly generates bitmap indexes on partitioned tables.
ERS-19243 Mapped images in HTML Reports now work properly when the zoom level is something other than 100%.
ERS-19280The DDL Wizard now offers the Enclose Names in Quotes/Brackets option for Netezza.
ERS-19299 Capacity Planning estimates are now reverse-engineered properly from Oracle databases.
ERS-19333Owner name is no longer shown unnecessarily in Where Used.
ERS-19304 The Compare Wizard now merges differences in brackets around owner and view names.
ERS-19314 The Compare Wizard now retains the column list when merging a view.
ERS-19337 The RepoSrvDb.log file now contains the name of the diagram being deleted from the Repository.
ERS-19412 The Duplicate Named Attribute editor now appears when multiple relationships are drawn from the same parent to a child.
ERS-19427Reverse engineering from Netezza via automation no longer fails if the owner is the wrong case.
ERS-19448 The DDL Wizard now generates column level check constraints for columns bound to UDTs when the "Generate table-level check constraints" option is enabled.
ERS-19503It is no longer necessary to open, save, close, and reopen files from previous versions before a Report can be generated.
ERS-19537Denormalization mapping folders are now correctly shown in data model tree in some cases.
ERS-19538Denormalization Mappings are now displayed correctly in HTML Reports containing multiple physical models.
ERS-19591 The Compare Wizard no longer truncates FK constraint names in DB2 z/OS alter scripts.
ERS-19616User-defined mappings are shown properly in reports.
ERS-19619Nested column mappings are now properly updated when loading files from older versions.
ERS-19691 The "Generate By Default" option has been added for DB2 z/OS TIMESTAMP columns.
ERS-19733 ER/Studio no longer prefixes the owner name on denormalized tables when converting the DM1 from an earlier version.
ERS-19752 The Submodel.SchemaObjDisplays collection now returns all schema objects in the submodel.
ERS-19755 The Entity/Table editor now displays the Logical/Physical Only status of FK columns in read-only format.
ERS-19811 The License Registration dialog is no longer displayed when performing a "silent" installation.
ERS-19842 The "Data Lineage Import from Excel" macro has been updated to not generate "Stack overflow" errors when the model contains large table and/or column id's.

Bugs Fixed in Bugs Fixed in ER/Studio DA 9.0
ERS-11021Entity names now wrap properly in Name display mode.
ERS-12204It is now possible to set PRIQTY -1 for DB2 indexes and tablespaces.
ERS-15307Relationship lines are now drawn properly after copy/paste.
ERS-16515Auto-Layout now properly handles subtype relationships.
ERS-16568Performance of Repository Get Diagram has been improved.
ERS-18001The Automation Interface methods for Visual Data Lineage now work properly.
ERS-18111Duplicate attributes are no longer created during check-in after deleting a relationship with Make Native enabled.
ERS-18341The Compare Wizard now generates the index COMPRESS clause when comparing against an Oracle database.
ERS-18410The performance of copying and pasting stored procedures has been improved.
ERS-18588Foreign Keys are now displayed in the Binding Information tab of the domain and UDT editors.
ERS-18682The Submodel Synch Utility no longer synchronizes submodel members when the option is deselected.
ERS-18732The Project.AddDiagrams automation interface method now works properly.
ERS-18737The Compare Wizard now generates the correct alter script when modifying DB2 tables that have Generated columns.
ERS-18752The Compare Wizard now properly drops indexes prior to recreating PK constraints that use indexes.
ERS-18798The Compare Wizard now properly generates "GENERATED ALWAYS" columns when altering a DB2 table.
ERS-18809HTML Report images no longer contain errant relationship lines.
ERS-18833SQL Import now supports TeraData scripts with the COMMENT clause.
ERS-18837Performance of Repository Get Diagram has been improved.
ERS-18842The DDL Wizard now properly generates Foreign Keys.
ERS-18848HTML Reports no longer include tree nodes for submodels that were excluded from the report.
ERS-18849The Automation Interface now remains stable when exporting submodel images.
ERS-18862The XML Schema Wizard now includes datatype lengths for local simple types.
ERS-18880The MergeModelObject automation method now uses the specified quicklaunch file.
ERS-18903The Model.Entities collection now only returns entities in the current model.
ERS-18905The DDL Wizard now properly generates Foreign Keys.
ERS-18931The ERSVersion automation method now returns the entire version string.
ERS-18941Oracle triggers using the keyword EXEMPT as an identifier are now supported.
ERS-18956The Generate DLL wizard now checks to make sure that the owner name being bracketed inside procedures and views is followed by a period.
ERS-18978ER/Studio Data Architect now remains stable when reverse-engineer DB2 sequence object permissions.
ERS-19118The Automation Interface methods for Visual Data Lineage now work properly.
ERS-19152The View parser now supports SQL Server views that use INTERSECT.
ERS-19154The View parser now supports SQL Server views that use EXCEPT.
ERS-19187HTML Report images no longer contain errant relationship lines.
ERS-19226The correct column sequence is now maintained when merging new columns into split tables.
ERS-19235Adding entities with relationships to a submodel no longer affects other submodels.
ERS-19244The Positioning Complete option has been removed from the View menu.
ERS-19245The DDL Wizard now properly generates Foreign Keys.
ERS-19260A file now remains marked dirty if an error occurs when saving the file.
ERS-19355The Automation Interface methods for Visual Data Lineage now work properly.
ERS-19388Naming Standards are no longer applied to Foreign Keys when translating Physical to Logical in a physical model
ERS-19422Diagram Attachments are now preserved after renaming a diagram
ERS-19510SQL Import now supports DB2 objects that have an owner name that begins with "$".

Upgrade Instructions

Upgrading ER/Studio Data Architect

Use the following checklist to ensure ER/Studio Data Architect is correctly upgraded.

Upgrade Checklist

Important Notes

Preparing to Upgrade

The steps that follow are for ER/Studio Enterprise installations only, which include ER/Studio Repository.

  1. Ensure you have backed up all your .dm1 files.
  2. Check in all your diagrams and objects. If you attempt check in a file from a previous-version that has the same name as an existing file, the existing file will become corrupted.
  3. Rename all local copies of Repository diagrams in the active file directory as follows:
  4. Ensure no one is logged into the Repository.
  5. Backup the current Repository database.
  6. Remove the previous version of the Repository application. Choose Control Panel > Add Remove Programs > Repository x.x, and then click Remove.
  7. Restart the Repository host computer.

Upgrading ER/Studio Data Architect

Follow the instruction for installing ER/Studio Data Architect, in ER/Studio Quick Start Guide located in the installation Readme directory.

Upgrading Diagrams

If you have an ER/Studio Data Architect installation that does not include ER/Studio Repository, see "Upgrading ER/Studio Data Architect Standard Diagrams". If you have ER/Studio Enterprise, which includes ER/Studio Repository, see "Upgrading ER/Studio Data Architect Diagrams."

Note: Since the denormalization feature has changed in 9.0, any documents containing denormalization mappings will be upgraded to use the new feature of ER/Studio DA 9.0. Denormalization mappings are now retained with the table data and can be viewed and edited on the Where Used tab of the Table Editor. Denormalization history, including Columns, Indexes, and Relationships of pre-map tables, is no longer retained, so the undo and make permanent functions specifically for denormalizations are no longer available. Denormalization mappings have been worked into the normal undo function of the product allowing them to be undone like other operations. However, the names of the pre-map tables are retained. Retaining only essential pre-map information means that the DM1 file with denormalizations is smaller and therefore opens faster.

Upgrading ER/Studio Data Architect Standard Diagrams

Note: This procedure is for ER/Studio Data Architect Standard installations only, which do not include the Repository.

Once you have installed the new version of ER/Studio Data Architect, from the new version of ER/Studio Data Architect, open each of your old *.dm1 files. ER/Studio Data Architect will convert the files to the new format before opening them. Then save the files with a new name or overwrite the previous version by using the same name.

Upgrading ER/Studio Data Architect Diagrams

Note: This procedure is for ER/Studio Enterprise installations only, which include ER/Studio Repository.

Update your existing diagrams before you check out any diagrams or do any work with the new version of ER/Studio Data Architect.

Upgrading diagrams can be time consuming and memory intensive. The number and size of ER/Studio Data Architect diagrams managed in the upgraded Repository will dictate how long the upgrade process takes.

  1. Start ER/Studio Data Architect.
  2. Update the Repository Options to recognize the new ER/Studio Repository as follows:
  3. Log on to the Repository using an account with Super User privileges
  4. Run the Diagram Data Version Upgrade utility as follows: From the ER/Studio Data Architect Main menu, choose Repository > Administration > Diagram Data Version Upgrade.

This will update your existing diagrams to the latest version.

Notes

Upgrading ER/Studio Repository

Use the following checklist to ensure ER/Studio Repository is correctly upgraded.

Upgrade Checklist

Important Notes

Preparing to Upgrade the Repository

  1. Ensure you have backed up all your .dm1 files.
  2. Check in all your diagrams and objects. Note:If you try to check in a file from the previous version with the same name as a current file, the current file will become corrupted.
  3. Rename all local copies of Repository diagrams in the active file directory as follows:
  4. Ensure no one is logged into the Repository.
  5. Backup the current Repository database.
  6. Restart the Repository host computer.

Upgrading the Repository

Note: This procedure is for ER/Studio Enterprise installations only, which include the Repository. When you upgrade ER/Studio Data Architect you must also upgrade ER/Studio Repository to correspond with the same build date as ER/Studio Data Architect.

  1. Log on to Windows with local administrator privileges.
  2. Start the Repository installation program and select Repair Repository Services. The installation program starts the following services:

The Repository services and your existing database will be upgraded to the current version.

Note: If you are upgrading from a Repository version prior to 4.0, you can delete the C:\Program Files\Embarcadero\Repository\Data directory. This directory is not used with Repository versions 4.0 and later.

Embarcadero Technologies Technical Support

If you have a valid maintenance contract with Embarcadero Technologies, our Support team will assist you with any problems you have with our applications. Our maintenance contract also entitles registered users of Embarcadero Technologies products to download free software upgrades during the active contract period.

Evaluators receive free technical support for the term of their evaluation. To download evaluations of Embarcadero Technologies products go to the www.embarcadero.com.

To contact Support, go to Support.