$$GETTING_STARTED$$ - %%projecttitle%%

ER/Studio Data Architect 2016 Automation Interface Reference Send comments on this topic.
Introduction

Introduction

This reference is compiled directly from the source code and includes comments by the software engineers who designed the automation interface.

All new content, added since the last major release is marked with a red star in the Contents tree and with a red triangle on topic page.

There are a few, but critical, syntactic differences between SAX BASIC and other BASIC languages you may have used. Be sure to read the Definitions section below, it may save you some debugging time.

External COM Programming vs ER/Studio's Macro Window

There's a different parent object in the script interpreter within ER/Studio as compared to the parent object named using an externally created executable, such as a VB program from Microsoft's Visual Studio. In the latter case, you're using ER/Studio's COM automation interface that supports BASIC. Invoke The Programmatic Id (PROGID) for ER/Studio: 'ERStudio.Application'.

Working examples of this type exist in MSVB6, .Net VB and C# and are in your ER/Studio application directory under "..\Readme\TableList.zip."

Macros which run inside ER/Studio's SAX BASIC shell will use the pre-initialized 'DiagramManager' object. There are numerous examples of this in ER/Studio's Macro Tab and in the Code Samples section of this online help file.

To summarize: Outside ER/Studio you begin with an instance of ERStudio.Application. Inside you begin with DiagramManager, and an instance is already running.

Good Programming Practice

To check for errors after method calls, use the DiagramManager.GetLastErrorCode() or DiagramManager.GetLastErrorString().

Definitions

In the list of Members of an object, the comments for METHOD, PROPERTY, PARAMETERS, and DESCRIPTION are written by the automation interface engineers. These comments include instructions or valid parameter lists. Where PARAMETERS are listed, they are usually more tightly-scoped than the universal BASIC type "Variant." Use the specific datatype as listed in PARAMETERS in your code. In the example above, you might write in your code:

Dim MyDiagram As Diagram

Dim MyFilePath As String

'**************

'NOT as Variant

'**************

MyFilePath = "C:\Model\ElleModel.dm1"

Set MyDiagram = DiagramManager.OpenFile(MyFilePath )

DEFINITION: Function OpenFile(FullFilePath) As Diagram

This is the actual source code definition. In the example, Function means a function (equivalently here, "method") is being defined.

"FullFilePath" is the only argument that OpenFile takes.

"As Diagram" means that OpenFile returns a custom datatype "Diagram." Other methods and properties may return typical data types such as Integer or String.

PARAMETERS lists any arguments the method/property takes and of what Type. In some places you may notice a difference between the datatype in the comments and the Type listed in the Parameters table. Such is the case above, where FullFilePath is listed as Type Variant in the table but as String in the comments.

The table lists the actual automation interface source-code definition, whereas the comments list the intended target type in ER/Studio.

Variant is a BASIC super-type that contains all but custom datatypes. You can generally declare any variable to be Variant and restrict it further when you use it, say, as a Boolean. The automation interface is defined in this way, but you should use the intended specific datatype in your code.

In other words, don't declare a Variant-type variable if you can use the specific data type, such as String in the example above.

Why am I using "DiagramManager" and not "Application" in the example above?

Outside ER/Studio (COM programming) you begin with an instance of ER/Studio.Application. Inside the ER/Studio Macro Editor you begin with DiagramManager, and an instance is already running. It's the only such difference in the entire object set. If you write programs only within ER/Studio, it will appear as above and you don't have to bother with it further. Otherwise, see the External COM Programming vs ER/Studio’s Macro Window notes above.

Syntax Notes

Note on Properties Get / Let

A property can be defined as Get/Let, meaning you can read the property (Get) or change it (Let). However, many properties such as numeric IDs, are set by ER/Studio and are in fact read-only; they are defined with Get but not Let permissions. For example, most of the numeric IDs are Get only.

In general, if you can edit a property using ER/Studio's GUI design controls, and there exists an automation object for it, it will exist as Get/Let. If you can't edit it in ER/Studio, it's read-only (Get-only).

Note on Use of SET

The code EXAMPLES in this reference do not always use " Set ." In the SAX BASIC Editor within ER/Studio, you must use the function Set on the first instance of the object in a script (or block of code within object scope). You must use it again if the object reference changes. Example:

Set MyDiagram = DiagramManager.ActiveDiagram

'some code that closes the active diagram and opens another diagram

Set MyDiagram = DiagramManager.ActiveDiagram

Note on Dim [what] As [ever]

SAX BASIC will not allow you to declare and initialize any variable in one statement. Example:

Dim MyData As Integer = 30 'No way

Dim MyData As Integer
MyData = 30 'OK

Database IDs by Platform

Where a platform is specified by integer, use the following:

  • 1 Microsoft SQL Server 4.x
  • 2 Sybase System 10.x
  • 3 MS SQL SERVER 6.x
  • 4 Sybase Watcom SQL
  • 6 Informix Online
  • 7 Informix SE
  • 8 Oracle 7.x
  • 9 IBM DB2 Common Server
  • 10 InterBase
  • 11 Sybase ASE 11.0
  • 12 Sybase SQL Anywhere 5.x
  • 14 Microsoft Access
  • 15 Microsoft Access 2.0
  • 16 Microsoft Access 95
  • 17 Microsoft Visual FoxPro 2.x
  • 28 Microsoft Visual FoxPro 3.x
  • 30 Microsoft Access 97
  • 31 Microsoft Visual FoxPro 5.x
  • 32 IBM DB2 UDB 5.x
  • 33 Microsoft SQL SERVER 7.x
  • 34 Oracle 8.X
  • 35 Sybase ASA 6.0
  • 36 Sybase ASE 11.9
  • 37 Sybase ASE 11.5
  • 38 IBM DB2 UDB 6.x
  • 39 IBM DB2 UDB for OS/390 6.x
  • 40 IBM DB2 UDB for OS/390 5.x
  • 41 Microsoft SQL Server 2000
  • 42 Microsoft Access 2000
  • 43 Sybase ASE 12.0
  • 44 IBM DB2 UDB 7.x
  • 45 Hitachi HiRDB
  • 46 IBM DB2 UDB for OS/390 7.x
  • 47 Oracle 9i
  • 48 IBM DB2 AS/400 4.x
  • 49 Sybase Adaptive Server IQ 12.5
  • 51 Generic DBMS
  • 54 Sybase ASE 12.5
  • 55 Sybase ASA 7.0
  • 56 Sybase ASA 8.0
  • 57 NCR Teradata V2R4
  • 58 MySQL 3.x
  • 59 IBM DB2 UDB 8.x
  • 60 MySQL 4.x
  • 61 NCR Teradata V2R5
  • 62 IBM DB2 AS/400 5.x
  • 64 Sybase ASA 9.0
  • 65 Informix 9.x
  • 66 Oracle 10g
  • 68 Microsoft SQL Server 2005
  • 69 IBM DB2 UDB for OS/390 8.x
  • 70 Generic ODBC
  • 71 NCR Teradata V2R6
  • 72 PostgreSQL 8.0
  • 73 MySQL 5.x
  • 74 IBM DB2 UDB 9.x
  • 75 Sybase ASE 15
  • 77 Oracle 11g
  • 78 IBM DB2 for OS/390 9.x
  • 79 Sybase ASA 10.0
  • 81 InterBase 2007
  • 82 Microsoft SQL Server 2008
  • 83 InterBase 2009
  • 84 NCR Teradata 12.0
  • 85 Netezza 4.6
  • 86 Netezza 5.0
  • 87 NCR Teradata 13.x
  • 88 Netezza 6.0
  • 89 Microsoft SQL Server 2012
  • 90 IBM DB2 UDB for OS/390 10.x
  • 91 PostgreSQL 9.x
  • 92 GreenPlum 4.x
  • 93 NCR Teradata 14.0
  • 94 Netezza 7.0
  • 95 IBM DB2 LUW 10.x
  • 96 InterBase XE
  • 97 InterBase XE3
  • 98 Firebird 1.5
  • 99 Firebird 2.x
  • 100 Oracle 12c
  • 101 Microsoft SQL Server 2014
  • 102 Hive 0.12
  • 103 MongoDB 2.4
  • 104 Sybase Adaptive Server IQ 15
  • 105 Sybase Adaptive Server IQ 16
  • 106 Teradata v15
  • 107 Microsoft SQL Azure

© Embarcadero Technologies, Inc. All Rights Reserved.


ER/Studio Code Samples

Automation Interface Code Samples

The code samples here are working scripts and also located in the ERStudio6.6\Macros\SampleMacros directory. Descriptions and comments appear in the code.

Basic Modeling Demonstrations: Add/Remove, Item, String and Attribute Editing

Add Base Attributes To Person Entity - Adds base attributes to selected entities, which represent people. It will also introduce a primary key based upon the entity's name.

Add Definition To Type Entities - Add a definition to selected entities. The definition applied to the selected entity will also include the object's name automatically, as in "My definition text + entity name +(s)"

Add Parent Name Prefix to Propagating Key - add the entity name as a prefix to all attribute role names. It demonstrates how to use the FKColumnPair object

Add Table Name Prefix Globally - Add a prefix string to the namesof all entities in the model. The macro opens adialog box prompting the user for the prefix. If the currentactive model is logical, it will assign the prefix toall entity names. If the current model is physical, it willassign the prefix to all table names.

Add Table Name Prefix Selectively - Add a prefix string to the names ofselected entities in the model. The macro opens a dialog toprompting the user for the prefix. If the current model islogical, it assigns the prefix to selected entity names. Ifthe current model is physical, it will assign the prefix toselected table names.

Add Table Owner Globally- For physical models, this will update the owner fieldin the table editor for all tables in the active model. Theactive model must be a physical model.

Add View Owner Selectively - For physical models, this will update the owner fieldin the view editor for all selected entities. The active modelmust be a physical model.

Attachment Example - exports attachment data for each boundattachment for every selected table in the active model.The file name and path is "C:\Attachment Data.txt.

Attribute Binding Macro - Lists all the unbound attributes/columnsof all the models (logical and all physicals) and domains. Theattributes can then be bounded to any of listed domains bypressing the "Bind" button.

Auto-Align Selected Entities Left - Performs the align left' operation (similar to the align buttons on the Alignment Toolbar) for all selected entities. This macro demonstrates more on how to use entity display objects.

Auto-Color All Entities with FKs - make all entities with foreign keys purple. It will first select (highlight) all entities in the current, submodel. Then it will make all selected entities with foreign keys (which, in this case, are all the entities in the submodel) purple. Finally, it will deselect (unhighlight) all entities in the current, active submodel. This macro illustrates how to use entity objects, entity display objects, and selected objects - and how to distinguish among 'them.

Auto-Combine Selected Entities - Takes all the attributes from all the selected entities and add them into one newly created entity. Includes a separate function GetAveragePoint(), this function will get the average x or y coordinate point among all selected entities. The second parameter determines whether to calculate the average x coordinate or the average y coordinate.

Auto-Convert Datatype - Iterate through all the selected entities and change the datatypes for all attributes which use VARCHAR to TEXT.

Auto-Create Data Dictionary and Bound Domain - Creates a new diagram, then create a rule, default and domain in the data dictionary. Then it will bind the rule and default to the domain. Next, it will then create an entity and an attribute. Finally, it will bind the domain to the attribute.

Auto-Create Data Dictionary - Creates a user-defined data dictionary quickly. The macro can be used as a template to create user-defined or business-specific data dictionaries. This macro can be inserted into ER/Studio's ERSBasicHandlers system (specifically in the '"CreateDiagramHandler(CurDiagram As Object)" section of ERSBasicHandlers) and if the Create Handlers option is checked on in ER/Studio's Automation Interface Options, this Data Dictionary will be created and populated any time a user creates a new diagram.

Auto-Create New Diagram - Creates a new diagram. The new diagram will contain an IBM DB/2 physical model and six entities in the physical model.

Constraint Generator - Generates constraints from the defined reference values. The reference values must be defined in the data dictionary of ER/Studio. The macro can select from bound attributes, all attributes, bound domains or all domains. This is chosen with the radio buttons at the bottom of the dialog. the constraint will be inserted in the check constraint/rule tab of the domain or attribute.

Convert Name Case - Converts the case of Attributes, Columns and Entty/Table names for the highlighted tables/Entities in the active SubModel to all upper or lower case. Works in Logical or Physical models

Definition Editor - Lists all the tables and allows the user to update the definition field for the table, by pressing the "update" button. There will also be a list of columns for the respective table, that the user can use to update the definitions for each column. This macro will run on a logical or a physical model and populate the lists accordingly.

Domain Bindings Export to Excel - Lists all the tables and allow the user to update the definition field for the table, by pressing the "update" button. There will also be a list of columns for the respective table, that the user can use to update the definitions for each column. This macro will run on a logical or a physical model and populate the lists accordingly.

Domain Bindings Import from Excel - Exports domain bindings for all the attributes in the current model. The existing columns in the spread sheet must be left in the same format if the bindings are going to be used to import back into a model. Note that the attribute data type is only in the spread sheet for informational purposes when refactoring attibutes and columns and assigning them to domains.

Domain Bindings - Imports domain bindings from Excel. I will map domains to attributes or columns depending on the data in the spread sheet. The macro provides an interface to select the dictionary where the domains are located and the model to search for the attributes or columns. When importing into a physical model the spread sheet must have the physical table and column names that match the selected physical model. When importing into the logical model, the names in the spread sheet must match the entity and attribute names.

Example macro- Loop through objects of Active Submodel - Brings up a dialog box that shows all attributes bounded to a selected domain. It also allows the user to unbind specific attributes from the selected domain. The dialog box contains two list boxes and two buttons. The first list box, "Domains", shows all the domains in the diagram. The second list box, "Bounded Attributes", shows all the attributes bounded to the selected domain in the "Domains" list box. There is also an "OK" button and an "UnBind" button. The user can press the "UnBind" button to unbind selected attributes in the "Bounded Attributes" list box from the selected domain in the "Domains" list box.

Export Domain Info to Excel - Exports the domains and their properties to excel. Each record in the Excel spread sheet represents on domains from the data dictionary. The spread sheet can be used to store domains outside of ER/Studio. The domain properties can be updated in the spread sheet and imported back into an existing model or a new model using the "Import Domains From Excel" macro. The columns in the spread sheet must remain in the same order to import them properly. REQUIREMENT: You must have MS Excel 97 or later installed.

Export Index Column Info to Excel - Generates an index column report for the active model in ER/Studio. Each record in the Excel spread sheet represents an indexed column. The spread sheet can be used to apply naming conventions to indexes. The new index name can be read in with the "Import Index Names from Excel" macro from the "New Index Name" column in the spread sheet. REQUIREMENT: You must have MS Excel 97 or later installed

Metadata Import/Export and Formatting Examples

The following examples demonstrate various methods of importing and exporting model meta data with MSOffice applications such as Excel and Word. Importing has such uses as transferring spreadsheets or lists of names and attributes into your model. Exporting might be used for a presentation or report.

Export Metadata to Excel Version 2.1

Export Metadata to Excel Version 2

Export Metadata to Excel Version 3.1

Export Metadata to Excel Version 3

Export Model Metadata to Excel

Export Model Metadata to Word

Export Object Definitions and Notes to Excel

Export Reference Value Info to Excel

Export Relationship Info to Excel

Import Domains from Excel

Import Index Names from Excel

Import Object Definitions and Notes from Excel

Import Reference Values from Excel

Import Relationship Names from Excel

Submodel Report

Pre/PostSQL Demonstrations for Selected Target Databases

Insert Synonym in PostSQL

Selectively Add DB2 Permissions to PostSQL

Selectively Add MS SQL Permissions to PostSQL

Selectively Add Oracle Permissions to PostSQL

Selectively Add Oracle Sequence

Selectively Add Sybase Permissions to PostSQL

Metadata Operations and Target Database Operations

Generate Partitions For OS390 Clustered Indexes - Provides and interface to add multiple partitions to clustered indexes. A list of tables is provided. Selecting a table will load the clustered indexes to be partitioned. The storage parameters are uniform across partitions.

Get Related Tables - Selects the related parents and/or child of the selected tables. To use the macro lasso a group of entities on the diagram or select them in the diagram tree, then right click on the macro to execute. Parents and children will be selected depending if the option is checked. This macro can be used to assist in submodel creation.

ImportDataDictionary - Import Data Dictionary objects from a flat file. The imported file has to follow a specific format guidelines listed in the comments with exmaples.

Index Naming - Applies naming conventions to all types of indexes. It provides an option to use the selected tables or all tables. The prefix and suffix variables can be used to add company specific conventions to the beginning and/or end of the target name. The target name can be either the existing name, table name, tablespace name or database name. The tablespace and database can only be used for applicable platforms such as Oracle or DB2. Truncate parameters can also be specified to remove the first N characters or the last N characters of the target name. Another parameter can also be used to limit the total number of characters in the target name. These are applied before the prefix and suffix are added.

Name Foreign Constraints - Prompts the user with a dialog to specify the naming convention for Foreign Constraints. It will then name all the constraints using the parent and child table names. It will also make sure the name is unique by adding an index for the last characters of duplicate names.

Name Primary Constraints - Names all primary key constraints with the given naming conventions. The table name with either a prefix or suffix.

ProcedureEdit - Adds a Synonym to a specified table/view. The macro will prompt the user with a dialog to choose the table/view. The synonym code will be inserted into the PostSQL of the specified table/view.

Selectively Output PK and FK DDL - Outputs DDL for primary and foreign constraints for all selected tables. To operate, selected the desired tables, then right-click on the macro to execute. The DDL can be previewed or written to a file.

Selectively Update Oracle Index Storage - Provides a list of tables from the active physical model. The tables in the right box will be updated with the specified storage parameters. Tables can be added and removed from the updated list.

Selectively Update OS390 Table Storage - Provides a list of tables from the active physical model. The tables in the right box will be updated with the specified storage parameters. Tables can be added and removed from the updated list.

SQL Server Storage Update - Updates SQL Server storage parameters for tables and indexes.

Switch Domain Bindings - Scans all the columns and attributes in the active model or all models and switches the domain bindings from the source domain to the target domain. The information for each bound column will be updated with the target domain. Any domain overrides will be preserved.

Update DB2 OS390 Index Storage Parameters - Provides a list of tables from the active physical model. The tables in the right box will be updated with the specified storage parameters. Tables can be added and removed from the updated list.

Update DB2 OS390 Table Storage Parameters - Provides a list of tables from the active physical model. The tables in the right box will be updated with the specified storage parameters. Tables can be added and removed from the updated list.


Add Base Attributes To Person Entity.bas

      ' MACRO TITLE: ADD BASE ATTRIBUTES TO PERSON ENTITY
      ' This macro adds base attributes to selected entities, which
      ' represent people. It will also introduce a primary key based
      ' upon the entity's name.
      '----------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MySubModel As SubModel
          Dim MyDictionary As Dictionary
          Dim MyDomain As Domain
          Dim MyEntity As Entity
          Dim MyAttribute As AttributeObj
          Dim MyPrimaryKey As Index
          Dim AttributeName As String
          Dim PrimaryKeyName As String
          Dim EntityName As String
          Dim Logical As Boolean
          Dim MySelObject As SelectedObject
          Dim NameID As Integer
          Dim CreateDateID As Integer
          Dim CreatedByID As Integer
          Dim ModifiedDateID As Integer
          Dim ModifiedByID As Integer
          Dim DomainID As Integer
          Dim ID As Integer
          Dim ObjType As Integer
          Dim MyIndex As Index

          ' Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          ' Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          'Get the current submodel.

          Set MySubModel = MyModel.ActiveSubModel

          ' Get the current Data Dictionary.

          Set MyDictionary = MyDiagram.Dictionary

          ' Determine Domains.

          Set MyDomain = MyDictionary.Domains.Item("Name")
          NameID = MyDomain.ID

          Set MyDomain = MyDictionary.Domains.Item("CreateDate")
          CreateDateID = MyDomain.ID

          Set MyDomain = MyDictionary.Domains.Item("CreatedBy")
          CreatedByID = MyDomain.ID

          Set MyDomain = MyDictionary.Domains.Item("ModifiedDate")
          ModifiedDateID = MyDomain.ID

          Set MyDomain = MyDictionary.Domains.Item("ModifiedBy")
          ModifiedByID = MyDomain.ID

          ' Determine if the current model is logical or physical.

          Logical = MyModel.Logical

          ' Iterate through all the selected objects in the current
          ' model.

          For Each MySelObject In MySubModel.SelectedObjects

              'Get the object type - we are only concerned
              'with entities.

              ObjType = MySelObject.Type

              If ObjType = 1 Then

                  ' Get the ID for the selected object.

                  ID = MySelObject.ID

                  ' Get the actual entity object with this ID.
                  ' The model contains the collection of all the
                  ' entities.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  If Logical = True Then

                      ' If the model is logical:

                      ' Get the entity name.

                      EntityName = MyEntity.EntityName

                      ' Set name of PK and PK attribute.

                      AttributeName = EntityName + " ID"
                      PrimaryKeyName = EntityName + " PK"

                      ' Add the PK attribute

                      Set MyAttribute = MyEntity.Attributes.Add(AttributeName, True)

                      ' Bind the ID domain to the PK attribute.

                      MyAttribute.DomainId = DomainID

                      ' Get ID for PK, using the kluge that it is the only index.
                       'Set MyPrimaryKey = MyEntity.Indexes.ID

                      ' Go through the collection of indexes in the entity and
                      ' find the PK index

                      For Each MyIndex In MyEntity.Indexes
                          If (MyIndex.IsPK = True) Then
                              Set MyPrimaryKey = MyIndex
                              Exit For
                          End If
                      Next 'MyIndex

                      ' Set the PK name.
                      MyPrimaryKey.Name = PrimaryKeyName

                      ' First Name
                      Set MyAttribute = MyEntity.Attributes.Add("First Name", False)
                      MyAttribute.DomainId = NameID

                      ' Last Name
                      Set MyAttribute = MyEntity.Attributes.Add("Last Name", False)
                      MyAttribute.DomainId = NameID

                      ' CreateDate
                      Set MyAttribute = MyEntity.Attributes.Add("Create Date", False)
                      MyAttribute.DomainId = CreateDateID

                      ' CreatedBy
                      Set MyAttribute = MyEntity.Attributes.Add("Created By", False)
                      MyAttribute.DomainId = CreatedByID

                      ' ModifiedDate
                      Set MyAttribute = MyEntity.Attributes.Add("Modified Date", False)
                      MyAttribute.DomainId = ModifiedDateID

                      ' CreatedBy
                      Set MyAttribute = MyEntity.Attributes.Add("Modified By", False)
                      MyAttribute.DomainId = ModifiedByID
                  End If

              End If

          Next MySelObject

      End Sub


Add Definition To Type Entities.bas

      'MACRO TITLE: ADD DEFINITION TO TYPE ENTITIES
      'This macro will add a definition to selected entities. The definition
      'applied to the selected entity will also include the object's name automatically,
      'as in "My definition text + entity name +(s)"
      '----------------------------------------------------------------

      Sub Main()
          Dim MyDiagram As Diagram
              Dim MyModel As Model
              Dim MySubModel As SubModel
              Dim MyEntity As Entity
              Dim Logical As Boolean
              Dim MySelObject As SelectedObject
              Dim ID As Integer
              Dim ObjType As Integer
              Dim EntityName As String
              Dim BaseEntityName As String
              Dim StartPosition As Integer

          ' Set the context: active Diagram, Model, Submodel

              Set MyDiagram = DiagramManager.ActiveDiagram
              Set MyModel = MyDiagram.ActiveModel
              Set MySubModel = MyModel.ActiveSubModel

              ' Determine if the current model is logical or physical.

              Logical = MyModel.Logical

              ' Iterate through all the selected objects in the current
              ' model.

              For Each MySelObject In MySubModel.SelectedObjects

                      'Get the object type - we are only concerned
                      'with entities.

                      ObjType = MySelObject.Type

                      If ObjType = 1 Then

                              ' Get the ID for the selected object.

                              ID = MySelObject.ID

                              ' Get the actual entity object with this ID.
                              ' The model contains the collection of all the
                              ' entities.

                              Set MyEntity = MyModel.Entities.Item(ID)

                              If Logical = True Then

                                      ' If the model is logical:

                                      ' Get the entity name.

                                      EntityName = MyEntity.EntityName

                      ' Strip out Type.

                      StartPosition = InStr(EntityName, "Type")

                      If StartPosition = 0 Then
                         StartPosition = Len(EntityName) + 1
                      End If

                      BaseEntityName = Trim(Left(EntityName, StartPosition - 1))

                      ' Apply the definition.

                      MyEntity.Definition = "Control table that classifies " + BaseEntityName + "(s)"

                              End If

                      End If

              Next MySelObject

      End Sub


Add Parent Name Prefix to Propagating Key.bas

      'MACRO TITLE: ADD PARENT NAME PREFIX TO PROPAGATING KEY MACRO
      'This macro will add the entity name as a prefix to all attribute
      'role names. It demonstrates how to use the FKColumnPair object.
      '-----------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim MyRelationship As Relationship
          Dim MyFKColumnPair As FKColumnPair
          Dim ParentAttribute As AttributeObj
          Dim ChildAttribute As AttributeObj

          Dim Logical As Boolean
          Dim RoleName As String
          Dim NewRoleName As String
          Dim Prefix As String
          Dim ObjectName As String

          'Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          'Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          'Determine if the model is logical or physical.

          Logical = MyModel.Logical

          'Iterate through all entities in the model.

          For Each MyEntity In MyModel.Entities

              'If the model is logical, then get the entity
              'name. Otherwise, get the table name.

              If Logical = True Then
                  ObjectName = MyEntity.EntityName
              Else
                  ObjectName = MyEntity.TableName
              End If

              'Now iterate through all the parent relationships
              'of the entity.

              For Each MyRelationship In MyEntity.ParentRelationships

                  'Iterate through all the foreign key column pairs in
                  'the relationship.

                  For Each MyFKColumnPair In MyRelationship.FKColumnPairs

                      'Get the child attribute of the column pair.

                      Set ChildAttribute = MyFKColumnPair.ChildAttribute

                      'Get the role name of the child attribute.

                      RoleName = ChildAttribute.RoleName

                      'Add the entity name to the beginning of the role
                      'name.  Update the child attribute to have the
                      'new role name.

                      NewRoleName = ObjectName + "_" + RoleName
                      ChildAttribute.RoleName = NewRoleName

                  Next MyFKColumnPair

              Next MyRelationship

          Next MyEntity

      End Sub


Add Table Name Prefix Globally.bas

      ' 'MACRO TITLE: ADD TABLE NAME PREFIX GLOBALLY MACRO
      ' This macro lets the user add a prefix string to the names
      ' of all entities in the model.  The macro opens a
      ' dialog box prompting the user for the prefix.  If the current
      ' active model is logical, it will assign the prefix to
      ' all entity names.   If the current model is physical, it will
      ' assign the prefix to all table names.
      '------------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim ObjectName As String
          Dim NewObjectName As String
          Dim Prefix As String
          Dim Logical As Boolean

          ' Create the dialog box.  This dialog box was
          ' created using the Sax Basic Dialog Editor.

          Begin Dialog UserDialog 260,112 ' %GRID:10,7,1,1
              TextBox 30,28,210,21,.Prefix
              Text 30,7,160,14,"Entity Name Prefix:",.Text1
              OKButton 80,70,90,21
          End Dialog

          Dim dlg As UserDialog

          ' Run the dialog box.

          Dialog dlg

          ' Get the prefix from the dialog box.

          Prefix = dlg.Prefix

          ' Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          ' Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          ' Determine if the current model is logical or physical.

          Logical = MyModel.Logical

          ' Iterate through all entities in the current model.

          For Each MyEntity In MyModel.Entities

              If Logical = True Then

                  ' If the model is logical, get the entity
                  ' name, add the prefix to the entity name and
                  ' set the new name back into the entity.

                  ObjectName = MyEntity.EntityName
                  NewObjectName = Prefix + ObjectName
                  MyEntity.EntityName = NewObjectName
              Else

                  ' If the model is physical, get the table
                  ' name, add the prefix to the table name and
                  ' set the new name back into the entity.

                  ObjectName = MyEntity.TableName
                  NewObjectName = Prefix + ObjectName
                  MyEntity.TableName = NewObjectName
              End If

          Next MyEntity

      End Sub


Add Table Name Prefix Selectively.bas

      ' 'MACRO TITLE: ADD TABLE NAME PREFIX SELECTIVELY MACRO
      ' This macro lets the user add a prefix string to the names of
      ' selected entities in the model.  The macro opens a dialog to
      ' prompting the user for the prefix.  If the current model is
      ' logical, it assigns the prefix to selected entity names.  If
      ' the current model is physical, it will assign the prefix to
      ' selected table names.
      '-------------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim MySubModel As SubModel
          Dim MySelObject As SelectedObject
          Dim MyEntities As Entities
          Dim EntityName As String
          Dim NewEntityName As String
          Dim Prefix As String
          Dim ID As Integer
          Dim ObjType As Integer
          Dim Logical As Boolean

          ' Create the dialog box.  This dialog box was
          ' created using the Sax Basic Dialog Editor.

          Begin Dialog UserDialog 300,105 ' %GRID:10,7,1,1
              Text 40,14,160,14,"Entity Name Prefix:",.Text1
              TextBox 40,35,220,21,.Prefix
              OKButton 100,70,90,21
          End Dialog

          Dim dlg As UserDialog

          ' Run the dialog box.

          Dialog dlg

          ' Get the prefix from the dialog box.

          Prefix = dlg.Prefix

          ' Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          ' Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          'Determine if the model is logical or physical.

          Logical = MyModel.Logical

          ' Get the current submodel.  Only submodels contain
          ' selected objects.

          Set MySubModel = MyModel.ActiveSubModel

          ' Iterate through all the selected objects in the current
          ' submodel.

          For Each MySelObject In MySubModel.SelectedObjects

              'Get the object type - we are only concerned
              'with entities.

              ObjType = MySelObject.Type

              If ObjType = 1 Then

                  ' Get the ID for the selected object.

                  ID = MySelObject.ID

                  ' Get the actual entity object with this ID.
                  ' The model contains the collection of all the
                  ' entities.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  If Logical = True Then

                      ' If the model is logical, get the entity
                      ' name, add the prefix to the entity name and
                      ' set the new name back into the entity.

                      ObjectName = MyEntity.EntityName
                      NewObjectName = Prefix + ObjectName
                      MyEntity.EntityName = NewObjectName
                  Else

                      ' If the model is physical, get the table
                      ' name, add the prefix to the table name and
                      ' set the new name back into the entity.

                      ObjectName = MyEntity.TableName
                      NewObjectName = Prefix + ObjectName
                      MyEntity.TableName = NewObjectName
                  End If

              End If

          Next MySelObject

      End Sub


Add Table Owner Globally.BAS

      'TITLE:  ADD TABLE OWNER GLOBALLY
      'DESCRIPTION:  For physical models, this will update the owner field
      '	in the table editor for all tables in the active model.  The
      '	active model must be a physical model.

      Sub Main

          Dim diag As Diagram
          Dim mdl As Model
          Dim ent As Entity
          Dim so As SelectedObject

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          If mdl.Logical = False Then

              Begin Dialog UserDialog 340,147,"Set Owner For all Tables" ' %GRID:10,7,1,1
                  TextBox 120,42,150,21,.Owner
                  Text 50,49,50,14,"Owner:",.Text1
                  OKButton 80,98,90,21
                  CancelButton 210,98,90,21
              End Dialog
              Dim dlg As UserDialog

              If Dialog(dlg) = -1 Then

                  'loop through selected objects
                  For Each ent In mdl.Entities

                      'update table owner from dialog input
                      ent.Owner = dlg.Owner

                  Next

              End If

          Else

              MsgBox("Active model must be a physical model.",vbOkOnly,"ERROR!")

          End If

      End Sub


Add View Owner Selectively.bas

      'TITLE:  ADD VIEW OWNER SELECTIVELY
      'DESCRIPTION:  For physical models, this will update the owner field
      '	in the view editor for all selected entities.  The active model
      '	must be a physical model.

      Sub Main

          Dim diag As Diagram
          Dim mdl As Model
          Dim vw As View
          Dim so As SelectedObject
          Dim submdl As SubModel

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          If mdl.Logical = False Then

              Begin Dialog UserDialog 340,147,"Set Owner For Selected Views" ' %GRID:10,7,1,1
                  TextBox 120,42,150,21,.Owner
                  Text 50,49,50,14,"Owner:",.Text1
                  OKButton 80,98,90,21
                  CancelButton 210,98,90,21
              End Dialog
              Dim dlg As UserDialog

              If Dialog(dlg) = -1 Then

                  'loop through selected objects
                  For Each so In submdl.SelectedObjects

                      'Only concern with views type 16 selected object
                      If so.Type = 16 Then

                          Debug.Print so.Type

                          Set vw = mdl.Views.Item(so.ID)

                          'update table owner from dialog input
                          vw.Owner = dlg.Owner

                      End If

                  Next

              End If

          Else

              MsgBox("Active model must be a physical model.",vbOkOnly,"ERROR!")

          End If

      End Sub


Attachment Example.BAS

      'TITLE:  ATTACHMENT EXAMPLE.BAS
      'DESCRIPTION:  This macro exports attachment data for each bound
      '	attachment for every selected table in the active model.
      '	The file name and path is "C:\Attachment Data.txt"
      '

      ' Dim ER/Studio variables
      Dim diag As Diagram
      Dim ent As Entity
      Dim attmnt As Attachment
      Dim battmnt As BoundAttachment
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim notepad As Object

      ' output string
      Dim outstring As String

      Sub Main

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          'loop through the selected objects
          For Each so In submdl.SelectedObjects

              'only get the entities.
              If so.Type = 1 Then

                  'grab entity using the ID from the selected object
                  Set ent = mdl.Entities.Item(so.ID)

                  'outstring will be used to write to the text file
                  'write the entity name and table name
                  outstring = outstring & "Entity Name:  " & ent.EntityName & vbCrLf & "Table Name: " & ent.TableName & vbCrLf

                  'determine if there are any bound attachments
                  If ent.BoundAttachments.Count = 0 Then

                      outstring = outstring & vbTab & "No attachments on entity/table." & vbCrLf

                  Else

                      'loop through bound attachments
                      For Each battmnt In ent.BoundAttachments

                          'set attachment object to the base attachment from the data dictionary.
                          Set attmnt = battmnt.Attachment

                          'output the name (from the attachment in dictionary)
                          outstring = outstring & vbTab & "Attachment Name:  " & attmnt.Name & vbCrLf

                          'output the type the attachment belongs to (again from the dictionary)
                          outstring = outstring & vbTab & vbTab & "Parent Type:      " & attmnt.AttachmentType.Name & vbCrLf

                          'output the override value, this comes from the bound attachment since the value
                          'is overridden on the table
                          outstring = outstring & vbTab & vbTab & "Override value:   " & battmnt.ValueOverride & vbCrLf

                          'output the default value, this is from the attachment in the data dictionary.
                          outstring = outstring & vbTab & vbTab & "Default Value:    " & attmnt.ValueDefault & vbCrLf

                          outstring = outstring & vbCrLf

                      Next

                  End If

                  outstring = outstring & vbCrLf

              End If

          Next

          'write outstring to file
          Open "C:\Attachment Data.txt" For Output As #1
          Print #1, outstring
          Close #1

          MsgBox("Done!  See ""c:\Attachment Data.txt""",vbOkOnly)

      End Sub


Attribute Binding Macro.BAS

      'TITLE:  ATTRIBUTE BINDING MACRO.BAS
      'DESCRIPTION:  This macro lists all the unbound attributes/columns
      '  of all the models (logical and all physicals) and domains.  The
      '  attributes can then be bounded to any of listed domains by
      '  pressing the "Bind" button.
      'DATE:  5/3/2001
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'COMPANY:  Embarcadero Technologies

      Option Explicit

      Dim AttributeArray() As String
      Dim DomainArray() As String
      Dim AttributeIndx As Integer
      Dim DomainIndx As Integer
      Dim DomainCount As Integer

      Function SetupAttributes()

          Dim MyModel As Model
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim	MyAttribute As AttributeObj
          Dim DomainName As String
          Dim AttributeName As String
          Dim i As Integer
          Dim MyDictionary As Dictionary
          Dim AttrCount As Integer
          Dim MyDomain As Domain
          Dim fk_count As Integer

          'Set ER variables
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyDictionary = MyDiagram.Dictionary

          Debug.Clear

          ReDim AttributeArray(0)

          AttrCount = 0
          i = 0
          fk_count = 0

          For Each MyModel In MyDiagram.Models

          For Each MyEntity In MyModel.Entities

              If MyEntity.Attributes.Count <> 0 Then

                  AttrCount = AttrCount + MyEntity.Attributes.Count

                  ReDim Preserve AttributeArray(0 To AttrCount - 1)

                  For Each MyAttribute In MyEntity.Attributes

                      If MyAttribute.DomainId = 0 And MyAttribute.ForeignKey = False Then

                          If MyModel.Logical = True Then

                              AttributeArray(i) = "Logical  --  " & MyEntity.EntityName & "  --  " & MyAttribute.AttributeName

                          Else

                              AttributeArray(i) =	MyModel.Name & "  --  " & MyEntity.TableName & "  --  " & MyAttribute.ColumnName

                          End If

                          i = i + 1

                      Else

                          fk_count = fk_count + 1

                      End If

                  Next MyAttribute

                  AttrCount = i

              End If

          Next MyEntity

          Next MyModel

          Debug.Print "AttrCount= " & AttrCount + fk_count

          DomainCount = MyDictionary.Domains.Count

          If DomainCount = 0 Then

              ReDim DomainArray(0)
              DomainArray(0) = "No Domains in Dictionary."

          Else

              ReDim DomainArray(0 To DomainCount - 1)
              i = 0

              For Each MyDomain In MyDictionary.Domains

                  DomainArray(i) = MyDomain.Name
                  i = i + 1

              Next MyDomain

              dhQuickSort DomainArray()

          End If

      End Function

      Sub Main

          SetupAttributes()

          Begin Dialog UserDialog 720,350,"Attribute Binding Macro",.MyDialogFunction ' %GRID:10,7,1,1
              ListBox 30,35,180,245,DomainArray(),.Domains
              ListBox 250,35,440,252,AttributeArray(),.Attributes
              Text 30,14,90,14,"Domains:",.Text1
              Text 250,14,430,14,"Attributes (Format:  ModelName  --  EntityName  --  AttributeName):",.Text2
              OKButton 360,301,140,35
              PushButton 540,301,120,35,"Bind",.Bind
          End Dialog
          Dim dlg As UserDialog
          Dialog dlg

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function MyDialogFunction(DlgItem$, Action%, SuppValue&) As Boolean

          Dim Mo As Model
          Dim Diag As Diagram
          Dim Attr As AttributeObj
          Dim Ent As Entity
          Dim dic As Dictionary
          Dim dom As Domain
          Dim EntityName As String
          Dim AttributeName As String
          Dim ModelName As String
          Dim Idx As Integer
          Dim PrvIdx As Integer
          Dim Length As Integer
          Dim DomainName As String
          Dim Label As String

          Set Diag = DiagramManager.ActiveDiagram

          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              Debug.Print DlgItem & " " & SuppValue

              If DlgItem = "Attributes" Then

                  AttributeIndx = SuppValue

              ElseIf DlgItem = "Domains" Then

                  DomainIndx = SuppValue

              ElseIf DlgItem = "Bind" Then

                  If DomainCount = 0 Then

                      MsgBox("No Domains are in the Dictionary",0,"Error!")

                  ElseIf AttributeIndx <> -1 Then

                      Debug.Print AttributeIndx

                      Label = AttributeArray(AttributeIndx)
                      Debug.Print Label

                      'First, get the model name.

                      Idx = InStr(1, Label, "  --  ")
                      Debug.Print Idx
                      ModelName = Left(Label, Idx - 1)
                      Debug.Print ModelName

                      'Second, get the entity name.

                      PrvIdx = Idx + 6
                      Idx = InStr(PrvIdx, Label, "  --  ")
                      Length = Idx - PrvIdx
                      EntityName = Mid(Label, PrvIdx, Length)

                      'Last, get the attribute name.

                      Length = Len(Label)
                      Length = Length - Idx - 5
                      AttributeName = Right(Label, Length)

                      'Now, get the model object from the model name.

                      Set Mo = Diag.Models.Item(ModelName)

                      'Get the entity from the entity name.

                      Set Ent = Mo.Entities.Item(EntityName)

                      'Get the attribute from the attribute name.

                      Set Attr = Ent.Attributes.Item(AttributeName)

                      'Get the domain associated with the one selected

                      DomainName = DomainArray(DomainIndx)

                      Set dom = Diag.Dictionary.Domains.Item(DomainName)

                      Attr.DomainId = dom.ID

                      SetupAttributes()
                      DlgListBoxArray("Attributes", AttributeArray())
                      AttributeIndx = -1

                  Else

                      MsgBox("Please select an Attribute.")

                  End If

                  MyDialogFunction = True ' Prevent button press from closing the dialog box

              End If
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem MyDialogFunction = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      ' **The following code is taken from the specified book.  It has been modified
      ' **to perform a case insensitive sort.

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant,Optional intLeft As Integer, Optional intRight As Integer)
          ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If
      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


Auto-Align Selected Entities Left.bas

      ''MACRO TITLE: AUTO-ALIGN SELECTED ENTITIES LEFT MACRO
      'This macro will perform the 'align left' operation (similar
      'to the align buttons on the Alignment Toolbar) for all selected
      'entities.

      'This macro demonstrates more on how to use entity display objects.
      '-------------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim MySubModel As SubModel
          Dim MySelObject As SelectedObject
          Dim MyAttribute As AttributeObj
          Dim MyEntityDisplay As EntityDisplay
          Dim LeftMostEntity As EntityDisplay

          Dim ID As Integer
          Dim LeftMost As Integer
          Dim xPosition As Integer
          Dim Logical As Boolean
          Dim ObjectName As String
          Dim ObjType As Integer

          LeftMost = -1

          'Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          'Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          'Get the current submodel.

          Set MySubModel = MyModel.ActiveSubModel

          'Determine if the model is logical or physical.

          Logical = MyModel.Logical

          'FDetermine the left-most coordinate position is. Iterate
          'through all the selected entities in the submodel and
          'found out which entity is the left-most.

          For Each MySelObject In MySubModel.SelectedObjects

              'Get type of the selected object.

              ObjType = MySelObject.Type

              'We only want to align entities, so check the
              'object type.

              If ObjType = 1 Then

                  'Get the ID of the selected object.

                  ID = MySelObject.ID

                  'Now, get the actual entity object with this ID.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  'We need to get the entity name, so that we can
                  'get the corresponding entity display object from
                  'the submodel.

                  'If the model is logical, get the entity name.
                  'If it is physical, get the table name.

                  If Logical = True Then
                      ObjectName = MyEntity.EntityName
                  Else
                      ObjectName = MyEntity.TableName
                  End If

                  'Get the entity display object from the submodel.

                  Set MyEntityDisplay = MySubModel.EntityDisplays.Item(ObjectName)

                  'Get the x coordinate (upper left corner) of the
                  'entity display object.

                  xpos = MyEntityDisplay.HorizontalPosition

                  'If this x coordinate is less than any of the
                  'x coordinates so far, then assign this x coordinate
                  'as the left-most.

                  If xpos < LeftMost Or LeftMost = -1 Then
                      LeftMost = xpos
                  End If

              End If

          Next MySelObject

          'Now iterate through all selected entities and align each
          'of the left sides with the smallest x coordinate
          'found above.

          For Each MySelObject In MySubModel.SelectedObjects

              'Get type of the selected object.

              ObjType = MySelObject.Type

              'We only want to align entities, so check the
              'object type.

              If ObjType = 1 Then

                  ID = MySelObject.ID

                  'Now, get the actual entity object with this ID.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  'We need to get the entity name, so that we can
                  'get the corresponding entity display object from
                  'the submodel.

                  'If the model is logical, get the entity name.
                  'If it is physical, get the table name.

                  If Logical = True Then
                      ObjectName = MyEntity.EntityName
                  Else
                      ObjectName = MyEntity.TableName
                  End If

                  'Get the entity display object from the submodel.

                  Set MyEntityDisplay = MySubModel.EntityDisplays.Item(ObjectName)

                  'Align the left side of the entity display object
                  'with the smallest x coordinate found in
                  'the previous iteration loop.

                  MyEntityDisplay.HorizontalPosition = LeftMost

              End If

          Next MySelObject

      End Sub


Auto-Color All Entities with FKs.bas

      ''MACRO TITLE: AUTO-COLOR ALL ENTITIES WITH FKS MACRO
      'This macro will make all entities with foreign keys purple.
      'It will first select (highlight) all entities in the current,
      'submodel. Then it will make all selected entities with
      'foreign keys (which, in this case, are all the entities in the
      'submodel) purple.  Finally, it will deselect (unhighlight) all
      'entities in the current, active submodel.

      'This macro illustrates how to use entity objects, entity display
      'objects, and selected objects - and how to distinguish among
      'them.
      '------------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntityDisplay As EntityDisplay
          Dim MyEntity As Entity
          Dim MySubModel As SubModel
          Dim MyAttribute As AttributeObj
          Dim MySelObject As SelectedObject

          Dim ObjectName As String
          Dim ForeignKey As Boolean
          Dim Logical As Boolean

          'Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          'Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          'Determine if the model is logical or physical.

          Logical = MyModel.Logical

          'Get the current submodel.

          Set MySubModel = MyModel.ActiveSubModel

          'Iterate through all the entity display objects in the
          'current SubModel And Select (highlight) all entities in
          'the SubModel.

          For Each MyEntityDisplay In MySubModel.EntityDisplays

              'In order to select (highlight) an entity object in
              'a submodel, we need to pass in the actual ID of the
              'entity object (not the entity display object) to
              'the 'Add' function of the SelectedObjects collection.

              'In order to get the ID of the actual entity object,
              'we get the name of the entity from the entity
              'display object, and then pass it to the 'Item' method
              'of the Entities collection.  This will allow us to get
              'the actual entity object.

              ObjectName = MyEntityDisplay.Name

              Set MyEntity = MyModel.Entities.Item(ObjectName)

              ID = MyEntity.ID

              'Now we actually add the entity to the SelectedObjects
              'collection.  This will highlight the entity on the screen.
              'The first parameter to 'Add' is the type.  In this case,
              'type is 1 (entity).  The second parameter is the ID of
              'the entity.

              MySubModel.SelectedObjects.Add(1, ID)

          Next MyEntityDisplay

          'Now, we iterate through all the selected entities in
          'the submodel and set the entity background color of
          'selected entities with foreign keys to red.

          For Each MySelObject In MySubModel.SelectedObjects

              'Get the object type - we are only concerned
              'with entities.

              ObjType = MySelObject.Type

              If ObjType = 1 Then

                  ' Get the ID for the selected object.

                  ID = MySelObject.ID

                  ' Now get the actual entity object with this ID.
                  ' The model contains the collection of all the
                  ' entities.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  'We need to the name of the entity.  We can use the
                  'name to get the entity display object from the submodel.

                  If Logical = True Then

                      ' If the model is logical, get the entity
                      ' name.

                      ObjectName = MyEntity.EntityName
                  Else

                      ' If the model is physical, get the table
                      ' name.

                      ObjectName = MyEntity.TableName
                  End If

                  'Iterate through all the attributes in the entity
                  'and see if there are any foreign keys.

                  For Each MyAttribute In MyEntity.Attributes

                      'Determine if the attribute is a foreign key.

                      ForeignKey = MyAttribute.ForeignKey

                      If ForeignKey = True Then

                          'If the attribute is a foreign key, then we want
                          'to get the entity display object from the
                          'submodel and make the entity display object
                          'red.

                          'In order to get the entity display object from
                          'the submodel, we pass in the entity name to the
                          'EntityDisplays 'Item' function.

                          'Note: We cannot pass in the ID of the entity object
                          'because entity display objects and entity objects
                          'use different sets of IDs.

                          If Logical = True Then

                              ' If the model is logical, get the entity
                              ' name.

                              ObjectName = MyEntity.EntityName
                          Else

                              ' If the model is physical, get the table
                              ' name.

                              ObjectName = MyEntity.TableName
                          End If

                          Set MyEntityDisplay = MySubModel.EntityDisplays.Item(ObjectName)

                          'Change the color of local, non-key attributes.
                          'We want the color to be purple.

                          'In hexadecimal, the color format is:
                          '0x00BBGGRR (RR - red, GG - green, BB - blue)

                          'Each of the three primary colors can have a
                          'value from 0-255.

                          'So, in hex, purple is 0x0000FFFF.

                          MyEntityDisplay.BackgroundColor =8866444

                          'Once we have changed the color of the entity
                          'display object, we don't have to continue to
                          'iterate through the attributes, so just exit
                          'the iteration loop.

                          Exit For

                      End If

                  Next MyAttribute

              End If

          Next MySelObject

          'Now we want to iterate through all the entity display
          'objects in the active submodel and deselect (unhighlight)
          'all entities in the submodel.

          For Each MyEntityDisplay In MySubModel.EntityDisplays

              'In order to select (highlight) an entity object in
              'a submodel, we need to pass In the actual ID of the
              'entity object (not the entity display object) to
              'the 'Add' function of the SelectedObjects collection.

              'In order to get the ID of the actual entity object,
              'we first get the name of the entity from the entity
              'display object, and then pass that to the 'Item' method
              'of the Entities collection.  This will allow us to get
              'the actual entity object.

              ObjectName = MyEntityDisplay.Name

              Set MyEntity = MyModel.Entities.Item(ObjectName)

              ID = MyEntity.ID

              'Now we actually add the entity to the SelectedObjects
              'collection.  This will highlight the entity on the screen.
              'The first parameter to 'Remove' is the type.  In this case,
              'type is 1 (entity).  The second parameter is the ID of
              'the entity.

              MySubModel.SelectedObjects.Remove(1, ID)

          Next MyEntityDisplay
      End Sub


Auto-Combine Selected Entities.bas

      ''MACRO TITLE: AUTO-COMBINE SELECTED ENTITIES MACRO
      'It will take all the attributes from all the selected entities
      'and add them into one newly created entity.
      '-----------------------------------------------------------------

      'GetAveragePoint/
      'This function will get the average x or y coordinate point among
      'all selected entities.  The second parameter determines whether
      'to calculate the average x coordinate or the average y coordinate.

      Function GetAveragePoint(MyModel As Model, GetXPoint As Boolean) As Integer

          Dim ID As Integer
          Dim MyEntity As Entity
          Dim MySubModel As SubModel
          Dim MySelObject As SelectedObject
          Dim ObjectName As String
          Dim Logical As Boolean
          Dim MyEntityDisplay As EntityDisplay

          Dim TotalPoint As Integer
          Dim AveragePoint As Integer
          Dim Point As Integer
          Dim ObjType As Integer

          Point = -1
          TotalPoint = -1
          AveragePoint = -1

          'Determine whether or not the model is logical.

          Logical = MyModel.Logical

          'Get the current submodel.

          Set MySubModel = MyModel.ActiveSubModel

          'Now iterate through all the selected objects and accumulate
          'all the x or y coordinates for all selected entities.

          For Each MySelObject In MySubModel.SelectedObjects

              'We are only concerned with entities, so check the
              'object type.

              ObjType = MySelObject.Type

              If ObjType = 1 Then

                  'Get the ID of the selected object.

                  ID = MySelObject.ID

                  'Now, get the entity object with this ID.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  'We need to get the entity name, so that we can
                  'get the corresponding entity display object from
                  'the submodel.

                  'If the model is logical, get the entity name.
                  'Otherwise, get the table name.

                  If Logical = True Then
                      ObjectName = MyEntity.EntityName
                  Else
                      ObjectName = MyEntity.TableName
                  End If

                  'Get the entity display object from the submodel.

                  Set MyEntityDisplay = MySubModel.EntityDisplays.Item(ObjectName)

                  'If the user wants the average x coordinate, then
                  'accumulate the x point of the selected entity.
                  'Otherwise, accumulate the y point of the selected
                  'entity.

                  If GetXPoint = True Then
                      Point = MyEntityDisplay.HorizontalPosition
                  Else
                      Point = MyEntityDisplay.VerticalPosition
                  End If

              End If

              'Add the current point to the total point value.

              TotalPoint = TotalPoint + Point

          Next MySelObject

          'Get the count of selected entities.

          NumSelObjects = MySubModel.SelectedObjects.Count

          'If the count is not 0, then get the average point value
          'by dividing the total Point value from the number of
          'selected objects.

          If NumSelObjects <> 0 Then
              AveragePoint = TotalPoint / NumSelObjects
          End If

          'Return this average point value.

          GetAveragePoint = AveragePoint

      End Function

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim MySubModel As SubModel
          Dim MySelObject As SelectedObject
          Dim MyAttribute As AttributeObj
          Dim MyEntityDisplay As EntityDisplay
          Dim LeftMostEntity As EntityDisplay
          Dim NewEntity As Entity
          Dim NewAttribute As AttributeObj

          Dim AttributeName As String
          Dim ID As Integer
          Dim Logical As Boolean
          Dim AttributePrefix As String
          Dim ObjType As Integer
          Dim PrimaryKey As Boolean
          Dim xPoint As Integer
          Dim yPoint As Integer
          Dim NewEntityName As String
          Dim Datatype As String
          Dim NullOption As String
          Dim DataScale As Integer
          Dim DataLength As Integer

          'Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          'Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          'Get the current submodel.

          Set MySubModel = MyModel.ActiveSubModel

          'Determine whether the model is logical.

          Logical = MyModel.Logical

          'Get the average x coordinate value among all selected
          'entities.

          xPoint = GetAveragePoint(MyModel, True)

          'Get the average y coordinate value among all selected
          'entities.

          yPoint = GetAveragePoint(MyModel, False)

          'Create a new entity at the average x and y coordinate
          'values.

          If xPoint <> -1 And yPoint <> -1 Then
              Set NewEntity = MyModel.Entities.Add(xPoint, yPoint)
          Else
              Exit Sub
          End If

          'Iterate through all the selected entities and 'move' all the
          'attributes from each selected entity into the new entity.
          'The way we 'move' attributes from each original entity
          'to the new entity is by creating a new attribute in the
          'new entity and copying all the attribute properties from
          'the old attribute to the new attribute.

          For Each MySelObject In MySubModel.SelectedObjects

              'Get type of the selected object.

              ObjType = MySelObject.Type

              'We are only concerned with entities, so
              'check the object type.

              If ObjType = 1 Then

                  'Get the ID of the selected object.

                  ID = MySelObject.ID

                  'Get the actual entity object with this ID

                  Set MyEntity = MyModel.Entities.Item(ID)

                  'We get the original entity name for two reasons:

                  '1)
                  'In order to create new, unique attribute names
                  'in the new entity we will take the old attribute name
                  'and add the original entity name as a prefix.
                  'This will ensure that all attribute
                  'names in the new entity will be unique.

                  '2)
                  'Also, we want to create a new name for the new
                  'entity.  The name will be all the original entity
                  'names appended together.

                  'If the model is logical, get the entity name.
                  'Otherwise, get the table name.

                  If Logical = True Then
                      AttributePrefix = MyEntity.EntityName
                      NewEntityName = MyEntity.EntityName + "_" + NewEntityName
                  Else
                      AttributePrefix = MyEntity.TableName
                      NewEntityName = MyEntity.TableName + "_" + NewEntityName
                  End If

                  'Iterate through all the attributes in the original
                  'selected entity. For each attribute, we will create
                  'a new attribute in the new entity and copy the
                  'properties of the old attribute to the new attribute.

                  For Each MyAttribute In MyEntity.Attributes

                      'We are only concerned with non-foreign key
                      'attributes.  So, check the foreign key status
                      'of the attribute.

                      If MyAttribute.ForeignKey = False Then

                          'To create the new attribute name,
                          'we have to get the old attribute name and
                          'prefix it with the original entity name.
                          '(As explained above.)

                          'We want the attribute name if the model
                          'is logical.  Otherwise, we want the column
                          'name.

                          If Logical = True Then
                              AttributeName = MyAttribute.AttributeName
                          Else
                              AttributeName = MyAttribute.ColumnName
                          End If

                          'Create the new attribute name.

                          AttributeName = AttributePrefix + "_" + AttributeName

                          'For now, we will just copy the primary
                          'key status, the datatype, and the null option
                          'from the old attribute to the new attribute.
                          'So, get these properties from the old
                          'attribute.

                          PrimaryKey = MyAttribute.PrimaryKey
                          Datatype = MyAttribute.Datatype
                          DataLength = MyAttribute.DataLength
                          DataScale = MyAttribute.DataScale
                          NullOption = MyAttribute.NullOption

                          'Create the new attribute in the new entity.
                          'The original primary key status is passed in
                          'as a parameter to the Add function.

                          Set NewAttribute = NewEntity.Attributes.Add(AttributeName, PrimaryKey)

                          'Now set the datatype and null option of the
                          'new attribute to match that of the old attribute.

                          NewAttribute.Datatype = Datatype
                          NewAttribute.DataLength = DataLength
                          NewAttribute.DataScale = DataScale
                          NewAttribute.NullOption = NullOption
                      End If

                  Next MyAttribute

                  'Now that we've copied all the attributes from
                  'the original selected entity, we can delete the
                  'original entity.

                  MyModel.Entities.Remove(ID)

              End If

          Next MySelObject

          'Change the name of the new entity.  The new name
          'equals all the original selected entity names appended
          'together.

          NewEntity.EntityName = NewEntityName
          NewEntity.TableName = NewEntityName

      End Sub


Auto-Convert Datatype.bas

      ''MACRO TITLE: AUTO-CONVERT DATATYPE (VARCHAR->TEXT)
      'This macro will iterate through all the selected entities
      'and change the datatypes for all attributes which use
      'VARCHAR to TEXT.
      '----------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim MySubModel As SubModel
          Dim MySelObject As SelectedObject
          Dim MyAttribute As AttributeObj

          Dim EntityName As String
          Dim NewEntityName As String
          Dim Prefix As String
          Dim Datatype As String
          Dim ID As Integer
          Dim ObjType As Integer

          ' Get the current diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          ' Get the current model.

          Set MyModel = MyDiagram.ActiveModel

          ' Get the current submodel.

          Set MySubModel = MyModel.ActiveSubModel

          ' Iterate through all the selected objects in the
          ' submodel.

          For Each MySelObject In MySubModel.SelectedObjects

              ' We are only concerned about entities.

              ObjType = MySelObject.Type

              If ObjType = 1 Then

                  ' Get the ID of the selected object.

                  ID = MySelObject.ID

                  ' Get the actual entity object with this ID.

                  Set MyEntity = MyModel.Entities.Item(ID)

                  ' Iterate through all attributes in this entity.

                  For Each MyAttribute In MyEntity.Attributes

                      ' Get the datatype of the attribute.

                      Datatype = MyAttribute.Datatype

                      ' If the datatype is "VARCHAR", then change
                      ' it to "TEXT".

                      If Datatype = "VARCHAR" Then
                          MyAttribute.Datatype = "TEXT"
                      End If

                  Next MyAttribute

              End If

          Next MySelObject

      End Sub


Auto-Create Data Dictionary.bas

      'MACRO TITLE: AUTO-CREATE DATA DICTIONARY
      'The purpose of this macro is to create a user defined data dictionary quickly. The macro
      'can be used as a template to create user-defined or business-specific data dictionaries. This macro
      'can be inserted into ER/Studio's ERSBasicHandlers system (specifically in the
      '"CreateDiagramHandler(CurDiagram As Object)" section of ERSBasicHandlers) and if the Create Handlers
      'option is checked on in ER/Studio's Automation Interface Options, this Data Dictionary will be created
      'and populated any time a user creates a new diagram.
      '------------------------------------------------------------------------------------------
      Sub Main()
              Dim MyDiagram As Diagram
              Dim MyModel As Model
              Dim MyDomain As Domain
              Dim MyDictionary As Dictionary
              Dim ID As Integer

              'Create a new diagram.

              Set MyDiagram = DiagramManager.ActiveDiagram

              'Get the data dictionary.

              Set MyDictionary = MyDiagram.Dictionary

              'Get the current model (in this case, the logical model).

              Set MyModel = MyDiagram.ActiveModel

              'ID domain.

              Set MyDomain = MyDictionary.Domains.Add("ID", "ID")
              MyDomain.Datatype = "INTEGER"
          MyDomain.Identity = True
          MyDomain.IdentitySeed = 1
          MyDomain.IdentityIncrement = 1

              'ObjectID domain.

              Set MyDomain = MyDictionary.Domains.Add("ObjectID", "Object ID")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False

              'Name domain.

              Set MyDomain = MyDictionary.Domains.Add("Name", "Name")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 30
              MyDomain.Nullable = False

              'LongName domain.

              Set MyDomain = MyDictionary.Domains.Add("LongName", "Name")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = False

              'Owner domain.

              Set MyDomain = MyDictionary.Domains.Add("Owner", "Owner")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 30
              MyDomain.Nullable = True

              'Description domain.

              Set MyDomain = MyDictionary.Domains.Add("Description", "Description")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = True

              'Comments domain.

              Set MyDomain = MyDictionary.Domains.Add("Comments", "Comments")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = True

              'FilePath domain.

              Set MyDomain = MyDictionary.Domains.Add("FilePath", "File Path")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = True

              'Role Name domain.

              Set MyDomain = MyDictionary.Domains.Add("RoleName", "Role Name")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = True

              'ValueString domain.

              Set MyDomain = MyDictionary.Domains.Add("ValueString", "Value")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = False

              'ValueShortString domain.

              Set MyDomain = MyDictionary.Domains.Add("ValueShortString", "Value")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 30
              MyDomain.Nullable = False

              'ValueNumber domain.

              Set MyDomain = MyDictionary.Domains.Add("ValueNumber", "Value")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False

              'URL domain.

              Set MyDomain = MyDictionary.Domains.Add("URL", "URL")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 254
              MyDomain.Nullable = True

              'Quantity domain.

              Set MyDomain = MyDictionary.Domains.Add("Quantity", "Quantity")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False

              'SequenceNbr domain.

              Set MyDomain = MyDictionary.Domains.Add("SequenceNbr", "Sequence Nbr")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False

              'ListOrder domain.

              Set MyDomain = MyDictionary.Domains.Add("ListOrder", "List Order")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False

              'Min domain.

              Set MyDomain = MyDictionary.Domains.Add("Min", "Min")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False

              'Max domain.

              Set MyDomain = MyDictionary.Domains.Add("Max", "Max")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = True

              'Epoch domain.

              Set MyDomain = MyDictionary.Domains.Add("Epoch", "Epoch")
              MyDomain.Datatype = "INTEGER"
              MyDomain.Nullable = False
              MyDomain.DeclaredDefault = 1

              'Percent domain.

              Set MyDomain = MyDictionary.Domains.Add("Percent", "Percent")
              MyDomain.Datatype = "NUMERIC"
              MyDomain.DataLength = 5
              MyDomain.DataScale = 3
              MyDomain.Nullable = False

              'Is domain.

              Set MyDomain = MyDictionary.Domains.Add("Is", "Is")
              MyDomain.Datatype = "BIT"
              MyDomain.Nullable = False

              'IsDefault domain.

              Set MyDomain = MyDictionary.Domains.Add("IsDefault", "Is Default")
              MyDomain.Datatype = "BIT"
              MyDomain.Nullable = False

              'IsCurrentVersion domain.

              Set MyDomain = MyDictionary.Domains.Add("IsCurrentVersion", "Is Current Version")
              MyDomain.Datatype = "BIT"
              MyDomain.Nullable = False

              'IsModified domain.

              Set MyDomain = MyDictionary.Domains.Add("IsModified", "Is Modified")
              MyDomain.Datatype = "BIT"
              MyDomain.Nullable = False

              'IsRequired domain.

              Set MyDomain = MyDictionary.Domains.Add("IsRequired", "Is Required")
              MyDomain.Datatype = "BIT"
              MyDomain.Nullable = False

              'IsSystemRequired domain.

              Set MyDomain = MyDictionary.Domains.Add("IsSystemRequired", "Is System Required")
              MyDomain.Datatype = "BIT"
              MyDomain.Nullable = False

              'CreateDate.

              Set MyDomain = MyDictionary.Domains.Add("CreateDate", "Create Date")
              MyDomain.Datatype = "DATETIME"
              MyDomain.Nullable = False
              MyDomain.DeclaredDefault = "getdate()"

              'CreatedBy.

              Set MyDomain = MyDictionary.Domains.Add("CreatedBy", "Created By")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 30
              MyDomain.Nullable = False
              MyDomain.DeclaredDefault = "user_name()"

              'ModifiedDate.

              Set MyDomain = MyDictionary.Domains.Add("ModifiedDate", "Modified Date")
              MyDomain.Datatype = "DATETIME"
              MyDomain.Nullable = False
              MyDomain.DeclaredDefault = "getdate()"

              'ModifiedBy.

              Set MyDomain = MyDictionary.Domains.Add("ModifiedBy", "Modified By")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 30
              MyDomain.Nullable = False
              MyDomain.DeclaredDefault = "user_name()"

              'IPAddress.

              Set MyDomain = MyDictionary.Domains.Add("IPAddress", "IP Address")
              MyDomain.Datatype = "CHAR"
              MyDomain.DataLength = 15
              MyDomain.Nullable = False

              'Subnet.

              Set MyDomain = MyDictionary.Domains.Add("Subnet", "Subnet")
              MyDomain.Datatype = "CHAR"
              MyDomain.DataLength = 15
              MyDomain.Nullable = False

              'Datetime.

              Set MyDomain = MyDictionary.Domains.Add("Datetime", "Datetime")
              MyDomain.Datatype = "DATETIME"
              MyDomain.Nullable = True

              'RowTimestamp.

              Set MyDomain = MyDictionary.Domains.Add("RowTimestamp", "RowTimestamp")
              MyDomain.Datatype = "TIMESTAMP"
              MyDomain.Nullable = True

              'Datetype.

              Set MyDomain = MyDictionary.Domains.Add("Datatype", "Data Type")
              MyDomain.Datatype = "VARCHAR"
              MyDomain.DataLength = 30
              MyDomain.Nullable = True

      End SuSuSu


Auto-Create Data Dictionary and Bound Domain.bas

      'MACRO TITLE: AUTO-CREATE DATA DICTIONARY AND BOUND DOMAIN MACRO
      'This macro will create a new diagram, then create a rule, default
      'and domain in the data dictionary. Then it will bind the rule and
      'default to the domain. Next, it will then create an entity and an
      'attribute. Finally, it will bind the domain to the attribute.
      '-------------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity
          Dim MyRule As Rule
          Dim MyDefault As Default
          Dim MyDomain As Domain
          Dim MyAttribute As AttributeObj
          Dim MyDictionary As Dictionary
          Dim ID As Integer

          'Create a new diagram.

          Set MyDiagram = DiagramManager.NewDiagram

          'Get the data dictionary.

          Set MyDictionary = MyDiagram.Dictionary

          'Get the current model (in this case, the logical model).

          Set MyModel = MyDiagram.ActiveModel

          'Create a default with a value of 1.

          Set MyDefault = MyDictionary.Defaults.Add("MyDefault", "1")

          'Create a rule with the constraint of "> 0".

          Set MyRule = MyDictionary.Rules.Add("MyRule", "@var > 0")

          'Create a domain.

          Set MyDomain = MyDictionary.Domains.Add("MyDomain", "MyDomain")

          'Set the datatype for the domain as integer.

          MyDomain.Datatype = "INTEGER"

          'Bind the default to the domain by setting the default's
          'ID into the domain's DefaultId property.

          ID = MyDefault.ID
          MyDomain.DefaultId = ID

          'Bind the rule to the domain by setting the rule's
          'ID into the domain's RuleId property.

          ID = MyRule.ID
          MyDomain.RuleId = ID

          'Create a new entity in the model.

          Set MyEntity = MyModel.Entities.Add(100, 100)

          MyEntity.EntityName = "MyEntity"
          MyEntity.TableName = "MyEntity"

          'Create a new attribute in the entity.

          Set MyAttribute = MyEntity.Attributes.Add("MyAttribute", False)

          'Bind the domain to the attribute by setting the domain's
          'ID into the attribute's DomainId property.

          ID = MyDomain.ID
          MyAttribute.DomainId = ID

      End Sub


Auto-Create New Diagram.bas

      'MACRO TITLE: AUTO-CREATE A NEW DIAGRAM
      'This macro creates a new diagram.  The new diagram will
      'contain an IBM DB/2 physical model and six entities in the
      'physical model.
      '----------------------------------------------------------------

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MyEntity As Entity

          ' Create a new diagram.

          Set MyDiagram = DiagramManager.NewDiagram

          ' A new diagram will automatically have a logical.
          ' model - which is also the currently, active model.

          Set MyModel = MyDiagram.ActiveModel

          ' Add 6 entities to the model.

          MyModel.Entities.Add(100, 100)
          MyModel.Entities.Add(300, 100)
          MyModel.Entities.Add(500, 100)
          MyModel.Entities.Add(100, 400)
          MyModel.Entities.Add(300, 400)
          MyModel.Entities.Add(500, 400)

          'Create a physical model with the IBM DB/2 database
          'platform type.

          MyDiagram.Models.Add("MyPhysicalModel", 32)

          'Get the physical model.

          Set MyModel = MyDiagram.Models("MyPhysicalModel")

          'Get the entity, 'Entity1.'

          Set MyEntity = MyModel.Entities.Item("Entity1")

          'Add a primary key attribute to 'Entity1.'

          MyEntity.Attributes.Add("PKAttribute1", True)

          'Now add relationships to connect all the six entities
          'together.

          MyModel.Relationships.Add("Entity1", "Entity5", 0)
          MyModel.Relationships.Add("Entity5", "Entity3", 0)
          MyModel.Relationships.Add("Entity3", "Entity6", 0)
          MyModel.Relationships.Add("Entity6", "Entity2", 0)
          MyModel.Relationships.Add("Entity2", "Entity4", 0)

      End Sub


Constraint Generator.bas

      'TITLE:  GENERATE CONSTRAINTS FROM REFERENCE VALUES
      'DESCRIPTION:  This macro generates constraints from the defined
      '	reference values.  The reference values must be defined in the
      '	data dictionary of ER/Studio.  The macro can select from bound
      '	attributes, all attributes, bound domains or all domains.  This
      '	is chosen with the radio buttons at the bottom of the dialog.
      '	the constraint will be inserted in the check constraint/rule
      '	tab of the domain or attribute.
      'MODIFY DATE:  11/25/2002

      'ER/Studio variables
      Dim ersMdl As Model
      Dim ersDiag As Diagram
      Dim ersEnt As Entity
      Dim ersAttr As AttributeObj
      Dim ersRefVal As ReferenceValue
      Dim ersDict As Dictionary
      Dim ersDom As Domain
      Dim ersUDT As UserDatatype

      'Dialog Array variables
      Dim arrRefVals() As String
      Dim arrAvailableAttrs() As String
      Dim arrSelectedAttrs() As String
      Dim arrAvailAttrsIndx As Integer
      Dim arrSelAttrsIndx As Integer

      'count variables
      Dim allattrcount As Integer
      Dim boundattrcount As Integer
      Dim domaincount As Integer

      Type AttrPair
       tblname As String
       attrname As String
       refvalid As Integer
      End Type

      Type DomPair
       domName As String
       refvalid As Integer
      End Type

      Dim AllAttrPairs() As AttrPair
      Dim boundAttrPairs() As AttrPair
      Dim AllDomains() As DomPair

      Dim AvailCurIndx As Integer
      Dim SelCurIndx As Integer
      Dim RefCurIndx As Integer

      Sub GetRefVals

          Dim i As Integer

          i = 0

          If ersDict.ReferenceValues.Count <> 0 Then

              ReDim arrRefVals (0 To ersDict.ReferenceValues.Count - 1) As String

              For Each ersRefVal In ersDict.ReferenceValues

                  arrRefVals(i) = ersRefVal.Name
                  Debug.Print ersRefVal.ID
                  i = i + 1

              Next

          Else

              ReDim arrRefVals (0)

          End If

      End Sub

      Function genConstraint (rvName As String) As String

          Dim constraint As String
          Dim vp As ValuePair
          Dim rv As ReferenceValue

          Set rv = ersDiag.Dictionary.ReferenceValues.Item(rvName)

          If Not(rv Is Nothing) Then

          If rv.IsRange = True Then

              If rv.IsNotBetween = True Then

                  constraint = "@var < " & rv.MinValue & " AND @var > " & rv.MaxValue

              Else

                  constraint = "@var >= " & rv.MinValue & " AND @var <= " & rv.MaxValue

              End If

          Else

              If rv.IsNotBetween = True Then

                  constraint = "@var NOT IN ("

                  For Each vp In rv.Values

                      If IsNumeric(vp.Value) Or hasQuotes(vp.Value) Then

                          constraint = constraint & vp.Value & ", "

                      ElseIf  Not(hasQuotes(vp.Value)) Then

                          constraint = constraint & "'" & vp.Value & "'" & ", "

                      End If

                  Next

                  Left(constraint, Len(constraint) - 2)

                  constraint = constraint & ")"

              Else

                  constraint = "@var IN ("

                  For Each vp In rv.Values

                      If IsNumeric(vp.Value) Or hasQuotes(vp.Value) Then

                          constraint = constraint & vp.Value & ", "

                      ElseIf  Not(hasQuotes(vp.Value)) Then

                          constraint = constraint & "'" & vp.Value & "'" & ", "

                      End If

                  Next

                  constraint = Left(constraint, Len(constraint) - 2)

                  constraint = constraint & ")"

              End If

          End If

          genConstraint = constraint

          Else

          genConstraint = ""

          End If

      End Function

      Function hasQuotes (st As String) As Boolean

          If Left(st, 1) = "'" And Right(st, 1) = "'" Then

              hasQuotes = True

          ElseIf Left(st, 1) = """" And Right(st, 1) = """" Then

              hasQuotes = True

          Else

              hasQuotes = False

          End If

      End Function

      Function applyConstraint (tbl As String, col As String, con As String)

          Dim ent As Entity
          Dim att As AttributeObj

          Set ent = ersMdl.Entities.Item(tbl)
          Set att = ent.Attributes.Item(col)

          att.CheckConstraint = con

      End Function

      Function applyConstraintDomain (d As String, con As String)

          Dim dom As Domain

          Set dom = ersDict.Domains.Item(d)

          dom.CheckConstraint = con

      End Function

      'This function is used to initialize the passed-in array with all
      'the tables in the physical model.  It will fill the target array
      'when the AddAll and RemoveAll buttons in the dialog are pressed.
      Function SetupBoundAttrArray(attrs() As String, refname As String)

          Debug.Print "SetupBoundAttrArray"

          Dim i,j,count As Integer

          count = 0

          For i = 0 To boundattrcount - 1

              Set ersRefVal = ersDiag.Dictionary.ReferenceValues.Item(refname)

              If ersRefVal.ID = boundAttrPairs(i).refvalid Then

                  count = count + 1

              End If

          Next

          Debug.Print "count = " & count

          i = 0

          If count <= 0 Then

              ReDim attrs(0) As String

          Else

              ReDim attrs (0 To count - 1) As String

              j = 0

              'Refresh Array with table names
              For i = 0 To boundattrcount - 1

                  Set ersRefVal = ersDiag.Dictionary.ReferenceValues.Item(refname)

                  If ersRefVal.ID = boundAttrPairs(i).refvalid Then

                      attrs(j) = boundAttrPairs(i).tblName & "  --  " & boundAttrPairs(i).attrName
                      Debug.Print vbTab & i & " = " & attrs(j)
                      j = j + 1

                  End If

              Next

          End If

      End Function

      'This function clears the passed-in array of all the names.  It clears the
      'source array when the AddAll and RemoveAll buttons are pressed.
      Function ClearAttrArray(attrs As Variant)

          If allattrcount > domaincount Then

              ReDim attrs(0 To allattrcount) As String

          Else

              ReDim attrs(0 To domaincount) As String

          End If

      End Function

      'This function is used to move single tables between the listboxes.  It
      'will add tables to the front of the target array and pad the back of the
      'source array with blank entries
      Function MoveAttr (source As Variant, target As Variant, source_indx As Integer)

          Dim s_count As Integer  'upper bound of the source array
          Dim t_count As Integer  'upper bound of the target array
          Dim i As Integer

          s_count = UBound(source)
          t_count = UBound(target) - 1

          Debug.Print "t_count = " & t_count

          'move all the entries back one slot in the target array to make
          'room for the new entry
          For i = t_count To 0 Step -1
              target(i+1) = target(i)
              Debug.Print "target(" & i & ") = " & target(i)
          Next i

          'add the new entry
          target(0) = source(source_indx)
          Debug.Print source(source_indx) & ", index = " & source_indx

          'move all the entries after the vacant slot up one slot to fill the hole
          For i = source_indx + 1 To s_count
              source(i-1) = source(i)
          Next i

          'pad the last entry with a null string
          source(s_count) = ""

      End Function

      Function loadBoundAttrs

          boundattrcount = 0

          For Each ersEnt In ersMdl.Entities

              For Each ersAttr In ersEnt.Attributes

                  If Not(ersAttr.GetReferenceValue Is Nothing) Then

                      Debug.Print ersAttr.GetReferenceValue.Name

                      boundattrcount = boundattrcount + 1

                  End If

              Next

          Next

          If boundattrcount > 0 Then

          ReDim boundAttrPairs (0  To boundattrcount - 1) As AttrPair

          For Each ersEnt In ersMdl.Entities

              If ersEnt.Attributes.Count <> 0 Then

                  For Each ersAttr In ersEnt.Attributes

                      If Not(ersAttr.GetReferenceValue Is Nothing) Then

                          If ersMdl.Logical = True Then

                              boundAttrPairs(i).tblName = ersEnt.EntityName
                              boundAttrPairs(i).attrname = ersAttr.AttributeName
                              Debug.Print "att name = " & boundAttrPairs(i).attrname

                          Else

                              boundAttrPairs(i).tblName = ersEnt.TableName
                              boundAttrPairs(i).attrname = ersAttr.ColumnName
                              Debug.Print "att name = " & boundAttrPairs(i).attrname

                          End If

                          Set ersRefVal = ersAttr.GetReferenceValue
                          boundAttrPairs(i).refvalid = ersRefVal.ID
                          i = i + 1

                      End If

                  Next

              End If

          Next

          End If

      End Function

      Function loadAllAttrs

          allattrcount = 0

          For Each ersEnt In ersMdl.Entities

              allattrcount = allattrcount + ersEnt.Attributes.Count

          Next

          ReDim AllAttrPairs ( 0 To allattrcount - 1) As AttrPair

          For Each ersEnt In  ersMdl.Entities

              For Each ersAttr In ersEnt.Attributes

                  If ersMdl.Logical = True Then

                      AllAttrPairs(i).tblName = ersEnt.EntityName
                      AllAttrPairs(i).attrname = ersAttr.AttributeName
                      Debug.Print "att name = " & AllAttrPairs(i).attrname

                  Else

                      AllAttrPairs(i).tblName = ersEnt.TableName
                      AllAttrPairs(i).attrname = ersAttr.ColumnName
                      Debug.Print "att name = " & AllAttrPairs(i).attrname

                  End If

                  i = i + 1

              Next

          Next

      End Function

      Function setupAllAttrArray ( attrs() As String )

          ReDim attrs (0 To allattrcount - 1) As String
          Dim i As Integer

          For i = 0 To allattrcount - 1

              attrs(i) = AllAttrPairs(i).tblName & "  --  " & AllAttrPairs(i).attrName

          Next

      End Function

      Function loadDomainArray ()

          Dim dom As Domain
          Dim i As Integer

          i = 0

          domaincount = ersDict.Domains.Count

          If ersDict.Domains.Count <> 0 Then

          ReDim AllDomains(0 To domaincount - 1) As DomPair

              For Each dom In ersDict.Domains

                  AllDomains(i).domName = dom.Name
                  AllDomains(i).refvalid = dom.ReferenceValueId

                  i = i + 1

              Next

          End If

      End Function

      Function setupAllDomains ( doms() As String )

          Dim i As Integer
          Dim count As Integer

          ReDim doms(0 To domaincount) As String

          For i = 0 To domaincount - 1

              doms(i) = AllDomains(i).domName

          Next

      End Function

      Function setupBoundDomains ( doms() As String, refname As String )

          Dim i, j As Integer
          Dim count As Integer

          count = 0

          Set ersRefVal = ersDiag.Dictionary.ReferenceValues.Item(refname)

          For i = 0 To domaincount - 1

              If ersRefVal.ID = AllDomains(i).refvalid Then

                  count = count + 1

              End If

          Next

          If count <= 0 Then

              ReDim doms(0) As String

          Else

              ReDim doms(0 To count - 1) As String

              j = 0

              For i = 0 To domaincount - 1

                  Set ersRefVal = ersDiag.Dictionary.ReferenceValues.Item(refname)

                  If ersRefVal.ID = AllDomains(i).refvalid Then

                      doms(j) = AllDomains(i).domName
                      j = j + 1

                  End If

              Next

          End If

      End Function

      Sub Main

          Debug.Clear

          Set ersDiag = DiagramManager.ActiveDiagram
          Set ersMdl = ersDiag.ActiveModel
          Set ersDict = ersDiag.Dictionary

          loadDomainArray
          loadBoundAttrs
          loadAllAttrs
          GetRefVals
          ClearAttrArray arrSelectedAttrs
          SetupBoundAttrArray arrAvailableAttrs, arrRefVals(0)
          AvailCurIndx = 0
          SelCurIndx = 0

          If ersDiag.Dictionary.ReferenceValues.Count = 0 Then

              MsgBox("There are no Reference Values in the Data Dictionary.",,"ER/Studio")

          End If

          Begin Dialog UserDialog 800,497,"Generate Constraints",.GenConstraintDialogFunc ' %GRID:10,7,1,1
              Text 30,35,120,14,"Reference Values:",.Text1
              ListBox 40,154,280,161,arrAvailableAttrs(),.Available
              ListBox 440,154,310,161,arrSelectedAttrs(),.Selected
              PushButton 350,168,60,21,">>",.AddAll
              PushButton 350,196,60,21,">",.AddOne
              PushButton 350,252,60,21,"<",.RemoveOne
              PushButton 350,280,60,21,"<<",.RemoveAll
              TextBox 200,343,460,63,.ConstraintValue,1
              Text 100,343,70,14,"Constraint:",.Text2
              Text 40,133,120,14,"Bound Columns:",.Text3
              Text 440,133,120,14,"Applied Columns:",.Text4
              PushButton 500,448,110,28,"Apply",.Apply
              ListBox 180,28,370,98,arrRefVals(),.RefVals
              PushButton 640,448,110,28,"Close",.CloseDlg
              GroupBox 30,420,300,63,"Load Choice",.GroupBox1
              OptionGroup .LoadChoice
                  OptionButton 50,441,140,14,"Bound Attributes",.OptionButton1
                  OptionButton 50,462,130,14,"All Attributes",.OptionButton2
                  OptionButton 190,441,130,14,"Bound Domains",.OptionButton3
                  OptionButton 190,462,90,14,"Domains",.OptionButton4
          End Dialog
          Dim dlg As UserDialog

          dlg.constraintvalue = genConstraint(arrRefVals(0))

          Dialog dlg

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function GenConstraintDialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

          Case 2 ' Value changing or button pressed

              If DlgItem = "RefVals" Then

                  RefCurIndx = SuppValue
                  ClearAttrArray arrSelectedAttrs

                  If DlgValue("LoadChoice") = 0 Then

                      ClearAttrArray arrAvailableAttrs
                      SetupBoundAttrArray arrAvailableAttrs, arrRefVals(SuppValue)

                  ElseIf DlgValue("LoadChoice") = 2 Then

                      ClearAttrArray arrAvailableAttrs
                      setupBoundDomains arrAvailableAttrs, arrRefVals(SuppValue)

                  End If

                  DlgListBoxArray "Available", arrAvailableAttrs
                  DlgListBoxArray "Selected", arrSelectedAttrs
                  DlgText "ConstraintValue", genConstraint(arrRefVals(SuppValue))

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "AddOne" Then

                  If arrAvailableAttrs(AvailCurIndx) <> "" Then

                      MoveAttr(arrAvailableAttrs, arrSelectedAttrs, AvailCurIndx)
                      DlgListBoxArray "Available", arrAvailableAttrs()
                      DlgListBoxArray "Selected", arrSelectedAttrs()

                      AvailCurIndx = 0
                      SelCurIndx = 0

                  End If

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "AddAll" Then

                  If DlgValue("LoadChoice") = 0 Then

                      SetupBoundAttrArray(arrSelectedAttrs, arrRefVals(RefCurIndx))

                  ElseIf DlgValue("LoadChoice") = 1 Then

                      setupAllAttrArray(arrSelectedAttrs)

                  ElseIf DlgValue("LoadChoice") = 2 Then

                      setupBoundDomains(arrSelectedAttrs, arrRefVals(RefCurIndx))

                  Else

                      setupAllDomains(arrSelectedAttrs)

                  End If

                  ClearAttrArray(arrAvailableAttrs)

                  DlgListBoxArray "Available", arrAvailableAttrs()
                  DlgListBoxArray "Selected", arrSelectedAttrs()

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "RemoveOne" Then

                  If arrSelectedAttrs(SelCurIndx) <> "" Then

                      MoveAttr(arrSelectedAttrs, arrAvailableAttrs, SelCurIndx)
                      DlgListBoxArray "Available", arrAvailableAttrs()
                      DlgListBoxArray "Selected", arrSelectedAttrs()

                      AvailCurIndx = 0
                      SelCurIndx = 0

                  End If

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "RemoveAll" Then

                  If DlgValue("LoadChoice") = 0 Then

                      SetupBoundAttrArray(arrAvailableAttrs, arrRefVals(RefCurIndx))

                  ElseIf DlgValue("LoadChoice") = 1 Then

                      setupAllAttrArray(arrAvailableAttrs)

                  ElseIf DlgValue("LoadChoice") = 2 Then

                      setupBoundDomains(arrAvailableAttrs, arrRefVals(RefCurIndx))

                  Else

                      setupAllDomains(arrAvailableAttrs)

                  End If

                  ClearAttrArray(arrSelectedAttrs)

                  DlgListBoxArray "Available", arrAvailableAttrs()
                  DlgListBoxArray "Selected", arrSelectedAttrs()

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "Available" Then

                  AvailCurIndx = SuppValue
                  Debug.Print AvailCurIndx

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "Selected" Then

                  SelCurIndx = SuppValue
                  Debug.Print SelCurIndx

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "Apply" Then

                  If DlgValue("LoadChoice") < 2 Then

                  If UBound(arrSelectedAttrs) > 0 Then

                      Dim tblname As String
                      Dim attrname As String
                      Dim Label As String
                      Dim x As Integer
                      Dim y As Integer
                      Dim Length As Integer
                      Dim ixname As String

                      For i = 0 To UBound(arrSelectedAttrs)

                          If arrSelectedAttrs(i) <> "" Then

                              'Get table name
                              Label = arrSelectedAttrs(i)
                              x = InStr(1, Label, "  --  ") - 1
                              tblname = Left(Label, x)
                              Debug.Print "tbl = " & "'" & tblname & "'"

                              'get attr name
                              x = x + 6
                              Length = Len(Label)
                              y = Length - x
                              attrname = Right(Label, y)
                              Debug.Print "attr = " & "'" & attrname & "'"

                              Set ersEnt = ersMdl.Entities.Item(tblname)
                              Set ersAttr = ersEnt.Attributes.Item(attrname)

                              ersAttr.CheckConstraint = DlgText("ConstraintValue")

                          End If

                      Next

                  End If

                  Else

                      If UBound(arrSelectedAttrs) > 0 Then

                      For i = 0 To UBound(arrSelectedAttrs)

                          If arrSelectedAttrs(i) <> "" Then

                              Set ersDom = ersDict.Domains.Item(arrSelectedAttrs(i))

                              ersDom.CheckConstraint = DlgText("ConstraintValue")
                              Debug.Print ersDom.Name & " = " & ersDom.UserDatatypeId

                          End If

                      Next

                      End If

                  End If

                  ClearAttrArray arrSelectedAttrs
                  DlgListBoxArray "Selected", arrSelectedAttrs()

                  GenConstraintDialogFunc = True

              ElseIf DlgItem = "LoadChoice" Then

                  If DlgValue("LoadChoice") = 0 Then

                      SetupBoundAttrArray arrAvailableAttrs, arrRefVals(RefCurIndx)
                      ClearAttrArray arrSelectedAttrs

                      DlgListBoxArray "Available", arrAvailableAttrs()
                      DlgListBoxArray "Selected", arrSelectedAttrs()

                  ElseIf DlgValue("LoadChoice") = 1 Then

                      setupAllAttrArray arrAvailableAttrs
                      ClearAttrArray arrSelectedAttrs

                      DlgListBoxArray "Available", arrAvailableAttrs()
                      DlgListBoxArray "Selected", arrSelectedAttrs()

                  ElseIf DlgValue("LoadChoice") = 2 Then

                      setupBoundDomains arrAvailableAttrs, arrRefVals(RefCurIndx)
                      ClearAttrArray arrSelectedAttrs

                      DlgListBoxArray "Available", arrAvailableAttrs()
                      DlgListBoxArray "Selected", arrSelectedAttrs()

                  Else

                      setupAllDomains arrAvailableAttrs
                      ClearAttrArray arrSelectedAttrs

                      DlgListBoxArray "Available", arrAvailableAttrs()
                      DlgListBoxArray "Selected", arrSelectedAttrs()

                  End If

              End If

              Rem GenConstraintDialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem GenConstraintDialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Convert Name Case.bas

      ' MACRO TITLE: 	CONVERT CASE NAME
      ' AUTHOR:		Mervyn Courtney
      ' DATE:			30/10/2003
      ' This macro converts the case of Attributes, Columns and Entty/Table names for the highlighted tables/Entities
      ' in the active SubModel to all upper or lower case.  Works in Logical or Physical models

      Sub Main
          ' Declare the variables.

          Dim d  As Diagram
          Dim m  As Model
          Dim sm As SubModel
          Dim o  As SelectedObject
          Dim id As Integer
          Dim e  As Entity
          Dim a As AttributeObj

          ' Do the normal stuff.

          Set d = DiagramManager.ActiveDiagram
          Set m = d.ActiveModel
          Set sm = m.ActiveSubModel

          ' Prompt the user to make a choice for upper/lower case.

          Begin Dialog UserDialog 300,112,"Case Selection" ' %GRID:10,7,1,1
              OKButton 110,91,90,21
              GroupBox 10,7,140,77,"Convert",.GroupBox1
              CheckBox 20,21,110,14,"Entity/Table",.chkEntity
              CheckBox 20,42,100,14,"Columns",.chkColumn
              CheckBox 20,63,90,14,"Attributes",.chkAttr
              GroupBox 160,7,130,77,"Case Conversion",.GroupBox2
              OptionGroup .optCase
                  OptionButton 170,28,100,14,"&Upper Case",.OptionButton1
                  OptionButton 170,49,100,14,"&Lower Case",.OptionButton2
          End Dialog
          Dim dlg As UserDialog
          Dialog dlg

          ' You need the submodel when determining what's selected.
          ' Iterate through all selected objects and process the only entities.

          For Each o In sm.SelectedObjects
              If o.Type = 1 Then		' Entities are Type 1 objects.

                  ' Get the entity.

                  id = o.ID
                  Set e = m.Entities.Item(id)

                  ' Make the conversion.

                  If dlg.optCase = 0 Then
                      If dlg.chkEntity = 1 Then
                          e.EntityName = StrConv(e.EntityName, vbUpperCase)
                          e.TableName = StrConv(e.TableName, vbUpperCase)
                      End If
                      If dlg.chkColumn = 1 Then
                          For Each a In e.Attributes
                              a.ColumnName =StrConv(a.ColumnName,vbUpperCase)
                          Next
                      End If
                      If dlg.chkAttr = 1 Then
                          For Each a In e.Attributes
                              a.AttributeName =StrConv(a.AttributeName,vbUpperCase)
                          Next
                      End If
                  ElseIf dlg.optCase = 1 Then
                      If dlg.chkEntity = 1 Then
                          e.EntityName = StrConv(e.EntityName, vbLowerCase)
                          e.TableName = StrConv(e.TableName, vbLowerCase)
                      End If
                      If dlg.chkColumn = 1 Then
                          For Each a In e.Attributes
                              a.ColumnName =StrConv(a.ColumnName,vbLowerCase)
                          Next
                      End If
                      If dlg.chkAttr = 1 Then
                          For Each a In e.Attributes
                              a.AttributeName =StrConv(a.AttributeName,vbLowerCase)
                          Next
                      End If
                  End If
              End If
          Next

      End Sub


Definition Editor.bas

      'TITLE:  DEFINITION EDITOR.BAS
      'DESCRIPTION:  This macro will list all the tables and allow
      '	the user to update the definition field for the table, by
      '	pressing the "update" button.  There will also be a list of
      '	columns for the respective table, that the user can use to update
      '	the definitions for each column.  This macro will run on a
      '	logical or a physical model and populate the lists accordingly.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'DATE:  5/29/2001

      Option Explicit

      'Array variables for the dialog
      Dim TableArray() As String
      Dim TableDef() As String
      Dim tableIndx As Integer
      Dim ColumnArray() As String
      Dim ColumnDef() As String
      Dim colIndx As Integer

      'Auto-Update variables
      Dim AutoTables As Boolean
      Dim AutoColumns As Boolean
      Dim UpdateBit As Boolean

      'ERStudio global variables
      Dim MyModel As Model
      Dim MyDiagram As Diagram
      Dim MyEntity As Entity
      Dim MyAttribute As AttributeObj
      Dim EntCount As Integer
      Dim ColCount As Integer

      'This function is used to populate the TableArray variable with
      'the list of tables from the active model.  It will use logical names
      'when run on a logical model.  It will use physical names when run on
      'a physical model.  It takes no parameters and returns no value.
      Function getTables()

          Dim indx As Integer

          indx = 0

          EntCount = MyModel.Entities.Count - 1

          're-initialize the table array to the appropriate size
          ReDim TableArray(0 To EntCount) As String

          'loop through each entity in the active model
          For Each MyEntity In MyModel.Entities

              If MyModel.Logical = True Then

                  'Use the Entity name if the model is logical
                  TableArray(indx) = MyEntity.EntityName

              Else

                  'Use the Table name if the model is physical
                  TableArray(indx) = MyEntity.TableName

              End If

              indx = indx + 1

          Next MyEntity

          dhQuickSort TableArray

      End Function

      'This function gets the columns for repective table.  It will refresh the
      'ColumnArray variable with the columns from the selected table.  It will
      'use the logical names when run on a logical model.  It will use physical
      'names when run on a physical model.  It returns nothing.  The parameter is
      'the table name that columns need to be refreshed.
      Function getColumns(TableName As String)

          Dim indx As Integer
          Dim count As Integer
          Dim quit As Boolean

          count = 1
          indx = 0

          Set MyEntity = MyModel.Entities.Item(TableName)

          ColCount = MyEntity.Attributes.Count

          'Re-initailize the column array with the number of columns in the table
          ReDim ColumnArray(0 To ColCount) As String

          For count = 1 To ColCount

          For Each MyAttribute In MyEntity.Attributes

              'Attributes will be inserted into the column array by sequence number
              '(displayed order, not created order)
              If MyAttribute.SequenceNumber = count Then

              'Need to determine to use logical or physical names
              If MyModel.Logical = True Then

                  If MyAttribute.HasLogicalRoleName = True Then

                      'Use logical rolename instead of attribute name
                      ColumnArray(indx) = MyAttribute.LogicalRoleName

                  Else

                      'Use attribute name if no rolename is used
                      ColumnArray(indx) = MyAttribute.AttributeName

                  End If

              Else

                  If MyAttribute.HasRoleName = True Then

                      'use rolename instead of column name
                      ColumnArray(indx) = MyAttribute.RoleName

                  Else

                      'Use column name if no rolename is used
                      ColumnArray(indx) = MyAttribute.ColumnName

                  End If

              End If

              indx = indx + 1

              End If

          Next MyAttribute

          Next count

      End Function

      'This function returns the defintion of the specified table name.  The
      'table name is passed in as a parameter.  This function is used to
      'populate the table definition of the dialog.
      Function getTableDef (tname As String) As String

          Set MyEntity = MyModel.Entities.Item(tname)

          getTableDef = MyEntity.Definition

      End Function

      'This function returns the definition of the specified attribute in the
      'specified table.  The column name and table name are passed in parameters
      'This function is used to populate the column defintion in the dialog.
      Function getColumnDef (tname As String, cname As String) As String

          Set MyEntity = MyModel.Entities.Item(tname)
          Set MyAttribute = MyEntity.Attributes.Item(cname)

          If cname = "" Then
              getColumnDef = ""
          Else
              getColumnDef = MyAttribute.Definition
          End If

      End Function

      Sub Main

          Debug.Clear

          'initialize ER variables
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel

          'initialize indexes for dialog arrays
          tableIndx = 0
          colIndx = 0

          'initialize auto update variables for dialog
          AutoTables = True
          AutoColumns = True
          UpdateBit = False

          'initialize dialog arrays
          getTables()
          getColumns(TableArray(0))

          Begin Dialog UserDialog 980,525,"Definition Editor",.MyDialogFunc ' %GRID:10,7,1,1
              GroupBox 20,7,940,231,"Table Definitions",.GroupBox1
              GroupBox 20,252,940,231,"Column Definitions",.GroupBox2
              ListBox 40,28,200,182,TableArray(),.TableList
              ListBox 40,273,200,182,ColumnArray(),.ColumnList
              TextBox 260,28,680,168,.TableDefinition,1
              TextBox 260,273,680,168,.ColumnDefinition,1
              PushButton 820,203,120,21,"Update",.UpdateTable
              PushButton 820,448,120,21,"Update",.UpdateColumn
              OKButton 820,490,140,28
              CheckBox 470,210,300,14,"Automatically Update Tables Definitions",.autoTab
              CheckBox 470,455,300,14,"Automatically Update Column Definitions",.autoCol
          End Dialog
          Dim dlg As UserDialog

              'initialize dialog parameters
              dlg.autoTab = 1
              dlg.autoCol = 1
              dlg.tabledefinition = getTableDef(TableArray(0))
              dlg.columndefinition = getColumnDef(TableArray(0),ColumnArray(0))

          Dialog dlg, -2

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function MyDialogFunc(DlgItem$, Action%, SuppValue&) As Boolean

          Dim value As Integer

          Select Case Action%
          Case 1 ' Dialog box initialization
                  'DlgText "ColumnDefinition", getColumnDef(TableArray(0),ColumnArray(0))
          Case 2 ' Value changing or button pressed
              Rem MyDialogFunc = True ' Prevent button press from closing the dialog box

              If DlgItem = "autoTab" Then

                  'set AutoTables variable to match checkbox
                  value = DlgValue("autoTab")

                  If value = 0 Then
                      AutoTables = False
                  Else
                      AutoTables = True
                  End If

                  UpdateBit = False

              ElseIf DlgItem = "autoCol" Then

                  'set AutoColumns variable top match checkbox
                  value = DlgValue("autoCol")

                  If value = 0 Then
                      AutoColumns = False
                  Else
                      AutoColumns = True
                  End If

                  UpdateBit = False

              ElseIf DlgItem = "TableList" Then

                  'insert table def into the TableDefinition dialog variable
                  DlgText "TableDefinition", getTableDef(TableArray(SuppValue))

                  'refresh column list with columns from selected table
                  getColumns(TableArray(SuppValue))
                  DlgListBoxArray "ColumnList", ColumnArray

                  Debug.Print "table= " & TableArray(SuppValue)

                  tableIndx = SuppValue

                  'insert column def into the ColumnDefinition dialog variable
                  DlgText "ColumnDefinition", ""   ' getColumnDef(TableArray(tableIndx),ColumnArray(0))

                  UpdateBit = False

                  MyDialogFunc = True

              ElseIf DlgItem = "ColumnList" Then

                  'insert column def into the ColumnDefinition dialog variable
                  DlgText "ColumnDefinition", getColumnDef(TableArray(tableIndx), ColumnArray(SuppValue))

                  colIndx = SuppValue

                  UpdateBit = True

                  MyDialogFunc = True

              End If

              If DlgItem = "UpdateTable" Then

                  Set MyEntity = MyModel.Entities.Item(TableArray(tableIndx))

                  'update the corresponding table definition when update Tables button is pushed.
                  MyEntity.Definition = DlgText("TableDefinition")

                  UpdateBit = False

                  MyDialogFunc = True

              ElseIf DlgItem = "UpdateColumn" Then

                  Set MyEntity = MyModel.Entities.Item(TableArray(tableIndx))
                  Set MyAttribute = MyEntity.Attributes.Item(ColumnArray(colIndx))

                  'update the corresponding column definition when update columns button is pushed.
                  MyAttribute.Definition = DlgText("ColumnDefinition")

                  UpdateBit = True

                  MyDialogFunc = True

              End If

          Case 3 ' TextBox or ComboBox text changed

              'Auto update when text block is changed and loses focus.
              If DlgItem = "TableDefinition" And AutoTables = True Then

                  Set MyEntity = MyModel.Entities.Item(TableArray(tableIndx))

                  'update table definition
                  MyEntity.Definition = DlgText("TableDefinition")

                  UpdateBit = False

                  MyDialogFunc = True

              ElseIf DlgItem = "ColumnDefinition" And AutoColumns = True Then

                  If UpdateBit = True Then

                      Set MyEntity = MyModel.Entities.Item(TableArray(tableIndx))
                      Set MyAttribute = MyEntity.Attributes.Item(ColumnArray(colIndx))

                      'update column definition
                      MyAttribute.Definition = DlgText("ColumnDefinition")

                      MyDialogFunc = True

                  End If

              End If

          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem MyDialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      ' **The following code is taken from the specified book.  It has been modified
      ' **to perform a case insensitive sort.

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant, _
       Optional intLeft As Integer As Integer ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If
      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


Domain Bindings.bas

      'MACRO TITLE: DOMAIN BINDINGS
      'This macro brings up a dialog box that shows all attributes bounded to
      'a selected domain.  It also allows the user to unbind specific attributes
      'from the selected domain.  The dialog box contains two list boxes and two buttons.
      'The first list box, "Domains", shows all the domains in the diagram. The second list
      'box, "Bounded Attributes", shows all the attributes bounded to the selected
      'domain in the "Domains" list box. There is also an "OK" button and an "UnBind" button.
      'The user can press the "UnBind" button to unbind selected attributes in the "Bounded
      'Attributes" list box from the selected domain in the "Domains" list box.
      '----------------------------------------------------------------------------------------

      'These are global variables.  They are delcared here.

          'This array is used to populate the "Bounded Attributes"
          'list box in the dialog box.

          Dim AttributeArray() As String

          'This array is used to populate the "Domains" list box
          'in the dialog box.

          Dim DomainArray() As String

          'This integer is used to keep track of the current selection
          'in the "Bounded Attributes" list box.

          Dim CurAttrIndex As Integer
      'SetupAttributeArray.
      'This function will initialize the attribute array with the
      'names of all attributes bounded to the selected domain given
      'by the DomainIndex parameter.

      Function SetupAttributeArray(DomainIndex)
          Dim MyModel As Model
          Dim MyDiagram As Diagram
          Dim MyDictionary As Dictionary
          Dim MyDomain As Domain
          Dim MyAttribute As AttributeObj
          Dim MyEntity As Entity

          Dim i As Integer
          Dim DomainName As String
          Dim Logical As Boolean
          Dim DomainID As Integer
          Dim ID As Integer
          Dim EntityName As String
          Dim AttributeName As String

          'Get the currently active diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          'Get the data dictionary

          Set MyDictionary = MyDiagram.Dictionary

          'Set the array size to be big enough for
          'the 0th index.  This is the initial size.

          ReDim AttributeArray(0) As String

          i = 0

          'Get the domain name from the given index.

          DomainName = DomainArray(DomainIndex)

          'Get the domain object with this domain name.

          Set MyDomain = MyDictionary.Domains.Item(DomainName)

          'Get the Id of the domain.

          ID = MyDomain.ID

          'Now we iterate through all models, all entities,
          'and all attributes.  We check if each attribute's
          'domain id matches the selected domain id.  If it
          'does, then we add the attribute to the attribute
          'array (this array will be used to update the "Bounded
          'Attributes" list box).

          For Each MyModel In MyDiagram.Models

              'See whether the model is logical or not.
              'We need to know this so that we can get
              'the correct names (entity and attribute names
              'in the logical model and table and column names
              'in a physical model).

              Logical = MyModel.Logical

              'Iterate through all entities in the model.

              For Each MyEntity In MyModel.Entities

                  'Iterate through all attributes in the entity.

                  For Each MyAttribute In MyEntity.Attributes

                      If Not(MyAttribute.ForeignKey) Then
                          'Get the domain id the attribute is bounded
                          'to (if any).

                          DomainID = MyAttribute.DomainId

                          'If the domain id matches the selected domain id,
                          'then get the attribute name and add it to the
                          'attribute array.

                          If DomainID = ID Then

                              'If the model is logical, then we get the
                              'entity name and attribute name.  If the
                              'model is physical, we get the table name
                              'and the column name.

                              If Logical = True Then
                                  EntityName = MyEntity.EntityName
                                  AttributeName = MyAttribute.LogicalRoleName
                              Else
                                  EntityName = MyEntity.TableName
                                  AttributeName = MyAttribute.RoleName
                              End If

                              'Now we create the full label.  The format
                              'is "Model Name -- Entity Name -- Attribute Name".

                              Label = MyModel.Name + "  --  " + EntityName + "  --  " + AttributeName

                              'Add this label to the attribute array.  This array
                              'will be used to populate the "Bounded Attributes"
                              'list box.

                              AttributeArray(i) = Label

                              'Increment the array size by 1.

                              i = i + 1

                              'Make the attribute array big enough to fit the
                              'new array size (while preserving all the previous
                              'entries set thus far).

                              ReDim Preserve AttributeArray(i) As String

                          End If
                      End If
                  Next MyAttribute

              Next MyEntity

          Next MyModel

      End Function

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyDictionary As Dictionary
          Dim MyDomain As Domain
          Dim i As Integer
          Dim DomainsExist As Boolean
          Dim Count As Integer

          CurAttrIndex = -1
          DomainsExist = False
          i = 0

          'Get the currently active diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          'Get the data dictionary.

          Set MyDictionary = MyDiagram.Dictionary

          'Get the number of domains in the data dictionary.

          Count = MyDictionary.Domains.Count

          'Resize the domains array to be big enough to
          'fit all the domain names in the data dictionary.

          ReDim DomainArray(Count) As String

          'Now iterate through all the domains in the data
          'dictionary, get each domain name and put it in the
          'domains array.

          For Each MyDomain In MyDictionary.Domains

              DomainsExist = True
              DomainArray(i) = MyDomain.Name

              i = i + 1

          Next MyDomain

          'If there are valid domains in the data dictionary,
          'then we will initialize the attributes array
          'with all the attributes bounded to the first domain
          'in the "Domains" list box.

          If DomainsExist = True Then
              CurAttrIndex = 0
              SetupAttributeArray(0)
          End If

          'Now create the dialog box.  The dialog box will use the
          'domains array to populate the "Domains" list box, and
          'it will use the attributes array to populate the "Bounded
          'Attributes" list box.

          Begin Dialog UserDialog 940,315,"Domain Bindings",.MyDialogFunction ' %GRID:10,7,1,1
              ListBox 20,42,230,203,DomainArray(),.DomainBox
              ListBox 300,42,620,203,AttributeArray(),.AttributeBox
              PushButton 530,266,110,28,"UnBind",.UnBind
              Text 30,21,90,14,"Domains",.Text1
              Text 310,21,400,14,"Bounded Attributes (Format: Model -- Entity -- Attribute)",.Text2
              OKButton 290,266,100,28
          End Dialog

          Dim dlg As UserDialog

          Dialog dlg

      End Sub

      Rem See DialogFunc help topic for more information.

      'MyDialogFunction
      'This function was created by the Sax Basic dialog editor.
      'It provides a way to handle certain events that happen in the dialog box.
      'Please read the Sax Basic help (DialogFunc help topic) for more details
      'about its overall use.  This function has been modified to specifically
      'handle selections done in the "Domains" list box and in the "Bounded
      'Attributes" list box.  It has also been modified to handle the pressing
      'of the "UnBind" button.

      Private Function MyDialogFunction(DlgItem$, Action%, SuppValue&) As Boolean

          Dim MyModel As Model
          Dim MyDiagram As Diagram
          Dim MyAttribute As AttributeObj
          Dim MyEntity As Entity

          Dim EntityName As String
          Dim AttributeName As String
          Dim Idx As Integer
          Dim PrvIdx As Integer
          Dim Length As Integer
          Dim Label As String

          'Get the currently active diagram.

          Set MyDiagram = DiagramManager.ActiveDiagram

          Select Case Action%
          Case 1 ' Dialog box initialization.

          Case 2 ' Value changing or button pressed.

              If DlgItem = "DomainBox" Then

                  'If the user is selecting a different domain in
                  'the "Domains" list box, then we want re-initialize
                  'the "Bounded Attributes" list box to contain all the attributes
                  'bounded to the new selection in the "Domains" list box.
                  'SuppValue contains the index of the new domain selection
                  'in the "Domains" list box.

                  CurAttrIndex = -1
                  SetupAttributeArray(SuppValue)

                  DlgListBoxArray("AttributeBox", AttributeArray())

              ElseIf DlgItem = "AttributeBox" Then

                  'If the user is selecting a different attribute in
                  'the "Bounded Attributes" list box, then we want to
                  'save the new selection.

                  CurAttrIndex = SuppValue

              ElseIf DlgItem = "UnBind" Then

                  'If the user presses the "UnBind" button, then we
                  'want to unbind the currently selected attribute in
                  'the "Bounded Attributes" list box from the currently
                  'selected domain in the "Domains" list box.

                  'First, check that there is a valid attribute selected.

                  If CurAttrIndex <> -1 Then

                      'Get the actual label which corresponds to the
                      'currently selected attribute index.

                      Label = AttributeArray(CurAttrIndex)

                      'See whether the currently selected attribute is
                      'already unbounded.  If it is, then do nothing.

                      Idx = InStr(1, Label, "(*Unbound*)")

                      If Idx = 0 Then

                          'The attribute is validly bounded, so
                          'we must get the model, entity, and attribute
                          'names from the label so that we can get each
                          'object.

                          'First, get the model name.

                          Idx = InStr(1, Label, "  --  ")
                          ModelName = Left(Label, Idx - 1)

                          'Second, get the entity name.

                          PrvIdx = Idx + 6
                          Idx = InStr(PrvIdx, Label, "  --  ")
                          Length = Idx - PrvIdx
                          EntityName = Mid(Label, PrvIdx, Length)

                          'Last, get the attribute name.

                          Length = Len(Label)
                          Length = Length - Idx - 5
                          AttributeName = Right(Label, Length)

                          'Now, get the model object from the model name.

                          Set MyModel = MyDiagram.Models(ModelName)

                          'Get the entity from the entity name.

                          Set MyEntity = MyModel.Entities.Item(EntityName)

                          'Get the attribute from the attribute name.

                          Set MyAttribute = MyEntity.Attributes.Item(AttributeName)

                          'Unbind the attribute from the selected domain by setting
                          'the attribute's domain id to 0.

                          MyAttribute.DomainId = 0

                          'Append the word "Unbounded" to the label.

                          Label = Label + "   (*Unbound*)"

                          'Update the label in the attributes array for
                          'the current attribute selected.

                          AttributeArray(CurAttrIndex) = Label

                          'Now update the "Bounded Attributes" list box with
                          'the updated attributes array.

                          DlgListBoxArray("AttributeBox", AttributeArray())

                      End If

                  Else

                      'If there is no valid attribute selected in the "Bounded
                      'Attributes" list box then put up an error message.

                      MsgBox("Please select a bounded attribute to unbind.")

                  End If

                  'The function must return true when handling the pressing
                  'of the "UnBind" button or else the dialog box will close.

                  MyDialogFunction = True

              End If

          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem MyDialogFunction = True ' Continue getting idle actions
          Case 6 ' Function key

          End Select

      End Function


Domain Bindings Export to Excel.bas

      'TITLE:  DOMAIN BINDINGS EXPORTTO EXCEL.BAS
      'DESCRIPTION:  This macro exports domain bindings for all the attributes in the
      '	current model.  The existing columns in the spread sheet must be left
      '	in the same format if the bindings are going to be used to import back into
      '	a model.  Note that the attribute data type is only in the spread sheet for
      '	informational purposes when refactoring attibutes and columns and assigning
      '	them to domains.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/

      'DATE:  3/23/2004
      'LAST UPDATE:  10/8/2004

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim enterprise_dict As Dictionary
      Dim dict As Dictionary
      Dim dom As Domain
      Dim dom_folder As DomainFolder
      Dim dictionary_list () As String
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj
      Dim entdisplay As EntityDisplay

      ' dim dialog variables
      Dim active_model_loop As Boolean       'if true, user selected to loop through only active model
                                             'if false, user selected all models
      Dim selected_object_loop As Boolean    'if true, macro loops through selected objects
                                             'if false, macro loops through all objects

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          Debug.Clear

          Dim active_submdl_name As String
          Dim active_mdl_name As String

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          active_mdl_name = mdl.Name
          active_submdl_name = submdl.Name

          Debug.Print active_mdl_name
          Debug.Print active_submdl_name

          DiagramManager.EnableScreenUpdate(False)

          Set Excel = CreateObject("Excel.Application")
          Excel.Workbooks.Add

          curRow = 1
          curCol = 1

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          Begin Dialog UserDialog 530,259,"Export domain bindings",.exp_dom_handler ' %GRID:10,7,1,1
              TextBox 60,42,420,70,.diag_info,1
              Text 50,21,150,14,"Diagram Information:",.text1
              GroupBox 60,126,420,77,"Export Scope",.GroupBox1
              OptionGroup .model_sel
                  OptionButton 100,154,90,14,"All Models",.OptionButton1
                  OptionButton 100,175,130,14,"Active model",.OptionButton2
              OptionGroup .object_sel
                  OptionButton 270,154,130,14,"All Objects",.OptionButton3
                  OptionButton 270,175,140,14,"Selected Objects",.OptionButton4
              OKButton 240,217,100,21
              CancelButton 370,217,100,21
          End Dialog
          Dim dlg As UserDialog

          If Dialog (dlg) = -1 Then

              InitColumnWidth
              PrintColumnHeader

              If active_model_loop = True Then  'loop through only the active model

                  PrintData

              Else		'loop through all models

                  For Each mdl In diag.Models

                      PrintData

                  Next

              End If

              MsgBox("Export   Complete!",,"ER/Studio")

              ' make Excel spread sheet visible
              Excel.Visible = True

          End If

          Set mdl = diag.Models.Item(active_mdl_name)
          Set submdl = mdl.SubModels.Item(active_submdl_name)
          submdl.ActivateSubModel

          DiagramManager.EnableScreenUpdate(True)

      End Sub

      Sub PrintData

          Dim bHideFont As Boolean
          bHideFont = False

          If selected_object_loop = False Then		'loop throug all objects in active model

              For Each ent In mdl.Entities

                  For Each attr In ent.Attributes

                      PrintRecord

                  Next

              Next

          Else				'loop through selected objects

              For Each so In submdl.SelectedObjects

                  If so.Type = 1 Then

                      Set ent = mdl.Entities.Item(so.ID)

                      For Each attr In ent.Attributes

                          PrintRecord

                      Next

                  End If

              Next
          End If
      End Sub

      'this routine is called by PrintData to right one record to the spread sheet.
      'there are no parameters associated with it.  The diagram variables are initialized
      'with in the Sub Main routine.
      Sub PrintRecord

          'find the domain and dictionary
          'first check local
          Set dict = diag.Dictionary
          Set dom = dict.Domains.Item(attr.DomainId)

          If dom Is Nothing Then

              'look through the enterprise dictionaries
              For Each dict In diag.EnterpriseDataDictionaries

                  Set dom = dict.Domains.Item(attr.DomainId)

                  If dom Is Nothing Then

                      'continue...

                  Else

                      Exit For  'domain is found exit the loop with the active dictionary and domain

                  End If

              Next

          End If

          'output the diagram name to the spread sheet
          PrintCell diag.ProjectName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          'output the model name to the spreadsheet
          PrintCell mdl.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          'output the entity or table name to the spread sheet dependending on the type of the model
          If mdl.Logical = True Then
              PrintCell ent.EntityName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          Else
              PrintCell ent.TableName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          End If

          'output the attribute or column name to the spread sheet depending on the type of the model
          If mdl.Logical = True Then

              'print attribute name if there is no role name
              If attr.HasLogicalRoleName = False Then

                  PrintCell attr.AttributeName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              Else 	'print rolename if there is one

                  PrintCell attr.LogicalRoleName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              End If

          Else		'use physical name

              'print column name if there is no role name
              If attr.HasRoleName = False Then

                  PrintCell attr.ColumnName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              Else 	'print rolename if there is one

                  PrintCell attr.RoleName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              End If

          End If

          'output attribute data type
          PrintCell attr.Datatype, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          'output attribute datatype length
          If attr.DataLength < 0 Then
              PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          Else
              PrintCell attr.DataLength, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          End If

          'output attribute datatype scale
          If attr.DataScale < 0 Then
              PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          Else
              PrintCell attr.DataScale, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          End If

          'output domain name to the spread sheet
          If dom Is Nothing Then
              PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          Else
              PrintCell dom.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          End If

          'output the dictionary name to the spreadsheet
          If dom Is Nothing Then
              PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          Else
              PrintCell dict.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
          End If

          curRow = curRow + 1
          curCol = 1
      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth

      Dim count As Integer

      count = 9

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 30
      Next j

      Excel.cells(1,5).columnwidth = 20  	'set datatype column width
      Excel.cells(1,6).columnwidth = 5	'set datatype length column width
      Excel.cells(1,7).columnwidth = 5	'set datatype scale column width

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader

              PrintCell "Diagram", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Model", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Entity/Table", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Attribute/Column", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Attribute Datatype", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Attribute Datatype Length", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Attribute Datatype Scale", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Domain", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Dictionary", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              curRow = curRow + 1
              curCol = 1

      End Sub

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub

      Function entitiesSelected() As Boolean

          Dim selObj As SelectedObject

          If submdl.SelectedObjects.Count > 0 Then
              For Each selObj In submdl.SelectedObjects
                  If selObj.Type=1 Then
                      entitiesSelected = True
                      Exit Function
                  End If
              Next
          End If

          entitiesSelected = False

      End Function

      Rem See DialogFunc help topic for more information.
      Private Function exp_dom_handler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

                  Dim sel_objects As String
                  Dim mdl_type As String

                  If entitiesSelected = False Then
                      sel_objects = "NO"
                  Else
                      sel_objects = "YES"
                  End If

                  If mdl.Logical = True Then
                      mdl_type = "LOGICAL"
                  Else
                      mdl_type = "PHYSICAL"
                  End If

                  'populate text box in the dialog with some information about what will be exported
                  DlgText diag_info, "Diagram:  " & diag.ProjectName & vbCrLf & "Model Name:  " & mdl.Name & vbCrLf & "Model Type:  " & mdl_type & vbCrLf & "Active Model:  " & submdl.Name & vbCrLf & "Selected Objects:  " & sel_objects

                  DlgValue "model_sel",0
                  DlgEnable "OptionButton4", False

          Case 2 ' Value changing or button pressed

              If DlgItem = "model_sel" Then

                  If DlgValue("model_sel") = 0 Then

                      DlgValue "object_sel", 0

                      DlgEnable "OptionButton4", False

                  ElseIf DlgValue("model_sel") = 1 And entitiesSelected = True  Then

                      DlgEnable "OptionButton4", True

                  End If

                  active_model_loop = DlgValue("model_sel")
                  Debug.Print "active_model_loop = " & active_model_loop

                  selected_object_loop = DlgValue("object_sel")
                  Debug.Print "selected_object_loop = " & selected_object_loop

              ElseIf DlgItem = "object_sel" Then

                  active_model_loop = DlgValue("model_sel")
                  Debug.Print "active_model_loop = " & active_model_loop

                  selected_object_loop = DlgValue("object_sel")
                  Debug.Print "selected_object_loop = " & selected_object_loop

              End If
              Rem exp_dom_handler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem exp_dom_handler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Domain Bindings Import from Excel.bas

      'TITLE:  DOMAIN BINDINGS IMPORT FROM EXCEL.BAS
      'DESCRIPTION:  This macro imports domain bindings from Excel.  I will map
      '	domains to attributes or columns depending on the data in the spread
      '	sheet.  The macro provides an interface to select the dictionary
      '	where the domains are located and the model to search for the attributes
      '	or columns.  When importing into a physical model the spread sheet
      '	must have the physical table and column names that match the selected
      '	physical model.  When importing into the logical model, the names in
      '	the spread sheet must match the entity and attribute names.

      'FORMAT OF SPREAD SHEET COLUMNS:

      '	1.  Diagram Name - Optional - String - Not used in import, used just for
      '			informational purposes in the spread sheet.
      '	2.  Model Name - Required - String - This is used to find the entity and attribute
      '			in the appropiate model from the spread sheet.
      '	3.  Entity/Table Name - Required - String - Needed to find the associated attribute
      '			and domain.
      '	4.	Attribute/Column Name - Required - String - Needed to find the associated domain
      '	5.  Attribute Datatype - Not required - String - Only for informational purposes
      '	6.  Attribute Datatype Length - Not required - String - Only for informational purposes
      '	7.  Attribute Datatype Precision - Not required - String - Only for information purposes
      '	8.  Domain Name - Required - String - Needed to match the domain with the attribute
      '	9.  Dictionary Name - Required - String - This column is used to find the correct
      '			dictionary for the domain from the spread sheet.  If blank, the local dictionary
      '			will be used

      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST UPDATE:  3/23/2004

      Dim diag As Diagram
      Dim dict As Dictionary
      Dim mdl As Model
      Dim ent As Entity
      Dim attr As AttributeObj
      Dim dom As Domain

      Sub Main

          Dim dom As Domain
          Dim excel As Object
          Dim error_log As String

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram

          Begin Dialog UserDialog 520,294,"Import Domains Bindings From Excel",.DialogFunc ' %GRID:10,7,1,1
              Text 30,21,210,14,"Path to binding info spreadsheet:",.Text1
              TextBox 70,42,350,21,.path
              OKButton 250,231,110,21
              CancelButton 390,231,110,21
              PushButton 440,42,60,21,"Browse",.Browse
              TextBox 150,77,290,21,.diagram_name_txt
              TextBox 150,112,290,21,.filename_txt
              Text 40,84,100,14,"Active Diagram",.Text2
              Text 70,119,60,14,"Filename",.Text4
              CheckBox 50,168,290,21,"Log errors to c:\domain_binding_log.txt",.log_errors_chbx
              PushButton 30,224,100,21,"Get Sample",.getsample
          End Dialog

          Dim dlg As UserDialog

          'initialize dialog defaults, 0 = unchecked, 1 = checked
          dlg.log_errors_chbx = 1

          'start_dialog:

          'start dialog
          If Dialog(dlg) = -1 Then

              'initialize excel object and make visible
              Set excel = CreateObject("Excel.Application")
              'excel.Visible = True

              'this error is for an errant file path, dialog will be restarted
              'On Error GoTo Error_handle

              excel.workbooks.open dlg.path

              'define excel variables
              Dim sheet As Object
              Dim range As Object

              'range variables for loop
              Dim binding_count As Integer
              Dim start_range As Integer

              'get sheet info from excel object
              Set sheet = excel.worksheets(1)
              Set range = sheet.usedrange

              'get count for loop
              binding_count = range.rows.Count
              start_range = 2						'ignore first row of sheet.

              'input diagram and model name in error log
              error_log = "Diagram Name:       " & diag.ProjectName & vbCrLf
              error_log = error_log & "File Name:          " & diag.FileName & vbCrLf & vbCrLf & vbCrLf & vbCrLf

              For i = start_range To binding_count

                  'make sure that the right data is initialized from the spread sheet.
                  'domain name = column 8 in sheet
                  'entity name = column 3 in sheet
                  'attribute name = column 4 in sheet
                  'datatype = column 5
                  'data length = column 6
                  'data precision = column 7

                  Dim domain_name As String
                  Dim entity_name As String
                  Dim attribute_name As String
                  Dim datatype As String
                  Dim datalength As Integer
                  Dim dataprecision As Integer
                  Dim dictionary_name As String
                  Dim model_name As String

                  'initialize string variables with data from spread sheet.
                  model_name = Trim(range.cells(i,2).Value)
                  dictionary_name = Trim(range.cells(i,9).Value)
                  domain_name = Trim(range.cells(i, 8).Value)
                  entity_name = Trim(range.cells(i, 3).Value)
                  attribute_name = Trim(range.cells(i, 4).Value)

                  'check if it is an enterprise dictionary
                  Set dict = diag.EnterpriseDataDictionaries.Item(dictionary_name)

                  'use local if an enterprise dictionary is not found
                  If dict Is Nothing Then
                      Set dict = diag.Dictionary
                  End If

                  'check to see if dictionary in the spreadsheet matches the initialized dictionary
                  If dict.Name <> dictionary_name Then

                      error_log = error_log & "Row < " & i & " > -  Dictionary not found." & vbCrLf & vbCrLf

                  Else

                      Set dom = dict.Domains.Item(domain_name)

                      If dom Is Nothing Then

                          'log missing domain in the error string
                          error_log = error_log & "Row < " & i & " > -  Domain  <" & domain_name & "> does not exist." & vbCrLf & vbCrLf

                      Else

                          Set mdl = diag.Models.Item(model_name)

                          If mdl Is Nothing Then

                              error_log = error_log & "Row < " & i & " > -  Model  <" & model_name & "> does not exist." & vbCrLf & vbCrLf

                          Else

                              Set ent = mdl.Entities.Item(entity_name)

                              If ent Is Nothing Then

                                  'log missing entity in the error string
                                  error_log = error_log & "Row < " & i & " > -  Entity  <" & entity_name & "> does not exist." & vbCrLf & vbCrLf

                              Else

                                  Set attr = ent.Attributes.Item(attribute_name)

                                  If attr Is Nothing Then

                                      'log missing attribute in the error string
                                      error_log = error_log & "Row < " & i & " > -  Attribute  <" & entity_name & "." & attribute_name & "> does not exist." & vbCrLf & vbCrLf

                                  Else

                                      If attr.ForeignKey = False  Then 'skip attribute if it is a foreign key.

                                          'set the attribute domain ID equal to the domain ID to bind the domain
                                          'to the attribute.
                                          attr.DomainId = dom.ID

                                      End If

                                  End If 'attribute existence check

                              End If	  'entity existence check

                          End If		  'model existence check

                      End If            'domain existence check

                  End If			  'dictionary existence check.

              Next

              excel.workbooks.Close
              'excel.visible = False

              If dlg.log_errors_chbx = 1 Then

                  Open "C:\domain_binding_log.txt" For Output As #1
                  Print #1, error_log
                  Close #1

              End If

              MsgBox("Import of Domain Bindings Complete.",vbOkOnly,"ERStudio")

              Exit Sub

              'Error_handle:
              '	MsgBox("Please enter a valid path.",,"Error!")
              '	GoTo start_dialog

          End If

      End Sub

      'This function checks to see if a domain exists in the model
      'it returns TRUE if it exists and FALSE if it doesn't
      Function DomainExists ( DName As String ) As Boolean

          Dim dom As Domain

          For Each dom In dict.Domains

              If UCase(dom.Name) = UCase(DName) Then

                  DomainExists = True
                  Exit Function

              End If

          Next

          DomainExists = False

      End Function

      'this function is used to print a sample sheet for the import format.
      Sub PrintSampleSheet()

          Dim ex As Object
          Dim wb, ws As Variant

          Set ex = CreateObject("excel.application")
          ex.visible = True

          Set wb = ex.workbooks.Add
          Set ws = wb.activesheet

          ws.cells(1,1).Value = "Diagram"
          ws.cells(1,2).Value = "Model"
          ws.cells(1,3).Value = "Entity/Table"
          ws.cells(1,4).Value = "Attribute/Column"
          ws.cells(1,5).Value = "Attribute Datatype"
          ws.cells(1,6).Value = "Attribute Datatype Length"
          ws.cells(1,7).Value = "Attribute Datatype Precision"
          ws.cells(1,8).Value = "Domain Name"
          ws.cells(1,9).Value = "Dictionary"

          ws.cells(2,1).Value = "string - Optional"
          ws.cells(2,2).Value = "string - Required"
          ws.cells(2,3).Value = "string - Required"
          ws.cells(2,4).Value = "string - Required"
          ws.cells(2,5).Value = "string - Optional"
          ws.cells(2,6).Value = "Numeric - Optional"
          ws.cells(2,7).Value = "Numeric - Optional"
          ws.cells(2,8).Value = "String - Required"
          ws.cells(2,9).Value = "String - Required"

          With ws.range(ws.cells(1,1),ws.cells(1,9))
              .font.Size = 12
              .font.Bold = True
              .columnwidth = 30
          End With

          ws.range(ws.cells(2,1),ws.cells(2,9)).wraptext = True

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

              'make diagram and file name text blocks read only
              DlgEnable "diagram_name_txt", False
              DlgEnable "filename_txt", False

              'populate the diagram and file name text blocks with the appropiate data.
              DlgText "diagram_name_txt", diag.ProjectName
              DlgText "filename_txt", diag.FileName

          Case 2 ' Value changing or button pressed

              If DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"xls",,"Open SpreadSheet")
                  DialogFunc = True
              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              ElseIf DlgItem = "getsample" Then
                  PrintSampleSheet
                  DialogFunc = True
              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Example macro- Loop through objects of Active Submodel.bas

      'TITLE:  LOOP THROUGH CURRENT SUBMODEL
      'DESCRIPTION:  This macro demonstrates how to loop through the objects
      '	of the current submodel.

      'ER/Studio Variables
      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel

      Dim ent As Entity
      Dim entdisp As EntityDisplay

      Dim rel As Relationship
      Dim reldisp As RelationshipDisplay

      Dim vw As View
      Dim vwdisp As ViewDisplay

      Sub Main

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          'loop through the entities
          For Each entdisp In submdl.EntityDisplays

              Set ent = entdisp.ParentEntity

              'insert entity operations here
              'and/or insert other loops for attributes or indexes
              'use "ent."

          Next entdisp

          'loop throgh the relationships
          For Each reldisp In submdl.RelationshipDisplays

              Set rel = reldisp.ParentRelationship

              'can insert relationship operations here
              'use "rel."

          Next reldisp

          'loop throgh the relationships
          For Each vwdisp In submdl.ViewDisplays

              Set vw = vwdisp.ParentView

              'can insert view operations here
              'use "vw."

          Next vwdisp

      End Sub


Export Domain Info to Excel.bas

      'MACRO TITLE: EXPORT DOMAIN INFO TO EXCEL (Enterprise).BAS
      'This macro exports the domains and their properties to excel.
      'Each record in the Excel spread sheet represents on domains from the
      'data dictionary.  The spread sheet can be used to store domains
      'outside of ER/Studio.  The domain properties can be updated in the
      'spread sheet and imported back into an existing model or a new model
      'using the "Import Domains From Excel" macro.  The columns in the
      'spread sheet must remain in the same order to import them properly.
      '	REQUIREMENT: You must have MS Excel 97 or later installed
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST UPDATE:  5/27/2003

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim dict As Dictionary
      Dim dom As Domain
      Dim dom_folder As DomainFolder
      Dim dictionary_list () As String

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          'Set dict = diag.Dictionary

          curRow = 1
          curCol = 1

          Debug.Clear

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          Begin Dialog UserDialog 510,133,"Domain Export" ' %GRID:10,7,1,1
              Text 20,21,130,14,"Select Dictionary:",.Text1
              DropListBox 150,21,330,112,dictionary_list(),.dictionary_select
              CancelButton 380,84,90,28
              OKButton 270,84,100,28
          End Dialog
          Dim dlg As UserDialog

          init_dictionary_list

          If Dialog(dlg) = -1 Then

              'choose the proper dictionary
              If dictionary_list(dlg.dictionary_select) = "Local" Then

                  Set dict = diag.Dictionary

              Else

                  Set dict = diag.EnterpriseDataDictionaries.Item(dictionary_list(dlg.dictionary_select))

              End If

              Debug.Print dict.Name

              ' Create Excel workbook.

              Set Excel = CreateObject("Excel.Application")
              Excel.Workbooks.Add

              'Excel.Visible = True

              InitColumnWidth
              PrintColumnHeader
              PrintData

              MsgBox("Export   Complete!",,"ER/Studio")

              ' make Excel spread sheet visible
              Excel.Visible = True

          End If

      End Sub
      'initialize the dictionary drop down list
      Sub init_dictionary_list

          ReDim dictionary_list (0 To diag.EnterpriseDataDictionaries.Count) As String

          dictionary_list (0) = "Local"
          i = 1

          For Each dict In diag.EnterpriseDataDictionaries

              dictionary_list (i) = dict.Name
              i = i + 1

          Next

      End Sub

      Sub PrintData

          Dim bHideFont As Boolean
          bHideFont = False

          'loop through the domains and export the properties of the domains
          For Each dom In dict.Domains

              PrintCell dom.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              PrintCell dom.AttributeName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              PrintCell dom.ColumnName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              PrintCell dom.DomainFolder, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              PrintCell dom.Definition, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              PrintCell dom.Note, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              PrintCell dom.Datatype, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              If dom.DataLength > 0 Then
                  PrintCell dom.DataLength, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
              Else
                  PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
              End If

              If dom.DataScale > 0 Then
                  PrintCell dom.DataScale, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
              Else
                  PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
              End If

              If dom.Nullable = True Then
                  PrintCell "YES", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
              Else
                  PrintCell "NO", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
              End If

              If dom.Identity = True Then

                  PrintCell "YES", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
                  PrintCell dom.IdentitySeed, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
                  PrintCell dom.IdentityIncrement, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              Else

                  PrintCell "NO", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
                  PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
                  PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

              End If

              curRow = curRow + 1
              curCol = 1

          Next

      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth

      Dim count As Integer

      count = 13

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 30
      Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader

              PrintCell "Domain Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Attribute Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Column Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Domain Folder", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Domain Definition", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Domain Note", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "DataType", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "DataType Width", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "DataType Scale", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Allow Nulls", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Identity Column", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Identity Seed", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Identity Increment", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              curRow = curRow + 1
              curCol = 1

      End Sub

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub


Export Index Column Info to Excel.BAS

      'MACRO TITLE: EXPORT INDEX COLUMN INFO TO EXCEL.BAS
      'This macro generates an index column report for the active
      'model in ER/Studio.  Each record in the Excel spread sheet
      'represents an indexed column.  The spread sheet can be used
      'to apply naming conventions to indexes.  The new index name
      'can be read in with the "Import Index Names from Excel" macro
      'from the "New Index Name" column in the spread sheet.
      '	REQUIREMENT: You must have MS Excel 97 or later installed
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST UPDATE:  5/6/2003

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj
      Dim entdisp As EntityDisplay
      Dim indx As Index
      Dim indxcol As IndexColumn

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          curRow = 1
          curCol = 1

          Debug.Clear

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          ' Create Excel workbook.

          Set Excel = CreateObject("Excel.Application")
          Excel.Workbooks.Add

          InitColumnWidth
          PrintColumnHeader
          PrintData

          MsgBox("Export   Complete!",,"ER/Studio")

          ' make Excel spread sheet visible
          Excel.Visible = True

      End Sub

      Sub PrintData

          Dim bHideFont As Boolean
          bHideFont = False

              'loop through entity displays of the current submodel
              For Each entdisp In submdl.EntityDisplays

                  'get the entity object from the entity display object
                  Set ent = entdisp.ParentEntity

                      'loop through the indexes of the entity
                      For Each indx In ent.Indexes

                          'loop through the indexed columns of the index
                          For Each indxcol In indx.IndexColumns

                              'Print the table name
                              PrintCell ent.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                              'Print the index name
                              PrintCell indx.Name, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                              'determine the type of the index and print it to the spread sheet
                              Select Case UCase(indx.KeyType)

                                    Case "P"  'Primary

                                        PrintCell "PK", curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                     Case "I"  'Inversion Entry or Non-unique index

                                         PrintCell "IE", curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                  Case "A"  'Alternate Key or Unique index

                                      PrintCell "AK", curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                 End Select

                              'print the column name of the indexed column
                              PrintCell indxcol.ColumnName , curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                              'increment the row counter for the next row in the spread sheet
                              curRow = curRow + 1
                              curCol = 1
                              bHideFont = False

                          Next

                      Next

              Next

      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth

      Dim count As Integer

      count = 5

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 20
      Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader

              PrintCell "Table Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Index Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Index Type", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Index Member Column Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "New Index Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              curRow = curRow + 1
              curCol = 1

      End Sub

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub


Export Metadata to Excel Version 2.BAS

      'MACRO TITLE: EXPORT MODEL METADATA TO EXCEL VERSION 2
      ' This macro generates a report for the active model in ER/Studio.
      ' REQUIREMENT: You must have MS Excel 97 or later installed

      ' PLEASE NOTE: This macro only reports on the selected entities!
      ' UPDATED: 9/18/03
      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj
      Dim rel As Relationship
      Dim eNames As Variant
      Dim eCount As Variant

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          curRow = 1
          curCol = 1

          Debug.Clear

          ' Prompt the user.

          Begin Dialog UserDialog 950,301,"Excel Export Options",.ExportHandler ' %GRID:10,7,1,1
              OKButton 580,259,150,35
              CancelButton 760,259,150,35
              GroupBox 20,14,320,245,"Entity/Table Export Options",.GroupBox1
              CheckBox 50,42,110,14,"Entity Name",.EntityName
              CheckBox 50,70,110,14,"Table Name",.TableName
              CheckBox 50,98,180,14,"Entity/Table Definition",.ETdefinition
              GroupBox 360,14,570,224,"Attribute Options",.GroupBox2
              CheckBox 390,42,140,14,"Attribute Name",.AttributeName
              CheckBox 390,70,120,14,"Column Name",.ColumnName
              CheckBox 390,98,210,14,"Attribute/Column Definition",.ACdefinition
              CheckBox 390,154,280,14,"Data Type (includes precision and scale)",.Datatype
              CheckBox 390,182,110,14,"Null Option",.NullOption
              CheckBox 680,42,220,14,"Primary Key Property (Boolean)",.PKproperty
              CheckBox 680,70,220,14,"Foreign Key Property (Boolean)",.FKproperty
              CheckBox 680,154,160,14,"Column Default",.columndefault
              CheckBox 680,182,190,14,"Column Check Constraint",.CheckConstraint
              CheckBox 680,98,240,14,"Has Logical Rolename (Boolean)",.HasLogicalRoleName
              CheckBox 680,126,200,14,"Has Rolename (Boolean)",.HasRoleName
              CheckBox 460,210,160,14,"Only Key Columns",.keycolumns
              CheckBox 390,126,180,14,"Domain",.Domain
              PushButton 660,224,90,21,"Select All",.attrselect
              PushButton 770,224,90,21,"Deselect All",.attrdeselect
              CheckBox 50,147,90,14,"Owner",.Owner
              CheckBox 50,175,200,14,"Storage Location",.StorageLocation
              CheckBox 50,210,90,14,"Database",.Database
              Text 80,189,240,14,"(i.e., Table Space, filegroup, segment)",.Text1
              Text 90,224,90,14,"(for OS/390)",.Text2
              PushButton 110,245,90,21,"Select All",.tblselect
              PushButton 220,245,90,21,"Deselect All",.tbldeselect
              Text 30,126,230,14,"Physical table properties:",.Text3
          End Dialog
          Dim dlg As UserDialog

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          ' Print the spread sheet.

          If Dialog(dlg) = -1 Then

          ' Start Excel and make it visible.

          Set Excel = CreateObject("Excel.Application")
          Excel.Visible = True
          Excel.Workbooks.Add

          ReDim EntDialogOptions ( 1 To 19 ) As Boolean

          'build array of Entity options to pass to Printdata subroutine

          EntDialogOptions(1) = dlg.EntityName
          EntDialogOptions(2) = dlg.TableName
          EntDialogOptions(3) = dlg.ETdefinition
          EntDialogOptions(4) = dlg.Owner
          EntDialogOptions(5) = dlg.StorageLocation
          EntDialogOptions(6) = dlg.Database
          EntDialogOptions(7) = dlg.AttributeName
          EntDialogOptions(8) = dlg.ColumnName
          EntDialogOptions(9) = dlg.ACdefinition
          EntDialogOptions(10) = dlg.Domain
          EntDialogOptions(11) = dlg.Datatype
          EntDialogOptions(12) = dlg.NullOption
          EntDialogOptions(13) = dlg.PKproperty
          EntDialogOptions(14) = dlg.FKProperty
          EntDialogOptions(15) = dlg.columndefault
          EntDialogOptions(16) = dlg.CheckConstraint
          EntDialogOptions(17) = dlg.HasLogicalRoleName
          EntDialogOptions(18) = dlg.HasRoleName
          EntDialogOptions(19) = dlg.keycolumns

          InitColumnWidth EntDialogOptions
              If submdl.SelectedObjects.Count > 0 Then
                PrintColumnHeader ColOrder, EntDialogOptions
                PrintData EntDialogOptions

                Excel.Visible = True
              Else
                MsgBox "Please select an Entity.  Or use Edit --> Select All."
              End If

          End If 'dialog

      End Sub

      Sub PrintData (EntOptions As Variant)

          Dim bHideFont As Boolean
          bHideFont = False

          Dim count As Integer
          Dim JustEntityInfo As Boolean

          count = 1

          'count the true values from the dialog array so that the correct number
          'of columns are printed out
          For i = 1 To 19
              Debug.Print EntOptions(i)
              If EntOptions(i) = True Then
                  count = count + 1
              End If
          Next

          JustEntityInfo = False

          'determine if only entity info is printed out so that entity names and
          'definitions are only printed once.
          For j = 7 To 19
              If EntOptions(j) = True Then
                  JustEntityInfo = True
                  Exit For
              End If
          Next j

          'submdl.EntityNames(eNames, eCount)

          'print entity and attribute info to excel
          'For i = 0 To eCount - 1

              'Set ent = mdl.Entities.Item(eNames(i))
          'Only report on selected entities

          For Each so In submdl.SelectedObjects

              If so.Type = 1 Then

                  Set ent = mdl.Entities.Item(so.ID)
              'If JustEntityInfo is false, then no attribute info is exported
              'so table/entity names and table definitions only have to be printed once
              If JustEntityInfo = False Then

                  'print entity name if option is true
                  If EntOptions(1) = True Then
                      PrintCell ent.EntityName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print table name if option is true
                  If EntOptions(2) = True Then
                      PrintCell ent.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity definition if option is true
                  If EntOptions(3) = True Then
                      PrintCell ent.Definition, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity owner if option is true
                  If EntOptions(4) = True Then
                      PrintCell ent.Owner, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity storage location if option is true
                  If EntOptions(5) = True Then
                      PrintCell ent.StorageLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity definition if option is true
                  If EntOptions(6) = True Then
                      PrintCell ent.DatabaseLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  curRow = curRow + 1
                  curCol = 1

              Else

              For j = 1 To ent.Attributes.Count

              For Each attr In ent.Attributes

                  If attr.SequenceNumber = j Then

                  If EntOptions(19) = False Then

                      GoTo SKIP

                  End If

                  If attr.PrimaryKey = True Or attr.ForeignKey = True Then

                  SKIP:
                  'bHideFont is true to hide repeated entity and table names and table level defintions
                  If bHideFont = True Then

                      'print entity name if option is true, use back color to hide repeated value
                      If EntOptions(1) = True Then
                          PrintCell ent.EntityName, curRow, curCol, 0, 1, clrBack, clrBack, 10, False
                      End If

                      'print table name if option is true, use back color to hide repeated value
                      If EntOptions(2) = True Then
                          PrintCell ent.TableName, curRow, curCol, 0, 1, clrBack, clrBack, 10, False
                      End If

                      'print entity level defintion if option is true, use back color to hide repeated value
                      If EntOptions(3) = True Then
                          PrintCell ent.Definition, curRow, curCol, 0, 1, clrBack, clrBack, 10, False
                      End If

                      'print entity owner if option is true
                      If EntOptions(4) = True Then
                          PrintCell ent.Owner, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print entity storage location if option is true
                      If EntOptions(5) = True Then
                          PrintCell ent.StorageLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print entity definition if option is true
                      If EntOptions(6) = True Then
                          PrintCell ent.DatabaseLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                  Else

                      'print entity name if option is true, use fore color
                      If EntOptions(1) = True Then
                          PrintCell ent.EntityName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print table name if option is true, use fore color
                      If EntOptions(2) = True Then
                          PrintCell ent.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print entity/table definition if option is true, use fore color
                      If EntOptions(3) = True Then
                          PrintCell ent.Definition, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print entity owner if option is true
                      If EntOptions(4) = True Then
                          PrintCell ent.Owner, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print entity storage location if option is true
                      If EntOptions(5) = True Then
                          PrintCell ent.StorageLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                      'print entity definition if option is true
                      If EntOptions(6) = True Then
                          PrintCell ent.DatabaseLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If

                  End If

                  bHideFont = True

                  'print attribute name if option is true
                  If EntOptions(7) = True Then
                      Dim attrname As String

                      If attr.HasLogicalRoleName = True Then
                          attrname = attr.LogicalRoleName
                      Else
                          attrname = attr.AttributeName
                      End If

                      PrintCell attrname,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print column name if option is true
                  If EntOptions(8) = True Then
                      Dim colname As String

                      If attr.HasRoleName = True Then
                          colname = attr.RoleName
                      Else
                          colname = attr.ColumnName
                      End If

                      PrintCell colname,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print attribute definition if option is true
                  If EntOptions(9) = True Then
                      PrintCell attr.Definition,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print attribute domain if option is true
                  If EntOptions(10) = True Then

                      Dim dom As Domain
                      If attr.DomainId <> 0 Then

                          Set dom = diag.Domain(attr.DomainId)
                          PrintCell dom.Name, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                      Else

                          PrintCell "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                      End If

                  End If

                  'print attribute datatype if option is true
                  If EntOptions(11) = True Then

                      Dim datatype As String

                      datatype = attr.CompositeDatatype
                      datatype = Replace(datatype, " NOT", "")
                      datatype = Replace(datatype, " NULL", "")

                      PrintCell datatype,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                  End If

                  'print null option if option is true
                  If EntOptions(12) = True Then
                      PrintCell attr.NullOption, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print yes or no depending on whether the attribute is a primary key if option is true
                  If EntOptions(13) = True Then

                      If (attr.PrimaryKey = "True") Then
                          PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      Else
                          PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If 'primary key check

                  End If 'primary option

                  'print yes or no depending on whether the attribute is a foreign key if option is true
                  If EntOptions(14) = True Then

                      If (attr.ForeignKey = "True") Then
                          PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      Else
                          PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If 'foreign key check

                  End If 'foreign option

                  If EntOptions(17) = True Then

                      If (attr.HasLogicalRoleName = "True") Then
                          PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      Else
                          PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If 'Logical rolename check

                  End If 'logical rolename option

                  If EntOptions(18) = True Then

                  If (attr.HasRoleName = "True") Then
                      PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  Else
                      PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If 'rolename check

                  End If 'rolename option

                  'print default if option is checked
                  If EntOptions(15) = True Then
                       PrintCell attr.DeclaredDefault,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print check constraint if option is checked
                  If EntOptions(16) = True Then
                      PrintCell attr.CheckConstraint,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  curRow = curRow + 1
                  curCol = 1

              End If

              End If

              Next attr

              Next

              End If

              curCol = 1
              bHideFont = False

            End If
          Next so

      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth (options As Variant)

      Dim count As Integer

      count = 0

      'count the number of true options
      For i = 1 To 18
          If options(i) = True Then
              count = count + 1
          End If
      Next i

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 30
      Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader(ColOrder As Variant, options As Variant)

          If options(1) = True Then
              PrintCell "Entity Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(2) = True Then
              PrintCell "Table Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(3) = True Then
              PrintCell "Entity/Table Definition", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(4) = True Then
              PrintCell "Entity/Table Owner", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(5) = True Then
              PrintCell "Storage Location", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(6) = True Then
              PrintCell "Database", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(7) = True Then
              PrintCell "Attribute Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(8) = True Then
              PrintCell "Column Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(9) = True Then
              PrintCell "Attribute/Column Definition", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(10) = True Then
              PrintCell "Domain", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(11) = True Then
              PrintCell "Column Datatype", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(12) = True Then
              PrintCell "Column Null Option", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(13) = True Then
              PrintCell "Primary Key", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(14) = True Then
              PrintCell "Foreign Key", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(17) = True Then
              PrintCell "Logical Rolename", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(18) = True Then
              PrintCell "Rolename", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(15) = True Then
              PrintCell "Column Default", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(16) = True Then
              PrintCell "Column Check Constraint", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          curRow = curRow + 1
          curCol = 1
      End Sub

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function ExportHandler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "OK" Then

                  Debug.Print mdl.DatabasePlatform

                  Dim DBplatform As String
                  DBplatform = Left(mdl.DatabasePlatform,22)

                  If (DlgValue("StorageLocation") = 1 Or DlgValue("Database") = 1 Or DlgValue("Owner") = 1) And mdl.Logical = True Then

                      MsgBox ("Physical table properties can only be selected for physical models.",,"MESSAGE")
                      ExportHandler = True

                  ElseIf DBplatform <> "IBM DB2 UDB for OS/390"  And DlgValue("Database") = 1 Then

                      MsgBox ("Database option is only for DB2 OS/390 physical models.",,"MESSAGE")
                      ExportHandler = True

                  End If

              ElseIf DlgItem = "tblselect" Then

                  DlgValue "EntityName", 1
                  DlgValue "TableName", 1
                  DlgValue "ETdefinition", 1
                  DlgValue "Owner", 1
                  DlgValue "StorageLocation", 1
                  DlgValue "Database", 1

                  ExportHandler = True

              ElseIf DlgItem = "tbldeselect" Then

                  DlgValue "EntityName", 0
                  DlgValue "TableName", 0
                  DlgValue "ETdefinition", 0
                  DlgValue "Owner", 0
                  DlgValue "StorageLocation", 0
                  DlgValue "Database", 0

                  ExportHandler = True

              ElseIf DlgItem = "attrselect" Then

                  DlgValue "AttributeName", 1
                  DlgValue "ColumnName", 1
                  DlgValue "ACdefinition", 1
                  DlgValue "Domain", 1
                  DlgValue "Datatype", 1
                  DlgValue "NullOption", 1
                  DlgValue "PKproperty", 1
                  DlgValue "FKProperty", 1
                  DlgValue "columndefault", 1
                  DlgValue "CheckConstraint", 1
                  DlgValue "HasLogicalRoleName", 1
                  DlgValue "HasRoleName", 1

                  ExportHandler = True

              ElseIf DlgItem = "attrdeselect" Then

                  DlgValue "AttributeName", 0
                  DlgValue "ColumnName", 0
                  DlgValue "ACdefinition", 0
                  DlgValue "Domain", 0
                  DlgValue "Datatype", 0
                  DlgValue "NullOption", 0
                  DlgValue "PKproperty", 0
                  DlgValue "FKProperty", 0
                  DlgValue "columndefault", 0
                  DlgValue "CheckConstraint", 0
                  DlgValue "HasLogicalRoleName", 0
                  DlgValue "HasRoleName", 0

                  ExportHandler = True

              End If

              Rem ExportHandler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem ExportHandler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Export Metadata to Excel Version 2.1.BAS

      'MACRO TITLE: EXPORT MODEL METADATA TO EXCEL VERSION 2.1
      ' This macro generates a report for the active model in ER/Studio.
      ' REQUIREMENT: You must have MS Excel 97 or later installed

      ' UPDATED ON 9/30/2004
      ' Updates include the option to export for selected objects or the main
      ' model and the include of attribute notes.

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' dim dialog variables
      Dim selected_object_loop As Boolean    'if true, macro loops through selected objects
                                             'if false, macro loops through all objects

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj
      Dim rel As Relationship
      Dim eNames As Variant
      Dim eCount As Variant
      Dim entdisplay As EntityDisplay

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          curRow = 1
          curCol = 1

          Debug.Clear

          ' Prompt the user.

          Begin Dialog UserDialog 970,406,"Excel Export Options",.ExportHandler ' %GRID:10,7,1,1
              GroupBox 20,112,320,273,"Entity/Table Options",.GroupBox1
              CheckBox 50,140,110,14,"Entity Name",.EntityName
              CheckBox 50,168,110,14,"Table Name",.TableName
              CheckBox 50,196,180,14,"Entity/Table Definition",.ETdefinition
              GroupBox 370,112,570,224,"Attribute Options",.GroupBox2
              CheckBox 390,140,140,14,"Attribute Name",.AttributeName
              CheckBox 390,168,120,14,"Column Name",.ColumnName
              CheckBox 390,196,210,14,"Attribute/Column Definition",.ACdefinition
              CheckBox 390,280,280,14,"Data Type (includes precision and scale)",.Datatype
              CheckBox 390,308,110,14,"Null Option",.NullOption
              CheckBox 680,140,220,14,"Primary Key Property (Boolean)",.PKproperty
              CheckBox 680,168,220,14,"Foreign Key Property (Boolean)",.FKproperty
              CheckBox 680,259,160,14,"Column Default",.columndefault
              CheckBox 680,287,190,14,"Column Check Constraint",.CheckConstraint
              CheckBox 680,203,240,14,"Has Logical Rolename (Boolean)",.HasLogicalRoleName
              CheckBox 680,231,200,14,"Has Rolename (Boolean)",.HasRoleName
              CheckBox 400,357,160,14,"Only Key Columns",.keycolumns
              CheckBox 390,252,180,14,"Domain",.Domain
              PushButton 660,322,90,21,"Select All",.attrselect
              PushButton 790,322,90,21,"Deselect All",.attrdeselect
              CheckBox 50,273,90,14,"Owner",.Owner
              CheckBox 50,301,200,14,"Storage Location",.StorageLocation
              CheckBox 50,336,90,14,"Database",.Database
              Text 80,315,240,14,"(i.e., Table Space, filegroup, segment)",.Text1
              Text 80,350,90,14,"(for OS/390)",.Text2
              PushButton 120,371,90,21,"Select All",.tblselect
              PushButton 230,371,90,21,"Deselect All",.tbldeselect
              Text 30,252,230,14,"Physical table properties:",.Text3
              Text 20,7,150,14,"Diagram Information:",.diaginfotxt
              GroupBox 600,21,240,77,"Export Scope",.GroupBox3
              OptionGroup .object_sel
                  OptionButton 650,42,130,14,"All Objects",.OptionButton3
                  OptionButton 650,70,140,14,"Selected Objects",.OptionButton4
              CheckBox 390,224,210,14,"Attribute/Column Note",.ACnote
              OKButton 590,357,160,35
              CancelButton 780,357,150,35
              TextBox 20,28,560,70,.diag_info,1
              CheckBox 50,224,210,14,"Entity/Table Note",.ETNote
          End Dialog
          Dim dlg As UserDialog

          'initialize the dialog info text block.
          Dim sel_objects As String
          Dim mdl_type As String

          If entitiesSelected = False Then
              sel_objects = "NO"
          Else
              sel_objects = "YES"
          End If

          If mdl.Logical = True Then
              mdl_type = "LOGICAL"
          Else
              mdl_type = "PHYSICAL"
          End If

          'populate text box in the dialog with some information about what will be exported
          dlg.diag_info = "Diagram:  " & diag.ProjectName & vbCrLf & "Model Name:  " & mdl.Name & vbCrLf & "Model Type:  " & mdl_type & vbCrLf & "Active Model:  " & submdl.Name & vbCrLf & "Selected Objects:  " & sel_objects

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          ' Print the spread sheet.

          If Dialog(dlg) = -1 Then

          ' Start Excel and make it visible.

          Set Excel = CreateObject("Excel.Application")
          Excel.Visible = True
          Excel.Workbooks.Add

          ReDim EntDialogOptions ( 1 To 21 ) As Boolean

          'build array of Entity options to pass to Printdata subroutine

          EntDialogOptions(1) = dlg.EntityName
          EntDialogOptions(2) = dlg.TableName
          EntDialogOptions(3) = dlg.ETdefinition
          EntDialogOptions(21) = dlg.ETNote
          EntDialogOptions(4) = dlg.Owner
          EntDialogOptions(5) = dlg.StorageLocation
          EntDialogOptions(6) = dlg.Database
          EntDialogOptions(7) = dlg.AttributeName
          EntDialogOptions(8) = dlg.ColumnName
          EntDialogOptions(9) = dlg.ACdefinition
          EntDialogOptions(20) = dlg.ACnote
          EntDialogOptions(10) = dlg.Domain
          EntDialogOptions(11) = dlg.Datatype
          EntDialogOptions(12) = dlg.NullOption
          EntDialogOptions(13) = dlg.PKproperty
          EntDialogOptions(14) = dlg.FKProperty
          EntDialogOptions(15) = dlg.columndefault
          EntDialogOptions(16) = dlg.CheckConstraint
          EntDialogOptions(17) = dlg.HasLogicalRoleName
          EntDialogOptions(18) = dlg.HasRoleName
          EntDialogOptions(19) = dlg.keycolumns

          InitColumnWidth EntDialogOptions

          PrintColumnHeader ColOrder, EntDialogOptions
          PrintData EntDialogOptions

          Excel.Visible = True

          End If 'dialog

      End Sub

      Sub PrintData (EntOptions As Variant)

          Dim count As Integer
          Dim JustEntityInfo As Boolean

          count = 1

          'count the true values from the dialog array so that the correct number
          'of columns are printed out
          For i = 1 To 21
              Debug.Print EntOptions(i)
              If EntOptions(i) = True Then
                  count = count + 1
              End If
          Next

          JustEntityInfo = True

          'determine if only entity info is printed out so that entity names and
          'definitions are only printed once.
          For j = 7 To 20
              If EntOptions(j) = True Then
                  JustEntityInfo = False
                  Exit For
              End If
          Next j

          If selected_object_loop = False Then

              'loop through all objects in the model
              For Each entdisplay In submdl.EntityDisplays

                  Set ent = entdisplay.ParentEntity

                  'If JustEntityInfo is true, then no attribute info is exported
                  'so table/entity names and table definitions only have to be printed once
                  If JustEntityInfo = True Then

                      printRecord_entOnly EntOptions

                      curRow = curRow + 1
                      curCol = 1

                  Else

                      For j = 1 To ent.Attributes.Count

                          For Each attr In ent.Attributes

                              If attr.SequenceNumber = j Then

                                  If EntOptions(19) = False Then

                                      GoTo SKIP

                                  End If

                                  If attr.PrimaryKey = True Or attr.ForeignKey = True Then

                                      SKIP:

                                      printRecord_ent_and_attr EntOptions

                                      curRow = curRow + 1
                                      curCol = 1

                                  End If ' key column check

                              End If  'sequence number check

                          Next attr

                      Next j

                  End If 'Just entity information check

                  curCol = 1

              Next entdisplay

          Else

              'Only report on selected entities
              For Each so In submdl.SelectedObjects

                  If so.Type = 1 Then

                  Set ent = mdl.Entities.Item(so.ID)

                  'If JustEntityInfo is true, then no attribute info is exported
                  'so table/entity names and table definitions only have to be printed once
                  If JustEntityInfo = True Then

                      printRecord_entOnly EntOptions

                      curRow = curRow + 1
                      curCol = 1

                  Else

                      For j = 1 To ent.Attributes.Count

                          For Each attr In ent.Attributes

                              If attr.SequenceNumber = j Then

                                  If EntOptions(19) = False Then

                                      GoTo SKIP2

                                  End If

                                  If attr.PrimaryKey = True Or attr.ForeignKey = True Then

                                      SKIP2:

                                      printRecord_ent_and_attr EntOptions

                                      curRow = curRow + 1
                                      curCol = 1

                                  End If ' key column check

                              End If  'sequence number check

                          Next attr

                      Next j

                  End If 'Just entity information check

                  curCol = 1

                  End If 'so ID check

              Next so

          End If ' selected object check

      End Sub

      Function printRecord_entOnly(EntOptions As Variant)

                  'print entity name if option is true
                  If EntOptions(1) = True Then
                      PrintCell ent.EntityName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print table name if option is true
                  If EntOptions(2) = True Then
                      PrintCell ent.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity definition if option is true
                  If EntOptions(3) = True Then
                      PrintCell ent.Definition, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  If EntOptions(21) = True Then
                      PrintCell ent.Note, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
                  End If

                  'print entity owner if option is true
                  If EntOptions(4) = True Then
                      PrintCell ent.Owner, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity storage location if option is true
                  If EntOptions(5) = True Then
                      PrintCell ent.StorageLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity definition if option is true
                  If EntOptions(6) = True Then
                      PrintCell ent.DatabaseLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

      End Function

      Function printRecord_ent_and_attr(EntOptions As Variant)

                  'print entity name if option is true, use fore color
                  If EntOptions(1) = True Then
                      PrintCell ent.EntityName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print table name if option is true, use fore color
                  If EntOptions(2) = True Then
                      PrintCell ent.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity/table definition if option is true, use fore color
                  If EntOptions(3) = True Then
                      PrintCell ent.Definition, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  If EntOptions(21) = True Then
                      PrintCell ent.Note, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False
                  End If

                  'print entity owner if option is true
                  If EntOptions(4) = True Then
                      PrintCell ent.Owner, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity storage location if option is true
                  If EntOptions(5) = True Then
                      PrintCell ent.StorageLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print entity definition if option is true
                  If EntOptions(6) = True Then
                      PrintCell ent.DatabaseLocation, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print attribute name if option is true
                  If EntOptions(7) = True Then
                      Dim attrname As String

                      If attr.HasLogicalRoleName = True Then
                          attrname = attr.LogicalRoleName
                      Else
                          attrname = attr.AttributeName
                      End If

                      PrintCell attrname,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print column name if option is true
                  If EntOptions(8) = True Then
                      Dim colname As String

                      If attr.HasRoleName = True Then
                          colname = attr.RoleName
                      Else
                          colname = attr.ColumnName
                      End If

                      PrintCell colname,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print attribute definition if option is true
                  If EntOptions(9) = True Then
                      PrintCell attr.Definition,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print attribute note if option is true
                  If EntOptions(20) = True Then
                      PrintCell attr.Notes,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print attribute domain if option is true
                  If EntOptions(10) = True Then

                      Dim dom As Domain
                      If attr.DomainId <> 0 Then

                          Set dom = diag.Domain(attr.DomainId)
                          PrintCell dom.Name, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                      Else

                          PrintCell "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                      End If

                  End If

                  'print attribute datatype if option is true
                  If EntOptions(11) = True Then

                      Dim datatype As String

                      datatype = attr.CompositeDatatype
                      datatype = Replace(datatype, " NOT", "")
                      datatype = Replace(datatype, " NULL", "")

                      PrintCell datatype,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                  End If

                  'print null option if option is true
                  If EntOptions(12) = True Then
                      PrintCell attr.NullOption, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print yes or no depending on whether the attribute is a primary key if option is true
                  If EntOptions(13) = True Then

                      If (attr.PrimaryKey = "True") Then
                          PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      Else
                          PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If 'primary key check

                  End If 'primary option

                  'print yes or no depending on whether the attribute is a foreign key if option is true
                  If EntOptions(14) = True Then

                      If (attr.ForeignKey = "True") Then
                          PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      Else
                          PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If 'foreign key check

                  End If 'foreign option

                  If EntOptions(17) = True Then

                      If (attr.HasLogicalRoleName = "True") Then
                          PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      Else
                          PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                      End If 'Logical rolename check

                  End If 'logical rolename option

                  If EntOptions(18) = True Then

                  If (attr.HasRoleName = "True") Then
                      PrintCell "Yes", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  Else
                      PrintCell "No", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If 'rolename check

                  End If 'rolename option

                  'print default if option is checked
                  If EntOptions(15) = True Then
                       PrintCell attr.DeclaredDefault,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  'print check constraint if option is checked
                  If EntOptions(16) = True Then
                      PrintCell attr.CheckConstraint,  curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

      End Function

      ' Initialize the column width.

      Sub InitColumnWidth (options As Variant)

      Dim count As Integer

      count = 0

      'count the number of true options
      For i = 1 To 21
          If options(i) = True Then
              count = count + 1
          End If
      Next i

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 30
      Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader(ColOrder As Variant, options As Variant)

          If options(1) = True Then
              PrintCell "Entity Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(2) = True Then
              PrintCell "Table Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(3) = True Then
              PrintCell "Entity/Table Definition", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(21) = True Then
              PrintCell "Entity/Table Note", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(4) = True Then
              PrintCell "Entity/Table Owner", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(5) = True Then
              PrintCell "Storage Location", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(6) = True Then
              PrintCell "Database", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(7) = True Then
              PrintCell "Attribute Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(8) = True Then
              PrintCell "Column Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(9) = True Then
              PrintCell "Attribute/Column Definition", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(20) = True Then
              PrintCell "Attribute/Column Note", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(10) = True Then
              PrintCell "Domain", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(11) = True Then
              PrintCell "Column Datatype", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(12) = True Then
              PrintCell "Column Null Option", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(13) = True Then
              PrintCell "Primary Key", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(14) = True Then
              PrintCell "Foreign Key", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(17) = True Then
              PrintCell "Logical Rolename", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(18) = True Then
              PrintCell "Rolename", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(15) = True Then
              PrintCell "Column Default", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          If options(16) = True Then
              PrintCell "Column Check Constraint", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          End If

          curRow = curRow + 1
          curCol = 1
      End Sub

      Function entitiesSelected() As Boolean

          Dim selObj As SelectedObject

          If submdl.SelectedObjects.Count > 0 Then
              For Each selObj In submdl.SelectedObjects
                  If selObj.Type=1 Then
                      entitiesSelected = True
                      Exit Function
                  End If
              Next
          End If

          entitiesSelected = False

      End Function

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function ExportHandler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

                  If entitiesSelected = False Then

                      DlgEnable "OptionButton4", False
                  Else
                      DlgEnable "optionbutton4", True

                  End If

          Case 2 ' Value changing or button pressed

              If DlgItem = "OK" Then

                  Debug.Print mdl.DatabasePlatform

                  Dim DBplatform As String
                  DBplatform = Left(mdl.DatabasePlatform,22)

                  If (DlgValue("StorageLocation") = 1 Or DlgValue("Database") = 1 Or DlgValue("Owner") = 1) And mdl.Logical = True Then

                      MsgBox ("Physical table properties can only be selected for physical models.",,"MESSAGE")
                      ExportHandler = True

                  ElseIf DBplatform <> "IBM DB2 UDB for OS/390"  And DlgValue("Database") = 1 Then

                      MsgBox ("Database option is only for DB2 OS/390 physical models.",,"MESSAGE")
                      ExportHandler = True

                  End If

              ElseIf DlgItem = "tblselect" Then

                  DlgValue "EntityName", 1
                  DlgValue "TableName", 1
                  DlgValue "ETdefinition", 1
                  DlgValue "ETNote", 1
                  DlgValue "Owner", 1
                  DlgValue "StorageLocation", 1
                  DlgValue "Database", 1

                  ExportHandler = True

              ElseIf DlgItem = "tbldeselect" Then

                  DlgValue "EntityName", 0
                  DlgValue "TableName", 0
                  DlgValue "ETdefinition", 0
                  DlgValue "ETNote", 0
                  DlgValue "Owner", 0
                  DlgValue "StorageLocation", 0
                  DlgValue "Database", 0

                  ExportHandler = True

              ElseIf DlgItem = "attrselect" Then

                  DlgValue "AttributeName", 1
                  DlgValue "ColumnName", 1
                  DlgValue "ACdefinition", 1
                  DlgValue "ACNote", 1
                  DlgValue "Domain", 1
                  DlgValue "Datatype", 1
                  DlgValue "NullOption", 1
                  DlgValue "PKproperty", 1
                  DlgValue "FKProperty", 1
                  DlgValue "columndefault", 1
                  DlgValue "CheckConstraint", 1
                  DlgValue "HasLogicalRoleName", 1
                  DlgValue "HasRoleName", 1

                  ExportHandler = True

              ElseIf DlgItem = "attrdeselect" Then

                  DlgValue "AttributeName", 0
                  DlgValue "ColumnName", 0
                  DlgValue "ACdefinition", 0
                  DlgValue "ACNote", 0
                  DlgValue "Domain", 0
                  DlgValue "Datatype", 0
                  DlgValue "NullOption", 0
                  DlgValue "PKproperty", 0
                  DlgValue "FKProperty", 0
                  DlgValue "columndefault", 0
                  DlgValue "CheckConstraint", 0
                  DlgValue "HasLogicalRoleName", 0
                  DlgValue "HasRoleName", 0

                  ExportHandler = True

              ElseIf DlgItem = "object_sel" Then

                  selected_object_loop = DlgValue("object_sel")
                  Debug.Print "selected_object_loop = " & selected_object_loop

              End If

              Rem ExportHandler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem ExportHandler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Export Metadata to Excel Version 3.bas

      'TITLE:  Export Metadata to Excel Version 3
      'DESCRIPTION: This macro outputs model meta data to Excel in
      'a format which may be appealing for a finished report.
      'NOTES:
      '   Information will be exported for each entity/table that is
      '	selected prior to executing the macro.
      'DATE:  3/4/2002
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/

      'Dim ER/Studio variables
      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj

      'dim excel variables
      Dim wb As Object
      Dim sheet As Object
      Dim excel As Object
      Dim selectedrange As Object

      Sub Main

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          Set excel = CreateObject("excel.application")
          excel.visible = True

          Dim curRow As Integer

          PrintHeader
          curRow = 3

          If submdl.SelectedObjects.Count > 0 Then

          For Each so In submdl.SelectedObjects

              If so.Type = 1 Then

                  Set ent = mdl.Entities.Item(so.ID)

                  For Each attr In ent.Attributes

                      sheet.cells(curRow,1).Value = ent.EntityName

                      If attr.HasLogicalRoleName = True Then
                          sheet.cells(curRow,2).Value = attr.LogicalRoleName
                      Else
                          sheet.cells(curRow,2).Value = attr.AttributeName
                      End If

                      sheet.cells(curRow,3).Value = attr.Definition
                      sheet.cells(curRow,4).Value = attr.ColumnName

                      Dim Datastring As String

                      Datastring = attr.CompositeDatatype
                      Datastring = Replace(Datastring, " NOT", "")
                      Datastring = Replace(Datastring, " NULL", "")

                      If InStr(Datastring, "(") <> 0 Then
                          Datastring = Left(Datastring,InStr(Datastring, "(") - 1)
                      End If

                      sheet.cells(curRow,5).Value = Datastring

                      If attr.DataLength > 0 Then
                          sheet.cells(curRow,6).Value = attr.DataLength
                      End If

                      If attr.DataScale > 0 Then
                          sheet.cells(curRow,7).Value = attr.DataScale
                      End If

                      If NullOption(attr) = "N" Then
                          sheet.cells(curRow,9).Value = "OPTIONAL"
                      Else
                          sheet.cells(curRow,9).Value = "MANDATORY"
                      End If

                      sheet.cells(curRow,10).Value = NullOption(attr)
                      sheet.cells(curRow,11).Value = KeyOption(attr)

                      curRow = curRow + 1

                  Next

              End If

          Next

          End If

      End Sub

      Function KeyOption ( att As AttributeObj ) As String

          Dim keystr As String

          If att.PrimaryKey = True Then

              keystr = "(PK)"

          End If

          If att.ForeignKey = True Then

              keystr = keystr & "(FK)"

          End If

          KeyOption = keystr

      End Function

      Function NullOption ( att As AttributeObj ) As String

          Dim nullstr As String

          If UCase(att.NullOption) = "NULL" Then

              nullstr = "N"

          End If

          If UCase(att.NullOption) = "NOT NULL" Then

              nullstr = "NN"

          End If

          If UCase(att.NullOption) = "NOT NULL" And att.DeclaredDefault <> "" Then

              nullstr = "ND"

          End If

          NullOption = nullstr

      End Function

      Function Datatype ( DT As String ) As String

          Dim test As String

          test = UCase(DT)

          Select Case test

              Case "DATE"
                  Datatype = "D"

              Case "TIMESTAMP/DATE","TIMESTAMP","DATETIME","DATETIMN","SMALLDATETIME","TIME/DATETIME"
                  Datatype = "T"

              Case "VARCHAR","VARCHAR2","NVARCHAR","CHAR","LONG VARCHAR","NTEXT/LONG VARCHAR","NCHAR","MLSLABEL/VARCHAR","ROWID/VARCHAR","BIT","BOOL","BOOLEAN","TEXT","IMAGE/LONG BINARY","IMAGE","BINARY","VARBINARY/BLOB","BLOB","CLOB"
                  Datatype = "C"

              Case "ID","NUMERIC","NUMBER","DECIMAL","MONEY","SMALLMONEY","MONEYN","DECIMALN","PICTURE","FLOAT","SINGLE","REAL/SMALLFLOAT","FLOATN","NUMBER","DOUBLE","DOUBLE PRECISION","INTEGER","INT","INTN","SERIAL/INTEGER","COUNTER","UNIQUEID","SMALLINT","TINYINT"
                  Datatype = "N"

              Case Else
                  datatyp = "C"
          End Select

      End Function

      Sub PrintHeader

          Set wb = excel.workbooks.Add
          Set sheet = wb.activesheet

          sheet.cells(1,1).Value = "=NOW()"
          sheet.cells(1,1).font.colorindex = 3

          With sheet.range("A:L")
                  .wraptext = True
                  .cells.borders.colorindex = 1
                  .font.Name = "ZapfHumnst BT"
          End With

          With sheet.range("A2:L2")
              .interior.colorindex = 15
              .font.Bold = True
              .font.Size = 9
          End With

          With sheet.range("E:G")
              .horizontalalignment = -4108
          End With

          sheet.Columns(10).horizontalalignment = -4108

          sheet.Columns(1).columnwidth = 16.29
          sheet.Columns(2).columnwidth = 17.86
          sheet.Columns(3).columnwidth = 52.14
          sheet.Columns(4).columnwidth = 22.14
          sheet.Columns(5).columnwidth = 14
          sheet.Columns(6).columnwidth = 10.29
          sheet.Columns(7).columnwidth = 10.71
          sheet.Columns(8).columnwidth = 23.43
          sheet.Columns(9).columnwidth = 13
          sheet.Columns(10).columnwidth = 11.71
          sheet.Columns(11).columnwidth = 11.57
          sheet.Columns(12).columnwidth = 23.29

          sheet.cells(2,1).Value = "TABLE BUSINESS NAME"
          sheet.cells(2,2).Value = "COLUMN BUSINESS NAME"
          sheet.cells(2,3).Value = "COLUMN BUSINESS DEFINITION"
          sheet.cells(2,4).Value = "COLUMN TECHNICAL NAME"
          sheet.cells(2,5).Value = "COLUMN DATA TYPE"
          sheet.cells(2,6).Value = "TOTAL COLUMN LENGTH"
          sheet.cells(2,7).Value = "# OF PLACES TO RIGHT OF DECIMAL"
          sheet.cells(2,8).Value = "VALID VALUES"
          sheet.cells(2,9).Value = "MANDATORY/ OPTIONAL         (Is Value Required)"
          sheet.cells(2,10).Value = "N=NULL NN=Not Null ND=Not Null W/Default"
          sheet.cells(2,11).Value = "Primary Key (PK)           Foreign Key (FK)"
          sheet.cells(2,12).Value = "Comments or Source Positions"

          sheet.cells(3,12).Value = ""

          With sheet.range("A2:L2")
              .verticalalignment = -4160
              .horizontalalignment = -4108
          End With

          sheet.Columns(11).horizontalalignment = 1

          For i = 1 To 11

              sheet.cells(1,i).borders(10).colorindex = -4142

          Next

      End Sub


Export Metadata to Excel Version 3.1.BAS

      'TITLE:  Export Metadata to Excel Version 3
      'DESCRIPTION: This macro outputs model meta data to Excel in
      'a format which may be appealing for a finished report.
      'NOTES:
      '   Information will be exported for each entity/table that is
      '	selected prior to executing the macro.
      'DATE:  3/4/2002
      'LAST UPDATE: 10/29/2004
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/

      'Dim ER/Studio variables
      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj

      'dim excel variables
      Dim wb As Object
      Dim sheet As Object
      Dim excel As Object
      Dim selectedrange As Object

      Sub Main

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          Set excel = CreateObject("excel.application")
          excel.visible = True

          Dim curRow As Integer

          PrintHeader
          curRow = 4

          If submdl.SelectedObjects.Count > 0 Then

          For Each so In submdl.SelectedObjects

              If so.Type = 1 Then

                  Set ent = mdl.Entities.Item(so.ID)

                  For Each attr In ent.Attributes

                      sheet.cells(curRow,1).Value = mdl.Name

                      sheet.cells(curRow,2).Value = submdl.Name

                      sheet.cells(curRow,3).Value = ent.EntityName

                      sheet.cells(curRow,4).Value = ent.TableName

                      If attr.HasLogicalRoleName = True Then
                          sheet.cells(curRow,5).Value = attr.LogicalRoleName
                      Else
                          sheet.cells(curRow,5).Value = attr.AttributeName
                      End If

                      sheet.cells(curRow,6).Value = attr.Definition
                      sheet.cells(curRow,7).Value = attr.ColumnName

                      Dim Datastring As String

                      Datastring = attr.CompositeDatatype
                      Datastring = Replace(Datastring, " NOT", "")
                      Datastring = Replace(Datastring, " NULL", "")

                      If InStr(Datastring, "(") <> 0 Then
                          Datastring = Left(Datastring,InStr(Datastring, "(") - 1)
                      End If

                      sheet.cells(curRow,8).Value = Datastring

                      If attr.DataLength > 0 Then
                          sheet.cells(curRow,9).Value = attr.DataLength
                      End If

                      If attr.DataScale > 0 Then
                          sheet.cells(curRow,10).Value = attr.DataScale
                      End If

                      If NullOption(attr) = "N" Then
                          sheet.cells(curRow,12).Value = "OPTIONAL"
                      Else
                          sheet.cells(curRow,12).Value = "MANDATORY"
                      End If

                      sheet.cells(curRow,13).Value = NullOption(attr)
                      sheet.cells(curRow,14).Value = KeyOption(attr)
                      sheet.cells(curRow,15).Value = Identity_value(attr)

                      curRow = curRow + 1

                  Next

              End If

          Next

          End If

      End Sub

      Function Identity_value (att As AttributeObj ) As String

          Dim Ident_val As String

          If att.Identity = True Then

              Ident_val = "YES"

          Else

              Ident_val = "NO"

          End If

          Identity_value = Ident_val

      End Function

      Function KeyOption ( att As AttributeObj ) As String

          Dim keystr As String

          If att.PrimaryKey = True Then

              keystr = "(PK)"

          End If

          If att.ForeignKey = True Then

              keystr = keystr & "(FK)"

          End If

          KeyOption = keystr

      End Function

      Function NullOption ( att As AttributeObj ) As String

          Dim nullstr As String

          If UCase(att.NullOption) = "NULL" Then

              nullstr = "N"

          End If

          If UCase(att.NullOption) = "NOT NULL" Then

              nullstr = "NN"

          End If

          If UCase(att.NullOption) = "NOT NULL" And att.DeclaredDefault <> "" Then

              nullstr = "ND"

          End If

          NullOption = nullstr

      End Function

      Function Datatype ( DT As String ) As String

          Dim test As String

          test = UCase(DT)

          Select Case test

              Case "DATE"
                  Datatype = "D"

              Case "TIMESTAMP/DATE","TIMESTAMP","DATETIME","DATETIMN","SMALLDATETIME","TIME/DATETIME"
                  Datatype = "T"

              Case "VARCHAR","VARCHAR2","NVARCHAR","CHAR","LONG VARCHAR","NTEXT/LONG VARCHAR","NCHAR","MLSLABEL/VARCHAR","ROWID/VARCHAR","BIT","BOOL","BOOLEAN","TEXT","IMAGE/LONG BINARY","IMAGE","BINARY","VARBINARY/BLOB","BLOB","CLOB"
                  Datatype = "C"

              Case "ID","NUMERIC","NUMBER","DECIMAL","MONEY","SMALLMONEY","MONEYN","DECIMALN","PICTURE","FLOAT","SINGLE","REAL/SMALLFLOAT","FLOATN","NUMBER","DOUBLE","DOUBLE PRECISION","INTEGER","INT","INTN","SERIAL/INTEGER","COUNTER","UNIQUEID","SMALLINT","TINYINT"
                  Datatype = "N"

              Case Else
                  datatyp = "C"
          End Select

      End Function

      Sub PrintHeader

          Set wb = excel.workbooks.Add
          Set sheet = wb.activesheet

          sheet.cells(1,1).Value = diag.ProjectName
          sheet.cells(1,2).Value = diag.FileName
          sheet.cells(2,1).Value = "=NOW()"
          sheet.cells(2,1).font.colorindex = 3
          sheet.cells(1,1).font.Size = 12
          sheet.cells(1,2).font.Size = 12
          sheet.cells(1,1).font.Bold = True
          sheet.cells(1,2).font.Bold = True

          With sheet.range("A:P")
                  .WrapText = True
                  .cells.borders.colorindex = 1
                  .font.Name = "ZapfHumnst BT"
          End With

          With sheet.range("A3:P3")
              .interior.colorindex = 15
              .font.Bold = True
              .font.Size = 9
          End With

          With sheet.range("H:J")
              .horizontalalignment = -4108
          End With

          sheet.Columns(10).horizontalalignment = -4108

          sheet.Columns(1).columnwidth = 22.14
          sheet.Columns(2).columnwidth = 22.14
          sheet.Columns(3).columnwidth = 22.14
          sheet.Columns(4).columnwidth = 16.29
          sheet.Columns(5).columnwidth = 17.86
          sheet.Columns(6).columnwidth = 52.14
          sheet.Columns(7).columnwidth = 22.14
          sheet.Columns(8).columnwidth = 14
          sheet.Columns(9).columnwidth = 10.29
          sheet.Columns(10).columnwidth = 10.71
          sheet.Columns(11).columnwidth = 23.43
          sheet.Columns(12).columnwidth = 13
          sheet.Columns(13).columnwidth = 11.71
          sheet.Columns(14).columnwidth = 11.57
          sheet.Columns(15).columnwidth = 11.57
          sheet.Columns(16).columnwidth = 23.29

          sheet.cells(3,1).Value = "MODEL NAME"
          sheet.cells(3,2).Value = "SUBMODEL NAME"
          sheet.cells(3,3).Value = "TABLE BUSINESS NAME"
          sheet.cells(3,4).Value = "TABLE TECHNICAL NAME"
          sheet.cells(3,5).Value = "COLUMN BUSINESS NAME"
          sheet.cells(3,6).Value = "COLUMN BUSINESS DEFINITION"
          sheet.cells(3,7).Value = "COLUMN TECHNICAL NAME"
          sheet.cells(3,8).Value = "COLUMN DATA TYPE"
          sheet.cells(3,9).Value = "TOTAL COLUMN LENGTH"
          sheet.cells(3,10).Value = "# OF PLACES TO RIGHT OF DECIMAL"
          sheet.cells(3,11).Value = "VALID VALUES"
          sheet.cells(3,12).Value = "MANDATORY/ OPTIONAL         (Is Value Required)"
          sheet.cells(3,13).Value = "N=NULL NN=Not Null ND=Not Null W/Default"
          sheet.cells(3,14).Value = "Primary Key (PK)           Foreign Key (FK)"
          sheet.cells(3,15).Value = "COLUMN IS AUTO-INCREMENTED (Identity)"
          sheet.cells(3,16).Value = "Comments or Source Positions"

          sheet.cells(4,17).Value = ""

          With sheet.range("A3:P3")
              .verticalalignment = -4160
              .horizontalalignment = -4108
          End With

          sheet.Columns(15).horizontalalignment = 1

          For i = 1 To 11

              sheet.cells(1,i).borders(10).colorindex = -4142
              sheet.cells(2,i).borders(10).colorindex = -4142

          Next

      End Sub


Export Model Metadata to Excel.bas

      'MACRO TITLE: EXPORT MODEL METADATA TO EXCEL
      'This macro generates a report for the active model in ER/Studio.
      ' REQUIREMENT: You must have MS Excel 97 installed

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim ent As Entity
      Dim attr As AttributeObj

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main
          ' Start Excel and make it visible.

          Set Excel = CreateObject("Excel.Application")
          Excel.Visible = True
          Excel.Workbooks.Add

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          curRow = 1
          curCol = 1

          ' Prompt the user.

          Begin Dialog UserDialog 150,140,"Report Type" ' %GRID:10,7,1,1
              OptionGroup .Group1
                  OptionButton 20,7,130,21,"Simple",.OptionButton1
                  OptionButton 20,35,130,21,"Colorful",.OptionButton2
              OKButton 20,98,90,28
          End Dialog
          Dim dlg As UserDialog
          Dialog dlg

          If dlg.Group1 = 0 Then
              clrBack = CLR_WHITE
              clrFore = CLR_BLACK
              clrTitleBack = CLR_GREY
              clrTitleFore = CLR_BLACK
          Else
              clrBack = CLR_TEAL
              clrFore = CLR_BLACK
              clrTitleBack = CLR_BLACK
              clrTitleFore = CLR_WHITE
          End If

          ' Print the spread sheet.

          InitColumnWidth
          PrintReportHeader mdl.Name
          PrintColumnHeader ColOrder
          PrintData

          Excel.Visible = True
      End Sub

      Sub PrintData
          Dim bHideFont As Boolean
          bHideFont = False

          For Each ent In mdl.Entities
              For Each attr In ent.Attributes
                  If bHideFont = True Then
                      PrintCell ent.TableName, "", curRow, curCol, 0, 1, clrBack, clrBack, 10, True
                  Else
                      PrintCell ent.TableName, ent.Definition, curRow, curCol, 0, 1, clrFore, clrBack, 10, True
                  End If

                  bHideFont = True

                  PrintCell attr.ColumnName, attr.Definition, curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  If (attr.DataLength <> "-1") Then
                      PrintCell attr.Datatype & " (" & attr.DataLength & ")", "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  Else
                      PrintCell attr.Datatype, "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If
                  PrintCell attr.NullOption, "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                  If (attr.PrimaryKey = "True") Then
                      PrintCell "Yes", "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  Else
                      PrintCell "No", "", curRow, curCol, 0, 1, clrFore, clrBack, 10, False
                  End If

                  If (attr.ForeignKey = "True") Then
                      PrintCell "Yes", "", curRow, curCol, 1, -5, clrFore, clrBack, 10, False
                  Else
                      PrintCell "No", "", curRow, curCol, 1, -5, clrFore, clrBack, 10, False
                  End If
              Next

              curCol = 1
              bHideFont = False
          Next

          With Excel
              .Range(.Cells(4, 1), .Cells(curRow, 6)).Sort .Cells(4, 1)
              If clrBack <> CLR_WHITE Then
                  .Range(.Cells(4, 1), .Cells(curRow, 6)).Interior.color = clrBack
              End If
          End With

      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth
          Excel.Cells(1, 1).ColumnWidth = 25
          Excel.Cells(1, 2).ColumnWidth = 25
          Excel.Cells(1, 3).ColumnWidth = 20
          Excel.Cells(1, 4).ColumnWidth = 25
          Excel.Cells(1, 5).ColumnWidth = 15
          Excel.Cells(1, 6).ColumnWidth = 15
      End Sub

      ' Print the report header.

      Sub PrintReportHeader(ModelName As String)
          With Excel.Cells(curRow, curCol)
              .Value = ModelName & " Model Table and Column Report"
              .Font.Italic = True
              .Font.Bold = True
              .Font.Size = 18
          End With

          curRow = curRow + 2

          With Excel
              .Range(.Cells(1, 1), .Cells(curRow, 6)).Font.Color = clrTitleFore
              .Range(.Cells(1, 1), .Cells(curRow, 6)).Interior.Color = clrTitleBack
          End With
      End Sub

      ' Print the column header.

      Sub PrintColumnHeader(ColOrder As Variant)
          PrintCell "Table Name", "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          PrintCell "Column Name", "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          PrintCell "Column Datatype", "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          PrintCell "Column Null Option", "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          PrintCell "Primary Key", "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True
          PrintCell "Foreign Key", "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True

          curRow = curRow + 1
          curCol = 1
      End Sub

      ' Print a cell

      Sub PrintCell(value As String, note As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          If (note <> "") Then
              Excel.Cells(row, col).NoteText note
          End If

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub


Export Model Metadata to Word.bas

      'MACRO TITLE: EXPORT MODEL METADATA TO WORD
      'This macro generates a mini report for the selected entities in the active model.
      ' REQUIREMENT: You must have Word 97 installed.

      Sub Main
          ' Dim MS Word variables zzz.

          Dim Word As Object
          Dim Docs As Object
          Dim WordBasic As Object
          Dim ActiveDoc As Object

          ' Dim ER/Studio variables.

          Dim diag As Diagram
          Dim mdl As Model
          Dim sm As SubModel
          Dim so As SelectedObject
          Dim id As Integer
          Dim ent As Entity
          Dim attr As AttributeObj

          ' Start MS Word and make it visible.

          Set Word = CreateObject("Word.Application")
          Word.Visible = True
          Word.Options.CheckGrammarAsYouType = False
          Word.Options.CheckSpellingAsYouType = False
          Word.Documents.Add
          Set ActiveDoc = Word.Documents(1)
          ActiveDoc.Activate

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set sm = mdl.ActiveSubModel

          ' You need the submodel when determining what's selected.
          ' Iterate through all selected objects and process only entities.

          For Each so In sm.SelectedObjects
              If so.Type = 1 Then		' Entities are Type 1 objects.

                  ' Get the entity.

                  id = so.ID
                  Set ent = mdl.Entities.Item(id)

                  Word.Selection.TypeText Text:=ent.EntityName & vbCrLf

                  For Each attr In ent.Attributes
                      Word.Selection.TypeText Text:=vbTab & attr.ColumnName & " [" & attr.Datatype & "]" & vbCrLf
                  Next

                  Word.Selection.TypeText Text:= vbCrLf
              End If
          Next
      End Sub


Export Object Definitions and Notes to Excel.bas

      'TITLE:  EXPORT OBJECT DEFINITIONS AND NOTES FROM EXCEL.BAS
      'DESCRIPTION:  This macro will export definitions and notes for
      '	tables, views, relationships and attributes to Excel.  The notes
      '	and definitions of each object are exported to different sheets
      '	in the workbook.  The sheets are labeled "Entities", "Attibutes",
      '	"Views", and "Relationships".  The labels must remain the same if
      '	the definitions and notes are going to be imported back into the
      '	model.  The order of the sheets is irrelevant, but the format of
      '	each sheet must remain the same if importing is desired.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'DATE: 	7/11/01
      'LAST UPDATE:  10/8/2004

      'global ER variables
      Dim diag As Diagram
      Dim ent As Entity
      Dim rel As Relationship
      Dim vi As View
      Dim attr As AttributeObj
      Dim mdl As Model

      Dim modeldd() As String

      'global count variables
      Dim EntCount As Integer
      Dim RelCount As Integer
      Dim ViewCount As Integer
      Dim AttrCount As Integer

      Dim overwrite As Boolean

      Sub Main
          Dim excel As Object
          Dim sheet As Object
          Dim workbook As Object

          ' Init the ER/Studio variables.

          DiagramManager.EnableScreenUpdate(False)

          Set diag = DiagramManager.ActiveDiagram

          'fill array for model drop down in the dialog
          modCount = diag.Models.Count

          ReDim modeldd (0 To modCount - 1)
          i = 0

          For Each mdl In diag.Models

              modeldd(i) = mdl.Name
              i = i + 1

          Next

          'initialize excel object
              Set excel = CreateObject("excel.application")

          Begin Dialog UserDialog 540,350,"Export Definitions to Excel",.dialogfunc ' %GRID:10,7,1,1
              GroupBox 40,14,460,259,"Export Options",.GroupBox1
              DropListBox 180,154,170,70,modeldd(),.model
              CheckBox 80,217,150,14,"Table Definitions",.tables
              CheckBox 80,245,150,14,"Attribute Definitions",.Attributes
              CheckBox 240,217,180,14,"Relationship Definitions",.Relationships
              CheckBox 240,245,130,14,"View Definitions",.Views
              OKButton 290,308,90,21
              CancelButton 400,308,90,21
              Text 70,161,100,14,"Choose Model:",.Text1
              Text 70,189,140,14,"Select Object Types",.Text2
              OptionGroup .WBchoice
                  OptionButton 60,35,140,14,"New Workbook",.newWB
                  OptionButton 60,56,150,14,"Existing Workbook",.existingWB
              Text 80,84,40,14,"Path:",.Text3
              TextBox 130,77,270,21,.WBpath
              PushButton 410,77,70,21,"Browse",.BrowseButton
              OptionGroup .OverwriteChoice
                  OptionButton 140,112,140,14,"Overwrite Entries",.overwrite
                  OptionButton 300,112,130,14,"Append Entries",.append
          End Dialog
          Dim dlg As UserDialog

          start_dialog:
          'Start dialog
          If Dialog(dlg) = -1 Then

              'get model specified in options
              Set mdl = diag.Models.Item(modeldd(dlg.model))

              If dlg.WBchoice = 0 Then

                  'add workbook
                  Set workbook = excel.workbooks.Add

                  'initialize Excel workbook with the proper sheets
                  initWorkBook workbook

              '	DiagramManager.ShowWindow

                  'print tables sheet if checked in dialog
                  If dlg.tables = 1 Then

                      'get entities sheet
                      Set sheet = workbook.worksheets("Entities")
                      PrintEntityDefs sheet

                  End If

                  'print attributes sheet if checked in dialog
                  If dlg.Attributes = 1 Then

                      'get attributes sheet
                      Set sheet = workbook.worksheets("Attributes")
                      PrintAttributeDefs sheet

                  End If

                  'print relationships sheet if checked in dialog
                  If dlg.Relationships = 1 Then

                      'get relationships sheet
                      Set sheet = workbook.worksheets("Relationships")
                      PrintRelationshipDefs sheet

                  End If

                  'print views sheet if checked in dialog
                  If dlg.Views = 1 Then

                      'get views sheet from workbook
                      Set sheet = workbook.worksheets("Views")
                      PrintViewDefs sheet

                  End If

                  MsgBox("Export Complete!", , "ER/Studio")

              Else

                  On Error GoTo Error_handle

                  excel.workbooks.open dlg.WBpath

              '	DiagramManager.ShowWindow

                  If dlg.OverwriteChoice = 0 Then
                      overwrite = True
                  Else
                      overwrite = False
                  End If

                  If dlg.tables = 1 Then

                      UpdateEntitySheet excel

                  End If

                  If dlg.Attributes = 1 Then

                      UpdateAttributeSheet excel

                  End If

                  If dlg.Views = 1 Then

                      UpdateViewSheet excel

                  End If

                  If dlg.Relationships = 1 Then

                      UpdateRelationshipSheet excel

                  End If

                  MsgBox("Update Complete!", , "ER/Studio")

              End If

          End If

          excel.visible = True

          DiagramManager.EnableScreenUpdate(True)

          Exit Sub

          Error_handle:

              MsgBox("Please Enter a valid path.",vbOkOnly, "Error!")
              GoTo start_dialog

      End Sub

      'Fills the entity array with definitions and notes from the spreadsheet
      Function UpdateEntitySheet (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer
          Dim unfound As Boolean
          Dim E_Name As String
          Dim ws_indx As Integer

          On Error GoTo Message

          Set sheet = ex.worksheets("Entities")
          Set range = sheet.usedrange
          unfound = True
          i = 2

          EntCount = range.rows.Count

          If EntCount < 2 Then
              ws_indx = 2
          Else
              ws_indx = EntCount
          End If

          Debug.Print "EntCount= " & EntCount

          For Each ent In mdl.Entities

              If mdl.Logical = True Then
                  E_Name = ent.EntityName
              Else
                  E_Name = ent.TableName
              End If

              For i = 2 To ws_indx

                  If UCase(E_Name) = UCase(range.cells(i, 1).Value) Then

                      unfound = False

                      If overwrite = True And ent.Definition <> "" Then

                          range.cells(i, 2).Value = ent.Definition

                      ElseIf overwrite = False And ent.Definition <> range.cells(i, 2).Value Then

                          range.cells(i, 2).Value = range.cells(i, 2).Value & " "  & ent.Definition

                      End If

                      If overwrite = True And ent.Note <> "" Then

                          range.cells(i, 3).Value = ent.Note

                      ElseIf overwrite = False And ent.Note <> range.cells(i, 3).Value Then

                          range.cells(i, 3).Value = range.cells(i, 3).Value & " " & ent.Note

                      End If

                      If unfound = False Then
                          Exit For
                      End If

                  End If

              Next

              If unfound = True Then

                  EntCount = EntCount + 1
                  range.cells(EntCount, 1) = E_Name
                  range.cells(EntCount, 2) = ent.Definition
                  range.cells(EntCount, 3) = ent.Note

              End If

              unfound = True

          Next

          Exit Function

          Message:
              MsgBox("There is no ""Entities"" sheet in the workbook or the name is invalid.  Entity Definitions will be ignored.")
              Exit Function

      End Function

      'Fills the attribute def array with the attribute definitions from the excel spread sheet
      Function UpdateAttributeSheet (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer
          Dim unfound As Boolean
          Dim E_Name As String
          Dim A_Name As String
          Dim ws_indx As Integer

          On Error GoTo AttMessage

          Set sheet = ex.worksheets("Attributes")
          Set range = sheet.usedrange
          unfound = True
          i = 2

          AttrCount = range.rows.Count

          If AttrCount < 2 Then
              ws_indx = 2
          Else
              ws_indx = AttrCount
          End If

          Debug.Print "AttrCount= " & AttrCount

          For Each ent In mdl.Entities

              If mdl.Logical = True Then
                  E_Name = ent.EntityName
              Else
                  E_Name = ent.TableName
              End If

              For Each attr In ent.Attributes

                  If mdl.Logical = True Then
                      A_Name = attr.AttributeName
                  Else
                      A_Name = attr.ColumnName
                  End If

                  For i = 2 To ws_indx

                      If UCase(A_Name) = UCase(range.cells(i, 1).Value) And UCase(E_Name) = UCase(range.cells(i, 3).Value) Then

                          unfound = False

                          If overwrite = True And attr.Definition <> "" Then

                              range.cells(i, 2).Value = attr.Definition

                          ElseIf overwrite = False And attr.Definition <> range.cells(i, 2).Value Then

                              range.cells(i, 2).Value = range.cells(i, 2).Value & " "  & attr.Definition

                          End If

                          If unfound = False Then
                              Exit For
                          End If

                      End If

                  Next

                  If unfound = True Then

                      AttrCount = AttrCount + 1
                      range.cells(AttrCount, 1) = A_Name
                      range.cells(AttrCount, 2) = attr.Definition
                      range.cells(AttrCount, 3) = E_Name

                  End If

                  unfound = True

              Next

              Next

          Exit Function

          AttMessage:
              MsgBox("There is no ""Attributes"" sheet in the workbook or the name is invalid.  Attribute Definitions will be ignored.")
              Exit Function

      End Function

      'fills the relationship def array with the notes and definitions from the excel spread sheet
      Function UpdateRelationshipSheet (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer
          Dim unfound As Boolean
          Dim ws_indx As Integer

          On Error GoTo RelMessage

          Set sheet = ex.worksheets("Relationships")
          Set range = sheet.usedrange
          unfound = True
          i = 2

          RelCount = range.rows.Count

          If RelCount < 2 Then
              ws_indx = 2
          Else
              ws_indx = RelCount
          End If

          Debug.Print "RelCount= " & RelCount

          For Each rel In mdl.Relationships

              If rel.Name <> "" Then

                  For i = 2 To ws_indx

                      If UCase(rel.Name) = UCase(range.cells(i, 1).Value) Then

                          unfound = False

                          If overwrite = True And rel.Definition <> "" Then

                              range.cells(i, 2).Value = rel.Definition

                          ElseIf overwrite = False And rel.Definition <> range.cells(i, 2).Value Then

                              range.cells(i, 2).Value = range.cells(i, 2).Value & " "  & rel.Definition

                          End If

                          If overwrite = True And rel.Note <> "" Then

                              range.cells(i, 3).Value = rel.Note

                          ElseIf overwrite = False And rel.Note <> range.cells(i, 3).Value Then

                              range.cells(i, 3).Value = range.cells(i, 3).Value & " " & rel.Note

                          End If

                          If unfound = False Then
                              Exit For
                          End If

                      End If

                  Next

                  If unfound = True Then

                      RelCount = RelCount + 1
                      range.cells(RelCount, 1) = rel.Name
                      range.cells(RelCount, 2) = rel.Definition
                      range.cells(RelCount, 3) = rel.Note

                  End If

              End If

              unfound = True

          Next

          Exit Function

          RelMessage:
              MsgBox("There is no ""Relationships"" sheet in the workbook or the name is invalid.  Relationship Definitions will be ignored.")
              Exit Function

      End Function

      'fills the view def array with the notes and definitions from the excel spread sheet.
      Function UpdateViewSheet (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer
          Dim unfound As Boolean
          Dim V_Name As String
          Dim ws_indx As Integer

          On Error GoTo ViewMessage

          Set sheet = ex.worksheets("Views")
          Set range = sheet.usedrange
          unfound = True
          i = 2

          ViewCount = range.rows.Count

          If ViewCount < 2 Then
              ws_indx = 2
          Else
              ws_indx = ViewCount
          End If

          Debug.Print "ViewCount= " & ViewCount

          For Each vi In mdl.Views

              For i = 2 To ws_indx

                  If UCase(vi.Name) = UCase(range.cells(i, 1).Value) Then

                      unfound = False

                      If overwrite = True And vi.Definition <> "" Then

                          range.cells(i, 2).Value = vi.Definition

                      ElseIf overwrite = False And vi.Definition <> range.cells(i, 2).Value Then

                          range.cells(i, 2).Value = range.cells(i, 2).Value & " "  & vi.Definition

                      End If

                      If overwrite = True And vi.Notes <> "" Then

                          range.cells(i, 3).Value = vi.Notes

                      ElseIf overwrite = False And vi.Notes <> range.cells(i, 3).Value Then

                          range.cells(i, 3).Value = range.cells(i, 3).Value & " " & vi.Notes

                      End If

                      If unfound = False Then
                          Exit For
                      End If

                  End If

              Next

              If unfound = True Then

                  ViewCount = ViewCount + 1
                  range.cells(ViewCount, 1) = vi.Name
                  range.cells(ViewCount, 2) = vi.Definition
                  range.cells(ViewCount, 3) = vi.Notes

              End If

              unfound = True

          Next

          Exit Function

          ViewMessage:
              MsgBox("There is no ""Views"" sheet in the workbook or the name is invalid.  View Definitions will be ignored.")
              Exit Function

      End Function

      'This procedure prints the entity notes and definitions to the "Entities" Sheet
      Sub PrintEntityDefs ( sh As Variant )

          Dim i As Integer

          EntCount = mdl.Entities.Count
          i = 2

          For Each ent In mdl.Entities

                  If mdl.Logical = True Then
                      sh.cells(i, 1).Value = ent.EntityName
                  Else
                      sh.cells(i, 1).Value = ent.TableName
                  End If

                  sh.cells(i, 2).Value = ent.Definition
                  sh.cells(i, 3).Value = ent.Note

                  i = i + 1

          Next

      End Sub

      'This procedure prints the attribute definitions to the "Attributes" sheet
      Sub PrintAttributeDefs ( sh As Variant )

          Dim i As Integer

          i = 2

          For Each ent In mdl.Entities

              For Each attr In ent.Attributes

                      If mdl.Logical = True Then
                          sh.cells(i, 1).Value = attr.AttributeName
                          sh.cells(i, 3).Value = ent.EntityName
                      Else
                          sh.cells(i, 1).Value = attr.ColumnName
                          sh.cells(i, 3).Value = ent.TableName
                      End If

                      sh.cells(i, 2).Value = attr.Definition

                      i = i + 1

              Next

          Next

      End Sub

      'this procedure prints the relationship definitions and notes to the "Relationships" sheet
      Sub PrintRelationshipDefs ( sh As Variant )

          Dim i As Integer

          i = 2

          For Each rel In mdl.Relationships

                  sh.cells(i, 1).Value = rel.Name
                  sh.cells(i, 2).Value = rel.Definition
                  sh.cells(i, 3).Value = rel.Note

                  i = i + 1

          Next

      End Sub

      'This procedure prints the view definitions and notes to the "Views" sheet
      Sub PrintViewDefs ( sh As Variant )

          Dim i As Integer

          i = 2

          For Each vi In mdl.Views

                  sh.cells(i, 1).Value = vi.Name
                  sh.cells(i, 2).Value = vi.Definition
                  sh.cells(i, 3).Value = vi.Notes

                  i = i + 1

          Next
      End Sub

      'This procedure will initialize the workbook with the column headers and the object sheets
      Sub initWorkBook ( wb As Variant )

          Dim ws As Object

          Set ws = wb.worksheets.Add

          With ws
              .Name End With

          Set ws = wb.worksheets.Add

          With ws
              .Name End With

          Set ws = wb.worksheets.Add

          With ws
              .Name End With

          Set ws = wb.worksheets.Add

          With ws
              .Name End With

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function dialogfunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "BrowseButton" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "WBpath", GetFilePath(,"xls",,"Open SpreadSheet")
                  dialogfunc = True
              ElseIf DlgItem = "OK" And DlgText("WBpath") = "" And DlgValue("WBchoice") = 1 Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  dialogfunc = True
              End If

              Rem dialogfunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem dialogfunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Export Reference Value Info to Excel.bas

      'MACRO TITLE: EXPORT REFERENCE VALUE INFO TO EXCEL (Enterprise).BAS
      'This macro exports the reference values and their properties to excel.
      'Each record in the Excel spread sheet represents one ref val from the
      'data dictionary.  The spread sheet can be used to store reference values
      'outside of ER/Studio.  The properties can be updated in the
      'spread sheet and imported back into an existing model or a new model
      'using the "Import Reference Values From Excel" macro.  The columns in the
      'spread sheet must remain in the same order to import them properly.
      '	REQUIREMENT: You must have MS Excel 97 or later installed
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST UPDATE:  5/8/2003

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim dict As Dictionary
      Dim refval As ReferenceValue
      Dim Value As ValuePair
      Dim dictionary_list () As String

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          'Set dict = diag.Dictionary

          curRow = 1
          curCol = 1

          Debug.Clear

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          Begin Dialog UserDialog 510,133,"Reference Value Export" ' %GRID:10,7,1,1
              Text 20,21,130,14,"Select Dictionary:",.Text1
              DropListBox 150,21,330,112,dictionary_list(),.dictionary_select
              CancelButton 380,84,90,28
              OKButton 270,84,100,28
          End Dialog
          Dim dlg As UserDialog

          init_dictionary_list

          If Dialog(dlg) = -1 Then

              'choose the proper dictionary
              If dictionary_list(dlg.dictionary_select) = "Local" Then

                  Set dict = diag.Dictionary

              Else

                  Set dict = diag.EnterpriseDataDictionaries.Item(dictionary_list(dlg.dictionary_select))

              End If

              ' Create Excel workbook.

              Set Excel = CreateObject("Excel.Application")
              Excel.Workbooks.Add

              'Excel.Visible = True

              InitColumnWidth
              PrintColumnHeader
              PrintData

              MsgBox("Export   Complete!",,"ER/Studio")

              ' make Excel spread sheet visible
              Excel.Visible = True

          End If

      End Sub

      'initialize the dictionary drop down list
      Sub init_dictionary_list

          ReDim dictionary_list (0 To diag.EnterpriseDataDictionaries.Count) As String

          dictionary_list (0) = "Local"
          i = 1

          For Each dict In diag.EnterpriseDataDictionaries

              dictionary_list (i) = dict.Name
              i = i + 1

          Next

      End Sub

      Sub PrintData

          Dim bHideFont As Boolean
          bHideFont = False

          'loop through the domains and export the properties of the domains
          For Each refval In dict.ReferenceValues

              If refval.IsRange = True Then

                  PrintCell refval.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                  PrintCell refval.Description, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                  PrintCell "Range",curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                  PrintCell refval.IsNotBetween, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                  PrintCell refval.MinValue, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                  PrintCell refval.MaxValue, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                  curRow = curRow + 1
                  curCol = 1

              Else

                  For Each Value In refval.Values

                      PrintCell refval.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      PrintCell refval.Description, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      PrintCell "List",curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      PrintCell refval.IsNotBetween, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      PrintCell Value.Value, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      PrintCell "", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      PrintCell Value.ValueDescription, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

                      curRow = curRow + 1
                      curCol = 1

                  Next

              End If

          Next

      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth

      Dim count As Integer

      count = 13

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 30
      Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader

              PrintCell "Reference Value Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Reference Value Description", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Reference Value Type", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Value NOT Between", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "RV Value", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "RV End Value", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "RV Value Description", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              curRow = curRow + 1
              curCol = 1

      End Sub

      ' Print a cell

      Sub PrintCell(Value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = Value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub


Export Relationship Info to Excel.bas

      'MACRO TITLE: EXPORT RELATIONSHIP INFO TO EXCEL.BAS
      'This macro generates a foreign key column report for the active
      'model in ER/Studio.  Each foreign key column will have an entry
      'in the spread sheet.  The spread sheet can be used to apply naming
      'standards to Relationships/foreign constraints.  The new relationship
      'name can be entered into the "New Relationship Name column" and
      'imported back into ER/Studio with the "Import Relationship Names"
      'macro.
      ' REQUIREMENT: You must have MS Excel 97 or later installed
      ' AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      ' LAST UPDATE:  5/6/2003

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      ' Dim MS Excel variables.

      Dim Excel As Object

      ' Dim ER/Studio variables.

      Dim diag As Diagram
      Dim mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity
      Dim attr As AttributeObj
      Dim rel As Relationship
      Dim reldisp As RelationshipDisplay
      Dim fkcol As FKColumnPair
      Dim fkcount As Integer														'dup check
      Dim FKduplicates() As String												'dup check

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Sub Main

          ' Init the ER/Studio variables.

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          curRow = 1
          curCol = 1

          Debug.Clear

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          ' Create Excel workbook.

          Set Excel = CreateObject("Excel.Application")
          Excel.Workbooks.Add

          InitColumnWidth
          PrintColumnHeader
          PrintData

          MsgBox("Export Complete!",,"ER/Studio")

          'make Excel visible
          Excel.Visible = True

      End Sub

      Sub PrintData

          Dim bHideFont As Boolean
          bHideFont = False

          Dim sequence  As Integer
          Dim j As Integer															'dup check

              j = 0																	'dup check
              fkcount = 0																'dup check
              sequence = 1

              'loop through the relationship display objects of the current submodel
              For Each reldisp In submdl.RelationshipDisplays

                  'get the relationship object from the display object
                  Set rel = reldisp.ParentRelationship

                  'provide a default name for the relationship if the relationship is unnamed
                  If rel.Name = "" Then

                      rel.Name = "REL_" & sequence
                      sequence = sequence + 1

                  End If

                  fkcount = fkcount + rel.FKColumnPairs.Count			 							'dup check
                  ReDim Preserve FKduplicates(0 To fkcount) As String 							'dup check
                  Debug.Print "Relationship:  " & rel.Name										'dup check
                  Debug.Print "FKs: " & fkcount 													'dup check
                  Debug.Print "size of FK Array: " & UBound(FKduplicates)							'dup check

                  'loop through the columns of the child entity table
                  For i = 1 To rel.ChildEntity.Attributes.Count

                      'loop through the FK columns of each relationship
                      For Each fkcol In rel.FKColumnPairs

                          'match the FK column's sequence number with the attribute sequence number
                          If fkcol.SequenceNo = i Then

                              If checkFKduplicates(rel.Name & fkcol.ChildAttribute.ColumnName) = 0 Then					'dup check

                                  'output Relationship information to Excel
                                  PrintCell rel.Name, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                  PrintCell rel.ParentEntity.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                  PrintCell rel.ChildEntity.TableName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                  PrintCell fkcol.ChildAttribute.ColumnName, curRow, curCol, 0, 1, clrFore, clrBack, 10, False

                                  curRow = curRow + 1
                                  curCol = 1
                                  bHideFont = False

                                  FKduplicates(j) = rel.Name & fkcol.ChildAttribute.ColumnName							'dup check
                                  j = j + 1																				'dup check

                              End If																						'dup check

                          End If

                      Next

                  Next

              Next

      End Sub

      ' Function to check for duplicate FK columns
      ' returns 1 if duplicate is found, 0 if duplicate is not found
      Function checkFKduplicates (input_str As String) As Integer					'dup check

          Dim i As Integer														'dup check

          For i = 0 To fkcount													'dup check

              If FKduplicates(i) = input_str Then									'dup check

                  checkFKduplicates = 1											'dup check
                  Exit Function													'dup check

              End If																'dup check

          Next																	'dup check

          checkFKduplicate = 0													'dup check

      End Function																'dup check

      ' Initialize the column width.

      Sub InitColumnWidth

      Dim count As Integer

      count = 5

      'initialize column widths
      For j = 1 To count
          Excel.Cells(1, j).ColumnWidth = 20
      Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader

              PrintCell "Parent Relationship FK Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Parent Table Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Child Table Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "Parent Migrated Column Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              PrintCell "New Parent Relationship FK Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, True

              curRow = curRow + 1
              curCol = 1

      End Sub

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub


Generate Partitions For OS390 Clustered Indexes.bas

      'TITLE:  GENERATE PARTITIONS FOR OS390 CLUSTERED INDEXES.BAS
      'DESCRIPTION:  This macro provides and interface to add multiple
      '	partitions to clustered indexes.  A list of tables is provided.
      '	Selecting a table will load the clustered indexes to be partitioned.
      '	The storage parameters are uniform across partitions.

      'dim ER/Studio variables
      Dim diag As Diagram
      Dim mdl As Model
      Dim ent As Entity
      Dim indx As Index
      Dim indxpart As DB2IdxPartition
      Dim indxcol As IndexColumn
      Dim sto As DB2StoGroup

      'dim array variables
      Dim tables () As String
      Dim clusteredindexes () As String
      Dim indexedcolumns () As String
      Dim stogroups () As String
      Dim blank() As String
      Dim tableindx As Integer
      Dim indexindx As Integer
      Dim indexselected As Boolean

      'partition variables
      Dim NumberInc As Integer
      Dim NumberStart As Integer
      Dim NumberEnd As Integer
      Dim location As String
      Dim locationopt As Integer
      Dim gbpcacheopt As Integer
      Dim priqty_val As Integer
      Dim secqty_val As Integer
      Dim freepage_val As Integer
      Dim pctfree_val As Integer
      Dim gbpcache_val As Integer

      Function GetTables

          ReDim tables ( 0 To mdl.Entities.Count - 1) As String

          i = 0

          For Each ent In mdl.Entities

              tables(i) = ent.TableName
              i = i + 1

          Next

          dhQuickSort(tables())

      End Function

      Function GetClusteredIndexes ( tblname As String )

          Set ent = mdl.Entities.Item(tblname)

          Dim indxcount As Integer

          For Each indx In ent.Indexes

              If indx.Clustered = True Then

                  count = count + 1

              End If

          Next

          If count > 0 Then

              ReDim clusteredindexes (0 To count - 1) As String
              i = 0

              For Each indx In ent.Indexes

                  If indx.Clustered = True Then

                      clusteredindexes(i) = indx.Name
                      i = i + 1

                  End If

              Next

          Else

              ReDim clusteredindexes(0)
              clusteredindexes(0) = "NO CLUSTERED INDEXES"

          End If

      End Function

      Function GetIndexedColumns ( tblname As String, indxname As String )

          Set ent = mdl.Entities.Item(tblname)
          Set indx = ent.Indexes.Item(indxname)

          If indxname <> "NO CLUSTERED INDEXES" Then

              ReDim indexedcolumns(0 To indx.IndexColumns.Count - 1)

              j = 0

              For i = 1 To indx.IndexColumns.Count

                  For Each indxcol In indx.IndexColumns

                      If indxcol.SequenceNo = i Then

                          indexedcolumns(j) = indxcol.ColumnName
                          j = j + 1

                      End If

                  Next

              Next

          End If

      End Function

      Function getstogroups

          If mdl.DB2StoGroups.Count > 0 Then

              ReDim stogroups (0 To mdl.DB2StoGroups.Count - 1)

              For Each sto In mdl.DB2StoGroups

                  stogroups(i) = sto.Name

              Next

          End If

      End Function

      Function generatepartition ( tblname As String, indxname As String )

          Set ent = mdl.Entities.Item(tblname)
          Set indx = ent.Indexes.Item(indxname)

          For i = 1 To 254

              indx.DB2IdxPartitions.Remove(i)

          Next

          For i = NumberStart To NumberEnd Step NumberInc

              Set indxpart = indx.DB2IdxPartitions.Add(i,CStr(i))

              indxpart.FreePage = freepage_val
              indxpart.PctFree = pctfree_val
              indxpart.PriQty = priqty_val
              indxpart.SecQty = secqty_val

              If locationopt = 0 Then
                  indxpart.IsStoGroup = False
                  indxpart.StorageLocation = location
              Else
                  indxpart.IsStoGroup = True
                  indxpart.StorageLocation = location
              End If

              Debug.Print gbpcache_val

              Select Case gbpcache_val

                  Case 0

                      indxpart.GBPCache = "CHANGE"

                  Case 1

                      indxpart.GBPCache = "ALL"

                  Case 2

                      indxpart.GBPCache = "NONE"

              End Select

          Next

      End Function

      Sub Main

          Dim dbplat As String

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          Debug.Print mdl.DatabasePlatform

          Debug.Print dbplat

          If mdl.MajorPlatform = "IBM DB2" Then

          GetTables
          GetClusteredIndexes(tables(0))
          GetIndexedColumns(tables(0),clusteredindexes(0))
          getstogroups

          ReDim blank (0) As String

          blank(0) = ""

          Begin Dialog UserDialog 820,371,"Partition Options",.partitionHandler ' %GRID:10,7,1,1
              ListBox 40,28,200,112,tables(),.tablelist
              Text 20,7,60,14,"Tables:",.Text1
              DropListBox 310,28,250,91,clusteredindexes(),.indexlist
              ListBox 310,77,250,70,indexedcolumns(),.columnlist
              Text 300,7,160,14,"Clustered Indexes:",.Text2
              Text 300,56,140,14,"Indexed Columns:",.Text3
              PushButton 520,329,100,28,"Apply",.apply
              PushButton 650,329,100,28,"Close",.CloseDialog
              GroupBox 270,154,530,154,"Storage Options",.GroupBox1
              GroupBox 20,154,220,154,"Partition Options",.GroupBox2
              OptionGroup .locationoption
                  OptionButton 290,189,90,14,"VCAT",.Vcat
                  OptionButton 290,217,130,14,"STOGROUP",.StoGroup
              DropListBox 420,217,120,70,stogroups(),.Stogrouplist,1
              TextBox 420,182,120,21,.Vcattxt
              Text 340,252,60,14,"PRIQTY",.textbox1
              Text 340,280,70,14,"SECQTY",.textbox2
              TextBox 420,245,90,21,.PriQty
              TextBox 420,273,90,21,.SecQty
              Text 40,189,90,14,"Start Value",.Text4
              Text 40,224,90,14,"End Value",.Text5
              Text 40,259,90,14,"Increment",.Text6
              TextBox 130,182,90,21,.startvalue
              TextBox 130,217,90,21,.endvalue
              TextBox 130,252,90,21,.Increment
              Text 580,182,90,14,"Percent free",.Text7
              Text 580,217,90,14,"Free Page",.Text8
              TextBox 680,175,90,21,.PercentFree
              TextBox 680,210,90,21,.FreePage
              OptionGroup .gbpoption
                  OptionButton 670,245,90,14,"Changed",.OptionButton1
                  OptionButton 670,266,90,14,"All",.OptionButton2
                  OptionButton 670,287,90,14,"None",.OptionButton3
              Text 580,259,80,14,"GBP Cache",.Text9
          End Dialog
          Dim dlg As UserDialog

          Dialog dlg, -2

          Else

              MsgBox("The active model must be a DB2 OS/390 model.",,"ERROR!")

          End If

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function partitionHandler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

              'initialize dialog defaults
              DlgText "Stogrouplist", "DTA1"
              DlgEnable "vcattxt",False
              DlgValue "locationoption", 1
              DlgText "PriQty", "720"
              DlgText "SecQty", "720"
              DlgText "PercentFree", "10"
              DlgText "FreePage", "31"

              DlgText "startvalue", "1"
              DlgText "endvalue", "254"
              DlgText "increment", "1"

              indexselected = True

          Case 2 ' Value changing or button pressed

              Select Case DlgItem

                  Case "locationoption"

                      If DlgValue("locationoption") = 0 Then

                          DlgEnable "vcattxt",True
                          DlgEnable "Stogrouplist",False
                          DlgEnable "PriQty",False
                          DlgEnable "SecQty",False

                      Else

                          DlgEnable "vcattxt",False
                          DlgEnable "Stogrouplist",True
                          DlgEnable "PriQty",True
                          DlgEnable "SecQty",True

                      End If

                  Case "tablelist"

                      GetClusteredIndexes(tables(SuppValue))
                      GetIndexedColumns(tables(SuppValue), clusteredindexes(0))

                      DlgListBoxArray "indexlist",clusteredindexes()
                      DlgListBoxArray "columnlist",blank()

                      tableindx = SuppValue
                      indexselected = False

                      partitionHandler = True

                  Case "indexlist"

                      GetIndexedColumns(tables(tableindx), clusteredindexes(SuppValue))
                      DlgListBoxArray "columnlist",indexedcolumns()
                      indexindx = SuppValue
                      indexselected = True

                      partitionHandler = True

                  Case "columnlist"

                      partitionHandler = True

                  Case "apply"

                      If clusteredindexes(indexindx) = "NO CLUSTERED INDEXES" Then

                          MsgBox("NO CLUSTERED INDEX ON SELECTED TABLE.",,"ERROR!")
                          partitionHandler = True

                      Else

                      If indexselected = False Then

                          MsgBox("Please Select an Index.",,"ERROR!")
                          partitionHandler = True

                      Else

                      NumberStart = CLng(DlgText("startvalue"))
                      NumberEnd = CLng(DlgText("endvalue"))
                      NumberInc = CLng(DlgText("Increment"))

                      If DlgValue("locationoption") = 0 Then

                          location = DlgText("vcattxt")
                          locationopt = DlgValue("locationoption")

                      Else

                          location = DlgText("stogrouplist")
                          locationopt = DlgValue("locationoption")

                      End If

                      gbpcache_val = DlgValue("gbpoption")

                      If IsNumeric(DlgText("PriQty")) Then
                          priqty_val = CLng(DlgText("PriQty"))
                      End If

                      If IsNumeric(DlgText("SecQty")) Then
                          secqty_val = CLng(DlgText("SecQty"))
                      End If

                      If IsNumeric(DlgText("FreePage")) Then
                          freepage_val = CLng(DlgText("FreePage"))
                      End If

                      If IsNumeric(DlgText("PercentFree")) Then
                          pctfree_val = CLng(DlgText("PercentFree"))
                      End If

                      generatepartition(tables(tableindx), clusteredindexes(indexindx))

                      partitionHandler = True

                      End If

                      End If

              End Select

              Rem partitionHandler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem partitionHandler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant, _
       Optional intLeft As Integer As Integer ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If

      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


Get Related Tables.BAS

      'TITLE:  GET RELATED ENTITIES
      'DESCRIPTION:  This macro selects the related parents and/or child
      '	of the selected tables.  To use the macro lasso a group of
      '	entities on the diagram or select them in the diagram tree, then
      '	right click on the macro to execute.  Parents and children will
      '	be selected depending if the option is checked.  This macro can
      '	be used to assist in submodel creation.
      'MODIFY DATE:  5/10/02

      'ER.Studio variables
      Dim ersMdl As Model
      Dim ersDiag As Diagram
      Dim ersSubmdl As SubModel
      Dim ersEnt As Entity
      Dim ersSO As SelectedObject
      Dim ersRel As Relationship

      'Array variables
      Dim arrParentTbls() As String
      Dim arrChildTbls() As String
      Dim arrSourceTbls() As String

      Sub fillSourceFromSelected (source As Variant)

          ReDim source (0 To ersSubmdl.SelectedObjects.Count - 1) As String

          Dim i As Integer

          i = 0

          For Each ersSO In ersSubmdl.SelectedObjects

              If ersSO.Type = 1 Then

                  Set ersEnt = ersMdl.Entities.Item(ersSO.ID)

                  If ersMdl.Logical = True Then

                      source(i) = ersEnt.EntityName

                  Else

                       source(i) = ersEnt.TableName

                  End If

                  i = i + 1

              End If

          Next

      End Sub

      Sub getParents (source As Variant, parents() As String)

          Dim i,j As Integer
          Dim count As Integer

          count = 0
          i = 0
          j = 0

          For i = 0 To UBound(source)

              If source(i) <> "" Then

              Set ersEnt = ersMdl.Entities.Item(source(i))

              count = count + ersEnt.ChildRelationships.Count

              If ersEnt.ChildRelationships.Count <> 0 Then

              ReDim Preserve parents(0 To count) As String

              For Each ersRel In ersEnt.ChildRelationships

                  If ersMdl.Logical = True Then

                      parents(j) = ersRel.ParentEntity.EntityName

                  Else

                      parents(j) = ersRel.ParentEntity.TableName

                  End If

                  j = j + 1

              Next

              Else

                  ReDim Preserve parents ( count ) As String

              End If

              End If

          Next

      End Sub

      Sub getChildren (source As Variant, children() As String)

          Dim i,j As Integer
          Dim count As Integer

          count = 0
          i = 0
          j = 0

          For i = 0 To UBound(source)

              If source(i) <> "" Then

              Set ersEnt = ersMdl.Entities.Item(source(i))

              count = count + ersEnt.ParentRelationships.Count

              If ersEnt.ParentRelationships.Count <> 0 Then

              ReDim Preserve children(0 To count) As String

              For Each ersRel In ersEnt.ParentRelationships

                  If ersMdl.Logical = True Then

                      children(j) = ersRel.ChildEntity.EntityName

                  Else

                      children(j) = ersRel.ChildEntity.TableName

                  End If

                  j = j + 1

              Next

              Else

                  ReDim Preserve children ( count ) As String

              End If

              End If

          Next

      End Sub

      Sub addEntities ( submdl As SubModel, newones As Variant )

          Dim i As Integer
          Dim count As Integer

          count = UBound(newones)

          For i = 0 To count

              If newones(i) <> "" Then

                  Set ersEnt = ersMdl.Entities.Item(newones(i))

                  submdl.SelectedObjects.Add(1, ersEnt.ID)

              End If

          Next

      End Sub

      Sub Main

          Debug.Clear

          Set ersDiag = DiagramManager.ActiveDiagram
          Set ersMdl = ersDiag.ActiveModel
          Set ersSubmdl = ersMdl.ActiveSubModel

          Begin Dialog UserDialog 320,98,"Get Related Entities",.GRTHandler ' %GRID:10,7,1,1
              CheckBox 60,21,80,14,"Parents",.parentschbx
              CheckBox 180,21,80,14,"Children",.childrenchbx
              OKButton 40,56,90,21
              CancelButton 190,56,90,21
          End Dialog
          Dim dlg As UserDialog

          dlg.parentschbx = 1
          dlg.childrenchbx = 1

          If ersSubmdl.SelectedObjects.Count <> 0 Then

          If Dialog(dlg, -2) = -1 Then

          '	If ersSubmdl.MainSubModel = True Then

                  fillSourceFromSelected arrSourceTbls
                  Debug.Print "selected0"

          '	Else

                  'Debug.Print "sub  " & dlg.submodelchbx

          '		If dlg.submodelchbx = 0 Then

                  '	fillSourceFromSelected arrSourceTbls
                  '	Debug.Print "selected1"

          '		Else

                  '	ersSubmdl.EntityNames (entnames, srcCount)
                  '	arrSourceTbls = entnames
                  '	Debug.Print "all"

          '		End If

          '	End If

          Debug.Print "Source Tables: "

          For i = 0 To UBound(arrSourceTbls)

              Debug.Print arrSourceTbls(i)

          Next

              If dlg.parentschbx = 1 Then

                  getParents arrSourceTbls, arrParentTbls

                  Debug.Print UBound(arrParentTbls)

                  If UBound(arrParentTbls) > 0 Then

                      Debug.Print "ParentTables: "
                      For i = 0 To UBound(arrParentTbls)
                          Debug.Print arrParentTbls(i)
                      Next

                      addEntities ersSubmdl, arrParentTbls

                  End If

              End If

              If dlg.childrenchbx = 1 Then

                  getChildren arrSourceTbls, arrChildTbls

                  If UBound(arrChildTbls) > 0 Then

                      Debug.Print "childTables: "
                      For i = 0 To UBound(arrChildTbls)
                          Debug.Print arrChildTbls(i)
                      Next

                      addEntities ersSubmdl, arrChildTbls

                  End If

              End If

          End If

          Else

              MsgBox("Please select entities in a submodel or in the Main Model.",,"ERROR!")

          End If

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function GRTHandler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

      '		If ersSubmdl.MainSubModel = True Then

      '			DlgEnable "submodelchbx",False

      '		End If

          Case 2 ' Value changing or button pressed
              Rem GRTHandler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem GRTHandler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Import Domains from Excel.bas

      'TITLE:  IMPORT DOMAINS FROM EXCEL (ENTERPRISE)
      'DESCRIPTION:  This macro imports domains from the specified excel
      '	spreadsheet.  Domains already in the domain list in ERStudio will
      '	be ignored.  As well as duplicate names in the spreadsheet.
      '	Domain name (first column in spreadsheet) and Attribute
      '	name and Column name must be unique.  The only required field
      '	in the spreadsheet is the first column.
      '
      'README:  The format of the spreadsheet must be a certain order for
      '	the information to be imported correctly.  The first row of the
      '	spreadsheet is ignored.  This is reserved for the column titles.
      '	Records will be imported starting with the second row.  The order
      '	of the columns must be as stated below.
      '
      '	1.  Domain Name - Required - String - Non-unique values will be
      '			ignored.
      '	2.  Attribute Name - Not required - String - Non-unique
      '			values will be ignored.  If this is blank the Domain Name
      '			is used.
      '	3.  Column Name - Not required - String - Non-unique
      '			values will be ignored.  If this is blank the Domain Name
      '			is used.
      '	4.	Domain Folder - Not required - String - Must not be the same name
      '			as an existing domain or domain folder.
      '	5.  Domain Definition - Not required - String
      '	6.  Domain Note - Not required - String
      '	7.  Datatype - Not Required - String - Must be a valid Logical
      '			datatype.  See Datatype dropdown in domain editor for
      '			list.
      '	8.  Datatype Width - Not Required - Numeric
      '	9.  Datatype Scale - Not Required - Numeric
      '	10.	Allow Nulls - Not Required - Valid values: YES or NO (not
      '			case-sensitive) - This is required to be YES if the
      '			Domain is to be an IDENTITY.
      '	11.  IDENTITY column - Not Required - YES or NO
      '	12.  Seed - Not Required - Numeric - If this is left blank or the
      '			value is not numeric when IDENTITY is YES, a value of 1
      '			will be used.
      '	13.  Increment - Not Required - Numeric - If this is left blank or the
      '			value is not numeric when IDENTITY is YES, a value of 1
      '			will be used.
      'AUTHOR:  Jason Tiret
      'LAST UPDATE:  5/27/2003

      Dim diag As Diagram
      Dim dict As Dictionary
      Dim dictionary_list () As String

      Sub Main

          Dim dom As Domain
          Dim excel As Object

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram

          Debug.Clear
          Debug.Print diag.ActiveModel.Name

          Begin Dialog UserDialog 520,343,"Import Domains From Excel",.DialogFunc ' %GRID:10,7,1,1
              DropListBox 160,21,320,133,dictionary_list(),.dictionary_select
              Text 40,56,170,14,"Path to XLS spreadsheet:",.Text1
              TextBox 70,84,340,21,.path
              OKButton 230,301,110,21
              CancelButton 380,301,110,21
              PushButton 430,84,60,21,"Browse",.Browse
              Text 50,126,340,42,"Note:  Domains must be in Sheet 1.  See ReadMe for the format of the sheet.  Double-click on macro to view ReadMe.",.Text2
              OptionGroup .UpdateChoice
                  OptionButton 80,189,340,14,"Update existing domains from spread sheet",.OptionButton1
                  OptionButton 80,224,340,14,"Ignore existing domains from spread sheet",.OptionButton2
              PushButton 80,266,160,21,"Get Sample Sheet",.getsample
              Text 30,28,120,14,"Select Dictionary:",.Text3
          End Dialog

          init_dictionary_list
          Dim dlg As UserDialog

          'default option for update radio button, 0 = update, 1 = ignore
          dlg.updatechoice = 1

          'start_dialog:

          'start dialog
          If Dialog(dlg) = -1 Then

          'initialize excel object and make visible
          Set excel = CreateObject("Excel.Application")
          'excel.Visible = True

          'this error is for an errant file path, dialog will be restarted
          'On Error GoTo Error_handle

          excel.workbooks.open dlg.path

          If dictionary_list(dlg.dictionary_select) = "Local" Then

              Set dict = diag.Dictionary

          Else

              Set dict = diag.EnterpriseDataDictionaries.Item(dictionary_list(dlg.dictionary_select))

          End If

          ImportDomains(excel, dlg.updatechoice)

      '	If dlg.UDT = 1 Then
      '		ImportUDTs(excel)
      '	End If

      '	If dlg.rule = 1 Then
      '		ImportRules(excel)
      '	End If

      '	If dlg.default = 1 Then
      '		ImportDefaults(excel)
      '	End If

          excel.workbooks.Close
          'excel.visible = False

          Exit Sub

          'Error_handle:
          '	MsgBox("Please enter a valid path.",,"Error!")
          '	GoTo start_dialog

          End If

      End Sub

      'initialize the dictionary drop down list
      Sub init_dictionary_list

          ReDim dictionary_list (0 To diag.EnterpriseDataDictionaries.Count) As String

          dictionary_list (0) = "Local"
          i = 1

          For Each dict In diag.EnterpriseDataDictionaries

              dictionary_list (i) = dict.Name
              i = i + 1

          Next

      End Sub

      Function DomainExists ( DName As String ) As Boolean

          Dim dom As Domain

          For Each dom In dict.Domains

              If UCase(dom.Name) = UCase(DName) Then

                  DomainExists = True
                  Exit Function

              End If

          Next

          DomainExists = False

      End Function

      Function ImportDomains(ex As Variant, updatebit As Integer)

          Dim sheet As Object
          Dim range As Object
          Dim DomCount As Integer
          Dim dom As Domain
          Dim dom_folder As DomainFolder

          Set sheet = ex.worksheets(1)
          Set range = sheet.usedrange
          range.select

          'On Error GoTo message
          'message:

          DomCount = range.rows.Count
          Debug.Print "Domain Count = " & DomCount

          If DomCount >= 2 Then

          For i = 2 To DomCount

              If range.cells(i,1).Value <> "" Then

                  If DomainExists(range.cells(i,1).Value) = False Then

                      GoTo CREATE

                  Else

                      If updatebit = 1 Then
                          GoTo IGNORE
                      Else
                          GoTo UPDATE
                      End If

                  End If

                  CREATE:

                  If range.cells(i, 4).Value = "" Then

                      'Domain Folder field is blank in spread sheet
                      'create domain, use domain name for attribute/column name if attribute/column name is blank
                      If range.cells(i,2).Value = "" And range.cells(i,3).Value = "" Then
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,1).Value, range.cells(i,1).Value,"")
                      ElseIf range.cells(i,2).Value = "" And range.cells(i,3).Value <> "" Then
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,1).Value, range.cells(i,3).Value,"")
                      ElseIf range.cells(i,2).Value <> "" And range.cells(i,3).Value = "" Then
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,2).Value, range.cells(i,1).Value,"")
                      Else
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,2).Value, range.cells(i,3).Value,"")
                      End If

                  Else

                      'Domain folder is in Spread sheet
                      Set dom_folder = dict.DomainFolders.Item(range.cells(i,4).Value)

                      'check if domain folder doesn't exist then added it
                      If dom_folder Is Nothing Then

                          Set dom_folder = dict.DomainFolders.Add(range.cells(i,4).Value,"")

                      End If

                      'create domain with domain folder, use domain name for attribute/column name if attribute/column name is blank
                      If range.cells(i,2).Value = "" And range.cells(i,3).Value = "" Then
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,1).Value, range.cells(i,1).Value,dom_folder.ID)
                      ElseIf range.cells(i,2).Value = "" And range.cells(i,3).Value <> "" Then
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,1).Value, range.cells(i,3).Value,dom_folder.ID)
                      ElseIf range.cells(i,2).Value <> "" And range.cells(i,3).Value = "" Then
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,2).Value, range.cells(i,1).Value,dom_folder.ID)
                      Else
                          Set dom = dict.Domains.AddEx(range.cells(i,1).Value, range.cells(i,2).Value, range.cells(i,3).Value,dom_folder.ID)
                      End If
                      'Debug.Print DiagramManager.GetLastErrorString

                  End If

                  GoTo SKIPUPD

                  UPDATE:

                      For Each dom In dict.Domains

                          If UCase(dom.Name) = UCase(range.cells(i,1).Value) Then
                              Exit For
                          End If

                      Next

                      If range.cells(i,2).Value <> "" Then
                          dom.AttributeName = range.cells(i,2).Value
                      End If

                      If range.cells(i,3).Value <> "" Then
                          dom.ColumnName = range.cells(i,3).Value
                      End If

                  SKIPUPD:

                      Debug.Print "i = " & i & "  " & DiagramManager.GetLastErrorString

                  'Set definition if spreadsheet column is not blank
                  If range.cells(i,5).Value <> "" Then
                      dom.Definition = range.cells(i,5).Value
                  End If

                  'Set note if spreadsheet column is not blank
                  If range.cells(i,6).Value <> "" Then
                      dom.Note = range.cells(i,6).Value
                  End If

                  'Set datatype if spreadsheet column is not blank
                  If range.cells(i,7).Value <> "" Then
                      dom.Datatype = UCase(range.cells(i,7).Value)
                  End If

                  'set width if spreadsheet column is not blank
                  If  IsNumeric(range.cells(i,8).Value) = True Then
                      dom.DataLength = CLng(range.cells(i,8).Value)
                  End If

                  'set scale if spreadsheet column is not blank
                  If IsNumeric(range.cells(i,9).Value) = True  Then
                      dom.DataScale = CLng(range.cells(i,9).Value)
                  End If

                  'set nullability if spreadsheet column is not blank, valid values "yes" or "no", not case-sensitive
                  If UCase(range.cells(i,10).Value) = "YES" Then
                      dom.Nullable = True
                  ElseIf UCase(range.cells(i,10).Value) = "NO" Then
                      dom.Nullable = False
                  End If

                  'set identity if speadsheet is not null
                  If UCase(range.cells(i,11).Value) = "YES" Then

                      dom.Identity = True

                      'add Identity seed if value is specified in spread sheet, use 1 otherwise
                      If IsNumeric(range.cells(i,12).Value) = True And range.cells(i,12).Value <> "" Then
                          dom.IdentitySeed = CLng(range.cells(i,12).Value)
                      Else
                          dom.IdentitySeed = 1
                      End If

                      'set increment value if specified in spread sheet, use 1 otherwise
                      If IsNumeric(range.cells(i,13).Value) = True And range.cells(i,13).Value <> "" Then
                          dom.IdentityIncrement = CLng(range.cells(i,13).Value)
                      Else
                          dom.IdentityIncrement = 1
                      End If

                  End If

              End If

              IGNORE:

          Next

          End If

          'message:
          '	MsgBox("There is no ""Domains"" sheet in the workbook or the name is invalid.  Domains will not be imported.")
          '	Exit Function

      End Function

      Function ImportUDTs(ex As Variant)

          Dim sheet As Object
          Dim range As Object

          On Error GoTo UDTMessage

          Set sheet = ex.worksheets("User Datatypes")
          Set range = sheet.usedrange

          UDTMessage:
              MsgBox("There is no ""User Datatypes"" sheet in the workbook or the name is invalid.  Entity Definitions will be ignored.")
              Exit Function

      End Function

      Function ImportRules(ex As Variant)

          Dim sheet As Object
          Dim range As Object

          On Error GoTo RuleMessage

          Set sheet = ex.worksheets("Rules")
          Set range = sheet.usedrange

          RuleMessage:
              MsgBox("There is no ""Rules"" sheet in the workbook or the name is invalid.  Entity Definitions will be ignored.")
              Exit Function

      End Function

      Function ImportDefaults(ex As Variant)

          Dim sheet As Object
          Dim range As Object

          On Error GoTo DefaultMessage

          Set sheet = ex.worksheets("Defaults")
          Set range = sheet.usedrange

          DefaultMessage:
              MsgBox("There is no ""Defaults"" sheet in the workbook or the name is invalid.  Entity Definitions will be ignored.")
              Exit Function

      End Function

      Sub PrintSampleSheet()

          Dim ex As Object
          Dim wb, ws As Variant

          Set ex = CreateObject("excel.application")
          ex.visible = True

          Set wb = ex.workbooks.Add
          Set ws = wb.activesheet

          ws.cells(1,1).Value = "Domain Name"
          ws.cells(1,2).Value = "Attribute Name"
          ws.cells(1,3).Value = "Column Name"
          ws.cells(1,4).Value = "Domain Folder"
          ws.cells(1,5).Value = "Domain Definition"
          ws.cells(1,6).Value = "Domain Note"
          ws.cells(1,7).Value = "Datatype"
          ws.cells(1,8).Value = "DataType Width"
          ws.cells(1,9).Value = "DataType Scale"
          ws.cells(1,10).Value = "Allow Nulls"
          ws.cells(1,11).Value = "Identity column"
          ws.cells(1,12).Value = "Identity Seed"
          ws.cells(1,13).Value = "Identity Increment"

          ws.cells(2,1).Value = "string - required"
          ws.cells(2,2).Value = "string - optional, default Domain Name"
          ws.cells(2,3).Value = "string - optional, default Domain Name"
          ws.cells(2,4).Value = "string - optional"
          ws.cells(2,5).Value = "string - optional"
          ws.cells(2,6).Value = "string - optional"
          ws.cells(2,7).Value = "Valid Domain Datatype - Optional"
          ws.cells(2,8).Value = "Numeric - optional"
          ws.cells(2,9).Value = "Numeric - optional"
          ws.cells(2,10).Value = "Yes or No - optional, case-insensitive"
          ws.cells(2,11).Value = "Yes or No - optional, case-insensitive"
          ws.cells(2,12).Value = "Numeric - optional, default 1"
          ws.cells(2,13).Value = "Numeric - optional, default 1"

          With ws.range(ws.cells(1,1),ws.cells(1,13))
              .font.Size = 12
              .font.Bold = True
              .columnwidth = 30
          End With

          ws.range(ws.cells(2,1),ws.cells(2,13)).wraptext = True

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"xls",,"Open SpreadSheet")
                  DialogFunc = True
              ElseIf DlgItem = "getsample" Then
                  PrintSampleSheet
                  DialogFunc = True
              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Import Index Names from Excel.bas

      'TITLE:  IMPORT INDEX NAMES FROM EXCEL
      'DESCRIPTION:  This macro is used to import relationship names from
      '	Microsoft Excel.  A sample spreadsheet can be printed when
      '	executing the macro.  Read the below ReadMe for the valid values
      '	of each column in the spreadsheet.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST MODIFY DATE: 1/29/2003

      'README:  This defines datatypes and constraints on each column of
      '	the speadsheet.  The first row of the spread sheet is reserved for
      '	column headers.  Values in the first row will be ignored.
      '	The specified column order is required for proper import.  All
      '	columns are required in the spreadsheet, but some may have null
      '	values.

      'FORMAT OF SPREAD SHEET:
      '(Column Order Number) Column Name - Datatype - Description

      ' (1) Table Name - String - This is required in the
      '		spread sheet.   The name of the table is used to match
      '		the model table with the entry in the spreadsheet.
      '		Unmatched entries in the spreadsheet will be logged to
      '		C:\Indx_import.txt.

      ' (2) Index Name - String - This is required in the
      '		spread sheet.   The name of the index is used to match
      '		the model index with the entry in the spreadsheet.
      '		Unmatched entries in the spreadsheet will be logged to
      '		C:\Indx_import.txt.

      ' (3) Index Type - String - This is the type of the relationship.
      '		It is not required for importing the names.  PK - Primary Key,
      '		AK - Alternate Key (Unique), IE - Inversion Entry (Non-unique)

      ' (4) Index Member Column - String - This is the name of the
      '		migrated column in the child table.  This is not needed to
      '		import the information into the model.

      ' (5) New Index Name - String - This is the new name
      '		of the relationship.  The relationship specified in column
      '		one will be updated with this name

      Dim diag As Diagram
      Dim mdl As Model

      Dim errorlog As String

      Sub Main

          Dim refval As ReferenceValue
          Dim excel As Object

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          Debug.Clear
          'Debug.Print diag.ActiveModel.Name

          Begin Dialog UserDialog 510,210,"Import Index Names From Excel",.DialogFunc ' %GRID:10,7,1,1
              Text 40,14,170,14,"Path to XLS spreadsheet:",.Text1
              TextBox 70,35,340,21,.path
              OKButton 200,168,110,21
              CancelButton 350,168,110,21
              PushButton 430,35,60,21,"Browse",.Browse
              Text 50,112,400,35,"Note:  Index info must be in Sheet 1.  See ReadMe for the format of the sheet.  Double-click on macro to view ReadMe.",.Text2
              PushButton 60,70,150,28,"Get Sample Sheet",.SampleSheet
          End Dialog
          Dim dlg As UserDialog

          start_dialog:

          'start dialog
          If Dialog(dlg) = -1 Then

          'initialize excel object and make visible
          Set excel = CreateObject("Excel.Application")
          'excel.Visible = True

          'this Error Is For an errant file path, Dialog will be restarted
          On Error GoTo Error_handle

          excel.workbooks.open dlg.path,,True 'readonly:=True

          ImportIndexes(excel)

          excel.Workbooks.Close
          'excel.visible = False

          MsgBox("Import    Complete!",,"ER/Studio")

          Exit Sub

          Error_handle:
              MsgBox("Please enter a valid path.",,"Error!")
              GoTo start_dialog

          End If

      End Sub

      Function ImportIndexes(ex As Variant)

          Dim sheet As Object
          Dim range As Object
          Dim IndxCount As Integer
          Dim ent As Entity
          Dim indx As Index

          Dim indx_name As String
          Dim ent_name As String
          Dim new_indx_name As String

          Set sheet = ex.worksheets(1)
          Set range = sheet.usedrange
          range.select

          IndxCount = range.rows.Count

          If IndxCount >= 2 Then

          errorlog = "Unmatched Entries in SpreadSheet::" & vbCrLf & vbCrLf

          For i = 2 To IndxCount

              If range.cells(i,1).Value <> "" Then

                  ent_name = Trim(range.cells(i,1).Value)
                  indx_name = Trim(range.cells(i,2).Value)
                  new_indx_name = Trim(range.cells(i,5).Value)

                  Set ent = mdl.Entities.Item(ent_name)

                  If ent Is Nothing Then

                      errorlog = errorlog & "Table Name:  " & ent_name & vbCrLf & vbCrLf

                  Else

                      Set indx = ent.Indexes.Item(indx_name)

                      If indx Is Nothing Then

                          errorlog = errorlog & "Table Name:  " & ent_name & vbCrLf

                          errorlog = errorlog & vbTab & "Index Name:   " & indx_name & vbCrLf & vbCrLf

                      Else

                          'update model with new Index name

                          If new_indx_name <> "" Then

                              indx.Name = new_indx_name

                          End If

                      End If

                  End If

              End If

          Next

          Open "C:\Indx_import.txt" For Output As #1
          Print #1, errorlog
          Close #1

          End If

      End Function

      Sub PrintSampleSheet()

          Dim ex As Object
          Dim wb, ws As Variant

          Set ex = CreateObject("excel.application")
          ex.visible = True

          Set wb = ex.workbooks.Add
          Set ws = wb.activesheet

          ws.cells(1,1).Value = "Table Name"
          ws.cells(1,2).Value = "Index Name"
          ws.cells(1,3).Value = "Index Type"
          ws.cells(1,4).Value = "Indexed Column"
          ws.cells(1,5).Value = "New Index Name"

          ws.cells(2,1).Value = "Number - required"
          ws.cells(2,2).Value = "string - optional"
          ws.cells(2,3).Value = "string - optional"
          ws.cells(2,4).Value = "string - optional"
          ws.cells(2,5).Value = "string - optional"

          With ws.range(ws.cells(1,1),ws.cells(1,5))
              .font.Size = 10
              .font.Bold = True
              .columnwidth = 30
          End With

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"xls",,"Open SpreadSheet")
                  DialogFunc = True
              ElseIf DlgItem = "SampleSheet" Then

                  PrintSampleSheet
                  DialogFunc = True

              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Import Object Definitions and Notes from Excel.bas

      'TITLE:  IMPORT OBJECT DEFINITION AND NOTES FROM EXCEL.BAS
      'DESCRIPTION:  This macro will import definition and notes for
      '	entities, attributes, views and relationships from an
      '	excel spreadsheet.  For the definitions and notes to imported
      '	into the correct fields, the spread sheet needs the be a
      '	certain formatt (specified below).  Use "EXPORT OJBECT
'	DEFINITION AND NOTES TO EXCEL" macro to get a sample file.
      '	Object names in the spreadsheet not found in the model will be
      '	ignored during the import.  If a definition or note is blank
      '	or the same in the model as the spread sheet, it will be
      '	ignored.  Case is ignored when comparing Object names between
      '	the spread sheet and the model.
      '
      'FORMAT:
      '	The respective object definitions and notes for each object are
      '	imported from a separate sheet in the Excel workbook.  Each sheet
      '   must be labeled with the respective object type, i.e., "Entities",
      '	"Attributes", "Views", and "Relationships".  The order of the
      '	sheets is irrelevant, but the sheets must be named as quoted
      '	previously.
      '
      '	ENTITIES SHEET:
      '		The "Entities" sheet must have the table name in first column,
      '		table definitions in the second column and table notes in the
      '		third column.  The first row with values in the sheet is
      '		ignored.  It is reserved for column titles, i.e., "Entity Name",
      '		"Entity Definitions", and "Entity Notes".
      '
      '	RELATIONSHIPS SHEET:
      '		The "Relationships" sheet must have the relationship name in
      '		first column, relationship definitions in the second column
      '		and relationship notes in the third column.  The first row
      '		with values in the sheet is ignored.  It is	reserved for
      '		column titles, i.e., "Relationship Name", "Relationship
'		Definitions", and "Relationship Notes".
      '
      '	VIEWS SHEET:
      '		The "Views" sheet must have the view name in first column,
      '		view definitions in the second column and view notes in the
      '		third column.  The first row with values in the sheet is
      '		ignored.  It is	reserved for column titles, i.e., "View Name",
      '		"View Definitions", and "View Notes".
      '
      '	ATTRIBUTES SHEET:
      '		The "Attributes" sheet must have the attribute name in the
      '		first column, attribute definition in the second column, and
      '		entity name of the table it belongs to in the third column.
      '		The first row with values in the sheet is ignored.  It is
      '		reserved for column titles, i.e., "Attribute Name",
      '		"Attribute Definitions", "Entity Name".
      '
      'AUTHOR:  Jason E. Tiret
      'EMAIL:  jason.tiret@embarcadero.com
      'DATE:  7/10/01
      'LAST UPDATE:  10/8/2004

      Option Explicit

      Type EntityDefStruct
          EntityName As String
          EntityDef As String
          EntityNotes As String
      End Type

      Type AttributeDefStruct
          AttributeName As String
          AttributeDef As String
          EntityName As String
      End Type

      Type RelationshipDefStruct
          RelationshipName As String
          RelationshipDef As String
          RelationshipNotes As String
      End Type

      Type ViewDefStruct
          ViewName As String
          ViewDef As String
          ViewNotes As String
      End Type

      'definition arrays
      Dim EntityDefs() As EntityDefStruct
      Dim AttributeDefs() As AttributeDefStruct
      Dim RelationshipDefs() As RelationshipDefStruct
      Dim ViewDefs() As ViewDefStruct

      Dim modeldd() As String

      'global variables
      Dim mdl As Model
      Dim diag As Diagram
      Dim ent As Entity
      Dim att As AttributeObj
      Dim vi As View
      Dim rel As Relationship
      Dim filename As String
      Dim entcount As Integer
      Dim attcount As Integer
      Dim relcount As Integer
      Dim viewcount As Integer

      Sub Main

          Dim excel As Object
          Dim entcount As Integer
          Dim eName As String
          Dim aName As String
          Dim rName As String
          Dim vName As String
          Dim eDef As String
          Dim eNote As String
          Dim aDef As String
          Dim rDef As String
          Dim rNote As String
          Dim vDef As String
          Dim vNote As String
          Dim modCount As Integer
          Dim i As Integer

          Set diag = DiagramManager.ActiveDiagram
          DiagramManager.EnableScreenUpdate(False)

          'fill array for model drop down in the dialog
          modCount = diag.Models.Count

          ReDim modeldd (0 To modCount - 1)
          i = 0

          For Each mdl In diag.Models

              modeldd(i) = mdl.Name
              i = i + 1

          Next

          Debug.Clear
          Debug.Print diag.ActiveModel.Name

          Begin Dialog UserDialog 510,357,"Import Definitions From Excel",.DialogFunc ' %GRID:10,7,1,1
              Text 40,14,170,14,"Path to XLS spreadsheet:",.Text1
              TextBox 70,35,340,21,.path
              OKButton 210,322,110,21
              CancelButton 350,322,110,21
              GroupBox 50,84,410,189,"Import Options",.GroupBox1
              Text 70,112,90,14,"Select Model",.model
              OptionGroup .Definitions
                  OptionButton 70,217,220,14,"Overwrite Existing Definitions",.Overwrite
                  OptionButton 70,238,350,14,"Append Definitions to the end of existing Definitions",.Append
              DropListBox 170,105,200,77,modeldd(),.ModelName
              PushButton 430,35,60,21,"Browse",.Browse
              Text 70,140,200,14,"Select Object Types",.Text3
              CheckBox 90,161,140,14,"Table Definitions",.tables
              CheckBox 90,182,150,14,"Attribute Definitions",.Attributes
              CheckBox 250,161,180,14,"Relationship Definitions",.Relationships
              CheckBox 250,182,130,14,"View Definitions",.Views
              Text 50,280,370,28,"Note:  Format of SpreadSheet is specified in the header of the macro.  Right-click and choose edit to view.",.Text2
          End Dialog
          Dim dlg As UserDialog

          start_dialog:

          'start dialog
          If Dialog(dlg) = -1 Then

          'initialize excel object and make visible
          Set excel = CreateObject("Excel.Application")
          excel.Visible = True

          'this error is for an errant file path, dialog will be restarted
          On Error GoTo Error_handle

          excel.workbooks.open dlg.path

          'initialize ER variables
          Set mdl = diag.Models.Item(modeldd(dlg.ModelName))

          'import table definitions and notes if option is checked in dialog
          If dlg.tables = 1 Then
              'fill entity array with definitions and notes from spread sheet
              FillEntityDefArray(excel)

              'Loop through entities to update definitions and notes
              For Each ent In mdl.Entities

                  'use logical or physical name depending on type of model
                  If mdl.Logical = True Then
                      eName = ent.EntityName
                  Else
                      eName = ent.TableName
                  End If

                  'get repective note and definition from array
                  eDef = GetEntityDef(eName)
                  eNote = GetEntityNote(eName)

                  'don't update definition if it is the same as the model or if it is blank
                  If eDef <> "" And ent.Definition <> eDef Then

                      If dlg.definitions = 0 Then

                          'overwrite definition
                          ent.Definition = eDef

                      Else

                          'append definition
                          ent.Definition = ent.Definition & vbCrLf & eDef

                      End If

                  End If

                  'don't update the note if it is the same as the model or if it is blank
                  If eNote <> "" And ent.Note <> eNote Then

                      If dlg.definitions = 0 Then

                          'overwrite note
                          ent.Note = eNote

                      Else

                          'append note
                          ent.Note = ent.Note & vbCrLf & eNote

                      End If

                  End If

              Next
          End If

          'import attribute definitions if option is checked in dialog
          If dlg.Attributes = 1 Then

              'Get Attribute definitions from spreadsheet
              FillAttributeDefArray(excel)

              For Each ent In mdl.Entities

                  'Loop through attributes to update definitions
                  For Each att In ent.Attributes

                      'use logical if model is logical, physical if model is physical
                      If mdl.Logical = True Then
                          eName = ent.EntityName
                          aName = att.AttributeName
                      Else
                          eName = ent.TableName
                          aName = att.ColumnName
                      End If

                      aDef = GetAttributeDef(eName, aName)

                      'don't udate definitions if spread sheet def is null or same as model def
                      If aDef <> "" And att.Definition <> aDef Then

                          If dlg.definitions = 0 Then

                              att.Definition = aDef

                          Else

                              att.Definition = att.Definition & vbCrLf & aDef

                          End If

                      End If

                  Next

              Next
          End If

          'update view notes and definitions if dialog option is checked
          If dlg.Views = 1 Then

              'get definitions and notes from the excel spread sheet
              FillViewDefArray(excel)

              'loop through views to update definitions and notes in the model
              For Each vi In mdl.Views

                  vName = vi.Name

                  'get view def and notes from respective arrays
                  vDef = GetViewDef(vName)
                  vNote = GetViewNote(vName)

                  'don't update the model def if it is the same as excel def or if excel def is blank
                  If vDef <> "" And vi.Definition <> vDef Then

                      If dlg.definitions = 0 Then

                          vi.Definition = vDef

                      Else

                          vi.Definition = vi.Definition & vbCrLf & vDef

                      End If

                  End If

                  'don't update note if it is the same as excel note or if excel note is blank
                  If vNote <> "" And vi.Notes <> vNote Then

                      If dlg.definitions = 0 Then

                          vi.Notes = vNote

                      Else

                          vi.Notes = vi.Notes & vbCrLf & vNote

                      End If

                  End If

              Next
          End If

          'Update relationship notes and defs if dialog option is checked
          If dlg.Relationships = 1 Then

              'get defs and notes from excel spreadsheet
              FillRelationshipDefArray(excel)

              'loop through relationships to update defs and notes
              For Each rel In mdl.Relationships

                  rName = rel.Name

                  'get note and def from respective arrays
                  rDef = GetRelationshipDef(rName)
                  rNote = GetRelationshipNote(rName)

                  'don't update def if it is the same as excel def or if excel def is blank
                  If rDef <> "" And rel.Definition <> rDef Then

                      If dlg.definitions = 0 Then

                          'overwrite def
                          rel.Definition = rDef

                      Else

                          'append def
                          rel.Definition = rel.Definition & vbCrLf & rDef

                      End If

                  End If

                  'don't update note if it is the same as excel note or if excel note is blank
                  If rNote <> "" And rel.Note <> rNote Then

                      If dlg.definitions = 0 Then

                          rel.Note = rNote

                      Else

                          rel.Note = rel.Note & vbCrLf & rNote

                      End If

                  End If

              Next
          End If

          excel.workbooks.Close
          excel.visible = False

          End If

          DiagramManager.EnableScreenUpdate(True)

          Exit Sub

          Error_handle:
              MsgBox("Please enter a valid path.",,"Error!")
              GoTo start_dialog

      End Sub

      'returns Entity def from Entity def Array given an Entity name from the model
      Function GetEntityDef( EntityName As String ) As String
          Dim i As Integer

          For i = 2 To entcount
              If UCase(EntityDefs(i).EntityName) = UCase(EntityName) Then
                  GetEntityDef = EntityDefs(i).EntityDef
                  Exit Function
              End If
          Next

          GetEntityDef = ""
      End Function

      'returns Entity def from Entity note Array given an Entity name from the model
      Function GetEntityNote( EntityName As String ) As String
          Dim i As Integer

          For i = 2 To entcount
              If UCase(EntityDefs(i).EntityName) = UCase(EntityName) Then
                  GetEntityNote = EntityDefs(i).EntityNotes
                  Exit Function
              End If
          Next

          GetEntityNote = ""
      End Function

      'returns a relationship definitions from the relationship definition array
      Function GetRelationshipDef( RelName As String ) As String
          Dim i As Integer

          For i = 2 To relcount
              If UCase(RelationshipDefs(i).relationshipName) = UCase(RelName) Then
                  GetRelationshipDef = RelationshipDefs(i).relationshipDef
                  Exit Function
              End If
          Next

          GetRelationshipDef = ""
      End Function

      'returns the relationship note from the relationship note array
      Function GetRelationshipNote( RelName As String ) As String
          Dim i As Integer

          For i = 2 To relcount
              If UCase(RelationshipDefs(i).RelationshipName) = UCase(RelName) Then
                  GetRelationshipNote = RelationshipDefs(i).RelationshipNotes
                  Exit Function
              End If
          Next

          GetRelationshipNote = ""
      End Function

      'returns the View definition from the view def array
      Function GetViewDef( ViewName As String ) As String
          Dim i As Integer

          For i = 2 To viewcount
              If UCase(ViewDefs(i).viewName) = UCase(ViewName) Then
                  GetViewDef = ViewDefs(i).viewDef
                  Exit Function
              End If
          Next

          GetViewDef = ""
      End Function

      'returns the view note from the view note array
      Function GetViewNote( ViewName As String ) As String
          Dim i As Integer

          For i = 2 To viewcount
              If UCase(ViewDefs(i).viewName) = UCase(ViewName) Then
                  GetViewNote = ViewDefs(i).viewNotes
                  Exit Function
              End If
          Next

          GetViewNote = ""
      End Function

      'returns the attribute definition from attribute def array
      Function GetAttributeDef ( EntityName As String, AttributeName As String ) As String
          Dim i As Integer

          For i = 2 To attcount
              If UCase(AttributeDefs(i).EntityName) = UCase(EntityName) And UCase(AttributeDefs(i).AttributeName) = UCase(AttributeName) Then
                  GetAttributeDef = AttributeDefs(i).AttributeDef
                  Exit Function
              End If
          Next

          GetAttributeDef = ""
      End Function

      'Fills the entity array with definitions and notes from the spreadsheet
      Function FillEntityDefArray (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer

          On Error GoTo Message

          Set sheet = ex.worksheets("Entities")
          Set range = sheet.usedrange

          entcount = range.rows.Count
          ReDim EntityDefs (2 To entcount)

          For i = 2 To entcount

              EntityDefs(i).EntityName = Trim(range.cells(i, 1).Value)
              EntityDefs(i).EntityDef = Trim(range.cells(i, 2).Value)
              EntityDefs(i).EntityNotes = Trim(range.cells(i, 3).Value)
              Debug.Print EntityDefs(i).EntityName
              Debug.Print EntityDefs(i).Entitydef

          Next

          Exit Function

          Message:
              MsgBox("There is no ""Entities"" sheet in the workbook or the name is invalid.  Entity Definitions will be ignored.")
              Exit Function

      End Function

      'Fills the attribute def array with the attribute definitions from the excel spread sheet
      Function FillAttributeDefArray (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer

          On Error GoTo AttMessage

          Set sheet = ex.worksheets("Attributes")
          Set range = sheet.usedrange

          attcount = range.rows.Count
          ReDim AttributeDefs (2 To attcount)

          For i = 2 To attcount

              AttributeDefs(i).AttributeName = Trim(range.cells(i, 1).Value)
              AttributeDefs(i).AttributeDef = Trim(range.cells(i, 2).Value)
              AttributeDefs(i).EntityName = Trim(range.cells(i, 3).Value)
              Debug.Print AttributeDefs(i).AttributeName
              Debug.Print AttributeDefs(i).attributedef

          Next

          Exit Function

          AttMessage:
              MsgBox("There is no ""Attributes"" sheet in the workbook or the name is invalid.  Attribute Definitions will be ignored.")
              Exit Function

      End Function

      'fills the relationship def array with the notes and definitions from the excel spread sheet
      Function FillRelationshipDefArray (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer

          On Error GoTo RelMessage

          Set sheet = ex.worksheets("Relationships")
          Set range = sheet.usedrange

          relcount = range.rows.Count
          ReDim RelationshipDefs (2 To relcount)

          For i = 2 To relcount

              RelationshipDefs(i).relationshipName = Trim(range.cells(i, 1).Value)
              RelationshipDefs(i).relationshipDef = Trim(range.cells(i, 2).Value)
              RelationshipDefs(i).relationshipNotes = Trim(range.cells(i, 3).Value)
              Debug.Print RelationshipDefs(i).relationshipName
              Debug.Print RelationshipDefs(i).relationshipdef

          Next

          Exit Function

          RelMessage:
              MsgBox("There is no ""Relationships"" sheet in the workbook or the name is invalid.  Relationship Definitions will be ignored.")
              Exit Function

      End Function

      'fills the view def array with the notes and definitions from the excel spread sheet.
      Function FillViewDefArray (ex As Object)

          Dim sheet As Object
          Dim range As Object
          Dim i As Integer

          On Error GoTo ViewMessage

          Set sheet = ex.worksheets("Views")
          Set range = sheet.usedrange

          viewcount = range.rows.Count
          ReDim ViewDefs (2 To viewcount)

          For i = 2 To viewcount

              ViewDefs(i).viewName = Trim(range.cells(i, 1).Value)
              ViewDefs(i).viewDef = Trim(range.cells(i, 2).Value)
              ViewDefs(i).viewNotes = Trim(range.cells(i, 3).Value)
              Debug.Print ViewDefs(i).viewName
              Debug.Print ViewDefs(i).viewdef

          Next

          Exit Function

          ViewMessage:
              MsgBox("There is no ""Views"" sheet in the workbook or the name is invalid.  View Definitions will be ignored.")
              Exit Function

      End Function

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean

          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"xls",,"Open SpreadSheet")
                  DialogFunc = True
              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Import Reference Values from Excel.BAS

      'TITLE:  IMPORT REFERENCE VALUES FROM EXCEL (Enterprise)
      'DESCRIPTION:  This macro is used to import reference values from
      '	Microsoft Excel.  A sample spreadsheet can be printed when
      '	executing the macro.  Read the below ReadMe for the valid values
      '	of each column in the spreadsheet.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST MODIFY DATE: 5/27/2003

      'README:  This defines datatypes and constraints on each column of
      '	the speadsheet.  The first row of the spread sheet is reserved for
      '	column headers.  Values in the first row will be ignored.
      '	The specified column order is required for proper import.  All
      '	columns are required in the spreadsheet, but some may have null
      '	values.  The spread sheet can be used to update existing
      '	reference values or import new values.  For list reference
      '	values, the new values are appended to the list.  For range
      '	reference values, the information will be updated from the spread
      '	sheet.  Blank rows will be ignored.

      'FORMAT OF SPREAD SHEET:
      '(Column Order Number) Column Name - Datatype - Description

      ' (1) Reference Value Name - String - This is required in the spread
      '		sheet.  The case is not sensitive meaning the case doesn't
      '		have to match in the spread sheet or between the spread
      '		sheet and existing reference values in the data dictionary.
      '		This name will be duplicated for list values with each list
      '		value and value description different for each.  The other
      '		columns will be ingored.

      ' (2) Reference Value Description - String - This is the description
      '		for the reference value.  This can be null.  For list values
      '		it only has to be in the first entry.

      ' (3) Reference Value Type - String - The valid values are "LIST" or
      '		"RANGE".  This is required.

      ' (4) Values NOT Between - String - The valid values are "True" or
      '		"False".  False is the default if left blank.

      ' (5) RV Value - Alphanumeric - This is the minvalue (or start value)
      '		for range reference values.  This is a list value for a
      '		List reference value.  This is required.

      ' (6) RV End Value - Alphanumeric - This is the max (or end value)
      '		for range reference values.  This is null for list reference
      '		values.

      ' (7) RV Description - String - This is the value description for
      '		list reference values.  This is null for range reference
      '		values.

      Dim diag As Diagram
      Dim dict As Dictionary
      Dim dictionary_list () As String

      Sub Main

          Dim refval As ReferenceValue
          Dim excel As Object

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram
          'Set dict = diag.Dictionary

          Debug.Clear
          'Debug.Print diag.ActiveModel.Name

          Begin Dialog UserDialog 550,266,"Import Reference Values From Excel",.DialogFunc ' %GRID:10,7,1,1
              DropListBox 170,14,340,112,dictionary_list(),.dictionary_select
              Text 30,56,170,14,"Path to XLS spreadsheet:",.Text1
              TextBox 70,84,340,21,.path
              OKButton 270,231,110,21
              CancelButton 410,231,110,21
              PushButton 430,84,60,21,"Browse",.Browse
              Text 70,182,400,35,"Note:  Reference Values must be in Sheet 1.  See ReadMe for the format of the sheet.  Double-click on macro to view ReadMe.",.Text2
              PushButton 60,133,150,28,"Get Sample Sheet",.SampleSheet
              Text 30,21,120,14,"Select Dictionary:",.Text3
          End Dialog
          Dim dlg As UserDialog

          init_dictionary_list

          start_dialog:

          'start dialog
          If Dialog(dlg) = -1 Then

              If dictionary_list(dlg.dictionary_select) = "Local" Then

                  Set dict = diag.Dictionary

              Else

                  Set dict = diag.EnterpriseDataDictionaries.Item(dictionary_list(dlg.dictionary_select))

              End If

              'initialize excel object and make visible
              Set excel = CreateObject("Excel.Application")
              'excel.Visible = True

              'this Error Is For an errant file path, Dialog will be restarted
              On Error GoTo Error_handle

              excel.workbooks.open dlg.path

              ImportRVs(excel)

              excel.workbooks.Close
              'excel.visible = False

              Exit Sub

              Error_handle:
                  MsgBox("Please enter a valid path.",,"Error!")
                  GoTo start_dialog

          End If

      End Sub

      'initialize the dictionary drop down list
      Sub init_dictionary_list

          ReDim dictionary_list (0 To diag.EnterpriseDataDictionaries.Count) As String

          dictionary_list (0) = "Local"
          i = 1

          For Each dict In diag.EnterpriseDataDictionaries

              dictionary_list (i) = dict.Name
              i = i + 1

          Next

      End Sub

      Function ImportRVs(ex As Variant)

          Dim sheet As Object
          Dim range As Object
          Dim RVCount As Integer
          Dim refval As ReferenceValue
          Dim currentRV As String
          Dim lastRV As String
          Dim RVvalue As ValuePair

          Set sheet = ex.worksheets(1)
          Set range = sheet.usedrange
          range.select

          'On Error GoTo message

          RVCount = range.rows.Count
          Debug.Print "Reference Value Count = " & RVCount

          If RVCount >= 2 Then

          For i = 2 To RVCount

              If range.cells(i,1).Value <> "" Then

                  If UCase(range.cells(i,3).Value) = "RANGE" Then

                      If dict.ReferenceValues.Item(range.cells(i,1).Value) Is Nothing Then

                          Set refval = dict.ReferenceValues.Add(range.cells(i,1).Value)

                      Else

                          Set refval = dict.ReferenceValues.Item(range.cells(i,1).Value)

                      End If

                          refval.IsRange = True
                          refval.Description = range.cells(i,2).Value
                          refval.MinValue = CStr(range.cells(i,5).Value)
                          refval.MaxValue = CStr(range.cells(i,6).Value)

                          If UCase(range.cells(i,4).Value) = "TRUE" Then
                              refval.IsNotBetween = True
                          Else
                              refval.IsNotBetween = False
                          End If

                  ElseIf UCase(range.cells(i,3).Value) = "LIST" Then

                      currentRV = range.cells(i,1).Value

                      If dict.ReferenceValues.Item(currentRV) Is Nothing Then
                      'create a new Reference value since it doesn't exist

                          Set refval = dict.ReferenceValues.Add(currentRV)

                      Else
                      'just add the new value and description to existing RV

                          Set refval = dict.ReferenceValues.Item(currentRV)

                      End If

                      refval.IsRange = False
                      refval.IsRange = False
                      refval.Description = range.cells(i,2).Value

                      Set RVvalue = refval.Values.Item(CStr(range.cells(i,5).Value))

                      If refval.Values.Item(CStr(range.cells(i,5).Value)) Is Nothing Then

                          refval.Values.Add(CStr(range.cells(i,5).Value), CStr(range.cells(i,7).Value))

                      Else

                          RVvalue.Value = CStr(range.cells(i,5).Value)
                          RVvalue.ValueDescription = CStr(range.cells(i,7).Value)

                      End If

                      If UCase(range.cells(i,4).Value) = "TRUE" Then
                          refval.IsNotBetween = True
                      Else
                          refval.IsNotBetween = False
                      End If

                  End If

              End If

          Next

          End If

          'message:

          '	MsgBox("There is no ""Domains"" sheet in the workbook or the name is invalid.  Domains will not be imported.")
          '	Exit Function

      End Function

      Sub PrintSampleSheet()

          Dim ex As Object
          Dim wb, ws As Variant

          Set ex = CreateObject("excel.application")
          ex.visible = True

          Set wb = ex.workbooks.Add
          Set ws = wb.activesheet

          ws.cells(1,1).Value = "Reference Value Name"
          ws.cells(1,2).Value = "Reference Value Description"
          ws.cells(1,3).Value = "Reference Value Type"
          ws.cells(1,4).Value = "Values NOT Between"
          ws.cells(1,5).Value = "RV Value"
          ws.cells(1,6).Value = "RV End Value"
          ws.cells(1,7).Value = "RV Value Description"

          ws.cells(2,1).Value = "string - required"
          ws.cells(2,2).Value = "string - optional"
          ws.cells(2,3).Value = """Range"" or ""List"" - required"
          ws.cells(2,4).Value = """True"" or ""False"" - optional (false is default)"
          ws.cells(2,5).Value = "alphanumeric (Begin value for Range RVs) - required"
          ws.cells(2,6).Value = "alphanumeric (null for ""List"" type) - required for Range type"
          ws.cells(2,7).Value = "string (Null for Range RVs) - optional"

          ws.cells(3,1).Value = "***Remove rows 2-4 from the spread sheet to import back into ER/Studio***"

          ws.cells(5,1).Value = "Product Codes"
          ws.cells(5,2).Value = "These are the product codes for the product value look up table"
          ws.cells(5,3).Value = "List"
          ws.cells(5,4).Value = "False"
          ws.cells(5,5).Value = "1"
          ws.cells(5,6).Value = ""
          ws.cells(5,7).Value = ""
          ws.cells(6,1).Value = "Product Codes"
          ws.cells(6,2).Value = ""
          ws.cells(6,3).Value = "List"
          ws.cells(6,4).Value = "False"
          ws.cells(6,5).Value = "2"
          ws.cells(6,6).Value = ""
          ws.cells(6,7).Value = ""
          ws.cells(7,1).Value = "Product Codes"
          ws.cells(7,2).Value = ""
          ws.cells(7,3).Value = "List"
          ws.cells(7,4).Value = "False"
          ws.cells(7,5).Value = "3"
          ws.cells(7,6).Value = ""
          ws.cells(7,7).Value = ""
          ws.cells(8,1).Value = "Product Codes"
          ws.cells(8,2).Value = ""
          ws.cells(8,3).Value = "List"
          ws.cells(8,4).Value = "False"
          ws.cells(8,5).Value = "4"
          ws.cells(8,6).Value = ""
          ws.cells(8,7).Value = ""
          ws.cells(9,1).Value = "Region Codes"
          ws.cells(9,2).Value = "These are the valid region values"
          ws.cells(9,3).Value = "List"
          ws.cells(9,4).Value = ""
          ws.cells(9,5).Value = "1"
          ws.cells(9,6).Value = ""
          ws.cells(9,7).Value = ""
          ws.cells(10,1).Value = "Region Codes"
          ws.cells(10,2).Value = ""
          ws.cells(10,3).Value = "List"
          ws.cells(10,4).Value = ""
          ws.cells(10,5).Value = "2"
          ws.cells(10,6).Value = ""
          ws.cells(10,7).Value = ""
          ws.cells(11,1).Value = "Region Codes"
          ws.cells(11,2).Value = ""
          ws.cells(11,3).Value = "List"
          ws.cells(11,4).Value = ""
          ws.cells(11,5).Value = "3"
          ws.cells(11,6).Value = ""
          ws.cells(11,7).Value = ""
          ws.cells(12,1).Value = "Region Codes"
          ws.cells(12,2).Value = ""
          ws.cells(12,3).Value = "List"
          ws.cells(12,4).Value = ""
          ws.cells(12,5).Value = "4"
          ws.cells(12,6).Value = ""
          ws.cells(12,7).Value = ""
          ws.cells(13,1).Value = "Salary"
          ws.cells(13,2).Value = "This is the typical salary range for each employee"
          ws.cells(13,3).Value = "Range"
          ws.cells(13,4).Value = "False"
          ws.cells(13,5).Value = "-10000"
          ws.cells(13,6).Value = "100000"
          ws.cells(13,7).Value = ""
          ws.cells(14,1).Value = "Commission"
          ws.cells(14,2).Value = "This is the commission range"
          ws.cells(14,3).Value = "Range"
          ws.cells(14,4).Value = "False"
          ws.cells(14,5).Value = "20000"
          ws.cells(14,6).Value = "50000"
          ws.cells(14,7).Value = ""
          ws.cells(15,1).Value = "Bank Type"
          ws.cells(15,2).Value = "This determines each bank type"
          ws.cells(15,3).Value = "List"
          ws.cells(15,4).Value = "False"
          ws.cells(15,5).Value = "1"
          ws.cells(15,6).Value = ""
          ws.cells(15,7).Value = ""
          ws.cells(16,1).Value = "Bank Type"
          ws.cells(16,2).Value = ""
          ws.cells(16,3).Value = "List"
          ws.cells(16,4).Value = ""
          ws.cells(16,5).Value = "2"
          ws.cells(16,6).Value = ""
          ws.cells(16,7).Value = ""
          ws.cells(17,1).Value = "STATE"
          ws.cells(17,2).Value = "State codes"
          ws.cells(17,3).Value = "List"
          ws.cells(17,4).Value = "False"
          ws.cells(17,5).Value = "CA"
          ws.cells(17,6).Value = ""
          ws.cells(17,7).Value = ""
          ws.cells(18,1).Value = "STATE"
          ws.cells(18,2).Value = "State codes"
          ws.cells(18,3).Value = "List"
          ws.cells(18,4).Value = "False"
          ws.cells(18,5).Value = "NY"
          ws.cells(18,6).Value = ""
          ws.cells(18,7).Value = ""
          ws.cells(19,1).Value = "STATE"
          ws.cells(19,2).Value = "State codes"
          ws.cells(19,3).Value = "List"
          ws.cells(19,4).Value = "False"
          ws.cells(19,5).Value = "OH"
          ws.cells(19,6).Value = ""
          ws.cells(19,7).Value = ""
          ws.cells(20,1).Value = "STATE"
          ws.cells(20,2).Value = "State codes"
          ws.cells(20,3).Value = "List"
          ws.cells(20,4).Value = "False"
          ws.cells(20,5).Value = "MA"
          ws.cells(20,6).Value = ""
          ws.cells(20,7).Value = ""
          ws.cells(21,1).Value = "State"
          ws.cells(21,2).Value = "State codes"
          ws.cells(21,3).Value = "List"
          ws.cells(21,4).Value = "False"
          ws.cells(21,5).Value = "AZ"
          ws.cells(21,6).Value = ""
          ws.cells(21,7).Value = ""
          ws.cells(22,1).Value = "STATE"
          ws.cells(22,2).Value = "State codes"
          ws.cells(22,3).Value = "List"
          ws.cells(22,4).Value = "False"
          ws.cells(22,5).Value = "NV"
          ws.cells(22,6).Value = ""
          ws.cells(22,7).Value = ""
          ws.cells(23,1).Value = "STATE"
          ws.cells(23,2).Value = ""
          ws.cells(23,3).Value = "List"
          ws.cells(23,4).Value = "False"
          ws.cells(23,5).Value = "HI"
          ws.cells(23,6).Value = ""
          ws.cells(23,7).Value = ""
          ws.cells(24,1).Value = "STATE"
          ws.cells(24,2).Value = ""
          ws.cells(24,3).Value = "List"
          ws.cells(24,4).Value = "False"
          ws.cells(24,5).Value = "ID"
          ws.cells(24,6).Value = ""
          ws.cells(24,7).Value = ""
          ws.cells(25,1).Value = "STATE"
          ws.cells(25,2).Value = ""
          ws.cells(25,3).Value = "List"
          ws.cells(25,4).Value = "False"
          ws.cells(25,5).Value = "MO"
          ws.cells(25,6).Value = ""
          ws.cells(25,7).Value = ""
          ws.cells(26,1).Value = "stATE"
          ws.cells(26,2).Value = ""
          ws.cells(26,3).Value = "List"
          ws.cells(26,4).Value = "False"
          ws.cells(26,5).Value = "MI"
          ws.cells(26,6).Value = ""
          ws.cells(26,7).Value = ""
          ws.cells(27,1).Value = "STATE"
          ws.cells(27,2).Value = ""
          ws.cells(27,3).Value = "List"
          ws.cells(27,4).Value = "False"
          ws.cells(27,5).Value = "MD"
          ws.cells(27,6).Value = ""
          ws.cells(27,7).Value = ""
          ws.cells(28,1).Value = "STATE"
          ws.cells(28,2).Value = ""
          ws.cells(28,3).Value = "List"
          ws.cells(28,4).Value = "False"
          ws.cells(28,5).Value = "OR"
          ws.cells(28,6).Value = ""
          ws.cells(28,7).Value = ""
          ws.cells(29,1).Value = "STATE"
          ws.cells(29,2).Value = ""
          ws.cells(29,3).Value = "List"
          ws.cells(29,4).Value = "False"
          ws.cells(29,5).Value = "MN"
          ws.cells(29,6).Value = ""
          ws.cells(29,7).Value = ""
          ws.cells(30,1).Value = "STATE"
          ws.cells(30,2).Value = ""
          ws.cells(30,3).Value = "List"
          ws.cells(30,4).Value = "False"
          ws.cells(30,5).Value = "WY"
          ws.cells(30,6).Value = ""
          ws.cells(30,7).Value = ""
          ws.cells(31,1).Value = "STATE"
          ws.cells(31,2).Value = ""
          ws.cells(31,3).Value = "List"
          ws.cells(31,4).Value = "False"
          ws.cells(31,5).Value = "TX"
          ws.cells(31,6).Value = ""
          ws.cells(31,7).Value = ""
          ws.cells(32,1).Value = "STATE"
          ws.cells(32,2).Value = ""
          ws.cells(32,3).Value = "List"
          ws.cells(32,4).Value = "False"
          ws.cells(32,5).Value = "OK"
          ws.cells(32,6).Value = ""
          ws.cells(32,7).Value = ""
          ws.cells(33,1).Value = "STATE"
          ws.cells(33,2).Value = ""
          ws.cells(33,3).Value = "List"
          ws.cells(33,4).Value = "False"
          ws.cells(33,5).Value = "VM"
          ws.cells(33,6).Value = ""
          ws.cells(33,7).Value = ""
          ws.cells(34,1).Value = "STATE"
          ws.cells(34,2).Value = ""
          ws.cells(34,3).Value = "List"
          ws.cells(34,4).Value = "False"
          ws.cells(34,5).Value = "PA"
          ws.cells(34,6).Value = ""
          ws.cells(34,7).Value = ""
          ws.cells(35,1).Value = "STATE"
          ws.cells(35,2).Value = ""
          ws.cells(35,3).Value = "List"
          ws.cells(35,4).Value = "False"
          ws.cells(35,5).Value = "FL"
          ws.cells(35,6).Value = ""
          ws.cells(35,7).Value = ""
          ws.cells(36,1).Value = "STATE"
          ws.cells(36,2).Value = ""
          ws.cells(36,3).Value = "List"
          ws.cells(36,4).Value = "False"
          ws.cells(36,5).Value = "NM"
          ws.cells(36,6).Value = ""
          ws.cells(36,7).Value = ""
          ws.cells(37,1).Value = "STATE"
          ws.cells(37,2).Value = ""
          ws.cells(37,3).Value = "List"
          ws.cells(37,4).Value = "False"
          ws.cells(37,5).Value = "WI"
          ws.cells(37,6).Value = ""
          ws.cells(37,7).Value = ""
          ws.cells(38,1).Value = "STATE"
          ws.cells(38,2).Value = ""
          ws.cells(38,3).Value = "List"
          ws.cells(38,4).Value = "False"
          ws.cells(38,5).Value = "IW"
          ws.cells(38,6).Value = ""
          ws.cells(38,7).Value = ""

          With ws.range(ws.cells(1,1),ws.cells(1,7))
              .font.Size = 12
              .font.Bold = True
              .columnwidth = 30
          End With

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"xls",,"Open SpreadSheet")
                  DialogFunc = True
              ElseIf DlgItem = "SampleSheet" Then

                  PrintSampleSheet
                  DialogFunc = True

              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Import Relationship Names from Excel.bas

      'TITLE:  IMPORT RELATIONSHIP NAMES FROM EXCEL
      'DESCRIPTION:  This macro is used to import index names from
      '	Microsoft Excel.  A sample spreadsheet can be printed when
      '	executing the macro.  Read the below ReadMe for the valid values
      '	of each column in the spreadsheet.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST MODIFY DATE: 1/29/2003

      'README:  This defines datatypes and constraints on each column of
      '	the speadsheet.  The first row of the spread sheet is reserved for
      '	column headers.  Values in the first row will be ignored.
      '	The specified column order is required for proper import.  All
      '	columns are required in the spreadsheet, but some may have null
      '	values.

      'FORMAT OF SPREAD SHEET:
      '(Column Order Number) Column Name - Datatype - Description

      ' (1) Parent Relationship FK Name - String - This is required in the
      '		spread sheet.   The name of the relationshipis used to match
      '		the model relationship with the  entry in the spreadsheet.
      '		Unmatched entries in the spreadsheet will be logged to
      '		C:\Rel_import.txt.

      ' (2) Parent Table Name - String - This is the name of the parent of
      '		the relationship.  It is not needed to import information into
      '		the model.

      ' (3) Child Table Name - String - This is the name of the child of
      '		the relationship.  It is not needed to import the information
      '		the model.

      ' (4) Parent Migrated Column Name - String - This is the name of the
      '		migrated column in the child table.  This is not needed to
      '		import the information into the model.

      ' (5) New Parent Relationship FK Name - String - This is the new name
      '		of the relationship.  The relationship specified in column
      '		one will be updated with this name

      Dim diag As Diagram
      Dim mdl As Model

      Dim errorlog As String

      Sub Main

          Dim refval As ReferenceValue
          Dim excel As Object

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          Debug.Clear
          'Debug.Print diag.ActiveModel.Name

          Begin Dialog UserDialog 510,210,"Import Relationship Names From Excel",.DialogFunc ' %GRID:10,7,1,1
              Text 40,14,170,14,"Path to XLS spreadsheet:",.Text1
              TextBox 70,35,340,21,.path
              OKButton 200,168,110,21
              CancelButton 350,168,110,21
              PushButton 430,35,60,21,"Browse",.Browse
              Text 50,112,400,35,"Note:  Relationship info must be in Sheet 1.  See ReadMe for the format of the sheet.  Double-click on macro to view ReadMe.",.Text2
              PushButton 60,70,150,28,"Get Sample Sheet",.SampleSheet
          End Dialog
          Dim dlg As UserDialog

          start_dialog:

          'start dialog
          If Dialog(dlg) = -1 Then

          'initialize excel object and make visible
          Set excel = CreateObject("Excel.Application")
          'excel.Visible = True

          'this Error Is For an errant file path, Dialog will be restarted
          'On Error GoTo Error_handle

          excel.workbooks.open dlg.path,,True 'readonly:=True

          ImportRels(excel)

          excel.Workbooks.Close
          'excel.visible = False

          MsgBox("Import   Complete!",,"ER/Studio")

          Exit Sub

          Error_handle:
              MsgBox("Please enter a valid path.",,"Error!")
              GoTo start_dialog

          End If

      End Sub

      Function ImportRels(ex As Variant)

          Dim sheet As Object
          Dim range As Object
          Dim RelCount As Integer
          Dim rel As Relationship
          Dim currentRel As String
          Dim lastRel As String
          Dim rel_name As String
          Dim new_rel_name As String

          Set sheet = ex.worksheets(1)
          Set range = sheet.usedrange
          range.select

          RelCount = range.rows.Count

          If RelCount >= 2 Then

          errorlog = "Unmatched Entries in SpreadSheet::" & vbCrLf & vbCrLf

          For i = 2 To RelCount

              new_rel_name = Trim(range.cells(i,5).Value)
              rel_name = Trim(range.cells(i,1).Value)

              If  rel_name <> "" Then

                  Set rel = mdl.Relationships.Item(rel_name)

                  If rel Is Nothing Then

                      'write relationship to error log
                      errorlog = errorlog & "Relationship:  " & Trim(range.cells(i,1).Value) & vbCrLf
                      errorlog = errorlog & vbTab & "Parent:  " & Trim(range.cells(i,2).Value) & vbCrLf
                      errorlog = errorlog & vbTab & "Child:   " & Trim(range.cells(i,3).Value) & vbCrLf & vbCrLf

                  Else

                      'update model with Relationship name

                      If new_rel_name <> "" Then

                          rel.Name = new_rel_name

                      End If

                  End If

              End If

          Next

          Open "C:\Rel_import.txt" For Output As #1
          Print #1, errorlog
          Close #1

          End If

      End Function

      Sub PrintSampleSheet()

          Dim ex As Object
          Dim wb, ws As Variant

          Set ex = CreateObject("excel.application")
          ex.visible = True

          Set wb = ex.workbooks.Add
          Set ws = wb.activesheet

          ws.cells(1,1).Value = "Parent Relationship FK Name"
          ws.cells(1,2).Value = "Parent Table Name"
          ws.cells(1,3).Value = "Child Table Name"
          ws.cells(1,4).Value = "Parent Migrated Column"
          ws.cells(1,5).Value = "New Parent Relationship FK Name"

          ws.cells(2,1).Value = "Number - required"
          ws.cells(2,2).Value = "string - optional"
          ws.cells(2,3).Value = "string - optional"
          ws.cells(2,4).Value = "string - optional"
          ws.cells(2,5).Value = "string - optional"

          With ws.range(ws.cells(1,1),ws.cells(1,6))
              .font.Size = 10
              .font.Bold = True
              .columnwidth = 30
          End With

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"xls",,"Open SpreadSheet")
                  DialogFunc = True
              ElseIf DlgItem = "SampleSheet" Then

                  PrintSampleSheet
                  DialogFunc = True

              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


ImportDataDictionary.BAS

      '#Reference {9B8C2BA4-CC29-44B0-99B3-693EB4595A9D}#1.0#0#D:\Public\IPQueue\ReleaseMinSize\IPQueue.dll#IPQueue 1.0 Type Library
      ' The import file has to be in the following format.
      '
      '*************************************************************************
      '[File_Info]
      'Type = DD_Import;
      'Name = test.vpp;
      'Version = ERStudio4.2;
      '
      '[Default]
      'Name = Def1;
      'Value = Def1-Val;
      '
      '[Rule]
      'Name = Rule1;
      'Value = Rule1-Val;
      '
      '[UserDatatype]
      'Name = UDT1;
      '
      '[UserDatatype]
      'Name = UDT2;
      'DataType = Decimal;
      'DataLength = 20;
      'DataScale = 3;
      'Bind_Default = Def1;
      'Bind_Rule = Rule1;
      '
      '[Domain]
      'Name = Dom1;
      'Column = Dom1-Col;
      '
      '[Domain]
      'Name = Dom2;
      'Column = Dom2-Col;
      'DataType = Decimal;
      'DataLength = 20;
      'DataScale = 3;
      'Bind_Default = Def1;
      'Bind_Rule = Rule1;
      'Bind_UserDatatype = UDT1;
      'Identity = 1;
      'IdentityIncrement = 2;
      'IdentitySeed = 100;
      '
      '[Domain]
      'Name = Dom3;
      'Column = Dom3-Col;
      'DataType = counter;
      'DataLength = 20;
      'DataScale = 3;
      'CheckConstraint = constraint_test;
      'DeclaredDefault = default_test;
      'Bind_UserDatatype = UDTTest3;
      'Identity = 1;
      'IdentityIncrement = 2;
      'IdentitySeed = 100;
      '
      '*************************************************************************
      '
      'GENERAL FORMAT:
      '***************
      'The section headers are wrapped in a open and close square brackets ("[]"), and
      'all the value pairs (i.e. property = value) indicating different Data Dictionary
      'object properties have to end in a semi-colon (";"). The macro will not work if these
      'specific syntax are not used. All the section header names (i.e. Default, Rule,
      'UserDataType, Domain) and value pair property names (i.e. Name, Column, DataType) are
      'all case sensitive. Group the objects together, and preferably in 'Default, Rule,
      'UserDatatype, and Domain order. The Rules, Defaults, and UserDatatypes'that are bound
      'to other objects have to be declared before the object they are bound to. If the
      'properties of the Data Dictionary objects are duplicated (i.e. there are 2 DataLengths
      'given in a Domain section), the last one in the list of property value pairs in that
      'section will be the one that is set for that property.
      '
      'File_Info:
      '*********
      'Properties available:
      'Type
      'Name
      'Version
      '
      'The [File_Info] section contains some information that we verify internally,
      'since this file format will be used for other file functions later on. The
      'Type has to indicate "DD_Import" and the actual file name has to match the
      'file name that will be given during the execution of the macro. If the Type
      'and Filename don't match in the verification the program will not work. The
      'version property needs the ERStudio version entered, to be used later for other
      'verification purposes.
      '
      'Default and Rule:
      '*****************
      'Properties available:
      'Name
      'Value
      '
      'The [Default] and [Rule] section can only be created by giving both the name
      'and the value (constraint/default).
      '
      'UserDatatype:
      '*************
      'Properties available:
      'Name
      'DataType
      'DataLength
      'DataScale
      'Bind_Default
      'Bind_Rule
      '
      'The UserDatatype name is a mandatory property to declare in the file.
      'And a UserDataType can be created with only a name specified. The
      'other properties are defaulted as follows:
      '
      'DataType = CHAR
      'DataLength = 18
      'And no Default or Rule binding.
      '
      'You can also create a UserDatatype by specifying it's properties explicitly.
      'Of course the DataLength and DataScale depends on the Datatype selected.
      'If they are not supported, then they will not affect the Dictionary object.
      'See the list of Datatypes below ( not case sensitive). You can also specify
      'Defaults and Rules to bind to this UserDatatype. Just specify the names
      '(case-sensitive) for the Bind-Default and Bind_Rule properties. Just leave
      'out the properties that you don't want to declare or reset.
      '
      'Domain:
      '*******
      'Properties available:
      'Name
      'Column
      'DataType
      'DataLength
      'DataScale
      'Bind_Default
      'Bind_Rule
      'Bind_UserDatatype
      'Identity
      'IdentityIncrement
      'IdentitySeed
      'CheckConstraint
      'DeclaredDefault
      '
      'The Domain Name and Column name are mandatory properties to declare in the file.
      'And a Domain can be created with only the Name and Column Name specified. The
      'other properties are defaulted as follows:
      '
      'DataType = CHAR
      'DataLength = 10
      'Identity = 0
      'And no Default,Rule, or UserDatatype bindings.
      '
      'You can also create a Domain by specifying it's properties explicitly.
      'The Identity property takes 0 (False) or 1 (True) as the input value. Of
      'course the properties DataLength, DataScale, Identity, IdentitySeed, and
      'IdentityIncrement all depend on the Datatype selected. If they are not
      'supported, then they will not affect the Dictionary object. See the list
      'of Datatypes below ( not case sensitive). You can also specify Defaults,
      'Rules, and UserDatatypes to bind to this Domain. Just specify the name
      '(case-sensitive) for the Bind-Default, Bind_Rule, Bind_UserDataType properties.
      'There is also another way of specifying constraints and defaults without
      'using inding. Use the CheckConstraint and DeclaredDefault properties to
      'set the constraint and default values. This properties can be used instead
      'of the Bind_Default and Bind_Rule properties. And as usual, just leave out
      'the properties that you don't want to declare or reset.
      '
      'DataTypes For UserDatatype And Domain:
      '**************************************
      'these are the same things you see in the combo box selection when you
      'choose the DataType in the Domain or UserDatatype editors.
      '
      'BINARY
      'BIT
      'CHAR
      'NCHAR
      'DATE
      'DECIMAL
      'DECIMALN
      'DATETIME
      'DATETIMN
      'TEXT
      'FLOATN
      'FLOAT
      'INTEGER
      'INTN
      'IMAGE/LONG BINARY
      'LONG VARCHAR
      'MLSLABEL/VARCHAR
      'MONEY
      'MONEYN
      'NUMERICN
      'NUMERIC
      'PICTURE
      'ROWID/VARCHAR
      'SMALLDATETIME
      'SERIAL/INTEGER
      'REAL/SMALLFLOAT
      'SMALLINT
      'SMALLMONEY
      'TIME/DATETIME
      'TINYINT
      'TIMESTAMP/DATE
      'NTEXT/LONG NVARCHAR
      'NVARCHAR
      'VARCHAR
      'VARBINARY/BLOB
      'COUNTER
      'DOUBLE PRECISION
      'UNIQUEID
      'BIGINT
      '
      '*************************************************************************
      'This macro is used to import Data Dictionary objects from a file.
      'The imported file has to follow a specific format guideline.
      '*************************************************************************
      Sub Main

          'declare needed variables
          Dim diag As Diagram
          Dim ddm As Dictionary
          Dim ipq As FmtRead
          Dim filename As Variant
          Dim nRetHeader As Long
          Dim nRetPair As Long
          Dim csObjName As Variant
          Dim csObjValue As Variant
          Dim csHeader As Variant
          Dim csProperty As Variant
          Dim csValue As Variant

          'define value for important variables
          Set ipq = New FmtRead
          Set diag = DiagramManager.ActiveDiagram
          Set ddm = diag.Dictionary

          'get the filenameto import
          filename = GetFilePath$

          'exit if no filename given
          If filename = "" Then
              MsgBox "No file has been selected. Program is terminating!"
              Exit Sub
          Else
              'variables to indicate that the file is verified
              Dim bFileType As Boolean
              Dim bFileName As Boolean
              bFileType = False
              bFileName = False

              'process the given file
              ipq.ReadFile filename
              ipq.GetNextHeader nRetHeader, csHeader

              'Check for validity of the file
              If nRetHeader <> 0 And csHeader = "[File_Info]" Then
                  ipq.GetNextValuePair nRetPair, csProperty, csValue

                  'extract the actual filename from the full path name
                  'returned by the GetFilePath function
                  Dim csFile As String
                  Dim Idx As Integer
                  csFile = filename
                  Idx = InStrRev(csFile,"\")
                  Idx = Len(csFile) - Idx
                  csFile = Right$(csFile,Idx)

                  'loop through the value pairs and compare with proper values
                  While nRetPair <> 0
                      'do we have the right file type
                      If csProperty = "Type" Then
                          If csValue = "DD_Import" Then
                              bFileType = True
                          End If
                      'do the file name match in the file
                      'info and the getfilepath function
                      ElseIf csProperty = "Name" Then
                          If csValue = csFile Then
                              bFileName = True
                          End If
                      End If
                      ipq.GetNextValuePair nRetPair, csProperty, csValue
                  Wend
              End If

              'file information is verified so import the Data Dictionary objects
              If bFileType = True And bFileName = True Then

                  'indicators if mandatory properties are already given
                  Dim bNameGiven As Boolean
                  Dim bValueGiven As Boolean

                  'loop through all the section headers
                  ipq.GetNextHeader nRetHeader, csHeader
                  While nRetHeader <> 0

                      'these variables has to be reset to false for each loop
                      'through a header and it's accompanying value pairs
                      bNameGiven = False
                      bValueGiven = False

                      'Check for new Defaults
                      If csHeader = "[Default]" Then
                          ipq.GetNextValuePair nRetPair, csProperty, csValue

                          'loop through the defaults value pairs to get the needed property values
                          While nRetPair <> 0
                              If csProperty = "Name" Then
                                  csObjName = csValue
                                  bNameGiven = True
                              ElseIf csProperty = "Value" Then
                                  csObjValue = csValue
                                  bValueGiven = True
                              End If
                              ipq.GetNextValuePair nRetPair, csProperty, csValue
                          Wend

                          'create the new default
                          If bNameGiven = True And bValueGiven = True Then
                              ddm.Defaults.Add(csObjName,csObjValue)
                          Else
                              MsgBox "The given properties for creating a Default were incomplete or some are not valid!" + vbCrLf + "The Default " + _
                                      "with property '" + csProperty + " = " + csValue + "' will not be created!"
                          End If

                      'Check for new Rule
                      ElseIf csHeader = "[Rule]" Then
                          ipq.GetNextValuePair nRetPair, csProperty, csValue

                          'get rule name and value
                          While nRetPair <> 0
                              If csProperty = "Name" Then
                                  csObjName = csValue
                                  bNameGiven = True
                              ElseIf csProperty = "Value" Then
                                  csObjValue = csValue
                                  bValueGiven = True
                              End If
                              ipq.GetNextValuePair nRetPair, csProperty, csValue
                          Wend

                          'create new rule
                          If bNameGiven = True And bValueGiven = True Then
                              ddm.Rules.Add(csObjName,csObjValue)
                          Else
                              MsgBox "The given properties for creating a Rule were incomplete or some are not valid!" + vbCrLf + "The Rule with" + _
                                      " property '" + csProperty + " = " + csValue + "' will not be created!"
                          End If

                      'Check for new UserDatatypes
                      ElseIf csHeader = "[UserDatatype]" Then
                          Dim udt As UserDatatype
                          ipq.GetNextValuePair nRetPair, csProperty, csValue

                          'get UDT name first to enable creation of UDT with default properties
                          If csProperty = "Name" Then
                              bNameGiven = True
                              Set	udt = ddm.UserDatatypes.Add (csValue)
                          Else
                              MsgBox "Error in file format! The Userdatatype name has to be entered first. The UserDatatype" + vbCrLf + _
                                      "with leading property '" + csProperty + " = " + csValue + "' will not be created!"
                          End If

                          'loop through the rest of the UDT properties
                          If bNameGiven = True Then

                              ipq.GetNextValuePair nRetPair, csProperty, csValue

                              While nRetPair <> 0
                                  'call function to set the other given properties
                                  Call Import_UDT_Properties(udt,ddm,csProperty,csValue)
                                  ipq.GetNextValuePair nRetPair, csProperty, csValue
                              Wend

                          End If

                      'Check for new Domain
                      ElseIf csHeader = "[Domain]" Then
                          ipq.GetNextValuePair nRetPair, csProperty, csValue

                          'get domain name and column name first to create a domain with default properties
                          If nRetPair <> 0 And csProperty = "Name" Then
                              csObjName = csValue
                              bNameGiven = True

                              'get column name
                              ipq.GetNextValuePair nRetPair, csProperty, csValue
                              If nRetPair <> 0 And csProperty = "Column"  And bNameGiven = True Then
                                  csObjValue = csValue
                                  bValueGiven = True
                              Else
                                  MsgBox "Error in file format! The Domain column name"+ vbCrLf +"has to be entered before the other" + _
                                          " properties." + vbCrLf + " The domain '" + csObjName + "' will not be created!"
                              End If
                          Else
                                  MsgBox "Error in file format! The Domain name has to be entered first. The domain" + vbCrLf + "with leading" + _
                                          " property '" + csProperty + " = " + csValue + "' will not be created!"
                          End If

                          'create the domain with defaulted properties
                          Dim dom As Domain
                          If bNameGiven = True And bValueGiven = True Then
                              Set dom = ddm.Domains.Add (csObjName,csObjValue)

                              'now loop through the rest of the Domain properties
                              ipq.GetNextValuePair nRetPair, csProperty, csValue

                              While nRetPair <> 0
                                  'call function to set the other given properties
                                  Call Import_Domain_Properties(dom,ddm,csProperty,csValue)
                                  ipq.GetNextValuePair nRetPair, csProperty, csValue
                              Wend
                          End If

                      End If

                      'next header to process
                      ipq.GetNextHeader nRetHeader, csHeader
                  Wend
              Else
                  MsgBox "The file information section [File_Info] is missing from the beginning" + vbCrLf + _
                          "of the file, or it has invalid entries. The import function failed!"
              End If
          End If
      End Sub

      '*************************************************************************
      'This function sets the optional properties of UserDatatypes
      'that can be specified in the import file.
      '*************************************************************************
      Sub Import_UDT_Properties(udt As UserDatatype, ddm As Dictionary, csProperty As Variant, csValue As Variant)

          Dim num As Integer
          Dim def As Default
          Dim rl As Rule
          Dim nId As Integer
          nId = 0

          If csProperty = "Name" Then
              MsgBox "The name for UserDatatype " + udt.Name + " cannot be reset!"
          ElseIf csProperty = "DataType" Then
              udt.Datatype = csValue
          ElseIf csProperty = "DataLength" Then
              num = Val(csValue)
              udt.DataLength = num
          ElseIf csProperty = "DataScale" Then
              num = Val(csValue)
              udt.DataScale = num
          ElseIf csProperty = "Bind_Default" Then
              'get the default ID to use for declaring the binding default
              For Each def In ddm.Defaults
                  If def.Name = csValue Then	nId = def.ID
              Next def

              'default not found popup error message
              If nId = 0 Then
                  MsgBox "UserDatatype '" + udt.Name + "' cannot bind to the given default!" + vbCrLf + _
                          "The specified Default name '" + csValue + "' does not exist!"
              End If

              'set the binding ( zero is default)
              udt.DefaultId = nId
          ElseIf csProperty = "Bind_Rule" Then
              'get the rule ID to use for declaring the binding rule
              For Each rl In ddm.Rules
                  If rl.Name = csValue Then	nId = rl.ID
              Next rl

              'rule not found popup error message
              If nId = 0 Then
                  MsgBox "UserDatatype '" + udt.Name + "' cannot bind to the given rule!"+ vbCrLf + _
                          "The specified Rule name '" + csValue + "' does not exist!"
              End If

              'set the binding ( zero is default)
              udt.RuleId = nId
          Else
              MsgBox "The UserDatatype property '" + csProperty + " = " + csValue + "'" + "is unknown!"
          End If

      End Sub

      '*************************************************************************
      'This function sets the optional properties of Domain
      'that can be specified in the import file.
      '*************************************************************************
      Sub Import_Domain_Properties(dom As Domain, ddm As Dictionary, csProperty As Variant, csValue As Variant)

          Dim num As Integer
          Dim bIdentity As Boolean
          Dim def As Default
          Dim rl As Rule
          Dim udt As UserDatatype
          Dim nId As Integer
          nId = 0

          'see which property has to be set
          If csProperty = "Name" Or csProperty = "Column" Then
              MsgBox "The name or column name for Domain " + dom.Name + " cannot be reset!"
          ElseIf csProperty = "DataType" Then
              dom.Datatype = csValue
          ElseIf csProperty = "DataLength" Then
              num = Val(csValue)
              dom.DataLength = num
          ElseIf csProperty = "DataScale" Then
              num = Val(csValue)
              dom.DataScale = num
          ElseIf csProperty = "Bind_Default" Then
              'get the default ID to use for declaring the binding default
              For Each def In ddm.Defaults
                  If def.Name = csValue Then	nId = def.ID
              Next def

              'default not found popup error message
              If nId = 0 Then
                  MsgBox "Domain '" + dom.Name + "' cannot bind to the given default!" + vbCrLf + _
                          "The specified Default name '" + csValue + "' does not exist!"
              End If

              'set the binding ( zero is default)
              dom.DefaultId = nId
          ElseIf csProperty = "Bind_Rule" Then
              'get the rule ID to use for declaring the binding rule
              For Each rl In ddm.Rules
                  If rl.Name = csValue Then	nId = rl.ID
              Next rl

              'rule not found popup error message
              If nId = 0 Then
                  MsgBox "Domain '" + dom.Name + "' cannot bind to the given rule!"+ vbCrLf + _
                          "The specified Rule name '" + csValue + "' does not exist!"
              End If

              'set the binding ( zero is default)
              dom.RuleId = nId
          ElseIf csProperty = "Bind_UserDatatype" Then

              'get the UserDatatype ID to use for declaring the binding UserDatatype
              For Each udt In ddm.UserDatatypes
                  If udt.Name = csValue Then	nId = udt.ID
              Next udt

              'udt not found popup error message
              If nId = 0 Then
                  MsgBox "Domain '" + dom.Name + "' cannot bind to the given userdatatype!" + vbCrLf + _
                          "The specified UserDatatype name '"+ csValue + "' does not exist!"
              End If

              'set the binding ( zero is default)
              dom.UserDatatypeId = nId
          ElseIf csProperty = "CheckConstraint" Then
              'set user-defined constraint
              dom.CheckConstraint = csValue
          ElseIf csProperty = "DeclaredDefault" Then
              'set user-defined default
              dom.DeclaredDefault = csValue
          ElseIf csProperty = "Identity" Then
              bIdentity = Val(csValue)
              dom.Identity = bIdentity
          ElseIf csProperty = "IdentityIncrement" Then
              If dom.Identity = True Then
                  num = Val(csValue)
                  dom.IdentityIncrement = num
              End If
          ElseIf csProperty = "IdentitySeed" Then
              If dom.Identity = True Then
                  num = Val(csValue)
                  dom.IdentitySeed = num
              End If
          Else
              MsgBox "The Domain property '" + csProperty + " = " + csValue + "'" + "is unknown!"
          End If

      End Sub


Index Naming.BAS

      'TITLE:  INDEX NAMING.BAS
      'DESCRIPTION:  This macro can be used to apply naming conventions to
      '	all types of indexes.  It provides an option to use the selected
      '	tables or all tables.
      '	The prefix and suffix variables can be used to add company
      '	specific conventions to the beginning and/or end of the target
      '	name.
      '	The target name can be either the existing name, table name,
      '	tablespace name or database name.  The tablespace and database
      '	can only be used for applicable platforms such as Oracle or
      '	DB2.
      '	Truncate parameters can also be specified to remove the first N
      '	characters or the last N characters of the target name.  Another
      '	parameter can also be used to limit the total number of characters
      '	in the target name.  These are applied before the prefix and
      '	suffix are added.

      'ER/Studio variables
      Dim mdl As Model
      Dim diag As Diagram
      Dim indx As Index
      Dim ent As Entity
      Dim submdl As SubModel
      Dim so As SelectedObject

      'truncate variables
      Dim starttrunc As Integer
      Dim endtrunc As Integer
      Dim totaltrunc As Integer
      Dim inistarttrunc As String
      Dim iniendtrunc As String
      Dim initotaltrunc As String

      'Dialog variables
      Dim BaseName As String
      Dim basenametype As Integer
      Dim prefix As String
      Dim suffix As String
      Dim IndexType As String
      Dim addincrement As Boolean
      Dim usetruncate As Boolean
      Dim looptype As Integer
      Dim IncrementType As Integer

      Dim errorstring As String

      Sub Main

          Debug.Clear

          Dim IndxName As String
          Dim i As Integer

          inistarttrunc = "0"
          iniendtrunc = "0"
          initotaltrunc = "ALL"

          Begin Dialog UserDialog 520,406,"Index Naming Convention",.dialogfunction ' %GRID:10,7,1,1
              OKButton 300,364,90,28
              CancelButton 410,364,90,28
              Text 40,266,90,14,"Suffix",.Text1
              Text 40,231,90,14,"Prefix",.Text2
              GroupBox 20,63,450,49,"Index Type",.Groupbox
              OptionGroup .IndexChoice
                  OptionButton 40,84,90,14,"Primary",.OptionButton2
                  OptionButton 140,84,90,14,"Unique",.OptionButton1
                  OptionButton 250,84,120,14,"Non Unique",.OptionButton3
                  OptionButton 380,84,60,14,"All",.OptionButton10
              GroupBox 20,119,480,77,"Using",.GroupBox2
              OptionGroup .NameChoice
                  OptionButton 80,140,170,14,"Existing Name",.OptionButton9
                  OptionButton 80,168,160,14,"Tablespace Name",.OptionButton5
                  OptionButton 280,168,130,14,"Database Name",.OptionButton6
                  OptionButton 280,140,110,14,"Table Name",.OptionButton4
              TextBox 120,224,90,21,.Prefix
              TextBox 120,259,90,21,.Suffix
              CheckBox 30,301,230,21,"Add Increment at end of name",.increment
              PushButton 310,238,150,28,"Truncate Parameters",.truncate
              OptionGroup .loopChoice
                  OptionButton 40,14,140,14,"Selected Objects",.OptionButton7
                  OptionButton 40,35,100,14,"All Objects",.OptionButton8
              Text 70,322,190,14,"(Duplicate Indexes on table)",.Text3
              CheckBox 290,210,190,14,"Use truncate parameters",.truncparam
              PushButton 310,280,150,28,"Preview Names",.Preview
              CheckBox 20,378,260,14,"Save errors to C:\IXnameslog.txt",.errorlog
              OptionGroup .incrementtype
                  OptionButton 90,343,90,14,"Numeric",.OptionButton11
                  OptionButton 90,357,110,14,"Alphabetical",.OptionButton12
          End Dialog

          Dim dlg As UserDialog

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          If Dialog(dlg) = -1 Then

              basenametype = dlg.namechoice
              Debug.Print "basenametype: " & basenametype
              prefix = dlg.prefix
              Debug.Print "Prefix: " & prefix
              suffix = dlg.suffix
              Debug.Print "Suffix: " & suffix
              addincrement = dlg.increment
              Debug.Print "addincrement: " & addincrement
              usetruncate = dlg.truncparam
              Debug.Print "usetruncate: " & usetruncate
              looptype = dlg.loopchoice
              Debug.Print "looptype: " & looptype
              IncrementType = dlg.incrementtype
              Debug.Print "incrementtype: " & IncrementType

              Select Case dlg.indexchoice
              Case 0
                  IndexType = "P"
              Case 1
                  IndexType = "A"
              Case 2
                  IndexType = "I"
              Case 3
                  IndexType = "N"
              End Select

              Debug.Print "IndexType: " & IndexType

              If looptype = 0 Then

                  For Each so In submdl.SelectedObjects

                      If so.Type = 1 Then

                          Set ent = mdl.Entities.Item(so.ID)

                          i = 1

                          For Each indx In ent.Indexes

                              If IndexType = "N" Then
                                  GoTo SKIP
                              End If

                              If indx.KeyType = IndexType Then

                              SKIP:

                              IndxName = ""

                              Select Case basenametype

                              Case 0

                                  IndxName = NameIndex(indx.Name, i)

                              Case 1

                                  If ent.StorageLocation = "" Then

                                      errorstring = errorstring & "Tablespace field for " & ent.TableName & " is blank." & vbCrLf
                                      errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                                  Else

                                      IndxName = NameIndex(ent.StorageLocation, i)

                                  End If

                              Case 2

                                  If ent.DatabaseLocation = "" Then

                                      errorstring = errorstring & "Database field for " & ent.TableName & " is blank." & vbCrLf
                                      errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                                  Else

                                      IndxName = NameIndex(ent.DatabaseLocation, i)

                                  End If

                              Case 3

                                  IndxName = NameIndex(ent.TableName, i)

                              End Select

                              If addincrement = True Then

                                  i = i + 1

                              Else

                                  IndxName = IndxName

                              End If

                              indx.Name = IndxName

                              End If

                          Next

                      End If

                  Next

              Else

                  For Each ent In mdl.Entities

                      i = 1

                      For Each indx In ent.Indexes

                          If IndexType = "N" Then
                              GoTo SKIP1
                          End If

                          If indx.KeyType = IndexType Then

                          SKIP1:

                          IndxName = ""

                          Select Case basenametype

                          Case 0

                              IndxName = NameIndex(indx.Name, i)

                          Case 1

                              If ent.StorageLocation = "" Then

                                  errorstring = errorstring & "Tablespace field for " & ent.TableName & " is blank." & vbCrLf
                                  errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                              Else

                                  IndxName = NameIndex(ent.StorageLocation, i)

                              End If

                          Case 2

                              If ent.DatabaseLocation = "" Then

                                  errorstring = errorstring & "Database field for " & ent.TableName & " is blank." & vbCrLf
                                  errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                              Else

                                  IndxName = NameIndex(ent.DatabaseLocation, i)

                              End If

                          Case 3

                                  IndxName = NameIndex(ent.TableName, i)

                          End Select

                          If addincrement = True Then

                              i = i + 1

                          Else

                              IndxName = IndxName

                          End If

                          indx.Name = IndxName

                          End If

                      Next

                  Next

              End If

              If dlg.errorlog = 1 Then

                  Open "C:\IXnameslog.txt" For Output As #1
                  Print #1, errorstring
                  Close #1

              End If

          End If

      End Sub

      Function NameIndex (bname As String, i As Integer) As String

          Dim IXname As String

          IXname = bname

          If usetruncate = True Then

              If starttrunc <> 0  And Len(IXname) > starttrunc Then

                  IXname = Right(IXname, Len(IXname) - starttrunc)

              End If

              If endtrunc <> 0 And Len(IXname) > endtrunc Then

                  IXname = Left(IXname, Len(IXname) - endtrunc)

              End If

              If totaltrunc <> 0 And Len(IXname) > totaltrunc Then

                  IXname = Left(IXname, totaltrunc)

              End If

          End If

          If prefix <> "" Then

              IXname = prefix & IXname

          End If

          If addincrement = True Then

              If IncrementType = 0 Then

                  IXname = IXname & i

              Else

                  Dim num As Integer

                  num = 64 + i
                  Debug.Print num

                  IXname = IXname & Chr(num)

              End If

          End If

          If suffix <> "" Then

              IXname = IXname & suffix

          End If

          NameIndex = IXname

      End Function

      Rem See DialogFunc help topic for more information.
      Private Function dialogfunction(DlgItem$, Action%, SuppValue&) As Boolean

          Dim platform As String

          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "truncate" Then

                  Begin Dialog UserDialog 410,245,"Truncate Options",.truncHandler ' %GRID:10,7,1,1
                      TextBox 280,56,90,21,.starttrunc
                      TextBox 280,98,90,21,.endtrunc
                      TextBox 280,140,90,21,.totaltrunc
                      Text 50,14,290,28,"Note:  These operations will be performed before the prefix and suffix are added.",.Text1
                      Text 20,56,240,28,"Specify number of chars to remove from START of target name.",.Text2
                      Text 20,98,220,28,"Specify number of chars to remove at the END of target name.",.Text3
                      Text 20,140,230,28,"Specify number of chars to use in target name. (total, after truncating)",.Text4
                      OKButton 150,203,100,28
                      Text 60,168,300,21,"(ALL, or number of characters starting from left)",.Text5
                  End Dialog
                  Dim dlg As UserDialog

                  'defaults for truncate variables
                  dlg.starttrunc = inistarttrunc
                  dlg.endtrunc = iniendtrunc
                  dlg.totaltrunc = initotaltrunc

                  Dialog dlg

                  If dlg.endtrunc = "" Then
                      endtrunc = 0
                  Else
                      endtrunc = CStr(dlg.endtrunc)
                  End If

                  If dlg.starttrunc = "" Then
                      starttrunc = 0
                  Else
                      starttrunc = CStr(dlg.starttrunc)
                  End If

                  If dlg.totaltrunc = "ALL" Or dlg.totaltrunc = "" Then
                      totaltrunc = 0
                  Else
                      totaltrunc = CStr(dlg.totaltrunc)
                  End If

                  dialogfunction = True

              ElseIf DlgItem = "Preview" Then

                  platform = Left(mdl.DatabasePlatform, 14)

                  If mdl.Logical = True And DlgValue("NameChoice") > 0 And DlgValue("NameChoice") < 3 Then

                      MsgBox("Tablespace and Database Names in Using option is only for physical models.",,"Error!")
                      dialogfunction = True

                  ElseIf platform <> "IBM DB2 OS/390" And DlgValue("NameChoice") = 2 Then

                      MsgBox("Database Name in Using option is only for OS390 physical models.",,"Error!")
                      dialogfunction = True

                  Else

                      basenametype= DlgValue("NameChoice")
                      prefix = DlgText("Prefix")
                      suffix = DlgText("Suffix")
                      addincrement = DlgValue("increment")
                      usetruncate = DlgValue("truncparam")
                      looptype = DlgValue("loopChoice")
                      IncrementType = DlgValue("incrementtype")

                      Select Case DlgValue("IndexChoice")
                      Case 0
                          IndexType = "P"
                      Case 1
                          IndexType = "A"
                      Case 2
                          IndexType = "I"
                      Case 3
                          IndexType = "N"
                      End Select

                      Begin Dialog UserDialog 400,273,"Index Names",.NamesHandler ' %GRID:10,7,1,1
                          TextBox 30,14,350,217,.IndxNames,1
                          OKButton 140,245,90,21
                      End Dialog
                      Dim dlgNames As UserDialog

                      Dialog dlgNames
                      dialogfunction = True

                  End If

              ElseIf DlgItem = "OK" Then

                  platform = Left(mdl.DatabasePlatform, 14)

                  If mdl.Logical = True And DlgValue("NameChoice") > 0 And DlgValue("NameChoice") < 3 Then

                      MsgBox("Tablespace and Database Names in Using option is only for physical models.",,"Error!")
                      dialogfunction = True

                  ElseIf platform <> "IBM DB2 OS/390" And DlgValue("NameChoice") = 2 Then

                      MsgBox("Database Name in Using option is only for OS390 physical models.",,"Error!")
                      dialogfunction = True

                  End If

              End If
              Rem dialogfunction = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem dialogfunction = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      Rem See DialogFunc help topic for more information.
      Private Function NamesHandler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

              Dim i As Integer

              If looptype = 0 Then

                  For Each so In submdl.SelectedObjects

                      If so.Type = 1 Then

                          Set ent = mdl.Entities.Item(so.ID)

                          i = 1

                          For Each indx In ent.Indexes

                              If IndexType = "N" Then
                                  GoTo SKIP
                              End If

                              If indx.KeyType = IndexType Then

                              SKIP:

                              IndxName = ""

                              Select Case basenametype

                              Case 0

                                  IndxName = NameIndex(indx.Name, i)

                              Case 1

                                  If ent.StorageLocation = "" Then

                                      errorstring = errorstring & "Tablespace field for " & ent.TableName & " is blank." & vbCrLf
                                      errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                                  Else

                                      IndxName = NameIndex(ent.StorageLocation, i)

                                  End If

                              Case 2

                                  If ent.DatabaseLocation = "" Then

                                      errorstring = errorstring & "Database field for " & ent.TableName & " is blank." & vbCrLf
                                      errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                                  Else

                                      IndxName = NameIndex(ent.DatabaseLocation , i)

                                  End If

                              Case 3

                                  IndxName = NameIndex(ent.TableName, i)

                              End Select

                              If addincrement = True Then

                                  i = i + 1

                              Else

                                  IndxName = IndxName

                              End If

                              DlgText "IndxNames", DlgText("IndxNames") & IndxName & vbCrLf

                              End If

                          Next

                      End If

                  Next

              Else

                  For Each ent In mdl.Entities

                      i = 1

                      For Each indx In ent.Indexes

                          If IndexType = "N" Then
                              GoTo SKIP2
                          End If

                          If indx.KeyType = IndexType Then

                          SKIP2:

                          IndxName = ""

                          Select Case basenametype

                          Case 0

                              IndxName = NameIndex(indx.Name, i)

                          Case 1

                              If ent.StorageLocation = "" Then

                                  errorstring = errorstring & "Tablespace field for " & ent.TableName & " is blank." & vbCrLf
                                  errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                              Else

                                  IndxName = NameIndex(ent.StorageLocation, i)

                              End If

                          Case 2

                              If ent.DatabaseLocation = "" Then

                                  errorstring = errorstring & "Database field for " & ent.TableName & " is blank." & vbCrLf
                                  errorstring = errorstring & vbTab & "Index: " & ent.TableName & "." & indx.Name & " name not changed." & vbCrLf

                              Else

                                  IndxName = NameIndex(ent.DatabaseLocation, i)

                              End If

                          Case 3

                                  IndxName = NameIndex(ent.TableName, i)

                          End Select

                          If addincrement = True Then

                              i = i + 1

                          Else

                              IndxName = IndxName

                          End If

                          DlgText "IndxNames", DlgText("IndxNames") & IndxName & vbCrLf

                          End If

                      Next

                  Next

              End If

          Case 2 ' Value changing or button pressed
              Rem NamesHandler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem NamesHandler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      Rem See DialogFunc help topic for more information.
      Private Function truncHandler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

                  'defaults for truncate variables
                  DlgText "starttrunc", inistarttrunc
                  DlgText "endtrunc", iniendtrunc
                  DlgText "totaltrunc", initotaltrunc

          Case 2 ' Value changing or button pressed

                  If DlgItem = "OK" Then

                      inistarttrunc = DlgText("starttrunc")
                      iniendtrunc = DlgText("endtrunc")
                      initotaltrunc = DlgText("totaltrunc")

                  End If
              Rem truncHandler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem truncHandler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Insert Synonym in PostSQL.bas

      'MACRO TITLE:  INSERT ORACLE SYNONYM IN POSTSQL.BAS
      'DESCRIPTION:  This Macro will add a Synonym to a specified table/view.
      'The macro will prompt the user with a dialog to choose the table/view.
      'The synonym code will be inserted into the PostSQL of the specified
      'table/view.

      Sub Main
          Dim MyModel As Model
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim MyView As View
          Dim Synonym As String

          'Current Model has to be physical

          'set ER variables
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel

          If MyModel.Logical = True Then

              MsgBox("Current Model has to be Physical.")

          ElseIf MyModel.MajorPlatform <> "Oracle 7/8" Then
              MsgBox ("Current model has to be Oracle 7/8 platform.")

          Else

          'initialize ObjectArray that holds tables and views
          'for the Dialog list
          Dim ObjectCount As Integer

          ObjectCount = MyModel.Entities.Count + MyModel.Views.Count

          ReDim ObjectArray( 0 To ObjectCount ) As String

          Dim count As Integer

          count = 0

          'insert tables and views into the ObjectArray for the dialog list
          For Each MyEntity In MyModel.Entities
              ObjectArray(count) = MyEntity.EntityName
              count = count + 1
          Next

          For Each MyView In MyModel.Views
              ObjectArray(count) = MyView.Name
              count = count + 1
          Next

          Begin Dialog UserDialog 510,224,"Synonym Editor" ' %GRID:10,7,1,1
              GroupBox 20,7,470,161,"Choose the Table or View that you would like to create a synonym for:",.GroupBox1
              CancelButton 350,182,130,28
              DropListBox 40,28,220,168,ObjectArray(),.ObjectList
              OKButton 200,182,130,28
              TextBox 40,140,220,21,.SynName
              OptionGroup .Group1
                  OptionButton 40,91,60,14,"Yes",.yes
                  OptionButton 110,91,60,14,"No",.no
              Text 30,70,430,14,"Do you want the Synonym accessible to all users (ie, PUBLIC)?",.Text2
              Text 30,119,370,14,"Please give a name for your synonym.",.Text1
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

              If dlg.group1 = 0 Then

                  Synonym = "CREATE PUBLIC SYNONYM " & dlg.SynName & vbCrLf
                  Synonym = Synonym & vbTab & "FOR " & ObjectArray(dlg.objectlist) & vbCrLf & ";" & vbCrLf

              Else

                  Synonym = "CREATE SYNONYM " & dlg.SynName & vbCrLf
                  Synonym = Synonym & vbTab & "FOR " & ObjectArray(dlg.objectlist) & vbCrLf & ";" & vbCrLf

              End If

              Dim ObjName As String

              ObjName = ObjectArray(dlg.objectlist)

              Set MyEntity = MyModel.Entities.Item(ObjName)
              Set MyView = MyModel.Views.Item(ObjName)

              If MyView Is Nothing Then

                  MyEntity.PostSQL = MyEntity.PostSQL & Synonym

              Else

                  MyView.PostSQL = MyView.PostSQL & Synonym

              End If

          End If 'dialog

          End If 'Physical check

      End Sub


Name Foreign Constraints.BAS

      'TITLE:  NAME FOREIGN CONSTRAINTS
      'DESCRIPTION:  This macro will prompt the user with a dialog to
      'specify the naming convention for Foreign Constraints.  It will
      'then name all the constraints using the parent and child table names.
      'It will also make sure the name is unique by adding an index for the
      'last characters of duplicate names.
      'INPUT:
      '	MAXIMUM CHARACTERS:  This is the max limit of the number of characters
      '	For the entire constraint Name.  Not required.  Can be specified even if
      ' 	truncation option is None.
      '	TRUNCATE NUMBER:  This limits the number of characters in both the parent and
      '	child part of the relationship to the number specified.
      '	PREFIX:  This is the prefix for the relationship name
      '	SEPARATOR:  This goes between the parent and child part of the relatioship name.
      '	SUFFIX:  This is the suffix for the relationship name.
      'CREATE DATE:  11/19/2000
      'LAST UPDATE:  1/4/2002

      Sub Main
          Dim ParTable As String
          Dim chiTable As String
          Dim separator As String
          Dim prefix As String
          Dim sufix As String
          Dim mdl As Model
          Dim diag As Diagram
          Dim truncation As Integer
          Dim maxchs As Integer
          Dim relation As Relationship
          Dim RName As String
          Dim C As Integer
          Dim ind As Integer
          Dim suf As String

          ' set er variables
          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          Begin Dialog UserDialog 660,350,"Foreign Constraint Naming Macro" ' %GRID:10,7,1,1
              Text 50,21,90,14,"Order:",.Text1
              CheckBox 150,203,90,14,"P&refix:",.chbxPrefix
              CheckBox 150,259,90,14,"&Suffix:",.chbxSuffix
              CheckBox 150,231,100,14,"S&eparator:",.chbxseparator
              Text 50,84,160,14,"Truncation:",.Text2
              Text 50,182,90,14,"Additions:",.Text3
              OptionGroup .Order
                  OptionButton 270,35,160,14,"&Parent Then Child",.OptionButton1
                  OptionButton 270,56,140,14,"&Child Then Parent",.OptionButton2
                  OptionButton 130,35,110,14,"Parent Only",.OptionButton5
                  OptionButton 130,56,90,14,"Child Only",.OptionButton6
              OptionGroup .Trunc
                  OptionButton 80,140,90,14,"&None",.OptionButton3
                  OptionButton 80,161,400,14,"&Use only this many characters of the Parent or Child name:",.OptionButton4
              TextBox 490,154,90,21,.numchars
              TextBox 310,196,90,21,.prefix
              TextBox 310,224,90,21,.separator
              TextBox 310,252,90,21,.suffix
              OKButton 330,301,120,28
              CancelButton 470,301,120,28
              Text 160,98,260,14,"Max characters for entire FK name:",.Text5
              TextBox 490,112,90,21,.MaxChars
              Text 160,119,310,14,"(Can be specified even when checking ""None"".)",.Text4
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

              'declare an array to check for duplictate relations
              C = mdl.Relationships.Count
              ReDim Rships(1 To C) As String
              Dim rels As Variant
              rels = Rships
              ind = 1

              For Each relation In mdl.Relationships

                  ParTable = relation.ParentEntity.TableName
                  chiTable = relation.ChildEntity.TableName

                  'Remove spaces from table names
                  ParTable = Replace(ParTable," ","")
                  chiTable = Replace(chiTable," ","")

                  If dlg.trunc = 1 And dlg.numchars <> Empty Then	'truncate Left

                      'truncate names of tables
                      truncate = Abs(CInt(dlg.numchars))
                      ParTable = Left(ParTable, truncate)
                      chiTable = Left(chiTable, truncate)

                  End If

                  prefix = dlg.prefix
                  suffix = dlg.suffix
                  separator = dlg.separator

                  'choose order, O = parent first, 1 = child first, 2 = parent only, 3 = child only
                  If dlg.Order = 0 Then

                      'Additions
                      RName = ""
                      'Add prefix if option is checked
                      If dlg.chbxprefix = 1 Then
                          RName = prefix
                      End If

                      RName = RName & ParTable

                      'Add separator if option is checked
                      If dlg.chbxseparator Then
                          RName = RName & separator
                      End If

                      RName = RName & chiTable

                      'Add suffix if option is checked
                      If dlg.chbxsuffix Then
                          RName = RName & suffix
                      End If

                  ElseIf dlg.order = 1 Then

                      'Additions
                      RName = ""

                      'Add prefix if option is checked
                      If dlg.chbxprefix = 1 Then
                          RName = prefix
                      End If

                      RName = RName & chiTable

                      'Add separator if option is checked
                      If dlg.chbxseparator = 1 Then
                          RName = RName & separator
                      End If

                      RName = RName & ParTable

                      'Add suffix if option is checked
                      If dlg.chbxsuffix = 1 Then
                          RName = RName & suffix
                      End If

                  ElseIf dlg.order = 2 Then

                      RName = ""

                      'Add prefix if option is checked
                      If dlg.chbxprefix = 1 Then
                          RName = prefix
                      End If

                      RName = RName & ParTable

                      'Add prefix if option is checked
                      If dlg.chbxsuffix = 1 Then
                          RName = RName & suffix
                      End If

                  Else 'dlg.order = 3

                      RName = ""

                      'add prefix if option is checked
                      If dlg.chbxprefix = 1 Then
                          RName = prefix
                      End If

                      RName = RName & chiTable

                      'add suffix if option is checked
                      If dlg.chbxsuffix = 1 Then
                          RName = RName & suffix
                      End If

                  End If

                  'truncate Name to max chars specified
                  If dlg.maxchars <> Empty Then
                      maxchs = Abs(CInt(dlg.maxchars))
                      RName = Left(RName, maxchs)
                  End If

                  'check if there is duplicate and change last couple characters
                  If checkdups(rels, RName, ind) = True Then

                      'add unique index to last of the relationship name
                      suf = Str(ind)
                      RName = Left(RName,(Len(RName) - Len(suf)))
                      RName = RName & suf
                      RName = Replace(RName," ","")

                  End If

                  relation.Name = RName
                  rels(ind) = RName
                  ind = ind + 1

              Next relation

          End If ' dialog

      End Sub

      Function checkdups ( R As Variant, RelName As String, C As Integer ) As Boolean

          Dim flag As Boolean

          flag = False

          For i = 1 To C
              If R(i) = RelName Then
                  flag = True
              End If
          Next i

          checkdups = flag
      End Function


Name Primary Constraints.BAS

      'TTTLE:  NAME PRIMARY CONSTRAINTS
      'DESCRIPTION:  This macro will name all primary key constraints
      '	with the given naming conventions.  The table name with either
      '	a prefix or suffix.

      Sub Main
          Dim MyModel As Model
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim NewName As String
          Dim MyIndex As Index

          ' set ER variables
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel

          Begin Dialog UserDialog 310,196,"PK Naming Macro" ' %GRID:10,7,1,1
              Text 50,14,210,28,"Choose Prefix, Suffix or Default (default is PK_)",.Text1
              OKButton 30,154,110,21
              CancelButton 180,154,110,21
              OptionGroup .namingconvention
                  OptionButton 50,56,90,14,"Default",.default
                  OptionButton 50,77,110,14,"Prefix",.prefixorsuffix
                  OptionButton 50,98,90,14,"Suffix",.OptionButton1
              TextBox 160,119,110,21,.Prefix
              Text 50,126,90,14,"Prefix/Suffix:",.Text2
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

          'loop through all entities
          For Each MyEntity In MyModel.Entities
              For Each MyIndex In MyEntity.Indexes

                  ' make sure index/constraint is a primary key
                  If MyIndex.IsPK = True Then

                      ' use naming convention specified in the dialog
                      If dlg.namingconvention = 0 Then
                          MyIndex.Name = "PK_" + MyEntity.TableName
                      ElseIf dlg.namingconvention = 1 Then
                          MyIndex.Name = dlg.prefix & MyEntity.TableName
                      Else
                          MyIndex.Name = MyEntity.TableName & dlg.prefix
                      End If

                  End If

              Next MyIndex
          Next MyEntity

          End If

      End Sub


Selectively Add DB2 Permissions to PostSQL.BAS

      'TITLE: SELECTIVELY ADD DB2 PERMISSIONS TO POSTSQL.BAS
      'DESCRIPTION:  This macro will add permissions to the PostSQL of
      '              any selected table in an DB2 physical model.
      'AUTHOR: Jason Tiret
      'DATE:  2/2/2000

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim MyModel As Model
          Dim MySelObj As SelectedObject
          Dim MySubModel As SubModel
          Dim grant As String
          Dim ID As Integer
          Dim MyView As View
          Dim ObjectName As String

          'Set ERStudio variable
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel
          Set MySubModel = MyModel.ActiveSubModel

          'create dialog
          Begin Dialog UserDialog 400,392,"GRANT Statement Options" ' %GRID:10,7,1,1
              Text 30,28,130,14,"Specify User/Role:",.Text1
              TextBox 190,21,160,21,.usertxt
              Text 20,84,140,14,"Choose Permissions:",.Text2
              CheckBox 60,112,120,14,"INSERT",.InsertChbx
              CheckBox 60,140,110,14,"UPDATE",.UpdateChbx
              CheckBox 60,196,110,14,"ALTER",.AlterChbx
              CheckBox 60,224,110,14,"DELETE",.DeleteChbx
              CheckBox 60,168,120,14,"SELECT",.SelectChbx
              CheckBox 200,112,160,14,"With Grant Option",.InsWithGrantChbx
              CheckBox 200,140,150,14,"With Grant Option",.UpdWithGrantChbx
              CheckBox 200,168,150,14,"With Grant Option",.SelWithGrantChbx
              CheckBox 200,196,150,14,"With Grant Option",.AltWithGrantChbx
              CheckBox 200,224,150,14,"With Grant Option",.DelWithGrantChbx
              OKButton 40,350,140,21
              CancelButton 210,350,140,21
              CheckBox 60,252,120,14,"CONTROL",.ControlChbx
              CheckBox 60,280,120,14,"REFERENCES",.referencesChbx
              CheckBox 60,308,110,14,"INDEX",.IndexChbx
              CheckBox 200,252,150,14,"With Grant Option",.ConWithGrantChbx
              CheckBox 200,280,150,14,"With Grant Option",.RefWithGrantChbx
              CheckBox 200,308,160,14,"With Grant Option",.IndWithGrantChbx
              OptionGroup .UserChoice
                  OptionButton 30,56,120,14,"Not Specified",.OptionButton1
                  OptionButton 170,56,80,14,"USER",.OptionButton2
                  OptionButton 270,56,90,14,"GROUP",.OptionButton3
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

              For Each MySelObj In MySubModel.SelectedObjects

                  'make sure selected object is an Entity
                  If MySelObj.Type = 1 Or MySelObj.Type = 16 Then

                      ID = MySelObj.ID

                      If MySelObj.Type = 1 Then

                          Set MyEntity = MyModel.Entities.Item(ID)
                          ObjectName = MyEntity.TableName

                      ElseIf MySelObj.Type = 16 Then

                          Set MyView = MyModel.Views.Item(ID)
                          ObjectName = MyView.Name

                      End If

                      'Add insert grant
                      If dlg.insertchbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = "GRANT INSERT ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = "GRANT INSERT ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = "GRANT INSERT ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.Inswithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'Add Alter grant
                      If dlg.alterchbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT ALTER ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT ALTER ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT ALTER ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.altwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'Add update grant
                      If dlg.updatechbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT UPDATE ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT UPDATE ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT UPDATE ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.updwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add select grant
                      If dlg.selectchbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT SELECT ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT SELECT ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT SELECT ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.selwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add delete grant
                      If dlg.deletechbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT DELETE ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT DELETE ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT DELETE ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.delwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add control grant
                      If dlg.controlchbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT CONTROL ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT CONTROL ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT CONTROL ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.conwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add references grant
                      If dlg.referenceschbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT REFERENCES ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT REFERENCES ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT REFERENCES ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.Refwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add index grant
                      If dlg.indexchbx = 1 Then

                          Select Case dlg.userchoice

                          Case 0
                              grant = grant & "GRANT INDEX ON " & ObjectName & " TO " & dlg.usertxt
                          Case 1
                              grant = grant & "GRANT INDEX ON " & ObjectName & " TO USER " & dlg.usertxt
                          Case 2
                              grant = grant & "GRANT INDEX ON " & ObjectName & " TO GROUP " & dlg.usertxt
                          End Select

                          If dlg.indwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      End If 'Selected Objects

                      If MySelObj.Type = 1 Then

                          MyEntity.PostSQL = MyEntity.PostSQL & grant

                      ElseIf MySelObj.Type = 16 Then

                          MyView.PostSQL = MyView.PostSQL & grant

                      End If

                      grant = ""

                      Next

          End If 'Dialog

      End Sub


Selectively Add MS SQL Permissions to PostSQL.bas

      'TITLE: SELECTIVELY ADD MS SQL PERMISSIONS TO POSTSQL.BAS
      'DESCRIPTION:  This macro will add permissions to the PostSQL of
      '              any selected table in an Sybase or MS SQL Server physical model.
      'AUTHOR: Jason Tiret
      'DATE:  2/2/2000

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim MyModel As Model
          Dim MySelObj As SelectedObject
          Dim MySubModel As SubModel
          Dim grant As String
          Dim ID As Integer
          Dim ObjectName As String
          Dim MyView As View

          'Set ERStudio variable
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel
          Set MySubModel = MyModel.ActiveSubModel

          'create dialog
          Begin Dialog UserDialog 450,287,"GRANT Options" ' %GRID:10,7,1,1
              Text 30,28,130,14,"Specify User/Role:",.Text1
              TextBox 190,21,160,21,.usertxt
              Text 30,56,140,14,"Choose Permissions:",.Text2
              CheckBox 60,77,120,14,"INSERT",.InsertChbx
              CheckBox 60,112,110,14,"UPDATE",.UpdateChbx
              CheckBox 60,182,120,14,"REFERENCES",.ReferenceChbx
              CheckBox 60,217,110,14,"DELETE",.DeleteChbx
              CheckBox 60,147,120,14,"SELECT",.SelectChbx
              CheckBox 200,77,160,14,"With Grant Option",.InsWithGrantChbx
              CheckBox 200,112,150,14,"With Grant Option",.UpdWithGrantChbx
              CheckBox 200,147,150,14,"With Grant Option",.SelWithGrantChbx
              CheckBox 200,182,150,14,"With Grant Option",.RefWithGrantChbx
              CheckBox 200,217,150,14,"With Grant Option",.DelWithGrantChbx
              OKButton 40,252,140,21
              CancelButton 260,252,140,21
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

              For Each MySelObj In MySubModel.SelectedObjects

                  'make sure selected object is an Entity
                  If MySelObj.Type = 1 Or MySelObj.Type = 16 Then

                      ID = MySelObj.ID

                      If MySelObj.Type = 1 Then

                          Set MyEntity = MyModel.Entities.Item(ID)
                          ObjectName = MyEntity.TableName

                      ElseIf MySelObj.Type = 16 Then

                          Set MyView = MyModel.Views.Item(ID)
                          ObjectName = MyView.Name

                      End If

                      'Add insert grant
                      If dlg.insertchbx = 1 Then

                          grant = "GRANT INSERT ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.Inswithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'Add References grant
                      If dlg.referencechbx = 1 Then

                          grant = grant & "GRANT REFERENCES ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.refwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'Add update grant
                      If dlg.updatechbx = 1 Then

                          grant = grant & "GRANT UPDATE ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.updwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'add select grant
                      If dlg.selectchbx = 1 Then

                          grant = grant & "GRANT SELECT ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.selwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'add delete grant
                      If dlg.deletechbx = 1 Then

                          grant = grant & "GRANT DELETE ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.delwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      End If

                      If MySelObj.Type = 1 Then

                          MyEntity.PostSQL = MyEntity.PostSQL & grant

                      ElseIf MySelObj.Type = 16 Then

                          MyView.PostSQL = MyView.PostSQL & grant

                      End If

                      grant = ""

                      Next

          End If 'Dialog

      End Sub


Selectively Add Oracle Permissions to PostSQL.BAS

      'TITLE: SELECTIVELY ADD ORACLE PERMISSIONS TO POSTSQL.BAS
      'DESCRIPTION:  This macro will add permissions to the PostSQL of
      '              any selected table in an Oracle physical model.
      'REQUIREMENT:  Active model must be Oracle.
      'AUTHOR: Jason Tiret
      'DATE:  2/2/2000

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim MyModel As Model
          Dim MySelObj As SelectedObject
          Dim MySubModel As SubModel
          Dim grant As String
          Dim ID As Integer
          Dim MyView As View
          Dim ObjectName As String

          'Set ERStudio variable
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel
          Set MySubModel = MyModel.ActiveSubModel

          'create dialog
          Begin Dialog UserDialog 450,336,"GRANT Statement Options" ' %GRID:10,7,1,1
              Text 30,28,130,14,"Specify User/Role:",.Text1
              TextBox 190,21,160,21,.usertxt
              Text 30,56,140,14,"Choose Permissions:",.Text2
              CheckBox 60,77,120,14,"INSERT",.InsertChbx
              CheckBox 60,112,110,14,"UPDATE",.UpdateChbx
              CheckBox 60,182,110,14,"ALTER",.AlterChbx
              CheckBox 60,217,110,14,"DELETE",.DeleteChbx
              CheckBox 60,147,120,14,"SELECT",.SelectChbx
              CheckBox 200,77,160,14,"With Grant Option",.InsWithGrantChbx
              CheckBox 200,112,150,14,"With Grant Option",.UpdWithGrantChbx
              CheckBox 200,147,150,14,"With Grant Option",.SelWithGrantChbx
              CheckBox 200,182,150,14,"With Grant Option",.AltWithGrantChbx
              CheckBox 200,217,150,14,"With Grant Option",.DelWithGrantChbx
              OKButton 40,294,140,21
              CancelButton 260,294,140,21
              CheckBox 60,252,130,14,"REFERENCES",.referenceschbx
              CheckBox 200,252,180,14,"With Grant Option",.refwithgrantchbx
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

              For Each MySelObj In MySubModel.SelectedObjects

                  'make sure selected object is an Entity
                  If MySelObj.Type = 1 Or MySelObj.Type = 16 Then

                      ID = MySelObj.ID

                      If MySelObj.Type = 1 Then

                          Set MyEntity = MyModel.Entities.Item(ID)
                          ObjectName = MyEntity.TableName

                      ElseIf MySelObj.Type = 16 Then

                          Set MyView = MyModel.Views.Item(ID)
                          ObjectName = MyView.Name

                      End If

                      'Add insert grant
                      If dlg.insertchbx = 1 Then

                          grant = "GRANT INSERT ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.Inswithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'Add Alter grant
                      If dlg.alterchbx = 1 Then

                          grant = grant & "GRANT ALTER ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.altwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'Add update grant
                      If dlg.updatechbx = 1 Then

                          grant = grant & "GRANT UPDATE ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.updwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add select grant
                      If dlg.selectchbx = 1 Then

                          grant = grant & "GRANT SELECT ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.selwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add delete grant
                      If dlg.deletechbx = 1 Then

                          grant = grant & "GRANT DELETE ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.delwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      'add references grant
                      If dlg.referenceschbx = 1 Then

                          grant = grant & "GRANT REFERENCES ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.Refwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & ";" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & ";" & vbCrLf

                          End If

                      End If

                      If MySelObj.Type  = 1 Then
                          MyEntity.PostSQL = MyEntity.PostSQL & grant
                      ElseIf MySelObj.Type  = 16 Then
                          MyView.PostSQL = MyView.PostSQL & grant
                      End If

                      grant = ""

                  End If

              Next

          End If 'Dialog

      End Sub


Selectively Add Oracle Sequence.BAS

      'MACRO TITLE: SELECTIVELY ADD ORACLE SEQUENCE
      ' This macro presents a dialog that allows the user to specify the
      ' naming convention and options for an Oracle Sequence.  The
      ' Sequence is added to the PreSQL of the selected tables.
      ' Author:  Jason E. Tiret
      ' Date:  8/17/2000

      Sub Main
          Dim MyEntity As Entity
          Dim MySelectedObj As SelectedObject
          Dim MyDiagram As Diagram
          Dim MyModel As Model
          Dim MySubModel As SubModel
          Dim Sequence As String
          Dim ID As Integer

          ' Set ER variables
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel
          Set MySubModel = MyModel.ActiveSubModel

          Begin Dialog UserDialog 470,364,"Oracle Sequence Macro" ' %GRID:10,7,1,1
              CheckBox 20,126,160,14,"&INCREMENT BY",.IncreChbx
              CheckBox 20,154,120,14,"&START WITH",.startwChbx
              CheckBox 20,182,310,14,"M&AXVALUE / NOMAXVALUE (gray check)",.maxvalChbx,2
              CheckBox 20,210,300,14,"MI&NVALUE / NOMINVALUE (gray check)",.minvalChbx,2
              CheckBox 20,238,280,14,"C&YCLE / NOCYCLE (gray check)",.cycleChbx,2
              CheckBox 20,266,270,14,"&CACHE / NOCACHE (gray check)",.cacheChbx,2
              CheckBox 20,294,290,14,"&ORDER / NOORDER (gray check)",.orderChbx,2
              TextBox 340,119,110,21,.increTxt
              TextBox 340,147,110,21,.startwTxt
              TextBox 340,175,110,21,.maxvalTxt
              TextBox 340,203,110,21,.minvalTxt
              TextBox 340,259,110,21,.cacheTxt
              OKButton 60,322,140,21
              CancelButton 270,322,140,21
              Text 20,98,230,14,"Choose Options:",.Text1
              Text 20,7,380,14,"Choose Naming Convention.  Default is ""S_""",.Text2
              OptionGroup .Group1
                  OptionButton 40,28,130,14,"Use &Default",.OptionButton0
                  OptionButton 40,49,100,14,"Add &Prefix",.OptionButton1
                  OptionButton 40,70,120,14,"Add S&uffix",.OptionButton2
              Text 190,70,90,14,"Prefix/Suffix:",.Text3
              TextBox 290,63,110,21,.attachTxt
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

          For Each MySelectedObj In MySubModel.SelectedObjects

              ' Only need entities
              If MySelectedObj.Type = 1 Then
                  ID = MySelectedObj.ID

                  Set MyEntity = MyModel.Entities.Item(ID)

                  If dlg.Group1 = 0 Then
                      ' use default
                      Sequence = "CREATE SEQUENCE " & "S_" & MyEntity.TableName & vbCrLf
                  ElseIf dlg.Group1 = 1 Then
                      ' use prefix
                      Sequence = "CREATE SEQUENCE " & dlg.attachTxt & MyEntity.TableName & vbCrLf
                  Else
                      ' use suffix
                      Sequence = "CREATE SEQUENCE " & MyEntity.TableName & dlg.attachTxt & vbCrLf
                  End If

                  ' Add Increment
                  If dlg.IncreChbx = 1 Then
                      Sequence = Sequence & vbTab & "INCREMENT BY " & Val(dlg.increTxt) & vbCrLf
                  End If

                  ' Add Start With parameter
                  If dlg.startwChbx = 1 Then
                      Sequence = Sequence & vbTab & "START WITH " & Val(dlg.startwTxt) & vbCrLf
                  End If

                  ' Add MaxValue parameter
                  If dlg.maxvalChbx = 1 Then
                      Sequence = Sequence & vbTab & "MAXVALUE " & Val(dlg.maxvalTxt) & vbCrLf
                  ElseIf dlg.maxvalChbx = 2 Then
                      Sequence = Sequence & vbTab & "NOMAXVALUE " & vbCrLf
                  End If

                  ' Add MinValue parameter
                  If dlg.minvalChbx = 1 Then
                      Sequence = Sequence & vbTab & "MINVALUE " & Val(dlg.minvalTxt) & vbCrLf
                  ElseIf dlg.minvalChbx = 2 Then
                      Sequence = Sequence & vbTab & "NOMINVALUE " & vbCrLf
                  End If

                  ' Add Cycle parameter
                  If dlg.cycleChbx = 1 Then
                      Sequence = Sequence & vbTab & "CYCLE " & vbCrLf
                  ElseIf dlg.minvalChbx = 2 Then
                      Sequence = Sequence & vbTab & "NOCYCLE " & vbCrLf
                  End If

                  ' Add Cache parameter
                  If dlg.cacheChbx = 1 Then
                      Sequence = Sequence & vbTab & "CACHE " & Val(dlg.cacheTxt) & vbCrLf
                  ElseIf dlg.cacheChbx = 2 Then
                      Sequence = Sequence & vbTab & "NOCACHE " & vbCrLf
                  End If

                  ' Add Order parameter
                  If dlg.orderChbx = 1 Then
                      Sequence = Sequence & vbTab & "ORDER " & vbCrLf
                  ElseIf dlg.orderChbx = 2 Then
                      Sequence = Sequence & vbTab & "NOORDER " & vbCrLf
                  End If

                  Sequence = Sequence & ";" & vbCrLf

                  MyEntity.PreSQL = MyEntity.PreSQL & vbCrLf & Sequence
                  Sequence = ""

                  End If
          Next MySelectedObj

          End If

      End Sub


Selectively Output PK and FK DDL.bas

      'TITLE:  SELECTIVELY OUTPUT PK AND FK DDL.BAS
      'DESCRIPTION:  This macro outputs DDL for primary and foreign
      '	constraints for all selected tables.  To operate, selected
      '	the desired tables, then right-click on the macro to execute.
      '	The DDL can be previewed or written to a file.
      'MODIFY DATE:   2/27/02

      Dim ent As Entity
      Dim mdl As Model
      Dim diag As Diagram
      Dim so As SelectedObject
      Dim submdl As SubModel
      Dim attr As AttributeObj
      Dim rel As Relationship
      Dim fkpair As FKColumnPair
      Dim fileoutput As String

      Dim pkchbx As Integer
      Dim fkchbx As Integer
      Dim filepath As String
      Dim delimiter As String

      Sub Main

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          Begin Dialog UserDialog 590,161,"Generate Constraints",.DialogFunc ' %GRID:10,7,1,1
              Text 30,21,90,14,"Save to:",.Text1
              TextBox 100,14,340,21,.path
              TextBox 460,70,90,21,.delimiter
              Text 370,77,70,14,"Delimiter:",.Text2
              PushButton 470,14,90,21,"Browse",.Browse
              OKButton 350,119,90,21
              CancelButton 460,119,90,21
              CheckBox 100,56,180,14,"Primary Constraints",.pkchbx
              CheckBox 100,84,170,14,"Foreign Constraints",.fkchbx
              PushButton 90,119,90,21,"Preview",.Preview
          End Dialog
          Dim dlg As UserDialog

          dlg.delimiter = ";"

          If Dialog(dlg) = -1 Then

              filepath = dlg.path
              pkchbx = dlg.pkchbx
              fkchbx = dlg.fkchbx
              delimiter = dlg.delimiter

              Open filepath For Output As #1

              Print #1, genPKFKDDL

              Close #1

          End If

      End Sub

      Function genPKFKDDL () As String

          Dim pkey As String
          Dim constraint As String
          Dim columnstring As String
          Dim idxcol As IndexColumn
          Dim i As Integer
          Dim idx As Index

          fileoutput = ""

          If pkchbx = 1 Then

              fileoutput = vbCrLf & "--" & vbCrLf & "--" & vbCrLf & "--  *********  Primary Key Definitions *********" & vbCrLf & "--" & vbCrLf & "--" & vbCrLf & vbCrLf

              For Each so In submdl.SelectedObjects

                  If so.Type = 1 Then

                      Set ent = mdl.Entities.Item(so.ID)

                      columnstring = PKcolumns (ent)

                      For Each idx In ent.Indexes

                          If idx.IsPK = True Then

                              Exit For

                          End If

                      Next

                      If columnstring <> ""  And idx.IsPK = True Then

                          If ent.Owner <> "" Then
                              constraint = "ALTER TABLE " & ent.Owner & "." & ent.TableName & vbCrLf
                          Else
                              constraint = "ALTER TABLE " & ent.TableName & vbCrLf
                          End If

                          constraint = constraint & "      " & "ADD    CONSTRAINT  " & idx.Name & vbCrLf
                          constraint = constraint & "      " & "PRIMARY KEY  (" & columnstring & ")" & vbCrLf
                          constraint = constraint & delimiter & vbCrLf & vbCrLf

                          Debug.Print constraint

                          fileoutput = fileoutput & constraint

                      End If

                  End If

              Next

          End If

          If fkchbx = 1 Then

              fileoutput = fileoutput & vbCrLf & "--" & vbCrLf & "--" & vbCrLf & "--  *********  Foreign Key Definitions *********" & vbCrLf & "--" & vbCrLf & "--" & vbCrLf & vbCrLf

              For Each so In submdl.SelectedObjects

                  If so.Type = 1 Then

                      colunnstring = ""

                      Set ent = mdl.Entities.Item(so.ID)

                      If ent.ChildRelationships.Count <> 0 Then

                          For Each rel In ent.ChildRelationships

                              If ent.Owner <> "" Then
                                  constraint = "ALTER TABLE " & ent.Owner & "." & ent.TableName & vbCrLf
                              Else
                                  constraint = "ALTER TABLE " & ent.TableName & vbCrLf
                              End If

                              constraint = constraint & "      ADD CONSTRAINT " & rel.Name & vbCrLf
                              constraint = constraint & "      FOREIGN KEY   (" & FKchildcolumns(rel, ent.Attributes.Count) & ")" & vbCrLf

                              If ent.Owner <> "" Then
                                  constraint = constraint & "      REFERENCES  " & ent.Owner & "." & rel.ParentEntity.TableName & "  (" & FKparentcolumns(rel, ent.Attributes.Count) & ")" & vbCrLf
                              Else
                                  constraint = constraint & "      REFERENCES  " & rel.ParentEntity.TableName & "  (" & FKparentcolumns(rel, ent.Attributes.Count) & ")" & vbCrLf
                              End If

                              constraint = constraint & delimiter & vbCrLf & vbCrLf

                              fileoutput = fileoutput & constraint

                          Next

                      End If

                  End If

              Next

          End If

          genPKFKDDL = fileoutput

      End Function

      Function PKcolumns ( e As Entity ) As String

          Dim colstr As String
          Dim i, count As Integer

          count = e.Attributes.Count

          ReDim colarr(1 To count) As String
          Dim a As AttributeObj

          i = 1

          For Each a In e.Attributes

              If a.PrimaryKey = True Then
                  colarr(a.SequenceNumber) = a.ColumnName
              End If

          Next

          For i = 1 To e.Attributes.Count

              If colarr(i) <> "" Then
                  colstr = colstr & colarr(i) & ","
              End If

          Next

          If Len(colstr) > 0 Then

              colstr = Left(colstr, Len(colstr) - 1)
              PKcolumns = colstr

          Else

              PKcolumns = ""

          End If

      End Function

      Function FKchildcolumns ( r As Relationship, count As Integer ) As String

          Dim colstr As String
          Dim i As Integer

          ReDim colarr(1 To count) As String
          Dim fkpair As FKColumnPair

          For Each fkpair In r.FKColumnPairs

              colarr(fkpair.SequenceNo) = fkpair.ChildAttribute.ColumnName

          Next

          For i = 1 To count

              If colarr(i) <> "" Then
                  colstr = colstr & colarr(i) & ","
              End If

          Next

          colstr = Left(colstr, Len(colstr) - 1)

          FKchildcolumns = colstr

      End Function

      Function FKparentcolumns ( r As Relationship, count As Integer ) As String

          Dim colstr As String
          Dim i As Integer

          ReDim colarr(1 To count) As String
          Dim fkpair As FKColumnPair

          For Each fkpair In r.FKColumnPairs

              colarr(fkpair.SequenceNo) = fkpair.ParentAttribute.ColumnName

          Next

          For i = 1 To count

              If colarr(i) <> "" Then
                  colstr = colstr & colarr(i) & ","
              End If

          Next

          colstr = Left(colstr, Len(colstr) - 1)

          FKparentcolumns = colstr

      End Function

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "Preview" Then

                  pkchbx = DlgValue("pkchbx")
                  fkchbx = DlgValue("fkchbx")
                  delimiter = DlgText("delimiter")

                  Begin Dialog UserDialog 750,413,"DDL" ' %GRID:10,7,1,1
                      TextBox 30,21,690,343,.code,1
                      OKButton 620,378,90,21
                  End Dialog
                  Dim dlg As UserDialog

                  dlg.code = genPKFKDDL

                  Dialog dlg

                  DialogFunc = True

              ElseIf DlgItem = "Browse" Then
                  'browse to excel file if used pushes browse button.  Put path in text box.
                  DlgText "path", GetFilePath(,"txt","C:\","Specify File Name",3)
                  DialogFunc = True
              ElseIf DlgItem = "OK" And DlgText("path") = "" Then
                  'don't exit dialog if a path is not specified
                  MsgBox("Please enter a valid path.",,"Error!")
                  DialogFunc = True
              End If
              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function


Selectively Update Oracle Index Storage.BAS

      'TITLE:  SELECTIVELY UPDATE ORACLE INDEX STORAGE.BAS
      'DESCRIPTION:  This macro provides a list of tables from the active
      '	physical model.  The tables in the right box will be updated
      '	with the specified storage parameters.  Tables can be added
      '	and removed from the updated list.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'DATE:  3/13/2002

      Option Explicit

      'Global Array variables to handle available and selected tables.
      Dim AvailableIndexes() As String
      Dim SelectedIndexes() As String
      Dim AvailIndexesIndx As Integer
      Dim SelIndexesIndx As Integer

      'array variables
      Dim tblspaces() As String
      Dim MaxExts() As String
      Dim BufferPool() As String

      'Global ERStudio Variables
      Dim mdl As Model
      Dim diag As Diagram
      Dim submdl As SubModel
      Dim ent As Entity
      Dim so As SelectedObject
      Dim indices As Indexes
      Dim indx As Index
      Dim indxcount As Integer

      Type IdxPair
       tblName As String
       idxname As String
      End Type

      Dim IndexPairs() As IdxPair

      Sub setBP

          ReDim BufferPool (0 To 4) As String

          BufferPool(0) = "NONE"
          BufferPool(1) = "DEFAULT"
          BufferPool(2) = "KEEP"
          BufferPool(3) = "RECYCLE"

      End Sub

      Sub setMaxExts

          ReDim MaxExts(0 To 1) As String

          MaxExts(1) = "UNLIMITED"

      End Sub

      Sub gettblspaces

          Dim i, count As Integer
          Dim oratblspc As OracleTablespace

          count = mdl.OracleTablespaces.Count
          i = 0

          If count = 0 Then

              ReDim tblspaces(0)

          Else

              ReDim tblspaces (0 To count - 1)

              For Each oratblspc In mdl.OracleTablespaces

                  tblspaces(i) = oratblspc.Name
                  i = i + 1

              Next

          End If

      End Sub

      Function getTableName ( idx As String ) As String

          Dim i As Integer
          Dim tblName As String

          For i = 0 To indxcount - 1

              If IndexPairs(i).idxname = idx Then
                  getTableName = IndexPairs(i).tblname
                  Exit For
              End If

          Next

          'getTableName = ""

      End Function

      'This function is used to initialize the passed-in array with all
      'the tables in the physical model.  It will fill the target array
      'when the AddAll and RemoveAll buttons in the dialog are pressed.
      Function SetupIndexArray(indxs As Variant)

          Debug.Print "SetupIndexArray"

          Dim i,count As Integer

          count = indxcount - 1

          i = 0

          If count < 0 Then

              ReDim indxs(0) As String

          Else

              ReDim indxs (0 To count) As String

              'Refresh Array with table names
              For i = 0 To indxcount - 1

                  indxs(i) = IndexPairs(i).tblName & "  --  " & IndexPairs(i).idxName
                  Debug.Print vbTab & i & " = " & indxs(i)

              Next
              Debug.Print indxcount

          End If

      End Function

      'This function clears the passed-in array of all the names.  It clears the
      'source array when the AddAll and RemoveAll buttons are pressed.
      Function ClearIndexArray(indxs As Variant)

          Dim i,count As Integer

          count = indxcount - 1

          If count < 0 Then

              ReDim indxs(0) As String

          Else

              ReDim indxs (0 To count) As String

              For i = 0 To indxcount - 1
                  indxs(i) = ""
                  i = i + 1
              Next

          End If

      End Function

      'This function is used to move single tables between the listboxes.  It
      'will add tables to the front of the target array and pad the back of the
      'source array with blank entries
      Function MoveIndex (source As Variant, target As Variant, source_indx As Integer)

          Dim s_count As Integer  'upper bound of the source array
          Dim t_count As Integer  'upper bound of the target array
          Dim i As Integer

          s_count = UBound(source)
          t_count = UBound(target) - 1

          Debug.Print "t_count = " & t_count

          'move all the entries back one slot in the target array to make
          'room for the new entry
          For i = t_count To 0 Step -1
              target(i+1) = target(i)
              Debug.Print "target(" & i & ") = " & target(i)
          Next i

          'add the new entry
          target(0) = source(source_indx)
          Debug.Print source(source_indx) & ", index = " & source_indx

          'move all the entries after the vacant slot up one slot to fill the hole
          For i = source_indx + 1 To s_count
              source(i-1) = source(i)
          Next i

          'pad the last entry with a null string
          source(s_count) = ""

      End Function

      Sub Main

          Debug.Clear

          'set ERStudio variables
          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          Dim count As Integer
          Dim i As Integer
          Dim tbl As String
          Dim idx As String
          Dim DBplatform As String

          DBplatform = Left(mdl.DatabasePlatform,6)

          Debug.Print DBplatform
          Debug.Print mdl.MajorPlatform
          Debug.Print mdl.DatabasePlatform

          If DBplatform <> "Oracle" Then

          MsgBox("Physical Model platform must be Oracle",,"Error!")

          Else

          Debug.Print "Initialize"

          For Each so In submdl.SelectedObjects

              If so.Type = 1 Then

                  Set ent = mdl.Entities.Item(so.ID)

                   indxcount = indxcount + ent.Indexes.Count

                   If ent.Indexes.Count <> 0 Then

                   ReDim Preserve IndexPairs (0 To indxcount - 1) As IdxPair

                   For Each indx In ent.Indexes

                         IndexPairs(i).tblname = ent.TableName
                         IndexPairs(i).idxname = indx.Name
                         Debug.Print i & " = " & IndexPairs(i).idxname
                         i = i + 1

                   Next

                   End If

               End If

           Next

           Debug.Print indxcount

          'initialize global arrays and indexes
          SetupIndexArray(AvailableIndexes)
          ClearIndexArray(SelectedIndexes)
          AvailIndexesIndx = 0
          SelIndexesIndx = 0

          gettblspaces
          setBP
          setMaxExts

          'Create the dialog
          Begin Dialog UserDialog 1170,525,"Oracle Index Storage Parameters",.DialogFunc ' %GRID:10,7,1,1
              GroupBox 650,308,480,154,"Selected Indexes",.GroupBox2
              ListBox 660,322,460,140,SelectedIndexes(),.SIndexes
              PushButton 560,329,60,21,">>",.AddAll
              GroupBox 40,308,490,154,"Available Indexes",.GroupBox1
              ListBox 50,322,460,140,AvailableIndexes(),.AIndexes
              PushButton 560,357,60,21,">",.AddSelected
              PushButton 560,406,60,21,"<",.RemoveSelected
              PushButton 560,434,60,21,"<<",.RemoveAll
              OKButton 770,483,130,28
              CancelButton 910,483,130,28
              GroupBox 120,14,280,140,"Properties",.GroupBox6
              GroupBox 430,14,210,140,"Physical",.GroupBox8
              GroupBox 20,161,380,105,"Segment",.GroupBox3
              DropListBox 80,203,280,91,tblspaces(),.tblspcsdd,1
              GroupBox 430,161,210,105,"Group",.GroupBox4
              PushButton 80,280,90,21,"Sort List",.SortAvail
              GroupBox 660,14,350,252,"Storage",.GroupBox5
              DropListBox 810,238,120,70,BufferPool(),.bufferpooldd
              CheckBox 440,161,70,14,"Parallel",.Parallelchbx
              PushButton 640,280,90,21,"Sort List",.SortSel
              Text 440,42,70,14,"Pct Free:",.PctFree
              Text 440,77,90,14,"Initial Trans:",.initrans
              Text 440,112,90,14,"Max Trans:",.maxtrans
              TextBox 530,35,90,21,.pctfreetxt
              TextBox 530,70,90,21,.initranstxt
              TextBox 530,105,90,21,.maxtranstxt
              Text 40,182,90,14,"Tablespace:",.tblspc
              Text 440,189,70,14,"Degrees:",.degrees
              Text 440,224,90,14,"Instances:",.Text7
              TextBox 530,182,90,21,.degreestxt
              TextBox 530,217,90,21,.instancestxt
              CheckBox 90,238,110,14,"No Logging",.nologgingchbx
              Text 690,42,90,14,"Initial Extent:",.Text8
              Text 690,70,90,14,"Next Extent:",.Text9
              Text 690,98,90,14,"Pct Increase:",.Text10
              Text 690,126,90,14,"Min Extents:",.Text11
              TextBox 800,35,130,21,.iniextenttxt
              TextBox 800,63,130,21,.NextExtenttxt
              Text 690,182,90,14,"Free Lists:",.Text13
              TextBox 800,91,130,21,.pctincreasetxt
              TextBox 800,119,130,21,.minextentstxt
              DropListBox 800,147,130,49,MaxExts(),.maxextentsdd,1
              TextBox 800,175,130,21,.freeliststxt
              Text 670,210,120,14,"Free List Groups:",.Text14
              TextBox 800,203,130,21,.freelistgroupstxt
              Text 680,238,90,14,"Buffer Pool:",.Text15
              Text 680,154,90,14,"Max Extents:",.Text12
              Text 950,42,20,14,"KB",.Text1
              Text 950,70,20,14,"KB",.Text2
              Text 140,35,80,14,"Index Type:",.Text3
              OptionGroup .indxtypeopt
                  OptionButton 250,42,90,14,"B-Tree",.btree
                  OptionButton 250,63,90,14,"Bitmap",.bitmap
              CheckBox 150,84,90,14,"Unique",.uniquechbx
              CheckBox 150,105,90,14,"No Sort",.nosortchbx
              CheckBox 150,126,160,14,"Reverse Byte Order",.reversechbx
              Text 50,483,360,28,"NOTE:  Setting fields to -1 will set storage parameters in the table editors to NULL",.Text4
          End Dialog
          Dim dlg As UserDialog

          Dim Label As String
          Dim x As Integer
          Dim y As Integer
          Dim Length As Integer
          Dim ixname As String

          'initialize dialog, -1 is the OK button, 0 is the CANCEL
          If Dialog(dlg,-2) = -1 Then

              'Iterate through all the tables from the SelectedTables array
              For count = 0 To indxcount - 1

                  'don't want the null values in the SelectedTables array
                  If SelectedIndexes(count) <> "" Then

                      'Get table name
                      Label = SelectedIndexes(count)
                      x = InStr(1, Label, "  --  ")
                      tbl = Left(Label, x - 1)
                      Debug.Print "table= " & tbl

                      'get index name
                      x = x + 5
                      Length = Len(Label)
                      y = Length - x
                      ixname = Right(Label, y)
                      Debug.Print "index= " & ixname

                      'get the respective entity
                      Set ent = mdl.Entities.Item(tbl)

                      'now get the respective index
                      Set indx = ent.Indexes.Item(ixname)

                      'update index parameters

                      If dlg.indxtypeopt = 0 Then

                          indx.OracleBitMap = False

                          If dlg.uniquechbx = 1 Then
                              indx.Unique = True
                          End If

                          If dlg.reversechbx = 1 Then
                              indx.OracleReverseByteOrder = True
                          End If

                          If dlg.nosortchbx = 1 Then
                              indx.OracleNoSort = True
                          End If

                      Else

                          indx.OracleBitMap = True
                          indx.Unique = False
                          indx.OracleNoSort = False
                          indx.OracleReverseByteOrder = False

                      End If

                      If IsNumeric(dlg.nextextenttxt) Then
                          indx.NextExtentSize  = CLng(dlg.nextextenttxt)
                      End If

                      If IsNumeric(dlg.freelistgroupstxt) Then
                          indx.FreeListGroups = CLng(dlg.freelistgroupstxt)
                      End If

                      If IsNumeric(dlg.FreeListstxt) Then
                          indx.FreeLists = CLng(dlg.FreeListstxt)
                      End If

                      If IsNumeric(dlg.iniextenttxt) Then
                          indx.InitialExtentSize = CLng(dlg.iniextenttxt)
                      End If

                      indx.Location = dlg.tblspcsdd

                      Debug.Print dlg.maxextentsdd

                      If dlg.maxextentsdd = "UNLIMITED" Then
                          indx.MaximumExtents = 2147483645
                      Else
                          If IsNumeric (dlg.maxextentsdd) Then
                              indx.MaximumExtents = CLng(dlg.maxextentsdd)    'This line works if uncommented, but can't set parameter to "UNLIMITED"
                          End If
                      End If

                      Debug.Print DiagramManager.GetLastErrorString

                      If IsNumeric(dlg.maxtranstxt) Then
                          indx.MaximumTransactions = CLng(dlg.maxtranstxt)
                      End If

                      If IsNumeric(dlg.minextentstxt) Then
                          indx.MinimumExtents = CLng(dlg.minextentstxt)
                      End If

                      If IsNumeric(dlg.initranstxt) Then
                          indx.MinimumTransactions = CLng(dlg.initranstxt)
                      End If

                      If IsNumeric(dlg.pctincreasetxt) Then
                          indx.ExtentGrowthFactor  = CLng(dlg.pctincreasetxt)
                      End If

                      If dlg.nologgingchbx = 1 Then
                          indx.NoLogging = True
                      End If

                      indx.OracleBufferPool = BufferPool(dlg.bufferpooldd)

                      If dlg.parallelchbx = 1 Then

                          indx.OracleParallel = True

                          If IsNumeric(dlg.degreestxt) Then
                              indx.OracleDegrees = CLng(dlg.degreestxt)
                          End If

                          If IsNumeric(dlg.instancestxt) Then
                              indx.OracleInstances = CLng(dlg.instancestxt)
                          End If

                      End If

                      If IsNumeric(dlg.pctfreetxt) Then
                          indx.PercentFree = CLng(dlg.pctfreetxt)
                      End If

                  End If

              Next

          End If

          End If

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "AIndexes" Then

                  'update the AvailIndexesIndx with current index when a
                  'table is selected in the available tables listbox
                  AvailIndexesIndx = SuppValue
                  Debug.Print AvailIndexesIndx

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "SIndexes" Then

                  'update the SelIndexIndx with the current index when a
                  'table is selected in the selected tables listbox
                  SelIndexesIndx = SuppValue
                  Debug.Print SelIndexesIndx

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "AddAll" Then

                  Debug.Print "addall"

                  'add all the tables to the SelectedIndexes array, remove all
                  'from the AvailableTables array
                  SetupIndexArray(SelectedIndexes)
                  ClearIndexArray(AvailableIndexes)

                  'refresh dialog listboxes
                  DlgListBoxArray "SIndexes", SelectedIndexes()
                  DlgListBoxArray "AIndexes", AvailableIndexes()

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "RemoveAll" Then

                  Debug.Print "removeall"

                  'add all the tables to the AvailableTables array, remove all
                  'from the SelectedIndexes array
                  SetupIndexArray(AvailableIndexes)
                  ClearIndexArray(SelectedIndexes)

                  'refresh dialog listboxes
                  DlgListBoxArray "AIndexes", AvailableIndexes()
                  DlgListBoxArray "SIndexes", SelectedIndexes()

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "RemoveSelected" Then

                  'don't move the table if the value is null
                  If SelectedIndexes(SelIndexesIndx) <> "" Then

                      'move the selected table from SelectedIndexes array to the
                      'AvailableIndexes array
                      MoveIndex(SelectedIndexes, AvailableIndexes, SelIndexesIndx)

                      'refresh dialog listboxes
                      DlgListBoxArray "AIndexes", AvailableIndexes()
                      DlgListBoxArray "SIndexes", SelectedIndexes()

                      're-initalize array indexes
                      SelIndexesIndx = 0
                      AvailIndexesIndx = 0

                  End If

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "AddSelected" Then

                  'Don't move table if there isn't any value in the list box
                  If AvailableIndexes(AvailIndexesIndx) <> "" Then

                      'move the selected table from the AvailableIndexes array to
                      'the SelectedIndexes array
                      MoveIndex(AvailableIndexes, SelectedIndexes, AvailIndexesIndx)

                      'refresh dialog listboxes
                      DlgListBoxArray "AIndexes", AvailableIndexes()
                      DlgListBoxArray "SIndexes", SelectedIndexes()

                      're-initalize array indexes
                      SelIndexesIndx = 0
                      AvailIndexesIndx = 0

                  End If

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "SortAvail" Then

                  dhQuickSort AvailableIndexes()
                  adjustArray(AvailableIndexes())
                  DlgListBoxArray "AIndexes", AvailableIndexes()
                  DialogFunc = True

              ElseIf DlgItem = "SortSel" Then

                  dhQuickSort SelectedIndexes()
                  adjustArray(SelectedIndexes())
                  DlgListBoxArray "SIndexes", SelectedIndexes()
                  DialogFunc = True

              ElseIf DlgItem = "OK" Then

                  If DlgValue("nosortchbx") = 1 And DlgValue("reversechbx") Then

                      MsgBox("The No Sort and Reverse Byte Order can not be both set.",,"ERROR!")
                      DialogFunc = True

                  End If

              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed

          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      Function adjustArray(varArray As Variant)

          Dim i, intItems As Integer
          intItems = UBound(varArray)

          While varArray(0) = ""

              For i = 1 To intItems
                  varArray(i - 1) = varArray(i)
              Next

              varArray(intItems) = ""

          Wend

      End Function

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant, _
       Optional intLeft As Integer As Integer ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If

      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


Selectively Update OS390 Table Storage.bas

      'TITLE:  SELECTIVELY UPDATE OS390 TABLE STORAGE PARAMETERS.BAS
      'DESCRIPTION:  This macro provides a list of tables from the active
      '	physical model.  The tables in the right box will be updated
      '	with the specified storage parameters.  Tables can be added
      '	and removed from the updated list.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'DATE:  3/13/2002
      'LAST UPDATE:  7/3/2003

      Dim Databases() As String
      Dim Tablespaces() As String

      'Global ERStudio Variables
      Dim mdl As Model
      Dim diag As Diagram
      Dim submdl As SubModel
      Dim so As SelectedObject
      Dim ent As Entity

      Function setupTablespaces()

          Dim i, count As Integer
          Dim tblspc As DB2Tablespace

          i = 0
          count = mdl.DB2Tablespaces.Count - 1

          If count < 0 Then

              ReDim Tablespaces(0)

          Else

              ReDim Tablespaces(0 To count)

              For Each tblspc In mdl.DB2Tablespaces

                  Tablespaces(i) = tblspc.Name
                  i = i + 1

              Next

          End If

      End Function

      Function setupDatabases()

          Dim i, count As Integer
          Dim db As DB2Database

          i = 0
          count = mdl.DB2Databases.Count - 1

          If count < 0 Then

              ReDim database(0)

          Else

              ReDim Databases(0 To count)

              For Each db In mdl.DB2Databases

                  Databases(i) = db.Name
                  i = i + 1

              Next

          End If

      End Function

      Sub Main

          Debug.Clear

          'set ERStudio variables
          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set submdl = mdl.ActiveSubModel

          Dim count As Integer
          Dim DBplatform As String

          If mdl.MajorPlatform <> "IBM DB2" Then

          MsgBox("Physical Model platform must be DB2 OS/390",,"Error!")

          Else

          setupTablespaces()
          setupDatabases()

          'Create the dialog
          Begin Dialog UserDialog 730,308,"DB2 Storage Parameters" ' %GRID:10,7,1,1
              GroupBox 20,14,320,98,"Location",.GroupBox3
              Text 40,63,80,14,"Tablespace:",.Text1
              OKButton 400,259,130,28
              CancelButton 560,259,130,28
              Text 40,35,80,14,"Database:",.Text2
              DropListBox 140,28,180,112,Databases(),.Database,1
              DropListBox 140,56,180,175,Tablespaces(),.TableSpace,1
              CheckBox 60,126,90,14,"Encoding",.EncodingChbx
              CheckBox 200,126,130,14,"Restrict On Drop",.restrictChbx
              OptionGroup .EncodingOpt
                  OptionButton 100,147,90,14,"ASCII",.OptionButton1
                  OptionButton 100,168,90,14,"EBCDIC",.OptionButton2
              GroupBox 30,189,310,49,"Logging",.GroupBox4
              CheckBox 60,210,170,14,"Log Data Changes",.LogDataChbx
              GroupBox 370,14,330,98,"Table Procedures",.GroupBox5
              Text 400,42,90,14,"Edit Proc:",.Text3
              Text 400,70,90,14,"Valid Proc:",.Text4
              TextBox 490,42,170,21,.Editproc
              TextBox 490,70,170,21,.ValidProc
              GroupBox 370,133,330,105,"Audit Option",.GroupBox6
              OptionGroup .AuditOpt
                  OptionButton 450,154,90,14,"None",.OptionButton3
                  OptionButton 450,182,90,14,"Changes",.OptionButton4
                  OptionButton 450,210,90,14,"All",.OptionButton5
          End Dialog
          Dim dlg As UserDialog

          'initialize dialog, -1 is the OK button, 0 is the CANCEL
          If Dialog(dlg,-2) = -1 Then

              For Each so In submdl.SelectedObjects

                  If so.Type = 1 Then

                      Set ent = mdl.Entities.Item(so.ID)

                      'Update the tablespace and database location with the give tablespace name
                      If dlg.Database <> "" Then
                          ent.DatabaseLocation = dlg.Database
                      End If

                      If dlg.TableSpace <> "" Then
                          ent.StorageLocation = dlg.TableSpace
                      End If

                      'Update the Edit proc
                      If dlg.editproc <> "" Then
                          ent.DB2EditProc = dlg.editproc
                          Debug.Print DiagramManager.GetLastErrorString
                      End If

                      'Update the Valid proc
                      If dlg.validproc <> "" Then
                          ent.DB2ValidProc = dlg.validproc
                          Debug.Print DiagramManager.GetLastErrorString
                      End If

                      'Update the restrict option
                      If dlg.restrictchbx = 1 Then
                          ent.DB2RestrictOnDrop = True
                      Else
                          ent.DB2RestrictOnDrop = False
                      End If

                      'Update encoding option
                      If dlg.encodingchbx = 1 Then

                          'determine which type of encoding
                          If dlg.encodingopt = 0 Then
                              ent.DB2Encoding = "ASCII"
                          Else
                              ent.DB2Encoding = "EBCDIC"
                          End If

                      Else

                          ent.DB2Encoding = "NONE"

                      End If

                      'Update audit option
                      If dlg.auditopt = 0 Then
                          ent.DB2Auditing = "NONE"
                      ElseIf dlg.auditopt = 1 Then
                          ent.DB2Auditing = "CHANGES"
                      Else
                          ent.DB2Auditing = "ALL"
                      End If

                      'Update logging option
                      If dlg.logdatachbx = 1 Then
                          ent.DB2DataCaptureChg = True
                      Else
                          ent.DB2DataCaptureChg = False
                      End If

                  End If

              Next

          End If

          End If

      End Sub


SQL Server Storage Update.BAS

      Sub Main
          Dim ind As Index
          Dim mo As Model
          Dim diag As Diagram
          Dim ent As Entity

          Debug.Clear

          ' Set ER variables

          Set diag = DiagramManager.ActiveDiagram
          Set mo = diag.ActiveModel

          ' Debug.Print mo.MajorPlatform

          ' Check that active model is a physical model and SQL Server model

          If mo.MajorPlatform = "Microsoft SQL Server" And mo.Logical = False Then

          Begin Dialog UserDialog 400,189,"SQL Server Storage Update Macro" ' %GRID:10,7,1,1
              CheckBox 50,14,190,14,"Update Table Parameter",.tablechckbx
              Text 80,42,70,14,"File Group:",.Text1
              Text 80,105,80,14,"File Group:",.Text2
              TextBox 170,35,160,21,.TBLFGInput
              CheckBox 50,77,230,14,"Update Index Parameters",.IndexChbx
              TextBox 170,98,160,21,.INXFGInput
              Text 80,133,80,14,"Fill Factor:",.Text3
              TextBox 170,126,160,21,.INXFFInput
              OKButton 50,154,130,21
              CancelButton 210,154,130,21
          End Dialog
          Dim dlg As UserDialog

              If Dialog(dlg) = -1 Then

                  For Each ent In mo.Entities

                      'set table File group if option is checked
                      If dlg.tablechckbx = 1 Then
                          ent.StorageLocation = dlg.TBLFGInput
                      End If

                      For Each ind In ent.Indexes

                          'set index file group and fill factor if option is checked
                          If dlg.indexchbx = 1 Then
                              ind.Location = dlg.INXFGInput
                              ind.FillfactorPercent = CLng(dlg.INXFFInput)
                          End If

                      Next ind
                  Next ent

              End If 'dialog

          Else

              MsgBox("Active Model is not a SQL Server Physical Model.")

          End If 'DB platform check

      End Sub


Submodel Report.bas

      'TITLE:  SUBMODEL REPORT
      'DESCRIPTION:  This report generates a list of entities and their
      '  submodels for the active model.  The output is an excel spread
      '  sheet.
      'AUTHOR:  Jason Tiret
      'DATE:    3/25/2004

      ' declare ERStudio variables
      Dim Diag As Diagram
      Dim Entdisp As EntityDisplay
      Dim Mdl As Model
      Dim submdl As SubModel
      Dim so As SelectedObject

      ' declare Excel variables
      Dim Excel As Object

      Dim curRow As Integer
      Dim curCol As Integer
      Dim clrBack As Variant
      Dim clrFore As Variant
      Dim clrTitleBack As Variant
      Dim clrTitleFore As Variant

      Public Const CLR_WHITE = RGB(255, 255, 255)
      Public Const CLR_BLACK = RGB(0, 0, 0)
      Public Const CLR_GREY = RGB(192, 192, 192)
      Public Const CLR_TEAL = RGB(0, 128, 128)

      Dim main_model_list () As String

      Sub Main

          ' Init the ER/Studio variables.

          Set Diag = DiagramManager.ActiveDiagram
          Set Mdl = Diag.ActiveModel
          Set submdl = Mdl.ActiveSubModel

          Set Excel = CreateObject("Excel.Application")
          Excel.Workbooks.Add

          curRow = 1
          curCol = 1

          clrBack = CLR_WHITE
          clrFore = CLR_BLACK
          clrTitleBack = CLR_GREY
          clrTitleFore = CLR_BLACK

          InitColumnWidth
          PrintColumnHeader
          PrintData

          MsgBox("Export   Complete!",,"ER/Studio")

          ' make Excel spread sheet visible
          Excel.Visible = True

      End Sub

      Sub PrintData

          Dim bHideFont As Boolean
          bHideFont = False

          For Each submdl In Mdl.SubModels

              For Each Entdisp In submdl.EntityDisplays

                  PrintRecord

              Next

          Next

      End Sub

      'this routine is called by PrintData to right one record to the spread sheet.
      'there are no parameters associated with it.  The diagram variables are initialized
      'with in the Sub Main routine.
      Sub PrintRecord

          'output the submodel name to the spread sheet
          PrintCell submdl.Name, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          'Output logical entity name to spread sheet
          PrintCell Entdisp.ParentEntity.EntityName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          'output physical table name to spread sheet
          PrintCell Entdisp.ParentEntity.TableName, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          'output entity definition to spread sheet
          PrintCell Entdisp.ParentEntity.Definition, curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 10, False

          curRow = curRow + 1
          curCol = 1

      End Sub

      ' Initialize the column width.

      Sub InitColumnWidth

          Dim count As Integer

          count = 4

          'initialize column widths
          For j = 1 To count
              Excel.Cells(1, j).ColumnWidth = 30
          Next j

      End Sub

      ' Print the column header.  Only print headers when value is true in options array.

      Sub PrintColumnHeader

              PrintCell "Submodel", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True

              PrintCell "Entity Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True

              PrintCell "Table Name", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True

              PrintCell "Entity/Table Definition", curRow, curCol, 0, 1, clrTitleFore, clrTitleBack, 12, True

              curRow = curRow + 1
              curCol = 1

      End Sub

      ' Print a cell

      Sub PrintCell(value As String, row As Integer, col As Integer, rowInc As Integer, colInc As Integer, clrFore As Variant, clrBack As Variant, szFont As Integer, bBold As Boolean)
          Excel.Cells(row, col).Value = value

          Excel.Cells(row, col).Font.Bold = bBold
          Excel.Cells(row, col).Font.Color = clrFore
          Excel.Cells(row, col).Font.Size = szFont

          curRow = curRow + rowInc
          curCol = curCol + colInc
      End Sub


Switch Domain Bindings.bas

      'TITLE:  SWITCH DOMAIN BINDINGS
      'DESCRIPTION:  This macro scans all the columns and attributes in the active model or all models
      '	and switches the domain bindings from the source domain to the target domain.  The
      '	information for each bound column will be updated with the target domain.  Any domain
      '	overrides will be preserved.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'LAST UPDATE:  5/27/2003

      Dim attr As AttributeObj
      Dim ent As Entity
      Dim mdl As Model
      Dim diag As Diagram
      Dim dom As Domain
      Dim dict As Dictionary
      Dim target_dom As Domain
      Dim source_dom As Domain
      Dim target_dict As Dictionary
      Dim source_dict As Dictionary

      'dialog variables and arrays
      Dim dictionary_list () As String
      Dim source_domain_names() As String
      Dim target_domain_names() As String

      Dim target_dom_index As Integer
      Dim source_dom_index As Integer
      Dim target_dict_index As Integer
      Dim source_dict_index As Integer

      Sub Main

          Debug.Clear

          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel

          Begin Dialog UserDialog 970,175,"Switch Domains",.dom_handler ' %GRID:10,7,1,1
              DropListBox 170,14,290,112,dictionary_list(),.source_dict_list
              DropListBox 170,56,290,91,dictionary_list(),.target_dict_list
              DropListBox 620,14,300,98,source_domain_names(),.Source_domain_dd
              Text 480,56,110,14,"Target Domain",.trgt_domain
              Text 480,14,110,14,"Source Domain",.src_domain
              DropListBox 620,56,300,91,target_domain_names(),.Target_domain_dd
              PushButton 690,112,100,28,"&Switch",.switch
              GroupBox 40,98,410,49,"Scope",.GroupBox1
              Text 30,14,140,14,"Source Dictionary",.Text1
              Text 30,56,130,14,"Target Dictionary",.Text2
              OptionGroup .modelscope
                  OptionButton 90,119,120,14,"&Active Model",.optionbutton1
                  OptionButton 230,119,130,14,"A&ll Models",.OptionButton2
              CancelButton 820,112,90,28
              PushButton 820,112,100,28,"&Close",.Close_dialog
          End Dialog
          Dim dlg As UserDialog

          init_local_domains "SOURCE"
          init_local_domains "TARGET"
          init_dictionary_list
          dhQuickSort(source_domain_names)
          dhQuickSort(target_domain_names)
          target_domain_index = 0
          source_domain_index = 0
          dlg.modelscope = 1
          Set source_dict = diag.Dictionary
          Set target_dict = diag.Dictionary

          If Dialog(dlg) = -1 Then
          End If

      End Sub

      'initialize the dictionary drop down list
      Sub init_dictionary_list

          ReDim dictionary_list (0 To diag.EnterpriseDataDictionaries.Count) As String

          dictionary_list (0) = "Local"
          i = 1

          For Each dict In diag.EnterpriseDataDictionaries

              dictionary_list (i) = dict.Name
              i = i + 1

          Next

      End Sub

      'Initialize the domains dropdown array
      Sub init_local_domains (loadoption As String)

          If diag.Dictionary.Domains.Count = 0 Then

              ReDim source_domain_names (0) As String
              ReDim target_domain_names (0) As String

              source_domain_names (0) = "NONE"
              target_domain_names (0) = "NONE"

          Else

              If loadoption = "SOURCE" Then
                  ReDim source_domain_names(0 To diag.Dictionary.Domains.Count - 1) As String
              Else
                  ReDim target_domain_names(0 To diag.Dictionary.Domains.Count - 1) As String
              End If

              Dim i As Integer

              i = 0

              For Each dom In diag.Dictionary.Domains

                  If loadoption = "SOURCE" Then
                      source_domain_names(i) = dom.Name
                  Else
                      target_domain_names(i) = dom.Name
                  End If

                  i = i + 1

              Next

          End If

      End Sub

      'initialize the domains drop down if an Enterprise dictionary is set
      Sub init_enterprise_domains (dict_name As String, loadoption As String)

          Set dict = diag.EnterpriseDataDictionaries.Item(dict_name)

          If dict.Domains.Count = 0 Then

              ReDim source_domain_names (0) As String
              ReDim target_domain_names (0) As String

              source_domain_names (0) = "NONE"
              target_domain_names (0) = "NONE"

          Else

              If loadoption = "SOURCE" Then
                  ReDim source_domain_names(0 To dict.Domains.Count - 1) As String
              Else
                  ReDim target_domain_names(0 To dict.Domains.Count - 1) As String
              End If

              i = 0

              For Each dom In dict.Domains

                  If loadoption = "SOURCE" Then
                      source_domain_names(i) = dom.Name
                  Else
                      target_domain_names(i) = dom.Name
                  End If

                  i = i + 1

              Next

          End If

      End Sub

      Sub switch_domains (src_ix As Integer, trg_ix As Integer)

          Debug.Print "Switch Domains"

          Set target_dom = target_dict.Domains.Item(target_domain_names(trg_ix))
          Set source_dom = source_dict.Domains.Item(source_domain_names(src_ix))

          Debug.Print "Switch - source dom: " & source_dom.Name
          Debug.Print "Switch - target dom: " & target_dom.Name

          For Each ent In mdl.Entities

              Debug.Print "Entity Name: " & ent.EntityName

              For Each attr In ent.Attributes

                  Debug.Print vbTab &  "Attribute Name: " & attr.AttributeName
                  Debug.Print vbTab &  vbTab & "Attribute Domain ID: " & attr.DomainId
                  Debug.Print vbTab &  vbTab & "Src Dict Domain ID: " & source_dom.ID
                  Debug.Print vbTab &  vbTab & "trgt Dict domain ID: " & target_dom.ID

                  'match domain id with attribute domain
                  If attr.DomainId = source_dom.ID Then

                      Debug.Print vbTab & vbTab & "MATCH!"

                      attr.DomainId = target_dom.ID   'set attribute domain id to target domain

                  End If

                  Debug.Print vbCrLf

              Next

          Next

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function dom_handler(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

          '	DlgEnable "Cancel", False
              DlgVisible "Cancel", False

          Case 2 ' Value changing or button pressed

              If DlgItem = "switch" Then

                  'debug check for right source domain
                  Debug.Print "Source Domain Index: " & source_dom_index
                  Set source_dom = source_dict.Domains.Item(source_domain_names(source_dom_index))
                  Debug.Print "Src Domain:  " & source_dom.Name

                  'debug check for right target domain
                  Debug.Print "Target Domain Index: " & target_dom_index
                  Set target_dom = target_dict.Domains.Item(target_domain_names(target_dom_index))
                  Debug.Print "Trgt Domain:  " & target_dom.Name

              '	definition_override = DlgValue("definition_overrides")
              '	default_override = DlgValue("default_overrides")
              '	rule_override = DlgValue("rule_overrides")

                  If DlgValue("modelscope") = 0 Then

                      Debug.Print "Active Model."

                      'only update domain bindings in current model
                      switch_domains	source_dom_index, target_dom_index

                  Else

                      Debug.Print "All Models."

                      'update all models
                      For Each mdl In diag.Models

                          switch_domains source_dom_index, target_dom_index

                      Next

                  End If

                  MsgBox("   DONE!!   ",,"ER/Studio")

                  dom_handler = True ' Prevent button press from closing the dialog box

              ElseIf DlgItem = "Source_domain_dd" Then

                  source_dom_index = SuppValue

                  dom_handler = True ' Prevent button press from closing the dialog box

              ElseIf DlgItem = "Target_domain_dd" Then

                  target_dom_index = SuppValue

                  dom_handler = True ' Prevent button press from closing the dialog box

              ElseIf DlgItem = "source_dict_list" Then

                  source_dict_index = SuppValue

                  If dictionary_list(SuppValue) = "Local" Then

                      Set source_dict = diag.Dictionary
                      init_local_domains "SOURCE"
                      dhQuickSort(source_domain_names)
                      DlgListBoxArray "Source_domain_dd", source_domain_names

                      dom_handler = True

                  Else

                      Set source_dict = diag.EnterpriseDataDictionaries.Item(dictionary_list(SuppValue))
                      init_enterprise_domains source_dict.Name, "SOURCE"
                      dhQuickSort(source_domain_names)
                      DlgListBoxArray "Source_domain_dd", source_domain_names

                      dom_handler = True

                  End If

              ElseIf DlgItem = "target_dict_list" Then

                  target_dict_index = SuppValue

                  If dictionary_list(SuppValue) = "Local" Then

                      Set	target_dict = diag.Dictionary
                      init_local_domains "TARGET"
                      dhQuickSort(target_domain_names)
                      DlgListBoxArray "Target_domain_dd", target_domain_names

                      dom_handler = True

                  Else

                      Set target_dict = diag.EnterpriseDataDictionaries.Item(dictionary_list(SuppValue))
                      init_enterprise_domains target_dict.Name, "TARGET"
                      dhQuickSort(target_domain_names)
                      DlgListBoxArray "Target_domain_dd", target_domain_names

                      dom_handler = True

                  End If

              End If

              Rem dom_handler = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem dom_handler = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant, _
       Optional intLeft As Integer As Integer ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If

      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


Update DB2 OS390 Index Storage Parameters.bas

      'TITLE:  UPDATE DB2 OS390 INDEX STORAGE PARAMETERS.BAS
      'DESCRIPTION:  This macro provides a list of tables from the active
      '	physical model.  The tables in the right box will be updated
      '	with the specified storage parameters.  Tables can be added
      '	and removed from the updated list.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'DATE:  7/7/2004

      Option Explicit

      'Global Array variables to handle available and selected tables.
      Dim AvailableIndexes() As String
      Dim SelectedIndexes() As String
      Dim AvailIndexesIndx As Integer
      Dim SelIndexesIndx As Integer

      Dim Stogroups() As String
      Dim BufferPool() As String

      'Global ERStudio Variables
      Dim mdl As Model
      Dim diag As Diagram
      Dim ents As Entities
      Dim ent As Entity
      Dim indices As Indexes
      Dim indx As Index
      Dim indxcount As Integer

      Type IdxPair
       tblName As String
       idxname As String
      End Type

      Dim IndexPairs() As IdxPair

      Function getTableName ( idx As String ) As String

          Dim i As Integer
          Dim tblName As String

          For i = 0 To indxcount - 1

              If IndexPairs(i).idxname = idx Then
                  getTableName = IndexPairs(i).tblname
                  Exit For
              End If

          Next

          'getTableName = ""

      End Function

      'This function is used to initialize the passed-in array with all
      'the tables in the physical model.  It will fill the target array
      'when the AddAll and RemoveAll buttons in the dialog are pressed.
      Function SetupIndexArray(indxs As Variant)

          Debug.Print "SetupIndexArray"

          Dim i,count As Integer

          count = indxcount - 1

          i = 0

          If count < 0 Then

              ReDim indxs(0) As String

          Else

              ReDim indxs (0 To count) As String

              'Refresh Array with table names
              For i = 0 To indxcount - 1

                  indxs(i) = IndexPairs(i).tblName & "  --  " & IndexPairs(i).idxName
                  Debug.Print vbTab & i & " = " & indxs(i)

              Next
              Debug.Print indxcount

          End If

      End Function

      'This function clears the passed-in array of all the names.  It clears the
      'source array when the AddAll and RemoveAll buttons are pressed.
      Function ClearIndexArray(indxs As Variant)

          Dim i,count As Integer

          count = indxcount - 1

          If count < 0 Then

              ReDim indxs(0) As String

          Else

              ReDim indxs (0 To count) As String

              For i = 0 To indxcount - 1
                  indxs(i) = ""
                  i = i + 1
              Next

          End If

      End Function

      Function SetupStogroups()

          Dim i, count As Integer
          Dim sto As DB2StoGroup

          count = mdl.DB2StoGroups.Count - 1
          Debug.Print mdl.DB2StoGroups.Count
          i = 0

          If count < 0 Then

              ReDim Stogroups(0)

          Else

              ReDim Stogroups(0 To count)

              For Each sto In mdl.DB2StoGroups

                  Stogroups(i) = sto.Name
                  i = i + 1

              Next

          End If

      End Function

      'This function is used to move single tables between the listboxes.  It
      'will add tables to the front of the target array and pad the back of the
      'source array with blank entries
      Function MoveIndex (source As Variant, target As Variant, source_indx As Integer)

          Dim s_count As Integer  'upper bound of the source array
          Dim t_count As Integer  'upper bound of the target array
          Dim i As Integer

          s_count = UBound(source)
          t_count = UBound(target) - 1

          Debug.Print "t_count = " & t_count

          'move all the entries back one slot in the target array to make
          'room for the new entry
          For i = t_count To 0 Step -1
              target(i+1) = target(i)
              Debug.Print "target(" & i & ") = " & target(i)
          Next i

          'add the new entry
          target(0) = source(source_indx)
          Debug.Print source(source_indx) & ", index = " & source_indx

          'move all the entries after the vacant slot up one slot to fill the hole
          For i = source_indx + 1 To s_count
              source(i-1) = source(i)
          Next i

          'pad the last entry with a null string
          source(s_count) = ""

      End Function

      Function setupBufferPool()

          ReDim BufferPool(0 To 80)

          BufferPool(0) = "(none)"
          BufferPool(1) = "BP0"
          BufferPool(2) = "BP1"
          BufferPool(3) = "BP2"
          BufferPool(4) = "BP3"
          BufferPool(5) = "BP4"
          BufferPool(6) = "BP5"
          BufferPool(7) = "BP6"
          BufferPool(8) = "BP7"
          BufferPool(9) = "BP8"
          BufferPool(10) = "BP9"
          BufferPool(11) = "BP10"
          BufferPool(12) = "BP11"
          BufferPool(13) = "BP12"
          BufferPool(14) = "BP13"
          BufferPool(15) = "BP14"
          BufferPool(16) = "BP15"
          BufferPool(17) = "BP16"
          BufferPool(18) = "BP17"
          BufferPool(19) = "BP18"
          BufferPool(20) = "BP19"
          BufferPool(21) = "BP20"
          BufferPool(22) = "BP21"
          BufferPool(23) = "BP22"
          BufferPool(24) = "BP23"
          BufferPool(25) = "BP24"
          BufferPool(26) = "BP25"
          BufferPool(27) = "BP26"
          BufferPool(28) = "BP27"
          BufferPool(29) = "BP28"
          BufferPool(30) = "BP29"
          BufferPool(31) = "BP30"
          BufferPool(32) = "BP31"
          BufferPool(33) = "BP32"
          BufferPool(34) = "BP33"
          BufferPool(35) = "BP34"
          BufferPool(36) = "BP35"
          BufferPool(37) = "BP36"
          BufferPool(38) = "BP37"
          BufferPool(39) = "BP38"
          BufferPool(40) = "BP39"
          BufferPool(41) = "BP40"
          BufferPool(42) = "BP41"
          BufferPool(43) = "BP42"
          BufferPool(44) = "BP43"
          BufferPool(45) = "BP44"
          BufferPool(46) = "BP45"
          BufferPool(47) = "BP46"
          BufferPool(48) = "BP47"
          BufferPool(49) = "BP48"
          BufferPool(50) = "BP49"
          BufferPool(51) = "BP8K0"
          BufferPool(52) = "BP8K1"
          BufferPool(53) = "BP8K2"
          BufferPool(54) = "BP8K3"
          BufferPool(55) = "BP8K4"
          BufferPool(56) = "BP8K5"
          BufferPool(57) = "BP8K6"
          BufferPool(58) = "BP8K7"
          BufferPool(59) = "BP8K8"
          BufferPool(60) = "BP8K9"
          BufferPool(61) = "BP16K0"
          BufferPool(62) = "BP16K1"
          BufferPool(63) = "BP16K2"
          BufferPool(64) = "BP16K3"
          BufferPool(65) = "BP16K4"
          BufferPool(66) = "BP16K5"
          BufferPool(67) = "BP16K6"
          BufferPool(68) = "BP16K7"
          BufferPool(69) = "BP16K8"
          BufferPool(70) = "BP16K9"
          BufferPool(71) = "BP32K"
          BufferPool(72) = "BP32K1"
          BufferPool(73) = "BP32K2"
          BufferPool(74) = "BP32K3"
          BufferPool(75) = "BP32K4"
          BufferPool(76) = "BP32K5"
          BufferPool(77) = "BP32K6"
          BufferPool(78) = "BP32K7"
          BufferPool(79) = "BP32K8"
          BufferPool(80) = "BP32K9"

      End Function

      Sub Main

          Debug.Clear

          'set ERStudio variables
          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set ents = mdl.Entities

          Dim count As Integer
          Dim i As Integer
          Dim tbl As String
          Dim idx As String
          Dim DBplatform As String

          If mdl.MajorPlatform <> "IBM DB2" Then

              MsgBox("Physical Model platform must be DB2 OS/390",,"Error!")

          Else

          Debug.Print "Initialize"

          For Each ent In mdl.Entities

               indxcount = indxcount + ent.Indexes.Count

               If ent.Indexes.Count <> 0 Then

                   ReDim Preserve IndexPairs (0 To indxcount - 1) As IdxPair

                   For Each indx In ent.Indexes

                         IndexPairs(i).tblname = ent.TableName
                         IndexPairs(i).idxname = indx.Name
                         Debug.Print i & " = " & IndexPairs(i).idxname
                         i = i + 1

                   Next

               End If

           Next

           Debug.Print indxcount

          'initialize global arrays and indexes
          SetupIndexArray(AvailableIndexes)
          ClearIndexArray(SelectedIndexes)
          AvailIndexesIndx = 0
          SelIndexesIndx = 0

          SetupStogroups()
          setupBufferPool()

          'Create the dialog
          Begin Dialog UserDialog 1150,483,"OS390 Index Storage Parameters",.DialogFunc ' %GRID:10,7,1,1
              GroupBox 640,266,480,154,"Selected Indexes",.GroupBox2
              ListBox 650,280,460,140,SelectedIndexes(),.SIndexes
              PushButton 550,273,60,21,">>",.AddAll
              GroupBox 30,266,490,154,"Available Indexes",.GroupBox1
              ListBox 40,280,460,140,AvailableIndexes(),.AIndexes
              PushButton 550,301,60,21,">",.AddSelected
              PushButton 550,357,60,21,"<",.RemoveSelected
              PushButton 550,385,60,21,"<<",.RemoveAll
              OKButton 730,434,130,28
              CancelButton 880,434,130,28
              CheckBox 230,7,90,14,"Unique",.UniqueChbx
              CheckBox 230,28,90,14,"Cluster",.ClusterChbx
              CheckBox 600,7,180,14,"Do Not Close Dataset",.CloseChbx
              CheckBox 380,28,160,14,"Concurrent Copy",.CopyChbx
              GroupBox 200,49,600,175,"Storage Options",.GroupBox3
              Text 230,70,90,14,"Using Clause",.Text1
              OptionGroup .UsingClause
                  OptionButton 250,91,90,14,"VCAT",.Vcat
                  OptionButton 250,119,110,14,"STOGROUP",.StoGroup
              Text 260,147,60,14,"PRIQTY",.PriQty
              Text 260,168,70,14,"SECQTY",.SecQty
              CheckBox 230,196,100,14,"Erase Data",.erasedataChbx
              TextBox 370,84,150,21,.VCATtxt
              DropListBox 370,112,180,119,Stogroups(),.StoGrpName,1
              TextBox 370,140,150,21,.PRIQTYtxt
              TextBox 370,168,150,21,.SECQTYtxt
              Text 570,70,90,14,"Buffer Pool",.Text4
              Text 570,98,90,14,"Percent Free",.Text5
              Text 570,126,90,14,"Free Page",.Text6
              Text 570,154,90,14,"Piece Size",.Text7
              DropListBox 680,63,100,140,BufferPool(),.BufferPool
              TextBox 680,91,100,21,.PercentFreetxt
              TextBox 680,119,100,21,.FreePagetxt
              TextBox 680,147,100,21,.PieceSizetxt
              Text 570,182,90,14,"GBP Cache",.Text8
              OptionGroup .GBPCache
                  OptionButton 680,175,90,14,"Changed",.Changed
                  OptionButton 680,189,90,14,"All",.All
                  OptionButton 680,203,90,14,"None",.None
              PushButton 90,238,90,21,"Sort List",.SortAvail
              PushButton 590,238,90,21,"Sort List",.SortSel
              CheckBox 380,7,140,14,"Where Not Null",.wherenotnullchbx
              CheckBox 600,28,180,14,"Defer Index Creation",.deferchbx
          End Dialog
          Dim dlg As UserDialog

          Dim Label As String
          Dim x As Integer
          Dim y As Integer
          Dim Length As Integer
          Dim ixname As String

          'initialize dialog, -1 is the OK button, 0 is the CANCEL
          If Dialog(dlg,-2) = -1 Then

              'Iterate through all the tables from the SelectedTables array
              For count = 0 To indxcount - 1

                  'don't want the null values in the SelectedTables array
                  If SelectedIndexes(count) <> "" Then

                      'Get table name
                      Label = SelectedIndexes(count)
                      x = InStr(1, Label, "  --  ")
                      tbl = Left(Label, x - 1)
                      Debug.Print "table= " & tbl

                      'get index name
                      x = x + 5
                      Length = Len(Label)
                      y = Length - x
                      ixname = Right(Label, y)
                      Debug.Print "index= " & ixname

                      'get the respective entity
                      Set ent = mdl.Entities.Item(tbl)

                      'now get the respective index
                      Set indx = ent.Indexes.Item(ixname)

                      If dlg.usingclause = 1 Then

                          If dlg.stogrpname <> "" Then

                              indx.IsStoGroup = True
                              indx.Location = dlg.stogrpname

                              If dlg.priqtytxt <> "" Then
                                  indx.InitialExtentSize = CLng(dlg.priqtytxt)
                              End If

                              If dlg.secqtytxt <> "" Then
                                  indx.NextExtentSize = CLng(dlg.secqtytxt)
                              End If

                              If dlg.erasedatachbx = 1 Then
                                  indx.DB2Erase = True
                              Else
                                  indx.DB2Erase = False
                              End If

                          End If

                      Else

                          If dlg.vcattxt <> "" Then

                              indx.IsStoGroup = False
                              indx.Location = dlg.vcattxt

                          End If

                      End If

                      If dlg.UniqueChbx = 1 Then
                          indx.Unique = True
                      Else
                          indx.Unique = False
                      End If

                      If dlg.clusterchbx = 1 Then
                          indx.Clustered = True
                      Else
                          indx.Clustered = False
                      End If

                      If dlg.closechbx = 1 Then
                          indx.DB2Close = False
                      Else
                          indx.DB2Close = True
                      End If

                      If dlg.copychbx = 1 Then
                          indx.DB2Copy = True
                      Else
                          indx.DB2Copy = False
                      End If

                      If BufferPool(dlg.BufferPool) <> "(none)" Then
                          indx.DB2BufferPool = BufferPool(dlg.BufferPool)
                      End If

                      If dlg.PercentFreetxt <> "" Then
                          indx.PercentFree = CLng(dlg.PercentFreetxt)
                      End If

                      If dlg.FreePagetxt <> "" Then
                          indx.PercentUsed = CLng(dlg.FreePagetxt)
                      End If

                      If dlg.PieceSizetxt <> "" Then
                          indx.MaximumRowsPerPage = CLng(dlg.PieceSizetxt)
                      End If

                      If dlg.GBPCache = 0 Then

                          indx.GBPCache = "CHANGED"

                      ElseIf dlg.GBPCache = 1 Then

                          indx.GBPCache = "ALL"

                      Else

                          indx.GBPCache = "NONE"

                      End If

                      If dlg.deferchbx = 1 Then

                          indx.DB2Defer = True

                      End If

                      If dlg.wherenotnullchbx = 1 Then

                          indx.DB2UniqueNotNull = True

                      End If

                  End If

              Next

          End If

          End If

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization

              DlgEnable "vcattxt",False
              DlgValue "UsingClause", 1
              DlgEnable "wherenotnullchbx", False

          Case 2 ' Value changing or button pressed

              If DlgItem = "AIndexes" Then

                  'update the AvailIndexesIndx with current index when a
                  'table is selected in the available tables listbox
                  AvailIndexesIndx = SuppValue
                  Debug.Print AvailIndexesIndx

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "SIndexes" Then

                  'update the SelIndexIndx with the current index when a
                  'table is selected in the selected tables listbox
                  SelIndexesIndx = SuppValue
                  Debug.Print SelIndexesIndx

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "AddAll" Then

                  Debug.Print "addall"

                  'add all the tables to the SelectedIndexes array, remove all
                  'from the AvailableTables array
                  SetupIndexArray(SelectedIndexes)
                  ClearIndexArray(AvailableIndexes)

                  'refresh dialog listboxes
                  DlgListBoxArray "SIndexes", SelectedIndexes()
                  DlgListBoxArray "AIndexes", AvailableIndexes()

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "RemoveAll" Then

                  Debug.Print "removeall"

                  'add all the tables to the AvailableTables array, remove all
                  'from the SelectedIndexes array
                  SetupIndexArray(AvailableIndexes)
                  ClearIndexArray(SelectedIndexes)

                  'refresh dialog listboxes
                  DlgListBoxArray "AIndexes", AvailableIndexes()
                  DlgListBoxArray "SIndexes", SelectedIndexes()

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "RemoveSelected" Then

                  'don't move the table if the value is null
                  If SelectedIndexes(SelIndexesIndx) <> "" Then

                      'move the selected table from SelectedIndexes array to the
                      'AvailableIndexes array
                      MoveIndex(SelectedIndexes, AvailableIndexes, SelIndexesIndx)

                      'refresh dialog listboxes
                      DlgListBoxArray "AIndexes", AvailableIndexes()
                      DlgListBoxArray "SIndexes", SelectedIndexes()

                      're-initalize array indexes
                      SelIndexesIndx = 0
                      AvailIndexesIndx = 0

                  End If

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "AddSelected" Then

                  'Don't move table if there isn't any value in the list box
                  If AvailableIndexes(AvailIndexesIndx) <> "" Then

                      'move the selected table from the AvailableIndexes array to
                      'the SelectedIndexes array
                      MoveIndex(AvailableIndexes, SelectedIndexes, AvailIndexesIndx)

                      'refresh dialog listboxes
                      DlgListBoxArray "AIndexes", AvailableIndexes()
                      DlgListBoxArray "SIndexes", SelectedIndexes()

                      're-initalize array indexes
                      SelIndexesIndx = 0
                      AvailIndexesIndx = 0

                  End If

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "SortAvail" Then

                  dhQuickSort AvailableIndexes()
                  adjustArray(AvailableIndexes())
                  DlgListBoxArray "AIndexes", AvailableIndexes()
                  DialogFunc = True

              ElseIf DlgItem = "SortSel" Then

                  dhQuickSort SelectedIndexes()
                  adjustArray(SelectedIndexes())
                  DlgListBoxArray "SIndexes", SelectedIndexes()
                  DialogFunc = True

              ElseIf DlgItem = "UsingClause" Then

                  If DlgValue("UsingClause") = 0 Then

                      DlgEnable "VCATtxt",True
                      DlgEnable "stogrpname",False
                      DlgEnable "PriQtytxt",False
                      DlgEnable "SecQtytxt",False
                      DlgEnable "erasedatachbx",False

                  Else

                      DlgEnable "vcattxt",False
                      DlgEnable "stogrpname",True
                      DlgEnable "PriQtytxt",True
                      DlgEnable "SecQtytxt",True
                      DlgEnable "erasedatachbx",True

                  End If

              ElseIf DlgItem = "UniqueChbx" Then

                  If DlgValue ("UniqueChbx") = 1 Then

                      DlgEnable "wherenotnullchbx", True

                  Else

                      DlgEnable "wherenotnullchbx", False

                  End If

              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed

          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      Function adjustArray(varArray As Variant)

          Dim i, intItems As Integer
          intItems = UBound(varArray)

          While varArray(0) = ""

              For i = 1 To intItems
                  varArray(i - 1) = varArray(i)
              Next

              varArray(intItems) = ""

          Wend

      End Function

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant, _
       Optional intLeft As Integer As Integer ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If

      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


Update DB2 OS390 Table Storage Parameters.bas

      'TITLE:  UPDATE DB2 OS390 TABLE STORAGE PARAMETERS.BAS
      'DESCRIPTION:  This macro provides a list of tables from the active
      '	physical model.  The tables in the right box will be updated
      '	with the specified storage parameters.  Tables can be added
      '	and removed from the updated list.
      'AUTHOR:  Jason Tiret
      'CONTACT:  http://support.embarcadero.com/
      'DATE:  10/17/2001
      'LAST UPDATE:  7/3/2003

      'Global Array variables to handle available and selected tables.
      Dim AvailableTables() As String
      Dim SelectedTables() As String
      Dim AvailTablesIndx As Integer
      Dim SelTablesIndx As Integer

      Dim Databases() As String
      Dim Tablespaces() As String

      'Global ERStudio Variables
      Dim mdl As Model
      Dim diag As Diagram
      Dim ents As Entities
      Dim ent As Entity
      Dim entcount As Integer

      'This function is used to initialize the passed-in array with all
      'the tables in the physical model.  It will fill the target array
      'when the AddAll and RemoveAll buttons in the dialog are pressed.
      Function SetupTableArray(Tables As Variant)

          Debug.Print "SetupTableArray"

          Dim i As Integer

          entcount = ents.Count - 1
          i = 0

          If entcount < 0 Then

              ReDim Tables(0)

          Else

              're-initialize the array
              ReDim Tables(0 To entcount) As String

              'Refresh Array with table names
              For Each ent In mdl.Entities

                  Tables(i) = ent.TableName
                  i = i + 1

              Next

          End If

      End Function

      'This function clears the passed-in array of all the names.  It clears the
      'source array when the AddAll and RemoveAll buttons are pressed.
      Function ClearTableArray(Tables As Variant)

          Debug.Print "ClearTableArray"

          entcount = ents.Count - 1

          If entcount < 0 Then

              ReDim Tables(0)

          Else

              'Clear the Array
              ReDim Tables(0 To entcount) As String

              For Each ent In mdl.Entities
                  Tables(i) = ""
              Next

          End If

      End Function

      'This function is used to move single tables between the listboxes.  It
      'will add tables to the front of the target array and pad the back of the
      'source array with blank entries
      Function MoveTable (source As Variant, target As Variant, source_indx As Integer)

          Dim s_count As Integer  'upper bound of the source array
          Dim t_count As Integer  'upper bound of the target array
          Dim i As Integer

          s_count = UBound(source)
          t_count = UBound(target) - 1

          Debug.Print "t_count = " & t_count

          'move all the entries back one slot in the target array to make
          'room for the new entry
          For i = t_count To 0 Step -1
              target(i+1) = target(i)
              Debug.Print "target(" & i & ") = " & target(i)
          Next i

          'add the new entry
          target(0) = source(source_indx)
          Debug.Print source(source_indx) & ", index = " & source_indx

          'move all the entries after the vacant slot up one slot to fill the hole
          For i = source_indx + 1 To s_count
              source(i-1) = source(i)
          Next i

          'pad the last entry with a null string
          source(s_count) = ""

      End Function

      Function setupTablespaces()

          Dim i, count As Integer
          Dim tblspc As DB2Tablespace

          i = 0
          count = mdl.DB2Tablespaces.Count - 1

          If count < 0 Then

              ReDim Tablespaces(0)

          Else

              ReDim Tablespaces(0 To count)

              For Each tblspc In mdl.DB2Tablespaces

                  Tablespaces(i) = tblspc.Name
                  i = i + 1

              Next

          End If

      End Function

      Function setupDatabases()

          Dim i, count As Integer
          Dim db As DB2Database

          i = 0
          count = mdl.DB2Databases.Count - 1

          If count < 0 Then

              ReDim database(0)

          Else

              ReDim Databases(0 To count)

              For Each db In mdl.DB2Databases

                  Databases(i) = db.Name
                  i = i + 1

              Next

          End If

      End Function

      Sub Main

          Debug.Clear

          'set ERStudio variables
          Set diag = DiagramManager.ActiveDiagram
          Set mdl = diag.ActiveModel
          Set ents = mdl.Entities

          Dim count As Integer

          If mdl.MajorPlatform  <> "IBM DB2" Then

          MsgBox("Physical Model platform must be DB2 OS/390",,"Error!")

          Else

          'initialize global arrays and indexes
          SetupTableArray(AvailableTables)
          ClearTableArray(SelectedTables)
          AvailTablesIndx = 0
          SelTablesIndx = 0

          setupTablespaces()
          setupDatabases()

          'Create the dialog
          Begin Dialog UserDialog 730,553,"DB2 Storage Parameters",.DialogFunc ' %GRID:10,7,1,1
              GroupBox 410,287,300,203,"Selected Tables",.GroupBox2
              ListBox 420,301,280,189,SelectedTables(),.STables
              GroupBox 20,14,320,98,"Location",.GroupBox3
              Text 40,63,80,14,"Tablespace:",.Text1
              PushButton 330,315,60,21,">>",.AddAll
              GroupBox 20,287,290,203,"Available Tables",.GroupBox1
              ListBox 30,301,270,189,AvailableTables(),.ATables
              PushButton 330,350,60,21,">",.AddSelected
              PushButton 330,420,60,21,"<",.RemoveSelected
              PushButton 330,455,60,21,"<<",.RemoveAll
              OKButton 360,504,130,28
              CancelButton 520,504,130,28
              Text 40,35,80,14,"Database:",.Text2
              DropListBox 140,28,180,112,Databases(),.Database,1
              DropListBox 140,56,180,175,Tablespaces(),.TableSpace,1
              CheckBox 60,126,90,14,"Encoding",.EncodingChbx
              CheckBox 200,126,130,14,"Restrict On Drop",.restrictChbx
              OptionGroup .EncodingOpt
                  OptionButton 100,147,90,14,"ASCII",.OptionButton1
                  OptionButton 100,168,90,14,"EBCDIC",.OptionButton2
              GroupBox 30,189,310,49,"Logging",.GroupBox4
              CheckBox 60,210,170,14,"Log Data Changes",.LogDataChbx
              GroupBox 370,14,330,98,"Table Procedures",.GroupBox5
              Text 400,42,90,14,"Edit Proc:",.Text3
              Text 400,70,90,14,"Valid Proc:",.Text4
              TextBox 490,42,170,21,.Editproc
              TextBox 490,70,170,21,.ValidProc
              GroupBox 370,133,330,105,"Audit Option",.GroupBox6
              OptionGroup .AuditOpt
                  OptionButton 450,154,90,14,"None",.OptionButton3
                  OptionButton 450,182,90,14,"Changes",.OptionButton4
                  OptionButton 450,210,90,14,"All",.OptionButton5
              PushButton 40,252,120,21,"Sort List",.SortAvail
              PushButton 430,252,110,21,"Sort List",.SortSel
          End Dialog
          Dim dlg As UserDialog

          'initialize dialog, -1 is the OK button, 0 is the CANCEL
          If Dialog(dlg,-2) = -1 Then

              'reinitialize entity count
              entcount = ents.Count - 1

              'Iterate through all the tables from the SelectedTables array
              For count = 0 To entcount

                  'don't want the null values in the SelectedTables array
                  If SelectedTables(count) <> "" Then

                      Set ent = ents.Item(SelectedTables(count))

                      'Update the tablespace and database location with the give tablespace name
                      If dlg.Database <> "" Then
                          ent.DatabaseLocation = dlg.Database
                      End If

                      If dlg.TableSpace <> "" Then
                          ent.StorageLocation = dlg.TableSpace
                      End If

                      'Update the Edit proc
                      If dlg.editproc <> "" Then
                          ent.DB2EditProc = dlg.editproc
                      End If

                      'Update the Valid proc
                      If dlg.validproc <> "" Then
                          ent.DB2ValidProc = dlg.validproc
                      End If

                      'Update the restrict option
                      If dlg.restrictchbx = 1 Then
                          ent.DB2RestrictOnDrop = True
                      Else
                          ent.DB2RestrictOnDrop = False
                      End If

                      'Update encoding option
                      If dlg.encodingchbx = 1 Then

                          'determine which type of encoding
                          If dlg.encodingopt = 0 Then
                              ent.DB2Encoding = "ASCII"
                          Else
                              ent.DB2Encoding = "EBCDIC"
                          End If

                      Else

                          ent.DB2Encoding = "NONE"

                      End If

                      'Update audit option
                      If dlg.auditopt = 0 Then
                          ent.DB2Auditing = "NONE"
                      ElseIf dlg.auditopt = 1 Then
                          ent.DB2Auditing = "CHANGES"
                      Else
                          ent.DB2Auditing = "ALL"
                      End If

                      'Update logging option
                      If dlg.logdatachbx = 1 Then
                          ent.DB2DataCaptureChg = True
                      Else
                          ent.DB2DataCaptureChg = False
                      End If

                  End If

              Next

          End If

          End If

      End Sub

      Rem See DialogFunc help topic for more information.
      Private Function DialogFunc(DlgItem$, Action%, SuppValue&) As Boolean
          Select Case Action%
          Case 1 ' Dialog box initialization
          Case 2 ' Value changing or button pressed

              If DlgItem = "ATables" Then

                  'update the AvailTablesIndx with current index when a
                  'table is selected in the available tables listbox
                  AvailTablesIndx = SuppValue
                  Debug.Print AvailTablesIndx

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "STables" Then

                  'update the SelTablesIndx with the current index when a
                  'table is selected in the selected tables listbox
                  SelTablesIndx = SuppValue
                  Debug.Print SelTablesIndx

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "AddAll" Then

                  Debug.Print "addall"

                  'add all the tables to the SelectedTables array, remove all
                  'from the AvailableTables array
                  SetupTableArray(SelectedTables)
                  ClearTableArray(AvailableTables)

                  'refresh dialog listboxes
                  DlgListBoxArray "STables", SelectedTables()
                  DlgListBoxArray "ATables", AvailableTables()

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "RemoveAll" Then

                  Debug.Print "removeall"

                  'add all the tables to the AvailableTables array, remove all
                  'from the SelectedTables array
                  SetupTableArray(AvailableTables)
                  ClearTableArray(SelectedTables)

                  'refresh dialog listboxes
                  DlgListBoxArray "ATables", AvailableTables()
                  DlgListBoxArray "STables", SelectedTables()

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "RemoveSelected" Then

                  'don't move the table if the value is null
                  If SelectedTables(SelTablesIndx) <> "" Then

                      'move the selected table from SelectedTables array to the
                      'AvailableTables array
                      MoveTable(SelectedTables, AvailableTables, SelTablesIndx)

                      'refresh dialog listboxes
                      DlgListBoxArray "ATables", AvailableTables()
                      DlgListBoxArray "STables", SelectedTables()

                      're-initalize array indexes
                      SelTablesIndx = 0
                      AvailTablesIndx = 0

                  End If

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "AddSelected" Then

                  'Don't move table if there isn't any value in the list box
                  If AvailableTables(AvailTablesIndx) <> "" Then

                      'move the selected table from the AvailableTables array to
                      'the SelectedTables array
                      MoveTable(AvailableTables, SelectedTables, AvailTablesIndx)

                      'refresh dialog listboxes
                      DlgListBoxArray "ATables", AvailableTables()
                      DlgListBoxArray "STables", SelectedTables()

                      're-initalize array indexes
                      SelTablesIndx = 0
                      AvailTablesIndx = 0

                  End If

                  'don't exit dialog
                  DialogFunc = True

              ElseIf DlgItem = "SortAvail" Then

                  dhQuickSort AvailableTables()
                  adjustArray(AvailableTables())
                  DlgListBoxArray "ATables", AvailableTables()
                  DialogFunc = True

              ElseIf DlgItem = "SortSel" Then

                  dhQuickSort SelectedTables()
                  adjustArray(selectedtables())
                  DlgListBoxArray "STables", SelectedTables()
                  DialogFunc = True

              End If

              Rem DialogFunc = True ' Prevent button press from closing the dialog box
          Case 3 ' TextBox or ComboBox text changed
          Case 4 ' Focus changed
          Case 5 ' Idle
              Rem DialogFunc = True ' Continue getting idle actions
          Case 6 ' Function key
          End Select
      End Function

      Function adjustArray(varArray As Variant)

          Dim i, intItems As Integer
          intItems = UBound(varArray)

          While varArray(0) = ""

              For i = 1 To intItems
                  varArray(i - 1) = varArray(i)
              Next

              varArray(intItems) = ""

          Wend

      End Function

      ' From "VBA Developer's Handbook"
      ' by Ken Getz and Mike Gilbert
      ' Copyright 1997; Sybex, Inc. All rights reserved.

      ' Quicksort for simple data types.

      ' Indicate that a parameter is missing.
      Const dhcMissing = -2

      Sub dhQuickSort(varArray As Variant, _
       Optional intLeft As Integer As Integer ' From "VBA Developer's Handbook"
          ' by Ken Getz and Mike Gilbert
          ' Copyright 1997; Sybex, Inc. All rights reserved.

          ' Entry point for sorting the array.

          ' This technique uses the recursive Quicksort
          ' algorithm to perform its sort.

          ' In:
          '   varArray:
          '       A variant pointing to an array to be sorted.
          '       This had better actually be an array, or the
          '       code will fail, miserably. You could add
          '       a test for this:
          '       If Not IsArray(varArray) Then Exit Sub
          '       but hey, that would slow this down, and it's
          '       only YOU calling this procedure.
          '       Make sure it's an array. It's your problem.
          '   intLeft:
          '   intRight:
          '       Lower and upper bounds of the array to be sorted.
          '       If you don't supply these values (and normally, you won't)
          '       the code uses the LBound and UBound functions
          '       to get the information. In recursive calls
          '       to the sort, the caller will pass this information in.
          '       To allow for passing integers around (instead of
          '       larger, slower variants), the code uses -2 to indicate
          '       that you've not passed a value. This means that you won't
          '       be able to use this mechanism to sort arrays with negative
          '       indexes, unless you modify this code.
          ' Out:
          '       The data in varArray will be sorted.

          Dim i As Integer
          Dim j As Integer
          Dim varTestVal As Variant
          Dim intMid As Integer

          If intLeft = dhcMissing Then intLeft = LBound(varArray)
          If intRight = dhcMissing Then intRight = UBound(varArray)

          If intLeft < intRight Then
              intMid = (intLeft + intRight) \ 2
              varTestVal = UCase(varArray(intMid))
              i = intLeft
              j = intRight
              Do
                  Do While UCase(varArray(i)) < varTestVal
                      i = i + 1
                  Loop
                  Do While UCase(varArray(j)) > varTestVal
                      j = j - 1
                  Loop
                  If i <= j Then
                      SwapElements varArray, i, j
                      i = i + 1
                      j = j - 1
                  End If
              Loop Until i > j
              ' To optimize the sort, always sort the
              ' smallest segment first.
              If j <= intMid Then
                  Call dhQuickSort(varArray, intLeft, j)
                  Call dhQuickSort(varArray, i, intRight)
              Else
                  Call dhQuickSort(varArray, i, intRight)
                  Call dhQuickSort(varArray, intLeft, j)
              End If
          End If

      End Sub

      Private Sub SwapElements(varItems As Variant, intItem1 As Integer, intItem2 As Integer)
          Dim varTemp As Variant

          varTemp = varItems(intItem2)
          varItems(intItem2) = varItems(intItem1)
          varItems(intItem1) = varTemp
      End Sub


%%PageItemTitle%%

Application Collection
See Also Members

Description

This is the main object through which all other objects are accessed from. The Programmatic ID (PROGID) for this object is 'ERStudio.Application'. Macros, which run inside ER/Studio's Macro Editor, will use the pre-initialized 'DiagramManager' object.

Object Model

Remarks

Within the Macro Editor, DiagramManager is the parent object that provides access to all other ER/Studio objects. The DiagramManager object is declared/created when you start the Macro Editor. You can immediately start using this object. You do not need to create it.

Good Programming Practice: Use the DiagramManager.GetLastErrorCode() or DiagramManager.GetLastErrorString() to check for errors after method calls.

If you run macros outside of the ER/Studio Macro Editor (for example, in Visual Studio), you must create the Application object through a method call. In Visual Basic, you can call CreateObject. The Programmatic ID (PROGID) for the Application object is ERStudio.Application.

In this external case, you'll need to create a link to the ER/Studio Type Library and declare ERStudio object types. Example applications in VB6, and .Net VB and C# are in your installation directory under "..\ERStudioX.X\Readme\TableList.zip."

See Also

Application Members


%%PageItemTitle%% $$Members$$

Application Collection Members
See Also Overview

Public Methods

Public Method ActiveDataDictionary | Returns the current, active Data Dictionary.
Public Method ActiveDiagram | Returns the current, active diagram.
Public Method CloseDiagram | Closes the diagram specified by the given, title string. PARAMETERS: Identifier as String.
Public Method CreateStringObjects | Returns a newly created and empty StringObjects.
Public Method DeleteNamedRelease | Delete a NamedRelease from the Repo Server using the given Name. Return value is 1 if it succeeded, else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.
Public Method EnableScreenUpdate | Enable (TRUE) or disable(FALSE) the screen updates of the diagram. PARAMETERS: Enable as Boolean.
Public Method EnableScreenUpdateEx | EnableTreeUpdate as Boolean, Enable or disable the screen and explorer tree updates of the diagram. PARAMETERS: EnableViewUpdate as Boolean.
Public Method GetAllNamedReleases | Returns the name of all NamedReleases.
Public Method GetLastErrorCode | Returns the last ErrorCode of the Diagram. It returns zero if the last operation succeeded. RETURN DATATYPE: Integer.
Public Method GetLastErrorString | Returns the last ErrorString (error detail) of the Diagram. It returns an empty string if the last operation succeeded. RETURN DATATYPE: String.
Public Method GetNamedRelease | Directory as String, Get a NamedRelease from the Repo Server using the given Name, and save it to given directory. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.
Public Method GetRegistryKey | Returns the Registry Key for this application. RETURN DATATYPE: String.
Public Method HideWindow | Make the application hidden. Use this outside of ERStudio such as in a VB Application.
Public Method ImportERXFile | Imports the given, complete file path of the .erx file, and opens a new diagram for the imported .erx file. PARAMETERS: FullFilePath as String.
Public Method ImportSQLFile | Imports the given, complete file path of the .sql file, and opens a new diagram for the imported .sql file. PARAMETERS: FullFilePath as String, TargetDatabasePlatform as String.
Public Method MetaImportObject | Returns an object which provides an interface for importing various file formats via MIMB (implements functionality of MetaWizard (import) for Automation.
Public Method NewDiagram | Opens a new diagram.
Public Method OpenFile | Reads in the given, complete file path of the .dm1 file, and opens a new diagram for the .dm1 file. PARAMETERS: FullFilePath as String.
Public Method Quit | Shutdown ER/Studio without saving any documents.
Public Method RepoAvailableSubmodels | Returns the collection of submodels (of the given diagram) available in the repository. PARAMETERS: DiagramName (String).
Public Method RepoDataDictionaries | Returns all Data Dictionary names from the Repo Server.
Public Method RepoDeleteDiagram | Delete a Diagram from the Repo Server using the given Diagram Name. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.
Public Method RepoDiagrams | Returns all Diagram names from the Repo Server.
Public Method RepoGetDiagram | GetDiagram from the Repo Server using the given Diagram Name. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.
Public Method RepoLogin | Login to the Repo Server using the given Name and Password. Return value is 1 if it succeeded, else it's 0. PARAMETERS: Name as String and Password as String. RETURN DATATYPE: Integer.
Public Method RepoLogout | Logout of the Repo Server. Return value is 1 if it succeeded, else it's 0. RETURN DATATYPE: Integer.
Public Method RepoObjectPrivileges | Returns all ObjectPrivilege names from the Repo Server.
Public Method RepoProjects | Returns all Projects from the Repo Server.
Public Method RepoRoles | Returns all Roles from the Repo Server.
Public Method RepoSoftDeleteDiagram | Delete a Diagram from the Repo Server but leave data still in the database (marked as deleted). Uses the given Diagram Name. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.
Public Method RepoUsers | Returns all Users from the Repo Server.
Public Method ReverseEngineerObject | Returns an object which provides an interface for reverse-engineering.
Public Method ShowWindow | If the application is hidden, this will make the application visible.
Public Method SynchronizeComments | Synchronize the user comments in the dm1 file with the ones in the repository database. Return value is 1 if it succeeded else it is 0.

Public Properties

Public Property _DiagramItem | Returns a diagram, given the diagram's title. PARAMETERS: Identifier as String.
Public Property _NewEnum |
Public Property CurrentUser | Returns the name of the user that is currently logged in. DATATYPE: String.
Public Property DiagramCount | Returns the number of currently, open diagrams. DATATYPE: Integer.
Public Property DiagramItem | Returns a diagram, given the diagram's title. PARAMETERS: Identifier as String.
Public Property ERSFullVersion | This property displays the ERStudio.exe Full Version and Build Number. DATATYPE: String.
Public Property ERSVersion | This property displays the ERStudio.exe Version and Build Number. DATATYPE: String.
Public Property HideRepositoryIcon | This Boolean flag controls the showing or hiding of Repository Status Icon. DATATYPE: Boolean.
Public Property RepoActiveDirectory | This is the Repository Active Directory of ER/Studio. DATATYPE: String.

See Also

Application Overview


%%PageItemTitle%%

ActiveDataDictionary Method
See Also

Description

Returns the current, active Data Dictionary.

Syntax

Visual Basic
Public Function ActiveDataDictionary() As Dictionary

See Also

Application Collection


%%PageItemTitle%%

ActiveDiagram Method

Description

Returns the current, active diagram.

Syntax

Visual Basic
Public Function ActiveDiagram() As Diagram

Example

Dim MyDiagram As Diagram

Set MyDiagram = DiagramManager.ActiveDiagram

See Also

Application Collection


%%PageItemTitle%%

CloseDiagram Method
Identifier

Description

Closes the diagram specified by the given, title string. PARAMETERS: Identifier as String.

Syntax

Visual Basic
Public Sub CloseDiagram( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

Example

Dim strFile As String

strFile = "MyDiagram.DM1"

DiagramManager.CloseDiagram(strFile)

See Also

Application Collection


%%PageItemTitle%%

CreateStringObjects Method

Description

Returns a newly created and empty StringObjects.

Syntax

Visual Basic
Public Function CreateStringObjects() As StringObjects

Example

Sub Main
Dim strObjects As StringObjects
Dim strObj As StringObject

Debug.Clear

Set strObjects = DiagramManager.CreateStringObjects

Set strObj = strObjects.Add("A")
Set strObj = strObjects.Add("B")
Set strObj = strObjects.Add("C")

For Each strObj In strObjects
Debug.Print strObj.StringValue
Next
End Sub

See Also

Application Collection


%%PageItemTitle%%

DeleteNamedRelease Method
Name

Description

Delete a NamedRelease from the Repo Server using the given Name. Return value is 1 if it succeeded, else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function DeleteNamedRelease( _
   ByVal Name As Variant _
) As Variant

Parameters

Name

Example

Dim CheckReturn As Integer

CheckReturn = 0

Dim MyDiagram As Diagram

Set MyDiagram = DiagramManager.ActiveDiagram

CheckReturn = DiagramManager.DeleteNamedRelease("MyDiagram.DM1")

See Also

Application Collection


%%PageItemTitle%%

EnableScreenUpdate Method
Enable

Description

Enable (TRUE) or disable(FALSE) the screen updates of the diagram. PARAMETERS: Enable as Boolean.

Syntax

Visual Basic
Public Function EnableScreenUpdate( _
   ByVal Enable As Variant _
) As Variant

Parameters

Enable

See Also

Application Collection


%%PageItemTitle%%

EnableScreenUpdateEx Method
EnableViewUpdate
EnableTreeUpdate

Description

EnableTreeUpdate as Boolean, Enable or disable the screen and explorer tree updates of the diagram. PARAMETERS: EnableViewUpdate as Boolean.

Syntax

Visual Basic
Public Function EnableScreenUpdateEx( _
   ByVal EnableViewUpdate As Variant, _
   ByVal EnableTreeUpdate As Variant _
) As Variant

Parameters

EnableViewUpdate
EnableTreeUpdate

See Also

Application Collection


%%PageItemTitle%%

GetAllNamedReleases Method

Description

Returns the name of all NamedReleases.

Syntax

Visual Basic
Public Function GetAllNamedReleases() As StringObjects

See Also

Application Collection


%%PageItemTitle%%

GetLastErrorCode Method

Description

Returns the last ErrorCode of the Diagram. It returns zero if the last operation succeeded. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetLastErrorCode() As Variant

See Also

Application Collection


%%PageItemTitle%%

GetLastErrorString Method

Description

Returns the last ErrorString (error detail) of the Diagram. It returns an empty string if the last operation succeeded. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function GetLastErrorString() As Variant

See Also

Application Collection


%%PageItemTitle%%

GetNamedRelease Method
Name
Directory

Description

Directory as String, Get a NamedRelease from the Repo Server using the given Name, and save it to given directory. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetNamedRelease( _
   ByVal Name As Variant, _
   ByVal Directory As Variant _
) As Variant

Parameters

Name
Directory

See Also

Application Collection


%%PageItemTitle%%

GetRegistryKey Method

Description

Returns the Registry Key for this application. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function GetRegistryKey() As Variant

See Also

Application Collection


%%PageItemTitle%%

HideWindow Method

Description

Make the application hidden. Use this outside of ERStudio such as in a VB Application.

Syntax

Visual Basic
Public Sub HideWindow()

See Also

Application Collection


%%PageItemTitle%%

ImportERXFile Method
FullFilePath

Description

Imports the given, complete file path of the .erx file, and opens a new diagram for the imported .erx file. PARAMETERS: FullFilePath as String.

Syntax

Visual Basic
Public Function ImportERXFile( _
   ByVal FullFilePath As Variant _
) As Diagram

Parameters

FullFilePath

See Also

Application Collection


%%PageItemTitle%%

ImportSQLFile Method
FullFilePath
TargetDatabasePlatform

Description

Imports the given, complete file path of the .sql file, and opens a new diagram for the imported .sql file. PARAMETERS: FullFilePath as String, TargetDatabasePlatform as String.

Syntax

Visual Basic
Public Function ImportSQLFile( _
   ByVal FullFilePath As Variant, _
   ByVal TargetDatabasePlatform As Variant _
) As Diagram

Parameters

FullFilePath
TargetDatabasePlatform

See Also

Application Collection


%%PageItemTitle%%

MetaImportObject Method

Description

Returns an object which provides an interface for importing various file formats via MIMB (implements functionality of MetaWizard (import) for Automation.

Syntax

Visual Basic
Public Function MetaImportObject() As MetaImportObject

See Also

Application Collection


%%PageItemTitle%%

NewDiagram Method

Description

Opens a new diagram.

Syntax

Visual Basic
Public Function NewDiagram() As Diagram

See Also

Application Collection


%%PageItemTitle%%

OpenFile Method
FullFilePath

Description

Reads in the given, complete file path of the .dm1 file, and opens a new diagram for the .dm1 file. PARAMETERS: FullFilePath as String.

Syntax

Visual Basic
Public Function OpenFile( _
   ByVal FullFilePath As Variant _
) As Diagram

Parameters

FullFilePath

Example

Dim MyDiagram As Diagram

Set MyDiagram = DiagramManager.OpenFile("C:\Program Files\Embarcadero\ERStudio\Model\MyModel.dm1")

or

Dim MyDiagram As Diagram

Dim strFile As String

strFile = "C:\Program Files\Embarcadero\ERStudio\Model\MyModel.dm1"

Set MyDiagram = DiagramManager.OpenFile(strFile)

See Also

Application Collection


%%PageItemTitle%%

Quit Method

Description

Shutdown ER/Studio without saving any documents.

Syntax

Visual Basic
Public Sub Quit()

See Also

Application Collection


%%PageItemTitle%%

RepoAvailableSubmodels Method
DiagramName

Description

Returns the collection of submodels (of the given diagram) available in the repository. PARAMETERS: DiagramName (String).

Syntax

Visual Basic
Public Function RepoAvailableSubmodels( _
   ByVal DiagramName As Variant _
) As RepoSubmodels

Parameters

DiagramName

See Also

Application Collection


%%PageItemTitle%%

RepoDataDictionaries Method

Description

Returns all Data Dictionary names from the Repo Server.

Syntax

Visual Basic
Public Function RepoDataDictionaries() As StringObjects

See Also

Application Collection


%%PageItemTitle%%

RepoDeleteDiagram Method
Name

Description

Delete a Diagram from the Repo Server using the given Diagram Name. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoDeleteDiagram( _
   ByVal Name As Variant _
) As Variant

Parameters

Name

See Also

Application Collection


%%PageItemTitle%%

RepoDiagrams Method

Description

Returns all Diagram names from the Repo Server.

Syntax

Visual Basic
Public Function RepoDiagrams() As StringObjects

See Also

Application Collection


%%PageItemTitle%%

RepoGetDiagram Method
Name

Description

GetDiagram from the Repo Server using the given Diagram Name. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoGetDiagram( _
   ByVal Name As Variant _
) As Variant

Parameters

Name

Example

Sub Main

Dim d As Diagram

DiagramManager.RepoGetDiagram(“Pubs.dm1”)

Debug.Print(DiagramManager.GetLastErrorString())

End Sub

See Also

Application Collection


%%PageItemTitle%%

RepoLogin Method
Name
Password

Description

Login to the Repo Server using the given Name and Password. Return value is 1 if it succeeded, else it's 0. PARAMETERS: Name as String and Password as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoLogin( _
   ByVal Name As Variant, _
   ByVal Password As Variant _
) As Variant

Parameters

Name
Password

See Also

Application Collection


%%PageItemTitle%%

RepoLogout Method

Description

Logout of the Repo Server. Return value is 1 if it succeeded, else it's 0. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoLogout() As Variant

See Also

Application Collection


%%PageItemTitle%%

RepoObjectPrivileges Method

Description

Returns all ObjectPrivilege names from the Repo Server.

Syntax

Visual Basic
Public Function RepoObjectPrivileges() As StringObjects

See Also

Application Collection


%%PageItemTitle%%

RepoProjects Method

Description

Returns all Projects from the Repo Server.

Syntax

Visual Basic
Public Function RepoProjects() As Projects

See Also

Application Collection


%%PageItemTitle%%

RepoRoles Method

Description

Returns all Roles from the Repo Server.

Syntax

Visual Basic
Public Function RepoRoles() As Roles

See Also

Application Collection


%%PageItemTitle%%

RepoSoftDeleteDiagram Method
Name

Description

Delete a Diagram from the Repo Server but leave data still in the database (marked as deleted). Uses the given Diagram Name. Return value is 1 if it succeeded else it's 0. PARAMETERS: Name as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoSoftDeleteDiagram( _
   ByVal Name As Variant _
) As Variant

Parameters

Name

See Also

Application Collection


%%PageItemTitle%%

RepoUsers Method

Description

Returns all Users from the Repo Server.

Syntax

Visual Basic
Public Function RepoUsers() As Users

See Also

Application Collection


%%PageItemTitle%%

ReverseEngineerObject Method

Description

Returns an object which provides an interface for reverse-engineering.

Syntax

Visual Basic
Public Function ReverseEngineerObject() As ReverseEngineer

See Also

Application Collection


%%PageItemTitle%%

ShowWindow Method

Description

If the application is hidden, this will make the application visible.

Syntax

Visual Basic
Public Sub ShowWindow()

See Also

Application Collection


%%PageItemTitle%%

SynchronizeComments Method

Description

Synchronize the user comments in the dm1 file with the ones in the repository database. Return value is 1 if it succeeded else it is 0.

Syntax

Visual Basic
Public Function SynchronizeComments() As Variant

See Also

Application Collection


%%PageItemTitle%%

_DiagramItem Property
Identifier

Description

Returns a diagram, given the diagram's title. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _DiagramItem( _
   ByVal Identifier As Variant _
) As Diagram

Parameters

Identifier

See Also

Application Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Application Collection


%%PageItemTitle%%

CurrentUser Property

Description

Returns the name of the user that is currently logged in. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentUser() As Variant

See Also

Application Collection


%%PageItemTitle%%

DiagramCount Property

Description

Returns the number of currently, open diagrams. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property DiagramCount() As Long

Example

Dim MyCount As Integer

MyCount = DiagramManager.DiagramCount

See Also

Application Collection


%%PageItemTitle%%

DiagramItem Property
Identifier

Description

Returns a diagram, given the diagram's title. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property DiagramItem( _
   ByVal Identifier As Variant _
) As Diagram

Parameters

Identifier

Example

Dim MyDiagram As Diagram

Set MyDiagram = DiagramManager.DiagramItem("MyDiagram.DM1")

See Also

Application Collection


%%PageItemTitle%%

ERSFullVersion Property

Description

This property displays the ERStudio.exe Full Version and Build Number. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ERSFullVersion() As Variant

See Also

Application Collection


%%PageItemTitle%%

ERSVersion Property

Description

This property displays the ERStudio.exe Version and Build Number. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ERSVersion() As Variant

See Also

Application Collection


%%PageItemTitle%%

HideRepositoryIcon Property

Description

This Boolean flag controls the showing or hiding of Repository Status Icon. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HideRepositoryIcon() As Variant

See Also

Application Collection


%%PageItemTitle%%

RepoActiveDirectory Property

Description

This is the Repository Active Directory of ER/Studio. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property RepoActiveDirectory() As Variant

See Also

Application Collection


%%PageItemTitle%%

Attachment Object
See Also Members

Description

This object represents an Attachment in ER/Studio.

Object Model

See Also

Attachment Members


%%PageItemTitle%% $$Members$$

Attachment Object Members
See Also Overview

Public Methods

Public Method AttachmentType | Returns the parent AttachmentType of this Attachment.
Public Method BoundObjects | Returns a collection of bindings that link the Attachment to diagram objects and/or dictionary objects.
Public Method RepoCheckOutStatus | Get the Check Out status of this Attachment object. DATATYPE: StringObjects.
Public Method TextList | Returns the Attachment's TextList data in a collection.
Public Method UserComments | Returns a collection of user comments associated with the attachment.

Public Properties

Public Property Datatype | This is a Datatype associated with the Attachment. DATATYPE: Integer.
Public Property Description | This is the description of the Attachment. DATATYPE: String.
Public Property GUID | This is the GUID of the Attachment. DATATYPE: String.
Public Property ID | Returns the Attachment ID. DATATYPE: Integer.
Public Property Name | This is the name of the Attachment. DATATYPE: String.
Public Property ValueDefault | This is the ValueDefault associated with the Attachment Datatype. Read Help file for proper formatting info for different Datatypes. DATATYPE: String.

See Also

Attachment Overview


%%PageItemTitle%%

AttachmentType Method

Description

Returns the parent AttachmentType of this Attachment.

Syntax

Visual Basic
Public Function AttachmentType() As AttachmentType

See Also

Attachment Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the Attachment to diagram objects and/or dictionary objects.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

Attachment Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Attachment object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Attachment Object


%%PageItemTitle%%

TextList Method

Description

Returns the Attachment's TextList data in a collection.

Syntax

Visual Basic
Public Function TextList() As TextList

See Also

Attachment Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with the attachment.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Attachment Object


%%PageItemTitle%%

Datatype Property

Description

This is a Datatype associated with the Attachment. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

Attachment Object


%%PageItemTitle%%

Description Property

Description

This is the description of the Attachment. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Attachment Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Attachment. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Attachment Object


%%PageItemTitle%%

ID Property

Description

Returns the Attachment ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Attachment Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Attachment. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Attachment Object


%%PageItemTitle%%

ValueDefault Property

Description

This is the ValueDefault associated with the Attachment Datatype. Read Help file for proper formatting info for different Datatypes. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueDefault() As Variant

See Also

Attachment Object


%%PageItemTitle%%

Attachments Collection
See Also Members

Description

This object represents a collection of Attachments. The owner of this collection is the AttachmentType.

Object Model

See Also

Attachments Members


%%PageItemTitle%% $$Members$$

Attachments Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new Attachment in the collection and returns the pointer. PARAMETERS: Name, Description, and ValueDefault as Strings, Datatype as Integer.
Public Method Remove | Deletes an Attachments object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Attachment object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Attachment objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Attachment object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

Attachments Overview


%%PageItemTitle%%

Add Method
Name
Description
ValueDefault
Datatype

Description

Creates a new Attachment in the collection and returns the pointer. PARAMETERS: Name, Description, and ValueDefault as Strings, Datatype as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant, _
   ByVal ValueDefault As Variant, _
   ByVal Datatype As Variant _
) As Attachment

Parameters

Name
Description
ValueDefault
Datatype

See Also

Attachments Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Attachments object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Attachments Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Attachment object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Attachment

Parameters

Identifier

See Also

Attachments Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Attachments Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Attachment objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Attachments Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Attachment object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Attachment

Parameters

Identifier

See Also

Attachments Collection


%%PageItemTitle%%

AttachmentType Object
See Also Members

Description

This object represents an AttachmentType in ER/Studio.

Object Model

See Also

AttachmentType Members


%%PageItemTitle%% $$Members$$

AttachmentType Object Members
See Also Overview

Public Methods

Public Method Attachments | Returns all the Attachment in this AttachmentType.
Public Method RepoCheckOutStatus | Get the Check Out status of this AttachmentType object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of the user comments associated with this AttachmentType.
Public Method ValidAttachmentBindings | Returns all the ValidAttachmentBinding in this AttachmentType.

Public Properties

Public Property Description | This is the description of the AttachmentType. DATATYPE: String.
Public Property DictionaryName | This is the Name of the DataDictionary for which the AttachmentType belongs to. DATATYPE: String.
Public Property EnterpriseLevel | This indicates that the AttachmentType is in an Enterprise Level Data Dictionary. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the AttachmentType. DATATYPE: String.
Public Property ID | Returns the AttachmentType ID. DATATYPE: Integer.
Public Property IsUserDefined | This is the IsUserDefined flag of the AttachmentType. DATATYPE: Boolean.
Public Property Name | This is the name of the AttachmentType. DATATYPE: String.

See Also

AttachmentType Overview


%%PageItemTitle%%

Attachments Method

Description

Returns all the Attachment in this AttachmentType.

Syntax

Visual Basic
Public Function Attachments() As Attachments

See Also

AttachmentType Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this AttachmentType object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of the user comments associated with this AttachmentType.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

AttachmentType Object


%%PageItemTitle%%

ValidAttachmentBindings Method

Description

Returns all the ValidAttachmentBinding in this AttachmentType.

Syntax

Visual Basic
Public Function ValidAttachmentBindings() As ValidAttachmentBindings

See Also

AttachmentType Object


%%PageItemTitle%%

Description Property

Description

This is the description of the AttachmentType. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the Name of the DataDictionary for which the AttachmentType belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

This indicates that the AttachmentType is in an Enterprise Level Data Dictionary. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the AttachmentType. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

ID Property

Description

Returns the AttachmentType ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

IsUserDefined Property

Description

This is the IsUserDefined flag of the AttachmentType. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsUserDefined() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

Name Property

Description

This is the name of the AttachmentType. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

AttachmentType Object


%%PageItemTitle%%

AttachmentTypes Collection
See Also Members

Description

This object represents a collection of AttachmentTypes. The owner of this collection is the Data Dictionary.

Object Model

See Also

AttachmentTypes Members


%%PageItemTitle%% $$Members$$

AttachmentTypes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new AttachmentType in the collection and returns the pointer. PARAMETERS: Name and Description as Strings.
Public Method Remove | Deletes an AttachmentType object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a AttachmentType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of AttachmentType objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a AttachmentType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

AttachmentTypes Overview


%%PageItemTitle%%

Add Method
Name
Description

Description

Creates a new AttachmentType in the collection and returns the pointer. PARAMETERS: Name and Description as Strings.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant _
) As AttachmentType

Parameters

Name
Description

See Also

AttachmentTypes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an AttachmentType object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

AttachmentTypes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a AttachmentType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As AttachmentType

Parameters

Identifier

See Also

AttachmentTypes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

AttachmentTypes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of AttachmentType objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

AttachmentTypes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a AttachmentType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As AttachmentType

Parameters

Identifier

See Also

AttachmentTypes Collection


%%PageItemTitle%%

AttributeObj Object
See Also Members

Description

This object represents an attribute in ER/Studio.

Object Model

See Also

AttributeObj Members


%%PageItemTitle%% $$Members$$

AttributeObj Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Attribute.
Public Method BoundSecurityProperties | Get all the BoundSecurityProperties of this Attribute.
Public Method DataMovementColumnLinks | Returns a collection of DataMovementLinks that link this column to source/target columns.
Public Method DataMovementRuleLinks | Get all the Bound Data Movement Rules of this Attribute.
Public Method DeleteNamingStandardsTemplate | Unbind this Attribute from the naming standards template by deleting the naming standards template ID from the attribute.
Public Method DeleteReferenceValue | Unbind this Attribute from the reference value by deleting the reference value ID from the attribute.
Public Method EnableOverride | Turn on or off a specified attribute override flag. PARAMETERS: OverridFlag as Integer, Enable as Boolean.
Public Method GetNamingStandardsTemplate | Returns the naming standards template bound to the attribute or null, if none is bound to the attribute.
Public Method GetParent | Returns the parent Entity of this attribute.
Public Method GetReferenceValue | Returns the reference value bound to the attribute or null, if none is bound to the attribute.
Public Method IsOverrideEnabled | Check if a specified attribute override flag is enabled. PARAMETERS: OverridFlag as Integer. RETURN DATATYPE: Boolean.
Public Method RepoCheckOutStatus | Get the Check Out status of this Attribute object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this Attribute from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method SetXMLType | Use to change the XML's type. Pass the collection name and true for DOCUMENT, false for CONTENT. PARAMETERS: IsDocument as Boolean, CollectionName as String.
Public Method SetXMLUnTyped | Use to make the XML datatype of a column untyped (clears CollectionName and DOCUMENT flag). Column has to have datatype XML. For SQL Server 2005 and later versions.
Public Method UniversalMappings | Returns a collection of universal mappings applied to this object.
Public Method UserComments | Returns a collection of user comments associated with this Attribute.
Public Method UserDefinedMappings | Returns a collection of user defined mappings applied to this object.
Public Method WhereUsedModelUsage | Returns a collection of matches in other models based on the results of a WhereUsed analysis on this object.

Public Properties

Public Property AllocatedWidth | This property returns the allocated width of a column. DATATYPE: Integer.
Public Property AttributeName | This is the logical, attribute name. DATATYPE: String.
Public Property AverageWidth | This is the average width of a column. This property applies only to physical models. DATATYPE: Integer.
Public Property Cache | This is the Cache property for the column. DATATYPE: Integer.
Public Property CharacterSet | This property specifies the character set for a char, varchar and blob(Interbase)/clob(Teradata) column. This property applies only to Interbase 2007, Teradata version V2R5 and up. DATATYPE: String.
Public Property CharUsed | This is the CharUsed property for the column. DATATYPE: Boolean.
Public Property CheckConstraint | This is the check constraint of the attribute (if any). DATATYPE: String.
Public Property CheckConstraintName | This is the Name of the Attribute's Check Constraint. DATATYPE: String.
Public Property Collate | This is the Collate property for the column. DATATYPE: String.
Public Property Color | This is the color of the Attribute object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).
Public Property ColumnName | This is the physical, column name. DATATYPE: String.
Public Property Compact | This is the Compact property for the column. DATATYPE: Boolean.
Public Property CompositeDatatype | This is the attribute's full datatype, including nullability. DATATYPE: String.
Public Property Compress | This is the Compress property for the column. This property is only used in Teradata models. DATATYPE: String.
Public Property Computation | This is the Computation property for columns that are computed. Applies to Interbase 2007 and SQL server 7.x and above only. DATATYPE: String.
Public Property Cycle | This is the Cycle property for the column. DATATYPE: Boolean.
Public Property DataLength | The data length of the datatype (if any). DATATYPE: Integer.
Public Property DataScale | The data scale of the datatype (if any). DATATYPE: Integer.
Public Property Datatype | This is the datatype. Note: User-defined datatype can be assigned in UserDatatypeId property. DATATYPE: String.
Public Property DeclaredDefault | This is the default constraint for the attribute (if any). DATATYPE: String.
Public Property DefaultId | The ID of the bounded, default object (if any). This ID is used by ER/Studio. A user can bind a default object to the attribute by assigning a particular default ID to this property. DATATYPE: Integer.
Public Property DefaultName | This is the Name of the Attribute's default constraint. DATATYPE: String.
Public Property Definition | This is the definition of the attribute. DATATYPE: String.
Public Property DomainId | The ID of the bounded, domain object (if any). This ID is used by ER/Studio. A user can bind a domain object to the attribute by assigning a particular domain ID to this property. DATATYPE: Integer.
Public Property Encrypted | This property indicates if a column is encrypted. This applies only to Oracle 10.2, Sybase ASE 12.5.3 and later versions of these two platforms. DATATYPE: Boolean.
Public Property EncryptionAlgorithm | This property specifies the algorithm used for the column encryption. This applies only to Oracle 10.2 and later versions of this platform. DATATYPE: String.
Public Property EncryptionKey | This property specifies the encryption keys used to encrypt the column. This applies only to Sybase ASE 12.5.3 and later versions of this platform. DATATYPE: String.
Public Property EncryptionSALT | This property indicates if a column is encrypted with SALT. This applies only to Oracle 10.2 and later versions. DATATYPE: Boolean.
Public Property EnumOrSetValues | This is the EnumOrSetValues property for columns that have either Enum or Ser as column data type. DATATYPE: String.
Public Property Font | Font for the attribute. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property ForBitData | This is the ForBitData property for the column. DATATYPE: Boolean.
Public Property ForeignKey | This indicates if the attribute is a foreign key. DATATYPE: Boolean.
Public Property Format | This is the Format property for the column. This property is only used in Teradata models. DATATYPE: String.
Public Property FreezeName | True if this attribute should not be affected by naming standards name updates. DATATYPE: Boolean.
Public Property GenerateByDefault | This is the GenerateByDefault property for the column. DATATYPE: Boolean.
Public Property GenerationExpression | Specifies how the column should be generated. This property applies only to DB2 UDB version 8 and later versions. DATATYPE: String.
Public Property GUID | This is the GUID of the attribute. This ID is assigned by ER/Studio. Each attribute has a unique GUID. DATATYPE: String.
Public Property HasLogicalRoleName | This indicates if the foreign key column has a logical rolename. DATATYPE: Boolean.
Public Property HasRoleName | This indicates if the foreign key column is rolenamed. DATATYPE: Boolean.
Public Property Heading | This is the DB2 AS/400 Heading for the column. DATATYPE: String.
Public Property Hidden | This is the flag indicating that an Attribute is hidden in the Diagram display. Only applied to PK and FK attributes/columns. DATATYPE: Boolean.
Public Property HiveColumnPartition | This property specifies whether the column is a Hive Partitioning Column. DATATYPE: Boolean
Public Property HiveComplexType | This property specifies the Hive column's Complex datatype. DATATYPE: String
Public Property ID | This is the ID of the attribute. This ID is assigned by ER/Studio. Each attribute in a diagram has a unique ID. DATATYPE: Integer.
Public Property Identity | This is the identity property of the attribute. DATATYPE: Boolean.
Public Property IdentityIncrement | This is the identity increment value of the attribute. DATATYPE: Integer.
Public Property IdentitySeed | This is the identity seed value of the attribute. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property IntervalYearToMonth | This is the IntervalYearToMonth property for the column. DATATYPE: Boolean.
Public Property IsCaseSpecific | True if this column is case specific. It applies only to CHAR and VARCHAR data types in Teradata version V2R5 and up. DATATYPE: Boolean.
Public Property IsComputed | Returns true if the column is computed (if there is a value specified for the Computation property), false otherwise. Applies to Interbase 2007 and SQL server 7.x and above only. DATATYPE: Boolean.
Public Property IsFileStream | True if this column has FILESTREAM property set. It applies only to VARBINARY(MAX) data type in MS SQL SERVER 2008. DATATYPE: Boolean.
Public Property IsGenerated | True if the column is generated with an expression. This property applies only to DB2 UDB version 8 and later versions. DATATYPE: Boolean.
Public Property IsSparse | True if this is a sparse column. DATATYPE: Boolean.
Public Property IsVirtual | True if this column is an Oracle (11g or higher) virtual column, i.e. a computed column. A column is virtual if it has a VirtualColumnExpression set. Read-Only. DATATYPE: Boolean
Public Property IsWithTimeZone | True if this column has WITH TIME ZONE property set. It applies only to TIME and TIMESTAMP data types in Teradata all versions. DATATYPE: Boolean.
Public Property IsXMLDocument | Returns true if the column has datatype XML and is flagged as document. Applies only to SQL server 2005 and later versions. DATATYPE: Boolean.
Public Property LOBUnit | This is the unit to be used for the LOB size. The value can be empty, "K", "M" or "G". DATATYPE: String.
Public Property LocalTimeZone | This is the LocalTimeZone property for the column. DATATYPE: Boolean.
Public Property LogicalRoleName | This is the Logical Rolename. DATATYPE: String.
Public Property LogOrPhysOnly | Controls the logical/physical only Attribute Property. DATATYPE: Boolean.
Public Property MaxValue | This is the MaxValue property for the column. DATATYPE: Integer.
Public Property MinValue | This is the MinValue property for the column. DATATYPE: Integer.
Public Property MongoDBArray | This property indicates that the Column is a MongoDB array. DATATYPE: Boolean
Public Property NamingStandardsTemplateId | ID of the NamingStandardsTemplate object bound to the attribute (if any). A user can bind a NamingStandardsTemplate to the attribute by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.
Public Property Notes | This is the Notes property of the attribute. DATATYPE: String.
Public Property NotForReplication | This property specifies if an identity column constraint is for replication. This applies only to MS SQL Server 2000 and later versions. DATATYPE: Boolean.
Public Property NotLogged | This is the NotLogged property for the column. DATATYPE: Boolean.
Public Property NullOption | This is the nullability of the attribute. The possible values are: 'NULL' or 'NOT NULL'. DATATYPE: String.
Public Property OracleNotNullConstraintName | This property specifies the Not Null constraint of the column. It only applies to Oracle 8 and later versions. DATATYPE: String
Public Property PercentNull | This is the percentage of nulls of a column in a table. This property applies only to physical models. DATATYPE: Integer.
Public Property Persisted | This property speicifies if a computed column is persisted. It applies only to a computed column in SQL Server 2005 and later versions. DATATYPE: Boolean.
Public Property PhysicalDatatype | This is the physical datatype of the attribute. DATATYPE: String.
Public Property PrimaryKey | This indicates if the attribute is a primary key. DATATYPE: Boolean.
Public Property ReferenceValueId | ID of the ReferenceValue object bound to the attribute (if any). A user can bind a ReferenceValue to the attribute by assigning a particular ReferenceValueId to this property. DATATYPE: Integer.
Public Property RoleName | This is the role name of the attribute. DATATYPE: String.
Public Property RowGuidColumn | This is the RowGuidColumn property for the column. DATATYPE: Boolean.
Public Property RuleId | The ID of the bounded, rule object (if any). This ID is used by ER/Studio. A user can bind a rule object to the attribute by assigning a particular rule ID to this property. DATATYPE: Integer.
Public Property SequenceNumber | This is the sequence number of the attribute. DATATYPE: Integer.
Public Property ShowLength | This tells whether the datatype length is used (true) or not (false). DATATYPE: Boolean.
Public Property ShowScale | This tells whether the datatype scale is used (true) or not (false). DATATYPE: Boolean.
Public Property ShowVirtualColumnDatatype | This property specifies whether the data type of an Oracle (11g or higher) virtual column should be manually set (true) or automatically determined by the database (false). DATATYPE: Boolean.
Public Property SourceDirectTransformationDescription | This is the source direct transformation description property for the column. This property applies only to physical models. DATATYPE: String.
Public Property SourceDirectTransformationLogic | This is the source direct transformation logic property for the column. This property applies only to physical models. DATATYPE: String.
Public Property SourceSecondaryTransformationDescription | This is the source secondary transformation description property for the column. This property applies only to physical models. DATATYPE: String.
Public Property SourceSecondaryTransformationLogic | This is the source secondary transformation logic property for the column. This property applies only to physical models. DATATYPE: String.
Public Property SystemName | This is the DB2 AS/400 SystemName for the column. DATATYPE: String.
Public Property TargetDirectTransformationDescription | This is the target direct transformation description property for the column. This property applies only to physical models. DATATYPE: String.
Public Property TargetDirectTransformationLogic | This is the target direct transformation logic property for the column. This property applies only to physical models. DATATYPE: String.
Public Property TargetSecondaryTransformationDescription | This is the target secondary transformation description property for the column. This property applies only to physical models. DATATYPE: String.
Public Property TargetSecondaryTransformationLogic | This is the target secondary transformation logic property for the column. This property applies only to physical models. DATATYPE: String.
Public Property TeradataCollectStatistics | This property specifies whether the collect statistics option of the column is on for Teradata (V12 or higher). DATATYPE: Boolean.
Public Property TeradataIntervalStr | This property specifies the interval string for a column with INTERVAL datatype, It only applies to Teradata 13 and later versions.. DATATYPE: String.
Public Property TeradataPeriod | This property specifies whether the column has PERIOD datatype. It only applies to columns that have datatype as TIME, TIMESTAMP and DATE in Teradata 13 and later versions. DATATYPE: Boolean
Public Property TeradataUsingSample | This property specifies whether the using sample option of the column is on for Teradata (V12 or higher), the collect statistics option has to be on before this option can be set. DATATYPE: Boolean.
Public Property TextLabel | This is the DB2 AS/400 TextLabel for the column. DATATYPE: String.
Public Property TimeZone | This is the TimeZone property for the column. DATATYPE: Boolean.
Public Property Title | This is the Title property for the column. This property is only used in Teradata models. DATATYPE: String.
Public Property Unsigned | This property specifies if the column data type is unsigned. It applies only to MySQL platforms. DATATYPE: Boolean.
Public Property UserDatatypeId | The ID of the bounded, user datatype object (if any). This ID is used by ER/Studio. A user can bind a user datatype object to the attribute by assigning a particular user datatype ID to this property. DATATYPE: Integer.
Public Property VirtualColumnExpression | This property holds the expression used to compute an Oracle (11g or higher) virtual column. DATATYPE: String
Public Property XMLCollection | This represents the column's Collection property, which applies to Columns with datatype XML. Applies only to SQL server 2005 and later versions. DATATYPE: String.

See Also

AttributeObj Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Attribute.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

AttributeObj Object


%%PageItemTitle%%

BoundSecurityProperties Method

Description

Get all the BoundSecurityProperties of this Attribute.

Syntax

Visual Basic
Public Function BoundSecurityProperties() As BoundSecurityProperties

See Also

AttributeObj Object


%%PageItemTitle%%

DataMovementColumnLinks Method

Description

Returns a collection of DataMovementLinks that link this column to source/target columns.

Syntax

Visual Basic
Public Function DataMovementColumnLinks() As DataMovementColumnLinks

See Also

AttributeObj Object


%%PageItemTitle%%

DataMovementRuleLinks Method

Description

Get all the Bound Data Movement Rules of this Attribute.

Syntax

Visual Basic
Public Function DataMovementRuleLinks() As DataMovementRuleLinks

See Also

AttributeObj Object


%%PageItemTitle%%

DeleteNamingStandardsTemplate Method

Description

Unbind this Attribute from the naming standards template by deleting the naming standards template ID from the attribute.

Syntax

Visual Basic
Public Function DeleteNamingStandardsTemplate() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DeleteReferenceValue Method

Description

Unbind this Attribute from the reference value by deleting the reference value ID from the attribute.

Syntax

Visual Basic
Public Function DeleteReferenceValue() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

EnableOverride Method
OverrideFlag

The value of OverrideFlag can be one of the following:
1 - Bound default
2 - Default text
3 - Bound rule
4 - Check constraint
5 - Definition
6 - Note
7 - Domain datatype (override domain's version)
8 - Foreign key datatype (override parent key's version)

Enable

Description

Turn on or off a specified attribute override flag. PARAMETERS: OverridFlag as Integer, Enable as Boolean.

Syntax

Visual Basic
Public Sub EnableOverride( _
   ByVal OverrideFlag As Variant, _
   ByVal Enable As Variant _
)

Parameters

OverrideFlag

The value of OverrideFlag can be one of the following:
1 - Bound default
2 - Default text
3 - Bound rule
4 - Check constraint
5 - Definition
6 - Note
7 - Domain datatype (override domain's version)
8 - Foreign key datatype (override parent key's version)

Enable

See Also

AttributeObj Object


%%PageItemTitle%%

GetNamingStandardsTemplate Method

Description

Returns the naming standards template bound to the attribute or null, if none is bound to the attribute.

Syntax

Visual Basic
Public Function GetNamingStandardsTemplate() As NamingStandardsTemplate

See Also

AttributeObj Object


%%PageItemTitle%%

GetParent Method

Description

Returns the parent Entity of this attribute.

Syntax

Visual Basic
Public Function GetParent() As Entity

See Also

AttributeObj Object


%%PageItemTitle%%

GetReferenceValue Method

Description

Returns the reference value bound to the attribute or null, if none is bound to the attribute.

Syntax

Visual Basic
Public Function GetReferenceValue() As ReferenceValue

See Also

AttributeObj Object


%%PageItemTitle%%

IsOverrideEnabled Method
OverrideFlag
The value of OverrideFlag can be one of the following:
1 - Bound default
2 - Default text
3 - Bound rule
4 - Check constraint
5 - Definition
6 - Note
7 - Domain datatype (override domain's version)
8 - Foreign key datatype (override parent key's version)

Description

Check if a specified attribute override flag is enabled. PARAMETERS: OverridFlag as Integer. RETURN DATATYPE: Boolean.

Syntax

Visual Basic
Public Function IsOverrideEnabled( _
   ByVal OverrideFlag As Variant _
) As Variant

Parameters

OverrideFlag
The value of OverrideFlag can be one of the following:
1 - Bound default
2 - Default text
3 - Bound rule
4 - Check constraint
5 - Definition
6 - Note
7 - Domain datatype (override domain's version)
8 - Foreign key datatype (override parent key's version)

See Also

AttributeObj Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Attribute object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this Attribute from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SetXMLType Method
IsDocument
ColumnName

Description

Use to change the XML's type. Pass the collection name and true for DOCUMENT, false for CONTENT. PARAMETERS: IsDocument as Boolean, CollectionName as String.

Syntax

Visual Basic
Public Sub SetXMLType( _
   ByVal IsDocument As Variant, _
   ByVal ColumnName As Variant _
)

Parameters

IsDocument
ColumnName

See Also

AttributeObj Object


%%PageItemTitle%%

SetXMLUnTyped Method

Description

Use to make the XML datatype of a column untyped (clears CollectionName and DOCUMENT flag). Column has to have datatype XML. For SQL Server 2005 and later versions.

Syntax

Visual Basic
Public Sub SetXMLUnTyped()

See Also

AttributeObj Object


%%PageItemTitle%%

UniversalMappings Method

Description

Returns a collection of universal mappings applied to this object.

Syntax

Visual Basic
Public Function UniversalMappings() As UniversalMappings

See Also

AttributeObj Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Attribute.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

AttributeObj Object


%%PageItemTitle%%

UserDefinedMappings Method

Description

Returns a collection of user defined mappings applied to this object.

Syntax

Visual Basic
Public Function UserDefinedMappings() As UserDefinedMappingCollection

See Also

AttributeObj Object


%%PageItemTitle%%

WhereUsedModelUsage Method

Description

Returns a collection of matches in other models based on the results of a WhereUsed analysis on this object.

Syntax

Visual Basic
Public Function WhereUsedModelUsage() As WhereUsedDataCollection

See Also

AttributeObj Object


%%PageItemTitle%%

AllocatedWidth Property

Description

This property returns the allocated width of a column. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllocatedWidth() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

AttributeName Property

Description

This is the logical, attribute name. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttributeName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

AverageWidth Property

Description

This is the average width of a column. This property applies only to physical models. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property AverageWidth() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Cache Property

Description

This is the Cache property for the column. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cache() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

CharacterSet Property

Description

This property specifies the character set for a char, varchar and blob(Interbase)/clob(Teradata) column. This property applies only to Interbase 2007, Teradata version V2R5 and up. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CharacterSet() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

CharUsed Property

Description

This is the CharUsed property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property CharUsed() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

CheckConstraint Property

Description

This is the check constraint of the attribute (if any). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckConstraint() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

CheckConstraintName Property

Description

This is the Name of the Attribute's Check Constraint. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckConstraintName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Collate Property

Description

This is the Collate property for the column. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Collate() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Color Property

Description

This is the color of the Attribute object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ColumnName Property

Description

This is the physical, column name. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Compact Property

Description

This is the Compact property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compact() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

CompositeDatatype Property

Description

This is the attribute's full datatype, including nullability. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property CompositeDatatype() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Compress Property

Description

This is the Compress property for the column. This property is only used in Teradata models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compress() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Computation Property

Description

This is the Computation property for columns that are computed. Applies to Interbase 2007 and SQL server 7.x and above only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Computation() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Cycle Property

Description

This is the Cycle property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cycle() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DataLength Property

Description

The data length of the datatype (if any). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataLength() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DataScale Property

Description

The data scale of the datatype (if any). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataScale() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Datatype Property

Description

This is the datatype. Note: User-defined datatype can be assigned in UserDatatypeId property. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DeclaredDefault Property

Description

This is the default constraint for the attribute (if any). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DeclaredDefault() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DefaultId Property

Description

The ID of the bounded, default object (if any). This ID is used by ER/Studio. A user can bind a default object to the attribute by assigning a particular default ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultId() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DefaultName Property

Description

This is the Name of the Attribute's default constraint. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Definition Property

Description

This is the definition of the attribute. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

DomainId Property

Description

The ID of the bounded, domain object (if any). This ID is used by ER/Studio. A user can bind a domain object to the attribute by assigning a particular domain ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DomainId() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Encrypted Property

Description

This property indicates if a column is encrypted. This applies only to Oracle 10.2, Sybase ASE 12.5.3 and later versions of these two platforms. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Encrypted() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

EncryptionAlgorithm Property

Description

This property specifies the algorithm used for the column encryption. This applies only to Oracle 10.2 and later versions of this platform. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncryptionAlgorithm() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

EncryptionKey Property

Description

This property specifies the encryption keys used to encrypt the column. This applies only to Sybase ASE 12.5.3 and later versions of this platform. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncryptionKey() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

EncryptionSALT Property

Description

This property indicates if a column is encrypted with SALT. This applies only to Oracle 10.2 and later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncryptionSALT() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

EnumOrSetValues Property

Description

This is the EnumOrSetValues property for columns that have either Enum or Ser as column data type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnumOrSetValues() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Font Property

Description

Font for the attribute. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property Font() As ERSFont

See Also

AttributeObj Object


%%PageItemTitle%%

ForBitData Property

Description

This is the ForBitData property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ForBitData() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ForeignKey Property

Description

This indicates if the attribute is a foreign key. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property ForeignKey() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Format Property

Description

This is the Format property for the column. This property is only used in Teradata models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Format() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

FreezeName Property

Description

True if this attribute should not be affected by naming standards name updates. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreezeName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

GenerateByDefault Property

Description

This is the GenerateByDefault property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateByDefault() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

GenerationExpression Property

Description

Specifies how the column should be generated. This property applies only to DB2 UDB version 8 and later versions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerationExpression() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the attribute. This ID is assigned by ER/Studio. Each attribute has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

HasLogicalRoleName Property

Description

This indicates if the foreign key column has a logical rolename. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasLogicalRoleName() As Variant

Example

Sub Main

Dim MyDiagram As Diagram

Dim m As Model

Dim e As Entities

Dim ent As Entity

Dim atr As AttributeObj

Set MyDiagram = DiagramManager.ActiveDiagram

Set m = MyDiagram.ActiveModel

Set e = m.Entities

For Each ent In e

For Each atr In ent.Attributes

atr.LogicalRoleName = ent.EntityName + "_" + atr.AttributeName + "_Role"

Next atr

Next ent

For Each ent In e

For Each atr In ent.Attributes

If atr.HasLogicalRoleName then

MsgBox("ENT: " + ent.EntityName + vbCrLf + _

"ATTR: " + atr.AttributeName + vbCrLf + _

"LogicalRoleName: " + atr.LogicalRoleName)

End If

Next atr

Next ent

End Sub

See Also

AttributeObj Object


%%PageItemTitle%%

HasRoleName Property

Description

This indicates if the foreign key column is rolenamed. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasRoleName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Heading Property

Description

This is the DB2 AS/400 Heading for the column. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Heading() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Hidden Property

Description

This is the flag indicating that an Attribute is hidden in the Diagram display. Only applied to PK and FK attributes/columns. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Hidden() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

HiveColumnPartition Property

Description

This property specifies whether the column is a Hive Partitioning Column. DATATYPE: Boolean

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveColumnPartition() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

HiveComplexType Property

Description

This property specifies the Hive column's Complex datatype. DATATYPE: String

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveComplexType() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the attribute. This ID is assigned by ER/Studio. Each attribute in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Identity Property

Description

This is the identity property of the attribute. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Identity() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IdentityIncrement Property

Description

This is the identity increment value of the attribute. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentityIncrement() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IdentitySeed Property

Description

This is the identity seed value of the attribute. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentitySeed() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

Example

Sub Main

Dim MyDiagram As Diagram

Dim m As Model

Dim e As Entities

Dim ent As Entity

Dim atr As AttributeObj

Set MyDiagram = DiagramManager.ActiveDiagram

Set m = MyDiagram.ActiveModel

Set e = m.Entities

For Each ent In e

For Each atr In ent.Attributes

atr.LogicalRoleName = ent.EntityName + "_" + atr.AttributeName + "_Role"

Next atr

Next ent

For Each ent In e

For Each atr In ent.Attributes

If atr.HasLogicalRoleName then

MsgBox("ENT: " + ent.EntityName + vbCrLf + _

"ATTR: " + atr.AttributeName + vbCrLf + _

"LogicalRoleName: " + atr.LogicalRoleName)

End If

Next atr

Next ent

End Sub

See Also

AttributeObj Object


%%PageItemTitle%%

IntervalYearToMonth Property

Description

This is the IntervalYearToMonth property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IntervalYearToMonth() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsCaseSpecific Property

Description

True if this column is case specific. It applies only to CHAR and VARCHAR data types in Teradata version V2R5 and up. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsCaseSpecific() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsComputed Property

Description

Returns true if the column is computed (if there is a value specified for the Computation property), false otherwise. Applies to Interbase 2007 and SQL server 7.x and above only. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsComputed() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsFileStream Property

Description

True if this column has FILESTREAM property set. It applies only to VARBINARY(MAX) data type in MS SQL SERVER 2008. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFileStream() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsGenerated Property

Description

True if the column is generated with an expression. This property applies only to DB2 UDB version 8 and later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsGenerated() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsSparse Property

Description

True if this is a sparse column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSparse() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsVirtual Property

Description

True if this column is an Oracle (11g or higher) virtual column, i.e. a computed column. A column is virtual if it has a VirtualColumnExpression set. Read-Only. DATATYPE: Boolean

Property type

Read-write property

Syntax

Visual Basic
Public Property IsVirtual() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsWithTimeZone Property

Description

True if this column has WITH TIME ZONE property set. It applies only to TIME and TIMESTAMP data types in Teradata all versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsWithTimeZone() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

IsXMLDocument Property

Description

Returns true if the column has datatype XML and is flagged as document. Applies only to SQL server 2005 and later versions. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsXMLDocument() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

LOBUnit Property

Description

This is the unit to be used for the LOB size. The value can be empty, "K", "M" or "G". DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LOBUnit() As Variant

Example

EXAMPLE:

Sub Main

Dim MyDiagram As Diagram

Dim m As Model

Dim e As Entities

Dim ent As Entity

Dim atr As AttributeObj

Set MyDiagram = DiagramManager.ActiveDiagram

Set m = MyDiagram.ActiveModel

Set e = m.Entities

For Each ent In e

For Each atr In ent.Attributes

atr.LogicalRoleName = ent.EntityName + "_" + atr.AttributeName + "_Role"

Next atr

Next ent

For Each ent In e

For Each atr In ent.Attributes

If atr.HasLogicalRoleName then

MsgBox("ENT: " + ent.EntityName + vbCrLf + _

"ATTR: " + atr.AttributeName + vbCrLf + _

"LogicalRoleName: " + atr.LogicalRoleName)

End If

Next atr

Next ent

End Sub

See Also

AttributeObj Object


%%PageItemTitle%%

LocalTimeZone Property

Description

This is the LocalTimeZone property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LocalTimeZone() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

LogicalRoleName Property

Description

This is the Logical Rolename. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogicalRoleName() As Variant

Example

Sub Main

Dim MyDiagram As Diagram

Dim m As Model

Dim e As Entities

Dim ent As Entity

Dim atr As AttributeObj

Set MyDiagram = DiagramManager.ActiveDiagram

Set m = MyDiagram.ActiveModel

Set e = m.Entities

For Each ent In e

For Each atr In ent.Attributes

atr.LogicalRoleName = ent.EntityName + "_" + atr.AttributeName + "_Role"

Next atr

Next ent

For Each ent In e

For Each atr In ent.Attributes

If atr.HasLogicalRoleName then

MsgBox("ENT: " + ent.EntityName + vbCrLf + _

"ATTR: " + atr.AttributeName + vbCrLf + _

"LogicalRoleName: " + atr.LogicalRoleName)

End If

Next atr

Next ent

End Sub

See Also

AttributeObj Object


%%PageItemTitle%%

LogOrPhysOnly Property

Description

Controls the logical/physical only Attribute Property. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogOrPhysOnly() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

MaxValue Property

Description

This is the MaxValue property for the column. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxValue() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

MinValue Property

Description

This is the MinValue property for the column. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinValue() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

MongoDBArray Property

Description

This property indicates that the Column is a MongoDB array. DATATYPE: Boolean

Property type

Read-write property

Syntax

Visual Basic
Public Property MongoDBArray() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

NamingStandardsTemplateId Property

Description

ID of the NamingStandardsTemplate object bound to the attribute (if any). A user can bind a NamingStandardsTemplate to the attribute by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamingStandardsTemplateId() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Notes Property

Description

This is the Notes property of the attribute. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Notes() As Variant

Example

Dim MyAttr As AttributeObj

Dim StorNotes As String

MyAttr.Notes = StorNotes

See Also

AttributeObj Object


%%PageItemTitle%%

NotForReplication Property

Description

This property specifies if an identity column constraint is for replication. This applies only to MS SQL Server 2000 and later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NotForReplication() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

NotLogged Property

Description

This is the NotLogged property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NotLogged() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

NullOption Property

Description

This is the nullability of the attribute. The possible values are: 'NULL' or 'NOT NULL'. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property NullOption() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

OracleNotNullConstraintName Property

Description

This property specifies the Not Null constraint of the column. It only applies to Oracle 8 and later versions. DATATYPE: String

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleNotNullConstraintName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

PercentNull Property

Description

This is the percentage of nulls of a column in a table. This property applies only to physical models. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentNull() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Persisted Property

Description

This property speicifies if a computed column is persisted. It applies only to a computed column in SQL Server 2005 and later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Persisted() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

PhysicalDatatype Property

Description

This is the physical datatype of the attribute. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalDatatype() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

PrimaryKey Property

Description

This indicates if the attribute is a primary key. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property PrimaryKey() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ReferenceValueId Property

Description

ID of the ReferenceValue object bound to the attribute (if any). A user can bind a ReferenceValue to the attribute by assigning a particular ReferenceValueId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferenceValueId() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

RoleName Property

Description

This is the role name of the attribute. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property RoleName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

RowGuidColumn Property

Description

This is the RowGuidColumn property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property RowGuidColumn() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

RuleId Property

Description

The ID of the bounded, rule object (if any). This ID is used by ER/Studio. A user can bind a rule object to the attribute by assigning a particular rule ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property RuleId() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SequenceNumber Property

Description

This is the sequence number of the attribute. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ShowLength Property

Description

This tells whether the datatype length is used (true) or not (false). DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property ShowLength() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ShowScale Property

Description

This tells whether the datatype scale is used (true) or not (false). DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property ShowScale() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

ShowVirtualColumnDatatype Property

Description

This property specifies whether the data type of an Oracle (11g or higher) virtual column should be manually set (true) or automatically determined by the database (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowVirtualColumnDatatype() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SourceDirectTransformationDescription Property

Description

This is the source direct transformation description property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceDirectTransformationDescription() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SourceDirectTransformationLogic Property

Description

This is the source direct transformation logic property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceDirectTransformationLogic() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SourceSecondaryTransformationDescription Property

Description

This is the source secondary transformation description property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceSecondaryTransformationDescription() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SourceSecondaryTransformationLogic Property

Description

This is the source secondary transformation logic property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceSecondaryTransformationLogic() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

SystemName Property

Description

This is the DB2 AS/400 SystemName for the column. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SystemName() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TargetDirectTransformationDescription Property

Description

This is the target direct transformation description property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetDirectTransformationDescription() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TargetDirectTransformationLogic Property

Description

This is the target direct transformation logic property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetDirectTransformationLogic() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TargetSecondaryTransformationDescription Property

Description

This is the target secondary transformation description property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetSecondaryTransformationDescription() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TargetSecondaryTransformationLogic Property

Description

This is the target secondary transformation logic property for the column. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetSecondaryTransformationLogic() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TeradataCollectStatistics Property

Description

This property specifies whether the collect statistics option of the column is on for Teradata (V12 or higher). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataCollectStatistics() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TeradataIntervalStr Property

Description

This property specifies the interval string for a column with INTERVAL datatype, It only applies to Teradata 13 and later versions.. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataIntervalStr() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TeradataPeriod Property

Description

This property specifies whether the column has PERIOD datatype. It only applies to columns that have datatype as TIME, TIMESTAMP and DATE in Teradata 13 and later versions. DATATYPE: Boolean

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataPeriod() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TeradataUsingSample Property

Description

This property specifies whether the using sample option of the column is on for Teradata (V12 or higher), the collect statistics option has to be on before this option can be set. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataUsingSample() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TextLabel Property

Description

This is the DB2 AS/400 TextLabel for the column. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TextLabel() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

TimeZone Property

Description

This is the TimeZone property for the column. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeZone() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Title Property

Description

This is the Title property for the column. This property is only used in Teradata models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Title() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Unsigned Property

Description

This property specifies if the column data type is unsigned. It applies only to MySQL platforms. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Unsigned() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

UserDatatypeId Property

Description

The ID of the bounded, user datatype object (if any). This ID is used by ER/Studio. A user can bind a user datatype object to the attribute by assigning a particular user datatype ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDatatypeId() As Variant

Example

Sub Main

Dim diag As Diagram

Dim dict As Dictionary

Dim mdl As Model

Dim ent As Entity

Dim attr As AttributeObj

Dim udt As UserDatatype

Set diag = DiagramManager.NewDiagram

Set dict = diag.Dictionary

Set mdl = diag.ActiveModel

Set udt = dict.UserDatatypes.Add(“MyUDT”)

udt.Datatype = “INTEGER”

Set ent = mdl.Entities.Add(100,100)

ent.EntityName = “MyEntity”

Set attr = ent.Attributes.Add(“NewAttr”, False)

attr.UserDatatypeId = udt.ID

End Sub

See Also

AttributeObj Object


%%PageItemTitle%%

VirtualColumnExpression Property

Description

This property holds the expression used to compute an Oracle (11g or higher) virtual column. DATATYPE: String

Property type

Read-write property

Syntax

Visual Basic
Public Property VirtualColumnExpression() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

XMLCollection Property

Description

This represents the column's Collection property, which applies to Columns with datatype XML. Applies only to SQL server 2005 and later versions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property XMLCollection() As Variant

See Also

AttributeObj Object


%%PageItemTitle%%

Attributes Collection
See Also Members

Description

This object represents a collection of attributes. The owner of this collection is the entity.

Object Model

See Also

Attributes Members


%%PageItemTitle%% $$Members$$

Attributes Collection Members
See Also Overview

Public Methods

Public Method Add | Adds a new attribute (specified by the given name and key/non-key value) to the entity, and returns the new attribute to the caller. PARAMETERS: Name as String, IsKey as Boolean.
Public Method Remove | Deletes an Attribute object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns an attribute (specified by the given name, GUID or ID) from the entity. When passing in a name to the function, the attribute is indexed by the attribute name/rolename in the logical model and by the column name/rolename in the physical model.
Public Property _NewEnum |
Public Property Count | This is the number of Attribute objects in the collection. DATATYPE: Integer.
Public Property Item | Returns an attribute (specified by the given name, GUID or ID) from the entity. When passing in a name to the function, the attribute is indexed by the attribute name/rolename in the logical model and by the column name/rolename in the physical model.

See Also

Attributes Overview


%%PageItemTitle%%

Add Method
Name
IsKey

Description

Adds a new attribute (specified by the given name and key/non-key value) to the entity, and returns the new attribute to the caller. PARAMETERS: Name as String, IsKey as Boolean.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal IsKey As Variant _
) As AttributeObj

Parameters

Name
IsKey

Example

Dim MyEntity As Entity

Dim MyAttribute As AttributeObj

Dim bIsKey As Boolean

Dim AttributeName As String

bIsKey = True

AttributeName = "City"

Set MyAttribute = MyEntity.Attributes.Add(AttributeName, bIsKey)

See Also

Attributes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Attribute object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

Example

Dim MyEntity As Entity

Dim AttributeID As Integer

' We want to remove the attribute with 2 as the ID

AttributeID = 2

MyEntity.Attributes.Remove(AttributeID)

See Also

Attributes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns an attribute (specified by the given name, GUID or ID) from the entity. When passing in a name to the function, the attribute is indexed by the attribute name/rolename in the logical model and by the column name/rolename in the physical model.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As AttributeObj

Parameters

Identifier

See Also

Attributes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Attributes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Attribute objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

Example

Dim MyEntity As Entity

Dim iCount As Long

MyEntity.Attributes.Count = iCount

See Also

Attributes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns an attribute (specified by the given name, GUID or ID) from the entity. When passing in a name to the function, the attribute is indexed by the attribute name/rolename in the logical model and by the column name/rolename in the physical model.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As AttributeObj

Parameters

Identifier

Example

Dim MyEntity As Entity

Dim MyAttribute As AttributeObj

Dim AttributeID As Integer

' We want the attribute with 2 as the ID

AttributeID = 2

Set MyAttribute = MyEntity.Attributes.Item(AttributeID)

See Also

Attributes Collection


%%PageItemTitle%%

BoundAttachment Object
See Also Members

Description

This object represents a BoundAttachment in ER/Studio.

Object Model

See Also

BoundAttachment Members


%%PageItemTitle%% $$Members$$

BoundAttachment Object Members
See Also Overview

Public Methods

Public Method Attachment Returns the Attachment object of this BoundAttachment.

Public Properties

Public Property SequenceNo | This is the Sequence number of the BoundAttachment. DATATYPE: Integer.
Public Property ValueCurrent | Returns the current value of the bound attachment, whether it be the default value or an override. DATATYPE: String.
Public Property ValueOverride | Returns the ValueOverride of this BoundAttachment. This property overrides the ValueDefault of the Attachment. DATATYPE: String.

See Also

BoundAttachment Overview


%%PageItemTitle%%

Attachment Method

Description

Returns the Attachment object of this BoundAttachment.

Syntax

Visual Basic
Public Function Attachment() As Attachment

See Also

BoundAttachment Object


%%PageItemTitle%%

SequenceNo Property

Description

This is the Sequence number of the BoundAttachment. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNo() As Variant

See Also

BoundAttachment Object


%%PageItemTitle%%

ValueCurrent Property

Description

Returns the current value of the bound attachment, whether it be the default value or an override. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueCurrent() As Variant

See Also

BoundAttachment Object


%%PageItemTitle%%

ValueOverride Property

Description

Returns the ValueOverride of this BoundAttachment. This property overrides the ValueDefault of the Attachment. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueOverride() As Variant

See Also

BoundAttachment Object


%%PageItemTitle%%

BoundAttachments Collection
See Also Members

Description

This object represents a collection of BoundAttachments. Many of the ERStudio objects have this collection

Object Model

See Also

BoundAttachments Members


%%PageItemTitle%% $$Members$$

BoundAttachments Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new BoundAttachment in the collection and returns the pointer. PARAMETERS: AttachmentID as Integer.
Public Method Remove | Deletes a BoundAttachment object specified by the given AttachmentID. PARAMETERS: AttachmentID as Integer.

Public Properties

Public Property _Item | Returns a BoundAttachment object specified by the given Attachment ID or Name. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of BoundAttachment objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a BoundAttachment object specified by the given Attachment ID or Name. PARAMETERS: Identifier as Integer or String.

See Also

BoundAttachments Overview


%%PageItemTitle%%

Add Method
AttachmentID

Description

Creates a new BoundAttachment in the collection and returns the pointer. PARAMETERS: AttachmentID as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal AttachmentID As Variant _
) As BoundAttachment

Parameters

AttachmentID

See Also

BoundAttachments Collection


%%PageItemTitle%%

Remove Method
AttachmentID

Description

Deletes a BoundAttachment object specified by the given AttachmentID. PARAMETERS: AttachmentID as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal AttachmentID As Variant _
)

Parameters

AttachmentID

See Also

BoundAttachments Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a BoundAttachment object specified by the given Attachment ID or Name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As BoundAttachment

Parameters

Identifier

See Also

BoundAttachments Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

BoundAttachments Collection


%%PageItemTitle%%

Count Property

Description

This is the number of BoundAttachment objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

BoundAttachments Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a BoundAttachment object specified by the given Attachment ID or Name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As BoundAttachment

Parameters

Identifier

See Also

BoundAttachments Collection


%%PageItemTitle%%

BoundObject Object
See Also Members

Description

This object represents a binding between a dictionary object and a using object, such as a diagram object and contains the IDs of the using object. For example for a domain bound to an attribute, it has the attribute's IDs.

Remarks

This Object represents a binding between a dictionary object (Owner of the parent collection) and a using object (which can be a diagram object or a dictionary object).

Objects of this type have four read-only properties:
Object type (the type of the using object),
Using Objects ID,
Using Objects ParentID,
Using Objects ModelID.
(For Using Objects that are dictionary objects, the ModelID is zero).

For example, for a domain bound to an attribute,
the BoundObject has an ObjectType of 3,
the attributes ID for an ID,
the parent entity ID for a ParentID,
and the parent Models ID for a ModelID.

However, if the dictionary object is an attachment and the using object is a domain, then
the ObjectType would be 19 (for Domain),
the ID would be the domains ID,
the ParentID would be the DataDictionarys ID,
and the ModelID would be zero.

If the using object is or was an Entity, then
the ID would be the entity ID,
and both the parent ID and the ModelID would be the parent models ID.

See Also

BoundObject Members


%%PageItemTitle%% $$Members$$

BoundObject Object Members
See Also Overview

Public Properties

Public Property GUID | Returns the GUID of the BoundObject. DATATYPE: String.
Public Property ID | Returns the ID of the bound (using) object. For example, for an attribute bound to a domain, this returns the attributeID. DATATYPE: Integer.
Public Property ModelID | Returns the ID of the parent model of the bound object or returns the ID of the parent data flow if the using object is a transformation. If the bound object is a dictionary object, such as default bound to an Attachment, this is 0. DATATYPE: Integer.
Public Property ObjectType | This property represents the type of the bound (using) object. DATATYPE: Integer.
Public Property ParentID | Returns the ID of the parent of the bound (using) object. For example, for an attribute bound to a domain, this returns the entityID. DATATYPE: Integer.

See Also

BoundObject Overview


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the BoundObject. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

BoundObject Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the bound (using) object. For example, for an attribute bound to a domain, this returns the attributeID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

BoundObject Object


%%PageItemTitle%%

ModelID Property

Description

Returns the ID of the parent model of the bound object or returns the ID of the parent data flow if the using object is a transformation. If the bound object is a dictionary object, such as default bound to an Attachment, this is 0. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ModelID() As Variant

See Also

BoundObject Object


%%PageItemTitle%%

ObjectType Property

Description

This property represents the type of the bound (using) object. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectType() As Variant

See Also

BoundObject Object


%%PageItemTitle%%

ParentID Property

Description

Returns the ID of the parent of the bound (using) object. For example, for an attribute bound to a domain, this returns the entityID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentID() As Variant

See Also

BoundObject Object


%%PageItemTitle%%

BoundObjects Collection
See Also Members

Description

This the collection of objects that represent bindings between a dictionary object and a using object, such as a diagram object. This collection is owned by the dictionary object of the binding.

Object Model

Remarks

Dictionary objects now own a new collection called BoundObjects. This is a collection of bindings between using objects and the dictionary object that owns the collection. Each object in the collection (BoundObject) has the ID, ParentID, and ModelID of the object bound to the dictionary object. Additionally each BoundObject has a property called ObjectType, that is a number that indicates the type of the using object (the object that is bound to the dictionary object). For the ObjectType enumeration see below the table. For Domains, UDTs, Rules, Defaults, and Reference Values each BoundObject refers to an Attribute. So the ObjectType will always be 3. For Attachments, however, the BoundObject can refer to any of the following objects:

1 Entity / Table
2 Index
3 Attribute / Column
4 View
5 Procedure / Function
6 Trigger
7 Package / Object Type
10 Model
11 Relationship
12 Diagram
13 Submodel
14 SubType Cluster
15 Templated Procedure
16 Default
17 Rule
18 UserDatatype
19 Domain
20 Reference Value
29 DB2 OS/390 StoGroup
30 DB2 UDB Node Group
31 Oracle Materialized View
32 Oracle Tablespace
33 DB2 UDB BufferPool
34 DB2 OS/390 Database
35 DB2 OS/390 Auxiliary Table
36 Oracle Synonym
37 Oracle Sequence
38 Oracle Rollback Segment
42 ObjectType
43 DB2 OS/390 Alias
44 DB2 UDB Materialized Query Table
45 Shape
46 Shape Edge
52 User
53 Role / Schema
54 Naming Standards Template
55 Transformation
56 User Defined Mapping
232 DB2 UDB Tablespace
236 DB2 OS/ 390 Synonym
243 DB2 UDB Alias
432 DB2 OS/390 Tablespace

See Also

BoundObjects Members


%%PageItemTitle%% $$Members$$

BoundObjects Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a BoundObject specified by the ID of the Object that is bound to the dictionary object parent. PARAMETERS: BoundObjectID (Integer).
Public Property _NewEnum |
Public Property Count | This is the number of BoundObjects in the collection; the number of all using objects this dictionary object is bound to. DATATYPE: Integer.
Public Property Item | Returns a BoundObject specified by the ID of the Object that is bound to the dictionary object parent. PARAMETERS: BoundObjectID (Integer).

See Also

BoundObjects Overview


%%PageItemTitle%%

_Item Property
BoundObjectID
ObjectType

Description

Returns a BoundObject specified by the ID of the Object that is bound to the dictionary object parent. PARAMETERS: BoundObjectID (Integer).

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal BoundObjectID As Variant, _
   ByVal ObjectType As Variant _
) As BoundObject

Parameters

BoundObjectID
ObjectType

See Also

BoundObjects Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

BoundObjects Collection


%%PageItemTitle%%

Count Property

Description

This is the number of BoundObjects in the collection; the number of all using objects this dictionary object is bound to. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

BoundObjects Collection


%%PageItemTitle%%

Item Property
BoundObjectID
ObjectType

Description

Returns a BoundObject specified by the ID of the Object that is bound to the dictionary object parent. PARAMETERS: BoundObjectID (Integer).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal BoundObjectID As Variant, _
   ByVal ObjectType As Variant _
) As BoundObject

Parameters

BoundObjectID
ObjectType

See Also

BoundObjects Collection


%%PageItemTitle%%

BoundSecurityProperties Collection
See Also Members

Description

This object represents a collection of BoundSecurityProperties. Many of the ERStudio objects have this collection

Object Model

See Also

BoundSecurityProperties Members


%%PageItemTitle%% $$Members$$

BoundSecurityProperties Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new BoundSecurityProperty in the collection and returns the pointer. PARAMETERS: SecurityPropertyID as Integer.
Public Method Remove | Deletes a BoundSecurityProperty object specified by the given SecurityPropertyID. PARAMETERS: SecurityPropertyID as Integer.

Public Properties

Public Property _Item | Returns a BoundSecurityProperty object specified by the given SecurityProperty ID or Name. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of BoundSecurityProperty objects in the collection. ATATYPE: Integer.
Public Property Item | Returns a BoundSecurityProperty object specified by the given SecurityProperty ID or Name. PARAMETERS: Identifier as Integer or String.

See Also

BoundSecurityProperties Overview


%%PageItemTitle%%

Add Method
SecurityPropertyID

Description

Creates a new BoundSecurityProperty in the collection and returns the pointer. PARAMETERS: SecurityPropertyID as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal SecurityPropertyID As Variant _
) As BoundSecurityProperty

Parameters

SecurityPropertyID

See Also

BoundSecurityProperties Collection


%%PageItemTitle%%

Remove Method
SecurityPropertyID

Description

Deletes a BoundSecurityProperty object specified by the given SecurityPropertyID. PARAMETERS: SecurityPropertyID as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal SecurityPropertyID As Variant _
)

Parameters

SecurityPropertyID

See Also

BoundSecurityProperties Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a BoundSecurityProperty object specified by the given SecurityProperty ID or Name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As BoundSecurityProperty

Parameters

Identifier

See Also

BoundSecurityProperties Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

BoundSecurityProperties Collection


%%PageItemTitle%%

Count Property

Description

This is the number of BoundSecurityProperty objects in the collection. ATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

BoundSecurityProperties Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a BoundSecurityProperty object specified by the given SecurityProperty ID or Name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As BoundSecurityProperty

Parameters

Identifier

See Also

BoundSecurityProperties Collection


%%PageItemTitle%%

BoundSecurityProperty Object
See Also Members

Description

This object represents a BoundSecurityProperty in ER/Studio.

Object Model

See Also

BoundSecurityProperty Members


%%PageItemTitle%% $$Members$$

BoundSecurityProperty Object Members
See Also Overview

Public Methods

Public Method SecurityProperty Returns the SecurityProperty object of this BoundSecurityProperty.

Public Properties

Public Property SequenceNo | This is the Sequence number of the BoundSecurityProperty. DATATYPE: Integer.
Public Property ValueCurrent | Returns the current value of the bound security property, whether it be the default value or an override. DATATYPE: String.
Public Property ValueOverride | Returns the ValueOverride of this BoundSecurityProperty. This property overrides the ValueDefault of the SecurityProperty. DATATYPE: String.

See Also

BoundSecurityProperty Overview


%%PageItemTitle%%

SecurityProperty Method

Description

Returns the SecurityProperty object of this BoundSecurityProperty.

Syntax

Visual Basic
Public Function SecurityProperty() As SecurityProperty

See Also

BoundSecurityProperty Object


%%PageItemTitle%%

SequenceNo Property

Description

This is the Sequence number of the BoundSecurityProperty. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNo() As Variant

See Also

BoundSecurityProperty Object


%%PageItemTitle%%

ValueCurrent Property

Description

Returns the current value of the bound security property, whether it be the default value or an override. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueCurrent() As Variant

See Also

BoundSecurityProperty Object


%%PageItemTitle%%

ValueOverride Property

Description

Returns the ValueOverride of this BoundSecurityProperty. This property overrides the ValueDefault of the SecurityProperty. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueOverride() As Variant

See Also

BoundSecurityProperty Object


%%PageItemTitle%%

BusinessDataObject Object
See Also Members

Description

This object represents a Business Data Object in ER/Studio.

Object Model

See Also

BusinessDataObject Members


%%PageItemTitle%% $$Members$$

BusinessDataObject Object Members
See Also Overview

Public Methods

Public Method AddContainedObject | Add a contained object to the BusinessDataObject using the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer. DATATYPE: BoundObject.
Public Method BoundAttachments | Get all the BoundAttachments of this BusinessDataObject.
Public Method ContainedObjects | Returns an object representing a collection of all objects contained in the BusinessDataObject.
Public Method RepoCheckOutStatus | Get the Check Out status of this BusinessDataObject. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this BusinessDataObject from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property AnchorID | Returns the Entity ID of the BusinessDataObject's anchor. DATATYPE: Integer.
Public Property Definition | This property represents the definition of the BusinessDataObject. DATATYPE: String.
Public Property GUID | Returns the BusinessDataObject's GUID. DATATYPE: String.
Public Property ID | Returns the BusinessDataObject ID. DATATYPE: Integer.
Public Property LogicalName | This property represents the logical name of the BusinessDataObject. DATATYPE: String.
Public Property Note | This property represents the note of the BusinessDataObject. DATATYPE: String.
Public Property PhysicalName | This property represents the physical name of the BusinessDataObject. DATATYPE: String.

See Also

BusinessDataObject Overview


%%PageItemTitle%%

AddContainedObject Method
Identifier

Description

Add a contained object to the BusinessDataObject using the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer. DATATYPE: BoundObject.

Syntax

Visual Basic
Public Function AddContainedObject( _
   ByVal Identifier As Variant _
) As BoundObject

Parameters

Identifier

See Also

BusinessDataObject Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this BusinessDataObject.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

BusinessDataObject Object


%%PageItemTitle%%

ContainedObjects Method

Description

Returns an object representing a collection of all objects contained in the BusinessDataObject.

Syntax

Visual Basic
Public Function ContainedObjects() As BoundObjects

See Also

BusinessDataObject Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this BusinessDataObject. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this BusinessDataObject from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

AnchorID Property

Description

Returns the Entity ID of the BusinessDataObject's anchor. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property AnchorID() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

Definition Property

Description

This property represents the definition of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

GUID Property

Description

Returns the BusinessDataObject's GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

ID Property

Description

Returns the BusinessDataObject ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

LogicalName Property

Description

This property represents the logical name of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogicalName() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

Note Property

Description

This property represents the note of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Note() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

PhysicalName Property

Description

This property represents the physical name of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PhysicalName() As Variant

See Also

BusinessDataObject Object


%%PageItemTitle%%

BusinessDataObjectDisplay Object
See Also Members

Description

This object represents an Business Data Object display object in ER/Studio. A Business Data Object display object is a graphical representation of a BusinessDataObject object in a specific submodel; it is not a BusinessDataObject object itself.

Object Model

See Also

BusinessDataObjectDisplay Members


%%PageItemTitle%% $$Members$$

BusinessDataObjectDisplay Object Members
See Also Overview

Public Methods

Public Method Collapse | Collapse this BusinessDataObject display object.
Public Method Expand | Expand this BusinessDataObject display object.
Public Method RepoCheckOutStatus | Get the Check Out status of this BusinessDataObjectDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this BusinessDataObject display object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method Resize | Resize the BusinessDataObject display to default size.

Public Properties

Public Property BackgroundColor | The background color of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property DisplayBackgroundColor | This determines whether to use a custom background color just for this BusinessDataObject display object (true) or whether to use the default background color of the submodel (false). DATATYPE: Boolean.
Public Property GUID | GUID of the BusinessDataObject display object. This GUID is assigned by ER/Studio. Each BusinessDataObject display object has a unique GUID. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the BusinessDataObject display object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the BusinessDataObject display object. DATATYPE: Integer.
Public Property ID | ID of the BusinessDataObject display object. This ID is assigned by ER/Studio. Each BusinessDataObject display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property LogicalName | This is the logical name of the BusinessDataObject object. DATATYPE: String.
Public Property NameColor | Color for the name. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NameFont | Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property OutlineColor | This is the OutlineColor of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property PhysicalName | This is the physical name of the BusinessDataObject object. DATATYPE: String.
Public Property VerticalPosition | This is the y coordinate of the BusinessDataObject display object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the BusinessDataObject display object. DATATYPE: Integer.

See Also

BusinessDataObjectDisplay Overview


%%PageItemTitle%%

Collapse Method

Description

Collapse this BusinessDataObject display object.

Syntax

Visual Basic
Public Sub Collapse()

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

Expand Method

Description

Expand this BusinessDataObject display object.

Syntax

Visual Basic
Public Sub Expand()

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this BusinessDataObjectDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this BusinessDataObject display object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

Resize Method

Description

Resize the BusinessDataObject display to default size.

Syntax

Visual Basic
Public Sub Resize()

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

BackgroundColor Property

Description

The background color of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackgroundColor() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

DisplayBackgroundColor Property

Description

This determines whether to use a custom background color just for this BusinessDataObject display object (true) or whether to use the default background color of the submodel (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayBackgroundColor() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the BusinessDataObject display object. This GUID is assigned by ER/Studio. Each BusinessDataObject display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the BusinessDataObject display object. This ID is assigned by ER/Studio. Each BusinessDataObject display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

LogicalName Property

Description

This is the logical name of the BusinessDataObject object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalName() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

NameColor Property

Description

Color for the name. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NameColor() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

NameFont Property

Description

Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NameFont() As ERSFont

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

OutlineColor Property

Description

This is the OutlineColor of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlineColor() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

PhysicalName Property

Description

This is the physical name of the BusinessDataObject object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalName() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

BusinessDataObjectDisplay Object


%%PageItemTitle%%

BusinessDataObjectDisplays Collection
See Also Members

Description

This object represents a collection of Business Data Object display objects. The owner of this collection is the submodel object.

Object Model

See Also

BusinessDataObjectDisplays Members


%%PageItemTitle%% $$Members$$

BusinessDataObjectDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new BusinessDataObject display object from the BusinessDataObject object identified by the given Name, GUID, or ID, and then returns the new display object. PARAMETERS: Identifier as String or Integer.
Public Method Remove | Deletes a BusinessDataObject display object specified by the given Name, GUID, or ID from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Business Data Object displays in the collection. DATATYPE: Integer.
Public Property Item | Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.

See Also

BusinessDataObjectDisplays Overview


%%PageItemTitle%%

Add Method
Identifier

Description

Creates a new BusinessDataObject display object from the BusinessDataObject object identified by the given Name, GUID, or ID, and then returns the new display object. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Identifier As Variant _
) As BusinessDataObjectDisplay

Parameters

Identifier

See Also

BusinessDataObjectDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a BusinessDataObject display object specified by the given Name, GUID, or ID from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

BusinessDataObjectDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As BusinessDataObjectDisplay

Parameters

Identifier

See Also

BusinessDataObjectDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

BusinessDataObjectDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Business Data Object displays in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

BusinessDataObjectDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As BusinessDataObjectDisplay

Parameters

Identifier

See Also

BusinessDataObjectDisplays Collection


%%PageItemTitle%%

BusinessDataObjects Collection
See Also Members

Description

This object represents a collection of Business Data Objects. The owner of this collection is the model.

Object Model

See Also

BusinessDataObjects Members


%%PageItemTitle%% $$Members$$

BusinessDataObjects Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new BusinessDataObject. PARAMETERS: LogicalName (String), PhysicalName (String).
Public Method Remove | Deletes a BusinessDataObject object specified by the given Name, GUID, or ID from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of BusinessDataObjects in the collection. DATATYPE: Integer.
Public Property Item | Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.

See Also

BusinessDataObjects Overview


%%PageItemTitle%%

Add Method
LogicalName
PhysicalName

Description

Creates and returns a new BusinessDataObject. PARAMETERS: LogicalName (String), PhysicalName (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal LogicalName As Variant, _
   ByVal PhysicalName As Variant _
) As BusinessDataObject

Parameters

LogicalName
PhysicalName

See Also

BusinessDataObjects Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a BusinessDataObject object specified by the given Name, GUID, or ID from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

BusinessDataObjects Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As BusinessDataObject

Parameters

Identifier

See Also

BusinessDataObjects Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

BusinessDataObjects Collection


%%PageItemTitle%%

Count Property

Description

This is the number of BusinessDataObjects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

BusinessDataObjects Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As BusinessDataObject

Parameters

Identifier

See Also

BusinessDataObjects Collection


%%PageItemTitle%%

DataFlow Object
See Also Members

Description

This object represents a data flow in ER/Studio.

Object Model

See Also

DataFlow Members


%%PageItemTitle%% $$Members$$

DataFlow Object Members
See Also Overview

Public Methods

Public Method DataStreams | Returns an object representing a collection of all data streams in the data flow.
Public Method ExportImageOptions | Get ExportImageOptions object for this data flow.
Public Method LineageComponentDisplays | Returns an object representing a collection of all lineage component display objects in the data flow.
Public Method LineageComponents | Returns an object representing a collection of all lineage components in the data flow.
Public Method LineDisplays | Returns an object representing a collection of all line display objects in the data flow.
Public Method Lines | Returns an object representing a collection of all lines in the data flow.
Public Method ShapeDisplays | Returns an object representing a collection of all shape display objects in the data flow.
Public Method Shapes | Returns the Shapes of this data flow.
Public Method TransformationDisplays | Returns an object representing a collection of all transformation display objects in the data flow.
Public Method Transformations | Returns an object representing a collection of all transformations in the data flow.
Public Method UserComments | Returns a collection of the user comments associated with this data flow.

Public Properties

Public Property GUID | This is the GUID of the data flow. DATATYPE: String.
Public Property ID | ID of the data flow. This ID is assigned by ER/Studio. Each data flow in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | DATATYPE: String. This is the name of the data flow.

See Also

DataFlow Overview


%%PageItemTitle%%

DataStreams Method

Description

Returns an object representing a collection of all data streams in the data flow.

Syntax

Visual Basic
Public Function DataStreams() As DataStreams

See Also

DataFlow Object


%%PageItemTitle%%

ExportImageOptions Method

Description

Get ExportImageOptions object for this data flow.

Syntax

Visual Basic
Public Function ExportImageOptions() As ExportImageOptions

See Also

DataFlow Object


%%PageItemTitle%%

LineageComponentDisplays Method

Description

Returns an object representing a collection of all lineage component display objects in the data flow.

Syntax

Visual Basic
Public Function LineageComponentDisplays() As LineageComponentDisplays

See Also

DataFlow Object


%%PageItemTitle%%

LineageComponents Method

Description

Returns an object representing a collection of all lineage components in the data flow.

Syntax

Visual Basic
Public Function LineageComponents() As LineageComponents

See Also

DataFlow Object


%%PageItemTitle%%

LineDisplays Method

Description

Returns an object representing a collection of all line display objects in the data flow.

Syntax

Visual Basic
Public Function LineDisplays() As LineDisplays

See Also

DataFlow Object


%%PageItemTitle%%

Lines Method

Description

Returns an object representing a collection of all lines in the data flow.

Syntax

Visual Basic
Public Function Lines() As Lines

See Also

DataFlow Object


%%PageItemTitle%%

ShapeDisplays Method

Description

Returns an object representing a collection of all shape display objects in the data flow.

Syntax

Visual Basic
Public Function ShapeDisplays() As ShapeDisplays

See Also

DataFlow Object


%%PageItemTitle%%

Shapes Method

Description

Returns the Shapes of this data flow.

Syntax

Visual Basic
Public Function Shapes() As Shapes

See Also

DataFlow Object


%%PageItemTitle%%

TransformationDisplays Method

Description

Returns an object representing a collection of all transformation display objects in the data flow.

Syntax

Visual Basic
Public Function TransformationDisplays() As TransformationDisplays

See Also

DataFlow Object


%%PageItemTitle%%

Transformations Method

Description

Returns an object representing a collection of all transformations in the data flow.

Syntax

Visual Basic
Public Function Transformations() As Transformations

See Also

DataFlow Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of the user comments associated with this data flow.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataFlow Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the data flow. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataFlow Object


%%PageItemTitle%%

ID Property

Description

ID of the data flow. This ID is assigned by ER/Studio. Each data flow in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataFlow Object


%%PageItemTitle%%

Name Property

Description

DATATYPE: String. This is the name of the data flow.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DataFlow Object


%%PageItemTitle%%

DataFlows Collection
See Also Members

Description

This object represents a collection of data flows. The owner of this collection is the diagram.

Object Model

See Also

DataFlows Members


%%PageItemTitle%% $$Members$$

DataFlows Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new data flow with the given name and returns the new data flow to the caller. PARAMETERS: Name as String
Public Method Remove | Deletes a DataFlow object (specified by one of the DataFlow properties, name, GUID or ID) from ER/Studio. PARAMETERS: Identifier as String(name or GUID) or Integer(ID).

Public Properties

Public Property _Item | Returns a DataFlow object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataFlow objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DataFlow object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DataFlows Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates a new data flow with the given name and returns the new data flow to the caller. PARAMETERS: Name as String

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DataFlow

Parameters

Name

See Also

DataFlows Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataFlow object (specified by one of the DataFlow properties, name, GUID or ID) from ER/Studio. PARAMETERS: Identifier as String(name or GUID) or Integer(ID).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataFlows Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DataFlow object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataFlow

Parameters

Identifier

See Also

DataFlows Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataFlows Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataFlow objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataFlows Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DataFlow object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataFlow

Parameters

Identifier

See Also

DataFlows Collection


%%PageItemTitle%%

DataLineageColumn Object
See Also Members

Description

This object represents a DataLineageColumn.

Object Model

See Also

DataLineageColumn Members


%%PageItemTitle%% $$Members$$

DataLineageColumn Object Members
See Also Overview

Public Methods

Public Method UserComments Returns a collection of user comments associated with this DataLineageColumn.

Public Properties

Public Property AttributeName | This property represents the attribute name of the DataLineageColumn. DATATYPE: String.
Public Property ColumnName | This property represents the column name of the DataLineageColumn. DATATYPE: String.
Public Property DataLength | The data length of the datatype (if any). DATATYPE: Integer.
Public Property DataScale | The data scale of the datatype (if any). DATATYPE: Integer.
Public Property Datatype | This is the datatype of the data lineage column. DATATYPE: String.
Public Property Definition | This is the definition of the DataLineageColumn. DATATYPE: String.
Public Property GUID | Returns the GUID of the DataLineageColumn. DATATYPE: String.
Public Property Hidden | This is the flag indicating that an DataLineageColumn is hidden in the Diagram display. DATATYPE: Boolean.
Public Property ID | Returns the ID of the DataLineageColumn. DATATYPE: Integer.
Public Property Identity | This is the identity property of the DataLineageColumn. DATATYPE: Boolean.
Public Property IdentityIncrement | This is the identity increment value of the DataLineageColumn. DATATYPE: Integer.
Public Property IdentitySeed | This is the identity seed value of the DataLineageColumn. DATATYPE: Integer.
Public Property NullOption | This is the nullability of the DataLineageColumn. DATATYPE: String. The possible values are: 'NULL' or 'NOT NULL'.
Public Property PrimaryKey | This property represents the Primary Key of the DataLineageColumn. If this property is true, the column is a PK. DATATYPE: Boolean.
Public Property SequenceNumber | This property is the sequence number of the DataLineageColumn. DATATYPE: Integer.

See Also

DataLineageColumn Overview


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataLineageColumn.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataLineageColumn Object


%%PageItemTitle%%

AttributeName Property

Description

This property represents the attribute name of the DataLineageColumn. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttributeName() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

ColumnName Property

Description

This property represents the column name of the DataLineageColumn. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnName() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

DataLength Property

Description

The data length of the datatype (if any). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataLength() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

DataScale Property

Description

The data scale of the datatype (if any). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataScale() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

Datatype Property

Description

This is the datatype of the data lineage column. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

Definition Property

Description

This is the definition of the DataLineageColumn. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the DataLineageColumn. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

Hidden Property

Description

This is the flag indicating that an DataLineageColumn is hidden in the Diagram display. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Hidden() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the DataLineageColumn. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

Identity Property

Description

This is the identity property of the DataLineageColumn. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Identity() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

IdentityIncrement Property

Description

This is the identity increment value of the DataLineageColumn. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentityIncrement() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

IdentitySeed Property

Description

This is the identity seed value of the DataLineageColumn. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentitySeed() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

NullOption Property

Description

This is the nullability of the DataLineageColumn. DATATYPE: String. The possible values are: 'NULL' or 'NOT NULL'.

Property type

Read-write property

Syntax

Visual Basic
Public Property NullOption() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

PrimaryKey Property

Description

This property represents the Primary Key of the DataLineageColumn. If this property is true, the column is a PK. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimaryKey() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

SequenceNumber Property

Description

This property is the sequence number of the DataLineageColumn. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

DataLineageColumn Object


%%PageItemTitle%%

DataLineageColumns Collection
See Also Members

Description

This object represents the collection of DataLineageColumns. The owner of this collection is the DataLineageTable (Data Source/Target Table).

Object Model

See Also

DataLineageColumns Members


%%PageItemTitle%% $$Members$$

DataLineageColumns Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DataLineageColumn, and adds it to the collection. If IsKey is true, it will be a Primary Key. PARAMETERS: Name (String).
Public Method Remove | Deletes a DataLineageColumn from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns the DataLineageColumn specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataLineageColumns in the collection (in the Data Source/Target Table). DATATYPE: Integer.
Public Property Item | Returns the DataLineageColumn specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

See Also

DataLineageColumns Overview


%%PageItemTitle%%

Add Method
Name
IsKey

Description

Creates and returns a new DataLineageColumn, and adds it to the collection. If IsKey is true, it will be a Primary Key. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal IsKey As Variant _
) As DataLineageColumn

Parameters

Name
IsKey

See Also

DataLineageColumns Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataLineageColumn from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataLineageColumns Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DataLineageColumn specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataLineageColumn

Parameters

Identifier

See Also

DataLineageColumns Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataLineageColumns Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataLineageColumns in the collection (in the Data Source/Target Table). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataLineageColumns Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DataLineageColumn specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataLineageColumn

Parameters

Identifier

See Also

DataLineageColumns Collection


%%PageItemTitle%%

DataLineageRule Object
See Also Members

Description

This object represents an DataLineageRule (Data Movement Rule) in ER/Studio.

Object Model

See Also

DataLineageRule Members


%%PageItemTitle%% $$Members$$

DataLineageRule Object Members
See Also Overview

Public Methods

Public Method UserComments Returns a collection of user comments associated with this DataLineageRule.

Public Properties

Public Property GUID | This is the GUID of the DataLineageRule. DATATYPE: String.
Public Property ID | Returns the DataLineageRule ID. DATATYPE: Integer.
Public Property Name | This is the name of the DataLineageRule. DATATYPE: String.
Public Property RuleText | This is the Rule Text of the DataLineageRule. DATATYPE: String.
Public Property RuleType | This is the RuleType of the DataLineageRule. DATATYPE: String. Valid RuleTypes are ARCHIVE RULE, BACKUP RULE, CREATE RULE, DELETION RULE, RECOVERY RULE, UPDATE RULE, BOOLEAN, DATE, EXTERNAL FILE PATH, NUMERIC, TEXT, TEXT LIST, TIME.

See Also

DataLineageRule Overview


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataLineageRule.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataLineageRule Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DataLineageRule. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataLineageRule Object


%%PageItemTitle%%

ID Property

Description

Returns the DataLineageRule ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataLineageRule Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DataLineageRule. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DataLineageRule Object


%%PageItemTitle%%

RuleText Property

Description

This is the Rule Text of the DataLineageRule. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property RuleText() As Variant

See Also

DataLineageRule Object


%%PageItemTitle%%

RuleType Property

Description

This is the RuleType of the DataLineageRule. DATATYPE: String. Valid RuleTypes are ARCHIVE RULE, BACKUP RULE, CREATE RULE, DELETION RULE, RECOVERY RULE, UPDATE RULE, BOOLEAN, DATE, EXTERNAL FILE PATH, NUMERIC, TEXT, TEXT LIST, TIME.

Property type

Read-write property

Syntax

Visual Basic
Public Property RuleType() As Variant

See Also

DataLineageRule Object


%%PageItemTitle%%

DataLineageRules Collection
See Also Members

Description

This object represents a collection of DataLineageRules. The owner of this collection is the DataDictionary.

Object Model

See Also

DataLineageRules Members


%%PageItemTitle%% $$Members$$

DataLineageRules Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DataLineageRule. PARAMETERS: Name, RuleText, and Type(String). Valid Types: ARCHIVE RULE, BACKUP RULE, CREATE RULE, DELETION RULE, RECOVERY RULE, UPDATE RULE, BOOLEAN, DATE, EXTERNAL FILE PATH, NUMERIC, TEXT, TEXT LIST, TIME.
Public Method Remove | Deletes a DataLineageRule object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DataLineageRule object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataLineageRule in the collection. DATATYPE: Integer.
Public Property Item | Returns a DataLineageRule object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

DataLineageRules Overview


%%PageItemTitle%%

Add Method
Name
RuleText
RuleType

Description

Creates and returns a new DataLineageRule. PARAMETERS: Name, RuleText, and Type(String). Valid Types: ARCHIVE RULE, BACKUP RULE, CREATE RULE, DELETION RULE, RECOVERY RULE, UPDATE RULE, BOOLEAN, DATE, EXTERNAL FILE PATH, NUMERIC, TEXT, TEXT LIST, TIME.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal RuleText As Variant, _
   ByVal RuleType As Variant _
) As DataLineageRule

Parameters

Name
RuleText
RuleType

See Also

DataLineageRules Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataLineageRule object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataLineageRules Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DataLineageRule object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataLineageRule

Parameters

Identifier

See Also

DataLineageRules Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataLineageRules Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataLineageRule in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataLineageRules Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DataLineageRule object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataLineageRule

Parameters

Identifier

See Also

DataLineageRules Collection


%%PageItemTitle%%

DataLineageSource Object
See Also Members

Description

This object represents a DataLineageSource (Data Source/Target model in the DataLineage tree).

Object Model

See Also

DataLineageSource Members


%%PageItemTitle%% $$Members$$

DataLineageSource Object Members
See Also Overview

Public Methods

Public Method DataLineageTables | Returns an object representing a collection of all source/target tables belonging to this DataLineageSourceModel (Data Source/Target model).
Public Method DataLineageViews | Returns an object representing a collection of all source/target views belonging to this DataLineageSourceModel (Data Source/Target model).
Public Method UserComments | Returns a collection of all the user comments associated with this DataLineageSourceModel (Data Source/Target model).

Public Properties

Public Property DatabasePlatform | This is the database platform type of the DataLineageSource model. DATATYPE: String.
Public Property DatabasePlatformID | This is the database platform type ID of the DataLineageSource model. This property can be used to change the database platform of the model. DATATYPE: Integer.
Public Property Description | This property is the description of the DataLineageSource model. DATATYPE: String.
Public Property Encoding | This property holds the Encoding information. This property applies to DataLineageSource models of type Flat File only. DATATYPE: String.
Public Property FileType | This property holds the file type information. This property applies to DataLineageSource models of type Flat File only. DATATYPE: String.
Public Property GUID | Returns the GUID of the DataLineageSource model. DATATYPE: String.
Public Property Host | This property holds the Host information. This applies to DataLineageSource models of type Relational only. DATATYPE: String.
Public Property ID | Returns the ID of the DataLineageSource model. DATATYPE: Integer.
Public Property MajorPlatform | This is a more generalized description of the database platform type of the DataLineageSource model. DATATYPE: String.
Public Property Name | This property represents the name of the DataLineageSource model. DATATYPE: String.
Public Property Path | This property holds the location/path information. This property applies to DataLineageSource models of type Other only. DATATYPE: String.
Public Property Port | This property holds the Port information. This property applies to DataLineageSource models of type Relational only. DATATYPE: String.
Public Property Server | This property holds the Server/Service information. This applies to DataLineageSource models of type Relational only. DATATYPE: String.
Public Property Type | This property is the type of the DataLineageSource model. DATATYPE: String. It can be RELATIONAL, FLAT FILE or OTHER.

See Also

DataLineageSource Overview


%%PageItemTitle%%

DataLineageTables Method

Description

Returns an object representing a collection of all source/target tables belonging to this DataLineageSourceModel (Data Source/Target model).

Syntax

Visual Basic
Public Function DataLineageTables() As DataLineageTables

See Also

DataLineageSource Object


%%PageItemTitle%%

DataLineageViews Method

Description

Returns an object representing a collection of all source/target views belonging to this DataLineageSourceModel (Data Source/Target model).

Syntax

Visual Basic
Public Function DataLineageViews() As DataLineageViews

See Also

DataLineageSource Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of all the user comments associated with this DataLineageSourceModel (Data Source/Target model).

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataLineageSource Object


%%PageItemTitle%%

DatabasePlatform Property

Description

This is the database platform type of the DataLineageSource model. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property DatabasePlatform() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

DatabasePlatformID Property

Description

This is the database platform type ID of the DataLineageSource model. This property can be used to change the database platform of the model. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabasePlatformID() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Description Property

Description

This property is the description of the DataLineageSource model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Encoding Property

Description

This property holds the Encoding information. This property applies to DataLineageSource models of type Flat File only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Encoding() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

FileType Property

Description

This property holds the file type information. This property applies to DataLineageSource models of type Flat File only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileType() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the DataLineageSource model. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Host Property

Description

This property holds the Host information. This applies to DataLineageSource models of type Relational only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Host() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the DataLineageSource model. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

MajorPlatform Property

Description

This is a more generalized description of the database platform type of the DataLineageSource model. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property MajorPlatform() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DataLineageSource model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Path Property

Description

This property holds the location/path information. This property applies to DataLineageSource models of type Other only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Path() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Port Property

Description

This property holds the Port information. This property applies to DataLineageSource models of type Relational only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Port() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Server Property

Description

This property holds the Server/Service information. This applies to DataLineageSource models of type Relational only. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Server() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

Type Property

Description

This property is the type of the DataLineageSource model. DATATYPE: String. It can be RELATIONAL, FLAT FILE or OTHER.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

DataLineageSource Object


%%PageItemTitle%%

DataLineageSources Collection
See Also Members

Description

This object represents the collection of DataLineageSources (Data Source/Target models in the DataLineage tree). The owner of this collection is the diagram.

Object Model

See Also

DataLineageSources Members


%%PageItemTitle%% $$Members$$

DataLineageSources Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DataLineageSource Model, and adds it to the collection. Database types are listed in the Introduction section of the Automation Interface Reference. PARAMETERS: Name (String), DatabaseType_ID (Integer).
Public Method Remove | Deletes a DataLineageSource Model from the collection (Data Source/Targets from the DataLineage tree). PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns the DataLineageSource specified by either the name, GUID or the ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataLineageSource models in the collection (Data Source/Targets in the DataLineage tree).DATATYPE: Integer.
Public Property Item | Returns the DataLineageSource specified by either the name, GUID or the ID. PARAMETERS: Identifier as String or Integer.

See Also

DataLineageSources Overview


%%PageItemTitle%%

Add Method
Name
DatabaseType_ID

Description

Creates and returns a new DataLineageSource Model, and adds it to the collection. Database types are listed in the Introduction section of the Automation Interface Reference. PARAMETERS: Name (String), DatabaseType_ID (Integer).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal DatabaseType_ID As Variant _
) As DataLineageSource

Parameters

Name
DatabaseType_ID

See Also

DataLineageSources Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataLineageSource Model from the collection (Data Source/Targets from the DataLineage tree). PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataLineageSources Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DataLineageSource specified by either the name, GUID or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataLineageSource

Parameters

Identifier

See Also

DataLineageSources Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataLineageSources Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataLineageSource models in the collection (Data Source/Targets in the DataLineage tree).DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataLineageSources Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DataLineageSource specified by either the name, GUID or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataLineageSource

Parameters

Identifier

See Also

DataLineageSources Collection


%%PageItemTitle%%

DataLineageTable Object
See Also Members

Description

This object represents a DataLineageTable.

Object Model

See Also

DataLineageTable Members


%%PageItemTitle%% $$Members$$

DataLineageTable Object Members
See Also Overview

Public Methods

Public Method DataLineageColumns | Returns an object representing a collection of all source/target Columns belonging to this DataLineageTable (source/target table).
Public Method UserComments | Returns a collection of user comments associated with this DataLineageTable.

Public Properties

Public Property Definition | This property is the definition of the DataLineageTable. DATATYPE: String.
Public Property GUID | Returns the GUID of the DataLineageTable. DATATYPE: String.
Public Property ID | Returns the ID of the DataLineageTable. DATATYPE: Integer.
Public Property Name | This property represents the name of the DataLineageTable. DATATYPE: String.
Public Property Owner | This property represents the owner of the DataLineageTable. DATATYPE: String.

See Also

DataLineageTable Overview


%%PageItemTitle%%

DataLineageColumns Method

Description

Returns an object representing a collection of all source/target Columns belonging to this DataLineageTable (source/target table).

Syntax

Visual Basic
Public Function DataLineageColumns() As DataLineageColumns

See Also

DataLineageTable Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataLineageTable.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataLineageTable Object


%%PageItemTitle%%

Definition Property

Description

This property is the definition of the DataLineageTable. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

DataLineageTable Object


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the DataLineageTable. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataLineageTable Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the DataLineageTable. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataLineageTable Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DataLineageTable. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DataLineageTable Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DataLineageTable. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DataLineageTable Object


%%PageItemTitle%%

DataLineageTables Collection
See Also Members

Description

This object represents the collection of DataLineageTables. The owner of this collection is the DataLineageSource (Data Source/Target).

Object Model

See Also

DataLineageTables Members


%%PageItemTitle%% $$Members$$

DataLineageTables Collection Members
See Also Overview

Public Methods

Public Method Add | Creates in the collection and returns a new DataLineageTable. Name specifies the TableName, but if the name passed in is a duplicate, then it uses the default name. PARAMETERS: Name (String).
Public Method Remove | Deletes a DataLineageTable from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns the DataLineageTable specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataLineageTables in the collection (Data Source/Target Tables).DATATYPE: Integer.
Public Property Item | Returns the DataLineageTable specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

See Also

DataLineageTables Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates in the collection and returns a new DataLineageTable. Name specifies the TableName, but if the name passed in is a duplicate, then it uses the default name. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DataLineageTable

Parameters

Name

See Also

DataLineageTables Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataLineageTable from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataLineageTables Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DataLineageTable specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataLineageTable

Parameters

Identifier

See Also

DataLineageTables Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataLineageTables Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataLineageTables in the collection (Data Source/Target Tables).DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataLineageTables Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DataLineageTable specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataLineageTable

Parameters

Identifier

See Also

DataLineageTables Collection


%%PageItemTitle%%

DataLineageView Object
See Also Members

Description

This object represents a DataLineageView.

Object Model

See Also

DataLineageView Members


%%PageItemTitle%% $$Members$$

DataLineageView Object Members
See Also Overview

Public Methods

Public Method DataLineageViewFields | Returns an object representing a collection of all source/target ViewFields belonging to this DataLineageView (source/target table).
Public Method UserComments | Returns a collection of user comments associated with this DataLineageView.

Public Properties

Public Property Definition | This property is the definition of the DataLineageView. DATATYPE: String.
Public Property GUID | Returns the GUID of the DataLineageView. DATATYPE: String.
Public Property ID | Returns the ID of the DataLineageView. DATATYPE: Integer.
Public Property Name | This property represents the name of the DataLineageView. DATATYPE: String.
Public Property Owner | This property represents the owner of the DataLineageView. DATATYPE: String.

See Also

DataLineageView Overview


%%PageItemTitle%%

DataLineageViewFields Method

Description

Returns an object representing a collection of all source/target ViewFields belonging to this DataLineageView (source/target table).

Syntax

Visual Basic
Public Function DataLineageViewFields() As DataLineageViewFields

See Also

DataLineageView Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataLineageView.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataLineageView Object


%%PageItemTitle%%

Definition Property

Description

This property is the definition of the DataLineageView. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

DataLineageView Object


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the DataLineageView. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataLineageView Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the DataLineageView. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataLineageView Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DataLineageView. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DataLineageView Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DataLineageView. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DataLineageView Object


%%PageItemTitle%%

DataLineageViewField Object
See Also Members

Description

This object represents a DataLineageViewField.

Object Model

See Also

DataLineageViewField Members


%%PageItemTitle%% $$Members$$

DataLineageViewField Object Members
See Also Overview

Public Methods

Public Method UserComments Returns a collection of user comments associated with this DataLineageViewField.

Public Properties

Public Property Alias | This is the alias of the DataLineageViewField. DATATYPE: String.
Public Property ColumnExpression | This is the column expression of the DataLineageViewField. DATATYPE: String.
Public Property GUID | GUID of the DataLineageViewField. This GUID is assigned by ER/Studio. Each DataLineageViewField has a unique GUID. DATATYPE: String.
Public Property ID | ID of the DataLineageViewField. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property ParentColumnName | This is the parent column name of the DataLineageViewField. DATATYPE: String.
Public Property ParentName | This is the parent name of the DataLineageViewField. It can be a DataLineageTable or DataLineageView name depending on what the parent is. DATATYPE: String.
Public Property SequenceNumber | This is the sequence number of the DataLineageViewField. DATATYPE: Integer.

See Also

DataLineageViewField Overview


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataLineageViewField.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataLineageViewField Object


%%PageItemTitle%%

Alias Property

Description

This is the alias of the DataLineageViewField. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Alias() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

ColumnExpression Property

Description

This is the column expression of the DataLineageViewField. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ColumnExpression() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

GUID Property

Description

GUID of the DataLineageViewField. This GUID is assigned by ER/Studio. Each DataLineageViewField has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

ID Property

Description

ID of the DataLineageViewField. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

ParentColumnName Property

Description

This is the parent column name of the DataLineageViewField. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentColumnName() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

ParentName Property

Description

This is the parent name of the DataLineageViewField. It can be a DataLineageTable or DataLineageView name depending on what the parent is. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentName() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

SequenceNumber Property

Description

This is the sequence number of the DataLineageViewField. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

DataLineageViewField Object


%%PageItemTitle%%

DataLineageViewFields Collection
See Also Members

Description

This object represents the collection of DataLineageViewFields. The owner of this collection is the DataLineageView (Data Source/Target View).

Object Model

See Also

DataLineageViewFields Members


%%PageItemTitle%% $$Members$$

DataLineageViewFields Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns the DataLineageViewField specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataLineageViewFields in the collection (in the Data Source/Target View). DATATYPE: Integer.
Public Property Item | Returns the DataLineageViewField specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

See Also

DataLineageViewFields Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DataLineageViewField specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataLineageViewField

Parameters

Identifier

See Also

DataLineageViewFields Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataLineageViewFields Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataLineageViewFields in the collection (in the Data Source/Target View). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataLineageViewFields Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DataLineageViewField specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataLineageViewField

Parameters

Identifier

See Also

DataLineageViewFields Collection


%%PageItemTitle%%

DataLineageViews Collection
See Also Members

Description

This object represents the collection of DataLineageViews. The owner of this collection is the DataLineageSource (Data Source/Target).

Object Model

See Also

DataLineageViews Members


%%PageItemTitle%% $$Members$$

DataLineageViews Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new DataLineageView with the given Name, and returns the new DataLineageView to the caller. PARAMETERS: Name as String.
Public Method Remove | Deletes a DataLineageView from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns the DataLineageView specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataLineageViews in the collection (Data Source/Target Tables).DATATYPE: Integer.
Public Property Item | Returns the DataLineageView specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

See Also

DataLineageViews Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates a new DataLineageView with the given Name, and returns the new DataLineageView to the caller. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DataLineageView

Parameters

Name

See Also

DataLineageViews Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataLineageView from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataLineageViews Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DataLineageView specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataLineageView

Parameters

Identifier

See Also

DataLineageViews Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataLineageViews Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataLineageViews in the collection (Data Source/Target Tables).DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataLineageViews Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DataLineageView specified by either the name or the ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataLineageView

Parameters

Identifier

See Also

DataLineageViews Collection


%%PageItemTitle%%

DataMovementColumnLink Object
See Also Members

Description

This object represents a link between a column in a Source/Target (Data Lineage) Model and a column in a physical model.

See Also

DataMovementColumnLink Members


%%PageItemTitle%% $$Members$$

DataMovementColumnLink Object Members
See Also Overview

Public Properties

Public Property GUID | Returns the GUID of the DataMovementColumnLink. DATATYPE: String.
Public Property ID | Returns the ID of the DataMovementColumnLink. DATATYPE: Integer.
Public Property IsDirectSource | This property determines whether the source/target column is mapped to the physical column as a direct source. If true, it is mapped as a direct source. DATATYPE: Boolean.
Public Property IsDirectTarget | This property determines whether the source/target column is mapped to the physical column as a direct target. If true, it is mapped as a direct target. DATATYPE: Boolean.
Public Property IsSecondarySource | This property tells whether the SourceTarget column is mapped to the physical column as a secondary source. If true, it is mapped as a secondary source. DATATYPE: Boolean.
Public Property IsSecondaryTarget | This property tells whether the SourceTarget column is mapped to the physical column as a secondary target. If true, it is mapped as a secondary target. DATATYPE: Boolean.
Public Property PhysicalColumnName | This property represents the name of the column being linked (that is in the physical model). DATATYPE: String.
Public Property PhysicalModelName | This property represents the name of the physical model that the physical column being linked belongs to. DATATYPE: String.
Public Property PhysicalTableName | This property represents the name of the physical table that the physical column being linked belongs to. DATATYPE: String.
Public Property PhysicalTableOwner | This property represents the owner of the physical table that the physical column being linked belongs to. DATATYPE: String.
Public Property SrcTrgtColumnName | This property represents the name of the column being linked (that is in the source/target model). DATATYPE: String.
Public Property SrcTrgtModelName | This property represents the name of the source/target model that the source/target column being linked belongs to. DATATYPE: String.
Public Property SrcTrgtTableName | This property represents the name of the source/target table that the source/target column being linked belongs to. DATATYPE: String.
Public Property SrcTrgtTableOwner | This property represents the owner of the source/target table that the source/target column being linked belongs to. DATATYPE: String.

See Also

DataMovementColumnLink Overview


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the DataMovementColumnLink. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the DataMovementColumnLink. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

IsDirectSource Property

Description

This property determines whether the source/target column is mapped to the physical column as a direct source. If true, it is mapped as a direct source. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDirectSource() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

IsDirectTarget Property

Description

This property determines whether the source/target column is mapped to the physical column as a direct target. If true, it is mapped as a direct target. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDirectTarget() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

IsSecondarySource Property

Description

This property tells whether the SourceTarget column is mapped to the physical column as a secondary source. If true, it is mapped as a secondary source. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSecondarySource() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

IsSecondaryTarget Property

Description

This property tells whether the SourceTarget column is mapped to the physical column as a secondary target. If true, it is mapped as a secondary target. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSecondaryTarget() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

PhysicalColumnName Property

Description

This property represents the name of the column being linked (that is in the physical model). DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalColumnName() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

PhysicalModelName Property

Description

This property represents the name of the physical model that the physical column being linked belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalModelName() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

PhysicalTableName Property

Description

This property represents the name of the physical table that the physical column being linked belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalTableName() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

PhysicalTableOwner Property

Description

This property represents the owner of the physical table that the physical column being linked belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalTableOwner() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

SrcTrgtColumnName Property

Description

This property represents the name of the column being linked (that is in the source/target model). DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SrcTrgtColumnName() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

SrcTrgtModelName Property

Description

This property represents the name of the source/target model that the source/target column being linked belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SrcTrgtModelName() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

SrcTrgtTableName Property

Description

This property represents the name of the source/target table that the source/target column being linked belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SrcTrgtTableName() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

SrcTrgtTableOwner Property

Description

This property represents the owner of the source/target table that the source/target column being linked belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SrcTrgtTableOwner() As Variant

See Also

DataMovementColumnLink Object


%%PageItemTitle%%

DataMovementColumnLinks Collection
See Also Members

Description

This object represents a collection of DataMovementColumnLinks. The owner of this collection is the Column.

Object Model

See Also

DataMovementColumnLinks Members


%%PageItemTitle%% $$Members$$

DataMovementColumnLinks Collection Members
See Also Overview

Public Methods

Public Method Add | Creates new ColumnLink. Input: IDs of the DataLineage column and its parent Table that is to be linked to the physical column owning this collection. PARAMETERS: ColumnID,TableID (Integer).
Public Method AddV2 | Creates new ColumnLink. Input: IDs of the DataLineage column and its parent Table that is to be linked to the physical column owning this collection, and target/seconday flags. PARAMETERS: ColumnID,TableID (Integer), IsTarget,IsSecondary(Boolean) .
Public Method Remove | Deletes a DataMovementColumnLink (specified by the ID of the DataMovementColumnLink) from the collection. PARAMETERS: ID as Integer.

Public Properties

Public Property _Item | Returns DataMovementColumnLink specified by the parent SourceTarget column's ID that is being linked to the physical column owning the collection. PARAMETERS: SourceTargetColumnID (Integer).
Public Property _NewEnum |
Public Property Count | This is the number of DataMovementColumnLinks in the collection, that link the parent physical Column to any source/target Columns. DATATYPE: Integer.
Public Property Item | Returns DataMovementColumnLink specified by the parent SourceTarget column's ID that is being linked to the physical column owning the collection. PARAMETERS: SourceTargetColumnID (Integer).

See Also

DataMovementColumnLinks Overview


%%PageItemTitle%%

Add Method
SourceTargetColumnID
SourceTargetTableID

Description

Creates new ColumnLink. Input: IDs of the DataLineage column and its parent Table that is to be linked to the physical column owning this collection. PARAMETERS: ColumnID,TableID (Integer).

Syntax

Visual Basic
Public Function Add( _
   ByVal SourceTargetColumnID As Variant, _
   ByVal SourceTargetTableID As Variant _
) As DataMovementColumnLink

Parameters

SourceTargetColumnID
SourceTargetTableID

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

AddV2 Method
SourceTargetColumnID
SourceTargetTableID
IsTarget
IsSecondary

Description

Creates new ColumnLink. Input: IDs of the DataLineage column and its parent Table that is to be linked to the physical column owning this collection, and target/seconday flags. PARAMETERS: ColumnID,TableID (Integer), IsTarget,IsSecondary(Boolean) .

Syntax

Visual Basic
Public Function AddV2( _
   ByVal SourceTargetColumnID As Variant, _
   ByVal SourceTargetTableID As Variant, _
   ByVal IsTarget As Variant, _
   ByVal IsSecondary As Variant _
) As DataMovementColumnLink

Parameters

SourceTargetColumnID
SourceTargetTableID
IsTarget
IsSecondary

Remarks

Creates new ColumnLink. Input: IDs of the DataLineage column and its parent Table that are to be linked to the physical column owning this collection, and target/seconday flags

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

Remove Method
DataMovementColumnLinkID

Description

Deletes a DataMovementColumnLink (specified by the ID of the DataMovementColumnLink) from the collection. PARAMETERS: ID as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal DataMovementColumnLinkID As Variant _
)

Parameters

DataMovementColumnLinkID

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

_Item Property
SourceTargetColumnID

Description

Returns DataMovementColumnLink specified by the parent SourceTarget column's ID that is being linked to the physical column owning the collection. PARAMETERS: SourceTargetColumnID (Integer).

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal SourceTargetColumnID As Variant _
) As DataMovementColumnLink

Parameters

SourceTargetColumnID

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataMovementColumnLinks in the collection, that link the parent physical Column to any source/target Columns. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

Item Property
SourceTargetColumnID

Description

Returns DataMovementColumnLink specified by the parent SourceTarget column's ID that is being linked to the physical column owning the collection. PARAMETERS: SourceTargetColumnID (Integer).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal SourceTargetColumnID As Variant _
) As DataMovementColumnLink

Parameters

SourceTargetColumnID

See Also

DataMovementColumnLinks Collection


%%PageItemTitle%%

DataMovementModelLink Object
See Also Members

Description

This object represents a link between a Source/Target (DataLineage) Model and a Physical Model.

See Also

DataMovementModelLink Members


%%PageItemTitle%% $$Members$$

DataMovementModelLink Object Members
See Also Overview

Public Properties

Public Property GUID | Returns the GUID of the DataMovementModelLink. DATATYPE: String.
Public Property ID | Returns the ID of the DataMovementModelLink. DATATYPE: Integer.
Public Property IsDirectSource | This property determines whether the source/target model is linked to the physical model as a direct source. If true, it is linked as a direct source. DATATYPE: Boolean.
Public Property IsDirectTarget | This property determines whether the source/target model is linked to the physical model as a direct target. If true, it is linked as a direct target. DATATYPE: Boolean.
Public Property IsSecondary | This property tells whether the SourceTarget model is linked to the physical model directly or secondary. If true, it is linked as a secondary source/target; otherwise, it is linked as a direct source/target. DATATYPE: Boolean.
Public Property IsSecondarySource | This property tells whether the SourceTarget model is linked to the physical model as a secondary source. If true, it is linked as a secondary source. DATATYPE: Boolean.
Public Property IsSecondaryTarget | This property tells whether the SourceTarget model is linked to the physical model as a secondary target. If true, it is linked as a secondary target. DATATYPE: Boolean.
Public Property IsTarget | This property determines whether the source/target model is linked to the physical model as a source or a target. If true, it is linked as a target; otherwise, it is linked as a source. DATATYPE: Boolean.
Public Property PhysicalModelName | This property represents the name of the physical model linked by this DataMovementModelLink. DATATYPE: String.
Public Property SrcTrgtModelDescr | This property represents the description of the source/target model linked to the physical model by this DataMovementModelLink. DATATYPE: String.
Public Property SrcTrgtModelName | This property represents the name of the source/target model linked to the physical model by this DataMovementModelLink. DATATYPE: String.

See Also

DataMovementModelLink Overview


%%PageItemTitle%%

GUID Property

Description

Returns the GUID of the DataMovementModelLink. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

ID Property

Description

Returns the ID of the DataMovementModelLink. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

IsDirectSource Property

Description

This property determines whether the source/target model is linked to the physical model as a direct source. If true, it is linked as a direct source. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDirectSource() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

IsDirectTarget Property

Description

This property determines whether the source/target model is linked to the physical model as a direct target. If true, it is linked as a direct target. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDirectTarget() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

IsSecondary Property

Description

This property tells whether the SourceTarget model is linked to the physical model directly or secondary. If true, it is linked as a secondary source/target; otherwise, it is linked as a direct source/target. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSecondary() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

IsSecondarySource Property

Description

This property tells whether the SourceTarget model is linked to the physical model as a secondary source. If true, it is linked as a secondary source. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSecondarySource() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

IsSecondaryTarget Property

Description

This property tells whether the SourceTarget model is linked to the physical model as a secondary target. If true, it is linked as a secondary target. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSecondaryTarget() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

IsTarget Property

Description

This property determines whether the source/target model is linked to the physical model as a source or a target. If true, it is linked as a target; otherwise, it is linked as a source. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsTarget() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

PhysicalModelName Property

Description

This property represents the name of the physical model linked by this DataMovementModelLink. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalModelName() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

SrcTrgtModelDescr Property

Description

This property represents the description of the source/target model linked to the physical model by this DataMovementModelLink. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SrcTrgtModelDescr() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

SrcTrgtModelName Property

Description

This property represents the name of the source/target model linked to the physical model by this DataMovementModelLink. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SrcTrgtModelName() As Variant

See Also

DataMovementModelLink Object


%%PageItemTitle%%

DataMovementModelLinks Collection
See Also Members

Description

This object represents a collection of DataMovementModelLinks. The owner of this collection is the model.

Object Model

See Also

DataMovementModelLinks Members


%%PageItemTitle%% $$Members$$

DataMovementModelLinks Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DataMovementModelLink, and adds it to the collection. PARAMETERS: SourceTargetModelName (String), IsTarget(Boolean), IsSecondary (Boolean).
Public Method Remove | Deletes a DataMovementModelLink (specified by either the parent source/target model name or the ID of the DataMovementModelLink itself) from the collection. PARAMETERS: SourceTargetModelName (String), IsTarget(Boolean), IsSecondary (Boolean).

Public Properties

Public Property _Item | Returns a DataMovementModelLink (specified by either the name of the parent source/target model or the ID of the link itself). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataMovementModelLinks in the collection, that link the parent physical model to any source/target models. DATATYPE: Integer.
Public Property Item | Returns a DataMovementModelLink (specified by either the name of the parent source/target model or the ID of the link itself). PARAMETERS: Identifier as String or Integer.

See Also

DataMovementModelLinks Overview


%%PageItemTitle%%

Add Method
SourceTargetModelName
IsTarget
IsSecondary

Description

Creates and returns a new DataMovementModelLink, and adds it to the collection. PARAMETERS: SourceTargetModelName (String), IsTarget(Boolean), IsSecondary (Boolean).

Syntax

Visual Basic
Public Function Add( _
   ByVal SourceTargetModelName As Variant, _
   ByVal IsTarget As Variant, _
   ByVal IsSecondary As Variant _
) As DataMovementModelLink

Parameters

SourceTargetModelName
IsTarget
IsSecondary

See Also

DataMovementModelLinks Collection


%%PageItemTitle%%

Remove Method
SourceTargetModelName
IsTarget
IsSecondary

Description

Deletes a DataMovementModelLink (specified by either the parent source/target model name or the ID of the DataMovementModelLink itself) from the collection. PARAMETERS: SourceTargetModelName (String), IsTarget(Boolean), IsSecondary (Boolean).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal SourceTargetModelName As Variant, _
   Optional ByVal IsTarget As Variant, _
   Optional ByVal IsSecondary As Variant _
)

Parameters

SourceTargetModelName
IsTarget
IsSecondary

See Also

DataMovementModelLinks Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DataMovementModelLink (specified by either the name of the parent source/target model or the ID of the link itself). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataMovementModelLink

Parameters

Identifier

See Also

DataMovementModelLinks Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataMovementModelLinks Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataMovementModelLinks in the collection, that link the parent physical model to any source/target models. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataMovementModelLinks Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DataMovementModelLink (specified by either the name of the parent source/target model or the ID of the link itself). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataMovementModelLink

Parameters

Identifier

See Also

DataMovementModelLinks Collection


%%PageItemTitle%%

DataMovementRuleLink Object
See Also Members

Description

This object represents a link between a DataMovementRule and a Table/Entity or a Transformation.

Object Model

See Also

DataMovementRuleLink Members


%%PageItemTitle%% $$Members$$

DataMovementRuleLink Object Members
See Also Overview

Public Methods

Public Method DataLineageRule | Returns the bound DataLineageRule object of this DataMovementRuleLink. RETURN DATATYPE: DataLineageRule.
Public Method UserComments | Returns a collection of user comments associated with this DataMovementRuleLink.

Public Properties

Public Property RuleName | Returns the name of the bound rule. DATATYPE: String.
Public Property RuleText | Returns the text of the bound rule. DATATYPE: String.
Public Property RuleType | Returns the type of the bound rule. DATATYPE: String.
Public Property SequenceNumber | Returns the sequence number of this rule binding. DATATYPE: Integer.
Public Property ValueCurrent | If overriden returns object's override for the rule's value. Otherwise returns the rule's value. DATATYPE: String.
Public Property ValueOverride | This property represents the object's override for the rule's value. DATATYPE: String.

See Also

DataMovementRuleLink Overview


%%PageItemTitle%%

DataLineageRule Method

Description

Returns the bound DataLineageRule object of this DataMovementRuleLink. RETURN DATATYPE: DataLineageRule.

Syntax

Visual Basic
Public Function DataLineageRule() As DataLineageRule

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataMovementRuleLink.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

RuleName Property

Description

Returns the name of the bound rule. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property RuleName() As Variant

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

RuleText Property

Description

Returns the text of the bound rule. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property RuleText() As Variant

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

RuleType Property

Description

Returns the type of the bound rule. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property RuleType() As Variant

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

SequenceNumber Property

Description

Returns the sequence number of this rule binding. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

ValueCurrent Property

Description

If overriden returns object's override for the rule's value. Otherwise returns the rule's value. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueCurrent() As Variant

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

ValueOverride Property

Description

This property represents the object's override for the rule's value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueOverride() As Variant

See Also

DataMovementRuleLink Object


%%PageItemTitle%%

DataMovementRuleLinks Collection
See Also Members

Description

This object represents a collection of DataMovementRuleLinks. The owner of this collection is the EntityObj.

Object Model

See Also

DataMovementRuleLinks Members


%%PageItemTitle%% $$Members$$

DataMovementRuleLinks Collection Members
See Also Overview

Public Methods

Public Method Add | Creates in collection and returns new DataMovementRuleLink (linking parent table and DataMovementRule specified by the passed in identifier). PARAMETERS: Identifier(String/Integer).
Public Method Remove | Deletes a DataMovementRuleLink (specified by either the parent Data Movement Rule's name or ID from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DataMovementRuleLink (specified by either the name or the ID of the parent data movement rule). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DataMovementRuleLinks in the collection, that link the parent physical Table to any Data Movement Rules. DATATYPE: Integer.
Public Property Item | Returns a DataMovementRuleLink (specified by either the name or the ID of the parent data movement rule). PARAMETERS: Identifier as String or Integer.

See Also

DataMovementRuleLinks Overview


%%PageItemTitle%%

Add Method
Identifier

Description

Creates in collection and returns new DataMovementRuleLink (linking parent table and DataMovementRule specified by the passed in identifier). PARAMETERS: Identifier(String/Integer).

Syntax

Visual Basic
Public Function Add( _
   ByVal Identifier As Variant _
) As DataMovementRuleLink

Parameters

Identifier

See Also

DataMovementRuleLinks Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DataMovementRuleLink (specified by either the parent Data Movement Rule's name or ID from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataMovementRuleLinks Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DataMovementRuleLink (specified by either the name or the ID of the parent data movement rule). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataMovementRuleLink

Parameters

Identifier

See Also

DataMovementRuleLinks Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataMovementRuleLinks Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DataMovementRuleLinks in the collection, that link the parent physical Table to any Data Movement Rules. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataMovementRuleLinks Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DataMovementRuleLink (specified by either the name or the ID of the parent data movement rule). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataMovementRuleLink

Parameters

Identifier

See Also

DataMovementRuleLinks Collection


%%PageItemTitle%%

DataStream Object
See Also Members

Description

This object represents a Data Lineage Stream in ER/Studio.

Object Model

See Also

DataStream Members


%%PageItemTitle%% $$Members$$

DataStream Object Members
See Also Overview

Public Methods

Public Method UserComments Returns a collection of user comments associated with this stream.

Public Properties

Public Property GUID | This is the GUID of the Data Stream. DATATYPE: String.
Public Property ID | Returns the Data Stream ID. DATATYPE: Integer.
Public Property IsInputStream | Returns the Input/Output type of the data stream. DATATYPE: Boolean.
Public Property LineageComponentID | Returns the Lineage Component ID linked to the stream. DATATYPE: Integer.
Public Property LineageComponentName | Returns the Lineage Component Name linked to the stream. DATATYPE: String.
Public Property TransformationID | Returns the Transformation ID linked to the stream. DATATYPE: Integer.
Public Property TransformationName | Returns the Transformation Name linked to the stream. DATATYPE: String.

See Also

DataStream Overview


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this stream.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DataStream Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Data Stream. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DataStream Object


%%PageItemTitle%%

ID Property

Description

Returns the Data Stream ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DataStream Object


%%PageItemTitle%%

IsInputStream Property

Description

Returns the Input/Output type of the data stream. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsInputStream() As Variant

See Also

DataStream Object


%%PageItemTitle%%

LineageComponentID Property

Description

Returns the Lineage Component ID linked to the stream. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property LineageComponentID() As Variant

See Also

DataStream Object


%%PageItemTitle%%

LineageComponentName Property

Description

Returns the Lineage Component Name linked to the stream. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineageComponentName() As Variant

See Also

DataStream Object


%%PageItemTitle%%

TransformationID Property

Description

Returns the Transformation ID linked to the stream. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property TransformationID() As Variant

See Also

DataStream Object


%%PageItemTitle%%

TransformationName Property

Description

Returns the Transformation Name linked to the stream. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TransformationName() As Variant

See Also

DataStream Object


%%PageItemTitle%%

DataStreams Collection
See Also Members

Description

This object represents a collection of DataStreams. The owner of this collection is the data flow.

Object Model

See Also

DataStreams Members


%%PageItemTitle%% $$Members$$

DataStreams Collection Members
See Also Overview

Public Methods

Public Method Add | Creates Data Stream with specified properties and returns new Data Stream. PARAMETERS: Transformation as String(name or GUID) or Integer(ID), LineageComponent(entity or view) as String(GUID) or Integer(ID), IsInputStream as Boolean.
Public Method Remove | Deletes a Data Stream object (specified by the given GUID or ID) from ER/Studio. PARAMETERS: Identifier as string(GUID) or Integer(ID).

Public Properties

Public Property _Item | Returns a Data Stream object (specified by the given GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Data Stream objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Data Stream object (specified by the given GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DataStreams Overview


%%PageItemTitle%%

Add Method
Transformation
LineageComponent
IsInputStream

Description

Creates Data Stream with specified properties and returns new Data Stream. PARAMETERS: Transformation as String(name or GUID) or Integer(ID), LineageComponent(entity or view) as String(GUID) or Integer(ID), IsInputStream as Boolean.

Syntax

Visual Basic
Public Function Add( _
   ByVal Transformation As Variant, _
   ByVal LineageComponent As Variant, _
   ByVal IsInputStream As Variant _
) As DataStream

Parameters

Transformation
LineageComponent
IsInputStream

See Also

DataStreams Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Data Stream object (specified by the given GUID or ID) from ER/Studio. PARAMETERS: Identifier as string(GUID) or Integer(ID).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DataStreams Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Data Stream object (specified by the given GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DataStream

Parameters

Identifier

See Also

DataStreams Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DataStreams Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Data Stream objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DataStreams Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Data Stream object (specified by the given GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DataStream

Parameters

Identifier

See Also

DataStreams Collection


%%PageItemTitle%%

DB2390AuxTable Object
See Also Members

Description

This object represents a DB2 OS/390 Auxiliary Table in ER/Studio. It is stored as its create statement.

Object Model

See Also

DB2390AuxTable Members


%%PageItemTitle%% $$Members$$

DB2390AuxTable Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this DB2AuxiliaryTable.
Public Method UserComments | Returns a collection of user comments associated with this DB2AuxiliaryTable.

Public Properties

Public Property BaseTableName | This property represents the name of the Base Table the Auxiliary Table was created for. DATATYPE: String.
Public Property BaseTableOwner | This property represents the owner of the Base Table the Auxiliary Table was created for. DATATYPE: String.
Public Property DatabaseName | This property represents the name of the Database that the Auxiliary Table is stored in. DATATYPE: String.
Public Property Description | This is the Description of the Auxiliary Table. DATATYPE: String.
Public Property GUID | This is the GUID of the Auxiliary Table. DATATYPE: String.
Public Property ID | Returns the Auxiliary Table's ID. DATATYPE: Integer.
Public Property IndexBufferPool | This property represents the BufferPool name of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexClose | This property represents the CLOSE option of the Auxiliary Table's Index. DATATYPE: String.
Public Property IndexCopy | This property represents the COPY option of the Auxiliary Table's Index. DATATYPE: String.
Public Property IndexErase | This property represents the ERASE option of the Auxiliary Table's Index. DATATYPE: String.
Public Property IndexFreePage | This property represents the FreePage setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexGBPCache | This property determines the auxiliary table's indexes setting for GBPCache (CHANGED, ALL, NONE). DATATYPE: String.
Public Property IndexName | This property represents the name of the Unique Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexOwner | This property represents the owner of the UniqueIndex created on the Auxiliary Table. DATATYPE: String.
Public Property IndexPercentFree | This property represents the PercentFree setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexPieceSize | This property represents the PieceSize setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexPriQty | This property represents the PriQty setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexSecQty | This property represents the SecQty setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexStogroup | This property represents the Stogroup name of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexUsing | This property determines whether the indexes data sets are user managed (VCAT), DB2 managed (STOGROUP) or whether neither was specified (NONE). DATATYPE: String.
Public Property IndexVCATName | This property represents the VCAT name of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property LOBColumnName | This property represents the name of the LOBColumn whose Data the Auxiliary Table stores. DATATYPE: String.
Public Property Name | This property represents the name of the Auxiliary Table. DATATYPE: String.
Public Property Owner | This property represents the owner of the Auxiliary Table. DATATYPE: String.
Public Property TablespaceName | This property represents the name of the Tablespace that the Auxiliary Table is stored in. DATATYPE: String.

See Also

DB2390AuxTable Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this DB2AuxiliaryTable.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2390AuxTable Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DB2AuxiliaryTable.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2390AuxTable Object


%%PageItemTitle%%

BaseTableName Property

Description

This property represents the name of the Base Table the Auxiliary Table was created for. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseTableName() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

BaseTableOwner Property

Description

This property represents the owner of the Base Table the Auxiliary Table was created for. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseTableOwner() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

DatabaseName Property

Description

This property represents the name of the Database that the Auxiliary Table is stored in. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseName() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Auxiliary Table. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

ID Property

Description

Returns the Auxiliary Table's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexBufferPool Property

Description

This property represents the BufferPool name of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexBufferPool() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexClose Property

Description

This property represents the CLOSE option of the Auxiliary Table's Index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexClose() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexCopy Property

Description

This property represents the COPY option of the Auxiliary Table's Index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexCopy() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexErase Property

Description

This property represents the ERASE option of the Auxiliary Table's Index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexErase() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexFreePage Property

Description

This property represents the FreePage setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexFreePage() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexGBPCache Property

Description

This property determines the auxiliary table's indexes setting for GBPCache (CHANGED, ALL, NONE). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexGBPCache() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexName Property

Description

This property represents the name of the Unique Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexName() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexOwner Property

Description

This property represents the owner of the UniqueIndex created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexOwner() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexPercentFree Property

Description

This property represents the PercentFree setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPercentFree() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexPieceSize Property

Description

This property represents the PieceSize setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPieceSize() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexPriQty Property

Description

This property represents the PriQty setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPriQty() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexSecQty Property

Description

This property represents the SecQty setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexSecQty() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexStogroup Property

Description

This property represents the Stogroup name of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexStogroup() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexUsing Property

Description

This property determines whether the indexes data sets are user managed (VCAT), DB2 managed (STOGROUP) or whether neither was specified (NONE). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexUsing() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

IndexVCATName Property

Description

This property represents the VCAT name of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexVCATName() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

LOBColumnName Property

Description

This property represents the name of the LOBColumn whose Data the Auxiliary Table stores. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LOBColumnName() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

TablespaceName Property

Description

This property represents the name of the Tablespace that the Auxiliary Table is stored in. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TablespaceName() As Variant

See Also

DB2390AuxTable Object


%%PageItemTitle%%

DB2390AuxTables Collection
See Also Members

Description

This object represents a collection of auxiliary tables. The owner of this collection is the model (of type DB2 OS/390).

Object Model

See Also

DB2390AuxTables Members


%%PageItemTitle%% $$Members$$

DB2390AuxTables Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Auxiliary Table, and adds it to the collection. PARAMETERS: (All are strings) Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName.
Public Method AddWithPosition | Creates a new Auxiliary Table. PARAMETERS: (Strings: Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName), (Integer: HorizontalPosition, VerticalPosition).
Public Method Remove | Deletes an auxiliary table object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of auxiliary tables in the collection. DATATYPE: Integer.
Public Property Item | Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2390AuxTables Overview


%%PageItemTitle%%

Add Method
Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName

Description

Creates and returns a new Auxiliary Table, and adds it to the collection. PARAMETERS: (All are strings) Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal Tablespace As Variant, _
   ByVal BaseTableName As Variant, _
   ByVal LOBColumnName As Variant, _
   ByVal IndexName As Variant _
) As DB2390AuxTable

Parameters

Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName
HorizontalPosition
VerticalPosition

Description

Creates a new Auxiliary Table. PARAMETERS: (Strings: Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName), (Integer: HorizontalPosition, VerticalPosition).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal Tablespace As Variant, _
   ByVal BaseTableName As Variant, _
   ByVal LOBColumnName As Variant, _
   ByVal IndexName As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2390AuxTable

Parameters

Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName
HorizontalPosition
VerticalPosition

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an auxiliary table object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2390AuxTable

Parameters

Identifier

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

Count Property

Description

This is the number of auxiliary tables in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2390AuxTable

Parameters

Identifier

See Also

DB2390AuxTables Collection


%%PageItemTitle%%

DB2Database Object
See Also Members

Description

This object represents a DB2Database in ER/Studio.

Object Model

See Also

DB2Database Members


%%PageItemTitle%% $$Members$$

DB2Database Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this DB2Database.
Public Method UserComments | Returns a collection of user comments associated with this DB2Database.

Public Properties

Public Property BufferPool | This is the BufferPool of the DB2Database. DATATYPE: String.
Public Property Description | This is the Description of the DB2Database. DATATYPE: String.
Public Property Encoding | This is the Encoding of the DB2Database. ASCII, EBCDIC and UNICODE are the only valid input strings. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2Database. DATATYPE: String.
Public Property ID | This is the ID of the DB2Database. DATATYPE: Integer.
Public Property IndexBP | This is the IndexBP of the DB2Database. DATATYPE: String.
Public Property IsWorkFile | Indicate if the DB2Database is a work file. DATATYPE: Boolean.
Public Property Name | This is the name of the DB2Database. DATATYPE: String.
Public Property StoGroup | This is the StoGroup of the DB2Database. DATATYPE: String.
Public Property WorkMember | This is the WorkMember of the DB2Database. DATATYPE: String.

See Also

DB2Database Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this DB2Database.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2Database Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DB2Database.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2Database Object


%%PageItemTitle%%

BufferPool Property

Description

This is the BufferPool of the DB2Database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferPool() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2Database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

Encoding Property

Description

This is the Encoding of the DB2Database. ASCII, EBCDIC and UNICODE are the only valid input strings. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Encoding() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2Database. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the DB2Database. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

IndexBP Property

Description

This is the IndexBP of the DB2Database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexBP() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

IsWorkFile Property

Description

Indicate if the DB2Database is a work file. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsWorkFile() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DB2Database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

StoGroup Property

Description

This is the StoGroup of the DB2Database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StoGroup() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

WorkMember Property

Description

This is the WorkMember of the DB2Database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property WorkMember() As Variant

See Also

DB2Database Object


%%PageItemTitle%%

DB2Databases Collection
See Also Members

Description

This object represents a collection of DB2Database objects.

Object Model

See Also

DB2Databases Members


%%PageItemTitle%% $$Members$$

DB2Databases Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new DB2Database object. PARAMETERS: Name as String.
Public Method AddWithPosition | Add a new DB2Database object with the given coordinates. PARAMETERS: Name as String, HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Remove a DB2Database specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2Database object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2Database objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2Database object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

DB2Databases Overview


%%PageItemTitle%%

Add Method
Name

Description

Add a new DB2Database object. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DB2Database

Parameters

Name

See Also

DB2Databases Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Add a new DB2Database object with the given coordinates. PARAMETERS: Name as String, HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2Database

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

DB2Databases Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Remove a DB2Database specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2Databases Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2Database object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2Database

Parameters

Identifier

See Also

DB2Databases Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2Databases Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2Database objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2Databases Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2Database object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2Database

Parameters

Identifier

See Also

DB2Databases Collection


%%PageItemTitle%%

DB2IdxPartition Object
See Also Members

Description

This object represents a DB2IdxPartition in ER/Studio.

See Also

DB2IdxPartition Members


%%PageItemTitle%% $$Members$$

DB2IdxPartition Object Members
See Also Overview

Public Properties

Public Property FreePage | This is the FreePage of the DB2IdxPartition. DATATYPE: Integer.
Public Property GBPCache | This is the GbpCache of the DB2IdxPartition. Valid strings are CHANGED, ALL, and NONE. DATATYPE: String.
Public Property GUID | DATATYPE: String. This is the GUID of the DB2IdxPartition.
Public Property HighValues | This is the HighValues of the DB2IdxPartition. DATATYPE: String.
Public Property ID | This is the ID of the DB2IdxPartition. DATATYPE: Integer.
Public Property IsStoGroup | This indicate if the DB2IdxPartition is a StoGroup. DATATYPE: Boolean.
Public Property Number | This is the Number of the DB2IdxPartition. DATATYPE: Integer.
Public Property PctFree | This is the PctFree of the DB2IdxPartition. DATATYPE: Integer.
Public Property PriQty | This is the PriQty of the DB2IdxPartition. DATATYPE: Integer.
Public Property SecQty | This is the SecQty of the DB2IdxPartition. DATATYPE: Integer.
Public Property StorageLocation | This is the StorageLocation of the DB2IdxPartition. DATATYPE: String.

See Also

DB2IdxPartition Overview


%%PageItemTitle%%

FreePage Property

Description

This is the FreePage of the DB2IdxPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreePage() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

GBPCache Property

Description

This is the GbpCache of the DB2IdxPartition. Valid strings are CHANGED, ALL, and NONE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GBPCache() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

GUID Property

Description

DATATYPE: String. This is the GUID of the DB2IdxPartition.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

HighValues Property

Description

This is the HighValues of the DB2IdxPartition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighValues() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the DB2IdxPartition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

IsStoGroup Property

Description

This indicate if the DB2IdxPartition is a StoGroup. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsStoGroup() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the DB2IdxPartition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

PctFree Property

Description

This is the PctFree of the DB2IdxPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctFree() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

PriQty Property

Description

This is the PriQty of the DB2IdxPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PriQty() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

SecQty Property

Description

This is the SecQty of the DB2IdxPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SecQty() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

StorageLocation Property

Description

This is the StorageLocation of the DB2IdxPartition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StorageLocation() As Variant

See Also

DB2IdxPartition Object


%%PageItemTitle%%

DB2IdxPartitions Collection
See Also Members

Description

This object represents a collection of DB2IdxPartition objects.

Object Model

See Also

DB2IdxPartitions Members


%%PageItemTitle%% $$Members$$

DB2IdxPartitions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new DB2IdxPartition object. PARAMETERS: Number as Integer, HighValues as String.
Public Method Remove | Remove a DB2IdxPartition specified by the given Number. PARAMETERS: Number as Integer.

Public Properties

Public Property _Item | Returns a DB2IdxPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of DB2IdxPartition objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2IdxPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

See Also

DB2IdxPartitions Overview


%%PageItemTitle%%

Add Method
Number
HighValues

Description

Add a new DB2IdxPartition object. PARAMETERS: Number as Integer, HighValues as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Number As Variant, _
   ByVal HighValues As Variant _
) As DB2IdxPartition

Parameters

Number
HighValues

See Also

DB2IdxPartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Remove a DB2IdxPartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

DB2IdxPartitions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2IdxPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2IdxPartition

Parameters

Identifier

See Also

DB2IdxPartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2IdxPartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2IdxPartition objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2IdxPartitions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2IdxPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2IdxPartition

Parameters

Identifier

See Also

DB2IdxPartitions Collection


%%PageItemTitle%%

DB2OS390Alias Object
See Also Members

Description

This object represents a DB2 OS/390 Alias in ER/Studio.

Object Model

See Also

DB2OS390Alias Members


%%PageItemTitle%% $$Members$$

DB2OS390Alias Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Object.
Public Method UserComments | Returns a collection of user comments associated with this DB2 OS/390 Alias.

Public Properties

Public Property Description | This is the Description of the DB2 OS/390 Alias. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2 OS/390 Alias. DATATYPE: String.
Public Property ID | Returns the DB2 OS/390 Alias ID.DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 OS/390 Alias. DATATYPE: String.
Public Property Owner | This property represents the owner of the DB2 OS/390 Alias. DATATYPE: String.
Public Property ReferencedObjectName | This property represents the name of the object refered to by the DB2 OS/390 Alias. DATATYPE: String.
Public Property ReferencedObjectOwner | This property represents the owner of the object refered to by the DB2 OS/390 Alias. DATATYPE: String.

See Also

DB2OS390Alias Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2OS390Alias Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DB2 OS/390 Alias.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2OS390Alias Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2 OS/390 Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2 OS/390 Alias. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 OS/390 Alias ID.DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 OS/390 Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DB2 OS/390 Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

ReferencedObjectName Property

Description

This property represents the name of the object refered to by the DB2 OS/390 Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectName() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

ReferencedObjectOwner Property

Description

This property represents the owner of the object refered to by the DB2 OS/390 Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectOwner() As Variant

See Also

DB2OS390Alias Object


%%PageItemTitle%%

DB2OS390Aliases Collection
See Also Members

Description

This object represents a collection of DB2 OS/390 Aliases. The owner of this collection is the model.

Object Model

See Also

DB2OS390Aliases Members


%%PageItemTitle%% $$Members$$

DB2OS390Aliases Collection Members
See Also Overview

Public Methods

Public Method Add | Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String), Creates and returns a new DB2 OS/390 Alias, and adds it to the collection. PARAMETERS: Name (String).
Public Method AddWithPosition | Creates a DB2 OS/390 Alias. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an DB2 OS/390 Alias object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2 OS/390 Alias object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Aliases in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2 OS/390 Alias object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2OS390Aliases Overview


%%PageItemTitle%%

Add Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner

Description

Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String), Creates and returns a new DB2 OS/390 Alias, and adds it to the collection. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant _
) As DB2OS390Alias

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

Description

Creates a DB2 OS/390 Alias. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2OS390Alias

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DB2 OS/390 Alias object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2 OS/390 Alias object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2OS390Alias

Parameters

Identifier

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Aliases in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2 OS/390 Alias object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2OS390Alias

Parameters

Identifier

See Also

DB2OS390Aliases Collection


%%PageItemTitle%%

DB2OS390AuxTable Object
See Also Members

Description

This object represents a DB2 OS/390 Auxiliary Table in ER/Studio. It is stored as its create statement.

Object Model

See Also

DB2OS390AuxTable Members


%%PageItemTitle%% $$Members$$

DB2OS390AuxTable Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this DB2AuxiliaryTable.
Public Method UserComments | Returns a collection of the user comments associated with this DB2AuxiliaryTable.

Public Properties

Public Property BaseTableName | This property represents the name of the Base Table the Auxiliary Table was created for. DATATYPE: String.
Public Property BaseTableOwner | This property represents the owner of the Base Table the Auxiliary Table was created for. DATATYPE: String.
Public Property DatabaseName | This property represents the name of the Database that the Auxiliary Table is stored in. DATATYPE: String.
Public Property Description | This is the Description of the Auxiliary Table. DATATYPE: String.
Public Property GUID | This is the GUID of the Auxiliary Table. DATATYPE: String.
Public Property ID | Returns the Auxiliary Table's ID. DATATYPE: Integer.
Public Property IndexBufferPool | This property represents the BufferPool name of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexClose | This property represents the CLOSE option of the Auxiliary Table's Index. DATATYPE: String.
Public Property IndexCopy | This property represents the COPY option of the Auxiliary Table's Index. DATATYPE: String.
Public Property IndexErase | This property represents the ERASE option of the Auxiliary Table's Index. DATATYPE: String.
Public Property IndexFreePage | This property represents the FreePage setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexGBPCache | This property determines the auxiliary table's indexes setting for GBPCache (CHANGED, ALL, NONE). DATATYPE: String.
Public Property IndexName | This property represents the name of the Unique Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexOwner | This property represents the owner of the UniqueIndex created on the Auxiliary Table. DATATYPE: String.
Public Property IndexPercentFree | This property represents the PercentFree setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexPieceSize | This property represents the PieceSize setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexPriQty | This property represents the PriQty setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexSecQty | This property represents the SecQty setting of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexStogroup | This property represents the Stogroup name of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property IndexUsing | This property determines whether the indexes data sets are user managed (VCAT), DB2 managed (STOGROUP) or whether neither was specified (NONE). DATATYPE: String.
Public Property IndexVCATName | This property represents the VCAT name of the Index created on the Auxiliary Table. DATATYPE: String.
Public Property LOBColumnName | This property represents the name of the LOBColumn whose Data the Auxiliary Table stores. DATATYPE: String.
Public Property Name | This property represents the name of the Auxiliary Table. DATATYPE: String.
Public Property Owner | This property represents the owner of the Auxiliary Table.
Public Property TablespaceName | This property represents the name of the Tablespace that the Auxiliary Table is stored in. DATATYPE: String.

See Also

DB2OS390AuxTable Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this DB2AuxiliaryTable.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of the user comments associated with this DB2AuxiliaryTable.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

BaseTableName Property

Description

This property represents the name of the Base Table the Auxiliary Table was created for. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseTableName() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

BaseTableOwner Property

Description

This property represents the owner of the Base Table the Auxiliary Table was created for. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BaseTableOwner() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

DatabaseName Property

Description

This property represents the name of the Database that the Auxiliary Table is stored in. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseName() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Auxiliary Table. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

ID Property

Description

Returns the Auxiliary Table's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexBufferPool Property

Description

This property represents the BufferPool name of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexBufferPool() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexClose Property

Description

This property represents the CLOSE option of the Auxiliary Table's Index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexClose() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexCopy Property

Description

This property represents the COPY option of the Auxiliary Table's Index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexCopy() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexErase Property

Description

This property represents the ERASE option of the Auxiliary Table's Index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexErase() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexFreePage Property

Description

This property represents the FreePage setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexFreePage() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexGBPCache Property

Description

This property determines the auxiliary table's indexes setting for GBPCache (CHANGED, ALL, NONE). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexGBPCache() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexName Property

Description

This property represents the name of the Unique Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexName() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexOwner Property

Description

This property represents the owner of the UniqueIndex created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexOwner() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexPercentFree Property

Description

This property represents the PercentFree setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPercentFree() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexPieceSize Property

Description

This property represents the PieceSize setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPieceSize() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexPriQty Property

Description

This property represents the PriQty setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPriQty() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexSecQty Property

Description

This property represents the SecQty setting of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexSecQty() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexStogroup Property

Description

This property represents the Stogroup name of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexStogroup() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexUsing Property

Description

This property determines whether the indexes data sets are user managed (VCAT), DB2 managed (STOGROUP) or whether neither was specified (NONE). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexUsing() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

IndexVCATName Property

Description

This property represents the VCAT name of the Index created on the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexVCATName() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

LOBColumnName Property

Description

This property represents the name of the LOBColumn whose Data the Auxiliary Table stores. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LOBColumnName() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Auxiliary Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the Auxiliary Table.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

TablespaceName Property

Description

This property represents the name of the Tablespace that the Auxiliary Table is stored in. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TablespaceName() As Variant

See Also

DB2OS390AuxTable Object


%%PageItemTitle%%

DB2OS390AuxTables Collection
See Also Members

Description

This object represents a collection of auxiliary tables. The owner of this collection is the model (of type DB2 OS/390).

Object Model

See Also

DB2OS390AuxTables Members


%%PageItemTitle%% $$Members$$

DB2OS390AuxTables Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Auxiliary Table, and adds it to the collection. PARAMETERS: (All are strings) Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName.
Public Method AddWithPosition | Creates a new Auxiliary Table. PARAMETERS: (Strings: Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName), (Integer: HorizontalPosition, VerticalPosition).
Public Method Remove | Deletes an auxiliary table object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of auxiliary tables in the collection. DATATYPE: Integer.
Public Property Item | Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2OS390AuxTables Overview


%%PageItemTitle%%

Add Method
Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName

Description

Creates and returns a new Auxiliary Table, and adds it to the collection. PARAMETERS: (All are strings) Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal Tablespace As Variant, _
   ByVal BaseTableName As Variant, _
   ByVal LOBColumnName As Variant, _
   ByVal IndexName As Variant _
) As DB2OS390AuxTable

Parameters

Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName
HorizontalPosition
VerticalPosition

Description

Creates a new Auxiliary Table. PARAMETERS: (Strings: Name, Owner, Tablespace, BaseTableName, LOBColumnName, IndexName), (Integer: HorizontalPosition, VerticalPosition).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal Tablespace As Variant, _
   ByVal BaseTableName As Variant, _
   ByVal LOBColumnName As Variant, _
   ByVal IndexName As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2OS390AuxTable

Parameters

Name
Owner
Tablespace
BaseTableName
LOBColumnName
IndexName
HorizontalPosition
VerticalPosition

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an auxiliary table object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2OS390AuxTable

Parameters

Identifier

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

Count Property

Description

This is the number of auxiliary tables in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns an Auxiliary Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2OS390AuxTable

Parameters

Identifier

See Also

DB2OS390AuxTables Collection


%%PageItemTitle%%

DB2OS390Synonym Object
See Also Members

Description

This object represents a DB2 OS/390 Synonym in ER/Studio.

Object Model

See Also

DB2OS390Synonym Members


%%PageItemTitle%% $$Members$$

DB2OS390Synonym Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the User Comments collection of this Object.

Public Properties

Public Property Description | This is the Description of the DB2 OS/390 Synonym. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2 OS/390 Synonym. DATATYPE: String.
Public Property ID | Returns the DB2 OS/390 Synonym ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 OS/390 Synonym. DATATYPE: String.
Public Property Owner | This property represents the owner of the DB2 OS/390 Synonym. DATATYPE: String.
Public Property ReferencedObjectName | This property represents the name of the object refered to by the DB2 OS/390 Synonym. DATATYPE: String.
Public Property ReferencedObjectOwner | This property represents the owner of the object refered to by the DB2 OS/390 Synonym. DATATYPE: String.

See Also

DB2OS390Synonym Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

UserComments Method

Description

Returns the User Comments collection of this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2 OS/390 Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2 OS/390 Synonym. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 OS/390 Synonym ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 OS/390 Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DB2 OS/390 Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

ReferencedObjectName Property

Description

This property represents the name of the object refered to by the DB2 OS/390 Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectName() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

ReferencedObjectOwner Property

Description

This property represents the owner of the object refered to by the DB2 OS/390 Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectOwner() As Variant

See Also

DB2OS390Synonym Object


%%PageItemTitle%%

DB2OS390Synonyms Collection
See Also Members

Description

This object represents a collection of DB2 OS/390 Synonyms. The owner of this collection is the model.

Object Model

See Also

DB2OS390Synonyms Members


%%PageItemTitle%% $$Members$$

DB2OS390Synonyms Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2 OS/390 Synonym, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).
Public Method AddWithPosition | Creates a DB2 OS/390 Synonym. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an DB2 OS/390 Synonym object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2 OS/390 Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Synonyms in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2 OS/390 Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2OS390Synonyms Overview


%%PageItemTitle%%

Add Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner

Description

Creates and returns a new DB2 OS/390 Synonym, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant _
) As DB2OS390Synonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

Description

Creates a DB2 OS/390 Synonym. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2OS390Synonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DB2 OS/390 Synonym object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2 OS/390 Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2OS390Synonym

Parameters

Identifier

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Synonyms in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2 OS/390 Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2OS390Synonym

Parameters

Identifier

See Also

DB2OS390Synonyms Collection


%%PageItemTitle%%

DB2OS390TablePartition Object
See Also Members

Description

This object represents a DB2OS390TablePartition in ER/Studio.

See Also

DB2OS390TablePartition Members


%%PageItemTitle%% $$Members$$

DB2OS390TablePartition Object Members
See Also Overview

Public Properties

Public Property GUID | This is the GUID of the Partition. DATATYPE: String.
Public Property HighValues | For type RANGE the are the HighValues of the Partition. For type LIST this is the List of Values of the Partition. DATATYPE: String.
Public Property ID | This is the ID of the Partition. DATATYPE: Integer.
Public Property Inclusive | This indicates whether the high values are inclusive. DATATYPE: Boolean.
Public Property Name | This is the Name of the Partition. DATATYPE: String.
Public Property Number | This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL.) DATATYPE: Integer.

See Also

DB2OS390TablePartition Overview


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Partition. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2OS390TablePartition Object


%%PageItemTitle%%

HighValues Property

Description

For type RANGE the are the HighValues of the Partition. For type LIST this is the List of Values of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighValues() As Variant

See Also

DB2OS390TablePartition Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the Partition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2OS390TablePartition Object


%%PageItemTitle%%

Inclusive Property

Description

This indicates whether the high values are inclusive. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Inclusive() As Variant

See Also

DB2OS390TablePartition Object


%%PageItemTitle%%

Name Property

Description

This is the Name of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2OS390TablePartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL.) DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

DB2OS390TablePartition Object


%%PageItemTitle%%

DB2OS390TablePartitions Collection
See Also Members

Description

This object represents a collection of DB2OS390TablePartition objects.

Object Model

Remarks

This is the collection of partitions of an DB2 OS/390 table. (O3/390 V8 and above). The Manager managing this collection also manages the Partition Key. Each partition can have different physical attributes,e.g., High values and Inclusive. However, each Partition of a table must have the same logical attributes, such as column names, datatypes, constraints. Those are determined by the columns in the partition key. The partition key is a set of one or more columns (ordered list) that determine the partition for each row. DB2 OS/390 only supports Range partition. RANGE partitioning partitions the data into ranges. Each partition defines a ENDING AT clause that specifies an inclusive/non-inclusive upper bound called High Value. (A MAXVALUE literal can be defined for the highest partition).

See Also

DB2OS390TablePartitions Members


%%PageItemTitle%% $$Members$$

DB2OS390TablePartitions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new TablePartition object. PARAMETERS: HighValues as String.
Public Method AddColumnToPartitionKey | Use to add another column to the partition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.
Public Method DeleteColumnFromPartitionKey | Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.
Public Method DeletePartitionKey | Use this method to delete all columns in the partition key. This also deletes all partitions and all subpartitions and the subpartition key.
Public Method GetPartitionColumnNumber | Looks for the column in the partition key. If it finds it, it returns the column's number. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: Integer.
Public Method Remove | Remove a TablePartition specified by the given Number. PARAMETERS: Number as Integer.
Public Method RemoveByName | Remove the TablePartition specified by the given Name. PARAMETERS: Name as String.
Public Method SetPartitionColumnNumber | Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer .

Public Properties

Public Property _Item | Returns a DB2OS390TablePartition object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of OracleTablePartition objects in the collection. DATATYPE: Integer.
Public Property GetPartitionKeyColumns | This is the names of the columns in hte PartitionKey as a comma separated list in sequence order. DATATYPE: String.
Public Property Item | Returns a DB2OS390TablePartition object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.

See Also

DB2OS390TablePartitions Overview


%%PageItemTitle%%

Add Method
HighValues

Description

Add a new TablePartition object. PARAMETERS: HighValues as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal HighValues As Variant _
) As DB2OS390TablePartition

Parameters

HighValues

Remarks

To change the position of the partition within the list, get the item and change the Number property. The passed in string will be saved as the HighValue.

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

AddColumnToPartitionKey Method
Name

Description

Use to add another column to the partition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub AddColumnToPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

DeleteColumnFromPartitionKey Method
Name

Description

Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub DeleteColumnFromPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

Remarks

You cannot delete last column in key. To delete all columns in the partition key, use DeletePartitionKey, but that also deletes all partitions.

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

DeletePartitionKey Method

Description

Use this method to delete all columns in the partition key. This also deletes all partitions and all subpartitions and the subpartition key.

Syntax

Visual Basic
Public Sub DeletePartitionKey()

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

GetPartitionColumnNumber Method
Name

Description

Looks for the column in the partition key. If it finds it, it returns the column's number. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetPartitionColumnNumber( _
   ByVal Name As Variant _
) As Long

Parameters

Name

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Remove a TablePartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

RemoveByName Method
Name

Description

Remove the TablePartition specified by the given Name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub RemoveByName( _
   ByVal Name As Variant _
)

Parameters

Name

Remarks

Removes the Partition specified by the given Name from the collection (if it can find it). If it does find it and remove it, then it updates the sequence numbers of all affected partitions (all partitions with numbers higher than the one removed, which will then all be one less than before).

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

SetPartitionColumnNumber Method
Name
Number
The number must be greater than zero. If the number is equal to the number of another column in the key, the method inserts the specified column before the column with the same sequence number. If the number is bigger than any other number, it adds the specified column to the end of the list

Description

Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer .

Syntax

Visual Basic
Public Sub SetPartitionColumnNumber( _
   ByVal Name As Variant, _
   ByVal Number As Variant _
)

Parameters

Name
Number
The number must be greater than zero. If the number is equal to the number of another column in the key, the method inserts the specified column before the column with the same sequence number. If the number is bigger than any other number, it adds the specified column to the end of the list

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2OS390TablePartition object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2OS390TablePartition

Parameters

Identifier

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of OracleTablePartition objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

GetPartitionKeyColumns Property

Description

This is the names of the columns in hte PartitionKey as a comma separated list in sequence order. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetPartitionKeyColumns() As Variant

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2OS390TablePartition object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2OS390TablePartition

Parameters

Identifier

See Also

DB2OS390TablePartitions Collection


%%PageItemTitle%%

DB2StoGroup Object
See Also Members

Description

This object represents a DB2StoGroup in ER/Studio.

Object Model

See Also

DB2StoGroup Members


%%PageItemTitle%% $$Members$$

DB2StoGroup Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this DB2StoGroup.
Public Method UserComments | Get all the user comments assocaited with this DB2StoGroup.

Public Properties

Public Property Description | This is the Description of the DB2StoGroup. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2StoGroup. DATATYPE: String.
Public Property ID | This is the ID of the DB2StoGroup. DATATYPE: Integer.
Public Property Name | This is the name of the DB2StoGroup. DATATYPE: String.
Public Property Vcat | This is the name of the Vcat for the DB2StoGroup. DATATYPE: String.
Public Property Volume | This is the name of the Volume for the DB2StoGroup. DATATYPE: String.

See Also

DB2StoGroup Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this DB2StoGroup.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2StoGroup Object


%%PageItemTitle%%

UserComments Method

Description

Get all the user comments assocaited with this DB2StoGroup.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2StoGroup Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2StoGroup. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2StoGroup Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2StoGroup. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2StoGroup Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the DB2StoGroup. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2StoGroup Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DB2StoGroup. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2StoGroup Object


%%PageItemTitle%%

Vcat Property

Description

This is the name of the Vcat for the DB2StoGroup. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Vcat() As Variant

See Also

DB2StoGroup Object


%%PageItemTitle%%

Volume Property

Description

This is the name of the Volume for the DB2StoGroup. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Volume() As Variant

See Also

DB2StoGroup Object


%%PageItemTitle%%

DB2StoGroups Collection
See Also Members

Description

This object represents a collection of DB2StoGroup objects.

Object Model

See Also

DB2StoGroups Members


%%PageItemTitle%% $$Members$$

DB2StoGroups Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new DB2StoGroup object. PARAMETERS: Name as String, Vcat as String, Volume as String.
Public Method AddWithPosition | Add a new DB2StoGroup object with the given coordinates. PARAMETERS: Name as String, Vcat as String, Volume as String, HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Remove a DB2StoGroup specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2StoGroup object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2StoGroup objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2StoGroup object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

DB2StoGroups Overview


%%PageItemTitle%%

Add Method
Name
Vcat
Volume

Description

Add a new DB2StoGroup object. PARAMETERS: Name as String, Vcat as String, Volume as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Vcat As Variant, _
   ByVal Volume As Variant _
) As DB2StoGroup

Parameters

Name
Vcat
Volume

See Also

DB2StoGroups Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Vcat
Volume
HorizontalPosition
VerticalPosition

Description

Add a new DB2StoGroup object with the given coordinates. PARAMETERS: Name as String, Vcat as String, Volume as String, HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Vcat As Variant, _
   ByVal Volume As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2StoGroup

Parameters

Name
Vcat
Volume
HorizontalPosition
VerticalPosition

See Also

DB2StoGroups Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Remove a DB2StoGroup specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2StoGroups Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2StoGroup object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2StoGroup

Parameters

Identifier

See Also

DB2StoGroups Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2StoGroups Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2StoGroup objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2StoGroups Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2StoGroup object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2StoGroup

Parameters

Identifier

See Also

DB2StoGroups Collection


%%PageItemTitle%%

DB2Tablespace Object
See Also Members

Description

This object represents a DB2Tablespace in ER/Studio.

Object Model

See Also

DB2Tablespace Members


%%PageItemTitle%% $$Members$$

DB2Tablespace Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this DB2Tablespace.
Public Method DB2TbsPartitions | Get all the DB2TbsPartitions of this DB2Tablespace.
Public Method UserComments | Get all the User comments associated with this DB2Tablespace.

Public Properties

Public Property BufferPool | This is the BufferPool of the DB2Tablespace. DATATYPE: String.
Public Property Close | This is the Close property of the DB2Tablespace. DATATYPE: Boolean.
Public Property Compress | This is the Compress property of the DB2Tablespace. DATATYPE: Boolean.
Public Property Database | This is the Database of the DB2Tablespace. DATATYPE: String.
Public Property Description | This is the Description of the DB2Tablespace. DATATYPE: String.
Public Property DssSize | This is the DssSize in Gigabytes of the DB2Tablespace. DATATYPE: Integer.
Public Property Encoding | This is the Encoding of the DB2Tablespace. ASCII, EBCDIC and UNICODE are the only valid input strings. DATATYPE: String.
Public Property Erase | This is the Erase property for the DB2Tablespace. DATATYPE: Boolean.
Public Property FreePage | This is the FreePage of the DB2Tablespace. DATATYPE: Integer.
Public Property GBPCache | This is the GbpCache of the DB2Tablespace. Valid strings are CHANGED, ALL, SYSTEM, and NONE. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2Tablespace. DATATYPE: String.
Public Property ID | This is the ID of the DB2Tablespace. DATATYPE: Integer.
Public Property LockMax | This is the LockMax of the DB2Tablespace. Set to -1 for SYSTEM. DATATYPE: Integer.
Public Property LockPart | This is the LockPart property of the DB2Tablespace. DATATYPE: Boolean.
Public Property LockSize | This is the LockSize of the DB2Tablespace. Valid strings are ANY, TABLESPACE, TABLE, PAGE, ROW, and LOB. DATATYPE: String.
Public Property Log | This is the Log of the DB2Tablespace. DATATYPE: Boolean.
Public Property MaxPartitions | This is the MaxPartitions of the DB2Tablespace. Input range is 1 to 4096 only. DATATYPE: Integer.
Public Property MaxRows | This is the MaxRows of the DB2Tablespace. Input range is 1 to 255 only. DATATYPE: Integer.
Public Property MemberCluster | This is the MemberCluster of the DB2Tablespace. DATATYPE: Boolean.
Public Property Name | This is the name of the DB2Tablespace. DATATYPE: String.
Public Property NumParts | This is the NumParts of the DB2Tablespace. Set value to 0 (zero) for not partitioned. DATATYPE: Integer.
Public Property PctFree | This is the PctFree of the DB2Tablespace. DATATYPE: Integer.
Public Property PriQty | This is the PriQty of the DB2Tablespace. DATATYPE: Integer.
Public Property SecQty | This is the SecQty of the DB2Tablespace. DATATYPE: Integer.
Public Property SegSize | This is the SegSize of the DB2Tablespace. DATATYPE: Integer.
Public Property StoGroupName | This is the StoGroupName of the DB2Tablespace. DATATYPE: String.
Public Property TrackMod | This is the TrackMod of the DB2Tablespace. DATATYPE: Boolean.
Public Property Type | This is the Type of the DB2Tablespace. LARGE and LOB are the only valid strings. DATATYPE: String.
Public Property VcatName | This is the VcatName of the DB2Tablespace. DATATYPE: String.

See Also

DB2Tablespace Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this DB2Tablespace.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2Tablespace Object


%%PageItemTitle%%

DB2TbsPartitions Method

Description

Get all the DB2TbsPartitions of this DB2Tablespace.

Syntax

Visual Basic
Public Function DB2TbsPartitions() As DB2TbsPartitions

See Also

DB2Tablespace Object


%%PageItemTitle%%

UserComments Method

Description

Get all the User comments associated with this DB2Tablespace.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2Tablespace Object


%%PageItemTitle%%

BufferPool Property

Description

This is the BufferPool of the DB2Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferPool() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Close Property

Description

This is the Close property of the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Close() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Compress Property

Description

This is the Compress property of the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compress() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Database Property

Description

This is the Database of the DB2Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Database() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

DssSize Property

Description

This is the DssSize in Gigabytes of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DssSize() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Encoding Property

Description

This is the Encoding of the DB2Tablespace. ASCII, EBCDIC and UNICODE are the only valid input strings. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Encoding() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Erase Property

Description

This is the Erase property for the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Erase() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

FreePage Property

Description

This is the FreePage of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreePage() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

GBPCache Property

Description

This is the GbpCache of the DB2Tablespace. Valid strings are CHANGED, ALL, SYSTEM, and NONE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GBPCache() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2Tablespace. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

LockMax Property

Description

This is the LockMax of the DB2Tablespace. Set to -1 for SYSTEM. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockMax() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

LockPart Property

Description

This is the LockPart property of the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockPart() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

LockSize Property

Description

This is the LockSize of the DB2Tablespace. Valid strings are ANY, TABLESPACE, TABLE, PAGE, ROW, and LOB. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockSize() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Log Property

Description

This is the Log of the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Log() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

MaxPartitions Property

Description

This is the MaxPartitions of the DB2Tablespace. Input range is 1 to 4096 only. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxPartitions() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

MaxRows Property

Description

This is the MaxRows of the DB2Tablespace. Input range is 1 to 255 only. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxRows() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

MemberCluster Property

Description

This is the MemberCluster of the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MemberCluster() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DB2Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

NumParts Property

Description

This is the NumParts of the DB2Tablespace. Set value to 0 (zero) for not partitioned. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumParts() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

PctFree Property

Description

This is the PctFree of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctFree() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

PriQty Property

Description

This is the PriQty of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PriQty() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

SecQty Property

Description

This is the SecQty of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SecQty() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

SegSize Property

Description

This is the SegSize of the DB2Tablespace. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SegSize() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

StoGroupName Property

Description

This is the StoGroupName of the DB2Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StoGroupName() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

TrackMod Property

Description

This is the TrackMod of the DB2Tablespace. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TrackMod() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

Type Property

Description

This is the Type of the DB2Tablespace. LARGE and LOB are the only valid strings. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

VcatName Property

Description

This is the VcatName of the DB2Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property VcatName() As Variant

See Also

DB2Tablespace Object


%%PageItemTitle%%

DB2Tablespaces Collection
See Also Members

Description

This object represents a collection of DB2Tablespace objects.

Object Model

See Also

DB2Tablespaces Members


%%PageItemTitle%% $$Members$$

DB2Tablespaces Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new DB2Tablespace object. PARAMETERS: Name as String.
Public Method AddWithPosition | Add a new DB2Tablespace object with the given coordinates. PARAMETERS: Name as String, HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Remove a DB2Tablespace specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | RReturns a DB2Tablespace object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2Tablespace objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2Tablespace object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

DB2Tablespaces Overview


%%PageItemTitle%%

Add Method
Name

Description

Add a new DB2Tablespace object. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DB2Tablespace

Parameters

Name

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Add a new DB2Tablespace object with the given coordinates. PARAMETERS: Name as String, HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2Tablespace

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Remove a DB2Tablespace specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

RReturns a DB2Tablespace object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2Tablespace

Parameters

Identifier

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2Tablespace objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2Tablespace object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2Tablespace

Parameters

Identifier

See Also

DB2Tablespaces Collection


%%PageItemTitle%%

DB2TbsPartition Object
See Also Members

Description

This object represents a DB2TbsPartition in ER/Studio.

See Also

DB2TbsPartition Members


%%PageItemTitle%% $$Members$$

DB2TbsPartition Object Members
See Also Overview

Public Methods

Public Method CompressReset | This resets the Compress property of the DB2TBSPartition to the default.
Public Method TrackModReset | This resets the TrackMod property of the DB2TBSPartition to the default.

Public Properties

Public Property Compress | This is the Compress property of the DB2TBSPartition. DATATYPE: Boolean.
Public Property Defined | This is the Defined property of the DB2TBSPartition. DATATYPE: Boolean.
Public Property Erase | This is the Erase Rule of the DB2TBSPartition. DATATYPE: Boolean.
Public Property FreePage | This is the FreePage of the DB2TBSPartition. DATATYPE: Integer.
Public Property GBPCache | This is the GbpCache of the DB2TBSPartition. DATATYPE: String. Valid strings are CHANGED, ALL, SYSTEM, and NONE.
Public Property Number | This is the Number of the DB2TBSPartition. DATATYPE: Integer.
Public Property PctFree | This is the PctFree of the DB2TBSPartition. DATATYPE: Integer.
Public Property PriQty | This is the PriQty of the DB2TBSPartition. DATATYPE: Integer.
Public Property SecQty | This is the SecQty of the DB2TBSPartition. DATATYPE: Integer.
Public Property StoGroupName | This is the StoGroupName of the DB2TBSPartition. DATATYPE: String.
Public Property TrackMod | This is the TrackMod property of the DB2TBSPartition. DATATYPE: Boolean.
Public Property VcatName | This is the VcatName of the DB2TBSPartition. DATATYPE: String.

See Also

DB2TbsPartition Overview


%%PageItemTitle%%

CompressReset Method

Description

This resets the Compress property of the DB2TBSPartition to the default.

Syntax

Visual Basic
Public Sub CompressReset()

See Also

DB2TbsPartition Object


%%PageItemTitle%%

TrackModReset Method

Description

This resets the TrackMod property of the DB2TBSPartition to the default.

Syntax

Visual Basic
Public Sub TrackModReset()

See Also

DB2TbsPartition Object


%%PageItemTitle%%

Compress Property

Description

This is the Compress property of the DB2TBSPartition. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compress() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

Defined Property

Description

This is the Defined property of the DB2TBSPartition. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Defined() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

Erase Property

Description

This is the Erase Rule of the DB2TBSPartition. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Erase() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

FreePage Property

Description

This is the FreePage of the DB2TBSPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreePage() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

GBPCache Property

Description

This is the GbpCache of the DB2TBSPartition. DATATYPE: String. Valid strings are CHANGED, ALL, SYSTEM, and NONE.

Property type

Read-write property

Syntax

Visual Basic
Public Property GBPCache() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the DB2TBSPartition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

PctFree Property

Description

This is the PctFree of the DB2TBSPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctFree() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

PriQty Property

Description

This is the PriQty of the DB2TBSPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PriQty() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

SecQty Property

Description

This is the SecQty of the DB2TBSPartition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SecQty() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

StoGroupName Property

Description

This is the StoGroupName of the DB2TBSPartition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StoGroupName() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

TrackMod Property

Description

This is the TrackMod property of the DB2TBSPartition. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TrackMod() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

VcatName Property

Description

This is the VcatName of the DB2TBSPartition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property VcatName() As Variant

See Also

DB2TbsPartition Object


%%PageItemTitle%%

DB2TbsPartitions Collection
See Also Members

Description

This object represents a collection of DB2TbsPartition objects. This is the collection of Partitions contained in a DB2Tablespace object.

Object Model

See Also

DB2TbsPartitions Members


%%PageItemTitle%% $$Members$$

DB2TbsPartitions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new DB2TbsPartition object. PARAMETERS: Number as Integer, Compress as Boolean.
Public Method Remove | Remove a DB2TbsPartition specified by the given Number. PARAMETERS: Number as Integer.

Public Properties

Public Property _Item | Returns a DB2TbsPartition object specified by the given Number. PARAMETERS: Number as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2TbsPartition objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2TbsPartition object specified by the given Number. PARAMETERS: Number as Integer.

See Also

DB2TbsPartitions Overview


%%PageItemTitle%%

Add Method
Number
Compress

Description

Add a new DB2TbsPartition object. PARAMETERS: Number as Integer, Compress as Boolean.

Syntax

Visual Basic
Public Function Add( _
   ByVal Number As Variant, _
   ByVal Compress As Variant _
) As DB2TbsPartition

Parameters

Number
Compress

See Also

DB2TbsPartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Remove a DB2TbsPartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

DB2TbsPartitions Collection


%%PageItemTitle%%

_Item Property
Number

Description

Returns a DB2TbsPartition object specified by the given Number. PARAMETERS: Number as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Number As Variant _
) As DB2TbsPartition

Parameters

Number

See Also

DB2TbsPartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2TbsPartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2TbsPartition objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2TbsPartitions Collection


%%PageItemTitle%%

Item Property
Number

Description

Returns a DB2TbsPartition object specified by the given Number. PARAMETERS: Number as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Number As Variant _
) As DB2TbsPartition

Parameters

Number

See Also

DB2TbsPartitions Collection


%%PageItemTitle%%

DB2UDBAlias Object
See Also Members

Description

This object represents a DB2 UDB Alias in ER/Studio.

Object Model

See Also

DB2UDBAlias Members


%%PageItemTitle%% $$Members$$

DB2UDBAlias Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comment collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the DB2 UDB Alias. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2 UDB Alias. DATATYPE: String.
Public Property ID | Returns the DB2 UDB Alias ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 UDB Alias. DATATYPE: String.
Public Property Owner | This property represents the owner of the DB2 UDB Alias. DATATYPE: String.
Public Property ReferencedObjectName | This property represents the name of the object refered to by the DB2 UDB Alias. DATATYPE: String.
Public Property ReferencedObjectOwner | This property represents the owner of the object refered to by the DB2 UDB Alias. DATATYPE: String.

See Also

DB2UDBAlias Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2UDBAlias Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comment collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2UDBAlias Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2 UDB Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2 UDB Alias. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 UDB Alias ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 UDB Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DB2 UDB Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

ReferencedObjectName Property

Description

This property represents the name of the object refered to by the DB2 UDB Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectName() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

ReferencedObjectOwner Property

Description

This property represents the owner of the object refered to by the DB2 UDB Alias. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectOwner() As Variant

See Also

DB2UDBAlias Object


%%PageItemTitle%%

DB2UDBAliases Collection
See Also Members

Description

This object represents a collection of DB2 UDB Aliases. The owner of this collection is the model.

Object Model

See Also

DB2UDBAliases Members


%%PageItemTitle%% $$Members$$

DB2UDBAliases Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2 UDB Alias, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).
Public Method AddWithPosition | Creates a DB2 UDB Alias. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an DB2 UDB Alias object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2 UDB Alias object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Aliases in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2 UDB Alias object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBAliases Overview


%%PageItemTitle%%

Add Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner

Description

Creates and returns a new DB2 UDB Alias, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant _
) As DB2UDBAlias

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

Description

Creates a DB2 UDB Alias. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2UDBAlias

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DB2 UDB Alias object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2 UDB Alias object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBAlias

Parameters

Identifier

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Aliases in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2 UDB Alias object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBAlias

Parameters

Identifier

See Also

DB2UDBAliases Collection


%%PageItemTitle%%

DB2UDBBufferPool Object
See Also Members

Description

This object represents a DB2 UDB BufferPool in ER/Studio. It is stored as its create statement.

Object Model

See Also

DB2UDBBufferPool Members


%%PageItemTitle%% $$Members$$

DB2UDBBufferPool Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method DB2UDBExceptNodes | Returns the DB2UDBExceptNodes associated with this bufferpool.
Public Method DB2UDBNodeNames | Returns the DB2UDBNodeNames associated with this bufferpool.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property AllNodes | Tells whether ON ALL NODES is specified in the CREATE statement. Setting AllNodes to true empties the Node Collection. No Nodes can be added, while AllNodes is true. DATATYPE: Boolean.
Public Property Description | This is the Description of the DB2 UDB BufferPool. DATATYPE: String.
Public Property ExtendedStorage | Tells whether extended storage can be used to cache pages that are being migrated. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the DB2 UDB BufferPool. DATATYPE: String.
Public Property ID | Returns the DB2 UDB BufferPool's ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 UDB BufferPool. DATATYPE: String.
Public Property PageSize | Specifies the page size of the bufferpool in kilobytes. Sizes of 4, 8, 16 and 32 are valid. DATATYPE: Integer.
Public Property Size | Specifies the size of the bufferpool as number of pages. DATATYPE: Integer.

See Also

DB2UDBBufferPool Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

DB2UDBExceptNodes Method

Description

Returns the DB2UDBExceptNodes associated with this bufferpool.

Syntax

Visual Basic
Public Function DB2UDBExceptNodes() As DB2UDBExceptNodes

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

DB2UDBNodeNames Method

Description

Returns the DB2UDBNodeNames associated with this bufferpool.

Syntax

Visual Basic
Public Function DB2UDBNodeNames() As DB2UDBNodeNames

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

AllNodes Property

Description

Tells whether ON ALL NODES is specified in the CREATE statement. Setting AllNodes to true empties the Node Collection. No Nodes can be added, while AllNodes is true. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllNodes() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2 UDB BufferPool. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

ExtendedStorage Property

Description

Tells whether extended storage can be used to cache pages that are being migrated. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExtendedStorage() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2 UDB BufferPool. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 UDB BufferPool's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 UDB BufferPool. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

PageSize Property

Description

Specifies the page size of the bufferpool in kilobytes. Sizes of 4, 8, 16 and 32 are valid. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageSize() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

Size Property

Description

Specifies the size of the bufferpool as number of pages. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Size() As Variant

See Also

DB2UDBBufferPool Object


%%PageItemTitle%%

DB2UDBBufferPools Collection
See Also Members

Description

This object represents a collection of DB2UDBBufferPools. The owner of this collection is the Model.

Object Model

See Also

DB2UDBBufferPools Members


%%PageItemTitle%% $$Members$$

DB2UDBBufferPools Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBBufferPool and adds it to the collection. PARAMETERS: Name (String) Size (Integer).
Public Method AddWithPosition | Creates and returns a new DB2UDBBufferPool with the given coordinates. PARAMETERS: Name (String) Size (Integer), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a BufferPool object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2UDBBufferPool object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of BufferPools in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2UDBBufferPool object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBBufferPools Overview


%%PageItemTitle%%

Add Method
Name
Size

Description

Creates and returns a new DB2UDBBufferPool and adds it to the collection. PARAMETERS: Name (String) Size (Integer).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Size As Variant _
) As DB2UDBBufferPool

Parameters

Name
Size

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Size
HorizontalPosition
VerticalPosition

Description

Creates and returns a new DB2UDBBufferPool with the given coordinates. PARAMETERS: Name (String) Size (Integer), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Size As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2UDBBufferPool

Parameters

Name
Size
HorizontalPosition
VerticalPosition

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a BufferPool object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2UDBBufferPool object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBBufferPool

Parameters

Identifier

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

Count Property

Description

This is the number of BufferPools in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2UDBBufferPool object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBBufferPool

Parameters

Identifier

See Also

DB2UDBBufferPools Collection


%%PageItemTitle%%

DB2UDBContainerDMS Object
See Also Members

Description

This object represents a DB2UDBContainerDMS in ER/Studio. It belongs to a database managed Tablespace.

See Also

DB2UDBContainerDMS Members


%%PageItemTitle%% $$Members$$

DB2UDBContainerDMS Object Members
See Also Overview

Public Properties

Public Property FilePath | Represents the DB2UDBContainerDMS's FileName. DATATYPE: String.
Public Property ID | Returns the DB2UDBContainerDMS's ID. DATATYPE: Integer.
Public Property Size | Represents the DB2UDBContainerDMS's Size. DATATYPE: Integer.
Public Property Type | Represents the DB2UDBContainerDMS's Type, which can be either DEVICE or FILE. DATATYPE: String.

See Also

DB2UDBContainerDMS Overview


%%PageItemTitle%%

FilePath Property

Description

Represents the DB2UDBContainerDMS's FileName. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property FilePath() As Variant

See Also

DB2UDBContainerDMS Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2UDBContainerDMS's ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBContainerDMS Object


%%PageItemTitle%%

Size Property

Description

Represents the DB2UDBContainerDMS's Size. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Size() As Variant

See Also

DB2UDBContainerDMS Object


%%PageItemTitle%%

Type Property

Description

Represents the DB2UDBContainerDMS's Type, which can be either DEVICE or FILE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

DB2UDBContainerDMS Object


%%PageItemTitle%%

DB2UDBContainersDMS Collection
See Also Members

Description

This object represents a collection of DB2 UDB ContainerDMSs. The owner of this collection is the DB2UDBTablespace.

Object Model

See Also

DB2UDBContainersDMS Members


%%PageItemTitle%% $$Members$$

DB2UDBContainersDMS Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new DB2UDBContainerDMS within the collection (Tablespace) and returns it. Type is either FILE or DEVICE. PARAMETERS: FileName and Type as String, Size as Integer.
Public Method Remove | Deletes the ContainerSMS object with the given ID or FileName from the collection. PARAMETERS: FileName as String or ID as Integer.

Public Properties

Public Property _Item | Returns the DB2UDBContainerDMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.
Public Property _NewEnum |
Public Property Count | This is the number of DB2UDBContainerDMSs in the collection (the given Tablespace). DATATYPE: Integer.
Public Property Item | Returns the DB2UDBContainerDMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.

See Also

DB2UDBContainersDMS Overview


%%PageItemTitle%%

Add Method
PathName
Type
Size

Description

Creates a new DB2UDBContainerDMS within the collection (Tablespace) and returns it. Type is either FILE or DEVICE. PARAMETERS: FileName and Type as String, Size as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal PathName As Variant, _
   ByVal Type As Variant, _
   ByVal Size As Variant _
) As DB2UDBContainerDMS

Parameters

PathName
Type
Size

See Also

DB2UDBContainersDMS Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes the ContainerSMS object with the given ID or FileName from the collection. PARAMETERS: FileName as String or ID as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBContainersDMS Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DB2UDBContainerDMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBContainerDMS

Parameters

Identifier

See Also

DB2UDBContainersDMS Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBContainersDMS Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2UDBContainerDMSs in the collection (the given Tablespace). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBContainersDMS Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DB2UDBContainerDMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBContainerDMS

Parameters

Identifier

See Also

DB2UDBContainersDMS Collection


%%PageItemTitle%%

DB2UDBContainerSMS Object
See Also Members

Description

This object represents a DB2UDBContainerSMS in ER/Studio. It belongs to a system managed Tablespace.

See Also

DB2UDBContainerSMS Members


%%PageItemTitle%% $$Members$$

DB2UDBContainerSMS Object Members
See Also Overview

Public Properties

Public Property ID | RReturns the DB2UDBContainerSMS's ID. DATATYPE: Integer.
Public Property PathName | Represents the DB2UDBContainerSMS's PathName. DATATYPE: String.

See Also

DB2UDBContainerSMS Overview


%%PageItemTitle%%

ID Property

Description

RReturns the DB2UDBContainerSMS's ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBContainerSMS Object


%%PageItemTitle%%

PathName Property

Description

Represents the DB2UDBContainerSMS's PathName. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PathName() As Variant

See Also

DB2UDBContainerSMS Object


%%PageItemTitle%%

DB2UDBContainersSMS Collection
See Also Members

Description

This object represents a collection of DB2 UDB ContainerSMSs. The owner of this collection is the DB2UDBTablespace.

Object Model

See Also

DB2UDBContainersSMS Members


%%PageItemTitle%% $$Members$$

DB2UDBContainersSMS Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBContainerSMS within the given Tablespace and adds it to the collection. PARAMETERS: FileName as String.
Public Method Remove | Deletes the ContainerSMS object with the given ID or FileName from the collection. PARAMETERS: FileName as String or ID as Integer.

Public Properties

Public Property _Item | Returns the DB2UDBContainerSMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.
Public Property _NewEnum |
Public Property Count | This is the number of DB2UDBContainerSMSs in the collection (the given Tablespace). DATATYPE: Integer.
Public Property Item | Returns the DB2UDBContainerSMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.

See Also

DB2UDBContainersSMS Overview


%%PageItemTitle%%

Add Method
FileName

Description

Creates and returns a new DB2UDBContainerSMS within the given Tablespace and adds it to the collection. PARAMETERS: FileName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal FileName As Variant _
) As DB2UDBContainerSMS

Parameters

FileName

See Also

DB2UDBContainersSMS Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes the ContainerSMS object with the given ID or FileName from the collection. PARAMETERS: FileName as String or ID as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBContainersSMS Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DB2UDBContainerSMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBContainerSMS

Parameters

Identifier

See Also

DB2UDBContainersSMS Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBContainersSMS Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2UDBContainerSMSs in the collection (the given Tablespace). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBContainersSMS Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DB2UDBContainerSMS object with the given ID or Name. PARAMETERS: ID as Integer or FileName as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBContainerSMS

Parameters

Identifier

See Also

DB2UDBContainersSMS Collection


%%PageItemTitle%%

DB2UDBDimension Object
See Also Members

Description

This object represents a DB2Dimension in ER/Studio.

See Also

DB2UDBDimension Members


%%PageItemTitle%% $$Members$$

DB2UDBDimension Object Members
See Also Overview

Public Properties

Public Property DimensionDefinition | This is the Column Definition of the Dimension. It is the comma separated list of columns for the Dimension. DATATYPE: String.
Public Property ParentTableID | This is the ID of the parent Entity. DATATYPE: Integer.
Public Property SequenceNumber | This is the Sequence Number of the Dimension. (Sequence Numbers determine the order in which the dimension appears in the DDL.) DATATYPE: Integer.

See Also

DB2UDBDimension Overview


%%PageItemTitle%%

DimensionDefinition Property

Description

This is the Column Definition of the Dimension. It is the comma separated list of columns for the Dimension. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionDefinition() As Variant

See Also

DB2UDBDimension Object


%%PageItemTitle%%

ParentTableID Property

Description

This is the ID of the parent Entity. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentTableID() As Variant

See Also

DB2UDBDimension Object


%%PageItemTitle%%

SequenceNumber Property

Description

This is the Sequence Number of the Dimension. (Sequence Numbers determine the order in which the dimension appears in the DDL.) DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

DB2UDBDimension Object


%%PageItemTitle%%

DB2UDBDimensions Collection
See Also Members

Description

This object represents a collection of DB2UDBDimension objects.

Object Model

See Also

DB2UDBDimensions Members


%%PageItemTitle%% $$Members$$

DB2UDBDimensions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new Dimension object. PARAMETERS: Comma Separated List of Columns as String, Sequence Number as Integer (-1 means append to end).
Public Method Remove | Remove a Dimension specified by the given column definition string (comma separated list of columns) or sequence number. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2UDBDimension object specified by the given Column definition (comma separated list of columns) or Sequence Number. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2UDBDimension objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2UDBDimension object specified by the given Column definition (comma separated list of columns) or Sequence Number. PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBDimensions Overview


%%PageItemTitle%%

Add Method
Columns
SequenceNumber

Description

Add a new Dimension object. PARAMETERS: Comma Separated List of Columns as String, Sequence Number as Integer (-1 means append to end).

Syntax

Visual Basic
Public Function Add( _
   ByVal Columns As Variant, _
   ByVal SequenceNumber As Variant _
) As DB2UDBDimension

Parameters

Columns
SequenceNumber

See Also

DB2UDBDimensions Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Remove a Dimension specified by the given column definition string (comma separated list of columns) or sequence number. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBDimensions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2UDBDimension object specified by the given Column definition (comma separated list of columns) or Sequence Number. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBDimension

Parameters

Identifier

See Also

DB2UDBDimensions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBDimensions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2UDBDimension objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBDimensions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2UDBDimension object specified by the given Column definition (comma separated list of columns) or Sequence Number. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBDimension

Parameters

Identifier

See Also

DB2UDBDimensions Collection


%%PageItemTitle%%

DB2UDBExceptNode Object
See Also Members

Description

This object represents a DB2UDBExceptNode in ER/Studio.

See Also

DB2UDBExceptNode Members


%%PageItemTitle%% $$Members$$

DB2UDBExceptNode Object Members
See Also Overview

Public Properties

Public Property ID | Returns the DB2UDBExceptNode's ID. DATATYPE: Integer.
Public Property NodeNumber | Returns the DB2UDBExceptNode's NodeNumber. DATATYPE: String.
Public Property Size | Represents the size in pages of the DB2UDBExceptNode. DATATYPE: Integer.

See Also

DB2UDBExceptNode Overview


%%PageItemTitle%%

ID Property

Description

Returns the DB2UDBExceptNode's ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBExceptNode Object


%%PageItemTitle%%

NodeNumber Property

Description

Returns the DB2UDBExceptNode's NodeNumber. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property NodeNumber() As Variant

See Also

DB2UDBExceptNode Object


%%PageItemTitle%%

Size Property

Description

Represents the size in pages of the DB2UDBExceptNode. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Size() As Variant

See Also

DB2UDBExceptNode Object


%%PageItemTitle%%

DB2UDBExceptNodes Collection
See Also Members

Description

This object represents a collection of DB2UDBExceptNodes. The owner of this collection is the DB2UDBBufferPool.

Object Model

See Also

DB2UDBExceptNodes Members


%%PageItemTitle%% $$Members$$

DB2UDBExceptNodes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBExceptNode within the given BufferPool and adds it to the collection. PARAMETERS: NodeNumber as Integer and Size as Integer.
Public Method Remove | Deletes the ExceptNode object with the given NodeNumber from the collection. PARAMETERS: NodeNumber as Integer.

Public Properties

Public Property _Item | Returns the DB2UDBExceptNode object with the given NodeNumber. The ID should not be used. PARAMETERS: NodeNumber as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2UDBExceptNodes in the collection (the given BufferPool). DATATYPE: Integer.
Public Property Item | Returns the DB2UDBExceptNode object with the given NodeNumber. The ID should not be used. PARAMETERS: NodeNumber as Integer.

See Also

DB2UDBExceptNodes Overview


%%PageItemTitle%%

Add Method
NodeNumber
Size

Description

Creates and returns a new DB2UDBExceptNode within the given BufferPool and adds it to the collection. PARAMETERS: NodeNumber as Integer and Size as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal NodeNumber As Variant, _
   ByVal Size As Variant _
) As DB2UDBExceptNode

Parameters

NodeNumber
Size

See Also

DB2UDBExceptNodes Collection


%%PageItemTitle%%

Remove Method
NodeNumber

Description

Deletes the ExceptNode object with the given NodeNumber from the collection. PARAMETERS: NodeNumber as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal NodeNumber As Variant _
)

Parameters

NodeNumber

See Also

DB2UDBExceptNodes Collection


%%PageItemTitle%%

_Item Property
NodeNumber

Description

Returns the DB2UDBExceptNode object with the given NodeNumber. The ID should not be used. PARAMETERS: NodeNumber as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal NodeNumber As Variant _
) As DB2UDBExceptNode

Parameters

NodeNumber

See Also

DB2UDBExceptNodes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBExceptNodes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2UDBExceptNodes in the collection (the given BufferPool). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBExceptNodes Collection


%%PageItemTitle%%

Item Property
NodeNumber

Description

Returns the DB2UDBExceptNode object with the given NodeNumber. The ID should not be used. PARAMETERS: NodeNumber as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal NodeNumber As Variant _
) As DB2UDBExceptNode

Parameters

NodeNumber

See Also

DB2UDBExceptNodes Collection


%%PageItemTitle%%

DB2UDBMaterializedQueryTable Object
See Also Members

Description

This object represents a DB2 UDB Materialized Query Table in ER/Studio.

Object Model

See Also

DB2UDBMaterializedQueryTable Members


%%PageItemTitle%% $$Members$$

DB2UDBMaterializedQueryTable Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the User Comments collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the DB2 UDB Materialized Query Table. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2 UDB Materialized Query Table. DATATYPE: String.
Public Property ID | Returns the DB2 UDB Materialized Query Table ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 UDB Materialized Query Table. DATATYPE: String.
Public Property Owner | This property represents the owner of the DB2 UDB Materialized Query Table. DATATYPE: String.
Public Property QueryOptimizationEnabled | This property is true if query optimization is enabled, otherwise it is false. DATATYPE: String.
Public Property Refreshable | This property tells whether the DB2 UDB Materialized Query Table is refreshable. DATATYPE: Boolean.
Public Property RefreshImmediate | This property is true if the refresh is immmediate, and false if it is deferred. DATATYPE: Boolean.
Public Property SelectStatement | This property represents the select statement of the DB2 UDB Materialized Query Table. DATATYPE: String.
Public Property Tablespace | This property represents the tablespace of the DB2 UDB Materialized Query Table. DATATYPE: String.

See Also

DB2UDBMaterializedQueryTable Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

UserComments Method

Description

Returns the User Comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2 UDB Materialized Query Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2 UDB Materialized Query Table. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 UDB Materialized Query Table ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 UDB Materialized Query Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DB2 UDB Materialized Query Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

QueryOptimizationEnabled Property

Description

This property is true if query optimization is enabled, otherwise it is false. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property QueryOptimizationEnabled() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

Refreshable Property

Description

This property tells whether the DB2 UDB Materialized Query Table is refreshable. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Refreshable() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

RefreshImmediate Property

Description

This property is true if the refresh is immmediate, and false if it is deferred. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property RefreshImmediate() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

SelectStatement Property

Description

This property represents the select statement of the DB2 UDB Materialized Query Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectStatement() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

Tablespace Property

Description

This property represents the tablespace of the DB2 UDB Materialized Query Table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

DB2UDBMaterializedQueryTable Object


%%PageItemTitle%%

DB2UDBMaterializedQueryTables Collection
See Also Members

Description

This object represents a collection of DB2 UDB Materialized Query Tables. The owner of this collection is the model.

Object Model

See Also

DB2UDBMaterializedQueryTables Members


%%PageItemTitle%% $$Members$$

DB2UDBMaterializedQueryTables Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2 UDB Materialized Query Table, and adds it to the collection. PARAMETERS: Name (String), Owner (String), SelectStatement (String).
Public Method AddWithPosition | Creates a DB2 UDB Materialized Query Table. PARAMETERS: Name (String), Owner (String), SelectStatement (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a DB2 UDB Materialized Query Table object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2 UDB Materialized Query Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Materialized Query Tables in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2 UDB Materialized Query Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBMaterializedQueryTables Overview


%%PageItemTitle%%

Add Method
Name
Owner
SelectStatement

Description

Creates and returns a new DB2 UDB Materialized Query Table, and adds it to the collection. PARAMETERS: Name (String), Owner (String), SelectStatement (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal SelectStatement As Variant _
) As DB2UDBMaterializedQueryTable

Parameters

Name
Owner
SelectStatement

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
SelectStatement
HorizontalPosition
VerticalPosition

Description

Creates a DB2 UDB Materialized Query Table. PARAMETERS: Name (String), Owner (String), SelectStatement (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal SelectStatement As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2UDBMaterializedQueryTable

Parameters

Name
Owner
SelectStatement
HorizontalPosition
VerticalPosition

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DB2 UDB Materialized Query Table object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2 UDB Materialized Query Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBMaterializedQueryTable

Parameters

Identifier

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Materialized Query Tables in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2 UDB Materialized Query Table object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBMaterializedQueryTable

Parameters

Identifier

See Also

DB2UDBMaterializedQueryTables Collection


%%PageItemTitle%%

DB2UDBNode Object
See Also Members

Description

This object represents a DB2 UDB Node in ER/Studio.

See Also

DB2UDBNode Members


%%PageItemTitle%% $$Members$$

DB2UDBNode Object Members
See Also Overview

Public Properties

Public Property ID | Returns the DB2 UDB Node's ID.DATATYPE: Integer.
Public Property NodeNumber | Returns the DB2 UDB Node's node number. DATATYPE: Integer.

See Also

DB2UDBNode Overview


%%PageItemTitle%%

ID Property

Description

Returns the DB2 UDB Node's ID.DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBNode Object


%%PageItemTitle%%

NodeNumber Property

Description

Returns the DB2 UDB Node's node number. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property NodeNumber() As Variant

See Also

DB2UDBNode Object


%%PageItemTitle%%

DB2UDBNodeGroup Object
See Also Members

Description

This object represents a DB2 UDB NodeGroup in ER/Studio. It is stored as its create statement.

Object Model

See Also

DB2UDBNodeGroup Members


%%PageItemTitle%% $$Members$$

DB2UDBNodeGroup Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method DB2UDBNodes | Returns the DB2 UDB Nodes associated with this NodeGroup.
Public Method SetAllNodes | Specifies ON ALL NODES and empties the Node Collection.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property AllNodes | Tells whether ON ALL NODES is specified in the CREATE statement. Returns true if the Node Collection is empty, false otherwise. DATATYPE: Boolean.
Public Property Description | This is the Description of the DB2 UDB NodeGroup. DATATYPE: String.
Public Property GUID | This is the GUID of the DB2 UDB NodeGroup. DATATYPE: String.
Public Property ID | Returns the DB2 UDB NodeGroup's ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 UDB NodeGroup. DATATYPE: String.

See Also

DB2UDBNodeGroup Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

DB2UDBNodes Method

Description

Returns the DB2 UDB Nodes associated with this NodeGroup.

Syntax

Visual Basic
Public Function DB2UDBNodes() As DB2UDBNodes

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

SetAllNodes Method

Description

Specifies ON ALL NODES and empties the Node Collection.

Syntax

Visual Basic
Public Sub SetAllNodes()

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

AllNodes Property

Description

Tells whether ON ALL NODES is specified in the CREATE statement. Returns true if the Node Collection is empty, false otherwise. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property AllNodes() As Variant

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2 UDB NodeGroup. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2 UDB NodeGroup. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 UDB NodeGroup's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 UDB NodeGroup. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBNodeGroup Object


%%PageItemTitle%%

DB2UDBNodeGroups Collection
See Also Members

Description

This object represents a collection of DB2 UDB NodeGroups. The owner of this collection is the Model.

Object Model

See Also

DB2UDBNodeGroups Members


%%PageItemTitle%% $$Members$$

DB2UDBNodeGroups Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBNodeGroup and adds it to the collection. PARAMETERS: Name (String).
Public Method AddWithPosition | Creates and returns a new DB2UDBNodeGroup with the given coordinates. PARAMETERS: Name (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a NodeGroup object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2UDBNodeGroup object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of NodeGroups in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2UDBNodeGroup object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBNodeGroups Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new DB2UDBNodeGroup and adds it to the collection. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DB2UDBNodeGroup

Parameters

Name

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Creates and returns a new DB2UDBNodeGroup with the given coordinates. PARAMETERS: Name (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2UDBNodeGroup

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a NodeGroup object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2UDBNodeGroup object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBNodeGroup

Parameters

Identifier

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

Count Property

Description

This is the number of NodeGroups in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2UDBNodeGroup object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBNodeGroup

Parameters

Identifier

See Also

DB2UDBNodeGroups Collection


%%PageItemTitle%%

DB2UDBNodeName Object
See Also Members

Description

This object represents a DB2UDBNodeName in ER/Studio.

See Also

DB2UDBNodeName Members


%%PageItemTitle%% $$Members$$

DB2UDBNodeName Object Members
See Also Overview

Public Properties

Public Property ID | Returns the DB2UDBNodeName's ID. DATATYPE: Integer.
Public Property Name | Returns the DB2UDBNodeName's Name, so it returns the node name. DATATYPE: String.

See Also

DB2UDBNodeName Overview


%%PageItemTitle%%

ID Property

Description

Returns the DB2UDBNodeName's ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBNodeName Object


%%PageItemTitle%%

Name Property

Description

Returns the DB2UDBNodeName's Name, so it returns the node name. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBNodeName Object


%%PageItemTitle%%

DB2UDBNodeNames Collection
See Also Members

Description

This object represents a collection of DB2 UDB NodeNames. The owner of this collection is the DB2UDBBufferPool.

Object Model

See Also

DB2UDBNodeNames Members


%%PageItemTitle%% $$Members$$

DB2UDBNodeNames Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBNodeName within the given BufferPool and adds it to the collection. PARAMETERS: Name as String.
Public Method Remove | Deletes the NodeName object with the given ID or name from the collection.

Public Properties

Public Property _Item | Returns the DB2UDBNodeName object with the given ID or Name. PARAMETERS: ID as Integer or Name as String RETURN DATATYPE: DB2UDBNode.
Public Property _NewEnum |
Public Property Count | This is the number of DB2UDBNodeNames in the collection (the given BufferPool). DATATYPE: Integer.
Public Property Item | Returns the DB2UDBNodeName object with the given ID or Name. PARAMETERS: ID as Integer or Name as String, RETURN DATATYPE: DB2UDBNode.

See Also

DB2UDBNodeNames Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new DB2UDBNodeName within the given BufferPool and adds it to the collection. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As DB2UDBNodeName

Parameters

Name

See Also

DB2UDBNodeNames Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes the NodeName object with the given ID or name from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBNodeNames Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns the DB2UDBNodeName object with the given ID or Name. PARAMETERS: ID as Integer or Name as String RETURN DATATYPE: DB2UDBNode.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBNodeName

Parameters

Identifier

See Also

DB2UDBNodeNames Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBNodeNames Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2UDBNodeNames in the collection (the given BufferPool). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBNodeNames Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns the DB2UDBNodeName object with the given ID or Name. PARAMETERS: ID as Integer or Name as String, RETURN DATATYPE: DB2UDBNode.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBNodeName

Parameters

Identifier

See Also

DB2UDBNodeNames Collection


%%PageItemTitle%%

DB2UDBNodes Collection
See Also Members

Description

This object represents a collection of DB2 UDB Nodes. The owner of this collection is the DB2UDBNodeGroup.

Object Model

See Also

DB2UDBNodes Members


%%PageItemTitle%% $$Members$$

DB2UDBNodes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBNode within the given NodeGroup and adds it to the collection. PARAMETERS: NodeNumber as Integer.
Public Method Remove | Deletes the Node object with the given ID from the collection. PARAMETERS: NodeNumber as Integer.

Public Properties

Public Property _Item | Returns the DB2UDBNode object with the given ID. PARAMETERS: NodeNumber as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2 UDB Nodes in the collection (the given NodeGroup). DATATYPE: Integer.
Public Property Item | Returns the DB2UDBNode object with the given ID. PARAMETERS: NodeNumber as Integer.

See Also

DB2UDBNodes Overview


%%PageItemTitle%%

Add Method
NodeNumber

Description

Creates and returns a new DB2UDBNode within the given NodeGroup and adds it to the collection. PARAMETERS: NodeNumber as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal NodeNumber As Variant _
) As DB2UDBNode

Parameters

NodeNumber

See Also

DB2UDBNodes Collection


%%PageItemTitle%%

Remove Method
ID

Description

Deletes the Node object with the given ID from the collection. PARAMETERS: NodeNumber as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal ID As Variant _
)

Parameters

ID

See Also

DB2UDBNodes Collection


%%PageItemTitle%%

_Item Property
ID

Description

Returns the DB2UDBNode object with the given ID. PARAMETERS: NodeNumber as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal ID As Variant _
) As DB2UDBNode

Parameters

ID

See Also

DB2UDBNodes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBNodes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2 UDB Nodes in the collection (the given NodeGroup). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBNodes Collection


%%PageItemTitle%%

Item Property
ID

Description

Returns the DB2UDBNode object with the given ID. PARAMETERS: NodeNumber as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal ID As Variant _
) As DB2UDBNode

Parameters

ID

See Also

DB2UDBNodes Collection


%%PageItemTitle%%

DB2UDBSequence Object
See Also Members

Description

This object represents an DB2UDB sequence in ER/Studio. It is stored as its create statement.

Object Model

See Also

DB2UDBSequence Members


%%PageItemTitle%% $$Members$$

DB2UDBSequence Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property CacheSize | This property specifies the the size of the cache used for the DB2UDB Sequence. DATATYPE: Integer.
Public Property Cycle | This property holds true if the DB2UDB Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.
Public Property Datatype | This property specifies the data type of the DB2UDB Sequence. DATATYPE: String.
Public Property DataWidth | This property represents the data width of the DB2UDB Sequence. DATATYPE: String.
Public Property Description | This is the Description of the DB2UDB Sequence. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the DB2UDB Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the DB2UDB Sequence. DATATYPE: Boolean.
Public Property GuaranteeOrder | This property holds true if the DB2UDB Sequence ordering should be guaranteed, false otherwise. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the DB2UDB Sequence. DATATYPE: String.
Public Property HasMaxValue | This property holds true if the DB2UDB Sequence has a maximum value set, false otherwise. DATATYPE: Boolean.
Public Property HasMinValue | This property holds true if the DB2UDB Sequence has a minimum value set, false otherwise. DATATYPE: Boolean.
Public Property ID | Returns the DB2UDB Sequence ID. DATATYPE: Integer.
Public Property IncrementBy | This property represents the value by which the DB2UDB Sequence will be implemented each time a new number is requested. DATATYPE: String.
Public Property MaxValue | This property represents the maximum DB2UDB Sequence value. DATATYPE: String.
Public Property MinValue | This property represents the minimum DB2UDB Sequence value. DATATYPE: String.
Public Property Name | This property represents the name of the DB2UDB Sequence. DATATYPE: String.
Public Property NeedCache | This property represents the need for cache size value of the DB2UDB Sequence. DATATYPE: Boolean.
Public Property NeedMaxValue | This property holds true if the DB2UDB Sequence needs a maximum value to be set, false otherwise. DATATYPE: Boolean.
Public Property NeedMinValue | This property holds true if the DB2UDB Sequence needs a minimum value to be set, false otherwise. DATATYPE: Boolean.
Public Property Owner | This property represents the owner of the DB2UDB Sequence. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the DB2UDB Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the DB2UDB Sequence. DATATYPE: String.
Public Property StartWith | This property represents the value that the DB2UDB Sequence will start with. DATATYPE: String.

See Also

DB2UDBSequence Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2UDBSequence Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

DB2UDBSequence Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2UDBSequence Object


%%PageItemTitle%%

CacheSize Property

Description

This property specifies the the size of the cache used for the DB2UDB Sequence. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CacheSize() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

Cycle Property

Description

This property holds true if the DB2UDB Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cycle() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

Datatype Property

Description

This property specifies the data type of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

DataWidth Property

Description

This property represents the data width of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataWidth() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the DB2UDB Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the DB2UDB Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

GuaranteeOrder Property

Description

This property holds true if the DB2UDB Sequence ordering should be guaranteed, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuaranteeOrder() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

HasMaxValue Property

Description

This property holds true if the DB2UDB Sequence has a maximum value set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasMaxValue() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

HasMinValue Property

Description

This property holds true if the DB2UDB Sequence has a minimum value set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasMinValue() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2UDB Sequence ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

IncrementBy Property

Description

This property represents the value by which the DB2UDB Sequence will be implemented each time a new number is requested. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementBy() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

MaxValue Property

Description

This property represents the maximum DB2UDB Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxValue() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

MinValue Property

Description

This property represents the minimum DB2UDB Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinValue() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

NeedCache Property

Description

This property represents the need for cache size value of the DB2UDB Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedCache() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

NeedMaxValue Property

Description

This property holds true if the DB2UDB Sequence needs a maximum value to be set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedMaxValue() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

NeedMinValue Property

Description

This property holds true if the DB2UDB Sequence needs a minimum value to be set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedMinValue() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the DB2UDB Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

StartWith Property

Description

This property represents the value that the DB2UDB Sequence will start with. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartWith() As Variant

See Also

DB2UDBSequence Object


%%PageItemTitle%%

DB2UDBSequences Collection
See Also Members

Description

This object represents a collection of DB2UDB sequences. The owner of this collection is the model.

Object Model

See Also

DB2UDBSequences Members


%%PageItemTitle%% $$Members$$

DB2UDBSequences Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDB Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).
Public Method AddWithPosition | Creates and returns a new DB2UDB Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an DB2UDB Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2UDB Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of sequences in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2UDB Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBSequences Overview


%%PageItemTitle%%

Add Method
Name
Owner

Description

Creates and returns a new DB2UDB Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant _
) As DB2UDBSequence

Parameters

Name
Owner

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
HorizontalPosition
VerticalPosition

Description

Creates and returns a new DB2UDB Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2UDBSequence

Parameters

Name
Owner
HorizontalPosition
VerticalPosition

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DB2UDB Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2UDB Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBSequence

Parameters

Identifier

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

Count Property

Description

This is the number of sequences in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2UDB Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBSequence

Parameters

Identifier

See Also

DB2UDBSequences Collection


%%PageItemTitle%%

DB2UDBTableRangePartition Object
See Also Members

Description

This object represents a DB2UDBTableRangePartition in ER/Studio.

See Also

DB2UDBTableRangePartition Members


%%PageItemTitle%% $$Members$$

DB2UDBTableRangePartition Object Members
See Also Overview

Public Properties

Public Property EndInclusive | This indicates whether the end values are inclusive. DATATYPE: Boolean.
Public Property EndValue | End Value for a table range partition. DATATYPE: String.
Public Property GUID | This is the GUID of the Partition. DATATYPE: String.
Public Property ID | This is the ID of the Partition. DATATYPE: Integer.
Public Property LongIn | Lets you specify a large tablespace where long data is to be stored. DATATYPE: String.
Public Property Name | This is the Name of the Partition. DATATYPE: String.
Public Property Number | This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL.) DATATYPE: Integer.
Public Property StartInclusive | This indicates whether the start values are inclusive. DATATYPE: Boolean.
Public Property StartValue | Start Value for a table range partition. DATATYPE: String.
Public Property Tablespace | This is the Tablespace of the Partition. DATATYPE: String.

See Also

DB2UDBTableRangePartition Overview


%%PageItemTitle%%

EndInclusive Property

Description

This indicates whether the end values are inclusive. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndInclusive() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

EndValue Property

Description

End Value for a table range partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndValue() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Partition. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the Partition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

LongIn Property

Description

Lets you specify a large tablespace where long data is to be stored. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LongIn() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

Name Property

Description

This is the Name of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL.) DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

StartInclusive Property

Description

This indicates whether the start values are inclusive. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartInclusive() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

StartValue Property

Description

Start Value for a table range partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartValue() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

Tablespace Property

Description

This is the Tablespace of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

DB2UDBTableRangePartition Object


%%PageItemTitle%%

DB2UDBTableRangePartitions Collection
See Also Members

Description

This object represents a collection of DB2UDBTableRangePartitions objects.

Object Model

See Also

DB2UDBTableRangePartitions Members


%%PageItemTitle%% $$Members$$

DB2UDBTableRangePartitions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new TableRangePartition object. PARAMETERS:Name as String, StartValue as String, EndValue as String.
Public Method AddColumnToDistributionKey | Use to add another column to the distribution key. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name as String.
Public Method AddColumnToPartitionKey | Use to add another column to the partition key. PARAMETERS: Name as String.
Public Method AddRange | Automatically generate a range of table partitions. PARAMETERS: StartValue as String, StartValueInclusive as Boolean, EndValue as String, EndValueInclusive as Boolean, RangeWidth as Number, DurationLabel as String, Tablespace as String, Long Tablespace as Stri?U?K??
Public Method DeleteColumnFromDistributionKey | Use to delete a column from the distribution key. Cannot delete last column in key. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name as String.
Public Method DeleteColumnFromPartitionKey | Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.
Public Method DeleteDistributionKey | Use this method to delete all columns in the distribution key. This also deletes all distributions key. This method applies only to IBM DB2 UDB 9.x.
Public Method DeletePartitionKey | Use this method to delete all columns in the partition key. This also deletes all partitions key.
Public Method GetDistributionColumnNumber | Looks for the column in the distribution key. If it finds it, it returns the column's number. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name of the distribution column as String. RETURN DATATYPE: Integer.
Public Method GetNullsOrderForPartitionColumn | Looks for the column in the partition key. If it finds it, it returns the column's Nulls Order. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: String.
Public Method GetPartitionColumnNumber | Looks for the column in the partition key. If it finds it, it returns the column's number. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: Integer.
Public Method Remove | Remove a TableRangePartition specified by the given Number. PARAMETERS: Number as Integer.
Public Method RemoveByName | Remove the TableRangePartition specified by the given Name. PARAMETERS: Name as String.
Public Method SetDistributionColumnNumber | Use to change the sequence of the columns in the partition key by setting the number of a column. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name of the partition column as String, Number as Integer .
Public Method SetNullsOrderForPartitionColumn | Use to set the Nulls Order for the given column (if the column is found in the partition key). PARAMETERS: Name of the partition column as String, Nulls Order as String .
Public Method SetPartitionColumnNumber | Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer .

Public Properties

Public Property _Item | Returns a DB2UDBTableRangePartitions object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DB2UDBTableRangePartitions objects in the collection. DATATYPE: Integer.
Public Property GetDistributionKeyColumns | This is the string with the names of the columns in the DistributionKey as a comma separated list in sequence order.This property applies only to IBM DB2 UDB 9.x. DATATYPE: String.
Public Property GetPartitionKeyColumns | This is the string with the names of the columns in the PartitionKey as a comma separated list in sequence order. DATATYPE: String.
Public Property Item | Returns a DB2UDBTableRangePartitions object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBTableRangePartitions Overview


%%PageItemTitle%%

Add Method
Name
StartValue
EndValue

Description

Add a new TableRangePartition object. PARAMETERS:Name as String, StartValue as String, EndValue as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal StartValue As Variant, _
   ByVal EndValue As Variant _
) As DB2UDBTableRangePartition

Parameters

Name
StartValue
EndValue

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

AddColumnToDistributionKey Method
Name

Description

Use to add another column to the distribution key. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub AddColumnToDistributionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

AddColumnToPartitionKey Method
Name

Description

Use to add another column to the partition key. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub AddColumnToPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

AddRange Method
StartValue
String
StartValueInclusive
Boolean
EndValue
String
EndValueInclusive
Boolean
RangeWidth
Number
DurationLabel
String
Tablespace
String
LongTablespace
String

Description

Automatically generate a range of table partitions. PARAMETERS: StartValue as String, StartValueInclusive as Boolean, EndValue as String, EndValueInclusive as Boolean, RangeWidth as Number, DurationLabel as String, Tablespace as String, Long Tablespace as Stri?U?K??

Syntax

Visual Basic
Public Sub AddRange( _
   ByVal StartValue As Variant, _
   ByVal StartValueInclusive As Variant, _
   ByVal EndValue As Variant, _
   ByVal EndValueInclusive As Variant, _
   ByVal RangeWidth As Variant, _
   ByVal DurationLabel As Variant, _
   ByVal Tablespace As Variant, _
   ByVal LongTablespace As Variant _
)

Parameters

StartValue
String
StartValueInclusive
Boolean
EndValue
String
EndValueInclusive
Boolean
RangeWidth
Number
DurationLabel
String
Tablespace
String
LongTablespace
String

Return Type

None

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

DeleteColumnFromDistributionKey Method
Name

Description

Use to delete a column from the distribution key. Cannot delete last column in key. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub DeleteColumnFromDistributionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

DeleteColumnFromPartitionKey Method
Name

Description

Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub DeleteColumnFromPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

DeleteDistributionKey Method

Description

Use this method to delete all columns in the distribution key. This also deletes all distributions key. This method applies only to IBM DB2 UDB 9.x.

Syntax

Visual Basic
Public Sub DeleteDistributionKey()

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

DeletePartitionKey Method

Description

Use this method to delete all columns in the partition key. This also deletes all partitions key.

Syntax

Visual Basic
Public Sub DeletePartitionKey()

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

GetDistributionColumnNumber Method
Name

Description

Looks for the column in the distribution key. If it finds it, it returns the column's number. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name of the distribution column as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetDistributionColumnNumber( _
   ByVal Name As Variant _
) As Long

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

GetNullsOrderForPartitionColumn Method
Name

Description

Looks for the column in the partition key. If it finds it, it returns the column's Nulls Order. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function GetNullsOrderForPartitionColumn( _
   ByVal Name As Variant _
) As Variant

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

GetPartitionColumnNumber Method
Name

Description

Looks for the column in the partition key. If it finds it, it returns the column's number. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetPartitionColumnNumber( _
   ByVal Name As Variant _
) As Long

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Remove a TableRangePartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

RemoveByName Method
Name

Description

Remove the TableRangePartition specified by the given Name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub RemoveByName( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

SetDistributionColumnNumber Method
Name
Number

Description

Use to change the sequence of the columns in the partition key by setting the number of a column. This method applies only to IBM DB2 UDB 9.x. PARAMETERS: Name of the partition column as String, Number as Integer .

Syntax

Visual Basic
Public Sub SetDistributionColumnNumber( _
   ByVal Name As Variant, _
   ByVal Number As Variant _
)

Parameters

Name
Number

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

SetNullsOrderForPartitionColumn Method
Name
NullsOrder

Description

Use to set the Nulls Order for the given column (if the column is found in the partition key). PARAMETERS: Name of the partition column as String, Nulls Order as String .

Syntax

Visual Basic
Public Sub SetNullsOrderForPartitionColumn( _
   ByVal Name As Variant, _
   ByVal NullsOrder As Variant _
)

Parameters

Name
NullsOrder

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

SetPartitionColumnNumber Method
Name
Number

Description

Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer .

Syntax

Visual Basic
Public Sub SetPartitionColumnNumber( _
   ByVal Name As Variant, _
   ByVal Number As Variant _
)

Parameters

Name
Number

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2UDBTableRangePartitions object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBTableRangePartition

Parameters

Identifier

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DB2UDBTableRangePartitions objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

GetDistributionKeyColumns Property

Description

This is the string with the names of the columns in the DistributionKey as a comma separated list in sequence order.This property applies only to IBM DB2 UDB 9.x. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetDistributionKeyColumns() As Variant

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

GetPartitionKeyColumns Property

Description

This is the string with the names of the columns in the PartitionKey as a comma separated list in sequence order. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetPartitionKeyColumns() As Variant

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2UDBTableRangePartitions object specified by the given Identifier (GUID or Number). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBTableRangePartition

Parameters

Identifier

See Also

DB2UDBTableRangePartitions Collection


%%PageItemTitle%%

DB2UDBTablespace Object
See Also Members

Description

This object represents a DB2 UDB Tablespace in ER/Studio. It is stored as its create statement.

Object Model

See Also

DB2UDBTablespace Members


%%PageItemTitle%% $$Members$$

DB2UDBTablespace Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method DB2UDBContainersDMS | If the given Tablespace is database managed, this returns the DMS Containers.
Public Method DB2UDBContainersSMS | If the given Tablespace is system managed, this returns the SMS Containers.
Public Method UserComments | Returns the user comment collection associated with this Object.

Public Properties

Public Property BufferPool | Holds the name of the BufferPool associated with the Tablespace. DATATYPE: String.
Public Property Description | This is the Description of the Tablespace. DATATYPE: String.
Public Property ExtentSize | Represents the ExtentSize (the number of 4k pages written to a container before skipping to the next). DATATYPE: Integer.
Public Property GUID | This is the GUID of the Tablespace. DATATYPE: String.
Public Property ID | Returns the DB2 UDB BufferPool's ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the DB2 UDB BufferPool. DATATYPE: String.
Public Property NodeGroup | Holds the name of the NodeGroup associated with the Tablespace. DATATYPE: String.
Public Property Overhead | Represents the Overhead of the Tablespace in milliseconds (I/O Controller, disk seek, and latency time. DATATYPE: String.
Public Property PageSize | Specifies the page size of the Tablespace in kilobytes. Sizes of 0 (default), 4, 8, 16 and 32 are valid. DATATYPE: Integer.
Public Property PrefetchSize | Represents the PrefetchSize (the number of pages read for prefetching). DATATYPE: Integer.
Public Property RecoveryStatus | Specifies the recovery status of the Tablespace. An empty string, ON, and OFF are valid. DATATYPE: String.
Public Property SystemManaged | Returns True if the Tablespace is SystemManaged (SMS) or False if it is DatabaseManaged (DMS). DATATYPE: Boolean.
Public Property TransferRate | Represents the time (in milliseconds) required to read one 4K Page into memory. DATATYPE: String.
Public Property Type | Represents the Tablespace Type (REGULAR, LONG or TEMPORARY). DATATYPE: String.

See Also

DB2UDBTablespace Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

DB2UDBContainersDMS Method

Description

If the given Tablespace is database managed, this returns the DMS Containers.

Syntax

Visual Basic
Public Function DB2UDBContainersDMS() As DB2UDBContainersDMS

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

DB2UDBContainersSMS Method

Description

If the given Tablespace is system managed, this returns the SMS Containers.

Syntax

Visual Basic
Public Function DB2UDBContainersSMS() As DB2UDBContainersSMS

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comment collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

BufferPool Property

Description

Holds the name of the BufferPool associated with the Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferPool() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

ExtentSize Property

Description

Represents the ExtentSize (the number of 4k pages written to a container before skipping to the next). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExtentSize() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Tablespace. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

ID Property

Description

Returns the DB2 UDB BufferPool's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the DB2 UDB BufferPool. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

NodeGroup Property

Description

Holds the name of the NodeGroup associated with the Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property NodeGroup() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

Overhead Property

Description

Represents the Overhead of the Tablespace in milliseconds (I/O Controller, disk seek, and latency time. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Overhead() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

PageSize Property

Description

Specifies the page size of the Tablespace in kilobytes. Sizes of 0 (default), 4, 8, 16 and 32 are valid. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageSize() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

PrefetchSize Property

Description

Represents the PrefetchSize (the number of pages read for prefetching). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrefetchSize() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

RecoveryStatus Property

Description

Specifies the recovery status of the Tablespace. An empty string, ON, and OFF are valid. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecoveryStatus() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

SystemManaged Property

Description

Returns True if the Tablespace is SystemManaged (SMS) or False if it is DatabaseManaged (DMS). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SystemManaged() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

TransferRate Property

Description

Represents the time (in milliseconds) required to read one 4K Page into memory. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TransferRate() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

Type Property

Description

Represents the Tablespace Type (REGULAR, LONG or TEMPORARY). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

DB2UDBTablespace Object


%%PageItemTitle%%

DB2UDBTablespaces Collection
See Also Members

Description

This object represents a collection of DB2UDBTablespaces. The owner of this collection is the Model.

Object Model

See Also

DB2UDBTablespaces Members


%%PageItemTitle%% $$Members$$

DB2UDBTablespaces Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new DB2UDBTablespace and adds it to the collection. PARAMETERS: Name and FilePath (String) and SystemManaged (Boolean).
Public Method AddWithPosition | Creates a new DB2UDBTablespace with the given coordinates. PARAMETERS: Name and FilePath (String), SystemManaged (Boolean), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a Tablespace object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DB2UDBTablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Tablespaces in the collection. DATATYPE: Integer.
Public Property Item | Returns a DB2UDBTablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DB2UDBTablespaces Overview


%%PageItemTitle%%

Add Method
Name
FilePath
SystemManaged

Description

Creates and returns a new DB2UDBTablespace and adds it to the collection. PARAMETERS: Name and FilePath (String) and SystemManaged (Boolean).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal FilePath As Variant, _
   ByVal SystemManaged As Variant _
) As DB2UDBTablespace

Parameters

Name
FilePath
SystemManaged

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

AddWithPosition Method
Name
FilePath
SystemManaged
HorizontalPosition
VerticalPosition

Description

Creates a new DB2UDBTablespace with the given coordinates. PARAMETERS: Name and FilePath (String), SystemManaged (Boolean), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal FilePath As Variant, _
   ByVal SystemManaged As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As DB2UDBTablespace

Parameters

Name
FilePath
SystemManaged
HorizontalPosition
VerticalPosition

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Tablespace object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DB2UDBTablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DB2UDBTablespace

Parameters

Identifier

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Tablespaces in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DB2UDBTablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DB2UDBTablespace

Parameters

Identifier

See Also

DB2UDBTablespaces Collection


%%PageItemTitle%%

DBRole Object
See Also Members

Description

This represents a Database Role in ER/Studio.

Object Model

See Also

DBRole Members


%%PageItemTitle%% $$Members$$

DBRole Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comment collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the DBRole. DATATYPE: String.
Public Property GUID | This is the GUID of the DBRole. DATATYPE: String.
Public Property ID | DBRole ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding DBRole. DATATYPE: Integer.
Public Property IdentificationType | This is the IdentificationType of the DBRole. DATATYPE: Integer.
Public Property Name | This is the name of the DBRole. DATATYPE: String.
Public Property Password | This is the Password of the DBRole. DATATYPE: String.

See Also

DBRole Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DBRole Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comment collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DBRole Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DBRole. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DBRole Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DBRole. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DBRole Object


%%PageItemTitle%%

ID Property

Description

DBRole ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding DBRole. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DBRole Object


%%PageItemTitle%%

IdentificationType Property

Description

This is the IdentificationType of the DBRole. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentificationType() As Variant

See Also

DBRole Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DBRole. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DBRole Object


%%PageItemTitle%%

Password Property

Description

This is the Password of the DBRole. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Password() As Variant

See Also

DBRole Object


%%PageItemTitle%%

DBRoles Collection
See Also Members

Description

This object represents a collection of Database Roles in ER/Studio. The owner of the collection is the Model.

Object Model

See Also

DBRoles Members


%%PageItemTitle%% $$Members$$

DBRoles Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a DBRole with the given data. PARAMETERS: Name as String, IdentificationType as Integer, Password as String, Description As String.
Public Method Remove | Deletes an DBRole object specified by the given ID or name from ER/Studio. PARAMETERS: Identifier as Integer.

Public Properties

Public Property _Item | This method returns a DBRole specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of DBRole objects in the collection. DATATYPE: Integer.
Public Property Item | This method returns a DBRole specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

See Also

DBRoles Overview


%%PageItemTitle%%

Add Method
Name
IdentificationType
Password
Description

Description

Creates a DBRole with the given data. PARAMETERS: Name as String, IdentificationType as Integer, Password as String, Description As String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal IdentificationType As Variant, _
   ByVal Password As Variant, _
   ByVal Description As Variant _
) As DBRole

Parameters

Name
IdentificationType
Password
Description

See Also

DBRoles Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DBRole object specified by the given ID or name from ER/Studio. PARAMETERS: Identifier as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DBRoles Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

This method returns a DBRole specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DBRole

Parameters

Identifier

See Also

DBRoles Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DBRoles Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DBRole objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DBRoles Collection


%%PageItemTitle%%

Item Property
Identifier

Description

This method returns a DBRole specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DBRole

Parameters

Identifier

See Also

DBRoles Collection


%%PageItemTitle%%

DBSchema Object
See Also Members

Description

This represents a Database Schema in ER/Studio.

Object Model

See Also

DBSchema Members


%%PageItemTitle%% $$Members$$

DBSchema Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns the collection of user comments associated with this object.

Public Properties

Public Property Authorization | This is the Password of the DBSchema. DATATYPE: String.
Public Property Description | This is the Description of the DBSchema. DATATYPE: String.
Public Property GUID | This is the GUID of the DBSchema. DATATYPE: String.
Public Property ID | DBSchema ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding DBSchema. DATATYPE: Integer.
Public Property Name | This is the name of the DBSchema. DATATYPE: String.

See Also

DBSchema Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DBSchema Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

DBSchema Object


%%PageItemTitle%%

UserComments Method

Description

Returns the collection of user comments associated with this object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DBSchema Object


%%PageItemTitle%%

Authorization Property

Description

This is the Password of the DBSchema. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Authorization() As Variant

See Also

DBSchema Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DBSchema. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DBSchema Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DBSchema. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DBSchema Object


%%PageItemTitle%%

ID Property

Description

DBSchema ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding DBSchema. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DBSchema Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DBSchema. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DBSchema Object


%%PageItemTitle%%

DBSchemas Collection
See Also Members

Description

This object represents a collection of Database Schemas in ER/Studio. The owner of the collection is the Model.

Object Model

See Also

DBSchemas Members


%%PageItemTitle%% $$Members$$

DBSchemas Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a DBSchema with the given data. PARAMETERS: Name as String, Authorization as String, Description As String.
Public Method Remove | Deletes an DBSchema object specified by the given ID or name from ER/Studio. PARAMETERS: Identifier as Integer.

Public Properties

Public Property _Item | This method returns a DBSchema specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of DBSchema objects in the collection. DATATYPE: Integer.
Public Property Item | This method returns a DBSchema specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

See Also

DBSchemas Overview


%%PageItemTitle%%

Add Method
Name
Authorization
Description

Description

Creates a DBSchema with the given data. PARAMETERS: Name as String, Authorization as String, Description As String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Authorization As Variant, _
   ByVal Description As Variant _
) As DBSchema

Parameters

Name
Authorization
Description

See Also

DBSchemas Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DBSchema object specified by the given ID or name from ER/Studio. PARAMETERS: Identifier as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DBSchemas Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

This method returns a DBSchema specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DBSchema

Parameters

Identifier

See Also

DBSchemas Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DBSchemas Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DBSchema objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DBSchemas Collection


%%PageItemTitle%%

Item Property
Identifier

Description

This method returns a DBSchema specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DBSchema

Parameters

Identifier

See Also

DBSchemas Collection


%%PageItemTitle%%

DBUser Object
See Also Members

Description

This represents a Database User in ER/Studio.

Object Model

See Also

DBUser Members


%%PageItemTitle%% $$Members$$

DBUser Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comment collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the DBUser. DATATYPE: String.
Public Property ExternalName | This is the ExternalName of the DBUser. DATATYPE: String.
Public Property GUID | This is the GUID of the DBUser. DATATYPE: String.
Public Property ID | DBUser ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding DBUser. DATATYPE: Integer.
Public Property IsGroup | This indicates if this DBUser contains Group specific settings. DATATYPE: Boolean.
Public Property Name | This is the name of the DBUser. DATATYPE: String.
Public Property OracleDefaultTablespace | This is the oracle default tablespace of the DBUser. DATATYPE: String. It only applies to Oracle platforms.
Public Property OracleTemporaryTablespace | This is the oracle temporary tablespace of the DBUser. DATATYPE: String. It only applies to Oracle platforms.
Public Property Password | This is the Password of the DBUser. DATATYPE: String.

See Also

DBUser Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

DBUser Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comment collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DBUser Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the DBUser. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

DBUser Object


%%PageItemTitle%%

ExternalName Property

Description

This is the ExternalName of the DBUser. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalName() As Variant

See Also

DBUser Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the DBUser. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DBUser Object


%%PageItemTitle%%

ID Property

Description

DBUser ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding DBUser. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DBUser Object


%%PageItemTitle%%

IsGroup Property

Description

This indicates if this DBUser contains Group specific settings. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsGroup() As Variant

See Also

DBUser Object


%%PageItemTitle%%

Name Property

Description

This is the name of the DBUser. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DBUser Object


%%PageItemTitle%%

OracleDefaultTablespace Property

Description

This is the oracle default tablespace of the DBUser. DATATYPE: String. It only applies to Oracle platforms.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleDefaultTablespace() As Variant

See Also

DBUser Object


%%PageItemTitle%%

OracleTemporaryTablespace Property

Description

This is the oracle temporary tablespace of the DBUser. DATATYPE: String. It only applies to Oracle platforms.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleTemporaryTablespace() As Variant

See Also

DBUser Object


%%PageItemTitle%%

Password Property

Description

This is the Password of the DBUser. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Password() As Variant

See Also

DBUser Object


%%PageItemTitle%%

DBUsers Collection
See Also Members

Description

This object represents a collection of Database Users in ER/Studio. The owner of the collection is the Model.

Object Model

See Also

DBUsers Members


%%PageItemTitle%% $$Members$$

DBUsers Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a DBUser with the given data. PARAMETERS: Name as String, ExternalName as String, Password as String, Description as String.
Public Method Remove | Deletes an DBUser object specified by the given ID or name from ER/Studio. PARAMETERS: Identifier as Integer.

Public Properties

Public Property _Item | This method returns a DBUser specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of DBUser objects in the collection. DATATYPE: Integer.
Public Property Item | This method returns a DBUser specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

See Also

DBUsers Overview


%%PageItemTitle%%

Add Method
Name
ExternalName
Password
Description

Description

Creates a DBUser with the given data. PARAMETERS: Name as String, ExternalName as String, Password as String, Description as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal ExternalName As Variant, _
   ByVal Password As Variant, _
   ByVal Description As Variant _
) As DBUser

Parameters

Name
ExternalName
Password
Description

See Also

DBUsers Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an DBUser object specified by the given ID or name from ER/Studio. PARAMETERS: Identifier as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DBUsers Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

This method returns a DBUser specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DBUser

Parameters

Identifier

See Also

DBUsers Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DBUsers Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DBUser objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DBUsers Collection


%%PageItemTitle%%

Item Property
Identifier

Description

This method returns a DBUser specified by the given ID, GUID or name. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DBUser

Parameters

Identifier

See Also

DBUsers Collection


%%PageItemTitle%%

DDLGeneration Object
See Also Members

Description

This object represents a DDLGeneration object that provides an interface for generating the DDL for the model.

Object Model

See Also

DDLGeneration Members


%%PageItemTitle%% $$Members$$

DDLGeneration Object Members
See Also Overview

Public Methods

Public Method EnhGenerateFKConstraints | Generate FK Constraints. GenType: 0=Don't generate, 1=Generate by Create Table, 2=Generate by Alter Table. PARAMETERS: GenType as Integer, DependencyOrder as Boolean.
Public Method GenDDLUsingFileBasedQuickLaunch | Generate DDL using the Quick Launch setting identified by the given filename. PARAMETERS: FileName as Strings.
Public Method GenDDLUsingQuickLaunch | Generate DDL using the Quick Launch setting identified by the given name. PARAMETERS: Name as Strings.
Public Method GenerateAllEntities | Set a flag to generate all Entities.
Public Method GenerateAllStoredProcedures | Set a flag to generate all Stored Procedures.
Public Method GenerateAllTriggers | Set a flag to generate all Triggers.
Public Method GenerateDDL | Generate the DDL, and return TRUE for success or FALSE for failure. RETURN DATATYPE: Boolean.
Public Method GenerateFKConstraintNames | Generate FK Constraint Names when GenerateNames is TRUE. If SupplyNames is TRUE, unnamed FK are given unique names. PARAMETERS: GenerateNames as Boolean, SupplyNames as Boolean.
Public Method GenerateNoEntities | Set a flag to not generate any Entities.
Public Method GenerateNoStoredProcedures | Set a flag to not generate any Stored Procedures.
Public Method GenerateNoTriggers | Set a flag to not generate any Triggers.
Public Method GenerateSelectedEntities | Set a flag to generate selected Entities, according to Entity names given in the parameter array. PARAMETERS: EntityNames as VariantArray of Strings.
Public Method GenerateSelectedStoredProcedures | Set a flag to generate selected Stored Procedures, according to Procedure names given in the parameter array. PARAMETERS: StoredProcedureNames as VariantArray of Strings.
Public Method GenerateSelectedTriggers | Set a flag to generate selected Triggers, according to Trigger names given in the parameter array. PARAMETERS: TriggerNames as VariantArray of Strings.
Public Method GetQuickLaunchList | Return all the names of available Quick Launch settings for the Model. RETURN DATATYPE: StringObjects.

Public Properties

Public Property AlternateKeyConstraintType | Set how Alternate Key is generated. 0 - don't generate, 1 - unique index, 2 - unique constraint. DATATYPE: Integer.
Public Property BufferPool | Enable/Disable Storage option - BufferPool. DATATYPE: Boolean.
Public Property ConnectionName | This is the Connection Name for generating DB objects. DATATYPE: String.
Public Property CreateNewDatabase | Create a new Database. DATATYPE: Boolean.
Public Property CreationScriptFilePath | This is the path to the Database creation script file. DATATYPE: String.
Public Property DatabaseDeviceFilename | Database Device Filename for new database. DATATYPE: String.
Public Property DatabaseLogin | Database Login for new database. DATATYPE: String.
Public Property DatabaseName | DATATYPE: String. Database name for new database.
Public Property DatabasePassword | Database Password for new database. DATATYPE: String.
Public Property DataDeviceName | Data Device Name for new database. DATATYPE: String.
Public Property DataDeviceSize | Data Device Size for new database. DATATYPE: Integer.
Public Property DataSourceName | This is the Data Source Name for generating DB objects. DATATYPE: String.
Public Property DropObjects | This is the Drop Object flag. DATATYPE: Boolean.
Public Property EnforceFKCreation | Flag to indicate if Foreign Key creation should be enforced. DATATYPE: Boolean.
Public Property ExtentGrowthFactor | Enable/Disable Storage option - ExtentGrowthFactor. DATATYPE: Boolean.
Public Property Fillfactor | Enable/Disable Storage option - FillFactor. DATATYPE: Boolean.
Public Property FreeListGroups | Enable/Disable Storage option - FreeListGroups. DATATYPE: Boolean.
Public Property FreeLists | Enable/Disable Storage option - FreeLists. DATATYPE: Boolean.
Public Property GenAliasComment | This is the generate Alias Comment flag. DATATYPE: Boolean.
Public Property GenAliasCreateStatement | This is the generate Alias Create Statement flag. DATATYPE: Boolean.
Public Property GenAliasDropStatement | This is the generate Alias Drop Statement flag. DATATYPE: Boolean.
Public Property GenAllOwnerNames | This is the generate All Owner Names flag. DATATYPE: Boolean.
Public Property GenAuxTableComment | This is the generate AuxTable Comment flag. DATATYPE: Boolean.
Public Property GenAuxTableCreateStatement | This is the generate AuxTable Create Statement flag. DATATYPE: Boolean.
Public Property GenAuxTableDropStatement | This is the generate AuxTable Drop Statement flag. DATATYPE: Boolean.
Public Property GenBufferPoolComment | This is the generate BufferPool Comment flag. DATATYPE: Boolean.
Public Property GenBufferpoolCreateStatement | This is the generate Bufferpool Create Statement flag. DATATYPE: Boolean.
Public Property GenBufferPoolDropStatement | This is the generate BufferPool Drop Statement flag. DATATYPE: Boolean.
Public Property GenCloseDataset | This is the generate Close Dataset flag. DATATYPE: Boolean.
Public Property GenColConstraintName | This is the generate Column Constraint Name flag. DATATYPE: Boolean.
Public Property GenColDefaultName | This is the generate Column Default Name flag. DATATYPE: Boolean.
Public Property GenCommitStatement | This is the generate Commit Statement flag. DATATYPE: Boolean.
Public Property GenDB2DatabaseComment | This is the generate DB2Database Comment flag. DATATYPE: Boolean.
Public Property GenDB2DatabaseCreateStatement | This is the generate DB2Database Create Statement flag. DATATYPE: Boolean.
Public Property GenDB2DatabaseDropStatement | This is the generate DB2Database Drop Statement flag. DATATYPE: Boolean.
Public Property GenDefaultDropStatement | This is the generate Default Drop Statement flag. DATATYPE: Boolean.
Public Property GenDefaultTableStoredProcedures | This is the generate Default Table Stored Procedures flag. DATATYPE: Boolean.
Public Property GenerateAliases | This is the generate Aliases flag. DATATYPE: Boolean.
Public Property GenerateAuxTables | This is the generate AuxTables flag. DATATYPE: Boolean.
Public Property GenerateBufferpools | This is the generate Bufferpools flag. DATATYPE: Boolean.
Public Property GenerateColumnComment | This is the generate Column Comment flag. DATATYPE: Boolean.
Public Property GenerateColumnConstraint | This is the generate Column Constraint flag. DATATYPE: Boolean.
Public Property GenerateColumnDefault | This is the generate Column Default flag. DATATYPE: Boolean.
Public Property GenerateColumnLabel | This is the generate Column Label flag. DATATYPE: Boolean.
Public Property GenerateDatabaseMethod | Set the method of creating the Database. 1 - single file, 2 - ODBC, 3 - Direct Connection, 4 - multiple files. DATATYPE: Integer.
Public Property GenerateDB2Databases | This is the generate DB2Databases flag. DATATYPE: Boolean.
Public Property GenerateDefaults | Enable/Disable generation of Defaults. DATATYPE: Boolean.
Public Property GenerateFKConstraints | Flag to indicate if Foreign Key Constraints should be generated. DATATYPE: Boolean.
Public Property GenerateIndexes | This is the generate Indexes flag. DATATYPE: Boolean.
Public Property GenerateLogicalFKs | Flag to indicate if Logical Foreign Keys should be generated. DATATYPE: Boolean.
Public Property GenerateLogicalPK | This is the generate Logical PK flag. DATATYPE: Boolean.
Public Property GenerateMaterializedQueryTables | This is the generate MaterializedQueryTables flag. DATATYPE: Boolean.
Public Property GenerateMaterializedViews | This is the generate MaterializedViews flag. DATATYPE: Boolean.
Public Property GenerateNodegroups | This is the generate Nodegroups flag. DATATYPE: Boolean.
Public Property GenerateNonUniqueIndexes | Flag to indicate if defined NonUnique Indexes should be generated. DATATYPE: Boolean.
Public Property GeneratePKByAlterStatement | This is the generate PK by Alter statement flag. DATATYPE: Boolean.
Public Property GeneratePKByAlterStatementAndUniqueIndex | This is the generate PK by Alter statement and unique index flag. DATATYPE: Boolean.
Public Property GenerateRollbackSegments | This is the generate RollbackSegments flag. DATATYPE: Boolean.
Public Property GenerateRules | Enable/Disable generation of Rules. DATATYPE: Boolean.
Public Property GenerateSequences | This is the generate Sequences flag. DATATYPE: Boolean.
Public Property GenerateStoGroups | This is the generate StoGroups flag. DATATYPE: Boolean.
Public Property GenerateSynonyms | This is the generate Synonyms flag. DATATYPE: Boolean.
Public Property GenerateSystemTriggers | This is the generate System Triggers flag. DATATYPE: Boolean.
Public Property GenerateTableCheckConstraints | Enable/Disable generation of Table CheckConstraints. DATATYPE: Boolean.
Public Property GenerateTableComment | This is the generate Table Comment flag. DATATYPE: Boolean.
Public Property GenerateTableCreateStatement | This is the generate PK by Alter statement flag. DATATYPE: Boolean.
Public Property GenerateTablePostSQL | This is the generate Table PostSQL statement flag. DATATYPE: Boolean.
Public Property GenerateTablePreSQL | This is the generate Table Pre SQL statement flag. DATATYPE: Boolean.
Public Property GenerateTablespaces | This is the generate Tablespaces flag. DATATYPE: Boolean.
Public Property GenerateUserDatatypes | Enable/Disable generation of UserDatatypes. DATATYPE: Boolean.
Public Property GenerateViews | Enable/Disable generation of Views. DATATYPE: Boolean.
Public Property GenFKDropStatement | This is the generate FK Drop Statement flag. DATATYPE: Boolean.
Public Property GenForceBackticks | This is the generate Force Backticks flag. DATATYPE: Boolean.
Public Property GenForceBrackets | This is the generate Force Brackets flag. DATATYPE: Boolean.
Public Property GenForceQuotes | This is the generate Force Quotes flag. DATATYPE: Boolean.
Public Property GenFunctionComment | This is the generate Function Comment flag. DATATYPE: Boolean.
Public Property GenFunctionCreateStatement | This is the generate Function Create Statement flag. DATATYPE: Boolean.
Public Property GenFunctionDropStatement | This is the generate Function Drop Statement flag. DATATYPE: Boolean.
Public Property GenIncludeObjHeader | This is the generate Include Object Header flag. DATATYPE: Boolean.
Public Property GenIndexDropStatement | This is the generate Drop statement flag for indexes. DATATYPE: Boolean.
Public Property GenIndexStorageBufferPool | This is the generate BufferPool property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageExtentGrowthFactor | This is the generate ExtentGrowthFactor property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageFillFactor | This is the generate FillFactor property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageFreeList | This is the generate FreeList property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageFreeListGroups | This is the generate FreeListGroups property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageInclude | This is the generate Include property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageInitialExtentSize | This is the generate InitialExtentSize property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageLocation | This is the generate Location property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageLockMode | This is the generate LockMode property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageLogging | This is the generate Logging property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageMaxExtents | This is the generate MaxExtents property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageMaxRowsPerPage | This is the generate MaxRowsPerPage property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageMaxTransactions | This is the generate MaxTransactions property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageMinExtents | This is the generate MinExtents property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageMinTransactions | This is the generate MinTransactions property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageNextExtentSize | This is the generate NextExtentSize property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStoragePadIndex | This is the generate PadIndex property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageParallel | This is the generate Parallel property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStoragePctFree | This is the generate PctFree property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStoragePctUsed | This is the generate PctUsed property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageReverseScans | This is the generate ReverseScans property of Index Storage. DATATYPE: Boolean.
Public Property GenIndexStorageSortTempDB | This is the generate SortTempDB property of Index Storage. DATATYPE: Boolean.
Public Property GenKeywordBackticks | This is the generate Keyword Backticks flag. DATATYPE: Boolean.
Public Property GenKeywordBrackets | This is the generate Keyword Brackets flag. DATATYPE: Boolean.
Public Property GenKeywordQuotes | This is the generate Keyword Quotes flag. DATATYPE: Boolean.
Public Property GenLOBSegments | This is the generate LOB Segments flag. DATATYPE: Boolean.
Public Property GenMaterializedQueryTableComment | This is the generate MaterializedQueryTable Comment flag. DATATYPE: Boolean.
Public Property GenMaterializedQueryTableCreateStatement | This is the generate MaterializedQueryTable Create Statement flag. DATATYPE: Boolean.
Public Property GenMaterializedQueryTableDropStatement | This is the generate MaterializedQueryTable Drop Statement flag. DATATYPE: Boolean.
Public Property GenMaterializedViewPostSQL | This is the Generate Materialized View Post SQL flag. DATATYPE: Boolean.
Public Property GenMaterializedViewPreSQL | This is the Generate Materialized View Pre SQL flag. DATATYPE: Boolean.
Public Property GenMatViewComment | This is the generate MaterializedView Comment flag. DATATYPE: Boolean.
Public Property GenMatViewCreateStatement | This is the generate MaterializedView Create Statement flag. DATATYPE: Boolean.
Public Property GenMatViewDropStatement | This is the generate MaterializedView Drop Statement flag. DATATYPE: Boolean.
Public Property GenModelPostSQL | This is the generate Model PostSQL flag. DATATYPE: Boolean.
Public Property GenModelPreSQL | This is the generate Model PreSQL flag. DATATYPE: Boolean.
Public Property GenNodeGroupComment | This is the generate NodeGroup Comment flag. DATATYPE: Boolean.
Public Property GenNodeGroupCreateStatement | This is the generate NodeGroup Create Statement flag. DATATYPE: Boolean.
Public Property GenNodeGroupDropStatement | This is the generate NodeGroup Drop Statement flag. DATATYPE: Boolean.
Public Property GenObjectTypeComment | This is the generate ObjectType Comment flag. DATATYPE: Boolean.
Public Property GenObjectTypeCreateStatement | This is the generate ObjectType Create Statement flag. DATATYPE: Boolean.
Public Property GenObjectTypeDropStatement | This is the generate ObjectType Drop Statement flag. DATATYPE: Boolean.
Public Property GenPackageComment | This is the generate Package Comment flag. DATATYPE: Boolean.
Public Property GenPackageCreateStatement | This is the generate Package Create Statement flag. DATATYPE: Boolean.
Public Property GenPackageDropStatement | This is the generate Package Drop Statement flag. DATATYPE: Boolean.
Public Property GenProcCreateStatement | This is the generate Procedure Create Statement flag. DATATYPE: Boolean.
Public Property GenProcDropStatement | This is the generate Procedure Drop Statement flag. DATATYPE: Boolean.
Public Property GenProcedureComment | This is the generate Procedure Comment flag. DATATYPE: Boolean.
Public Property GenRBSegmentComment | This is the generate RollBackSegment Comment flag. DATATYPE: Boolean.
Public Property GenRBSegmentCreateStatement | This is the generate RollBackSegment Create Statement flag. DATATYPE: Boolean.
Public Property GenRBSegmentDropStatement | This is the generate RollBackSegment Drop Statement flag. DATATYPE: Boolean.
Public Property GenRuleDropStatement | This is the generate Rule Drop Statement flag. DATATYPE: Boolean.
Public Property GenSequenceComment | This is the generate Sequence Comment flag. DATATYPE: Boolean.
Public Property GenSequenceCreateStatement | This is the generate Sequence Create Statement flag. DATATYPE: Boolean.
Public Property GenSequenceDropStatement | This is the generate Sequence Drop Statement flag. DATATYPE: Boolean.
Public Property GenSequencePostSQL | This is the Generate Sequence Post SQL flag. DATATYPE: Boolean.
Public Property GenSequencePreSQL | This is the Generate Sequence Pre SQL flag. DATATYPE: Boolean.
Public Property GenStoGroupComment | This is the generate StoGroup Comment flag. DATATYPE: Boolean.
Public Property GenStoGroupCreateStatement | This is the generate StoGroup Create Statement flag. DATATYPE: Boolean.
Public Property GenStoGroupDropStatement | This is the generate StoGroup Drop Statement flag. DATATYPE: Boolean.
Public Property GenSynonymComment | This is the generate Synonym Comment flag. DATATYPE: Boolean.
Public Property GenSynonymCreateStatement | This is the generate Synonym Create Statement flag. DATATYPE: Boolean.
Public Property GenSynonymDropStatement | This is the generate Synonym Drop Statement flag. DATATYPE: Boolean.
Public Property GenTableConstraintName | This is the generate Table Constraint Name flag. DATATYPE: Boolean.
Public Property GenTablespaceComment | This is the generate Tablespace Comment flag. DATATYPE: Boolean.
Public Property GenTablespaceCreateStatement | This is the generate Tablespace Create Statement flag. DATATYPE: Boolean.
Public Property GenTablespaceDropStatement | This is the generate Tablespace Drop Statement flag. DATATYPE: Boolean.
Public Property GenTableStorageAuditOptions | This is the generate AuditOptions property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageCacheStrategy | This is the generate CacheStrategy property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageDataBlockSize | This is the generate DataBlockSize property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageEncoding | This is the generate Encoding property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageFallback | This is the generate Fallback property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageIdentityGap | This is the generate IdentityGap property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageIndexTablespace | This is the generate IndexTablespace property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageJournaling | This is the generate Journaling property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageLogDataChanges | This is the generate LogDataChanges property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageLogging | This is the generate Logging property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageLongTablespace | This is the generate LongTablespace property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageNotLogInitially | This is the generate NotLoggedInitially property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageOrganization | This is the generate Organization property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageParallel | This is the generate Parallel property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageReservePageGap | This is the generate ReservePageGap property of Table Storage. DATATYPE: Boolean.
Public Property GenTableStorageRestrictOnDrop | This is the generate RestrictOnDrop property of Table Storage. DATATYPE: Boolean.
Public Property GenTriggerCreateStatement | This is the generate Trigger Create Statement flag. DATATYPE: Boolean.
Public Property GenTriggerDropStatement | This is the generate Trigger Drop Statementt flag. DATATYPE: Boolean.
Public Property GenUserDatatypeDropStatement | This is the generate UserDatatype Drop Statement flag. DATATYPE: Boolean.
Public Property GenVerifyStatement | This is the generate Verify Statement flag. DATATYPE: Boolean.
Public Property GenViewCreateStatement | This is the generate View Create Statement flag. DATATYPE: Boolean.
Public Property GenViewDropStatement | This is the generate View Drop Statement flag. DATATYPE: Boolean.
Public Property GenViewPostSQL | This is the generate View PostSQL flag. DATATYPE: Boolean.
Public Property GenViewPreSQL | This is the generate View PreSQL flag. DATATYPE: Boolean.
Public Property IndexPartitions | Enable/Disable Storage option - IndexPartitions. DATATYPE: Boolean.
Public Property InitialExtentSize | Enable/Disable Storage option - InitialExtentSize. DATATYPE: Boolean.
Public Property Location | Enable/Disable Storage option - Location. DATATYPE: Boolean.
Public Property LockMode | Enable/Disable Storage option - LockMode. DATATYPE: Boolean.
Public Property LogDeviceFilename | Log Device Filename for new database. DATATYPE: String.
Public Property LogDeviceName | Log Device Name for new database. DATATYPE: String.
Public Property LogDeviceSize | Log Device Size for new database. DATATYPE: Integer.
Public Property MaximumExtents | Enable/Disable Storage option - MaximumExtents. DATATYPE: Boolean.
Public Property MaximumTransactions | Enable/Disable Storage option - MaximumTransactions. DATATYPE: Boolean.
Public Property MaxRowsPerPage | Enable/Disable Storage option - MaxRowsPerPage. DATATYPE: Boolean.
Public Property MinimumExtents | Enable/Disable Storage option - MinimumExtents. DATATYPE: Boolean.
Public Property MinimumTransactions | Enable/Disable Storage option - MinimumTransactions. DATATYPE: Boolean.
Public Property NextExtentSize | Enable/Disable Storage option - NextExtentSize. DATATYPE: Boolean.
Public Property PercentFree | Enable/Disable Storage option - PercentFree. DATATYPE: Boolean.
Public Property PercentUsed | Enable/Disable Storage option - PercentUsed. DATATYPE: Boolean.
Public Property PrimaryKeyConstraintType | Set how Primary Key is generated. 0 - don't generate, 1 - unique index, 2 - PK constraint. DATATYPE: Integer.
Public Property SelectExistingDatabase | Use an existing Database. DATATYPE: Boolean.
Public Property SupplyAKConstraintName | If AK Constraint type is 2, this indicates if constraint names are supplied. DATATYPE: Boolean.
Public Property SupplyPKConstraintName | If PK Constraint type is 2, this indicates if constraint names are supplied. DATATYPE: Boolean.
Public Property TablePartitions | Enable/Disable Storage option - TablePartitions. DATATYPE: Boolean.
Public Property Username | This is the User Name for generating DB objects. DATATYPE: String.
Public Property UserPassword | This is the User Password for generating DB objects. DATATYPE: String.

See Also

DDLGeneration Overview


%%PageItemTitle%%

EnhGenerateFKConstraints Method
GenType
DependencyOrder

Description

Generate FK Constraints. GenType: 0=Don't generate, 1=Generate by Create Table, 2=Generate by Alter Table. PARAMETERS: GenType as Integer, DependencyOrder as Boolean.

Syntax

Visual Basic
Public Sub EnhGenerateFKConstraints( _
   ByVal GenType As Variant, _
   ByVal DependencyOrder As Variant _
)

Parameters

GenType
DependencyOrder

Example

Sub Main

Dim d As Diagram

Dim m As Model

Dim ddl As DDLGeneration

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

Set ddl = m.DDLGenerationObject

ddl.GenerateAllEntities = True

ddl.EnhGenerateFKConstraints(1, True)

ddl.GenerateFKConstraintNames(True, True)

ddl.GenerateDDL

End Sub

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDDLUsingFileBasedQuickLaunch Method
FileName

Description

Generate DDL using the Quick Launch setting identified by the given filename. PARAMETERS: FileName as Strings.

Syntax

Visual Basic
Public Sub GenDDLUsingFileBasedQuickLaunch( _
   ByVal FileName As Variant _
)

Parameters

FileName

Example

Sub Main

Dim d As Diagram

Dim m As Model

Dim ddl As DDLGeneration

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

Set ddl = m.DDLGenerationObject

ddl.GenDDLUsingFileBasedQuickLaunch("c:\Tmp\file.ddo")

End Sub

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDDLUsingQuickLaunch Method
Name

Description

Generate DDL using the Quick Launch setting identified by the given name. PARAMETERS: Name as Strings.

Syntax

Visual Basic
Public Sub GenDDLUsingQuickLaunch( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateAllEntities Method

Description

Set a flag to generate all Entities.

Syntax

Visual Basic
Public Sub GenerateAllEntities()

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateAllStoredProcedures Method

Description

Set a flag to generate all Stored Procedures.

Syntax

Visual Basic
Public Sub GenerateAllStoredProcedures()

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateAllTriggers Method

Description

Set a flag to generate all Triggers.

Syntax

Visual Basic
Public Sub GenerateAllTriggers()

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateDDL Method

Description

Generate the DDL, and return TRUE for success or FALSE for failure. RETURN DATATYPE: Boolean.

Syntax

Visual Basic
Public Function GenerateDDL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateFKConstraintNames Method
GenerateNames
SupplyNames

Description

Generate FK Constraint Names when GenerateNames is TRUE. If SupplyNames is TRUE, unnamed FK are given unique names. PARAMETERS: GenerateNames as Boolean, SupplyNames as Boolean.

Syntax

Visual Basic
Public Sub GenerateFKConstraintNames( _
   ByVal GenerateNames As Variant, _
   ByVal SupplyNames As Variant _
)

Parameters

GenerateNames
SupplyNames

Example

Sub Main

Dim d As Diagram

Dim m As Model

Dim ddl As DDLGeneration

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

Set ddl = m.DDLGenerationObject

ddl.GenerateAllEntities = True

ddl.EnhGenerateFKConstraints(1, True)

ddl.GenerateFKConstraintNames(True, True)

ddl.GenerateDDL

End Sub

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateNoEntities Method

Description

Set a flag to not generate any Entities.

Syntax

Visual Basic
Public Sub GenerateNoEntities()

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateNoStoredProcedures Method

Description

Set a flag to not generate any Stored Procedures.

Syntax

Visual Basic
Public Sub GenerateNoStoredProcedures()

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateNoTriggers Method

Description

Set a flag to not generate any Triggers.

Syntax

Visual Basic
Public Sub GenerateNoTriggers()

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateSelectedEntities Method
EntityNames

Description

Set a flag to generate selected Entities, according to Entity names given in the parameter array. PARAMETERS: EntityNames as VariantArray of Strings.

Syntax

Visual Basic
Public Sub GenerateSelectedEntities( _
   ByRef EntityNames As Variant _
)

Parameters

EntityNames

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateSelectedStoredProcedures Method
StoredProcedureNames

Description

Set a flag to generate selected Stored Procedures, according to Procedure names given in the parameter array. PARAMETERS: StoredProcedureNames as VariantArray of Strings.

Syntax

Visual Basic
Public Sub GenerateSelectedStoredProcedures( _
   ByRef StoredProcedureNames As Variant _
)

Parameters

StoredProcedureNames

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateSelectedTriggers Method
TriggerNames

Description

Set a flag to generate selected Triggers, according to Trigger names given in the parameter array. PARAMETERS: TriggerNames as VariantArray of Strings.

Syntax

Visual Basic
Public Sub GenerateSelectedTriggers( _
   ByRef TriggerNames As Variant _
)

Parameters

TriggerNames

See Also

DDLGeneration Object


%%PageItemTitle%%

GetQuickLaunchList Method

Description

Return all the names of available Quick Launch settings for the Model. RETURN DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function GetQuickLaunchList() As StringObjects

See Also

DDLGeneration Object


%%PageItemTitle%%

AlternateKeyConstraintType Property

Description

Set how Alternate Key is generated. 0 - don't generate, 1 - unique index, 2 - unique constraint. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property AlternateKeyConstraintType() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

BufferPool Property

Description

Enable/Disable Storage option - BufferPool. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferPool() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

ConnectionName Property

Description

This is the Connection Name for generating DB objects. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectionName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

CreateNewDatabase Property

Description

Create a new Database. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property CreateNewDatabase() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

CreationScriptFilePath Property

Description

This is the path to the Database creation script file. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CreationScriptFilePath() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DatabaseDeviceFilename Property

Description

Database Device Filename for new database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseDeviceFilename() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DatabaseLogin Property

Description

Database Login for new database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseLogin() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DatabaseName Property

Description

DATATYPE: String. Database name for new database.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DatabasePassword Property

Description

Database Password for new database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabasePassword() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DataDeviceName Property

Description

Data Device Name for new database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataDeviceName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DataDeviceSize Property

Description

Data Device Size for new database. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataDeviceSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DataSourceName Property

Description

This is the Data Source Name for generating DB objects. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataSourceName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

DropObjects Property

Description

This is the Drop Object flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DropObjects() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

EnforceFKCreation Property

Description

Flag to indicate if Foreign Key creation should be enforced. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnforceFKCreation() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

ExtentGrowthFactor Property

Description

Enable/Disable Storage option - ExtentGrowthFactor. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExtentGrowthFactor() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

Fillfactor Property

Description

Enable/Disable Storage option - FillFactor. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Fillfactor() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

FreeListGroups Property

Description

Enable/Disable Storage option - FreeListGroups. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeListGroups() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

FreeLists Property

Description

Enable/Disable Storage option - FreeLists. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeLists() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAliasComment Property

Description

This is the generate Alias Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAliasComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAliasCreateStatement Property

Description

This is the generate Alias Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAliasCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAliasDropStatement Property

Description

This is the generate Alias Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAliasDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAllOwnerNames Property

Description

This is the generate All Owner Names flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAllOwnerNames() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAuxTableComment Property

Description

This is the generate AuxTable Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAuxTableComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAuxTableCreateStatement Property

Description

This is the generate AuxTable Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAuxTableCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenAuxTableDropStatement Property

Description

This is the generate AuxTable Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAuxTableDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenBufferPoolComment Property

Description

This is the generate BufferPool Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenBufferPoolComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenBufferpoolCreateStatement Property

Description

This is the generate Bufferpool Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenBufferpoolCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenBufferPoolDropStatement Property

Description

This is the generate BufferPool Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenBufferPoolDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenCloseDataset Property

Description

This is the generate Close Dataset flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenCloseDataset() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenColConstraintName Property

Description

This is the generate Column Constraint Name flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenColConstraintName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenColDefaultName Property

Description

This is the generate Column Default Name flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenColDefaultName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenCommitStatement Property

Description

This is the generate Commit Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenCommitStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDB2DatabaseComment Property

Description

This is the generate DB2Database Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenDB2DatabaseComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDB2DatabaseCreateStatement Property

Description

This is the generate DB2Database Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenDB2DatabaseCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDB2DatabaseDropStatement Property

Description

This is the generate DB2Database Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenDB2DatabaseDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDefaultDropStatement Property

Description

This is the generate Default Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenDefaultDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenDefaultTableStoredProcedures Property

Description

This is the generate Default Table Stored Procedures flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenDefaultTableStoredProcedures() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateAliases Property

Description

This is the generate Aliases flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateAliases() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateAuxTables Property

Description

This is the generate AuxTables flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateAuxTables() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateBufferpools Property

Description

This is the generate Bufferpools flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateBufferpools() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateColumnComment Property

Description

This is the generate Column Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateColumnComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateColumnConstraint Property

Description

This is the generate Column Constraint flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateColumnConstraint() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateColumnDefault Property

Description

This is the generate Column Default flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateColumnDefault() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateColumnLabel Property

Description

This is the generate Column Label flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateColumnLabel() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateDatabaseMethod Property

Description

Set the method of creating the Database. 1 - single file, 2 - ODBC, 3 - Direct Connection, 4 - multiple files. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateDatabaseMethod() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateDB2Databases Property

Description

This is the generate DB2Databases flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateDB2Databases() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateDefaults Property

Description

Enable/Disable generation of Defaults. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateDefaults() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateFKConstraints Property

Description

Flag to indicate if Foreign Key Constraints should be generated. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateFKConstraints() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateIndexes Property

Description

This is the generate Indexes flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateIndexes() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateLogicalFKs Property

Description

Flag to indicate if Logical Foreign Keys should be generated. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateLogicalFKs() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateLogicalPK Property

Description

This is the generate Logical PK flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateLogicalPK() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateMaterializedQueryTables Property

Description

This is the generate MaterializedQueryTables flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateMaterializedQueryTables() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateMaterializedViews Property

Description

This is the generate MaterializedViews flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateMaterializedViews() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateNodegroups Property

Description

This is the generate Nodegroups flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateNodegroups() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateNonUniqueIndexes Property

Description

Flag to indicate if defined NonUnique Indexes should be generated. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateNonUniqueIndexes() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GeneratePKByAlterStatement Property

Description

This is the generate PK by Alter statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GeneratePKByAlterStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GeneratePKByAlterStatementAndUniqueIndex Property

Description

This is the generate PK by Alter statement and unique index flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GeneratePKByAlterStatementAndUniqueIndex() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateRollbackSegments Property

Description

This is the generate RollbackSegments flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateRollbackSegments() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateRules Property

Description

Enable/Disable generation of Rules. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateRules() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateSequences Property

Description

This is the generate Sequences flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateSequences() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateStoGroups Property

Description

This is the generate StoGroups flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateStoGroups() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateSynonyms Property

Description

This is the generate Synonyms flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateSynonyms() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateSystemTriggers Property

Description

This is the generate System Triggers flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateSystemTriggers() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateTableCheckConstraints Property

Description

Enable/Disable generation of Table CheckConstraints. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateTableCheckConstraints() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateTableComment Property

Description

This is the generate Table Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateTableComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateTableCreateStatement Property

Description

This is the generate PK by Alter statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateTableCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateTablePostSQL Property

Description

This is the generate Table PostSQL statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateTablePostSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateTablePreSQL Property

Description

This is the generate Table Pre SQL statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateTablePreSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateTablespaces Property

Description

This is the generate Tablespaces flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateTablespaces() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateUserDatatypes Property

Description

Enable/Disable generation of UserDatatypes. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateUserDatatypes() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenerateViews Property

Description

Enable/Disable generation of Views. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateViews() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenFKDropStatement Property

Description

This is the generate FK Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenFKDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenForceBackticks Property

Description

This is the generate Force Backticks flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenForceBackticks() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenForceBrackets Property

Description

This is the generate Force Brackets flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenForceBrackets() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenForceQuotes Property

Description

This is the generate Force Quotes flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenForceQuotes() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenFunctionComment Property

Description

This is the generate Function Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenFunctionComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenFunctionCreateStatement Property

Description

This is the generate Function Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenFunctionCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenFunctionDropStatement Property

Description

This is the generate Function Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenFunctionDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIncludeObjHeader Property

Description

This is the generate Include Object Header flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIncludeObjHeader() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexDropStatement Property

Description

This is the generate Drop statement flag for indexes. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageBufferPool Property

Description

This is the generate BufferPool property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageBufferPool() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageExtentGrowthFactor Property

Description

This is the generate ExtentGrowthFactor property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageExtentGrowthFactor() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageFillFactor Property

Description

This is the generate FillFactor property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageFillFactor() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageFreeList Property

Description

This is the generate FreeList property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageFreeList() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageFreeListGroups Property

Description

This is the generate FreeListGroups property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageFreeListGroups() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageInclude Property

Description

This is the generate Include property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageInclude() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageInitialExtentSize Property

Description

This is the generate InitialExtentSize property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageInitialExtentSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageLocation Property

Description

This is the generate Location property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageLocation() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageLockMode Property

Description

This is the generate LockMode property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageLockMode() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageLogging Property

Description

This is the generate Logging property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageLogging() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageMaxExtents Property

Description

This is the generate MaxExtents property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageMaxExtents() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageMaxRowsPerPage Property

Description

This is the generate MaxRowsPerPage property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageMaxRowsPerPage() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageMaxTransactions Property

Description

This is the generate MaxTransactions property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageMaxTransactions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageMinExtents Property

Description

This is the generate MinExtents property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageMinExtents() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageMinTransactions Property

Description

This is the generate MinTransactions property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageMinTransactions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageNextExtentSize Property

Description

This is the generate NextExtentSize property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageNextExtentSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStoragePadIndex Property

Description

This is the generate PadIndex property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStoragePadIndex() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageParallel Property

Description

This is the generate Parallel property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageParallel() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStoragePctFree Property

Description

This is the generate PctFree property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStoragePctFree() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStoragePctUsed Property

Description

This is the generate PctUsed property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStoragePctUsed() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageReverseScans Property

Description

This is the generate ReverseScans property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageReverseScans() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenIndexStorageSortTempDB Property

Description

This is the generate SortTempDB property of Index Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenIndexStorageSortTempDB() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenKeywordBackticks Property

Description

This is the generate Keyword Backticks flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenKeywordBackticks() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenKeywordBrackets Property

Description

This is the generate Keyword Brackets flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenKeywordBrackets() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenKeywordQuotes Property

Description

This is the generate Keyword Quotes flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenKeywordQuotes() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenLOBSegments Property

Description

This is the generate LOB Segments flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenLOBSegments() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMaterializedQueryTableComment Property

Description

This is the generate MaterializedQueryTable Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMaterializedQueryTableComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMaterializedQueryTableCreateStatement Property

Description

This is the generate MaterializedQueryTable Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMaterializedQueryTableCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMaterializedQueryTableDropStatement Property

Description

This is the generate MaterializedQueryTable Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMaterializedQueryTableDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMaterializedViewPostSQL Property

Description

This is the Generate Materialized View Post SQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMaterializedViewPostSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMaterializedViewPreSQL Property

Description

This is the Generate Materialized View Pre SQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMaterializedViewPreSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMatViewComment Property

Description

This is the generate MaterializedView Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMatViewComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMatViewCreateStatement Property

Description

This is the generate MaterializedView Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMatViewCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenMatViewDropStatement Property

Description

This is the generate MaterializedView Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenMatViewDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenModelPostSQL Property

Description

This is the generate Model PostSQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenModelPostSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenModelPreSQL Property

Description

This is the generate Model PreSQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenModelPreSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenNodeGroupComment Property

Description

This is the generate NodeGroup Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenNodeGroupComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenNodeGroupCreateStatement Property

Description

This is the generate NodeGroup Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenNodeGroupCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenNodeGroupDropStatement Property

Description

This is the generate NodeGroup Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenNodeGroupDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenObjectTypeComment Property

Description

This is the generate ObjectType Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenObjectTypeComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenObjectTypeCreateStatement Property

Description

This is the generate ObjectType Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenObjectTypeCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenObjectTypeDropStatement Property

Description

This is the generate ObjectType Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenObjectTypeDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenPackageComment Property

Description

This is the generate Package Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPackageComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenPackageCreateStatement Property

Description

This is the generate Package Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPackageCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenPackageDropStatement Property

Description

This is the generate Package Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPackageDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenProcCreateStatement Property

Description

This is the generate Procedure Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenProcCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenProcDropStatement Property

Description

This is the generate Procedure Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenProcDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenProcedureComment Property

Description

This is the generate Procedure Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenProcedureComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenRBSegmentComment Property

Description

This is the generate RollBackSegment Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenRBSegmentComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenRBSegmentCreateStatement Property

Description

This is the generate RollBackSegment Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenRBSegmentCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenRBSegmentDropStatement Property

Description

This is the generate RollBackSegment Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenRBSegmentDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenRuleDropStatement Property

Description

This is the generate Rule Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenRuleDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSequenceComment Property

Description

This is the generate Sequence Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSequenceComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSequenceCreateStatement Property

Description

This is the generate Sequence Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSequenceCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSequenceDropStatement Property

Description

This is the generate Sequence Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSequenceDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSequencePostSQL Property

Description

This is the Generate Sequence Post SQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSequencePostSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSequencePreSQL Property

Description

This is the Generate Sequence Pre SQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSequencePreSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenStoGroupComment Property

Description

This is the generate StoGroup Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenStoGroupComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenStoGroupCreateStatement Property

Description

This is the generate StoGroup Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenStoGroupCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenStoGroupDropStatement Property

Description

This is the generate StoGroup Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenStoGroupDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSynonymComment Property

Description

This is the generate Synonym Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSynonymComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSynonymCreateStatement Property

Description

This is the generate Synonym Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSynonymCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenSynonymDropStatement Property

Description

This is the generate Synonym Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenSynonymDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableConstraintName Property

Description

This is the generate Table Constraint Name flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableConstraintName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTablespaceComment Property

Description

This is the generate Tablespace Comment flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTablespaceComment() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTablespaceCreateStatement Property

Description

This is the generate Tablespace Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTablespaceCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTablespaceDropStatement Property

Description

This is the generate Tablespace Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTablespaceDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageAuditOptions Property

Description

This is the generate AuditOptions property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageAuditOptions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageCacheStrategy Property

Description

This is the generate CacheStrategy property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageCacheStrategy() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageDataBlockSize Property

Description

This is the generate DataBlockSize property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageDataBlockSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageEncoding Property

Description

This is the generate Encoding property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageEncoding() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageFallback Property

Description

This is the generate Fallback property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageFallback() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageIdentityGap Property

Description

This is the generate IdentityGap property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageIdentityGap() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageIndexTablespace Property

Description

This is the generate IndexTablespace property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageIndexTablespace() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageJournaling Property

Description

This is the generate Journaling property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageJournaling() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageLogDataChanges Property

Description

This is the generate LogDataChanges property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageLogDataChanges() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageLogging Property

Description

This is the generate Logging property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageLogging() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageLongTablespace Property

Description

This is the generate LongTablespace property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageLongTablespace() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageNotLogInitially Property

Description

This is the generate NotLoggedInitially property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageNotLogInitially() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageOrganization Property

Description

This is the generate Organization property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageOrganization() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageParallel Property

Description

This is the generate Parallel property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageParallel() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageReservePageGap Property

Description

This is the generate ReservePageGap property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageReservePageGap() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTableStorageRestrictOnDrop Property

Description

This is the generate RestrictOnDrop property of Table Storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTableStorageRestrictOnDrop() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTriggerCreateStatement Property

Description

This is the generate Trigger Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTriggerCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenTriggerDropStatement Property

Description

This is the generate Trigger Drop Statementt flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenTriggerDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenUserDatatypeDropStatement Property

Description

This is the generate UserDatatype Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenUserDatatypeDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenVerifyStatement Property

Description

This is the generate Verify Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenVerifyStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenViewCreateStatement Property

Description

This is the generate View Create Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenViewCreateStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenViewDropStatement Property

Description

This is the generate View Drop Statement flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenViewDropStatement() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenViewPostSQL Property

Description

This is the generate View PostSQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenViewPostSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

GenViewPreSQL Property

Description

This is the generate View PreSQL flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenViewPreSQL() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

IndexPartitions Property

Description

Enable/Disable Storage option - IndexPartitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexPartitions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

InitialExtentSize Property

Description

Enable/Disable Storage option - InitialExtentSize. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitialExtentSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

Location Property

Description

Enable/Disable Storage option - Location. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

LockMode Property

Description

Enable/Disable Storage option - LockMode. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockMode() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

LogDeviceFilename Property

Description

Log Device Filename for new database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogDeviceFilename() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

LogDeviceName Property

Description

Log Device Name for new database. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogDeviceName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

LogDeviceSize Property

Description

Log Device Size for new database. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogDeviceSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

MaximumExtents Property

Description

Enable/Disable Storage option - MaximumExtents. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaximumExtents() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

MaximumTransactions Property

Description

Enable/Disable Storage option - MaximumTransactions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaximumTransactions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

MaxRowsPerPage Property

Description

Enable/Disable Storage option - MaxRowsPerPage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxRowsPerPage() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

MinimumExtents Property

Description

Enable/Disable Storage option - MinimumExtents. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinimumExtents() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

MinimumTransactions Property

Description

Enable/Disable Storage option - MinimumTransactions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinimumTransactions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

NextExtentSize Property

Description

Enable/Disable Storage option - NextExtentSize. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtentSize() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

PercentFree Property

Description

Enable/Disable Storage option - PercentFree. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentFree() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

PercentUsed Property

Description

Enable/Disable Storage option - PercentUsed. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentUsed() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

PrimaryKeyConstraintType Property

Description

Set how Primary Key is generated. 0 - don't generate, 1 - unique index, 2 - PK constraint. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimaryKeyConstraintType() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

SelectExistingDatabase Property

Description

Use an existing Database. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectExistingDatabase() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

SupplyAKConstraintName Property

Description

If AK Constraint type is 2, this indicates if constraint names are supplied. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SupplyAKConstraintName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

SupplyPKConstraintName Property

Description

If PK Constraint type is 2, this indicates if constraint names are supplied. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SupplyPKConstraintName() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

TablePartitions Property

Description

Enable/Disable Storage option - TablePartitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TablePartitions() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

Username Property

Description

This is the User Name for generating DB objects. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Username() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

UserPassword Property

Description

This is the User Password for generating DB objects. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserPassword() As Variant

See Also

DDLGeneration Object


%%PageItemTitle%%

Default Object
See Also Members

Description

This object represents a default in ER/Studio.

Object Model

See Also

Default Members


%%PageItemTitle%% $$Members$$

Default Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this default.
Public Method BoundObjects | Returns a collection of bindings that link the default to attributes.
Public Method RepoCheckOutStatus | Get the Check Out status of this Default object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this Default object.

Public Properties

Public Property DictionaryName | This is the name of the Dictionary associated with this object. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the Default. DATATYPE: String.
Public Property ID | This is the ID of the default. This ID is assigned by ER/Studio. Each default has a unique ID in the data dictionary. DATATYPE: Integer.
Public Property Name | This is the name of the default. DATATYPE: String.
Public Property Text | This is the text of the default. DATATYPE: String.

See Also

Default Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this default.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Default Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the default to attributes.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

Default Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Default object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Default Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Default object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Default Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary associated with this object. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

Default Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

Default Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Default. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Default Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the default. This ID is assigned by ER/Studio. Each default has a unique ID in the data dictionary. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Default Object


%%PageItemTitle%%

Name Property

Description

This is the name of the default. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Default Object


%%PageItemTitle%%

Text Property

Description

This is the text of the default. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Text() As Variant

See Also

Default Object


%%PageItemTitle%%

Defaults Collection
See Also Members

Description

This object represents a collection of defaults. The owner of this collection is the data dictionary.

Object Model

See Also

Defaults Members


%%PageItemTitle%% $$Members$$

Defaults Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new default with the given names, adds it to the data dictionary, and returns the new object to the caller. PARAMETERS: Name as String, ColumnName as String.
Public Method Remove | Deletes a Default object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Default object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Default objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Default object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Defaults Overview


%%PageItemTitle%%

Add Method
Name
Value

Description

Creates a new default with the given names, adds it to the data dictionary, and returns the new object to the caller. PARAMETERS: Name as String, ColumnName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Value As Variant _
) As Default

Parameters

Name
Value

See Also

Defaults Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Default object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Defaults Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Default object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Default

Parameters

Identifier

See Also

Defaults Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Defaults Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Default objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Defaults Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Default object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Default

Parameters

Identifier

See Also

Defaults Collection


%%PageItemTitle%%

Diagram Object
See Also Members

Description

This object represents a diagram in ER/Studio.

Object Model

See Also

Diagram Members


%%PageItemTitle%% $$Members$$

Diagram Object Members
See Also Overview

Public Methods

Public Method ActiveDataFlow | This is the Active DataFlow of the Diagram. RETURN DATATYPE: DataFlow.
Public Method ActiveModel | This is the Active Model of the Diagram. RETURN DATATYPE: Model.
Public Method BoundAttachments | Get all the BoundAttachments of this Diagram.
Public Method DataFlows | Returns an object representing a collection of all data flows in the diagram.
Public Method DataLineageRules | Returns an object representing a collection of all data movement rules in the diagram.
Public Method DataLineageSources | Returns an object representing a collection of all source/target models in the diagram.
Public Method Default | Returns the default with the given DefaultID. PARAMETERS: DefaultID.
Public Method Domain | Returns the domain with the given domainID. PARAMETERS: DomainID.
Public Method EnterpriseDataDictionaries | Returns a collection of enterprise data dictionaries.
Public Method GenerateReport | Make an HTML or RTF report indicatedd by the given QuickLaunch file. PARAMETERS: QuickLaunchFile as String.
Public Method GetFullFilePath | This is the full file path of the diagram. DATATYPE: String.
Public Method ImportDictionary | Import a Data Dictionary from the given file. PARAMETERS: FileName as String.
Public Method MergeModelObject | Returns an object which provides an interface for merging models.
Public Method Models | Returns an object representing a collection of all models in the diagram.
Public Method RepoAddDiagram | Add this Diagram to Repository. Returns 0 for failure or 1 if succesfull. RETURN DATATYPE: Integer.
Public Method RepoCheckinDiagram | Checkin a diagram to the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: Comment as String. RETURN DATATYPE: Integer.
Public Method RepoCheckinObjects | Checkin objects to the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: Comment as String. RETURN DATATYPE: Integer.
Public Method RepoCheckoutDiagram | Checkout a diagram from the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS GetLatest as Boolean, Comment as String. RETURN DATATYPE: Integer.
Public Method RepoCheckoutObjects | Comment as String, Checkout selected objects from the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: GetLatest as Boolean. RETURN DATATYPE: Integer.
Public Method RepoCheckOutStatus | Get the Check Out status of this Diagram object. DATATYPE: StringObjects.
Public Method RepoExclusiveCheckoutDiagram | Checkout a diagram exclusively from the Repo Server. Return value is 1 if successful, 0 otherwise. PARAMETERS GetLatest as Boolean. RETURN DATATYPE: Integer.
Public Method RepoExclusiveCheckOutObjects | Exclusively checks out selected objects from the repository. Synchronizes with server if GetLatest is true. Returns 1 on success, 0 otherwise.PARAMETERS GetLatest as Boolean. RETURN DATATYPE: Integer.
Public Method RepoGetLatestDiagram | Get the latest data of this Diagram from Repository. Returns 0 for failure or 1 if succesfull. RETURN DATATYPE: Integer.
Public Method RepoRedoCheckOutDiagram | Redo the diagram check out. Return 1 for success and 0 for failure. DATATYPE: Integer.
Public Method RepoRedoCheckOutObjects | Redo the check out of objects. Return 1 for success and 0 for failure. DATATYPE: Integer.
Public Method RepoSetNamedRelease | Set a NamedRelease for this diagram. PARAMETERS: Name as String, Description as String. DATATYPE: Integer.
Public Method RepoUndoCheckOutDiagram | Undo the diagram check out. Return 1 for success and 0 for failure. DATATYPE: Integer.
Public Method RepoUndoCheckOutObjects | Undo the check out of objects. Return 1 for success and 0 for failure. DATATYPE: Integer.
Public Method RepoVersionHistory | Get the Version History of this Diagram from the Repository server. Returns the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method Rule | Returns the Rule with the given RuleID. PARAMETERS: RuleID.
Public Method SaveFile | Saves the diagram to the specified location given in the FullFilePath. PARAMETERS: FullFilePath as String.
Public Method SetActiveDataFlow | Sets the Active DataFlow for the Diagram. PARAMETERS: DataFlowName as String.
Public Method SetActiveModel | Sets the Active Model for the Diagram. PARAMETERS: ModelName as String.
Public Method UserComments | Returns a collection of user comments associated with this Diagram.
Public Method UserDatatype | Returns the user data type with the given UserDataTypeID. PARAMETERS: UserDataTypeID.

Public Properties

Public Property Author | This is the Author of the Diagram. DATATYPE: String.
Public Property CodePage | This is the codepage of the Diagram. DATATYPE: Integer.
Public Property Company | This is the Company that made this Diagram. DATATYPE: String.
Public Property CopyrightOwner | This is the CopyrightOwner of the Diagram. DATATYPE: String.
Public Property CopyrightYear | This is the Copyright Year of the Diagram. DATATYPE: String.
Public Property CreateDate | This is when the Diagram is created. DATATYPE: String.
Public Property Description | This is the description of the Diagram. DATATYPE: String.
Public Property Dictionary | Returns a Data Dictionary object.
Public Property FileName | This is the file name of the diagram. DATATYPE: String.
Public Property GUID | GUID of the Diagram. This GUID is assigned by ER/Studio. Each Diagram has a unique GUID. DATATYPE: String.
Public Property LastUpdate | This is when the Diagram is last updated. DATATYPE: String.
Public Property ProjectName | This is the Project Name of the Diagram. DATATYPE: String.
Public Property Version | This is the version of the Diagram. DATATYPE: String.

See Also

Diagram Overview


%%PageItemTitle%%

ActiveDataFlow Method

Description

This is the Active DataFlow of the Diagram. RETURN DATATYPE: DataFlow.

Syntax

Visual Basic
Public Function ActiveDataFlow() As Variant

See Also

Diagram Object


%%PageItemTitle%%

ActiveModel Method

Description

This is the Active Model of the Diagram. RETURN DATATYPE: Model.

Syntax

Visual Basic
Public Function ActiveModel() As Variant

Example

Dim MyDiagram As Diagram

Dim Mod As Model

Set MyDiagram = DiagramManager.ActiveDiagram

Mod = MyDiagram.ActiveModel

See Also

Diagram Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Diagram.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Diagram Object


%%PageItemTitle%%

DataFlows Method

Description

Returns an object representing a collection of all data flows in the diagram.

Syntax

Visual Basic
Public Function DataFlows() As DataFlows

See Also

Diagram Object


%%PageItemTitle%%

DataLineageRules Method

Description

Returns an object representing a collection of all data movement rules in the diagram.

Syntax

Visual Basic
Public Function DataLineageRules() As DataLineageRules

See Also

Diagram Object


%%PageItemTitle%%

DataLineageSources Method

Description

Returns an object representing a collection of all source/target models in the diagram.

Syntax

Visual Basic
Public Function DataLineageSources() As DataLineageSources

See Also

Diagram Object


%%PageItemTitle%%

Default Method
Identifier

Description

Returns the default with the given DefaultID. PARAMETERS: DefaultID.

Syntax

Visual Basic
Public Function Default( _
   ByVal Identifier As Variant _
) As Default

Parameters

Identifier

See Also

Diagram Object


%%PageItemTitle%%

Domain Method
Identifier

Description

Returns the domain with the given domainID. PARAMETERS: DomainID.

Syntax

Visual Basic
Public Function Domain( _
   ByVal Identifier As Variant _
) As Domain

Parameters

Identifier

See Also

Diagram Object


%%PageItemTitle%%

EnterpriseDataDictionaries Method

Description

Returns a collection of enterprise data dictionaries.

Syntax

Visual Basic
Public Function EnterpriseDataDictionaries() As EnterpriseDataDictionaries

See Also

Diagram Object


%%PageItemTitle%%

GenerateReport Method
QuickLaunchFile

Description

Make an HTML or RTF report indicatedd by the given QuickLaunch file. PARAMETERS: QuickLaunchFile as String.

Syntax

Visual Basic
Public Sub GenerateReport( _
   ByVal QuickLaunchFile As Variant _
)

Parameters

QuickLaunchFile

See Also

Diagram Object


%%PageItemTitle%%

GetFullFilePath Method

Description

This is the full file path of the diagram. DATATYPE: String.

Syntax

Visual Basic
Public Function GetFullFilePath() As Variant

See Also

Diagram Object


%%PageItemTitle%%

ImportDictionary Method
FileName

Description

Import a Data Dictionary from the given file. PARAMETERS: FileName as String.

Syntax

Visual Basic
Public Sub ImportDictionary( _
   ByVal FileName As Variant _
)

Parameters

FileName

Example

Dim MyDiagram As Diagram

Set MyDiagram = DiagramManager.ActiveDiagram

MyDiagram.ImportDictionary("C:\Program Files\Embarcadero\ERStudio\Model\demo.dm1")

See Also

Diagram Object


%%PageItemTitle%%

MergeModelObject Method

Description

Returns an object which provides an interface for merging models.

Syntax

Visual Basic
Public Function MergeModelObject() As MergeModel

See Also

Diagram Object


%%PageItemTitle%%

Models Method

Description

Returns an object representing a collection of all models in the diagram.

Syntax

Visual Basic
Public Function Models() As Models

Example

Dim MyDiagram As Diagram

Set MyDiagram = DiagramManager.ActiveDiagram MyDiagram.Models

See Also

Diagram Object


%%PageItemTitle%%

RepoAddDiagram Method

Description

Add this Diagram to Repository. Returns 0 for failure or 1 if succesfull. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoAddDiagram() As Variant

See Also

Diagram Object


%%PageItemTitle%%

RepoCheckinDiagram Method
Comment

Description

Checkin a diagram to the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: Comment as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoCheckinDiagram( _
   ByVal Comment As Variant _
) As Variant

Parameters

Comment

Example

Sub Main
Dim d As Diagram
Dim nRet As Integer
Debug.Clear
Set d = DiagramManager.ActiveDiagram

nRet = d.RepoCheckinDiagram("RepoCheckInComment")
Debug.Print(DiagramManager.GetLastErrorString())
End Sub

See Also

Diagram Object


%%PageItemTitle%%

RepoCheckinObjects Method
Comment

Description

Checkin objects to the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: Comment as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoCheckinObjects( _
   ByVal Comment As Variant _
) As Variant

Parameters

Comment

Example

Sub Main

Dim d As Diagram

Dim s As SelectedObjects

Dim m As Model

Dim sm As SubModel

Dim ents As Entities

Dim e As Entity

Debug.Clear

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

Set sm = m.ActiveSubModel

Set s = sm.SelectedObjects

Set ents = m.Entities

For Each e In ents

s.Add(1, e.ID)

Next

nRet = d.RepoCheckinObjects()

Debug.Print(DiagramManager.GetLastErrorString())

End Sub

See Also

Diagram Object


%%PageItemTitle%%

RepoCheckoutDiagram Method
GetLatest
Comment

Description

Checkout a diagram from the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS GetLatest as Boolean, Comment as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoCheckoutDiagram( _
   ByVal GetLatest As Variant, _
   ByVal Comment As Variant _
) As Variant

Parameters

GetLatest
Comment

Example

Sub Main
Dim d As Diagram
Dim nRet As Integer
Dim bSynWithLatest As Boolean

Debug.Clear
Set d = DiagramManager.ActiveDiagram

bSynWithLatest = False

nRet = d.RepoCheckoutDiagram(bSynWithLatest, "RepoCheckOutCommentIsNoLongerUsed")
Debug.Print(DiagramManager.GetLastErrorString())
End Sub

See Also

Diagram Object


%%PageItemTitle%%

RepoCheckoutObjects Method
GetLatest
Comment

Description

Comment as String, Checkout selected objects from the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: GetLatest as Boolean. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoCheckoutObjects( _
   ByVal GetLatest As Variant, _
   ByVal Comment As Variant _
) As Variant

Parameters

GetLatest
Comment

Example

Sub Main

Dim d As Diagram

Dim s As SelectedObjects

Dim m As Model

Dim sm As SubModel

Dim ents As Entities

Dim e As Entity

Debug.Clear

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

Set sm = m.ActiveSubModel

Set s = sm.SelectedObjects

Set ents = m.Entities

For Each e In ents

s.Add(1, e.ID)

Next

nRet = d.RepoCheckoutObjects()

Debug.Print(DiagramManager.GetLastErrorString())

End Sub

See Also

Diagram Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Diagram object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Diagram Object


%%PageItemTitle%%

RepoExclusiveCheckoutDiagram Method
GetLatest

Description

Checkout a diagram exclusively from the Repo Server. Return value is 1 if successful, 0 otherwise. PARAMETERS GetLatest as Boolean. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoExclusiveCheckoutDiagram( _
   ByVal GetLatest As Variant _
) As Variant

Parameters

GetLatest

See Also

Diagram Object


%%PageItemTitle%%

RepoExclusiveCheckOutObjects Method
GetLatest

Description

Exclusively checks out selected objects from the repository. Synchronizes with server if GetLatest is true. Returns 1 on success, 0 otherwise.PARAMETERS GetLatest as Boolean. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoExclusiveCheckOutObjects( _
   ByVal GetLatest As Variant _
) As Variant

Parameters

GetLatest

See Also

Diagram Object


%%PageItemTitle%%

RepoGetLatestDiagram Method

Description

Get the latest data of this Diagram from Repository. Returns 0 for failure or 1 if succesfull. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoGetLatestDiagram() As Variant

See Also

Diagram Object


%%PageItemTitle%%

RepoRedoCheckOutDiagram Method

Description

Redo the diagram check out. Return 1 for success and 0 for failure. DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoRedoCheckOutDiagram() As Variant

Example

Sub Main

Dim d As Diagram

Set d = DiagramManager.ActiveDiagram

Debug.Clear

‘ Check out the diagram

d.RepoCheckoutDiagram(True, ““)

Debug.Print DiagramManager.GetLastErrorString

‘ Reset object after checkout reloads it.

Set d = DiagramManager.ActiveDiagram

Debug.Print DiagramManager.GetLastErrorString

d.RepoRedoCheckOutDiagram

Debug.Print DiagramManager.GetLastErrorString

End Sub

See Also

Diagram Object


%%PageItemTitle%%

RepoRedoCheckOutObjects Method

Description

Redo the check out of objects. Return 1 for success and 0 for failure. DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoRedoCheckOutObjects() As Variant

See Also

Diagram Object


%%PageItemTitle%%

RepoSetNamedRelease Method
Name
Description

Description

Set a NamedRelease for this diagram. PARAMETERS: Name as String, Description as String. DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoSetNamedRelease( _
   ByVal Name As Variant, _
   ByVal Description As Variant _
) As Variant

Parameters

Name
Description

See Also

Diagram Object


%%PageItemTitle%%

RepoUndoCheckOutDiagram Method

Description

Undo the diagram check out. Return 1 for success and 0 for failure. DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoUndoCheckOutDiagram() As Variant

Example

Sub Main

Dim d As Diagram

Set d = DiagramManager.ActiveDiagram

Debug.Clear

‘ Check out the diagram

d.RepoCheckoutDiagram(True, ““)

Debug.Print DiagramManager.GetLastErrorString

‘ Reset object after checkout reloads it.

Set d = DiagramManager.ActiveDiagram

Debug.Print DiagramManager.GetLastErrorString

d.RepoUndoCheckOutDiagram

Debug.Print DiagramManager.GetLastErrorString

End Sub

See Also

Diagram Object


%%PageItemTitle%%

RepoUndoCheckOutObjects Method

Description

Undo the check out of objects. Return 1 for success and 0 for failure. DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoUndoCheckOutObjects() As Variant

See Also

Diagram Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this Diagram from the Repository server. Returns the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

Diagram Object


%%PageItemTitle%%

Rule Method
Identifier

Description

Returns the Rule with the given RuleID. PARAMETERS: RuleID.

Syntax

Visual Basic
Public Function Rule( _
   ByVal Identifier As Variant _
) As Rule

Parameters

Identifier

See Also

Diagram Object


%%PageItemTitle%%

SaveFile Method
FullFilePath

Description

Saves the diagram to the specified location given in the FullFilePath. PARAMETERS: FullFilePath as String.

Syntax

Visual Basic
Public Sub SaveFile( _
   ByVal FullFilePath As Variant _
)

Parameters

FullFilePath

Example

Sub Main

Dim d As Diagram

Set d = DiagramManager.ActiveDiagram

‘save the file as it is (File - Save)

d.SaveFile(““)

‘save to a different file (File - Save As)

d.SaveFile(“d:\embarcadero\erstudio\pubs.dm1”)

End Sub

See Also

Diagram Object


%%PageItemTitle%%

SetActiveDataFlow Method
DataFlowName

Description

Sets the Active DataFlow for the Diagram. PARAMETERS: DataFlowName as String.

Syntax

Visual Basic
Public Sub SetActiveDataFlow( _
   ByVal DataFlowName As Variant _
)

Parameters

DataFlowName

See Also

Diagram Object


%%PageItemTitle%%

SetActiveModel Method
ModelName

Description

Sets the Active Model for the Diagram. PARAMETERS: ModelName as String.

Syntax

Visual Basic
Public Sub SetActiveModel( _
   ByVal ModelName As Variant _
)

Parameters

ModelName

See Also

Diagram Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Diagram.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Diagram Object


%%PageItemTitle%%

UserDatatype Method
Identifier

Description

Returns the user data type with the given UserDataTypeID. PARAMETERS: UserDataTypeID.

Syntax

Visual Basic
Public Function UserDatatype( _
   ByVal Identifier As Variant _
) As UserDatatype

Parameters

Identifier

See Also

Diagram Object


%%PageItemTitle%%

Author Property

Description

This is the Author of the Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Author() As Variant

See Also

Diagram Object


%%PageItemTitle%%

CodePage Property

Description

This is the codepage of the Diagram. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property CodePage() As Variant

See Also

Diagram Object


%%PageItemTitle%%

Company Property

Description

This is the Company that made this Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Company() As Variant

See Also

Diagram Object


%%PageItemTitle%%

CopyrightOwner Property

Description

This is the CopyrightOwner of the Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyrightOwner() As Variant

See Also

Diagram Object


%%PageItemTitle%%

CopyrightYear Property

Description

This is the Copyright Year of the Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyrightYear() As Variant

See Also

Diagram Object


%%PageItemTitle%%

CreateDate Property

Description

This is when the Diagram is created. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property CreateDate() As Variant

See Also

Diagram Object


%%PageItemTitle%%

Description Property

Description

This is the description of the Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Diagram Object


%%PageItemTitle%%

Dictionary Property

Description

Returns a Data Dictionary object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Dictionary() As Dictionary

Example

Dim MyDiagram As Diagram

Dim MyDictionary As Dictionary

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyDictionary = MyDiagram.Dictionary

See Also

Diagram Object


%%PageItemTitle%%

FileName Property

Description

This is the file name of the diagram. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileName() As Variant

Example

Dim MyDiagram As Diagram

Dim MyFileName As String

Set MyDiagram = DiagramManager.ActiveDiagram

MyFileName = MyDiagram.FileName

See Also

Diagram Object


%%PageItemTitle%%

GUID Property

Description

GUID of the Diagram. This GUID is assigned by ER/Studio. Each Diagram has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Diagram Object


%%PageItemTitle%%

LastUpdate Property

Description

This is when the Diagram is last updated. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastUpdate() As Variant

See Also

Diagram Object


%%PageItemTitle%%

ProjectName Property

Description

This is the Project Name of the Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ProjectName() As Variant

See Also

Diagram Object


%%PageItemTitle%%

Version Property

Description

This is the version of the Diagram. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Version() As Variant

See Also

Diagram Object


%%PageItemTitle%%

Dictionary Object
See Also Members

Description

This object represents the data dictionary in ER/Studio.

Object Model

See Also

Dictionary Members


%%PageItemTitle%% $$Members$$

Dictionary Object Members
See Also Overview

Public Methods

Public Method AttachmentTypes | Returns an object representing a collection of all AttachmentTypes in this Data Dictionary.
Public Method Defaults | Returns an object representing a collection of all defaults in the Data Dictionary.
Public Method DomainFolders | Returns an object representing a collection of all domain folders in the Data Dictionary.
Public Method Domains | Returns an object representing a collection of all domains in the Data Dictionary.
Public Method ImportDictionary | Import the specified Data Dictionary from the given file into this data dictionary. Duplicate names are resolved via the duplicate name option: 0 - Rename, 1 - Update, 2 - Skip. PARAMETERS: FileName as String, DataDictionaryName As String, DupNameOption As Int?U?K??
Public Method NamingStandardsTemplates | Returns an object representing a collection of all NamingStandardsTemplates in this Data Dictionary.).
Public Method ReferenceValues | Returns an object representing a collection of all ReferenceValues in this Data Dictionary.).
Public Method RepoCheckinDataDictionary | CheckOut a Data Dictionary to the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: Comment as String. RETURN DATATYPE: Integer.
Public Method RepoCheckoutDataDictionary | Checkout a Data Dictionary from the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS GetLatest as Boolean, Comment as String. RETURN DATATYPE: Integer.
Public Method RepoExclusiveCheckoutDataDictionary | Exclusively checks out a Dictionary from the Repository - synchoronizes with it if GetLatest is true. Returns 1 on success, 0 otherwise. PARAMETERS GetLatest as Boolean. RETURN DATATYPE: Integer.
Public Method Rules | Returns an object representing a collection of all rules in the Data Dictionary.
Public Method SecurityTypes | Returns an object representing a collection of all SecurityTypes in this Data Dictionary.
Public Method UserComments | Returns a collection of user comments associated with this data dictionary.
Public Method UserDatatypes | Returns an object representing a collection of all user datatypes in the Data Dictionary.

Public Properties

Public Property Description | This is the description of the Dictionary. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary is enterprise level. DATATYPE: Boolean.
Public Property GUID | GUID of the Dictionary. This GUID is assigned by ER/Studio. Each Dictionary has a unique GUID. DATATYPE: String.
Public Property ID | ID of the Dictionary. The ID of the Main Dictionary is 1, whereas the ID of the Enterprise Dictionaries is assigned by ER/Studio. Each Enterprise Dictionary bound to a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the Dictionary. DATATYPE: String.

See Also

Dictionary Overview


%%PageItemTitle%%

AttachmentTypes Method

Description

Returns an object representing a collection of all AttachmentTypes in this Data Dictionary.

Syntax

Visual Basic
Public Function AttachmentTypes() As AttachmentTypes

See Also

Dictionary Object


%%PageItemTitle%%

Defaults Method

Description

Returns an object representing a collection of all defaults in the Data Dictionary.

Syntax

Visual Basic
Public Function Defaults() As Defaults

Example

Dim MyDictionary As Dictionary

Dim MyDefault As Default

For Each MyDefault In MyDictionary.Defaults

' Operations on defaults go here

...

Next MyDefault

See Also

Dictionary Object


%%PageItemTitle%%

DomainFolders Method

Description

Returns an object representing a collection of all domain folders in the Data Dictionary.

Syntax

Visual Basic
Public Function DomainFolders() As DomainFolders

See Also

Dictionary Object


%%PageItemTitle%%

Domains Method

Description

Returns an object representing a collection of all domains in the Data Dictionary.

Syntax

Visual Basic
Public Function Domains() As Domains

Example

Dim MyDictionary As Dictionary

Dim MyDomain As Domain

For Each MyDomain In MyDictionary.Domains

' Operations on domains go here

...

Next MyDomain

See Also

Dictionary Object


%%PageItemTitle%%

ImportDictionary Method
FileName
DataDictionaryName
DupNameOption

Description

Import the specified Data Dictionary from the given file into this data dictionary. Duplicate names are resolved via the duplicate name option: 0 - Rename, 1 - Update, 2 - Skip. PARAMETERS: FileName as String, DataDictionaryName As String, DupNameOption As Int?U?K??

Syntax

Visual Basic
Public Sub ImportDictionary( _
   ByVal FileName As Variant, _
   ByVal DataDictionaryName As Variant, _
   ByVal DupNameOption As Variant _
)

Parameters

FileName
DataDictionaryName
DupNameOption

Remarks

METHOD: ImportDictionary, RETURN DATATYPE: None, PARAMETERS: FileName as String, DataDictionaryName As String, DupNameOption As Integer DESCRIPTION: Import the specified Data Dictionary from the given file into this data dictionary. Duplicate names are resolved via the duplicate name option: 0 - Rename, 1 - Update, 2 - Skip.

See Also

Dictionary Object


%%PageItemTitle%%

NamingStandardsTemplates Method

Description

Returns an object representing a collection of all NamingStandardsTemplates in this Data Dictionary.).

Syntax

Visual Basic
Public Function NamingStandardsTemplates() As NamingStandardsTemplates

See Also

Dictionary Object


%%PageItemTitle%%

ReferenceValues Method

Description

Returns an object representing a collection of all ReferenceValues in this Data Dictionary.).

Syntax

Visual Basic
Public Function ReferenceValues() As ReferenceValues

See Also

Dictionary Object


%%PageItemTitle%%

RepoCheckinDataDictionary Method
Comment

Description

CheckOut a Data Dictionary to the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS: Comment as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoCheckinDataDictionary( _
   ByVal Comment As Variant _
) As Variant

Parameters

Comment

See Also

Dictionary Object


%%PageItemTitle%%

RepoCheckoutDataDictionary Method
GetLatest
Comment

Description

Checkout a Data Dictionary from the Repo Server. Return value is 1 if it succeeded else it's 0. PARAMETERS GetLatest as Boolean, Comment as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoCheckoutDataDictionary( _
   ByVal GetLatest As Variant, _
   ByVal Comment As Variant _
) As Variant

Parameters

GetLatest
Comment

See Also

Dictionary Object


%%PageItemTitle%%

RepoExclusiveCheckoutDataDictionary Method
GetLatest

Description

Exclusively checks out a Dictionary from the Repository - synchoronizes with it if GetLatest is true. Returns 1 on success, 0 otherwise. PARAMETERS GetLatest as Boolean. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoExclusiveCheckoutDataDictionary( _
   ByVal GetLatest As Variant _
) As Variant

Parameters

GetLatest

See Also

Dictionary Object


%%PageItemTitle%%

Rules Method

Description

Returns an object representing a collection of all rules in the Data Dictionary.

Syntax

Visual Basic
Public Function Rules() As Rules

Example

Dim MyDictionary As Dictionary

Dim MyRule As Rule

For Each MyRule In MyDictionary.Rules

' Operations on rules go here

...

Next MyRule

See Also

Dictionary Object


%%PageItemTitle%%

SecurityTypes Method

Description

Returns an object representing a collection of all SecurityTypes in this Data Dictionary.

Syntax

Visual Basic
Public Function SecurityTypes() As SecurityTypes

See Also

Dictionary Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this data dictionary.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Dictionary Object


%%PageItemTitle%%

UserDatatypes Method

Description

Returns an object representing a collection of all user datatypes in the Data Dictionary.

Syntax

Visual Basic
Public Function UserDatatypes() As UserDatatypes

Example

Dim MyDictionary As Dictionary

Dim MyUserDatatype As UserDatatype

For Each MyUserDatatype In MyDictionary.UserDatatypes

' Operations on user datatypes go here

...

Next MyUserDatatype

See Also

Dictionary Object


%%PageItemTitle%%

Description Property

Description

This is the description of the Dictionary. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Dictionary Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

Dictionary Object


%%PageItemTitle%%

GUID Property

Description

GUID of the Dictionary. This GUID is assigned by ER/Studio. Each Dictionary has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Dictionary Object


%%PageItemTitle%%

ID Property

Description

ID of the Dictionary. The ID of the Main Dictionary is 1, whereas the ID of the Enterprise Dictionaries is assigned by ER/Studio. Each Enterprise Dictionary bound to a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Dictionary Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Dictionary. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Dictionary Object


%%PageItemTitle%%

Document Object
See Also Members

See Also

Document Members


%%PageItemTitle%% $$Members$$

Document Object Members
See Also Overview

See Also

Document Overview


%%PageItemTitle%%

Domain Object
See Also Members

Description

This object represents a domain in ER/Studio.

Object Model

See Also

Domain Members


%%PageItemTitle%% $$Members$$

Domain Object Members
See Also Overview

Public Methods

Public Method ApplyNullabilityToBoundColumns | When updates are called, all bound attributes have the same nullability as the domain.
Public Method BoundAttachments | Get all the BoundAttachments of this domain.
Public Method BoundObjects | Returns a collection of bindings that link the domain to attributes.
Public Method DeleteNamingStandardsTemplate | Unbind this Domain from the naming standards template by deleting the naming standards template ID from the domain.
Public Method DeleteReferenceValue | Unbind this domain from the reference value by deleting the reference value ID from the domain.
Public Method GetNamingStandardsTemplate | Returns the naming standards template bound to the domain or null, if none is bound to the domain.
Public Method GetOverrideControl | Returns true if the override control passed in is set for this domain. PARAMETERS: OverrideControlType As Integer. DATATYPE: Boolean.
Public Method GetReferenceValue | Returns the reference value bound to the domain or null, if none is bound to it.
Public Method RepoCheckOutStatus | Get the Check Out status of this Domain object. DATATYPE: StringObjects.
Public Method SetOverrideControl | Turns on the passed in override control for this domain. PARAMETERS: OverrideControlType As Integer.
Public Method UserComments | Returns a collection of user comments associated with this Domain object.

Public Properties

Public Property AttributeName | This is the AttributeName of this Domain. DATATYPE: String.
Public Property CheckConstraint | This is the check constraint of the domain. DATATYPE: String.
Public Property ColumnName | This is the column name of the domain. DATATYPE: String.
Public Property DataLength | This is the datatype's length. DATATYPE: Integer.
Public Property DataScale | This is the datatype's scale. DATATYPE: Integer.
Public Property Datatype | This is the datatype of the domain. DATATYPE: String.
Public Property DeclaredDefault | This is the declared default of the domain. DATATYPE: String.
Public Property DefaultId | This is the ID of the bounded default. To bind a default to a domain, assign the default's ID to this property. DATATYPE: Integer.
Public Property Definition | This is the Definition of this Domain. DATATYPE: String.
Public Property DictionaryName | This is the name of the Dictionary associated with this object. DATATYPE: String.
Public Property DomainFolder | This is the DomainFolder Name of this Domain. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.
Public Property FreezeName | True if this domain should not be affected by batch naming standards applications. DATATYPE: Boolean.
Public Property GUID | GUID of the domain. GUIDs are unique IDs assigned by ER/Studio. DATATYPE: String.
Public Property ID | ID of the domain. This ID is assigned by ER/Studio. Each domain in a diagram has a unique ID. DATATYPE: Integer.
Public Property Identity | This is the datatype's identity value (true or false). DATATYPE: Boolean.
Public Property IdentityIncrement | This is the datatype's identity increment value. DATATYPE: Integer.
Public Property IdentitySeed | This is the datatype's identity seed value. DATATYPE: Integer.
Public Property Name | This is the logical name of the domain. DATATYPE: String.
Public Property NamingStandardsTemplateId | ID of the NamingStandardsTemplate object bound to the domain (if any). A user can bind a NamingStandardsTemplate to the domain by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.
Public Property Note | This is the Note of this Domain. DATATYPE: String.
Public Property Nullable | This is the Nullability of this Domain. DATATYPE: Boolean.
Public Property ParentDomain | This is the name of the immediate parent domain if the current object has a parent domain. DATATYPE: String.
Public Property ReceiveParentModifications | True if this domain should be updated by changes to its parent domain. DATATYPE: Boolean.
Public Property ReferenceValueId | ID of the ReferenceValue object bound to the domain (if any). A user can bind a ReferenceValue to the domain by assigning a particular ReferenceValueId to this property. DATATYPE: Integer.
Public Property RuleId | This is the ID of the bounded rule. To bind a rule to a domain, assign the rule's ID to this property. DATATYPE: Integer.
Public Property UserDatatypeId | This is the ID of the bounded user datatype. To bind a user datatype to a domain, assign the user datatype's ID to this property. DATATYPE: Integer.

See Also

Domain Overview


%%PageItemTitle%%

ApplyNullabilityToBoundColumns Method

Description

When updates are called, all bound attributes have the same nullability as the domain.

Syntax

Visual Basic
Public Sub ApplyNullabilityToBoundColumns()

See Also

Domain Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this domain.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Domain Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the domain to attributes.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

Domain Object


%%PageItemTitle%%

DeleteNamingStandardsTemplate Method

Description

Unbind this Domain from the naming standards template by deleting the naming standards template ID from the domain.

Syntax

Visual Basic
Public Function DeleteNamingStandardsTemplate() As Variant

See Also

Domain Object


%%PageItemTitle%%

DeleteReferenceValue Method

Description

Unbind this domain from the reference value by deleting the reference value ID from the domain.

Syntax

Visual Basic
Public Function DeleteReferenceValue() As Variant

See Also

Domain Object


%%PageItemTitle%%

GetNamingStandardsTemplate Method

Description

Returns the naming standards template bound to the domain or null, if none is bound to the domain.

Syntax

Visual Basic
Public Function GetNamingStandardsTemplate() As NamingStandardsTemplate

See Also

Domain Object


%%PageItemTitle%%

GetOverrideControl Method
OverrideControlType

The override control types and their corresponding IDs are:

  • 1 Allow datatype
  • 2 Disallow datatype
  • 3 Allow default
  • 4 Disallow default
  • 5 Allow rule
  • 6 Disallow rule
  • 7 Allow definition
  • 8 Disallow definition
  • 9 Allow note
  • 10 Disallow note
  • 20 Initially migrate attachments
  • 21 Never migrate attachments
  • 22 Always migrate attachments
  • 30 Partial synchronize attribute name
  • 31 Never synchronize attribute name
  • 40 Partial synchronize column name
  • 41 Never synchronize column name

Description

Returns true if the override control passed in is set for this domain. PARAMETERS: OverrideControlType As Integer. DATATYPE: Boolean.

Syntax

Visual Basic
Public Function GetOverrideControl( _
   ByVal OverrideControlType As Variant _
) As Variant

Parameters

OverrideControlType

The override control types and their corresponding IDs are:

  • 1 Allow datatype
  • 2 Disallow datatype
  • 3 Allow default
  • 4 Disallow default
  • 5 Allow rule
  • 6 Disallow rule
  • 7 Allow definition
  • 8 Disallow definition
  • 9 Allow note
  • 10 Disallow note
  • 20 Initially migrate attachments
  • 21 Never migrate attachments
  • 22 Always migrate attachments
  • 30 Partial synchronize attribute name
  • 31 Never synchronize attribute name
  • 40 Partial synchronize column name
  • 41 Never synchronize column name

See Also

Domain Object


%%PageItemTitle%%

GetReferenceValue Method

Description

Returns the reference value bound to the domain or null, if none is bound to it.

Syntax

Visual Basic
Public Function GetReferenceValue() As ReferenceValue

See Also

Domain Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Domain object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Domain Object


%%PageItemTitle%%

SetOverrideControl Method
OverrideControlType
The override control types and their corresponding IDs are:
  • 1 Allow datatype
  • 2 Disallow datatype
  • 3 Allow default
  • 4 Disallow default
  • 5 Allow rule
  • 6 Disallow rule
  • 7 Allow definition
  • 8 Disallow definition
  • 9 Allow note
  • 10 Disallow note
  • 20 Initially migrate attachments
  • 21 Never migrate attachments
  • 22 Always migrate attachments
  • 30 Partial synchronize attribute name
  • 31 Never synchronize attribute name
  • 40 Partial synchronize column name
  • 41 Never synchronize column name

Description

Turns on the passed in override control for this domain. PARAMETERS: OverrideControlType As Integer.

Syntax

Visual Basic
Public Sub SetOverrideControl( _
   ByVal OverrideControlType As Variant _
)

Parameters

OverrideControlType
The override control types and their corresponding IDs are:
  • 1 Allow datatype
  • 2 Disallow datatype
  • 3 Allow default
  • 4 Disallow default
  • 5 Allow rule
  • 6 Disallow rule
  • 7 Allow definition
  • 8 Disallow definition
  • 9 Allow note
  • 10 Disallow note
  • 20 Initially migrate attachments
  • 21 Never migrate attachments
  • 22 Always migrate attachments
  • 30 Partial synchronize attribute name
  • 31 Never synchronize attribute name
  • 40 Partial synchronize column name
  • 41 Never synchronize column name

See Also

Domain Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Domain object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Domain Object


%%PageItemTitle%%

AttributeName Property

Description

This is the AttributeName of this Domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttributeName() As Variant

See Also

Domain Object


%%PageItemTitle%%

CheckConstraint Property

Description

This is the check constraint of the domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckConstraint() As Variant

See Also

Domain Object


%%PageItemTitle%%

ColumnName Property

Description

This is the column name of the domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnName() As Variant

See Also

Domain Object


%%PageItemTitle%%

DataLength Property

Description

This is the datatype's length. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataLength() As Variant

See Also

Domain Object


%%PageItemTitle%%

DataScale Property

Description

This is the datatype's scale. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataScale() As Variant

See Also

Domain Object


%%PageItemTitle%%

Datatype Property

Description

This is the datatype of the domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

Domain Object


%%PageItemTitle%%

DeclaredDefault Property

Description

This is the declared default of the domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DeclaredDefault() As Variant

See Also

Domain Object


%%PageItemTitle%%

DefaultId Property

Description

This is the ID of the bounded default. To bind a default to a domain, assign the default's ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultId() As Variant

See Also

Domain Object


%%PageItemTitle%%

Definition Property

Description

This is the Definition of this Domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

Domain Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary associated with this object. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

Domain Object


%%PageItemTitle%%

DomainFolder Property

Description

This is the DomainFolder Name of this Domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DomainFolder() As Variant

See Also

Domain Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

Domain Object


%%PageItemTitle%%

FreezeName Property

Description

True if this domain should not be affected by batch naming standards applications. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreezeName() As Variant

See Also

Domain Object


%%PageItemTitle%%

GUID Property

Description

GUID of the domain. GUIDs are unique IDs assigned by ER/Studio. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Domain Object


%%PageItemTitle%%

ID Property

Description

ID of the domain. This ID is assigned by ER/Studio. Each domain in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Domain Object


%%PageItemTitle%%

Identity Property

Description

This is the datatype's identity value (true or false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Identity() As Variant

See Also

Domain Object


%%PageItemTitle%%

IdentityIncrement Property

Description

This is the datatype's identity increment value. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentityIncrement() As Variant

See Also

Domain Object


%%PageItemTitle%%

IdentitySeed Property

Description

This is the datatype's identity seed value. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IdentitySeed() As Variant

See Also

Domain Object


%%PageItemTitle%%

Name Property

Description

This is the logical name of the domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Domain Object


%%PageItemTitle%%

NamingStandardsTemplateId Property

Description

ID of the NamingStandardsTemplate object bound to the domain (if any). A user can bind a NamingStandardsTemplate to the domain by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamingStandardsTemplateId() As Variant

See Also

Domain Object


%%PageItemTitle%%

Note Property

Description

This is the Note of this Domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Note() As Variant

See Also

Domain Object


%%PageItemTitle%%

Nullable Property

Description

This is the Nullability of this Domain. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Nullable() As Variant

See Also

Domain Object


%%PageItemTitle%%

ParentDomain Property

Description

This is the name of the immediate parent domain if the current object has a parent domain. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ParentDomain() As Variant

See Also

Domain Object


%%PageItemTitle%%

ReceiveParentModifications Property

Description

True if this domain should be updated by changes to its parent domain. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReceiveParentModifications() As Variant

See Also

Domain Object


%%PageItemTitle%%

ReferenceValueId Property

Description

ID of the ReferenceValue object bound to the domain (if any). A user can bind a ReferenceValue to the domain by assigning a particular ReferenceValueId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferenceValueId() As Variant

See Also

Domain Object


%%PageItemTitle%%

RuleId Property

Description

This is the ID of the bounded rule. To bind a rule to a domain, assign the rule's ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property RuleId() As Variant

See Also

Domain Object


%%PageItemTitle%%

UserDatatypeId Property

Description

This is the ID of the bounded user datatype. To bind a user datatype to a domain, assign the user datatype's ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDatatypeId() As Variant

See Also

Domain Object


%%PageItemTitle%%

DomainFolder Object
See Also Members

Description

This object represents a Domain Folder in ER/Studio.

Object Model

See Also

DomainFolder Members


%%PageItemTitle%% $$Members$$

DomainFolder Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this DomainFolder object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this Domain Folder.

Public Properties

Public Property DomainFolder | This is the name of this Domain Folder's parent Domain Folder. DATATYPE: String.
Public Property GUID | GUID of the Domain Folder. This GUID is assigned by ER/Studio. Each domain folder has a unique GUID. DATATYPE: String.
Public Property ID | ID of the Domain Folder. This ID is assigned by ER/Studio. Each domain folder in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the domain folder. DATATYPE: String.

See Also

DomainFolder Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this DomainFolder object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

DomainFolder Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Domain Folder.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

DomainFolder Object


%%PageItemTitle%%

DomainFolder Property

Description

This is the name of this Domain Folder's parent Domain Folder. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DomainFolder() As Variant

See Also

DomainFolder Object


%%PageItemTitle%%

GUID Property

Description

GUID of the Domain Folder. This GUID is assigned by ER/Studio. Each domain folder has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

DomainFolder Object


%%PageItemTitle%%

ID Property

Description

ID of the Domain Folder. This ID is assigned by ER/Studio. Each domain folder in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

DomainFolder Object


%%PageItemTitle%%

Name Property

Description

This is the name of the domain folder. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

DomainFolder Object


%%PageItemTitle%%

DomainFolders Collection
See Also Members

Description

This object represents a collection of Domain Folders. The owner of this collection is the data dictionary.

Object Model

See Also

DomainFolders Members


%%PageItemTitle%% $$Members$$

DomainFolders Collection Members
See Also Overview

Public Methods

Public Method Add | Adds a new DomainFolder with the given name and parent DomainFolder Identifier to the data dictionary and returns the new object. PARAMETERS: Name as String, DomainFolder as String or Integer.
Public Method Remove | Deletes a DomainFolder object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a DomainFolder object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of DomainFolder objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a DomainFolder object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

DomainFolders Overview


%%PageItemTitle%%

Add Method
Name
DomainFolder

Description

Adds a new DomainFolder with the given name and parent DomainFolder Identifier to the data dictionary and returns the new object. PARAMETERS: Name as String, DomainFolder as String or Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal DomainFolder As Variant _
) As DomainFolder

Parameters

Name
DomainFolder

See Also

DomainFolders Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a DomainFolder object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

DomainFolders Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a DomainFolder object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As DomainFolder

Parameters

Identifier

See Also

DomainFolders Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

DomainFolders Collection


%%PageItemTitle%%

Count Property

Description

This is the number of DomainFolder objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

DomainFolders Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a DomainFolder object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As DomainFolder

Parameters

Identifier

See Also

DomainFolders Collection


%%PageItemTitle%%

Domains Collection
See Also Members

Description

This object represents a collection of domains. The owner of this collection is the data dictionary.

Object Model

See Also

Domains Members


%%PageItemTitle%% $$Members$$

Domains Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new domain with the given names, adds it to the data dictionary, and returns the new object to the caller. PARAMETERS: Name as String, ColumnName as String.
Public Method AddEx | Adds a domain with the given parameters to the data dictionary and returns the new object. PARAMETERS: Name as String, AttributeName as String, ColumnName as String, DomainFolder as String or Integer.
Public Method Remove | Deletes a Domain object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Domain object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Domain objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Domain object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Domains Overview


%%PageItemTitle%%

Add Method
Name
ColumnName

Description

Creates a new domain with the given names, adds it to the data dictionary, and returns the new object to the caller. PARAMETERS: Name as String, ColumnName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal ColumnName As Variant _
) As Domain

Parameters

Name
ColumnName

See Also

Domains Collection


%%PageItemTitle%%

AddEx Method
Name
AttributeName
ColumnName
DomainFolder

Description

Adds a domain with the given parameters to the data dictionary and returns the new object. PARAMETERS: Name as String, AttributeName as String, ColumnName as String, DomainFolder as String or Integer.

Syntax

Visual Basic
Public Function AddEx( _
   ByVal Name As Variant, _
   ByVal AttributeName As Variant, _
   ByVal ColumnName As Variant, _
   ByVal DomainFolder As Variant _
) As Domain

Parameters

Name
AttributeName
ColumnName
DomainFolder

See Also

Domains Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Domain object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Domains Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Domain object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Domain

Parameters

Identifier

See Also

Domains Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Domains Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Domain objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Domains Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Domain object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Domain

Parameters

Identifier

See Also

Domains Collection


%%PageItemTitle%%

EnterpriseDataDictionaries Collection
See Also Members

Description

This object represents a collection of EnterpriseDataDictionary objects.

Object Model

See Also

EnterpriseDataDictionaries Members


%%PageItemTitle%% $$Members$$

EnterpriseDataDictionaries Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a Dictionary object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of EnterpriseDataDictionary objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Dictionary object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

See Also

EnterpriseDataDictionaries Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Dictionary object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Dictionary

Parameters

Identifier

See Also

EnterpriseDataDictionaries Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

EnterpriseDataDictionaries Collection


%%PageItemTitle%%

Count Property

Description

This is the number of EnterpriseDataDictionary objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

EnterpriseDataDictionaries Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Dictionary object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Dictionary

Parameters

Identifier

See Also

EnterpriseDataDictionaries Collection


%%PageItemTitle%%

Entities Collection
See Also Members

Description

This object represents a collection of entities. The owner of this collection is the model.

Object Model

See Also

Entities Members


%%PageItemTitle%% $$Members$$

Entities Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new entity with the given coordinates, adds it to the model, and returns the new entity to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method AddEx | Creates new entity with the given coordinates in parent model and returns it. Fixes positional problems of AddItem. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method AddMongoDBCollection | Creates new Collection (applicable to MondoDB models only) with the given coordinates, adds it to the model, and returns the new collection as type Entity to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Deletes a Entity object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns an entity (specified by the given name or ID) from the model. When passing a name to the function, the entity is indexed by the entity name in the logical model, and by the table name in a physical model.
Public Property _NewEnum |
Public Property Count | This is the number of Entity objects in the collection. DATATYPE: Integer.
Public Property Item | Returns an entity (specified by the given name or ID) from the model. When passing a name to the function, the entity is indexed by the entity name in the logical model, and by the table name in a physical model.

See Also

Entities Overview


%%PageItemTitle%%

Add Method
HorizontalPosition
VerticalPosition

Description

Creates a new entity with the given coordinates, adds it to the model, and returns the new entity to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Entity

Parameters

HorizontalPosition
VerticalPosition

See Also

Entities Collection


%%PageItemTitle%%

AddEx Method
HorizontalPosition
VerticalPosition

Description

Creates new entity with the given coordinates in parent model and returns it. Fixes positional problems of AddItem. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddEx( _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Entity

Parameters

HorizontalPosition
VerticalPosition

See Also

Entities Collection


%%PageItemTitle%%

AddMongoDBCollection Method
HorizontalPosition
VerticalPosition

Description

Creates new Collection (applicable to MondoDB models only) with the given coordinates, adds it to the model, and returns the new collection as type Entity to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddMongoDBCollection( _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Entity

Parameters

HorizontalPosition
VerticalPosition

See Also

Entities Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Entity object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Entities Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns an entity (specified by the given name or ID) from the model. When passing a name to the function, the entity is indexed by the entity name in the logical model, and by the table name in a physical model.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Entity

Parameters

Identifier

See Also

Entities Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Entities Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Entity objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Entities Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns an entity (specified by the given name or ID) from the model. When passing a name to the function, the entity is indexed by the entity name in the logical model, and by the table name in a physical model.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Entity

Parameters

Identifier

See Also

Entities Collection


%%PageItemTitle%%

Entity Object
See Also Members

Description

This object represents an entity in ER/Studio.

Object Model

See Also

Entity Members


%%PageItemTitle%% $$Members$$

Entity Object Members
See Also Overview

Public Methods

Public Method Attributes | Returns an object representing a collection of attributes in the entity.
Public Method BoundAttachments | Get all the BoundAttachments of this Entity.
Public Method BoundSecurityProperties | Get all the BoundSecurityProperties of this Entity.
Public Method ChildRelationships | Returns an object representing a collection of child relationships for the entity.
Public Method DataMovementRuleLinks | Get all the DataMovementRules bound to this Entity.
Public Method DB2OS390TablePartitions | Returns the collection of DB2 OS/390 table partitions. Also manages the partition key.
Public Method DB2UDBDimensions | Returns a collection of DB2 UDB v9.x dimensions.
Public Method DB2UDBTableRangePartitions | Returns the collection of DB2 UDB v9.x table range partitions. Also manages the partition key.
Public Method DeleteNamingStandardsTemplate | Unbind this Entity from the naming standards template by deleting the naming standards template ID from the entity.
Public Method GetNamingStandardsTemplate | Returns the naming standards template bound to the entity or null, if none is bound to the entity.
Public Method HiveStoredAsInputOutputHandlers | Use to set INPUTFORMAT and OUTPUTFORMAT handler class names for the STORED AS clause of the Create Table statement. Either strings must be empty or both strings must contain a handler name.
Public Method Indexes | Returns an object representing a collection of indexes in the entity.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method OracleTablePartitions | Returns the collection of oracle table partitions. Also manages the partition key and subpartition key and table level subpartitions.
Public Method ParentRelationships | Returns an object representing a collection of parent relationships for the entity.
Public Method RepoCheckOutStatus | Get the Check Out status of this Entity object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this Entity from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method TableCheckConstraints | Returns an object representing a collection of Table Level Check Constraints in the entity.
Public Method Triggers | Returns an object representing a collection of triggers in the entity.
Public Method UniversalMappings | Returns a collection of universal mappings applied to this object.
Public Method UserComments | Returns a collection of user comments associated with the entity.
Public Method UserDefinedMappings | Returns a collection of user defined mappings applied to this object.
Public Method WhereUsedModelUsage | Returns a collection of matches in other models based on the results of a WhereUsed analysis on this object.
Public Method WhereUsedSubmodelUsage | Returns a collection based on the results of a WhereUsed analysis of SubModels in the current model that contain this object.

Public Properties

Public Property AverageRowSize | This is the read-only AverageRowSize property of the table. It applies only to Oracle 10 g and higher versions of Oracle platforms.
Public Property Compress | This is the Compress property of the table. DATATYPE: Boolean.
Public Property CompressExpression | This property holds the table compress expression for the table. It only applies to Oracle 9 and older versions. DATATYPE: String.
Public Property DatabaseLocation | This is the Database location of the entity. The input string should not include dots. Dots will be removed. DATATYPE: String.
Public Property DB2Auditing | This is the Table Storage Auditing option. The only valid strings are NONE, CHANGES, and ALL. DATATYPE: String.
Public Property DB2DataCaptureChg | This is the Table Storage Log Data Changes value. DATATYPE: Boolean.
Public Property DB2EditProc | This is the Table Storage Edit Proc value. DATATYPE: String.
Public Property DB2Encoding | This is the Table Storage Encoding option. Valid string values are only ASCII, EBCDIC, and NONE. DATATYPE: String.
Public Property DB2InDatabase | This indicates if the Table Storage is In Database. DATATYPE: Boolean.
Public Property DB2OSVolatile | This specifies if a table is volatile and it applies only to DB2 OS/390 V8 or later versions. DATATYPE: Boolean.
Public Property DB2RestrictOnDrop | This is the Table Storage Restrict On Drop value. DATATYPE: Boolean.
Public Property DB2ValidProc | This is the Table Storage Valid Proc value.DATATYPE: String.
Public Property Definition | This is the definition of the entity. DATATYPE: String.
Public Property DimensionTableType | This is the Dimension Table Type. The possible values are FIXED, TYPE1, TYPE2 or TYPE3. DATATYPE: String.
Public Property DimModelTableType | This is the Dimensional Model Table Type. The possible values are DIMENSION, FACT, SNOWFLAKE or UNDEFINED. DATATYPE: String.
Public Property DimModelTableTypeOverride | This sets the Dimensional Model Table Type Override on or off. The possible values are true or false. DATATYPE: Boolean.
Public Property DoNotGenerate | If true, the Table will not be generated in the DDL. DATATYPE: Boolean.
Public Property EntityName | This is the name of the entity in the logical model. DATATYPE: String.
Public Property FreeListGroups | This is the FreeListGroups of the entity storage. DATATYPE: Integer.
Public Property FreeLists | This is the FreeLists of the entity storage. DATATYPE: Integer.
Public Property FreezeName | True if this entity should not be affected by naming standards name updates. DATATYPE: Boolean.
Public Property GenPostSQL | This is the Generate PostSQL option of the entity. DATATYPE: Boolean.
Public Property GenPreSQL | This is the Generate PreSQL option of the entity. DATATYPE: Boolean.
Public Property GreenplumDistributionColumns | This is the GreenplumDistributionColumns property of the table. It applies only to Greenplum. DATATYPE: String.
Public Property GreenplumDistributionRandom | This is the GreenplumDistributionRandom property of the table. It applies only to Greenplum. DATATYPE: Boolean.
Public Property GrowthPeriod | This is the period the growth rate is based on. The value of this property can be one of these: Day, Week, Month, Quarter or Year. This property applies only to physical models. DATATYPE: String.
Public Property GrowthRate | This determines how fast a table will grow. This property applies only to physical models. DATATYPE: Integer.
Public Property GrowthType | This is the the type the growth rate is based on. The value of this property can be either Percent or Rows. This property applies only to physical models. DATATYPE: String.
Public Property GUID | GUID of the entity. This GUID is assigned by ER/Studio. Each entity has a unique GUID. DATATYPE: String.
Public Property HiRDBFix | This is the Fix option of the entity storage. DATATYPE: Boolean.
Public Property HiRDBRowLock | This is the Row Lock option of the entity storage. DATATYPE: Boolean.
Public Property HiRDBStorageIn | This is the Storage In option of the entity storage. DATATYPE: Boolean.
Public Property HiveAsSelect | Hive only. This property holds AsSelect value for the table. DATATYPE: String.
Public Property HiveClusteredByColumns | Hive only. This property holds the comma separated list of Clustered By columns. DATATYPE: String.
Public Property HiveExternalTable | This is the External property of the table. If true, the table with be created extenally: CREATE EXTERNAL TABLE ... It applies only to Hive models. DATATYPE: Boolean.
Public Property HiveLocation | This property determines where the table will be stored in the HDFS. It applies only to Hive models. DATATYPE: String.
Public Property HiveNumBuckets | Hive only. This property NUM_BUCKETS value for the table. DATATYPE: Integer.
Public Property HiveRowFormatCollections | This property corresponds to COLLECTION ITEMS TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.
Public Property HiveRowFormatDelimited | This Hive only property pertains to the RowFormat of the table. If true, the table will be created with ROW FORMAT DELIMITED. Cannot be set to true if a RowFormat SerDe has been specified (via HiveStoredBySerDeHandler). DATATYPE: Boolean.
Public Property HiveRowFormatEscapedBy | This Hive only property corresponds to ESCAPED BY part of the FIELDS TERMINATED BY clause in the create table statement. It requires HiveRowFormatFields to be set. DATATYPE: String.
Public Property HiveRowFormatFields | This property corresponds to FIELDS TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.
Public Property HiveRowFormatLines | This property corresponds to LINES TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.
Public Property HiveRowFormatMapKeys | This property corresponds to MAP KEYS TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.
Public Property HiveRowFormatNullDefinedBy | This Hive only property corresponds to NULL DEFINED AS of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. (Available on DBServers starting with Hive 0.13). DATATYPE: String.
Public Property HiveRowFormatSerDeHandler | This property is the name of the SerDe handler for ROW FORMAT. It requires HiveRowFormatDelimited to be false. It applies only to Hive models. DATATYPE: String.
Public Property HiveRowFormatSerDeProperties | This property holds the comma separated properties for ROW FORMAT SerDe. It requires HiveRowFormatSerDeHandler to be set. It applies only to Hive models. DATATYPE: String.
Public Property HiveSkewedByColumns | Hive only. This property holds the comma separated list of Skewed By columns. DATATYPE: String.
Public Property HiveSkewedByValues | Hive only. This property holds the Skewed On Values for the table. DATATYPE: String.
Public Property HiveSortedByColumns | Hive only. This property holds the comma separated list of Sorted By columns. DATATYPE: String.
Public Property HiveStoredAs | Hive only. Is file format in the STORED AS clause. Valid input: , BINARYFILE, ORC, RCFILE, SEQUENCEFILE, TEXTFILE. Output also includes InputOutput Handler clause. HiveStoredBySerDeHandler must be empty. DATATYPE: String.
Public Property HiveStoredAsByNumber | Same as HiveStoredAs, but enumerates the file format as follows: 0:not set, 1:BINARYFILE, 2:INPUT FORMAT OUTPUT FORMAT , 3:ORC, 4:RCFILE, 5:SEQUENCEFILE, 6:TEXTFILE. 2 is output only. DATATYPE: Integer.
Public Property HiveStoredAsInputHandler | Hive only. Read only. This is the INPUTFORMAT handler name of the STORED AS clause. Of the INPUTFORMAT handler.class.name string it returns the handler.class.name part. HiveStoredBySerDeHandler must be empty. DATATYPE: String.
Public Property HiveStoredAsOutputHandler | Hive only. Read only. This is the OUTPUTFORMAT handler name of the STORED AS clause. Of the OUTPUTFORMAT handler.class.name string it returns the handler.class.name part. HiveStoredBySerDeHandler must be empty. DATATYPE: String.
Public Property HiveStoredBySerDeHandler | This Hive only property is the name of the SerDe handler that would appear in the STORED BY clause of the Create Table statement. It requires HiveStoredAs to be empty. DATATYPE: String.
Public Property HiveStoredBySerDeProperties | This Hive only property holds the comma separated properties for STORED BY SerDe. It requires HiveStoredBySerDeHandler to be set. DATATYPE: String.
Public Property HiveTblProperties | Hive only. This property holds the TblProperties value for the table. DATATYPE: String.
Public Property ID | ID of the entity. This ID is assigned by ER/Studio. Each entity in a diagram has a unique ID. DATATYPE: Integer.
Public Property IndexTablespace | This property specifies the Tablespace in which the Index for this table will be created. DATATYPE: String.
Public Property InformixLockMode | This is the InformixLockMode property of the table. It applies to Informix Online and Informix 9.x or later versions. DATATYPE: Integer. Possible values: 0 for PAGE and 1 for ROW.
Public Property InitialExtent | This is the initial extent of the entity storage. DATATYPE: Integer.
Public Property InitTransactions | This is the Initial Transactions of the entity storage. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property IsStatic | This determines if a table is a static table or it will grow. This property applies only to physical models. DATATYPE: Boolean.
Public Property LastSourced | This property is for DataLineage and applies only if the parent model is physical and has been enabled for data movement. This property tells when the data was last sourced. DATATYPE: String.
Public Property LogForReplication | Specifies that the table's data are physically replicated on each partition on which the table is defined. DATATYPE: Boolean.
Public Property LogOrPhysOnly | Controls the logical/physical only Entity Property. DATATYPE: Boolean.
Public Property LongTablespace | This property identifies the Tablespace in which the values of any long columns will be stored. DATATYPE: String.
Public Property MaxExtents | This is the MaxExtents of the entity storage. Parameter can be positive integer as string or UNLIMITED. DATATYPE: String.
Public Property MaximumRows | This is the maximum number of rows a table can hold. This property applies only to physical models. DATATYPE: Integer.
Public Property MaxTransactions | This is the MaxTransactions of the entity storage. DATATYPE: Integer.
Public Property MinExtents | This is the MinExtents of the entity storage. DATATYPE: Integer.
Public Property MySQLTableType | This is the type of the table for MySQL model. The possible values are MYISAM or INNODB. DATATYPE: String.
Public Property NamingStandardsTemplateId | ID of the NamingStandardsTemplate object bound to the entity (if any). A user can bind a NamingStandardsTemplate to the entity by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.
Public Property NetezzaDistributionColumns | This is the NetezzaDistributionColumns property of the table. It applies only to Netezza 4.6, 5.0 and later versions. DATATYPE: String.
Public Property NetezzaDistributionRandom | This is the NetezzaDistributionRandom property of the table. It applies only to Netezza 4.6, 5.0 and later versions. DATATYPE: Boolean.
Public Property NetezzaOrganizationColumns | This is the Organization Key property of the table and contains up to four comma separated columns. It applies to Netezza 6.0 or later. DATATYPE: String.
Public Property NextExtent | This is the next extent of the entity storage. DATATYPE: Integer.
Public Property NoLogging | This determines whether there is no logging (true) or logging (false) in the entity storage. DATATYPE: Boolean.
Public Property Note | This is the note of the entity. DATATYPE: String.
Public Property OracleBufferPool | This is the BufferPool of the entity storage. Values can be KEEP, RECYCLE, DEFAULT or NONE. DATATYPE: String.
Public Property OracleCache | This is the Cache property of the entity storage. Must be heap organized. True for Cache on, false for Cache off. DATATYPE: Boolean.
Public Property OracleDegrees | This is the Degrees property of the entity storage. Degrees is only valid if parallel is true. DATATYPE: String.
Public Property OracleIndex | This is the Index property of the entity storage. It is true if index organized, false if heap organized. DATATYPE: Boolean.
Public Property OracleInstances | This is the Indexes property of the entity storage. Instances is only valid if parallel is true. DATATYPE: String.
Public Property OracleParallel | This is the Parallel option of the entity storage. DATATYPE: Boolean.
Public Property OracleRowMovement | This is the OracleRowMovement property of the table. It applies only to Oracle 9 and later versions, and it is not supported for non-partitioned index-organized tables. DATATYPE: Boolean.
Public Property Owner | This is the owner of the entity. DATATYPE: String.
Public Property PctFree | This is the percent free of the entity storage. DATATYPE: Integer.
Public Property PctIncrease | This is the percent increase of the entity storage. DATATYPE: Integer.
Public Property PctUsed | This is the percent used by the entity storage. DATATYPE: Integer.
Public Property PostSQL | This is the PostSQL of the entity. DATATYPE: String.
Public Property PreSQL | This is the PreSQL of the entity. DATATYPE: String.
Public Property RowCount | This is the current number of rows in a table. This property applies only to physical models. DATATYPE: Integer.
Public Property SourcingFrequency | This property is for DataLineage and applies only if the parent model is physical and has been enabled for data movement. This property tells how often the data is sourced. DATATYPE: String.
Public Property StorageLocation | This is the storage location of the entity. DATATYPE: String.
Public Property SybaseIdentityGap | This is the Identity Gap option of the entity storage. It must be a positive integer (in kilobytes). DATATYPE: Integer.
Public Property SybaseLockingScheme | This is the Locking Scheme option of the entity storage. The possible values are ALLPAGES, DATAPAGES or DATAROWS. DATATYPE: String.
Public Property SybaseMaxRowsPerPage | This is the Max Rows Per Page option of the sybase table storage. DATATYPE: Integer.
Public Property SybasePrefetchStrategyOn | This is the Prefetch Strategy option of the entity storage. If it is true then the prefetch strategy is on, if it is false then it is off. DATATYPE: Boolean.
Public Property SybaseReplacementStrategyMRU | This is the Replacement Strategy option of the entity storage. If it is true then the MRU replacement strategy is use, if it is false then LRU is used. DATATYPE: Boolean.
Public Property SybaseReservePageGap | This is the Reserve Page Gap option of the entity storage. It must be a positive integer (in kilobytes). DATATYPE: Integer.
Public Property SystemName | This is the system name of the AS400 table. DATATYPE: String.
Public Property TableDDL | This is the TableDDL of the entity. DATATYPE: String.
Public Property TableName | This is the name of the table in a physical model. DATATYPE: String.
Public Property TeradataAfterJournal | This is the After Journal option of the entity storage. The possible values are -- --, NO, DUAL, LOCAL, NOT LOCAL or the empty string (meaning nothing has been specified). DATATYPE: String.
Public Property TeradataBeforeJournal | This is the Before Journal option of the entity storage. The possible values are -- --, NO, DUAL or the empty string (meaning nothing has been specified). DATATYPE: String.
Public Property TeradataChecksum | This is the TeradataChecksum property of the table. It applies to Teradata 12 or later versions. DATATYPE: String. Possible values: Default,All,High,Medium,Low,None, or empty(no DDL output)
Public Property TeradataDatablockSize | This is the Datablock Size option of the entity storage. It can be a positive integer (in kilobytes) or the string MINIMUM or MAXIMUM. DATATYPE: Integer or String.
Public Property TeradataDuplicateRowControl | This is the DuplicateRowControl option of the entity storage. The possible values are SET, MULTISET or the empty string (meaning nothing has been specified). DATATYPE: String.
Public Property TeradataFallback | This is the Fallback protection option of the entity storage. If it is true then Fallback protection is used for the table. DATATYPE: Boolean.
Public Property TeradataJournalName | This is the Journal Name option of the entity storage. If the entity has a Journal Table, then the name of the table is stored here. DATATYPE: String.
Public Property TextImageFileGroup | This property specifies the table space in which the text/image columns are stored for the table. DATATYPE: String.
Public Property TextLabel | This is the text label of the AS400 table. DATATYPE: String.

See Also

Entity Overview


%%PageItemTitle%%

Attributes Method

Description

Returns an object representing a collection of attributes in the entity.

Syntax

Visual Basic
Public Function Attributes() As Attributes

Example

Dim MyEntity As Entity

Dim MyAttribute As AttributeObj

For Each MyAttribute In MyEntity.Attributes

' Operations on Attributes collection go here

...

Next MyAttribute

See Also

Entity Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Entity.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Entity Object


%%PageItemTitle%%

BoundSecurityProperties Method

Description

Get all the BoundSecurityProperties of this Entity.

Syntax

Visual Basic
Public Function BoundSecurityProperties() As BoundSecurityProperties

See Also

Entity Object


%%PageItemTitle%%

ChildRelationships Method

Description

Returns an object representing a collection of child relationships for the entity.

Syntax

Visual Basic
Public Function ChildRelationships() As Relationships

Example

Dim MyEntity As Entity

Dim MyChildRelationship As Relationship

For Each MyChildRelationship In MyEntity.ChildRelationships

' Operations on the ChildRelationships collection go here

...

Next MyChildRelationship

See Also

Entity Object


%%PageItemTitle%%

DataMovementRuleLinks Method

Description

Get all the DataMovementRules bound to this Entity.

Syntax

Visual Basic
Public Function DataMovementRuleLinks() As DataMovementRuleLinks

See Also

Entity Object


%%PageItemTitle%%

DB2OS390TablePartitions Method

Description

Returns the collection of DB2 OS/390 table partitions. Also manages the partition key.

Syntax

Visual Basic
Public Function DB2OS390TablePartitions() As DB2OS390TablePartitions

See Also

Entity Object


%%PageItemTitle%%

DB2UDBDimensions Method

Description

Returns a collection of DB2 UDB v9.x dimensions.

Syntax

Visual Basic
Public Function DB2UDBDimensions() As DB2UDBDimensions

See Also

Entity Object


%%PageItemTitle%%

DB2UDBTableRangePartitions Method

Description

Returns the collection of DB2 UDB v9.x table range partitions. Also manages the partition key.

Syntax

Visual Basic
Public Function DB2UDBTableRangePartitions() As DB2UDBTableRangePartitions

See Also

Entity Object


%%PageItemTitle%%

DeleteNamingStandardsTemplate Method

Description

Unbind this Entity from the naming standards template by deleting the naming standards template ID from the entity.

Syntax

Visual Basic
Public Function DeleteNamingStandardsTemplate() As Variant

See Also

Entity Object


%%PageItemTitle%%

GetNamingStandardsTemplate Method

Description

Returns the naming standards template bound to the entity or null, if none is bound to the entity.

Syntax

Visual Basic
Public Function GetNamingStandardsTemplate() As NamingStandardsTemplate

See Also

Entity Object


%%PageItemTitle%%

HiveStoredAsInputOutputHandlers Method
Input
Output

Description

Use to set INPUTFORMAT and OUTPUTFORMAT handler class names for the STORED AS clause of the Create Table statement. Either strings must be empty or both strings must contain a handler name.

Syntax

Visual Basic
Public Sub HiveStoredAsInputOutputHandlers( _
   ByVal Input As Variant, _
   ByVal Output As Variant _
)

Parameters

Input
Output

See Also

Entity Object


%%PageItemTitle%%

Indexes Method

Description

Returns an object representing a collection of indexes in the entity.

Syntax

Visual Basic
Public Function Indexes() As Indexes

Example

Dim MyEntity As Entity

Dim MyIndex As Index

For Each MyIndex In MyEntity.Indexes

' Operations on Indexes collection go here

...

Next MyIndex

See Also

Entity Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

Entity Object


%%PageItemTitle%%

OracleTablePartitions Method

Description

Returns the collection of oracle table partitions. Also manages the partition key and subpartition key and table level subpartitions.

Syntax

Visual Basic
Public Function OracleTablePartitions() As OracleTablePartitions

See Also

Entity Object


%%PageItemTitle%%

ParentRelationships Method

Description

Returns an object representing a collection of parent relationships for the entity.

Syntax

Visual Basic
Public Function ParentRelationships() As Relationships

Example

Dim MyEntity As Entity

Dim MyParentRelationship As Relationship

For Each MyParentRelationship In MyEntity.ParentRelationships

' Operations on the ParentRelationships collection go here

...

Next MyParentRelationship

See Also

Entity Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Entity object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Entity Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this Entity from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

Entity Object


%%PageItemTitle%%

TableCheckConstraints Method

Description

Returns an object representing a collection of Table Level Check Constraints in the entity.

Syntax

Visual Basic
Public Function TableCheckConstraints() As TableCheckConstraints

See Also

Entity Object


%%PageItemTitle%%

Triggers Method

Description

Returns an object representing a collection of triggers in the entity.

Syntax

Visual Basic
Public Function Triggers() As Triggers

Example

Dim MyEntity As Entity

Dim MyTrigger As Trigger

For Each MyTrigger In MyEntity.Triggers

' Operations on Triggers collection go here

...

Next MyTrigger

See Also

Entity Object


%%PageItemTitle%%

UniversalMappings Method

Description

Returns a collection of universal mappings applied to this object.

Syntax

Visual Basic
Public Function UniversalMappings() As UniversalMappings

See Also

Entity Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with the entity.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Entity Object


%%PageItemTitle%%

UserDefinedMappings Method

Description

Returns a collection of user defined mappings applied to this object.

Syntax

Visual Basic
Public Function UserDefinedMappings() As UserDefinedMappingCollection

See Also

Entity Object


%%PageItemTitle%%

WhereUsedModelUsage Method

Description

Returns a collection of matches in other models based on the results of a WhereUsed analysis on this object.

Syntax

Visual Basic
Public Function WhereUsedModelUsage() As WhereUsedDataCollection

See Also

Entity Object


%%PageItemTitle%%

WhereUsedSubmodelUsage Method

Description

Returns a collection based on the results of a WhereUsed analysis of SubModels in the current model that contain this object.

Syntax

Visual Basic
Public Function WhereUsedSubmodelUsage() As WhereUsedDataCollection

See Also

Entity Object


%%PageItemTitle%%

AverageRowSize Property

Description

This is the read-only AverageRowSize property of the table. It applies only to Oracle 10 g and higher versions of Oracle platforms.

Property type

Read-only property

Syntax

Visual Basic
Public Property AverageRowSize() As Variant

See Also

Entity Object


%%PageItemTitle%%

Compress Property

Description

This is the Compress property of the table. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compress() As Variant

See Also

Entity Object


%%PageItemTitle%%

CompressExpression Property

Description

This property holds the table compress expression for the table. It only applies to Oracle 9 and older versions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CompressExpression() As Variant

See Also

Entity Object


%%PageItemTitle%%

DatabaseLocation Property

Description

This is the Database location of the entity. The input string should not include dots. Dots will be removed. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseLocation() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2Auditing Property

Description

This is the Table Storage Auditing option. The only valid strings are NONE, CHANGES, and ALL. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2Auditing() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2DataCaptureChg Property

Description

This is the Table Storage Log Data Changes value. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2DataCaptureChg() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2EditProc Property

Description

This is the Table Storage Edit Proc value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2EditProc() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2Encoding Property

Description

This is the Table Storage Encoding option. Valid string values are only ASCII, EBCDIC, and NONE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2Encoding() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2InDatabase Property

Description

This indicates if the Table Storage is In Database. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2InDatabase() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2OSVolatile Property

Description

This specifies if a table is volatile and it applies only to DB2 OS/390 V8 or later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2OSVolatile() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2RestrictOnDrop Property

Description

This is the Table Storage Restrict On Drop value. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2RestrictOnDrop() As Variant

See Also

Entity Object


%%PageItemTitle%%

DB2ValidProc Property

Description

This is the Table Storage Valid Proc value.DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2ValidProc() As Variant

See Also

Entity Object


%%PageItemTitle%%

Definition Property

Description

This is the definition of the entity. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

Example

Dim MyEntity As Entity

Dim EntDef As String

MyEntity.Definition = EntDef

See Also

Entity Object


%%PageItemTitle%%

DimensionTableType Property

Description

This is the Dimension Table Type. The possible values are FIXED, TYPE1, TYPE2 or TYPE3. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionTableType() As Variant

See Also

Entity Object


%%PageItemTitle%%

DimModelTableType Property

Description

This is the Dimensional Model Table Type. The possible values are DIMENSION, FACT, SNOWFLAKE or UNDEFINED. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimModelTableType() As Variant

See Also

Entity Object


%%PageItemTitle%%

DimModelTableTypeOverride Property

Description

This sets the Dimensional Model Table Type Override on or off. The possible values are true or false. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimModelTableTypeOverride() As Variant

See Also

Entity Object


%%PageItemTitle%%

DoNotGenerate Property

Description

If true, the Table will not be generated in the DDL. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DoNotGenerate() As Variant

See Also

Entity Object


%%PageItemTitle%%

EntityName Property

Description

This is the name of the entity in the logical model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityName() As Variant

Example

Sets the entity name for each entity in the given collection

Dim MyDiagram As Diagram

Dim MyModel As Model

Dim MyEntity As Entity

Dim EntName As String

Dim Count As Integer

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.ActiveModel

Count = 1

Iterates through the Entities collection to rename all entities

For Each MyEntity In MyModel.Entities

Uses CStr function to convert the Count variable to a string

EntName = "ShinyNewEntity" + CStr (Count)

MyEntity.EntityName = EntName

Count = Count + 1

Next MyEntity

See Also

Entity Object


%%PageItemTitle%%

FreeListGroups Property

Description

This is the FreeListGroups of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeListGroups() As Variant

See Also

Entity Object


%%PageItemTitle%%

FreeLists Property

Description

This is the FreeLists of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeLists() As Variant

See Also

Entity Object


%%PageItemTitle%%

FreezeName Property

Description

True if this entity should not be affected by naming standards name updates. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreezeName() As Variant

See Also

Entity Object


%%PageItemTitle%%

GenPostSQL Property

Description

This is the Generate PostSQL option of the entity. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

Entity Object


%%PageItemTitle%%

GenPreSQL Property

Description

This is the Generate PreSQL option of the entity. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

Entity Object


%%PageItemTitle%%

GreenplumDistributionColumns Property

Description

This is the GreenplumDistributionColumns property of the table. It applies only to Greenplum. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GreenplumDistributionColumns() As Variant

See Also

Entity Object


%%PageItemTitle%%

GreenplumDistributionRandom Property

Description

This is the GreenplumDistributionRandom property of the table. It applies only to Greenplum. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GreenplumDistributionRandom() As Variant

See Also

Entity Object


%%PageItemTitle%%

GrowthPeriod Property

Description

This is the period the growth rate is based on. The value of this property can be one of these: Day, Week, Month, Quarter or Year. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GrowthPeriod() As Variant

See Also

Entity Object


%%PageItemTitle%%

GrowthRate Property

Description

This determines how fast a table will grow. This property applies only to physical models. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GrowthRate() As Variant

See Also

Entity Object


%%PageItemTitle%%

GrowthType Property

Description

This is the the type the growth rate is based on. The value of this property can be either Percent or Rows. This property applies only to physical models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GrowthType() As Variant

See Also

Entity Object


%%PageItemTitle%%

GUID Property

Description

GUID of the entity. This GUID is assigned by ER/Studio. Each entity has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiRDBFix Property

Description

This is the Fix option of the entity storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiRDBFix() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiRDBRowLock Property

Description

This is the Row Lock option of the entity storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiRDBRowLock() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiRDBStorageIn Property

Description

This is the Storage In option of the entity storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiRDBStorageIn() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveAsSelect Property

Description

Hive only. This property holds AsSelect value for the table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveAsSelect() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveClusteredByColumns Property

Description

Hive only. This property holds the comma separated list of Clustered By columns. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveClusteredByColumns() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveExternalTable Property

Description

This is the External property of the table. If true, the table with be created extenally: CREATE EXTERNAL TABLE ... It applies only to Hive models. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveExternalTable() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveLocation Property

Description

This property determines where the table will be stored in the HDFS. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveLocation() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveNumBuckets Property

Description

Hive only. This property NUM_BUCKETS value for the table. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveNumBuckets() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatCollections Property

Description

This property corresponds to COLLECTION ITEMS TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatCollections() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatDelimited Property

Description

This Hive only property pertains to the RowFormat of the table. If true, the table will be created with ROW FORMAT DELIMITED. Cannot be set to true if a RowFormat SerDe has been specified (via HiveStoredBySerDeHandler). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatDelimited() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatEscapedBy Property

Description

This Hive only property corresponds to ESCAPED BY part of the FIELDS TERMINATED BY clause in the create table statement. It requires HiveRowFormatFields to be set. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatEscapedBy() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatFields Property

Description

This property corresponds to FIELDS TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatFields() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatLines Property

Description

This property corresponds to LINES TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatLines() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatMapKeys Property

Description

This property corresponds to MAP KEYS TERMINATED BY of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatMapKeys() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatNullDefinedBy Property

Description

This Hive only property corresponds to NULL DEFINED AS of the ROW FORMAT clause in the create table statement. It requires HiveRowFormatDelimited to be true. (Available on DBServers starting with Hive 0.13). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatNullDefinedBy() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatSerDeHandler Property

Description

This property is the name of the SerDe handler for ROW FORMAT. It requires HiveRowFormatDelimited to be false. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatSerDeHandler() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveRowFormatSerDeProperties Property

Description

This property holds the comma separated properties for ROW FORMAT SerDe. It requires HiveRowFormatSerDeHandler to be set. It applies only to Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveRowFormatSerDeProperties() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveSkewedByColumns Property

Description

Hive only. This property holds the comma separated list of Skewed By columns. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveSkewedByColumns() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveSkewedByValues Property

Description

Hive only. This property holds the Skewed On Values for the table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveSkewedByValues() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveSortedByColumns Property

Description

Hive only. This property holds the comma separated list of Sorted By columns. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveSortedByColumns() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveStoredAs Property

Description

Hive only. Is file format in the STORED AS clause. Valid input: , BINARYFILE, ORC, RCFILE, SEQUENCEFILE, TEXTFILE. Output also includes InputOutput Handler clause. HiveStoredBySerDeHandler must be empty. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveStoredAs() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveStoredAsByNumber Property

Description

Same as HiveStoredAs, but enumerates the file format as follows: 0:not set, 1:BINARYFILE, 2:INPUT FORMAT OUTPUT FORMAT , 3:ORC, 4:RCFILE, 5:SEQUENCEFILE, 6:TEXTFILE. 2 is output only. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveStoredAsByNumber() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveStoredAsInputHandler Property

Description

Hive only. Read only. This is the INPUTFORMAT handler name of the STORED AS clause. Of the INPUTFORMAT handler.class.name string it returns the handler.class.name part. HiveStoredBySerDeHandler must be empty. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property HiveStoredAsInputHandler() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveStoredAsOutputHandler Property

Description

Hive only. Read only. This is the OUTPUTFORMAT handler name of the STORED AS clause. Of the OUTPUTFORMAT handler.class.name string it returns the handler.class.name part. HiveStoredBySerDeHandler must be empty. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property HiveStoredAsOutputHandler() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveStoredBySerDeHandler Property

Description

This Hive only property is the name of the SerDe handler that would appear in the STORED BY clause of the Create Table statement. It requires HiveStoredAs to be empty. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveStoredBySerDeHandler() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveStoredBySerDeProperties Property

Description

This Hive only property holds the comma separated properties for STORED BY SerDe. It requires HiveStoredBySerDeHandler to be set. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveStoredBySerDeProperties() As Variant

See Also

Entity Object


%%PageItemTitle%%

HiveTblProperties Property

Description

Hive only. This property holds the TblProperties value for the table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveTblProperties() As Variant

See Also

Entity Object


%%PageItemTitle%%

ID Property

Description

ID of the entity. This ID is assigned by ER/Studio. Each entity in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyEntity As Entity

Dim EntID As Integer

'code that Sets Diagram and Model references here

EntID = MyEntity.ID

See Also

Entity Object


%%PageItemTitle%%

IndexTablespace Property

Description

This property specifies the Tablespace in which the Index for this table will be created. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexTablespace() As Variant

See Also

Entity Object


%%PageItemTitle%%

InformixLockMode Property

Description

This is the InformixLockMode property of the table. It applies to Informix Online and Informix 9.x or later versions. DATATYPE: Integer. Possible values: 0 for PAGE and 1 for ROW.

Property type

Read-write property

Syntax

Visual Basic
Public Property InformixLockMode() As Variant

See Also

Entity Object


%%PageItemTitle%%

InitialExtent Property

Description

This is the initial extent of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitialExtent() As Variant

Example

Dim MyEntity As Entity

Dim InitExtent As Integer

InitExtent = 30 'gives 30KB space

MyEntity.InitialExtent = InitExtent

See Also

Entity Object


%%PageItemTitle%%

InitTransactions Property

Description

This is the Initial Transactions of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitTransactions() As Variant

See Also

Entity Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

Example

Sub Main

Dim MyDiagram As Diagram

Dim m As Model

Dim e As Entities

Dim ent As Entity

Dim atr As AttributeObj

Set MyDiagram = DiagramManager.ActiveDiagram

Set m = MyDiagram.ActiveModel

Set e = m.Entities

For Each ent In e

For Each atr In ent.Attributes

atr.LogicalRoleName = ent.EntityName + "_" + atr.AttributeName + "_Role"

Next atr

Next ent

For Each ent In e

For Each atr In ent.Attributes

If atr.HasLogicalRoleName then

MsgBox("ENT: " + ent.EntityName + vbCrLf + _

"ATTR: " + atr.AttributeName + vbCrLf + _

"LogicalRoleName: " + atr.LogicalRoleName)

End If

Next atr

Next ent

End Sub

See Also

Entity Object


%%PageItemTitle%%

IsStatic Property

Description

This determines if a table is a static table or it will grow. This property applies only to physical models. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsStatic() As Variant

See Also

Entity Object


%%PageItemTitle%%

LastSourced Property

Description

This property is for DataLineage and applies only if the parent model is physical and has been enabled for data movement. This property tells when the data was last sourced. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LastSourced() As Variant

See Also

Entity Object


%%PageItemTitle%%

LogForReplication Property

Description

Specifies that the table's data are physically replicated on each partition on which the table is defined. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogForReplication() As Variant

See Also

Entity Object


%%PageItemTitle%%

LogOrPhysOnly Property

Description

Controls the logical/physical only Entity Property. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogOrPhysOnly() As Variant

See Also

Entity Object


%%PageItemTitle%%

LongTablespace Property

Description

This property identifies the Tablespace in which the values of any long columns will be stored. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LongTablespace() As Variant

See Also

Entity Object


%%PageItemTitle%%

MaxExtents Property

Description

This is the MaxExtents of the entity storage. Parameter can be positive integer as string or UNLIMITED. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtents() As Variant

See Also

Entity Object


%%PageItemTitle%%

MaximumRows Property

Description

This is the maximum number of rows a table can hold. This property applies only to physical models. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaximumRows() As Variant

See Also

Entity Object


%%PageItemTitle%%

MaxTransactions Property

Description

This is the MaxTransactions of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxTransactions() As Variant

See Also

Entity Object


%%PageItemTitle%%

MinExtents Property

Description

This is the MinExtents of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtents() As Variant

See Also

Entity Object


%%PageItemTitle%%

MySQLTableType Property

Description

This is the type of the table for MySQL model. The possible values are MYISAM or INNODB. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MySQLTableType() As Variant

See Also

Entity Object


%%PageItemTitle%%

NamingStandardsTemplateId Property

Description

ID of the NamingStandardsTemplate object bound to the entity (if any). A user can bind a NamingStandardsTemplate to the entity by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamingStandardsTemplateId() As Variant

See Also

Entity Object


%%PageItemTitle%%

NetezzaDistributionColumns Property

Description

This is the NetezzaDistributionColumns property of the table. It applies only to Netezza 4.6, 5.0 and later versions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property NetezzaDistributionColumns() As Variant

See Also

Entity Object


%%PageItemTitle%%

NetezzaDistributionRandom Property

Description

This is the NetezzaDistributionRandom property of the table. It applies only to Netezza 4.6, 5.0 and later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NetezzaDistributionRandom() As Variant

See Also

Entity Object


%%PageItemTitle%%

NetezzaOrganizationColumns Property

Description

This is the Organization Key property of the table and contains up to four comma separated columns. It applies to Netezza 6.0 or later. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property NetezzaOrganizationColumns() As Variant

See Also

Entity Object


%%PageItemTitle%%

NextExtent Property

Description

This is the next extent of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtent() As Variant

Example

Dim MyEntity As Entity

Dim iNextExtent As Integer

iNextExtent = 30

MyEntity.NextExtent = iNextExtent

See Also

Entity Object


%%PageItemTitle%%

NoLogging Property

Description

This determines whether there is no logging (true) or logging (false) in the entity storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoLogging() As Variant

Example

Dim MyEntity As Entity

Dim bNoLogging As Boolean

bNoLogging = True

MyEntity.NoLogging = bNoLogging

See Also

Entity Object


%%PageItemTitle%%

Note Property

Description

This is the note of the entity. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Note() As Variant

Example

Dim MyEntity As Entity

Dim StorNote As String = "Pick up shirts from laundry"

MyEntity.Note = StorNote

See Also

Entity Object


%%PageItemTitle%%

OracleBufferPool Property

Description

This is the BufferPool of the entity storage. Values can be KEEP, RECYCLE, DEFAULT or NONE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleBufferPool() As Variant

See Also

Entity Object


%%PageItemTitle%%

OracleCache Property

Description

This is the Cache property of the entity storage. Must be heap organized. True for Cache on, false for Cache off. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleCache() As Variant

See Also

Entity Object


%%PageItemTitle%%

OracleDegrees Property

Description

This is the Degrees property of the entity storage. Degrees is only valid if parallel is true. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleDegrees() As Variant

See Also

Entity Object


%%PageItemTitle%%

OracleIndex Property

Description

This is the Index property of the entity storage. It is true if index organized, false if heap organized. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleIndex() As Variant

See Also

Entity Object


%%PageItemTitle%%

OracleInstances Property

Description

This is the Indexes property of the entity storage. Instances is only valid if parallel is true. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleInstances() As Variant

See Also

Entity Object


%%PageItemTitle%%

OracleParallel Property

Description

This is the Parallel option of the entity storage. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleParallel() As Variant

See Also

Entity Object


%%PageItemTitle%%

OracleRowMovement Property

Description

This is the OracleRowMovement property of the table. It applies only to Oracle 9 and later versions, and it is not supported for non-partitioned index-organized tables. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleRowMovement() As Variant

See Also

Entity Object


%%PageItemTitle%%

Owner Property

Description

This is the owner of the entity. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

Example

Dim MyEntity As Entity

Dim strOwner As String = "EntOwner"

MyEntity.Owner = strOwner

See Also

Entity Object


%%PageItemTitle%%

PctFree Property

Description

This is the percent free of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctFree() As Variant

Example

Dim MyEntity As Entity

Dim iPctFree As Integer

iPctFree = MyEntity.PctFree

See Also

Entity Object


%%PageItemTitle%%

PctIncrease Property

Description

This is the percent increase of the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctIncrease() As Variant

See Also

Entity Object


%%PageItemTitle%%

PctUsed Property

Description

This is the percent used by the entity storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctUsed() As Variant

Example

Dim MyEntity As Entity

Dim iPctUsed As Integer

iPctUsed = MyEntity.PctUsed

See Also

Entity Object


%%PageItemTitle%%

PostSQL Property

Description

This is the PostSQL of the entity. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

Entity Object


%%PageItemTitle%%

PreSQL Property

Description

This is the PreSQL of the entity. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

Entity Object


%%PageItemTitle%%

RowCount Property

Description

This is the current number of rows in a table. This property applies only to physical models. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property RowCount() As Variant

See Also

Entity Object


%%PageItemTitle%%

SourcingFrequency Property

Description

This property is for DataLineage and applies only if the parent model is physical and has been enabled for data movement. This property tells how often the data is sourced. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourcingFrequency() As Variant

See Also

Entity Object


%%PageItemTitle%%

StorageLocation Property

Description

This is the storage location of the entity. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StorageLocation() As Variant

Example

Dim MyEntity As Entity

Dim StorLoc As String = "SQLSVR-7"

MyEntity.StorageLocation = StorLoc

See Also

Entity Object


%%PageItemTitle%%

SybaseIdentityGap Property

Description

This is the Identity Gap option of the entity storage. It must be a positive integer (in kilobytes). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseIdentityGap() As Variant

See Also

Entity Object


%%PageItemTitle%%

SybaseLockingScheme Property

Description

This is the Locking Scheme option of the entity storage. The possible values are ALLPAGES, DATAPAGES or DATAROWS. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseLockingScheme() As Variant

See Also

Entity Object


%%PageItemTitle%%

SybaseMaxRowsPerPage Property

Description

This is the Max Rows Per Page option of the sybase table storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseMaxRowsPerPage() As Variant

See Also

Entity Object


%%PageItemTitle%%

SybasePrefetchStrategyOn Property

Description

This is the Prefetch Strategy option of the entity storage. If it is true then the prefetch strategy is on, if it is false then it is off. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybasePrefetchStrategyOn() As Variant

See Also

Entity Object


%%PageItemTitle%%

SybaseReplacementStrategyMRU Property

Description

This is the Replacement Strategy option of the entity storage. If it is true then the MRU replacement strategy is use, if it is false then LRU is used. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseReplacementStrategyMRU() As Variant

See Also

Entity Object


%%PageItemTitle%%

SybaseReservePageGap Property

Description

This is the Reserve Page Gap option of the entity storage. It must be a positive integer (in kilobytes). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseReservePageGap() As Variant

See Also

Entity Object


%%PageItemTitle%%

SystemName Property

Description

This is the system name of the AS400 table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SystemName() As Variant

See Also

Entity Object


%%PageItemTitle%%

TableDDL Property

Description

This is the TableDDL of the entity. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property TableDDL() As Variant

See Also

Entity Object


%%PageItemTitle%%

TableName Property

Description

This is the name of the table in a physical model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TableName() As Variant

Example

Dim MyEntity As Entity

Dim TblName As String = "Overdue"

MyEntity.TableName = TblName

See Also

Entity Object


%%PageItemTitle%%

TeradataAfterJournal Property

Description

This is the After Journal option of the entity storage. The possible values are -- --, NO, DUAL, LOCAL, NOT LOCAL or the empty string (meaning nothing has been specified). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataAfterJournal() As Variant

See Also

Entity Object


%%PageItemTitle%%

TeradataBeforeJournal Property

Description

This is the Before Journal option of the entity storage. The possible values are -- --, NO, DUAL or the empty string (meaning nothing has been specified). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataBeforeJournal() As Variant

See Also

Entity Object


%%PageItemTitle%%

TeradataChecksum Property

Description

This is the TeradataChecksum property of the table. It applies to Teradata 12 or later versions. DATATYPE: String. Possible values: Default,All,High,Medium,Low,None, or empty(no DDL output)

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataChecksum() As Variant

See Also

Entity Object


%%PageItemTitle%%

TeradataDatablockSize Property

Description

This is the Datablock Size option of the entity storage. It can be a positive integer (in kilobytes) or the string MINIMUM or MAXIMUM. DATATYPE: Integer or String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataDatablockSize() As Variant

See Also

Entity Object


%%PageItemTitle%%

TeradataDuplicateRowControl Property

Description

This is the DuplicateRowControl option of the entity storage. The possible values are SET, MULTISET or the empty string (meaning nothing has been specified). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataDuplicateRowControl() As Variant

See Also

Entity Object


%%PageItemTitle%%

TeradataFallback Property

Description

This is the Fallback protection option of the entity storage. If it is true then Fallback protection is used for the table. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataFallback() As Variant

See Also

Entity Object


%%PageItemTitle%%

TeradataJournalName Property

Description

This is the Journal Name option of the entity storage. If the entity has a Journal Table, then the name of the table is stored here. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataJournalName() As Variant

See Also

Entity Object


%%PageItemTitle%%

TextImageFileGroup Property

Description

This property specifies the table space in which the text/image columns are stored for the table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TextImageFileGroup() As Variant

See Also

Entity Object


%%PageItemTitle%%

TextLabel Property

Description

This is the text label of the AS400 table. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TextLabel() As Variant

See Also

Entity Object


%%PageItemTitle%%

EntityDisplay Object
See Also Members

Description

This object represents an entity display object in ER/Studio. An entity display object is a graphical representation of an entity in a specific submodel - it is not an entity itself.

Object Model

See Also

EntityDisplay Members


%%PageItemTitle%% $$Members$$

EntityDisplay Object Members
See Also Overview

Public Methods

Public Method ParentEntity | Get the parent Entity of this EntityDisplay. DATATYPE: Entity.
Public Method RepoCheckOutStatus | Get the Check Out status of this EntityDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this EntityDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method Resize | Resize the EntityDisplay to default size.

Public Properties

Public Property AttachmentsColor | Color for all attachments. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property AttachmentsFont | Font for all attachments. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property BackgroundColor | This is the background color of the entity display object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property DataSecurityColor | Color for all data security. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property DataSecurityFont | DATATYPE: ERSFont, Font for all data security. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property DisplayBackgroundColor | This determines whether to use a custom background color just for this entity display object (true) or whether to use the default entity background color of the submodel (false). DATATYPE: Boolean.
Public Property GUID | GUID of the entity display object. This GUID is assigned by ER/Studio. Each entity display object has a unique GUID. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the entity display object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the entity display object. DATATYPE: Integer.
Public Property ID | ID of the entity display object. This ID is assigned by ER/Studio. Each entity display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property InheritedNonKeysColor | Color for all inherited, non-keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property InheritedNonKeysFont | Font for all inherited, non-keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property InheritedPrimaryKeysColor | Color for all inherited, primary keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property InheritedPrimaryKeysFont | Font for all inherited, primary keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property Name | This is the name of the entity. DATATYPE: String.
Public Property NameColor | This is the NameColor of the entitydisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NameFont | Font for the entity name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property NonInheritedNonKeysColor | Color for all non-inherited, non-keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NonInheritedNonKeysFont | Font for all non-inherited, non-keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property NonInheritedPrimaryKeysColor | Color for all non-inherited, primary keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NonInheritedPrimaryKeysFont | Font for all non-inherited, primary keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property NonUniqueIndexes | Color for all non-unique indexes. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NonUniqueIndexesFont | Font for all non-unique indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property OutlineColor | This is the OutlineColor of the entitydisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property PKIndexesColor | Color for all PK Indexes. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property PKIndexesFont | Font for all PK Indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property TriggersColor | Color for all triggers. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property TriggersFont | Font for all triggers. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property UniqueIndexesColor | Color for all unique indexes. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property UniqueIndexesFont | Font for all unique indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property VerticalPosition | This is the y coordinate of the entity display object. DATATYPE: Integer.
Public Property VerticalPositionEx | This is the y coordinate of the entity display object. (This property corrects a bug in the VerticalPosition property). DATATYPE: Integer.
Public Property VerticalSize | This is the height of the entity display object. DATATYPE: Integer.

See Also

EntityDisplay Overview


%%PageItemTitle%%

ParentEntity Method

Description

Get the parent Entity of this EntityDisplay. DATATYPE: Entity.

Syntax

Visual Basic
Public Function ParentEntity() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this EntityDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this EntityDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

Resize Method

Description

Resize the EntityDisplay to default size.

Syntax

Visual Basic
Public Sub Resize()

See Also

EntityDisplay Object


%%PageItemTitle%%

AttachmentsColor Property

Description

Color for all attachments. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property AttachmentsColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

AttachmentsFont Property

Description

Font for all attachments. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property AttachmentsFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

BackgroundColor Property

Description

This is the background color of the entity display object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackgroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MyEntityDisplay As EntityDisplay

Dim BkgrdColor As Integer

MyEntityDisplay.BackgroundColor = BkgrdColor

or

' Sets the background color

Dim MyEntityDisplay As EntityDisplay

Dim BkgrdColor As Integer

BkgrdColor = 669933

MyEntityDisplay.BackgroundColor = BkgrdColor

See Also

EntityDisplay Object


%%PageItemTitle%%

DataSecurityColor Property

Description

Color for all data security. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property DataSecurityColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

DataSecurityFont Property

Description

DATATYPE: ERSFont, Font for all data security. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataSecurityFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

DisplayBackgroundColor Property

Description

This determines whether to use a custom background color just for this entity display object (true) or whether to use the default entity background color of the submodel (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayBackgroundColor() As Variant

Remarks

Color settings takes a 4 byte integer where the first (low-order) byte represents a red value (0-255), the second byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MyEntityDisplay As EntityDisplay

Dim DispBGColor As Boolean

MyEntityDisplay.DisplayBackgroundColor = DispBGColor

or

' Sets the display background color

Dim MyEntityDisplay As EntityDisplay

Dim DispBGColor As Boolean

DispBGColor = 669933

MyEntityDisplay.DisplayBackgroundColor = DispBGColor

See Also

EntityDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the entity display object. This GUID is assigned by ER/Studio. Each entity display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the entity display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

Example

Dim MyEntityDisplay As EntityDisplay

Dim HorizPo As Integer

HorizPo = 100

MyEntityDisplay.HorizontalPosition = HorizPo

See Also

EntityDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the entity display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

Example

Dim MyEntityDisplay As EntityDisplay

Dim HorizSize As Integer

HorizSize = 250

MyEntityDisplay.HorizontalSize = HorizSize

See Also

EntityDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the entity display object. This ID is assigned by ER/Studio. Each entity display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyEntityDisplay As EntityDisplay

Dim EntDisplayID As Integer

EntDisplayID = MyEntityDisplay.ID

See Also

EntityDisplay Object


%%PageItemTitle%%

InheritedNonKeysColor Property

Description

Color for all inherited, non-keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property InheritedNonKeysColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

InheritedNonKeysFont Property

Description

Font for all inherited, non-keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property InheritedNonKeysFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

InheritedPrimaryKeysColor Property

Description

Color for all inherited, primary keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property InheritedPrimaryKeysColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

InheritedPrimaryKeysFont Property

Description

Font for all inherited, primary keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property InheritedPrimaryKeysFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

Name Property

Description

This is the name of the entity. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

Example

Dim MyEntityDisplay As EntityDisplay

Dim MyEntityName As String

MyEntityName = MyEntityDisplay.Name

See Also

EntityDisplay Object


%%PageItemTitle%%

NameColor Property

Description

This is the NameColor of the entitydisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NameColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

NameFont Property

Description

Font for the entity name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NameFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

NonInheritedNonKeysColor Property

Description

Color for all non-inherited, non-keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NonInheritedNonKeysColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

NonInheritedNonKeysFont Property

Description

Font for all non-inherited, non-keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NonInheritedNonKeysFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

NonInheritedPrimaryKeysColor Property

Description

Color for all non-inherited, primary keys. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NonInheritedPrimaryKeysColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

NonInheritedPrimaryKeysFont Property

Description

Font for all non-inherited, primary keys. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NonInheritedPrimaryKeysFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

NonUniqueIndexes Property

Description

Color for all non-unique indexes. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NonUniqueIndexes() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

NonUniqueIndexesFont Property

Description

Font for all non-unique indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NonUniqueIndexesFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

OutlineColor Property

Description

This is the OutlineColor of the entitydisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlineColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

PKIndexesColor Property

Description

Color for all PK Indexes. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property PKIndexesColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

PKIndexesFont Property

Description

Font for all PK Indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property PKIndexesFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

TriggersColor Property

Description

Color for all triggers. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggersColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

TriggersFont Property

Description

Font for all triggers. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property TriggersFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

UniqueIndexesColor Property

Description

Color for all unique indexes. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property UniqueIndexesColor() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

UniqueIndexesFont Property

Description

Font for all unique indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property UniqueIndexesFont() As ERSFont

See Also

EntityDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the entity display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

Example

Dim MyEntityDisplay As EntityDisplay

Dim VertPo As Integer

VertPo = 100

MyEntityDisplay.VerticalPosition = VertPo

See Also

EntityDisplay Object


%%PageItemTitle%%

VerticalPositionEx Property

Description

This is the y coordinate of the entity display object. (This property corrects a bug in the VerticalPosition property). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPositionEx() As Variant

See Also

EntityDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the entity display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

Example

Dim MyEntityDisplay As EntityDisplay

Dim VertSize As Integer

VertSize = 250

MyEntityDisplay.VerticalSize = VertSize

See Also

EntityDisplay Object


%%PageItemTitle%%

EntityDisplays Collection
See Also Members

Description

This object represents a collection of entity display objects. The owner of this collection is the submodel object.

Object Model

See Also

EntityDisplays Members


%%PageItemTitle%% $$Members$$

EntityDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new EntityDisplay from the Entity identified by the given name, and returns the new EntityDisplay. PARAMETERS: EntityName as String.
Public Method Remove | Deletes a EntityDisplay object (specified by the given name or ID) from ER/Studio.PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a EntityDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of EntityDisplay objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a EntityDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

EntityDisplays Overview


%%PageItemTitle%%

Add Method
EntityName

Description

Creates a new EntityDisplay from the Entity identified by the given name, and returns the new EntityDisplay. PARAMETERS: EntityName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal EntityName As Variant _
) As EntityDisplay

Parameters

EntityName

See Also

EntityDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a EntityDisplay object (specified by the given name or ID) from ER/Studio.PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

EntityDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a EntityDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As EntityDisplay

Parameters

Identifier

See Also

EntityDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

EntityDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of EntityDisplay objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

EntityDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a EntityDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As EntityDisplay

Parameters

Identifier

See Also

EntityDisplays Collection


%%PageItemTitle%%

ERSFont Object
See Also Members

Description

This object represents a font in ER/Studio. A user can get a font object for a specific label (ie, the font for the entity name or the font for the attribute name) from the submodel. A user can access or change font properties through this object.

See Also

ERSFont Members


%%PageItemTitle%% $$Members$$

ERSFont Object Members
See Also Overview

Public Properties

Public Property Bold | This determines whether the font is bold (true) or not (false). DATATYPE: Boolean.
Public Property Charset | This is the character set. Microsoft has various predefined character sets. Here is an example list: Ansi - 0, Japanese - 128, Chinese Big 5 - 136, Hebrew - 177, Arabic - 178, Greek - 161, Turkish - 162, Vietnamese - 163. DATATYPE: Integer.
Public Property Italic | This determines whether the font is italicized (true) or not (false). DATATYPE: Boolean.
Public Property Name | This is the name of the font (ie, 'Arial', 'Courier', etc.). DATATYPE: String.
Public Property Size | This is the size of the font. DATATYPE: Integer.
Public Property Strikethrough | This determines whether the font is striked through (true) or not (false). DATATYPE: Boolean.
Public Property Underline | This determines whether the font is underlined (true) or not (false). DATATYPE: Boolean.
Public Property Weight | This is the width of the font. DATATYPE: Integer.

See Also

ERSFont Overview


%%PageItemTitle%%

Bold Property

Description

This determines whether the font is bold (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Bold() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Charset Property

Description

This is the character set. Microsoft has various predefined character sets. Here is an example list: Ansi - 0, Japanese - 128, Chinese Big 5 - 136, Hebrew - 177, Arabic - 178, Greek - 161, Turkish - 162, Vietnamese - 163. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Charset() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Italic Property

Description

This determines whether the font is italicized (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Italic() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Name Property

Description

This is the name of the font (ie, 'Arial', 'Courier', etc.). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Size Property

Description

This is the size of the font. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Size() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Strikethrough Property

Description

This determines whether the font is striked through (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Strikethrough() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Underline Property

Description

This determines whether the font is underlined (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Underline() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

Weight Property

Description

This is the width of the font. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Weight() As Variant

See Also

ERSFont Object


%%PageItemTitle%%

ExportImageOptions Object
See Also Members

Description

This object represents an ExportImageOptions object that provides an interface for generating an image of the Submodel.

See Also

ExportImageOptions Members


%%PageItemTitle%% $$Members$$

ExportImageOptions Object Members
See Also Overview

Public Methods

Public Method ExportImage This will export the image according to the options that are set.

Public Properties

Public Property ColorDepth | This is the color depth of the image to export. It can be 8, 16, 24 or 32 bits only. DATATYPE: Integer.
Public Property EMFDescription | This is the description for an EMF image. DATATYPE: String.
Public Property FileName | This is the Filename for the created image. DATATYPE: String.
Public Property Height | This is the Height of the image. Custom size only. DATATYPE: Integer.
Public Property ImageQuality | This is the quality of the image to export. It can range from 0-100. DATATYPE: Integer.
Public Property ImageType | Indicates what type of image to generate. The values are either 0 = BMP, 1 = JPG, 2 = EMF, 3 = GIF or 4 = PNG. DATATYPE: Integer.
Public Property PreserveAspectRatio | This is the flag to preserve the aspect ratio of the image. Custom size only. DATATYPE: Boolean.
Public Property SaveHTMLFile | This is the flag to save the image in HTML file. DATATYPE: Boolean.
Public Property SelectedObjectsOnly | This property indicates if the image to be created will show the Selected Objects Only. DATATYPE: Boolean.
Public Property Size | This is the Size of the image. Valid values are 0=CurrentZoomLevel, 1=ActualSize, 2=FitInWindow, 3=Custom. DATATYPE: Integer.
Public Property Transparent | This property set the Transparent option for the image. DATATYPE: Boolean.
Public Property VisibleWindowOnly | This flag indicates that the image will show the visible window only. DATATYPE: Boolean.
Public Property Width | This is the Width of the image. Custom size only. DATATYPE: Integer.

See Also

ExportImageOptions Overview


%%PageItemTitle%%

ExportImage Method

Description

This will export the image according to the options that are set.

Syntax

Visual Basic
Public Sub ExportImage()

See Also

ExportImageOptions Object


%%PageItemTitle%%

ColorDepth Property

Description

This is the color depth of the image to export. It can be 8, 16, 24 or 32 bits only. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColorDepth() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

EMFDescription Property

Description

This is the description for an EMF image. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property EMFDescription() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

FileName Property

Description

This is the Filename for the created image. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileName() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

Height Property

Description

This is the Height of the image. Custom size only. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

ImageQuality Property

Description

This is the quality of the image to export. It can range from 0-100. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImageQuality() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

ImageType Property

Description

Indicates what type of image to generate. The values are either 0 = BMP, 1 = JPG, 2 = EMF, 3 = GIF or 4 = PNG. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImageType() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

PreserveAspectRatio Property

Description

This is the flag to preserve the aspect ratio of the image. Custom size only. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreserveAspectRatio() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

SaveHTMLFile Property

Description

This is the flag to save the image in HTML file. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SaveHTMLFile() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

SelectedObjectsOnly Property

Description

This property indicates if the image to be created will show the Selected Objects Only. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedObjectsOnly() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

Size Property

Description

This is the Size of the image. Valid values are 0=CurrentZoomLevel, 1=ActualSize, 2=FitInWindow, 3=Custom. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Size() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

Transparent Property

Description

This property set the Transparent option for the image. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Transparent() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

VisibleWindowOnly Property

Description

This flag indicates that the image will show the visible window only. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property VisibleWindowOnly() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

Width Property

Description

This is the Width of the image. Custom size only. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Variant

See Also

ExportImageOptions Object


%%PageItemTitle%%

FirebirdGenerator Object
See Also Members

Description

This object represents a Firebird Generator in ER/Studio. It is stored as its create statement.

Object Model

See Also

FirebirdGenerator Members


%%PageItemTitle%% $$Members$$

FirebirdGenerator Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the Firebird Generator. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the Firebird Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the Firebird Sequence. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the Firebird Generator. DATATYPE: String.
Public Property ID | Returns the Firebird Generator ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the Firebird Generator. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the Firebird Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the Firebird Sequence. DATATYPE: String.

See Also

FirebirdGenerator Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

FirebirdGenerator Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

FirebirdGenerator Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Firebird Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the Firebird Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the Firebird Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Firebird Generator. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

ID Property

Description

Returns the Firebird Generator ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Firebird Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the Firebird Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the Firebird Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

FirebirdGenerator Object


%%PageItemTitle%%

FirebirdGenerators Collection
See Also Members

Description

This object represents a collection of Firebird generators. The owner of this collection is the model.

Object Model

See Also

FirebirdGenerators Members


%%PageItemTitle%% $$Members$$

FirebirdGenerators Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Firebird Generator, and adds it to the collection. PARAMETERS: Name (String).
Public Method AddWithPosition | Creates and returns a new Firebird Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an Firebird Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of generators in the collection. DATATYPE: Integer.
Public Property Item | Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

FirebirdGenerators Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new Firebird Generator, and adds it to the collection. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As FirebirdGenerator

Parameters

Name

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Creates and returns a new Firebird Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As FirebirdGenerator

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Firebird Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As FirebirdGenerator

Parameters

Identifier

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

Count Property

Description

This is the number of generators in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As FirebirdGenerator

Parameters

Identifier

See Also

FirebirdGenerators Collection


%%PageItemTitle%%

FKColumnPair Object
See Also Members

Description

This object represents a foreign key column pair. A foreign key column pair gives information on a parent attribute (an attribute in the parent entity) and its corresponding child attribute (a propagated foreign key attribute in the child entity).

Object Model

See Also

FKColumnPair Members


%%PageItemTitle%% $$Members$$

FKColumnPair Object Members
See Also Overview

Public Properties

Public Property ChildAttribute | This is the child attribute object.
Public Property GUID | GUID of the foreign key column pair. This GUID is assigned by ER/Studio. Each foreign key column pair has a unique GUID. DATATYPE: String.
Public Property ID | ID of the foreign key column pair. This ID is assigned by ER/Studio. Each foreign key column pair in a diagram has a unique ID. DATATYPE: Integer.
Public Property ParentAttribute | This is the parent attribute object.
Public Property SequenceNo | This is the sequence number of this FKColumnPair. DATATYPE: Integer.

See Also

FKColumnPair Overview


%%PageItemTitle%%

ChildAttribute Property

Description

This is the child attribute object.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChildAttribute() As AttributeObj

See Also

FKColumnPair Object


%%PageItemTitle%%

GUID Property

Description

GUID of the foreign key column pair. This GUID is assigned by ER/Studio. Each foreign key column pair has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

FKColumnPair Object


%%PageItemTitle%%

ID Property

Description

ID of the foreign key column pair. This ID is assigned by ER/Studio. Each foreign key column pair in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

FKColumnPair Object


%%PageItemTitle%%

ParentAttribute Property

Description

This is the parent attribute object.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentAttribute() As AttributeObj

See Also

FKColumnPair Object


%%PageItemTitle%%

SequenceNo Property

Description

This is the sequence number of this FKColumnPair. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNo() As Variant

See Also

FKColumnPair Object


%%PageItemTitle%%

FKColumnPairs Collection
See Also Members

Description

This object represents a collection of foreign key column pairs. The owner of this collection is the relationship.

Object Model

See Also

FKColumnPairs Members


%%PageItemTitle%% $$Members$$

FKColumnPairs Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a FKColumnPair object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of FKColumnPair objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a FKColumnPair object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

FKColumnPairs Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a FKColumnPair object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As FKColumnPair

Parameters

Identifier

See Also

FKColumnPairs Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

FKColumnPairs Collection


%%PageItemTitle%%

Count Property

Description

This is the number of FKColumnPair objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

FKColumnPairs Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a FKColumnPair object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As FKColumnPair

Parameters

Identifier

See Also

FKColumnPairs Collection


%%PageItemTitle%%

IBusinessDataObject Object
See Also Members

Object Model

See Also

IBusinessDataObject Members


%%PageItemTitle%% $$Members$$

IBusinessDataObject Object Members
See Also Overview

Public Methods

Public Method AddContainedObject | Add a contained object to the BusinessDataObject using the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer. DATATYPE: BoundObject.
Public Method BoundAttachments | Get all the BoundAttachments of this BusinessDataObject.
Public Method ContainedObjects | Returns an object representing a collection of all objects contained in the BusinessDataObject.
Public Method RepoCheckOutStatus | Get the Check Out status of this BusinessDataObject. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this BusinessDataObject from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property AnchorID | Returns the Entity ID of the BusinessDataObject's anchor. DATATYPE: Integer.
Public Property Definition | This property represents the definition of the BusinessDataObject. DATATYPE: String.
Public Property GUID | Returns the BusinessDataObject's GUID. DATATYPE: String.
Public Property ID | Returns the BusinessDataObject ID. DATATYPE: Integer.
Public Property LogicalName | This property represents the logical name of the BusinessDataObject. DATATYPE: String.
Public Property Note | This property represents the note of the BusinessDataObject. DATATYPE: String.
Public Property PhysicalName | This property represents the physical name of the BusinessDataObject. DATATYPE: String.

See Also

IBusinessDataObject Overview


%%PageItemTitle%%

AddContainedObject Method
Identifier

Description

Add a contained object to the BusinessDataObject using the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer. DATATYPE: BoundObject.

Syntax

Visual Basic
Public Function AddContainedObject( _
   ByVal Identifier As Variant _
) As BoundObject

Parameters

Identifier

See Also

IBusinessDataObject Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this BusinessDataObject.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

IBusinessDataObject Object


%%PageItemTitle%%

ContainedObjects Method

Description

Returns an object representing a collection of all objects contained in the BusinessDataObject.

Syntax

Visual Basic
Public Function ContainedObjects() As BoundObjects

See Also

IBusinessDataObject Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this BusinessDataObject. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this BusinessDataObject from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

AnchorID Property

Description

Returns the Entity ID of the BusinessDataObject's anchor. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property AnchorID() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

Definition Property

Description

This property represents the definition of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

GUID Property

Description

Returns the BusinessDataObject's GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

ID Property

Description

Returns the BusinessDataObject ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

LogicalName Property

Description

This property represents the logical name of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogicalName() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

Note Property

Description

This property represents the note of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Note() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

PhysicalName Property

Description

This property represents the physical name of the BusinessDataObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PhysicalName() As Variant

See Also

IBusinessDataObject Object


%%PageItemTitle%%

IBusinessDataObjectDisplay Object
See Also Members

Object Model

See Also

IBusinessDataObjectDisplay Members


%%PageItemTitle%% $$Members$$

IBusinessDataObjectDisplay Object Members
See Also Overview

Public Methods

Public Method Collapse | Collapse this BusinessDataObject display object.
Public Method Expand | Expand this BusinessDataObject display object.
Public Method RepoCheckOutStatus | Get the Check Out status of this BusinessDataObjectDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this BusinessDataObject display object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method Resize | Resize the BusinessDataObject display to default size.

Public Properties

Public Property BackgroundColor | The background color of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property DisplayBackgroundColor | This determines whether to use a custom background color just for this BusinessDataObject display object (true) or whether to use the default background color of the submodel (false). DATATYPE: Boolean.
Public Property GUID | GUID of the BusinessDataObject display object. This GUID is assigned by ER/Studio. Each BusinessDataObject display object has a unique GUID. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the BusinessDataObject display object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the BusinessDataObject display object. DATATYPE: Integer.
Public Property ID | ID of the BusinessDataObject display object. This ID is assigned by ER/Studio. Each BusinessDataObject display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property LogicalName | This is the logical name of the BusinessDataObject object. DATATYPE: String.
Public Property NameColor | Color for the name. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NameFont | Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property OutlineColor | This is the OutlineColor of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property PhysicalName | This is the physical name of the BusinessDataObject object. DATATYPE: String.
Public Property VerticalPosition | This is the y coordinate of the BusinessDataObject display object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the BusinessDataObject display object. DATATYPE: Integer.

See Also

IBusinessDataObjectDisplay Overview


%%PageItemTitle%%

Collapse Method

Description

Collapse this BusinessDataObject display object.

Syntax

Visual Basic
Public Sub Collapse()

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

Expand Method

Description

Expand this BusinessDataObject display object.

Syntax

Visual Basic
Public Sub Expand()

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this BusinessDataObjectDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this BusinessDataObject display object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

Resize Method

Description

Resize the BusinessDataObject display to default size.

Syntax

Visual Basic
Public Sub Resize()

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

BackgroundColor Property

Description

The background color of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackgroundColor() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

DisplayBackgroundColor Property

Description

This determines whether to use a custom background color just for this BusinessDataObject display object (true) or whether to use the default background color of the submodel (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayBackgroundColor() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the BusinessDataObject display object. This GUID is assigned by ER/Studio. Each BusinessDataObject display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the BusinessDataObject display object. This ID is assigned by ER/Studio. Each BusinessDataObject display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

LogicalName Property

Description

This is the logical name of the BusinessDataObject object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalName() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

NameColor Property

Description

Color for the name. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NameColor() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

NameFont Property

Description

Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NameFont() As ERSFont

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

OutlineColor Property

Description

This is the OutlineColor of the BusinessDataObject display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlineColor() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

PhysicalName Property

Description

This is the physical name of the BusinessDataObject object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property PhysicalName() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the BusinessDataObject display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

IBusinessDataObjectDisplay Object


%%PageItemTitle%%

IBusinessDataObjectDisplays Collection
See Also Members

Object Model

See Also

IBusinessDataObjectDisplays Members


%%PageItemTitle%% $$Members$$

IBusinessDataObjectDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new BusinessDataObject display object from the BusinessDataObject object identified by the given Name, GUID, or ID, and then returns the new display object. PARAMETERS: Identifier as String or Integer.
Public Method Remove | Deletes a BusinessDataObject display object specified by the given Name, GUID, or ID from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Business Data Object displays in the collection. DATATYPE: Integer.
Public Property Item | Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.

See Also

IBusinessDataObjectDisplays Overview


%%PageItemTitle%%

Add Method
Identifier

Description

Creates a new BusinessDataObject display object from the BusinessDataObject object identified by the given Name, GUID, or ID, and then returns the new display object. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Identifier As Variant _
) As BusinessDataObjectDisplay

Parameters

Identifier

See Also

IBusinessDataObjectDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a BusinessDataObject display object specified by the given Name, GUID, or ID from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

IBusinessDataObjectDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As BusinessDataObjectDisplay

Parameters

Identifier

See Also

IBusinessDataObjectDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

IBusinessDataObjectDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Business Data Object displays in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

IBusinessDataObjectDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a BusinessDataObject display object (specified by the given Name, GUID, or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As BusinessDataObjectDisplay

Parameters

Identifier

See Also

IBusinessDataObjectDisplays Collection


%%PageItemTitle%%

IBusinessDataObjects Collection
See Also Members

Object Model

See Also

IBusinessDataObjects Members


%%PageItemTitle%% $$Members$$

IBusinessDataObjects Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new BusinessDataObject. PARAMETERS: LogicalName (String), PhysicalName (String).
Public Method Remove | Deletes a BusinessDataObject object specified by the given Name, GUID, or ID from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of BusinessDataObjects in the collection. DATATYPE: Integer.
Public Property Item | Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.

See Also

IBusinessDataObjects Overview


%%PageItemTitle%%

Add Method
LogicalName
PhysicalName

Description

Creates and returns a new BusinessDataObject. PARAMETERS: LogicalName (String), PhysicalName (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal LogicalName As Variant, _
   ByVal PhysicalName As Variant _
) As BusinessDataObject

Parameters

LogicalName
PhysicalName

See Also

IBusinessDataObjects Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a BusinessDataObject object specified by the given Name, GUID, or ID from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

IBusinessDataObjects Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As BusinessDataObject

Parameters

Identifier

See Also

IBusinessDataObjects Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

IBusinessDataObjects Collection


%%PageItemTitle%%

Count Property

Description

This is the number of BusinessDataObjects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

IBusinessDataObjects Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a BusinessDataObject object specified by the given Name, GUID, or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As BusinessDataObject

Parameters

Identifier

See Also

IBusinessDataObjects Collection


%%PageItemTitle%%

IFirebirdGenerator Object
See Also Members

Object Model

See Also

IFirebirdGenerator Members


%%PageItemTitle%% $$Members$$

IFirebirdGenerator Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the Firebird Generator. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the Firebird Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the Firebird Sequence. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the Firebird Generator. DATATYPE: String.
Public Property ID | Returns the Firebird Generator ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the Firebird Generator. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the Firebird Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the Firebird Sequence. DATATYPE: String.

See Also

IFirebirdGenerator Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Firebird Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the Firebird Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the Firebird Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Firebird Generator. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

ID Property

Description

Returns the Firebird Generator ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Firebird Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the Firebird Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the Firebird Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

IFirebirdGenerator Object


%%PageItemTitle%%

IFirebirdGenerators Collection
See Also Members

Object Model

See Also

IFirebirdGenerators Members


%%PageItemTitle%% $$Members$$

IFirebirdGenerators Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Firebird Generator, and adds it to the collection. PARAMETERS: Name (String).
Public Method AddWithPosition | Creates and returns a new Firebird Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an Firebird Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of generators in the collection. DATATYPE: Integer.
Public Property Item | Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

IFirebirdGenerators Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new Firebird Generator, and adds it to the collection. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As FirebirdGenerator

Parameters

Name

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Creates and returns a new Firebird Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As FirebirdGenerator

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Firebird Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As FirebirdGenerator

Parameters

Identifier

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

Count Property

Description

This is the number of generators in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Firebird Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As FirebirdGenerator

Parameters

Identifier

See Also

IFirebirdGenerators Collection


%%PageItemTitle%%

IInterBaseGenerator Object
See Also Members

Object Model

See Also

IInterBaseGenerator Members


%%PageItemTitle%% $$Members$$

IInterBaseGenerator Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the InterBase Generator. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the InterBase Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the InterBase Sequence. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the InterBase Generator. DATATYPE: String.
Public Property ID | Returns the InterBase Generator ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the InterBase Generator. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the InterBase Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the InterBase Sequence. DATATYPE: String.

See Also

IInterBaseGenerator Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the InterBase Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the InterBase Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the InterBase Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the InterBase Generator. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

ID Property

Description

Returns the InterBase Generator ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the InterBase Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the InterBase Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the InterBase Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

IInterBaseGenerator Object


%%PageItemTitle%%

IInterBaseGenerators Collection
See Also Members

Object Model

See Also

IInterBaseGenerators Members


%%PageItemTitle%% $$Members$$

IInterBaseGenerators Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new InterBase Generator, and adds it to the collection. PARAMETERS: Name (String).
Public Method AddWithPosition | Creates and returns a new InterBase Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an InterBase Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of generators in the collection. DATATYPE: Integer.
Public Property Item | Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

IInterBaseGenerators Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new InterBase Generator, and adds it to the collection. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As InterBaseGenerator

Parameters

Name

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Creates and returns a new InterBase Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As InterBaseGenerator

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an InterBase Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As InterBaseGenerator

Parameters

Identifier

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

Count Property

Description

This is the number of generators in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As InterBaseGenerator

Parameters

Identifier

See Also

IInterBaseGenerators Collection


%%PageItemTitle%%

INamingStandardsTemplate Object
See Also Members

Object Model

See Also

INamingStandardsTemplate Members


%%PageItemTitle%% $$Members$$

INamingStandardsTemplate Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this naming standards template.
Public Method BoundObjects | Returns a collection of bindings that link the naming standards template to objects.
Public Method RepoCheckOutStatus | Get the Check Out status of this NamingStandardsTemplate object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this naming standards template.

Public Properties

Public Property Description | This is the description of the naming standards template. DATATYPE: String.
Public Property DictionaryName | This is the name of the Dictionary this object is part of. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary this object is part of is enterprise level. DATATYPE: Boolean.
Public Property GUID | GUID of the NamingStandardTemplate. GUIDs are unique IDs assigned by ER Studio. DATATYPE: String.
Public Property ID | Returns the naming standards template ID. DATATYPE: Integer.
Public Property Name | This is the name of the naming standards template. DATATYPE: String.

See Also

INamingStandardsTemplate Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this naming standards template.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the naming standards template to objects.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this NamingStandardsTemplate object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this naming standards template.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

Description Property

Description

This is the description of the naming standards template. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary this object is part of. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary this object is part of is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

GUID Property

Description

GUID of the NamingStandardTemplate. GUIDs are unique IDs assigned by ER Studio. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

ID Property

Description

Returns the naming standards template ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

Name Property

Description

This is the name of the naming standards template. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

INamingStandardsTemplate Object


%%PageItemTitle%%

INamingStandardsTemplates Collection
See Also Members

Object Model

See Also

INamingStandardsTemplates Members


%%PageItemTitle%% $$Members$$

INamingStandardsTemplates Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns new NamingStandardsTemplate, adds it to collection. PARAMETERS: Name, Description, Value, ValueDescription as Strings.
Public Method Remove | Deletes a naming standards template object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of naming standards template objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

INamingStandardsTemplates Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns new NamingStandardsTemplate, adds it to collection. PARAMETERS: Name, Description, Value, ValueDescription as Strings.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As NamingStandardsTemplate

Parameters

Name

See Also

INamingStandardsTemplates Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a naming standards template object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

INamingStandardsTemplates Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As NamingStandardsTemplate

Parameters

Identifier

See Also

INamingStandardsTemplates Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

INamingStandardsTemplates Collection


%%PageItemTitle%%

Count Property

Description

This is the number of naming standards template objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

INamingStandardsTemplates Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As NamingStandardsTemplate

Parameters

Identifier

See Also

INamingStandardsTemplates Collection


%%PageItemTitle%%

Index Object
See Also Members

Description

This object represents an index in ER/Studio.

Object Model

See Also

Index Members


%%PageItemTitle%% $$Members$$

Index Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Index.
Public Method DB2IdxPartitions | Get DB2IdxPartitions of this Index.
Public Method IndexColumns | Returns an object representing a collection of index columns for the index.
Public Method OracleIndexPartitions | Get Partitions of this Index (applicable for Oracle 9i Models and later versions.
Public Method RepoCheckOutStatus | Get the Check Out status of this Index object.
Public Method RepoVersionHistory | Get the Version History of this Index from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection od user comments associated with this Index.

Public Properties

Public Property AllowReverseScans | This property specifies whether or not reverse scans are allowed. DATATYPE: Boolean.
Public Property Clustered | This determines whether the index is clustered (true) or not clustered (false). DATATYPE: Boolean.
Public Property Color | Color for the index. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property Compress | This is the Compress property of the Index. DATATYPE: Boolean.
Public Property CompressLength | This is the Compression Prefix Length property of the Index. DATATYPE: Integer.
Public Property DB2BufferPool | This determines which bufferpool is used for the index. DATATYPE: String.
Public Property DB2Close | This determines whether the index CLOSE property is YES (true) or NO (false). DATATYPE: Boolean.
Public Property DB2Copy | This determines whether the index COPY property is YES (true) or NO (false). DATATYPE: Boolean.
Public Property DB2Defer | This is a flag for the Index Defer property to delay creation of B-Tree. DATATYPE: Boolean.
Public Property DB2Erase | This determines whether the index ERASE property is YES (true) or NO (false). DATATYPE: Boolean.
Public Property DB2OSPadded | This specifies if the index is padded, and it applies only to DB2 OS390 V8 or later versions of this platform. DATATYPE: Boolean.
Public Property DB2OSPartitioned | This specifies if the index is partitioned, and it applies only to DB2 OS/390 V8 or later versions of this platform. DATATYPE: Boolean.
Public Property DB2UniqueNotNull | This is a flag for the Index Unique Not NULL property. DATATYPE: Boolean.
Public Property Disable | Used for PKIndexes on Oracle platforms. Determines if the constraint is disabled (true) or enabled (false). When set to true, the corresponding FKs are also set to true. DATATYPE: Boolean.
Public Property ExtentGrowthFactor | This is the ExtentGrowthFactor of the index storage. DATATYPE: Integer.
Public Property FillfactorPercent | This is the FillfactorPercent of the index storage. DATATYPE: Integer.
Public Property Font | Font for the index name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property FreeListGroups | This property specifies the value for FreeListGroups. Input should be a positive integer or zero. DATATYPE: Integer.
Public Property FreeLists | This property specifies the value for FreeLists. Input should be a positive integer or zero. DATATYPE: Integer.
Public Property Fulltext | This property specifies whether or not the index is a MySql FULLTEXT index. DATATYPE: Boolean.
Public Property GBPCache | This deterimines the GBPCACHE setting. It must be ALL, CHANGED or NONE. DATATYPE: String.
Public Property GUID | GUID of the index. This GUID is assigned by ER/Studio. Each index has a unique GUID. DATATYPE: String.
Public Property HiRDBSplit | This property specifies whether the Unbalanced Split Option is set (true). DATATYPE: Boolean.
Public Property HiveDeferredRebuild | This property specifies the deferred rebuild option of the index on Hive models. DATATYPE: Boolean.
Public Property HiveIndexType | This property specifies Hive Index Type for indexes in Hive models. DATATYPE: String.
Public Property ID | ID of the index. This ID is assigned by ER/Studio. Each index in a diagram has a unique ID. DATATYPE: Integer.
Public Property IgnoreDupKeys | This is the flag for the Ignore Dup Keys option of indexes in SQL Server models. DATATYPE: Boolean.
Public Property Include | This property specifies the DB2 include columns. DATATYPE: String.
Public Property InitialExtentSize | This is the InitialExtentSize of the index storage. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property IsFunctionBased | This read-only property is true if the index is a function based index. DATATYPE: Boolean.
Public Property IsPK | This determines whether the index is PKIndex (true) or not PKIndex (false). DATATYPE: Boolean.
Public Property IsStoGroup | This determines whether the index storage type is STOGROUP (true) or VCAT (false). DATATYPE: Boolean.
Public Property IsUniqueConstraint | This specifies if the index is a Unique Constraint. DATATYPE: Boolean.
Public Property KeyType | This identifies and sets the KeyType if it's P (PK), A (Alternate) or I (Inversion). DATATYPE: String.
Public Property Location | This is the location of the index storage. DATATYPE: String.
Public Property LockModeSetting | This is the LockModeSetting of the index storage. DATATYPE: Integer.
Public Property LogOrPhysOnly | Controls the logical/physical only Index Property. DATATYPE: Boolean.
Public Property MaximumExtents | This is the MaximumExtents of the index storage. Parameter can be positive integer as string or UNLIMITED. DATATYPE: String.
Public Property MaximumRowsPerPage | This is the MaximumRowsPerPage of the index storage. DATATYPE: Integer.
Public Property MaximumTransactions | This is the MaximumTransactions of the index storage. DATATYPE: Integer.
Public Property MinimumExtents | This is the MinimumExtents of the index storage. DATATYPE: Integer.
Public Property MinimumTransactions | This is the MinimumTransactions of the index storage. DATATYPE: Integer.
Public Property MinPercentUsed | This property specifies the minimum percent used. DATATYPE: Integer.
Public Property Name | This is the name of the index. DATATYPE: String.
Public Property NextExtentSize | This is the NextExtentSize of the index storage. DATATYPE: Integer.
Public Property NoLogging | This property specifies whether NoLogging is set (true). DATATYPE: Boolean.
Public Property NoValidate | Used for PKIndexes on Oracle platforms. Determines if the constraint is NoValidate (true) or Validate (false).DATATYPE: Boolean.
Public Property OracleBitMap | This property specifies either BTree (false) or BitMap (true). To set it, BitMap, Unique, NoSort, and ReverseByteOrder must be false. DATATYPE: Boolean.
Public Property OracleBufferPool | This property holds the value for BufferPool. Legal values are KEEP, DEFAULT, RECYCLE. DATATYPE: String.
Public Property OracleDegrees | Property holds the value for Degrees (positive int or zero). To set it, Degrees Parallel must be true. DATATYPE: Integer.
Public Property OracleIndexFunction | This specifies the expression used for a function based index in Oracle. DATATYPE: String.
Public Property OracleInstances | Property holds the value for Instances (postive int or zero). To set it, Instances Parallel must be true. DATATYPE: Integer.
Public Property OracleNoSort | This property specifies whether NoSort is set (true). To set it, NoSort, BitMap, and ReverseByteOrder must be false. DATATYPE: Boolean.
Public Property OracleParallel | This property specifies whether the Parallel Option is set (true). DATATYPE: Boolean.
Public Property OracleReverseByteOrder | This property specifies whether ReverseByteOrder is true, false specifies forward. To set it, NoSort and BitMap must be false. DATATYPE: Boolean.
Public Property Owner | This property specifies the owner of the index. Applies to Oracle, DB2 UDB V6, V7, V8 and OS390 platforms. On Oracle platforms this property is readonly. DATATYPE: String.
Public Property PadIndex | This property specifies the space to leave open on each page (node) in the intermediate levels of the index. The PadIndex option is useful only when FillFactor is specified. DATATYPE: Boolean.
Public Property PercentFree | This is the PercentFree of the index storage. DATATYPE: Integer.
Public Property PercentUsed | This is the PercentUsed of the index storage. DATATYPE: Integer.
Public Property PKConstraintName | This specifies if the ConstraintName associated with the index. This applies only to DB2 UDB V6 or later versions and Oracle 9 and later versions. DATATYPE: String.
Public Property SortInTempdb | This property specifies whether or not the intermediate sort results used to build the index will be sorted in the tempdb database. DATATYPE: Boolean.
Public Property SybaseIQDelimitedBy | This property specifies the string separators for WD index in SybaseIQ. DATATYPE: String.
Public Property SybaseIQIndexType | This property specifies the index type in SybaseIQ. DATATYPE: String.
Public Property SybaseIQLimit | This property specifies the max length of the WD index column in SybaseIQ. DATATYPE: Integer.
Public Property TeradataCollectStatistics | This property specifies whether the collect statistics option of the index is on for Teradata (V12 or higher). DATATYPE: Boolean.
Public Property TeradataPartitioningExpression | This specifies the Teradata Partitioning Expression of the index. DATATYPE: String.
Public Property TeradataPrimary | This property specifies whether or not the index is a Teradata primary index. DATATYPE: Boolean.
Public Property TeradataUsingSample | This property specifies whether the using sample option of the index is on for Teradata (V12 or higher), the collect statistics option has to be on before this option can be set. DATATYPE: Boolean.
Public Property Type | This is the type of the index. The possible values are: Clustered -'C', NonClustered - 'N', Hashed - 'H'. DATATYPE: String.
Public Property Unique | This determines whether the index is unique (true) or not unique (false). DATATYPE: Boolean.

See Also

Index Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Index.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Index Object


%%PageItemTitle%%

DB2IdxPartitions Method

Description

Get DB2IdxPartitions of this Index.

Syntax

Visual Basic
Public Function DB2IdxPartitions() As DB2IdxPartitions

See Also

Index Object


%%PageItemTitle%%

IndexColumns Method

Description

Returns an object representing a collection of index columns for the index.

Syntax

Visual Basic
Public Function IndexColumns() As IndexColumns

See Also

Index Object


%%PageItemTitle%%

OracleIndexPartitions Method

Description

Get Partitions of this Index (applicable for Oracle 9i Models and later versions.

Syntax

Visual Basic
Public Function OracleIndexPartitions() As OracleIndexPartitions

See Also

Index Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Index object.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Index Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this Index from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

Index Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection od user comments associated with this Index.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Index Object


%%PageItemTitle%%

AllowReverseScans Property

Description

This property specifies whether or not reverse scans are allowed. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowReverseScans() As Variant

See Also

Index Object


%%PageItemTitle%%

Clustered Property

Description

This determines whether the index is clustered (true) or not clustered (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Clustered() As Variant

See Also

Index Object


%%PageItemTitle%%

Color Property

Description

Color for the index. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

Index Object


%%PageItemTitle%%

Compress Property

Description

This is the Compress property of the Index. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compress() As Variant

See Also

Index Object


%%PageItemTitle%%

CompressLength Property

Description

This is the Compression Prefix Length property of the Index. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CompressLength() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2BufferPool Property

Description

This determines which bufferpool is used for the index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2BufferPool() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2Close Property

Description

This determines whether the index CLOSE property is YES (true) or NO (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2Close() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2Copy Property

Description

This determines whether the index COPY property is YES (true) or NO (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2Copy() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2Defer Property

Description

This is a flag for the Index Defer property to delay creation of B-Tree. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2Defer() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2Erase Property

Description

This determines whether the index ERASE property is YES (true) or NO (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2Erase() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2OSPadded Property

Description

This specifies if the index is padded, and it applies only to DB2 OS390 V8 or later versions of this platform. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2OSPadded() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2OSPartitioned Property

Description

This specifies if the index is partitioned, and it applies only to DB2 OS/390 V8 or later versions of this platform. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2OSPartitioned() As Variant

See Also

Index Object


%%PageItemTitle%%

DB2UniqueNotNull Property

Description

This is a flag for the Index Unique Not NULL property. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2UniqueNotNull() As Variant

See Also

Index Object


%%PageItemTitle%%

Disable Property

Description

Used for PKIndexes on Oracle platforms. Determines if the constraint is disabled (true) or enabled (false). When set to true, the corresponding FKs are also set to true. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Disable() As Variant

See Also

Index Object


%%PageItemTitle%%

ExtentGrowthFactor Property

Description

This is the ExtentGrowthFactor of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExtentGrowthFactor() As Variant

See Also

Index Object


%%PageItemTitle%%

FillfactorPercent Property

Description

This is the FillfactorPercent of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FillfactorPercent() As Variant

See Also

Index Object


%%PageItemTitle%%

Font Property

Description

Font for the index name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property Font() As ERSFont

See Also

Index Object


%%PageItemTitle%%

FreeListGroups Property

Description

This property specifies the value for FreeListGroups. Input should be a positive integer or zero. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeListGroups() As Variant

See Also

Index Object


%%PageItemTitle%%

FreeLists Property

Description

This property specifies the value for FreeLists. Input should be a positive integer or zero. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeLists() As Variant

See Also

Index Object


%%PageItemTitle%%

Fulltext Property

Description

This property specifies whether or not the index is a MySql FULLTEXT index. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Fulltext() As Variant

See Also

Index Object


%%PageItemTitle%%

GBPCache Property

Description

This deterimines the GBPCACHE setting. It must be ALL, CHANGED or NONE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GBPCache() As Variant

See Also

Index Object


%%PageItemTitle%%

GUID Property

Description

GUID of the index. This GUID is assigned by ER/Studio. Each index has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Index Object


%%PageItemTitle%%

HiRDBSplit Property

Description

This property specifies whether the Unbalanced Split Option is set (true). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiRDBSplit() As Variant

See Also

Index Object


%%PageItemTitle%%

HiveDeferredRebuild Property

Description

This property specifies the deferred rebuild option of the index on Hive models. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveDeferredRebuild() As Variant

See Also

Index Object


%%PageItemTitle%%

HiveIndexType Property

Description

This property specifies Hive Index Type for indexes in Hive models. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HiveIndexType() As Variant

See Also

Index Object


%%PageItemTitle%%

ID Property

Description

ID of the index. This ID is assigned by ER/Studio. Each index in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Index Object


%%PageItemTitle%%

IgnoreDupKeys Property

Description

This is the flag for the Ignore Dup Keys option of indexes in SQL Server models. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IgnoreDupKeys() As Variant

See Also

Index Object


%%PageItemTitle%%

Include Property

Description

This property specifies the DB2 include columns. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Include() As Variant

See Also

Index Object


%%PageItemTitle%%

InitialExtentSize Property

Description

This is the InitialExtentSize of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitialExtentSize() As Variant

See Also

Index Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

Index Object


%%PageItemTitle%%

IsFunctionBased Property

Description

This read-only property is true if the index is a function based index. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsFunctionBased() As Variant

See Also

Index Object


%%PageItemTitle%%

IsPK Property

Description

This determines whether the index is PKIndex (true) or not PKIndex (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsPK() As Variant

See Also

Index Object


%%PageItemTitle%%

IsStoGroup Property

Description

This determines whether the index storage type is STOGROUP (true) or VCAT (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsStoGroup() As Variant

See Also

Index Object


%%PageItemTitle%%

IsUniqueConstraint Property

Description

This specifies if the index is a Unique Constraint. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsUniqueConstraint() As Variant

See Also

Index Object


%%PageItemTitle%%

KeyType Property

Description

This identifies and sets the KeyType if it's P (PK), A (Alternate) or I (Inversion). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property KeyType() As Variant

See Also

Index Object


%%PageItemTitle%%

Location Property

Description

This is the location of the index storage. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location() As Variant

See Also

Index Object


%%PageItemTitle%%

LockModeSetting Property

Description

This is the LockModeSetting of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockModeSetting() As Variant

See Also

Index Object


%%PageItemTitle%%

LogOrPhysOnly Property

Description

Controls the logical/physical only Index Property. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogOrPhysOnly() As Variant

See Also

Index Object


%%PageItemTitle%%

MaximumExtents Property

Description

This is the MaximumExtents of the index storage. Parameter can be positive integer as string or UNLIMITED. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaximumExtents() As Variant

See Also

Index Object


%%PageItemTitle%%

MaximumRowsPerPage Property

Description

This is the MaximumRowsPerPage of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaximumRowsPerPage() As Variant

See Also

Index Object


%%PageItemTitle%%

MaximumTransactions Property

Description

This is the MaximumTransactions of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaximumTransactions() As Variant

See Also

Index Object


%%PageItemTitle%%

MinimumExtents Property

Description

This is the MinimumExtents of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinimumExtents() As Variant

See Also

Index Object


%%PageItemTitle%%

MinimumTransactions Property

Description

This is the MinimumTransactions of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinimumTransactions() As Variant

See Also

Index Object


%%PageItemTitle%%

MinPercentUsed Property

Description

This property specifies the minimum percent used. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinPercentUsed() As Variant

See Also

Index Object


%%PageItemTitle%%

Name Property

Description

This is the name of the index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Index Object


%%PageItemTitle%%

NextExtentSize Property

Description

This is the NextExtentSize of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtentSize() As Variant

See Also

Index Object


%%PageItemTitle%%

NoLogging Property

Description

This property specifies whether NoLogging is set (true). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoLogging() As Variant

See Also

Index Object


%%PageItemTitle%%

NoValidate Property

Description

Used for PKIndexes on Oracle platforms. Determines if the constraint is NoValidate (true) or Validate (false).DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoValidate() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleBitMap Property

Description

This property specifies either BTree (false) or BitMap (true). To set it, BitMap, Unique, NoSort, and ReverseByteOrder must be false. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleBitMap() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleBufferPool Property

Description

This property holds the value for BufferPool. Legal values are KEEP, DEFAULT, RECYCLE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleBufferPool() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleDegrees Property

Description

Property holds the value for Degrees (positive int or zero). To set it, Degrees Parallel must be true. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleDegrees() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleIndexFunction Property

Description

This specifies the expression used for a function based index in Oracle. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleIndexFunction() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleInstances Property

Description

Property holds the value for Instances (postive int or zero). To set it, Instances Parallel must be true. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleInstances() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleNoSort Property

Description

This property specifies whether NoSort is set (true). To set it, NoSort, BitMap, and ReverseByteOrder must be false. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleNoSort() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleParallel Property

Description

This property specifies whether the Parallel Option is set (true). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleParallel() As Variant

See Also

Index Object


%%PageItemTitle%%

OracleReverseByteOrder Property

Description

This property specifies whether ReverseByteOrder is true, false specifies forward. To set it, NoSort and BitMap must be false. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OracleReverseByteOrder() As Variant

See Also

Index Object


%%PageItemTitle%%

Owner Property

Description

This property specifies the owner of the index. Applies to Oracle, DB2 UDB V6, V7, V8 and OS390 platforms. On Oracle platforms this property is readonly. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

Index Object


%%PageItemTitle%%

PadIndex Property

Description

This property specifies the space to leave open on each page (node) in the intermediate levels of the index. The PadIndex option is useful only when FillFactor is specified. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PadIndex() As Variant

See Also

Index Object


%%PageItemTitle%%

PercentFree Property

Description

This is the PercentFree of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentFree() As Variant

See Also

Index Object


%%PageItemTitle%%

PercentUsed Property

Description

This is the PercentUsed of the index storage. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentUsed() As Variant

See Also

Index Object


%%PageItemTitle%%

PKConstraintName Property

Description

This specifies if the ConstraintName associated with the index. This applies only to DB2 UDB V6 or later versions and Oracle 9 and later versions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PKConstraintName() As Variant

See Also

Index Object


%%PageItemTitle%%

SortInTempdb Property

Description

This property specifies whether or not the intermediate sort results used to build the index will be sorted in the tempdb database. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SortInTempdb() As Variant

See Also

Index Object


%%PageItemTitle%%

SybaseIQDelimitedBy Property

Description

This property specifies the string separators for WD index in SybaseIQ. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseIQDelimitedBy() As Variant

See Also

Index Object


%%PageItemTitle%%

SybaseIQIndexType Property

Description

This property specifies the index type in SybaseIQ. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseIQIndexType() As Variant

See Also

Index Object


%%PageItemTitle%%

SybaseIQLimit Property

Description

This property specifies the max length of the WD index column in SybaseIQ. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SybaseIQLimit() As Variant

See Also

Index Object


%%PageItemTitle%%

TeradataCollectStatistics Property

Description

This property specifies whether the collect statistics option of the index is on for Teradata (V12 or higher). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataCollectStatistics() As Variant

See Also

Index Object


%%PageItemTitle%%

TeradataPartitioningExpression Property

Description

This specifies the Teradata Partitioning Expression of the index. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataPartitioningExpression() As Variant

See Also

Index Object


%%PageItemTitle%%

TeradataPrimary Property

Description

This property specifies whether or not the index is a Teradata primary index. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataPrimary() As Variant

See Also

Index Object


%%PageItemTitle%%

TeradataUsingSample Property

Description

This property specifies whether the using sample option of the index is on for Teradata (V12 or higher), the collect statistics option has to be on before this option can be set. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property TeradataUsingSample() As Variant

See Also

Index Object


%%PageItemTitle%%

Type Property

Description

This is the type of the index. The possible values are: Clustered -'C', NonClustered - 'N', Hashed - 'H'. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

Index Object


%%PageItemTitle%%

Unique Property

Description

This determines whether the index is unique (true) or not unique (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Unique() As Variant

See Also

Index Object


%%PageItemTitle%%

IndexColumn Object
See Also Members

Description

This object represents an index column in ER/Studio.

See Also

IndexColumn Members


%%PageItemTitle%% $$Members$$

IndexColumn Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this IndexColumn object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this IndexColumn from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property ColumnGUID | This is the GUID of the column used as an index column. This GUID is assigned by ER/Studio. DATATYPE: String.
Public Property ColumnName | This is the column name of the index column. DATATYPE: String.
Public Property GUID | GUID of the index column. This GUID is assigned by ER/Studio. Each index column has a GUID. DATATYPE: String.
Public Property ID | ID of the index column. This ID is assigned by ER/Studio. Each index column in a diagram has a unique ID. DATATYPE: Integer.
Public Property SequenceNo | This is the Sequence number of this Index column. DATATYPE: Integer.
Public Property SortOrder | This is the sort order of the index column. The possible values are: 'A' for Ascending and 'D' for Descending. DATATYPE: String.

See Also

IndexColumn Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this IndexColumn object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this IndexColumn from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

ColumnGUID Property

Description

This is the GUID of the column used as an index column. This GUID is assigned by ER/Studio. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ColumnGUID() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

ColumnName Property

Description

This is the column name of the index column. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ColumnName() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

GUID Property

Description

GUID of the index column. This GUID is assigned by ER/Studio. Each index column has a GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

ID Property

Description

ID of the index column. This ID is assigned by ER/Studio. Each index column in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

SequenceNo Property

Description

This is the Sequence number of this Index column. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SequenceNo() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

SortOrder Property

Description

This is the sort order of the index column. The possible values are: 'A' for Ascending and 'D' for Descending. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SortOrder() As Variant

See Also

IndexColumn Object


%%PageItemTitle%%

IndexColumns Collection
See Also Members

Description

This object represents a collection of index columns. The owner of this collection is the index.

Object Model

See Also

IndexColumns Members


%%PageItemTitle%% $$Members$$

IndexColumns Collection Members
See Also Overview

Public Methods

Public Method Add | Create an Index Column and return it to the caller. Logical Model Input: LogicalRoleName (if available)/Attribute name. Physical Model Input: RoleName (if available)/ColumnName. PARAMETERS: ColumnName as String.
Public Method Remove | Deletes a IndexColumn object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | RReturns a IndexColumn object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of IndexColumn objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a IndexColumn object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

IndexColumns Overview


%%PageItemTitle%%

Add Method
ColumnName

Description

Create an Index Column and return it to the caller. Logical Model Input: LogicalRoleName (if available)/Attribute name. Physical Model Input: RoleName (if available)/ColumnName. PARAMETERS: ColumnName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal ColumnName As Variant _
) As IndexColumn

Parameters

ColumnName

See Also

IndexColumns Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a IndexColumn object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

IndexColumns Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

RReturns a IndexColumn object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As IndexColumn

Parameters

Identifier

See Also

IndexColumns Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

IndexColumns Collection


%%PageItemTitle%%

Count Property

Description

This is the number of IndexColumn objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

IndexColumns Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a IndexColumn object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As IndexColumn

Parameters

Identifier

See Also

IndexColumns Collection


%%PageItemTitle%%

Indexes Collection
See Also Members

Description

This object represents a collection of indexes. The owner of this collection is the entity.

Object Model

See Also

Indexes Members


%%PageItemTitle%% $$Members$$

Indexes Collection Members
See Also Overview

Public Methods

Public Method Add | Create an Index and return it to the caller. ColumnName by Model: Logical - LogicalRoleName if it exist/AttributeName; Physical - RoleName if it exist/ColumnName. PARAMETERS: ColumnName as String, IndexName as String.
Public Method Remove | Deletes an Index object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Index object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Index objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Index object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

See Also

Indexes Overview


%%PageItemTitle%%

Add Method
ColumnName
IndexName

Description

Create an Index and return it to the caller. ColumnName by Model: Logical - LogicalRoleName if it exist/AttributeName; Physical - RoleName if it exist/ColumnName. PARAMETERS: ColumnName as String, IndexName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal ColumnName As Variant, _
   ByVal IndexName As Variant _
) As Index

Parameters

ColumnName
IndexName

See Also

Indexes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Index object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Indexes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Index object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Index

Parameters

Identifier

See Also

Indexes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Indexes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Index objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Indexes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Index object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Index

Parameters

Identifier

See Also

Indexes Collection


%%PageItemTitle%%

InterBaseGenerator Object
See Also Members

Description

This object represents a InterBase Generator in ER/Studio. It is stored as its create statement.

Object Model

See Also

InterBaseGenerator Members


%%PageItemTitle%% $$Members$$

InterBaseGenerator Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property Description | This is the Description of the InterBase Generator. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the InterBase Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the InterBase Sequence. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the InterBase Generator. DATATYPE: String.
Public Property ID | Returns the InterBase Generator ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the InterBase Generator. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the InterBase Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the InterBase Sequence. DATATYPE: String.

See Also

InterBaseGenerator Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

InterBaseGenerator Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

InterBaseGenerator Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the InterBase Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the InterBase Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the InterBase Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the InterBase Generator. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

ID Property

Description

Returns the InterBase Generator ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the InterBase Generator. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the InterBase Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the InterBase Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

InterBaseGenerator Object


%%PageItemTitle%%

InterBaseGenerators Collection
See Also Members

Description

This object represents a collection of InterBase generators. The owner of this collection is the model.

Object Model

See Also

InterBaseGenerators Members


%%PageItemTitle%% $$Members$$

InterBaseGenerators Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new InterBase Generator, and adds it to the collection. PARAMETERS: Name (String).
Public Method AddWithPosition | Creates and returns a new InterBase Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an InterBase Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of generators in the collection. DATATYPE: Integer.
Public Property Item | Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

InterBaseGenerators Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new InterBase Generator, and adds it to the collection. PARAMETERS: Name (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As InterBaseGenerator

Parameters

Name

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

AddWithPosition Method
Name
HorizontalPosition
VerticalPosition

Description

Creates and returns a new InterBase Generator with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As InterBaseGenerator

Parameters

Name
HorizontalPosition
VerticalPosition

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an InterBase Generator object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As InterBaseGenerator

Parameters

Identifier

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

Count Property

Description

This is the number of generators in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a InterBase Generator object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As InterBaseGenerator

Parameters

Identifier

See Also

InterBaseGenerators Collection


%%PageItemTitle%%

ISQLServerSequence Object
See Also Members

Object Model

See Also

ISQLServerSequence Members


%%PageItemTitle%% $$Members$$

ISQLServerSequence Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property CacheSize | This property specifies the the size of the cache used for the SQL Server Sequence. DATATYPE: Integer.
Public Property Cycle | This property holds true if the SQL Server Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.
Public Property Datatype | This property specifies the data type of the SQL Server Sequence. DATATYPE: String.
Public Property DataWidth | This property represents the data width of the SQL Server Sequence. DATATYPE: String.
Public Property Description | This is the Description of the SQL Server Sequence. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the SQL Server Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the SQL Server Sequence. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the SQL Server Sequence. DATATYPE: String.
Public Property HasMaxValue | This property holds true if the SQL Server Sequence has a maximum value set, false otherwise. DATATYPE: Boolean.
Public Property HasMinValue | This property holds true if the SQL Server Sequence has a minimum value set, false otherwise. DATATYPE: Boolean.
Public Property ID | Returns the SQL Server Sequence ID. DATATYPE: Integer.
Public Property IncrementBy | This property represents the value by which the SQL Server Sequence will be implemented each time a new number is requested. DATATYPE: String.
Public Property MaxValue | This property represents the maximum SQL Server Sequence value. DATATYPE: String.
Public Property MinValue | This property represents the minimum SQL Server Sequence value. DATATYPE: String.
Public Property Name | This property represents the name of the SQL Server Sequence. DATATYPE: String.
Public Property NeedCache | This property represents the need for cache size value of the SQL Server Sequence. DATATYPE: Boolean.
Public Property NeedMaxValue | This property holds true if the SQL Server Sequence needs a maximum value to be set, false otherwise. DATATYPE: Boolean.
Public Property NeedMinValue | This property holds true if the SQL Server Sequence needs a minimum value to be set, false otherwise. DATATYPE: Boolean.
Public Property Owner | This property represents the owner of the SQL Server Sequence. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the SQL Server Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the SQL Server Sequence. DATATYPE: String.
Public Property StartWith | This property represents the value that the SQL Server Sequence will start with. DATATYPE: String.

See Also

ISQLServerSequence Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

ISQLServerSequence Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

ISQLServerSequence Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

ISQLServerSequence Object


%%PageItemTitle%%

CacheSize Property

Description

This property specifies the the size of the cache used for the SQL Server Sequence. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CacheSize() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

Cycle Property

Description

This property holds true if the SQL Server Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cycle() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

Datatype Property

Description

This property specifies the data type of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

DataWidth Property

Description

This property represents the data width of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataWidth() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the SQL Server Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the SQL Server Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the SQL Server Sequence. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

HasMaxValue Property

Description

This property holds true if the SQL Server Sequence has a maximum value set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasMaxValue() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

HasMinValue Property

Description

This property holds true if the SQL Server Sequence has a minimum value set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasMinValue() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

ID Property

Description

Returns the SQL Server Sequence ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

IncrementBy Property

Description

This property represents the value by which the SQL Server Sequence will be implemented each time a new number is requested. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementBy() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

MaxValue Property

Description

This property represents the maximum SQL Server Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxValue() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

MinValue Property

Description

This property represents the minimum SQL Server Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinValue() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

NeedCache Property

Description

This property represents the need for cache size value of the SQL Server Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedCache() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

NeedMaxValue Property

Description

This property holds true if the SQL Server Sequence needs a maximum value to be set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedMaxValue() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

NeedMinValue Property

Description

This property holds true if the SQL Server Sequence needs a minimum value to be set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedMinValue() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

StartWith Property

Description

This property represents the value that the SQL Server Sequence will start with. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartWith() As Variant

See Also

ISQLServerSequence Object


%%PageItemTitle%%

ISQLServerSequences Collection
See Also Members

Object Model

See Also

ISQLServerSequences Members


%%PageItemTitle%% $$Members$$

ISQLServerSequences Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new SQL Server Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).
Public Method AddWithPosition | Creates and returns a new SQL Server Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an SQL Server Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of sequences in the collection. DATATYPE: Integer.
Public Property Item | Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

ISQLServerSequences Overview


%%PageItemTitle%%

Add Method
Name
Owner

Description

Creates and returns a new SQL Server Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant _
) As SQLServerSequence

Parameters

Name
Owner

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
HorizontalPosition
VerticalPosition

Description

Creates and returns a new SQL Server Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As SQLServerSequence

Parameters

Name
Owner
HorizontalPosition
VerticalPosition

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an SQL Server Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SQLServerSequence

Parameters

Identifier

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

Count Property

Description

This is the number of sequences in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SQLServerSequence

Parameters

Identifier

See Also

ISQLServerSequences Collection


%%PageItemTitle%%

Line Object
See Also Members

Description

This object represents a line in ER/Studio.

Object Model

See Also

Line Members


%%PageItemTitle%% $$Members$$

Line Object Members
See Also Overview

Public Methods

Public Method BoundAttachments Get all the BoundAttachments of this Line.

Public Properties

Public Property ChildName | This is the child object name of the line. DATATYPE: String.
Public Property ChildType | This is the child object type of the line. DATATYPE: Integer.
Public Property GUID | GUID of the Line object. This GUID is assigned by ER/Studio. Each Line object in a diagram has a unique GUID. DATATYPE: String.
Public Property ID | ID of the Line object. This ID is assigned by ER/Studio. Each Line object in a diagram has a unique ID. DATATYPE: Integer.
Public Property ParentName | This is the parent object name of the line. DATATYPE: String.
Public Property ParentType | This is the parent object type of the line. DATATYPE: Integer.

See Also

Line Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Line.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Line Object


%%PageItemTitle%%

ChildName Property

Description

This is the child object name of the line. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChildName() As Variant

See Also

Line Object


%%PageItemTitle%%

ChildType Property

Description

This is the child object type of the line. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChildType() As Variant

See Also

Line Object


%%PageItemTitle%%

GUID Property

Description

GUID of the Line object. This GUID is assigned by ER/Studio. Each Line object in a diagram has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Line Object


%%PageItemTitle%%

ID Property

Description

ID of the Line object. This ID is assigned by ER/Studio. Each Line object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Line Object


%%PageItemTitle%%

ParentName Property

Description

This is the parent object name of the line. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentName() As Variant

See Also

Line Object


%%PageItemTitle%%

ParentType Property

Description

This is the parent object type of the line. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentType() As Variant

See Also

Line Object


%%PageItemTitle%%

LineageComponent Object
See Also Members

Description

This object represents a Data Lineage Component in ER/Studio.

See Also

LineageComponent Members


%%PageItemTitle%% $$Members$$

LineageComponent Object Members
See Also Overview

Public Properties

Public Property GUID | This is the GUID of the LineageComponent. DATATYPE: String.
Public Property ID | Returns the LineageComponent ID. DATATYPE: Integer.
Public Property Name | Returns the name of the LineageComponent . DATATYPE: String.
Public Property SourceModelID | Returns the ID of the model that contains the source object. DATATYPE: Integer.
Public Property SourceObjectID | Returns the ID of the source object. DATATYPE: Integer.
Public Property SourceObjectType | Returns the type of the source object. DATATYPE: Integer.(1=Entity,16=View)

See Also

LineageComponent Overview


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the LineageComponent. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

LineageComponent Object


%%PageItemTitle%%

ID Property

Description

Returns the LineageComponent ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

LineageComponent Object


%%PageItemTitle%%

Name Property

Description

Returns the name of the LineageComponent . DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

LineageComponent Object


%%PageItemTitle%%

SourceModelID Property

Description

Returns the ID of the model that contains the source object. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceModelID() As Variant

See Also

LineageComponent Object


%%PageItemTitle%%

SourceObjectID Property

Description

Returns the ID of the source object. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceObjectID() As Variant

See Also

LineageComponent Object


%%PageItemTitle%%

SourceObjectType Property

Description

Returns the type of the source object. DATATYPE: Integer.(1=Entity,16=View)

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceObjectType() As Variant

See Also

LineageComponent Object


%%PageItemTitle%%

LineageComponentDisplay Object
See Also Members

Description

This object represents a lineage component display in ER/Studio. A view lineage component object is a graphical representation of a lineage component in a specific data flow - it is not a lineage component itself.

See Also

LineageComponentDisplay Members


%%PageItemTitle%% $$Members$$

LineageComponentDisplay Object Members
See Also Overview

Public Properties

Public Property GUID | This is the GUID of the LineageComponentDisplay object. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the LineageComponentDisplay object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the LineageComponentDisplay object. DATATYPE: Integer.
Public Property ID | This is the ID of the LineageComponentDisplay object. This ID is assigned by ER/Studio and it is the same as the parent LineageComponent ID. DATATYPE: Integer.
Public Property Name | This is the name of the LineageComponentDisplay object. DATATYPE: String.
Public Property VerticalPosition | This is the y coordinate of the LineageComponentDisplay object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the LineageComponentDisplay object. DATATYPE: Integer.

See Also

LineageComponentDisplay Overview


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the LineageComponentDisplay object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the LineageComponentDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the LineageComponentDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the LineageComponentDisplay object. This ID is assigned by ER/Studio and it is the same as the parent LineageComponent ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

Name Property

Description

This is the name of the LineageComponentDisplay object. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the LineageComponentDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the LineageComponentDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

LineageComponentDisplay Object


%%PageItemTitle%%

LineageComponentDisplays Collection
See Also Members

Description

This object represents a collection of LineageComponentDisplays. The owner of this collection is the data flow.

Object Model

See Also

LineageComponentDisplays Members


%%PageItemTitle%% $$Members$$

LineageComponentDisplays Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a LineageComponentDisplay object (specified by the given GUID or by the given ID of the parent LineageComponent). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Lineage Component Display objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a LineageComponentDisplay object (specified by the given GUID or by the given ID of the parent LineageComponent). PARAMETERS: Identifier as String or Integer.

See Also

LineageComponentDisplays Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a LineageComponentDisplay object (specified by the given GUID or by the given ID of the parent LineageComponent). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As LineageComponentDisplay

Parameters

Identifier

See Also

LineageComponentDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

LineageComponentDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Lineage Component Display objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

LineageComponentDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a LineageComponentDisplay object (specified by the given GUID or by the given ID of the parent LineageComponent). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As LineageComponentDisplay

Parameters

Identifier

See Also

LineageComponentDisplays Collection


%%PageItemTitle%%

LineageComponents Collection
See Also Members

Description

This object represents a collection of LineageComponents. The owner of this collection is the data flow.

Object Model

See Also

LineageComponents Members


%%PageItemTitle%% $$Members$$

LineageComponents Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new LineageComponent with the given source data and returns the new LineageComponents to the caller. PARAMETERS: SourceObjectType as Integer (1=Entity,16=View), SourceObjectID, HorizontalPosition, and VerticalPosition as Integer.
Public Method ItemBySource | Returns a LineageComponent object (specified by the given SourceObjectType and SourceObjectID). PARAMETERS: SourceObjectType as Integer (1=Entity,16=View), SourceObjectID as Integer.
Public Method Remove | Deletes a LineageComponent object (specified by the given GUID or ID) from ER/Studio. PARAMETERS: Identifier as string(GUID) or Integer(ID).

Public Properties

Public Property _Item | Returns a LineageComponent object specified by the given GUID or ID). PARAMETER: Identifier as Integer(ID) or as String(GUID).
Public Property _NewEnum |
Public Property Count | This is the number of LineageComponent objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a LineageComponent object specified by the given GUID or ID). PARAMETER: Identifier as Integer(ID) or as String(GUID).

See Also

LineageComponents Overview


%%PageItemTitle%%

Add Method
SourceObjectType
SourceObjectID
HorizontalPosition
VerticalPosition

Description

Creates a new LineageComponent with the given source data and returns the new LineageComponents to the caller. PARAMETERS: SourceObjectType as Integer (1=Entity,16=View), SourceObjectID, HorizontalPosition, and VerticalPosition as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal SourceObjectType As Variant, _
   ByVal SourceObjectID As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As LineageComponent

Parameters

SourceObjectType
SourceObjectID
HorizontalPosition
VerticalPosition

See Also

LineageComponents Collection


%%PageItemTitle%%

ItemBySource Method
SourceObjectType
SourceObjectID

Description

Returns a LineageComponent object (specified by the given SourceObjectType and SourceObjectID). PARAMETERS: SourceObjectType as Integer (1=Entity,16=View), SourceObjectID as Integer.

Syntax

Visual Basic
Public Function ItemBySource( _
   ByVal SourceObjectType As Variant, _
   ByVal SourceObjectID As Variant _
) As LineageComponent

Parameters

SourceObjectType
SourceObjectID

See Also

LineageComponents Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a LineageComponent object (specified by the given GUID or ID) from ER/Studio. PARAMETERS: Identifier as string(GUID) or Integer(ID).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

LineageComponents Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a LineageComponent object specified by the given GUID or ID). PARAMETER: Identifier as Integer(ID) or as String(GUID).

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As LineageComponent

Parameters

Identifier

See Also

LineageComponents Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

LineageComponents Collection


%%PageItemTitle%%

Count Property

Description

This is the number of LineageComponent objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

LineageComponents Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a LineageComponent object specified by the given GUID or ID). PARAMETER: Identifier as Integer(ID) or as String(GUID).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As LineageComponent

Parameters

Identifier

See Also

LineageComponents Collection


%%PageItemTitle%%

LineDisplay Object
See Also Members

Description

This object represents a line display object in ER/Studio. A line display object is a graphical representation of a line in a specific submodel; it is not a line itself.

See Also

LineDisplay Members


%%PageItemTitle%% $$Members$$

LineDisplay Object Members
See Also Overview

Public Methods

Public Method ParentLine | Get the parent Line of this LineDisplay. DATATYPE: Line.
Public Method RepoCheckOutStatus | Get the Check Out status of this LineDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this LineDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property Color | This is the color of the line display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).
Public Property GUID | GUID of the line display object. This GUID is assigned by ER/Studio. Each line display object has a unique GUID. DATATYPE: String.
Public Property ID | ID of the line display object. This ID is assigned by ER/Studio. Each line display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property Width | This is the width of the line display object.

See Also

LineDisplay Overview


%%PageItemTitle%%

ParentLine Method

Description

Get the parent Line of this LineDisplay. DATATYPE: Line.

Syntax

Visual Basic
Public Function ParentLine() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this LineDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this LineDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

Color Property

Description

This is the color of the line display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the line display object. This GUID is assigned by ER/Studio. Each line display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the line display object. This ID is assigned by ER/Studio. Each line display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

Width Property

Description

This is the width of the line display object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Variant

See Also

LineDisplay Object


%%PageItemTitle%%

LineDisplays Collection
See Also Members

Description

This object represents a collection of line display objects. The owner of this collection is the submodel.

Object Model

See Also

LineDisplays Members


%%PageItemTitle%% $$Members$$

LineDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new LineDisplay from the Line identified by the given ID, and returns the new LineDisplay. PARAMETERS: LineID as Integer.
Public Method Remove | Deletes a LineDisplay object (specified by the given ID) from ER/Studio. PARAMETERS: Identifier as Integer.

Public Properties

Public Property _Item | Returns a LineDisplay object (specified by the given ID). PARAMETERS: Identifier as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of LineDisplay objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a LineDisplay object (specified by the given ID). PARAMETERS: Identifier as Integer.

See Also

LineDisplays Overview


%%PageItemTitle%%

Add Method
LineID

Description

Creates a new LineDisplay from the Line identified by the given ID, and returns the new LineDisplay. PARAMETERS: LineID as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal LineID As Variant _
) As LineDisplay

Parameters

LineID

See Also

LineDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a LineDisplay object (specified by the given ID) from ER/Studio. PARAMETERS: Identifier as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

LineDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a LineDisplay object (specified by the given ID). PARAMETERS: Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As LineDisplay

Parameters

Identifier

See Also

LineDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

LineDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of LineDisplay objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

LineDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a LineDisplay object (specified by the given ID). PARAMETERS: Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As LineDisplay

Parameters

Identifier

See Also

LineDisplays Collection


%%PageItemTitle%%

Lines Collection
See Also Members

Description

This object represents a collection of lines. The owner of this collection is the model.

Object Model

See Also

Lines Members


%%PageItemTitle%% $$Members$$

Lines Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a line. The possible type values are: Entity - 1, View - 16, etc. See ER/Studio help for a complete list. PARAMETERS: ParentType as Integer, ParentObject as String, ChildType as Integer, ChildObject as String.
Public Method Remove | Deletes a Line object (specified by the given ID) from ER/Studio. PARAMETERS: Identifier as Integer.

Public Properties

Public Property _Item | Returns a Line object (specified by the given ID or GUID). PARAMETERS: Identifier as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Line objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Line object (specified by the given ID or GUID). PARAMETERS: Identifier as Integer.

See Also

Lines Overview


%%PageItemTitle%%

Add Method
ParentType
ParentObject
ChildType
ChildObject

Description

Creates a line. The possible type values are: Entity - 1, View - 16, etc. See ER/Studio help for a complete list. PARAMETERS: ParentType as Integer, ParentObject as String, ChildType as Integer, ChildObject as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal ParentType As Variant, _
   ByVal ParentObject As Variant, _
   ByVal ChildType As Variant, _
   ByVal ChildObject As Variant _
) As Line

Parameters

ParentType
ParentObject
ChildType
ChildObject

See Also

Lines Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Line object (specified by the given ID) from ER/Studio. PARAMETERS: Identifier as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Lines Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Line object (specified by the given ID or GUID). PARAMETERS: Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Line

Parameters

Identifier

See Also

Lines Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Lines Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Line objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Lines Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Line object (specified by the given ID or GUID). PARAMETERS: Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Line

Parameters

Identifier

See Also

Lines Collection


%%PageItemTitle%%

ListMember Object
See Also Members

Description

This object represents a ListMember in ER/Studio. It's an item in an Attachment TextList

See Also

ListMember Members


%%PageItemTitle%% $$Members$$

ListMember Object Members
See Also Overview

Public Properties

Public Property IsDefault | Indicates if this Text is the default for the TextList. DATATYPE: Boolean.
Public Property SequenceNumber | Returns the sequence number of the TextListItem. If you modified the text list, the sequence number may not be acurate anymore. DATATYPE: Integer .
Public Property Text | Returns the string value of this TextValue. DATATYPE: String.

See Also

ListMember Overview


%%PageItemTitle%%

IsDefault Property

Description

Indicates if this Text is the default for the TextList. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDefault() As Variant

See Also

ListMember Object


%%PageItemTitle%%

SequenceNumber Property

Description

Returns the sequence number of the TextListItem. If you modified the text list, the sequence number may not be acurate anymore. DATATYPE: Integer .

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

ListMember Object


%%PageItemTitle%%

Text Property

Description

Returns the string value of this TextValue. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Text() As Variant

See Also

ListMember Object


%%PageItemTitle%%

MacroResultObj Object
See Also Members

Description

This is a hidden object that is used internally in different Editors inside ER/Studio. It represents templated Procedures and triggers.

See Also

MacroResultObj Members


%%PageItemTitle%% $$Members$$

MacroResultObj Object Members
See Also Overview

Public Properties

Public Property ResultString
Public Property TriggerAction
Public Property TriggerName

See Also

MacroResultObj Overview


%%PageItemTitle%%

ResultString Property

Property type

Read-write property

Syntax

Visual Basic
Public Property ResultString() As String

See Also

MacroResultObj Object


%%PageItemTitle%%

TriggerAction Property

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerAction() As String

See Also

MacroResultObj Object


%%PageItemTitle%%

TriggerName Property

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerName() As String

See Also

MacroResultObj Object


%%PageItemTitle%%

MergeModel Object
See Also Members

Description

This object represent the MergeModel object in ER/Studio.

See Also

MergeModel Members


%%PageItemTitle%% $$Members$$

MergeModel Object Members
See Also Overview

Public Methods

Public Method DoMerge | Executes the Merge Model process using the indicated QuickLaunch file and Decision (0=Ignore, 1=MergeAllToTarget, 2=MergeAllToCurrent.) PARAMETERS: FilePath as String, Decision as Integer. RETURN DATATYPE: Boolean.
Public Method MergeReport | PARAMETERS: FilePath as String, ReportFile as String, Decision as Integer, ReportType as Integer, Use quicklaunch to create a reportfile using the given decision. ReportType(0=RTF,1=HTML). RETURN DATATYPE: Boolean.

See Also

MergeModel Overview


%%PageItemTitle%%

DoMerge Method
FilePath
Decision

Description

Executes the Merge Model process using the indicated QuickLaunch file and Decision (0=Ignore, 1=MergeAllToTarget, 2=MergeAllToCurrent.) PARAMETERS: FilePath as String, Decision as Integer. RETURN DATATYPE: Boolean.

Syntax

Visual Basic
Public Function DoMerge( _
   ByVal FilePath As Variant, _
   ByVal Decision As Variant _
) As Variant

Parameters

FilePath
Decision

See Also

MergeModel Object


%%PageItemTitle%%

MergeReport Method
FilePath
ReportFile
Decision
ReportType

Description

PARAMETERS: FilePath as String, ReportFile as String, Decision as Integer, ReportType as Integer, Use quicklaunch to create a reportfile using the given decision. ReportType(0=RTF,1=HTML). RETURN DATATYPE: Boolean.

Syntax

Visual Basic
Public Function MergeReport( _
   ByVal FilePath As Variant, _
   ByVal ReportFile As Variant, _
   ByVal Decision As Variant, _
   ByVal ReportType As Variant _
) As Variant

Parameters

FilePath
ReportFile
Decision
ReportType

See Also

MergeModel Object


%%PageItemTitle%%

MetaImportObject Object
See Also Members

Description

This object represent the MetaImportObject object in ER/Studio, which implements MetaWizard (Import) functionality for the automation interface.

See Also

MetaImportObject Members


%%PageItemTitle%% $$Members$$

MetaImportObject Object Members
See Also Overview

Public Methods

Public Method DoImport Executes the import with the specified properties. RETURN DATATYPE: Diagram.

Public Properties

Public Property BridgeID | ID specifying the Bridge used to import the file. (The bridge to choose is determined by the type of file you want to import). Please see MIRModelBridges.xml to see the valid BridgeIDs and corresponding bridge names. DATATYPE: Integer.
Public Property BridgeIDName | Name specifying the Bridge used to import the file. This name can be looked up in MIRModelBridges.xml and is the ID property of the Bridge element. MetaIntegration guarantees BridgeIDs to not change. DATATYPE: String.
Public Property BridgeName | Name of Bridge used for import as it appears in combo of the wizard. These names are in MIRModelBridges.xml. ID property of DisplayName element. These names can change with new releases by MetaIntegration. DATATYPE: String.
Public Property ConsistencyCheck | This is the ConsistencyCheck (Validate Source). DATATYPE: Integer. Valid options are: 1 - no check, 2 - default, 3 - Debug.
Public Property DimensionalProperties | This is the Export Dimensional Properties option (as on the second page of the ImportMetaWizard). DATATYPE: Boolean.
Public Property EncodingID | ID specifying the Encoding option (as on the second page of the ImportMetaWizard). Please see help to see the valid EncodingIDs and corresponding Encoding names. DATATYPE: Integer.
Public Property EncodingName | Encoding Name option (as on the second page of the ImportMetaWizard). Please see help to see the valid EncodingIDs and corresponding Encoding names. DATATYPE: String.
Public Property FileNameAndPath | This is the path and file name of the file to be imported. DATATYPE: String.
Public Property GenerateLogFile | Setting determines whether a log file will be generated: 0 - always, 1 - only on warnings and errors, 2 - only on errors (2 is the default). DATATYPE: Integer.
Public Property ImportOptionModel | Model locator string: For SQL Server: mmart://MyDatabase/MyLibrary/MyModel - For Oracle: mmart:///MyLibrary/MyModel. DATATYPE: String.
Public Property ImportOptionPassword | Password import option parameter for ERwin 7 data modeler (via ModelManager). Used for database authentication. Displayed in clear text not asterisks. DATATYPE: String.
Public Property ImportOptionSummaryLineage | Import option SummaryLineage: Possible Values: 0 – None, 1 – Activity Driven, 2 – Target Table Driven, 3 – Source Table Driven, 4 – Target Column Driven, 5 – Source Column Driven. DATATYPE: Integer.
Public Property ImportOptionUserName | User Name import option parameter for ERwin 7 data modeler (via ModelManager). Used for database authentication. DATATYPE: String.
Public Property ImportToFileNameAndPath | This is the path and file name to where the to be generated dm1 file will be imported. DATATYPE: String.
Public Property LogFileLocation | This is the path and file name of the log file to be generated. DATATYPE: String.
Public Property TargetDatabase | This option is no longer supported. DATATYPE: String.
Public Property TargetDatabaseID | This option is no longer supported. DATATYPE: Integer.

See Also

MetaImportObject Overview


%%PageItemTitle%%

DoImport Method

Description

Executes the import with the specified properties. RETURN DATATYPE: Diagram.

Syntax

Visual Basic
Public Function DoImport() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

BridgeID Property

Description

ID specifying the Bridge used to import the file. (The bridge to choose is determined by the type of file you want to import). Please see MIRModelBridges.xml to see the valid BridgeIDs and corresponding bridge names. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property BridgeID() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

BridgeIDName Property

Description

Name specifying the Bridge used to import the file. This name can be looked up in MIRModelBridges.xml and is the ID property of the Bridge element. MetaIntegration guarantees BridgeIDs to not change. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BridgeIDName() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

BridgeName Property

Description

Name of Bridge used for import as it appears in combo of the wizard. These names are in MIRModelBridges.xml. ID property of DisplayName element. These names can change with new releases by MetaIntegration. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BridgeName() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

ConsistencyCheck Property

Description

This is the ConsistencyCheck (Validate Source). DATATYPE: Integer. Valid options are: 1 - no check, 2 - default, 3 - Debug.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConsistencyCheck() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

DimensionalProperties Property

Description

This is the Export Dimensional Properties option (as on the second page of the ImportMetaWizard). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionalProperties() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

EncodingID Property

Description

ID specifying the Encoding option (as on the second page of the ImportMetaWizard). Please see help to see the valid EncodingIDs and corresponding Encoding names. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncodingID() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

EncodingName Property

Description

Encoding Name option (as on the second page of the ImportMetaWizard). Please see help to see the valid EncodingIDs and corresponding Encoding names. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property EncodingName() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

FileNameAndPath Property

Description

This is the path and file name of the file to be imported. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileNameAndPath() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

GenerateLogFile Property

Description

Setting determines whether a log file will be generated: 0 - always, 1 - only on warnings and errors, 2 - only on errors (2 is the default). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenerateLogFile() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

ImportOptionModel Property

Description

Model locator string: For SQL Server: mmart://MyDatabase/MyLibrary/MyModel - For Oracle: mmart:///MyLibrary/MyModel. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImportOptionModel() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

ImportOptionPassword Property

Description

Password import option parameter for ERwin 7 data modeler (via ModelManager). Used for database authentication. Displayed in clear text not asterisks. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImportOptionPassword() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

ImportOptionSummaryLineage Property

Description

Import option SummaryLineage: Possible Values: 0 – None, 1 – Activity Driven, 2 – Target Table Driven, 3 – Source Table Driven, 4 – Target Column Driven, 5 – Source Column Driven. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImportOptionSummaryLineage() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

ImportOptionUserName Property

Description

User Name import option parameter for ERwin 7 data modeler (via ModelManager). Used for database authentication. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImportOptionUserName() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

ImportToFileNameAndPath Property

Description

This is the path and file name to where the to be generated dm1 file will be imported. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImportToFileNameAndPath() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

LogFileLocation Property

Description

This is the path and file name of the log file to be generated. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogFileLocation() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

TargetDatabase Property

Description

This option is no longer supported. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetDatabase() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

TargetDatabaseID Property

Description

This option is no longer supported. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetDatabaseID() As Variant

See Also

MetaImportObject Object


%%PageItemTitle%%

Model Object
See Also Members

Description

This object represents a model in ER/Studio.

Object Model

See Also

Model Members


%%PageItemTitle%% $$Members$$

Model Object Members
See Also Overview

Public Methods

Public Method ActiveSubModel | Returns the active submodel. The active submodel is the submodel that is currently displayed in ER/Studio. RETURN DATATYPE: SubModel.
Public Method BoundAttachments | Get all the BoundAttachments of this Model.
Public Method BoundSecurityProperties | Get all the BoundSecurityProperties of this Model.
Public Method BusinessDataObjects | Returns the BusinessDataObjects of this model.
Public Method DataMovementModelLinks | Returns the DataMovementModelLinks collection, containing all datamovement links that link this model to source/target models.
Public Method DB2390AuxTables | Returns an object representing a collection of all auxiliary tables (DB2 OS/390 only).
Public Method DB2Databases | Returns the DB2Databases in this model.
Public Method DB2OS390Aliases | Returns the DB2OS390Aliases of this model.
Public Method DB2OS390AuxTables | Returns an object representing a collection of all auxiliary tables (DB2 OS/390 only).
Public Method DB2OS390Synonyms | Returns the DB2OS390Synonyms of this model.
Public Method DB2StoGroups | Returns the DB2StoGroups in this model.
Public Method DB2Tablespaces | Returns the DB2Tablespaces in this model.
Public Method DB2UDBAliases | Returns the DB2UDBAliases of this model.
Public Method DB2UDBBufferPools | Returns the DB2UDBBufferPools associated with this Model.
Public Method DB2UDBMaterializedQueryTables | Returns the DB2UDBMaterializedQueryTables of this model.
Public Method DB2UDBNodeGroups | Returns the DB2 UDB NodeGroups associated with this Model.
Public Method DB2UDBSequences | Returns the DB2UDBSequences of this model.
Public Method DB2UDBTablespaces | Returns the DB2UDBTablespaces associated with this Model.
Public Method DBRoles | Returns an object representing a collection of all DBRoles in the model.
Public Method DBSchemas | Returns an object representing a collection of all DBSchemas in the model.
Public Method DBUsers | Returns an object representing a collection of all DBUsers in the model.
Public Method DDLGenerationObject | Returns an object which provides an interface for generating the DDL for the model.
Public Method DeleteNamingStandardsTemplate | Unbind this Model from the naming standards template by deleting the naming standards template ID from the model.
Public Method Entities | Returns an object representing a collection of all entities in the model.
Public Method FirebirdGenerators | Returns the FirebirdGenerators of this model.
Public Method GetNamingStandardsTemplate | Returns the naming standards template bound to the model or null, if none is bound to the model.
Public Method HTMLReport | Creates an HTML report for the Model and saves it in the given WebDirectory. PARAMETERS: WebDirectory as String, UseUnixDelimiter as Boolean, IncludeModel as Boolean.
Public Method InterBaseGenerators | Returns the InterBaseGenerators of this model.
Public Method Lines | Returns an object representing a collection of all lines in the model.
Public Method NetezzaSynonyms | Returns the NeezzaSynonyms of this model.
Public Method ObjectTypes | Returns the ObjectTypes of this model.
Public Method OracleMaterializedViews | Returns the OracleMaterializedViews of this model.
Public Method OracleRollbackSegments | Returns the OracleRollbackSegments of this model.
Public Method OracleSequences | Returns the OracleSequences of this model.
Public Method OracleSynonyms | Returns the OracleSynonyms of this model.
Public Method OracleTablespaces | Returns the OracleTablespaces associated with this Model.
Public Method Packages | Returns the Packages of this model.
Public Method PhysicalGenerationObject | Returns an object which provides an interface for generating the physical model for the logical model.
Public Method Procedures | Returns an object representing a collection of all stored procedures in the model.
Public Method Relationships | Returns an object representing a collection of all relationships in the model.
Public Method RepoCheckOutStatus | Get the Check Out status of this Model object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this Model from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method Shapes | Returns the Shapes of this model.
Public Method SQLServerSequences | Returns the SQLServerSequences of this model.
Public Method SQLServerSynonyms | Returns the SQLServerSynonyms of this model.
Public Method SubModels | Returns an object representing a collection of all submodels in the model.
Public Method SubTypeClusters | Returns an object representing a collection of all SubTypeClusters in the model.
Public Method UserComments | Returns a collection of user comments associated with this model.
Public Method ViewRelationships | RETURN DATATYPE: ViewRelationships, Returns an object representing a collection of all view relationships in the model.
Public Method Views | Returns an object representing a collection of all views in the model.

Public Properties

Public Property BlobBlockSize | This is the blob block size which will be used to estimate the size of a table row in the capacity planning dialog. DATATYPE: Integer.
Public Property BlobOverhead | This is the Blob storage overhead which will be used to estimate the size of a table row in the capacity planning dialog. DATATYPE: Integer.
Public Property CaseHandling | This is the CaseHandling used in the Model. Values: PreserveCase = 0, LowerCase = 1, UpperCase = 2. DATATYPE: Integer.
Public Property CaseShift | This is the CaseShift setting used in the Model Options. Values: PreserveCase = 0, LowerCase = 1, UpperCase = 2. DATATYPE: Integer.
Public Property DatabasePlatform | This is the database platform type of the model. DATATYPE: String.
Public Property Datatype | This is the Datatype default in the Model. DATATYPE: String.
Public Property DatatypeNotNullable | This is the default Datatype Nullability used in the Model. Nullable = 0 and NotNullable = 1. DATATYPE: Integer.
Public Property DatatypeScale | This is the default Datatype Scale used in the Model. DATATYPE: Integer.
Public Property DatatypeWidth | This is the default Datatype Width used in the Model. DATATYPE: Integer.
Public Property Dimensional | This sets the model as Dimensional (true) or Relational (false). DATATYPE: Boolean.
Public Property DisablePostSQL | This is the DisablePostSQL boolean used in the Model Options. If this option is true then PostSQL will not be generated. DATATYPE: Boolean.
Public Property DisablePreSQL | This is the DisablePreSQL boolean used in the Model Options. If this option is true then PreSQL will not be generated. DATATYPE: Boolean.
Public Property GenAlternateKey | This is the flag to Generate Alternate Key in the Model. DATATYPE: Boolean.
Public Property GenForeignKey | This is the flag to Generate Foreign Key in the Model. DATATYPE: Boolean.
Public Property GenInversionEntry | This is the flag to Generate Inversion Entry in the Model. DATATYPE: Boolean.
Public Property GenPKWithCluster | This is the flag to Generate the Primary Key with Cluster in Generate Physical Model. DATATYPE: Boolean.
Public Property GenPrimaryKey | This is the flag to Generate Primary Key in the Model. DATATYPE: Boolean.
Public Property GUID | GUID of the model. GUID is assigned by ER/Studio. Each model has a unique GUID. DATATYPE: String.
Public Property ID | ID of the model. This ID is assigned by ER/Studio. Each model in a diagram has a unique ID. DATATYPE: Integer.
Public Property IndexOverhead | This is the Index storage overhead which will be used to estimate the size of an index in the capacity planning dialog. DATATYPE: Integer.
Public Property Logical | This tells whether the model is logical or not. DATATYPE: Boolean.
Public Property MajorPlatform | This is a more generalized description of the database platform type of the model. DATATYPE: String.
Public Property Name | DATATYPE: String. This is the name of the model.
Public Property NameMax | This is the Maximum Name Length used in the Model. Only Logical Model can be changed by this property. DATATYPE: Integer.
Public Property NamePrefix | This is the NamePrefix used in Generating Physical Model. DATATYPE: String.
Public Property NameSync | This is the NameSynchronization scheme in the Model.Value: Complete = 0, Partial = 1, None = 2. DATATYPE: Integer.
Public Property NamingStandardsTemplateId | ID of the NamingStandardsTemplate object bound to the model (if any). A user can bind a NamingStandardsTemplate to the model by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.
Public Property Notation | This is the Notation used in the Model. Values: IDEF1X = 0, IE = 1, TRUE_IE = 2, DASHED_IE = 3. DATATYPE: Integer.
Public Property PostSQL | This is the PostSQL string used in the Model Options. DATATYPE: String.
Public Property PreSQL | This is the PreSQL string used in the Model Options. DATATYPE: String.
Public Property RoleNamePrefix | This is the default RoleName prefix used in the Model. DATATYPE: String.
Public Property RowOverhead | This is the row storage overhead which will be used to estimate the size of a table row in the capacity planning dialog. DATATYPE: Integer.
Public Property SpaceHandling | This is the SpaceHandling used in the Model. Values: PreserveSpaces = 0, RemoveSpaces = 1, UnderScoreSpaces = 2. DATATYPE: Integer.
Public Property StatementDelimiter | This is the statement delimiter of the model. DATATYPE: String.
Public Property TableOverhead | This is the Table storage overhead which will be used to estimate the size of a table in the capacity planning dialog. DATATYPE: Integer.

See Also

Model Overview


%%PageItemTitle%%

ActiveSubModel Method

Description

Returns the active submodel. The active submodel is the submodel that is currently displayed in ER/Studio. RETURN DATATYPE: SubModel.

Syntax

Visual Basic
Public Function ActiveSubModel() As Variant

Example

Dim MyModel As Model

MyModel = Model.ActiveSubModel

See Also

Model Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Model.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Model Object


%%PageItemTitle%%

BoundSecurityProperties Method

Description

Get all the BoundSecurityProperties of this Model.

Syntax

Visual Basic
Public Function BoundSecurityProperties() As BoundSecurityProperties

See Also

Model Object


%%PageItemTitle%%

BusinessDataObjects Method

Description

Returns the BusinessDataObjects of this model.

Syntax

Visual Basic
Public Function BusinessDataObjects() As BusinessDataObjects

See Also

Model Object


%%PageItemTitle%%

DataMovementModelLinks Method

Description

Returns the DataMovementModelLinks collection, containing all datamovement links that link this model to source/target models.

Syntax

Visual Basic
Public Function DataMovementModelLinks() As DataMovementModelLinks

See Also

Model Object


%%PageItemTitle%%

DB2390AuxTables Method

Description

Returns an object representing a collection of all auxiliary tables (DB2 OS/390 only).

Syntax

Visual Basic
Public Function DB2390AuxTables() As DB2390AuxTables

See Also

Model Object


%%PageItemTitle%%

DB2Databases Method

Description

Returns the DB2Databases in this model.

Syntax

Visual Basic
Public Function DB2Databases() As DB2Databases

See Also

Model Object


%%PageItemTitle%%

DB2OS390Aliases Method

Description

Returns the DB2OS390Aliases of this model.

Syntax

Visual Basic
Public Function DB2OS390Aliases() As DB2OS390Aliases

See Also

Model Object


%%PageItemTitle%%

DB2OS390AuxTables Method

Description

Returns an object representing a collection of all auxiliary tables (DB2 OS/390 only).

Syntax

Visual Basic
Public Function DB2OS390AuxTables() As DB2OS390AuxTables

See Also

Model Object


%%PageItemTitle%%

DB2OS390Synonyms Method

Description

Returns the DB2OS390Synonyms of this model.

Syntax

Visual Basic
Public Function DB2OS390Synonyms() As DB2OS390Synonyms

See Also

Model Object


%%PageItemTitle%%

DB2StoGroups Method

Description

Returns the DB2StoGroups in this model.

Syntax

Visual Basic
Public Function DB2StoGroups() As DB2StoGroups

See Also

Model Object


%%PageItemTitle%%

DB2Tablespaces Method

Description

Returns the DB2Tablespaces in this model.

Syntax

Visual Basic
Public Function DB2Tablespaces() As DB2Tablespaces

See Also

Model Object


%%PageItemTitle%%

DB2UDBAliases Method

Description

Returns the DB2UDBAliases of this model.

Syntax

Visual Basic
Public Function DB2UDBAliases() As DB2UDBAliases

See Also

Model Object


%%PageItemTitle%%

DB2UDBBufferPools Method

Description

Returns the DB2UDBBufferPools associated with this Model.

Syntax

Visual Basic
Public Function DB2UDBBufferPools() As DB2UDBBufferPools

See Also

Model Object


%%PageItemTitle%%

DB2UDBMaterializedQueryTables Method

Description

Returns the DB2UDBMaterializedQueryTables of this model.

Syntax

Visual Basic
Public Function DB2UDBMaterializedQueryTables() As DB2UDBMaterializedQueryTables

See Also

Model Object


%%PageItemTitle%%

DB2UDBNodeGroups Method

Description

Returns the DB2 UDB NodeGroups associated with this Model.

Syntax

Visual Basic
Public Function DB2UDBNodeGroups() As DB2UDBNodeGroups

See Also

Model Object


%%PageItemTitle%%

DB2UDBSequences Method

Description

Returns the DB2UDBSequences of this model.

Syntax

Visual Basic
Public Function DB2UDBSequences() As DB2UDBSequences

See Also

Model Object


%%PageItemTitle%%

DB2UDBTablespaces Method

Description

Returns the DB2UDBTablespaces associated with this Model.

Syntax

Visual Basic
Public Function DB2UDBTablespaces() As DB2UDBTablespaces

See Also

Model Object


%%PageItemTitle%%

DBRoles Method

Description

Returns an object representing a collection of all DBRoles in the model.

Syntax

Visual Basic
Public Function DBRoles() As DBRoles

See Also

Model Object


%%PageItemTitle%%

DBSchemas Method

Description

Returns an object representing a collection of all DBSchemas in the model.

Syntax

Visual Basic
Public Function DBSchemas() As DBSchemas

See Also

Model Object


%%PageItemTitle%%

DBUsers Method

Description

Returns an object representing a collection of all DBUsers in the model.

Syntax

Visual Basic
Public Function DBUsers() As DBUsers

See Also

Model Object


%%PageItemTitle%%

DDLGenerationObject Method

Description

Returns an object which provides an interface for generating the DDL for the model.

Syntax

Visual Basic
Public Function DDLGenerationObject() As DDLGeneration

See Also

Model Object


%%PageItemTitle%%

DeleteNamingStandardsTemplate Method

Description

Unbind this Model from the naming standards template by deleting the naming standards template ID from the model.

Syntax

Visual Basic
Public Function DeleteNamingStandardsTemplate() As Variant

See Also

Model Object


%%PageItemTitle%%

Entities Method

Description

Returns an object representing a collection of all entities in the model.

Syntax

Visual Basic
Public Function Entities() As Entities

Example

Dim MyModel As Model

Dim AllEnts As Entities

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.ActiveModel

AllEnts = MyModel.Entities

See Also

Model Object


%%PageItemTitle%%

FirebirdGenerators Method

Description

Returns the FirebirdGenerators of this model.

Syntax

Visual Basic
Public Function FirebirdGenerators() As FirebirdGenerators

See Also

Model Object


%%PageItemTitle%%

GetNamingStandardsTemplate Method

Description

Returns the naming standards template bound to the model or null, if none is bound to the model.

Syntax

Visual Basic
Public Function GetNamingStandardsTemplate() As NamingStandardsTemplate

See Also

Model Object


%%PageItemTitle%%

HTMLReport Method
WebDirectory
IncludeModel
UseUnixDelimiter

Description

Creates an HTML report for the Model and saves it in the given WebDirectory. PARAMETERS: WebDirectory as String, UseUnixDelimiter as Boolean, IncludeModel as Boolean.

Syntax

Visual Basic
Public Sub HTMLReport( _
   ByVal WebDirectory As Variant, _
   ByVal IncludeModel As Variant, _
   ByVal UseUnixDelimiter As Variant _
)

Parameters

WebDirectory
IncludeModel
UseUnixDelimiter

See Also

Model Object


%%PageItemTitle%%

InterBaseGenerators Method

Description

Returns the InterBaseGenerators of this model.

Syntax

Visual Basic
Public Function InterBaseGenerators() As InterBaseGenerators

See Also

Model Object


%%PageItemTitle%%

Lines Method

Description

Returns an object representing a collection of all lines in the model.

Syntax

Visual Basic
Public Function Lines() As Lines

See Also

Model Object


%%PageItemTitle%%

NetezzaSynonyms Method

Description

Returns the NeezzaSynonyms of this model.

Syntax

Visual Basic
Public Function NetezzaSynonyms() As NetezzaSynonyms

See Also

Model Object


%%PageItemTitle%%

ObjectTypes Method

Description

Returns the ObjectTypes of this model.

Syntax

Visual Basic
Public Function ObjectTypes() As ObjectTypes

See Also

Model Object


%%PageItemTitle%%

OracleMaterializedViews Method

Description

Returns the OracleMaterializedViews of this model.

Syntax

Visual Basic
Public Function OracleMaterializedViews() As OracleMaterializedViews

See Also

Model Object


%%PageItemTitle%%

OracleRollbackSegments Method

Description

Returns the OracleRollbackSegments of this model.

Syntax

Visual Basic
Public Function OracleRollbackSegments() As OracleRollbackSegments

See Also

Model Object


%%PageItemTitle%%

OracleSequences Method

Description

Returns the OracleSequences of this model.

Syntax

Visual Basic
Public Function OracleSequences() As OracleSequences

See Also

Model Object


%%PageItemTitle%%

OracleSynonyms Method

Description

Returns the OracleSynonyms of this model.

Syntax

Visual Basic
Public Function OracleSynonyms() As OracleSynonyms

See Also

Model Object


%%PageItemTitle%%

OracleTablespaces Method

Description

Returns the OracleTablespaces associated with this Model.

Syntax

Visual Basic
Public Function OracleTablespaces() As OracleTablespaces

See Also

Model Object


%%PageItemTitle%%

Packages Method

Description

Returns the Packages of this model.

Syntax

Visual Basic
Public Function Packages() As Packages

See Also

Model Object


%%PageItemTitle%%

PhysicalGenerationObject Method

Description

Returns an object which provides an interface for generating the physical model for the logical model.

Syntax

Visual Basic
Public Function PhysicalGenerationObject() As PhysicalGeneration

See Also

Model Object


%%PageItemTitle%%

Procedures Method

Description

Returns an object representing a collection of all stored procedures in the model.

Syntax

Visual Basic
Public Function Procedures() As Procedures

Example

Dim MyModel As Model

Dim AllProcs As Procedures

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.ActiveModel

AllProcs = MyModel.Procedures

See Also

Model Object


%%PageItemTitle%%

Relationships Method

Description

Returns an object representing a collection of all relationships in the model.

Syntax

Visual Basic
Public Function Relationships() As Relationships

Example

Dim MyModel As Model

Dim AllRs As Relationships

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.ActiveModel

AllRs = MyModel.Relationships

See Also

Model Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Model object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Model Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this Model from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

Model Object


%%PageItemTitle%%

Shapes Method

Description

Returns the Shapes of this model.

Syntax

Visual Basic
Public Function Shapes() As Shapes

See Also

Model Object


%%PageItemTitle%%

SQLServerSequences Method

Description

Returns the SQLServerSequences of this model.

Syntax

Visual Basic
Public Function SQLServerSequences() As SQLServerSequences

See Also

Model Object


%%PageItemTitle%%

SQLServerSynonyms Method

Description

Returns the SQLServerSynonyms of this model.

Syntax

Visual Basic
Public Function SQLServerSynonyms() As SQLServerSynonyms

See Also

Model Object


%%PageItemTitle%%

SubModels Method

Description

Returns an object representing a collection of all submodels in the model.

Syntax

Visual Basic
Public Function SubModels() As SubModels

Example

Dim MyModel As Model

Dim Allsubs As SubModels

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.ActiveModel

Allsubs = MyModel.SubModels

See Also

Model Object


%%PageItemTitle%%

SubTypeClusters Method

Description

Returns an object representing a collection of all SubTypeClusters in the model.

Syntax

Visual Basic
Public Function SubTypeClusters() As SubTypeClusters

See Also

Model Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this model.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Model Object


%%PageItemTitle%%

ViewRelationships Method

Description

RETURN DATATYPE: ViewRelationships, Returns an object representing a collection of all view relationships in the model.

Syntax

Visual Basic
Public Function ViewRelationships() As ViewRelationships

Remarks

The instantiation order (sequence of functions) is identical for collection objects of any type.

Example

See the examples for Model.Procedures, Model.Relationships, Model.SubModels, Model.Entities, etc.

See Also

Model Object


%%PageItemTitle%%

Views Method

Description

Returns an object representing a collection of all views in the model.

Syntax

Visual Basic
Public Function Views() As Views

Remarks

The instantiation order (sequence of functions) is identical for collection objects of any type.

Example

See the examples for Model.Procedures, Model.Relationships, Model.SubModels, Model.Entities, etc.

See Also

Model Object


%%PageItemTitle%%

BlobBlockSize Property

Description

This is the blob block size which will be used to estimate the size of a table row in the capacity planning dialog. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property BlobBlockSize() As Variant

See Also

Model Object


%%PageItemTitle%%

BlobOverhead Property

Description

This is the Blob storage overhead which will be used to estimate the size of a table row in the capacity planning dialog. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property BlobOverhead() As Variant

See Also

Model Object


%%PageItemTitle%%

CaseHandling Property

Description

This is the CaseHandling used in the Model. Values: PreserveCase = 0, LowerCase = 1, UpperCase = 2. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CaseHandling() As Variant

See Also

Model Object


%%PageItemTitle%%

CaseShift Property

Description

This is the CaseShift setting used in the Model Options. Values: PreserveCase = 0, LowerCase = 1, UpperCase = 2. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CaseShift() As Variant

See Also

Model Object


%%PageItemTitle%%

DatabasePlatform Property

Description

This is the database platform type of the model. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property DatabasePlatform() As Variant

Example

Dim MyModel As Model

Dim DBPlat As String

MyModel.DatabasePlatform = DBPlat

See Also

Model Object


%%PageItemTitle%%

Datatype Property

Description

This is the Datatype default in the Model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

Model Object


%%PageItemTitle%%

DatatypeNotNullable Property

Description

This is the default Datatype Nullability used in the Model. Nullable = 0 and NotNullable = 1. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatatypeNotNullable() As Variant

See Also

Model Object


%%PageItemTitle%%

DatatypeScale Property

Description

This is the default Datatype Scale used in the Model. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatatypeScale() As Variant

See Also

Model Object


%%PageItemTitle%%

DatatypeWidth Property

Description

This is the default Datatype Width used in the Model. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatatypeWidth() As Variant

See Also

Model Object


%%PageItemTitle%%

Dimensional Property

Description

This sets the model as Dimensional (true) or Relational (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Dimensional() As Variant

See Also

Model Object


%%PageItemTitle%%

DisablePostSQL Property

Description

This is the DisablePostSQL boolean used in the Model Options. If this option is true then PostSQL will not be generated. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisablePostSQL() As Variant

See Also

Model Object


%%PageItemTitle%%

DisablePreSQL Property

Description

This is the DisablePreSQL boolean used in the Model Options. If this option is true then PreSQL will not be generated. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisablePreSQL() As Variant

See Also

Model Object


%%PageItemTitle%%

GenAlternateKey Property

Description

This is the flag to Generate Alternate Key in the Model. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenAlternateKey() As Variant

See Also

Model Object


%%PageItemTitle%%

GenForeignKey Property

Description

This is the flag to Generate Foreign Key in the Model. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenForeignKey() As Variant

See Also

Model Object


%%PageItemTitle%%

GenInversionEntry Property

Description

This is the flag to Generate Inversion Entry in the Model. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenInversionEntry() As Variant

See Also

Model Object


%%PageItemTitle%%

GenPKWithCluster Property

Description

This is the flag to Generate the Primary Key with Cluster in Generate Physical Model. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPKWithCluster() As Variant

See Also

Model Object


%%PageItemTitle%%

GenPrimaryKey Property

Description

This is the flag to Generate Primary Key in the Model. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPrimaryKey() As Variant

See Also

Model Object


%%PageItemTitle%%

GUID Property

Description

GUID of the model. GUID is assigned by ER/Studio. Each model has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Model Object


%%PageItemTitle%%

ID Property

Description

ID of the model. This ID is assigned by ER/Studio. Each model in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyModel As Model

Dim MyID As Integer

MyID = MyModel.ID

See Also

Model Object


%%PageItemTitle%%

IndexOverhead Property

Description

This is the Index storage overhead which will be used to estimate the size of an index in the capacity planning dialog. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexOverhead() As Variant

See Also

Model Object


%%PageItemTitle%%

Logical Property

Description

This tells whether the model is logical or not. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property Logical() As Variant

Example

Dim MyModel As Model

Dim IsLogical As Boolean

IsLogical = MyModel.Logical

See Also

Model Object


%%PageItemTitle%%

MajorPlatform Property

Description

This is a more generalized description of the database platform type of the model. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property MajorPlatform() As Variant

Example

Dim MyModel As Model

Dim MajPlat As String

MajPlat = MyModel.MajorPlatform

See Also

Model Object


%%PageItemTitle%%

Name Property

Description

DATATYPE: String. This is the name of the model.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

Example

Dim MyModel As Model

Dim MyName As String

MyModel.Name = MyName

See Also

Model Object


%%PageItemTitle%%

NameMax Property

Description

This is the Maximum Name Length used in the Model. Only Logical Model can be changed by this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NameMax() As Variant

See Also

Model Object


%%PageItemTitle%%

NamePrefix Property

Description

This is the NamePrefix used in Generating Physical Model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamePrefix() As Variant

See Also

Model Object


%%PageItemTitle%%

NameSync Property

Description

This is the NameSynchronization scheme in the Model.Value: Complete = 0, Partial = 1, None = 2. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NameSync() As Variant

See Also

Model Object


%%PageItemTitle%%

NamingStandardsTemplateId Property

Description

ID of the NamingStandardsTemplate object bound to the model (if any). A user can bind a NamingStandardsTemplate to the model by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamingStandardsTemplateId() As Variant

See Also

Model Object


%%PageItemTitle%%

Notation Property

Description

This is the Notation used in the Model. Values: IDEF1X = 0, IE = 1, TRUE_IE = 2, DASHED_IE = 3. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Notation() As Variant

See Also

Model Object


%%PageItemTitle%%

PostSQL Property

Description

This is the PostSQL string used in the Model Options. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

Model Object


%%PageItemTitle%%

PreSQL Property

Description

This is the PreSQL string used in the Model Options. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

Model Object


%%PageItemTitle%%

RoleNamePrefix Property

Description

This is the default RoleName prefix used in the Model. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property RoleNamePrefix() As Variant

See Also

Model Object


%%PageItemTitle%%

RowOverhead Property

Description

This is the row storage overhead which will be used to estimate the size of a table row in the capacity planning dialog. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property RowOverhead() As Variant

See Also

Model Object


%%PageItemTitle%%

SpaceHandling Property

Description

This is the SpaceHandling used in the Model. Values: PreserveSpaces = 0, RemoveSpaces = 1, UnderScoreSpaces = 2. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SpaceHandling() As Variant

See Also

Model Object


%%PageItemTitle%%

StatementDelimiter Property

Description

This is the statement delimiter of the model. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property StatementDelimiter() As Variant

Example

Dim MyModel As Model

Dim StDelim As String

StDelim = MyModel.StatementDelimiter

See Also

Model Object


%%PageItemTitle%%

TableOverhead Property

Description

This is the Table storage overhead which will be used to estimate the size of a table in the capacity planning dialog. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property TableOverhead() As Variant

See Also

Model Object


%%PageItemTitle%%

Models Collection
See Also Members

Description

This object represents a collection of models. The owner of this collection is the diagram.

Object Model

See Also

Models Members


%%PageItemTitle%% $$Members$$

Models Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new model with the given name and database type and returns the new model to the caller. Refer to the reference guide for database types. PARAMETERS: Name as String, DatabaseType_ID as Integer.
Public Method Remove | Deletes a Model object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Model object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Model objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Model object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Models Overview


%%PageItemTitle%%

Add Method
Name
DatabaseType_ID

The supported database types and their corresponding IDs are:

  • 1 Microsoft SQL Server 4.x
  • 2 Sybase System 10.x
  • 3 MS SQL SERVER 6.x
  • 4 Sybase Watcom SQL
  • 6 Informix Online
  • 7 Informix SE
  • 8 Oracle 7.x
  • 9 IBM DB2 Common Server
  • 10 Interbase
  • 11 Sybase ASE 11.0
  • 12 Sybase SQL Anywhere 5.x
  • 14 Microsoft Access
  • 15 Microsoft Access 2.0
  • 16 Microsoft Access 95
  • 17 Microsoft Visual FoxPro 2.x
  • 28 Microsoft Visual FoxPro 3.x
  • 30 Microsoft Access 97
  • 31 Microsoft Visual FoxPro 5.x
  • 32 IBM DB2 UDB 5.x
  • 33 Microsoft SQL SERVER 7.x
  • 34 Oracle 8.X
  • 35 Sybase ASA 6.0
  • 36 Sybase ASE 11.9
  • 37 Sybase ASE 11.5
  • 38 IBM DB2 UDB 6.x
  • 39 IBM DB2 UDB for OS/390 6.x
  • 40 IBM DB2 UDB for OS/390 5.x
  • 41 Microsoft SQL Server 2000
  • 42 Microsoft Access 2000
  • 43 Sybase ASE 12.0
  • 44 IBM DB2 UDB 7.x
  • 45 Hitachi HiRDB
  • 46 IBM DB2 UDB for OS/390 7.x
  • 47 Oracle 9i
  • 48 IBM DB2 AS/400 4.x
  • 49 Sybase Adaptive Server IQ 12.5
  • 51 Generic DBMS
  • 54 Sybase ASE 12.5
  • 55 Sybase ASA 7.0
  • 56 Sybase ASA 8.0
  • 57 NCR Teradata V2R4
  • 58 MySQL 3.x
  • 59 IBM DB2 UDB 8.x
  • 60 MySQL 4.x
  • 61 NCR Teradata V2R5
  • 62 IBM DB2 AS/400 5.x
  • 64 Sybase ASA 9.0
  • 65 Informix 9.x
  • 66 Oracle 10g
  • 68 Microsoft SQL Server 2005
  • 69 IBM DB2 UDB for OS/390 8.x
  • 70 Generic ODBC
  • 71 NCR Teradata V2R6
  • 72 PostgreSQL 8.0
  • 73 MySQL 5.x
  • 74 IBM DB2 UDB 9.x
  • 75 Sybase ASE 15
  • 77 Oracle 11g
  • 78 IBM DB2 for OS/390 9.x
  • 79 Sybase ASA 10.0
  • 81 InterBase 2007
  • 82 Microsoft SQL Server 2008
  • 83 InterBase 2009
  • 84 Teradata 12.0
  • 85 Netezza 4.6
  • 86 Netezza 5.0
  • 87 NCR Teradata 13.x
  • 88 Netezza 6.0
  • 89 Microsoft SQL Server 2012
  • 90 IBM DB2 UDB for OS/390 10.x
  • 91 PostgreSQL 9.x
  • 92 GreenPlum 4.x
  • 93 NCR Teradata 14.0
  • 94 Netezza 7.0
  • 95 IBM DB2 LUW 10.x
  • 96 InterBase XE
  • 97 InterBase XE3
  • 98 Firebird 1.5
  • 99 Firebird 2.x
  • 100 Oracle 12c
  • 101 Microsoft SQL Server 2014

Description

Creates a new model with the given name and database type and returns the new model to the caller. Refer to the reference guide for database types. PARAMETERS: Name as String, DatabaseType_ID as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal DatabaseType_ID As Variant _
) As Model

Parameters

Name
DatabaseType_ID

The supported database types and their corresponding IDs are:

  • 1 Microsoft SQL Server 4.x
  • 2 Sybase System 10.x
  • 3 MS SQL SERVER 6.x
  • 4 Sybase Watcom SQL
  • 6 Informix Online
  • 7 Informix SE
  • 8 Oracle 7.x
  • 9 IBM DB2 Common Server
  • 10 Interbase
  • 11 Sybase ASE 11.0
  • 12 Sybase SQL Anywhere 5.x
  • 14 Microsoft Access
  • 15 Microsoft Access 2.0
  • 16 Microsoft Access 95
  • 17 Microsoft Visual FoxPro 2.x
  • 28 Microsoft Visual FoxPro 3.x
  • 30 Microsoft Access 97
  • 31 Microsoft Visual FoxPro 5.x
  • 32 IBM DB2 UDB 5.x
  • 33 Microsoft SQL SERVER 7.x
  • 34 Oracle 8.X
  • 35 Sybase ASA 6.0
  • 36 Sybase ASE 11.9
  • 37 Sybase ASE 11.5
  • 38 IBM DB2 UDB 6.x
  • 39 IBM DB2 UDB for OS/390 6.x
  • 40 IBM DB2 UDB for OS/390 5.x
  • 41 Microsoft SQL Server 2000
  • 42 Microsoft Access 2000
  • 43 Sybase ASE 12.0
  • 44 IBM DB2 UDB 7.x
  • 45 Hitachi HiRDB
  • 46 IBM DB2 UDB for OS/390 7.x
  • 47 Oracle 9i
  • 48 IBM DB2 AS/400 4.x
  • 49 Sybase Adaptive Server IQ 12.5
  • 51 Generic DBMS
  • 54 Sybase ASE 12.5
  • 55 Sybase ASA 7.0
  • 56 Sybase ASA 8.0
  • 57 NCR Teradata V2R4
  • 58 MySQL 3.x
  • 59 IBM DB2 UDB 8.x
  • 60 MySQL 4.x
  • 61 NCR Teradata V2R5
  • 62 IBM DB2 AS/400 5.x
  • 64 Sybase ASA 9.0
  • 65 Informix 9.x
  • 66 Oracle 10g
  • 68 Microsoft SQL Server 2005
  • 69 IBM DB2 UDB for OS/390 8.x
  • 70 Generic ODBC
  • 71 NCR Teradata V2R6
  • 72 PostgreSQL 8.0
  • 73 MySQL 5.x
  • 74 IBM DB2 UDB 9.x
  • 75 Sybase ASE 15
  • 77 Oracle 11g
  • 78 IBM DB2 for OS/390 9.x
  • 79 Sybase ASA 10.0
  • 81 InterBase 2007
  • 82 Microsoft SQL Server 2008
  • 83 InterBase 2009
  • 84 Teradata 12.0
  • 85 Netezza 4.6
  • 86 Netezza 5.0
  • 87 NCR Teradata 13.x
  • 88 Netezza 6.0
  • 89 Microsoft SQL Server 2012
  • 90 IBM DB2 UDB for OS/390 10.x
  • 91 PostgreSQL 9.x
  • 92 GreenPlum 4.x
  • 93 NCR Teradata 14.0
  • 94 Netezza 7.0
  • 95 IBM DB2 LUW 10.x
  • 96 InterBase XE
  • 97 InterBase XE3
  • 98 Firebird 1.5
  • 99 Firebird 2.x
  • 100 Oracle 12c
  • 101 Microsoft SQL Server 2014

Return Type

Creates a new model with the given name and database type, adds it to the diagram, and returns the new model to the caller.

Example

Dim MyDiagram As Diagram

Dim NewModelName As String

Dim DBType As Integer

'Setting the new model name and the database type as an Oracle 8 database

NewModelName = "ShinyNewModel"

DBType = 34

Set MyDiagram = DiagramManager.ActiveDiagram

MyDiagram.Models.Add(NewModelName,34)

See Also

Models Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Model object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Models Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Model object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Model

Parameters

Identifier

See Also

Models Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Models Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Model objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

Example

Dim MyDiagram As Diagram

Dim iCount As Long

Set MyDiagram = DiagramManager.ActiveDiagram
iCount = MyDiagram.Models.Count

See Also

Models Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Model object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Model

Parameters

Identifier

Example

Dim MyDiagram As Diagram

Dim MyModel As Model

Dim ModelName As String

ModelName = "Physical"

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.Models.Item(ModelName)

See Also

Models Collection


%%PageItemTitle%%

NamingStandardsTemplate Object
See Also Members

Description

This object represents a naming standards template in ER/Studio.

Object Model

See Also

NamingStandardsTemplate Members


%%PageItemTitle%% $$Members$$

NamingStandardsTemplate Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this naming standards template.
Public Method BoundObjects | Returns a collection of bindings that link the naming standards template to objects.
Public Method RepoCheckOutStatus | Get the Check Out status of this NamingStandardsTemplate object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this naming standards template.

Public Properties

Public Property Description | This is the description of the naming standards template. DATATYPE: String.
Public Property DictionaryName | This is the name of the Dictionary this object is part of. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary this object is part of is enterprise level. DATATYPE: Boolean.
Public Property GUID | GUID of the NamingStandardTemplate. GUIDs are unique IDs assigned by ER Studio. DATATYPE: String.
Public Property ID | Returns the naming standards template ID. DATATYPE: Integer.
Public Property Name | This is the name of the naming standards template. DATATYPE: String.

See Also

NamingStandardsTemplate Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this naming standards template.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the naming standards template to objects.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this NamingStandardsTemplate object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this naming standards template.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

Description Property

Description

This is the description of the naming standards template. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary this object is part of. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary this object is part of is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

GUID Property

Description

GUID of the NamingStandardTemplate. GUIDs are unique IDs assigned by ER Studio. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

ID Property

Description

Returns the naming standards template ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

Name Property

Description

This is the name of the naming standards template. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

NamingStandardsTemplate Object


%%PageItemTitle%%

NamingStandardsTemplates Collection
See Also Members

Description

This object represents a collection of NamingStandardsTemplates. The owner of this collection is the data dictionary.

Object Model

See Also

NamingStandardsTemplates Members


%%PageItemTitle%% $$Members$$

NamingStandardsTemplates Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns new NamingStandardsTemplate, adds it to collection. PARAMETERS: Name, Description, Value, ValueDescription as Strings.
Public Method Remove | Deletes a naming standards template object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of naming standards template objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

NamingStandardsTemplates Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns new NamingStandardsTemplate, adds it to collection. PARAMETERS: Name, Description, Value, ValueDescription as Strings.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As NamingStandardsTemplate

Parameters

Name

See Also

NamingStandardsTemplates Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a naming standards template object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

NamingStandardsTemplates Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As NamingStandardsTemplate

Parameters

Identifier

See Also

NamingStandardsTemplates Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

NamingStandardsTemplates Collection


%%PageItemTitle%%

Count Property

Description

This is the number of naming standards template objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

NamingStandardsTemplates Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a NamingStandardsTemplate object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As NamingStandardsTemplate

Parameters

Identifier

See Also

NamingStandardsTemplates Collection


%%PageItemTitle%%

NetezzaSynonym Object
See Also Members

Description

This object represents a Netezza Synonym in ER/Studio. It is stored as its create statement.

Object Model

See Also

NetezzaSynonym Members


%%PageItemTitle%% $$Members$$

NetezzaSynonym Object Members
See Also Overview

Public Methods

Public Method BoundAttachments METHOD: BoundAttachments, DATATYPE: BoundAttachments, PARAMETER: None, DESCRIPTION: returns the BoundAttachments collection of this Object.

Public Properties

Public Property Description | PROPERTY: Description, DATATYPE: String, DESCRIPTION: This is the Description of the Netezza Synonym.
Public Property GUID | PROPERTY: GUID (Read Only), DATATYPE: String, DESCRIPTION: This is the GUID of the Netezza Synonym.
Public Property ID | PROPERTY: ID, DATATYPE: Integer, DESCRIPTION: Returns the Netezza Synonym id.
Public Property Name | PROPERTY: Name, DATATYPE: String, DESCRIPTION: This property represents the name of the Netezza Synonym.
Public Property Owner | PROPERTY: Owner, DATATYPE: String, DESCRIPTION: This property represents the owner of the Netezza Synonym.
Public Property ReferencedObjectName | PROPERTY: ReferencedObjectName, DATATYPE: String, DESCRIPTION: This property represents the name of the object referred to by the Netezza Synonym.
Public Property ReferencedObjectOwner | PROPERTY: ReferencedObjectOwner, DATATYPE: String, DESCRIPTION: This property represents the owner of the object referred to by the Netezza Synonym.

See Also

NetezzaSynonym Overview


%%PageItemTitle%%

BoundAttachments Method

Description

METHOD: BoundAttachments, DATATYPE: BoundAttachments, PARAMETER: None, DESCRIPTION: returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

NetezzaSynonym Object


%%PageItemTitle%%

Description Property

Description

PROPERTY: Description, DATATYPE: String, DESCRIPTION: This is the Description of the Netezza Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

GUID Property

Description

PROPERTY: GUID (Read Only), DATATYPE: String, DESCRIPTION: This is the GUID of the Netezza Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

ID Property

Description

PROPERTY: ID, DATATYPE: Integer, DESCRIPTION: Returns the Netezza Synonym id.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

Name Property

Description

PROPERTY: Name, DATATYPE: String, DESCRIPTION: This property represents the name of the Netezza Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

Owner Property

Description

PROPERTY: Owner, DATATYPE: String, DESCRIPTION: This property represents the owner of the Netezza Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

ReferencedObjectName Property

Description

PROPERTY: ReferencedObjectName, DATATYPE: String, DESCRIPTION: This property represents the name of the object referred to by the Netezza Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectName() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

ReferencedObjectOwner Property

Description

PROPERTY: ReferencedObjectOwner, DATATYPE: String, DESCRIPTION: This property represents the owner of the object referred to by the Netezza Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectOwner() As Variant

See Also

NetezzaSynonym Object


%%PageItemTitle%%

NetezzaSynonyms Collection
See Also Members

Description

This object represents a collection of Netezza Synonyms. The owner of this collection is the model.

Object Model

See Also

NetezzaSynonyms Members


%%PageItemTitle%% $$Members$$

NetezzaSynonyms Collection Members
See Also Overview

Public Methods

Public Method Add | METHOD: Add, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String), DESCRIPTION: Creates and returns a new Netezza Synonym, and adds it to the collection.
Public Method AddWithPosition | METHOD: AddWithPosition, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer), DESCRIPTION: Creates a Netezza Synonym.
Public Method Remove | METHOD: Remove, RETURN DATATYPE: None, PARAMETERS: Identifier as String or Integer, DESCRIPTION: Deletes a Netezza Synonym object (specified by the given name or Id) from the collection.

Public Properties

Public Property _Item | METHOD: Item, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: Identifier as String or Integer, DESCRIPTION: Returns a Netezza Synonym object (specified by the given name, GUID, or Id).
Public Property _NewEnum |
Public Property Count | PROPERTY: Count (Read Only), DATATYPE: Integer, DESCRIPTION: This is the number of Synonyms in the collection.
Public Property Item | METHOD: Item, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: Identifier as String or Integer, DESCRIPTION: Returns a Netezza Synonym object (specified by the given name, GUID, or Id).

See Also

NetezzaSynonyms Overview


%%PageItemTitle%%

Add Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner

Description

METHOD: Add, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String), DESCRIPTION: Creates and returns a new Netezza Synonym, and adds it to the collection.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant _
) As NetezzaSynonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

Description

METHOD: AddWithPosition, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer), DESCRIPTION: Creates a Netezza Synonym.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As NetezzaSynonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

METHOD: Remove, RETURN DATATYPE: None, PARAMETERS: Identifier as String or Integer, DESCRIPTION: Deletes a Netezza Synonym object (specified by the given name or Id) from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

METHOD: Item, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: Identifier as String or Integer, DESCRIPTION: Returns a Netezza Synonym object (specified by the given name, GUID, or Id).

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As NetezzaSynonym

Parameters

Identifier

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

Count Property

Description

PROPERTY: Count (Read Only), DATATYPE: Integer, DESCRIPTION: This is the number of Synonyms in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

Item Property
Identifier

Description

METHOD: Item, RETURN DATATYPE: NetezzaSynonym, PARAMETERS: Identifier as String or Integer, DESCRIPTION: Returns a Netezza Synonym object (specified by the given name, GUID, or Id).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As NetezzaSynonym

Parameters

Identifier

See Also

NetezzaSynonyms Collection


%%PageItemTitle%%

ObjectPermission Object
See Also Members

Description

This represents an ObjectPermission in ER/Studio.

See Also

ObjectPermission Members


%%PageItemTitle%% $$Members$$

ObjectPermission Object Members
See Also Overview

Public Methods

Public Method ChangeGrantee Change the grantee of the ObjectPermission given the new GranteeType (0=DBUSer or 1=DBRole) and GranteeID. PARAMETERS: GranteeType as Integer, GranteeId as Integer.

Public Properties

Public Property ActionType | This is the ActionType of the ObjectPermission. 'G' means GRANT and 'R' means Revoke. DATATYPE: String.
Public Property AttributeID | AttributeID of the ObjectPermission if it was Granted to an Attribute. DATATYPE: Integer.
Public Property GranteeID | GranteeId is the ID of the DBUser or DBRole of this ObjectPermission. DATATYPE: Integer.
Public Property GranteeName | This is the name of the DBUser or DBRole of this ObjectPermission. DATATYPE: String.
Public Property GranteeType | GranteeType of the ObjectPermission where 0 = DBUser and 1 = DBRole. DATATYPE: Integer.
Public Property GUID | ObjectPermission's object GUID. The GUID (assigned by ER/Studio) is unique. DATATYPE: String.
Public Property ID | ObjectPermission ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding ObjectPermission. DATATYPE: Integer.
Public Property IsActionExtended | This indicates the permission ActionExtended value. DATATYPE: Boolean.
Public Property IsSystem | This indicates whether this permission is a System Permission or not. DATATYPE: Boolean.
Public Property PermissionType | This is the PermissionType of the ObjectPermission. DATATYPE: String.

See Also

ObjectPermission Overview


%%PageItemTitle%%

ChangeGrantee Method
GranteeType
GranteeID

Description

Change the grantee of the ObjectPermission given the new GranteeType (0=DBUSer or 1=DBRole) and GranteeID. PARAMETERS: GranteeType as Integer, GranteeId as Integer.

Syntax

Visual Basic
Public Sub ChangeGrantee( _
   ByVal GranteeType As Variant, _
   ByVal GranteeID As Variant _
)

Parameters

GranteeType
GranteeID

See Also

ObjectPermission Object


%%PageItemTitle%%

ActionType Property

Description

This is the ActionType of the ObjectPermission. 'G' means GRANT and 'R' means Revoke. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionType() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

AttributeID Property

Description

AttributeID of the ObjectPermission if it was Granted to an Attribute. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttributeID() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

GranteeID Property

Description

GranteeId is the ID of the DBUser or DBRole of this ObjectPermission. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GranteeID() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

GranteeName Property

Description

This is the name of the DBUser or DBRole of this ObjectPermission. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GranteeName() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

GranteeType Property

Description

GranteeType of the ObjectPermission where 0 = DBUser and 1 = DBRole. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GranteeType() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

GUID Property

Description

ObjectPermission's object GUID. The GUID (assigned by ER/Studio) is unique. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

ID Property

Description

ObjectPermission ID of the object. This ID is assigned by ER/Studio and can be used to obtain the corresponding ObjectPermission. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

IsActionExtended Property

Description

This indicates the permission ActionExtended value. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsActionExtended() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

IsSystem Property

Description

This indicates whether this permission is a System Permission or not. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSystem() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

PermissionType Property

Description

This is the PermissionType of the ObjectPermission. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PermissionType() As Variant

See Also

ObjectPermission Object


%%PageItemTitle%%

ObjectPermissions Collection
See Also Members

Description

This represents a collection of ObjectPermissions. The owner of the collection can be an Entity, View, Procedure, Package, Materialized View, and Sequence.

Object Model

See Also

ObjectPermissions Members


%%PageItemTitle%% $$Members$$

ObjectPermissions Collection Members
See Also Overview

Public Methods

Public Method Add | Creates an ObjectPermission.) PARAMETERS: GranteeType(DBUser=0, DBRole=1), Grantee(String/integer), ActionType('G'=GRANT, 'R'=Revoke), PermissionType(String), AttributeId(integer).
Public Method Remove | Deletes an ObjectPermission object specified by the given ID from ER/Studio. PARAMETERS: Identifier as Integer.

Public Properties

Public Property _Item | This method returns an ObjectPermission specified by the given ID or GUID. PARAMETERS: Identifier as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ObjectPermission objects in the collection. DATATYPE: Integer.
Public Property Item | This method returns an ObjectPermission specified by the given ID or GUID. PARAMETERS: Identifier as Integer.

See Also

ObjectPermissions Overview


%%PageItemTitle%%

Add Method
GranteeType
Grantee
ActionType
PermissionType
AttributeID

Description

Creates an ObjectPermission.) PARAMETERS: GranteeType(DBUser=0, DBRole=1), Grantee(String/integer), ActionType('G'=GRANT, 'R'=Revoke), PermissionType(String), AttributeId(integer).

Syntax

Visual Basic
Public Function Add( _
   ByVal GranteeType As Variant, _
   ByVal Grantee As Variant, _
   ByVal ActionType As Variant, _
   ByVal PermissionType As Variant, _
   ByVal AttributeID As Variant _
) As ObjectPermission

Parameters

GranteeType
Grantee
ActionType
PermissionType
AttributeID

See Also

ObjectPermissions Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an ObjectPermission object specified by the given ID from ER/Studio. PARAMETERS: Identifier as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ObjectPermissions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

This method returns an ObjectPermission specified by the given ID or GUID. PARAMETERS: Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ObjectPermission

Parameters

Identifier

See Also

ObjectPermissions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ObjectPermissions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ObjectPermission objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ObjectPermissions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

This method returns an ObjectPermission specified by the given ID or GUID. PARAMETERS: Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ObjectPermission

Parameters

Identifier

See Also

ObjectPermissions Collection


%%PageItemTitle%%

ObjectType Object
See Also Members

Description

This object represents an Object Type in ER/Studio.

Object Model

See Also

ObjectType Members


%%PageItemTitle%% $$Members$$

ObjectType Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Object Type.
Public Method UserComments | Returns a collection of the user comments associated with this Object Type.

Public Properties

Public Property Body | This is the Body of the Object Type. DATATYPE: String.
Public Property Description | This is the description of the Object Type. DATATYPE: String.
Public Property GUID | GUID of the Object Type. This GUID is assigned by ER/Studio. Each Object Type has a unique GUID. DATATYPE: String.
Public Property Header | This is the Header of the Object Type. DATATYPE: String.
Public Property ID | ID of the Object Type. This ID is assigned by ER/Studio. Each Object Type in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the Object Type. DATATYPE: String.
Public Property Owner | This is the Owner of the Object Type. DATATYPE: String.

See Also

ObjectType Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Object Type.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

ObjectType Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of the user comments associated with this Object Type.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

ObjectType Object


%%PageItemTitle%%

Body Property

Description

This is the Body of the Object Type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Body() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

Description Property

Description

This is the description of the Object Type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

GUID Property

Description

GUID of the Object Type. This GUID is assigned by ER/Studio. Each Object Type has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

Header Property

Description

This is the Header of the Object Type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Header() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

ID Property

Description

ID of the Object Type. This ID is assigned by ER/Studio. Each Object Type in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Object Type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

Owner Property

Description

This is the Owner of the Object Type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

ObjectType Object


%%PageItemTitle%%

ObjectTypes Collection
See Also Members

Description

This object represents a collection of Object Types. The owner of this collection is the model.

Object Model

See Also

ObjectTypes Members


%%PageItemTitle%% $$Members$$

ObjectTypes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates an Object Type with the given name and header. PARAMETERS: Name as String, Header as String.
Public Method AddWithPosition | Creates an Object Type with the given name and header and coordinates. PARAMETERS: Name as String, Header as String, HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Deletes an Object Type object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns an Object Type object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Object Type objects in the collection. DATATYPE: Integer.
Public Property Item | Returns an Object Type object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

ObjectTypes Overview


%%PageItemTitle%%

Add Method
Name
Header

Description

Creates an Object Type with the given name and header. PARAMETERS: Name as String, Header as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Header As Variant _
) As ObjectType

Parameters

Name
Header

See Also

ObjectTypes Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Header
HorizontalPosition
VerticalPosition

Description

Creates an Object Type with the given name and header and coordinates. PARAMETERS: Name as String, Header as String, HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Header As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As ObjectType

Parameters

Name
Header
HorizontalPosition
VerticalPosition

See Also

ObjectTypes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Object Type object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ObjectTypes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns an Object Type object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ObjectType

Parameters

Identifier

See Also

ObjectTypes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ObjectTypes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Object Type objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ObjectTypes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns an Object Type object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ObjectType

Parameters

Identifier

See Also

ObjectTypes Collection


%%PageItemTitle%%

OracleDatafile Object
See Also Members

Description

This object represents an Oracle Datafile in ER/Studio.

See Also

OracleDatafile Members


%%PageItemTitle%% $$Members$$

OracleDatafile Object Members
See Also Overview

Public Properties

Public Property AutoExtend | This property enables (true) or disables (false) the automatic extension of the Datafile. DATATYPE: Boolean.
Public Property FileSize | This property represents the file size of the datafile. The size is specified in Mega Bytes. DATATYPE: Integer.
Public Property MaxExtentSize | This property specifies the maximum extent size allowed for a datafile. Must be positive integer or UNLIMITED. DATATYPE: String.
Public Property Name | This property represents the name of the Datafile. DATATYPE: String.
Public Property NextExtSize | This property represents the size of the next or secondary extent for the Datafile in kilo bytes. DATATYPE: Integer.
Public Property Reuse | This property specifies the Reuse status of the Datafile. If true, Oracle is allowed to resue an existing file. DATATYPE: Boolean.

See Also

OracleDatafile Overview


%%PageItemTitle%%

AutoExtend Property

Description

This property enables (true) or disables (false) the automatic extension of the Datafile. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoExtend() As Variant

See Also

OracleDatafile Object


%%PageItemTitle%%

FileSize Property

Description

This property represents the file size of the datafile. The size is specified in Mega Bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileSize() As Variant

See Also

OracleDatafile Object


%%PageItemTitle%%

MaxExtentSize Property

Description

This property specifies the maximum extent size allowed for a datafile. Must be positive integer or UNLIMITED. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtentSize() As Variant

See Also

OracleDatafile Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Datafile. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleDatafile Object


%%PageItemTitle%%

NextExtSize Property

Description

This property represents the size of the next or secondary extent for the Datafile in kilo bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtSize() As Variant

See Also

OracleDatafile Object


%%PageItemTitle%%

Reuse Property

Description

This property specifies the Reuse status of the Datafile. If true, Oracle is allowed to resue an existing file. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Reuse() As Variant

See Also

OracleDatafile Object


%%PageItemTitle%%

OracleDatafiles Collection
See Also Members

Description

This object represents a collection of Datafiles. The owner of this collection is the Oracle Tablespace.

Object Model

See Also

OracleDatafiles Members


%%PageItemTitle%% $$Members$$

OracleDatafiles Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Datafile within the given Tablespace and adds it to the collection. PARAMETERS: Name (String) RETURN DATATYPE: Datafile .
Public Method Remove | Deletes a Tablespace object (specified by the given name) from the collection. PARAMETERS: Name as String.

Public Properties

Public Property _Item | Returns a Datafile object (specified by the given name). PARAMETERS: Name as String RETURN DATATYPE: Datafile.
Public Property _NewEnum |
Public Property Count | This is the number of Datafiles in the collection (the given tablespace). DATATYPE: Integer.
Public Property Item | Returns a Tablespace object (specified by the given name). PARAMETERS: Name as String, RETURN DATATYPE: Tablespace.

See Also

OracleDatafiles Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns a new Datafile within the given Tablespace and adds it to the collection. PARAMETERS: Name (String) RETURN DATATYPE: Datafile .

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As OracleDatafile

Parameters

Name

See Also

OracleDatafiles Collection


%%PageItemTitle%%

Remove Method
Name

Description

Deletes a Tablespace object (specified by the given name) from the collection. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleDatafiles Collection


%%PageItemTitle%%

_Item Property
Name

Description

Returns a Datafile object (specified by the given name). PARAMETERS: Name as String RETURN DATATYPE: Datafile.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Name As Variant _
) As OracleDatafile

Parameters

Name

See Also

OracleDatafiles Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleDatafiles Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Datafiles in the collection (the given tablespace). DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleDatafiles Collection


%%PageItemTitle%%

Item Property
Name

Description

Returns a Tablespace object (specified by the given name). PARAMETERS: Name as String, RETURN DATATYPE: Tablespace.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Name As Variant _
) As OracleDatafile

Parameters

Name

See Also

OracleDatafiles Collection


%%PageItemTitle%%

OracleIndexPartition Object
See Also Members

Description

This object represents a OracleIndexPartition in ER/Studio.

See Also

OracleIndexPartition Members


%%PageItemTitle%% $$Members$$

OracleIndexPartition Object Members
See Also Overview

Public Properties

Public Property BufferPool | This is the Buffer Pool property of the Partition. DATATYPE: String. Input should be a string containing NONE, DEFAULT, KEEP or RECYCLE. Not for HASH partitions.
Public Property FreeListGroups | This is the Free List Groups property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property FreeLists | This is the Free Lists property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property GUID | This is the GUID of the Partition. DATATYPE: String.
Public Property HighValues | For type RANGE the are the HighValues of the Partition. For type LIST this is the List of Values of the Partition. DATATYPE: String.
Public Property ID | This is the ID of the Partition. DATATYPE: Integer.
Public Property InitExtent | This is the Initial Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property InitTrans | This is the Initial Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property MaxExtents | This is the Max Extents property of the Partition. Input should be a string containing non-negative integer or UNLIMITED. Not for HASH partitions. DATATYPE: String.
Public Property MaxTrans | This is the Max Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property MinExtents | This is the Min Extents property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property Name | This is the Name of the Partition. DATATYPE: String.
Public Property NextExtent | This is the Next Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property NoLogging | This indicates whether the operation will be logged in the redo file. Not for HASH partitions. DATATYPE: Boolean.
Public Property Number | This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL. DATATYPE: Integer.
Public Property PctFree | This is the PctFree property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property PctIncrease | This is the Percent Increase property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property Tablespace | This is the Tablespace of the Partition. DATATYPE: String.

See Also

OracleIndexPartition Overview


%%PageItemTitle%%

BufferPool Property

Description

This is the Buffer Pool property of the Partition. DATATYPE: String. Input should be a string containing NONE, DEFAULT, KEEP or RECYCLE. Not for HASH partitions.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferPool() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

FreeListGroups Property

Description

This is the Free List Groups property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeListGroups() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

FreeLists Property

Description

This is the Free Lists property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeLists() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Partition. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

HighValues Property

Description

For type RANGE the are the HighValues of the Partition. For type LIST this is the List of Values of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighValues() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the Partition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

InitExtent Property

Description

This is the Initial Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitExtent() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

InitTrans Property

Description

This is the Initial Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitTrans() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

MaxExtents Property

Description

This is the Max Extents property of the Partition. Input should be a string containing non-negative integer or UNLIMITED. Not for HASH partitions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtents() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

MaxTrans Property

Description

This is the Max Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxTrans() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

MinExtents Property

Description

This is the Min Extents property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtents() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

Name Property

Description

This is the Name of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

NextExtent Property

Description

This is the Next Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtent() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

NoLogging Property

Description

This indicates whether the operation will be logged in the redo file. Not for HASH partitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoLogging() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

PctFree Property

Description

This is the PctFree property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctFree() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

PctIncrease Property

Description

This is the Percent Increase property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctIncrease() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

Tablespace Property

Description

This is the Tablespace of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

OracleIndexPartition Object


%%PageItemTitle%%

OracleIndexPartitions Collection
See Also Members

Description

This object represents a collection of OracleIndexPartition objects. The owner of this collection is Index.

Object Model

See Also

OracleIndexPartitions Members


%%PageItemTitle%% $$Members$$

OracleIndexPartitions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new OracleIndexPartition object. PARAMETERS: HighValues as String.
Public Method AddColumnToPartitionKey | Use to add another column to the partition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.
Public Method DeleteColumnFromPartitionKey | Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.
Public Method DeletePartitionKey | Use this method to delete all columns in the partition key. This also deletes all partitions and all subpartitions and the subpartition key.
Public Method GetPartitionColumnNumber | Looks for the column in the partition key. If it finds it, it returns the column's number. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: Integer.
Public Method Remove | Remove a OracleIndexPartition specified by the given Number. PARAMETERS: Number as Integer.
Public Method RemoveByName | Remove the OracleIndexPartition specified by the given Name. PARAMETERS: Name as String.
Public Method SetPartitionColumnNumber | Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer.

Public Properties

Public Property _Item | Returns a OracleIndexPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of OracleIndexPartition objects in the collection. DATATYPE: Integer.
Public Property GetPartitionKeyColumns | This is the names of the columns in hte PartitionKey as a comma separated list in sequence order. DATATYPE: String.
Public Property HashPartitionCount | This specifies the number of hash partitions when the index is partitioned by quantity. DATATYPE: Integer.
Public Property HashPartitionTablespaces | This specifies the tablespaces the index hash partitions should be stored. DATATYPE: String.
Public Property IsGlobal | This property determines whether the indexes scope is global or local. DATATYPE: Boolean.
Public Property Item | Returns a OracleIndexPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.
Public Property PartitionType | This specifies what type of index partition is used to partition the index for Oracle 10 and later versions. DATATYPE: String.

See Also

OracleIndexPartitions Overview


%%PageItemTitle%%

Add Method
HighValues

Description

Add a new OracleIndexPartition object. PARAMETERS: HighValues as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal HighValues As Variant _
) As OracleIndexPartition

Parameters

HighValues

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

AddColumnToPartitionKey Method
Name

Description

Use to add another column to the partition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub AddColumnToPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

DeleteColumnFromPartitionKey Method
Name

Description

Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub DeleteColumnFromPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

DeletePartitionKey Method

Description

Use this method to delete all columns in the partition key. This also deletes all partitions and all subpartitions and the subpartition key.

Syntax

Visual Basic
Public Sub DeletePartitionKey()

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

GetPartitionColumnNumber Method
Name

Description

Looks for the column in the partition key. If it finds it, it returns the column's number. PARAMETERS: Name of the partition column as String. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetPartitionColumnNumber( _
   ByVal Name As Variant _
) As Long

Parameters

Name

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Remove a OracleIndexPartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

RemoveByName Method
Name

Description

Remove the OracleIndexPartition specified by the given Name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub RemoveByName( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

SetPartitionColumnNumber Method
Name
Number

Description

Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer.

Syntax

Visual Basic
Public Sub SetPartitionColumnNumber( _
   ByVal Name As Variant, _
   ByVal Number As Variant _
)

Parameters

Name
Number

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a OracleIndexPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleIndexPartition

Parameters

Identifier

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of OracleIndexPartition objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

GetPartitionKeyColumns Property

Description

This is the names of the columns in hte PartitionKey as a comma separated list in sequence order. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetPartitionKeyColumns() As Variant

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

HashPartitionCount Property

Description

This specifies the number of hash partitions when the index is partitioned by quantity. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HashPartitionCount() As Variant

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

HashPartitionTablespaces Property

Description

This specifies the tablespaces the index hash partitions should be stored. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HashPartitionTablespaces() As Variant

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

IsGlobal Property

Description

This property determines whether the indexes scope is global or local. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsGlobal() As Variant

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a OracleIndexPartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleIndexPartition

Parameters

Identifier

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

PartitionType Property

Description

This specifies what type of index partition is used to partition the index for Oracle 10 and later versions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PartitionType() As Variant

See Also

OracleIndexPartitions Collection


%%PageItemTitle%%

OracleMaterializedView Object
See Also Members

Description

This object represents an Oracle Materialized View in ER/Studio. It is stored as its create statement.

Object Model

See Also

OracleMaterializedView Members


%%PageItemTitle%% $$Members$$

OracleMaterializedView Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns a collection of user comments associated with this Object.

Public Properties

Public Property CachedData | This property represents whether or not the Oracle Materialized View uses cached data. DATATYPE: Boolean.
Public Property Compress | This is the Compress property of the Oracle Materialized View. DATATYPE: Boolean.
Public Property Description | This is the Description of the Oracle Materialized View. DATATYPE: String.
Public Property FillImmediate | This property represents whether or not the Oracle Materialized View is be filled immediately. DATATYPE: Boolean.
Public Property FirstRefresh | This property represents the time of the first refresh of the Oracle Materialized View. DATATYPE: String. Must be in the form "dd-Mon-YYYY HH:MM PP" where the time is in 12 hour format and P is either AM or PM.
Public Property GenPostSQL | This is the Generate PostSQL of the Oracle Materialized View. DATATYPE: Boolean.
Public Property GenPretSQL | This is the Generate PretSQL of the Oracle Materialized View. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the Oracle Materialized Query. DATATYPE: String.
Public Property ID | Returns the Oracle Materialized View ID. DATATYPE: Integer.
Public Property InitialExtent | This property represents the initial extent of the Oracle Materialized View. DATATYPE: Integer.
Public Property InitialTransactions | This property represents the initial transactions of the Oracle Materialized View. DATATYPE: Integer.
Public Property LocalRollbackSegment | This property represents the local rollback segment used by the Oracle Materialized View. DATATYPE: String.
Public Property LogUpdates | This property represents whether or not the Oracle Materialized View logs updates. DATATYPE: Boolean.
Public Property MasterRollbackSegment | This property represents the master rollback segment used by the Oracle Materialized View. DATATYPE: String.
Public Property MaxExtents | This property represents the maximum extents of the Oracle Materialized View. DATATYPE: Integer.
Public Property MaxTransactions | This property represents the maximum transactions of the Oracle Materialized View. DATATYPE: Integer.
Public Property MinExtents | This property represents the minimum extents of the Oracle Materialized View. DATATYPE: Integer.
Public Property Name | This property represents the name of the Oracle Materialized View. DATATYPE: String.
Public Property NextExtent | This property represents the next extent of the Oracle Materialized View. DATATYPE: Integer.
Public Property OnPrebuiltTable | This property represents whether or not the Oracle Materialized View is built on an existing table. DATATYPE: Boolean.
Public Property Owner | This property represents the owner of the Oracle Materialized View. DATATYPE: String.
Public Property ParallelDegree | This property represents the parallel degree of the Oracle Materialized View. DATATYPE: Integer.
Public Property PercentFree | This property represents the percent free of the Oracle Materialized View. DATATYPE: Integer.
Public Property PercentIncrease | This property represents the percent increase of the Oracle Materialized View. DATATYPE: Integer.
Public Property PercentUsed | This property represents the percent used of the Oracle Materialized View. DATATYPE: Integer.
Public Property PostSQL | This is the PostSQL of the Oracle Materialized View. DATATYPE: String.
Public Property PreSQL | This is the PreSQL of the Oracle Materialized View. DATATYPE: String.
Public Property Query | This property represents the SQL query used to generate the data in the Oracle Materialized View. DATATYPE: String.
Public Property QueryRewrite | This property represents whether or not the Oracle Materialized View uses query rewrite. DATATYPE: Boolean.
Public Property RefreshInterval | This property represents the refresh interval used by the Oracle Materialized View. DATATYPE: Integer.
Public Property RefreshIntervalUnit | This property represents the unit of the refresh interval used by the Oracle Materialized View. DATATYPE: String. Can be "DAYS", "HOURS", "MINUTES" or "SECONDS".
Public Property RefreshMechanism | This property represents the refresh mechanism used by the Oracle Materialized View. DATATYPE: String. Can be "ON COMMIT", "ON DEMAND" or "AUTOMATICALLY".
Public Property RefreshMethod | This property represents the refresh method used by the Oracle Materialized View. DATATYPE: String. Can be "ROWID" or "PK".
Public Property RefreshType | This property represents the type of refresh done by the Oracle Materialized View. DATATYPE: String. Can be "FAST", "COMPLETE", "FORCE" or "NEVER".
Public Property Tablespace | This property represents the tablespace where the Oracle Materialized View is located. DATATYPE: String.
Public Property Updatable | This property represents whether or not the Oracle Materialized View is updatable. DATATYPE: Boolean.

See Also

OracleMaterializedView Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

OracleMaterializedView Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

OracleMaterializedView Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

OracleMaterializedView Object


%%PageItemTitle%%

CachedData Property

Description

This property represents whether or not the Oracle Materialized View uses cached data. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property CachedData() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Compress Property

Description

This is the Compress property of the Oracle Materialized View. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Compress() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

FillImmediate Property

Description

This property represents whether or not the Oracle Materialized View is be filled immediately. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property FillImmediate() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

FirstRefresh Property

Description

This property represents the time of the first refresh of the Oracle Materialized View. DATATYPE: String. Must be in the form "dd-Mon-YYYY HH:MM PP" where the time is in 12 hour format and P is either AM or PM.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstRefresh() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

GenPostSQL Property

Description

This is the Generate PostSQL of the Oracle Materialized View. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

GenPretSQL Property

Description

This is the Generate PretSQL of the Oracle Materialized View. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPretSQL() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Oracle Materialized Query. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

ID Property

Description

Returns the Oracle Materialized View ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

InitialExtent Property

Description

This property represents the initial extent of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitialExtent() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

InitialTransactions Property

Description

This property represents the initial transactions of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitialTransactions() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

LocalRollbackSegment Property

Description

This property represents the local rollback segment used by the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property LocalRollbackSegment() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

LogUpdates Property

Description

This property represents whether or not the Oracle Materialized View logs updates. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogUpdates() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

MasterRollbackSegment Property

Description

This property represents the master rollback segment used by the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MasterRollbackSegment() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

MaxExtents Property

Description

This property represents the maximum extents of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtents() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

MaxTransactions Property

Description

This property represents the maximum transactions of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxTransactions() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

MinExtents Property

Description

This property represents the minimum extents of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtents() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

NextExtent Property

Description

This property represents the next extent of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtent() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

OnPrebuiltTable Property

Description

This property represents whether or not the Oracle Materialized View is built on an existing table. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property OnPrebuiltTable() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

ParallelDegree Property

Description

This property represents the parallel degree of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ParallelDegree() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

PercentFree Property

Description

This property represents the percent free of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentFree() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

PercentIncrease Property

Description

This property represents the percent increase of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentIncrease() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

PercentUsed Property

Description

This property represents the percent used of the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PercentUsed() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

PostSQL Property

Description

This is the PostSQL of the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

PreSQL Property

Description

This is the PreSQL of the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Query Property

Description

This property represents the SQL query used to generate the data in the Oracle Materialized View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Query() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

QueryRewrite Property

Description

This property represents whether or not the Oracle Materialized View uses query rewrite. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property QueryRewrite() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

RefreshInterval Property

Description

This property represents the refresh interval used by the Oracle Materialized View. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property RefreshInterval() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

RefreshIntervalUnit Property

Description

This property represents the unit of the refresh interval used by the Oracle Materialized View. DATATYPE: String. Can be "DAYS", "HOURS", "MINUTES" or "SECONDS".

Property type

Read-write property

Syntax

Visual Basic
Public Property RefreshIntervalUnit() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

RefreshMechanism Property

Description

This property represents the refresh mechanism used by the Oracle Materialized View. DATATYPE: String. Can be "ON COMMIT", "ON DEMAND" or "AUTOMATICALLY".

Property type

Read-write property

Syntax

Visual Basic
Public Property RefreshMechanism() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

RefreshMethod Property

Description

This property represents the refresh method used by the Oracle Materialized View. DATATYPE: String. Can be "ROWID" or "PK".

Property type

Read-write property

Syntax

Visual Basic
Public Property RefreshMethod() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

RefreshType Property

Description

This property represents the type of refresh done by the Oracle Materialized View. DATATYPE: String. Can be "FAST", "COMPLETE", "FORCE" or "NEVER".

Property type

Read-write property

Syntax

Visual Basic
Public Property RefreshType() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Tablespace Property

Description

This property represents the tablespace where the Oracle Materialized View is located. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

Updatable Property

Description

This property represents whether or not the Oracle Materialized View is updatable. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Updatable() As Variant

See Also

OracleMaterializedView Object


%%PageItemTitle%%

OracleMaterializedViews Collection
See Also Members

Description

This object represents a collection of Oracle materialized views. The owner of this collection is the model.

Object Model

See Also

OracleMaterializedViews Members


%%PageItemTitle%% $$Members$$

OracleMaterializedViews Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Oracle Materialized View, and adds it to the collection. PARAMETERS: Name (String), Owner (String), Query (String).
Public Method AddWithPosition | Creates a new Oracle Materialized View. PARAMETERS: Name (String), Owner (String), Query (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an Oracle Materialized View object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Oracle Materialized View object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of materialized views in the collection. DATATYPE: Integer.
Public Property Item | Returns a Oracle Materialized View object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

OracleMaterializedViews Overview


%%PageItemTitle%%

Add Method
Name
Owner
Query

Description

Creates and returns a new Oracle Materialized View, and adds it to the collection. PARAMETERS: Name (String), Owner (String), Query (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal Query As Variant _
) As OracleMaterializedView

Parameters

Name
Owner
Query

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
Query
HorizontalPosition
VerticalPosition

Description

Creates a new Oracle Materialized View. PARAMETERS: Name (String), Owner (String), Query (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal Query As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As OracleMaterializedView

Parameters

Name
Owner
Query
HorizontalPosition
VerticalPosition

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Oracle Materialized View object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Oracle Materialized View object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleMaterializedView

Parameters

Identifier

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

Count Property

Description

This is the number of materialized views in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Oracle Materialized View object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleMaterializedView

Parameters

Identifier

See Also

OracleMaterializedViews Collection


%%PageItemTitle%%

OracleRollbackSegment Object
See Also Members

Description

This object represents an Oracle rollback segment in ER/Studio. It is stored as its create statement.

Object Model

See Also

OracleRollbackSegment Members


%%PageItemTitle%% $$Members$$

OracleRollbackSegment Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns a collection of user comments associated wit this Object.

Public Properties

Public Property Description | This is the Description of the rollback segment. DATATYPE: String.
Public Property GUID | This is the GUID of the rollback segment. DATATYPE: String.
Public Property ID | Returns the rollback segment ID. DATATYPE: Integer.
Public Property InitExtSize | This property represents the size of the initial extent for the rollback segment in kilo bytes. DATATYPE: Integer.
Public Property IsPublic | This property holds true if the public keyword is specified in the CREATE ROLLBACK SEGMENT clause for this rollback segment and false otherwise. DATATYPE: Boolean.
Public Property MaxExtents | This property specifies the maximum number of extents allowed in a segment. Must be positive integer or UNLIMITED. DATATYPE: String.
Public Property MinExtents | This property specifies the minimum number of extents allowed in a segment. DATATYPE: Integer.
Public Property Name | This property represents the name of the rollback segment. DATATYPE: String.
Public Property NextExtSize | This property represents the size of the next or secondary extent for the rollback segment in kilo bytes. DATATYPE: Integer.
Public Property OptimalSize | This property specifies the optimal size for a rollback segement in Kilo Bytes. Must be positive integer or NULL. DATATYPE: String.
Public Property Tablespace | This property specifies the name of the tablespace that this rollback segment is defined in. DATATYPE: String.

See Also

OracleRollbackSegment Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated wit this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the rollback segment. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the rollback segment. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

ID Property

Description

Returns the rollback segment ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

InitExtSize Property

Description

This property represents the size of the initial extent for the rollback segment in kilo bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitExtSize() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

IsPublic Property

Description

This property holds true if the public keyword is specified in the CREATE ROLLBACK SEGMENT clause for this rollback segment and false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsPublic() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

MaxExtents Property

Description

This property specifies the maximum number of extents allowed in a segment. Must be positive integer or UNLIMITED. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtents() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

MinExtents Property

Description

This property specifies the minimum number of extents allowed in a segment. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtents() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the rollback segment. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

NextExtSize Property

Description

This property represents the size of the next or secondary extent for the rollback segment in kilo bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtSize() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

OptimalSize Property

Description

This property specifies the optimal size for a rollback segement in Kilo Bytes. Must be positive integer or NULL. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property OptimalSize() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

Tablespace Property

Description

This property specifies the name of the tablespace that this rollback segment is defined in. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

OracleRollbackSegment Object


%%PageItemTitle%%

OracleRollbackSegments Collection
See Also Members

Description

This object represents a collection of Oracle rollback segments. The owner of this collection is the model.

Object Model

See Also

OracleRollbackSegments Members


%%PageItemTitle%% $$Members$$

OracleRollbackSegments Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new RollbackSegment, and adds it to the collection. PARAMETERS: Name (String), IsPublic (Boolean), and TableSpace (String), RETURN DATATYPE: RollbackSegment.
Public Method AddWithPosition | Creates a new RollbackSegment with given coordinates. PARAMETERS: Name (String), IsPublic (Boolean), TableSpace (String), HorizontalPosition (Integer), VerticalPosition (Integer) RETURN DATATYPE: RollbackSegment.
Public Method Remove | Deletes a rollback segment object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Rollback Segment object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer RETURN DATATYPE: RollbackSegment.
Public Property _NewEnum |
Public Property Count | This is the number of rollback segments in the collection. DATATYPE: Integer.
Public Property Item | Returns a Rollback Segment object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer, RETURN DATATYPE: RollbackSegment.

See Also

OracleRollbackSegments Overview


%%PageItemTitle%%

Add Method
Name
IsPublic
Tablespace

Description

Creates and returns a new RollbackSegment, and adds it to the collection. PARAMETERS: Name (String), IsPublic (Boolean), and TableSpace (String), RETURN DATATYPE: RollbackSegment.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal IsPublic As Variant, _
   ByVal Tablespace As Variant _
) As OracleRollbackSegment

Parameters

Name
IsPublic
Tablespace

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

AddWithPosition Method
Name
IsPublic
Tablespace
HorizontalPosition
VerticalPosition

Description

Creates a new RollbackSegment with given coordinates. PARAMETERS: Name (String), IsPublic (Boolean), TableSpace (String), HorizontalPosition (Integer), VerticalPosition (Integer) RETURN DATATYPE: RollbackSegment.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal IsPublic As Variant, _
   ByVal Tablespace As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As OracleRollbackSegment

Parameters

Name
IsPublic
Tablespace
HorizontalPosition
VerticalPosition

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a rollback segment object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Rollback Segment object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer RETURN DATATYPE: RollbackSegment.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleRollbackSegment

Parameters

Identifier

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

Count Property

Description

This is the number of rollback segments in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Rollback Segment object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer, RETURN DATATYPE: RollbackSegment.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleRollbackSegment

Parameters

Identifier

See Also

OracleRollbackSegments Collection


%%PageItemTitle%%

OracleSequence Object
See Also Members

Description

This object represents an Oracle sequence in ER/Studio. It is stored as its create statement.

Object Model

See Also

OracleSequence Members


%%PageItemTitle%% $$Members$$

OracleSequence Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns a collection of user comments associated with this Object.

Public Properties

Public Property CacheSize | This property specifies the the size of the cache used for the Oracle Sequence. DATATYPE: Integer.
Public Property Cycle | This property holds true if the Oracle Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.
Public Property Description | This is the Description of the Oracle Sequence. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the Oracle Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the Oracle Sequence. DATATYPE: Boolean.
Public Property GuaranteeOrder | This property holds true if the Oracle Sequence ordering should be guaranteed, false otherwise. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the Oracle Sequence. DATATYPE: String.
Public Property ID | Returns the Oracle Sequence ID. DATATYPE: Integer.
Public Property IncrementBy | This property represents the value by which the Oracle Sequence will be implemented each time a new number is requested. DATATYPE: String.
Public Property MaxValue | This property represents the maximum Oracle Sequence value. DATATYPE: String.
Public Property MinValue | This property represents the minimum Oracle Sequence value. DATATYPE: String.
Public Property Name | This property represents the name of the Oracle Sequence. DATATYPE: String.
Public Property Owner | This property represents the owner of the Oracle Sequence. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the Oracle Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the Oracle Sequence. DATATYPE: String.
Public Property StartWith | This property represents the value that the Oracle Sequence will start with. DATATYPE: String.

See Also

OracleSequence Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

OracleSequence Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

OracleSequence Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

OracleSequence Object


%%PageItemTitle%%

CacheSize Property

Description

This property specifies the the size of the cache used for the Oracle Sequence. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CacheSize() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

Cycle Property

Description

This property holds true if the Oracle Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cycle() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Oracle Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the Oracle Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the Oracle Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

GuaranteeOrder Property

Description

This property holds true if the Oracle Sequence ordering should be guaranteed, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuaranteeOrder() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Oracle Sequence. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

ID Property

Description

Returns the Oracle Sequence ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

IncrementBy Property

Description

This property represents the value by which the Oracle Sequence will be implemented each time a new number is requested. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementBy() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

MaxValue Property

Description

This property represents the maximum Oracle Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxValue() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

MinValue Property

Description

This property represents the minimum Oracle Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinValue() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Oracle Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the Oracle Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the Oracle Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the Oracle Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

StartWith Property

Description

This property represents the value that the Oracle Sequence will start with. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartWith() As Variant

See Also

OracleSequence Object


%%PageItemTitle%%

OracleSequences Collection
See Also Members

Description

This object represents a collection of Oracle sequences. The owner of this collection is the model.

Object Model

See Also

OracleSequences Members


%%PageItemTitle%% $$Members$$

OracleSequences Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Oracle Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).
Public Method AddWithPosition | Creates and returns a new Oracle Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an Oracle Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Oracle Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of sequences in the collection. DATATYPE: Integer.
Public Property Item | Returns a Oracle Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

OracleSequences Overview


%%PageItemTitle%%

Add Method
Name
Owner

Description

Creates and returns a new Oracle Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant _
) As OracleSequence

Parameters

Name
Owner

See Also

OracleSequences Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
HorizontalPosition
VerticalPosition

Description

Creates and returns a new Oracle Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As OracleSequence

Parameters

Name
Owner
HorizontalPosition
VerticalPosition

See Also

OracleSequences Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Oracle Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

OracleSequences Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Oracle Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleSequence

Parameters

Identifier

See Also

OracleSequences Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleSequences Collection


%%PageItemTitle%%

Count Property

Description

This is the number of sequences in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleSequences Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Oracle Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleSequence

Parameters

Identifier

See Also

OracleSequences Collection


%%PageItemTitle%%

OracleSynonym Object
See Also Members

Description

This object represents an Oracle Synonym in ER/Studio. It is stored as its create statement.

Object Model

See Also

OracleSynonym Members


%%PageItemTitle%% $$Members$$

OracleSynonym Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns a collection of user comments associated with this Object.

Public Properties

Public Property DatabaseLink | This property represents the database link of the Oracle Synonym. DATATYPE: String.
Public Property Description | This is the Description of the Oracle Synonym. DATATYPE: String.
Public Property GUID | This is the GUID of the Oracle Synonym. DATATYPE: String.
Public Property ID | Returns the Oracle Synonym ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the Oracle Synonym. DATATYPE: String.
Public Property Owner | This property represents the owner of the Oracle Synonym. DATATYPE: String.
Public Property Public | This property represents the public property of the Oracle Synonym. DATATYPE: Boolean.
Public Property ReferencedObjectName | This property represents the name of the object refered to by the Oracle Synonym. DATATYPE: String.
Public Property ReferencedObjectOwner | This property represents the owner of the object refered to by the Oracle Synonym. DATATYPE: String.

See Also

OracleSynonym Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

OracleSynonym Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

OracleSynonym Object


%%PageItemTitle%%

DatabaseLink Property

Description

This property represents the database link of the Oracle Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatabaseLink() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Oracle Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Oracle Synonym. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

ID Property

Description

Returns the Oracle Synonym ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Oracle Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the Oracle Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

Public Property

Description

This property represents the public property of the Oracle Synonym. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Public() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

ReferencedObjectName Property

Description

This property represents the name of the object refered to by the Oracle Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectName() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

ReferencedObjectOwner Property

Description

This property represents the owner of the object refered to by the Oracle Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectOwner() As Variant

See Also

OracleSynonym Object


%%PageItemTitle%%

OracleSynonyms Collection
See Also Members

Description

This object represents a collection of Oracle Synonyms. The owner of this collection is the model.

Object Model

See Also

OracleSynonyms Members


%%PageItemTitle%% $$Members$$

OracleSynonyms Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Oracle Synonym, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).
Public Method AddWithPosition | Creates an Oracle Synonym. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an Oracle Synonym object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Oracle Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Synonyms in the collection. DATATYPE: Integer.
Public Property Item | Returns a Oracle Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

OracleSynonyms Overview


%%PageItemTitle%%

Add Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner

Description

Creates and returns a new Oracle Synonym, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant _
) As OracleSynonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner

See Also

OracleSynonyms Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

Description

Creates an Oracle Synonym. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As OracleSynonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

See Also

OracleSynonyms Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an Oracle Synonym object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

OracleSynonyms Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Oracle Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleSynonym

Parameters

Identifier

See Also

OracleSynonyms Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleSynonyms Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Synonyms in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleSynonyms Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Oracle Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleSynonym

Parameters

Identifier

See Also

OracleSynonyms Collection


%%PageItemTitle%%

OracleTablePartition Object
See Also Members

Description

This object represents a OracleTablePartition in ER/Studio.

Object Model

See Also

OracleTablePartition Members


%%PageItemTitle%% $$Members$$

OracleTablePartition Object Members
See Also Overview

Public Methods

Public Method OracleTableSubpartitions Returns the collection of Oracle partition level subpartitions of the parent partition.

Public Properties

Public Property BufferPool | This is the Buffer Pool property of the Partition. DATATYPE: String. Input should be a string containing NONE, DEFAULT, KEEP or RECYCLE. Not for HASH partitions.
Public Property FreeListGroups | This is the Free List Groups property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property FreeLists | This is the Free Lists property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property GUID | This is the GUID of the Partition. DATATYPE: String.
Public Property HighValues | For type RANGE the are the HighValues of the Partition. For type LIST this is the List of Values of the Partition. DATATYPE: String.
Public Property ID | This is the ID of the Partition. DATATYPE: Integer.
Public Property InitExtent | This is the Initial Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property InitTrans | This is the Initial Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property MaxExtents | This is the Max Extents property of the Partition. Input should be a string containing non-negative integer or UNLIMITED. Not for HASH partitions. DATATYPE: String.
Public Property MaxTrans | This is the Max Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property MinExtents | This is the Min Extents property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property Name | This is the Name of the Partition. DATATYPE: String.
Public Property NextExtent | This is the Next Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property NoLogging | This indicates whether the operation will be logged in the redo file. Not for HASH partitions. DATATYPE: Boolean.
Public Property Number | This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL.) DATATYPE: Integer.
Public Property PctFree | This is the PctFree property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property PctIncrease | This is the Percent Increase property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property PctUsed | This is the PctUsed property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.
Public Property Tablespace | This is the Tablespace of the Partition. DATATYPE: String.

See Also

OracleTablePartition Overview


%%PageItemTitle%%

OracleTableSubpartitions Method

Description

Returns the collection of Oracle partition level subpartitions of the parent partition.

Syntax

Visual Basic
Public Function OracleTableSubpartitions() As OracleTableSubpartitions

See Also

OracleTablePartition Object


%%PageItemTitle%%

BufferPool Property

Description

This is the Buffer Pool property of the Partition. DATATYPE: String. Input should be a string containing NONE, DEFAULT, KEEP or RECYCLE. Not for HASH partitions.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferPool() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

FreeListGroups Property

Description

This is the Free List Groups property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeListGroups() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

FreeLists Property

Description

This is the Free Lists property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeLists() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Partition. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

HighValues Property

Description

For type RANGE the are the HighValues of the Partition. For type LIST this is the List of Values of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighValues() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the Partition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

InitExtent Property

Description

This is the Initial Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitExtent() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

InitTrans Property

Description

This is the Initial Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitTrans() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

MaxExtents Property

Description

This is the Max Extents property of the Partition. Input should be a string containing non-negative integer or UNLIMITED. Not for HASH partitions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtents() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

MaxTrans Property

Description

This is the Max Transaction property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxTrans() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

MinExtents Property

Description

This is the Min Extents property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtents() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

Name Property

Description

This is the Name of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

NextExtent Property

Description

This is the Next Extent property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtent() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

NoLogging Property

Description

This indicates whether the operation will be logged in the redo file. Not for HASH partitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoLogging() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the Partition. (Partition Numbers determine the order in which the partitions appear in the DDL.) DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

PctFree Property

Description

This is the PctFree property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctFree() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

PctIncrease Property

Description

This is the Percent Increase property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctIncrease() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

PctUsed Property

Description

This is the PctUsed property of the Partition. Input should be a non-negative integer. Not for HASH partitions. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctUsed() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

Tablespace Property

Description

This is the Tablespace of the Partition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

OracleTablePartition Object


%%PageItemTitle%%

OracleTablePartitions Collection
See Also Members

Description

This object represents a collection of OracleTablePartition objects.

Object Model

See Also

OracleTablePartitions Members


%%PageItemTitle%% $$Members$$

OracleTablePartitions Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new OracleTablePartition object. PARAMETERS: HighValues as String.
Public Method AddColumnToPartitionKey | Use to add another column to the partition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.
Public Method AddColumnToSubpartitionKey | Use to add another column to the subpartition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.
Public Method DeleteColumnFromPartitionKey | Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.
Public Method DeleteColumnFromSubpartitionKey | Use to delete a column from the subpartition key. Cannot delete last column in key. PARAMETERS: Name as String.
Public Method DeletePartitionKey | Use this method to delete all columns in the partition key. This also deletes all partitions and all subpartitions and the subpartition key.
Public Method DeleteSubpartitionKey | Use this method to delete all columns in the subpartition key. This also deletes all subpartitions.
Public Method GetPartitionColumnNumber | PARAMETERS: Name of the partition column as String, Looks for the column in the partition key. If it finds it, it returns the column's number. RETURN DATATYPE: Integer.
Public Method GetSubpartitionColumnNumber | Looks for the column in the subpartition key. If it finds it, it returns the column's number. If not, it returns zero. PARAMETERS: Name of the subpartition column as String, RETURN DATATYPE: Integer.
Public Method OracleTableSubpartitions | Returns the collection of oracle table level subpartitions of the parent table.
Public Method Remove | Remove a OracleTablePartition specified by the given Number. PARAMETERS: Number as Integer.
Public Method RemoveByName | Remove the OracleTablePartition specified by the given Name. PARAMETERS: Name as String.
Public Method SetPartitionColumnNumber | Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer .
Public Method SetPartitionType | Use to change the partition type. Pass in a string containing RANGE, LIST, HASH or COMPOSITE. PARAMETERS: Type as String, ColumnName as String.
Public Method SetSubpartitionColumnNumber | Use to change the sequence of the columns in the subpartition key by setting the number of a column. PARAMETERS: Name of the subpartition column as String, Number as Integer .
Public Method SetSubpartitionType | Deletes all subpartitions and SubpartitionKey. Passed in name is new Key. PARAMETERS: Type,ColumnName (String), Changes SubpartitionType if PartitionType is COMPOSITE. Pass in 'LIST' or 'HASH'.

Public Properties

Public Property _Item | Returns a OracleTablePartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.
Public Property _NewEnum |
Public Property Count | This is the number of OracleTablePartition objects in the collection. DATATYPE: Integer.
Public Property GetPartitionKeyColumns | This is the names of the columns in hte PartitionKey as a comma separated list in sequence order. DATATYPE: String.
Public Property GetPartitionType | This returns the type of partition: RANGE, HASH, LIST, COMPOSITE. DATATYPE: String.
Public Property GetSubpartitionKeyColumns | This is the names of the columns in the Subpartition Key as a comma separated list in sequence order. DATATYPE: String.
Public Property GetSubpartitionType | This returns the type of subpartition: HASH or LIST or NONE, if the partition type is not COMPOSITE. DATATYPE: String.
Public Property HashPartitionCount | For HASH partitions only. This represents the quantity of partitions. Use when not wanting to name individual partitions. Positive integers only. Delete any named partitions first. DATATYPE: String.
Public Property HashPartitionTablespaces | For HASH partitions only. This is the comma separated list of tablespaces for un-named partitions. DATATYPE: String.
Public Property Item | Returns a OracleTablePartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.
Public Property SubpartitionCount | This returns the number of subpartitions. This does not include subpartitions specified under each partition. DATATYPE: Integer.

See Also

OracleTablePartitions Overview


%%PageItemTitle%%

Add Method
HighValues

Description

Add a new OracleTablePartition object. PARAMETERS: HighValues as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal HighValues As Variant _
) As OracleTablePartition

Parameters

HighValues

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

AddColumnToPartitionKey Method
Name

Description

Use to add another column to the partition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub AddColumnToPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

AddColumnToSubpartitionKey Method
Name

Description

Use to add another column to the subpartition key. For type LIST the passed in column will replace the previous column. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub AddColumnToSubpartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

DeleteColumnFromPartitionKey Method
Name

Description

Use to delete a column from the partition key. Cannot delete last column in key. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub DeleteColumnFromPartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

DeleteColumnFromSubpartitionKey Method
Name

Description

Use to delete a column from the subpartition key. Cannot delete last column in key. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub DeleteColumnFromSubpartitionKey( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

DeletePartitionKey Method

Description

Use this method to delete all columns in the partition key. This also deletes all partitions and all subpartitions and the subpartition key.

Syntax

Visual Basic
Public Sub DeletePartitionKey()

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

DeleteSubpartitionKey Method

Description

Use this method to delete all columns in the subpartition key. This also deletes all subpartitions.

Syntax

Visual Basic
Public Sub DeleteSubpartitionKey()

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

GetPartitionColumnNumber Method
Name

Description

PARAMETERS: Name of the partition column as String, Looks for the column in the partition key. If it finds it, it returns the column's number. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetPartitionColumnNumber( _
   ByVal Name As Variant _
) As Long

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

GetSubpartitionColumnNumber Method
Name

Description

Looks for the column in the subpartition key. If it finds it, it returns the column's number. If not, it returns zero. PARAMETERS: Name of the subpartition column as String, RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function GetSubpartitionColumnNumber( _
   ByVal Name As Variant _
) As Long

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

OracleTableSubpartitions Method

Description

Returns the collection of oracle table level subpartitions of the parent table.

Syntax

Visual Basic
Public Function OracleTableSubpartitions() As OracleTableSubpartitions

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Remove a OracleTablePartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

RemoveByName Method
Name

Description

Remove the OracleTablePartition specified by the given Name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub RemoveByName( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

SetPartitionColumnNumber Method
Name
Number

Description

Use to change the sequence of the columns in the partition key by setting the number of a column. PARAMETERS: Name of the partition column as String, Number as Integer .

Syntax

Visual Basic
Public Sub SetPartitionColumnNumber( _
   ByVal Name As Variant, _
   ByVal Number As Variant _
)

Parameters

Name
Number

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

SetPartitionType Method
Type
ColumnName

Description

Use to change the partition type. Pass in a string containing RANGE, LIST, HASH or COMPOSITE. PARAMETERS: Type as String, ColumnName as String.

Syntax

Visual Basic
Public Sub SetPartitionType( _
   ByVal Type As Variant, _
   ByVal ColumnName As Variant _
)

Parameters

Type
ColumnName

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

SetSubpartitionColumnNumber Method
Name
Number

Description

Use to change the sequence of the columns in the subpartition key by setting the number of a column. PARAMETERS: Name of the subpartition column as String, Number as Integer .

Syntax

Visual Basic
Public Sub SetSubpartitionColumnNumber( _
   ByVal Name As Variant, _
   ByVal Number As Variant _
)

Parameters

Name
Number

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

SetSubpartitionType Method
Type
ColumnName

Description

Deletes all subpartitions and SubpartitionKey. Passed in name is new Key. PARAMETERS: Type,ColumnName (String), Changes SubpartitionType if PartitionType is COMPOSITE. Pass in 'LIST' or 'HASH'.

Syntax

Visual Basic
Public Sub SetSubpartitionType( _
   ByVal Type As Variant, _
   ByVal ColumnName As Variant _
)

Parameters

Type
ColumnName

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a OracleTablePartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleTablePartition

Parameters

Identifier

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of OracleTablePartition objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

GetPartitionKeyColumns Property

Description

This is the names of the columns in hte PartitionKey as a comma separated list in sequence order. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetPartitionKeyColumns() As Variant

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

GetPartitionType Property

Description

This returns the type of partition: RANGE, HASH, LIST, COMPOSITE. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetPartitionType() As Variant

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

GetSubpartitionKeyColumns Property

Description

This is the names of the columns in the Subpartition Key as a comma separated list in sequence order. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetSubpartitionKeyColumns() As Variant

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

GetSubpartitionType Property

Description

This returns the type of subpartition: HASH or LIST or NONE, if the partition type is not COMPOSITE. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetSubpartitionType() As Long

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

HashPartitionCount Property

Description

For HASH partitions only. This represents the quantity of partitions. Use when not wanting to name individual partitions. Positive integers only. Delete any named partitions first. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HashPartitionCount() As Variant

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

HashPartitionTablespaces Property

Description

For HASH partitions only. This is the comma separated list of tablespaces for un-named partitions. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property HashPartitionTablespaces() As Variant

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a OracleTablePartition object specified by the given Number or GUID. PARAMETERS: Identifier as Integer or String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleTablePartition

Parameters

Identifier

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

SubpartitionCount Property

Description

This returns the number of subpartitions. This does not include subpartitions specified under each partition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubpartitionCount() As Long

See Also

OracleTablePartitions Collection


%%PageItemTitle%%

OracleTablespace Object
See Also Members

Description

This object represents an Oracle Tablespace in ER/Studio. It is stored as its create statement.

Object Model

See Also

OracleTablespace Members


%%PageItemTitle%% $$Members$$

OracleTablespace Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method OracleDatafiles | Returns the OracleDatafiles associated with this Tablespace.
Public Method UserComments | Returns a collection of User Comments associated with this Object.

Public Properties

Public Property Description | This is the Description of the Tablespace. DATATYPE: String.
Public Property GUID | This is the GUID of the Tablespace. DATATYPE: String.
Public Property ID | Returns the Tablespace's ID. DATATYPE: Integer.
Public Property InitExtSize | This property represents the size of the initial extent for the Tablespace in kilo bytes. DATATYPE: Integer.
Public Property LocallyManaged | This property specifies whether the tablespace is locally managed (true). DATATYPE: Boolean.
Public Property Logging | This property holds the Logging status. DATATYPE: Boolean.
Public Property MaxExtents | This property specifies the maximum number of extents allowed in a segment. Must be positive integer or the string "UNLIMITED". DATATYPE: String.
Public Property MinExtents | This property specifies the minimum number of extents allowed in a segment. DATATYPE: Integer.
Public Property MinExtSize | This property represents the minimum size of an extent for the Tablespace in kilo bytes. DATATYPE: Integer.
Public Property Name | This property represents the name of the Tablespace. DATATYPE: String.
Public Property NextExtSize | This property represents the size of the next or secondary extent for the Tablespace in kilo bytes. DATATYPE: Integer.
Public Property Offline | This property specifies the Offline status, which tells whether the given tablespace is online (false) or offline (true). DATATYPE: Boolean.
Public Property PctIncrease | This property specifies the percentage increase in size. DATATYPE: Integer.
Public Property SegmentSpaceManagementAutomatic | This property specifies whether the segment space management is Automatic (TRUE) or Manual (FALSE). DATATYPE: Boolean.
Public Property UniformExtents | This property specifies whether the Extent Size of the tablespace is uniform (true). This property applies only to locally managed tablespaces and is invalid otherwise. DATATYPE: Boolean.
Public Property UniformExtentSize | This property holds the extent size for locally managed tablespaces with uniform extents. Invalid for tablespaces that are not locally managed or do not have uniform extents. DATATYPE: Integer.

See Also

OracleTablespace Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

OracleTablespace Object


%%PageItemTitle%%

OracleDatafiles Method

Description

Returns the OracleDatafiles associated with this Tablespace.

Syntax

Visual Basic
Public Function OracleDatafiles() As OracleDatafiles

See Also

OracleTablespace Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of User Comments associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

OracleTablespace Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Tablespace. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

ID Property

Description

Returns the Tablespace's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

InitExtSize Property

Description

This property represents the size of the initial extent for the Tablespace in kilo bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitExtSize() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

LocallyManaged Property

Description

This property specifies whether the tablespace is locally managed (true). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LocallyManaged() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

Logging Property

Description

This property holds the Logging status. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Logging() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

MaxExtents Property

Description

This property specifies the maximum number of extents allowed in a segment. Must be positive integer or the string "UNLIMITED". DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxExtents() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

MinExtents Property

Description

This property specifies the minimum number of extents allowed in a segment. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtents() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

MinExtSize Property

Description

This property represents the minimum size of an extent for the Tablespace in kilo bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinExtSize() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Tablespace. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

NextExtSize Property

Description

This property represents the size of the next or secondary extent for the Tablespace in kilo bytes. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NextExtSize() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

Offline Property

Description

This property specifies the Offline status, which tells whether the given tablespace is online (false) or offline (true). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Offline() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

PctIncrease Property

Description

This property specifies the percentage increase in size. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PctIncrease() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

SegmentSpaceManagementAutomatic Property

Description

This property specifies whether the segment space management is Automatic (TRUE) or Manual (FALSE). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SegmentSpaceManagementAutomatic() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

UniformExtents Property

Description

This property specifies whether the Extent Size of the tablespace is uniform (true). This property applies only to locally managed tablespaces and is invalid otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property UniformExtents() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

UniformExtentSize Property

Description

This property holds the extent size for locally managed tablespaces with uniform extents. Invalid for tablespaces that are not locally managed or do not have uniform extents. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property UniformExtentSize() As Variant

See Also

OracleTablespace Object


%%PageItemTitle%%

OracleTablespaces Collection
See Also Members

Description

This object represents a collection of Oracle Tablespaces. The owner of this collection is the Model.

Object Model

See Also

OracleTablespaces Members


%%PageItemTitle%% $$Members$$

OracleTablespaces Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Tablespace with one datafile, and adds it to the collection. PARAMETERS: Name (String) and FileName (String).
Public Method AddWithPosition | Creates and returns a new Tablespace with the given coordinates. PARAMETERS: Name (String), FileName (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a Tablespace object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Tablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Tablespaces in the collection. DATATYPE: Integer.
Public Property Item | Returns a Tablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

OracleTablespaces Overview


%%PageItemTitle%%

Add Method
Name
FileName

Description

Creates and returns a new Tablespace with one datafile, and adds it to the collection. PARAMETERS: Name (String) and FileName (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal FileName As Variant _
) As OracleTablespace

Parameters

Name
FileName

See Also

OracleTablespaces Collection


%%PageItemTitle%%

AddWithPosition Method
Name
FileName
HorizontalPosition
VerticalPosition

Description

Creates and returns a new Tablespace with the given coordinates. PARAMETERS: Name (String), FileName (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal FileName As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As OracleTablespace

Parameters

Name
FileName
HorizontalPosition
VerticalPosition

See Also

OracleTablespaces Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Tablespace object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

OracleTablespaces Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Tablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As OracleTablespace

Parameters

Identifier

See Also

OracleTablespaces Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleTablespaces Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Tablespaces in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleTablespaces Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Tablespace object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As OracleTablespace

Parameters

Identifier

See Also

OracleTablespaces Collection


%%PageItemTitle%%

OracleTableSubpartition Object
See Also Members

Description

This object represents a OracleTableSubpartition in ER/Studio.

See Also

OracleTableSubpartition Members


%%PageItemTitle%% $$Members$$

OracleTableSubpartition Object Members
See Also Overview

Public Properties

Public Property Name | This is the Name of the Subpartition. (Does not apply to HASH partitions that have been specified by number).DATATYPE: String.
Public Property Number | This is the Number of the Subpartition. (Subpartition Numbers determine the order in which the subpartitions appear in the DDL.) DATATYPE: Integer.
Public Property SubpartitionType | This returns the type of this Subpartition: Either LIST, RANGE or NONE, if the Partition Type is not COMPOSITE. DATATYPE: String.
Public Property Tablespace | This is the Tablespace of the Subpartition. DATATYPE: String.
Public Property Values | This is the List of Values of the Subpartition (applies only to LIST subpartitions).DATATYPE: String.

See Also

OracleTableSubpartition Overview


%%PageItemTitle%%

Name Property

Description

This is the Name of the Subpartition. (Does not apply to HASH partitions that have been specified by number).DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

OracleTableSubpartition Object


%%PageItemTitle%%

Number Property

Description

This is the Number of the Subpartition. (Subpartition Numbers determine the order in which the subpartitions appear in the DDL.) DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Variant

See Also

OracleTableSubpartition Object


%%PageItemTitle%%

SubpartitionType Property

Description

This returns the type of this Subpartition: Either LIST, RANGE or NONE, if the Partition Type is not COMPOSITE. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubpartitionType() As Variant

See Also

OracleTableSubpartition Object


%%PageItemTitle%%

Tablespace Property

Description

This is the Tablespace of the Subpartition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tablespace() As Variant

See Also

OracleTableSubpartition Object


%%PageItemTitle%%

Values Property

Description

This is the List of Values of the Subpartition (applies only to LIST subpartitions).DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Values() As Variant

See Also

OracleTableSubpartition Object


%%PageItemTitle%%

OracleTableSubpartitions Collection
See Also Members

Description

This object represents a collection of OracleTableSubpartition objects.

Object Model

See Also

OracleTableSubpartitions Members


%%PageItemTitle%% $$Members$$

OracleTableSubpartitions Collection Members
See Also Overview

Public Methods

Public Method AddHash | Adds new PartitionLevel subpartition if HASHByName (HASHQuantity equal 0, no tablespaces exist. HashByName(true) removes any).TBS optional. PARAMETERS: Number(Integer>0), Name,TBS(String).
Public Method AddList | Adds a new subpartition. Requires subpartition type LIST. PARAMETERS: Number as Integer, String: Name, Values, TBS, Number must be greater than zero. Tablespace can be empty.
Public Method AddTablespace | Adds new tablespace. Requires HASH by Number (no named HASH subpartitions may exist. HashByName(false) removes any that exist.) PARAMETERS: Number(Integer>0), TBS(non-empty String).
Public Method Remove | Removes a subpartition specified by the given Number. PARAMETERS: Number as Integer.

Public Properties

Public Property _Item | Returns a OracleTableSubpartition object specified by the given Number. PARAMETERS: Number as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of OracleTableSubpartition objects in this collection. For example, if this is the manager of a partition, then Count is the number of subpartitions specified for that partition. DATATYPE: Integer.
Public Property HashByName | Returns true if named HASH subpartitions exist. Setting this to true zeroes out the HASH Quantity and deletes all existing tablespaces. Setting it to false, deletes all existing named HASH subpartitions. DATATYPE: Boolean.
Public Property HashQuantity | Returns default number of subpartitions or zero if not specified. Applies only to HASH subpartitions. Can only set this if no named HASH subpartitions exist. HashType(FALSE) removes any remaining ones. DATATYPE: Integer.
Public Property Item | Returns a OracleTableSubpartition object specified by the given Number. PARAMETERS: Number as Integer.
Public Property SubpartitionType | This returns the type of subpartition: HASH or LIST or NONE, if the partition type is not COMPOSITE. DATATYPE: String.

See Also

OracleTableSubpartitions Overview


%%PageItemTitle%%

AddHash Method
Number
Name
TBS

Description

Adds new PartitionLevel subpartition if HASHByName (HASHQuantity equal 0, no tablespaces exist. HashByName(true) removes any).TBS optional. PARAMETERS: Number(Integer>0), Name,TBS(String).

Syntax

Visual Basic
Public Function AddHash( _
   ByVal Number As Variant, _
   ByVal Name As Variant, _
   ByVal TBS As Variant _
) As OracleTableSubpartition

Parameters

Number
Name
TBS

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

AddList Method
Number
Name
Values
TBS

Description

Adds a new subpartition. Requires subpartition type LIST. PARAMETERS: Number as Integer, String: Name, Values, TBS, Number must be greater than zero. Tablespace can be empty.

Syntax

Visual Basic
Public Function AddList( _
   ByVal Number As Variant, _
   ByVal Name As Variant, _
   ByVal Values As Variant, _
   ByVal TBS As Variant _
) As OracleTableSubpartition

Parameters

Number
Name
Values
TBS

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

AddTablespace Method
Number
TBS

Description

Adds new tablespace. Requires HASH by Number (no named HASH subpartitions may exist. HashByName(false) removes any that exist.) PARAMETERS: Number(Integer>0), TBS(non-empty String).

Syntax

Visual Basic
Public Function AddTablespace( _
   ByVal Number As Variant, _
   ByVal TBS As Variant _
) As OracleTableSubpartition

Parameters

Number
TBS

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

Remove Method
Number

Description

Removes a subpartition specified by the given Number. PARAMETERS: Number as Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Number As Variant _
)

Parameters

Number

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

_Item Property
Number

Description

Returns a OracleTableSubpartition object specified by the given Number. PARAMETERS: Number as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Number As Variant _
) As OracleTableSubpartition

Parameters

Number

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

Count Property

Description

This is the number of OracleTableSubpartition objects in this collection. For example, if this is the manager of a partition, then Count is the number of subpartitions specified for that partition. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

HashByName Property

Description

Returns true if named HASH subpartitions exist. Setting this to true zeroes out the HASH Quantity and deletes all existing tablespaces. Setting it to false, deletes all existing named HASH subpartitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HashByName() As Variant

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

HashQuantity Property

Description

Returns default number of subpartitions or zero if not specified. Applies only to HASH subpartitions. Can only set this if no named HASH subpartitions exist. HashType(FALSE) removes any remaining ones. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HashQuantity() As Variant

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

Item Property
Number

Description

Returns a OracleTableSubpartition object specified by the given Number. PARAMETERS: Number as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Number As Variant _
) As OracleTableSubpartition

Parameters

Number

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

SubpartitionType Property

Description

This returns the type of subpartition: HASH or LIST or NONE, if the partition type is not COMPOSITE. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubpartitionType() As Long

See Also

OracleTableSubpartitions Collection


%%PageItemTitle%%

Package Object
See Also Members

Description

This object represents a Package in ER/Studio.

Object Model

See Also

Package Members


%%PageItemTitle%% $$Members$$

Package Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Package.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns a collection of user comments associated with this Package.

Public Properties

Public Property Body | This is the Body of the Package. DATATYPE: String.
Public Property Description | This is the description of the Package. DATATYPE: String.
Public Property GUID | GUID of the Package. This GUID is assigned by ER/Studio. Each Package has a unique GUID. DATATYPE: String.
Public Property Header | This is the Header of the Package. DATATYPE: String.
Public Property ID | ID of the Package. This ID is assigned by ER/Studio. Each Package in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the Package. DATATYPE: String.
Public Property Owner | This is the Owner of the Package. DATATYPE: String.

See Also

Package Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Package.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Package Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

Package Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Package.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Package Object


%%PageItemTitle%%

Body Property

Description

This is the Body of the Package. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Body() As Variant

See Also

Package Object


%%PageItemTitle%%

Description Property

Description

This is the description of the Package. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Package Object


%%PageItemTitle%%

GUID Property

Description

GUID of the Package. This GUID is assigned by ER/Studio. Each Package has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Package Object


%%PageItemTitle%%

Header Property

Description

This is the Header of the Package. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Header() As Variant

See Also

Package Object


%%PageItemTitle%%

ID Property

Description

ID of the Package. This ID is assigned by ER/Studio. Each Package in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Package Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Package. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Package Object


%%PageItemTitle%%

Owner Property

Description

This is the Owner of the Package. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

Package Object


%%PageItemTitle%%

Packages Collection
See Also Members

Description

This object represents a collection of Packages. The owner of this collection is the model.

Object Model

See Also

Packages Members


%%PageItemTitle%% $$Members$$

Packages Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a Package with the given name and header. PARAMETERS: Name as String, Header as String.
Public Method AddWithPosition | Creates a Package with the given name and header and coordinates. PARAMETERS: Name as String, Header as String, HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Deletes a Package object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Package object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Package objects in the collection.DATATYPE: Integer.
Public Property Item | Returns a Package object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Packages Overview


%%PageItemTitle%%

Add Method
Name
Header

Description

Creates a Package with the given name and header. PARAMETERS: Name as String, Header as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Header As Variant _
) As Package

Parameters

Name
Header

See Also

Packages Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Header
HorizontalPosition
VerticalPosition

Description

Creates a Package with the given name and header and coordinates. PARAMETERS: Name as String, Header as String, HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Header As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Package

Parameters

Name
Header
HorizontalPosition
VerticalPosition

See Also

Packages Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Package object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Packages Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Package object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Package

Parameters

Identifier

See Also

Packages Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Packages Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Package objects in the collection.DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Packages Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Package object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Package

Parameters

Identifier

See Also

Packages Collection


%%PageItemTitle%%

PhysicalGeneration Object
See Also Members

Description

This object represents a PhysicalGeneration object that provides an interface for generating the physical model for the logical model.

Object Model

See Also

PhysicalGeneration Members


%%PageItemTitle%% $$Members$$

PhysicalGeneration Object Members
See Also Overview

Public Methods

Public Method GenPhysicalUsingFileBasedQuickLaunch | Generate a physical model using the Quick Launch setting identified by the given filename. PARAMETERS: FileName as Strings.
Public Method GenPhysicalUsingQuickLaunch | Generate a physical model using the Quick Launch setting identified by the given name. PARAMETERS: Name as Strings.
Public Method GetQuickLaunchList | Return all the names of available Quick Launch settings for the Model. RETURN DATATYPE: StringObjects.

See Also

PhysicalGeneration Overview


%%PageItemTitle%%

GenPhysicalUsingFileBasedQuickLaunch Method
FileName

Description

Generate a physical model using the Quick Launch setting identified by the given filename. PARAMETERS: FileName as Strings.

Syntax

Visual Basic
Public Sub GenPhysicalUsingFileBasedQuickLaunch( _
   ByVal FileName As Variant _
)

Parameters

FileName

See Also

PhysicalGeneration Object


%%PageItemTitle%%

GenPhysicalUsingQuickLaunch Method
Name

Description

Generate a physical model using the Quick Launch setting identified by the given name. PARAMETERS: Name as Strings.

Syntax

Visual Basic
Public Sub GenPhysicalUsingQuickLaunch( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

PhysicalGeneration Object


%%PageItemTitle%%

GetQuickLaunchList Method

Description

Return all the names of available Quick Launch settings for the Model. RETURN DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function GetQuickLaunchList() As StringObjects

See Also

PhysicalGeneration Object


%%PageItemTitle%%

PrintOptions Object
See Also Members

Description

This object represents a PrintOptions object that provides an interface for printing an image of the Submodel.

See Also

PrintOptions Members


%%PageItemTitle%% $$Members$$

PrintOptions Object Members
See Also Overview

Public Methods

Public Method Print This will print the submodel according to the options that are set.

Public Properties

Public Property BorderColor | This is the border color. It takes a 4 byte integer where 1st byte is red value(0-255), the 2nd byte is green value(0-255), and 3rd byte is blue value(0-255). DATATYPE: Integer.
Public Property BorderWidth | Indicates the thickness of the border lines. The values allowed range from 1 to 5 only. DATATYPE: Double.
Public Property Collate | This is the flag to enable/disable collate when printing. DATATYPE: Boolean.
Public Property DateTimeStampPosition | Indicates the position of the date and time stamp. The values are either 0 = top or 1 = bottom. DATATYPE: Integer.
Public Property Margin | Indicates the size of the margin. The values allowed ranges from 0.20 to 2.20 in inches. DATATYPE: Double.
Public Property NumberOfCopies | Indicates how many copies to print. DATATYPE: Integer.
Public Property PageScale | Indicates the page sclea. The values are either 0=PrintCurrentZoom, 1=Print 1:1(NoZoom), 2=FitPage, 3=UserDefined. DATATYPE: Integer.
Public Property PrintBorder | This is the flag to enable/disable printing of the border. DATATYPE: Boolean.
Public Property PrintCropMarks | This is the flag to enable/disable printing of the crop marks. DATATYPE: Boolean.
Public Property PrintDateTimeStamp | This is the flag to enable/disable printing of the date and time stamp. DATATYPE: Boolean.
Public Property PrintDiagramSubmodelName | This is the flag to enable/disable printing of the diagram and submodel name. DATATYPE: Boolean.
Public Property PrintGrid | This is the flag to enable/disable printing of the grid. DATATYPE: Boolean.
Public Property PrintModelBackground | This is the flag to enable/disable printing of the model background. DATATYPE: Boolean.
Public Property PrintObjectBackground | This is the flag to enable/disable printing of the object background. DATATYPE: Boolean.
Public Property PrintPageNumbers | This is the flag to enable/disable printing of the page numbers. DATATYPE: Boolean.
Public Property Scale | If page scale is set to UserDefined this peoprty is used to set the actual scale. Allowed values are 5 to 400. DATATYPE: Double.

See Also

PrintOptions Overview


%%PageItemTitle%%

Print Method

Description

This will print the submodel according to the options that are set.

Syntax

Visual Basic
Public Sub Print()

See Also

PrintOptions Object


%%PageItemTitle%%

BorderColor Property

Description

This is the border color. It takes a 4 byte integer where 1st byte is red value(0-255), the 2nd byte is green value(0-255), and 3rd byte is blue value(0-255). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property BorderColor() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

BorderWidth Property

Description

Indicates the thickness of the border lines. The values allowed range from 1 to 5 only. DATATYPE: Double.

Property type

Read-write property

Syntax

Visual Basic
Public Property BorderWidth() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

Collate Property

Description

This is the flag to enable/disable collate when printing. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Collate() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

DateTimeStampPosition Property

Description

Indicates the position of the date and time stamp. The values are either 0 = top or 1 = bottom. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateTimeStampPosition() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

Margin Property

Description

Indicates the size of the margin. The values allowed ranges from 0.20 to 2.20 in inches. DATATYPE: Double.

Property type

Read-write property

Syntax

Visual Basic
Public Property Margin() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

NumberOfCopies Property

Description

Indicates how many copies to print. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumberOfCopies() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PageScale Property

Description

Indicates the page sclea. The values are either 0=PrintCurrentZoom, 1=Print 1:1(NoZoom), 2=FitPage, 3=UserDefined. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageScale() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintBorder Property

Description

This is the flag to enable/disable printing of the border. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintBorder() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintCropMarks Property

Description

This is the flag to enable/disable printing of the crop marks. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintCropMarks() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintDateTimeStamp Property

Description

This is the flag to enable/disable printing of the date and time stamp. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintDateTimeStamp() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintDiagramSubmodelName Property

Description

This is the flag to enable/disable printing of the diagram and submodel name. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintDiagramSubmodelName() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintGrid Property

Description

This is the flag to enable/disable printing of the grid. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintGrid() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintModelBackground Property

Description

This is the flag to enable/disable printing of the model background. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintModelBackground() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintObjectBackground Property

Description

This is the flag to enable/disable printing of the object background. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintObjectBackground() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

PrintPageNumbers Property

Description

This is the flag to enable/disable printing of the page numbers. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageNumbers() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

Scale Property

Description

If page scale is set to UserDefined this peoprty is used to set the actual scale. Allowed values are 5 to 400. DATATYPE: Double.

Property type

Read-write property

Syntax

Visual Basic
Public Property Scale() As Variant

See Also

PrintOptions Object


%%PageItemTitle%%

Procedure Object
See Also Members

Description

This object represents a stored procedure in ER/Studio.

Object Model

See Also

Procedure Members


%%PageItemTitle%% $$Members$$

Procedure Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Procedure.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method SetText | Sets the Text (SQL) for the Procedure. Returns the validation error message or none if validated succesfully. PARAMETERS: NewText as String. RETURN DATATYPE: String.
Public Method UserComments | Returns a collection of User Comments associated with this object.

Public Properties

Public Property Description | This is the description of the stored procedure. DATATYPE: String.
Public Property GUID | GUID of the stored procedure. This GUID is assigned by ER/Studio. Each stored procedure has a unique GUID. DATATYPE: String.
Public Property ID | ID of the stored procedure. This ID is assigned by ER/Studio. Each stored procedure in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the stored procedure. DATATYPE: String.
Public Property Owner | This is the Owner of the stored procedure. DATATYPE: String.
Public Property Text | This is the body text (SQL) of the stored procedure. DATATYPE: String.
Public Property Type | This is the type of the stored procedure. The possible values are: SQL Procedure - 0, SQL Function - 1, Basic Procedure - 2, Basic Function - 3. DATATYPE: Integer.

See Also

Procedure Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Procedure.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Procedure Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

Procedure Object


%%PageItemTitle%%

SetText Method
NewText

Description

Sets the Text (SQL) for the Procedure. Returns the validation error message or none if validated succesfully. PARAMETERS: NewText as String. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function SetText( _
   ByVal NewText As Variant _
) As Variant

Parameters

NewText

See Also

Procedure Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of User Comments associated with this object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Procedure Object


%%PageItemTitle%%

Description Property

Description

This is the description of the stored procedure. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

Example

Dim MyProcedure As Procedure

Dim ProcDescrip As String

MyProcedure.Description = ProcDescrip

See Also

Procedure Object


%%PageItemTitle%%

GUID Property

Description

GUID of the stored procedure. This GUID is assigned by ER/Studio. Each stored procedure has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Procedure Object


%%PageItemTitle%%

ID Property

Description

ID of the stored procedure. This ID is assigned by ER/Studio. Each stored procedure in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyProc As Integer

MyProcedure.ID = MyProc

See Also

Procedure Object


%%PageItemTitle%%

Name Property

Description

This is the name of the stored procedure. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

Example

Dim MyProcedure As Procedure

Dim ProcName As String

ProcName = "MyStoredProcedure"

MyProcedure.Name = ProcName

See Also

Procedure Object


%%PageItemTitle%%

Owner Property

Description

This is the Owner of the stored procedure. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

Procedure Object


%%PageItemTitle%%

Text Property

Description

This is the body text (SQL) of the stored procedure. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Text() As Variant

Example

Dim MyProcedure As Procedure

Dim ProcText As String

MyProcedure.Text = ProcText

See Also

Procedure Object


%%PageItemTitle%%

Type Property

Description

This is the type of the stored procedure. The possible values are: SQL Procedure - 0, SQL Function - 1, Basic Procedure - 2, Basic Function - 3. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

Example

Dim MyProcedure As Procedure

Dim iType As Integer

' 0 indicates that the stored procedure is a SQL Procedure

iType = 0

MyProcedure.Type = iType

See Also

Procedure Object


%%PageItemTitle%%

Procedures Collection
See Also Members

Description

This object represents a collection of stored procedures. The owner of this collection is the model.

Object Model

See Also

Procedures Members


%%PageItemTitle%% $$Members$$

Procedures Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a stored procedure with the given name and type. Procedure types are: SQL Procedure - 0, SQL Function - 1. PARAMETERS: Name as String, ProcedureType as Integer.
Public Method AddWithPosition | Creates a stored procedure with the given name and type. Types are: SQL Procedure-0, SQL Function-1. PARAMETERS: Name (String), ProcedureType (Integer), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a Procedure object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Procedure object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Procedure objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Procedure object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Procedures Overview


%%PageItemTitle%%

Add Method
Name
ProcedureType

Description

Creates a stored procedure with the given name and type. Procedure types are: SQL Procedure - 0, SQL Function - 1. PARAMETERS: Name as String, ProcedureType as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal ProcedureType As Variant _
) As Procedure

Parameters

Name
ProcedureType

Example

Dim MyModel As Model

Dim MyProc As Procedure

Dim ProcName As String

Dim ProcType As Integer

' Setting ProcType to 0 to represent a SQL procedure

ProcName = "LatestProc"

ProcType = 0

Set MyProc = MyModel.Procedures.Add(ProcName, ProcType)

See Also

Procedures Collection


%%PageItemTitle%%

AddWithPosition Method
Name
ProcedureType
HorizontalPosition
VerticalPosition

Description

Creates a stored procedure with the given name and type. Types are: SQL Procedure-0, SQL Function-1. PARAMETERS: Name (String), ProcedureType (Integer), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal ProcedureType As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Procedure

Parameters

Name
ProcedureType
HorizontalPosition
VerticalPosition

See Also

Procedures Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Procedure object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

Example

Dim MyModel As Model

Dim ProcID As Integer

' We want to remove the procedure with 2 as the ID

ProcID = 2

MyModel.Procedures.Remove(ProcID)

See Also

Procedures Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Procedure object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Procedure

Parameters

Identifier

See Also

Procedures Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Procedures Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Procedure objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

Example

Dim MyModel As Model

Dim iCount As Long

MyModel.Procedures.Count = iCount

See Also

Procedures Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Procedure object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Procedure

Parameters

Identifier

Example

Dim MyModel As Model

Dim MyProc As Procedure

Dim ProcID As Integer

' We want the procedure with 2 as the ID

ProcID = 2

Set MyProc = MyModel.Procedures.Item(ProcID)

See Also

Procedures Collection


%%PageItemTitle%%

Profile Object
See Also Members

Description

This object represents a Profile in ER/Studio.

See Also

Profile Members


%%PageItemTitle%% $$Members$$

Profile Object Members
See Also Overview

Public Methods

Public Method DoModify Sends Modify Profile request using current Profile data. If Users are affected, IgnoreUserEffects determine if operation continues(TRUE) or not(FALSE). PARAMETERS: IgnoreUserEffects as Boolean, RETURN DATATYPE: Integer.

Public Properties

Public Property Description | This is the description of the Profile. DATATYPE: String.
Public Property Name | This is the name of the Profile. DATATYPE: String.

See Also

Profile Overview


%%PageItemTitle%%

DoModify Method
IgnoreUserEffects

Description

Sends Modify Profile request using current Profile data. If Users are affected, IgnoreUserEffects determine if operation continues(TRUE) or not(FALSE). PARAMETERS: IgnoreUserEffects as Boolean, RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function DoModify( _
   ByVal IgnoreUserEffects As Variant _
) As Variant

Parameters

IgnoreUserEffects

See Also

Profile Object


%%PageItemTitle%%

Description Property

Description

This is the description of the Profile. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Profile Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Profile. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Profile Object


%%PageItemTitle%%

Profiles Collection
See Also Members

Description

This object represents a collection of Profile objects

Object Model

See Also

Profiles Members


%%PageItemTitle%% $$Members$$

Profiles Collection Members
See Also Overview

Public Methods

Public Method Add Description as String, Privileges as StringObjects, Add a new Profile object. PARAMETERS: Name as String.

Public Properties

Public Property _Item | Returns a Profile object specified by the given name. PARAMETERS: Identifier as String.
Public Property _NewEnum |
Public Property Count | This is the number of Profile objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Profile object specified by the given name.PARAMETERS: Identifier as String.

See Also

Profiles Overview


%%PageItemTitle%%

Add Method
Name
Description
Privileges

Description

Description as String, Privileges as StringObjects, Add a new Profile object. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant, _
   ByVal Privileges As StringObjects _
) As Profile

Parameters

Name
Description
Privileges

See Also

Profiles Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Profile object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Profile

Parameters

Identifier

See Also

Profiles Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Profiles Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Profile objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Profiles Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Profile object specified by the given name.PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Profile

Parameters

Identifier

See Also

Profiles Collection


%%PageItemTitle%%

Project Object
See Also Members

Description

This object represents a Repository Project in ER/Studio.

Object Model

See Also

Project Members


%%PageItemTitle%% $$Members$$

Project Object Members
See Also Overview

Public Methods

Public Method AddDiagrams | Send Modify Project request to repository to add diagrams to a specific project. The diagrams to be added to the project are specified through SetDiagramList method. RETURN DATATYPE: Integer.
Public Method DoModify | Sends Modify Project request to the Repository to modify the defintion of the project. Return 1 if successful, and 0 if it failed. RETURN DATATYPE: Integer.
Public Method GetDiagramList | Returns a StringObject collection of the Diagrams assigned to this Project.
Public Method RemoveDiagrams | Send Modify Project request to repository to remove diagrams from a specific project. The diagrams to be removed are specified through SetDiagramList. RETURN DATATYPE: Integer.
Public Method SetDiagramList | Set the Project's DiagramList according to the Diagram names in the given StringObject collection. PARAMETERS: StringObjects.

Public Properties

Public Property Description | This is the description for the Project. DATATYPE: String.
Public Property Name | This is the name of the Project. DATATYPE: String.

See Also

Project Overview


%%PageItemTitle%%

AddDiagrams Method

Description

Send Modify Project request to repository to add diagrams to a specific project. The diagrams to be added to the project are specified through SetDiagramList method. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function AddDiagrams() As Variant

See Also

Project Object


%%PageItemTitle%%

DoModify Method

Description

Sends Modify Project request to the Repository to modify the defintion of the project. Return 1 if successful, and 0 if it failed. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function DoModify() As Variant

See Also

Project Object


%%PageItemTitle%%

GetDiagramList Method

Description

Returns a StringObject collection of the Diagrams assigned to this Project.

Syntax

Visual Basic
Public Function GetDiagramList() As StringObjects

See Also

Project Object


%%PageItemTitle%%

RemoveDiagrams Method

Description

Send Modify Project request to repository to remove diagrams from a specific project. The diagrams to be removed are specified through SetDiagramList. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RemoveDiagrams() As Variant

See Also

Project Object


%%PageItemTitle%%

SetDiagramList Method
Diagrams

Description

Set the Project's DiagramList according to the Diagram names in the given StringObject collection. PARAMETERS: StringObjects.

Syntax

Visual Basic
Public Sub SetDiagramList( _
   ByVal Diagrams As StringObjects _
)

Parameters

Diagrams

See Also

Project Object


%%PageItemTitle%%

Description Property

Description

This is the description for the Project. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Project Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Project. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Project Object


%%PageItemTitle%%

Projects Collection
See Also Members

Description

This object represents a collection of Project objects.

Object Model

See Also

Projects Members


%%PageItemTitle%% $$Members$$

Projects Collection Members
See Also Overview

Public Methods

Public Method Add | Description as String, Diagrams as StringObjects, Roles as StringObjects, Add a new Project object. PARAMETERS: Name as String.
Public Method Remove | Remove Project object specified by the given name. PARAMETERS: Name as String.

Public Properties

Public Property _Item | Returns a Project object specified by the given name. PARAMETERS: Identifier as String.
Public Property _NewEnum |
Public Property Count | This is the number of Project objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Project object specified by the given name. PARAMETERS: Identifier as String.

See Also

Projects Overview


%%PageItemTitle%%

Add Method
Name
Description
Diagrams
Roles

Description

Description as String, Diagrams as StringObjects, Roles as StringObjects, Add a new Project object. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant, _
   ByVal Diagrams As StringObjects, _
   ByVal Roles As StringObjects _
) As Project

Parameters

Name
Description
Diagrams
Roles

Example

Sub Main

Dim modlist As StringObjects

Dim projs As Projects

Dim addmodlist As StringObjects

Dim addrolelist As StringObjects

Set projs = DiagramManager.RepoProjects

Set addmodlist = DiagramManager.CreateStringObjects

Set addrolelist = DiagramManager.CreateStringObjects

addrolelist.Add("Modeler")

addmodlist.Add("TestOracle.dm1")

projs.Remove("testproj")

projs.Add( "Repository", "Repository-related models.", addmodlist, addrolelist)

Debug.Print DiagramManager.GetLastErrorString

End Sub

See Also

Projects Collection


%%PageItemTitle%%

Remove Method
Name

Description

Remove Project object specified by the given name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

Projects Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Project object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Project

Parameters

Identifier

See Also

Projects Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Projects Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Project objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Projects Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Project object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Project

Parameters

Identifier

See Also

Projects Collection


%%PageItemTitle%%

ReferenceValue Object
See Also Members

Description

This object represents a reference value in ER/Studio.

Object Model

See Also

ReferenceValue Members


%%PageItemTitle%% $$Members$$

ReferenceValue Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this reference value.
Public Method BoundObjects | Returns a collection of bindings that link the default to attributes.
Public Method RepoCheckOutStatus | Get the Check Out status of this ReferenceValue object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this reference value.
Public Method Values | Get the Values and ValueDescriptions of this ReferenceValue and return them in a collection.

Public Properties

Public Property Description | This is the description of the reference value. DATATYPE: String.
Public Property DictionaryName | This is the name of the Dictionary this object is part of. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary this object is part of is enterprise level. DATATYPE: Boolean.
Public Property GUID | GUID of the ReferenceValue. GUIDs are unique IDs assigned by ER/Studio. DATATYPE: String.
Public Property ID | Returns the reference value ID. DATATYPE: Integer.
Public Property IsNotBetween | True if not in between, false otherwise. DATATYPE: Boolean.
Public Property IsRange | True if it is a range. DATATYPE: Boolean.
Public Property MaxValue | This is the maximum value of the reference value. DATATYPE: String.
Public Property MinValue | This is the minimum value of the reference value. DATATYPE: String.
Public Property Name | This is the name of the reference value. DATATYPE: String.

See Also

ReferenceValue Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this reference value.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

ReferenceValue Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the default to attributes.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

ReferenceValue Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this ReferenceValue object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this reference value.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

ReferenceValue Object


%%PageItemTitle%%

Values Method

Description

Get the Values and ValueDescriptions of this ReferenceValue and return them in a collection.

Syntax

Visual Basic
Public Function Values() As Values

See Also

ReferenceValue Object


%%PageItemTitle%%

Description Property

Description

This is the description of the reference value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary this object is part of. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary this object is part of is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

GUID Property

Description

GUID of the ReferenceValue. GUIDs are unique IDs assigned by ER/Studio. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

ID Property

Description

Returns the reference value ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

IsNotBetween Property

Description

True if not in between, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsNotBetween() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

IsRange Property

Description

True if it is a range. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsRange() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

MaxValue Property

Description

This is the maximum value of the reference value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxValue() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

MinValue Property

Description

This is the minimum value of the reference value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinValue() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

Name Property

Description

This is the name of the reference value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

ReferenceValue Object


%%PageItemTitle%%

ReferenceValues Collection
See Also Members

Description

This object represents a collection of ReferenceValues. The owner of this collection is the data dictionary.

Object Model

See Also

ReferenceValues Members


%%PageItemTitle%% $$Members$$

ReferenceValues Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns new ReferenceValue, adds it to collection. PARAMETERS: Name, Description, Value, ValueDescription, MinValue, MaxValue as Strings, IsNotBetween, IsRange as booleans.
Public Method Remove | Deletes a reference value object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a ReferenceValue object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of reference value objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ReferenceValue object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

ReferenceValues Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates and returns new ReferenceValue, adds it to collection. PARAMETERS: Name, Description, Value, ValueDescription, MinValue, MaxValue as Strings, IsNotBetween, IsRange as booleans.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As ReferenceValue

Parameters

Name

See Also

ReferenceValues Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a reference value object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ReferenceValues Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ReferenceValue object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ReferenceValue

Parameters

Identifier

See Also

ReferenceValues Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ReferenceValues Collection


%%PageItemTitle%%

Count Property

Description

This is the number of reference value objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ReferenceValues Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ReferenceValue object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ReferenceValue

Parameters

Identifier

See Also

ReferenceValues Collection


%%PageItemTitle%%

Relationship Object
See Also Members

Description

This object represents a relationship in ER/Studio.

Object Model

See Also

Relationship Members


%%PageItemTitle%% $$Members$$

Relationship Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Relationship.
Public Method ChildAction | Returns the child action of the given type. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The return action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS: ActionType as String. RETURN DATATYPE: String.
Public Method FKColumnPairs | Returns an object representing a collection of all foreign key column pairs maintained by the relationship.
Public Method ParentAction | Returns the parent action of the given type. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The return action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS: ActionType as String. RETURN DATATYPE: String.
Public Method RepoCheckOutStatus | Get the Check Out status of this Relationship object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this Relationship from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method SetChildAction | Sets the child action of the given type with the given action. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS: ActionType as String, ActionName as String.
Public Method SetParentAction | Sets the parent action of the given type with the given action. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS:ActionType as String, ActionName as String.
Public Method UserComments | Returns a collection of user comments associated with this Relationship.

Public Properties

Public Property BusinessName | This is the business name of the relationship. DATATYPE: String.
Public Property CardinalityNo | This is the Child Cardinality No of the relationship: Zero or One to Zero or More = 0, Zero or One to One or More = 1, Zero or One to Zero or One = 2, Zero or One to exactly N = 3. DATATYPE: Integer.
Public Property CardinalityValue | This is the Cardinality Value of the relationship when the Cardinality No is 3 (Zero or One to exactly N). DATATYPE: Integer.
Public Property ChildEntity | This is the child entity of the relationship.
Public Property DB2OSNotEnforced | This property specifies if a relationship is enforced or not enforced. It applies only to DB2 OS390 V8 or later versions of the platform. DATATYPE: Boolean.
Public Property Deferrable | If true, the FK constriant check can be deferred to the end of the transaction. DATATYPE: Boolean.
Public Property Definition | This is the definition of the relationship. DATATYPE: String.
Public Property Disable | Applies to Oracle platforms. Determines if the FK constraint is disabled (true) or enabled (false). When set to false, the corresponding PK is also set to false. DATATYPE: Boolean.
Public Property DoNotGenerate | If true, the Foreign Key Constraint will not be generated in the DDL of the Child Entity. DATATYPE: Boolean.
Public Property GUID | GUID of the relationship. This GUID is assigned by ER/Studio. Each relationship has a unique GUID. DATATYPE: String.
Public Property ID | ID of the relationship. This ID is assigned by ER/Studio. Each relationship in a diagram has a unique ID. DATATYPE: Integer.
Public Property InitiallyDeferred | If true, the FK constriant check is Initially Deferred. DATATYPE: Boolean.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property InversePhrase | This is the inverse verb phrase of the relationship. DATATYPE: String.
Public Property LogOrPhysOnly | Controls the logical/physical only Relationship Property. DATATYPE: Boolean.
Public Property Mandatory | This determines if the relationship is mandatory (true) or not (false). DATATYPE: Boolean.
Public Property Name | This is the name of the relationship. DATATYPE: String.
Public Property NOCHECK | Applies to SQL Server 2005, SQL Server 2008, Teradata v2R6, Teradata 12.0 platforms. Determines if the FK constraint is disabled (true) or enabled (false). DATATYPE: Boolean.
Public Property Note | This the note of the relationship. DATATYPE: String.
Public Property NotForReplication | This property specifies if a FK constraint is checked for replication. It applies only to MS SQL Server 2000 or later versions. DATATYPE: Boolean.
Public Property NoValidate | Applies to Oracle platforms. Determines if the FK constraint is NoValidate (true) or Validate (false). DATATYPE: Boolean.
Public Property OptionalityValue | This the Optionality of the Relationship. Optional = 0. Mandatory = 1. DATATYPE: Integer.
Public Property ParentEntity | This is the parent entity of the relationship.
Public Property ParentKeyID | ID of the relationship's parent index. Zero for this property indicates Primary Key. To set the relationship to use the PK, please assign zero. DATATYPE: Integer.
Public Property Type | This is the type of the relationship. The relationship types are: Identifying - 0, NonIdentifying - 1, NonSpecific - 2, NonIdentifying Optional - 3, Containment - 8(MongoDB Only). DATATYPE: Integer.
Public Property VerbPhrase | This is the verb phrase of the relationship. DATATYPE: String.

See Also

Relationship Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Relationship.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Relationship Object


%%PageItemTitle%%

ChildAction Method
ActionType

Description

Returns the child action of the given type. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The return action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS: ActionType as String. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function ChildAction( _
   ByVal ActionType As Variant _
) As Variant

Parameters

ActionType

Example

Dim MyRelationship As Relationship

Dim strActionType As String

MyRelationship.ChildAction (strActionType)

See Also

Relationship Object


%%PageItemTitle%%

FKColumnPairs Method

Description

Returns an object representing a collection of all foreign key column pairs maintained by the relationship.

Syntax

Visual Basic
Public Function FKColumnPairs() As FKColumnPairs

Example

Dim MyRelationship As Relationship

Dim MyFKColumnPair As FKColumnPair

For Each MyFKColumnPair In MyRelationship.FKColumnPairs

...

...

Next MyFKColumnPair

See Also

Relationship Object


%%PageItemTitle%%

ParentAction Method
ActionType

Description

Returns the parent action of the given type. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The return action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS: ActionType as String. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function ParentAction( _
   ByVal ActionType As Variant _
) As Variant

Parameters

ActionType

Example

Dim MyRelationship As Relationship

Dim strActionType As String

MyRelationship.ParentAction (strActionType)

See Also

Relationship Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Relationship object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Relationship Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this Relationship from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

Relationship Object


%%PageItemTitle%%

SetChildAction Method
ActionType
ActionName

Description

Sets the child action of the given type with the given action. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS: ActionType as String, ActionName as String.

Syntax

Visual Basic
Public Sub SetChildAction( _
   ByVal ActionType As Variant, _
   ByVal ActionName As Variant _
)

Parameters

ActionType
ActionName

Example

Dim MyRelationship As Relationship

Dim strActionType As String

Dim strActionName As String

' Select from possible action types and names

strActionType = UPDATE

strActionName = NONE

MyRelationship.SetChildAction (strActionType, strActionName)

See Also

Relationship Object


%%PageItemTitle%%

SetParentAction Method
ActionType
ActionName

Description

Sets the parent action of the given type with the given action. The action types are 'INSERT', 'UPDATE' or 'DELETE'. The action names are 'NONE', 'RESTRICT', 'CASCADE', 'SETNULL' or 'SETDEFAULT'. PARAMETERS:ActionType as String, ActionName as String.

Syntax

Visual Basic
Public Sub SetParentAction( _
   ByVal ActionType As Variant, _
   ByVal ActionName As Variant _
)

Parameters

ActionType
ActionName

Example

Dim MyRelationship As Relationship

Dim strActionType As String

Dim strActionName As String

' Select from possible action types and names

strActionType = UPDATE

strActionName = NONE

MyRelationship.SetParentAction (strActionType, strActionName)

See Also

Relationship Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Relationship.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Relationship Object


%%PageItemTitle%%

BusinessName Property

Description

This is the business name of the relationship. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BusinessName() As Variant

See Also

Relationship Object


%%PageItemTitle%%

CardinalityNo Property

Description

This is the Child Cardinality No of the relationship: Zero or One to Zero or More = 0, Zero or One to One or More = 1, Zero or One to Zero or One = 2, Zero or One to exactly N = 3. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CardinalityNo() As Variant

Remarks

Values may be:

Mandatory:

One to Zero or More = 0

One to One or More = 1
One to Zero or One = 2
One to Exactly N = 3
Optional:
Zero or One to Zero or More = 0
Zero or One to One or More = 1
Zero or One to Zero or One = 2
One to Exactly N = 3

Example

Sub Main

Dim d As Diagram

Dim m As Model

Dim rel As Relationship

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

'Force every Relationship to be Mandatory and One-To-One or More

For Each rel In m.Relationships

rel. = 1

rel.CardinalityNo = 1

Next rel

End Sub

See Also

Relationship Object


%%PageItemTitle%%

CardinalityValue Property

Description

This is the Cardinality Value of the relationship when the Cardinality No is 3 (Zero or One to exactly N). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CardinalityValue() As Variant

See Also

Relationship Object


%%PageItemTitle%%

ChildEntity Property

Description

This is the child entity of the relationship.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChildEntity() As Entity

Example

Dim MyRelationship As Relationship

Dim ChEntity As Entity

Set ChEntity = MyRelationship.ChildEntity

See Also

Relationship Object


%%PageItemTitle%%

DB2OSNotEnforced Property

Description

This property specifies if a relationship is enforced or not enforced. It applies only to DB2 OS390 V8 or later versions of the platform. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DB2OSNotEnforced() As Variant

See Also

Relationship Object


%%PageItemTitle%%

Deferrable Property

Description

If true, the FK constriant check can be deferred to the end of the transaction. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Deferrable() As Variant

See Also

Relationship Object


%%PageItemTitle%%

Definition Property

Description

This is the definition of the relationship. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

Example

Dim MyRelationship As Relationship

Dim RelDef As String

MyRelationship.Definition = RelDef

See Also

Relationship Object


%%PageItemTitle%%

Disable Property

Description

Applies to Oracle platforms. Determines if the FK constraint is disabled (true) or enabled (false). When set to false, the corresponding PK is also set to false. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Disable() As Variant

See Also

Relationship Object


%%PageItemTitle%%

DoNotGenerate Property

Description

If true, the Foreign Key Constraint will not be generated in the DDL of the Child Entity. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DoNotGenerate() As Variant

See Also

Relationship Object


%%PageItemTitle%%

GUID Property

Description

GUID of the relationship. This GUID is assigned by ER/Studio. Each relationship has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Relationship Object


%%PageItemTitle%%

ID Property

Description

ID of the relationship. This ID is assigned by ER/Studio. Each relationship in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyRelationship As Relationship

Dim RelID As Integer

MyRelationship.ID = RelID

See Also

Relationship Object


%%PageItemTitle%%

InitiallyDeferred Property

Description

If true, the FK constriant check is Initially Deferred. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitiallyDeferred() As Variant

See Also

Relationship Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

Relationship Object


%%PageItemTitle%%

InversePhrase Property

Description

This is the inverse verb phrase of the relationship. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property InversePhrase() As Variant

Example

Dim MyRelationship As Relationship

Dim InvPhrase As String

MyRelationship.InversePhrase = InvPhrase

See Also

Relationship Object


%%PageItemTitle%%

LogOrPhysOnly Property

Description

Controls the logical/physical only Relationship Property. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogOrPhysOnly() As Variant

See Also

Relationship Object


%%PageItemTitle%%

Mandatory Property

Description

This determines if the relationship is mandatory (true) or not (false). DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property Mandatory() As Variant

Example

Dim MyRelationship As Relationship

Dim bMandatory As String

MyRelationship.Mandatory = bMandatory

See Also

Relationship Object


%%PageItemTitle%%

Name Property

Description

This is the name of the relationship. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

Example

Dim MyRelationship As Relationship

Dim RelName As String

MyRelationship.Name = RelName

See Also

Relationship Object


%%PageItemTitle%%

NOCHECK Property

Description

Applies to SQL Server 2005, SQL Server 2008, Teradata v2R6, Teradata 12.0 platforms. Determines if the FK constraint is disabled (true) or enabled (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NOCHECK() As Variant

See Also

Relationship Object


%%PageItemTitle%%

Note Property

Description

This the note of the relationship. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Note() As Variant

Example

Dim MyRelationship As Relationship

Dim RelNote As String

MyRelationship.Note = RelNote

See Also

Relationship Object


%%PageItemTitle%%

NotForReplication Property

Description

This property specifies if a FK constraint is checked for replication. It applies only to MS SQL Server 2000 or later versions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NotForReplication() As Variant

See Also

Relationship Object


%%PageItemTitle%%

NoValidate Property

Description

Applies to Oracle platforms. Determines if the FK constraint is NoValidate (true) or Validate (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoValidate() As Variant

See Also

Relationship Object


%%PageItemTitle%%

OptionalityValue Property

Description

This the Optionality of the Relationship. Optional = 0. Mandatory = 1. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property OptionalityValue() As Variant

Example

Sub Main

Dim d As Diagram

Dim m As Model

Dim rel As Relationship

Set d = DiagramManager.ActiveDiagram

Set m = d.ActiveModel

'Force every Relationship to be Mandatory and One-To-One or More

For Each rel In m.Relationships

rel.OptionalityValue = 1

rel.CardinalityNo = 1

Next rel

End Sub

See Also

Relationship Object


%%PageItemTitle%%

ParentEntity Property

Description

This is the parent entity of the relationship.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentEntity() As Entity

Example

Dim MyRelationship As Relationship

Dim ParEntity As Entity

Set ParEntity = MyRelationship.ParentEntity

See Also

Relationship Object


%%PageItemTitle%%

ParentKeyID Property

Description

ID of the relationship's parent index. Zero for this property indicates Primary Key. To set the relationship to use the PK, please assign zero. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ParentKeyID() As Variant

See Also

Relationship Object


%%PageItemTitle%%

Type Property

Description

This is the type of the relationship. The relationship types are: Identifying - 0, NonIdentifying - 1, NonSpecific - 2, NonIdentifying Optional - 3, Containment - 8(MongoDB Only). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

Example

Dim MyRelationship As Relationship

Dim RelType As Integer

MyRelationship.Type = RelType

or

' Sets the type of the relationship

Dim MyRelationship As Relationship

Dim RelType As Integer

' O indicates an identifying relationship

RelType = 0

MyRelationship.Type = RelType

See Also

Relationship Object


%%PageItemTitle%%

VerbPhrase Property

Description

This is the verb phrase of the relationship. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerbPhrase() As Variant

Example

Dim MyRelationship As Relationship

Dim VbPhrase As String

MyRelationship.VerbPhrase = VbPhrase

See Also

Relationship Object


%%PageItemTitle%%

RelationshipDisplay Object
See Also Members

Description

This object represents a relationship display object in ER/Studio. A relationship display object is a graphical representation of a relationship in a specific submodel - it is not a relationship itself.

See Also

RelationshipDisplay Members


%%PageItemTitle%% $$Members$$

RelationshipDisplay Object Members
See Also Overview

Public Methods

Public Method ParentRelationship | Get the parent Relationship of this RelationshipDisplay. DATATYPE: Relationship.
Public Method RepoCheckOutStatus | Get the Check Out status of this RelationshipDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this RelationshipDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property Color | This is the color of the relationship display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).
Public Property ElbowPosition | This is the elbow position (position of the middle line segment when the relationship is drawn in rectilinear line mode) of the relationship. DATATYPE: Integer.
Public Property GUID | GUID of the relationship display object. This GUID is assigned by ER/Studio. Each relationship display object has a unique GUID. DATATYPE: String.
Public Property HorizontalBusinessNameOffset | This is the x coordinate of the business name. DATATYPE: Integer.
Public Property HorizontalInverseOffset | This is the x coordinate of the inverse verb. DATATYPE: Integer.
Public Property HorizontalNameOffset | This is the x coordinate of the name. DATATYPE: Integer.
Public Property HorizontalVerbOffset | This is the x coordinate of the verb. DATATYPE: Integer.
Public Property ID | ID of the relationship display object. This ID is assigned by ER/Studio. Each relationship display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property VerticalBusinessNameOffset | This is the y coordinate of the business name. DATATYPE: Integer.
Public Property VerticalInverseOffset | This is the y coordinate of the inverse verb. DATATYPE: Integer.
Public Property VerticalNameOffset | This is the y coordinate of the name. DATATYPE: Integer.
Public Property VerticalVerbOffset | This is the y coordinate of the verb. DATATYPE: Integer.

See Also

RelationshipDisplay Overview


%%PageItemTitle%%

ParentRelationship Method

Description

Get the parent Relationship of this RelationshipDisplay. DATATYPE: Relationship.

Syntax

Visual Basic
Public Function ParentRelationship() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this RelationshipDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this RelationshipDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

Color Property

Description

This is the color of the relationship display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

ElbowPosition Property

Description

This is the elbow position (position of the middle line segment when the relationship is drawn in rectilinear line mode) of the relationship. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ElbowPosition() As Variant

Example

Dim MyRelationshipDisplay As RelationshipDisplay

Dim ElboPo As Integer

MyRelationshipDisplay.ElbowPosition = ElboPo

or

' Sets the elbow position of the relationship

Dim MyRelationshipDisplay As RelationshipDisplay

Dim ElboPo As Integer

ElboPo = 25

MyRelationshipDisplay.ElbowPosition = ElboPo

See Also

RelationshipDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the relationship display object. This GUID is assigned by ER/Studio. Each relationship display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

HorizontalBusinessNameOffset Property

Description

This is the x coordinate of the business name. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalBusinessNameOffset() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

HorizontalInverseOffset Property

Description

This is the x coordinate of the inverse verb. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalInverseOffset() As Variant

Example

Dim MyRelationshipDisplay As RelationshipDisplay

Dim HorizInvOff As Integer

MyRelationshipDisplay.HorizontalInverseOffset = HorizInvOff

or

' Sets the x coordinate of the inverse verb

Dim MyRelationshipDisplay As RelationshipDisplay

Dim HorizInvOff As Integer

HorizInvOff = 125

MyRelationshipDisplay.HorizontalInverseOffset = HorizInvOff

See Also

RelationshipDisplay Object


%%PageItemTitle%%

HorizontalNameOffset Property

Description

This is the x coordinate of the name. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalNameOffset() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

HorizontalVerbOffset Property

Description

This is the x coordinate of the verb. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalVerbOffset() As Variant

Example

Dim MyRelationshipDisplay As RelationshipDisplay Dim HorizVerbOff As Integer

MyRelationshipDisplay.HorizontalVerbOffset = HorizVerbOff

or

' Sets the x coordinate of the verb

Dim MyRelationshipDisplay As RelationshipDisplay

Dim HorizVerbOff As Integer

HorizVerbOff = 125

MyRelationshipDisplay.HorizontalVerbOffset = HorizVerbOff

See Also

RelationshipDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the relationship display object. This ID is assigned by ER/Studio. Each relationship display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyRelationshipDisplay As RelationshipDisplay

Dim MyRelDispID As Integer

MyRelDispID = MyRelationshipDisplay.ID

See Also

RelationshipDisplay Object


%%PageItemTitle%%

VerticalBusinessNameOffset Property

Description

This is the y coordinate of the business name. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalBusinessNameOffset() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

VerticalInverseOffset Property

Description

This is the y coordinate of the inverse verb. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalInverseOffset() As Variant

Example

Dim MyRelationshipDisplay As RelationshipDisplay

Dim VertInvOff As Integer

MyRelationshipDisplay.VerticalInverseOffset = VertInvOff

or

' Sets the y coordinate of the inverse verb

Dim MyRelationshipDisplay As RelationshipDisplay

Dim VertInvOff As Integer

VertInvOff = 125

MyRelationshipDisplay.VerticalInverseOffset = VertInvOff

See Also

RelationshipDisplay Object


%%PageItemTitle%%

VerticalNameOffset Property

Description

This is the y coordinate of the name. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalNameOffset() As Variant

See Also

RelationshipDisplay Object


%%PageItemTitle%%

VerticalVerbOffset Property

Description

This is the y coordinate of the verb. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalVerbOffset() As Variant

Example

Dim MyRelationshipDisplay As RelationshipDisplay

Dim VertVerbOff As Integer

MyRelationshipDisplay.VerticalVerbOffset = VertVerbOff

or

' Sets the y coordinate of the verb

Dim MyRelationshipDisplay As RelationshipDisplay

Dim VertVerbOff As Integer

VertVerbOff = 125

MyRelationshipDisplay.VerticalVerbOffset = VertVerbOff

See Also

RelationshipDisplay Object


%%PageItemTitle%%

RelationshipDisplays Collection
See Also Members

Description

This object represents a collection of relationship display objects. The owner of this collection is the submodel.

Object Model

See Also

RelationshipDisplays Members


%%PageItemTitle%% $$Members$$

RelationshipDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new RelationshipDisplay from the Relationship identified by the given ID, and returns the new RelationshipDisplay. PARAMETERS: RelationshipID as Integer.
Public Method Remove | Deletes a RelationshipDisplay object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a RelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of RelationshipDisplay objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a RelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

RelationshipDisplays Overview


%%PageItemTitle%%

Add Method
RelationshipID

Description

Creates a new RelationshipDisplay from the Relationship identified by the given ID, and returns the new RelationshipDisplay. PARAMETERS: RelationshipID as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal RelationshipID As Variant _
) As RelationshipDisplay

Parameters

RelationshipID

See Also

RelationshipDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a RelationshipDisplay object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

RelationshipDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a RelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As RelationshipDisplay

Parameters

Identifier

See Also

RelationshipDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

RelationshipDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of RelationshipDisplay objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

RelationshipDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a RelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As RelationshipDisplay

Parameters

Identifier

See Also

RelationshipDisplays Collection


%%PageItemTitle%%

Relationships Collection
See Also Members

Description

This object represents a collection of relationships. The owner of this collection is the model.

Object Model

See Also

Relationships Members


%%PageItemTitle%% $$Members$$

Relationships Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a relationship. The relationship types are: Identifying - 0, NonIdentifying - 1, NonSpecific - 2, NonIdentifying Optional - 3, Containment(MongoDB Only) - 8. PARAMETERS: ParentEntity as String or Integer, ChildEntity as String or Integer, RelationshipT?U?K??
Public Method AddWithRoleName | PCreates a relationship. Relationship types: Identifying-0, NonIdentifying-1, NonSpecific-2, NonIdentifyingOptional-3, Containment(MongoDB Only) - 8. ARAMETERS: ParentEntity as String or Integer, ChildEntity as String or Integer, RelationshipType as Integer, P?U?K??
Public Method AddWithUnification | Creates a relationship. The relationship types are: Identifying - 0, NonIdentifying - 1, NonSpecific - 2, NonIdentifying Optional - 3, Containment(MongoDB Only) - 8. PARAMETERS: ParentEntity as String or Integer, ChildEntity as String or Integer, RelationshipT?U?K??
Public Method Remove | Deletes a Relationship object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.
Public Method RemoveWithMakeFKsNative | Deletes specified Relationship with Make FKs Native Option enabled. FK columns in Child Tables will not be deleted, but will become native columns. PARAMETERS: Identifier (String/Integer).

Public Properties

Public Property _Item | Returns a Relationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Relationship objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Relationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Relationships Overview


%%PageItemTitle%%

Add Method
ParentEntity
ChildEntity
RelationshipType

Description

Creates a relationship. The relationship types are: Identifying - 0, NonIdentifying - 1, NonSpecific - 2, NonIdentifying Optional - 3, Containment(MongoDB Only) - 8. PARAMETERS: ParentEntity as String or Integer, ChildEntity as String or Integer, RelationshipT?U?K??

Syntax

Visual Basic
Public Function Add( _
   ByVal ParentEntity As Variant, _
   ByVal ChildEntity As Variant, _
   ByVal RelationshipType As Variant _
) As Relationship

Parameters

ParentEntity
ChildEntity
RelationshipType

Example

Dim MyModel As Model

Dim MyRel As Relationship

Dim strParent As String

Dim strChild As String

Dim RelType As Integer

' Naming the parent and child in the relationship

' Setting RelType to 5 indicates that the relationship type is mandatory

strParent = "authors"

strChild = "titles"

RelType = 5

Set MyRel = MyModel.Relationships.Add(strParent, strChild, RelType)

See Also

Relationships Collection


%%PageItemTitle%%

AddWithRoleName Method
ParentEntity
ChildEntity
RelationshipType
PKPairList

Description

PCreates a relationship. Relationship types: Identifying-0, NonIdentifying-1, NonSpecific-2, NonIdentifyingOptional-3, Containment(MongoDB Only) - 8. ARAMETERS: ParentEntity as String or Integer, ChildEntity as String or Integer, RelationshipType as Integer, P?U?K??

Syntax

Visual Basic
Public Function AddWithRoleName( _
   ByVal ParentEntity As Variant, _
   ByVal ChildEntity As Variant, _
   ByVal RelationshipType As Variant, _
   ByVal PKPairList As Variant _
) As Relationship

Parameters

ParentEntity
ChildEntity
RelationshipType
PKPairList

Remarks

PKPairList syntax/rules:
  1. Each PKPairList string should be in this format "PKname1,RoleName1;PKName2,RoleName2" . PKName is the Primary Key Attribute/Column name of the Parent Entity, and the RoleName is the RoleName to use in the propagated ForeignKey. PKName and RoleName are comma separated and each pair is separated by a semi-colon.
  2. There is an escape character "\" so that you can use the separator characters inside the names. All other letters are alright to use as long as SaxBasic allows you to enter it into the parameter string. Example: Column,Role;Name has to be input as Column\,Role\;Name
  3. PK names are strictly enforced. It is case sensitive. The name has to be entered the way it is used in the model.
  4. Any PK Column Names that donʼt match to any of the Primary Keys of the ParentEntity will be automatically disregarded.
The PKPairList must follow these rules strictly. Any deviation from it will make the Relationship creation fail. Check the returned Relationship for a valid ID. Zero indicates that creation failed. In Automation, this function works well for Recursive Relationship creation because it can automatically RoleName the Foreign Keys.

Example

Sub Main

Dim diag As Diagram

Dim mod As Model

Dim rels As Relationships

Dim newrel As Relationship

Set diag = DiagramManager.ActiveDiagram

Set mod = diag.ActiveModel

Set rels = mod.Relationships

'Recursive relationship

'Entity1 or Entity2 can be specified as tablename, owner.tablename, or ID.

Set newrel = rels.AddWithRoleName("Entity1", "Entity1", 1," attr1,attr1_role; col1, col1_role")

If newrel.ID <> 0 Then

MsgBox("Succesfully added new Relationship")

End If

End Sub

See Also

Relationships Collection


%%PageItemTitle%%

AddWithUnification Method
ParentEntity
ChildEntity
RelationshipType

Description

Creates a relationship. The relationship types are: Identifying - 0, NonIdentifying - 1, NonSpecific - 2, NonIdentifying Optional - 3, Containment(MongoDB Only) - 8. PARAMETERS: ParentEntity as String or Integer, ChildEntity as String or Integer, RelationshipT?U?K??

Syntax

Visual Basic
Public Function AddWithUnification( _
   ByVal ParentEntity As Variant, _
   ByVal ChildEntity As Variant, _
   ByVal RelationshipType As Variant _
) As Relationship

Parameters

ParentEntity
ChildEntity
RelationshipType

See Also

Relationships Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Relationship object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

Example

Dim MyModel As Model

Dim MyRel As Relationship

Dim RelID As Integer

' We want the relationship with 2 as the ID

RelID = 2

MyModel.Relationships.Remove(RelID)

See Also

Relationships Collection


%%PageItemTitle%%

RemoveWithMakeFKsNative Method
Identifier

Description

Deletes specified Relationship with Make FKs Native Option enabled. FK columns in Child Tables will not be deleted, but will become native columns. PARAMETERS: Identifier (String/Integer).

Syntax

Visual Basic
Public Sub RemoveWithMakeFKsNative( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Relationships Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Relationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Relationship

Parameters

Identifier

See Also

Relationships Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Relationships Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Relationship objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

Example

Dim MyModel As Model

Dim iCount As Integer

MyModel.Relationships.Count = iCount

See Also

Relationships Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Relationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Relationship

Parameters

Identifier

Example

Dim MyModel As Model

Dim MyRel As Relationship

Dim RelID As Integer

' Looking for the relationship with 2 as the ID

RelID = 2

Set MyRel = MyModel.Relationships.Item(RelID)

See Also

Relationships Collection


%%PageItemTitle%%

RepoSubmodel Object
See Also Members

Description

This object does NOT represents a submodel object in ER/Studio. It represents the combination of model name, submodel name referencing a submodel belonging to a diagram that exists in the repository.

See Also

RepoSubmodel Members


%%PageItemTitle%% $$Members$$

RepoSubmodel Object Members
See Also Overview

Public Properties

Public Property ModelName | Name of the Model to which the submodel belongs. DATATYPE: String.
Public Property SubmodelName | Name of the submodel. DATATYPE: String.

See Also

RepoSubmodel Overview


%%PageItemTitle%%

ModelName Property

Description

Name of the Model to which the submodel belongs. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ModelName() As Variant

See Also

RepoSubmodel Object


%%PageItemTitle%%

SubmodelName Property

Description

Name of the submodel. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubmodelName() As Variant

See Also

RepoSubmodel Object


%%PageItemTitle%%

RepoSubmodels Collection
See Also Members

Description

This object represents a collection of RepoSubmodels (i.e. model/submodel name combinations of submodels belonging to the diagram represented by this collection. The owner of this collection is the diagram manager.

Object Model

See Also

RepoSubmodels Members


%%PageItemTitle%% $$Members$$

RepoSubmodels Collection Members
See Also Overview

Public Methods

Public Method RepoGetSubmodel Gets the submodel from the Repository (and checks it out (exclusively)). Returns 1 on success, 0 otherwise. PARAMETERS: Model (String), Submodel (String), CheckOut (Boolean), Exclusive (Boolean). RETURN DATATYPE: Integer.

Public Properties

Public Property _NewEnum |
Public Property Count | This is the number of Submodels belonging to the diagram represented by this collection. DATATYPE: Integer.
Public Property DialogName | Name of the Diagram containing the submodels contained in this collection. DATATYPE: String.
Public Property Item | Returns a RepoSubmodel object. PARAMETERS: ModelName (String), SubmodelName (String).

See Also

RepoSubmodels Overview


%%PageItemTitle%%

RepoGetSubmodel Method
Model
SubModel
CheckOut
Exclusive

Description

Gets the submodel from the Repository (and checks it out (exclusively)). Returns 1 on success, 0 otherwise. PARAMETERS: Model (String), Submodel (String), CheckOut (Boolean), Exclusive (Boolean). RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function RepoGetSubmodel( _
   ByVal Model As Variant, _
   ByVal SubModel As Variant, _
   ByVal CheckOut As Variant, _
   ByVal Exclusive As Variant _
) As Variant

Parameters

Model
SubModel
CheckOut
Exclusive

See Also

RepoSubmodels Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

RepoSubmodels Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Submodels belonging to the diagram represented by this collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

RepoSubmodels Collection


%%PageItemTitle%%

DialogName Property

Description

Name of the Diagram containing the submodels contained in this collection. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DialogName() As Variant

See Also

RepoSubmodels Collection


%%PageItemTitle%%

Item Property
ModelName
SubmodelName

Description

Returns a RepoSubmodel object. PARAMETERS: ModelName (String), SubmodelName (String).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal ModelName As Variant, _
   ByVal SubmodelName As Variant _
) As RepoSubmodel

Parameters

ModelName
SubmodelName

See Also

RepoSubmodels Collection


%%PageItemTitle%%

ReverseEngineer Object
See Also Members

Description

This object represent the ReverseEngineer object in ER/Studio.

Object Model

See Also

ReverseEngineer Members


%%PageItemTitle%% $$Members$$

ReverseEngineer Object Members
See Also Overview

Public Methods

Public Method DoReverseEngineer | Executes the reverse-engineer process with the specified properties. RETURN DATATYPE: Diagram.
Public Method GetDatabaseList | Returns a StringObject collection of the databases to be reverse-engineered.
Public Method GetObjectOwnerList | Returns a StringObject collection of the owners of objects to be reverse-engineered.
Public Method SetDatabaseList | Set the databases to be reverse-engineered. PARAMETERS: StringObjects.
Public Method SetObjectOwnerList | Set the owners of the objects that are to be reverse-engineered. PARAMETERS: StringObjects.

Public Properties

Public Property Alias | Specifies whether or not to reverse-engineer alias. DATATYPE: Boolean.
Public Property ConnectionType | The connection type. Valid types are 'Native' and 'ODBC'. DATATYPE: String.
Public Property ConnectString | The reverse engineer use this string to connect to database when the connection type is Native. DATATYPE: String.
Public Property Database | The database to be reverse-engineered. It applies only if the source DBMS is SQL Server or Sybase. DATATYPE: String.
Public Property Datasource | If the ConnectionType is 'ODBC', this property designates the ODBC datasource name. If ConnectionType is 'Native', this is the server name or connection string required to connect to the DBMS server. DATATYPE: String.
Public Property DBMSType | The DBMS type for a Native ConnectionType. Valid values are 'Oracle', 'Sybase', 'SQL Server' and 'DB2'. If the ConnectionType is ODBC, this property is ignored. DATATYPE: String.
Public Property IgnoreIndexPartitions | Specifies whether or not reverse-engineer index partitions. DATATYPE: Boolean.
Public Property IgnoreTablePartitions | Specifies whether or not reverse-engineer table partitions. DATATYPE: Boolean.
Public Property InferDomains | Specifies whether or not to infer domains. Default is FALSE. DATATYPE: Boolean.
Public Property InferFKByIndex | Specifies whether or not to infer Foreign Keys based on indexes. Default is FALSE. DATATYPE: Boolean.
Public Property InferFKByName | Specifies whether or not to infer Foreign Keys based on names. Default is FALSE. DATATYPE: Boolean.
Public Property InferPK | Specifies whether or not to infer Primary Keys. Default is FALSE. DATATYPE: Boolean.
Public Property MaterializedViews | Specifies whether or not to reverse-engineer Materialized Views. DATATYPE: Boolean.
Public Property ObjectOwner | The owner of the objects. If the database type is SQL Server or Sybase, the default is 'dbo'. For other platforms, the defalt is UserName. DATATYPE: String.
Public Property ObjectTypes | Specifies whether or not to reverse-engineer object types. DATATYPE: Boolean.
Public Property Packages | Specifies whether or not to reverse-engineer packages. DATATYPE: Boolean.
Public Property Password | The password for the database connection. DATATYPE: String.
Public Property Procedures | Specifies whether or not to reverse-engineer stored procedures. Default is FALSE. DATATYPE: Boolean.
Public Property QuickLaunchFile | Specifies the quick launch file that will be used to do the reverse-engineer. DATATYPE: String.
Public Property Sequences | Specifies whether or not to reverse-engineer Sequences. DATATYPE: Boolean.
Public Property ShowStatus | This property determines whether to display the status dialog. DATATYPE: Boolean.
Public Property StorageObjects | Specifies whether or not to reverse-engineer storage objects. DATATYPE: Boolean.
Public Property Synonyms | Specifies whether or not to reverse-engineer Synonyms. DATATYPE: Boolean.
Public Property SystemTables | Specifies whether or not to reverse-engineer system tables. Default is FALSE. DATATYPE: Boolean.
Public Property SystemViews | Specifies whether or not to reverse-engineer system views. Default is FALSE. DATATYPE: Boolean.
Public Property Triggers | Specifies whether or not to reverse-engineer triggers. Default is FALSE. DATATYPE: Boolean.
Public Property Username | The login name for the database connection. DATATYPE: String.
Public Property UserTables | Specifies whether or not to reverse-engineer user tables. Default is TRUE. DATATYPE: Boolean.
Public Property UserViews | Specifies whether or not to reverse-engineer user views. Default is FALSE. DATATYPE: Boolean.

See Also

ReverseEngineer Overview


%%PageItemTitle%%

DoReverseEngineer Method

Description

Executes the reverse-engineer process with the specified properties. RETURN DATATYPE: Diagram.

Syntax

Visual Basic
Public Function DoReverseEngineer() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

GetDatabaseList Method

Description

Returns a StringObject collection of the databases to be reverse-engineered.

Syntax

Visual Basic
Public Function GetDatabaseList() As StringObjects

See Also

ReverseEngineer Object


%%PageItemTitle%%

GetObjectOwnerList Method

Description

Returns a StringObject collection of the owners of objects to be reverse-engineered.

Syntax

Visual Basic
Public Function GetObjectOwnerList() As StringObjects

See Also

ReverseEngineer Object


%%PageItemTitle%%

SetDatabaseList Method
Owners

Description

Set the databases to be reverse-engineered. PARAMETERS: StringObjects.

Syntax

Visual Basic
Public Sub SetDatabaseList( _
   ByVal Owners As StringObjects _
)

Parameters

Owners

See Also

ReverseEngineer Object


%%PageItemTitle%%

SetObjectOwnerList Method
Owners

Description

Set the owners of the objects that are to be reverse-engineered. PARAMETERS: StringObjects.

Syntax

Visual Basic
Public Sub SetObjectOwnerList( _
   ByVal Owners As StringObjects _
)

Parameters

Owners

See Also

ReverseEngineer Object


%%PageItemTitle%%

Alias Property

Description

Specifies whether or not to reverse-engineer alias. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Alias() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

ConnectionType Property

Description

The connection type. Valid types are 'Native' and 'ODBC'. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectionType() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

ConnectString Property

Description

The reverse engineer use this string to connect to database when the connection type is Native. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectString() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Database Property

Description

The database to be reverse-engineered. It applies only if the source DBMS is SQL Server or Sybase. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Database() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Datasource Property

Description

If the ConnectionType is 'ODBC', this property designates the ODBC datasource name. If ConnectionType is 'Native', this is the server name or connection string required to connect to the DBMS server. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datasource() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

DBMSType Property

Description

The DBMS type for a Native ConnectionType. Valid values are 'Oracle', 'Sybase', 'SQL Server' and 'DB2'. If the ConnectionType is ODBC, this property is ignored. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DBMSType() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

IgnoreIndexPartitions Property

Description

Specifies whether or not reverse-engineer index partitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IgnoreIndexPartitions() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

IgnoreTablePartitions Property

Description

Specifies whether or not reverse-engineer table partitions. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property IgnoreTablePartitions() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

InferDomains Property

Description

Specifies whether or not to infer domains. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InferDomains() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

InferFKByIndex Property

Description

Specifies whether or not to infer Foreign Keys based on indexes. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InferFKByIndex() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

InferFKByName Property

Description

Specifies whether or not to infer Foreign Keys based on names. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InferFKByName() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

InferPK Property

Description

Specifies whether or not to infer Primary Keys. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InferPK() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

MaterializedViews Property

Description

Specifies whether or not to reverse-engineer Materialized Views. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaterializedViews() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

ObjectOwner Property

Description

The owner of the objects. If the database type is SQL Server or Sybase, the default is 'dbo'. For other platforms, the defalt is UserName. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectOwner() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

ObjectTypes Property

Description

Specifies whether or not to reverse-engineer object types. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectTypes() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Packages Property

Description

Specifies whether or not to reverse-engineer packages. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Packages() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Password Property

Description

The password for the database connection. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Password() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Procedures Property

Description

Specifies whether or not to reverse-engineer stored procedures. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Procedures() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

QuickLaunchFile Property

Description

Specifies the quick launch file that will be used to do the reverse-engineer. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property QuickLaunchFile() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Sequences Property

Description

Specifies whether or not to reverse-engineer Sequences. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Sequences() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

ShowStatus Property

Description

This property determines whether to display the status dialog. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowStatus() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

StorageObjects Property

Description

Specifies whether or not to reverse-engineer storage objects. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property StorageObjects() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Synonyms Property

Description

Specifies whether or not to reverse-engineer Synonyms. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Synonyms() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

SystemTables Property

Description

Specifies whether or not to reverse-engineer system tables. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SystemTables() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

SystemViews Property

Description

Specifies whether or not to reverse-engineer system views. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SystemViews() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Triggers Property

Description

Specifies whether or not to reverse-engineer triggers. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Triggers() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Username Property

Description

The login name for the database connection. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Username() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

UserTables Property

Description

Specifies whether or not to reverse-engineer user tables. Default is TRUE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserTables() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

UserViews Property

Description

Specifies whether or not to reverse-engineer user views. Default is FALSE. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserViews() As Variant

See Also

ReverseEngineer Object


%%PageItemTitle%%

Role Object
See Also Members

Description

This object represents a Repository Role in ER/Studio.

See Also

Role Members


%%PageItemTitle%% $$Members$$

Role Object Members
See Also Overview

Public Methods

Public Method DoModify Sends Modify Role request to the Repository using current Role data. Return 1 if successful, and 0 if it failed. RETURN DATATYPE: Integer.

Public Properties

Public Property Description | This is the description for the Role. DATATYPE: String.
Public Property Name | This is the name of the Role. DATATYPE: String.

See Also

Role Overview


%%PageItemTitle%%

DoModify Method

Description

Sends Modify Role request to the Repository using current Role data. Return 1 if successful, and 0 if it failed. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function DoModify() As Variant

See Also

Role Object


%%PageItemTitle%%

Description Property

Description

This is the description for the Role. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Role Object


%%PageItemTitle%%

Name Property

Description

This is the name of the Role. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Role Object


%%PageItemTitle%%

Roles Collection
See Also Members

Description

This object represents a collection of Role objects.

Object Model

See Also

Roles Members


%%PageItemTitle%% $$Members$$

Roles Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new Role object. PARAMETERS: Name as String, Description as String, ObjectPrivilege as String, Users as StringObjects, Diagrams as StringObjects, DataDictionaries as StringObjects.
Public Method Remove | Remove a Role specified by the given name. PARAMETERS: Name as String.

Public Properties

Public Property _Item | Returns a Role object specified by the given name. PARAMETERS: Identifier as String.
Public Property _NewEnum |
Public Property Count | This is the number of Role objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Role object specified by the given name. PARAMETERS: Identifier as String.

See Also

Roles Overview


%%PageItemTitle%%

Add Method
Name
Description
ObjectPrivilege
Users
Diagrams
DataDictionary

Description

Add a new Role object. PARAMETERS: Name as String, Description as String, ObjectPrivilege as String, Users as StringObjects, Diagrams as StringObjects, DataDictionaries as StringObjects.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant, _
   ByVal ObjectPrivilege As Variant, _
   ByVal Users As StringObjects, _
   ByVal Diagrams As StringObjects, _
   ByVal DataDictionary As StringObjects _
) As Role

Parameters

Name
Description
ObjectPrivilege
Users
Diagrams
DataDictionary

See Also

Roles Collection


%%PageItemTitle%%

Remove Method
Name

Description

Remove a Role specified by the given name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

Roles Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Role object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Role

Parameters

Identifier

See Also

Roles Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Roles Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Role objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Roles Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Role object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Role

Parameters

Identifier

See Also

Roles Collection


%%PageItemTitle%%

Rule Object
See Also Members

Description

This object represents a rule in ER/Studio.

Object Model

See Also

Rule Members


%%PageItemTitle%% $$Members$$

Rule Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this rule.
Public Method BoundObjects | Returns a collection of bindings that link the rule to attributes.
Public Method RepoCheckOutStatus | Get the Check Out status of this Rule object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this Rule object.

Public Properties

Public Property DictionaryName | This is the name of the Dictionary associated with this object. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the Rule. DATATYPE: String.
Public Property ID | ID of the rule. This ID is assigned by ER/Studio. Each rule in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the rule. DATATYPE: String.
Public Property Text | This is the text of the rule. DATATYPE: String.

See Also

Rule Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this rule.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Rule Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the rule to attributes.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

Rule Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this Rule object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

Rule Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Rule object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Rule Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary associated with this object. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

Rule Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

Rule Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Rule. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Rule Object


%%PageItemTitle%%

ID Property

Description

ID of the rule. This ID is assigned by ER/Studio. Each rule in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Rule Object


%%PageItemTitle%%

Name Property

Description

This is the name of the rule. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Rule Object


%%PageItemTitle%%

Text Property

Description

This is the text of the rule. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Text() As Variant

See Also

Rule Object


%%PageItemTitle%%

Rules Collection
See Also Members

Description

This object represents a collection of rules. The owner of this collection is the data dictionary.

Object Model

See Also

Rules Members


%%PageItemTitle%% $$Members$$

Rules Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new rule with the given name and text value, adds it to the data dictionary, and returns the new rule to the caller. PARAMETERS: Name as String, Value as String.
Public Method Remove | PDeletes a Rule object (specified by the given name or ID) from ER/Studio. ARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Rule object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Rule objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Rule object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Rules Overview


%%PageItemTitle%%

Add Method
Name
Value

Description

Creates a new rule with the given name and text value, adds it to the data dictionary, and returns the new rule to the caller. PARAMETERS: Name as String, Value as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Value As Variant _
) As Rule

Parameters

Name
Value

See Also

Rules Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

PDeletes a Rule object (specified by the given name or ID) from ER/Studio. ARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Rules Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Rule object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Rule

Parameters

Identifier

See Also

Rules Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Rules Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Rule objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Rules Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Rule object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Rule

Parameters

Identifier

See Also

Rules Collection


%%PageItemTitle%%

SchemaObjDisplay Object
See Also Members

Description

This object represents an schema display object in ER/Studio. An schema display object is a graphical representation of a schema object in a specific submodel - it is not a schema object itself.

See Also

SchemaObjDisplay Members


%%PageItemTitle%% $$Members$$

SchemaObjDisplay Object Members
See Also Overview

Public Methods

Public Method ParentSchemaObj | Get the parent schema object of this schema display object. DATATYPE: Schema Object.
Public Method RepoCheckOutStatus | Get the Check Out status of this SchemaObjDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this schema display object from the Repository server. Return the data in the StringObjects collection.DATATYPE: StringObjects.
Public Method Resize | Resize the schema display object to default size.

Public Properties

Public Property BackgroundColor | This is the background color of the entity display object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property DisplayBackgroundColor | This determines whether to use a custom background color just for this schema object display (true) or whether to use the default schema obj background color of the submodel (false). DATATYPE: Boolean.
Public Property GUID | GUID of the schema display object. This GUID is assigned by ER/Studio. Each schema display object has a unique GUID. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the schema display object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the schema display object. DATATYPE: Integer.
Public Property ID | ID of the schema display object. This ID is assigned by ER/Studio. Each schema display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the schema object. DATATYPE: String.
Public Property OutlineColor | This is the OutlineColor of the schema display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property VerticalPosition | This is the y coordinate of the schema display object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the schema display object. DATATYPE: Integer.

See Also

SchemaObjDisplay Overview


%%PageItemTitle%%

ParentSchemaObj Method

Description

Get the parent schema object of this schema display object. DATATYPE: Schema Object.

Syntax

Visual Basic
Public Function ParentSchemaObj() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this SchemaObjDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this schema display object from the Repository server. Return the data in the StringObjects collection.DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

Resize Method

Description

Resize the schema display object to default size.

Syntax

Visual Basic
Public Sub Resize()

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

BackgroundColor Property

Description

This is the background color of the entity display object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackgroundColor() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

DisplayBackgroundColor Property

Description

This determines whether to use a custom background color just for this schema object display (true) or whether to use the default schema obj background color of the submodel (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayBackgroundColor() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the schema display object. This GUID is assigned by ER/Studio. Each schema display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the schema display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the schema display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the schema display object. This ID is assigned by ER/Studio. Each schema display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

Name Property

Description

This is the name of the schema object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

OutlineColor Property

Description

This is the OutlineColor of the schema display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlineColor() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the schema display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the schema display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

SchemaObjDisplay Object


%%PageItemTitle%%

SchemaObjDisplays Collection
See Also Members

Description

This object represents a collection of schema display objects. The owner of this collection is the submodel object.

Object Model

See Also

SchemaObjDisplays Members


%%PageItemTitle%% $$Members$$

SchemaObjDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new schema display object from the schema object identified by the given name, and returns the new schema display object. PARAMETERS: EntityName as String.
Public Method Remove | Deletes a schema display object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a schema display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of schema object displays in the collection. DATATYPE: Integer.
Public Property Item | Returns a schema display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

SchemaObjDisplays Overview


%%PageItemTitle%%

Add Method
SchemaObjName

Description

Creates a new schema display object from the schema object identified by the given name, and returns the new schema display object. PARAMETERS: EntityName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal SchemaObjName As Variant _
) As SchemaObjDisplay

Parameters

SchemaObjName

See Also

SchemaObjDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a schema display object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SchemaObjDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a schema display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SchemaObjDisplay

Parameters

Identifier

See Also

SchemaObjDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SchemaObjDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of schema object displays in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SchemaObjDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a schema display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SchemaObjDisplay

Parameters

Identifier

See Also

SchemaObjDisplays Collection


%%PageItemTitle%%

SchemaObjRelationshipDisplay Object
See Also Members

Description

This object represents a schema object relationship display object in ER/Studio. A schema object relationship display object is a graphical representation of a schema object in a specific submodel.

See Also

SchemaObjRelationshipDisplay Members


%%PageItemTitle%% $$Members$$

SchemaObjRelationshipDisplay Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this SchemaObjRelationshipDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property ChildName | This is the name of the child object. DATATYPE: String.
Public Property ChildType | This is the type of the child object. [1 - ENTITY, 2 - VIEW, 3 - PROCEDURE, 4 - PACKAGE, 5 - FUNCTION].
Public Property Color | This is the color of the schema object's relationship display object. It takes a 4 byte integer where the 1st byte is a red value (0-255), the 2nd byte is a green value (0-255), and the 3rd byte is a blue value (0-255).
Public Property GUID | GUID of the schema object relationship display object. This GUID is assigned by ER/Studio. Each schema object relationship display object has a unique GUID. DATATYPE: String.
Public Property ID | ID of the schema object relationship display object. This ID is assigned by ER/Studio. Each schema object relationship display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property ParentName | This is the name of the parent object. DATATYPE: String.
Public Property ParentType | This is the type of the parent object. [1 - ENTITY, 2 - VIEW, 3 - PROCEDURE, 4 - PACKAGE, 5 - FUNCTION].

See Also

SchemaObjRelationshipDisplay Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this SchemaObjRelationshipDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

ChildName Property

Description

This is the name of the child object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChildName() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

ChildType Property

Description

This is the type of the child object. [1 - ENTITY, 2 - VIEW, 3 - PROCEDURE, 4 - PACKAGE, 5 - FUNCTION].

Property type

Read-only property

Syntax

Visual Basic
Public Property ChildType() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

Color Property

Description

This is the color of the schema object's relationship display object. It takes a 4 byte integer where the 1st byte is a red value (0-255), the 2nd byte is a green value (0-255), and the 3rd byte is a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the schema object relationship display object. This GUID is assigned by ER/Studio. Each schema object relationship display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the schema object relationship display object. This ID is assigned by ER/Studio. Each schema object relationship display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

ParentName Property

Description

This is the name of the parent object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentName() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

ParentType Property

Description

This is the type of the parent object. [1 - ENTITY, 2 - VIEW, 3 - PROCEDURE, 4 - PACKAGE, 5 - FUNCTION].

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentType() As Variant

See Also

SchemaObjRelationshipDisplay Object


%%PageItemTitle%%

SchemaObjRelationshipDisplays Collection
See Also Members

Description

This object represents a collection of schema object relationship display objects. The owner of this collection is the submodel.

Object Model

See Also

SchemaObjRelationshipDisplays Members


%%PageItemTitle%% $$Members$$

SchemaObjRelationshipDisplays Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a schema object relationship display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | DATATYPE: Integer. This is the number of schema object relationship display objects in the collection.
Public Property Item | Returns a schema object relationship display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

SchemaObjRelationshipDisplays Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a schema object relationship display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SchemaObjRelationshipDisplay

Parameters

Identifier

See Also

SchemaObjRelationshipDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SchemaObjRelationshipDisplays Collection


%%PageItemTitle%%

Count Property

Description

DATATYPE: Integer. This is the number of schema object relationship display objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SchemaObjRelationshipDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a schema object relationship display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SchemaObjRelationshipDisplay

Parameters

Identifier

See Also

SchemaObjRelationshipDisplays Collection


%%PageItemTitle%%

SecurityProperties Collection
See Also Members

Description

This object represents a collection of SecurityProperties associated with a given SecurityType. The owner of this collection is that SecurityType.

Object Model

See Also

SecurityProperties Members


%%PageItemTitle%% $$Members$$

SecurityProperties Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new SecurityProperty in the collection and returns the pointer. PARAMETERS: Name, Description, and ValueDefault as Strings, Datatype as Integer.
Public Method Remove | Deletes a SecurityProperty object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SecurityProperty object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of SecurityProperty objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a SecurityProperty object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

SecurityProperties Overview


%%PageItemTitle%%

Add Method
Name
Description
ValueDefault
Datatype

Description

Creates a new SecurityProperty in the collection and returns the pointer. PARAMETERS: Name, Description, and ValueDefault as Strings, Datatype as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant, _
   ByVal ValueDefault As Variant, _
   ByVal Datatype As Variant _
) As SecurityProperty

Parameters

Name
Description
ValueDefault
Datatype

See Also

SecurityProperties Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a SecurityProperty object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SecurityProperties Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SecurityProperty object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SecurityProperty

Parameters

Identifier

See Also

SecurityProperties Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SecurityProperties Collection


%%PageItemTitle%%

Count Property

Description

This is the number of SecurityProperty objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SecurityProperties Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SecurityProperty object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SecurityProperty

Parameters

Identifier

See Also

SecurityProperties Collection


%%PageItemTitle%%

SecurityProperty Object
See Also Members

Description

This object represents a SecurityProperty in ER/Studio.

Object Model

See Also

SecurityProperty Members


%%PageItemTitle%% $$Members$$

SecurityProperty Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this DataSecurityProperty object. DATATYPE: StringObjects.
Public Method SecurityType | Returns the parent SecurityType of this SecurityProperty. RETURN DATATYPE: SecurityType.
Public Method TextList | RETURN DATATYPE: TextList, Returns the SecurityProperty's TextList data in a collection.
Public Method UserComments | Returns a collection of user comments associated with this DataSecurityProperty object.

Public Properties

Public Property Datatype | This is a Datatype associated with the SecurityProperty. DATATYPE: Integer.
Public Property Description | This is the description of the SecurityProperty. DATATYPE: String.
Public Property GUID | This is the GUID of the SecurityProperty. DATATYPE: String.
Public Property ID | Returns the SecurityProperty's ID. DATATYPE: Integer.
Public Property Name | This is the name of the SecurityProperty. DATATYPE: String.
Public Property ValueDefault | This is the ValueDefault associated with the SecurityProperty Datatype. Read Help file for proper formatting info for different Datatypes. DATATYPE: String.

See Also

SecurityProperty Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this DataSecurityProperty object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

SecurityType Method

Description

Returns the parent SecurityType of this SecurityProperty. RETURN DATATYPE: SecurityType.

Syntax

Visual Basic
Public Function SecurityType() As SecurityType

See Also

SecurityProperty Object


%%PageItemTitle%%

TextList Method

Description

RETURN DATATYPE: TextList, Returns the SecurityProperty's TextList data in a collection.

Syntax

Visual Basic
Public Function TextList() As TextList

See Also

SecurityProperty Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this DataSecurityProperty object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

SecurityProperty Object


%%PageItemTitle%%

Datatype Property

Description

This is a Datatype associated with the SecurityProperty. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

Description Property

Description

This is the description of the SecurityProperty. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the SecurityProperty. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

ID Property

Description

Returns the SecurityProperty's ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

Name Property

Description

This is the name of the SecurityProperty. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

ValueDefault Property

Description

This is the ValueDefault associated with the SecurityProperty Datatype. Read Help file for proper formatting info for different Datatypes. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueDefault() As Variant

See Also

SecurityProperty Object


%%PageItemTitle%%

SecurityType Object
See Also Members

Description

This object represents a SecurityType in ER/Studio.

Object Model

See Also

SecurityType Members


%%PageItemTitle%% $$Members$$

SecurityType Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this DataSecurityType object. DATATYPE: StringObjects.
Public Method SecurityProperties | Returns all the SecurityProperties belonging to this SecurityType.
Public Method UserComments | Returns all the user comments associated with this SecurityType.

Public Properties

Public Property Description | This is the description of the SecurityType. DATATYPE: String.
Public Property DictionaryName | This is the Name of the DataDictionary the SecurityType belongs to. DATATYPE: String.
Public Property EnterpriseLevel | This indicates that the SecurityType is in an Enterprise Level Data Dictionary. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the SecurityType. DATATYPE: String.
Public Property ID | Returns the SecurityType's ID. DATATYPE: Integer.
Public Property Name | This is the name of the SecurityType. DATATYPE: String.

See Also

SecurityType Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this DataSecurityType object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

SecurityProperties Method

Description

Returns all the SecurityProperties belonging to this SecurityType.

Syntax

Visual Basic
Public Function SecurityProperties() As SecurityProperties

See Also

SecurityType Object


%%PageItemTitle%%

UserComments Method

Description

Returns all the user comments associated with this SecurityType.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

SecurityType Object


%%PageItemTitle%%

Description Property

Description

This is the description of the SecurityType. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the Name of the DataDictionary the SecurityType belongs to. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

This indicates that the SecurityType is in an Enterprise Level Data Dictionary. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the SecurityType. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

ID Property

Description

Returns the SecurityType's ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

Name Property

Description

This is the name of the SecurityType. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

SecurityType Object


%%PageItemTitle%%

SecurityTypes Collection
See Also Members

Description

This object represents a collection of SecurityTypes. The owner of this collection is the Data Dictionary.

Object Model

See Also

SecurityTypes Members


%%PageItemTitle%% $$Members$$

SecurityTypes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new SecurityType in the collection and returns the pointer. PARAMETERS: Name and Description as Strings.
Public Method Remove | Deletes a SecurityType object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SecurityType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of SecurityType objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a SecurityType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

SecurityTypes Overview


%%PageItemTitle%%

Add Method
Name
Description

Description

Creates a new SecurityType in the collection and returns the pointer. PARAMETERS: Name and Description as Strings.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Description As Variant _
) As SecurityType

Parameters

Name
Description

See Also

SecurityTypes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a SecurityType object specified by the given name or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SecurityTypes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SecurityType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SecurityType

Parameters

Identifier

See Also

SecurityTypes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SecurityTypes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of SecurityType objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SecurityTypes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SecurityType object specified by the given name, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SecurityType

Parameters

Identifier

See Also

SecurityTypes Collection


%%PageItemTitle%%

SelectedObject Object
See Also Members

Description

This object represents a selected object in ER/Studio. A selected object is highlighted in a submodel. Usually, a selected object will either be a view or an entity.

See Also

SelectedObject Members


%%PageItemTitle%% $$Members$$

SelectedObject Object Members
See Also Overview

Public Properties

Public Property ID | ID of the selected object. This ID is assigned by ER/Studio. Each selected object in a diagram has a unique ID. The ID is really the ID of the specific object which is selected (ie, the ID is an entity ID or a view ID, etc.).
Public Property Type | DATATYPE: Integer. This is the type of the selected object. The possible values are: Entity - 1, Relationship - 2, View - 16, and ViewRelationship - 18.

See Also

SelectedObject Overview


%%PageItemTitle%%

ID Property

Description

ID of the selected object. This ID is assigned by ER/Studio. Each selected object in a diagram has a unique ID. The ID is really the ID of the specific object which is selected (ie, the ID is an entity ID or a view ID, etc.).

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SelectedObject Object


%%PageItemTitle%%

Type Property

Description

DATATYPE: Integer. This is the type of the selected object. The possible values are: Entity - 1, Relationship - 2, View - 16, and ViewRelationship - 18.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type() As Variant

Remarks

PROPERTY: Type (Read Only), DATATYPE: Integer, DESCRIPTION: This is the type of the selected object. The possible values are:

  • ENTITY = 1
  • RELATIONSHIP = 2
  • SUPERTYPE = 8
  • VIEW = 16
  • VIEW RELATIONSHIP = 18
  • PACKAGE = 29
  • PROCEDURE = 31
  • STOGROUP = 33
  • DATABASE = 35
  • TABLESPACE = 37
  • ROLLBACK SEGMENT = 39
  • NODE GROUP = 41
  • BUFFERPOOL = 43
  • SEQUENCE = 45
  • MATERIALIZED VIEW = 47
  • SYNONYM = 49
  • AUXILIARY TABLE = 51
  • FUNCTION = 54
  • OBJECT TYPE = 60
  • ALIAS = 62
  • SUMMARY TABLE = 65
  • SHAPE = 73

See Also

SelectedObject Object


%%PageItemTitle%%

SelectedObjects Collection
See Also Members

Description

This object represents a collection of selected objects. The owner of this collection is the submodel.

Object Model

See Also

SelectedObjects Members


%%PageItemTitle%% $$Members$$

SelectedObjects Collection Members
See Also Overview

Public Methods

Public Method Add | Adds the object specified by the given type and ID to the selected objects collection in the submodel. It then returns a selectedobject object. PARAMETERS: Type as Integer, Identifier as Integer.
Public Method Remove | Deletes a SelectedObject object (specified by the given type and ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SelectedObject object (specified by the given type and ID). PARAMETERS: Type as Integer, Identifier as Integer.
Public Property _NewEnum |
Public Property Count | This is the number of SelectedObject objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a SelectedObject object (specified by the given type and ID). PARAMETERS: Type as Integer, Identifier as Integer.

See Also

SelectedObjects Overview


%%PageItemTitle%%

Add Method
Type
ID

Description

Adds the object specified by the given type and ID to the selected objects collection in the submodel. It then returns a selectedobject object. PARAMETERS: Type as Integer, Identifier as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal Type As Variant, _
   ByVal ID As Variant _
) As SelectedObject

Parameters

Type
ID

See Also

SelectedObjects Collection


%%PageItemTitle%%

Remove Method
Type
ID

Description

Deletes a SelectedObject object (specified by the given type and ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Type As Variant, _
   ByVal ID As Variant _
)

Parameters

Type
ID

See Also

SelectedObjects Collection


%%PageItemTitle%%

_Item Property
Type
Identifier

Description

Returns a SelectedObject object (specified by the given type and ID). PARAMETERS: Type as Integer, Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Type As Variant, _
   ByVal Identifier As Variant _
) As SelectedObject

Parameters

Type
Identifier

See Also

SelectedObjects Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SelectedObjects Collection


%%PageItemTitle%%

Count Property

Description

This is the number of SelectedObject objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SelectedObjects Collection


%%PageItemTitle%%

Item Property
Type
Identifier

Description

Returns a SelectedObject object (specified by the given type and ID). PARAMETERS: Type as Integer, Identifier as Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Type As Variant, _
   ByVal Identifier As Variant _
) As SelectedObject

Parameters

Type
Identifier

See Also

SelectedObjects Collection


%%PageItemTitle%%

Shape Object
See Also Members

Description

This object represents a Shape in ER/Studio.

Object Model

See Also

Shape Members


%%PageItemTitle%% $$Members$$

Shape Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this Shape.
Public Method UniversalMappings | Returns a collection of universal mappings applied to this object.

Public Properties

Public Property GUID | Returns the Shape's GUID. DATATYPE: String.
Public Property ID | Returns the Shape ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the Shape. DATATYPE: String.
Public Property Text | This property represents the text of the Shape. DATATYPE: String.
Public Property Type | This property represents the Shape type. DATATYPE: String.

See Also

Shape Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this Shape.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Shape Object


%%PageItemTitle%%

UniversalMappings Method

Description

Returns a collection of universal mappings applied to this object.

Syntax

Visual Basic
Public Function UniversalMappings() As UniversalMappings

See Also

Shape Object


%%PageItemTitle%%

GUID Property

Description

Returns the Shape's GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Shape Object


%%PageItemTitle%%

ID Property

Description

Returns the Shape ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Shape Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the Shape. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Shape Object


%%PageItemTitle%%

Text Property

Description

This property represents the text of the Shape. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Text() As Variant

See Also

Shape Object


%%PageItemTitle%%

Type Property

Description

This property represents the Shape type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

Shape Object


%%PageItemTitle%%

ShapeDisplay Object
See Also Members

Description

This object represents an shape display object in ER/Studio. A shape display object is a graphical representation of a shape object in a specific submodel; it is not a shape object itself.

Object Model

See Also

ShapeDisplay Members


%%PageItemTitle%% $$Members$$

ShapeDisplay Object Members
See Also Overview

Public Methods

Public Method ParentShape | Get the parent shape object of this shape display object. DATATYPE: Shape.
Public Method RepoCheckOutStatus | Get the Check Out status of this ShapeDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this shape display object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property BackgroundColor | The background color of the shape display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property DisplayBackgroundColor | This determines whether to use a custom background color just for this shape display object (true) or whether to use the default shape background color of the submodel (false). DATATYPE: Boolean.
Public Property FitShape | When enabled, fits the shape to the size of the text.
Public Property GUID | GUID of the shape display object. This GUID is assigned by ER/Studio. Each shape display object has a unique GUID. DATATYPE: String.
Public Property HorizontalJustification | Sets the way in which text is justified horizontally. 1 - Left, 2 - Center, 3 - Right.
Public Property HorizontalPosition | This is the x coordinate of the shape display object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the shape display object. DATATYPE: Integer.
Public Property ID | ID of the shape display object. This ID is assigned by ER/Studio. Each shape display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the shape object. DATATYPE: String.
Public Property NameColor | Color for the name. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NameFont | Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property OutlineColor | This is the OutlineColor of the shape display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property TextColor | Color for the text. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property TextFont | Font for the text. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property VerticalJustification | Sets the way in which text is justified vertically. 1 - Top, 2 - Center, 3 - Bottom.
Public Property VerticalPosition | This is the y coordinate of the shape display object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the shape display object. DATATYPE: Integer.
Public Property WrapText | When enabled, wraps the text to the size of the object.

See Also

ShapeDisplay Overview


%%PageItemTitle%%

ParentShape Method

Description

Get the parent shape object of this shape display object. DATATYPE: Shape.

Syntax

Visual Basic
Public Function ParentShape() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this ShapeDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this shape display object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

BackgroundColor Property

Description

The background color of the shape display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackgroundColor() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

DisplayBackgroundColor Property

Description

This determines whether to use a custom background color just for this shape display object (true) or whether to use the default shape background color of the submodel (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayBackgroundColor() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

FitShape Property

Description

When enabled, fits the shape to the size of the text.

Property type

Read-write property

Syntax

Visual Basic
Public Property FitShape() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the shape display object. This GUID is assigned by ER/Studio. Each shape display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

HorizontalJustification Property

Description

Sets the way in which text is justified horizontally. 1 - Left, 2 - Center, 3 - Right.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalJustification() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the shape display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the shape display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the shape display object. This ID is assigned by ER/Studio. Each shape display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

Name Property

Description

This is the name of the shape object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

NameColor Property

Description

Color for the name. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NameColor() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

NameFont Property

Description

Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NameFont() As ERSFont

See Also

ShapeDisplay Object


%%PageItemTitle%%

OutlineColor Property

Description

This is the OutlineColor of the shape display object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlineColor() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

TextColor Property

Description

Color for the text. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TextColor() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

TextFont Property

Description

Font for the text. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property TextFont() As ERSFont

See Also

ShapeDisplay Object


%%PageItemTitle%%

VerticalJustification Property

Description

Sets the way in which text is justified vertically. 1 - Top, 2 - Center, 3 - Bottom.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalJustification() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the shape display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the shape display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

WrapText Property

Description

When enabled, wraps the text to the size of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property WrapText() As Variant

See Also

ShapeDisplay Object


%%PageItemTitle%%

ShapeDisplays Collection
See Also Members

Description

This object represents a collection of shape display objects. The owner of this collection is the submodel object.

Object Model

See Also

ShapeDisplays Members


%%PageItemTitle%% $$Members$$

ShapeDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new shape display object from the shape object identified by the given name, and returns the new shape display object. PARAMETERS: ShapeName as String.
Public Method Remove | Deletes a shape display object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a shape display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of shape displays in the collection. DATATYPE: Integer.
Public Property Item | Returns a shape display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

ShapeDisplays Overview


%%PageItemTitle%%

Add Method
ShapeName

Description

Creates a new shape display object from the shape object identified by the given name, and returns the new shape display object. PARAMETERS: ShapeName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal ShapeName As Variant _
) As ShapeDisplay

Parameters

ShapeName

See Also

ShapeDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a shape display object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ShapeDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a shape display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ShapeDisplay

Parameters

Identifier

See Also

ShapeDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ShapeDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of shape displays in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ShapeDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a shape display object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ShapeDisplay

Parameters

Identifier

See Also

ShapeDisplays Collection


%%PageItemTitle%%

Shapes Collection
See Also Members

Description

This object represents a collection of Shapes. The owner of this collection is the model.

Object Model

See Also

Shapes Members


%%PageItemTitle%% $$Members$$

Shapes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new Shape. Shape types are: Rectangle-1, Rounded Rectangle-2, Ellipse-3, Pentagon-4, Hexagon-5, Octagon-6, Note-7. PARAMETERS: Name (String), Text (String), ShapeType (Integer).
Public Method AddWithPosition | Creates a Shape. PARAMETERS: Name (String), Text (String), ShapeType (Integer), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a Shape object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Shape object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Shapes in the collection. DATATYPE: Integer.
Public Property Item | Returns a Shape object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Shapes Overview


%%PageItemTitle%%

Add Method
Name
Text
ShapeType

Description

Creates and returns a new Shape. Shape types are: Rectangle-1, Rounded Rectangle-2, Ellipse-3, Pentagon-4, Hexagon-5, Octagon-6, Note-7. PARAMETERS: Name (String), Text (String), ShapeType (Integer).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Text As Variant, _
   ByVal ShapeType As Variant _
) As Shape

Parameters

Name
Text
ShapeType

See Also

Shapes Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Text
ShapeType
HorizontalPosition
VerticalPosition

Description

Creates a Shape. PARAMETERS: Name (String), Text (String), ShapeType (Integer), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Text As Variant, _
   ByVal ShapeType As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Shape

Parameters

Name
Text
ShapeType
HorizontalPosition
VerticalPosition

See Also

Shapes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Shape object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Shapes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Shape object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Shape

Parameters

Identifier

See Also

Shapes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Shapes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Shapes in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Shapes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Shape object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Shape

Parameters

Identifier

See Also

Shapes Collection


%%PageItemTitle%%

SQLServerSequence Object
See Also Members

Description

This object represents an SQL Server sequence in ER/Studio. It is stored as its create statement.

Object Model

See Also

SQLServerSequence Members


%%PageItemTitle%% $$Members$$

SQLServerSequence Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method UserComments | Returns the user comments collection associated with this Object.

Public Properties

Public Property CacheSize | This property specifies the the size of the cache used for the SQL Server Sequence. DATATYPE: Integer.
Public Property Cycle | This property holds true if the SQL Server Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.
Public Property Datatype | This property specifies the data type of the SQL Server Sequence. DATATYPE: String.
Public Property DataWidth | This property represents the data width of the SQL Server Sequence. DATATYPE: String.
Public Property Description | This is the Description of the SQL Server Sequence. DATATYPE: String.
Public Property GenPostSQL | This property represents the Generate PostSQL of the SQL Server Sequence. DATATYPE: Boolean.
Public Property GenPreSQL | This property represents the Generate PreSQL of the SQL Server Sequence. DATATYPE: Boolean.
Public Property GUID | This is the GUID of the SQL Server Sequence. DATATYPE: String.
Public Property HasMaxValue | This property holds true if the SQL Server Sequence has a maximum value set, false otherwise. DATATYPE: Boolean.
Public Property HasMinValue | This property holds true if the SQL Server Sequence has a minimum value set, false otherwise. DATATYPE: Boolean.
Public Property ID | Returns the SQL Server Sequence ID. DATATYPE: Integer.
Public Property IncrementBy | This property represents the value by which the SQL Server Sequence will be implemented each time a new number is requested. DATATYPE: String.
Public Property MaxValue | This property represents the maximum SQL Server Sequence value. DATATYPE: String.
Public Property MinValue | This property represents the minimum SQL Server Sequence value. DATATYPE: String.
Public Property Name | This property represents the name of the SQL Server Sequence. DATATYPE: String.
Public Property NeedCache | This property represents the need for cache size value of the SQL Server Sequence. DATATYPE: Boolean.
Public Property NeedMaxValue | This property holds true if the SQL Server Sequence needs a maximum value to be set, false otherwise. DATATYPE: Boolean.
Public Property NeedMinValue | This property holds true if the SQL Server Sequence needs a minimum value to be set, false otherwise. DATATYPE: Boolean.
Public Property Owner | This property represents the owner of the SQL Server Sequence. DATATYPE: String.
Public Property PostSQL | This property represents the PostSQL of the SQL Server Sequence. DATATYPE: String.
Public Property PreSQL | This property represents the PreSQL of the SQL Server Sequence. DATATYPE: String.
Public Property StartWith | This property represents the value that the SQL Server Sequence will start with. DATATYPE: String.

See Also

SQLServerSequence Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

SQLServerSequence Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

SQLServerSequence Object


%%PageItemTitle%%

UserComments Method

Description

Returns the user comments collection associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

SQLServerSequence Object


%%PageItemTitle%%

CacheSize Property

Description

This property specifies the the size of the cache used for the SQL Server Sequence. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property CacheSize() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

Cycle Property

Description

This property holds true if the SQL Server Sequence values should be cycled when the minimum or maximum value is reached, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cycle() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

Datatype Property

Description

This property specifies the data type of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

DataWidth Property

Description

This property represents the data width of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataWidth() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

GenPostSQL Property

Description

This property represents the Generate PostSQL of the SQL Server Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPostSQL() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

GenPreSQL Property

Description

This property represents the Generate PreSQL of the SQL Server Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenPreSQL() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the SQL Server Sequence. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

HasMaxValue Property

Description

This property holds true if the SQL Server Sequence has a maximum value set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasMaxValue() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

HasMinValue Property

Description

This property holds true if the SQL Server Sequence has a minimum value set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasMinValue() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

ID Property

Description

Returns the SQL Server Sequence ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

IncrementBy Property

Description

This property represents the value by which the SQL Server Sequence will be implemented each time a new number is requested. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementBy() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

MaxValue Property

Description

This property represents the maximum SQL Server Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxValue() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

MinValue Property

Description

This property represents the minimum SQL Server Sequence value. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinValue() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

NeedCache Property

Description

This property represents the need for cache size value of the SQL Server Sequence. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedCache() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

NeedMaxValue Property

Description

This property holds true if the SQL Server Sequence needs a maximum value to be set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedMaxValue() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

NeedMinValue Property

Description

This property holds true if the SQL Server Sequence needs a minimum value to be set, false otherwise. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property NeedMinValue() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

Owner Property

Description

This property represents the owner of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

PostSQL Property

Description

This property represents the PostSQL of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

PreSQL Property

Description

This property represents the PreSQL of the SQL Server Sequence. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

StartWith Property

Description

This property represents the value that the SQL Server Sequence will start with. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartWith() As Variant

See Also

SQLServerSequence Object


%%PageItemTitle%%

SQLServerSequences Collection
See Also Members

Description

This object represents a collection of SQL Server sequences. The owner of this collection is the model.

Object Model

See Also

SQLServerSequences Members


%%PageItemTitle%% $$Members$$

SQLServerSequences Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new SQL Server Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).
Public Method AddWithPosition | Creates and returns a new SQL Server Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes an SQL Server Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of sequences in the collection. DATATYPE: Integer.
Public Property Item | Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

SQLServerSequences Overview


%%PageItemTitle%%

Add Method
Name
Owner

Description

Creates and returns a new SQL Server Sequence, and adds it to the collection. PARAMETERS: Name (String), Owner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant _
) As SQLServerSequence

Parameters

Name
Owner

See Also

SQLServerSequences Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
HorizontalPosition
VerticalPosition

Description

Creates and returns a new SQL Server Sequence with the given coordinates. PARAMETERS: Name (String), Owner (String), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As SQLServerSequence

Parameters

Name
Owner
HorizontalPosition
VerticalPosition

See Also

SQLServerSequences Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an SQL Server Sequence object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SQLServerSequences Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SQLServerSequence

Parameters

Identifier

See Also

SQLServerSequences Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SQLServerSequences Collection


%%PageItemTitle%%

Count Property

Description

This is the number of sequences in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SQLServerSequences Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SQL Server Sequence object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SQLServerSequence

Parameters

Identifier

See Also

SQLServerSequences Collection


%%PageItemTitle%%

SQLServerSynonym Object
See Also Members

Description

This object represents a SQLServer Synonym in ER/Studio. It is stored as its create statement.

Object Model

See Also

SQLServerSynonym Members


%%PageItemTitle%% $$Members$$

SQLServerSynonym Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Object.
Public Method UserComments | Returns a collection of user comments associated with this Object.

Public Properties

Public Property Description | This is the Description of the SQLServer Synonym. DATATYPE: String.
Public Property GUID | This is the GUID of the SQLServer Synonym. DATATYPE: String.
Public Property ID | Returns the SQLServer Synonym ID. DATATYPE: Integer.
Public Property Name | This property represents the name of the SQLServer Synonym. DATATYPE: String.
Public Property ReferencedObjectName | This property represents the name of the object referred to by the SQLServer Synonym. DATATYPE: String.
Public Property ReferencedObjectSchema | PROPERTY: ReferencedObjectSchema, DATATYPE: String, DESCRIPTION: This property represents the Schema of the object referred to by the SQLServer Synonym.
Public Property Schema | PROPERTY: Schema, DATATYPE: String, DESCRIPTION: This property represents the Schema of the SQLServer Synonym.

See Also

SQLServerSynonym Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

SQLServerSynonym Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this Object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

SQLServerSynonym Object


%%PageItemTitle%%

Description Property

Description

This is the Description of the SQLServer Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the SQLServer Synonym. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

ID Property

Description

Returns the SQLServer Synonym ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

Name Property

Description

This property represents the name of the SQLServer Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

ReferencedObjectName Property

Description

This property represents the name of the object referred to by the SQLServer Synonym. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectName() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

ReferencedObjectSchema Property

Description

PROPERTY: ReferencedObjectSchema, DATATYPE: String, DESCRIPTION: This property represents the Schema of the object referred to by the SQLServer Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferencedObjectSchema() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

Schema Property

Description

PROPERTY: Schema, DATATYPE: String, DESCRIPTION: This property represents the Schema of the SQLServer Synonym.

Property type

Read-write property

Syntax

Visual Basic
Public Property Schema() As Variant

See Also

SQLServerSynonym Object


%%PageItemTitle%%

SQLServerSynonyms Collection
See Also Members

Description

This object represents a collection of SQLServer Synonyms. The owner of this collection is the model.

Object Model

See Also

SQLServerSynonyms Members


%%PageItemTitle%% $$Members$$

SQLServerSynonyms Collection Members
See Also Overview

Public Methods

Public Method Add | Creates and returns a new SQLServer Synonym, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).
Public Method AddWithPosition | Creates a SQLServer Synonym. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).
Public Method Remove | Deletes a SQLServer Synonym object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SQLServer Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Synonyms in the collection. DATATYPE: Integer.
Public Property Item | Returns a SQLServer Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

SQLServerSynonyms Overview


%%PageItemTitle%%

Add Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner

Description

Creates and returns a new SQLServer Synonym, and adds it to the collection. PARAMETERS: Name (String), Owner (String), ReferencedObjectName (String), ReferencedObjectOwner (String).

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant _
) As SQLServerSynonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

AddWithPosition Method
Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

Description

Creates a SQLServer Synonym. PARAMETERS: (Strings: Name, Owner, ReferencedObjectName, and ReferencedObjectOwner), HorizontalPosition (Integer), VerticalPosition (Integer).

Syntax

Visual Basic
Public Function AddWithPosition( _
   ByVal Name As Variant, _
   ByVal Owner As Variant, _
   ByVal ReferencedObjectName As Variant, _
   ByVal ReferencedObjectOwner As Variant, _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As SQLServerSynonym

Parameters

Name
Owner
ReferencedObjectName
ReferencedObjectOwner
HorizontalPosition
VerticalPosition

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a SQLServer Synonym object (specified by the given name or ID) from the collection. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SQLServer Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SQLServerSynonym

Parameters

Identifier

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Synonyms in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SQLServer Synonym object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SQLServerSynonym

Parameters

Identifier

See Also

SQLServerSynonyms Collection


%%PageItemTitle%%

StringObject Object
See Also Members

Description

This is a string object. Needed to store string collection.

See Also

StringObject Members


%%PageItemTitle%% $$Members$$

StringObject Object Members
See Also Overview

Public Properties

Public Property StringValue This is the text of the StringObject. DATATYPE: String.

See Also

StringObject Overview


%%PageItemTitle%%

StringValue Property

Description

This is the text of the StringObject. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property StringValue() As Variant

See Also

StringObject Object


%%PageItemTitle%%

StringObjects Collection
See Also Members

Description

This object represent a collection of StringObject

Object Model

See Also

StringObjects Members


%%PageItemTitle%% $$Members$$

StringObjects Collection Members
See Also Overview

Public Methods

Public Method Add | Add a new string object. PARAMETERS: Value as String.
Public Method Remove | Deletes a StringObject object specified by the given name. PARAMETERS: Identifier as String.

Public Properties

Public Property _Item | Returns a StringObject object specified by the given name. PARAMETERS: Identifier as String.
Public Property _NewEnum |
Public Property Count | This is the number of StringObject objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a StringObject object specified by the given name. PARAMETERS: Identifier as String.

See Also

StringObjects Overview


%%PageItemTitle%%

Add Method
Value

Description

Add a new string object. PARAMETERS: Value as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Value As Variant _
) As StringObject

Parameters

Value

See Also

StringObjects Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a StringObject object specified by the given name. PARAMETERS: Identifier as String.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

StringObjects Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a StringObject object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As StringObject

Parameters

Identifier

See Also

StringObjects Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

StringObjects Collection


%%PageItemTitle%%

Count Property

Description

This is the number of StringObject objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

StringObjects Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a StringObject object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As StringObject

Parameters

Identifier

See Also

StringObjects Collection


%%PageItemTitle%%

SubModel Object
See Also Members

Description

This object represents a submodel in ER/Studio.

Object Model

See Also

SubModel Members


%%PageItemTitle%% $$Members$$

SubModel Object Members
See Also Overview

Public Methods

Public Method ActivateSubModel | Sets this SubModel as the Active Submodel.
Public Method AliasDisplays | Returns an object representing a collection of all alias display objects in the submodel.
Public Method AuxiliaryTableDisplays | Returns an object representing a collection of all auxiliary table display objects in the submodel.
Public Method BoundAttachments | Get all the BoundAttachments of this SubModel.
Public Method BoundSecurityProperties | Get all the BoundSecurityProperties of this SubModel.
Public Method BufferPoolDisplays | Returns an object representing a collection of all buffer pool display objects in the submodel.
Public Method BusinessDataObjectDisplays | Returns an object representing a collection of all BusinessDataObject displays in the submodel.
Public Method DatabaseDisplays | Returns an object representing a collection of all database display objects in the submodel.
Public Method DeleteNamingStandardsTemplate | Unbind this Submodel from the naming standards template by deleting the naming standards template ID from the submodel.
Public Method EntityDisplays | Returns an object representing a collection of all entity display objects in the submodel.
Public Method EntityNames | Returns the names of all entities in the submodel. A user can pass in a Variant variable for the first parameter. PARAMETERS:EntityNames as Variant (an array will be filled in by the method), NumFetched as Integer (will be set by the method).
Public Method ExportImageOptions | Get ExportImageOptions object for this SubModel.
Public Method FunctionDisplays | Returns an object representing a collection of all function display objects in the submodel.
Public Method GetNamingStandardsTemplate | Returns the naming standards template bound to the submodel or null, if none is bound to the submodel.
Public Method LineDisplays | Returns an object representing a collection of all line display objects in the submodel.
Public Method MaterializedViewDisplays | Returns an object representing a collection of all materialized view display objects in the submodel.
Public Method NodeGroupDisplays | Returns an object representing a collection of all nodegroup display objects in the submodel.
Public Method ObjectTypeDisplays | Returns an object representing a collection of all object type display objects in the submodel.
Public Method PackageDisplays | Returns an object representing a collection of all package display objects in the submodel.
Public Method PrintOptions | Get PrintOptions object for this SubModel.
Public Method ProcedureDisplays | Returns an object representing a collection of all procedure display objects in the submodel.
Public Method RelationshipDisplays | Returns an object representing a collection of all relationship display objects in the submodel.
Public Method RepoCheckOutStatus | Get the Check Out status of this SubModel object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this SubModel from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method RollbackSegmentDisplays | Returns an object representing a collection of all rollback segment display objects in the submodel.
Public Method SchemaObjRelationshipDisplays | Returns an object representing a collection of all schema object relationship display objects in the submodel.
Public Method SelectedObjects | Returns an object representing a collection of all selected objects in the submodel.
Public Method SequenceDisplays | Returns an object representing a collection of all sequence display objects in the submodel.
Public Method ShapeDisplays | Returns an object representing a collection of all shape display objects in the submodel.
Public Method StoGroupDisplays | Returns an object representing a collection of all stogroup display objects in the submodel.
Public Method SynonymDisplays | Returns an object representing a collection of all synonym display objects in the submodel.
Public Method TablespaceDisplays | Returns an object representing a collection of all tablespace display objects in the submodel.
Public Method UserComments | Returns a collection of all the user comments associated with the submodel.
Public Method ViewDisplays | Returns an object representing a collection of all view display objects in the submodel.
Public Method ViewNames | Return all the View names in this Submodel. DATATYPE: StringObjects.
Public Method ViewRelationshipDisplays | Returns an object representing a collection of all view relationship display objects in the submodel.

Public Properties

Public Property AttachmentColor | This is the color for Attachments. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property AttachmentFont | This is the font for Attachments. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property AttributeFont | This is the font for local, non-key attributes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property CompleteRoleName | This determines whether complete role names are displayed (true) or not (false). DATATYPE: Boolean.
Public Property DataSecurityColor | This is the color for Data Security. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property DataSecurityFont | This is the font for Data Security. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property Definition | This is the submodel definition property. DATATYPE: String.
Public Property DiagramBackgroundColor | This is the color for the background of the submodel. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property EntityBackgroundColor | This is the color for the background of the entity. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property EntityDimTypeLabelColor | This is the color for Entity Dimension Type Label. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property EntityDimTypeLabelFont | This is the font for Entity Dimension Type Label. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property EntityDisplayFormat | This is the display format of Entities in the submodel. The possible values are: 1 - Attributes, 2 - Entities, 3 - Primary Keys, 4 - All Keys, 5 - Definition, 6 - Note. DATATYPE: Integer.
Public Property EntityForegroundColor | This is the color for the foreground of the entity. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property EntityNameFont | This is the font for the entity name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property EntityTitleColor | This is the color for the title of the entity. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property ForeignKeyFont | This is the font for foreign key attributes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property ForeignNonKeyFont | This is the font for foreign, non-key attributes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property GridSpacing | This is the spacing for grid points. DATATYPE: Double.
Public Property GridsPerLine | This is the number of grid points per line. DATATYPE: Integer.
Public Property GridUnits | This is the unit type for the grid measurement. The possible values are: 0 - Inches, 1 - Centimeters. DATATYPE: Integer.
Public Property GUID | GUID of the submodel. This GUID is assigned by ER/Studio. Each submodel has a unique GUID. DATATYPE: String.
Public Property HorizontalScrollPosition | This is the horizontal scroll bar position of the diagram display window. DATATYPE: Integer.
Public Property HorizontalViewSize | This is the width of the diagram display window. DATATYPE: Integer.
Public Property ID | ID of the submodel. This ID is assigned by ER/Studio. Each submodel in a diagram has a unique ID. DATATYPE: Integer.
Public Property IndexColor | This is the color for Indexes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property IndexFont | This is the font for Indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property InheritedNonKeyColor | This is the color for the foreign, non-key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property InheritedPrimaryKeyColor | This is the color for foreign, primary key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property InheritOption | This determines if the submodel will inherit objects added to nested submodels. DATATYPE: Boolean.
Public Property IsActive | This indicates if the submodel is the one currently displayed. DATATYPE: Boolean.
Public Property MainSubModel | This tells the user whether the currently displayed submodel is the main sub model (true) or not (false). DATATYPE: Boolean.
Public Property Name | This is the name of the submodel. DATATYPE: String.
Public Property NamingStandardsTemplateId | ID of the NamingStandardsTemplate object bound to the submodel (if any). A user can bind a NamingStandardsTemplate to the submodel by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.
Public Property NonInheritedNonKeyColor | This is the color for local, non-key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property NonInheritedPrimaryKeyColor | This is the color for local, primary key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property OffPageBackgroundColor | This is the color for the background of the off page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property OffPageForegroundColor | This is the color for the foreground of the off page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property PageBoundary | This is the page boundary. DATATYPE: Integer.
Public Property PageForegroundColor | This is the color for the foreground of the page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property PageNumberColor | This is the color for the number of the page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property PageNumberFont | This is the font for the page numbers. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property PageOrientation | This is the page orientation. The possible values are: 1 - Portrait, 2 - Landscape. DATATYPE: Integer.
Public Property PageSize | This is the page size. DATATYPE: Integer.
Public Property ParentSubmodelID | ID of the parent Submodel object if this Submodel is a child in a nested Submodel. DATATYPE: Integer.
Public Property PrimaryKeyFont | This is the font for the local, primary key font. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property RelationshipBusinessNameColor | This is the color for the relationship business name. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property RelationshipBusinessNameFont | This is the font for the relationship business name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property RelationshipColor | This is the color for the relationships. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property RelationshipNameColor | This is the color for the relationship name. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property RelationshipNameFont | This is the font for the relationship name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property SchemaObjDisplayFormat | This is the display format of Schema Objects in the submodel. The possible values are: 1 - Name, 2 - Definition. DATATYPE: Integer.
Public Property Shadow | This determines whether shadows are drawn (true) or not (false). DATATYPE: Boolean.
Public Property ShadowColor | This is the color for the shadow of entities, views, etc. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property ShapeNameFont | This is the font for the shape name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property ShapeTextFont | This is the font for the shape text. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property ShowAttributeName | This determines whether attribute's physical name is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowCardinality | This determines whether cardinality is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowColumnName | This determines whether attribute's logical name is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityAlternateKey | This determines whether entity's alternate keys are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityAttachment | This determines whether entity's attachments are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityAttachmentValue | This determines whether entity's attachment values are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityAttributeBitmap | This determines whether entity's attribute bitmaps are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityDataSecurity | This determines whether entity's data security are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityDataSecurityValue | This determines whether entity's data security values are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityDataType | This determines whether entity's data types are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityDimensionalType | This determines whether entity's dimension type are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityDimensionAttributes | This determines whether entity's dimension attributes are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityDomain | This determines whether entity's domains are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityFactAttributes | This determines whether entity's fact attributes are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityIndex | This determines whether entity's indexes are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityInversionEntry | This determines whether entity's inversion entries are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityName | This determines whether entity's physical name is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityNameCompartment | This determines whether entity name compartments are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityNullOption | This determines whether entity's null options are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowEntityOwner | This determines whether entity's owner is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowGrid | This determines whether to show the grid (true) or not (false). DATATYPE: Boolean.
Public Property ShowRelationshipBusinessName | This determines whether relationship business names are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowRelationshipName | This determines whether relationship names are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowSchemaObjRelationships | This determines whether schema object relationships are drawn (true) or not (false). DATATYPE: Boolean.
Public Property ShowSchemaObjs | This determines whether schema objects are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowShapeNames | This determines whether shape names are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowTableName | This determines whether entity's logical name is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowTrigger | This sets the ShowTrigger flag. DATATYPE: Boolean.
Public Property ShowTriggerActions | This determines whether relationship trigger actions are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowVerbs | This determines whether verbs are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowViewNameCompartment | This determines whether view name compartments are displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowViewOwner | This determines whether view's owner is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowViewParentName | This determines whether view's parent name is displayed (true) or not (false). DATATYPE: Boolean.
Public Property ShowViewRelationships | This determines whether view relationships are drawn (true) or not (false). DATATYPE: Boolean.
Public Property ShowViews | This determines whether views are displayed (true) or not (false). DATATYPE: Boolean.
Public Property SnapToGrid | This determines whether to snap objects (entites, views, etc.) to the grid (true) or not (false). DATATYPE: Boolean.
Public Property StraightRelLine | This determines whether straight relationship lines are drawn (true) or not (false). DATATYPE: Boolean.
Public Property TextBackgroundColor | This is the color for the background of the text object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TextBlockBorderColor | This is the color for the border of the text object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TextBlockFont | This is the font for the text object. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property TextForegroundColor | This is the color for the text in text objects. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TitleBlockBackgroundColor | This is the color for the background of title blocks. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TitleBlockBorderColor | This is the color for the border of the title block. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TitleBlockFont | This is the font for the title block. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property TitleBlockTextColor | This is the color for the text of the title block. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TriggerColor | This is the color for Triggers. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property TriggerFont | This is the font for Triggers. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property VerbFont | This is the font for the verb. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property VerbTextColor | This is the color for the verb. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property VerticalScrollPosition | This is the vertical scroll bar position of the diagram display window. DATATYPE: Integer.
Public Property VerticalViewSize | This is the height of the diagram display window. DATATYPE: Integer.
Public Property ViewBackgroundColor | This is the color for the background of views. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property ViewDisplayFormat | This is the display format of Views in the submodel. The possible values are: 1 - Attributes, 2 - Entities, 3 - Primary Keys, 4 - All Keys, 5 - Definition, 6 - Note. DATATYPE: Integer.
Public Property ViewFieldFont | This is the font for local, non-key view fields. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property ViewFieldTextColor | This is the color for the view field text. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property ViewForegroundColor | This is the color for the foreground of views. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property ViewNameFont | This is the font for the view name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property ViewRelationshipColor | This is the color for the view relationship. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property ViewTitleColor | This is the color for the title text of views. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property WrapEntityName | This determines whether entity names are wrapped (true) or not (false). DATATYPE: Boolean.
Public Property WrapViewName | This determines whether view names are wrapped (true) or not (false). DATATYPE: Boolean.
Public Property ZoomFactor | This is the viewing zoom percentage of the submodel (ie, 50, 100, %200, etc.). DATATYPE: Integer.

See Also

SubModel Overview


%%PageItemTitle%%

ActivateSubModel Method

Description

Sets this SubModel as the Active Submodel.

Syntax

Visual Basic
Public Sub ActivateSubModel()

See Also

SubModel Object


%%PageItemTitle%%

AliasDisplays Method

Description

Returns an object representing a collection of all alias display objects in the submodel.

Syntax

Visual Basic
Public Function AliasDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

AuxiliaryTableDisplays Method

Description

Returns an object representing a collection of all auxiliary table display objects in the submodel.

Syntax

Visual Basic
Public Function AuxiliaryTableDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this SubModel.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

SubModel Object


%%PageItemTitle%%

BoundSecurityProperties Method

Description

Get all the BoundSecurityProperties of this SubModel.

Syntax

Visual Basic
Public Function BoundSecurityProperties() As BoundSecurityProperties

See Also

SubModel Object


%%PageItemTitle%%

BufferPoolDisplays Method

Description

Returns an object representing a collection of all buffer pool display objects in the submodel.

Syntax

Visual Basic
Public Function BufferPoolDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

BusinessDataObjectDisplays Method

Description

Returns an object representing a collection of all BusinessDataObject displays in the submodel.

Syntax

Visual Basic
Public Function BusinessDataObjectDisplays() As BusinessDataObjectDisplays

See Also

SubModel Object


%%PageItemTitle%%

DatabaseDisplays Method

Description

Returns an object representing a collection of all database display objects in the submodel.

Syntax

Visual Basic
Public Function DatabaseDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

DeleteNamingStandardsTemplate Method

Description

Unbind this Submodel from the naming standards template by deleting the naming standards template ID from the submodel.

Syntax

Visual Basic
Public Function DeleteNamingStandardsTemplate() As Variant

See Also

SubModel Object


%%PageItemTitle%%

EntityDisplays Method

Description

Returns an object representing a collection of all entity display objects in the submodel.

Syntax

Visual Basic
Public Function EntityDisplays() As EntityDisplays

Example

Dim MySubModel As SubModel

Dim CurrentEDs As EntityDisplays

CurrentEDs = MySubModel.EntityDisplays

See Also

SubModel Object


%%PageItemTitle%%

EntityNames Method
EntityNames
NumFetched

Description

Returns the names of all entities in the submodel. A user can pass in a Variant variable for the first parameter. PARAMETERS:EntityNames as Variant (an array will be filled in by the method), NumFetched as Integer (will be set by the method).

Syntax

Visual Basic
Public Sub EntityNames( _
   ByRef EntityNames As Variant, _
   ByRef NumFetched As Variant _
)

Parameters

EntityNames
NumFetched

Example

Sub Main

Dim diag As Diagram

Dim model As Model

Dim MySubModel As SubModel

Dim EntNames As Variant

Dim EntNum As Variant

Dim n As Integer

n = 0

Set diag = DiagramManager.ActiveDiagram

Set model = diag.ActiveModel

Set MySubModel = model.ActiveSubModel

Debug.Clear

MySubModel.EntityNames(EntNames, EntNum)

While n < EntNum

Debug.Print EntNames(n)

n = n + 1

Wend

End Sub

See Also

SubModel Object


%%PageItemTitle%%

ExportImageOptions Method

Description

Get ExportImageOptions object for this SubModel.

Syntax

Visual Basic
Public Function ExportImageOptions() As ExportImageOptions

See Also

SubModel Object


%%PageItemTitle%%

FunctionDisplays Method

Description

Returns an object representing a collection of all function display objects in the submodel.

Syntax

Visual Basic
Public Function FunctionDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

GetNamingStandardsTemplate Method

Description

Returns the naming standards template bound to the submodel or null, if none is bound to the submodel.

Syntax

Visual Basic
Public Function GetNamingStandardsTemplate() As NamingStandardsTemplate

See Also

SubModel Object


%%PageItemTitle%%

LineDisplays Method

Description

Returns an object representing a collection of all line display objects in the submodel.

Syntax

Visual Basic
Public Function LineDisplays() As LineDisplays

See Also

SubModel Object


%%PageItemTitle%%

MaterializedViewDisplays Method

Description

Returns an object representing a collection of all materialized view display objects in the submodel.

Syntax

Visual Basic
Public Function MaterializedViewDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

NodeGroupDisplays Method

Description

Returns an object representing a collection of all nodegroup display objects in the submodel.

Syntax

Visual Basic
Public Function NodeGroupDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

ObjectTypeDisplays Method

Description

Returns an object representing a collection of all object type display objects in the submodel.

Syntax

Visual Basic
Public Function ObjectTypeDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

PackageDisplays Method

Description

Returns an object representing a collection of all package display objects in the submodel.

Syntax

Visual Basic
Public Function PackageDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

PrintOptions Method

Description

Get PrintOptions object for this SubModel.

Syntax

Visual Basic
Public Function PrintOptions() As PrintOptions

See Also

SubModel Object


%%PageItemTitle%%

ProcedureDisplays Method

Description

Returns an object representing a collection of all procedure display objects in the submodel.

Syntax

Visual Basic
Public Function ProcedureDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

RelationshipDisplays Method

Description

Returns an object representing a collection of all relationship display objects in the submodel.

Syntax

Visual Basic
Public Function RelationshipDisplays() As RelationshipDisplays

Example

Dim MySubModel As SubModel

Dim CurrentRDs As RelationshipDisplays

CurrentRDs = MySubModel.RelationshipDisplays

See Also

SubModel Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this SubModel object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

SubModel Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this SubModel from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

SubModel Object


%%PageItemTitle%%

RollbackSegmentDisplays Method

Description

Returns an object representing a collection of all rollback segment display objects in the submodel.

Syntax

Visual Basic
Public Function RollbackSegmentDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

SchemaObjRelationshipDisplays Method

Description

Returns an object representing a collection of all schema object relationship display objects in the submodel.

Syntax

Visual Basic
Public Function SchemaObjRelationshipDisplays() As SchemaObjRelationshipDisplays

See Also

SubModel Object


%%PageItemTitle%%

SelectedObjects Method

Description

Returns an object representing a collection of all selected objects in the submodel.

Syntax

Visual Basic
Public Function SelectedObjects() As SelectedObjects

Example

Dim MySubModel As SubModel

Dim SelObj As SelectedObjects

SelObj = MySubModel.SelectedObjects

See Also

SubModel Object


%%PageItemTitle%%

SequenceDisplays Method

Description

Returns an object representing a collection of all sequence display objects in the submodel.

Syntax

Visual Basic
Public Function SequenceDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

ShapeDisplays Method

Description

Returns an object representing a collection of all shape display objects in the submodel.

Syntax

Visual Basic
Public Function ShapeDisplays() As ShapeDisplays

See Also

SubModel Object


%%PageItemTitle%%

StoGroupDisplays Method

Description

Returns an object representing a collection of all stogroup display objects in the submodel.

Syntax

Visual Basic
Public Function StoGroupDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

SynonymDisplays Method

Description

Returns an object representing a collection of all synonym display objects in the submodel.

Syntax

Visual Basic
Public Function SynonymDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

TablespaceDisplays Method

Description

Returns an object representing a collection of all tablespace display objects in the submodel.

Syntax

Visual Basic
Public Function TablespaceDisplays() As SchemaObjDisplays

See Also

SubModel Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of all the user comments associated with the submodel.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

SubModel Object


%%PageItemTitle%%

ViewDisplays Method

Description

Returns an object representing a collection of all view display objects in the submodel.

Syntax

Visual Basic
Public Function ViewDisplays() As ViewDisplays

See Also

SubModel Object


%%PageItemTitle%%

ViewNames Method

Description

Return all the View names in this Submodel. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function ViewNames() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ViewRelationshipDisplays Method

Description

Returns an object representing a collection of all view relationship display objects in the submodel.

Syntax

Visual Basic
Public Function ViewRelationshipDisplays() As ViewRelationshipDisplays

Example

Dim MySubModel As SubModel

Dim VRDs As ViewRelationshipDisplays

VRDs = MySubModel.ViewRelationshipDisplays

See Also

SubModel Object


%%PageItemTitle%%

AttachmentColor Property

Description

This is the color for Attachments. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property AttachmentColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

AttachmentFont Property

Description

This is the font for Attachments. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property AttachmentFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

AttributeFont Property

Description

This is the font for local, non-key attributes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property AttributeFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.AttributeFont

See Also

SubModel Object


%%PageItemTitle%%

CompleteRoleName Property

Description

This determines whether complete role names are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property CompleteRoleName() As Variant

Example

Dim MySubModel As SubModel

Dim CmpRlNm As Boolean

MySubModel.CompleteRoleName = CmpRlNm

See Also

SubModel Object


%%PageItemTitle%%

DataSecurityColor Property

Description

This is the color for Data Security. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property DataSecurityColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

DataSecurityFont Property

Description

This is the font for Data Security. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataSecurityFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

Definition Property

Description

This is the submodel definition property. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

SubModel Object


%%PageItemTitle%%

DiagramBackgroundColor Property

Description

This is the color for the background of the submodel. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property DiagramBackgroundColor() As Variant

Remarks

Here is the hexadecimal representation: 0x00bbggrr

Example

Dim MySubModel As SubModel

MySubModel.DiagramBackgroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

EntityBackgroundColor Property

Description

This is the color for the background of the entity. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityBackgroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

'

MySubModel.EntityBackgroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

EntityDimTypeLabelColor Property

Description

This is the color for Entity Dimension Type Label. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityDimTypeLabelColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

EntityDimTypeLabelFont Property

Description

This is the font for Entity Dimension Type Label. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property EntityDimTypeLabelFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

EntityDisplayFormat Property

Description

This is the display format of Entities in the submodel. The possible values are: 1 - Attributes, 2 - Entities, 3 - Primary Keys, 4 - All Keys, 5 - Definition, 6 - Note. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityDisplayFormat() As Variant

Remarks

The possible values are:
1 - Attributes level
Note: Defaults to the logical attribute order in the logical model and the physical display order in the physical model.
2 - Entities level
3 - Primary Keys level
4 - All Keys level
5 - Definition level
6 - Notes
7 - Logical Attribute Order
8 - Physical Column Order

Example

Dim MySubModel As SubModel

MySubModel.DisplayFormat = 3

See Also

SubModel Object


%%PageItemTitle%%

EntityForegroundColor Property

Description

This is the color for the foreground of the entity. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityForegroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.EntityForegroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

EntityNameFont Property

Description

This is the font for the entity name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property EntityNameFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.EntityNameFont

See Also

SubModel Object


%%PageItemTitle%%

EntityTitleColor Property

Description

This is the color for the title of the entity. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityTitleColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.EntityTitleColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

ForeignKeyFont Property

Description

This is the font for foreign key attributes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ForeignKeyFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.ForeignKeyFont

See Also

SubModel Object


%%PageItemTitle%%

ForeignNonKeyFont Property

Description

This is the font for foreign, non-key attributes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ForeignNonKeyFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.ForeignNonKeyFont

See Also

SubModel Object


%%PageItemTitle%%

GridSpacing Property

Description

This is the spacing for grid points. DATATYPE: Double.

Property type

Read-write property

Syntax

Visual Basic
Public Property GridSpacing() As Variant

See Also

SubModel Object


%%PageItemTitle%%

GridsPerLine Property

Description

This is the number of grid points per line. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GridsPerLine() As Variant

See Also

SubModel Object


%%PageItemTitle%%

GridUnits Property

Description

This is the unit type for the grid measurement. The possible values are: 0 - Inches, 1 - Centimeters. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property GridUnits() As Variant

Example

Dim MySubModel As SubModel

MySubModel.GridUnits = 1

See Also

SubModel Object


%%PageItemTitle%%

GUID Property

Description

GUID of the submodel. This GUID is assigned by ER/Studio. Each submodel has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SubModel Object


%%PageItemTitle%%

HorizontalScrollPosition Property

Description

This is the horizontal scroll bar position of the diagram display window. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalScrollPosition() As Variant

Example

Dim MySubModel As SubModel

MySubModel.HorizontalScrollPosition = 50

See Also

SubModel Object


%%PageItemTitle%%

HorizontalViewSize Property

Description

This is the width of the diagram display window. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalViewSize() As Variant

Example

Dim MySubModel As SubModel

MySubModel.HorizontalViewSize = 100

See Also

SubModel Object


%%PageItemTitle%%

ID Property

Description

ID of the submodel. This ID is assigned by ER/Studio. Each submodel in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MySubModel As SubModel

Dim MyID As Integer

MyID = MySubModel.ID

See Also

SubModel Object


%%PageItemTitle%%

IndexColor Property

Description

This is the color for Indexes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

IndexFont Property

Description

This is the font for Indexes. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property IndexFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

InheritedNonKeyColor Property

Description

This is the color for the foreign, non-key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property InheritedNonKeyColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.InheritedNonKeyColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

InheritedPrimaryKeyColor Property

Description

This is the color for foreign, primary key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property InheritedPrimaryKeyColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.InheritedPrimaryKeyColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

InheritOption Property

Description

This determines if the submodel will inherit objects added to nested submodels. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property InheritOption() As Variant

See Also

SubModel Object


%%PageItemTitle%%

IsActive Property

Description

This indicates if the submodel is the one currently displayed. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsActive() As Variant

See Also

SubModel Object


%%PageItemTitle%%

MainSubModel Property

Description

This tells the user whether the currently displayed submodel is the main sub model (true) or not (false). DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property MainSubModel() As Variant

Example

Dim MySubModel As SubModel

Dim MainSubMod As Boolean

MainSubMod = MySubModel.MainSubModel

See Also

SubModel Object


%%PageItemTitle%%

Name Property

Description

This is the name of the submodel. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

Example

Dim MySubModel As SubModel

Dim SubName As String

SubName = "Submarine"

MySubModel.Name = SubName

See Also

SubModel Object


%%PageItemTitle%%

NamingStandardsTemplateId Property

Description

ID of the NamingStandardsTemplate object bound to the submodel (if any). A user can bind a NamingStandardsTemplate to the submodel by assigning a particular NamingStandardsTemplateId to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamingStandardsTemplateId() As Variant

See Also

SubModel Object


%%PageItemTitle%%

NonInheritedNonKeyColor Property

Description

This is the color for local, non-key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NonInheritedNonKeyColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.NonInheritedNonKeyColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

NonInheritedPrimaryKeyColor Property

Description

This is the color for local, primary key attributes. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NonInheritedPrimaryKeyColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.NonInheritedPrimaryKeyColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

OffPageBackgroundColor Property

Description

This is the color for the background of the off page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OffPageBackgroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.OffPageBackgroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

OffPageForegroundColor Property

Description

This is the color for the foreground of the off page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OffPageForegroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.OffPageForegroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

PageBoundary Property

Description

This is the page boundary. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageBoundary() As Variant

Example

Dim MySubModel As SubModel

Dim PageBound As Integer

PageBound = 100

MySubModel.PageBoundary = PageBound

See Also

SubModel Object


%%PageItemTitle%%

PageForegroundColor Property

Description

This is the color for the foreground of the page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property PageForegroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.PageForegroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

PageNumberColor Property

Description

This is the color for the number of the page. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property PageNumberColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.PageNumberColor = 669933

See Definitions for an explanation of the format and datatypes

See Also

SubModel Object


%%PageItemTitle%%

PageNumberFont Property

Description

This is the font for the page numbers. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property PageNumberFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.PageNumberFont

See Also

SubModel Object


%%PageItemTitle%%

PageOrientation Property

Description

This is the page orientation. The possible values are: 1 - Portrait, 2 - Landscape. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageOrientation() As Variant

Example

Dim MySubModel As SubModel

Dim PageOrient As Integer

PageOrient = 1

MySubModel.PageOrientation = PageOrient

See Also

SubModel Object


%%PageItemTitle%%

PageSize Property

Description

This is the page size. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageSize() As Variant

Remarks

Select the Integer corresponding to your paper below, e.g. Letter size = 1.

Const DMPAPER_LETTER = 1< /FONT >

Const DMPAPER_LETTERSMALL = 2 ' Letter Small 8 1/2 x 11 in< /FONT >

Const DMPAPER_TABLOID = 3 ' Tabloid 11 x 17 in< /FONT >

Const DMPAPER_LEDGER = 4 ' Ledger 17 x 11 in< /FONT >

Const DMPAPER_LEGAL = 5 ' Legal 8 1/2 x 14 in< /FONT >

Const DMPAPER_STATEMENT = 6 ' Statement 5 1/2 x 8 1/2 in< /FONT >

Const DMPAPER_EXECUTIVE = 7 ' Executive 7 1/4 x 10 1/2 in< /FONT >

Const DMPAPER_A3 = 8 ' A3 297 x 420 mm< /FONT >

Const DMPAPER_A4 = 9 ' A4 210 x 297 mm< /FONT >

Const DMPAPER_A4SMALL = 10 ' A4 Small 210 x 297 mm< /FONT >

Const DMPAPER_A5 = 11 ' A5 148 x 210 mm< /FONT >

Const DMPAPER_B4 = 12 ' B4 250 x 354< /FONT >

Const DMPAPER_B5 = 13 ' B5 182 x 257 mm< /FONT >

Const DMPAPER_FOLIO = 14 ' Folio 8 1/2 x 13 in< /FONT >

Const DMPAPER_QUARTO = 15 ' Quarto 215 x 275 mm< /FONT >

Const DMPAPER_10X14 = 16 ' 10x14 in< /FONT >

Const DMPAPER_11X17 = 17 ' 11x17 in< /FONT >

Const DMPAPER_NOTE = 18 ' Note 8 1/2 x 11 in< /FONT >

Const DMPAPER_ENV_9 = 19 ' Envelope #9 3 7/8 x 8 7/8< /FONT >

Const DMPAPER_ENV_10 = 20 ' Envelope #10 4 1/8 x 9 1/2< /FONT >

Const DMPAPER_ENV_11 = 21 ' Envelope #11 4 1/2 x 10 3/8< /FONT >

Const DMPAPER_ENV_12 = 22 ' Envelope #12 4 \276 x 11< /FONT >

Const DMPAPER_ENV_14 = 23 ' Envelope #14 5 x 11 1/2< /FONT >

Const DMPAPER_CSHEET = 24 ' C size sheet< /FONT >

Const DMPAPER_DSHEET = 25 ' D size sheet< /FONT >

Const DMPAPER_ESHEET = 26 ' E size sheet< /FONT >

Const DMPAPER_ENV_DL = 27 ' Envelope DL 110 x 220mm< /FONT >

Const DMPAPER_ENV_C5 = 28 ' Envelope C5 162 x 229 mm< /FONT >

Const DMPAPER_ENV_C3 = 29 ' Envelope C3 324 x 458 mm< /FONT >

Const DMPAPER_ENV_C4 = 30 ' Envelope C4 229 x 324 mm< /FONT >

Const DMPAPER_ENV_C6 = 31 ' Envelope C6 114 x 162 mm< /FONT >

Const DMPAPER_ENV_C65 = 32 ' Envelope C65 114 x 229 mm< /FONT >

Const DMPAPER_ENV_B4 = 33 ' Envelope B4 250 x 353 mm< /FONT >

Const DMPAPER_ENV_B5 = 34 ' Envelope B5 176 x 250 mm< /FONT >

Const DMPAPER_ENV_B6 = 35 ' Envelope B6 176 x 125 mm< /FONT >

Const DMPAPER_ENV_ITALY = 36 ' Envelope 110 x 230 mm< /FONT >

Const DMPAPER_ENV_MONARCH = 37 ' Envelope Monarch 3.875 x 7.5 in< /FONT >

Const DMPAPER_ENV_PERSONAL = 38 ' 6 3/4 Envelope 3 5/8 x 6 1/2 in< /FONT >

Const DMPAPER_FANFOLD_US = 39 ' US Std Fanfold 14 7/8 x 11 in< /FONT >

Const DMPAPER_FANFOLD_STD_GERMAN = 40 ' German Std Fanfold 8 1/2 x 12 in< /FONT >

Const DMPAPER_FANFOLD_LGL_GERMAN = 41 ' German Legal Fanfold 8 1/2 x 13 in< /FONT >

Const DMPAPER_LAST = DMPAPER_FANFOLD_LGL_GERMAN< /FONT >

Const DMPAPER_USER = 256< /FONT >

42 through 256 are printer defined.

Example

Dim MySubModel As SubModel

Dim PageSize As Integer

PageSize = 1

MySubModel.PageSize = PageSize

See Also

SubModel Object


%%PageItemTitle%%

ParentSubmodelID Property

Description

ID of the parent Submodel object if this Submodel is a child in a nested Submodel. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentSubmodelID() As Variant

See Also

SubModel Object


%%PageItemTitle%%

PrimaryKeyFont Property

Description

This is the font for the local, primary key font. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property PrimaryKeyFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.PrimaryKeyFont

See Also

SubModel Object


%%PageItemTitle%%

RelationshipBusinessNameColor Property

Description

This is the color for the relationship business name. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property RelationshipBusinessNameColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

RelationshipBusinessNameFont Property

Description

This is the font for the relationship business name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property RelationshipBusinessNameFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

RelationshipColor Property

Description

This is the color for the relationships. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property RelationshipColor() As Variant

Example

Dim MySubModel As SubModel

MySubModel.RelationshipColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

RelationshipNameColor Property

Description

This is the color for the relationship name. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property RelationshipNameColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

RelationshipNameFont Property

Description

This is the font for the relationship name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property RelationshipNameFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

SchemaObjDisplayFormat Property

Description

This is the display format of Schema Objects in the submodel. The possible values are: 1 - Name, 2 - Definition. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property SchemaObjDisplayFormat() As Variant

Example

Dim MySubModel As SubModel

MySubModel.SchemaObjDisplayFormat = 1

See Also

SubModel Object


%%PageItemTitle%%

Shadow Property

Description

This determines whether shadows are drawn (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Shadow() As Variant

Example

Dim MySubModel As SubModel

Dim Shadow As Boolean

Shadow = True

MySubModel.Shadow = Shadow

See Also

SubModel Object


%%PageItemTitle%%

ShadowColor Property

Description

This is the color for the shadow of entities, views, etc. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ShadowColor() As Variant

Example

Dim MySubModel As SubModel

MySubModel.ShadowColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

ShapeNameFont Property

Description

This is the font for the shape name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ShapeNameFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

ShapeTextFont Property

Description

This is the font for the shape text. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ShapeTextFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

ShowAttributeName Property

Description

This determines whether attribute's physical name is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowAttributeName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowCardinality Property

Description

This determines whether cardinality is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowCardinality() As Variant

Example

Dim MySubModel As SubModel

Dim Cardinality As Boolean

Cardinality = True

MySubModel.ShowCardinality = Cardinality

See Also

SubModel Object


%%PageItemTitle%%

ShowColumnName Property

Description

This determines whether attribute's logical name is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowColumnName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityAlternateKey Property

Description

This determines whether entity's alternate keys are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityAlternateKey() As Variant

Example

Dim MySubModel As SubModel

Dim EntityAlternateKey As Boolean

EntityAlternateKey = True

MySubModel.ShowEntityAlternateKey = EntityAlternateKey

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityAttachment Property

Description

This determines whether entity's attachments are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityAttachment() As Variant

Example

Dim MySubModel As SubModel

Dim EntityAttachment As Boolean

EntityAttachment = True

MySubModel.ShowEntityAttachment = EntityAttachment

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityAttachmentValue Property

Description

This determines whether entity's attachment values are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityAttachmentValue() As Variant

Example

Dim MySubModel As SubModel

Dim EntityAttachmentValue As Boolean

EntityAttachmentValue = True

MySubModel.ShowEntityAttachmentValue = EntityAttachmentValue

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityAttributeBitmap Property

Description

This determines whether entity's attribute bitmaps are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityAttributeBitmap() As Variant

Example

Dim MySubModel As SubModel

Dim EntityAttributeBitmap As Boolean

EntityAttributeBitmap = True

MySubModel.ShowEntityAttributeBitmap = EntityAttributeBitmap

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityDataSecurity Property

Description

This determines whether entity's data security are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityDataSecurity() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityDataSecurityValue Property

Description

This determines whether entity's data security values are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityDataSecurityValue() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityDataType Property

Description

This determines whether entity's data types are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityDataType() As Variant

Example

Dim MySubModel As SubModel

Dim EntityDataType As Boolean

EntityDataType = True

MySubModel.ShowEntityDataType = EntityDataType

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityDimensionalType Property

Description

This determines whether entity's dimension type are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityDimensionalType() As Variant

Example

Dim MySubModel As SubModel

Dim EntityDimensionalType As Boolean

EntityDimensionalType = True

MySubModel.ShowEntityDimensionalType = EntityDimensionalType

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityDimensionAttributes Property

Description

This determines whether entity's dimension attributes are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityDimensionAttributes() As Variant

Example

Dim MySubModel As SubModel

Dim EntityDimensionAttributes As Boolean

EntityDimensionAttributes = True

MySubModel.ShowEntityDimensionAttributes = EntityDimensionAttributes

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityDomain Property

Description

This determines whether entity's domains are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityDomain() As Variant

Example

Dim MySubModel As SubModel

Dim EntityDomain As Boolean

EntityDomain = True

MySubModel.ShowEntityDomain = EntityDomain

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityFactAttributes Property

Description

This determines whether entity's fact attributes are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityFactAttributes() As Variant

Example

Dim MySubModel As SubModel

Dim EntityFactAttributes As Boolean

EntityFactAttributes = True

MySubModel.ShowEntityFactAttributes = EntityFactAttributes

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityIndex Property

Description

This determines whether entity's indexes are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityIndex() As Variant

Example

Dim MySubModel As SubModel

Dim EntityIndex As Boolean

EntityIndex = True

MySubModel.ShowEntityIndex = EntityIndex

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityInversionEntry Property

Description

This determines whether entity's inversion entries are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityInversionEntry() As Variant

Example

Dim MySubModel As SubModel

Dim EntityInversionEntry As Boolean

EntityInversionEntry = True

MySubModel.ShowEntityInversionEntry = EntityInversionEntry

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityName Property

Description

This determines whether entity's physical name is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityNameCompartment Property

Description

This determines whether entity name compartments are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityNameCompartment() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityNullOption Property

Description

This determines whether entity's null options are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityNullOption() As Variant

Example

Dim MySubModel As SubModel

Dim EntityNullOption As Boolean

EntityNullOption = True

MySubModel.ShowEntityNullOption = EntityNullOption

See Also

SubModel Object


%%PageItemTitle%%

ShowEntityOwner Property

Description

This determines whether entity's owner is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEntityOwner() As Variant

Example

Dim MySubModel As SubModel

Dim EntityOwner As Boolean

EntityOwner = True

MySubModel.ShowEntityOwner = EntityOwner

See Also

SubModel Object


%%PageItemTitle%%

ShowGrid Property

Description

This determines whether to show the grid (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowGrid() As Variant

Example

Dim MySubModel As SubModel

Dim ShoGrid As Boolean

ShoGrid = True

MySubModel.ShowGrid = ShoGrid

See Also

SubModel Object


%%PageItemTitle%%

ShowRelationshipBusinessName Property

Description

This determines whether relationship business names are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowRelationshipBusinessName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowRelationshipName Property

Description

This determines whether relationship names are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowRelationshipName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowSchemaObjRelationships Property

Description

This determines whether schema object relationships are drawn (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowSchemaObjRelationships() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowSchemaObjs Property

Description

This determines whether schema objects are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowSchemaObjs() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowShapeNames Property

Description

This determines whether shape names are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowShapeNames() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowTableName Property

Description

This determines whether entity's logical name is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowTableName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowTrigger Property

Description

This sets the ShowTrigger flag. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowTrigger() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowTriggerActions Property

Description

This determines whether relationship trigger actions are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowTriggerActions() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowVerbs Property

Description

This determines whether verbs are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowVerbs() As Variant

Example

Dim MySubModel As SubModel

Dim Verbs As Boolean

Verbs = True

MySubModel.ShowVerbs = Verbs

See Also

SubModel Object


%%PageItemTitle%%

ShowViewNameCompartment Property

Description

This determines whether view name compartments are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowViewNameCompartment() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ShowViewOwner Property

Description

This determines whether view's owner is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowViewOwner() As Variant

Example

Dim MySubModel As SubModel

Dim Verbs As Boolean

Verbs = True

MySubModel.ShowViewOwner = Verbs

See Also

SubModel Object


%%PageItemTitle%%

ShowViewParentName Property

Description

This determines whether view's parent name is displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowViewParentName() As Variant

Example

Dim MySubModel As SubModel

Dim Verbs As Boolean

Verbs = True

MySubModel.ShowViewParentName = Verbs

See Also

SubModel Object


%%PageItemTitle%%

ShowViewRelationships Property

Description

This determines whether view relationships are drawn (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowViewRelationships() As Variant

Example

Dim MySubModel As SubModel

Dim ShoViewRels As Boolean

ShoViewRels = True

MySubModel.ShowViewRelationships = ShoViewRels

See Also

SubModel Object


%%PageItemTitle%%

ShowViews Property

Description

This determines whether views are displayed (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowViews() As Variant

Example

Dim MySubModel As SubModel

Dim ShoViews As Boolean

ShoViews = True

MySubModel.ShowViews = ShoViews

See Also

SubModel Object


%%PageItemTitle%%

SnapToGrid Property

Description

This determines whether to snap objects (entites, views, etc.) to the grid (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SnapToGrid() As Variant

Example

Dim MySubModel As SubModel

Dim SnapTo As Boolean = True

SnapTo = True

MySubModel.SnapToGrid = SnapTo

See Also

SubModel Object


%%PageItemTitle%%

StraightRelLine Property

Description

This determines whether straight relationship lines are drawn (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property StraightRelLine() As Variant

Example

Dim MySubModel As SubModel

Dim StrRelLine As Boolean

StrRelLine = True

MySubModel.StraightRelLine = StrRelLine

See Also

SubModel Object


%%PageItemTitle%%

TextBackgroundColor Property

Description

This is the color for the background of the text object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TextBackgroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.TextBackgroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

TextBlockBorderColor Property

Description

This is the color for the border of the text object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TextBlockBorderColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.TextBlockBorderColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

TextBlockFont Property

Description

This is the font for the text object. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property TextBlockFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.TextBlockFont

See Also

SubModel Object


%%PageItemTitle%%

TextForegroundColor Property

Description

This is the color for the text in text objects. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TextForegroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.TextForegroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

TitleBlockBackgroundColor Property

Description

This is the color for the background of title blocks. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleBlockBackgroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.TitleBlockBackgroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

TitleBlockBorderColor Property

Description

This is the color for the border of the title block. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleBlockBorderColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.TitleBlockBorderColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

TitleBlockFont Property

Description

This is the font for the title block. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property TitleBlockFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.TitleBlockFont

See Also

SubModel Object


%%PageItemTitle%%

TitleBlockTextColor Property

Description

This is the color for the text of the title block. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleBlockTextColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.TitleBlockTextColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

TriggerColor Property

Description

This is the color for Triggers. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerColor() As Variant

See Also

SubModel Object


%%PageItemTitle%%

TriggerFont Property

Description

This is the font for Triggers. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property TriggerFont() As ERSFont

See Also

SubModel Object


%%PageItemTitle%%

VerbFont Property

Description

This is the font for the verb. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property VerbFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.VerbFont

See Also

SubModel Object


%%PageItemTitle%%

VerbTextColor Property

Description

This is the color for the verb. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property VerbTextColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.VerbTextColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

VerticalScrollPosition Property

Description

This is the vertical scroll bar position of the diagram display window. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalScrollPosition() As Variant

Example

Dim MySubModel As SubModel

MySubModel.VerticalScrollPosition = 50

See Also

SubModel Object


%%PageItemTitle%%

VerticalViewSize Property

Description

This is the height of the diagram display window. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalViewSize() As Variant

Example

Dim MySubModel As SubModel

MySubModel.VerticalViewSize = 100

See Also

SubModel Object


%%PageItemTitle%%

ViewBackgroundColor Property

Description

This is the color for the background of views. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewBackgroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.ViewBackgroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

ViewDisplayFormat Property

Description

This is the display format of Views in the submodel. The possible values are: 1 - Attributes, 2 - Entities, 3 - Primary Keys, 4 - All Keys, 5 - Definition, 6 - Note. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewDisplayFormat() As Variant

Example

Dim MySubModel As SubModel

Dim VDs As ViewDisplays
VDs = MySubModel.ViewDisplays

See Also

SubModel Object


%%PageItemTitle%%

ViewFieldFont Property

Description

This is the font for local, non-key view fields. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ViewFieldFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.ViewFieldFont

See Also

SubModel Object


%%PageItemTitle%%

ViewFieldTextColor Property

Description

This is the color for the view field text. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewFieldTextColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.ViewFieldTextColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

ViewForegroundColor Property

Description

This is the color for the foreground of views. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewForegroundColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.ViewForegroundColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

ViewNameFont Property

Description

This is the font for the view name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ViewNameFont() As ERSFont

Example

Dim MySubModel As SubModel

Dim MyERSFont As ERSFont

Set MyERSFont = MySubModel.ViewNameFont

See Also

SubModel Object


%%PageItemTitle%%

ViewRelationshipColor Property

Description

This is the color for the view relationship. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewRelationshipColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.ViewRelationshipColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

ViewTitleColor Property

Description

This is the color for the title text of views. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewTitleColor() As Variant

Remarks

Hex representation: 0x00bbggrr, or Integer: bbggrr.

Example

Dim MySubModel As SubModel

MySubModel.ViewTitleColor = 669933

See Also

SubModel Object


%%PageItemTitle%%

WrapEntityName Property

Description

This determines whether entity names are wrapped (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property WrapEntityName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

WrapViewName Property

Description

This determines whether view names are wrapped (true) or not (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property WrapViewName() As Variant

See Also

SubModel Object


%%PageItemTitle%%

ZoomFactor Property

Description

This is the viewing zoom percentage of the submodel (ie, 50, 100, %200, etc.). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ZoomFactor() As Variant

Example

Dim MySubModel As SubModel

MySubModel.ZoomFactor = 200

See Also

SubModel Object


%%PageItemTitle%%

SubModels Collection
See Also Members

Description

This object represents a collection of submodels. The owner of this collection is the model.

Object Model

See Also

SubModels Members


%%PageItemTitle%% $$Members$$

SubModels Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new submodel with the given name, and returns the new submodel to the caller. Only objects which are selected in the main model will be added to the new submodel. PARAMETERS: Name as String.
Public Method Remove | Deletes a SubModel object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SubModel object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of SubModel objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a SubModel object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

See Also

SubModels Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates a new submodel with the given name, and returns the new submodel to the caller. Only objects which are selected in the main model will be added to the new submodel. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As SubModel

Parameters

Name

Example

Dim MyModel As Model

Dim NewSubModelName As String

NewSubModelName = "Sales"

MyModel.SubModels.Add(NewSubModelName)

See Also

SubModels Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a SubModel object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

Example

Dim MyModel As Model

Dim strRemove As String

strRemove = "Sales"

MyModel.SubModels.Remove(strRemove)

See Also

SubModels Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SubModel object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SubModel

Parameters

Identifier

See Also

SubModels Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SubModels Collection


%%PageItemTitle%%

Count Property

Description

This is the number of SubModel objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

Example

Dim MyDiagram As Diagram

Dim MyModel As Model

Dim ModelName As String

Dim iCount As Long

ModelName = "Physical"

Set MyDiagram = DiagramManager.ActiveDiagram

Set MyModel = MyDiagram.Models.Item(ModelName)

MyModel.SubModels.Count = iCount

See Also

SubModels Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SubModel object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SubModel

Parameters

Identifier

Example

Dim MyModel As Model

Dim MySubModel As SubModel

Dim ModelName As String

Dim SubModelName As String

ModelName = "Physical"

SubModelName = "Sales"

Set MyModel = MyDiagram.Models.Item(ModelName)

Set MySubModel = MyModel.SubModels.Item(SubModelName)

See Also

SubModels Collection


%%PageItemTitle%%

SubType Object
See Also Members

Description

This object represents a SubType in a SubTypeCluster.

Object Model

See Also

SubType Members


%%PageItemTitle%% $$Members$$

SubType Object Members
See Also Overview

Public Properties

Public Property Entity | This is the SubType for the SubTypeCluster.
Public Property GUID | GUID of the SubType. This GUID is assigned by ER/Studio. Each SubType has a unique GUID. DATATYPE: String.
Public Property ID | ID of the SubType. This ID is assigned by ER/Studio. Each SubType in a diagram has a unique ID. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

See Also

SubType Overview


%%PageItemTitle%%

Entity Property

Description

This is the SubType for the SubTypeCluster.

Property type

Read-only property

Syntax

Visual Basic
Public Property Entity() As Entity

See Also

SubType Object


%%PageItemTitle%%

GUID Property

Description

GUID of the SubType. This GUID is assigned by ER/Studio. Each SubType has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SubType Object


%%PageItemTitle%%

ID Property

Description

ID of the SubType. This ID is assigned by ER/Studio. Each SubType in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SubType Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

SubType Object


%%PageItemTitle%%

SubTypeCluster Object
See Also Members

Description

This object represents a SubTypeCluster in ER/Studio.

Object Model

See Also

SubTypeCluster Members


%%PageItemTitle%% $$Members$$

SubTypeCluster Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this SubTypeCluster.
Public Method RepoCheckOutStatus | Get the Check Out status of this SubTypeCluster object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this SubTypeCluster from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method SubTypes | Returns an object representing a collection of all SubTypes in the SubTypeCluster.

Public Properties

Public Property Discriminator | This is the AttributeName of the Discrminator for the SubTypeCluster. DATATYPE: String.
Public Property GUID | GUID of the SubTypeCluster. This GUID is assigned by ER/Studio. Each SubTypeCluster has a unique GUID. DATATYPE: String.
Public Property ID | ID of the SubTypeCluster. This ID is assigned by ER/Studio. Each SubTypeCluster in a diagram has a unique ID. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property Membership | This is the Membership type of SubTypeCluster where Exclusive - 1 and Inclusive - 2. DATATYPE: Integer.
Public Property SuperType | This is the SuperType for the SubTypeCluster.
Public Property Type | This is the Type of SubTypeCluster where Complete - 0 and InComplete - 1. DATATYPE: Integer.

See Also

SubTypeCluster Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this SubTypeCluster.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

SubTypeCluster Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this SubTypeCluster object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this SubTypeCluster from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

SubTypes Method

Description

Returns an object representing a collection of all SubTypes in the SubTypeCluster.

Syntax

Visual Basic
Public Function SubTypes() As SubTypes

See Also

SubTypeCluster Object


%%PageItemTitle%%

Discriminator Property

Description

This is the AttributeName of the Discrminator for the SubTypeCluster. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Discriminator() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

GUID Property

Description

GUID of the SubTypeCluster. This GUID is assigned by ER/Studio. Each SubTypeCluster has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

ID Property

Description

ID of the SubTypeCluster. This ID is assigned by ER/Studio. Each SubTypeCluster in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

Membership Property

Description

This is the Membership type of SubTypeCluster where Exclusive - 1 and Inclusive - 2. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Membership() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

SuperType Property

Description

This is the SuperType for the SubTypeCluster.

Property type

Read-only property

Syntax

Visual Basic
Public Property SuperType() As Entity

See Also

SubTypeCluster Object


%%PageItemTitle%%

Type Property

Description

This is the Type of SubTypeCluster where Complete - 0 and InComplete - 1. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

SubTypeCluster Object


%%PageItemTitle%%

SubTypeClusters Collection
See Also Members

Description

This object represents a collection of SubTypeCluster in ER/Studio. The owner of this collection is the model.

Object Model

See Also

SubTypeClusters Members


%%PageItemTitle%% $$Members$$

SubTypeClusters Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a SubTypeCluster. The SubTypeCluster types are: Incomplete - 0 and Complete - 1. PARAMETERS: ParentEntity as String, ChildEntity as String, SubTypeType as Integer.
Public Method Remove | Deletes a SubTypeCluster object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SubTypeCluster object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of SubTypeCluster objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a SubTypeCluster object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

SubTypeClusters Overview


%%PageItemTitle%%

Add Method
ParentEntity
ChildEntity
SubTypeClusterType

Description

Creates a SubTypeCluster. The SubTypeCluster types are: Incomplete - 0 and Complete - 1. PARAMETERS: ParentEntity as String, ChildEntity as String, SubTypeType as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal ParentEntity As Variant, _
   ByVal ChildEntity As Variant, _
   ByVal SubTypeClusterType As Variant _
) As SubTypeCluster

Parameters

ParentEntity
ChildEntity
SubTypeClusterType

See Also

SubTypeClusters Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a SubTypeCluster object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SubTypeClusters Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SubTypeCluster object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SubTypeCluster

Parameters

Identifier

See Also

SubTypeClusters Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SubTypeClusters Collection


%%PageItemTitle%%

Count Property

Description

This is the number of SubTypeCluster objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SubTypeClusters Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SubTypeCluster object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SubTypeCluster

Parameters

Identifier

See Also

SubTypeClusters Collection


%%PageItemTitle%%

SubTypes Collection
See Also Members

Description

This object represents a collection of SubType in a SubTypeCluster.

Object Model

See Also

SubTypes Members


%%PageItemTitle%% $$Members$$

SubTypes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new SubType and return it to the caller. PARAMETERS: EntityName as String.
Public Method Remove | Deletes a SubType object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a SubType object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of SubType objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a SubType object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

SubTypes Overview


%%PageItemTitle%%

Add Method
EntityName

Description

Creates a new SubType and return it to the caller. PARAMETERS: EntityName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal EntityName As Variant _
) As SubType

Parameters

EntityName

See Also

SubTypes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a SubType object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

SubTypes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a SubType object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As SubType

Parameters

Identifier

See Also

SubTypes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

SubTypes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of SubType objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

SubTypes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a SubType object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As SubType

Parameters

Identifier

See Also

SubTypes Collection


%%PageItemTitle%%

TableCheckConstraint Object
See Also Members

Description

This object represents a Table Level Check Constraint in ER/Studio.

See Also

TableCheckConstraint Members


%%PageItemTitle%% $$Members$$

TableCheckConstraint Object Members
See Also Overview

Public Properties

Public Property ConstraintName | Returns the ConstraintName of this Table level Check Constraint. DATATYPE: String.
Public Property ConstraintText | Returns the ConstraintText of this Table level Check Constraint. DATATYPE: String.
Public Property GUID | Returns the Table level Check Constraint's GUID. DATATYPE: String.
Public Property ID | Returns the Table level Check Constraint ID. DATATYPE: Integer.

See Also

TableCheckConstraint Overview


%%PageItemTitle%%

ConstraintName Property

Description

Returns the ConstraintName of this Table level Check Constraint. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConstraintName() As Variant

See Also

TableCheckConstraint Object


%%PageItemTitle%%

ConstraintText Property

Description

Returns the ConstraintText of this Table level Check Constraint. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConstraintText() As Variant

See Also

TableCheckConstraint Object


%%PageItemTitle%%

GUID Property

Description

Returns the Table level Check Constraint's GUID. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

TableCheckConstraint Object


%%PageItemTitle%%

ID Property

Description

Returns the Table level Check Constraint ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

TableCheckConstraint Object


%%PageItemTitle%%

TableCheckConstraints Collection
See Also Members

Description

This object represents a collection of TableCheckConstraint. The owner of this collection is the Entity object.

Object Model

See Also

TableCheckConstraints Members


%%PageItemTitle%% $$Members$$

TableCheckConstraints Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new TableCheckConstraint in the collection and returns the pointer. PARAMETERS: Name as String, Text as String.
Public Method Remove | Deletes a Table level Check Constraint object specified by the given Identifier. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a TableCheckConstraint object specified by the given Identifier. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Table level Check Constraint objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a TableCheckConstraint object specified by the given Identifier. PARAMETERS: Identifier as String or Integer.

See Also

TableCheckConstraints Overview


%%PageItemTitle%%

Add Method
Name
Text

Description

Creates a new TableCheckConstraint in the collection and returns the pointer. PARAMETERS: Name as String, Text as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant, _
   ByVal Text As Variant _
) As TableCheckConstraint

Parameters

Name
Text

See Also

TableCheckConstraints Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Table level Check Constraint object specified by the given Identifier. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

TableCheckConstraints Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a TableCheckConstraint object specified by the given Identifier. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As TableCheckConstraint

Parameters

Identifier

See Also

TableCheckConstraints Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

TableCheckConstraints Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Table level Check Constraint objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

TableCheckConstraints Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a TableCheckConstraint object specified by the given Identifier. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As TableCheckConstraint

Parameters

Identifier

See Also

TableCheckConstraints Collection


%%PageItemTitle%%

TextList Collection
See Also Members

Description

This object represents a collection that's equivalent to an Attachment TextList. The owner of this collection is the Attachment object.

Object Model

See Also

TextList Members


%%PageItemTitle%% $$Members$$

TextList Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new ListMember in the collection and returns the pointer to it. PARAMETERS: Text as String.
Public Method Remove | Deletes a ListMember object specified by the given Text or sequence number. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a ListMember object specified by the given Text or sequence number. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ListMember objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ListMember object specified by the given Text or sequence number. PARAMETERS: Identifier as String or Integer.

See Also

TextList Overview


%%PageItemTitle%%

Add Method
Text

Description

Creates a new ListMember in the collection and returns the pointer to it. PARAMETERS: Text as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Text As Variant _
) As ListMember

Parameters

Text

See Also

TextList Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a ListMember object specified by the given Text or sequence number. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

TextList Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ListMember object specified by the given Text or sequence number. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ListMember

Parameters

Identifier

See Also

TextList Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

TextList Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ListMember objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

TextList Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ListMember object specified by the given Text or sequence number. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ListMember

Parameters

Identifier

See Also

TextList Collection


%%PageItemTitle%%

Transformation Object
See Also Members

Description

This object represents a data lineage transformation in ER/Studio.

Object Model

See Also

Transformation Members


%%PageItemTitle%% $$Members$$

Transformation Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Returns the BoundAttachments collection of this Transformation.
Public Method DataMovementRuleLinks | Get all the DataMovementRules bound to this Transformation.
Public Method LineageInputs | Returns the inputs of this transformation as a TransformationFields collection.
Public Method LineageOutputs | Returns the outputs of this transformation as a TransformationFields collection.
Public Method UserComments | Returns a collection of user comments associated with this transformation.

Public Properties

Public Property BusinessDefinition | Returns the Transformation business definition. DATATYPE: String.
Public Property CodeDefinition | Returns the Transformation code definition. DATATYPE: String.
Public Property GUID | This is the GUID of the Transformation. DATATYPE: String.
Public Property ID | Returns the Transformation ID. DATATYPE: Integer.
Public Property Name | Returns the Transformation name. DATATYPE: String.
Public Property Type | Returns the Transformation type. DATATYPE: String.

See Also

Transformation Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Transformation.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Transformation Object


%%PageItemTitle%%

DataMovementRuleLinks Method

Description

Get all the DataMovementRules bound to this Transformation.

Syntax

Visual Basic
Public Function DataMovementRuleLinks() As DataMovementRuleLinks

See Also

Transformation Object


%%PageItemTitle%%

LineageInputs Method

Description

Returns the inputs of this transformation as a TransformationFields collection.

Syntax

Visual Basic
Public Function LineageInputs() As TransformationFields

See Also

Transformation Object


%%PageItemTitle%%

LineageOutputs Method

Description

Returns the outputs of this transformation as a TransformationFields collection.

Syntax

Visual Basic
Public Function LineageOutputs() As TransformationFields

See Also

Transformation Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this transformation.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Transformation Object


%%PageItemTitle%%

BusinessDefinition Property

Description

Returns the Transformation business definition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property BusinessDefinition() As Variant

See Also

Transformation Object


%%PageItemTitle%%

CodeDefinition Property

Description

Returns the Transformation code definition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property CodeDefinition() As Variant

See Also

Transformation Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the Transformation. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Transformation Object


%%PageItemTitle%%

ID Property

Description

Returns the Transformation ID. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Transformation Object


%%PageItemTitle%%

Name Property

Description

Returns the Transformation name. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Transformation Object


%%PageItemTitle%%

Type Property

Description

Returns the Transformation type. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

Transformation Object


%%PageItemTitle%%

TransformationDisplay Object
See Also Members

Description

This object represents a data lineage transformation display in ER/Studio. A data lineage transformation display object is a graphical representation of a transformation in a specific data flow - it is not a transformation itself.

See Also

TransformationDisplay Members


%%PageItemTitle%% $$Members$$

TransformationDisplay Object Members
See Also Overview

Public Properties

Public Property GUID | This is the GUID of the TransformationDisplay object. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the TransformationDisplay object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the TransformationDisplay object. DATATYPE: Integer.
Public Property ID | This is the ID of the TransformationDisplay object. This ID is assigned by ER/Studio, and this is the same as the parent Transformation ID. DATATYPE: Integer.
Public Property Name | This is the name of the TransformationDisplay object. DATATYPE: String.
Public Property VerticalPosition | This is the y coordinate of the TransformationDisplay object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the TransformationDisplay object. DATATYPE: Integer.

See Also

TransformationDisplay Overview


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the TransformationDisplay object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the TransformationDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the TransformationDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

ID Property

Description

This is the ID of the TransformationDisplay object. This ID is assigned by ER/Studio, and this is the same as the parent Transformation ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

Name Property

Description

This is the name of the TransformationDisplay object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the TransformationDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the TransformationDisplay object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

TransformationDisplay Object


%%PageItemTitle%%

TransformationDisplays Collection
See Also Members

Description

This object represents a collection of TransformationDisplays. The owner of this collection is the data flow.

Object Model

See Also

TransformationDisplays Members


%%PageItemTitle%% $$Members$$

TransformationDisplays Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a TransformationDisplay object (specified by the given GUID or by the given name or ID of the parent Transformation). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Item | Returns a TransformationDisplay object (specified by the given GUID or by the given name or ID of the parent Transformation). PARAMETERS: Identifier as String or Integer.

See Also

TransformationDisplays Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a TransformationDisplay object (specified by the given GUID or by the given name or ID of the parent Transformation). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As TransformationDisplay

Parameters

Identifier

See Also

TransformationDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

TransformationDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a TransformationDisplay object (specified by the given GUID or by the given name or ID of the parent Transformation). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As TransformationDisplay

Parameters

Identifier

See Also

TransformationDisplays Collection


%%PageItemTitle%%

TransformationField Object
See Also Members

Description

This object represents a data lineage transformation field in ER/Studio.

See Also

TransformationField Members


%%PageItemTitle%% $$Members$$

TransformationField Object Members
See Also Overview

Public Properties

Public Property DataStreamID | Returns the ID of the corresponding data stream. DATATYPE: Integer.
Public Property GUID | This is the GUID of the TransformationField. DATATYPE: String.
Public Property ID | Returns the TransformationField ID. DATATYPE: Integer.
Public Property IsInput | Returns True if the TransformationField is an input and False if it is an output. DATATYPE: Boolean.
Public Property LineageComponentID | Returns the ID of the corresponding lineage component. DATATYPE: Integer.
Public Property Name | Returns the name of the TransformationField . DATATYPE: String.
Public Property SourceModelID | Returns the ID of the model that contains the source object. DATATYPE: Integer.
Public Property SourceObjectID | Returns the ID of the source object, which is the Attribute ID or ViewField ID. DATATYPE: Integer.
Public Property SourceObjectType | Returns the type of the source object. DATATYPE: Integer (5=Attribute, 17=ViewField).
Public Property SourceParentID | Returns the ID of the parent of the source object. This is either an Entity ID or a View ID depending on whether the source object is an attribute or a view field. DATATYPE: Integer.

See Also

TransformationField Overview


%%PageItemTitle%%

DataStreamID Property

Description

Returns the ID of the corresponding data stream. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataStreamID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the TransformationField. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

ID Property

Description

Returns the TransformationField ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

IsInput Property

Description

Returns True if the TransformationField is an input and False if it is an output. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsInput() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

LineageComponentID Property

Description

Returns the ID of the corresponding lineage component. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property LineageComponentID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

Name Property

Description

Returns the name of the TransformationField . DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

SourceModelID Property

Description

Returns the ID of the model that contains the source object. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceModelID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

SourceObjectID Property

Description

Returns the ID of the source object, which is the Attribute ID or ViewField ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceObjectID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

SourceObjectType Property

Description

Returns the type of the source object. DATATYPE: Integer (5=Attribute, 17=ViewField).

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceObjectType() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

SourceParentID Property

Description

Returns the ID of the parent of the source object. This is either an Entity ID or a View ID depending on whether the source object is an attribute or a view field. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SourceParentID() As Variant

See Also

TransformationField Object


%%PageItemTitle%%

TransformationFields Collection
See Also Members

Description

This object represents a collection of transformationFields. The owner of this collection is the transformation.

Object Model

See Also

TransformationFields Members


%%PageItemTitle%% $$Members$$

TransformationFields Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new TransformationField with the given source data and returns the new TransformationField to the caller. PARAMETERS: SourceObjectType as Integer (5=Attribute, 17=ViewField), SourceObjectID As Integer.
Public Method Remove | Deletes a TransformationField object specified by the given Identifier (ID or GUID). PARAMETERS: Identifier as String(GUID) or Integer(ID).

Public Properties

Public Property _Item | Returns a TransformationField object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).
Public Property _NewEnum |
Public Property Count | This is the number of TransformationField objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a TransformationField object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).
Public Property ItemBySource | Returns a TransformationField object specified by the given SourceObjectType and SourceObjectID. PARAMETERS: SourceObjectType as Integer (5=Attribute, 17=ViewField), SourceObjectID As Integer.

See Also

TransformationFields Overview


%%PageItemTitle%%

Add Method
SourceObjectType
SourceObjectID

Description

Creates a new TransformationField with the given source data and returns the new TransformationField to the caller. PARAMETERS: SourceObjectType as Integer (5=Attribute, 17=ViewField), SourceObjectID As Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal SourceObjectType As Variant, _
   ByVal SourceObjectID As Variant _
) As TransformationField

Parameters

SourceObjectType
SourceObjectID

See Also

TransformationFields Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a TransformationField object specified by the given Identifier (ID or GUID). PARAMETERS: Identifier as String(GUID) or Integer(ID).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

TransformationFields Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a TransformationField object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As TransformationField

Parameters

Identifier

See Also

TransformationFields Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

TransformationFields Collection


%%PageItemTitle%%

Count Property

Description

This is the number of TransformationField objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

TransformationFields Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a TransformationField object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As TransformationField

Parameters

Identifier

See Also

TransformationFields Collection


%%PageItemTitle%%

ItemBySource Property
SourceObjectType
SourceObjectID

Description

Returns a TransformationField object specified by the given SourceObjectType and SourceObjectID. PARAMETERS: SourceObjectType as Integer (5=Attribute, 17=ViewField), SourceObjectID As Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemBySource( _
   ByVal SourceObjectType As Variant, _
   ByVal SourceObjectID As Variant _
) As TransformationField

Parameters

SourceObjectType
SourceObjectID

See Also

TransformationFields Collection


%%PageItemTitle%%

Transformations Collection
See Also Members

Description

This object represents a collection of transformations. The owner of this collection is the data flow.

Object Model

See Also

Transformations Members


%%PageItemTitle%% $$Members$$

Transformations Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new Transformation with the given position and returns the new Transformation to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Deletes a Transformation object (specified by one of the Transformation properties, name, GUID or ID) from ER/Studio. PARAMETERS: Identifier as String(Name or GUID) or Integer(ID).

Public Properties

Public Property _Item | Returns a Transformation object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Transformation objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Transformation object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Transformations Overview


%%PageItemTitle%%

Add Method
HorizontalPosition
VerticalPosition

Description

Creates a new Transformation with the given position and returns the new Transformation to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As Transformation

Parameters

HorizontalPosition
VerticalPosition

See Also

Transformations Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Transformation object (specified by one of the Transformation properties, name, GUID or ID) from ER/Studio. PARAMETERS: Identifier as String(Name or GUID) or Integer(ID).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Transformations Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Transformation object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Transformation

Parameters

Identifier

See Also

Transformations Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Transformations Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Transformation objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Transformations Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Transformation object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Transformation

Parameters

Identifier

See Also

Transformations Collection


%%PageItemTitle%%

Trigger Object
See Also Members

Description

This object represents a trigger in ER/Studio.

Object Model

See Also

Trigger Members


%%PageItemTitle%% $$Members$$

Trigger Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this trigger.
Public Method SetText | Sets the Text (SQL) for the Trigger. Returns the validation error message or none if validated succesfully. PARAMETERS: NewText as String. RETURN DATATYPE: String.
Public Method UserComments | Returns a collection of user comments associated with this trigger.

Public Properties

Public Property Action | This is the trigger action. The possible values are: 'INSERT', 'UPDATE', and/or 'DELETE' (in a coma separated string). DATATYPE: String.
Public Property Description | This is the description of the trigger. DATATYPE: String.
Public Property GUID | GUID of the trigger. This GUID is assigned by ER/Studio. Each trigger has a unique GUID. DATATYPE: String.
Public Property ID | ID of the trigger. This ID is assigned by ER/Studio. Each trigger in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the trigger. DATATYPE: String.
Public Property Text | This is the body text of the trigger. DATATYPE: String.
Public Property Type | This is the type of the trigger. The possible values are: SQL - 0, BASIC - 1, SYSTEM - 2. DATATYPE: Integer.

See Also

Trigger Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this trigger.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

Trigger Object


%%PageItemTitle%%

SetText Method
NewText

Description

Sets the Text (SQL) for the Trigger. Returns the validation error message or none if validated succesfully. PARAMETERS: NewText as String. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function SetText( _
   ByVal NewText As Variant _
) As Variant

Parameters

NewText

See Also

Trigger Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this trigger.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

Trigger Object


%%PageItemTitle%%

Action Property

Description

This is the trigger action. The possible values are: 'INSERT', 'UPDATE', and/or 'DELETE' (in a coma separated string). DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Action() As Variant

See Also

Trigger Object


%%PageItemTitle%%

Description Property

Description

This is the description of the trigger. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

Trigger Object


%%PageItemTitle%%

GUID Property

Description

GUID of the trigger. This GUID is assigned by ER/Studio. Each trigger has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

Trigger Object


%%PageItemTitle%%

ID Property

Description

ID of the trigger. This ID is assigned by ER/Studio. Each trigger in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

Trigger Object


%%PageItemTitle%%

Name Property

Description

This is the name of the trigger. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

Trigger Object


%%PageItemTitle%%

Text Property

Description

This is the body text of the trigger. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Text() As Variant

See Also

Trigger Object


%%PageItemTitle%%

Type Property

Description

This is the type of the trigger. The possible values are: SQL - 0, BASIC - 1, SYSTEM - 2. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Variant

See Also

Trigger Object


%%PageItemTitle%%

Triggers Collection
See Also Members

Description

This object represents a collection of triggers. The owner of this collection is the entity.

Object Model

See Also

Triggers Members


%%PageItemTitle%% $$Members$$

Triggers Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new trigger with the given name, adds it to the entity, and returns the new trigger to the caller. PARAMETERS: Name as String.
Public Method Remove | Deletes a Trigger object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a Trigger object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of Trigger objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a Trigger object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

Triggers Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates a new trigger with the given name, adds it to the entity, and returns the new trigger to the caller. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As Trigger

Parameters

Name

See Also

Triggers Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a Trigger object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

Triggers Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a Trigger object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As Trigger

Parameters

Identifier

See Also

Triggers Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Triggers Collection


%%PageItemTitle%%

Count Property

Description

This is the number of Trigger objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Triggers Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a Trigger object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As Trigger

Parameters

Identifier

See Also

Triggers Collection


%%PageItemTitle%%

UniversalMapping Object
See Also Members

Description

This represents a universal mapping in ER/Studio - a mapping between objects across Data Architect diagrams and/or Business Architect workspaces.

See Also

UniversalMapping Members


%%PageItemTitle%% $$Members$$

UniversalMapping Object Members
See Also Overview

Public Methods

Public Method MappedObjectProperty Lookup the value of a property of the mapped object indicated by the passed in string. Available properties depend on the type of the mapped object.

Public Properties

Public Property LocalObjectGUID | The unique GUID of the local object.
Public Property LocalObjectName | The display name of the local object.
Public Property LocalObjectType | An enumerated value that corresponds to the object type of the local object.
Public Property MappedObjectGUID | The unique GUID of the mapped object.
Public Property MappedObjectName | The display name of the mapped object.
Public Property MappedObjectParentBusinessEntityGUID | The unique GUID of the mapped object's parent business entity. This applies only when the mapped object is an business attribute.
Public Property MappedObjectParentBusinessEntityName | The display name of the mapped object's parent business entity. This applies only when the mapped object is an business attribute.
Public Property MappedObjectParentDiagramGUID | The unique GUID of the mapped object's parent diagram. This applies only to Data Architect objects.
Public Property MappedObjectParentDiagramName | The display name of the mapped object's parent diagram. This applies only to Data Architect objects.
Public Property MappedObjectParentEntityGUID | The unique GUID of the mapped object's parent entity. This applies only when the mapped object is an attribute.
Public Property MappedObjectParentEntityName | The display name of the mapped object's parent entity. This applies only when the mapped object is an attribute.
Public Property MappedObjectParentModelGUID | The unique GUID of the mapped object's parent model, if it applies.
Public Property MappedObjectParentModelName | The display name of the mapped object's parent model, if it applies.
Public Property MappedObjectParentWorkspaceGUID | The unique GUID of the mapped object's parent workspace. This applies only to Business Architect objects.
Public Property MappedObjectParentWorkspaceName | The display name of the mapped object's parent workspace. This applies only to Business Architect objects.
Public Property MappedObjectType | An enumerated value that corresponds to the object type of the mapped object.

See Also

UniversalMapping Overview


%%PageItemTitle%%

MappedObjectProperty Method
Identifier

Description

Lookup the value of a property of the mapped object indicated by the passed in string. Available properties depend on the type of the mapped object.

Syntax

Visual Basic
Public Function MappedObjectProperty( _
   ByVal Identifier As Variant _
) As Variant

Parameters

Identifier

See Also

UniversalMapping Object


%%PageItemTitle%%

LocalObjectGUID Property

Description

The unique GUID of the local object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LocalObjectGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

LocalObjectName Property

Description

The display name of the local object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LocalObjectName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

LocalObjectType Property

Description

An enumerated value that corresponds to the object type of the local object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LocalObjectType() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectGUID Property

Description

The unique GUID of the mapped object.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectName Property

Description

The display name of the mapped object.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentBusinessEntityGUID Property

Description

The unique GUID of the mapped object's parent business entity. This applies only when the mapped object is an business attribute.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentBusinessEntityGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentBusinessEntityName Property

Description

The display name of the mapped object's parent business entity. This applies only when the mapped object is an business attribute.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentBusinessEntityName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentDiagramGUID Property

Description

The unique GUID of the mapped object's parent diagram. This applies only to Data Architect objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentDiagramGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentDiagramName Property

Description

The display name of the mapped object's parent diagram. This applies only to Data Architect objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentDiagramName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentEntityGUID Property

Description

The unique GUID of the mapped object's parent entity. This applies only when the mapped object is an attribute.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentEntityGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentEntityName Property

Description

The display name of the mapped object's parent entity. This applies only when the mapped object is an attribute.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentEntityName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentModelGUID Property

Description

The unique GUID of the mapped object's parent model, if it applies.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentModelGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentModelName Property

Description

The display name of the mapped object's parent model, if it applies.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentModelName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentWorkspaceGUID Property

Description

The unique GUID of the mapped object's parent workspace. This applies only to Business Architect objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentWorkspaceGUID() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectParentWorkspaceName Property

Description

The display name of the mapped object's parent workspace. This applies only to Business Architect objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectParentWorkspaceName() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

MappedObjectType Property

Description

An enumerated value that corresponds to the object type of the mapped object.

Property type

Read-only property

Syntax

Visual Basic
Public Property MappedObjectType() As Variant

See Also

UniversalMapping Object


%%PageItemTitle%%

UniversalMappings Collection
See Also Members

Description

This object represents a collection of UniversalMapping objects returned as a result of a UniversalMapping query.

Object Model

See Also

UniversalMappings Members


%%PageItemTitle%% $$Members$$

UniversalMappings Collection Members
See Also Overview

Public Properties

Public Property _NewEnum |
Public Property Count | This is the number of UniversalMapping objects in the collection.

See Also

UniversalMappings Overview


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

UniversalMappings Collection


%%PageItemTitle%%

Count Property

Description

This is the number of UniversalMapping objects in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

UniversalMappings Collection


%%PageItemTitle%%

User Object
See Also Members

Description

This object represents a Repository User in ER/Studio.

See Also

User Members


%%PageItemTitle%% $$Members$$

User Object Members
See Also Overview

Public Methods

Public Method DoModify Sends Modify User request to the Repository using current User data. Return 1 if successful, and 0 if it failed. RETURN DATATYPE: Integer.

Public Properties

Public Property Description | This is the description for the User. DATATYPE: String.
Public Property Name | This is the name of the User. DATATYPE: String.
Public Property Password | This is the Password of the User. DATATYPE: String.

See Also

User Overview


%%PageItemTitle%%

DoModify Method

Description

Sends Modify User request to the Repository using current User data. Return 1 if successful, and 0 if it failed. RETURN DATATYPE: Integer.

Syntax

Visual Basic
Public Function DoModify() As Variant

See Also

User Object


%%PageItemTitle%%

Description Property

Description

This is the description for the User. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description() As Variant

See Also

User Object


%%PageItemTitle%%

Name Property

Description

This is the name of the User. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

User Object


%%PageItemTitle%%

Password Property

Description

This is the Password of the User. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Password() As Variant

See Also

User Object


%%PageItemTitle%%

UserComment Object
See Also Members

Description

This object represents a user comment in ER/Studio.

See Also

UserComment Members


%%PageItemTitle%% $$Members$$

UserComment Object Members
See Also Overview

Public Properties

Public Property CommentValue | Returns the comment string of the UserComment. DATATYPE: String.
Public Property CreatedBy | Returns the name of the user who created the UserComment. DATATYPE: String.
Public Property GUID | This is the GUID of the UserComment. DATATYPE: String.
Public Property ID | Returns the UserComment ID. DATATYPE: Integer.
Public Property Timestamp | Returns the timestamp string when the UserComment was created. DATATYPE: String.

See Also

UserComment Overview


%%PageItemTitle%%

CommentValue Property

Description

Returns the comment string of the UserComment. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property CommentValue() As Variant

See Also

UserComment Object


%%PageItemTitle%%

CreatedBy Property

Description

Returns the name of the user who created the UserComment. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property CreatedBy() As Variant

See Also

UserComment Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the UserComment. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

UserComment Object


%%PageItemTitle%%

ID Property

Description

Returns the UserComment ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

UserComment Object


%%PageItemTitle%%

Timestamp Property

Description

Returns the timestamp string when the UserComment was created. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Timestamp() As Variant

See Also

UserComment Object


%%PageItemTitle%%

UserComments Collection
See Also Members

Description

This object represents a collection of user comments. The owner of this collection is a dm1 object, e.g., an entity, an attribute, or an index, etc..

Object Model

See Also

UserComments Members


%%PageItemTitle%% $$Members$$

UserComments Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new user comment with given comment string, and returns the new usercomment to the caller. PARAMETERS: Comment as string.
Public Method Remove | Deletes a user comment object specified by the given Identifier (ID or GUID). Only the user who created the comment can delete it. PARAMETERS: Identifier as String(GUID) or Integer(ID).

Public Properties

Public Property _Item | Returns a user comment object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).
Public Property _NewEnum |
Public Property Count | This is the number of user comment objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a user comment object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).

See Also

UserComments Overview


%%PageItemTitle%%

Add Method
Comment

Description

Creates a new user comment with given comment string, and returns the new usercomment to the caller. PARAMETERS: Comment as string.

Syntax

Visual Basic
Public Function Add( _
   ByVal Comment As Variant _
) As UserComment

Parameters

Comment

See Also

UserComments Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a user comment object specified by the given Identifier (ID or GUID). Only the user who created the comment can delete it. PARAMETERS: Identifier as String(GUID) or Integer(ID).

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

UserComments Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a user comment object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As UserComment

Parameters

Identifier

See Also

UserComments Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

UserComments Collection


%%PageItemTitle%%

Count Property

Description

This is the number of user comment objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

UserComments Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a user comment object specified by the given Identifier (ID or GUID). PARAMETER: Identifier as Integer(ID) or String (GUID).

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As UserComment

Parameters

Identifier

See Also

UserComments Collection


%%PageItemTitle%%

UserDatatype Object
See Also Members

Description

This object represents a user datatype in ER/Studio.

Object Model

See Also

UserDatatype Members


%%PageItemTitle%% $$Members$$

UserDatatype Object Members
See Also Overview

Public Methods

Public Method ApplyNullabilityToBoundColumns | When updates are called, all bound attributes have the same nullability as the userdatatype.
Public Method BoundAttachments | Get all the BoundAttachments of this user datatype.
Public Method BoundObjects | Returns a collection of bindings that link the default to attributes.
Public Method RepoCheckOutStatus | Get the Check Out status of this UserDataType object. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this user datatype.

Public Properties

Public Property DataLength | This is the length of the datatype (if applicable). DATATYPE: Integer.
Public Property DataScale | This is the scale or precision of the datatype (if applicable). DATATYPE: Integer.
Public Property Datatype | This is the datatype of the user datatype. DATATYPE: String.
Public Property DefaultId | This is the ID of the bounded default. To bind a default to a user datatype, assign the default's ID to this property. DATATYPE: Integer.
Public Property DictionaryName | This is the name of the Dictionary associated with this object. DATATYPE: String.
Public Property EnterpriseLevel | True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.
Public Property GUID | GUID of the UserDataType. GUIDs are unique IDs assigned by ER/Studio. DATATYPE: String.
Public Property ID | ID of the user datatype. This ID is assigned by ER/Studio. Each user datatype in the data dictionary has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the user datatype. DATATYPE: String.
Public Property Nullable | This is the Nullability of this UserDataType. DATATYPE: Boolean.
Public Property RuleId | This is the ID of the bounded rule. To bind a rule to a user datatype, assign the rule's ID to this property. DATATYPE: Integer.

See Also

UserDatatype Overview


%%PageItemTitle%%

ApplyNullabilityToBoundColumns Method

Description

When updates are called, all bound attributes have the same nullability as the userdatatype.

Syntax

Visual Basic
Public Sub ApplyNullabilityToBoundColumns()

See Also

UserDatatype Object


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this user datatype.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

UserDatatype Object


%%PageItemTitle%%

BoundObjects Method

Description

Returns a collection of bindings that link the default to attributes.

Syntax

Visual Basic
Public Function BoundObjects() As BoundObjects

See Also

UserDatatype Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this UserDataType object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this user datatype.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

UserDatatype Object


%%PageItemTitle%%

DataLength Property

Description

This is the length of the datatype (if applicable). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataLength() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

DataScale Property

Description

This is the scale or precision of the datatype (if applicable). DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataScale() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

Datatype Property

Description

This is the datatype of the user datatype. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Datatype() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

DefaultId Property

Description

This is the ID of the bounded default. To bind a default to a user datatype, assign the default's ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultId() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

DictionaryName Property

Description

This is the name of the Dictionary associated with this object. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property DictionaryName() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

EnterpriseLevel Property

Description

True if Dictionary associated with this object is enterprise level. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterpriseLevel() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

GUID Property

Description

GUID of the UserDataType. GUIDs are unique IDs assigned by ER/Studio. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

ID Property

Description

ID of the user datatype. This ID is assigned by ER/Studio. Each user datatype in the data dictionary has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

Name Property

Description

This is the name of the user datatype. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

Nullable Property

Description

This is the Nullability of this UserDataType. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property Nullable() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

RuleId Property

Description

This is the ID of the bounded rule. To bind a rule to a user datatype, assign the rule's ID to this property. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property RuleId() As Variant

See Also

UserDatatype Object


%%PageItemTitle%%

UserDatatypes Collection
See Also Members

Description

This object represents a collection of user datatypes. The owner of this collection is the data dictionary.

Object Model

See Also

UserDatatypes Members


%%PageItemTitle%% $$Members$$

UserDatatypes Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new user datatype with the given name, adds it to the data dictionary, and returns the new user datatype to the caller. PARAMETERS: Name as String.
Public Method Remove | Deletes a UserDatatype object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a UserDatatype object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of UserDatatype objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a UserDatatype object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

UserDatatypes Overview


%%PageItemTitle%%

Add Method
Name

Description

Creates a new user datatype with the given name, adds it to the data dictionary, and returns the new user datatype to the caller. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As Variant _
) As UserDatatype

Parameters

Name

See Also

UserDatatypes Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a UserDatatype object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

UserDatatypes Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a UserDatatype object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As UserDatatype

Parameters

Identifier

See Also

UserDatatypes Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

UserDatatypes Collection


%%PageItemTitle%%

Count Property

Description

This is the number of UserDatatype objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

UserDatatypes Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a UserDatatype object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As UserDatatype

Parameters

Identifier

See Also

UserDatatypes Collection


%%PageItemTitle%%

UserDefinedMappingCollection Collection
See Also Members

Description

This object represents a collection of UserDefinedMappingObj objects returned as a result of a User Defined Mapping query.

Object Model

See Also

UserDefinedMappingCollection Members


%%PageItemTitle%% $$Members$$

UserDefinedMappingCollection Collection Members
See Also Overview

Public Properties

Public Property _NewEnum |
Public Property Count | This is the number of UserDefinedMappingObj objects in the collection. DATATYPE: Integer.

See Also

UserDefinedMappingCollection Overview


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

UserDefinedMappingCollection Collection


%%PageItemTitle%%

Count Property

Description

This is the number of UserDefinedMappingObj objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

UserDefinedMappingCollection Collection


%%PageItemTitle%%

UserDefinedMappingObj Object
See Also Members

Description

This represents a user defined mapping in ER/Studio - an object in one model that maps to an object in another model.

Object Model

See Also

UserDefinedMappingObj Members


%%PageItemTitle%% $$Members$$

UserDefinedMappingObj Object Members
See Also Overview

Public Methods

Public Method BoundAttachments Returns the BoundAttachments collection of this Object.

Public Properties

Public Property AttributeID | Attribute ID of the mapped object. This ID is assigned by ER/Studio and can be used with the ModelID and EntityID to obtain the corresponding AttributeObj object. Valid for ModelUsage queries for AttributeObj objects.
Public Property Definition | Returns the UserDefinedMappingObj Definition. DATATYPE: String.
Public Property EntityID | Entity ID of the mapped object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding Entity object. Valid for ModelUsage queries for Entities and child object types (e.g. AttributeObj).
Public Property ModelID | Model ID of the mapped object. This ID is assigned by ER/Studio and can be used to obtain the corresponding Model object. Valid for ModelUsage and SubmodelUsage queries for all objects.

See Also

UserDefinedMappingObj Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Returns the BoundAttachments collection of this Object.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

UserDefinedMappingObj Object


%%PageItemTitle%%

AttributeID Property

Description

Attribute ID of the mapped object. This ID is assigned by ER/Studio and can be used with the ModelID and EntityID to obtain the corresponding AttributeObj object. Valid for ModelUsage queries for AttributeObj objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttributeID() As Variant

See Also

UserDefinedMappingObj Object


%%PageItemTitle%%

Definition Property

Description

Returns the UserDefinedMappingObj Definition. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

See Also

UserDefinedMappingObj Object


%%PageItemTitle%%

EntityID Property

Description

Entity ID of the mapped object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding Entity object. Valid for ModelUsage queries for Entities and child object types (e.g. AttributeObj).

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityID() As Variant

See Also

UserDefinedMappingObj Object


%%PageItemTitle%%

ModelID Property

Description

Model ID of the mapped object. This ID is assigned by ER/Studio and can be used to obtain the corresponding Model object. Valid for ModelUsage and SubmodelUsage queries for all objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property ModelID() As Variant

See Also

UserDefinedMappingObj Object


%%PageItemTitle%%

Users Collection
See Also Members

Description

This object represents a collection of User objects.

Object Model

See Also

Users Members


%%PageItemTitle%% $$Members$$

Users Collection Members
See Also Overview

Public Methods

Public Method Create | Description as String, Password as String, create a new User object. PARAMETERS: Name as String.
Public Method CreateDSUser | Create a new Directory Service (Windows Authenticated) User object. PARAMETERS: Name as String, Description as String.
Public Method Deactivate | Deactivate a User object specified by the given name. PARAMETERS: Name as String.
Public Method DeactivatedUsers | Returns a StringObject collection containing the names of all the deactivated Users.
Public Method Reactivate | Reactivate a User object specified by the given name. PARAMETERS: Name as String.
Public Method Remove | Delete a User object specified by the given name. PARAMETERS: Name as String.

Public Properties

Public Property _Item | Returns a User object specified by the given name. PARAMETERS: Identifier as String.
Public Property _NewEnum |
Public Property Count | This is the number of User objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a User object specified by the given name. PARAMETERS: Identifier as String.

See Also

Users Overview


%%PageItemTitle%%

Create Method
Name
Description
Password

Description

Description as String, Password as String, create a new User object. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Function Create( _
   ByVal Name As Variant, _
   ByVal Description As Variant, _
   ByVal Password As Variant _
) As User

Parameters

Name
Description
Password

Remarks

In ER/Studio 8.5 and later releases, this method replaces the Add method.

See Also

Users Collection


%%PageItemTitle%%

CreateDSUser Method
Name
Description

Description

Create a new Directory Service (Windows Authenticated) User object. PARAMETERS: Name as String, Description as String.

Syntax

Visual Basic
Public Function CreateDSUser( _
   ByVal Name As Variant, _
   ByVal Description As Variant _
) As User

Parameters

Name
Description

See Also

Users Collection


%%PageItemTitle%%

Deactivate Method
Name

Description

Deactivate a User object specified by the given name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub Deactivate( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

Users Collection


%%PageItemTitle%%

DeactivatedUsers Method

Description

Returns a StringObject collection containing the names of all the deactivated Users.

Syntax

Visual Basic
Public Function DeactivatedUsers() As StringObjects

See Also

Users Collection


%%PageItemTitle%%

Reactivate Method
Name

Description

Reactivate a User object specified by the given name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub Reactivate( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

Users Collection


%%PageItemTitle%%

Remove Method
Name

Description

Delete a User object specified by the given name. PARAMETERS: Name as String.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Name As Variant _
)

Parameters

Name

See Also

Users Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a User object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As User

Parameters

Identifier

See Also

Users Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Users Collection


%%PageItemTitle%%

Count Property

Description

This is the number of User objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Users Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a User object specified by the given name. PARAMETERS: Identifier as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As User

Parameters

Identifier

See Also

Users Collection


%%PageItemTitle%%

ValidAttachmentBinding Object
See Also Members

Description

This object represents an ValidAttachmentBinding in ER/Studio.

See Also

ValidAttachmentBinding Members


%%PageItemTitle%% $$Members$$

ValidAttachmentBinding Object Members
See Also Overview

Public Properties

Public Property GUID | Returns the ValidAttachmentBinding GUID. DATATYPE: String.
Public Property ID | Returns the ValidAttachmentBinding ID. DATATYPE: Integer.
Public Property ObjectType | This is the ObjectType of the ValidAttachmentBinding. DATATYPE: String.

See Also

ValidAttachmentBinding Overview


%%PageItemTitle%%

GUID Property

Description

Returns the ValidAttachmentBinding GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ValidAttachmentBinding Object


%%PageItemTitle%%

ID Property

Description

Returns the ValidAttachmentBinding ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ValidAttachmentBinding Object


%%PageItemTitle%%

ObjectType Property

Description

This is the ObjectType of the ValidAttachmentBinding. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectType() As Variant

See Also

ValidAttachmentBinding Object


%%PageItemTitle%%

ValidAttachmentBindings Collection
See Also Members

Description

This object represents a collection of ValidAttachmentBindings. The owner of this collection is the AttachmentType.

Object Model

See Also

ValidAttachmentBindings Members


%%PageItemTitle%% $$Members$$

ValidAttachmentBindings Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new ValidAttachmentBinding in the collection and returns the pointer. PARAMETERS: ObjectType as String.
Public Method Remove | Deletes an ValidAttachmentBinding object specified by the given ObjectType or ID. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a ValidAttachmentBinding object specified by the given ObjectType, GUID or ID. PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ValidAttachmentBinding objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ValidAttachmentBinding object specified by the given ObjectType, GUID or ID. PARAMETERS: Identifier as String or Integer.

See Also

ValidAttachmentBindings Overview


%%PageItemTitle%%

Add Method
ObjectType

Description

Creates a new ValidAttachmentBinding in the collection and returns the pointer. PARAMETERS: ObjectType as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal ObjectType As Variant _
) As ValidAttachmentBinding

Parameters

ObjectType

See Also

ValidAttachmentBindings Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes an ValidAttachmentBinding object specified by the given ObjectType or ID. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ValidAttachmentBindings Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ValidAttachmentBinding object specified by the given ObjectType, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ValidAttachmentBinding

Parameters

Identifier

See Also

ValidAttachmentBindings Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ValidAttachmentBindings Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ValidAttachmentBinding objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ValidAttachmentBindings Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ValidAttachmentBinding object specified by the given ObjectType, GUID or ID. PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ValidAttachmentBinding

Parameters

Identifier

See Also

ValidAttachmentBindings Collection


%%PageItemTitle%%

ValuePair Object
See Also Members

Description

This object represents a ValuePair (Value and ValueDescription) in ER/Studio.

See Also

ValuePair Members


%%PageItemTitle%% $$Members$$

ValuePair Object Members
See Also Overview

Public Properties

Public Property Value | Returns the Value of this ValuePair. DATATYPE: String.
Public Property ValueDescription | Returns the ValueDescription of this ValuePair. DATATYPE: String.

See Also

ValuePair Overview


%%PageItemTitle%%

Value Property

Description

Returns the Value of this ValuePair. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value() As Variant

See Also

ValuePair Object


%%PageItemTitle%%

ValueDescription Property

Description

Returns the ValueDescription of this ValuePair. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueDescription() As Variant

See Also

ValuePair Object


%%PageItemTitle%%

Values Collection
See Also Members

Description

This object represents a collection of ValuePairs. The owner of this collection is the ReferenceValue object.

Object Model

See Also

Values Members


%%PageItemTitle%% $$Members$$

Values Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new ValuePair in the collection and returns the pointer. PARAMETERS: Value as String, ValueDescription as String.
Public Method Remove | Deletes a ValuePair object specified by the given Value. PARAMETERS: Value as String.

Public Properties

Public Property _Item | Returns a ValuePair object specified by the given Value. PARAMETERS: Value as String.
Public Property _NewEnum |
Public Property Count | This is the number of ValuePair objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ValuePair object specified by the given Value. PARAMETERS: Value as String.

See Also

Values Overview


%%PageItemTitle%%

Add Method
Value
ValueDescription

Description

Creates a new ValuePair in the collection and returns the pointer. PARAMETERS: Value as String, ValueDescription as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal Value As Variant, _
   ByVal ValueDescription As Variant _
) As ValuePair

Parameters

Value
ValueDescription

See Also

Values Collection


%%PageItemTitle%%

Remove Method
Value

Description

Deletes a ValuePair object specified by the given Value. PARAMETERS: Value as String.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Value As Variant _
)

Parameters

Value

See Also

Values Collection


%%PageItemTitle%%

_Item Property
Value

Description

Returns a ValuePair object specified by the given Value. PARAMETERS: Value as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Value As Variant _
) As ValuePair

Parameters

Value

See Also

Values Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Values Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ValuePair objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Values Collection


%%PageItemTitle%%

Item Property
Value

Description

Returns a ValuePair object specified by the given Value. PARAMETERS: Value as String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Value As Variant _
) As ValuePair

Parameters

Value

See Also

Values Collection


%%PageItemTitle%%

View Object
See Also Members

Description

This object represents a view in ER/Studio.

Object Model

See Also

View Members


%%PageItemTitle%% $$Members$$

View Object Members
See Also Overview

Public Methods

Public Method BoundAttachments | Get all the BoundAttachments of this View.
Public Method BoundSecurityProperties | Get all the BoundSecurityProperties of this View.
Public Method ChildViewRelationships | Returns an object representing a collection of child view relationships for the view.
Public Method ObjectPermissions | Returns the collection of Object Permissions for this object.
Public Method ParentViewRelationships | Returns an object representing a collection of parent view relationships for the view.
Public Method RepoCheckOutStatus | Get the Check Out status of this View object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this View from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method SetViewDDL | Sets the DDL for the View. Returns the validation error message or none if validated succesfully. PARAMETERS: NewDDL as String. RETURN DATATYPE: String.
Public Method UniversalMappings | Returns a collection of universal mappings applied to this object.
Public Method UserComments | Returns a collection of user comments associated with this View.
Public Method ViewFields | Returns an object representing a collection of view fields in the view.
Public Method WhereUsedModelUsage | Returns a collection of matches in other models based on the results of a WhereUsed analysis on this object.
Public Method WhereUsedSubmodelUsage | Returns a collection based on the results of a WhereUsed analysis of SubModels in the current model that contain this object.

Public Properties

Public Property Definition | This is the definition of the view. DATATYPE: String.
Public Property GeneratePostSQL | This is the Generate PostSQL option of the View. DATATYPE: Boolean.
Public Property GeneratePreSQL | This is the Generate PreSQL option of the View. DATATYPE: Boolean.
Public Property GUID | GUID of the view. This GUID is assigned by ER/Studio. Each view has a unique GUID. DATATYPE: String.
Public Property ID | ID of the view. This ID is assigned by ER/Studio. Each view in a diagram has a unique ID. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property LogOrPhysOnly | Controls the logical/physical only View Property. DATATYPE: Boolean.
Public Property Name | This is the name of the view. DATATYPE: String.
Public Property Notes | This is the note of the view. DATATYPE: String.
Public Property Owner | This is the owner of the view. DATATYPE: String.
Public Property PostSQL | This is the PostSQL of the View. DATATYPE: String.
Public Property PreSQL | This is the PreSQL of the View. DATATYPE: String.
Public Property SortAlphabetic | This is the Alphabetical Order Column Sorting option of the View. If set to TRUE, it'll sort all the view fields of this view alphabetically. DATATYPE: Boolean.
Public Property ViewDDL | This is the DDL of the View. DATATYPE: String.

See Also

View Overview


%%PageItemTitle%%

BoundAttachments Method

Description

Get all the BoundAttachments of this View.

Syntax

Visual Basic
Public Function BoundAttachments() As BoundAttachments

See Also

View Object


%%PageItemTitle%%

BoundSecurityProperties Method

Description

Get all the BoundSecurityProperties of this View.

Syntax

Visual Basic
Public Function BoundSecurityProperties() As BoundSecurityProperties

See Also

View Object


%%PageItemTitle%%

ChildViewRelationships Method

Description

Returns an object representing a collection of child view relationships for the view.

Syntax

Visual Basic
Public Function ChildViewRelationships() As ViewRelationships

Example

Dim MyView As View

Dim MyChildViewRelationship As ViewRelationship

For Each MyChildViewRelationship In MyView.ChildViewRelationships

' Operations on child view relationships go here

...

Next MyChildViewRelationship

See Also

View Object


%%PageItemTitle%%

ObjectPermissions Method

Description

Returns the collection of Object Permissions for this object.

Syntax

Visual Basic
Public Function ObjectPermissions() As ObjectPermissions

See Also

View Object


%%PageItemTitle%%

ParentViewRelationships Method

Description

Returns an object representing a collection of parent view relationships for the view.

Syntax

Visual Basic
Public Function ParentViewRelationships() As ViewRelationships

Example

Dim MyView As View

Dim MyParentViewRelationship As ViewRelationship

For Each MyParentViewRelationship In MyView.ParentViewRelationships

' Operations on parent view relationships go here

...

Next MyParentViewRelationship

See Also

View Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this View object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

View Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this View from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

View Object


%%PageItemTitle%%

SetViewDDL Method
NewDDL

Description

Sets the DDL for the View. Returns the validation error message or none if validated succesfully. PARAMETERS: NewDDL as String. RETURN DATATYPE: String.

Syntax

Visual Basic
Public Function SetViewDDL( _
   ByVal NewDDL As Variant _
) As Variant

Parameters

NewDDL

See Also

View Object


%%PageItemTitle%%

UniversalMappings Method

Description

Returns a collection of universal mappings applied to this object.

Syntax

Visual Basic
Public Function UniversalMappings() As UniversalMappings

See Also

View Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this View.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

View Object


%%PageItemTitle%%

ViewFields Method

Description

Returns an object representing a collection of view fields in the view.

Syntax

Visual Basic
Public Function ViewFields() As ViewFields

Example

Dim MyView As View

Dim MyViewField As ViewField

For Each MyViewField In MyView.ViewFields

' Operations on view fields go here

...

Next MyViewField

See Also

View Object


%%PageItemTitle%%

WhereUsedModelUsage Method

Description

Returns a collection of matches in other models based on the results of a WhereUsed analysis on this object.

Syntax

Visual Basic
Public Function WhereUsedModelUsage() As WhereUsedDataCollection

See Also

View Object


%%PageItemTitle%%

WhereUsedSubmodelUsage Method

Description

Returns a collection based on the results of a WhereUsed analysis of SubModels in the current model that contain this object.

Syntax

Visual Basic
Public Function WhereUsedSubmodelUsage() As WhereUsedDataCollection

See Also

View Object


%%PageItemTitle%%

Definition Property

Description

This is the definition of the view. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Definition() As Variant

Example

Dim MyView As View

Dim ViewDef As String = Logical

MyView.Definition = ViewDef

See Also

View Object


%%PageItemTitle%%

GeneratePostSQL Property

Description

This is the Generate PostSQL option of the View. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GeneratePostSQL() As Variant

See Also

View Object


%%PageItemTitle%%

GeneratePreSQL Property

Description

This is the Generate PreSQL option of the View. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property GeneratePreSQL() As Variant

See Also

View Object


%%PageItemTitle%%

GUID Property

Description

GUID of the view. This GUID is assigned by ER/Studio. Each view has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

View Object


%%PageItemTitle%%

ID Property

Description

ID of the view. This ID is assigned by ER/Studio. Each view in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

Example

Dim MyView As View

Dim ViewID As Integer

ViewID = MyView.ID

See Also

View Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

View Object


%%PageItemTitle%%

LogOrPhysOnly Property

Description

Controls the logical/physical only View Property. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogOrPhysOnly() As Variant

See Also

View Object


%%PageItemTitle%%

Name Property

Description

This is the name of the view. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As Variant

Example

Dim MyView As View

Dim ViewName As String

ViewName = "TheViewName"

MyView.Name = ViewName

See Also

View Object


%%PageItemTitle%%

Notes Property

Description

This is the note of the view. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Notes() As Variant

Example

Dim MyView As View

Dim ViewNotes As String

MyView.Notes = ViewNotes

See Also

View Object


%%PageItemTitle%%

Owner Property

Description

This is the owner of the view. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Owner() As Variant

Example

Dim MyView As View

Dim ViewOwner As String = Admin

MyView.Owner = ViewOwner

See Also

View Object


%%PageItemTitle%%

PostSQL Property

Description

This is the PostSQL of the View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PostSQL() As Variant

See Also

View Object


%%PageItemTitle%%

PreSQL Property

Description

This is the PreSQL of the View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSQL() As Variant

See Also

View Object


%%PageItemTitle%%

SortAlphabetic Property

Description

This is the Alphabetical Order Column Sorting option of the View. If set to TRUE, it'll sort all the view fields of this view alphabetically. DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property SortAlphabetic() As Variant

See Also

View Object


%%PageItemTitle%%

ViewDDL Property

Description

This is the DDL of the View. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewDDL() As Variant

See Also

View Object


%%PageItemTitle%%

ViewDisplay Object
See Also Members

Description

This objects represents a view display object in ER/Studio. A view display object is a graphical representation of a view in a specific submodel - it is not a view itself.

Object Model

See Also

ViewDisplay Members


%%PageItemTitle%% $$Members$$

ViewDisplay Object Members
See Also Overview

Public Methods

Public Method ParentView | Get the parent View of this ViewDisplay. DATATYPE: View.
Public Method RepoCheckOutStatus | Get the Check Out status of this ViewDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this ViewDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method Resize | Resize the ViewDisplay to default size.

Public Properties

Public Property BackgroundColor | This is the background color of the view display object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).
Public Property DisplayBackgroundColor | This determines whether to use a custom background color just for this view display object (true) or whether to use the default view background color of the submodel (false). DATATYPE: Boolean.
Public Property GUID | GUID of the view display object. This GUID is assigned by ER/Studio. Each view display object has a unique GUID. DATATYPE: String.
Public Property HorizontalPosition | This is the x coordinate of the view display object. DATATYPE: Integer.
Public Property HorizontalSize | This is the width of the view display object. DATATYPE: Integer.
Public Property ID | ID of the view display object. This ID is assigned by ER/Studio. Each view display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property Name | This is the name of the view object. DATATYPE: String.
Public Property NameColor | This is the NameColor of the Viewdisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property NameFont | Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property OutlineColor | This is the OutlineColor of the viewdisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property VerticalPosition | This is the y coordinate of the entity display object. DATATYPE: Integer.
Public Property VerticalSize | This is the height of the view display object. DATATYPE: Integer.
Public Property ViewFieldsColor | Color for all view fields. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).
Public Property ViewFieldsFont | Font for all view fields. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

See Also

ViewDisplay Overview


%%PageItemTitle%%

ParentView Method

Description

Get the parent View of this ViewDisplay. DATATYPE: View.

Syntax

Visual Basic
Public Function ParentView() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this ViewDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this ViewDisplay from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

Resize Method

Description

Resize the ViewDisplay to default size.

Syntax

Visual Basic
Public Sub Resize()

See Also

ViewDisplay Object


%%PageItemTitle%%

BackgroundColor Property

Description

This is the background color of the view display object. This property takes a 4 byte integer where the first byte represents a red value (0-255), the second 8 byte represents a green value (0-255), and the third byte represents a blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackgroundColor() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

DisplayBackgroundColor Property

Description

This determines whether to use a custom background color just for this view display object (true) or whether to use the default view background color of the submodel (false). DATATYPE: Boolean.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayBackgroundColor() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the view display object. This GUID is assigned by ER/Studio. Each view display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

HorizontalPosition Property

Description

This is the x coordinate of the view display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalPosition() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

HorizontalSize Property

Description

This is the width of the view display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalSize() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the view display object. This ID is assigned by ER/Studio. Each view display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

Name Property

Description

This is the name of the view object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

NameColor Property

Description

This is the NameColor of the Viewdisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property NameColor() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

NameFont Property

Description

Font for the name. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property NameFont() As ERSFont

See Also

ViewDisplay Object


%%PageItemTitle%%

OutlineColor Property

Description

This is the OutlineColor of the viewdisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlineColor() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

VerticalPosition Property

Description

This is the y coordinate of the entity display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalPosition() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

VerticalSize Property

Description

This is the height of the view display object. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalSize() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

ViewFieldsColor Property

Description

Color for all view fields. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte is the green value (0-255), and the 3rd byte is the blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewFieldsColor() As Variant

See Also

ViewDisplay Object


%%PageItemTitle%%

ViewFieldsFont Property

Description

Font for all view fields. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property ViewFieldsFont() As ERSFont

See Also

ViewDisplay Object


%%PageItemTitle%%

ViewDisplays Collection
See Also Members

Description

This object represents a collection of view display objects. The owner of this collection is the submodel.

Object Model

See Also

ViewDisplays Members


%%PageItemTitle%% $$Members$$

ViewDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new ViewDisplay from the View identified by the given name, and returns the new ViewDisplay. PARAMETERS: ViewName as String.
Public Method Remove | Deletes a ViewDisplay object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a ViewDisplay object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ViewDisplay objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ViewDisplay object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

See Also

ViewDisplays Overview


%%PageItemTitle%%

Add Method
ViewName

Description

Creates a new ViewDisplay from the View identified by the given name, and returns the new ViewDisplay. PARAMETERS: ViewName as String.

Syntax

Visual Basic
Public Function Add( _
   ByVal ViewName As Variant _
) As ViewDisplay

Parameters

ViewName

See Also

ViewDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a ViewDisplay object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ViewDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ViewDisplay object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ViewDisplay

Parameters

Identifier

See Also

ViewDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ViewDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ViewDisplay objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ViewDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ViewDisplay object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ViewDisplay

Parameters

Identifier

See Also

ViewDisplays Collection


%%PageItemTitle%%

ViewField Object
See Also Members

Description

This object represents a view field in ER/Studio.

Object Model

See Also

ViewField Members


%%PageItemTitle%% $$Members$$

ViewField Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this ViewField object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this ViewField from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this ViewField object.

Public Properties

Public Property Alias | This is the alias of the view field. DATATYPE: String.
Public Property Color | Color for the ViewField. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).
Public Property ColumnExpression | This is the column expression of the view field. DATATYPE: String.
Public Property Font | Font for the ViewField. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.
Public Property GUID | GUID of the view field. This GUID is assigned by ER/Studio. Each view field has a unique GUID. DATATYPE: String.
Public Property ID | ID of the view field. This ID is assigned by ER/Studio. Each view field in a diagram has a unique ID. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property ParentColumnName | This is the parent column name of the view field. DATATYPE: String.
Public Property ParentName | This is the parent name of the view field. It can be a Table or View name depending on what the parent is. DATATYPE: String.
Public Property SequenceNumber | This is the sequence number of the view field. DATATYPE: Integer.

See Also

ViewField Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this ViewField object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

ViewField Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this ViewField from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

ViewField Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this ViewField object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

ViewField Object


%%PageItemTitle%%

Alias Property

Description

This is the alias of the view field. DATATYPE: String.

Property type

Read-write property

Syntax

Visual Basic
Public Property Alias() As Variant

See Also

ViewField Object


%%PageItemTitle%%

Color Property

Description

Color for the ViewField. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

ViewField Object


%%PageItemTitle%%

ColumnExpression Property

Description

This is the column expression of the view field. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ColumnExpression() As Variant

See Also

ViewField Object


%%PageItemTitle%%

Font Property

Description

Font for the ViewField. Although this property, itself, is read only, the user can modify the font by setting the properties in the ERSFont object which is returned to the caller.

Property type

Read-only property

Syntax

Visual Basic
Public Property Font() As ERSFont

See Also

ViewField Object


%%PageItemTitle%%

GUID Property

Description

GUID of the view field. This GUID is assigned by ER/Studio. Each view field has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ViewField Object


%%PageItemTitle%%

ID Property

Description

ID of the view field. This ID is assigned by ER/Studio. Each view field in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ViewField Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

ViewField Object


%%PageItemTitle%%

ParentColumnName Property

Description

This is the parent column name of the view field. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentColumnName() As Variant

See Also

ViewField Object


%%PageItemTitle%%

ParentName Property

Description

This is the parent name of the view field. It can be a Table or View name depending on what the parent is. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentName() As Variant

See Also

ViewField Object


%%PageItemTitle%%

SequenceNumber Property

Description

This is the sequence number of the view field. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SequenceNumber() As Variant

See Also

ViewField Object


%%PageItemTitle%%

ViewFields Collection
See Also Members

Description

This object represents a collection of view fields. The owner of this collection is the view.

Object Model

See Also

ViewFields Members


%%PageItemTitle%% $$Members$$

ViewFields Collection Members
See Also Overview

Public Properties

Public Property _Item | Returns a ViewField object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ViewField objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ViewField object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

See Also

ViewFields Overview


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ViewField object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ViewField

Parameters

Identifier

See Also

ViewFields Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ViewFields Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ViewField objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ViewFields Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ViewField object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ViewField

Parameters

Identifier

See Also

ViewFields Collection


%%PageItemTitle%%

ViewRelationship Object
See Also Members

Description

This object represents a view relationship in ER/Studio.

Object Model

See Also

ViewRelationship Members


%%PageItemTitle%% $$Members$$

ViewRelationship Object Members
See Also Overview

Public Methods

Public Method RepoCheckOutStatus | Get the Check Out status of this ViewRelationship object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this ViewRelationship from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.
Public Method UserComments | Returns a collection of user comments associated with this ViewRelationship object.

Public Properties

Public Property ChildView | This is the child view of the view relationship.
Public Property GUID | GUID of the View Relationship object. This GUID is assigned by ER/Studio. Each View Relationship object has a unique GUID. DATATYPE: String.
Public Property ID | ID of the View Relationship Display object. This ID is assigned by ER/Studio. Each View Relationship display object in a diagram has a unique ID. DATATYPE: Integer.
Public Property InterModelID | InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.
Public Property IsParentView | This determines if the parent is a view or entity. DATATYPE: Boolean.
Public Property ParentEntity | This is the parent entity of the view relationship (if the parent is an entity).
Public Property ParentView | This is the parent view of the view relationship (if the parent is a view).

See Also

ViewRelationship Overview


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this ViewRelationship object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

ViewRelationship Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this ViewRelationship from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

ViewRelationship Object


%%PageItemTitle%%

UserComments Method

Description

Returns a collection of user comments associated with this ViewRelationship object.

Syntax

Visual Basic
Public Function UserComments() As UserComments

See Also

ViewRelationship Object


%%PageItemTitle%%

ChildView Property

Description

This is the child view of the view relationship.

Property type

Read-write property

Syntax

Visual Basic
Public Property ChildView() As View

Example

Dim MyViewRelationship As ViewRelationship

Dim MyChildView As View

Set MyChildView = MyViewRelationship.ChildView

See Also

ViewRelationship Object


%%PageItemTitle%%

GUID Property

Description

GUID of the View Relationship object. This GUID is assigned by ER/Studio. Each View Relationship object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ViewRelationship Object


%%PageItemTitle%%

ID Property

Description

ID of the View Relationship Display object. This ID is assigned by ER/Studio. Each View Relationship display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ViewRelationship Object


%%PageItemTitle%%

InterModelID Property

Description

InterModelID of the object. This ID is assigned by ER/Studio. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterModelID() As Variant

See Also

ViewRelationship Object


%%PageItemTitle%%

IsParentView Property

Description

This determines if the parent is a view or entity. DATATYPE: Boolean.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsParentView() As Variant

Example

Dim MyViewRelationship As ViewRelationship

Dim bParentView As Boolean

bParentView = True

MyViewRelationship.IsParentView = bParentView

See Also

ViewRelationship Object


%%PageItemTitle%%

ParentEntity Property

Description

This is the parent entity of the view relationship (if the parent is an entity).

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentEntity() As Entity

Example

Dim MyViewRelationship As ViewRelationship

Dim MyParentEntity As Entity

Set MyParentEntity = MyViewRelationship.ParentEntity

See Also

ViewRelationship Object


%%PageItemTitle%%

ParentView Property

Description

This is the parent view of the view relationship (if the parent is a view).

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentView() As View

Example

Dim MyViewRelationship As ViewRelationship

Dim MyParentView As View

Set MyParentView = MyViewRelationship.ParentView

See Also

ViewRelationship Object


%%PageItemTitle%%

ViewRelationshipDisplay Object
See Also Members

Description

This object represents a view relationship display object in ER/Studio. A view relationship display object is a graphical representation of a view relationship in a specific submodel - it is not a view relationship itself.

See Also

ViewRelationshipDisplay Members


%%PageItemTitle%% $$Members$$

ViewRelationshipDisplay Object Members
See Also Overview

Public Methods

Public Method ParentViewRelationship | Get the parent ViewRelationship of this ViewRelationshipDisplay. DATATYPE: ViewRelationship.
Public Method RepoCheckOutStatus | Get the Check Out status of this ViewRelationshipDisplay object. DATATYPE: StringObjects.
Public Method RepoVersionHistory | Get the Version History of this object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Public Properties

Public Property Color | This is the color of the ViewRelationshipDisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).
Public Property ElbowPosition | This is the elbow position (position of the middle line segment when the view relationship is drawn in rectilinear line mode) of the view relationship. DATATYPE: Integer.
Public Property GUID | GUID of the view relationship display object. This GUID is assigned by ER/Studio. Each view relationship display object has a unique GUID. DATATYPE: String.
Public Property ID | ID of the view relationship display object. This ID is assigned by ER/Studio. Each view relationship display object in a diagram has a unique ID. DATATYPE: Integer.

See Also

ViewRelationshipDisplay Overview


%%PageItemTitle%%

ParentViewRelationship Method

Description

Get the parent ViewRelationship of this ViewRelationshipDisplay. DATATYPE: ViewRelationship.

Syntax

Visual Basic
Public Function ParentViewRelationship() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

RepoCheckOutStatus Method

Description

Get the Check Out status of this ViewRelationshipDisplay object. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoCheckOutStatus() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

RepoVersionHistory Method

Description

Get the Version History of this object from the Repository server. Return the data in the StringObjects collection. DATATYPE: StringObjects.

Syntax

Visual Basic
Public Function RepoVersionHistory() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

Color Property

Description

This is the color of the ViewRelationshipDisplay object. It takes a 4 byte integer where the 1st byte represents red value (0-255), the 2nd byte represents green value (0-255), and the 3rd byte represents blue value (0-255).

Property type

Read-write property

Syntax

Visual Basic
Public Property Color() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

ElbowPosition Property

Description

This is the elbow position (position of the middle line segment when the view relationship is drawn in rectilinear line mode) of the view relationship. DATATYPE: Integer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ElbowPosition() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

GUID Property

Description

GUID of the view relationship display object. This GUID is assigned by ER/Studio. Each view relationship display object has a unique GUID. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

ID Property

Description

ID of the view relationship display object. This ID is assigned by ER/Studio. Each view relationship display object in a diagram has a unique ID. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID() As Variant

See Also

ViewRelationshipDisplay Object


%%PageItemTitle%%

ViewRelationshipDisplays Collection
See Also Members

Description

This object represents a collection of view relationship display objects. The owner of this collection is the submodel.

Object Model

See Also

ViewRelationshipDisplays Members


%%PageItemTitle%% $$Members$$

ViewRelationshipDisplays Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new ViewRelationshipDisplay from the ViewRelationship identified by the given ID, and returns the new ViewRelationshipDisplay. PARAMETERS: ViewRelationID as Integer.
Public Method Remove | Deletes a ViewRelationshipDisplay object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a ViewRelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ViewRelationshipDisplay objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ViewRelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

ViewRelationshipDisplays Overview


%%PageItemTitle%%

Add Method
ViewRelationID

Description

Creates a new ViewRelationshipDisplay from the ViewRelationship identified by the given ID, and returns the new ViewRelationshipDisplay. PARAMETERS: ViewRelationID as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal ViewRelationID As Variant _
) As ViewRelationshipDisplay

Parameters

ViewRelationID

See Also

ViewRelationshipDisplays Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a ViewRelationshipDisplay object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ViewRelationshipDisplays Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ViewRelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ViewRelationshipDisplay

Parameters

Identifier

See Also

ViewRelationshipDisplays Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ViewRelationshipDisplays Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ViewRelationshipDisplay objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ViewRelationshipDisplays Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ViewRelationshipDisplay object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ViewRelationshipDisplay

Parameters

Identifier

See Also

ViewRelationshipDisplays Collection


%%PageItemTitle%%

ViewRelationships Collection
See Also Members

Description

This object represents a collection of view relationships. The owner of this collection is the model.

Object Model

See Also

ViewRelationships Members


%%PageItemTitle%% $$Members$$

ViewRelationships Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a view relationship. The caller must specify whether the parent is a view or entity. PARAMETERS: ParentEntVw as String, ChildView as String, IsParentView as Boolean.
Public Method Remove | Deletes a ViewRelationship object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a ViewRelationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of ViewRelationship objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a ViewRelationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

See Also

ViewRelationships Overview


%%PageItemTitle%%

Add Method
ParentEntVw
ChildView
IsParentView

Description

Creates a view relationship. The caller must specify whether the parent is a view or entity. PARAMETERS: ParentEntVw as String, ChildView as String, IsParentView as Boolean.

Syntax

Visual Basic
Public Function Add( _
   ByVal ParentEntVw As Variant, _
   ByVal ChildView As Variant, _
   ByVal IsParentView As Variant _
) As ViewRelationship

Parameters

ParentEntVw
ChildView
IsParentView

See Also

ViewRelationships Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a ViewRelationship object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

See Also

ViewRelationships Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a ViewRelationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As ViewRelationship

Parameters

Identifier

See Also

ViewRelationships Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

ViewRelationships Collection


%%PageItemTitle%%

Count Property

Description

This is the number of ViewRelationship objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ViewRelationships Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a ViewRelationship object (specified by the given name, GUID or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As ViewRelationship

Parameters

Identifier

See Also

ViewRelationships Collection


%%PageItemTitle%%

Views Collection
See Also Members

Description

This object represents a collection of views. The owner of this collection is the model.

Object Model

See Also

Views Members


%%PageItemTitle%% $$Members$$

Views Collection Members
See Also Overview

Public Methods

Public Method Add | Creates a new view with the given coordinates, adds it to the model, and returns the new view to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.
Public Method Remove | Deletes a View object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Public Properties

Public Property _Item | Returns a View object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.
Public Property _NewEnum |
Public Property Count | This is the number of View objects in the collection. DATATYPE: Integer.
Public Property Item | Returns a View object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

See Also

Views Overview


%%PageItemTitle%%

Add Method
HorizontalPosition
VerticalPosition

Description

Creates a new view with the given coordinates, adds it to the model, and returns the new view to the caller. PARAMETERS: HorizontalPosition as Integer, VerticalPosition as Integer.

Syntax

Visual Basic
Public Function Add( _
   ByVal HorizontalPosition As Variant, _
   ByVal VerticalPosition As Variant _
) As View

Parameters

HorizontalPosition
VerticalPosition

Example

Dim MyModel As Model

Dim MyView As View

Dim HorizPo As Integer

Dim VertPo As Integer

' Setting horizontal and vertical position for the new view

HorizPo = 100

VertPo = 100

Set MyView = MyModel.Views.Add(HorizPo, VertPo)

See Also

Views Collection


%%PageItemTitle%%

Remove Method
Identifier

Description

Deletes a View object (specified by the given name or ID) from ER/Studio. PARAMETERS: Identifier as String or Integer.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Identifier As Variant _
)

Parameters

Identifier

Example

Dim MyModel As Model

Dim ViewID As Integer

' We want to remove the view with 2 as the ID

ViewID = 2

MyModel.Views.Remove(ViewID)

See Also

Views Collection


%%PageItemTitle%%

_Item Property
Identifier

Description

Returns a View object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property _Item( _
   ByVal Identifier As Variant _
) As View

Parameters

Identifier

See Also

Views Collection


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

Views Collection


%%PageItemTitle%%

Count Property

Description

This is the number of View objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

Example

Dim MyModel As Model

Dim iCount As Long

iCount = MyModel.Views.Count

See Also

Views Collection


%%PageItemTitle%%

Item Property
Identifier

Description

Returns a View object (specified by the given name or ID). PARAMETERS: Identifier as String or Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Identifier As Variant _
) As View

Parameters

Identifier

Example

Dim MyModel As Model

Dim MyView As View

Dim ViewID As Integer

' We want to get the view with 2 as the ID

ViewID = 2

Set MyView = MyModel.Views.Item(ViewID)

See Also

Views Collection


%%PageItemTitle%%

WhereUsedDataCollection Collection
See Also Members

Description

This object represents a collection of WhereUsedDataObj objects returned as a result of a WhereUsed ModelUsage or SubmodelUsage query.

Object Model

See Also

WhereUsedDataCollection Members


%%PageItemTitle%% $$Members$$

WhereUsedDataCollection Collection Members
See Also Overview

Public Properties

Public Property _NewEnum |
Public Property Count | This is the number of WhereUsedDataObj objects in the collection. DATATYPE: Integer.

See Also

WhereUsedDataCollection Overview


%%PageItemTitle%%

_NewEnum Property

Property type

Read-only property

Syntax

Visual Basic
Public Property _NewEnum() As Unknown

See Also

WhereUsedDataCollection Collection


%%PageItemTitle%%

Count Property

Description

This is the number of WhereUsedDataObj objects in the collection. DATATYPE: Integer.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count() As Long

See Also

WhereUsedDataCollection Collection


%%PageItemTitle%%

WhereUsedDataObj Object
See Also Members

Description

This represents a WhereUsed match in ER/Studio - an object in one model that matches an object in another model based on a WhereUsed query. It can also refer to a submodel that contains a particular object based on a WhereUsed Submodel Usage query.

See Also

WhereUsedDataObj Members


%%PageItemTitle%% $$Members$$

WhereUsedDataObj Object Members
See Also Overview

Public Properties

Public Property AttributeID | Attribute ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID and EntityID to obtain the corresponding AttributeObj object. Valid for ModelUsage queries for AttributeObj objects.
Public Property EntityID | Entity ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding Entity object. Valid for ModelUsage queries for Entities and child object types (e.g. AttributeObj).
Public Property GUID | This is the GUID of the matched object. DATATYPE: String.
Public Property ModelID | Model ID of the matched object. This ID is assigned by ER/Studio and can be used to obtain the corresponding Model object. Valid for ModelUsage and SubmodelUsage queries for all objects.
Public Property SubModelID | Submodel ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding SubModel object. Valid for SubmodelUsage queries for all objects.
Public Property UserMapping | Returns TRUE if this match was made manually by the user.
Public Property ViewID | View ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding View object. Valid for ModelUsage queries for Views.

See Also

WhereUsedDataObj Overview


%%PageItemTitle%%

AttributeID Property

Description

Attribute ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID and EntityID to obtain the corresponding AttributeObj object. Valid for ModelUsage queries for AttributeObj objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttributeID() As Variant

See Also

WhereUsedDataObj Object


%%PageItemTitle%%

EntityID Property

Description

Entity ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding Entity object. Valid for ModelUsage queries for Entities and child object types (e.g. AttributeObj).

Property type

Read-write property

Syntax

Visual Basic
Public Property EntityID() As Variant

See Also

WhereUsedDataObj Object


%%PageItemTitle%%

GUID Property

Description

This is the GUID of the matched object. DATATYPE: String.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID() As Variant

See Also

WhereUsedDataObj Object


%%PageItemTitle%%

ModelID Property

Description

Model ID of the matched object. This ID is assigned by ER/Studio and can be used to obtain the corresponding Model object. Valid for ModelUsage and SubmodelUsage queries for all objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property ModelID() As Variant

See Also

WhereUsedDataObj Object


%%PageItemTitle%%

SubModelID Property

Description

Submodel ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding SubModel object. Valid for SubmodelUsage queries for all objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubModelID() As Variant

See Also

WhereUsedDataObj Object


%%PageItemTitle%%

UserMapping Property

Description

Returns TRUE if this match was made manually by the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserMapping() As Variant

See Also

WhereUsedDataObj Object


%%PageItemTitle%%

ViewID Property

Description

View ID of the matched object. This ID is assigned by ER/Studio and can be used with the ModelID to obtain the corresponding View object. Valid for ModelUsage queries for Views.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewID() As Variant

See Also

WhereUsedDataObj Object


%%phrase%%

Project Overview

Description

ER/Studio Type Library

Classes

Class Module | Description
Application | This is the main object through which all other objects are accessed from. The Programmatic ID (PROGID) for this object is 'ERStudio.Application'. Macros, which run inside ER/Studio's Macro Editor, will use the pre-initialized 'DiagramManager' object.
Attachment | This object represents an Attachment in ER/Studio.
Attachments | This object represents a collection of Attachments. The owner of this collection is the AttachmentType.
AttachmentType | This object represents an AttachmentType in ER/Studio.
AttachmentTypes | This object represents a collection of AttachmentTypes. The owner of this collection is the Data Dictionary.
AttributeObj | This object represents an attribute in ER/Studio.
Attributes | This object represents a collection of attributes. The owner of this collection is the entity.
BoundAttachment | This object represents a BoundAttachment in ER/Studio.
BoundAttachments | This object represents a collection of BoundAttachments. Many of the ERStudio objects have this collection
BoundObject | This object represents a binding between a dictionary object and a using object, such as a diagram object and contains the IDs of the using object. For example for a domain bound to an attribute, it has the attribute's IDs.
BoundObjects | This the collection of objects that represent bindings between a dictionary object and a using object, such as a diagram object. This collection is owned by the dictionary object of the binding.
BoundSecurityProperties | This object represents a collection of BoundSecurityProperties. Many of the ERStudio objects have this collection
BoundSecurityProperty | This object represents a BoundSecurityProperty in ER/Studio.
BusinessDataObject | This object represents a Business Data Object in ER/Studio.
BusinessDataObjectDisplay | This object represents an Business Data Object display object in ER/Studio. A Business Data Object display object is a graphical representation of a BusinessDataObject object in a specific submodel; it is not a BusinessDataObject object itself.
BusinessDataObjectDisplays | This object represents a collection of Business Data Object display objects. The owner of this collection is the submodel object.
BusinessDataObjects | This object represents a collection of Business Data Objects. The owner of this collection is the model.
DataFlow | This object represents a data flow in ER/Studio.
DataFlows | This object represents a collection of data flows. The owner of this collection is the diagram.
DataLineageColumn | This object represents a DataLineageColumn.
DataLineageColumns | This object represents the collection of DataLineageColumns. The owner of this collection is the DataLineageTable (Data Source/Target Table).
DataLineageRule | This object represents an DataLineageRule (Data Movement Rule) in ER/Studio.
DataLineageRules | This object represents a collection of DataLineageRules. The owner of this collection is the DataDictionary.
DataLineageSource | This object represents a DataLineageSource (Data Source/Target model in the DataLineage tree).
DataLineageSources | This object represents the collection of DataLineageSources (Data Source/Target models in the DataLineage tree). The owner of this collection is the diagram.
DataLineageTable | This object represents a DataLineageTable.
DataLineageTables | This object represents the collection of DataLineageTables. The owner of this collection is the DataLineageSource (Data Source/Target).
DataLineageView | This object represents a DataLineageView.
DataLineageViewField | This object represents a DataLineageViewField.
DataLineageViewFields | This object represents the collection of DataLineageViewFields. The owner of this collection is the DataLineageView (Data Source/Target View).
DataLineageViews | This object represents the collection of DataLineageViews. The owner of this collection is the DataLineageSource (Data Source/Target).
DataMovementColumnLink | This object represents a link between a column in a Source/Target (Data Lineage) Model and a column in a physical model.
DataMovementColumnLinks | This object represents a collection of DataMovementColumnLinks. The owner of this collection is the Column.
DataMovementModelLink | This object represents a link between a Source/Target (DataLineage) Model and a Physical Model.
DataMovementModelLinks | This object represents a collection of DataMovementModelLinks. The owner of this collection is the model.
DataMovementRuleLink | This object represents a link between a DataMovementRule and a Table/Entity or a Transformation.
DataMovementRuleLinks | This object represents a collection of DataMovementRuleLinks. The owner of this collection is the EntityObj.
DataStream | This object represents a Data Lineage Stream in ER/Studio.
DataStreams | This object represents a collection of DataStreams. The owner of this collection is the data flow.
DB2390AuxTable | This object represents a DB2 OS/390 Auxiliary Table in ER/Studio. It is stored as its create statement.
DB2390AuxTables | This object represents a collection of auxiliary tables. The owner of this collection is the model (of type DB2 OS/390).
DB2Database | This object represents a DB2Database in ER/Studio.
DB2Databases | This object represents a collection of DB2Database objects.
DB2IdxPartition | This object represents a DB2IdxPartition in ER/Studio.
DB2IdxPartitions | This object represents a collection of DB2IdxPartition objects.
DB2OS390Alias | This object represents a DB2 OS/390 Alias in ER/Studio.
DB2OS390Aliases | This object represents a collection of DB2 OS/390 Aliases. The owner of this collection is the model.
DB2OS390AuxTable | This object represents a DB2 OS/390 Auxiliary Table in ER/Studio. It is stored as its create statement.
DB2OS390AuxTables | This object represents a collection of auxiliary tables. The owner of this collection is the model (of type DB2 OS/390).
DB2OS390Synonym | This object represents a DB2 OS/390 Synonym in ER/Studio.
DB2OS390Synonyms | This object represents a collection of DB2 OS/390 Synonyms. The owner of this collection is the model.
DB2OS390TablePartition | This object represents a DB2OS390TablePartition in ER/Studio.
DB2OS390TablePartitions | This object represents a collection of DB2OS390TablePartition objects.
DB2StoGroup | This object represents a DB2StoGroup in ER/Studio.
DB2StoGroups | This object represents a collection of DB2StoGroup objects.
DB2Tablespace | This object represents a DB2Tablespace in ER/Studio.
DB2Tablespaces | This object represents a collection of DB2Tablespace objects.
DB2TbsPartition | This object represents a DB2TbsPartition in ER/Studio.
DB2TbsPartitions | This object represents a collection of DB2TbsPartition objects. This is the collection of Partitions contained in a DB2Tablespace object.
DB2UDBAlias | This object represents a DB2 UDB Alias in ER/Studio.
DB2UDBAliases | This object represents a collection of DB2 UDB Aliases. The owner of this collection is the model.
DB2UDBBufferPool | This object represents a DB2 UDB BufferPool in ER/Studio. It is stored as its create statement.
DB2UDBBufferPools | This object represents a collection of DB2UDBBufferPools. The owner of this collection is the Model.
DB2UDBContainerDMS | This object represents a DB2UDBContainerDMS in ER/Studio. It belongs to a database managed Tablespace.
DB2UDBContainersDMS | This object represents a collection of DB2 UDB ContainerDMSs. The owner of this collection is the DB2UDBTablespace.
DB2UDBContainerSMS | This object represents a DB2UDBContainerSMS in ER/Studio. It belongs to a system managed Tablespace.
DB2UDBContainersSMS | This object represents a collection of DB2 UDB ContainerSMSs. The owner of this collection is the DB2UDBTablespace.
DB2UDBDimension | This object represents a DB2Dimension in ER/Studio.
DB2UDBDimensions | This object represents a collection of DB2UDBDimension objects.
DB2UDBExceptNode | This object represents a DB2UDBExceptNode in ER/Studio.
DB2UDBExceptNodes | This object represents a collection of DB2UDBExceptNodes. The owner of this collection is the DB2UDBBufferPool.
DB2UDBMaterializedQueryTable | This object represents a DB2 UDB Materialized Query Table in ER/Studio.
DB2UDBMaterializedQueryTables | This object represents a collection of DB2 UDB Materialized Query Tables. The owner of this collection is the model.
DB2UDBNode | This object represents a DB2 UDB Node in ER/Studio.
DB2UDBNodeGroup | This object represents a DB2 UDB NodeGroup in ER/Studio. It is stored as its create statement.
DB2UDBNodeGroups | This object represents a collection of DB2 UDB NodeGroups. The owner of this collection is the Model.
DB2UDBNodeName | This object represents a DB2UDBNodeName in ER/Studio.
DB2UDBNodeNames | This object represents a collection of DB2 UDB NodeNames. The owner of this collection is the DB2UDBBufferPool.
DB2UDBNodes | This object represents a collection of DB2 UDB Nodes. The owner of this collection is the DB2UDBNodeGroup.
DB2UDBSequence | This object represents an DB2UDB sequence in ER/Studio. It is stored as its create statement.
DB2UDBSequences | This object represents a collection of DB2UDB sequences. The owner of this collection is the model.
DB2UDBTableRangePartition | This object represents a DB2UDBTableRangePartition in ER/Studio.
DB2UDBTableRangePartitions | This object represents a collection of DB2UDBTableRangePartitions objects.
DB2UDBTablespace | This object represents a DB2 UDB Tablespace in ER/Studio. It is stored as its create statement.
DB2UDBTablespaces | This object represents a collection of DB2UDBTablespaces. The owner of this collection is the Model.
DBRole | This represents a Database Role in ER/Studio.
DBRoles | This object represents a collection of Database Roles in ER/Studio. The owner of the collection is the Model.
DBSchema | This represents a Database Schema in ER/Studio.
DBSchemas | This object represents a collection of Database Schemas in ER/Studio. The owner of the collection is the Model.
DBUser | This represents a Database User in ER/Studio.
DBUsers | This object represents a collection of Database Users in ER/Studio. The owner of the collection is the Model.
DDLGeneration | This object represents a DDLGeneration object that provides an interface for generating the DDL for the model.
Default | This object represents a default in ER/Studio.
Defaults | This object represents a collection of defaults. The owner of this collection is the data dictionary.
Diagram | This object represents a diagram in ER/Studio.
Dictionary | This object represents the data dictionary in ER/Studio.
Document |
Domain | This object represents a domain in ER/Studio.
DomainFolder | This object represents a Domain Folder in ER/Studio.
DomainFolders | This object represents a collection of Domain Folders. The owner of this collection is the data dictionary.
Domains | This object represents a collection of domains. The owner of this collection is the data dictionary.
EnterpriseDataDictionaries | This object represents a collection of EnterpriseDataDictionary objects.
Entities | This object represents a collection of entities. The owner of this collection is the model.
Entity | This object represents an entity in ER/Studio.
EntityDisplay | This object represents an entity display object in ER/Studio. An entity display object is a graphical representation of an entity in a specific submodel - it is not an entity itself.
EntityDisplays | This object represents a collection of entity display objects. The owner of this collection is the submodel object.
ERSFont | This object represents a font in ER/Studio. A user can get a font object for a specific label (ie, the font for the entity name or the font for the attribute name) from the submodel. A user can access or change font properties through this object.
ExportImageOptions | This object represents an ExportImageOptions object that provides an interface for generating an image of the Submodel.
FirebirdGenerator | This object represents a Firebird Generator in ER/Studio. It is stored as its create statement.
FirebirdGenerators | This object represents a collection of Firebird generators. The owner of this collection is the model.
FKColumnPair | This object represents a foreign key column pair. A foreign key column pair gives information on a parent attribute (an attribute in the parent entity) and its corresponding child attribute (a propagated foreign key attribute in the child entity).
FKColumnPairs | This object represents a collection of foreign key column pairs. The owner of this collection is the relationship.
IBusinessDataObject |
IBusinessDataObjectDisplay |
IBusinessDataObjectDisplays |
IBusinessDataObjects |
IFirebirdGenerator |
IFirebirdGenerators |
IInterBaseGenerator |
IInterBaseGenerators |
INamingStandardsTemplate |
INamingStandardsTemplates |
Index | This object represents an index in ER/Studio.
IndexColumn | This object represents an index column in ER/Studio.
IndexColumns | This object represents a collection of index columns. The owner of this collection is the index.
Indexes | This object represents a collection of indexes. The owner of this collection is the entity.
InterBaseGenerator | This object represents a InterBase Generator in ER/Studio. It is stored as its create statement.
InterBaseGenerators | This object represents a collection of InterBase generators. The owner of this collection is the model.
ISQLServerSequence |
ISQLServerSequences |
Line | This object represents a line in ER/Studio.
LineageComponent | This object represents a Data Lineage Component in ER/Studio.
LineageComponentDisplay | This object represents a lineage component display in ER/Studio. A view lineage component object is a graphical representation of a lineage component in a specific data flow - it is not a lineage component itself.
LineageComponentDisplays | This object represents a collection of LineageComponentDisplays. The owner of this collection is the data flow.
LineageComponents | This object represents a collection of LineageComponents. The owner of this collection is the data flow.
LineDisplay | This object represents a line display object in ER/Studio. A line display object is a graphical representation of a line in a specific submodel; it is not a line itself.
LineDisplays | This object represents a collection of line display objects. The owner of this collection is the submodel.
Lines | This object represents a collection of lines. The owner of this collection is the model.
ListMember | This object represents a ListMember in ER/Studio. It's an item in an Attachment TextList
MacroResultObj | This is a hidden object that is used internally in different Editors inside ER/Studio. It represents templated Procedures and triggers.
MergeModel | This object represent the MergeModel object in ER/Studio.
MetaImportObject | This object represent the MetaImportObject object in ER/Studio, which implements MetaWizard (Import) functionality for the automation interface.
Model | This object represents a model in ER/Studio.
Models | This object represents a collection of models. The owner of this collection is the diagram.
NamingStandardsTemplate | This object represents a naming standards template in ER/Studio.
NamingStandardsTemplates | This object represents a collection of NamingStandardsTemplates. The owner of this collection is the data dictionary.
NetezzaSynonym | This object represents a Netezza Synonym in ER/Studio. It is stored as its create statement.
NetezzaSynonyms | This object represents a collection of Netezza Synonyms. The owner of this collection is the model.
ObjectPermission | This represents an ObjectPermission in ER/Studio.
ObjectPermissions | This represents a collection of ObjectPermissions. The owner of the collection can be an Entity, View, Procedure, Package, Materialized View, and Sequence.
ObjectType | This object represents an Object Type in ER/Studio.
ObjectTypes | This object represents a collection of Object Types. The owner of this collection is the model.
OracleDatafile | This object represents an Oracle Datafile in ER/Studio.
OracleDatafiles | This object represents a collection of Datafiles. The owner of this collection is the Oracle Tablespace.
OracleIndexPartition | This object represents a OracleIndexPartition in ER/Studio.
OracleIndexPartitions | This object represents a collection of OracleIndexPartition objects. The owner of this collection is Index.
OracleMaterializedView | This object represents an Oracle Materialized View in ER/Studio. It is stored as its create statement.
OracleMaterializedViews | This object represents a collection of Oracle materialized views. The owner of this collection is the model.
OracleRollbackSegment | This object represents an Oracle rollback segment in ER/Studio. It is stored as its create statement.
OracleRollbackSegments | This object represents a collection of Oracle rollback segments. The owner of this collection is the model.
OracleSequence | This object represents an Oracle sequence in ER/Studio. It is stored as its create statement.
OracleSequences | This object represents a collection of Oracle sequences. The owner of this collection is the model.
OracleSynonym | This object represents an Oracle Synonym in ER/Studio. It is stored as its create statement.
OracleSynonyms | This object represents a collection of Oracle Synonyms. The owner of this collection is the model.
OracleTablePartition | This object represents a OracleTablePartition in ER/Studio.
OracleTablePartitions | This object represents a collection of OracleTablePartition objects.
OracleTablespace | This object represents an Oracle Tablespace in ER/Studio. It is stored as its create statement.
OracleTablespaces | This object represents a collection of Oracle Tablespaces. The owner of this collection is the Model.
OracleTableSubpartition | This object represents a OracleTableSubpartition in ER/Studio.
OracleTableSubpartitions | This object represents a collection of OracleTableSubpartition objects.
Package | This object represents a Package in ER/Studio.
Packages | This object represents a collection of Packages. The owner of this collection is the model.
PhysicalGeneration | This object represents a PhysicalGeneration object that provides an interface for generating the physical model for the logical model.
PrintOptions | This object represents a PrintOptions object that provides an interface for printing an image of the Submodel.
Procedure | This object represents a stored procedure in ER/Studio.
Procedures | This object represents a collection of stored procedures. The owner of this collection is the model.
Profile | This object represents a Profile in ER/Studio.
Profiles | This object represents a collection of Profile objects
Project | This object represents a Repository Project in ER/Studio.
Projects | This object represents a collection of Project objects.
ReferenceValue | This object represents a reference value in ER/Studio.
ReferenceValues | This object represents a collection of ReferenceValues. The owner of this collection is the data dictionary.
Relationship | This object represents a relationship in ER/Studio.
RelationshipDisplay | This object represents a relationship display object in ER/Studio. A relationship display object is a graphical representation of a relationship in a specific submodel - it is not a relationship itself.
RelationshipDisplays | This object represents a collection of relationship display objects. The owner of this collection is the submodel.
Relationships | This object represents a collection of relationships. The owner of this collection is the model.
RepoSubmodel | This object does NOT represents a submodel object in ER/Studio. It represents the combination of model name, submodel name referencing a submodel belonging to a diagram that exists in the repository.
RepoSubmodels | This object represents a collection of RepoSubmodels (i.e. model/submodel name combinations of submodels belonging to the diagram represented by this collection. The owner of this collection is the diagram manager.
ReverseEngineer | This object represent the ReverseEngineer object in ER/Studio.
Role | This object represents a Repository Role in ER/Studio.
Roles | This object represents a collection of Role objects.
Rule | This object represents a rule in ER/Studio.
Rules | This object represents a collection of rules. The owner of this collection is the data dictionary.
SchemaObjDisplay | This object represents an schema display object in ER/Studio. An schema display object is a graphical representation of a schema object in a specific submodel - it is not a schema object itself.
SchemaObjDisplays | This object represents a collection of schema display objects. The owner of this collection is the submodel object.
SchemaObjRelationshipDisplay | This object represents a schema object relationship display object in ER/Studio. A schema object relationship display object is a graphical representation of a schema object in a specific submodel.
SchemaObjRelationshipDisplays | This object represents a collection of schema object relationship display objects. The owner of this collection is the submodel.
SecurityProperties | This object represents a collection of SecurityProperties associated with a given SecurityType. The owner of this collection is that SecurityType.
SecurityProperty | This object represents a SecurityProperty in ER/Studio.
SecurityType | This object represents a SecurityType in ER/Studio.
SecurityTypes | This object represents a collection of SecurityTypes. The owner of this collection is the Data Dictionary.
SelectedObject | This object represents a selected object in ER/Studio. A selected object is highlighted in a submodel. Usually, a selected object will either be a view or an entity.
SelectedObjects | This object represents a collection of selected objects. The owner of this collection is the submodel.
Shape | This object represents a Shape in ER/Studio.
ShapeDisplay | This object represents an shape display object in ER/Studio. A shape display object is a graphical representation of a shape object in a specific submodel; it is not a shape object itself.
ShapeDisplays | This object represents a collection of shape display objects. The owner of this collection is the submodel object.
Shapes | This object represents a collection of Shapes. The owner of this collection is the model.
SQLServerSequence | This object represents an SQL Server sequence in ER/Studio. It is stored as its create statement.
SQLServerSequences | This object represents a collection of SQL Server sequences. The owner of this collection is the model.
SQLServerSynonym | This object represents a SQLServer Synonym in ER/Studio. It is stored as its create statement.
SQLServerSynonyms | This object represents a collection of SQLServer Synonyms. The owner of this collection is the model.
StringObject | This is a string object. Needed to store string collection.
StringObjects | This object represent a collection of StringObject
SubModel | This object represents a submodel in ER/Studio.
SubModels | This object represents a collection of submodels. The owner of this collection is the model.
SubType | This object represents a SubType in a SubTypeCluster.
SubTypeCluster | This object represents a SubTypeCluster in ER/Studio.
SubTypeClusters | This object represents a collection of SubTypeCluster in ER/Studio. The owner of this collection is the model.
SubTypes | This object represents a collection of SubType in a SubTypeCluster.
TableCheckConstraint | This object represents a Table Level Check Constraint in ER/Studio.
TableCheckConstraints | This object represents a collection of TableCheckConstraint. The owner of this collection is the Entity object.
TextList | This object represents a collection that's equivalent to an Attachment TextList. The owner of this collection is the Attachment object.
Transformation | This object represents a data lineage transformation in ER/Studio.
TransformationDisplay | This object represents a data lineage transformation display in ER/Studio. A data lineage transformation display object is a graphical representation of a transformation in a specific data flow - it is not a transformation itself.
TransformationDisplays | This object represents a collection of TransformationDisplays. The owner of this collection is the data flow.
TransformationField | This object represents a data lineage transformation field in ER/Studio.
TransformationFields | This object represents a collection of transformationFields. The owner of this collection is the transformation.
Transformations | This object represents a collection of transformations. The owner of this collection is the data flow.
Trigger | This object represents a trigger in ER/Studio.
Triggers | This object represents a collection of triggers. The owner of this collection is the entity.
UniversalMapping | This represents a universal mapping in ER/Studio - a mapping between objects across Data Architect diagrams and/or Business Architect workspaces.
UniversalMappings | This object represents a collection of UniversalMapping objects returned as a result of a UniversalMapping query.
User | This object represents a Repository User in ER/Studio.
UserComment | This object represents a user comment in ER/Studio.
UserComments | This object represents a collection of user comments. The owner of this collection is a dm1 object, e.g., an entity, an attribute, or an index, etc..
UserDatatype | This object represents a user datatype in ER/Studio.
UserDatatypes | This object represents a collection of user datatypes. The owner of this collection is the data dictionary.
UserDefinedMappingCollection | This object represents a collection of UserDefinedMappingObj objects returned as a result of a User Defined Mapping query.
UserDefinedMappingObj | This represents a user defined mapping in ER/Studio - an object in one model that maps to an object in another model.
Users | This object represents a collection of User objects.
ValidAttachmentBinding | This object represents an ValidAttachmentBinding in ER/Studio.
ValidAttachmentBindings | This object represents a collection of ValidAttachmentBindings. The owner of this collection is the AttachmentType.
ValuePair | This object represents a ValuePair (Value and ValueDescription) in ER/Studio.
Values | This object represents a collection of ValuePairs. The owner of this collection is the ReferenceValue object.
View | This object represents a view in ER/Studio.
ViewDisplay | This objects represents a view display object in ER/Studio. A view display object is a graphical representation of a view in a specific submodel - it is not a view itself.
ViewDisplays | This object represents a collection of view display objects. The owner of this collection is the submodel.
ViewField | This object represents a view field in ER/Studio.
ViewFields | This object represents a collection of view fields. The owner of this collection is the view.
ViewRelationship | This object represents a view relationship in ER/Studio.
ViewRelationshipDisplay | This object represents a view relationship display object in ER/Studio. A view relationship display object is a graphical representation of a view relationship in a specific submodel - it is not a view relationship itself.
ViewRelationshipDisplays | This object represents a collection of view relationship display objects. The owner of this collection is the submodel.
ViewRelationships | This object represents a collection of view relationships. The owner of this collection is the model.
Views | This object represents a collection of views. The owner of this collection is the model.
WhereUsedDataCollection | This object represents a collection of WhereUsedDataObj objects returned as a result of a WhereUsed ModelUsage or SubmodelUsage query.
WhereUsedDataObj | This represents a WhereUsed match in ER/Studio - an object in one model that matches an object in another model based on a WhereUsed query. It can also refer to a submodel that contains a particular object based on a WhereUsed Submodel Usage query.


ProcedureEdit.bas

      'MACRO TITLE:  INSERT ORACLE SYNONYM IN POSTSQL.BAS
      'DESCRIPTION:  This Macro will add a Synonym to a specified table/view.
      'The macro will prompt the user with a dialog to choose the table/view.
      'The synonym code will be inserted into the PostSQL of the specified
      'table/view.

      Sub Main
          Dim MyModel As Model
          Dim MyDiagram As Diagram
          Dim MyItem As Procedure
          Dim Synonym As String

          'Current Model has to be physical

          'set ER variables
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel

          'Begin If Physical Check
          If MyModel.Logical = True Then

              MsgBox("Current Model has to be Physical.")

          Else

          'initialize ObjectArray that holds tables and views
          'for the Dialog list
          Dim ObjectCount As Integer

          ObjectCount = (MyModel.Procedures.Count)*2

          ReDim ObjectArray( 0 To ObjectCount ) As Procedure 'String

          ReDim ProcNames(0 To ObjectCount) As String

          Dim count As Integer
          Dim SQLProc As Procedure
          Dim ProcID As Integer

          Dim SQLtext As Variant

          'This won't work to retrieve Procedure info:
          'Synonym = "CustOrderHist"
          'Set SQLProc.Name = Synonym
          'SQLtext = SQLProc.Text

          'This will
          Set SQLProc = MyModel.Procedures.Item("CustOrderHist")
          SQLtext = SQLProc.Text
          ProcID = SQLProc.ID

          Set SQLProc = MyModel.Procedures.Item(8%)
          SQLtext = SQLProc.Text
          ProcID = SQLProc.ID

          count = 0%
          'insert tables and views into the ObjectArray for the dialog list
          For Each MyItem In MyModel.Procedures

              If ((MyModel.Procedures.Item(count)) <> 0) Then

                  Set ObjectArray(count) = MyModel.Procedures.Item(count)
                  ProcNames(count) = ObjectArray(count).Name
              End If
              count = count + 1
          Next

          Begin Dialog UserDialog 510,224,"Procedure Editor" ' %GRID:10,7,1,1
              GroupBox 20,7,470,161,"Select Procedure:",.GroupBox1
              CancelButton 350,182,130,28
              DropListBox 40,28,220,168,ProcNames(),.ObjectList
              OKButton 200,182,130,28
              TextBox 40,140,220,21,.SynName
              Text 30,119,370,14,"Please give a name for your synonym.",.Text1
          End Dialog
          Dim dlg As UserDialog

          'If Dialog(dlg) = -1 Then

          '	If dlg.group1 = 0 Then

          '		Synonym = "CREATE PUBLIC SYNONYM " & dlg.SynName & vbCrLf
          '		Synonym = Synonym & vbTab & "FOR " & ObjectArray(dlg.objectlist) & vbCrLf & ";" & vbCrLf

      '		End If

          '	Dim ObjName As String

          '	ObjName = ObjectArray(dlg.objectlist)

      '		Set MyEntity = MyModel.Entities.Item(ObjName)
          '	Set MyView = MyModel.Views.Item(ObjName)

          '	If MyView Is Nothing Then

      '			MyEntity.PostSQL = MyEntity.PostSQL & Synonym

          '	Else

          '		MyView.PostSQL = MyView.PostSQL & Synonym

      '		End If

      '	End If 'dialog

          End If 'Physical check

      End Sub


Selectively Add Sybase Permissions to PostSQL.BAS

      'TITLE: SELECTIVELY ADD SYBASE PERMISSIONS TO POSTSQL.BAS
      'DESCRIPTION:  This macro will add permissions to the PostSQL of
      '              any selected table in an Sybase or MS SQL Server physical model.
      'AUTHOR: Jason Tiret
      'DATE:  2/2/2000

      Sub Main
          Dim MyDiagram As Diagram
          Dim MyEntity As Entity
          Dim MyModel As Model
          Dim MySelObj As SelectedObject
          Dim MySubModel As SubModel
          Dim grant As String
          Dim ID As Integer
          Dim ObjectName As String
          Dim MyView As View

          'Set ERStudio variable
          Set MyDiagram = DiagramManager.ActiveDiagram
          Set MyModel = MyDiagram.ActiveModel
          Set MySubModel = MyModel.ActiveSubModel

          'create dialog
          Begin Dialog UserDialog 450,287,"GRANT Options" ' %GRID:10,7,1,1
              Text 30,28,130,14,"Specify User/Role:",.Text1
              TextBox 190,21,160,21,.usertxt
              Text 30,56,140,14,"Choose Permissions:",.Text2
              CheckBox 60,77,120,14,"INSERT",.InsertChbx
              CheckBox 60,112,110,14,"UPDATE",.UpdateChbx
              CheckBox 60,182,120,14,"REFERENCES",.ReferenceChbx
              CheckBox 60,217,110,14,"DELETE",.DeleteChbx
              CheckBox 60,147,120,14,"SELECT",.SelectChbx
              CheckBox 200,77,160,14,"With Grant Option",.InsWithGrantChbx
              CheckBox 200,112,150,14,"With Grant Option",.UpdWithGrantChbx
              CheckBox 200,147,150,14,"With Grant Option",.SelWithGrantChbx
              CheckBox 200,182,150,14,"With Grant Option",.RefWithGrantChbx
              CheckBox 200,217,150,14,"With Grant Option",.DelWithGrantChbx
              OKButton 40,252,140,21
              CancelButton 260,252,140,21
          End Dialog
          Dim dlg As UserDialog

          If Dialog(dlg) = -1 Then

              For Each MySelObj In MySubModel.SelectedObjects

                  'make sure selected object is an Entity
                  If MySelObj.Type = 1 Or MySelObj.Type = 16 Then

                      ID = MySelObj.ID

                      If MySelObj.Type = 1 Then

                          Set MyEntity = MyModel.Entities.Item(ID)
                          ObjectName = MyEntity.TableName

                      ElseIf MySelObj.Type = 16 Then

                          Set MyView = MyModel.Views.Item(ID)
                          ObjectName = MyView.Name

                      End If

                      'Add insert grant
                      If dlg.insertchbx = 1 Then

                          grant = "GRANT INSERT ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.Inswithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'Add References grant
                      If dlg.referencechbx = 1 Then

                          grant = grant & "GRANT REFERENCES ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.refwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'Add update grant
                      If dlg.updatechbx = 1 Then

                          grant = grant & "GRANT UPDATE ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.updwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'add select grant
                      If dlg.selectchbx = 1 Then

                          grant = grant & "GRANT SELECT ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.selwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      'add delete grant
                      If dlg.deletechbx = 1 Then

                          grant = grant & "GRANT DELETE ON " & ObjectName & " TO " & dlg.usertxt

                          If dlg.delwithgrantchbx = 1 Then

                              grant = grant & " WITH GRANT OPTION" & vbCrLf & "go" & vbCrLf

                          Else

                          grant = grant &  vbCrLf & "go" & vbCrLf

                          End If

                      End If

                      End If

                      If MySelObj.Type = 1 Then

                          MyEntity.PostSQL = MyEntity.PostSQL & grant

                      ElseIf MySelObj.Type = 16 Then

                          MyView.PostSQL = MyView.PostSQL & grant
                      End If

                      grant = ""

                      Next

          End If 'Dialog

      End Sub