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Introduction

ER/Studio is a visual modeling application used for platform-independent, logical data architecture analysis and
design in addition to platform-specific physical database design and construction. Its powerful, multi-level design
environment addresses the everyday needs of database administrators, developers, and data architects who build
and maintain large, complex database applications and strive to consolidate, report, and re-use metadata across the
enterprise.

ER/Studio’s progressive interface and simplicity have been designed to effectively address the ease-of-use issues that
have plagued data modeling and CASE tools for the past decade and more. The application equips you to create,
understand, and manage the life-cycle of mission-critical database designs and business metadata within the
enterprise.

The product offers strong logical design capabilities. From one logical design you can spawn many physical designs.
ER/Studio offers bidirectional model comparison and information synchronization. It is rich and customizable. You can
use Visual-Basic for Applications API for product customization. ER/Studio also offers powerful DDL reverse
engineering and generation, metadata import and export capabilities, and sophisticated HTML and RTF-based
documentation and reporting facilities.

Product Benefits by Audience

Data Modelers and Data Architects

ER/Studio is critical for organizations concerned with eliminating data redundancy, creating an
enterprise view of data assets and assisting development with making informed decisions about
how best to reuse elements pre-defined by the enterprise. Its powerful logical (non-database or
technology specific) analysis and design environment helps to normalize and create an enterprise
view of the objects concerning the data managed by an organization. More importantly, it can
communicate this quickly through powerful reporting and metadata exchange mechanisms
throughout the enterprise.

Database Administrators and Database Developers

Managing databases can be incredibly difficult without a blue print or road map to understand
important object dependencies. ER/Studio’s round-trip engineering capabilities, including database
reverse-engineering, provide database administrators (DBAs) or developers with important physical
data models in seconds. These models can be used as powerful and efficient change management
platforms, allowing users to update a model when changes need to be implemented at the
database. The model can then be used to automatically generate DBMS-specific, syntactically
correct alteration or database DDL.

Business and IT Managers

ER/Studio’s robust reporting facilities allow delivery of critical information about designs to the
enterprise in seconds. This heavily leveraged and beneficial capability of ER/Studio allows users to
provide, in literally seconds, clear, easy to navigate, and safe-to-distribute documentation about a
database or enterprise data model to those who need to review it.



About this Guide

This guide is intended to help you get started using Embarcadero’s data modeling and database design solution,
ER/Studio and its collaborative Repository available in Enterprise Edition.

After completing this guide, you will have the foundation you need to explore the many features and benefits of
ER/Studio. You will have learned how to do the following:

* Create a new data model.

Work with logical and physical diagrams.

* Leverage productivity-focused features such as powerful reporting engines.

Use the Enterprise Edition to collaborate, set versions, and manage model security.
e Use common tasks and commands to make you more productive.
This guide is divided into nine sessions. Do them all at once or complete them individually as your time permits.
» Getting Started with ER/Studio
» Logical and Physical Modeling
* Documenting an Existing Database

¢ Documenting Data Lineage

« Diagram Navigation and Aesthetics

« Importing and Exporting Metadata

¢ Dimensional Modeling

* Automating Tasks
« Collaborative Modeling

You can use this basic tutorial as a road map of product highlights, but also to help you find your own path in exploring
ER/Studio.



Once you've started, from the Main menu you can click Help to find many additional resources that complement and
build on many of the activities shown in this brief guide.
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Getting Started with ER/Studio

Downloading and Installing

You can obtain the latest version of the ER/Studio Enterprise software from the Embarcadero Web site at:
www.embarcadero.com/downloads/download.html

Click Download, and then follow the steps indicated. Save the file on your computer and then double-click to launch
the self-extracting installer that will guide you through the installation process.

When you first install an evaluation copy of ER/Studio, you can use the tool for 14 days. After that time, a permanent
license is needed and can be acquired by contacting Sales@Embarcadero.com or by calling (415) 834 3131.


http://www.embarcadero.com/downloads/download.html
mailto:Sales@Embarcadero.com

Overview

The graphic below names and describes the functionality of some key elements of the ER/Studio user interface.

Sophisticated diagram

Data Model Explorer displays information auto-layout tools provide

about logical and physical models, single-click clean up of
submodels, and nested submodels. Repository object status diagram objects.
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Starting to Data Model with ER/Studio
1 Onthe Windows Start > Programs menu, click Embarcadero > ER/Studio.

2 Click File > New and then in the dialog that appears, click Draw a new data model.
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As you can see in the Create a New Model dialog, there are a number of ways to begin modeling with ER/Studio:

XK Cancel
2  Hep

Build a new design from the ground up by drawing a new data model.
« Build a data model from an existing database through live reverse engineering.
Import designs from other modeling products such as Computer Associate’s ERwin or SQL files.

TIP:  You can select an initial layout style for your model before the SQL import takes place.

3 Ensure Relational is selected for the new model type and then click OK.



After selecting Draw a new data model and clicking OK, ER/Studio will resemble the image below:
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Logical and Physical Modeling

ER/Studio supports both logical (hon-DBMS or technology-specific) modeling and physical (DBMS-specific) modeling.
ER/Studio is designed to allow organizations the flexibility to analyze and design a business problem or application
logically and generate as many different physical interpretations from the logical model as required. Multiple physical
models can be generated from the logical model for the same DBMS (for example, Oracle) or other DBMSs (such as
Oracle, SQL Server, and DB2). Generating logical and physical models will be discussed in detail in the following
sessions.

« Using Data Dictionary Domains to Populate New Entity

« Establishing Relationships Between Entities

¢ Creating and Working with Submodels in ER/Studio

¢ Generating Physical Models from a Logical Model

« Denormalizing the Physical Model

« Finding out How an Entity Maps to the Physical Model\

Using Data Dictionary Domains to Populate New Entity

As instructed in Getting Started with ER/Studio, you have chosen to draw a new data model to begin a logical model
from the ground up. Before we begin to add entities, we will populate ER/Studio with some sample domains (Domains
are re-usable attributes).

1 Click File > Import Data Dictionary.

Import Data Dictionary Options

Select Source Data Dictionary

Pleaze zelect the Diml File and Data Dictionary from which toimpart:
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2 Nextto the File Location box, click the ellipsis and browse to the Sample Models folder, which is located at:

e For Windows XP:
C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudio_X.X\Sample Models

e For Windows Vista:
C:\ProgramData\Embarcadero\ERStudio_X.X\Sample Models

3 Double-click the Orders.dml sample model and then click OK.
This model contains a pre-populated, sample data dictionary.

NOTE: Under Resolve Imported Objects with Duplicate Names, you can choose between a couple of
options to determine how the dictionary objects are imported. This is important when importing
into a diagram that already has dictionary objects in it.

Once opened, you will see that the ER/Studio Data Model Explorer has automatically switched to the Data
Dictionary tab to allow immediate drag and drop access to domains
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4 Now, to add an entity to the Data Model Window, click the Entity tool on the Modeling toolbar,

ModeYag Toolbar + X
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and then click in the Data Model Window to drop the entity.

The cursor will change to an entity symbol once the Entity tool is clicked, so you can click to drop
as many entities on the Data Model Window as you want.

.
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Right-click to return your mouse to the selection cursor.

In the entity name field, type Customer, replacing the default entity name, Entity.
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In the Domains folder of the Data Dictionary tab, locate the ID domain in the Numeric Domains folder.

Click the ID domain (do not release your mouse), drag it onto the Customer entity, and then release it just below
the entity’s name, which is the entity’s Primary Key field.

You can edit or rename an entity and insert, edit or rename attributes by holding down the Shift
key and then clicking the name or attribute. Pressing the Tab key cycles between the entity’s
name, and primary key, and non-primary key fields. After naming the field, press Return to insert
a new field.

If you need to zoom in on the entity to read the entity name and attributes, press F8 to view the
Zoom Window, then use the scroll bars of the Zoom Window to center the entity on the Data Model
Window. Press Shift while rolling the mouse wheel forward to increase the view magnification.
You can use the Pan tool to reposition the view to better see the entity.

In the entity, click ID, the name of the attribute we just created from the ID domain, and change its name to
CustomerlD, as seen in the illustration above.
Repeat the process in 7 and 8 to populate the Customer entity with the following domains:

« Name and Phone from the Property Domains folder
e Address, City, State, Zip Code from the Address Domains folder.

Drop another entity on the Data Model Window and call it Order.
Drag the ID domain onto the Order entity’s Primary Key field, change the ID domain name to OrderID.

Save your data model. We'll use it in the next session of this tutorial.



Establishing Relationships Between Entities

1 On the Modeling toolbar, click the Non-Identifying, Mandatory Relationship tool.
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{Mon-Identifying, Mandatory Relationship

NOTE: The screen shots of this tutorial were taken using a model where the notation was set to
IE (Crow'’s Feet). Depending upon the notation your model is currently set to, the icons for each
relationship will be slightly different.

You can change the model notation by clicking Model > Model Options, and then choosing
another notation option in the Notation pane.

2 To establish a relationship between Customer and Order, click the parent entity, Customer and then click the
child entity, Order.

NOTE: ER/Studio supports sound design practices by automatically propagating the primary key from
parent to child entities. If there are candidate alternate keys that should also be propagated to the
child, in the Relationship Editor you can choose all available parent entity keys in the Parent Key
list. Deleting a relationship will remove a non-native propagated attribute. However, if you want to
keep the child columns of the relationship or foreign constraint, when you delete the relationship
you can check the Make Foreign Keys Native option. In this case, if the relationship between
Customer and Order is deleted, the CustomerID will be left in the Order entity.

What are Domains? Domains are valuable tools for establishing standard, re-usable attributes/columns. They
allow data modelers to create a data element once (such as an ID field you require all of your entities to leverage as its
primary key) which has the same data type, definition, rule, and constraint no matter where the data element is
distributed and bound. Read more about Domains in ER/Studio’s Help.

Creating and Working with Submodels in ER/Studio

Now that you have a general understanding of how to build logical models from the ground up in ER/Studio, it is
important to understand how to work with an important navigation feature of ER/Studio, called Submodels. Submodels
and nested submodels are designed to break down large, complicated views of a data model in order to focus on a
specific area. An important aspect of Submodels to understand is that any changes made in the submodel, other than
layout, color, display settings, notation, etc. which can be unique to the submodel, will occur automatically in the Main
Model view. In other words, change or add an attribute to an object in a Submodel and the change is automatically
propagated to its Main Model counterpart.

Let’s close the current sample model, and open a more mature model. Use this exercise to learn more about
submodeling.

1 Click File > Open.
2 Select Orders.dm1 and then click Open.

3 To preserve this sample model for future use, click File > Save As and then save the Orders.dml file with a
new name.

In this exercise, we will be modifying this model.



4 Collapse the folders in the Data Model tab of the Data Model Explorer to look like the image below:
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In the Orders.DM1 sample model, there are no physical models. This model includes several submodel folders
that help to describe the logical model:

* Main Model: This is the entire collection of all logical objects in the Orders.DML1 file. Note the absence of the
magnifying glass on the folder icon which designates it as the main model.

e Bill of Materials through Shopping Cart: These are submodels, which are smaller collections of entities
derived from the Main Model that help to describe specific areas of the Main Model free from other entities.

e Alternate Key through Primary Key: These are nested submodels, which can go ‘n’ levels deep and are
literally submodels of submodels.

Feel free to explore. Click the plus sign (+) to expand these folders.

Let’s create a submodel with all the objects related to the Orders.DM1 Address components.



5 To make a new submodel, navigate to Logical Main model and with the Ctrl key depressed, click the objects in
the Data Model Explorer. as seen in the image below.
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NOTE: Any objects selected in the Data Model Explorer will also be selected on the Data Model Window
as well (also seen here). You can also select entities by lassoing them on the Data Model Window.
With the entities selected, click Model > Create Submodel.

2% Create Submodel

Addresz Components | ¢ Edit Submodel |

|~f Qk. | |x Cancel |

6 Below Create Submodel, enter Address Components as the name for the submodel.



7 Click OK.

ER/Studio creates the Address Components submodel.
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What do the results look like and how do | navigate to the submodel? Once created, you will see the
new submodel listed in the Data Model Explorer, denoted as a submodel by the magnifying glass over its folder, as in
the case with Bill of Materials and the other submodels.Generating Physical Models from a Logical Model.

ER/Studio can generate as many physical models from a single logical model as desired. There are many ways to
leverage multiple physical models in ER/Studio to help the design process. Examples of how multiple physical models
are used are:

¢ Managing change in an existing application: Maintain independent development, test, and production
physical model diagrams that represent specific databases.

* Migrating database applications: Use ER/Studio as an analysis and design hub for migrating database
applications. You can also use ER/Studio to manage a physical model of the legacy source database application
in addition to its new target physical model. The target physical model can be for an entirely new DBMS than
originally maintained in the legacy database.

Generating Physical Models from a Logical Model

ER/Studio can generate as many physical models from a single logical model as desired. There are many ways to
leverage multiple physical models in ER/Studio to help the design process. Examples of how multiple physical models
are used are:

e Managing change in an existing application: Maintain independent development, test, and production
physical model diagrams that represent specific databases.

« Migrating database applications: Use ER/Studio as an analysis and design hub for migrating database
applications. Manage a physical model of the legacy source database application in addition to its new target
physical model, which can be for an entirely new DBMS than originally maintained in the legacy database.

Let's generate a new physical model from a logical model in order to build a database. We’ll use the Orders.DM1
sample model.

1 Open your version of the Orders.DM1 sample model.

Use the steps shown in the last session to do so.



2 Select the Main Model and then click Model > Generate Physical Model.

ER/Studio invokes a step-by-step wizard to walk you through the process of generating a DBMS-specific
physical model.

E= Generate Physical Model - Page 1 of 5
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3 Name the new physical model DB2 Physical Model and then select DB2 UDB for OS/390 8.x as the target
DBMS to generate

4 Continue through the Generate Physical Model Wizard, which prompts very clear and concise questions about
how you want your physical model to be generated.

NOTE: The wizard prompts you to customize items such as individual object selection, index assignment,
default storage parameters, resolution of many-to-many relationships that may be in the logical
model, and naming conventions. A DBMS-specific validation check is also provided in this wizard.

TIP:  The Quick Launch can store common settings so that an operation can be reused on this model
or on any other models. You can reuse the settings on another model by choosing the Use
File-Based Quick Launch Setting option when saving the Quick Launch information on the last
page of the wizard.



5 To generate the new Physical Model, on the last page of the wizard, click Finish.

Now that a physical model has been generated from the logical model, feel free to navigate to specific objects
via the Data Model Explorer, such as the CUSTMR table selected here. Double-click and view the physical
details of the object such as DDL, Indexes, Partitions, and Storage.
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Denormalizing the Physical Model

ER/Studio comes equipped with denormalization wizards to help you optimize the physical design once the physical
model is generated. The wizards help automate the process and keep the ties between the physical tables and the
logical entities.

The active, denormalization wizards available depend on which tables are selected in the physical model when you
select Denormalization Mapping. For example, if two tables that are related to each other are selected, the valid
operations would be Rollups or Rolldowns

Delete Table

Entity Color and Font Settings »

Align Entities »

Denormalization Mapping >|| Rollups...

Edit User-Defined Mappings. .. Rolldowns...
Resize Harizontal Splits. ..

Vertica

LN

it

Ll

Create Submodel ...
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—
]
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-
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Create Procedurs

Create Trigger L4
Create View

Apply To Submodel(s)...

Macros L4

E Add/Remove Macro Shortcuts

@ Compare and Merge Utility. ..
i@ Submodel Synch Utlity. ..

When only one table is selected, the options to split the tables becomes available. The Table Merge option is available
when two unrelated tables are selected.



Let’'s walk through an example of a denormalization operation using the generated physical model in a previous
session of this tutorial. We may want to reduce the overhead on the Custmr table by splitting it into two physical

tables, Custmr_East and Custmr_West. Splitting the table can reduce the query time and provide opportunities to
store the tables at different locations which could further reduce lookup time.

Before the operation, the Custmr table should look like:

nii

G

1 Open the Ordersl.dml model you modified and saved in the last session.

2 Inthe Data Model Explorer, right-click the Custmr table.

3 Click Denormalization Mapping > Horizontal Splits.

Notice that since only Custmr is selected, the only possible mappings are vertical and horizontal splits.

The Horizontal Table Split Wizard launches.

= Horizontal Table Split Wizard - Page 2 of 4

X Cancel

Y Help

Pleaze review the naming conventions for each of the replicated table. Mate
} that in order for bao or more tables ko retain the zame name on the physical
model, a unique databasze ownerdqualifier muzt be provided.
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af the original table.

Replicated Tables Submodel |Mew Table Hame Owner
Pre mapped T able Cuztmr
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2 [ Cuztmr_wiest

# Back Hext *’
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4 On Page 1, type 2 for the number of splits.
5 On Page 2, rename splitsl and 2 to Custmr_East and Custmr_West respectively.
6 On Page 3, click Next.

We will keep all the relationships.

7 On Page 4, type a name and definition for the denormalization operation, select Reflect changes to original
tables, and then click Finish.

Finished! After the split the Custmr table will be two physical tables that look like this:

Custmr_Ezst

Custmr_ Vst

stmr 1D [P
rs1_Mme
Lsl Wme
CaTgry_hme
Ziil_Addr

L]

i

The two tables are identical except for the name.
You can selectively choose which attributes are included in the resultant tables by using a vertical split.

The denormalization mapping is stored in the data model tree underneath the submodels. You can use this to
undo the operation or see the history of what happened. ER/Studio tracks the before and after states of these
operations. This comes in handy in the next section where we discuss the Where Used analysis that can be
performed between the logical and physical models.

Finding out How an Entity Maps to the Physical Model

Now that we have performed a denormalization operation, the logical entity, Customer, essentially has become two
physical tables, Custmr_East and Custmr_West. The ties between the logical and physical models are not lost.
ER/Studio allows you to see what Customer in the logical model maps to in the DB2 physical model.

Let's take a look at the Customer entity in the logical model.
1 Inthe Data Model Explorer, navigate back to the Customer entity in the Logical model

2 To start the Entity Editor, double-click the Customer entity.



3 Click the Where Used tab.

38 Entity Editor

Entity Hame: IEustDmer T able Hame: IEustmr

[~ Logical Only
Attributes | F.eys I Relationzhips
Maming Standards | [rata Lineage | Securnty |nf
Where Uzed I |lzer-Defined M appings

Double-click on an Entity/T able in another model to edit it
[ Show only submodels that uze this object
@ Where Used
El Logical
FHES Submodel Usage
=y DB2 Physical Maodel (IEM DB 2)
__" Table Mame: Custrr_E ast
1___'| Table Mame: Custrr_west
El{:,f_'_] Drenarmalization bMappings
El% Custrr_Harizontal_S plit_kapping_1
rj Drovnztream Mappings
rj |pstream tappings
EH:__.! Pre-map State
ﬁ Table Hame: Custrr
=9 Postmap State
__' Table Mame: Custrr_E ast
1_| Table Mame: Custrr_west

Once the tree is expanded, you can see the lineage of what has happened to the object. Notice that
Custmr_East and Custmr_West are listed as physical implementations of the Customer entity. The
denormalization mapping object from the data model explorer tree is visible to show how the end result was
achieved.

The Where Used tab also displays the submodel usage of a particular entity within the logical or physical model.
This allows you to see which business areas the entity belongs to.

NOTE: Where Used information is also available for attributes and columns.

Conclusion
In this session, you have seen how incredibly quick and easy it is to:

« Build a logical data model from scratch.

e Create a new submodel view to understand how to model on specific parts of a larger Main Model.
« Generate a physical model from a logical database in preparation for building a new database.

« Denormalize objects in the physical model.

« View the mappings between the logical and physical models using the Where Used tabs.

For more information, refer to the ER/Studio Help and the review the topics “Developing the Logical Model” and
Developing the Physical Model,” “Synchronizing Physical and Logical Models,” and “Generating a Script File or
Database.”



Documenting an Existing Database

One of ER/Studio’s most powerful applications is that of a documentation generator to communicate complex
databases and associated metadata to the Enterprise. ER/Studio is equipped with extensive report generation
capabilities:

« HTML Report Generation: Instantaneous generation of an HTML-based Web site designed to provide simple
navigability through data models and model metadata using standard browsers such as Microsoft’s Internet
Explorer or Netscape Navigator.

« RTF Report Generation: Instantaneous documentation generation compatible with applications like Microsoft
Word.

In the exercise below, we will reverse-engineer an existing database and generate an HTML report for distribution and
navigation to those who depend upon the information about the data model, but who may not be permitted to connect
to the database for security or organizational reasons.

Generating an HTML Intranet Dictionary Report

PRE-REQUISITE: This exercise assumes that you can connect to an existing database in order to document it.
Please refer to “Reverse-Engineering an Existing Database” in ER/Studio’s Help for explicit setup details if needed. If
you cannot connect to an existing database, you can still generate documentation from the installed sample models.
Skip steps 1 through 7 below, which relate to reverse-engineering, and begin at step 8 after opening a sample model
included with ER/Studio.

1 Click File > New.

—Create a New Model

%) i~ Draw a new data model
X Cancel

@ ¥ Feverse-engineer an existing databaze

% ™ |mport Model From: |EF: Fils j

Y Heb

2 Click Reverse-engineer an existing database.
3 Click Login.

You can reverse engineer the database from either an ODBC datasource or via Native RDBMS client
connectivity. In this example, Native Connectivity to Microsoft SQL Server will be demonstrated.



DOCUMENTING AN EXISTING DATABASE > GENERATING AN HTML INTRANET DICTIONARY REPORT

4  Type the relevant connectivity information such as the data source name, user name, and password, and then
click Next.

i Reverse Engineer Wizard - Page 1of 5

MS SOL Server 2
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EMBARCADERO TECHNOLOGIES > ER/STUDIO® 8.0.3 EVALUATION GUIDE 26



DOCUMENTING AN EXISTING DATABASE > GENERATING AN HTML INTRANET DICTIONARY REPORT

5 Walk through the Reverse Engineer Wizard selecting the objects, options, and layout preferences for the model.
i Reverse Engineer Wizand - Page 2 of 5
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iﬂeveme Engineer Wizard - Page 3 of 5
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6 Continue through the wizard to select layout styles and other preferences.

i Reverse Engineer Wizard - Page 4 of 5

X Cancel

% Help |
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i Reverse Engineer Wizand - Page 5 of 5 Hi=]E3
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| |

} Summary of Selected Objects
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Object Type Owner Object Hame -

T able dbia backupfile |
T able dbio backuprnediafanmily
Table dbio backupmediazet
T able dbo backupzet

U T able dbia lag_shipping_prim...
T able dbio log_zhipping_seca...
Table dbio logrnarkhigtary
T able dbo mawebtasks
T able dbo restorefile LI

} Save Settings for Quick Launch? Save bz .. |
¥ Finish |
Z

7 Help | <§ Back | P Hext

X Cancel

Click Finish and ER/Studio reverse engineers your database!

Once reverse engineering of your database is complete, let's generate a complete HTML report of the database
for others in your organization to review.

In the Data Model Explorer, select the Physical Main Model.



9 Click Tools > Generate Reports.

% ER/Studio Report Wizard - Page 1 of 4 |:| E|[Z|

} Generate HTML or RTF file
Select report type
o HTHML report i~ RTF report

Report Directory
Select directory for report
|E:'xDDcuments and Settingzh] acquietdpplication Data\Embarca I:l

Wizard Quick Launch

Select Settings File
[ Usze file-bazed Quick Launch settings.

|Nn:|r'|e ﬂ | ‘

(" Settings Orly % Settings and Objects

} Do you want to invoke an Editor to view the report after it is
generated?
™+ ‘Yes " Mo

Generate HTML report using performance-enhanced yersion for
large data models.

[ Usze enhanced wversion.

(X coes ] (2 i |

10 On the first page of the wizard, for the report type, select HTML.




11

On page 2, click Select All in both areas of the Diagram tab.

¥ ER/Studio Report Wizard - Page 2 of 4 |:| E'E'

Pleaze zelect the objects in your data model that you'd
like to generate a report for.
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12

Click Select All in both areas of the Data Dictionary and the Procedures tabs, and then click Next.

NOTE: The tabs available on page 2 depend on what objects are supported by the database platform of the
selected model. Some databases support more database objects than Microsoft SQL Server 2005, such as
Oraclellg and IBM DB2 LUW 9.x for which there are also tabs on this page for procedures, functions, triggers,
packages, and tablespaces. If the model was previously denormalized, a Denormalization Mappings tab would
also appear.



13 On page 3, below Submodel Image Options, click Select All.

TIP:

¥ ER/Studio Report Wizard - Page 3 of 4

In the Logo and Link Options, you can choose to replace ER/Studio’s default Embarcadero
Technologies logo in favor of your own corporate logo (and Hyperlink).

Select HTML generation options

Submodel Image Options

Report Formatting
Object Definition and Mate Formatting
{* Preserve Formatting
Explorer Tree

[ Include owner in tree.

|-@ Back |

|x Qan-::el| | ? Help | Mext @

Submodel images will be generated in the = @ .ﬁ.dventgre workls.... 25
report for the submodelz zelected in the [ Lagical
tree. Individual £oom and Quality settings | [ b air b odel
can I:u_a zet _f-:ur each submodel by — Human Resa.
zelecting it in the tree.
[ Perzon
Zoont —J 100% [ Froduction
— [ = T I N —
Guality: —  mx SelectAll | Unselectall |
Logo and Link Options
|mage file | Browse. ..
Mew Link | Report Title
Description  |S0L Server 2005 Sample Model

" “wirap definition and note text

Because HTML formatting can be included in object definitions, you can also choose to preserve the formatting

specified on the Definitions tab of the various object editors.

14 Click Next to advance to Page 4 of 4, and then click Finish.

ER/Studio then begins the report publication process and launches the default browser so you can review the

report.




15 Finished!

Start navigating the report via your browser. Navigation will perform exactly as it does when you are using
ER/Studio! Expand the tree to find Model Image and click on it (see below). You will see a read-only version of
your data model (as seen below). Use the Explorer to navigate to any metadata you want or select the entities
and relationships in the model image to jump to their information.

EMEARCADERO

recanotosies:  ER/Studio® Web Report Generation

we make data work

Fa
@B Title
= BEmbarcadera Sales Order Processing Product
E--E=E|Lngical Product ID

= EMain Mogel Name Product
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= EEntities RowTirmeStamp
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T';QKE%;S
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+ BBl of Materials

Product Version

E ‘ Product Yersion IO DE Platform
Eﬂ-ﬁj@nmmmsmn Tracking Froduct ID (FK) OB Platiorm 1D
HEFCustomer Yersion Mumber Name
= ElCustomer Address Label Description
s ) Is Default
& &liMain Model Displays Is Supported ClEEITEE Y]
RowTimeStamp
P ayment Created By
= EPricing rowTimestame ~L
Conclusion

In this session, you have learned how to:
« Connect to and reverse-engineer an existing database with ER/Studio.
« Document a database in seconds using ER/Studio’s automatic HTML documentation publication facility.

For more information on Reporting, refer to ER/Studio’s Help and review the “Generating RTF and HTML Model
Reports” section.



Documenting Data Lineage

The Data Lineage features of ER/Studio enables you to document the movement of data from point A to point B (and
any intermediate steps in between) is sometimes referred to as ETL (Extraction, Transformation and Load). Points A
and B can be anything from flat files, databases, XML, Access, and Excel spreadsheets. This is sometimes referred to
as source and target mapping. A model produced in ERStudio can represent any point along the way. Data Architects
need to ability to specify the source or target of data down to the column-level. Along with the metadata that defines
the source and target mapping are rules for how the data is manipulated along the way.

This section will help you document the data lineage of your systems. It is comprised of the following tasks which
correspond to the general ETL workflow:

¢ Create a Data Flow
¢ Create a Data Movement Rule
« Define External Source and Target Systems

* Create a Data Lineage and Transformation Visualization

Create a Data Flow

The Data Flow organizes and encapsulates one data transformation and the source tables and columns used in the
transformation to produce the target data. Multi-tiered mappings are possible and there can be multiple
transformations involving different columns between two tables as illustrated below.

M# DataLineage
= |""- Data Flows EROKER

#1 Broker § BROKER_ID (FK)
#{ Client Load

INVESTMENT
F INVESTMENT_ID (PK)

w8 Client Load 2
E}@ﬁ D ata Movement Rules

% OFFICE_LOCATION_ID (FK)
3 BROKER_LAST_MAME
2 BROKER_FIRST_MAWE

5% INWVESTMENT _T¥PE_ID (FK)
¥ INVESTMENT_WENDOR

3 INVESTMENT_MAWE
2 INVESTMENT_UMIT
3 INVESTMEMT_DURATION

—& D ata Retention [Archive Fule] ‘
—& Upzert [Update Rule] % MANAGER_ID (FI)
I'i: Data Sources “F ¥EARS_WITH_FIRM

—Hi % Local Models \ /
2| Logical
Entities [10] i Broker Name
lM—DW Input=:
1 Tables (4] BROKER.BROKER_LAST_HAWE

‘F‘, GiM_OLTF BROKER.BROKER_FIRST_MAME
Tables (5] INWVESTMENT.INVESTMENT_MN AhiE
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Create a Data Lineage Data Flow
1 Click File > Open and select the GIMB.DM1 diagram in the Sample Models directory.

2 Click the Data Lineage tab at the bottom of the application window.

You are prompted to create a Data Lineage Data Flow.

ER/Studio 8.0 X

L] E There are currently no Data Lineage Data Flows available to display. Would you like to create one now?
L]

Yes Mo |

3 Click Yes.

If this is not the first time you click the Data Lineage tab after opening a diagram, from the Data Lineage explorer,
right-click the Data Flows node and then click Create Data Flow.

4 Enter a Data Lineage Data Flow name and then click OK.

Add Data Lineage Data Flow

M arne: |Er|:|ker

|¥' ak. | |x LCancel |

NOTE: The name that appears in the diagram title tab at the top of the application window is appended
with : task name, when you click a task in the Data Lineage explorer, such as GIMDB.DM1 - Data
Flow Model View: Broker*.

L JFGIMDE_80_testing.DML1 - Data Flow Model View: Broker *

M# DataLineage
= |""- Data Flows EROKER

3 Broker § BROKER_ID (FK)
# Cliert Load

% OFFICE LOCATION 10 (FED

The Data Flow has been created.

Create a Data Movement Rule

Data Movement rules describe how source and target tables and entities are related. You can relate source data to
one or more tables and entities in the same model, the active diagram, or to tables imported from legacy systems. The
rules defined here are used at the table level on the Data Lineage tab of the entity and table editors.



Create a data movement rule

1 Onthe Data Lineage tab, right-click Data Movement Rules and choose New Data Movement Rule.

% Data Movement Rule

Rule Information l Binding Information

Rule Hame: |B ackup

« 0K

Rule Type: | Create Fule

il Tzt Create Rule

Deletion Rule
Recovery Rule
|Jpdate Rule
Boolean

Drate

Euternal File Path
M umeric

x Cancel

? Help

2 Complete the Data Movement Rule editor as required and then click OK to exit the editor.

TIP: Once created, you can edit the Data Movement rule by double-clicking it to launch the Data

Movement Rule editor.

The following describes options that are not self-explanatory:

Rule Information tab

« Rule Name: Enter a name that indicates the operation and objects acted on, depending on the specifics of your

binding definition.

¢ Rule Type: Select a generic movement rule type that best describes the data movement.

* Rule Text: Document your data movement plan here, perhaps adding instructions or contingency plans.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this attachment. You can override this
setting using the Data Lineage tab of the entity or table editor.




Define External Source and Target Systems

Data sources can originate from models in the active diagram (local models) or from external sources that are either
imported into the active diagram or created on the Data Lineage tab. A data source can be imported from *_.dm1 files,
*_dtl files, database or a SQL files, flat files, and other common application files. The following describes how to
import metadata from an external source.

NOTE: Source data imported through the Data Lineage tab only includes information such as table and
column name, datatype, nillability, primary key, and column definitions. To obtain more details,
reverse engineer the database or import it into ER/Studio using the Metadata Wizard.

Import external source or target data
1 From the Data Lineage tab, expand the Data Sources node.

2 Right-click Other Sources and choose New Source.

E% Import Source - Page 1 of 5

Welcome to the Data Source Import Wizard!

Please select where you would like to import the source
metadata from:

i+ From a model in anaother D1 file
| ~

i From a Repository bazed DM file

i From a SOL file

E—
b " From a live database

Comparizon Quick Launch

f=—— —

Select Settings File
v Uze file-bazed Quick Launch zettings.

| Load file...

" Settings Orly ™ Settings and Objects

xgan-::el |? Help |

3 Complete the Data Source/Target Properties dialog as required and then click OK to exit the editor.



The following describes options that are not self-explanatory:

General tab

« General Properties

« Name: The name you give it here will be displayed as a data source in the physical model.

« Type: Select the source/target type. This setting affects available options in the Connectivity group. For
example, select Relational for a DBMS such as MySQL.

* Host, Server/Service, Port: For connecting to an external DBMS. For an existing ER/Studio physical model,

« Connectivity Properties

leave blank.

« DBMS Type, Version, Location/Path, File Type, Encoding: These settings depend on the Type selected

abo

Vve.

Model Usage tab

This is a read-only display of the source or target defined on the General tab. Ensure that it matches your
intentions.

Create a Data Lineage and Transformation Visualization

1

3 To obtain the Transformation insertion tool, right-click an empty space in the Data Lineage window and then click

To create the data source or transformation input tables, expand Data Sources > Local Models > Logical >

Entities and then drag and drop the Broker and Investment tables onto the Data Lineage window.

To create the data target or transformation output tables, navigate to Data Sources > Local Models > GIM_DW
and then drag and drop the Broker table onto the Data Lineage window.

JFGIMDE_80_testing.DM1 - Data Flow Model View: Broker *
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4

To insert the transformation, click in the Data Lineage window between the source and target data sources and
then right-click to drop the Transformation Insertion tool.

Right-click an empty space of the Data Lineage window and then click Insert Data Stream.

TIP:
the tool you need.

Transformation and Data Flow tools are also available on the toolbar. Mouse over the tools to find

Click an input and then click the transformation object. Repeat as many times as necessary to link all the inputs
to the transformation object.

Click the transformation object and then click an output.

GIMDE_80_testing - Data Flow Model ¥iew: Broker * ]
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If the Inputs and Outputs do not display in the diagram as they do in the illustration above, click

View > Diagram and Object Display Options > Transformation and then click Input and Output

Columns.

transformation to open the Transformation Editor.

8 To define which columns should be used in the transformation and any transformation rules, double-click the new



9 Complete the Transformation Editor as required and then click OK to exit the editor.
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You are done! Now you can more easily share your ideas with your colleagues!

TIP:  Once the Data Flow is created, you can double-click it to change its name, or double click a
transformation or component to change its properties.

The following describes options in the Transformation Editor that are not self-explanatory:
Columns tab
« Inputs: Click the ellipsis (...) button to choose the source data to be transformed in this task.
« Outputs: Click the ellipsis (...) button to choose the outputs resulting from the transformation.
Definition tab
« Business: Describe the transformation for your audience.

« Code: Enter the code that will perform the transformation, such as a SELECT statement, of a VB Basic or Java
Script function or procedure.

Rules tab
These are the rules from the Data Movement Rules node of the Data Lineage Explorer.

NOTE: You can delete or edit an input or output column by double-clicking the transformation in the Data
Lineage window, clicking the ellipsis in the Transformation Editor, and then deselecting the
column you want to remove.



Attachments tab

Lets you bind an external piece of information, or attachment to the transformation. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list, depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be
applied to the default before they will display on this tab.



Diagram Navigation and Aesthetics

To assist with the creation of presentation-quality diagrams that are easy to navigate and are aesthetically pleasing,
ER/Studio offers progressive diagram Auto Layout and Navigation utilities that also help you to clean up complex
diagrams. Modelers should spend time solving complex database or business data model problems, not forcing boxes
and lines to look a certain way.

Diagram Navigation

To demonstrate some of ER/Studio’s layout and navigation utilities, we will import a sample SQL script provided with
ER/Studio.

1 Close any files you have open.

2 Click File > New.

==X ER/Studio

Create a New Model

Eﬁ) " Draw a new data model

@ " Reverse-engineer an existing database

% * |mport Madel From: | ER File ﬂ

ER= File
Extermal Metadata

d’ Import .
X Cancel
T  Heb




3 Select Import Model From: and then in the import list, click SQL File.

NOTE: The ERX File choice enables you to import Computer Associates ERwin 3.5.2 ERX files. The
From External Metadata choice launches the MetaWizard to import from alternative sources.

The Import Database SQL File dialog appears:

22 Import Database SQL File

} Select a Databaze SOL File
|E:'\D|:u:uments and Settingzh] acquieApplication D at @

} Select the target databaze platform

IBK DB2 DB far O

} ER/Studio can infer Beferential [ntearity when none iz declared
in the zcnpt. Chicking the options below will create relationshipz
bebween entities in your diagram.

[ Infer Prirmary Keys

| Infer Foreign Keys from Indexes

[ Infer Fareign Keys from Mames

[ Infer Domains [Create a Domain far each Column)

} Select the |nitial Lavaut Optian

@ Circular Orthogonal @ Tree
@ Hierarchical ﬂ Symmetric

YWwhat twpe of Physical Model iz this?
{* Relational
" Dimensional

Select the Logical View Parzer Option
[ Usze Physical Parser

4 To the right of Select a Database SQL File click the folder icon, click IBM DB2 0S390.SQL, and then click
Open.

The full path to this file is:

For Windows XP:
C:\Documents and Settings\<user>\Application Data\Embarcadero\ERStudio\SQLCode

For Windows Vista:
C:\Users\<user>\AppData\Roaming\Embarcadero\ERStudio\SQLCodeSample

5 Inthe Select the target database platform list, click IBM DB2 UDB for OS /390 9.x.



6 Click OK.

Finished! Once the SQL Script is finished importing (as depicted below) the following items will assist you in
leveraging a variety of Auto Layout and Navigation Features.

Layout and Alignment Toolbar Zoom Window

Data Model Explorer Overview Window
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« Layout and Alignment Toolbar: Use any of the four Auto Layout styles to change the layout of the diagram with
the click of a button. The auto layout styles are all entirely customizable. You can also customize the diagram
layout via the Layout Properties pages that can be launched by clicking Layout > Layout Properties.

« Data Model Explorer: Click on any object in the Data Model Explorer and it will automatically be selected in the
diagram and focused in both the Zoom and Overview windows.

¢ Overview Window: Use this window as a thumbnail of your model to pan the entire model or zoom in and out. It
can also pan and zoom the diagram if grabbed or sized. If the Overview Window is not already visible, press the
F9 key to activate it.

e Zoom Window: Use this window as a magnifying glass to enlarge any diagram objects under your mouse cursor.
You can also press SHIFT+F8 to freeze the zoom window to keep a single object frozen while you continue to
pan around the diagram. If the Zoom Window is not already visible, press F8 to activate it.



Diagram Aesthetics

One of the tremendous benefits of building data models is the wide range of audiences that can realize value from
them. Part of this relies on what information is displayed on the diagram. Depending on the audience you may want to
limit or expand what is displayed. For example, developers may benefit from looking at a model that displays data
type, null option, and unique and non-unique index information, while business analysts may just need the entity name
and the definition. ER/Studio offers many display properties that can be customized exactly for this purpose.

Continuing with the previous section, we will use the DB2 model that was built to demonstrate some of the ways to
customize the appearance of the model.

We will use the Diagram and Object Display Options dialog on the Diagram toolbar to customize the view of the logical
and physical models.

NOTE: You can use the Colors & Fonts tool to further customize the look and feel of each model.

Setting the Logical Model Display

1 Select the logical model and then on the Diagram Toolbar, click the Diagram and Objects Display Options
tool.

Diagram Toolbar

[l dy & & QW & | AR A

|Diagram and Object Display Optinnsl

2 Inthe Diagram And Object Display Options dialog, click the Entity tab, and then in the Display Level area,
select Entity.

3 Click OK.

=

| RGST_CLNT

|
|
|
|
|
|
|
|
K‘ | FRIWK_ACTUL

FHCL_TRANS I

NOTE: Only entity names are displayed for each entity. You may also want to re-layout the diagram since
the entity sizes have changed.




Setting the Physical Model Display

1 Select the physical model and then on the Diagram toolbar, click the Diagram and Objects Display Options

2

tool.

TIP:

Mouse over the icons on the toolbar to see the name of each tool.

In the Diagram And Object Display Options dialog, click the Table tab.

Diagram And Object Display Options
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[ Indexes

[ Attachments
-

[ Colurn Bitmaps

Drawing Shapes

Security Dbjects ] Apply To l
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[v Triggers
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[ Drata Security
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|x LCancel |
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4

In the Display Level area, select Physical Attribute Ordering.

In the Available Options are, select the specific properties you want to display.



5 Click OK.

The model should now display more details for the physical model, as seen below.

DB2OVINSS. EDE_SPEC (EDE_SPEC)

FSPEC_ID (FK)  CHAR[T1)  NOT NULL [AK1:2)
LACTERY_ID SMALLINT  WOT MULL

“#ABER CHAR(E) MOT NULL

“#LAST_UFDT_DT TIMESTAMPMOT MULL

WP EYS_MAME CHAR{22) MULL {AK1:1)
LFSHORT_MAME  CHAR(ZZ) MULL

W LONG_MAME  CHAR{120) MULL

B FRTOAIK

T o —!_ WERTO2EIK [AKT) :':::::::

| - _—IT, —L_ __L:________I______: ____________

DB20V/N33.EDB_SPEC_XREF (EDB_SPEC_XREF) H- - G==0B20UN93.EDE_FRMUIK_SPEC (EDE_FRMWK_
~ =) -~ e L LA A -
& ASSN_TYFE [FK) SMALLINT NOT MULL {IE1:2) ! % EFECID P CHAR[11) Wz
& STRT_DT (FK) DATE NOT NULL (IE1:2) | W DATA HORHS URRCHAR WO
R SPEC 1D LEFT (PKWFK CHARM NOT MULL {IE1:1 | e SEQ_NUM SMALLINT NOT I
B SFEC_ID_RIGHT (FKYFK) CHAR(11)  MOT MULL (IE1:4 : « LAST_UFDT TIMESTAMF NOT |
@ LAST_UFDT_OT TIMESTAMPHNOT MULL : S STRT_OT DATE WOT I
% END_DT DATE NCT NULL | “#END_DT DATE HOT
< MIN_CROML SMALLINT MOT MULL ! W CREAT_DT TIMESTAME  NET!
I . -
& MAX_CRDML SMALLINT MOT MULL | 0T AL (A
B FRTOTALL |
& FRTOTEIX (IE1) :
L— |

|

NOTE: Since the sizes of the objects changed, you may want to change the model layout using one of
the ER/Studio advanced layout engines. You can also customize the default display properties for
new models by clicking Tools > Options, and then selecting the desired options on the Display
tab.

Conclusion
In this session, you have learned how to:

« Import an SQL file and allow ER/Studio to automatically create a diagram.

« Use a variety of auto layout and navigation tools to enhance the aesthetic experience of the diagram and to
improve the data model navigability.

« Customize the display of both the logical and physical models.



Importing and Exporting Metadata

The MetaWizard allows you to import and export metadata from a wide spectrum of sources and targets. Various
metadata formats are supported that provide connectivity to environments such as XML Schemas and DTDs, OMG's
CWM-XMI, and business intelligence repositories such as Business Objects, Cognos, DB2 Cube Views, and various
UML and data modeling tools.

NOTE: The MetaWizard is a separately licensed module. For evaluation purposes the Import Bridge is
enabled during the install, but the Export Bridge is not. Contact Sales@Embarcadero.com to
enable the Export Bridge for evaluation.

Importing Metadata

Let's walk through an example of how to build a model from a specific metadata source. In this case we will use OMG
CWM XMI 1.1, one of the popular formats used by various modeling tools.

1 Close any open files.

2 To launch the Import MetaWizard, click File > Import File > From External Metadata.

cl s SR — 20
Close s

Save Ctrl+5
Physical * r Modell - Logical Model Vie

E File | Edit View Insert Model Format Layout Database Tools F
f 1o ew. N G [ 3 e cga By | 0%
HIT Open... Ctrl=0

.08

Save As..
@ Diagram Properties...
ﬁ Import Data Dictionary... ‘{
| Import File P|| From External Metadata...
".;é Export Image... From ERX File...
Export File L4 From SQL File...

3 To select the external metadata, in the Type list, click OMG CWM 1.xXMI 1.x.

4 Nextto From, click the folder icon and browse to the Sample Models directory, select OrangeMart (XMI).xml,
and then click Open.

The sample models are located at:

¢ Windows XP:
C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudio_X.X\Sample Models


mailto:Sales@Embarcadero.com

e Windows Vista:
C:\ProgramData\Embarcadero\ERStudio_X.X\Sample Models

Each environment has specific versions that determine how the metadata is translated. When importing models
or metadata from another source of your own, ensure you select the appropriate platform and version.

] Import External Metadata - Step 1 of 3 |

"y P Thiz wizard allows pou to import metadata from a wariety of external
AFLEL B gources to create an ERAStudio data maodel.

Select External Metadata

Type: |OMG Chwh 1.0 XM 1. |

Fram: |E:'xDDcuments and Settingzhall Usershdpplication DatahEmbarcaderosER

E Ayvailable Options

Walidate Source: Basic Congistency Check j

ﬁ M ame Yalue
Target Taal Auta Detect
Ao Comrect Trie
Top Package Logical Wiew
[rpart LUJID 2

True

Drata model Table... Physical
Dimengional mode... Dizabled

Specify which tool was uzed to generate the model vou want toimpart. This parameter allovws H
bridge to fine tune the its behavior to match the way the source tool zaved the model,

Btn Detect' - The bridge will auto-detect which tool generated the file.

|x Cancel | | ? Help |




5 Click Next, click through page 2, and then on page 3 click Finish

By default, the MetaWizard performs a basic consistency check of the file imported and reports any

inconsistencies on page 2 of the wizard.

B4 MetaWizard (Import External Metadata) Step 3 of 3

<INFOx1
<INFO1
<INFO1
Ij <INFO:1
<INFOx1

<INFO1

<INFO1

il

L

|x Cancel | | ? Help |

i) <INFO315pstemn Hardware: Intel[R) Core{TH12 Duo CPU T7250 @ 2.00GHz at
<IMFO =15 ystem Software: Microsoft Windows <P 5.1 286 with Office; 12.0
<IMFOz15ystem encoding: Westerm European [windows-1252]

<IMFOzImpaort tool: Object kM anagement Group Common Warehouze kMetamodel [0
<IMFO = Nmport interface: [Metadata Management] Metadata Repository, Data Ston
<IMFO > lmport bridge: 'OmgCwrreami' 6.0.7 - Jul 14 2002 15:03:54

File = C:A\Documentz and Settingzshall Uzershdpplication DatasE mbarcar
Target Toaol = Auto Detect

Auto Correct = True

Top Package = Logical Yiew

[mport UJID s = True

Drata model Tables design level = Physical

Dimenzional model reverse engineenng = Dizabled

<STATUS:NI2E:2) Loading the CWMRDE:Catalog 'Model

<STATUS139:2] Loading the CwkMADE:Schema 'unnamed_E
<STATUS:IN03:2) Loading the CWMBDE: S chema ‘unnamed_20°
<STATUS:INEV:2] Loading the CwHRDE:Schema 'DEMO

<IMNFO1The model has been succeszsfully imported <2008-08-20 16:29.52>
<IMFOzI5tarting bazic consistency check, [model validation] < 2008-028-20 16:25:52

T AT, e [ C [ERTTEY 8 ]

m Save to File..

;

The MetaWizard builds a logical and physical model based on the source metadata.

6 Click File > Save and then specify a filename.

Please keep this model for use in the Dimensional Modeling session.

NOTE: In some cases the layout will not import from the source metadata. If this happens you can use
one of ER/Studio’s advanced layout engines as described in a previous section.



Exporting Metadata

ER/Studio can export metadata in the same formats from which it can import. Metadata can be exported from the
entire diagram by clicking File > Export or by right-clicking any of the submodels or the main model.

Let’'s walk through an example of exporting. We’'ll use the model that was built from the XMl file. In this example we
want to export the diagram metadata to Business Objects so you can use the metadata to generate reports.

NOTE: You need a separate license for the Export Bridge for use in this session.

1 Click File > Export File > Export Diagram Metadata.

B Export Diagram Metadata - Page 1 of 3

Thiz wizard allows pou to export ER /Studio model metadata to a variety
of targets. Pleaze nate that the expaorted model will uze the physical
hares.

Select Output Type

Type: |Eusiness Objects Data Integrator B.x to 11,2 [via Cwhd =M1 j .I

Save Ta |I::"~D ocuments and Settingsh) acquiehdpplication Datah\EmbarcadercsER @

E A ailable Options

M ame Walue | ”
Ciab werzion Ci't 1.0
Schema mapping  Uze Package: names
Default Schema n...
D E Ewport Index of Key True
UID= Falze

smlnz: Ciut'h org.omg. k1.0
wrnlng: Cw' kR DB arg. omg. w1 .0/F elational
sminz CwMOLAP  org.omg, Cwibd1.0/0LaF

wrnling: A T F arg. amd. Cw 1.0/ T ranzformation W

Specifies the target model; ~

'UML" - Export the logizal model anly ag an instance of the metamodel for the Cwid Object resource
package [e.q. an entity/table iz an instance of Cwkd:Clasz with the logical/buzsiness name as
name). Mote: the CWwh Object Metamodel a subszet of the ML Class Diagram Metamodel,

(Xien) [7

This launches the Export Bridge.

2 To select the output type:

« Inthe Type list, click Business Objects Data Integrator.

* Next to Save To, click the folder icon and browse to a file location for the XML file, enter a filename, and then
click OK.



3 Click Next.
This will run a check on the exported metadata.
4  Click Finish.

This will save the file to the specified location. We will use this file in the next session.

Conclusion
In this session we have explored the metadata management capabilities of ER/Studio, specifically how to:

« Import metadata from a wide range of sources to produce a logical and physical model.

« Export metadata to an equally wide range of formats so that metadata can be shared with other groups within
your organization.



Dimensional Modeling

ER/Studio allows you to model dimensional structures such as star and snowflake schemas that can be leveraged for
data warehouses, data marts, and OLAP. ER/Studio’s dimensional notation helps you to visualize and build these
complex models by using icons for the various table types, and enforcing rules specific to dimensional modeling
standards. This session will help you construct a dimensional model and walk you through some of the aspects
inherent to dimensional notation.

Overview of Dimensional Notation

First, let's create a dimensional model. There are a number of ways you can designate a model as dimensional.

Designating a Model as Dimensional
If you are creating a new model you can designate the model as dimensional in one of the following dialogs:

¢ On Page 5 of the Reverse Engineer Wizard.

Click File > New, select Reverse-engineer en existing database. Login to the database, click Next to page 5,
and then in answer to What type of Physical Model is this?, select Dimensional.

* Inthe SQL Import dialog.

Click File > Import file from SQL file, and then in answer to What type of Physical Model is this?, select
Dimensional.

¢ On Page 1 of the Generate Physical Model Wizard.

Right-click the Logical model, select Generate Physical Model, and then in answer to What type of Physical
Model is this, select Dimensional

If you have an existing physical model, you can change the type in Model > Model Options. For the purpose of this
session, we will use the model created from the XMl file in the Import Metadata session. If you skipped that session,
go back to Importing and Exporting Metadata and walk through the Import Metadata section.

Since we already have an existing model, we will just change the notation.

1 Click File > Open, navigate to the physical model you saved in Importing Metadata, and then click Open.

2 Right-click the physical model and then click Model Options.



3 Inthe Model Notation area, select Dimensional.

# Physical Model Options
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4 Click OK.

Now that we have changed the model notation, we can use an auto-layout tool to rearrange the tables.

5 On the Layout and Alignment Toolbar, click the Hierarchical Layout tool.

Layout and Alignment Toolbar

SEE 2 60 ) &5

IHierarchicaI Layout

Notice that the look and feel of the tables has changed and each table has a specific icon depending on the type

of table ER/Studio determines it is. ER/Studio analyzes the foreign key chains of the model and uses

dimensional modeling rules to decipher fact tables of dimension, snowflake, and or other dimensional tables.




Working in a Dimensional Model

The illustration below gives an overview of dimensional notation.

Icons in the

Data Model Explojé

correspond to
table typein
the model. The
same icon will
appear in the
upper-left
corner of each
table.
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Notice in the previous picture that ER/Studio determined that Product_Patent is a fact table, Approved_Product is a
dimension table and the parent tables of Approved_Product are snowflakes. This is because Product_Patent has no
child tables, Approved_Product is a parent of Product_Patent, and the parent tables of Approved_Product are two
relationships away from the perceived fact table. Analyzing this a little further, it looks like Approved_Product is
actually the fact table, Product_Patent could be a bridge to another fact table, and the parents of Approved_Product
are actually qualifiers of Approved_Product or dimensions. The table type can be changed to override how ER/Studio
originally interpreted the table.

Let's walk through an example. With the physical model from the previous example selected, let’s edit the
Approved_Product table.

1 To open the Table Editor, double-click the Approved_Product table.
2 Click the Dimensional tab.
3 Inthe Dimensional Model Table Type list, click Fact.

TIP: There are other dimensional model type tables such as Bridge and Hierarchy Navigation. Click
the list to see the other table types.

8 Table Editor

Entity Hame: |.ﬂ-.pprcuved_F'deuct Table Hame: |.ﬂ-.pprcuved_F'deuct Owner: |dbo -
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Dimenszional Model Table Type Table Type

| Fact j | [Mone] ﬂ

[v Owermide Autornatic D esignation

[ Run Automatic Table Type |dentification
[T hiz aption will run after exiting the editar. 1t will affect all tables that are up ar dawn stream of this table. ]

|J ak. ||XEanceI||? Hel|:||

4 Ensure the Override Automatic Designation option is selected.
5 Select the Run Automatic Table Type Identification option.
6 Click OK.

TIP:  You can change the designation of a table without affecting related tables by deselecting the Run
Automatic Table Type Identification option.



The result is that Approved_Product becomes the Fact table. The parent tables of Approved_Product will all
become dimension tables and the Product_Patent table will be designated as undefined. As another exercise,
select another dimensional table and change the type of dimension depending on the desired data refresh rate
as in the following illustration.

dio - [Repo Server: S % % [Logged In As: Admin] - [OrangeMart (XMI).dm1 - Phy... 2 |[B
Edit View Insert Model Format Layout Database Tools Repository  Macro Shortcuts Window  He

HS/ ¢ OO PNGo 2o -/0/Q K

QAW NGEI o) FEMensEE s chhnnb0e

gebd art [=k1].dm1 Dimensional Tables

agical
I kain Model / * \

I Main Model
1 Tables [22]

Active_lngredient
Applicant
Applicant_Full_Hame
Application_Mbr
Approval
Approved_Product
Competitor
Dozage_Form
Escluzivity_Code
Encluzivity_Status

F Active_Ingredient_ID (FKD
& Active_Ingredients

FRx_Status 1D (FK)
‘ RX_Status

F Route_of_Admin_ID (FK)
‘% Route_of_Admin

Dimension Type: Fixed

Dimension Type: Fixed Dimension Type: Type 1

AN Z

< —~

\\ //
Dimensional type set to Type 1.
Fixed is the default.

P Approved_Produ
% fpproval_ID (FE)

% Trade_Mame_ID (FK) Now designated

as a Fact table

% Application_Hbr_ID (FK)
% Praduct_Nbr_ID (FI)
% fictive_Ingredient_|D (FK)

Manually set to a Bridge table

Foute_of_

Fe_Status

Strength % Dozage_Farm_ID (FK)

Therapeutic_Edviv_Cor % Route_of_Admin_ID (FI)

Tiade Mame  \ % Rx_Status_ID (FI)
Enlumnsﬁﬂ?] EliTherapeutic_Equixr_Eu:-de_lD [FKD T Product_Patent_ID (PL)
Indexes [65] \;‘P LGl = Approved_Product (D (FED
Foreign Keys [21] b PR ERED b P atent_Status_ID (FIS)
oh gn hey 4 ls_Ref_Listed N

apes -

. Patent_Expiration

Icons in the Data Model Explorer have
changed to reflect the dimensional
model designation.

Bo. |MHD.. (B8 QR | |< e 2




Automating Tasks

ER/Studio is equipped with a highly-documented automation interface. The automation interface is driven by the Sax
Basic language (a derivative of the Visual Basic for Applications language) and serves many purposes, fundamentally
enabling you to customize ER/Studio through an application interface

There are two main reasons to employ the Automation Interface:

« Automate Routine Tasks: Automate tedious, routine modeling tasks or customize ER/Studio to enforce
modeling practices in your organization. For example, you can write a macro that will automatically colorize child
tables that contain propagated foreign keys. Or, you can write a macro to automatically insert a specific name and
primary key into new entities as they are created.

¢ Collaborate with Other Applications: Your ER/Studio models contain valuable metadata that you can access
from applications such as Microsoft Excel, Access, and Outlook. Using ER/Studio's automation interface, you can
collaborate with any external application that has an exposed API or its own automation interface.

In this walk-through, we will demonstrate an example of how to leverage ER/Studio’s automation interface to
dramatically increase modeler productivity. You will not be writing any Sax Basic (VBA) code in this walk-through. You
will be running a macro that is included with the product. You can write your own macros using the Sax Basic
Integrated Development Environment included in ER/Studio.

Creating Macros

Using the Sax Basic integrated development environment, you can expand upon the functionality offered in the
sample macros provided or create macros to automate model development and maintenance.

To access the Sax Basic development environment, click Tools > Basic Macro Editor.

L

ERfStudio Macro Editor - Untitled
= ddSE B T o I

Object: |[E eneral] j Froc: |Main

1 Sub Main
Dim clrBack A=
1 Attachment -
End Sub [#1 Attachments
[#1 AttachmentT ppe
1 AttachmentT ypes
21 Attribube0bi
B2 Altributes
Boolean
#1 BoundAttachment
1 BoundAttachments
[#1 BoundObject
[#1 BoundObjects w

TIP:  The automatic appearance of lists as you type, allows you to select and insert ER/Studio
Automation Objects. After inserting an object, you can get information about the object by
selecting it and then clicking the Browse Obiject tool on the application toolbar.



Using Macros to Automate the Modeling Process

You can use Visual Basic macros to speed development and enforce the re-use of metadata.

In this example, we will be leveraging macros provided with the product to demonstrate powerful automated modeling
activities you can benefit from.

1 Close all open diagrams.
2 Click File > New and then select Draw a New Data Model.

3 Inthe Data Model Explorer, click the Macros tab.

ﬁ Macros

[l]-rj Sample Macroz

R

ERSBazicHandlers
ERSDeleteH andlers
ERSUpdateH andlers

4 Inthe Modeling Productivity Macros, locate the Auto-Create Data Dictionary macro.

5 Right-click the Auto Create Data Dictionary macro and then click Run Macro.
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Domain Bindings Delete Macro

Example macro- | [
Get Related Tabl
ImportD atalriction
Index Maming i
Mame Foreign Col (i I[

Marne Primary Canstraints | IE& Trade Ham

Run Macro |

Add/Remove to Shortcuts 4 I

Running this macro will create a set of Domains in the Data Dictionary which the next macro we run will
leverage. For more information on Domains, see Logical and Physical Modeling.

6 With the set of Domains now ready, create an entity on the Data Model Window.

For a refresher on creating an entity, see Using Data Dictionary Domains to Populate New Entity.

7 Name the entity, Person.



1 Model2 - Logical Model View *

Bl DATAMODEL
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=H=5 Main Model
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Relationzhipz
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Rolez
Shapes

You do not need to implement any attributes for the Person entity at this time.

8 Select the Person entity and in the Modeling Productivity Macros folder, right-click Add Base Attributes To
Person Entity and then click Run Macro.

NOTE: The macro automatically created all of the attributes for Person entity for you!

# Person ID

& First Name
o QLast Mame
“# Create Date
& Created By
@ Wodified Date
& Modified By

You have just:

« Saved the effort of manually typing these standard attributes into selected entities that require them.
« Bound all the new attributes to Domains for proper standard enforcement.

You can customize these macros in any way you choose! This example merely stresses how to increase the
productivity of modelers to automate repetitive tasks such as ensuring entities conform to the same standard set
of attributes. Feel free to explore the other macros we've included for you as well to see how they can increase
your productivity.

Conclusion
In this session, you have learned how to:

« Access the Basic Macro Editor to create your own macros from scratch.

« Select the Macro tab of the Explorer Browser and launch sample macros included with ER/Studio to help
increase modeler productivity.

For more assistance on the Automation Interface, refer to ER/Studio’s Help and review the section on Automation
Interface.



Collaborative Modeling

ER/Studio Enterprise includes a server-side component to ER/Studio designed to distribute work across modeling
team members in a safe and controlled way, facilitating a real-time collaborative modeling environment and increasing
productivity for teams. The solution implements utilities and features that enable concurrent modeling, version
management for models and model objects, establishment of continually reusable data elements, and more. The
secure, scalable environment is fully integrated with the current, natural workflow in ER/Studio.

This portion of the guide is intended to give a brief overview and walkthrough of ER/Studio Enterprise. It will start with
the install and configuration of the Repository and continue on to include inserting a diagram into the Repository,
working with the diagram in the Repository, versioning the diagram, sharing and reusing objects across diagrams and
finally applying security to your diagrams. It is intended as an introduction of the Repository. For more information
please refer to the Repository section of ER/Studio’s Help or contact Technical Support at
Support@Embarcadero.com or call (415) 834 3131 x2.

Getting Started with ER/Studio Enterprise

Downloading and Installing the Repository

To evaluate the collaborative modeling benefits of ER/Studio Enterprise, you will need to download and install a
separate installation executable. You can download the Repository installation executable from the Embarcadero Web
site at:

www.embarcadero.com/downloads/download.html

You need to download the ER/Studio Enterprise zip file or the ER/Studio Standard Upgrade to Enterprise executable.

ER/Studio Enterprise requires installation on an RDBMS of your choice: IBM DB2 UDB, Oracle, Sybase ASE or
Microsoft SQL Server. Two components will be installed: the server and the database. The server machine requires
the chosen database client utilities to be installed in advance so that the server can initially build and subsequently
connect to and communicate with the database thereafter.

« For comprehensive installation instructions, including Repository server requirements and database sizing
projections, please refer to the Install Guide.

« For information regarding ER/Studio Architecture, see the User Guide.
Installation guides are available on Embarcadero.com:

www.embarcadero.com/resources/documentation.html

Configuring ER/Studio to Connect to the Repository

1 Install the server component.

2 Ifthe Repository menu is not visible on ER/Studio’s Main menu, select Tools > Options > Repository Options.


mailto:Support@Embarcadero.com
http://www.embarcadero.com/downloads/download.html
http://www.embarcadero.com/resources/documentation.html

3 To configure ER/Studio to connect to the Repository, click Repository > Options.

4

»= Repository Options

|General ﬂ |qf ak | |x Cancel | | % Help |

R epository Oplions

Server Machine: |H EPODBSWYR j Fefrezh

Active File Directorny: |E:HD ocuments and SettingsiUzerMy Docum [

General l

Check Out Policy |

[ Hide Repository Status lcons Diagram Mame Dizplay Farmat:

v Show Repository Status Dialog ¢ Diagram Mame [Filenarne. dr]
o E
W View SOL Alerts Filename. dm

[+ Enable Repo Events Palling

FRepao Events Polling Interval: |30 = zeconds

=

In the Repository Options area, click Refresh and ER/Studio will automatically detect Repositories already
installed on your network. You can also manually enter the Repository Server machine name in the specified

field.

NOTE:

If the Repository list on the ER/Studio main menu is unavailable, check to see if you have a valid
license. You can check this by clicking Help > About ER/Studio. This will display the names of the
modules you have installed. If you do not see RepoClient or it is unavailable then you can request
an evaluation extension to trial the software for 14 days. After that a permanent license is
required.

In the Active File Directory, enter the directory path where the local ER/Studio .DM1 diagram files will be saved.

ER/Studio manages a local working copy of the data model and submits changes you have made to this file to
the Repository or, conversely, updates changes others have made in the Repository in order to update your
locally managed file. All of this you control through the sophisticated Review Changes user interface.

NOTE:

The Active File directory should be on your local machine and not a network location. You will
need read/write privileges on this path.



Connecting to the Repository

To connect to the Repository, click Repository > Log In.

Eepository | Macro Shortcuts  Window  Help

P

Diagrams g *‘r_;.

[Drata Dictionary 4
| Q) aal i

b=

| View: OrangeMart pMI = |

e | (iR

Eeleases 4

| D N

-'_| Log In... \ |

P Y

Ol

=| Options...

The login dialog will prompt you for a user ID and password. The default login after installation is Admin and the
default password is Admin. Both are case-sensitive.

Once you are connected to the Repository, you are ready to add diagrams.

Working with Diagrams in the Repository

This section contains the following topics:

Adding a Diagram into the Repository

Repository Status lcons

Organizing Diagrams Through the Repository Project Center

Checking Out Diagrams vs. Checking Out Objects

Checking Out at the Object Level
Checking Out at the Diagram Level
Setting a Named Release

Adding a Diagram into the Repository

1

2

Click File > Open.
Browse to the Sample Models folder, select Orders.dm1, and then click OK.
The Sample Models folder is located at:

* Windows XP:
C:\Documents and Settings\All Users\Application
Data\Embarcadero\ERStudio_X.X\Sample Models

¢ Windows Vista:
C:\ProgramData\Embarcadero\ERStudio_X.X\Sample Models



3 Once the diagram is opened, select Repository > Diagrams > Add Diagram.

Eepository | Macro Shortcuts  Window  Help

h Project Center

| Diagrams I*| %] Add Diagram...
Data Dictionary bk Change Diagram Filename...
Beleases M=
= (3 Get from Repository...
Security 4

-'J Log Cut

= options...

Rennsitore Pronerties...

4 Fill in the appropriate information in the Add Diagram to ER/Studio Repository dialog.

4 Add Diagram to ER/Studio Repository

Select Diagram to Add Diagram Properties

* Add Currently Open Diagram Diagram M ame
" Add Mew Blank Diagram |Em|:uar-:au:len:| Salez Order Processing

(™ Add Existing Diagram Save fs File Name
\C:ADocuments and 5 ettingsiUser\My DocumentshERSHu |Orders. dm1
Author

|S tephen Wong

Fepository Binding Options

Add to Repozitor Project:

Company
NOME -
| [ ! J |E mbarcadero Technaologies, he.

Bind Exizting Enterprize D ata Dictionaries: .
Wergion

[ Care Components |1 .0

Coppright Wear  Copyright Owner
|2EIEI4-2EIEIE Embarcadero Technologies, Inc.

Dezcription

[ Promate Local Data Dictionary T o Enterprise
Drata Dictionary M ame

| e

|f ] | |x Cancel | |? Help

5 Optional. To assign the diagram to a project, below Add to Repository Project, select a project from the list.

6 Optional. To bind an enterprise data dictionary to the diagram, in the Bind Existing Enterprise Data
Dictionaries area, select a data dictionary.



7 Click OK.
This will start the process of adding a diagram.

Once the Add Diagram operation is finished, you will see Repository status icons appear on the model objects
(explained in Repository Status Icons). Now added, the diagram is available for any users who can connect to
your Repository and who have been granted authorization.

Repository Status Icons

Once the Orders diagram has been added to the Repository, Status Icons will appear in the Data Model Explorer on
the diagram. These are the lock and monitor icons.

¢ Lock icons: Indicates the real-time status of object metadata in the Repository, such as attributes, definitions,
and storage properties.

« Monitor icons: Indicates the real-time status of display metadata, such as object color and font.



These icons indicate the check out status of the diagram and the objects in the models. Depending on what type of
check out (exclusive vs. non-exclusive) and who has checked out the object (you locally vs. others remotely), the
status icons will change to provide a real-time status of exactly who is doing what, and when, to a diagram object. A
matrix of these icons is available in Help.

RiStudio - [Repo Server: S - Smsas [Logged In As: Admin] - [Orders.dm1 - Logical Model
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Organizing Diagrams Through the Repository Project Center

Projects offer a way to organize your diagrams into groups. This organization will become evident when you or anyone
else selects Get Diagram to view the contents of the Repository while accessing a diagram. Projects are used to
group ER/Studio diagrams and enterprise data dictionaries managed in the Repository. Projects allow for security to
be enforced at the project level to all diagrams managed in the Repository. For example, you can apply No Access
permissions to all diagrams in a project for a specific user or role. You can organize projects by subject matter, such as
Sales Diagrams and HR Diagrams, or you can organize projects by the groups who will be working on the diagrams in
the project, such as DBA Diagrams and DA DiagramsProjects can be added, edited and deleted by clicking
Repository > Project Center.



Let’s create a project for the newly added Orders data model.

1 Click Repository > Project Center and then click New.

#* Repository Project Center

} YWwelcome To the ER/Studio Reposzitary Project Centerl Uze thiz interface to manage repositon projects.

= g Projects M e |
ﬁ Samples
?' System Models Diagrams In Project
i ‘ork InProgress Hyvailable Diagrams Selected Diagrams

12

Project Description

KKl

|q‘f ok | |x Ear‘u:e|| |? Help |

2 Inthe Name field, enter Sales Order Diagrams.

3 Inthe Description field, type a description for the project and then click OK.

4 Inthe Repository Project Center dialog, click Orders.dml, and then click the right arrow to move
Orders.dml to Selected Diagrams
5 Click OK.

TIP: The Repository supports nested projects. You can create a nested project under the Sales Order
Diagrams project by selecting it and then clicking New. The new project will appear under the
Sales Order Diagrams folder.

Checking Out Diagrams vs. Checking Out Objects

ER/Studio Enterprise’s management of diagrams is very similar to source code control systems you may use for
document or source code management. The difference is the degree to which ER/Studio can allow for object check
out and team collaboration. Each and every element in an ER/Studio diagram can be individually checked out; starting
from the entire diagram itself, down to individual elements, such as entities, managed in a diagram. There are two
check out modes that can be used depending on how you want to work on the diagrams, models, and model objects.

« Exclusive Checkout: This is a very restrictive and secure mode and will lock the objects that are checked out
within the Repository, so that no remote users can work on or more specifically check out the same object at the
same time.



¢ (Non-Exclusive) Checkout: Checking out an object ‘normally’ will allow multiple team members to work
collaboratively on the same elements at the same time. Objects can be simultaneously checked out by two or
more users concurrently. Any conflict will be resolved with the advanced Review Changes dialog.

Assume for the remainder of this session that Exclusive Lock Out is not required. Let’s look at a selection of Check
Out scenarios:

Checking Out at the Object Level

You can check out individual objects by right-clicking on the object in the explorer tree or double clicking on the object
in the diagram.

1 With the Orders model open, In the Data Model Explorer navigate to the Customer entity.
2 In the Data Model Window, double-click the Customer table.

You will be prompted you to check out the table.

Repository Check Out @

The Entity object iz not checked out. “Would pou like to check it
oLk o ?

[ Check out exclusively

| Check Out | Wigw kode Cancel Help




3 Click Check Out.

Once the editor opens, the status icon in the Data Model Explorer changes to indicate that you have checked out
the object locally to work on it.
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4 In the Entity Editor, rename the Last Name attribute to Last Name_Change and then click OK.



5 Inthe Data Model Explorer, right-click Customer and then from the shortcut menu, select Check in Object(s).

You will be prompted for check in comments and notes as well as to review the changes.

Repository Check In b_<|

Check In Comments:

[ Eeep Checked Dut

v FReview changes before check in

2k, | Cancel Help




6 Select Review changes before check in and then click OK.

You will be presented with a status of what has changed locally to provide you with an opportunity to report,
review, and possibly reject changes before check in.

¥ Review Changes and Resolve Conflicts

Pleaze review the changes you have made to vour locally managed diagram since vour last check out. Changes by other uzers to
aut which have resulted in conflicting decizions have alzo been provided for you ta regalve. For each categony, vou must decide if
muzt be submitted to Bepozitory or Bepositon's current data zhould remain and be refrezhed in your local diagram.
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7 When finished reviewing the changes, leave the change selected and then click OK.

The changes are saved to the Repository.

Checking Out at the Diagram Level

In some cases you may want access to the entire ER/Studio diagram. For example, you may need to derive a new
physical model from the logical. In this case you will need to check out the entire diagram.

1 With the Ordrers.dml diagram we used in the last session open, click Repository > Diagrams > Check Out
Diagram.

Repository Check Out

v Synchronize with latest Repositary diagram data

[ Check out exclusively

| ] 4 | Cancel Help |

Now let's generate a physical model.




2 Click Model > Generate Physical Model.

3 Enter a name for the physical model, choose the option to validate the model, and then click through the
Generate Physical Model Wizard, choosing other options you want.

TIP:  You can click Finish at any time in the wizard to accept the defaults.

4 Click Finish.
The Model Validation Wizard appears.
5 Inthe Model Validation Wizard, choose the options you want and then click Run Validation.

An entirely new physical model has been generated as seen in the Data Model Explorer.

=X ER/Studio - [Repo Server: Sss & e

@ File Edit View Insert Model Format
DS Q) N B G E
8 hBhuhg

lelly & Q @ @ & | e
B0 080> =T &
9 Orders.dml - Physical Model View: Physical ]

@ Embarcadero S ales Order Processing i

= Logical T
ﬁ-' Physical 7
EHE=3 Main Model G|

— Tables [40)
Colurnz [279]

6 Select Repository > Diagrams > Check In Diagram.

You will be prompted to enter check in comments and to review your changes.
7 Click OK.

Your new physical model is saved to the Repository.

Creating Different Versions of a Diagram

Up until this point we have only added a diagram into the Repository and made a few simple changes. The Repository
automatically tracks the changes you and team members are making to the diagram and associate a version with
each check in. These versions are located in the version history of each object, which is accessed by right-clicking the
object. Assume you want to set frozen baselines of the entire diagram as a mechanism to track milestone releases of
the diagram. You can do this by setting a Named Release. Named releases can be used to rollback the diagram back
to a previous state if the changes since the last release are not desired.



Setting a Named Release

1 With the model from the last session open, click Repository > Releases > Set Named Release.
You will be prompted to check in the diagram.

After checking in the diagram, the Set Named Release dialog appears.

X

B Set Named Release
Diagram:  Embarcadero Sales Order Processing

Drate: August 21, 2008

Release Mame:
Diagram Yersion 1.0 j

D escription:

"erzion 1.0 of the diagram.

( [n] 4 |x Eancel| | ? Help |

2 Inthe Release Name box, enter Orders — Version 1.

3 Inthe Description box, enter a description of the release:



4  Click OK.
The release is stored in the Repository.

TIP: Atany time you can access the named release by clicking Repository > Diagrams > Get from
Repository interface or Repository > Releases > Get Named Release.

Named releases are denoted with a camera icon:

&7 Get From Repository

Diagrams available in the A epozitary are listed below. A diagram node may be expanded to displ
releazes. To get a diagram, submodel, or named releaze, pleaze select it in the tree and click OF
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Options
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Too  |C:\Documents and SettingstUsersMy DocumentshE RS budicsd <




When you get a named release, the diagram will appear with a camera icon on the Data Model Explorer object
instead of traditional lock icons. Named release diagrams can be used to roll back and replace an existing
diagram or compared against the active diagram to individually roll back changes for certain objects you want.

@ Embarcadero Sales Order Processing. [
EHEE Logical g

5 Wain Model g3

Q3 Bill of Material: g
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For more information, see the “Rolling Back a Diagram to a Previous Version” section in the User Guide.

Applying Security to Diagrams through the Security Center

Now that diagrams such as Orders.dml, and others you will eventually add to the Repository, can be shared across
ateam, itis a good idea to control who is accessing them. ER/Studio Repository offers a simple to use security center
for all of these needs. The Security Center will enable you to create users, roles and apply them selectively to the
projects, diagrams, specific models within diagrams, and data dictionaries in the Repository. Let’s look at each more
closely.



Creating a Repository User

Before anyone else can log in and begin using ER/Studio Repository, you need to create instances of Users. To set up
individual users, follow these steps:

1 To launch the Security Center, click Repository > Security > Security Center.

2 Click the Manage Users tab and then click New.

% [R/Studio Repository Security Center

Welcome To the Repository Security Center!

IJze the tabbed interface to create and manage Users, Roles, and the assignments they hawve to
Repozitary Projects, Diagrams and Diagrarm objects.

Repository Securty  Manage Users l anage Roles l ED
User |Is Logged In?  |Items Chec... |User Description |
Admin ez ez Drefault Adminiztrator
JaneDatadn,.. |Mo Mo
JoeDatadre.. (Mo es
MaryDevelo... Mo Mo Default uzer
{SamlBA Mo Mo

Ilzer Management

Hew | | |

Administrator Uzer 'Force' Options

[Logmatir [oicsiobs

|& &pply | |-af ax | |x Eancel| |? Help

Enter user1 as the name for this sample user, and then type a password and a description for the new user.

4 On the Create Repository User dialog, click OK.

Now that you are back in the Security Center, note that userl has been created locally, but has not yet been
submitted to the Repository. You can see this is the case because there is a star next to the user.



5 To submit the changes to the Repository, click Apply.

@' [R/Studio Repository Security Center

Welcome To the Repository 5ecurity Centerl

IJze the tabbed interface to create and manage Users, Roles, and the assignments thep have to
R epozitary Projects, Diagrams and Diagram objects.

Repository Secuity  Manage Uszers l Manage Roles l ED
Uszer |ls Logged In? |Items Chec... |User Description |
Adrnin Yz Ve Drefault Adminiztratar
JaneDatadn... (Mo Mo
JoeDatadre... (Mo ez
MamDevelo... Mo Mo Default user
SamDBa Mo Mo
S

Ilzer Management

M e | Edit | Delete | Deactivate Reactivate

Adminigtrator User 'Force’ Options

Log Cut Lser Check In Uzer

|& Apply | |a( ar | |x Eancel| |? Help

TIP:  The Apply feature will allow you send incremental updates to the Repository while continuing to

work in the Security Center.

6 Keep the Security Center open for the next procedure.

With userl created and submitted to the Repository, let's move on to creating a role.

Creating a Role

Now that our user is built, we need to build a package of permissions for the user through the Repository’s Roles to

allow or prevent certain activities to be performed against objects in the Repository. We do this by creating a Role on
the Manage Roles tab of the Security Center.



In this example, let's assume we want to create a role for all data architects in the organization. Let's assume data
architects have permissions to create, manage, and modify logical models, but have no rights to modify physical
(DBMS-specific) models.

1 To launch the Security Center, click Repository > Security > Security Center.

2 Click the Manage Roles tab.

@' [R/Studio Repository Security Center

Welcome To the Repository Security Center!

|1ze the tabbed interface to create and manage Userz, Roles, and the aszignments they have to
R epozitary Projects, Diagrams and Diagram objects.

Repazitary Security Manage Uzerz  Manage Roles l Dj
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Faole Description Fole Permizzion Details
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Diagram W Create Diagram
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W Create Project
W Delete Project
Select Al | Unselect Al |
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3 Click New.

@' Create Repository Role

Fale Marme: |D-'“-"-

Description:

Thiz role applies to Data Architects who manage Logical
Models.

Cancel Help

4 Enter a name such as DA, and provide a description or the role.
5 To return to the Repository Security Center, click OK.

With the initial DA Role created, we now need to build a permission set for it.



6 Set permissions for each Repository object type beginning with the Repository itself.
This is done under the Role Permission Details.

As an example of permissions to set, you may not want DAs to access or modify anything in the Security Center,
S0 you may choose not to select those options as follows:

@ ER/Studio Repository Security Center

Welcome To the Repository Security Center!

Ilze the tabbed interface to create and manage Users, Roles, and the assignments they hawve to
Repazitary Projects, Diagrams and Diagram objects.

Fepozitary Security Manage serz  Manage Roles l Dj
D, ﬂ Mew | Delete Renarme |
Raole Descrption Role Permizzion Detailz
This fole applies to Data Reposzsitory Object Type Reposzitory Object Type Pemizzion
architects who manage (R epositary | [ Accesz Secunty Info
Logical Models. Project [ Update Securty Infa
Diagram W Create Diagram
Drata Dictionary W Update Diagram
Logical Main Model W Delete Diagram
Subkdodel W Create Enterprize Dictionary
Phwszical Main Model W Update Dictionary
Subkadel W Delete Enterprize Dictionany
W Create Project
[ [Delete Project |

Select All nzelect Al

7 Continue to assign permissions for the rest of the object types, Project, Diagram, Data Dictionary, Logical
Main Model, and the Submodel of the Logical Main Model.

As mentioned before, the DA should have no rights or privileges to modify physical models, so leave all the
options for Physical Main Model and Submodel unselected.

8 To save the changes to the Repository, click Apply.
9 Keep the Security Center open for the next procedure.

With the DA Role created and submitted to the Repository, let's move on to binding the User and Role to specific
Diagrams in the Repository.



Applying Permissions to Models, Diagrams, and Dictionaries

Now that we have created a User, userl, and a Role, DA, we must now decide to which diagrams or parts of diagrams
we want to allow these users to access. This is done under the Security Center’s Repository Security tab.

1 Click the Repository Security tab.

You will see the Orders diagram within the Sales Order Diagrams project you created earlier. Expand this node
and select the Logical Model node as you see here:

2 Grab userl from Available Users and drag it on top of the DA role you created.

@' [R/Studio Repository Security Center

Welcome To the Repository 5ecurity Center!

Llze the tabbed interface to create and manage Uzerz, Roles, and the azzignments they have to
Repozitomy Projectz, Diagrams and Diagram objects.

Reposzitory Securnity | Manage Users kanage Roles ED
To create Repository Object, Uzer and Role aszociations, highlight a Repozsitary Object [e.q. a diagram or Submodel], select
an Available User then drag and drop the uzer to an Available Raole the user should perform againzt the Object.

Fepoziton Object Available zers Available Foles
Repozsitany L L Super User
—HE Sales Order Diagrams Q Admir
Orders.dm1 DA @J
e DataArchitect
=5 Main bodel JaneDatadnalyst
HOg Altemnate Key JoeD atadrchitect
O3 Bill of Materials D atabazeDesigner
HOg Cornmizsion Tracking Q SamDBa
—ﬁ Conceptual Developer
—ﬁ Custarmer Q MaryD eweloper
HOg Customer Address Reviewer
O3 Datatype
% Mefinitinns o
| o 0K | | XK Cancel | | % Help

This will give userl the DA permissions you set when creating the Role on the Orders logical model and all its
Submodels.

3 If you want this user to have access to the Data Dictionary associated with the Orders.dm1 file, in the Repository
Object section, select the Orders_DD data dictionary, grab userl from Available Users, and then drag it over
on top of DA.

4  Click Apply.

Finished! When userl logs into the ER/Repository, userl will have only the rights and privileges available that
were created in the DA role. Do this for other diagrams you eventually add to the Repository.



Conclusion

At this point we have finished the Repository portion of the Evaluation Guide. This should have given you a good start
to continue working with your diagrams in a collaborative environment. You should now know how to apply security to
diagrams, version diagrams, check in and out portions of diagrams, and reuse common data elements.



Additional Evaluation Resources

Embarcadero Technologies provides a variety of resources to help support your evaluation and selection of a Data
Modeling product for your organization.

Web site

Visit our Web site for current product and company information, educational materials and supporting
information. Visit www.embarcadero.com.

To download an evaluation copy of ER/Studio, please visit:
www.embarcadero.com/products/erstudio/index.html

Electronic Documentation

Detailed reference documentation is available on the ER/Studio Evaluation CD or online at
docs.embarcadero.com/products/er_studio

Online FAQ

The ER/Studio online FAQ provides answers to commonly asked questions regarding licensing,
installation and other helpful topics.

To review the FAQs for ER/Studio visit: www.embarcadero.com/products/er_studio/faq.php
Email Support
You can contact ER/Studio support engineers, consultants and engineers directly by sending inquiries to:
For North America, Latin America and Asia Pacific:
support@embarcadero.com
For Europe, Africa and the Middle East:
uk.support@embarcadero.com

or log a case through embarcadero.com at: www.embarcadero.com/support/open_case.jsp

Telephone Support
We encourage you to call us anytime you would like help or have questions during your evaluation.
For North America, Latin America and Asia Pacific:
Phone: 415.834.3131 x2
Hours: Monday to Friday, 6:00am - 6:00pm Pacific time
For Europe, Africa and the Middle East
Phone: +44 (0) 1628 684499
Hours: Monday to Friday, 9:00am to 5:30pm UK time

Request a Product Key
For North America, Latin America and Asia Pacific:
key@embarcadero.com
For Europe, Africa and the Middle East:
uk.key@embarcadero.com


www.embarcadero.com
www.embarcadero.com/products/erstudio/index.html
http://docs.embarcadero.com/products/er_studio/
http://www.embarcadero.com/products/er_studio/faq.php
mailto:support@embarcadero.com
mailto:uk.support@embarcadero.com
www.embarcadero.com/support/open_case.jsp
mailto:key@embarcadero.com
mailto:uk.key@embarcadero.com
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