ER/Studio® 8.0 New Features Guide
Contents

New Features Summary ................................................................. 2
Top New Features ................................................................. 2
  Visual Data Lineage ............................................................. 2
  Attribute-level Submodeling .................................................. 2
  LDAP and Active Directory Integration ................................ 2
  Object-level Compare Flags ................................................... 2
Wizard and Editor Improvements ............................................... 3
  User-Defined Mapping Supports Definitions and Attachments .... 3
  Infer Foreign Keys when Declared Referential Integrity (RI) Dependencies Exist .............................................................. 3
User Interface Improvements ..................................................... 4
  Apply Color and Font Changes to Selected Objects ............ 4
  Display Attributes and Column Names ................................... 4
  Search Through Attachments and Data Security Objects .... 5
New DBMS Support ............................................................... 5
  SQL Server 2008 Support ....................................................... 5
  Sybase IQ Support ............................................................... 5
  General SQL Server Updates ............................................... 6
Details of Top New Features .................................................... 6
  Visual Data Lineage ............................................................. 6
    Creating a Data Flow ........................................................ 7
    Creating a Data Movement Rule ......................................... 8
    Defining Legacy Source and Target Systems ....................... 10
    Creating a Data Lineage and Transformation Visualization .... 11
  Attribute-level Submodeling .............................................. 14
  LDAP and Active Directory Integration ............................. 15
  Object-level Compare Flags ............................................... 16
New Features Summary

The new features supported by ER/Studio 8.0 fall into the following categories.

- Top New Features
- Wizard and Editor Improvements
- User Interface Improvements
- New DBMS Support

Top New Features

Visual Data Lineage
Visually analyze and document how data flows through your organization without needing to inspect code using the new visualization tools available on the Data Lineage tab.

Attribute-level Submodeling
Choose which attributes/columns to include in the entities/tables in the submodel on the new Attributes/Columns tab of the Create Submodel editor and also describe submodels on the new Definition tab of the Create Submodel editor. You can then create queries to search on these definitions.

LDAP and Active Directory Integration
Manage user authentication in the Repository using integrated user authentication facilitated by Lightweight Directory Access Protocol (LDAP) and Active Directory integration.

Object-level Compare Flags
Indicate intentional discrepancies when comparing models by choosing which properties to ignore on the new Compare Options tab available on the editors for entities, tables, attributes, columns, and relationships. This enables you to indicate discrepancies the Compare Wizard should ignore.
Wizard and Editor Improvements

User-Defined Mapping Supports Definitions and Attachments

Document user-defined mappings (UDM) using the User-Defined Mapping Editor, accessible from the entity and table editors, where you can enter a definition to describe the mapping and bind available attachments to the UDM or override the values of bound attachments.

Infer Foreign Keys when Declared Referential Integrity (RI) Dependencies Exist

The Compare and Merge Utility can now infer foreign keys from names or from indexes for tables which have RI dependencies.
User Interface Improvements

Apply Color and Font Changes to Selected Objects
Apply color and font characteristics to a select group of objects by Ctrl-clicking the objects you want to share specific properties.

Display Attributes and Column Names
Display table/entity and column/attribute names by choosing to do so in Diagram and Object Display Options.
Search Through Attachments and Data Security Objects

Search for a string or value override in attachments, attachment types, and security information by choosing newly added objects in the Selected Objects area of the Object Scope tab in the Universal Naming Utility.

New DBMS Support

ER/Studio now supports SQL Server 2008, Sybase IQ, and InterBase. These platforms are supported in all ER/Studio functions such as Add New Physical Model, Reverse-engineer an existing database, Change Physical Model, and are fully supported in the Automation Interface.

SQL Server 2008 Support

Changes to support SQL Server 2008 include:

Datatype Support Expanded to Include Hierarchy ID: The datatypes you can choose from in the Table Editor now include hierarchyid. This support has also been implemented in DDL Generation, Reverse-Engineering Wizard, Compare and Merge Utility, SQL Import, Automation Interface, DB Alter statements, Generate Physical Database, Report Generation, and Datatype Mapping.

Date and time datatypes: The datatypes you can choose from in the Table Editor now support SQL Server 2008 and include date, datetime2, datetimetz, and time. This enables ER/Studio to properly import data from an SQL Server 2008 database and retain the data and time datatypes defined in the database.

Table Editor Supports Sparse Columns Datatype: Optimize disk space usage and enhance data retrieval for your databases by selecting a new Sparse check box in the Table editor that enables the column to be treated as Sparse.

Sybase IQ Support

Sybase IQ Index Types: Sybase IQ support now includes index types, such as High Group, High Non-Group, and Low Fast.
General SQL Server Updates

**Supports INCLUDE Index Property**: The Options tab of the Index Editor for SQL Server 2005 tables now supports the option to enter an INCLUDE statement in the Include text box provided. This enable you to create tables with INCLUDE statements similar to the following:

```
CREATE INDEX TestIdx on dbo.Test (ID2)
INCLUDE (ShortString)
```

Details of Top New Features

Top new features for this release include the following:

- **Visual Data Lineage**
- **Attribute-level Submodeling**
- **LDAP and Active Directory Integration**
- **Object-level Compare Flags**

Visual Data Lineage

The Data Lineage features of ERStudio enables you to document the movement of data from point A to point B (and any intermediate steps in between). This movement is sometimes referred to as Extraction, Transformation and Load (ETL). Points A and B can be anything from flat files, high-end databases such as Oracle and DB2, XML, Access databases, and Excel worksheets. This is sometimes referred to as source and target mapping. A model produced in ERStudio can represent any point along the way. Data Architects need the ability to specify the source or target of data, down to the column-level. Along with the metadata that defines the source and target mapping are rules for how the data is manipulated along the way.

This section will help you document the data lineage of your systems. It is comprised of the following tasks which correspond to the general ETL workflow:

- **Creating a Data Flow**
- **Creating a Data Movement Rule**
- **Defining Legacy Source and Target Systems**
- **Creating a Data Lineage and Transformation Visualization**
Creating a Data Flow

The Data Flow organizes and encapsulates one data transformation and the source tables and columns used in the transformation to produce the target data. Multi-tiered mappings are possible and there can be multiple transformations involving different columns between two tables as illustrated below.

Create a Data Lineage Data Flow

1. Click File > Open and select the GIMB.DM1 diagram in the Sample Models directory.
2. Click the Data Lineage tab at the bottom of the application window.

You are prompted to create a Data Lineage Data Flow.

3. Click Yes.

If this is not the first time you click the Data Lineage tab after opening a diagram, from the Data Lineage explorer, right-click the Data Flows node and then click Create Data Flow.
4 Enter a Data Lineage Data Flow name and then click **OK**.

![Add Data Lineage Data Flow dialog box]

**NOTE:** The name that appears in the diagram title tab at the top of the application window is appended with: *data flow name*, when you click a task in the Data Lineage explorer, such as `JFGIMDB.DM1 - Data Flow Model View: Broker*`

![Data Lineage diagram]

The Data Flow has been created.

**Creating a Data Movement Rule**

Data movement rules describe how source and target tables and entities are related. You can relate source data to one or more tables and entities in the same model, the active diagram, or to tables imported from legacy systems. The rules defined here are used on the at the table level on the Data Lineage tab of the entity and table editors.
Create a data movement rule


2. Complete the Data Movement Rule editor as required and then click OK to exit the editor.

   **TIP:** Once created, you can edit the Data Movement rule by double-clicking it to launch the Data Movement Rule editor.

The following describes options that are not self-explanatory:

**Rule Information** tab

- **Rule Name:** Enter a name that indicates the operation and objects acted on, depending on the specifics of your binding definition.

- **Rule Type:** Select a generic movement rule type that best describes the data movement.

- **Rule Text:** Document your data movement plan here, perhaps adding instructions or contingency plans.

**Binding Information** tab

Select the object classes and/or specific objects to which you want to bind this attachment. You can override this setting using the Data Lineage tab of the entity or table editor.
Defining Legacy Source and Target Systems

The source can originate in models in the active diagram, Local Model data source, or from an external source imported into the active diagram, Legacy sources. The source can be imported from *.dml files, *.dt1 files, database or a SQL files, flat files, and other common application files. The following describes how to import metadata from an external source.

**NOTE:** Source data imported through the Data Lineage tab only includes information such as table and column name, datatype, nillability, primary key, and column definitions. To obtain more details, reverse engineer the database or import it into ER/Studio using the Metadata Wizard.

**Import legacy source or target data**
1. From the Data Lineage tab, expand the Data Sources node.
2. Right-click Other Sources and choose Import New Source.

3. Complete the Data Source Import Wizard as required and then click Finish to create the source.

   The following describes options that are not self-explanatory:

**General tab**
• General Properties

  • Name: The name you give it here will be displayed as a data source in the physical model.

  • Type: Select the source/target type. This setting affects available options in the Connectivity group. For example, select Relational for a DBMS such as MySQL.

• Connectivity Properties

  • Host, Server/Service, Port: For connecting to an external DBMS. For an existing ER/Studio physical model, leave blank.

  • DBMS Type, Version, Location/Path, File Type, Encoding: These settings depend on the Type selected above.

Model Usage tab

This is a read-only display of the source or target defined on the General tab. Ensure that it matches your intentions.

Creating a Data Lineage and Transformation Visualization

1. To create the data source or transformation input tables, expand Data Sources > Local Models > Logical > Entities and then drag and drop the Broker and Investment tables onto the Data Lineage window.

2. To create the data target or transformation output tables, navigate to Data Sources > Local Models > GIM_DW and then drag and drop the Broker table onto the Data Lineage window.

3. To obtain the Transformation insertion tool, right-click an empty space in the Data Lineage window and then click Insert Transformation.

4. To insert the transformation, click in the Data Lineage window between the source and target data sources and then right-click to drop the Transformation Insertion tool.

5. Reposition and resize the transformation object to suit your needs.
6 Right-click an empty space of the Data Lineage window and then click **Insert Data Stream**.

7 Click an input source and then click the transformation object. Repeat as many times as necessary to link all the inputs to the transformation object.

8 Click the transformation object and then click an input source. Repeat as many times as necessary to link all the inputs to the transformation object.

9 To define which columns should be used in the transformation and any transformation rules, double-click the new transformation to open the **Transformation Editor**.
10. Complete the **Transformation Editor** as required and then click **OK** to exit the editor.

**TIP:** If the Inputs and Outputs don’t display as they do in the illustration above, click **View > Diagram and Object Display Options > Transformation** and then click **Input and Output Columns**.

You’re done! Now you can more easily share your ideas with your colleagues!

**TIP:** Once the Data Flow is created, you can double-click it to change its name, or double-click a transformation or component to change its properties.

The following describes options that are not self-explanatory:

**Columns tab**

- **Inputs:** Click the ellipsis (…) button to choose the source data to be transformed in this task.
- **Outputs:** Click the ellipsis (…) button to choose the source data to be transformed in this task.

**Definition tab**

- **Business:** Describe the transformation for your audience.
- **Code:** Enter the code that will perform the transformation, such as a SELECT statement, or a VBBasic of JavaScript function or procedure.
Rules tab

These are the rules from the Data Movement Rules node of the Data Lineage explorer.

**NOTE:** You can delete or edit an input or output column by double-clicking the transformation in the Data Lineage window, clicking the ellipsis in the Transformation Editor and then deselectiong the column you want to remove in either the Input Columns dialog.

Attachments tab

Lets you bind an external piece of information or attachment to the transformation. You can also remove an attachment from an object, override an attachment binding’s default value, or change a bound attachment’s position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the default before they will display on this tab.

Attribute-level Submodeling

ER/Studio lets you create independent views of all or part of your logical or physical models called submodels. Submodels can focus attention on specific characteristics of a model and can facilitate faster data access. New features in this release let you choose which attributes to include in the submodel and create definitions and attachments to document the submodel.

1. On the **Diagram Window** or **Diagram Explorer**, select one or more objects to include in the submodel.
   **TIP:** Ctrl-Click to select multiple objects.

2. Click **Model > Create Submodel**.

3. In the **Create Submodel** dialog, enter a name for the submodel.

4. Complete the **Create Submodel** dialog as required and then click **OK** to create the submodel.
Attributes tab

Lets you choose which attributes of the entities selected on the Edit Submodel tab to include in the submodel.

Definition tab

Enter or edit a definition for the submodel.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the submodel. You can also remove an attachment from an object, override an attachment binding’s default value, or change a bound attachment’s position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary.

LDAP and Active Directory Integration

Manage user authentication in the Repository through LDAP and Active Directory integration.

Managing users entails creating, changing, and deleting user account permissions and logins, checking in a users checked out documents under unusual circumstances. You can control the privileges granted to a user for a specific diagram, model, submodel or Enterprise Data Dictionary by associating the user with a role. Using Roles, you can choose the permissions granted a user for the Repository item.

NOTE: To access, create, update, and delete user information, a Repository administrator must have Repository Object Type Permission, Access Security Info and Update Security Info privileges.

Create Users

2. Select the Manage Users tab.
3. On the Manage Users tab, you can manage users by clicking their name in the list and then clicking a management option and following the prompts as required.
4. Click New to access the Create Repository User dialog.
5. If you want the new user to login to the Repository using their Windows credentials, select Directory Service User.
6 Continue making security changes and then click **OK** to exit the security center.

**Object-level Compare Flags**

New Compare Options available for entities, tables, attributes, columns, and relationships enable you to indicate intentional discrepancies that will be ignored by the Compare Wizard. For example, double-click an entity to launch the Entity Editor and then click the Compare Options tab. Here you can choose which properties to include or ignore when comparing this model or database to another.