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NAME CHANGE

EA/Studio Business Modeler Edition has been renamed to ER/Studio Business Architect. 
Likewise, ER/Studio has been renamed to ER/Studio Data Architect. Shortened forms of these 
product names and ER/Studio BA and ER/Studio DA respecitively.

NEW FEATURES SUMMARY

ER/Studio Business Architect 1.6, now includes support for ER/Studio Repository, providing the 
business modeler with the same version control and collaborative work environment enjoyed by 
ER/Studio Data Architect users.

ER/Studio Business Architect 1.6.1 also includes support for Windows 7.

WORKING WITH ER/STUDIO REPOSITORY

The Repository provides access to workspaces for one person at a time. Modelers can update or 
delete model information simultaneously by working with ER/Studio® Business Architect in the 
normal fashion and by merging their changes into a single model. 

To use Repository operations such as check in, check out, and get workspace, you must first 
specify the Repository connection details and then log in to the Repository. 

When you are finished working with the Repository, you should log out. If you close ER/Studio 
Business Architect, you are automatically logged out of the Repository.

This section provides usage information for Repository Users:

• Specifying Repository Connection Details

• Logging In and Out of the Repository

• Establishing Security for the Repository

• Working with Objects in the Repository

NOTE: Repository architecture, setup, maintenance, control, and query options are covered in 
the “Administrator’s Reference” of the ER/Studio Data Architect Users Guide.

SPECIFYING REPOSITORY CONNECTION DETAILS
Using configurable Repository settings you can specify and modify server check out policy and 
communication settings. 
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WORKING WITH ER/STUDIO REPOSITORY
Setting Repository Options

1 Click Window > Preferences.

2 Specify your connection details in the Repository Options and click Apply and then click OK 
to exit the editor.

The following describe options that require additional explanation:

Server Machine: Specify the URL or hostname of the ER/Studio Enterprise Repository.

Server Port: Specify the port ER/Studio BA uses to communicate with the Repository server. 
The default is 54333.

Check out model when checking out diagram: Choose what action, if any, you want the 
system to perform with respect to the models in a diagram, when a diagram is checked out; 
always check out the models, never check out the models, or prompt you to decide what to 
do each time a diagram is checked out.

Check out workspace when creating/deleting models: Choose what action, if any, you 
want the system to perform with respect to the workspace, when a model is checked out 
and deleted or when diagram is checked out and a new model is added to it; always check 
out the workspace, never check out the workspace, or prompt you to decide what to do 
each time a workspace is checked out.

LOGGING IN AND OUT OF THE REPOSITORY

Log in to the Repository

1 To log in to the Repository, click Repository > Log In.

2 Complete the log in dialog and then click OK.

The following describes the options that require additional explanation:

User Name: Enter your user name. This is case-sensitive.

Password: Enter your password. This is case-sensitive. You can change your password, click 
Repository > Security > Change Password.

Remember me: Select this option and ER/Studio BA will remember and then auto 
complete the User Name and Password for you when you choose to log in.

Notes

• During the Repository Installation, a default user name and password Admin is set. The 
Administrator should change the Admin password after the initial log in.

• The Admin user can’t be deleted. This prevents an accidental lockout. In the ER/Studio BA 
Security Center, you can set up additional users with Roles and Privileges to maintain 
Repository security. 
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WORKING WITH ER/STUDIO REPOSITORY
• If an administrator changes the Repository security, users must log in again to update their 
permissions. 

Log out of the Repository

To log out of the Repository, click Repository > Log Out.

ESTABLISHING SECURITY FOR THE REPOSITORY
Security of the Repository contents is managed through the Repository Security Center by 
creating and then assigning users particular Roles and Privileges. 

NOTE: To prevent an accidental lockout, the Admin user can’t be deleted.

The Administrator can restrict user access to Repository items at the workspace level. To restrict 
access to the Repository, the administrator creates users and then assigns the users a role, which 
grants specific permissions to the user, or the administrator creates new roles to assign to users. 
Then the Administrator can grant users full access to some Repository items and restrict or deny 
access to other items.

Before creating users and roles, the Administrator should understand the following Repository 
concepts:

• Client Side Security Caching: To promote the concept of detached modeling collaboration 
(e.g. being logged out of ER/Studio Repository and possibly detached from the network), all 
security associated with the user by diagram is cached on the client when the user logs into 
ER/Studio Repository. 

NOTE: When security changes are made, users must re-login to update their permissions. 

• Super User: Super User is a default Role created upon installation of ER/Studio Repository. 
The default 'Admin' user is assigned to the Super User role. This user can do anything to 
Repository objects, users and roles managed in the ER/Studio Repository as it is granted all 
privileges. It is not removable or editable, and is only found at the 'Repository' level of the 
Repository Security area of the Security Center.

• No Access: No Access is a role that can be applied only at the workspace level of the 
Repository. It is a quick and global mechanism to prevent any access whatsoever to certain 
workspaces.
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WORKING WITH ER/STUDIO REPOSITORY
Notes

• When a user checks out a workspace from the Repository, ER/Studio BA tracks the user and 
machine combination for that particular file. In addition, to enable users to model while they 
are "offline” or unable to connect to the Repository server, when a workspace is checked 
out, ER/Studio BA stores information about the security rights of the user and the workspace 
with the file, which has the following effects:

• When a user is logged into the Repository, and attempts to open a workspace that was 
retrieved from the Repository by a different user/machine combination than the currently 
logged in user, ER/Studio BA indicates that the file cannot be opened due to the conflict. 
This ensures that one user does not attempt to work on or check in changes to a 
workspace that was originally retrieved by a different user. Because the Repository keeps 
track of object check outs based on the user and machine, only the user on the machine 
that originally checked out an object can check it back in.

• Even if a user is not logged into the Repository, Repository files that have been checked 
out can be opened and worked on in ER/Studio BA. ER/Studio BA will load the security 
permission data for the user that originally retrieved the file from the Repository, and that 
security data will govern the rest of the working session until the user either logs in to the 
Repository or closes the file. If multiple files are open while the user is NOT logged in to 
the Repository they must all have been retrieved by the same user. Of course, this also 
applies when the user IS logged in.

• The cached security data stored with each diagram is updated whenever an open 
Repository file is saved while logged in to the Repository, but if the file is not saved before 
closing it, then any changes to the security permissions for that user and workspace will 
not be cached with the file. So, if you plan to work offline, and the security settings have 
changed since the file was last saved, then you should open each file while logged into 
the Repository and save it before taking the files to work offline.

• If an admin makes changes to the security UI, such as changing permissions on worspaces to 
grant or revoke access, users must re-login to update their permissions.

This section includes the following topics:

• Creating and Managing Roles

• Creating and Managing Users

• Granting and Prohibiting User Access to Repository Items

See Also

Working with Objects in the Repository

CREATING AND MANAGING ROLES
ER/Studio BA supports customized roles with different sets of permissions. Repository Object 
Type Permissions are pre-defined privileges to operate on Repository items. You can assign 
them to a role, which gives users assigned to that role, permission to perform certain Repository 
operations. You can use the available privileges to create specific roles to suit your environment. 
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WORKING WITH ER/STUDIO REPOSITORY
For example, you can create a role which has the Repository permissions to create, update, and 
delete workspaces. You can then assign a new user that role for the Repository and then create 
and assign another role to provide update priveledges to existing workspaces the user may 
need to update. 

NOTE: To access, create, update, and delete user and roles, a Repository administrator must 
have Access Security Info and Update Security Info privileges.

Create, Update, Rename, and Delete Roles

1 Click Repository > Security > Security Center.

2 Select the Manage Roles tab.

3 To create a new role, click New.

• In the Create Repository Role dialog, enter a Name and a Description for the new role.

• In the Repository Object Type Permission area, select the permissions you want to 
assign to the role for the selected object type.

• Click Apply and continue changing security settings and then when finished, click OK to 
exit the security center.

• To apply the new role to exisitng users, see Assigning Users Roles for Accessing 
Repository Items.

To update a role, select a role from the list, select or clear the checkboxes to add or remove 
permission, click OK, and then click OK again to exit the security center.

To rename a role, select a role from the list and then click Rename. 

• In the Rename Repository Role dialog, enter a new name, click OK, and then click OK 
again to exit the security center.

To delete a role, select a role from the list and then click Delete.

4 Inform affected users that they should log out of the Repository and then log in again to 
receive the security updates.

Notes

• Once created, the Administrator can select the role and update, delete or rename it at any 
time. Renaming the role does not affect the privileges users have, but if you delete a role 
users who had access to Repository items through that role, will no longer have access to 
those items.

• Users cannot modify workspaces without the necessary permissions, regardless of whether 
the user has the workspace checked out.

• Once you delete a role from the Repository, it will no longer be in the database.
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WORKING WITH ER/STUDIO REPOSITORY
• The following lists the Repository Object Types, the permissions you can grant, and the 
common operations these permissions give access to:

CREATING AND MANAGING USERS
Managing users entails creating, changing, and deleting user account permissions and logins, 
and activating and deactivating their accounts. Using Roles, you can choose the permissions 
granted a user for the Repository item. 

NOTE: To access, create, update, and delete user information, a Repository administrator 
must have Repository Object Type Permission, Access Security Info and Update 
Security Info privileges.

Create, Edit, Delete, Deactivate, Reactivate, and Check In Users

1 Log in to the Repository.

2 Click Repository > Security > Security Center.

3 Click the Manage Users tab.

4 On the Manage Users tab, you can manage users by clicking their name in the list and then 
clicking a management option and following the prompts as required.

5 Continue making security changes and then click OK to exit the security center.

6 To assign permissions to users, see Assigning Users Roles for Accessing Repository Items.

7 Notify users that they must log out and then log in again to receive the security updates.

Notes

• You cannot delete or deactivate the Admin user, but you should change the Admin 
password from the default, which is Admin.

Repository Object 
Types

Repository Object Type 
Permissions

Permitted Operations 

Repository Access Security Info Security Center: View settings

Update Security Info Security Center: View and change settings

Create Workspace Add Workspace

Update Workspace Check Out Workspace, Check In Workspace
Check Out Object(s), Check In Object(s)
Undo Check Out Workspace, Undo Check Out Object(s)

Delete Workspace Delete Workspace
If you delete a workspace in Repository, the file itself remains on the 
local disk.
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• The new user appears in the user list with a star indicating that this user does not yet have 
any roles assigned to it for any Repository items. 

• Users must log out and log in again to receive any security updates.

• The Admin does not need to know the user’s password to create a new password for the 
user.

• The Admin can look to the Manage Users tab to find out which users are logged in to the 
Repository and whether or not they currently have items checked out. Knowing if users have 
items checked out is particularly useful when upgrading the Repository, because after before 
upgrading the Repository the users should check all their items in and then do a clean get 
and check out of the items when the upgrade is complete. Knowing which users are logged 
in is useful when changing security center settings because after making any setting 
changes, the Admin should request online users to log off and log in again to receive the 
security center updates.

• The Aministrator may want to deactivate a user to prevent the user from logging into the 
server while the Repository is being updated. Once deactivated the user must be 
reactivated before they can log in to the Repository.

GRANTING AND PROHIBITING USER ACCESS TO REPOSITORY ITEMS
On the Repository Security tab of the Security Center, users with the appropriate privileges can 
assign other users the appropriate access privileges for different objects, granting them 
permission to perform specific operations on a Repository item and prohibiting them from 
performing other operations on the same object.

Assigning Users Roles for Accessing Repository Items

1 Log in to the Repository.

2 Click Repository > Security > Security Center.

3 Click the Manage Roles tab; explore the available roles to determine if an existing role 
provides the access you want to grant the user. If necessary, create a new role with the 
appropriate permissions.

4 To grant permission to access and update security information, or to view only workspaces, 
in the Repository Object pane, select Repository.

To grant permission to update or delete an existing workspace, in the Repository Object 
pane, expand Repository and select the name of a workspace.

5 In the Available Users pane, click and drag a user name onto the name of the role you want 
to apply to the user for the Repository or for the selected workspace.

6 Click Apply and then click OK to exit the Security Center.
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WORKING WITH ER/STUDIO REPOSITORY
7 Notify users that the must log out and then log in again to receive the security updates.

TIP: To remove the role assignment of a user to a Repository item, click the Repository item, 
drag the user name from under role onto another role in the Available Roles area or 
drag the user name back to the Available Users pane.

Notes

• A user can only have one role for each object. But a user can have different roles for different 
objects.

• If a user is listed in the Available Users area, but is unselectable, the user has been 
deactivated and must be reactivated before you can modify the user.

Prevent Users from Accessing Specific Repository Items

The system-defined No Access role can prevent a user from accessing selected projects or 
diagrams

1 Log in to the Repository.

2 Click Repository > Security > Security Center.

3 In the Repository Object area, navigate to and then click to select the workspace you want 
to secure from specific users.

4 From the list of users in the Available Users area, click a user name or CTRL-click several 
names and then drag the users onto the No Access role in the Available Roles area.

5 Repeat step 3 and step 4 as required to secure other diagrams and projects.

6 Click Apply, continue changing security settings if required, and then click OK to exit the 
security center.

Change User Access to Repository Items

To change user access to Repository items, change the permissions of the role the user has for 
the Repository item or assign another role to the user for that particular Repository item.

WORKING WITH OBJECTS IN THE REPOSITORY
The Repository performs version control and allows other users to retrieve a copy of the 
workspace to view or edit on their local machines if they have permission. 

The Repository includes a robust features set for working with workspaces. Detailed procedures 
for using these features are provided in subsequent sections. 

• Adding a Workspace to the Repository

• Retrieving a Repository Workspace

• Getting the Latest Version of a Workspace
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• Saving Changed Items to the Repository (Checking In)

• Checking Out Repository Items

• Discarding Changes Made to a Checked Out Workspace

• Deleting Workspaces from the Repository

ADDING A WORKSPACE TO THE REPOSITORY
Using the Add Workspace operation you can add the active workspace to the Repository. 

NOTE: You cannot add data model objects to the Repository without first adding the 
workspace containing them.

1 Log in to the Repository.

2 Click Repository > Workspace > Add Workspace. 

3 Enter a comment if you want to and then click OK to exit the dialog and complete the 
operation.

When an object has been added to the Repository, the object icon changes to include a 
little database icon in the upper left-hand corner. 

RETRIEVING A REPOSITORY WORKSPACE
Retrieving a workspace in the Repository downloads a copy of the selected workspace from the 
Repository onto your local machine. If a local version of the workspace exists, the Get from 
Repository operation refreshes the local copy with the version from the Repository.

NOTE: Permissions assigned to your user account in the Repository Security Center determine 
what type of access you have to Repository objects. For more information, see About 
Repository Permissions.

1 Log in to the Repository.

2 Click Repository > Workspace > Get Worspace.

Workspace Repository Workspace 

Add to Repository

Checked In
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3 In the Repository Get Workspace Selection dialog, scroll through the list of available 
workspaces, select the workspace you want, and then click OK.

NOTE: You can also get a workspace through the Welcome to ER/Studio Business Architect 
dialog that appears each time ER/Studio BA is started.

GETTING THE LATEST VERSION OF A WORKSPACE
The Get Latest Version function synchronizes the local version of the open workspace with the 
version in the Repository, copying the Repository version to local storage and overwriting the 
local copy. For example, if another user has changed the workspace since you last checked it in, 
you can get the latest version to update your local version after they submit their changes. 

Click Repository > Workspace > Get Latest Version.

SAVING CHANGED ITEMS TO THE REPOSITORY (CHECKING IN)
The check in process synchronizes the changes made to the local checked out item with the 
Repository version by updating the Repository version. 

The check in process lets you check in an object, such as an diagram or a model, when you are 
done working with it. 

Checking In Objects

When you check in an object, all object components are checked in as well. You can check in a 
newly created object, such as a model which you added to a checked-out workspace or you can 
check in multiple, selected objects simultaneously to the Repository. 

The procedure to check in an object into the Repository is basically the same for all object types. 

To check in a project, diagram or model

1 Save the changes you have made to the workspace; click File > Save.

2 Click the object you want to check in or CTRL-click several objects to check in more than one 
object.

3 Right-click and then select Repository > Check In Object(s).

4 Enter a comment in the Repository Check In Object(s) dialog and then click OK to start the 
check-in process.

To check in a workspace

1 Save the changes you have made to the workspace; click File > Save.

2 Click Repository > Check In Workspace.
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3 Enter a comment in the Repository Check In Object(s) dialog and then click OK to start the 
check-in process.

CHECKING OUT REPOSITORY ITEMS
Checking out write enables items previously added to the Repository, such a workspace, project, 
diagram or model. The procedure to check out an item from the Repository is the same for all 
object types. 

To check out a project, diagram or model

If you have a workspace checked out, and have checked in some objects, you can check them 
back out using this procedure.

1 Open a Repository workspace; a workspace that was previously added to the Repository.

2 Click the item you want to check out or CTRL-click several items to check out more than one.

3 Select Repository > Workspace > Check Out Object(s).

4 In the Repository Check Out Object(s) dialog, enter a comment if you want to and then click 
OK to start the check-out process.

NOTE: Checked out objects appear in the workspace explorer tree with a check mark in the 
top left-corner of the object icon.

To check out a workspace

If the active workspace was previously added to or retrieved from the Repository, you can check 
it out.

1 Open a Repository workspace.

2 Select Repository > Workspace > Check Out Workspace.

3 In the Repository Check Out Workspace dialog, enter a comment if you want to and then 
click OK.

NOTE: Checked out objects, including the workspace, appear in the workspace explorer tree 
with a check mark in the top left-corner of the object icon.

Repository Workspace 

Check Out of Repository

Checked In
Repository Workspace

Checked Out
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DISCARDING CHANGES MADE TO A CHECKED OUT WORKSPACE
If you have checked out a workspace, made changes to it, and want to undo all the changes you 
made you can undo the check out.

1 Log in to the Repository and open the target workspace.

2 To discard the changes, click Repository > Workspace > Undo Check Out Workspace.

DELETING WORKSPACES FROM THE REPOSITORY
The Delete Workspace operation lets you delete a workspace from the Repository. 

1 Log in to the Repository.

2 On the Repository toolbar, click the Delete Workspace icon.

3 In the Repository Delete Workspace Selection dialog, select the diagram to delete and 
then click OK.

Notes

• When you delete a Workspace from the Repository, the local copy of the Workspace is not 
deleted.

• When deleting a workspace, the Repository leaves workspace data behind and marks it as 
deleted. If deleted, data is still present in the Repository but visible only when querying the 
Repository directly, not through ER/Studio BA.
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