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Describe Enterprise functionality is accessible through an Integrated Development Environment (IDE). This version of 
the application supports the following IDEs:

• Borland JBuilder 9.0

• IBM WebSphere Studio Application Developer 5.0. and Integrated Edition 5.0

• Eclipse Platform 2.1.3 and 3.0.1 (WinXP only)

Working within IBM WebSphere Studio Application Developer
Describe Enterprise offers a seamless, embedded integration within IBM WebSphere Studio Application Developer 
(WSAD) to provide a single, integrated modeling and development environment. With superior navigation, 
wizard-based automation of common tasks, and synchronous, Round Trip engineering, Describe Enterprise turns your 
UML into a live tool for understanding and manipulating the source base.

NOTE: Describe Enterprise does not add WebSphere Studio Application Enterprise files to SCM 
(because they are stored in a repository).

What Is WebSphere?
WebSphere software is an Integrated Development Environment (IDE) for the Java platform providing a fully modular 
and extensible environment. This environment, called the workspace, consists of several panes and panels for 
performing the following development functions:

• Editing

• Visual designing

• Navigating

• Browsing

• Compiling

• Debugging
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Why Integrate with Describe?
The WebSphere Studio Application Developer/Describe integration lets Unified Modeling Language tools 
communicate with Integrated Development Environments. This eliminates the need to switch back and forth from 
design environment to development environment and maintains synchronization between design elements and the 
source code as you design systems. The two environments are combined by embedding modeling functionality within 
WebSphere Studio Application Developer, letting you view and manipulate the class model and its underlying code 
simultaneously.

TIP: You can have multiple Projects open simultaneously while working with integrated IDEs. This lets 
you easily switch back and forth between Projects.

Opening Describe Enterprise in WebSphere
When you start WebSphere and create a WebSphere project, the application automatically displays selected Describe 
Enterprise windows, toolbars, and menu options. Upon opening, Describe Enterprise automatically embeds itself in 
WebSphere if you install WebSphere prior to Describe Enterprise. Once embedded, you can connect and disconnect 
to Describe Enterprise, as needed.

Opening Describe Enterprise in WebSphere
1 On the Windows Start button, point to Programs, Embarcadero Describe 6, WebSphere.

WebSphere starts, and automatically detects the integration with Describe Enterprise. The application then 
displays its workspace, along with the embedded Describe Enterprise windows, toolbars, and menu items.

Disconnecting and Reconnecting to Describe Enterprise in 
WebSphere
Once open, WebSphere lets you disconnect and reconnect to Describe Enterprise. When you disconnect from 
Describe Enterprise, WebSphere removes the Describe Enterprise toolbar and all related panes. When you 
reconnect, the application redisplays these workspace components.
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Disconnecting from Describe Enterprise
• On the Tools menu, click Disconnect from Describe.

WebSphere disconnects from Describe Enterprise, and removes the toolbar and all related panes.

Reconnecting to Describe Enterprise
• On the Tools menu, click Connect to Describe.

WebSphere reconnects to Describe Enterprise and displays all Describe Enterprise windows and toolbars.

Running the WebSphere/Describe Integration
Take the following steps to run WebSphere with the Describe application.

Starting WebSphere:
On the Windows Start button, point to Programs, Embarcadero Describe 6, WebSphere 5 Studio Application 
Developer.

WebSphere starts, and automatically detects the integration with Describe Enterprise. The application then 
displays its workspace, along with the embedded Describe Enterprise windows, toolbars, and menu items. 

 When the application loads, the Describe Enterprise splash screen opens. On the splash screen, 

1 Enter a User Name and Password. 

2 Click OK. 

The Describe Enterprise application is launched.

WebSphere Main Window
The icons below are the Describe modeling icons. You see these when you open the main window.
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Model Hierarchy Window
The Model Hierarchy Window pane opens when you select the Describe Workspace pane. The Workspace appears 
and displays the current Describe system.

You can access the following Describe functionality from within the IDE:

• Describe Design Center

• Describe Documentation

• Describe Property Editor

• Describe Workspace

The System Explorer displays the different tabs at the bottom of the Pane. To work in the Describe Workspace, click 
the Describe Workspace Tab. 
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If a Describe View is not present in Show View, 

1 Select Other… from the menu

The Show View pop-up window opens.

2 Expand the Describe node, and then select the Describe Diagram View.
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3 Click OK.

Describe saves your selection and the Describe Diagram View tab will be visible on the Workspace window.

An example of how the diagrams and classes are displayed in the Package Explorer pane of WebSphere is shown 
below:
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Create a New Project
1 On the WebSphere File menu, click New Project

The New Project dialog box opens. 
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2 Select Java, Java Project, and then Next.

The New Java Project dialog box opens.
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3 In the Project Name box, type the project’s name. For purposes of this tutorial name the project 
"Describe_Project." 

4 Click Finish.

Describe associates a workspace and project with the newly created WebSphere project.

NOTE: When you create a project in WebSphere, a corresponding Workspace and Project is created and 
opened in Describe.

Create a New Diagram
1 In the Describe Workspace pane, right-click Describe_Project. 

A background menu opens.
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2 Choose New Diagram from the menu. 

The Create New Diagram dialog box opens.
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3 In the Diagram name box, type a diagram name.

4 Click OK.

The Diagram pane opens. 

NOTE: Once the diagram is created, the navigation icons and the Class Methodology icons are now 
active in the WebSphere main window.

NOTE: When you create a diagram in WebSphere, a corresponding diagram is created and opened in 
Describe.
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Create a Model Element
As a final step, we are going to create a class with an attribute.

1 In the WebSphere window. click .

2 In the Diagrams pane, click once to place the class notation. 

A class notation is placed in pane.

3 Label the attribute. 

TIP: Start typing to automatically name it.

The Source pane opens and you can see the source code.

NOTE: The diagram and class you just created also appears in the Describe Workspace pane.

4 In the Attribute compartment, right-click.
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5  From the background menu, select Insert Attribute.

6 Name the attribute verify private int verify;. 

NOTE: Using the Describe Preferences dialog box, users can set preferences on modeling elements as 
well source code generation.

7 From the WebSphere menu select Describe, and then Preferences.
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The Preferences dialog box opens.

The attribute you entered appears in the class. You will also see the Getter and Setters are populated. In the Describe 
Preferences Editor you have the ability to change those.

Create a New Class in WebSphere
1 On the WebSphere File menu, select New Class.

2 In the Class Wizard dialog box, name the class (in this case, ClassTwo)
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3  Click Finish.

NOTE: Any classes that are created or modified in WebSphere are instantly updated in the Describe 
Workspace Tab.

The new class appears in the WebSphere Package Explorer pane.

The new class also appears in the Describe Workspace Pane
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Opening an Existing WebSphere Project with Describe
When opening an existing project in WebSphere, Describe will ask you to reverse engineer your source code. Once 
you have reverse engineered your source code, Describe will create a corresponding Workspace and Project with the 
same name. After this, you can create diagrams by using the Create Diagram from Selected short cut menu on the 
Workspace. You can also Update Model from Source from the WebSphere Package pane. 

To open an existing project do the following:

In the Package Explorer, right-click Update Model from Source. 
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Working with WebSphere Projects
You can easily turn off auto compile when reverse engineering Projects.

1 On the Window menu, click Preferences.

The Preferences dialog box opens.

2 On the Workbench node, clear the Perform build automatically on resource modification check box. 

3 When you want to build, do one of the following:

Press CTRL+B.

OR

On the Project menu, click Build All. 

TIP: When you turn "auto compile" off and build manually, you may also want to select the Window 
>Preferences > Workbench > Save all modified resources automatically prior to manual build 
check box. 

NOTE: When reverse engineering a project like DigSim in WSAD the main project package is seen as a 
file folder when Importing the Filesystem. To reduce compile errors, create a package (for DigSim 
create the DigSim source directory) in the Package Explorer. Move all the source files from the 
“default package” to the DigSim package. This removes errors from DigSim when compiling. The 
remaining “warnings” generally relate to deprecated code.

Architecture and File Extensions
Describe Enterprise uses specific file extensions for 

• Workspaces

• Projects

• Diagrams

• Versioned elements

The file extensions are described below.

Workspaces
File Extension: .etw

Describe Enterprise introduces *.etw files, represented in the application as unique workspaces used to contain 
project files. Superficially analogous to Describe Developer 5.8's System Groups, this new unit of file organization has 
no exact counterpart in previous versions of the application. You can open, close, and save workspaces in the 
application, but only one workspace can be open at a time.

Projects
File Extension: .etd

Describe Enterprise replaces the old concept of Systems with Projects. These stand-alone *.etd files are stored in 
workspaces, and are represented as subnodes of a workspace in the new Describe Workspace pane. Each project 
may consist of diagrams, artifacts, and other modeling elements. In any workspace, you can open, close, and save 
projects, as well as insert specific projects from other workspaces. Describe Enterprise lets you open and work with 
only one project at a time. 
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Diagrams
File Extension: .etld for layout

This is the topographical data that makes up the diagram in Describe Enterprise's Diagram window. For example: the 
x and y locations of all objects, the length of links, the location of all diagram elements.

Describe Enterprise saves this information in a binary file with the extension *.etld.

File Extension: .etld for presentation

This is the cosmetic data that makes up the look of the diagram in Describe Enterprise's Diagram window. For 
example: the color of all class elements in the diagram, the font used to denote class attributes, and so on.

Describe Enterprise saves this information in an editable XML file with the extension *.etlp.

Versioned Elements
File Extension: .etx

Describe generates associated versioned files with the extension .etx.

Associated artifact of element that has been versioned.
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