
 

Embarcadero®  Change Manager™ 5.0 New Features Guide
Published: October 23, 2008



Change Manager 5.0 New Features Guide

Contents
NEW FEATURES SUMMARY........................................................................................................3

Schema Comparison Integration and Enhancements......................................................................................3

Configuration Standard Enhancements............................................................................................................3

Source Code Control Support...........................................................................................................................3

Data Comparison Job Enhancements..............................................................................................................3

Job Explorer......................................................................................................................................................3

Data Source Explorer........................................................................................................................................3

Job Reporting....................................................................................................................................................4

TOP NEW FEATURES...................................................................................................................5

Schema Comparison Integration and Enhancements......................................................................................5

Configuration Standard Enhancements............................................................................................................7

Source Code Control Support...........................................................................................................................8

Data Comparison Job Enhancements............................................................................................................10

Job Explorer....................................................................................................................................................13

Data Source Explorer......................................................................................................................................14

Job Reporting..................................................................................................................................................16

ADDITIONAL RESOURCES........................................................................................................17

Licensing Your Embarcadero Technologies Product......................................................................................17

Embarcadero Technologies Product Support.................................................................................................17

Embarcadero Technologies Technical Support..............................................................................................17

Embarcadero Technologies on the Web.........................................................................................................17

2 of 17



Change Manager 5.0 New Features Guide

New Features Summary

Schema Comparison Integration and Enhancements
Change Manager 5.0 features the complete integration of its schema comparison feature into the 
application framework. This major interface rework provides an enhanced user experience by 
providing improvements to versatility, performance, and user comprehension. This includes 
enhancements to the interface, such as drag and drop functionality when creating jobs, quick type 
features, and larger editor spaces. Additionally, schema comparison takes advantage of its new 
framework and offers one-to-many comparison jobs, job history storage, enhanced mapping options, 
and single step schema refinement.

Configuration Standard Enhancements
Standards Explorer has been removed from the application and all configuration standards are now 
managed via Project Explorer. Additionally, static property definitions are no longer associated with a 
source. They are simply marked as static and stored as independent values. Furthermore, all 
configuration comparison jobs, archives, and standards now provide more detailed information 
regarding the platform versions for the source and target DBMS.

Source Code Control Support
Change Manager now supports source code control through compatible source control plug-ins. All 
data source definitions, jobs, standards, synchronization scripts, and archives can be stored as 
specified file formats, placed into a repository, and then shared across multiple instances of the 
application. This feature functions via the Project Explorer, which organizes definition files and stores 
them in the system. The Navigator is then used in conjunction with the source control system to share 
these files across a development team or project from within the application interface.

Data Comparison Job Enhancements
The data comparison job process has been improved to provide users with greater control over the job 
comparison and synchronization process. These enhancements include the ability to specify high-level 
refinement mapping (by database, schema, or owner) prior to the standard refinement process, which 
automatically filters mapping selections to a more manageable number on the Mapping tab. 
Additionally, the Check Rows from Source and Check Rows from Target commands provide a 
more precise comparison, as they indicate to the process to only examine the rows in one or the other 
data source of the job. Finally, the table comparison results display includes paging options to optimize 
loading and browsing times, and also includes the Show Rows command, which filters specified rows 
from the view automatically.

Job Explorer
The Job Explorer view replaces Change Explorer, and provides an organized list of data, 
configuration, and schema comparison jobs from which to explore and manage. It includes enhanced 
interface and organizational functionality which improves comprehension and the ease at which jobs 
are set up, managed, and viewed.

Data Source Explorer
The Auto Discover button on Data Source Explorer scans your system for data sources and 
automatically adds them to the tree. Additionally, the Import command enables you to import new 
data sources from the Windows registry, Eclipse Data Tools Platform (DTP), TOAD, or other instances 
of Change Manager. Conversely, the Export command enables you to store the current definitions 
catalog in a file for import purposes on other systems.
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Job Reporting
Job reports can now be generated across all modules in XML, PDF, RTF, CSV, and HTML file 
formats. Additionally, a preview window is provided to view reports prior to saving and distributing 
them.



Change Manager 5.0 New Features Guide

Top New Features

Schema Comparison Integration and Enhancements
Schema comparison provides the ability to capture, compare, and synchronize schema in databases 
and provide reports on comparison jobs to enable the distribution of the information throughout your 
working environment. In previous versions of Change Manager, schema comparison was not 
integrated into the interface in the same format as configuration and data comparison. In version 5, the 
module is fully integrated and provides the same level of versatility, performance, and comprehension 
offered by the other modules.

Schema comparison is now fully integrated with Change Manager framework and provides the same level of interface detail as 
configuration and data comparison functionality.

The following features and enhancements can be utilized via the new interface for schema 
comparison:

• Drag and drop functionality when setting up schema comparison jobs and archives.

• Quick type features to find and open jobs.

• Quick type features to find available data sources.

• Single step schema refinement.

• Larger editor spaces.
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• Simultaneous job execution.

• One-to-many option for comparison jobs.

• Job History storage for comparisons and archives saved in the system.

To start a schema comparison job

• Select File > New > Schema Comparison Job from the Main Menu.

To start a schema archive job

• Select File > New > Schema Archive Job from the Main Menu.
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Configuration Standard Enhancements
Configuration standards are specific to configuration comparison jobs and were previously stored in 
Standards Explorer. This view has been removed, and all standards are now managed and 
controlled on the interface via Project Explorer.

Project Explorer provides a view that organizes jobs, standards, and synchronization scripts into tree-
structured project folders for management and source control purposes.

Project Explorer stores configuration standards in a tree for management and source control purposes.

To explore and manage configuration standards

 Navigate to Project Explorer and expand the Standards node. All standards that are saved 
in the system are displayed by standard name. You can open a standard by double-clicking on 
the job you want to access. Additionally, when using standards in jobs, drag and drop the 
standard from Project Explorer into the appropriate source or target box.
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Source Code Control Support
Change Manager files can now be integrated and shared with source control systems such as 
Concurrent Versions System (CVS).

These systems provide a repository for project files and are aimed specifically at team programming 
and resource sharing by multiple people working in the environment. Most source control systems also 
provide versioning, and Change Manager supports this feature as well.

Source control is managed in the Navigator, a new view that provides a directory tree of XML files 
generated whenever a comparison job, standard, or archive is created or modified in Change Manager 
that contain definition values of the specified element. If a source control system has been 
implemented, these files share a common repository, and individuals working in Change Manager can 
store, update, and view files created by other members of the team.

The Navigator View provides quick access to all definition files in the system for use with source control systems when sharing 
files across a team of administrators and/or developers.

To utilize Source Control System features in Change Manager

Change Manager can be integrated with source control systems such as Concurrent Versions System (CVS) and 
Visual Source Safe (VSS).

Source control systems provide a repository for project files and are aimed specifically at team programming 
environments where developers can work on the same code simultaneously and merge it as needed. Most source 
control systems provide versioning as well, which provides backup instances of code when development 
regression is required.

Typically, a source control system repository and its associated files are updated by individual members of a 
development team as they add and modify files in the project. Work is shared in this manner as the project 
evolves, and the latest work is always available in a given project as individuals can update files from the 
specified Change Manager directory to the branch repository and vice-versa.

The Navigator provides an interface for accessing these files in the Change Manager development environment. 
Job files and archive versions are stored as XML files and synchronization scripts are stored as text, in a specified 
directory for the purpose of sharing them in some manner of third-party source control system.
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For more information regarding the implementation of source control systems, as well as the client and tool 
application software and how it integrates with Change Manager (built on the Eclipse platform framework for 
source sharing and version control systems), consult the third-party documentation provided with these plug-ins 
and/or applications.

All source code control actions much be manually performed.

Note: Change Manager 5.0 is built on the Eclipse 3.3 framework. Consequently, any source code control 
plug-in designed to work with Eclipse 3.3 can also be implemented in Change Manager 5.0.



Change Manager 5.0 New Features Guide

Data Comparison Job Enhancements
Data comparison jobs provide the ability to compare the data repositories of two specified data 
sources at the table and row levels. In Change Manager 5.0, the job creation process has been 
enhanced to provide more comprehensive results, as well as supply users with additional options for 
fine tuning the job process.

This includes:

 A high-level refinement mapping option that enables users to select a database, schema, or 
owner prior to entering the lower-level refinement process.

 New job execution and result options, including source/target row specification when running a 
comparison job, and paging options when viewing the results.

The Data Comparison Job Editor provides a number of new options, including high-level mapping refinement and new 
execution and results parameters.
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High-Level Mapping Refinements

On the Overview tab of the Data Comparison Job Editor, drop down menus have been added to the 
Source and Target boxes.

When you specify a source or target data source in these boxes and click the drop down, the menu 
populates with the owners, databases, or schema of the data source (depending on the platform). 
Choose an item from the list provided to specify mapping at a high-level. When selected, the lower-
level selections on the Mapping tab are automatically filtered to reflect your higher level choice.

The drop down menu provided beneath the Source and Target comparison boxes enables you to select an owner, schema, or 
database to filter out mapping objects at a higher level than the Mapping tab provides.

New Job Comparison Options

On the Options tab of the Data Comparison Job Editor, two new options are provided in the 
Comparison Options section:

 Check Rows from Source

 Check Rows from Target

The Check Rows from Source option enables you to specify that the job process will examine the 
rows that exist in the source tables, while the Check Rows from Target option specifies that the job 
process will examine the rows in the target tables.

If you de-select either of these options, the rows on the specified data source will not be included in 
the comparison, enabling you to define static comparisons between the two data sources.

The Comparison Options selection panel includes two new options: Check Rows from Source and Check Rows from Target.
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New Job Results Options

The Database Results tab contains a Show Rows section that contains a series of new row filtering 
parameters:

 All

 Mismatched

 Source

 Only Source

 Target

 Only Target

These options define how result rows are displayed in the results tables above. This feature enables 
you to show only the row comparisons you want to view. If you choose to generate a synchronization 
script, the system automatically generates it based on the selection you have made in the Show 
Rows option.

The Show Rows parameters enable you to specify what rows are shown after you have run a data comparison job in the results 
tables.
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Job Explorer
Job Explorer replaces the old Change Explorer view for providing an organized list of data, 
configuration, and schema jobs to explore and manage. It includes enhanced interface features and 
organizational functionality to improve comprehension and the speed at which jobs can be set up, 
managed, and viewed in the development environment.

Jobs are organized by date created, source and target platform types, last modified, last executed, job 
name, data source name, job type, and module. You can use Job Explorer when searching for jobs of 
a specific name or type.

Job Explorer is used to manage jobs in the system and enables you to quickly sort, filter, and retrieve through a variety of 
categories and options.

To use Job Explorer

 Navigate to the Job Explorer view in the workbench and click Arrange By. When you select 
a new category, the jobs are automatically re-sorted based on your selection, with each job 
categorized as a node beneath the category title in the view. You can open a job by double-
clicking its name in the window and it will automatically open in the appropriate editor.
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Data Source Explorer
Data Source Explorer now provides an Auto Detect Data Sources button for manually searching for 
data sources in pre-existing catalogs to add to Change Manager.

Similar to the autosearch function when you first install and run Change Manager, when you click the 
Auto Detect Data Sources button, Change Manager searches all available sources for data source 
definitions and then prompts you to add them to the view. This enables you to quickly and efficiently 
add new data sources to the system from a variety of different definition sources, without having to 
manually add them one at a time beyond Change Manager's initial search.

The Data Source Explorer view bar now features the Auto Detect Data Sources button, which initiates a catalog source and 
prompts you to register any newly discovered data sources to Change Manager.

To search for new data sources

 Click the  icon in Data Source Explorer. A window indicates that Change Manager is 
searching for any data source definitions in the system. If it finds any, it will prompt you and 
then automatically register your selections in the application.

In addition to Auto Detect Data Sources, Data Source Explorer also features the Import and Export 
commands, which enable you to import definition files from the Windows registry, Eclipse Data Tools 
Platform (DTP), TOAD, and other instances of Change Manager, or export the current list of registered 
data sources to a file for the import purposes on other systems.

The Import and Export commands enable you to import data source definitions from other sources, or export Change Manager's 
current registry to a source file.
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To import data source definitions from other source providers

 Highlight Data Source Explorer and select File > Import from the Main Menu. The Import 
dialog opens and prompts you through a series of options that specify the type of file to import, 
and the source provider. Complete the steps and click OK. Data Source Explorer is 
automatically populated with the new definitions from the imported file.

To export the current data source catalog

 Highlight Data Source Explorer and select File > Export from the Main Menu. The Export 
dialog opens and prompts you through a series of options that specify the type of file to export 
into, and what individual data source definitions you want to provide. Complete the steps and 
click OK. The definitions file is stored in the directory path you specified.
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Job Reporting
New file formats are provided for the generation of job reports, and options are provided for all job 
facets of schema, configuration, and data comparisons. Additionally, a Preview Report command is 
provided that enables you to open a view of the report prior to saving it for the purposes of previewing 
the information.

Jobs are created on the Results tab of the specified editor whenever you execute the job. The View 
Report command automatically opens a report of the job in a separate window that can be read on 
screen, sent to your printer, or saved to disk.

In addition to the View Report command, the Export Results command enables you to produce a 
report file in a specified file format at a directory location of your choosing.

Job Reporting commands are available on the results tabs of the schema, data, and configuration job editors.

To view a report

 When a job has executed, click View Report. A new window opens that contains the details of 
the executed job in a formatted display. Use the icon buttons at the top of the window to print, 
save, or otherwise retain the information generated by the report.

To export the results of a report

 When a job has executed, click Export Results. The Export Results dialog opens and 
provides a directory path field and file format options. Specify the directory where you want the 
report to be saved and choose its file format. Click Finish to complete the export.
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Additional Resources

Licensing Your Embarcadero Technologies Product
All Embarcadero Technologies products include a 14-day trial period. To continue using the product 
without interruption, we recommend that you license it as soon as possible. To license your product, 
use the License Request Wizard found in the Help menu of your respective product. If you have not 
yet purchased your Embarcadero Technologies product, contact sales@embarcadero.com, or 
uk.sales@embarcadero.com for sales in the EMEA region.

Embarcadero Technologies Product Support
The Embarcadero Technologies Web site is an excellent source for additional product information, 
including white papers, articles, FAQs, discussion groups, and the Embarcadero Knowledge Base. Go 
to www.embarcadero.com/resources, or click any of the links below, to find:

• Documentation  

• Online Demos  

• Technical Papers  

• Discussion Groups  

• Knowledge Base  

Embarcadero Technologies Technical Support
If you have a valid maintenance contract with Embarcadero Technologies, the Embarcadero Technical 
Support team is available to assist you with any problems you have with our applications. Our 
maintenance contract also entitles registered users of Embarcadero Technologies products to 
download free software upgrades during the active contract period. Evaluators receive free technical 
support for the term of their evaluation (14 days).

We encourage you to open technical support cases via the Technical Support request form at the 
Embarcadero Technologies Web site. For additional information about Embarcadero Technologies 
Technical Support, go to the Support page on our Web site.

Embarcadero Technologies on the Web
To download evaluations of other Embarcadero Technologies products or to learn more about our 
company and our products visit us at www.embarcadero.com.

mailto:sales@embarcadero.com
http://www.embarcadero.com/
http://www.embarcadero.com/
http://www.embarcadero.com/support/open_case.jsp
http://www.embarcadero.com/jive/index.jspa
http://www.embarcadero.com/resources/discussion_groups.html
http://www.embarcadero.com/resources/technical_papers.html
http://www.embarcadero.com/resources/online_demos.html
http://www.embarcadero.com/resources/documentation.html
http://www.embarcadero.com/resources
mailto:uk.sales@embarcadero.com
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