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Introduction to Change Manager

Embarcadero® Change Manager™ offers database administrators and developers a powerful tool to 
simplify and automate the database change management lifecycle. The schema compare and alter, 
data compare and synchronization, and configuration auditing capabilities let you report on database 
changes, roll out new releases, and troubleshoot database performance problems that result from both 
planned and unplanned changes. Change Manager supports IBM® DB2® for LUW, Microsoft® SQL 
Server, Oracle®, and Sybase®.

Product Benefits
Change Manager provides a means of simplifying and automating database change management, 
streamlining development cycles, and ensuring database performance, availability, and compliance.

Data comparison enables the creation and execution of comparison jobs between the data 
repositories of two data sources within an enterprise for the purposes of validating and keeping 
reference and test data synchronized between development, staging, testing, and production 
environments when implementing new systems, keeping lookup data stored in multiple repositories 
synchronized, troubleshooting replication issues by determining what changes need to be made 
between two data sources, ensuring the correct data has been added/removed between two data 
sources, data migration, and repository change tracking between a data source and its backup over 
time.

Configuration comparison enables the creation and execution of comparison jobs between two data 
source configuration settings. It is important to have the ability to monitor and maintain the 
configuration settings between two data sources from a database administrator perspective, in order to 
provide maximum performance and availability for each data source in the network. The management 
of configuration settings through data source comparison helps DBAs tune data source performance 
and quickly diagnose problems.

Using configuration comparison jobs, administrators can define configuration setting standards based 
on existing data sources, archives, and customized values, and run comparison jobs to ensure the 
configuration settings of data sources that compose the enterprise meet the specified requirements.

Schema comparison provides a means to manage schema changes on database platforms, for the 
purpose of identifying environment changes when databases are implemented through development, 
testing, and production cycles. Schema comparison also features archive functionality, as well as the 
ability to run comparison jobs against two or more instances of a data source.



About This Evaluation Guide

This evaluation guide is intended to help you get started with Change Manager.

After completing this guide, you will have the foundation needed to fully utilize the features and 
benefits of the product and apply them to your own enterprise.

This guide contains information on running and maintaining data, configuration, and schema 
comparison jobs, how to create and maintain standards and archives, and additional information 
related to adding, configuring, and organizing the management of data sources.

This guide is divided into five sections:

Session 1: Getting Started with Change Manager

Session 2: Running Data Comparison Jobs

Session 3: Running Configuration Comparison Jobs

Session 4: Running Schema Comparison Jobs

Session 5: Defining Batch Files for Bulk Job Execution

Once you’ve started, you can select Help from the Menu Bar to find many additional resources that 
complement and build on the features and tasks presented in this guide.



Session 1: Getting Started with Change Manager

Download, Install, and Start Change Manager
Change Manager is packaged with a 30-day trial license that activates upon installation. After the trial 
period expires, you must purchase a permanent license to continue using the product.

Launch the installation program via the MSI Installer included in the package and follow the 
instructions provided by the Installation Wizard. You may be required to restart your machine once the 
Wizard is finished. It is also recommended you copy the MSI Installer to the Desktop of the machine 
on which you are installing the software prior to running it.

The Change Manager Installation Wizard guides you through the installation process.

If this is your first time using Change Manager, you will be prompted by a message that asks if you 
want to import data sources from an existing catalog. You can choose to import them now, or at a later 
point in time via commands in the Change Manager interface.

To start Change Manager:

• From the Desktop, choose the Windows Start menu and then select Programs  > 
Embarcadero > Change Manager 5.0 > Change Manager 5.0.

User Interface Overview
The Change Manager application environment is known as the Workbench. The Workbench provides 
an interface through which you create, manage, and execute comparison jobs.



The Change Manager Workbench provides an environment to define, manage, and execute comparison jobs.

The Workbench is composed of common interface elements that provide tools to accomplish the 
creation, management, and execution of comparison jobs. These objects provide a uniform system for 
working with jobs and data sources.



The Welcome Page is the first screen you will see when you initially launch the application. This 
screen provides links to documentation and other help files/tutorials to further familiarize you with the 
product. It provides easy access to information that may be of value to new users.

• The Workbench Space is composed of Views, Editors, and the Menu Bar and Command 
Toolbar. Views and Editors are interface components that enable you to define and execute 
comparison jobs, as well as manage resources.

• The Menu Bar and Command Toolbar contain commands that execute various functional 
aspects of the application such as launching Views and Editors, navigation commands, and 
environment preference settings. The Toolbar contains icons that represent specific menu 
commands. For example, the Search command can be launched via the Search>Search 
menu in the Menu Bar, and also via the Search icon in the Command Toolbar.

• Views are Workbench interface components typically used to navigate a hierarchy of 
information, open Editors, or display the properties of various application elements. For 
example, the Datasource Explorer view provides a tree of all datasources in the environment 
and the comparison jobs associated with each. You can launch these jobs directly from 
Datasource Explorer, modify the connection properties of datasources, or create and edit 
configuration archives from this View.

• Editors are Workbench interface components typically used to access Change Manager 
functionality such as job execution. For example, the Data Comparison Editor is used to 
define and execute data comparison jobs. Editors are largely differentiated from Views in that 
they operate on an individual level rather than a supportive one.



Adding Data Sources
In order to define and run comparison jobs, you need to register data sources to be used as sources in 
the environment by providing connection information and other details to Change Manager.

Data sources are registered and managed in Data Source Explorer. Each time you register a new 
data source you need to specify its connection information and organize it in the view, as needed. 
Once a data source has been registered, it remains stored in a catalog and does not need to be re-
registered each time you open Change Manager. It can be used in multiple jobs, archived, or 
otherwise “shared” with regards to the general functionality of the application.

The Data Source Explorer  provides an organizational tree of registered data sources and the comparison jobs and archives 
associated with them.

To add a data source

1. Highlight Data Source Explorer and choose File > New > Data Source from the Menu Bar. 
The Data Source Wizard appears.

Follow the steps in the Data Source Wizard by selecting the data source platform and entering 
the appropriate connectivity parameters in the fields provided. Click OK when you are 
finished. The new data source appears in Data Source Explorer.

Note: You can also import data source definitions from other sources via the File > Import command 
in the Main Menu. Additionally, if you have other Embarcadero products installed on your machine 



already, you can click the Auto Discover Data Sources icon in Data Source Explorer and Change 
Manager will automatically add any definitions it finds to the organizational tree.



Managing Data Sources
In large enterprises where data sources exist on multiple platforms, are located in multiple physical 
locations, or serve multiple purposes or different departments, it can become unwieldy to keep data 
sources, archives, configuration standards, and individual comparison jobs organized within the 
application environment.

In Data Source Explorer, you can create folders named Data Source Groups and then drag and 
drop data sources into the appropriate folders as needed. For example, you could create a folder 
named Oracle and place all Oracle-based data sources you register in Data Source Explorer inside of 
it.

The Create Data Source Group Wizard enables you to define folders to organize data sources in Data Source Explorer.

To create Data Source Group folders and organize Data Source Explorer objects

1. Right-click on the Managed Data Sources node in Data Source Explorer.

2. Enter a meaningful name for the new group in the Name field and choose a parent folder, if 
any.

3. Click Finish. The Data Source Group folder is added to Data Source Explorer. You can 
drag and drop data sources in the folder or add new data sources to the folder, as needed.



Adding Jobs
In addition to organizing the data sources in your enterprise within the application environment, it is 
important to maintain the organization of comparison jobs, archives, and configuration standards, 
especially when maintaining a particularly large system or when jobs need to be run periodically on a 
set schedule for maintenance purposes.

When you define a new comparison job, archive, or standard, you can save the job (in any state) and 
it is automatically added to the tree in Data Source Explorer or Job Explorer. Saved jobs stored in 
these views can then be opened at a later point to be re-executed or completed.



Data Source Explorer and Job  Explorer store saved jobs so they can be reused without having to redefine the job.

To add a job

1. Create a new comparison job, archive, or standard and ensure that the specified editor is 
selected.

2. Select File > Save or File > Save All from the Menu Bar, depending on what command is 
available.

3. The job is saved and automatically added to the appropriate view, as a child of the node to 
which it applies.



Managing Jobs
In large enterprises composed of many data sources with strict configuration and data retention 
guidelines that require many jobs, archives, and standards, the organization of jobs in Data Source 
Explorer and Standards Explorer can grow unwieldy.

Data Source Explorer provides nodes that organize data source jobs and configuration archives by 
type as children of the data sources that were included in the job when it was defined, or in the case of 
archives, the data source from which the archive was defined. Additionally, Job Explorer provides a 
list of all configuration standards that have been defined in the application.

Furthermore, both views contain right-click menus that enable you to delete and rename jobs in the 
tree for organizational purposes. These menus provide easy access to organizational commands such 
as Rename and Delete in order to better help you control the contents of the Views.

The right-click menu provides commands to help you organize jobs in Data Source Explorer.

To manage jobs

1. Right-click on a job node in Data Source Explorer, or Job Explorer, respectively.

2. Choose Delete to remove the job node from the view or Rename to enter a more meaningful 
name in the field. The job will be removed from the tree altogether (and thus the application) 
or appear with your newly defined name, depending on the command you selected. The Open 
command opens the job in its respective editor, while the Run command executes the job..

Additionally, Job Explorer also provides enhanced organization functionality by providing a full history 
of all jobs defined and saved in the application. Jobs can be organized by date created, source and 
target platform type, last modified, last executed, job name, data source name, and job type. Double-
clicking on a job in the view opens it in its respective editor. Use Job Explorer when searching for 
jobs of a specific type or name.



Job Explorer enables you to organize jobs based on a variety of criteria.

To view jobs in Change Explorer

1. Navigate to Job Explorer and click Arrange By to view a list of categories by which you can 
organize the view.

2. Select a category. Job Explorer displays all jobs based on your new selection.

3. Double-click a job to open it in its respective editor. Alternatively, right-click on the job and 
select Run to execute the job immediately.



Session 2: Running Data Comparison Jobs

Data retention or synchronization between a data source and its backup repository can be a difficult 
and time-consuming job to monitor and maintain in the manual sense. Further time must be spent if 
data repositories are found to be out of synchronization and must be checked and corrected at the 
table row level to determine and correct any discrepancies between the servers. In system 
implementations, keeping data synchronized between test and production environments is also 
crucial, as is the synchronization of lookup data stored on multiple repositories, the troubleshooting of 
replication issues, and data migration confirmations when moving large amounts of data between two 
data sources during upgrade or maintenance phases.

Change Manager provides the ability to run data comparison jobs that automate much of the data 
repository comparison and correction process between a pair of data sources at the database, table, 
and row level. A data comparison job enables you to select a pair of data sources from Data Source 
Explorer, map databases and tables between your two selections for comparison purposes, and then 
execute the job. Change Manager then compares the information you provided and returns a results 
screen with details such as an overall percentage of data that matched between your selections, and 
discrepancies between the two databases in terms of data values that exist on only one of the two 
data sources.

Once a data comparison job has executed, you can then correct any synchronization issues by 
running an automated SQL script that will add missing rows and update out-of-sync values. 
Additionally, Change Manager enables you to modify the script prior to execution, and stores the script 
for later usage, as needed.



The Data Comparison Job Editor enables you to analyze and correct the data repositories of two data sources automatically.

To define and run a data comparison job:

1. Select File > New > Data Comparison Job. The Data Comparison Job Editor opens.

2. Type the name of the job in the Name field.

3. Click and drag a data source from Data Source Explorer to the Data Comparison Source 
and Data Comparison Target boxes, or click Select Data Source in the appropriate box and 
choose a data source from the dialog. You can use the drop down menus under each box to 
specify high-level mapping by choosing a database, owner, or schema from the list provided. 
This selection will affect the items that appear in the mapping table in the following step.

4. Navigate to the Mapping tab. The Data Comparison Job Editor will attempt to automatically 
map the databases and tables of the specified source and target. Manually adjust or finish 
defining incomplete mapping parameters between source and target before continuing.

5. Navigate to the Options tab and select or de-select the options in the Mapping Options 
section, as required.

6. Navigate to the Mapping tab. If you changed mapping parameters in step 5, the Editor re-
examines the source and target data sources and updates accordingly. You can manually 
adjust or finish defining incomplete mapping parameters based on the new results, as needed.



7. Select or de-select the check box beside each database pair to include or exclude specific 
pairings from the job when it runs. De-selected pairs will not be included in the comparison. 
Use the All and None commands to select all or none of the rows in the table, respectively.

8. Select a relevant pair to view the associated table mappings. Select or de-select the check 
boxes beside each table pair to include or exclude specific pairings from the job, and use the 
Edit button to further detail mapping refinements on the Columns, Comparison Key, and 
Filter dialog.

9. Navigate to the Options tab and select or de-select the Execution, Comparison, and 
Resolution options, as required to control job execution parameters.

10. Click the Run icon located in the upper right-hand corner of the tab to execute the job. The 
Results tab appears and displays the progress of the comparison job.

11. Review the job results for individual pairs by clicking the View command in the Results 
column on individual pairs. The Database Results tab shows detail results for the tables and 
rows of the selected databases.

12. Click View Report to view a report of the executed job. From the report window, you can 
save, print, or otherwise modify the report file for storage or distribution purposes.

13. To synchronize a database pair, click Generate a SQL Script and run it. Synchronization 
scripts are added to Project Explorer under the Sync Scripts node and can be run by the 
Execute SQL command in the right-click menu when the script is highlighted. The job 
automatically updates the source and target data sources to match via the insertion of 
UPDATE, INSERT, and DELETE statements on both data sources, as required.



Understanding Table Mapping
In the process of data source migration and the general upkeep and maintenance of a data source 
and its backup, databases and tables can be modified and re-defined so naming conventions no 
longer apply between two repositories that contain data. This is especially true when moving systems 
into production from a testing environment.

Data comparison jobs enable you to modify the mapping parameters of a given data comparison job 
manually by choosing to exclude paired elements or re-define those pairings altogether, from the 
database level to the row level. Customized mapping is performed on the Mapping tab of the Data 
Comparison Job Editor.

Data comparison features customized mapping for individual data comparison jobs to the row level of a pair of data sources.

To view and refine the database, table, and row mappings of a data comparison job:

1. Navigate to the Mapping tab. The Database Mapping table provides a list of paired rows at 
the database level between the source and target data sources. The % Mapped column 
indicates how much of each database that Change Manager has automatically mapped.

2. Use the check boxes to include or exclude a pair of databases from the job and/or redefine the 
mappings themselves by using the drop down menus provided in the Target column and 
select a different database.

3. To modify table mappings, double-click on a paired database row. The Table Mapping table 
populates with the table pairings for the selected databases.

4. Use the check boxes to include or exclude a pair of tables from the job and/or redefine the 
mappings themselves via drop down menus provided.

5. To view row pairings, double-click on a paired table row. The pairings appear in a new tab of 
the Data Comparison Job Editor. Mappings at this level are modified on in the Table Mapping 
table.

6. To modify row mappings, click Edit in the appropriate table row. The Columns, Comparison 
Key, and Filter dialog enables the further detailing of mapping refinements:

• The Columns and Comparison Key tab enables the mapping of columns to compare 
between the paired tables.

• The Comparison Filter tab enables you to manually insert a WHERE clause for 
execution when the job runs.



Specifying the ‘Fast Compare’ Option
The comparison of large repositories with many databases, tables, and rows can be a time consuming 
and tedious process, especially when you are required to check at the row level to ensure complete 
accuracy between a data source and its backup, or during migration procedures from testing to 
production that require optimum levels of accuracy.

Data comparison features a Compression Comparison option that enables an algorithm during the 
execution process of a job. The algorithm allows Change Manager to compare at a table level instead 
of the row level initially. Each table in a pair is assigned a value and if the values match the 
comparison process moves to the next pair of tables. If the values do not match, the process performs 
a more detailed comparison at the row level. This feature allows for a faster comparison process in 
general, without losing any accuracy during the process.

The Compression Comparison option is enabled on the Options tab of the Data Comparison Job 
Editor, but is only available on SQL Server 2005, DB2 for LUW, and Oracle platforms. Additionally, it 
requires CLR to be enabled to function correctly.

To enable Fast Compare:

• Before executing a job in the Data Comparison Job Editor, navigate to the Options tab and 
select Compression Comparison in the Execution Options section. Fast Compare is 
enabled and when the job is executed, the system will perform the comparison, as 
appropriate.



Session 3: Running Configuration Comparison Jobs

The monitoring and maintenance of configuration settings between two data sources in an enterprise 
is important to provide maximum performance and availability of each data source in the network, and 
enables DBAs to tune performance and quickly diagnose problems. However, like data comparison, 
the manual effort required to investigate and correct the configuration settings of multiple data sources 
can be a time-consuming and tedious task.

Configuration comparison provides the ability to run configuration comparison jobs that automate the 
comparison process between two data sources by examining the configuration settings of two 
specified data sources and outlining the differences between the two sets of parameters. A 
configuration comparison job enables you to select a pair of data sources from Data Source Explorer, 
refine the property comparisons prior to job execution and then run the job and view the results, 
enabling you to correct any issues you find between the pair.

Furthermore, configuration comparison jobs utilize configuration archives and standards as well as 
registered data sources. Archives provide an older snapshot of the configuration settings of a data 
source, while standards are customized sets of properties with threshold operators that allow you to 
create the ‘perfect’ configuration against which you can compare existing data source settings.

The Configuration Comparison Job Editor enables you to analyze the configuration settings of two data sources automatically.



To define and run a configuration comparison job

1. Select File > New > Configuration Comparison Job. The Configuration Comparison Job 
Editor opens.

2. Type the name of the job in the Name field.

3. Click and drag a data source or archive from Data Source Explorer to the Configuration 
Comparison Source or Configuration Comparison Target boxes, or click and drag a 
standard from Standards Explorer to the Configuration Comparison Source box. 
Alternatively, click Select Data Source in the appropriate box and choose a data source from 
the dialog.

4. Navigate to the Refinements tab and select or de-select the configuration properties in the 
table listing. De-selected properties will not be included in the comparison when the job 
executes.

5. Click the Run icon located in the upper right-hand corner of the tab to execute the job. The 
Comparison Results tab appears and displays the progress of the comparison job.

6. Review the job results once it completes on the Comparison Results tab.

7. Click View Report to view a report of the executed job. From the report window, you can 
save, print, or otherwise modify the report file for storage or distribution purposes.



Defining Configuration Standards
In many cases, it is often desirable to maintain a list of ideal configuration settings that each system in 
your enterprise should maintain, or, at minimum, fall between certain thresholds in order to maintain 
acceptable levels of performance and data retention.

A configuration standard is a configuration comparison job object that is composed of user-defined 
configuration properties (static or dynamically updated based on the source values) with customized 
values that include threshold comparison operators (greater than, less than, falls within or is a member 
of a specified set, etc.) Once defined, standards can be used in configuration comparison jobs against 
registered data sources and archives in order to determine if target data sources meet and fall within 
the specified values of the standard’s requirements.

The Standards Editor is used to define and modify configuration standards.

Standards are defined in the Project Editor. Once a standard is defined it appears in the Project 
Explorer view and contains the interface and navigation functionality of a registered data source 
object with the exception that it can only be used as a Source in comparison jobs.

To define a configuration standard

1. Select File > New > Configuration Standard. The Standards Editor opens.



2. Enter the name of the Standard in the Name field.

3. Drag and drop a data source, archive, or standard from Data Source Explorer to the 
Standard Sources table. Alternatively, use the Add Datasource and Add Archive Version 
commands beneath the table to add properties to the standard.

4. Navigate to the Standard Refinement tab and define each listed property as Linked or Static 
by clicking the appropriate row value in the Type column and choosing a selection from the 
drop down menu.

5. Define each property operator by clicking the appropriate row value in the Operator column 
and choosing a selection from the drop down menu.

6. Select File > Save or File > Save All to save the Standard. It automatically appears in 
Standards Explorer.

7. Drag and drop the new standard from Standards Explorer to the Comparison Source box in 
the Configuration Comparison Job Editor. You can now proceed to run a job using the 
standard’s properties as you would a registered data source or an archive.



Defining Configuration Archives
A snapshot of a data source’s configuration properties at various points in time is often useful for 
backup and restoration purposes as well as to monitor value slippage and otherwise preserve older 
settings that may or may not impact your enterprise in the near or far future.

An archive is a static view of a single data source’s configuration properties from a specific point in 
time. A single archive can contain multiple versions that enable you to periodically capture the property 
values of a data source over the course of time.

Archives are defined in the Archive Job Editor and appear as child nodes of the appropriate data 
source in Data Source Explorer. Once an archive is defined, its various versions can be used in 
configuration comparison jobs with data sources and configuration standards.

The Archive Job Editor is used to capture and save data source properties at a specific point in time.

To define a configuration archive

1. Right-click on a data source in Data Source Explorer and select Archive > Configuration 
from the menu. The Archive Job Editor opens.

2. Enter the name of the Archive in the Name field. 



3. Navigate to the Refinements tab and use the check boxes to select or de-select properties, 
as needed. Selected properties are included in the Archive, while de-selected properties are 
ignored.

4. Click the Run Job icon in the upper right-hand corner of the Editor. A tab named Unsaved 
Version appears containing the properties of the captured source.

5. Select File > Save. The Unsaved Version tab changes to Version 1 and Version 1 appears 
in the Archive Versions table on the Overview tab with a time stamp. You can create more 
versions by clicking the Run Job icon again.

6. Drag and drop the new archive version from Data Source Explorer to the Source or Target 
boxes in Configuration Comparison Job Editor. You can now proceed to run a job using the 
archive properties as you would a registered data source.



Session 4: Running Schema Comparison Jobs

Schema comparison supports the capture and comparison of database schema in your enterprise. 
This can be used to create a baseline of your database schema for analyzing schema and permission 
changes between the baseline and the live environment.

In order to create a baseline of your schema, you must first capture and store it. Once it has been 
captured, you can use this archive to compare it against the live environment. If needed, the schema 
comparison editor then provides the ability to synchronize the schema of a live data source with the 
archive.

The Schema Comparison Job Editor is used to compare the schema of two or more data sources in your environment.

To define a schema comparison

1. Select File > New > Schema Comparison Job in the Menu Bar. The Schema 
Comparison Job Editor opens.

Type the name of the job in the Name field. Ensure that you specify a meaningful name that 
identifies the job in other views and dialogs.



1. Click and drag a data source from Data Source Explorer to the Schema Comparison 
Source or Schema Comparison Target box, or click Select Data Source in the appropriate 
box and choose a data source from the dialog that appears. Additionally, you can add multiple 
targets by clicking Add More Targets to enable one-to-many comparison.

2. Navigate the the Refinements tab and select or de-select the objects in the table, as required. 
Selected objects are included in the comparison job, and de-selected properties are ignored 
during job execution.

3. Navigate to the Mapping tab and then click the target of the pair you want to change. You can 
use the drop down menu to redefine the schema object pairing, as needed.

4. Navigate to the Options tab to set the Alter, Compare, Decorator, and Identifier options for 
the comparison job. These options generally control how statements are built during the 
comparison process, as well as what objects will be included or excluded in the final results.

5. Click the Run icon located in the upper right-hand corner of the tab to execute the job. The 
Results tab appears and displays the progress of the comparison job.

6. Review the job results once it completes on the Comparison Results tab.

7. Click View Report to view a report of the executed job. From the report window, you can 
save, print, or otherwise modify the report file for storage or distribution purposes.

8. To synchronize the schema, click Generate a SQL Script and run it. Synchronization scripts 
are added to Project Explorer under the Sync Scripts node and can be run by the Execute 
SQL command in the right-click menu when the script is highlighted.



Defining Schema Archives
An archive is an object related to schema comparison that contains a snapshot of the schema of a 
registered data source. A schema archive is used in schema comparisons against other data sources 
and archives as a baseline to monitor data loss and inconsistencies when moving between testing and 
production environments.

Schema archives are composed of a name, description, and schema derived from a single live data 
source at a specific point in time. Additionally, archives have versioning functionality and can be 
periodically updated with the current values of an associated data source. Older versions are retained 
within an archive and can be recalled as needed.

Archives are created in the Schema Archive Job Editor, and, once saved, are organized in Data 
Source Explorer, on the Schema Archive Jobs node of the corresponding data source.

The Schema Archive Job Editor allows you to take a snapshot of data source schema at a specific point in time.

To define a schema archive

1. Enter the name of the archive in the Name field of the Archive Job Editor.

2. Drag and drop the data source to be archived from Data Source Explorer to the Schema 
Archive Source box.



3. Navigate to the Refinements tab and use the check boxes to select or de-select schema 
objects, as needed. Selected objects are included in the archive while de-selected objects are 
ignored.

4. Navigate to the Options tab and use the drop down menu to specify the DDL Extraction 
settings for the archive process. This setting defines how DDL is extracted and stored when 
the archive job runs. If you choose to store extracted DDL, the directory location of the files 
can be viewed on the History tab once archive versions have been created.

5. Click the Run Job icon in the upper right-hand corner of the screen. A version automatically 
appears in the Archive Job History table on the History tab. You can create additional 
versions of the archive by clicking Run Job as many times as needed. Each time the job is 
executed, a new version appears in the Archive Job History table.

6. If you want to create a report based on the archive job, right-click on a version and choose 
View Report. A summary report appears in a separate window that contains commands to 
print or save the report file to disk.



Session 5: Defining Batch Files for Bulk Job Execution
In scenarios where you are required to run the same jobs multiple times over a repetitive time frame 
(for example, you may be required to archive the properties of a data source on a daily basis),  it is 
desirable to set up automated tasks that execute the jobs on a regular schedule. Change Manager 
provides the ability to extract a command line executable from each job defined in the environment. 
The command line syntax can then be used to trigger a job outside the Workspace, or multiple 
executables can be contained inside a batch file and triggered at the same time.

On each tab in the editors of Change Manager, the Command Line Syntax icon provides the means 
to automatically create command line syntax for the specified job. The icon is located beside Run Job 
in the upper right-hand corner of the editor. When selected, it opens the Script Generation Wizard.

The Script Generation Wizard provides command line syntax for the specified job. 

In addition to providing the syntax needed to execute the job outside of the Change Manager 
environment, the Script Generation Wizard also enables you to generate a batch file that contains 
the specified command line. Once a batch file has been defined, multiple execution commands can be 
added to the file in order to create a script that will automatically run Change Manager bulk jobs when 
executed.



To define command line syntax and generate batch files

1. Open the job you want to define an execution script for and select the Command Line Syntax 
icon in the lower-right hand corner of any tab. The Script Generation Wizard appears.

2. Add output report options, as needed, and specify the Directory where the files will be 
generated. Click Next.

3. Specify the Location where the batch file will be generated and provide a file format for the 
script.

4. Click Finish. The batch file is generated in the directory you specified in Step 3.

5. In the Location field, specify the directory path and file name of the batch file to be generated.

6. Click Finish. The batch file is generated as defined in Step 2.

7. If you want to add multiple jobs to the batch file, generate a batch file as normal, and then 
copy the script syntax to the clipboard for each job you want to add to the batch file. You can 
then add them to the existing batch file manually.



Additional Evaluation Resources

Embarcadero Technologies Product Support
The Embarcadero Web site is an excellent source of additional product information, including white 
papers, articles, FAQs, discussion groups and the Embarcadero Knowledge Base.

Go to www.embarcadero.com/support or click any of the links below to find:

• Documentation  

• Online Demos  

• Technical Papers  

• Discussion Forums  

• Knowledge Base  

Licensing Your Embarcadero Technologies Product
All Embarcadero Technologies products include a 30-day trial period. To continue using the product 
without interruption, we recommend that you license it as soon as possible. To license your product, 
use the License Request Wizard found in the Help menu of your respective product. If you have not 
yet purchased your Embarcadero Technologies product, contact sales@embarcadero.com, or 
uk.sales@embarcadero.com for sales in the EMEA region.

Embarcadero Technologies Technical Support
If you have a valid maintenance contract with Embarcadero Technologies, the Embarcadero Technical 
Support team is available to assist you with any problems you have with the application. Our 
maintenance contract also entitles registered users of Embarcadero Technologies’ products to 
download free software upgrades during the active contract period.

To save you time, Embarcadero Technologies maintains a Knowledge Base of commonly encountered 
issues and hosts Discussion Forums that allow users to discuss their experiences using our products 
and any quirks they may have discovered.

For additional information regarding Embarcadero Technologies Technical Support, go to the Support 
page on our Web site.

Embarcadero Technologies on the Web
To download evaluations of other Embarcadero Technologies products or to learn more about our 
company and our products visit us at www.embarcadero.com.

http://www.embarcadero.com/support
http://www.embarcadero.com/
http://www.embarcadero.com/jive/forumindex.jspa
http://www.embarcadero.com/jive/kbcategory.jspa?categoryID=1
mailto:uk.sales@embarcadero.com
mailto:sales@embarcadero.com
http://www.embarcadero.com/jive/kbcategory.jspa?categoryID=1
http://www.embarcadero.com/jive/forumindex.jspa
http://www.embarcadero.com/resources/technical_papers.html
http://www.embarcadero.com/resources/online_demos.html
http://www.embarcadero.com/resources/documentation.html
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