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INTRODUCING DB CHANGE MANAGER

Embarcadero® DB Change Manager™ helps database administrators and developers to:

• Simplify and automate database change management.

• Streamline development cycles.

• Ensure availability, performance and compliance.

DB Change Manager provides comparison, synchronization, data masking, and auditing 
capabilities that let you track and report on changes, roll out new releases, and pinpoint 
problems resulting from changes at the data, schema, and database configuration levels. 

By comparing a live database to a schema or configuration “snapshot”, administrators can 
quickly identify changes and correct problems. By monitoring configuration settings, 
administrators can ensure compliance with regulatory policies and performance standards and 
maintain overall database performance and availability. 

• Key Features of DB Change Manager

• Technical Requirements

• Database Support

• Installing and Upgrading DB Change Manager

• Key Concepts of DB Change Manager

• Additional Product Information

KEY FEATURES OF DB CHANGE MANAGER

DB Change Manager provides features to help you manage databases from development to 
deployment and maintenance cycles. These features include: 

• Data Comparison and Synchronization

• Schema Comparison and Synchronization

• Database Configuration Management

• Reports, Notifications, and Change History

• Data Masking

• Source Control System Integration

For a video overview, see DB Change Manager XE.
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INTRODUCING DB CHANGE MANAGER > KEY FEATURES OF DB CHANGE MANAGER
DATA COMPARISON AND SYNCHRONIZATION 
DB Change Manager can anaylze and compare the data in two different data sources. It 
generates a SQL script that can update one data source so that it matches another. You can 
modify the SQL and run it as you wish. You can even define a comparison and synchronization 
process, called a job, and set it to run automatically. These features help you better manage 
common scenarios, such as:

• Keeping primary and backup data in sync

• Keeping up with data changes during the development and testing cycles, and later on to 
deployment environments

• Managing data migrations during upgrade activities

SCHEMA COMPARISON AND SYNCHRONIZATION
DB Change Manager can capture and compare the database schema in your enterprise. Over 
the lifecycle of a single schema, you can capture a baseline or archive schema and analyze 
changes through time. In addition, DB Change Manager generates a SQL script that can update 
a target schema so that it matches a standard. You can modify the SQL and execute it as 
needed. 

For more information, see the video demos Schema Compare with Auto-Synchronization and 
Cross-DBMS Schema Compare. The demos were made for the 5.1 release and are still relevant. 

DATABASE CONFIGURATION MANAGEMENT
In addition to schema, there are configuration settings that can vary across an enterprise. DB 
Change Manager can capture the configuration settings of a data source. You can capture a 
baseline or archive configuration and analyze changes through time. You can create a 
configuration standard that defines the norms for your enterprise and against which you can 
compare your databases. 

For more information, see the video demo Monitoring for Change. The demo was made for the 
5.1 release and is still relevant. 

REPORTS, NOTIFICATIONS, AND CHANGE HISTORY
DB Change Manager supports your data management activities with notifications when 
processes execute, reports that capture key information, and change history tracking.

For more information, see the video demo Monitoring for Change. The demo was made for the 
5.1 release and is still relevant. 
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INTRODUCING DB CHANGE MANAGER > TECHNICAL REQUIREMENTS
DATA MASKING
There are specific scenarios when you need to hide the true values of the data in a database. For 
example, during development you need to protect personal or proprietary data, yet you still 
need to work with data that accurately represents the source. By combining data synchronization 
with data masking features, such as randomization or shuffling, you can duplicate source data 
and use the masked copies in non-production or non-secure environments. 

For more information, see the video demo Data Masking. The demo was made for the 5.1 
release and is still relevant. 

SOURCE CONTROL SYSTEM INTEGRATION
You can integrate DB Change Manager with source control systems such as Concurrent Versions 
System (CVS), Visual Source Safe (VSS), or Eclipse plugins. The Navigator in DB Change 
Manager is the interface for accessing files under source control. Job files and archive versions 
are stored as XML files and synchronization scripts are stored as text files. You perform all source 
code control actions using the source control system.

For more information, see the video demo Developer Versioning Database and Code. The 
demo was made for the 5.1 release and is still relevant. 

TECHNICAL REQUIREMENTS

Before installing DB Change Manager, verify that your environment meets the following 
requirements:

• 1.2 Ghz processor

• 1 GB of RAM

• 500 MB of hard disk space (more space is recommended for large data source comparisons)

• High resolution monitor (1024 x 768), 16-bit display (or greater)

• Operating systems:

• Microsoft Windows 7 (x86-32, Win32), Windows 2008 (x86-32, Win32), Windows XP (x86-
32, Win32), Windows Vista (x86-32, Win32), or Windows Server 2003 

• Red Hat Enterprise Linux 5.0 (x86-32), GTK 2, or SuSe Linux Enterprise Server (x86) GTK+ 
2.x

• If you choose to install the Eclipse plugin version, you need: 

• Eclipse version 3.3 or newer

• Sun Java Standard Edition 5.0 Update 11 or newer
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INTRODUCING DB CHANGE MANAGER > DATABASE SUPPORT
DATABASE SUPPORT

DB Change Manager supports the following database platforms:

• IBM DB2 LUW 8.0 - 9.5

• Oracle 8i - 11g

• Microsoft SQL Server 2000, 2005, and 2008

• Sybase ASE 12.5 - 15, 15.0.1, and 15.0.2

• Firebird® 1.5, 2.0

• InterBase® 2007, 2009

DB Change Manager supports data sources that use the Unicode format.

INSTALLING AND UPGRADING DB CHANGE MANAGER

To install DB Change Manager 5.x, see Installing DB Change Manager.

To install DB Change Manager XE, see Installing DB Change Manager XE.

When needed, DB Change Manager provides an upgrade process for moving jobs and other 
information from an existing DB Change Manager installation to the new version. For 
information about upgrading, see the Read Me file at the DB Change Manager documentation 
site.

 KEY CONCEPTS OF DB CHANGE MANAGER

To use DB Change Manager most effectively, first learn about how it represents and stores 
reusable processes that help you manage your data, and the features of its user interface. 

• Understanding Jobs and Scripts in DB Change Manager

• Understanding The DB Change Manager User Interface

UNDERSTANDING JOBS AND SCRIPTS IN DB CHANGE MANAGER
DB Change Manager uses the concept of a job to organize reusable processes. A job uses 
objects of the following types:

• Data source: A data source is a data repository or database. 
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INTRODUCING DB CHANGE MANAGER > KEY CONCEPTS OF DB CHANGE MANAGER
• Configuration standard: A standard is a customized set of properties with threshold 
operators that help you create optimal configurations against which you can compare other 
data source configurations.

• Schema or configuration archive: An archive is a snapshot of a configuration or schema. 
You can use this archive to compare against other schemas or configurations. 

There are two types of jobs in DB Change Manager:

• Object creation jobs: Some jobs create objects that are used in other jobs. You use a job to 
create configuration standards and archives. 

• Comparison jobs: A comparison job processes source and target objects and provides 
information describing their similarities and differences. This comparison is then used to 
generate SQL scripts. A comparison job can be of the following types:

• Data comparison: A data comparison job looks at the data repositories of two data 
sources and determines their differences. You can use this information to determine 
whether to update a target data source.

• Data masking: A data masking job is a special kind of data comparison job that creates a 
copy of sensitive data, which masks the true values of specified fields. 

• Configuration comparison: A configuration comparison job determines whether the 
configuration settings between a source and a target are the same. This information helps 
you quickly diagnose problems. 

• Schema comparison: A schema comparison job lets you compare the schemas of 
different data sources or archives. It helps you manage schema changes through 
development, testing, and production cycles. 

Once it has run a comparison job, DB Change Manager can generate an SQL synchronization 
script that will update target data, configurations, or schemas. You can modify a script before 
you run it. For example, you can use a DB Change Manager script to synchronize data between 
development and testing environments. Once you are comfortable with the job’s specifications, 
you can let it automatically run the script and synchronize the data. 

You can group jobs and scripts into projects, which are visible in the Project explorer and in the 
Navigator view. The Navigator view provides a way to interact with files in a source control 
system. 

UNDERSTANDING THE DB CHANGE MANAGER USER INTERFACE 
The Workbench is the DB Change Manager development environment. It provides you with an 
interface to create, manage, and navigate comparison jobs through interaction with views, 
editors, and menus. If you are familiar with Eclipse you will recognize many elements of the 
interface.
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INTRODUCING DB CHANGE MANAGER > KEY CONCEPTS OF DB CHANGE MANAGER
The Welcome Page is the first screen you see when you initially launch the application. The 
screen provides links to information that may be of value to new users. 

Views help you navigate a hierarchy of information, open editors, or display the properties of 
various application elements. For example, the Data Source Explorer view provides a tree of all 
data sources in the environment and the comparison jobs associated with each. You can launch 
these jobs directly, modify the connection properties of data sources, or create and edit 
configuration archives from the view. 

Editors help you perform various tasks, such as running a job. For example, you use the Schema 
Comparison Job editor to define and execute schema comparison jobs. 

The Menu Bar and Command Toolbar options provide various functions, such as launching 
views and editors, navigating, and setting preferences. 
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INTRODUCING DB CHANGE MANAGER > ADDITIONAL PRODUCT INFORMATION
ADDITIONAL PRODUCT INFORMATION

Embarcadero Technologies web sites are an excellent source for additional product information, 
including white papers, articles, FAQs, discussion groups. Visit these sites: 

• The DB Change Manager product home page

• The Embarcadero Technologies Documentation site

• The online DB Change Manager demos 
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INTRODUCING DB CHANGE MANAGER > ADDITIONAL PRODUCT INFORMATION
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WHAT IS NEW IN DB CHANGE MANAGER 
See the DB Change Manager User Guide at http://docs.embarcadero.com/products/
change_manager/ or the online help for details about the new features.  

Changes in the 5.6/XE release include:

• Schema comparison job user interface improvements let you easily browse and filter results 
and review a summary of object types and actions before you run a sync script. These 
features also improve performance and scalability.

• You can specify how schema or configuration archive versions are kept on disk. Versions can 
be deleted based on how old they are, how many there are, or how much disk space they 
consume.

• Schema comparison jobs include new objects by default. You can modify this setting in the 
Preferences. 

• A Split reports feature breaks large reports into smaller sections and limits the number of 
objects per section. By default the number is 1000. This improves performance for very large 
reports.

• Schema comparison and archive job Refinements tab activities now perform faster. 

• In SQL Editor, if a SQL script is larger than 3 MB, it will open and a message will say that 
parsing was deactivated.

• The format in which schema comparisons are saved has changed. Use the import feature to 
import pre-5.6 schema comparison jobs. 

Changes in the 5.5.3/XE release included:

• Various bugfixes; in particular, a fix to how database platform licenses were handled by All-
Access ToolCloud

Changes in the 5.5.2/XE release included:

• You can post notification reports on a web server

Changes in the 5.5/XE release included:

• The product name “Change Manager” changed to “DB Change Manager”. 

• There is an XE version for use with Embarcadero ToolCloud.

• DB Change Manager runs on Microsoft Windows 7 (x86-32, Win32). 

DB Change Manager XE and 5.5 contain usability improvements including:

• Support for Windows Task Scheduler to schedule comparison, configuration, and schema 
jobs 

• Ability to clone schema comparison jobs 

• Ability to switch workspaces between versions of DB Change Manager 
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WHAT IS NEW IN DB CHANGE MANAGER  UPGRADING DB CHANGE MANAGER FROM PREVIOUS 
• New toolbars for Data Sources and Layout & Preferences 

• New Preference and View main menu items and an updated File menu

• Elapsed and remaining time estimates for in-progress jobs in the Results tab 

• Datasource target names are links that open the individual results of schema comparison 
jobs 

• Individual archived objects now have history, which is useful for comparisons 

• Ability to ignore selected objects and properties in a comparison job 

• Schema comparison jobs can now automatically include dependent objects for a table 

• For Oracle, the mapping page can show all users, including those without schemas in the 
target 

• Cross-platform comparison and synchronization between Firebird and InterBase 

• For SQL Server and Sybase databases:

• USE <DATABASE NAME> statements added to scripts generated by DB Change Manager

• Option to SET QUOTED IDENTIFIER ON and OFF 

• New, easier to understand icons for Compliance range preferences

• Easier to use Email Notification preferences

• Reports now include the creation date of an archive

• Quality updates for SQL scripts and schemas

DB Change Manager XE and 5.5.x contain performance enhancements including:

• Faster schema archive jobs and reports

• Option to turn off DDL in schema archive and comparison reports

• Faster automatic data synchronization jobs 

UPGRADING DB CHANGE MANAGER FROM PREVIOUS VERSIONS

The format in which schema comparisons are saved changed in release 5.6. Use the import 
feature to import pre-5.6 schema comparison jobs. 

For information about upgrading, see the Read Me file at the DB Change Manager 
documentation site.
12 DB CHANGE MANAGER XE AND 5.6 QUICK START GUIDE

http://docs.embarcadero.com/products/change_manager/
http://docs.embarcadero.com/products/change_manager/


INSTALLING DB CHANGE MANAGER

This section includes:

• Technical Requirements

• Installing DB Change Manager

• Licensing DB Change Manager

• Registering a Trial or Workstation License at Application Startup

• Registering a Workstation License after Application Startup

• Registering by Phone

 TECHNICAL REQUIREMENTS

Before installing DB Change Manager, verify that your environment meets the requirements 
listed at Technical Requirements. 

INSTALLING DB CHANGE MANAGER

To install DB Change Manager, run the installer and follow the prompts provided by the 
Installation Wizard. The notes below provide information on parts of the installation process that 
are not self-explanatory. When the installation is complete, it is advised that you review the 
ReadMe file to check if it contains any known issues or advisory notes that will affect your 
installation of the product.

LICENSING DB CHANGE MANAGER

DB Change Manager supports the following types of licenses:

• Trial licenses: A license for a time-limited, full-featured trial version of the product. You must 
register the trial license before you can use the product. For more information, see 
Registering a Trial or Workstation License at Application Startup.

• Workstation licenses: A license or set of licenses that is tied to a particular workstation. The 
product can only be used on that workstation. For more information, see Registering a 
Workstation License after Application Startup.

If you have problems registering, see Registering by Phone.
DB CHANGE MANAGER XE AND 5.6 QUICK START GUIDE 13



INSTALLING DB CHANGE MANAGER > LICENSING DB CHANGE MANAGER
REGISTERING A TRIAL OR WORKSTATION LICENSE AT APPLICATION 
STARTUP
Shortly after downloading a trial version of an Embarcadero product, you should receive an 
email from Embarcadero Technologies containing a serial number, which must be registered. 
These instructions also apply if you have purchased a product and received a serial number prior 
to running the application for the first time, or if the trial period has expired.

To register a serial number at application startup

1 Start the application. 

The Embarcadero License Registration dialog appears.

2 Copy the serial number from the email, and then paste it into the Serial Number field.

3 Enter your Embarcadero Developer Network (EDN) account credentials in the Login or 
Email and Password fields. 

If you have not previously created an EDN account, or have forgotten your password, click I 
need to create ... or I’ve lost my password.

4 Click Register.

The activation file should automatically download and install. If this does not happen, click 
the Trouble Connecting? Try Web Registration link and follow the prompts. If you still 
have problems, see Registering by Phone.

REGISTERING A WORKSTATION LICENSE AFTER APPLICATION STARTUP
The following instructions assume that you have received a workstation license by email and that 
you currently have a valid trial license. If you did not install a trial version or if the trial period has 
expired, follow the instructions in Registering a Trial or Workstation License at Application 
Startup instead.

To register a serial number after application startup

1 Click Help > Launch License Manager.

2 In the License Manager dialog, click Serial > Add.

3 Copy the serial number from the email and paste it into the Add Serial Number dialog.

4 Click OK.

5 Expand Unregistered Serial Numbers, right-click the serial number just added, and then 
click Register.

A registration dialog appears.

NOTE: The Registration Code box shows a machine-specific identifier required with other 
registration methods.
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6 Ensure that Register using Online Registration is selected.

7 Provide Developer Network credentials in the Login name or Email and Password fields.

8 Click Register.

The activation file should download and install automatically. If this does not happen, click 
the Trouble Connecting? Try Web Registration link and follow the prompts. If you still 
have problems, see Registering by Phone.

REGISTERING BY PHONE
If you have problems with either of the above procedures, you can register licenses by phone. 
You must provide the following information:

• Developer Network credentials

• The registration code displayed in the Embarcadero License Registration dialog that 
appears when you start an unlicensed application

• The product base license serial number

• The license serial numbers for any additional features you have purchased

For North America, Latin America, and Asia Pacific: call (415) 834-3131 option 2, and then follow 
the prompts. The hours are Monday to Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For Europe, Africa, and the Middle East: Call +44 (0)1628-684 494. The hours are Monday to 
Friday, 9 A.M. to 5:30 P.M. U.K. time.

After phoning in, you will receive an email containing an activation file to import into DB Change 
Manager.

To import an activation file

1 Save the activation file from the email to the desktop or to a scratch directory such as 
c:\temp.

2 From within the application, click Help > Launch License Manager.

3 Click License > Import.

4 Navigate to the directory where you saved the activation file and then double-click the 
activation file.

5 Click the Import button to import the activation file.

6 Click Finish.
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INSTALLING DB CHANGE MANAGER  XE
This section includes:

• Technical Requirements

• Installing DB Change Manager XE For ToolBox Users

• Installing ToolCloud and DB Change Manager XE For Administrators

TECHNICAL REQUIREMENTS

Before installing DB Change Manager XE, verify that your environment meets the requirements 
listed at Technical Requirements. In addition, if you will be installing the ToolCloud on the same 
machine, verify the requirements listed at ToolCloud Requirements for XE.

TOOLCLOUD REQUIREMENTS FOR XE
The ToolCloud has these minimum requirements:

• Intel Pentium III 1.2 GHz processor or higher

• 1 GB of RAM

• 100 MB of hard disk space for the ToolCloud

• At least 8 GB is recommended for the repository of initial and future product downloads

• High resolution monitor (1024 x 768), 16-bit display or greater

• Microsoft Windows XP Professional (x86-32, Win32), Microsoft Windows Server 2003, or 
Microsoft Windows Vista

• Internet Explorer 7 or later, or Mozilla Firefox

• Java Runtime Environment, version 1.5 (provided by the installer if you do not already have it 
installed)

• The ToolCloud requires ports 8005 and 9001 for Tomcat and other internal processes

INSTALLING DB CHANGE MANAGER XE FOR TOOLBOX USERS

If you are a DB Change Manager user and your System Administrator is already providing you 
with Embarcadero ToolBox, then DB Change Manager XE will become available in your ToolBox. 
Consult your System Administrator and ToolBox User Guide for details. 
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INSTALLING TOOLCLOUD AND DB CHANGE MANAGER XE FOR 
ADMINISTRATORS

This section tells you how to install Embarcadero ToolCloud, including the Embarcadero License 
Center (ELC), and get them up and running for use with DB Change Manager XE and other XE 
products.  

If you are already using the ToolCloud, go to Step 4: Setting Up Licenses in the ToolCloud.

NOTE: For complete information on using the ToolCloud, see the ToolCloud Administration 
Guide, Embarcadero License Center Administration Guide, and ToolBox User Guide, 
available from the Start menu after you install the applications. For wiki FAQs, see 
http://docwiki.embarcadero.com/AllAccess/en/Main_Page. 

Steps for installing the ToolCloud include:

• Step 1: Obtaining the ToolCloud Installer

• Step 2: Installing the ToolCloud and ELC

• Step 3: Logging in to the ToolCloud Administration Web Console

• Step 4: Setting Up Licenses in the ToolCloud

• Step 5: Named or Concurrent Licenses?

• Step 6: Setting Up Named Network Licenses in ToolCloud

• Step 7: Setting Up Named Network Users in the ELC

• Step 8: Downloading XE Applications to the Product Repository

• Step 9: Distributing the ToolBox to Product Users

• Step 10: Configuring Product Catalog Updates

• Step 11: Change the ToolCloud Administrator Password

STEP 1: OBTAINING THE TOOLCLOUD INSTALLER 
In most situations, you will receive an email containing instructions, including how to download 
the installer. 

STEP 2: INSTALLING THE TOOLCLOUD AND ELC
1 Quit all programs.

2 Launch the ToolCloud installer and click Next.

3 Read the terms of the license agreement and if you agree select I Agree and click Next.
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4 If you do not have Embarcadero License Center (ELC) installed on your machine click Next. 
Otherwise, clear the box and click Next. 

5 The ELC installer opens. Click Next.

a Select I accept the terms of the License Agreement and click Next.

b Accept the default installation folder and click Next. 

c Accept the default Typical installation and click Next.

d Install the Java VM specifically for ELC. Note: The host name of the Java VM is the name used when creating 
.slip license files for Embarcadero products.

e Accept the default Program Group for the icons and click Next. 

f Review the Summary and click Install. 

g When the installer prompts for configuration, click Next. 

h Accept the check box to enable logging in ELC and click Next.

i Select the check box to run the ELC as a Windows service and click Next. 

j The installer displays the Server Host Name and Server IP Address, which are later used by the license 
hosting site to create configuration files to manage licenses. Important: Write down this information for later 
use and click Next. 

k Select the check box to start the ELC and click Next. 

l You want to configure the Reporting Engine, so click Next. 

m The final ELC installation screen displays the directory where the application was installed. Note this for future 
reference. Click Done. The ToolCloud installer returns.

6 Accept the default installation directory and click Next. 

7 Provide a new valid listening port for network communication. Write down the port number 
for later use. 

NOTE: Do not use ports 8005 or 9001; use other port numbers. The ToolCloud uses ports 
8005 and 9001 for Tomcat and other internal processes.

8 The ToolCloud distributes products through a shared repository created during installation. 
The Installer grants read-only access rights to everyone in order to provide a shared network 
directory from which products can be distributed. Normally you should accept the default 
and click Next. If there are specific restrictions for creating share directories, you can choose 
an existing shared directory.

9 The installer is ready to install. Click Next. 

10 The installer prompts you to enable automatic updates. Important: Do not enable updates 
at this time.  You can configure this option later. Click Next.

11 Click Next to install the ToolCloud. Click Finish to complete.
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STEP 3: LOGGING IN TO THE TOOLCLOUD ADMINISTRATION WEB 
CONSOLE
1 From the machine onto which you installed the ToolCloud, open a browser and go to the 

URL:

 http://localhost/aaserver

If you gave it a port number other than 80 during installation, use:

http://localhost:<port_number>/aaserver 

2  At the top of the ToolCloud HOME page, click ADMIN. 

3 Enter your login credentials. By default, the initial login is "admin" and the password is 
"admin".  

4 Click Login. The ADMIN page opens.

STEP 4: SETTING UP LICENSES IN THE TOOLCLOUD
1 In the LICENSES menu of the ADMIN page, click Retrieve Licenses. 

2 Enter your login ID and password, as supplied to you by Embarcadero. 

3 Enter the license certificate number, as supplied to you by Embarcadero.

4 Enter the ELC host address name or IP number, as you previously noted. 
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5 Click Retrieve. 

The license or licenses will be registered with the ToolCloud and the ELC. 

STEP 5: NAMED OR CONCURRENT LICENSES?
If you have named network licenses, proceed to Steps 6 and  7. You must set up users in both 
the ToolCloud and the ELC. 

If you have concurrent network licenses, you do not need to set up specific users. When a user 
connects to the ToolCloud from the ToolBox, the ToolCloud will provide access to its concurrent 
licenses.  You can skip to Step 8.  
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STEP 6: SETTING UP NAMED NETWORK LICENSES IN TOOLCLOUD
For named network licenses, you add a user or users to the ToolCloud. 

1 On the ADMIN page, click Import Users. 

2 Select Create user. 

3 Enter a network domain and user name. 

4 If you are using All-Access licensing, select an All-Access level to match the type of license 
you want to provide to the user. If you select the default, None, then the default access level 
specified in the Current Licenses page will apply.

5 Click Create User. The ToolCloud displays the user you have created. 
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STEP 7: SETTING UP NAMED NETWORK USERS IN THE ELC
For named network licenses, you need to add the exact same user or users to the ELC as you 
added to the ToolCloud in Step 6. 

1 On the ADMIN page, click Embarcadero License Center. 

2 Enter your login credentials. By default, the initial login is "admin" and the password is 
"admin". 

3 Select Named Users. 

4 Click Add entry. 

5 Enter a user name that matches one in Step 5. 

6 Click Add.

7 Click Save to file. 
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STEP 8: DOWNLOADING XE APPLICATIONS TO THE PRODUCT 
REPOSITORY
In the ToolCloud, the ADMIN page lists products along with their status.

1 Click the name of the product you want. The Product  page opens.

2 Click Cache Product version or Cache all versions. 

STEP 9: DISTRIBUTING THE TOOLBOX TO PRODUCT USERS
Product users access software from the ToolCloud using the ToolBox. Have them follow these 
instructions, and substitute the correct values for the ToolCloud host name and port: 

1 Connect to the ToolCloud at:

      http://<serverhostname>:<portnumber>/aaserver

2 The ToolCloud HOME page lists the ToolBox. Click Download.

3 Save the ToolBox InstantOn to disk; the location depends on your browser setting.

4 After the copy completes, click Yes to launch the ToolBox. Subsequent launches will 
originate from the local machine. 

Products that are not available are grayed out in the ToolBox interface.

Click the wrench icon to configure the InstantOn launch and installation options.
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STEP 10: CONFIGURING PRODUCT CATALOG UPDATES
Set the ToolCloud behavior for obtaining product updates from Embarcadero. 

1 In the PRODUCTS menu of the ToolCloud ADMIN page, click Update Product Catalog.

2 Select the option you want for getting updates.

3 If you select Automatic or Notify..., specify the frequency and time for notifications.  

4 Click Save.  If you selected Automatic or Notify..., the NOTIFICATIONS button will display 
the number of new messages in red text.  Click NOTIFICATIONS to see the messages. 

STEP 11: CHANGE THE TOOLCLOUD ADMINISTRATOR PASSWORD
Most commonly, you will have internal policies about software passwords. Using your company 
guidelines, change the Administrator password. 

1 At the top of the ToolCloud HOME page, click CHANGE PASSWORD. 

2 Enter the new password.

3 Click Save.   

NOTE: Do not forget the Administrator password, as the system cannot recover it for you. 
Write it down and store it in a secure location. 
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DB CHANGE MANAGER QUICK START TUTORIALS

This document guides you through the key features of DB Change Manager using these step-
by-step tutorials: 

• Tutorial 1: Comparing Data

• Tutorial 2: Synchronizing Data 

• Tutorial 3: Comparing Configurations

• Tutorial 4: Defining a Configuration Standard

• Tutorial 5: Comparing and Synchronizing Schemas

• Tutorial 6: Defining a Schema Archive

• Tutorial 7: Masking Data

• Tutorial 8: Defining and Running Automated Scripts

Before you begin, identify two data sources that you can use in the tutorials. These data sources 
should not be live or mission-critical, and they should be similar in schema and data. 

TUTORIAL 1: COMPARING DATA

Data comparison jobs automate the process of comparing and correcting data between data 
sources at the database, table, and row level. You select a source and a target data source from 
Data Source Explorer, map databases and tables between the two selections, and then run the 
comparison job. 

Change Manage compares the information and returns a results screen with details including:

• An overall percentage of the data that is the same between the source and target

• Discrepancies between the two databases, such as data values that exist on only one 

Once a data comparison job has run, you can then correct any synchronization issues by running 
an automatically-generated SQL script that will add missing rows and update out-of-sync values. 
You can modify the SQL script prior to running it, and store it for future use. 

To start Change Manager

• From the Start menu, click Programs > Embarcadero Change Manager > Change 
Manager.

When DB Change Manager first starts, it prompts you to discover data sources. Click No for 
now and you will do that later in this tutorial. 
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ADDING DATA SOURCES 
In order to define and run jobs, you first register data sources by providing connection 
information and other details to DB Change Manager. Once a data source has been registered, 
it remains stored in a catalog and does not need to be reregistered each time you open DB 
Change Manager. You can use a single registered data source in multiple jobs. 

Data Source Explorer shows the registered data sources and their associated jobs, if any. 

Before registering a data source, gather the information about the repository location and 
connectivity permissions. 

To add a data source

1 Click the Discover Data Sources icon at the top of the Data Source Explorer view.

2 In the Discover Data Sources wizard, select the locations to search for data sources and 
click Next. 
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3 Select the data sources you want to add to the DB Change Manager environment and click 
Finish. 

The new data source or sources appear in the Data Source Explorer. 

Right-click on an entry to set its connection properties. 
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CREATING A DATA COMPARISON JOB
Prior to performing the following steps, make sure you have at least two data sources registered 
in DB Change Manager. Ideally these two data sources are similar in schema and content, so 
that the comparison is meaningful to you. 

To create a data comparison job in the Overview tab

1 Click File > New > Data Comparison Job. 

.

2 In the Overview tab of the Data Comparison Job editor, type the name of the job in the 
Name field. 

3 Click and drag a data source from Data Source Explorer to the Data Comparison Source 
box. 

By default, all databases in the data source are selected. If you prefer, use the pulldown to 
specify a single database. 

4 Click and drag a data source from Data Source Explorer to the Data Comparison Target 
box.

5 Click File > Save or type Ctrl-S to save the job.
30 DB CHANGE MANAGER XE AND 5.6 QUICK START GUIDE



DB CHANGE MANAGER QUICK START TUTORIALS > TUTORIAL 1: COMPARING DATA
To customize the job in the Options tab

1 Click the Options tab. 

2 In the Options tab, review the various settings available to you. In particular, select or de-
select the check boxes in the Mapping Options section.  
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To refine comparisons in the Mapping tab

1 Click the Mapping tab. 

2 Select the database you want to compare; usually they would have the same or a similar 
name.  

TIP: Use the All and None commands at the bottom of the pane to select all or none of the 
databases. 
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3 By default DB Change Manager does not show the table mappings. To see them, select the 
Inspect: Checked option. The progress bar displays in the lower right corner. Then the 
Table Mapping pane shows how and whether the tables map to each other in the two 
databases. 

The Data Comparison Job editor automatically maps and selects databases and tables 
between the source and target when it detects correspondences. It indicates when there is 
no mapping and displays information when it cannot make a match.
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• Select or de-select the check box beside each mapping, as needed. You can adjust 
incomplete mappings before running the job. Click undefined items in the Target data 
source column and use the drop down menu to map them. 

TIP: Click Filter: edit while a pair is selected to use the Columns, Comparison Key, and 
Filter dialog and further refine the mappings, such as inserting a WHERE clause.
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To specify notifiers in the Notification tab

1 Click the Notification tab.

2 In the Notification tab, select where DB Change Manager will send notifications when this 
job is run. 

To Run the Job and See the Results

1 In the upper right-hand corner, Click the Run icon. 

2 In the Results tab, the job progress bar displays and the results appear. Review the job 
results. 
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• Click the View command in the Results column on an individual pair. 

3 In the Database Results tab, review the detailed results for the tables and rows of the 
selected databases. 
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TUTORIAL 2: SYNCHRONIZING DATA

To generate and run an SQL synchronization script

1 At the bottom of the Database Results tab, click one of the radio buttons, for example, 
Mismatched, to specify the type of resolution to perform. 

2 At the lower right, click Generate an SQL Script.

3 In the SQL Editor, select the Execute Script icon to synchronize the data. 

NOTE: Executing an SQL script may change the data in your data sources. Be sure to review 
all potential changes, and read the script, before running the script. 

4 If you want to create a report, select the Results tab and click View Diff Report. 
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HIGHLIGHTED FEATURE: THE COMPRESSION COMPARISON OPTION 
Comparing large repositories with many databases, tables, and rows can be a time consuming 
and tedious process, especially when you require row-level accuracy. 

The Compression Comparison option enables an algorithm that causes the data comparison to 
initially execute at a table level instead of the row level. Each table in a pair is assigned a value 
and if the values match the comparison process moves to the next pair of tables. If the values do 
not match, the process performs a more detailed comparison at the row level. This allows for a 
faster comparison process in general, without losing any accuracy during the process. 

To enable this feature, navigate to the Options tab Execution Options section and select 
Compression Comparison. 

TUTORIAL 3: COMPARING CONFIGURATIONS

Configuration comparison jobs examine the configuration settings of two specified data sources 
and describe the differences between them. You select a pair of data sources from Data Source 
Explorer, refine the property comparisons, run the job, and view the results. Based on the results 
you can correct any issues between the pair. 

You can also compare a data source against a configuration archive or standard. Archives are a 
snapshot of the configuration settings of a data source at a point in time. Standards are 
customized sets of properties with threshold operators that help you create optimal 
configurations, against which you can compare existing data source settings. 

To define and run a configuration comparison job 

1 Select File > New > Configuration Comparison Job. 

2 In the Configuration Comparison Job editor, type the name of the job in the Name field. 

3 Drag and drop a data source from Data Source Explorer to the Configuration Comparison 
Source box.

4 Drag and drop a data source from Data Source Explorer to the Configuration Comparison 
Target box.
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5 Click the Refinements tab.

6 Keep the defaults in the Refinements tab. Click the Options tab. 

7 In the Options tab, select the Extract DDL check box. 

8 In the upper right, click the Run icon. 
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9 In the Comparison Results tab, the job progress bar displays and the results appear. Review 
the job results. 

In the Comparison Results tab, you can generate an SQL script to synchronize the 
configurations just as in Tutorial 2: Synchronizing Data.

HIGHLIGHTED FEATURE: COMPARING MULTIPLE TARGETS 
You can compare multiple target sources against a single source. In the Configuration 
Comparison Target box of the Overview tab, click the Add More Targets option. 

The box changes to a column list view, where you can drag and drop additional sources from 
Data Source Explorer to the Configuration Comparison Target box.

TUTORIAL 4: DEFINING A CONFIGURATION STANDARD

A configuration standard is composed of properties and values that you define:

• Configuration properties (static or dynamically updated based on the source values) 

• Values that include threshold comparison operators (greater than, less than, falls within or is 
a member of a specified set, etc.) 
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You can use a standard in configuration comparison jobs against data sources and archives in 
order to determine if the target conforms to the standard. A standard can only be used as a 
source in comparison jobs. 

To define a configuration standard

1 Select File > New > Configuration Standard. 

2 If prompted, select a project to use.

3 In the Standard Overview tab, enter the name of the standard in the Name field. 

4 Drag and drop a data source from Data Source Explorer to the Standard Sources table. 

5 In the Standard Refinement tab, define each listed property as Linked or Static by clicking 
the appropriate row value in the Type column and selecting from the drop down menu. 

6 Define each property operator by clicking the appropriate row value in the Operator 
column and selecting from the drop down menu. 

7 Select File > Save to save the standard. It appears in the Project Explorer. 

8 Drag and drop the new standard from Project Explorer to the Comparison Source box in 
the Configuration Comparison Job editor. You can now run a job using the standard as you 
would a registered data source. 
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TUTORIAL 5: COMPARING AND SYNCHRONIZING SCHEMAS

Once you create a baseline archive of your schema, you can compare it against the other 
schemas, even in live environments. Also, you can synchronize the schema of a data source with 
the archive using the Schema Comparison Job editor. 

To define a schema comparison job

1 Select File > New > Schema Comparison Job. 

2 In the Schema Comparison Job editor, type the name of the job in the Name field. 

3 Drag and drop a data source from Data Source Explorer to the Configuration Comparison 
Source box.

4 Drag and drop a data source from Data Source Explorer to the Configuration Comparison 
Target box.

5 Click the Mapping tab. 

6 In the Mapping tab, review the object mappings that are already set up for you. Change the 
target mappings as needed.

7 In the Options tab, select or de-select the configuration properties in the table listing. 

8 In the upper right, click the Run icon. 

9 In the Results tab, the job progress bar displays and the results appear. Review the job 
results. 

To generate and run a schema synchronization script

1 In the Results tab, click Sync All in the Resolution column of the Comparison Results table. 
DB Change Manager generates a synchronization script in the SQL Editor. 

2 Modify the script as needed, and save it using the File > Save command.

3 In the SQL Editor, select the Execute Script icon to synchronize the data. 

NOTE: Executing the SQL script will change the schema in your target data source. Be sure to 
review all potential changes and read the script, before running the script. 

4 If you want to create a report, select the Reports tab and click View Report. The report 
opens in a separate window where additional report options are available. 
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TUTORIAL 6: DEFINING A SCHEMA ARCHIVE 
A schema archive contains a snapshot of the schema of a registered data source. You compare 
schema archives against other data sources and archives to identify possible inconsistencies. 

A schema archive is generated from a single data source at a specific point in time. Like a 
configuration archive, a schema archive has versioning functionality and can be periodically 
updated with the current values of the data source. Older versions are retained and can be 
recalled as needed. 

You create a schema archive using the Schema Archive Job editor. It will be listed in the Data 
Source Explorer. 

To define a configuration archive

1 Right-click on a data source in Data Source Explorer and select Archive > Configuration 
Archive Job. 

2 In the Archive Job editor, enter the name of the archive in the Name field. 

3 Drag and drop the data source to be archived from Data Source Explorer to the 
Configuration Archive Source box. 

4 In the Refinements tab, select properties to include in the archive. 

5 In the upper right-hand corner, click the Run icon. 

6 In the Unsaved Version tab, the results appear. Review the job results. 

7 Select File > Save. The Unsaved Version tab changes to Version 1, and Version 1 with a 
times tamp appears in the Archive Versions table on the Overview tab. 

TIP: You can create more versions by clicking the Run icon again. 

8 Drag and drop the new archive version from Data Source Explorer to the Source or Target 
boxes in the Configuration Comparison Job editor. You can now run a job using the archive 
just as you would use a data source. 

TUTORIAL 7: MASKING DATA

A data masking job is a type of comparison job. You set it up just as in Tutorial 2: Synchronizing 
Data. 

You specify masking rules in the Mapping tab. 
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1 In the Table Mapping box, click View Column Mapping.

2 Click on the data Masking Rule option for the column and select from the pulldown menu 
one of the following:

• Use Default: The default masking rule as set in the Database Mapping box. 

• None: No masking will be applied.

• Randomize: Replaces characters with random other characters. 

• Shuffle: Reorders the values in different rows; for example, in a First Name column Bob, 
Ted, and Alice can change to Alice, Bob, and Ted. 

Close the window.
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3 Click File > Save  to save the job.

4 Click the Run Job icon in the upper right-hand corner.  

The Database Results tab shows the masked data.
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TUTORIAL 8: DEFINING AND RUNNING AUTOMATED SCRIPTS 
When you need to repeatedly run the same job, you can set up automated tasks that execute 
the jobs on a regular schedule. DB Change Manager helps create a command line executable 
for any job. You can run the command line executable on an ad hoc basis. You can also group 
the commands into a batch file and run them. 

To define command line syntax and generate batch files

1 Open the job for which you want to define an execution script.

2 Select the Command Line Syntax icon in the lower-right hand corner of any tab. 

3 In the Script Generation Wizard, add output report options.

4 Specify the Directory where the files will be generated. 

5 Click Next. 

6 Specify the Location where the batch file will be generated.

7 Specify the file format for the script. 

8 Click Finish. 

9 DB Change Manager generates the file and saves it to the location you specified.

If you want to add multiple jobs to the batch file, generate a batch file as normal, and then copy 
the script syntax to the clipboard for each job you want to add to the batch file. You can then 
add them to the existing batch file manually. 

ADDITIONAL DOCUMENTATION

For additional instructions and reference information about DB Change Manager, see the 
documentation at: http://docs.embarcadero.com/products/change_manager/.
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