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Introduction to Change Manager™

Embarcadero® Change Manager™ offers database administrators and developers a powerful tool to 
simplify and automate the database change management lifecycle. The schema compare and alter, 
data compare and synchronization, and configuration auditing capabilities enable you to report on 
database changes, roll out new releases, and troubleshoot database performance problems that result 
from both planned and unplanned changes. Change Manager supports IBM® DB2® for LUW, Microsoft® 

SQL Server, Oracle®, and Sybase®.

Product Benefits
Change Manager provides a means of simplifying and automating database change management, 
streamlining development cycles, and ensuring database performance, availability, and compliance. 
Data comparison enables the creation and execution of comparison jobs between the data 
repositories of two data sources within an enterprise for the purposes of validating and keeping 
reference and test data synchronized between development, staging, testing, and production 
environments when implementing new systems, keeping lookup data stored in multiple repositories 
synchronized, troubleshooting replication issues by determining what changes need to be made 
between two data sources, ensuring the correct data has been added/removed between two data 
sources, data migration, and repository change tracking between a data source and its backup over 
time.

Configuration comparison enables the creation and execution of comparison jobs between two data 
source configuration settings. It is important to have the ability to monitor and maintain the 
configuration settings between two data sources from a database administrator perspective, in order to 
provide maximum performance and availability for each data source in the network. The management 
of configuration settings through data source comparison helps DBAs tune data source performance 
and quickly diagnose problems.

Using configuration comparison jobs, administrators can define configuration setting standards based 
on existing data sources, archives, and customized values, and run comparison jobs to ensure the 
configuration settings of data sources that compose the enterprise meet the specified requirements. 
Schema comparison provides a means to manage schema changes on database platforms, for the 
purpose of identifying environment changes when databases are implemented through development, 
testing, and production cycles. Schema comparison also features archive functionality, as well as the 
ability to run comparison jobs against two or more instances of a data source.
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About This Evaluation Guide

This evaluation guide is intended to help you get started with Change Manager.

After completing this guide, you will have the foundation needed to fully utilize the features and 
benefits of the product and apply them to your own enterprise. This guide contains information on 
running and maintaining data, configuration, and schema comparison jobs, how to create and maintain 
standards and archives, and additional information related to adding, configuring, and organizing the 
management of data sources.

This guide is divided into five sections:

Session 1: Getting Started with Change Manager

Session 2: Running Data Comparison Jobs

Session 3: Running Configuration Comparison Jobs

Session 4: Running Schema Comparison Jobs

Session 5: Defining Batch Files for Bulk Job Execution

Once you’ve started, you can select Help from the Menu Bar to find many additional resources that 
complement and build on the features and tasks presented in this guide.

Additionally, this section contains a section that outlines the new features of the product.
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What’s New in Change Manager 5.1

Data Masking
Data masking is the process of securing sensitive data for testing or development purposes by 
masking or “scrambling” valid production data. It is often performed as a security or compliance 
measure that protects important information, while still providing data that represents your production 
environment for further database development operations.

Change Manager provides masking for data comparison jobs and features two masking functions: 
randomization and shuffling. Randomization inspects each value on a Source and then adds a 
corresponding new value to the Target. Shuffling randomly assigns different values between the 
source and target data sources of a job.

Auto-Synchronization for Data Comparison and Schema Comparison Jobs
New options in data comparison and schema comparison jobs can be selected that enable automatic 
synchronization of a target data source when a job is executed.

The auto-synchronization option is located on the Options tabs of Data Comparison Job Editor and 
Schema Comparison Job Editor. When selected, Change Manager automatically deletes all of the 
data on the target data source and replaces it with all of the data from the source. If this option is left 
de-selected, normal synchronization operations will be required for the job.

DBMS Unicode Support
Change Manager now fully supports data sources with Japanese, Korean, and other foreign 
characters for data, schema object names, and configuration values.

Cross-Platform Support for Schema Comparison Jobs
Cross-platform schema comparisons are now supported between Oracle and SQL Server platforms, 
as well as Sybase and SQL Server platforms for the following objects:

• Tables

• Unique Keys

• Check Constraints

• Foreign Keys

• Indexes

• Primary Keys

• Views

Project Creation and Management
The Explorer view enables you to create projects in addition to the Change Management default 
project. Subsequently, Jobs, Standards, and Synchronization Scripts can be saved to different projects 
for file organization and performance needs.

Job Notification Enhancements
Job Notification options have been expanded to include file system parameters that send notifications 
to local or network directories, and system tray parameters, that enable pop-up notifications on the 
Desktop.

To access the new notification options, from any Job Editor, click the Notifications tab.
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New History Tab on the Data Comparison Job Editor
A History tab has been added to Data Comparison Job Editor. This new tab tracks the execution 
activities of the specified job and displays information including the date of execution, host name, and 
the synchronization methods that were used each time the job was run (None, Script, or Automatic 
Synchronization.)

Enhanced Data Comparison Mapping
The Mapping tab of the Data Comparison Job Editor has been enhanced to feature high-level alters 
and warnings when invalid or incomplete mapping is detected.

Additionally, new mapping functionality enables you to set custom warning levels for criteria such as 
length mismatches, constraints on the target, and precision and scale differences.
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Session 1: Getting Started with Change Manager

Download, Install, and Start Change Manager
Change Manager is packaged with a 30-day trial license that activates upon installation. After the trial 
period expires, you must purchase a permanent license to continue using the product.

Launch the installation program via the MSI Installer included in the package and follow the 
instructions provided by the Installation Wizard. You may be required to restart your machine once the 
Wizard is finished. It is also recommended you copy the MSI Installer to the Desktop of the machine 
on which you are installing the software prior to running it.

The Change Manager Installation Wizard will guide you through the installation process.

If this is your first time using Change Manager, you will be prompted by a message that asks if you 
want to import data sources from an existing catalog. You can choose to import them now, or at a later 
point in time via commands in the Change Manager interface.

To start Change Manager:

• From the Desktop, choose the Windows Start menu and then select Programs > Em-
barcadero > Change Manager 5.0 > Change Manager 5.0.
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User Interface Overview
The Change Manager application environment is known as the Workbench. The Workbench provides 
an interface through which you create, manage, and execute comparison jobs.

The Change Manager Workbench provides an environment to define, manage, and execute comparison jobs.

The Workbench is composed of common interface elements that provide tools to accomplish the 
creation, management, and execution of comparison jobs. These objects provide a uniform system for 
working with jobs and data sources.

• The Welcome Page is the first screen you will see when you initially launch the 
application. The screen provides links to documentation, cheat sheets, and other help files 
and tutorials to further familiarize you with the product. It provides easy access to 
information that may be of value to new users.

• The Menu Bar and Command Toolbar contain commands that execute various 
functional aspects of the application, such as launching Views and Editors, navigation 
commands, and environment preference settings. The Toolbar contains icons that 
represent specific menu commands. For example, the Search command can be launched 
via the Search > Search menu in the Menu Bar, and also via the Search icon in the 
Command Toolbar.
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• Views are Workbench interface components typically used to navigate a hierarchy of 
information, open Editors, or display the properties of various application elements. For 
example, the Data Source Explorer view provides a tree of all data sources in the 
environment and the comparison jobs associated with each. You can launch these jobs 
directly, modify the connection properties or data sources, or create and edit configuration 
archives from the View.

• Editors are Workbench interface components typically used to access Change Manager 
functionality such as job execution. For example, the Data Comparison Editor is used to 
define and execute data comparison jobs. Editors are largely differentiated from Views in 
that they operate on an individual level rather than a supportive one.

10 of 35



Embarcadero Change Manager 5.1 Evaluation Guide

Adding Data Sources
In order to define and run comparison jobs, you need to register data sources to be used as sources in 
the environment by providing connection information and other details to Change Manager.

Data sources are registered and managed in Data Source Explorer. Each time you register a new 
data source you need to specify its connection information and organize it in the view, as needed.

Once a data source has been registered, it remains stored in a catalog and does not need to be 
reregistered each time you open Change Manager. It can be used in multiple jobs, archived, or 
otherwise “shared” with regards to the general functionality of the application.

Data Source Explorer provides an organizational tree of registered data sources and the comparison jobs and archives 
associated with them.

To add a data source:

1. Highlight Data Source Explorer and Choose File > New > Data Source from the Menu 
Bar. The Data Source Wizard appears.

2. Follow the steps in the Data Source Wizard by selecting the data source platform and 
entering the appropriate connectivity parameters in the fields provided. Click OK when you 
are finished. The new data source appears in Data Source Explorer.

Note: You can also import data source definitions from other sources via the File > Import command 
in the Main Menu. If you have other Embarcadero products on your machine, you can click the Auto 
Discover Data Sources icon in Data Source Explorer and Change Manager automatically adds any 
definitions it finds to the organizational tree.
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Managing Data Sources
In large enterprises where data sources exist on multiple platforms, are located in multiple physical 
locations, or serve multiple purposes or different departments, it can become unwieldy to keep data 
sources, archives, configuration standards, and individual comparison jobs organized within the 
application environment.

In Data Source Explorer, you can create folders named Data Source Groups and then drag and 
drop data sources into the appropriate folders as needed. For example, you could create a folder 
named Oracle and place all Oracle-based data sources you register in Data Source Explorer inside of 
it.

The Create Data Source Group Wizard enables you to define folders to organize data sources in Data Source Explorer.

To create Data Source Group folders and organize Data Source Explorer objects:

1. Right-click on the Managed Data Sources node in Data Source Explorer and select New > 
Data Source Group.

2. Enter a meaningful name for the new group in the Name field and choose a parent folder, if 
any.

3. Click Finish. The Data Source Group folder is added to Data Source Explorer. You can 
drag and drop data sources in the folder or add new data sources to the folder, as needed.
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Adding Jobs
In addition to organizing the data sources in your enterprise within the application environment, it is 
important to maintain the organization of comparison jobs, archives, and configuration standards, 
especially when maintaining a particularly large system or when jobs need to be run periodically on a 
set schedule for maintenance purposes.

When you define a new comparison job, archive, or standard, you can save the job (in any state) and 
it is automatically added to the tree in Data Source Explorer or Job Explorer. Saved jobs stored in 
these views can then be opened at a later point to be re-executed or completed.

Data Source Explorer and Job Explorer store saved jobs so they can be re-used without having to redefine the job.
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To add a job:

1. Create a new comparison job, archive, or standard and ensure that the specified editor is 
selected.

2. Select File > Save or File > Save All from the Menu Bar, depending on the command that is 
available.

3. The job is saved and automatically added to the appropriate view, as a child of the node to 
which it applies.
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Managing Jobs
In large enterprises composed of many data sources with strict configuration and data retention 
guidelines that require many jobs, archives, and standards, the organization of jobs in Data Source 
Explorer and Standards Explorer can grow unwieldy.

Data Source Explorer provides nodes that organize data source jobs and configuration archives by 
type as children of the data sources that were included in the job when it was defined, or in the case of 
archives, the data source from which the archive was defined. Additionally, Job Explorer provides a 
list of all configuration standards that have been defined in the application.

Furthermore, both views contain right-click menus that enable you to delete and rename jobs in the 
tree for organizational purposes. These menus provide easy access to organizational commands such 
as Rename and Delete in order to better help you control the contents of the Views.

The right-click menu provides commands to help you organize jobs in Data Source Explorer.

To manage jobs:

1. Right-click on a job node in Data Source Explorer, or Job Explorer, respectively.

2. Choose Delete to remove the job node from the view or Rename to enter a more meaningful 
name in the field. The job will be removed from the tree altogether (and thus the application) 
or appear with your newly defined name, depending on the command you selected. The Open 
command opens the job in its respective editor, while the Run command will execute it.
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Additionally, Job Explorer also provides enhanced organization functionality by providing a full history 
of all jobs defined and saved in the application. Jobs can be organized by date created, source and 
target platform type, last modified, last executed, job name, data source name, and job type.

Double-click on a job in the view to open it in its respective editor. Use Job Explorer when searching 
for jobs of a specific type or name.

Job Explorer enables you to organize jobs based on a variety of criteria.

To view jobs in Change Explorer:

1. Navigate to Job Explorer and click Arrange By to view a list of categories by which you can 
organize the view.

2. Select a category. Job Explorer displays all jobs based on your new selection.

3. Double-click a job to open it in its respective editor. Alternatively, right-click on the job and 
select Run to execute the job immediately.
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Session 2: Running Data Comparison Jobs

Data retention or synchronization between a data source and its backup repository can be a difficult 
and time-consuming job to monitor and maintain in the manual sense. Further time must be spent if 
data repositories are found to be out of synchronization and must be checked and corrected at the 
table row level to determine and correct any discrepancies between the servers. In system 
implementations, keeping data synchronized between test and production environments is also 
crucial, as is the synchronization of lookup data stored on multiple repositories, the troubleshooting of 
replication issues, and data migration confirmations when moving large amounts of data between two 
data sources during upgrade or maintenance phases. 

Change Manager provides the ability to run data comparison jobs that automate much of the data 
repository comparison and correction process between a pair of data sources at the database, table, 
and row level. A data comparison job enables you to select a pair of data sources from Data Source 
Explorer, map databases and tables between your two selections for comparison purposes, and then 
execute the job. Change Manager then compares the information you provided and returns a results 
screen with details such as an overall percentage of data that matched between your selections, and 
discrepancies between the two databases in terms of data values that exist on only one of the two 
data sources.

Once a data comparison job has executed, you can then correct any synchronization issues by 
running an automated SQL script that will add missing rows and update out-of-sync values. 
Additionally, Change Manager enables you to modify the script prior to execution, and stores the script 
for later usage, as needed.
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The Data Comparison Job Editor enables you to analyze and correct the data repositories of two data sources automatically.

To define and run a data comparison job:

1. Select File > New > Data Comparison Job. The Data Comparison Job Editor opens.

2. Type the name of the job in the Name field.

3. Click and drag a data source from Data Source Explorer to the Data Comparison Source 
and Data Comparison Target boxes, or click Select Data Source in the appropriate box to 
specify high-level mapping by choosing a database, owner, or schema from the list provided. 
This selection will affect the items that appear in the mapping table in the following step.
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4. Navigate to the Options tab and select or de-select the options in the Mapping Options 
section, as required.

5. Navigate to the Mapping tab. The Data Comparison Job Editor attempts to automatically map 
databases and tables between the source and target. Manually adjust or finish defining 
incomplete mapping parameters between the source and target before continuing.

6. To manually modify database pairings, select or de-select the check box beside each 
database pair, as needed. Use the All and None commands at the bottom of the table to 
select all or none of the rows in the table, respectively.

7. To manually modify table pairings, click the corresponding item in the Target data source 
column and define it via the drop down menu, as with database pairings. If you click Edit in the 
appropriate pairing, the Columns, Comparison  Key, and Filter dialog enables you to further 
detail mapping refinements in terms of defining table roles in the execution of the job.

8. Click the Notifications tab to specify email, file system, or system tray notifications for this job, 
as needed.

9. Click the Run icon located in the upper-right hand corner of the tab to execute the job. The 
Results tab appears and displays the progress of the comparison job.

10. Review the job results for individual pairs by clicking the View command in the Results 
column on individual pairs. The Database Results tab shows detailed results for the tables 
and rows of the selected databases.

11. Specify the type of Resolution by clicking All, Mismatched, Source, Only Source, Target, or 
Only Target.

12. Click Generate an SQL Script and then select the Execute Script icon to synchronize the 
specified data.

13. If you want to create a report, select View Report. The report opens in a separate window 
where additional report options are available.
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Understanding Table Mapping
In the process of data source migration and the general upkeep and maintenance of a data source 
and its backup, databases and tables can be modified and re-defined so naming conventions no 
longer apply between two repositories that contain data. This is especially true when moving systems 
into production from a testing environment.

Data comparison jobs enable you to modify the mapping parameters of a given data comparison job 
manually by choosing to exclude paired elements or re-define those pairings altogether, from the 
database level to the row level. Customized mapping is performed on the Mapping tab of the Data 
Comparison Job Editor.

Data comparison features customized mapping for individual data comparison jobs to the row level of a pair of data sources.

To view and refine the database, table, and row mappings of a data comparison job:

1. The mapping table provides a list of paired rows at the database and table level between the 
Source and Target data sources.

2. Use the check boxes to include or exclude pairs and/or redefine the mappings themselves by 
using the drop down menus in the target column.

3. To modify table mappings, click View Column Mapping in the appropriate selection. The 
Columns, Comparison Key, and Filter dialog enables you to further detail mapping 
refinements in terms of defining table roles in the execution of a job.

• The Columns and Comparison Key tab enables the mappings of columns to 
compare between the paired tables.

• The Comparison Filter tab enables you to manually insert a WHERE clause for 
execution when the job runs.
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Specifying the ‘Fast Compare’ Option
The comparison of large repositories with many databases, tables, and rows can be a time consuming 
and tedious process, especially when you are required to check at the row level to ensure complete 
accuracy between a data source and its backup, or during migration procedures from testing to 
production that require optimum levels of accuracy.

Data comparison features a Compression Comparison option that enables an algorithm during the 
execution process of a job. The algorithm allows Change Manager to compare at a table level instead 
of the row level initially. Each table in a pair is assigned a value and if the values match the 
comparison process moves to the next pair of tables. If the values do not match, the process performs 
a more detailed comparison at the row level. This feature allows for a faster comparison process in 
general, without losing any accuracy during the process.

The Compression Comparison job option enables an algorithm that enables Change Manager to compare at the table level 
instead of the row level, initially.

To enable fast-compare:

• Before executing a job, navigate to the Options tab and select Compression 
Comparison in the Execution Options section. Fast Compare is enabled and when 
the job executes, the system will perform the comparison, as appropriate.

21 of 35



Embarcadero Change Manager 5.1 Evaluation Guide

Session 3: Running Configuration Comparison Jobs

The monitoring and maintenance of configuration settings between two data sources in an enterprise 
is important to provide maximum performance and availability of each data source in the network, and 
enables DBAs to tune performance and quickly diagnose problems. However, like data comparison, 
the manual effort required to investigate and correct the configuration settings of multiple data sources 
can be a time-consuming and tedious task.

Configuration comparison provides the ability to run configuration comparison jobs that automate the 
comparison process between two data sources by examining the configuration settings of two 
specified data sources and outlining the differences between the two sets of parameters. A 
configuration comparison job enables you to select a pair of data sources from Data Source Explorer, 
refine the property comparisons prior to job execution and then run the job and view the results, 
enabling you to correct any issues you find between the pair.

Furthermore, configuration comparison jobs utilize configuration archives and standards as well as 
registered data sources. Archives provide an older snapshot of the configuration settings of a data 
source, while standards are customized sets of properties with threshold operators that allow you to 
create the ‘perfect’ configuration against which you can compare existing data source settings.

The Configuration Comparison Job Editor enables you to analyze the configuration settings of two data sources automatically.
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To define and run a configuration comparison job:

1. Select File > New > Configuration Comparison Job. The Configuration Comparison Job 
Editor opens.

2. Type the name of the job in the Name field.

3. Click and drag a data source or archive from Data Source Explorer to the Configuration 
Comparison Source or Configuration Comparison Target boxes, or click and drag a 
standard from Standards Explorer to the Configuration Comparison Source box. 
Alternatively, click Select Data Source in the appropriate box and choose a data source from 
the dialog.

4. Navigate to the Options tab and select or de-select the Extract DDL check box to turn this 
function on or off, respectively.

5. Navigate to the Refinements tab and select or de-select the configuration properties in the 
table listing. Selected properties are included in the comparison job, and de-selected 
properties are ignored during job execution.

6. Click the Run icon located in the upper right-hand corner of the tab to execute the job. The 
Comparison Results tab appears and displays the progress of the comparison job.

7. Review the job results once it completes on the Comparison Results tab.

8. Click the Execute icon. Change Manager executes the code on the specified data source. 
Results of the execution are displayed in the same tab or in a new tab.

9. Click View Report command on the Results tab. From the report window, you can save, 
print, or otherwise modify the report file for storage or distribution purposes.

23 of 35



Embarcadero Change Manager 5.1 Evaluation Guide

Adding Multiple Targets to a Configuration Comparison Job
The Configuration Comparison Target box enables you to add multiple comparison targets via the Add 
More Targets command. This allows you to associate multiple target data sources for comparison 
purposes against a single data source.

The Add More Targets command enables you to compare multiple targets against a single source.

To add more than one target to a configuration comparison job:

1. Click the Add More Targets command. The box changes to a column list view.

2. Drag and drop additional sources from Data Source Explorer to the Configuration 
Comparison Target box, or click the Add Archive or Add Data Source commands beneath 
the table and select the appropriate target from the dialog provided.\
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Defining Configuration Standards
In many cases, it is often desirable to maintain a list of ideal configuration settings that each system in 
your enterprise should maintain, or, at minimum, fall between certain thresholds in order to maintain 
acceptable levels of performance and data retention.

A configuration standard is a configuration comparison job object that is composed of user-defined 
configuration properties (static or dynamically updated based on the source values) with customized 
values that include threshold comparison operators (greater than, less than, falls within or is a member 
of a specified set, etc.) Once defined, standards can be used in configuration comparison jobs against 
registered data sources and archives in order to determine if target data sources meet and fall within 
the specified values of the standard’s requirements.

The Standards Editor is used to define and modify configuration standards.

Standards are defined in the Project Editor. Once a standard is defined it appears in the Project 
Explorer view and contains the interface and navigation functionality of a registered data source 
object with the exception that it can only be used as a Source in comparison jobs.

To define a configuration standard:

1. Select File > New > Configuration Standard. The Standards Editor opens.

2. Enter the name of the Standard in the Name field.
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3. Drag and drop a data source, archive, or standard from Data Source Explorer to the 
Standard Sources table. Alternatively, use the Add Data Source and Add Archive Version 
commands beneath the table to add properties to the standard.

4. Navigate to the Standard Refinement tab and define each listed property as Linked or Static 
by clicking the appropriate row value in the Type column and choosing a selection from the 
drop down menu.

5. Define each property operator by clicking the appropriate row value in the Operator column 
and choosing a selection from the drop down menu.

6. Select File > Save or File > Save All to save the Standard. It automatically appears in 
Standards Explorer.

7. Drag and drop the new standard from Standards Explorer to the Comparison Source box in 
the Configuration Comparison Job Editor. You can now proceed to run a job using the 
standard’s properties as you would a registered data source or an archive.
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Defining Configuration Archives
A snapshot of a data source’s configuration properties at various points in time is often useful for 
backup and restoration purposes as well as to monitor value slippage and otherwise preserve older 
settings that may or may not impact your enterprise in the near or far future.

An archive is a static view of a single data source’s configuration properties from a specific point in 
time. A single archive can contain multiple versions that enable you to periodically capture the property 
values of a data source over the course of time.

Archives are defined in the Archive Job Editor and appear as child nodes of the appropriate data 
source in Data Source Explorer. Once an archive is defined, its various versions can be used in 
configuration comparison jobs with data sources and configuration standards.

The Archive Job Editor is used to capture and save data source properties at a specific point in time.

To define a configuration archive:

1. Right-click on a data source in Data Source Explorer and select Archive > Configuration 
Archive Job from the menu. The Archive Job Editor opens.

2. Enter the name of the Archive in the Name field.

3. Drag and drop the data source to be archived from Data Source Explorer to the 
Configuration Archive Source box.
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4. Navigate to the Refinements tab and use the check boxes to select or de-select properties, 
as needed. Selected properties are included in the Archive, while de-selected properties are 
ignored.

5. Navigate to the Notifications tab and modify the settings, as appropriate. Email, file system, 
and system tray notification options are labeled and contained in separate sections on the 
interface.

6. Click the Run Job icon in the upper right-hand corner of the Editor. A tab named Unsaved 
Version appears containing the properties of the captured source.

7. Select File > Save. The Unsaved Version tab changes to Version 1 and Version 1 appears 
in the Archive Versions table on the Overview tab with a time stamp. You can create more 
versions by clicking the Run Job icon again.

8. Click the View Report command on the Results tab. The report opens in a new window.

9. Drag and drop the new archive version from Data Source Explorer to the Source or Target 
boxes in Configuration Comparison Job Editor. You can now proceed to run a job using the 
archive properties as you would a registered data source.
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Session 4: Running Schema Comparison Jobs

Schema comparison supports the capture and comparison of database schema in your enterprise. 
This can be used to create a baseline of your database schema for analyzing schema and permission 
changes between the baseline and the live environment.

In order to create a baseline of your schema, you must first capture and store it. Once it has been 
captured, you can use this archive to compare it against the live environment. If needed, the schema 
comparison editor then provides the ability to synchronize the schema of a live data source with the 
archive.

The Schema Comparison Job Editor is used to compare the schema of two or more data sources in your environment.

To define a schema comparison:

1. Select File > New > Schema Comparison Job in the Menu Bar. The Schema Comaprison 
Job Editor opens.

2. Enter the name of the job in the Name field of the Data Comparison Job Editor.

3. Click and drag a data source from Data Source Explorer to the Schema Comparison 
Source or Schema Comparison Target box.
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4. Navigate to the Refinements tab and select or de-select the objects in the table, as required. 
Selected objects are included in the comparison job, and de-selected properties are ignored 
during job execution.

5. If you want to re-define the object pairings, navigate to the Mapping tab and click the target of 
the pair you want to change. You can use the drop down menu to re-define the schema object 
pairing, as needed.

6. If you want to change the job options, navigate to the Options tab and modify the options, as 
needed. Options are grouped into execution, mapping, comparison, and resolution sections.

7. Navigate to the Notifications tab and modify the settings, as appropriate. Email, file system, 
and system tray notification options are labeled and contained in separate sections on the 
interface.

8. Click the Run icon located in the upper right-hand corner of the editor. The Results tab 
appears and displays the progress of the comparison job.

9. Click View Report to view a report of the executed job.

10. On the Results tab, click Sync All in the Resolution column of the Comparison Results 
table. A synchronization script is produced in another window.

11. Modify the script as needed, save it via the File > Save command, or use the commands in 
the Run menu on the Workbench toolbar to execute the script, as needed.
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Defining a Schema Archive
An archive is an object related to schema comparison that contains a snapshot of the schema of a 
registered data source. A schema archive is used in schema comparisons against other data sources 
and archives as a baseline to monitor data loss and inconsistencies when moving between testing and 
production environments.

Schema archives are composed of a name, description, and schema derived from a single live data 
source at a specific point in time. Additionally, archives have versioning functionality and can be 
periodically updated with the current values of an associated data source. Older versions are retained 
within an archive and can be recalled as needed.

Archives are created in the Schema Archive Job Editor, and, once saved, are organized in Data 
Source Explorer, on the Schema Archive Jobs node of the corresponding data source.

The Schema Archive Job Editor allows you to take a snapshot of data source schema at a specific point in time.

To define a schema archive:

1. Select File > New > Schema Archive from the Main Menu. The Schema Archive Job Editor 
opens.

2. Enter the name of the archive in the Name field of the Archive Job Editor.
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3. Drag and drop the data source to be archived from Data Source Explorer to the Schema 
Archive Source box.

4. Navigate to the Refinements tab and use the check boxes to select or de-select schema 
objects, as needed. Selected objects are included in the archive while de-selected objects are 
ignored.

5. Navigate to the Options tab and use the drop down menu to specify the DDL Extraction 
settings for the archive process. This setting defines how DDL is extracted and stored when 
the archive job runs. If you choose to store extracted DDL, the directory location of the files 
can be viewed on the History tab once archive versions have been created.

6. Navigate to the Notifications tab and modify the settings, as appropriate. Email, file system, 
and system tray notification options are labeled and contained in separate sections on the 
interface.

7. Click the Run Job icon. After saving a version, it appears in the Job History table on the 
History tab and contains various archive information such as version number, timestamp, 
DDL location, host name, and number of errors.

8. You can compare the archive version with its live source by right-clicking the Archive 
Contents table and selecting Compare. Schema Comparison Job Editor opens and 
designates the archive version and its original as the source and target data sources, 
respectively.

9. If you want to extract the DDL of the archive contents, choose Extract from the right-click 
menu.

10. To generate a report, click the History tab and then right-click on the version you want to 
create a report for. From the menu, select View Report. A summary report of the schema 
archive appears in a separate window.

11. To use the archive in a schema comparison job, click and drag the appropriate version from 
Data Source Explorer to the Source or Target box in Schema Comparison Editor.
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Session 5: Defining Batch Files for Bulk Job Execution

In scenarios where you are required to run the same jobs multiple times over a repetitive time frame 
(for example, you may be required to archive the properties of a data source on a daily basis), it is 
desirable to set up automated tasks that execute the jobs on a regular schedule. Change Manager 
provides the ability to extract a command line executable from each job defined in the environment.

The command line syntax can then be used to trigger a job outside the Workspace, or multiple 
executables can be contained inside a batch file and triggered at the same time.

On each tab in the editors of Change Manager, the Command Line Syntax icon provides the means 
to automatically create command line syntax for the specified job. The icon is located beside Run Job 
in the upper right-hand corner of the editor. When selected, it opens the Script Generation Wizard.

The Script Generation Wizard provides command line syntax for the specified job.

In addition to providing the syntax needed to execute the job outside of the Change Manage 
environment, the Script Generation Wizard also enables you to generate a batch file that contains 
the specified command line. Once a batch file has been defined, multiple execution commands can b 
added to the file in order to create a script that will automatically run Change Manager bulk jobs when 
executed.
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To define command line syntax and generate batch files:

1. Open the job you want to define an execution script for, and select the Command Line 
Syntax icon in the lower-right hand corner of any tab. The Script Generation Wizard 
appears.

2. Add output report options, as needed, and specify the Directory where the files will be 
generated. Click Next.

3. Specify the Location where the batch file will be generated and provide a file format for the 
script.

4. Click Finish. The batch file is generated in the directory you specified in Step 3.

5. In the Location field, specify the directory path and file name of the batch file to be generated.

6. Click Finish. The batch file is generated as defined in Step 2.

7. If you want to add multiple jobs to the batch file, generate a batch file as normal, and then 
copy the script syntax to the clipboard for each job you want to add to the batch file. You can 
then add them to the existing batch file manually.
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Additional Evaluation Resources

Embarcadero Technologies Product Support
The Embarcadero Web site is an excellent source of additional product information, including white 
papers, articles, FAQs, discussion groups and the Embarcadero Knowledge Base.

Go to www.embarcadero.com/support or click any of the links below to find:

• Documentation  

• Technical Papers  

• Discussion Forums  

• Knowledge Base  
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http://www.embarcadero.com/jive/kbcategory.jspa?categoryID=1
http://www.embarcadero.com/jive/forumindex.jspa
http://www.embarcadero.com/resources/technical_papers.html
http://www.embarcadero.com/resources/documentation.html
http://www.embarcadero.com/support
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