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Use DB Change Manager to:

+ Quickly roll out and reconcile database changes

+ Reveal, track, and report on database changes

Comply with database audit and reporting requirements
Protect data privacy within the database environment

+ Track changes from multiple major database platforms
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Welcome to DB Change Manager

IDERA DB Change Manager helps database administrators and developers to:

« Simplify and automate database change management.
« Streamline development cycles.
+ Ensure availability, performance, and compliance.

DB Change Manager provides comparison, synchronization, data masking, and auditing capabilities that let you
track and report on changes, roll out new releases, and pinpoint problems resulting from changes at the data,
schema, and database configuration levels.

By comparing a live database to a schema or configuration “snapshot,” administrators can quickly identify changes
and correct problems. By monitoring configuration settings, administrators can ensure compliance with regulatory
policies and performance standards and maintain overall database performance and availability.

What can you do with DB Change Manager?

This topic describes what you can do with DB Change Manager and links to more detailed information about how to
perform the tasks. In addition, DB Change Manager includes step-by- step Eclipse-style cheat sheets to help you
learn the tasks.

« Complete Commonly-performed tasks. These tasks describe basic functions and help you use DB Change
Manager most effectively. In addition, you can customize the interface using preferences. See the Preference
s reference for details.
» Registering and organizing data sources
» Creating a job report
» Scheduling a job
« Filtering data source objects
+ Searching for database objects and synchronization scripts
«+ Viewing Change History
» Exporting and importing jobs
+ Compare and synchronize data. Data Comparison jobs help you manage data changes and synchronize
changes between databases.
« Comparing data
» Synchronizing data repositories
« Compare and synchronize schemas. In DB Change Manager you can select schema objects and types,
compare them across data sources, and synchronize them to each other. You can also create a snapshot or
archive of the schema objects, to use in a comparison or to save for future reference. In addition, you can
clone schema comparison jobs to make it easier to reuse existing jobs.
« Comparing schemas, including how to clone a schema comparison job
+ Synchronizing schemas
+ Creating a schema archive
« Manage database configurations. DB Change Manager helps you keep track of database settings and
version information; such as patch levels. You can define database configuration values and ranges and then
run a configuration comparison job to check for compliance against those parameters.
« Comparing database configuration settings
+ Creating a standard for configuration settings
+ Creating a configuration archive
+ Create masked data for development environments. Protecting personally identifiable information while
having accurate data for testing can be difficult. DB Change Manager lets you create a masked copy of
production data for use during development and testing. This way the data is functionally correct and at the
same time does not compromise privacy or security.


http://wiki.idera.com/display/DCM/Preferences+reference
http://wiki.idera.com/display/DCM/Preferences+reference
http://wiki.idera.com/display/DCM/Registering+and+organizing+data+sources
http://wiki.idera.com/display/DCM/Creating+a+job+report
http://wiki.idera.com/display/DCM/Scheduling+a+job
http://wiki.idera.com/display/DCM/Filtering+data+source+objects
http://wiki.idera.com/display/DCM/User+interface+reference#Userinterfacereference-Search
http://wiki.idera.com/display/DCM/Views#Views-ViewChanges
http://wiki.idera.com/display/DCM/Exporting+and+importing+jobs
http://wiki.idera.com/display/DCM/Comparing+data
http://wiki.idera.com/display/DCM/Synchronizing+data+repositories
http://wiki.idera.com/display/DCM/Comparing+schemas
http://wiki.idera.com/display/DCM/Comparing+schemas#Comparingschemas-CloneJob
http://wiki.idera.com/display/DCM/Synchronizing+schemas
http://wiki.idera.com/display/DCM/Creating+a+schema+archive
http://wiki.idera.com/display/DCM/Comparing+database+configuration+settings
http://wiki.idera.com/display/DCM/Creating+a+standard+for+configuration+settings
http://wiki.idera.com/display/DCM/Creating+a+configuration+archive
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« Masking data
+ Automate and script jobs. You may need some jobs to run on a regular basis without using Windows Task
Scheduler (as described in Scheduling a job.) The Script Wizard lets you define scripts that run jobs, and
batch files to run multiple scripts.
+ Scheduling ajob
« Generating command line scripts


http://wiki.idera.com/display/DCM/Masking+data
http://wiki.idera.com/display/DCM/Scheduling+a+job
http://wiki.idera.com/display/DCM/Scheduling+a+job
http://wiki.idera.com/display/DCM/Automating+batch+scripts#Automatingbatchscripts-GenCLScripts
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Getting started

DB Change Manager provides features to help you manage databases from development to deployment and
maintenance cycles. These features include:

« Data comparison and synchronization

« Schema comparison and synchronization
+ Database configuration management

» Reports, notifications, and change history
+ Data masking

+ Source control system integration

Data comparison and synchronization

DB Change Manager can analyze and compare the data in two different data sources. It generates a SQL script that
can update one data source so that it matches another. You can modify the SQL and run it as you wish. You can
even define a comparison and synchronization process, called a job, and set it to run automatically. These features
help you better manage common scenarios, such as:

« Keeping primary and backup data in sync

+ Keeping up with data changes during the development and testing cycles, and later on to deployment
environments

« Managing data migrations during upgrade activities

Schema comparison and synchronization

DB Change Manager can capture and compare the database schema in your enterprise. Over the lifecycle of a single
schema, you can capture a baseline or archive schema and analyze changes through time. In addition, DB Change
Manager generates a SQL script that can update a target schema so that it matches a standard. You can modify the
SQL and execute it as needed.

Database configuration management

In addition to schema, there are configuration settings that can vary across an enterprise. DB Change Manager can
capture the configuration settings of a data source. You can capture a baseline or archive configuration and analyze
changes through time. You can create a configuration standard that defines the norms for your enterprise and
against which you can compare your databases.

Reports, notifications, and change history

DB Change Manager supports your data management activities with notifications when processes execute, reports
that capture key information, and change history tracking.

Data masking

There are specific scenarios when you need to hide the true values of the data in a database. For example, during
development you need to protect personal or proprietary data, yet you still need to work with data that accurately
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represents the source. By combining data synchronization with data masking features, such as randomization or
shuffling, you can duplicate source data and use the masked copies in non-production or non-secure environments.

Source control system integration

You can integrate DB Change Manager with source control systems such as Concurrent Versions System (CVS),
Visual Source Safe (VSS), or Eclipse plugins. The Navigator in DB Change Manager is the interface for accessing files
under source control. Job files and archive versions are stored as XML files and synchronization scripts are stored as
text files. You perform all source code control actions using the source control system.

Product requirements and database support

Type Platform Version

CPU + 1+ GHz

Random Access Memory (RAM) « 3GB

Storage Disk Space + 1GB

Operating System Microsoft Windows « 10

.
(0]

Microsoft Windows Server « 2019
« 2016
« 2012R2
« 2012
« 2008 SP1
« 2008 R2

Cloud « Amazon Elastic Compute Cloud (EC2)
« Microsoft Azure Virtual Machine (VM)

Database IBM Db2 LUW and Z/0S o 11.x*
« 10.x
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Type Platform Version

Microsoft SQL Server o Azure*
« 2019*
o 2017*
« 2016*
« 2014
« 2012 SP3
« 2008

Oracle o 21c*
o 19c*
o 18c*
« 12cR2*
+ 11gR2*
. 10g*

Sybase ASE o 16.x*
« 15X

* DB Change Manager supports only a subset of features and functions for this database version.

(® DB Change Manager supports data sources that use the Unicode format.

Eclipse plugin support
If you choose to install the Eclipse plugin version, you also need the following items:

+ Eclipse 3.6+
« Sun Java Standard Edition 6, Update 45+

Installing DB Change Manager

To install DB Change Manager on a workstation, run the installer and follow the prompts provided by the
Installation Wizard. When the installation is complete, see the ReadMe file for known issues or advisory notes that
could affect your use of the product.

Installing DB Change Manager in an AppWave environment

If you are a DB Change Manager user and your System Administrator provides you with AppWave, then your System
Administrator enables DB Change Manager in your AppWave Browser. Consult your System Administrator and the
AppWave Browser online help for details.



IDERA DB Change Manager 18.0.x Quick Start Guide

Licensing DB Change Manager

DB Change Manager supports the following types of licenses:

« Trial licenses. A license for a time-limited, full-featured trial version of the product. You must register the
trial license before you can use the product.

« Workstation licenses. A license or set of licenses that is tied to a particular workstation. The product can
only be used on that workstation.

« AppWave licenses. AppWave licenses are normally concurrent licenses managed by your System
Administrator. See your System Administrator for details.

Registering a Trial or Workstation license at application startup

Shortly after downloading a trial version of an IDERA product, you should receive an email from IDERA containing a
serial number, which must be registered. These instructions also apply if you have purchased a product and
received a serial number prior to running the application for the first time, or if the trial period expired.

To register a serial number at application startup

1. Start the application. The License Registration dialog appears.

2. Copy the serial number from the email, and then paste it into Serial Number.

3. Enter your Developer Network (EDN) account credentials in the Login, or in the Email and Password fields.
If you have not previously created an EDN account, or have forgotten your password, click I need to
create ... or ’'ve lost my password.

4. Click Register.

The activation file should automatically download and install. If this does not happen, click the Trouble
Connecting? Try Web Registration link and follow the prompts.

Registering a Workstation license after application startup

The following instructions assume that you have received a workstation license by email and that you currently
have a valid trial license. If you did not install a trial version or if the trial period has expired, follow the instructions
in Registering a Tri al or Workstation License at Application Startup instead.

To register a serial number after application startup

1. Click Help > Launch License Manager.

The License Manager dialog appears.

In the License Manager dialog, click Serial > Add.

Copy the serial number from the email, and then paste it into the Add Serial Number dialog.

Click OK.

Expand Unregistered Serial Numbers, right-click the serial number just added, and then click Register.
A registration dialog appears.

AR S

(@ The Registration Code box shows a machine-specific identifier required with other registration
methods.

6. Ensure that Register using Online Registration is selected.

Provide Developer Network credentials in the Login field, or into the Email and Password fields.

8. Click Register.
The activation file should download and install automatically. If this does not happen, click the Trouble
Connecting? Try Web Registration link and follow the prompts.

~

10
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Registering by phone

If you have problems with either of the above procedures, you can register licenses by phone. You must provide the
following information:

« Developer Network credentials;

« registration code displayed in the License Registration dialog that appears when you start an unlicensed
application;

« product base license serial number; and

« license serial numbers for any additional features purchased

For North America, Latin America, and Asia Pacific: call (415) 834-3131 option 2, and then follow the prompts.
The hours are Monday to Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For Europe, Africa, and the Middle East: Call +44 (0)1628-684 494. The hours are Monday to Friday, 9 A.M. to 5:30
P.M. U.K. time.

After phoning in, you will receive an email containing an activation file to import into DB Change Manager.
To import an activation file

1. Save the activation file from the email to the desktop or to a scratch directory such as c:\temp.
From within the application, click Help > IDERA Licensing > License Registration.

Click License > Import.

Navigate to the directory where you saved the activation file and then double-click the activation
Click the Import button to import the activation

Click Finish.

o0k wN

Key concepts of DB Change Manager

+ Understanding jobs and scripts in DB Change Manager
+ Understanding the DB Change Manager User Interface

Understanding jobs and scripts in DB Change Manager

DB Change Manager uses the concept of a job to organize reusable processes. A job uses objects of the following
types:

« Data source. A data source is a data repository or database.

« Configuration standard. A standard is a customized set of properties with threshold operators that help
you create optimal configurations against which you can compare other data source configurations.

» Schema or configuration archive. An archive is a snapshot of a configuration or schema.

You can use this archive to compare against other schemas or configurations.
There are two types of jobs in DB Change Manager:

« Object creation jobs. Some jobs create objects that are used in other jobs. You use a job to create
configuration standards and archives.

« Comparison jobs. Processes source and target objects and provides information describing their similarities
and differences. This comparison is then used to generate SQL scripts. A comparison job can be of the
following types:

11
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« Data comparison. Looks at the data repositories of two data sources and determines their
differences. You can use this information to determine whether to update a target data source.

« Data masking. A special kind of data comparison job that creates a copy of sensitive data, which
masks the true values of specified fields.

+ Configuration comparison. Determines whether the configuration settings between a source and a
target are the same. This information helps you quickly diagnose problems.

+ Schema comparison. Lets you compare the schemas of different data sources or archives. It helps
you manage schema changes through development, testing, and production cycles.

Once it has run a comparison job, DB Change Manager can generate an SQL synchronization script that can update
target data, configurations, or schemas. You can modify a script before you run it. For example, you can use a DB
Change Manager script to synchronize data between development and testing environments. Once you are
comfortable with the job’s specifications, you can let it automatically run the script and synchronize the data.

You can group jobs and scripts into projects, which are visible in the Project explorer and in the Navigator view. The
Navigator view provides a way to interact with files in a source control system.

Understanding the DB Change Manager User Interface

The Workbench is the DB Change Manager development environment. It provides you with an interface to create,
manage, and navigate comparison jobs through interaction with views, editors, and menus. If you are familiar with
Eclipse you will recognize many elements of the interface.

File Edt View Preferences Search Fun Tools Window Help

M- He ¥g BB @ £ | @ Databaze C...
Hy Data B ob E | % Navig & interbasa?_Config_Archive i) *Untitied-Data-Compar ison-Job-1
mdily 5% 7 = Dwervbew [ Options | = Mapping [ lotificstion | B History tz - N
= 1= Managed Data Sources (5) v Hﬂi:%«hﬂimtnm}uﬂw:m*ﬂmmm . 1.4
L] .-_-,*M:r{:-f.ﬂﬂEQ Servir (2 ix I E b s
b & MyGrow s ':'F‘L Steps Through Job Tasks J Job aJ.u.bl '
8- SFTeat (1) Jols Name ard Decernon
% M TORLABINTEREOL
» i TORLABINTERBOZ (iterBase9.0x|  Mome e
pntatied-Cata-Compiar ison-Job- 1

Data Sources Froject: Change Management

{ Lists Registered ] ;
[ Track Resuits n Compliance Ex[ Job Editors l

Jobh Soarces

£ » X o
Namir: TORLABINTERBOL Narm: TORLABINTERBOZ
Type: InterBase Type: IntorBase
Host: TORLABINTEREQ) Host:  TORLABINTERSOR
: ; @ Change Data Source & Change Data Source
Lists Projects e . v
and Jobs € >

> | | Overview Options Mapping Notfication History

The Welcome Page is the first screen you see when you initially launch the application. The screen provides links to
information that may be of value to new users.

12
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Views help you navigate a hierarchy of information, open editors, or display the properties of various application
elements. For example, the Data Source Explorer view provides a tree of all data sources in the environment and the
comparison jobs associated with each. You can launch these jobs directly, modify the connection properties of data
sources, or create and edit configuration archives from the view.

Editors help you perform various tasks, such as running a job. For example, you use the Schema Comparison Job
editor to define and execute schema comparison jobs.

The Menu Bar and Command Toolbar options provide various functions, such as launching views and editors,
navigating, and setting preferences.

Tutorials for DB Change Manager

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

This section guides you through the key features of DB Change Manager using the following step-by-step tutorials:

+ Tutorial 1: Comparing data

+ Tutorial 2: Synchronizing data

» Tutorial 3: Comparing configurations

+ Tutorial 4: Defining a configuration standard

+ Tutorial 5: Comparing and synchronizing schemas
+ Tutorial 6: Defining a schema archive

+ Tutorial 7: Masking data

+ Tutorial 8: Defining and running automated scripts

Tutorial 1: Comparing data

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Data comparison jobs automate the process of comparing and correcting data between data sources at the
database, table, and row level. You select a source and a target data source from Data Source Explorer, map
databases and tables between the two selections, and then run the comparison job.

DB Change Manager compares the information and returns a results screen with details including:

+ An overall percentage of the data that is the same between the source and target
« Discrepancies between the two databases, such as data values that exist on only one

Once a data comparison job has run, you can then correct any synchronization issues by running an automatically-
generated SQL script that adds missing rows and updates out-of-sync values. You can modify the SQL script prior to
running it, and store it for future use.

To start Change Manager
« Start Change Manager using the Start menu’s IDERA DB Change Manager [version] item.

When DB Change Manager first starts, it displays a Welcome screen. Review the Welcome screen options, and then
closeit.

13
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Adding data sources

In order to define and run jobs, you first register data sources by providing connection information and other details
to DB Change Manager. Once a data source has been registered, it remains stored in a catalog and does not need to
be reregistered each time you open DB Change Manager. You can use a single registered data source in multiple
jobs.

Data Source Explorer shows the registered data sources and their associated jobs, if any. Before registering a data
source, gather the information about the repository location and connectivity permissions.

To add a data source

1. Click the Discover Data Sources icon at the top of the Data Source Explorer view.
File Edit Search Run Tools Window Help

1 B ER o A @t
95 Data Source Expl s % J0b Explorer | %5 Navigator |~ B
mufR 8% 7

tere tiltar h
e T

2. Inthe Discover Data Sources wizard, select the locations to search for data sources, and then click Next.

% Discover Data Sources

Discover Data Sources
Select the locations to search for data sources.

ClPreviously registered Embarcadero data sources (Registry)
CIFile systern and network
[ClEclipse Data Tooks Platform (DTF)

CiQuest Software (TOAD)

14
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3. Select the data sources you want to add to the DB Change Manager environment, and then click Finish.

4.

% Job Explorer | & Navigator| — U]
S-S

B mud By

= = Managed Data Sources (6)
& 1= Microsoft SCL Server (2)
# 1= MyGroup
= = SFTest (1)
= 1= Microsoft SOL Server (1)

= TDM#EIHTERNL {InferBase 9.0.0.206)
# Ml TORLABINTERBOZ (InterBase 9,0.0,206)

its connection properties.

The new data source or sources appear in the Data Source Explorer.
(@ Analternative to using the Discover Data Sources wizard is to click File > New Data Source and set

In the Data Source Explorer, right-click on a data source and select Properties to work with connection

properties for the datasource.

= Properties for SFWLABOO2/TEST (SQL Server)

hype filter text Data Source Configuration
Configuration

Data Source Indexing Configuratin |advanced|
SOL Filters

Fhlta e aiinaci| 5P ARACTEST

Microsoft SOL Server
& Use a natwork library configuration
Server alias: | SFWLABDNZ\TEST

{Ciuse a direct connection

Default database: |

Security credentisls
User name:"|

Password: |

tas: \norma

[ Allow trusted connections

Dmmtﬁmmmmmpmwd}

(Test connecten | |_apely |

l . ” Cancel

15
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Prior to performing the following steps, make sure you have at least two data sources registered in DB Change

you.

To create a data comparison job in the Overview tab

1. Click File > New > Data Comparison Job.

Manager. Ideally these two data sources are similar in schema and content, so that the comparison is meaningful to

2. Use the Select a Project dialog’s Create New button to open a dialog that lets you provide a name and
location for a project for this exercise. Select the new project from the Select a Project dialog.

e Unititle 1=

Job Name and Description
Ham
Urititled-Data-Cormpar ison- Job-1

[JTrack results in Compliance Explorer

Job Sources

& Data Comparison Source

8 Select Datasource

o Owerview "rh Options 'F‘a- Mapping L- Hotification 'F- History

Froject: Change Management

3 Step 1: Select a source and target to compare and name the job

it Create or Modify a Data Comparison Job

& Data Comparison Target
Marre:;

Type:
Host:

CEL=]

3. Inthe Overview tab, type the name of the job in the Name field.
4. Click and drag a data source from Data Source Explorer to the Data Comparison Source box.
By default, all databases in the data source are selected. If you prefer, use the menu to specify a single

database.

5. Click and drag a data source from Data Source Explorer to the Data Comparison Target.
6. Click File > Save or type Ctrl+S to save the job.

To customize the job in the Options tab

16
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B> Overview 5= Options | > Mapping | B Hotitcation b isory

¥ Step Z Customize the comparisen and mapping (paiving) of taldes and columns

* Execution Options
[ Automatically Synchronize

O Compression Comparison
With &

WO

[ Generate Dt

= Mapping Options

[lignore Case
- :

Clear all data on the target and replace it with all data from the source automaticatly. If unchecked,

ripts. This will disable tradking results n
e significant way you will need o rerepect the pair,

% option enabled data on your datasources &8 compressed before being transmitted 1o the
!":l_':"l _=|:T.| Compangd. In certan siators data COMPressiin &
faster rate by removing the need to transfer and compare large volurmes of data

|

Automatically output the synchronizabion DL resulting from job execution, This DL file can then

npliarce

e the job torun at a rmuch

[ael
] @ |

mwmlapmﬁ:’wappmwuftamniuw;r

2.
boxes in the Mapping Options section.

In the Options tab, review the various settings available to you. In particular, select or de- select the check

= Mapping Options
[Fllgnore Caze

Dratabaees

owners, tables and colurnns will be pai
"PRODUCT _PRICES"

[Fl1gnoce Spaces
Pairs database objects for Corparsor

ched the tablke "Product Prices”

Clignore Underscores

Pairs database objects for

QNOring spaces N their

will b

Clinchude views

you wish o inchude in the comparison,

CEnchude Computed Cokimis

r s without regands to case. For

example, with this option salected the tabke "Product_Prices" will be

nanmes, Fof
g paired with the table "ProductPrice

COFfRaE 0N ignoring underscores in ther names.
option selected the table "Product_Prices" will be pared with the table "FroductPrices"

Enable this option to nclude views in the mapping. Ctherwize, views will be filtered out of the mapping
arnd will not be compared. Mote that with this option enabled, you may still sslect which views (if any)

Enable this option to exclude from mapping (and cormparson) the colurmns whose values are computed.

paired with table

axample, with this option

For gxamgie, with this

L
To refine comparisons in the Mapping tab

+ Click the Mapping tab.

17
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+ Select the databases you want to compare; usually they have the same or a similar name.

PO oS 50
B Overview | Options | = Mapping | B> lotification | b= History @ =) &
¥ Step ¥z Pair databases, schemas, owners, table s, and columns between the source and target =< back npest >>

+ Database Mapping

TORLABSOLOO_3 TORLABSOLOO_1
rnaster master Source: pubs
rriockz| rrodel Target: pubs
rresc rrscl

= oA Northwind Inspected: [Mot Inspected]

= pubs pubs Inspect: All | Qurrent | Checked

] Sake0s [Unirnapped ]
tempch tempab * Refresh Databases
i [Unmapped] * Remap to Defaults

(%l : )

Select: All , None

* Tabile Mapping
The selected pair has not yet been irspected, Would you like o inspect the table and column pairs in these objects?
S g, rafrieve the ohiects in this pair
£ ¥

i e ——— - e

Overview Options Mapping Notification History

W

@ Use the Alland None commands at the bottom of the pane to select all or none of the databases.

+ By default, DB Change Manager does not show the table mappings. To see them, select the Inspect:
Checked option on the right side of the Database Mapping pane. The progress bar displays in the lower
right corner. The Table Mapping pane shows how and whether the tables map to each other in the two

databases.
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=Tm

[ Overview | [ Options | [ Mapping | [> Hotification | > History | Q\:’ =) &
L& M!:P;M--:m:ﬁ«-.uﬂ--.:;dm- htlrnnﬂn source and target =< back npest >>
T LT O TWIN T I - T ;:]
= 40 pubs pubs Irspect: All | Current | Checkad
[] Salesl [Unmapped]
tempdn tempdn ¥ Refrech Datshases
= 555555 [Unmapped] » Rermap to Defaults
& i y (3 |
Select: All , Hone
= Table Mapping
TORLABSOLO0_3 pubrs TORLABSQLOO_ 1.4
O M oo APFTEST [Unmapped] Source:
i B0 @O doo.authors [ dbo.authors Target:
O 0 dbo.azsx [Urimappe=d)
I doo.azss_hzecff7 [Uriirapped] Columns:
O [ dbo.blob [Unmapped)
0 dbo.ca [Urimapped)
El-E I dbo.cCa [Unmapped)] Flker:
O @il O dodscounts [ dbo.discounts :
= @8 @ dooemployes [ dboemployes .er
cA nm | [N A e i s
] | 2
Creerview | Options | Mapping | Motification | History

The Data Comparison Job Editor automatically maps and selects databases and tables between the source
and target when it detects correspondences. It indicates when there is no mapping and displays information
when it cannot make a match.

« Table Mapping
TORLABSOLOO0_3. pubs TORLABSQLOO_15 & _

O 0 dooca [Unrnapped] Source: dbo.publishers
HES dho.Ca [Urirnapped ] | Target: dbo.publishers
D@l O doodiscounts M dbo.discourts | - B
“ .. B8 @ don.employes I dboemplyes Columns: 5/5 o 5/5
M. B1 @ wojobs I dbo.jobs :
Wi @ dbonewtablel [Unmapped] i b gy
. 00 @ dopib_nb M dbo.pub_nfo -~
I | | dho. publehers [ dho.publishers il wil
[0 &The following ermors have been found:
0 Table or View can not be ool if there is no column selected as ison
0O M doo.simpleTestTaleld_eSddffic?  [Unmapped]
il []'] Il dbo.stores [ dbostores
aj M doostudents_aCk1 [Unmapped]
- L B A S I ' Lt n b Ll —in ma ! T b e, mmamamd T L)

£ | 2]

Select: All , None

+ Select or de-select the check box next to each mapping, as needed. You can adjust incomplete mappings
before running the job. Click undefined items in the Target data source column and use the drop down
menu to map them.
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(@ Click Filter: edit while a pair is selected to use the Columns, Comparison Key, and Filter dialog and further
refine the mappings, such as inserting a WHERE clause.

To specify notifiers in the Notification tab
1. Click the Notification tab.

Lt - LSO Crar 50

B Owerview | [ Options | > Mapping | [ Notification | [ History w =) &

¥ Step & Turn on and customize notifications for when the job runs << hack FINESH

= Email Notifier

[ClEnabile Email Motifier

Enabile thiz Notifier to see its settings here.
= Fila System Naotifier

[ClEnable File Systern Motifier

Enable this Notifier o s2e its settings here.
= System Tray Notifier

[Censble System Tray Motifier
Ensble this Notifier to see its settings here.

Owerview | Options | Mapping | Motification History
2. Inthe Notification tab, select where DB Change Manager sends notifications when this job is run.

To run the job and see the results

1. Click the Run Job icon located in the upper-right side of the window.

) (=)

The Results tab displays the job progress bar and the results, when available.
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2. Click View in the Results column to view information for an individual pair.
) "Date Compere - Torlshsglln 2 51 =

B Notification | g Higtory | o Resulie | Datsbaee Resulis ?\_ﬁj -

= Overview | p Options | > Mapping

Oose results

+ Resolts Owverview - activation

E‘ Seufce: actlv... |Tarpet: activation [Matched Cnly in torlabegl... | Saly in TORLAE... |Differant o SaUrce 1%
tho.actwation_key cho.achwaton_key 0 1] a 1] 1] o
|dbo.activation k.. cbo.actvation k.. D a a 0 0
tho.actwation_k... cho.achwation k... 0 a i} ] i
tho.activation_... dho.acivation ... D a a 1] 1]

| eho.capadity the.canacity = e 0 i 0 0 =
£ | ¥

|Z} view DiffReport  [2] Euport Diff Aesuits.

= Seplected Table

o0 | oo |
=
L e
-
-
=
-E
Sel=ct All

showrows: (53 al imematched O Source ) Onlysource ) Target (3 Orly target

[®=5] Ganarate a 5L Sopt

Overview | Cptions |Manping |Motificstion | Hstory | Results | Database Reaults |

3. Inthe Database Results tab, review the detailed results for the tables and rows of the selected databases.

Tutorial 2: Synchronizing data

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

To generate and run an SQL synchronization script

1. Atthe bottom of the Database Results tab of a database comparison job, click one of the radio buttons, such
as Mismatched, to specify the type of resolution to perform.
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2. Atthe lower right, click Generate an SQL Script.
=t Syrc dorlansglD0_2 Apr 27, 2008 4 55 20 PMl.sgl i3
¥ ) Micosoft SOL S=rver ¥ S tordebegl1a_2(3.0.2039.0) k[ perf_anca

Emkareaders Change Manager SV
-- DATE Az 27

SOURCE DATA S0URCE remlabarbarclBlL
CREATE TAELE ddd.TESTINDULTIMA

gdfgfd numeric HOLL,
2dfgd numeric MULL

go

0T NHULL

' IS W

SIF GEJECT ID(N'ddd
PRINT M'<<< CREZ
E

PRINT H'<<<

-]

EL

FATLED CBEARTING TAELE GdGd.TEST

(= ]=]

[MA

IDERA DB Change Manager 18.0.x Quick Start Guide

LINOUL Y 1N

arrow, to synchronize the data.

your data sources. Be sure to review all potential

3. Inthe SQL Editor, click the Execute SQL icon, the green
® Executing an SQL script may change the data in
changes, and read the script, before running the script.
4,

Highlighted Feature: The Compression Comparison

Comparing large repositories with many databases, tables, an
especially when you require row-level accuracy.

The Compression Comparison option enables an algorithm th
table level instead of the row level. Each table in a pair is assig

If you want to create a report, select the Database Results tab, and then click View Diff Report.

Option

d rows can be a time consuming and tedious process,

at causes the data comparison to initially execute at a
ned a value and if the values match the comparison

process moves to the next pair of tables. If the values do not match, the process performs a more detailed
comparison at the row level. This allows for a faster comparison process in general, without losing any accuracy

during the process.

[Jcompression Comparison
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To enable this feature, navigate to the Options tab > Execution Options section, and then select Compression
Comparison.

Tutorial 3: Comparing configurations

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Configuration comparison jobs examine the configuration settings of two specified data sources and describe the
differences between them. You select a pair of data sources from Data Source Explorer, refine the property
comparisons, run the job, and view the results. Based on the results you can correct any issues between the pair.

You can also compare a data source against a configuration archive or standard. Archives are a snapshot of the
configuration settings of a data source at a point in time. Standards are customized sets of properties with

threshold operators that help you create optimal configurations; against which you can compare existing data
source settings.

To define and run a configuration comparison job

1. Select File > New > Configuration Comparison Job. If prompted to select a project, select the project you
created earlier.

2. Type the name of the job in the Name field.
3. Dragand drop a data source from Data Source Explorer to the Configuration Comparison Source box.
4. Dragand drop a data source from Data Source Explorer to the Configuration Comparison Target box.
5. Click the Refinements tab.
ity *Unititied-Data-Compar ison-Job-1 = *TestingConfigComparel
B Owernview | [ Refinements | b Options | B Notification | [ History E~r} - _r_..f:l
¥ Step 2 Select the configuration properties to compare =< hack peat >>

Configuration Property Refinement
::"lueas-e salect from the properties below those that you would like to dheck in your configuration comparison job.

Property Type Description
# [«] B SOL Server Yiersion Informiation
# [v] & Core SQL Properties

£ »

Owerview | Refinements  Options | Notification | History

6. Keep the defaults in the Refinements tab.
7. Click the Options tab.
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8. Inthe Options tab, select the Extract DDL check box.

B Overvlew | B Refinements | [> Options | B Notification | b= History U - )
¥ Step 3 Customize the job with the settings listed below << haeh  peEEt >
Make thess the defaults for new jobs Restore defaults

= DOL Extract Options

Extract DOL

9. Click the Run Job icon.
10. Inthe Comparison Results tab, the job progress bar displays and the results appear. Review the job results.

ity *Unitited-Dats-Comparison-Job-1 | 28 *TestingConfigComparal [

B Owerview | B Refinements | [ Options | B Notification | B History | [ Comparison Results @ =) &

Close results
Comparison Summary Resalution
. Generate a SOL Script
Source: [l TORLABSQUOS_1 Target: G TORLABSQLOO_3

¥ 53 Properties Malched 58.9% B al
¥ 12 Properties Did Mot Match 13.3%
I 25 Properties Not Found 27.8%

5 View Report L] Export Results .,

Comparison Results
Property = Source Op TORLABSOLOD_= o~
| s e b n a1} ¥ n e

Owerview Refinements | Options |Notification History Comparison Results

In the Comparison Results tab, you can generate an SQL script to synchronize the configurations just as in
Tutorial 2: Synchronizing data.

Highlighted feature: Comparing multiple targets

You can compare multiple target sources against a single source. In the Configuration Comparison Target box of the
Overview tab, click the Add More Targets option. The box changes to a column list view, where you can drag and
drop additional sources from Data Source Explorer to the Configuration Comparison Target box.

Tutorial 4: Defining a configuration standard

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.
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A configuration standard is composed of properties and values that you define:

« Configuration properties (static or dynamically updated based on the source values)
+ Values thatinclude threshold comparison operators (greater than, less than, falls within or is a member of a
specified set, etc.)

You can use a standard in configuration comparison jobs against data sources and archives in order to determine if
the target conforms to the standard. A standard can only be used as a source in comparison jobs.

To define a configuration standard

Select File > New > Configuration Standard.

If prompted, select a project to use.

In the Overview tab, enter the name of the standard in the Name field.

Drag and drop a data source from Data Source Explorer to the Standard Sources table.
i *Unitithed-Data-Compar ison-Job-1 b * TestingConfioCompared [ *ConfigStandardl i

bk N =

w Owerview .r“ Fefinement
E Create or Modify a Configuration Standard

Standard Name and Description

MName MNotes
ConfigStandardl

Fropct: ConfigCompare 1

Standard Sources

ersion
| | TORLABSOLOD 3 Microsoft SOL Server ...

Hostname: TORLABSOLOD_3
Typa: Linked

%] ¥
COrarview | Refinement

5. Inthe Refinement tab, define each listed property using the Source, Operator, and Value controls.
6. Select File > Save to save the standard. It appears in the Project Explorer.

You can subsequently drag and drop the new standard from Project Explorer to the Comparison Source box in the
Configuration Comparison Job Editor. You can then run a job using the standard as you would use a registered data
source.

Tutorial 5: Comparing and synchronizing schemas

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Once you create a baseline archive of your schema, you can compare it against the other schemas, even in live
environments. Also, you can synchronize the schema of a data source with the archive using the Schema
Comparison Job editor.

To define a schema comparison job
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Select File > New > Schema Comparison Job and if prompted, select a project.

In the Schema Comparison Job editor, type the name of the job in the Name field.

Drag and drop a data source from Data Source Explorer to the Schema Comparison Source box.

Drag and drop a data source from Data Source Explorer to the Schema Comparison Target box.

Click the Mapping tab.

In the Mapping tab, review the object mappings that are already set up for you. Change the target mappings
as needed.

In the Options tab, select or de-select the configuration properties.

Click the Run Job icon.

9. Inthe Comparison Results tab, the job progress bar displays and the results appear. Review the job results.

ok wpnH

© N

To generate and run a schema synchronization script

1. Inthe Comparison Results tab, click Generate Sync Script in the Resolution column of the Comparison
Results table. DB Change Manager generates a synchronization script in the SQL Editor.

2. Modify the script as needed, and save it using the File > Save command.

3. Inthe SQL Editor, select the Execute SQL icon to synchronize the data.

(® Executing the SQL script changes the schema in your target data source. Be sure to review all
potential changes and read the script before running it.

4. If you want to create a report, click Generate Report. The Export dialog opens and provides additional
report options.

Tutorial 6: Defining a schema archive

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

A schema archive contains a snapshot of the schema of a registered data source. You compare schema archives
against other data sources and archives to identify possible inconsistencies.

A schema archive is generated from a single data source at a specific point in time. Like a configuration archive, a
schema archive has versioning functionality and can be periodically updated with the current values of the data
source. Older versions are retained and can be recalled as needed.

You create a schema archive using the Schema Archive Job editor. Once created and saved, it is listed in the Data
Source Explorer.

To define a schema archive

1. Right-click on a data source in Data Source Explorer and select Archive > Schema Archive Job. Select a

project, if prompted.

In the Archive Job editor, enter the name of the archive in the Name field.

3. Inthe Refinements tab, narrow the job down by selecting owners, object types, and specific objects to
include.

4. Click the Run Job icon.

5. Inthe New Unsaved Version tab, the results appear. Review the job results.

6. Click File > Save. The Unsaved Version tab changes to Version 1, and Version 1 appears in the Datasource
Explorer tab under the datasource you chose.

N

(® You can create more versions by clicking the Run Job icon again.

You can subsequently drag and drop the new archive version from Data Source Explorer to the Source or Target
boxes in the Schema Comparison Job editor. You can now run a job using the archive just as you would use a data
source.
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Tutorial 7: Masking data

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Data masking is a way of securing sensitive data during the development or testing phases of a database
development project. It is often performed as a security or compliance measure that protects important
information. By masking valid production data, you can provide a copy of the data that is “scrambled” but still
represents your production environment.

To mask data

1. Select File > New > Data Comparison Job and if prompted, select a project.

2. Provide a name of the job in the Name field and then drag and drop datasources from the Data Source
Explorer to the Data Comparison Source and Data Comparison Target boxes.

3. Inthe Options tab, ensure that Automatically Synchronize is selected and read the description shown for
that option.

4. Inthe Mapping tab, select a row corresponding to a matching database pair in the Database Mapping box,
and then select Yes retrieve the objects in this pair.

= Table Mapping

TORLABSOLOS 1 Frankhma TORLABSOLOS 2.F
v if] O doo.Address [ dbo.Address | Source: dbo.Address
< .. 11 T dbo.Category [ dooCategary | yarget: dbo.Address
¥ 1] O doo.Customer [ dbo.Customer
w ] T doo.Customer_Address [ dboCustomer ¢ Columns: 7/7 to 77
o 1] O dbo.Customer_Order [0 dbo.Customer_t .
» 1] I dbo.Customer_Order_Product [ dbo.Customer_t Yiewr Cohumn Magoing
. i 4 dbo.Product Il dbo.Product Default Masking Rule:
% ] T doo.Ref_Address_Type M dboRef_hddres | o e r
¥ . Bl T doo.Supplier [ dooSuppler | | EEEEEEEL L
&poly to All
Columns: No Masking
Filter: edit
<.l >/ [no filer]

Select: All , None
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In the Table Mapping box, click View Column Mapping.

Columns and Filter &3
| |Tw:ue |C|:|Iumr'| |Ma5l<ir‘|q Rule |C|:|Iumr‘| |Tﬁ.fr:|e

o [g) Address 1ID Mone v Address 1D | int

o it Address Type ID Mone w Address Type... v int

v varchar  Steet 1 EREElgE=] | % | Steet 1 warchar
W varchar Steet 2 Use Default v Steet 2 w  warchar
o varchar  City Use Default  » City w | yarchar
o char State se Default v State | char

[ char Zin Use Default v Zip w  char
Select: All , None

Columns | Filter

Click on the Data Masking Rule option for a column and select one of the following:
+ Use Default. The default masking rule as set in the Database Mapping box.
+ None. No masking is applied.
« Randomize. Replaces characters with other random characters.
« Shuffle. Reorders the values in different rows; for example, in a First Name column, Bob, Ted, and
Alice can change to Alice, Bob, and Ted.
Close the window.
Continue to experiment with selection and settings until you are comfortable with masking options.
Click File > Save to save the job.
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10. Click the Run Job icon.

[Talrins = to I *Untitlad-Data-Comparison-lob-1 XN
B Overview | = Options | b= Mapping | B Hotification | B+ History | b= Results | = Database Results U -
-~
Closg regults
» Results Overview - Franklyna
[Source: Fran... [~ Tarnet: Fra... [Matrhed [Only in TORL... [Only in TORL... [Different R
doo.Category  dbo.Catenory D 16 0 o 0 (o
dbo.Custorer dbo.Customer O o o = 348 [0 [
4| ¥

2 view Diff Report [ Bxport Diff Reayits

= Selected Table

I TORLARSOLOS 1.Frankhma.dbo.Customer [ TORLARSCLOS 2 Frarkhma. dbo.Customer

. |Customer I [First Name  [Last Nara! =2 [ [Customer ID [First Name  [Last Nars
74 James Battiste ' 734 et iessfrmst
735 Sarmual Fhilpott Fa 735 Jacigh Frwiztioc
736 Mioel Afra .0 735 ol Eaae
737 Gaston Amesoui 737 Okaybx Oaseghe] .

< | ) w0 (<] >

Cverview | Options | Mapping | Notification History | Results | Database Results
The Database Results tab shows the masked data.

Tutorial 8: Defining and running automated scripts

© Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

When you need to repeatedly run the same job, you can set up automated tasks that execute the jobs on a regular
schedule. DB Change Manager helps create a command line executable for any job. You can run the command line
executable on an ad hoc basis. You can also group the commands into a batch file and run them.

To define command line syntax and generate batch files

Open the job for which you want to define an execution script.

Select the Command Line Syntax icon in the upper right of any tab.

In the Script Generation Wizard, add output report options.

Specify the Directory where the files are generated.

Click Next.

Specify the Location where the batch file is generated.

Specify the file format for the script.

Click Finish.

DB Change Manager generates the file and saves it to the location you specified.

PN WD

If you want to add multiple jobs to the batch file, generate a batch file as normal, and then copy the script syntax to
the clipboard for each job you want to add to the batch file. You can then add them to the existing batch file
manually.
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