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INTRODUCING DB CHANGE MANAGER

Introducing DB Change Manager

IDERA DB Change Manager™ helps database administrators and developers to:
¢ Simplify and automate database change management.
e Streamline development cycles.
e Ensure availability, performance, and compliance.

DB Change Manager provides comparison, synchronization, data masking, and auditing
capabilities that let you track and report on changes, roll out new releases, and pinpoint
problems resulting from changes at the data, schema, and database configuration levels.

By comparing a live database to a schema or configuration “snapshot,” administrators can
quickly identify changes and correct problems. By monitoring configuration settings,
administrators can ensure compliance with regulatory policies and performance standards and
maintain overall database performance and availability.

e Key Features of DB Change Manager

e Technical Requirements

e Database Support

e |Installing and Upagrading DB Change Manager

e Key Concepts of DB Change Manager

e Additional Product Information

Key Features of DB Change Manager

DB Change Manager provides features to help you manage databases from development to
deployment and maintenance cycles. These features include:

e Data Comparison and Synchronization

e Schema Comparison and Synchronization

e Database Configuration Management

e Reports, Notifications, and Change History

e Data Masking

e Source Control System Integration

For video overviews, see the DB Change Manager product demos.
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Data Comparison and Synchronization

DB Change Manager can analyze and compare the data in two different data sources. It
generates a SQL script that can update one data source so that it matches another. You can
modify the SQL and run it as you wish. You can even define a comparison and synchronization
process, called a job, and set it to run automatically. These features help you better manage
common scenarios, such as:

e Keeping primary and backup data in sync

e Keeping up with data changes during the development and testing cycles, and later on to
deployment environments

e Managing data migrations during upgrade activities

Schema Comparison and Synchronization

DB Change Manager can capture and compare the database schema in your enterprise. Over
the lifecycle of a single schema, you can capture a baseline or archive schema and analyze
changes through time. In addition, DB Change Manager generates a SQOL script that can update a
target schema so that it matches a standard. You can modify the SQL and execute it as needed.

For more information, see the video demos Schema Compare with Auto-Synchronization and
Cross-DBMS Schema Compare. The demos were made for the 5.1 release and are still relevant.

Database Configuration Management

In addition to schema, there are configuration settings that can vary across an enterprise. DB
Change Manager can capture the configuration settings of a data source. You can capture a
baseline or archive configuration and analyze changes through time. You can create a
configuration standard that defines the norms for your enterprise and against which you can
compare your databases.

For more information, see the video demo Monitoring for Change. The demo was made for the
5.1 release and is still relevant.

Reports, Notifications, and Change History

DB Change Manager supports your data management activities with notifications when
processes execute, reports that capture key information, and change history tracking.

For more information, see the video demo Monitoring for Change.
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Data Masking

There are specific scenarios when you need to hide the true values of the data in a database. For
example, during development you need to protect personal or proprietary data, yet you still need
to work with data that accurately represents the source. By combining data synchronization with
data masking features, such as randomization or shuffling, you can duplicate source data and use
the masked copies in non-production or non-secure environments.

For more information, see the video demo Data Masking. The demo was made for the 5.1
release and is still relevant

Source Control System Integration

You can integrate DB Change Manager with source control systems such as Concurrent Versions
System (CVS), Visual Source Safe (VSS), or Eclipse plugins. The Navigator in DB Change Manager
is the interface for accessing files under source control. Job files and archive versions are stored
as XML files and synchronization scripts are stored as text files. You perform all source code
control actions using the source control system.

For more information, see the video demo Developer Versioning Database and Code. The
demo was made for the 5.1 release and is still relevant

Requirements

NOTE: For the most recent list of requirements and supported database platforms, see the DB Change
Manager Tech Specs online at www.idera.com/database-change-management/systemrequirements.

Before installing DB Change Manager, verify that your environment meets the following
requirements:

e 1 GHz or faster CPU

e 3GBof RAM

e 1 GB of free disk space (more space is recommended for large data source comparisons)
e 1024 x 768 dispay

e Operating systems:

0 Microsoft Windows 10, Microsoft Windows 8.1, Microsoft Windows 8, Microsoft
Windows 7 (32-bit and 64-bit)

0 Microsoft Windows Server 2012 & 2012 R2, Microsoft Windows Server 2008 SP1 &
2008 R2

If you choose to install the Eclipse plugin version, you need:
e Eclipse version 3.6 or newer

e Sun Java Standard Edition 6 Update 45 or newer
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Database Support

NOTE: For the most recent list of requirements and supported database platforms, see the DB Change
Manager Tech Specs online at www.idera.com/database-change-management/systemrequirements.

DB Change Manager supports the following database platforms:
e |IBM DB2 for LUW 9-10.x and 11.x*
e Oracle 9i, 10g*, 11*, and 12c*
e  Microsoft SQL Server 2008, 2012*, 2014*, and 2016*
e Sybase ASE 12.x, 15.x, and 16.x*

*  For these databases, DB Change Manager supports a subset of this database version’s
features and functions.

DB Change Manager supports data sources that use the Unicode format.

Installing and Upgrading DB Change Manager

To install DB Change Manager, see Installing DB Change Manager.

When needed, DB Change Manager provides an upgrade process for moving jobs and other
information from an existing DB Change Manager installation to the new version. For information
about upgrading, see the Read Mefile at the DB Change Manager documentation site.

Key Concepts of DB Change Manager

To use DB Change Manager most effectively, first learn about how it represents and stores
reusable processes that help you manage your data, and the features of its user interface.

e Understanding Jobs and Scripts in DB Change Manager

e Understandingthe DB Change Manager User Interface

Understanding Jobs and Scripts in DB Change Manager

DB Change Manager uses the concept of a job to organize reusable processes. A job uses
objects of the following types:

e Data source: A data source is a data repository or database.

e Configuration standard: A standard is a customized set of properties with threshold
operators that help you create optimal configurations against which you can compare
other data source configurations.

e Schema or configuration archive: An archive is a snapshot of a configuration or schema.

You can use this archive to compare against other schemas or configurations.
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There are two types of jobs in DB Change Manager:

e Object creation jobs: Some jobs create objects that are used in other jobs. You use a job
to create configuration standards and archives.

e Comparison jobs: A comparison job processes source and target objects and provides
information describing their similarities and differences. This comparison is then used to
generate SQL scripts. A comparison job can be of the following types:

e Data comparison: A data comparison job looks at the data repositories of two data
sources and determines their differences. You can use this information to determine
whether to update a target data source.

e Data masking: A data masking job is a special kind of data comparison job that creates a
copy of sensitive data, which masks the true values of specified fields.

¢ Configuration comparison: A configuration comparison job determines whether the
configuration settings between a source and a target are the same. This information helps
you quickly diagnose problems.

e Schema comparison: A schema comparison job lets you compare the schemas of
different data sources or archives. It helps you manage schema changes through
development, testing, and production cycles.

Once it has run a comparison job, DB Change Manager can generate an SQL synchronization
script that can update target data, configurations, or schemas. You can modify a script before you
run it. For example, you can use a DB Change Manager script to synchronize data between
development and testing environments. Once you are comfortable with the job’s specifications,
you can let it automatically run the script and synchronize the data.

You can group jobs and scripts into projects, which are visible in the Project explorer and in the
Navigator view. The Navigator view provides a way to interact with files in a source control
system.

Understanding the DB Change Manager User Interface

The Workbench is the DB Change Manager development environment. It provides you with an
interface to create, manage, and navigate comparison jobs through interaction with views,
editors, and menus. If you are familiar with Eclipse you will recognize many elements of the
interface.
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The Welcome Page is the first screen you see when you initially launch the application. The
screen provides links to information that may be of value to new users.

Views help you navigate a hierarchy of information, open editors, or display the properties of
various application elements. For example, the Data Source Explorer view provides a tree of all
data sources in the environment and the comparison jobs associated with each. You can launch
these jobs directly, modify the connection properties of data sources, or create and edit
configuration archives from the view.

Editors help you perform various tasks, such as running a job. For example, you use the Schema
Comparison Job editor to define and execute schema comparison jobs.

The Menu Bar and Command Toolbar options provide various functions, such as launching
views and editors, navigating, and setting preferences.

Additional Product Information

IDERA web sites are an excellent source for additional product information, including white
papers, articles, FAQs, discussion groups. Visit these sites:

e The product home page.

e The IDERA Documentation site.
e The DB Change Manager Video Demos.
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Installing and Licensing DB Change Manager

This section includes:

e Requirements
e |nstalling DB Change Manager

e Licensing DB Change Manager

e Registering a Trial or Workstation License at Application Startup

e Registering a Workstation License after Application Startup

e Registering by Phone

Requirements

Before installing DB Change Manager, verify that your environment meets the requirements listed
at https://www.idera.com/database-change-management/systemrequirements.

Installing DB Change Manager

To install DB Change Manager on a workstation, run the installer and follow the prompts
provided by the Installation Wizard. When the installation is complete, see the ReadMe file for
known issues or advisory notes that could affect your use of the product.

Installing DB Change Manager in an AppWave Environment

If you are a DB Change Manager user and your System Administrator provides you with
AppWave, then your System Administrator enables DB Change Manager in your AppWave
Browser. Consult your System Administrator and the AppWave Browser online help for details.

11
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Licensing DB Change Manager

DB Change Manager supports the following types of licenses:

e Trial licenses: A license for a time-limited, full-featured trial version of the product. You
must register the trial license before you can use the product. For more information, see
Registering a Trial or Workstation License at Application Startup.

e Workstation licenses: A license or set of licenses that is tied to a particular workstation.
The product can only be used on that workstation. For more information, see Registering
a Workstation License after Application Startup.

e AppWave licenses: AppWave licenses are normally concurrent licenses managed by your
System Administrator. See your System Administrator for details.

If you have problems registering, see Registering by Phone.

Registering a Trial or Workstation License at Application Startup

Shortly after downloading a trial version of an IDERA product, you should receive an email from
IDERA containing a serial number, which must be registered. These instructions also apply if you
have purchased a product and received a serial number prior to running the application for the
first time, or if the trial period has expired.

To register a serial number at application startup
1. Start the application.
The License Registration dialog appears.
2. Copy the serial number from the email, and then paste it into the Serial Number field.

3. Enter your Developer Network (EDN) account credentials in the Login or Email and
Password fields.

If you have not previously created an EDN account, or have forgotten your password, click
| need to create ... or I've lost my password.

4. Click Register.

The activation file should automatically download and install. If this does not happen, click the
Trouble Connecting? Try Web Registration link and follow the prompts. If you still have
problems, see Registering by Phone.

12
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Registering a Workstation License after Application Startup

The following instructions assume that you have received a workstation license by email and that
you currently have a valid trial license. If you did not install a trial version or if the trial period has
expired, follow the instructions in Registering a Trial or Workstation License at Application
Startup instead.

To register a serial number after application startup
1. Click Help > Launch License Manager.
2. Inthe License Manager dialog, click Serial > Add.
3. Copy the serial number from the email and paste it into the Add Serial Number dialog.
4. Click OK.
5. Expand Unregistered Serial Numbers, right-click the serial number just added, and then
click Register.
A registration dialog appears.

NOTE: The Registration Code box shows a machine-specific identifier required with other
registration methods.

6. Ensure that Register using Online Registration is selected.
7. Provide Developer Network credentials in the Login or Email and Password fields.
8. Click Register.

The activation file should download and install automatically. If this does not happen, click the
Trouble Connecting? Try Web Registration link and follow the prompts. If you still have
problems, see Registering by Phone.

Registering by Phone

If you have problems with either of the above procedures, you can register licenses by phone.
You must provide the following information:

e Developer Network credentials

e The registration code displayed in the License Registration dialog that appears when you
start an unlicensed application

e The product base license serial number
e The license serial numbers for any additional features you have purchased

For North America, Latin America, and Asia Pacific. call (415) 834-3131 option 2, and then follow
the prompts. The hours are Monday to Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For Europe, Africa, and the Middle East. Call +44 (0)1628-684 494. The hours are Monday to
Friday, 2 A.M. to 5:30 PM. U.K. time.

13
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After phoning in, you will receive an email containing an activation file to import into DB Change
Manager.

To import an activation file

1.

Save the activation file from the email to the desktop or to a scratch directory such as
c:\temp.

From within the application, click Help > IDERA Licensing > License Registration.
Click License > Import.

Navigate to the directory where you saved the activation file and then double-click the
activation file.

Click the Import button to import the activation file.
Click Finish.

14
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DB Change Manager Quick Start Tutorials

This document guides you through the key features of DB Change Manager using these step-
by-step tutorials:

e Tutorial 1: Comparing Data

e Tutorial 2: Synchronizing Data

e Tutorial 3: Comparing Configurations

e Tutorial 4: Defining a Configuration Standard

e Tutorial 5: Comparing and Synchronizing Schemas

e Tutorial 6: Defining a Schema Archive

e Tutorial 7: Masking Data

e Tutorial 8: Defining and Running Automated Scripts

Before you begin, identify two data sources that you can use in the tutorials. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Tutorial 1: Comparing Data

Data comparison jobs automate the process of comparing and correcting data between data
sources at the database, table, and row level. You select a source and a target data source from
Data Source Explorer, map databases and tables between the two selections, and then run the
comparison job.

DB Change Manager compares the information and returns a results screen with details
including:

e An overall percentage of the data that is the same between the source and target
e Discrepancies between the two databases, such as data values that exist on only one

Once a data comparison job has run, you can then correct any synchronization issues by running
an automatically-generated SQL script that adds missing rows and updates out-of-sync values.
You can modify the SQL script prior to running it, and store it for future use.

To start Change Manager
e Start Change Manager using the Start menu’s IDERA DB Change Manager version item.

When DB Change Manager first starts, it displays a Welcome screen. Look over the Welcome
screen options and then close it.

DB CHANGE MANAGER 6.3.1/XE5 QUICK START GUIDE 15
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Adding Data Sources

In order to define and run jobs, you first register data sources by providing connection
information and other details to DB Change Manager. Once a data source has been registered,
it remains stored in a catalog and does not need to be reregistered each time you open DB
Change Manager. You can use a single registered data source in multiple jobs.

Data Source Explorer shows the registered data sources and their associated jobs, if any. Before

registering a data source, gather the information about the repository location and connectivity
permissions.

To add a data source
1. Click the Discover Data Sources icon at the top of the Data Source Explorer view.
File Edit Search Run Tools ‘\Window Help
- [i- - £ AR AR AR
94 Data Source Expl &2 % Job Explorer | ©5 Mavigator | O
ik 5% 7

A

2. In the Discover Data Sources wizard, select the locations to search for data sources, and
then click Next.

% Discover Data Sources

Discover Data Sources
Select the locations to search for data sources.

ClPreviously reqistered Embarcadero data souroes (Regitry)
CIFike system and network
ClEclipse Data Tooks Plstform (DTE)

[ Quest Saftware (TOAD)
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3. Select the data sources you want to add to the DB Change Manager environment and
click Finish.

= = Managed Data Sources (6)
& 1= Microsoft SCL Server (2)
# 1= MyGroup
= 1= SFTaest (1)
2= Mln'muﬂsq.aa'-m {1}

Sarver

= M Tmnmm:. {InterB 252 9.0.0,206)
@ B TORLABINTERBOZ (InterBase 9.0.0,206)

The new data source or sources appear in the Data Source Explorer.

TIP:  An alternative to using the Discover Data Sources wizard is to click File > New Data
Source and set its connection properties.

4. Inthe Data Source Explorer, right-click on a data source and select Properties to work
with connection properties for the datasource.

- Prnpertles for SFWLABOOZ/TEST (SQL Server)

ype f t | | Data Source Configuration -
 Confiuratin , :
Diata Source Indexing M

SOL Filters
Data source name: | SPWLABDOZ,TEST

Microsoft SOL Server
®se a network lbrary configuration
Server alias: | SFWLABOOZ\TEST vl IE]

ClUse a direct connection

Default database: |
Security credentials
User name:"
Password:

rerma

Dmmmtﬁamaﬁwmtspmﬁd}
Al trusted connections
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Creating a Data Comparison Job

Prior to performing the following steps, make sure you have at least two data sources registered
in DB Change Manager. Ideally these two data sources are similar in schema and content, so that
the comparison is meaningful to you.

To create a data comparison job in the Overview tab

1.
2.

Click File > New > Data Comparison Job.

Use the Select a Project dialog’'s Create New button to open a dialog that lets you
provide a name and location for a project for this exercise. Select the new project from
the Select a Project dialog.

= Owerview [ Options | [ Mapping [ Notification | = History @ =) W)
M Step 1: Select a source and target to compare and name the job et >>

it Create or Modify a Data Comparison Job

Job Name and Description

HMams Nobas
Unitithed-Data-Cormpar son- Job- 1

Froject: Change Management

] Track results in Compliance Explorer

Job Sources
& Data Comparison Source & Data Comparison Target
Marme: Marme:
Type: Type:
Hest: Hiest:
& Select Datasource 8 Select Datasource
W W

Crwerview | Options  Mapping | Motification . History

In the Overview tab of the Data Comparison Job editor, type the name of the job in the
Name field.

Click and drag a data source from Data Source Explorer to the Data Comparison
Source box.

By default, all databases in the data source are selected. If you prefer, use the menu to
specify a single database.

Click and drag a data source from Data Source Explorer to the Data Comparison
Target box.

Click File > Save or type Ctrl-S to save the job.
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To customize the job in the Options tab
1. Click the Options tab.

e-n"

B Overview | Options bﬂmﬂu!bﬂm-ﬂm b= History 6@ @
¥ Step 2 Customize the comparison and mapping (pairing) of tables and columns << back next =>
Fe]

= Execution Options
[Clautomatically Synchronize

Clear all data on the target and replace it with all data from the source autormaticably. Bf unchecked,
rranial synchronization will be required, where you can review the comparison results and select rows
to symchronize in eter drection 1o generate S0L scripts. This will disable tracking results in Compliance
Explorer.If the database has changed in some significant way you will need o reinspect the palr.

Clcompression Comgarkson
With this option enabled data on your datasources ks compressed before being ransmitted o the
wirkbench and compared. In certain situations data compression enables the job tomun at a rmuch
faster rate by removing the need 1o tramsfer and compare lange volumes of data

DGenerate oML
Aytomatically output the synchronization DML resulting from job execution, This DVL file can then
cptionally be sent with any enabled Notification

= Mapping Options
[Flignore Case [l

I[ﬂg‘ - . | 2
Cverview opuumimmpmwun:amnéuum

2. Inthe Options tab, review the various settings available to you. In particular, select or de-
select the check boxes in the Mapping Options section.

i
= Mapping Options
[Flignore Case
Databases, owrers, ables and cobimns will be pared up for cormparisnn without regands to case, For
example, with this option selsctad the table Product_Prices” will be paired with table
"PRODUCT _PRICES",
[Flignore Spaces
Pairs databass objects for Cofrparson ignoring spaces n thar names, For exampla, with this opton
selbectid the table "Product Prices” will be paired with the table "ProducitPrices”,
Cignore Underscores
Fairs databass l.'b_}'?'i ts for cormparison gnorersg underscores i ther names. For example, with this
option selected the tablke "Product_Prices" will be pared with the table "ProductPrices”
Oinclude views
Enable this aption to inchude views in the mapping. Ctherwise, views will be filtered out of the mapping
and will not be compared. hote that with this opticn enabled, you may still select which views {if ary)
wous wish b inchade in the comparison,
CExchude Computed Columns
Enable this option to exclude from rapping (and cormparison) the colurmns whiose values are computed,
.
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To refine comparisons in the Mapping tab
1. Click the Mapping tab.

2. Select the databases you want to compare; usually they have the same or a similar name.

=i
B> Overview | > Options | [> Mapping | B> Nothication | P> Wistory | t!’ - &
-v' mxr&mﬁm%nmn-ﬁmmm-mcwwm ﬁmm.
' e
+ Databhase Mapping
TORLABSOLOO0_3 TORLABSOLOO_1
O master master Source: pubs
O rricche| model Target: pubs
O rrsch msdh
0 p i P— Inspected: [Mot Inspected]
b pubs pubs Irspect: All | Current | Checked -
0O Sakes0B [Unirnapped ]
O tempch tempch * Refresh Databases
C 5555584 [Unmapped] | » Remap to Defaults
(21 - ' 2
Select: All , hone
= Table Mapping
The selected pair has not yet been irspected, Would you like to inspect the table and colurmn pairs in these objects?
{ﬂ
o] _ | [l
Onerview | Options | Mapping | Notification | History |

TIP:  Use the All and None commands at the bottom of the pane to select all or none of the
databases.
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3. By default, DB Change Manager does not show the table mappings. To see them, select
the Inspect: Checked option on the right side of the Database Mapping pane. The
progress bar displays in the lower right corner. The Table Mapping pane shows how and
whether the tables map to each other in the two databases.

= = =

<< hack pext >>
[a]

B Owerview | > Options | [> Mapping | B> liotitication | B History
L maw*um-u;um W. l.uhlﬂ.ar;dwh.lTnl between the source and target
T T TR v r
% 308 pubs pubs Inspact: Al | Current | Chicked
(] Sake:0B [Unimapped]
tempd tempdn » Befrech Datshases
555584 [Unrmapped] » Remap to Defaults
£ »
Select: All , Hone
= Table Mapping
TORLABSOLOO_3. pubes TORLABEQI.EIII_L[.L*::
T dbo.APPTEST [Unmapped] | | Source:
w an 0 doo.authors [ dbo.authors Target:
I dbo.azsx [Unmapped] !
I dbo.azsy_fbzacff7 [Unirmapped] Columis:
T dboblob [Unmapped]
il dbo.ca [Urimapped)
L 0 dbocCa [Unmapped] e
O @08 O dodscounts 0 dbo.dscounts sk
F.. HE I dooemployes [ dbo.employes
P —————— —
Owerview | Options | Mapping  Motification | History

The Data Comparison Job editor automatically maps and selects databases and tables
between the source and target when it detects correspondences. It indicates when there is no
mapping and displays information when it cannot make a match.
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+ Table Mapping

TORLABSQLO0_3 pubs TORLABSOLOD_ 1.5 &
0 choca [Unmapped] Source: dbo.publishers
o O dbo.Ca [Urirnapped] 5
O @il O doodisconts [ dbo.discounts el kel
o B8 @ doo.employes [ dbo.employes Columns: 5/5 to 5/5
.. B0 O doo.jobs O dbo.jobs : ;
0. [ ceorewtsbiel [Unmapped) igw Colsmn Mapping
¥ ., B8 O doopub_info [ dbo.pub_info i '
¥ 88 O dbopublshers O cbopublshers | FIter: =l
[ &The following errors have been found:
B8 Table or Wiew can not be compared if there is no column selected as comparison key
m R [ dbo.simpleTestTablels_eSd4ffic?  [Unmapped]
# .. BB [ dbo.stores [ dbo.stores
M doo.students_aCK1 [Unimapped] -
.( ] N S I e Lt e EE L T e Tt b s, mamiam el T = il
Select: All | Nore

e Select or de-select the check box next to each mapping, as needed. You can adjust
incomplete mappings before running the job. Click undefined items in the Target
data source column and use the drop down menu to map them.

TIP:  Click Filter: edit while a pair is selected to use the Columns, Comparison Key, and
Filter dialog and further refine the mappings, such as inserting a WHERE clause.
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To specify notifiers in the Notification tab

1.

2.

Click the Notification tab.

*Unititled Data-Compar ison-Jot =-n

| ¥ |
B Owerview | B Options | [ Mapping | = lotification | B History @ vt} g
¥ Step & Turn on and customize notifications for when the job runs << back HHISH

« Email Notifier

I Enabile Email Matifiar
Enable thiz Motifier to see its settings here.,

= File System Notifier

[ensble File System Notifier
Ensble this Notifier to sse its ssttings here.

+ System Tray Notifier

Cenable Systern Tray Notifier
Enable this MNotifier to see its settings here.

Cwerview | Options | Mapping | Motification | History

In the Notification tab, select where DB Change Manager sends notifications when thi
jobis run.

To run the job and see the results

1.

Click the Run Job icon, located in the upper right of the window.

®) @

Mack Fil

S
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In the Results tab, the job progress bar displays and the results appear. To review the job
results, click the View command in the Results column on an individual pair.
5 *Detn Carpere - Torlebisgll0,2 £ =g
= Hlﬂl:-nr; ¢ Resulie | & Database Reewlls tﬁ) t ) !

b= Overview | j= Options | = Mapping | j= Notification

COose resulis

* Resulbx Owverview - ackivation

= Source: activ... imrgel:acuuamn | Matched | ©nly in torlsbegl.. | Qnly in TORLAB. .. | Differant o source 1
dho.achwation_key cho.achwation_key 0 L] a 1} 0 I
dho.activation k... dbo.actvation k.. D a a a a
thowactwatian_k... dbo.actwation k.. 0 a 1] 0 0
dbo.actiwation_... dbo.actvation_... D a a a a
tho.copadity tho.copadity TR i i i i 3
i Ll i
|%] Vew DiffRemort 2] Export Diff Resuis. .
= Selected Table

o0 00

]

—

L

=

@

Select All

chowrows: (841 O Mematched D source (Onlvsource 0 Target (O Only target

Ganarate a SQLSopk

Overview | Cptiors | Maoping |Matfication | History | Results |Catzbese Results |

In the Database Results tab, review the detailed results for the tables and rows of the
selected databases.

25



DB CHANGE MANAGER QUICK START TUTORIALS

Tutorial 2: Synchronizing Data

To generate and run an SQL synchronization script

1. At the bottom of the Database Results tab of a database comparison job, click one of
the radio buttons, for example, Mismatched, to specify the type of resolution to perform.

2. At the lower right, click Generate an SQL Script.

EI} Syrc.iodabsglD0_2 Apr 27, 20054 55 20 PM.sql 52 N =g
b ) Micosoft QL Sereer b Sy torlebsghlo_2(3.0.2039.0) k[ perfarca " T

vs romlabartorclfi )

- FOURCE DATA SOURCE @ romlzbarCorclBi
- TARGET DATA SOURCE : torlabsglif 2
CEELTE TAELE ddd.TESTINDULTIML
{
gdfgfd numeric HUOLL,
zdfgd numeric HOLL
]

goa

“IF UBJELT ID(N'ddd, TESTINDULTIMA'} IS5 NOT NULL
PRINT H'-++ CREATED TABLE ddd.TESTINDULTIMA >»X»'
EL3E
PRTNT H'<<< FAILED CBEATING TAELE ddd.TESTINOULTIMA >>>"

(= (=]

3. Inthe SQL Editor, click the Execute SQL icon, the green arrow, to synchronize the data.

NOTE: Executing an SQL script may change the data in your data sources. Be sure to
review all potential changes, and read the script, before running the script.

4. If you want to create a report, select the Database Results tab and click View Diff
Report.
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Highlighted Feature: The Compression Comparison Option

Comparing large repositories with many databases, tables, and rows can be a time consuming
and tedious process, especially when you require row-level accuracy.

The Compression Comparison option enables an algorithm that causes the data comparison to
initially execute at a table level instead of the row level. Each table in a pair is assigned a value
and if the values match the comparison process moves to the next pair of tables. If the values do
not match, the process performs a more detailed comparison at the row level. This allows for a
faster comparison process in general, without losing any accuracy during the process.

[CJcompression Comparison

To enable this feature, navigate to the Options tab Execution Options section and select
Compression Comparison.

Tutorial 3: Comparing Configurations

Configuration comparison jobs examine the configuration settings of two specified data sources
and describe the differences between them. You select a pair of data sources from Data Source
Explorer, refine the property comparisons, run the job, and view the results. Based on the results
you can correct any issues between the pair.

You can also compare a data source against a configuration archive or standard. Archives are a
snapshot of the configuration settings of a data source at a point in time. Standards are
customized sets of properties with threshold operators that help you create optimal
configurations, against which you can compare existing data source settings.

To define and run a configuration comparison job

1. Select File > New > Configuration Comparison Job. If prompted to select a project,
select the project you created earlier.

2. Type the name of the job in the Name field.

3. Dragand drop a data source from Data Source Explorer to the Configuration
Comparison Source box.

4. Dragand drop a data source from Data Source Explorer to the Configuration
Comparison Target box.

27



DB CHANGE MANAGER QUICK START TUTORIALS

5. Click the Refinements tab.

i *Untitled-Data-Comparison-lob-1 |25 =0
B Overview | = Refinoments | = options | B Notification | [ History @ tlfj Q

¥ Step & Select the configuration properties to comparne << hack next =>

Configuration Property Refinement
?bmmmtﬁmﬁapwﬁasheh&mﬁmmmﬂ ke to chedk in your configuration comparison job.

il"r-l:\‘-:-artw,' Type Description
| ® @] B SOL Server Version Information

| ® [#] B~ Core SCL Properties

|

&l . I
Overview |Refinements | Options: Notification | History |

6. Keep the defaults in the Refinements tab. Click the Options tab.
7. In the Options tab, select the Extract DDL check box.

- Refinements | Options | B lotification | = History

+ DOL Extract Options

[¥] Extract DOL
%.uturrmt-:a:h output the syrc DOL resulting from job execution

8. Click the Run Job icon.

28



DB CHANGE MANAGER QUICK START TUTORIALS

9. Inthe Comparison Results tab, the job progress bar displays and the results appear.
Review the job results.

i) *Untitled-Data-Comparison-Job-1 b *TestingConfigComparel |

B Overview | - Refinements | [ Options | B lotification | B Mistory | [ Comparison Resulis t:} =) W)
Close results
Comparison Summary Resolution
GEnerate 4 SOL SCriph
Source: S TORLABSOLOS 1 Taget: G TORLABSOLOO 3

¥ 53 Properties Malched 58.9% |
K 12 Properties Did Mot Match 12.3%
I+ 25 Properties Not Fournd 27.8%

5] View Report L Esport Pesults
Comparison Results
Frogperty Source Op TORLABSOLOD_3 o
1iear rrennceHoes n [T L ¥ e

Orverview | Refinements | Options: |Notification | History | Compar ison Results

In the Comparison Results tab, you can generate an SQL script to synchronize the
configurations just as in Tutorial 2: Synchronizing Data.

Highlighted Feature: Comparing Multiple Targets

You can compare multiple target sources against a single source. In the Configuration
Comparison Target box of the Overview tab, click the Add More Targets option. The box
changes to a column list view, where you can drag and drop additional sources from Data Source
Explorer to the Configuration Comparison Target box.

Tutorial 4: Defining a Configuration Standard
A configuration standard is composed of properties and values that you define:
e Configuration properties (static or dynamically updated based on the source values)

e Values that include threshold comparison operators (greater than, less than, falls within or
is a member of a specified set, etc.)

You can use a standard in configuration comparison jobs against data sources and archives in
order to determine if the target conforms to the standard. A standard can only be used as a
source in comparison jobs.

29



DB CHANGE MANAGER QUICK START TUTORIALS

To define a configuration standard
1. Select File > New > Configuration Standard.
2. If prompted, select a project to use.
3. Inthe Overview tab, enter the name of the standard in the Name field.
4

Drag and drop a data source from Data Source Explorer to the Standard Sources
table.

i *Unitithed-Data-Compar ison-Job-1 =h *TestingConfigCompare] [ *configStandardl £
= Owerview r" Fefinement

 Create or Modify a Configuration Standard

Standard Name and Description

MNarme Notes
ConfigStandardl

Frofect: ConfigConparel

Standard Sources

fersion

Source
| | ToRLARSOLOD 3 Microsoft SOL Server ...

Hosmamse: TORLARSOLOOD 3
Typa: Linked

[ <]
Crverview | Refinement

5. In the Refinement tab, define each listed property using the Source, Operator, and
Value controls.

6. Select File > Save to save the standard. It appears in the Project Explorer.

You can subsequently drag and drop the new standard from Project Explorer to the Comparison
Source box in the Configuration Comparison Job editor. You can then run a job using the
standard as you would use a registered data source.

Tutorial 5: Comparing and Synchronizing Schemas

Once you create a baseline archive of your schema, you can compare it against the other
schemas, even in live environments. Also, you can synchronize the schema of a data source with

the archive using the Schema Comparison Job editor.
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To define a schema comparison job

1.
2.
3.

Select File > New > Schema Comparison Job and if prompted, select a project.
In the Schema Comparison Job editor, type the name of the job in the Name field.

Drag and drop a data source from Data Source Explorer to the Schema Comparison
Source box.

Drag and drop a data source from Data Source Explorer to the Schema Comparison
Target box.

Click the Mapping tab.

In the Mapping tab, review the object mappings that are already set up for you. Change
the target mappings as needed.

In the Options tab, select or de-select the configuration properties.
Click the Run Job icon.

In the Comparison Results tab, the job progress bar displays and the results appear.
Review the job results.

To generate and run a schema synchronization script

1.

In the Comparison Results tab, click Generate Sync Script in the Resolution column of
the Comparison Results table. DB Change Manager generates a synchronization script in
the SQL Editor.

Modify the script as needed, and save it using the File > Save command.
In the SQL Editor, select the Execute SQL icon to synchronize the data.

NOTE: Executingthe SQL script changes the schema in your target data source. Be sure
to review all potential changes and read the script before running it.

If you want to create a report, click Generate Report. The Export dialog opens and
provides additional report options.

Tutorial 6: Defining a Schema Archive

A schema archive contains a snapshot of the schema of a registered data source. You compare
schema archives against other data sources and archives to identify possible inconsistencies.

A schema archive is generated from a single data source at a specific point in time. Like a
configuration archive, a schema archive has versioning functionality and can be periodically
updated with the current values of the data source. Older versions are retained and can be
recalled as needed.

You create a schema archive using the Schema Archive Job editor. Once created and saved, it is
listed in the Data Source Explorer.
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To define a schema archive

1. Right-click on a data source in Data Source Explorer and select Archive > Schema
Archive Job. Select a project, if prompted.

2. In the Archive Job editor, enter the name of the archive in the Name field.

3. Inthe Refinements tab, narrow the job down by selecting owners, object types, and
specific objects to include.

4. Click the Run Job icon.
In the New Unsaved Version tab, the results appear. Review the job results.

6. Click File > Save. The Unsaved Version tab changes to Version 1, and Version 1
appears in the Datasource Explorer tab under the datasource you chose.

TIP:  You can create more versions by clicking the Run Job icon again.

You can subsequently drag and drop the new archive version from Data Source Explorer to the
Source or Target boxes in the Schema Comparison Job editor. You can now run a job using the
archive just as you would use a data source.

Tutorial 7: Masking Data

Data masking is a way of securing sensitive data during the development or testing phases of a
database development project. It is often performed as a security or compliance measure that
protects important information. By masking valid production data, you can provide a copy of the
data that is “scrambled” but still represents your production environment.

1. Select File > New > Data Comparison Job and if prompted, select a project.

2. Provide a name of the job in the Name field and then drag and drop datasources from
the Data Source Explorer to the Data Comparison Source and Data Comparison
Target boxes.

3. Inthe Options tab, ensure that Automatically Synchronize is selected and read the
description shown for that option.

4. Inthe Mapping tab, select a row corresponding to a matching database pair in the
Database Mapping box and then, in the Table Mapping box, select Yes, retrieve the
objects in this pair.
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= Table Mapping
TORLABSOLOS 1. Frankhmi TORLABSOLOS_2.F
= || 0 dbo.Address [ dbo.Address |~ Source: dbo.Address
> .. 3l 0 dbo.Category O dooCategry | yarget: dbo.Address
o il O dbo.Customer 0 dbo.Customer
v ad I dbo.Customer_tddress [ dbo.Custormer ¢ Columns: 7/7 o 7/7
o 1] O dbo.Customer_Ordir [ dbo.Customer_t T
1 i m Yienw Column Mapping
" 38 W dbo.Customer_Ordier_Product Wl b Custamer _(
o 1] I dbo.Product [ dbo Product Default Masking Rule:
W il I dboRef_sddress_Type M dbo.Raf_addres e —
7 .. 0l 0 dbo.Supplier 0 dooSuppler | | EESESEE
Apply to ANl
Columns: Mo Masking
Filter: edit
£ | * [m ﬁlte”]
Select: All , Nong

5. Inthe Table Mapping box, click View Column Mapping.

Columns and Filter

| |Tﬁ.fr:|e |C|:|Iu N |Maskir‘u:| Rule |C|:|Iu 1N |Tﬁ.fr:le
int Address ID Mone w Address ID ¥ int
int Address Type 1D MNone v Address Type... v int
varchar Street 1 andomize BE Ak = w warchar
varchar Street 2 Use Default |+ Sireet 2 w wvarchar
varchar  City Use Default v City w warchar
char State Use Default  + State v char
char Zin Use Default |+ Zin v char

Select: All , None

Columns | Filer

6. Click on the data Masking Rule option for a column and select one of the following:

(0]

(0]
o
o

Use Default: The default masking rule as set in the Database Mapping box.
None: No masking is applied.
Randomize: Replaces characters with other random characters.

Shuffle: Reorders the values in different rows; for example, in a First Name
column Bob, Ted, and Alice can change to Alice, Bob, and Ted.

7. Close the window.
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8. Continue to experiment with selection and settings until you are comfortable with

masking options.
9. Click File > Save to save the job.
10. Click the Run Job icon.

Cloge results
+ Results Overview = Franklyna
Source: Fran... |~ Taroet: Fra... |Matched |Only in TORL... |Only in TORL... |Different R
dooCateqory  cho.Catemory oo 16 0 0 o (@
dho.Custorer  cbo.Custorer 0 i i = 348 [0 (o
£ | *
S view Diff Report [ Export Diff Results, .
= Selected Table
I TORLABSOQLOS_1.Frankhmd.dbo.Customer [ TORLABSOLOS_2 Frarkhmé.dbo.Customer
L. |Csomer D [FrstName  [Last Nara| ot [.]Customer D [First Name  [Last Naia
T4 James Battiste : 734 Gk yrssfimel
735 Samual Philpott - 735 lagcigh Prwztioc
735 Miosz| Arra o0 735 Hogl Eaaa
737 Gaston Amesoui, 737 Ohaybx Oaszegh
< Ta so0 (] i >

Overview | Options | Mapping | Motification | History | Results | Database Results
The Database Results tab shows the masked data.

Tutorial 8: Defining and Running Automated Scripts

When you need to repeatedly run the same job, you can set up automated tasks that execute the
jobs on a regular schedule. DB Change Manager helps create a command line executable for any
job. You can run the command line executable on an ad hoc basis. You can also group the

commands into a batch file and run them.

To define command line syntax and generate batch files

1. Open the job for which you want to define an execution script.

Select the Command Line Syntax icon in the upper right of any tab.

2
3. Inthe Script Generation Wizard, add output report options.
4

Specify the Directory where the files are generated.
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Click Next.

Specify the Location where the batch file is generated.
Specify the file format for the script.

Click Finish.

9. DB Change Manager generates the file and saves it to the location you specified.

o N o v

If you want to add multiple jobs to the batch file, generate a batch file as normal, and then copy
the script syntax to the clipboard for each job you want to add to the batch file. You can then add
them to the existing batch file manually.

Additional Documentation

For additional instructions and reference information about DB Change Manager, see the
documentation at: https://www.idera.com/support/productdocuments.
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